P4API Namespace

P4.Net -- Managed API for Perforce
P4API Namespace
Objects for connecting to a Perforce server, and running commands.

Classes

Class | Description
ArrayFieldDictionary | Strongly typed dictionary to represent array-valued fields returned from Perforce commands.
FieldDictionary | Strongly typed dictionary to represent fields returned from Perforce commands.
P4BaseRecordSet | Base functionality for P4Recordset and P4UnParsedRecordset.
P4Connection | A connection to a Perforce server instance.
P4Form | Represents a Perforce 'Form' object.
P4PendingChangelist | Represents a pending changelist from Perforce.
P4PrintStreamEventArgs | EventArgs class to supply file details.
P4PromptEventArgs | Arguments provided for an OnPrompt event.
P4Record | P4Record is a dictionary-like object that provides a means of interpreting Perforce results.
P4RecordSet | Provides output of a Perforce Command in "tagged" moded.
P4UnParsedRecordSet | This class represents the "unparsed" output from a Perforce command.

Delegates

Delegate | Description
OnPrintEndEventHandler | Delaget to handle the OnPrintEndFile event.
OnPrintStreamEventHandler | Delegate to handle the OnPrintStream event.
OnPromptEventHandler | Delegate to handle the OnPrompt event.

Enumerations

Enumeration | Description
P4ExceptionLevels | Defines the exception levels available in P4Connection.
P4.Net SourceForge Project Web Site

Copyright © 2007 Shawn Hladky


ArrayFieldDictionary Class

ArrayFieldDictionary Class
Members See Also
Strongly typed dictionary to represent array-valued fields returned from Perforce commands.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ArrayFieldDictionary

Remarks

The FieldDictionary only contains fields that contain a string array values. Fields that return a single string values are stored in FieldDictionary.
If a value is read from a key that does not exist, an empty array will be returned. If a value is set with a key that does not exist, it will automatically be added. This behavior is to support many Perforce commands that omit a key, rather than supply a default value.

Inheritance Hierarchy

System..::.Object
P4API..::.ArrayFieldDictionary

See Also

ArrayFieldDictionary Members


ArrayFieldDictionary Members

[image]

P4.Net -- Managed API for Perforce
ArrayFieldDictionary Members
ArrayFieldDictionary Class Methods Properties See Also

The ArrayFieldDictionary type exposes the following members.

Methods

Name | Description
Clear | Clears all elements of the dictionary.
ContainsKey | Tests if the key exists in the dictionary.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes elements from the dictionary.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the dictionary
Item | Returns the value assocatied to the key.
Keys | Gets all keys contained in the dictionary.

See Also

ArrayFieldDictionary Class


ArrayFieldDictionary Methods

[image]

P4.Net -- Managed API for Perforce
ArrayFieldDictionary Methods
ArrayFieldDictionary Class See Also

The ArrayFieldDictionary type exposes the following methods.

Methods

Name | Description
Clear | Clears all elements of the dictionary.
ContainsKey | Tests if the key exists in the dictionary.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes elements from the dictionary.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArrayFieldDictionary Class


Clear Method

ArrayFieldDictionary..::.Clear Method
ArrayFieldDictionary Class See Also
Clears all elements of the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Clear()

See Also

ArrayFieldDictionary Class


ContainsKey Method

ArrayFieldDictionary..::.ContainsKey Method
ArrayFieldDictionary Class See Also
Tests if the key exists in the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool ContainsKey(
    string key
)

Parameters

key
Type: System..::.String
The key to test

Return Value

True if the key is defined in the dictionary.

See Also

ArrayFieldDictionary Class


Remove Method

ArrayFieldDictionary..::.Remove Method
ArrayFieldDictionary Class See Also
Removes elements from the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Remove(
    string key
)

Parameters

key
Type: System..::.String
The key of the element to remove.

See Also

ArrayFieldDictionary Class


ArrayFieldDictionary Properties

[image]

P4.Net -- Managed API for Perforce
ArrayFieldDictionary Properties
ArrayFieldDictionary Class See Also

The ArrayFieldDictionary type exposes the following properties.

Properties

Name | Description
Count | Gets the number of elements in the dictionary
Item | Returns the value assocatied to the key.
Keys | Gets all keys contained in the dictionary.

See Also

ArrayFieldDictionary Class


Count Property

ArrayFieldDictionary..::.Count Property
ArrayFieldDictionary Class See Also
Gets the number of elements in the dictionary

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Count { get; }

Field Value

Number of items.

See Also

ArrayFieldDictionary Class


Item Property

ArrayFieldDictionary..::.Item Property
ArrayFieldDictionary Class See Also
Returns the value assocatied to the key.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string[] this[
    string key
] { get; set; }

Parameters

key
Type: System..::.String
The key to search on.

Return Value

String array value associated to the key.

See Also

ArrayFieldDictionary Class


Keys Property

ArrayFieldDictionary..::.Keys Property
ArrayFieldDictionary Class See Also
Gets all keys contained in the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string[] Keys { get; }

Field Value

Keys in the ArrayFieldDictionary.

See Also

ArrayFieldDictionary Class


FieldDictionary Class

FieldDictionary Class
Members See Also
Strongly typed dictionary to represent fields returned from Perforce commands.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class FieldDictionary

Remarks

The FieldDictionary only contains fields that contain a single string value. Fields that return array values are stored in ArrayFieldDictionary.

Inheritance Hierarchy

System..::.Object
P4API..::.FieldDictionary

See Also

FieldDictionary Members


FieldDictionary Members

[image]

P4.Net -- Managed API for Perforce
FieldDictionary Members
FieldDictionary Class Methods Properties See Also

The FieldDictionary type exposes the following members.

Methods

Name | Description
Clear | Clears all elements of the dictionary.
ContainsKey | Tests if the key exists in the dictionary.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes elements from the dictionary.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements in the dictionary
Item | Returns the value assocatied to the key.
Keys | Gets all keys contained in the dictionary.

See Also

FieldDictionary Class


FieldDictionary Methods

[image]

P4.Net -- Managed API for Perforce
FieldDictionary Methods
FieldDictionary Class See Also

The FieldDictionary type exposes the following methods.

Methods

Name | Description
Clear | Clears all elements of the dictionary.
ContainsKey | Tests if the key exists in the dictionary.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes elements from the dictionary.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDictionary Class


Clear Method

FieldDictionary..::.Clear Method
FieldDictionary Class See Also
Clears all elements of the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Clear()

See Also

FieldDictionary Class


ContainsKey Method

FieldDictionary..::.ContainsKey Method
FieldDictionary Class See Also
Tests if the key exists in the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool ContainsKey(
    string key
)

Parameters

key
Type: System..::.String
The key to test

Return Value

True if the key is defined in the dictionary.

See Also

FieldDictionary Class


Remove Method

FieldDictionary..::.Remove Method
FieldDictionary Class See Also
Removes elements from the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Remove(
    string key
)

Parameters

key
Type: System..::.String
The key of the element to remove.

See Also

FieldDictionary Class


FieldDictionary Properties

[image]

P4.Net -- Managed API for Perforce
FieldDictionary Properties
FieldDictionary Class See Also

The FieldDictionary type exposes the following properties.

Properties

Name | Description
Count | Gets the number of elements in the dictionary
Item | Returns the value assocatied to the key.
Keys | Gets all keys contained in the dictionary.

See Also

FieldDictionary Class


Count Property

FieldDictionary..::.Count Property
FieldDictionary Class See Also
Gets the number of elements in the dictionary

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Count { get; }

Field Value

Count of items.

See Also

FieldDictionary Class


Item Property

FieldDictionary..::.Item Property
FieldDictionary Class See Also
Returns the value assocatied to the key.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string this[
    string key
] { get; set; }

Parameters

key
Type: System..::.String
The key to search on.

Return Value

String value associated to the key.

See Also

FieldDictionary Class


Keys Property

FieldDictionary..::.Keys Property
FieldDictionary Class See Also
Gets all keys contained in the dictionary.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string[] Keys { get; }

Field Value

Keys in the FieldDictionary

See Also

FieldDictionary Class


OnPrintEndEventHandler Delegate

OnPrintEndEventHandler Delegate
See Also
Delaget to handle the OnPrintEndFile event.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public delegate void OnPrintEndEventHandler(
    P4PrintStreamEventArgs args,
    Stream stream
)

Parameters

args
Type: P4API..::.P4PrintStreamEventArgs
Arguments describing the printed file.
stream
Type: System.IO..::.Stream
The stream that was written.

See Also

P4Connection..::.OnPrintEndFile


OnPrintStreamEventHandler Delegate

OnPrintStreamEventHandler Delegate
See Also
Delegate to handle the OnPrintStream event.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public delegate void OnPrintStreamEventHandler(
    P4PrintStreamEventArgs args,
    out Stream outputStream
)

Parameters

args
Type: P4API..::.P4PrintStreamEventArgs
Arguments describing the printed file.
outputStream
Type: System.IO..::.Stream %
The stream to write the file.

See Also

P4Connection..::.OnPrintStream


OnPromptEventHandler Delegate

OnPromptEventHandler Delegate
See Also
Delegate to handle the OnPrompt event.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public delegate void OnPromptEventHandler(
    Object sender,
    P4PromptEventArgs args
)

Parameters

sender
Type: System..::.Object
Sender
args
Type: P4API..::.P4PromptEventArgs
P4PromptEventArgs

Remarks

Handle Perforce "prompts". Prompts are from commands that ask the user to respond, such as:
  • login
  • passwd
  • resolve (without an -a* switch)

    • See Also

    P4Connection..::.OnPrompt


P4BaseRecordSet Class

P4BaseRecordSet Class
Members See Also
Base functionality for P4Recordset and P4UnParsedRecordset.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public abstract class P4BaseRecordSet

Remarks

This is a base class for internal use. Do not use directly.

Inheritance Hierarchy

System..::.Object
P4API..::.P4BaseRecordSet
P4API..::.P4RecordSet
P4API..::.P4UnParsedRecordSet

See Also

P4BaseRecordSet Members
P4API..::.P4RecordSet


P4BaseRecordSet Members

[image]

P4.Net -- Managed API for Perforce
P4BaseRecordSet Members
P4BaseRecordSet Class Methods Properties See Also

The P4BaseRecordSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasErrors | Checks the Recordset to determine if errors occured.
HasWarnings | Checks the Recordset to determine if warnings occured.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorMessage | Gets an error messages returned from the Perforce command.
Errors | Gets an array of error messages returned from the Perforce command.
Warnings | Gets an array of warning messages returned from the Perforce command.

See Also

P4BaseRecordSet Class


P4BaseRecordSet Methods

[image]

P4.Net -- Managed API for Perforce
P4BaseRecordSet Methods
P4BaseRecordSet Class See Also

The P4BaseRecordSet type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasErrors | Checks the Recordset to determine if errors occured.
HasWarnings | Checks the Recordset to determine if warnings occured.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4BaseRecordSet Class


HasErrors Method

P4BaseRecordSet..::.HasErrors Method
P4BaseRecordSet Class See Also
Checks the Recordset to determine if errors occured.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool HasErrors()

Return Value

True if the p4 command returned errors.

Remarks

This is the same as testing Errors.Count.

See Also

P4BaseRecordSet Class


HasWarnings Method

P4BaseRecordSet..::.HasWarnings Method
P4BaseRecordSet Class See Also
Checks the Recordset to determine if warnings occured.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool HasWarnings()

Return Value

True if the p4 command returned warnings.

Remarks

This is the same as testing Warnings.Count.

See Also

P4BaseRecordSet Class


P4BaseRecordSet Properties

[image]

P4.Net -- Managed API for Perforce
P4BaseRecordSet Properties
P4BaseRecordSet Class See Also

The P4BaseRecordSet type exposes the following properties.

Properties

Name | Description
ErrorMessage | Gets an error messages returned from the Perforce command.
Errors | Gets an array of error messages returned from the Perforce command.
Warnings | Gets an array of warning messages returned from the Perforce command.

See Also

P4BaseRecordSet Class


ErrorMessage Property

P4BaseRecordSet..::.ErrorMessage Property
P4BaseRecordSet Class See Also
Gets an error messages returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string ErrorMessage { get; }

Remarks

Errors are concatanated to one string, seperated by new lines.

See Also

P4BaseRecordSet Class


Errors Property

P4BaseRecordSet..::.Errors Property
P4BaseRecordSet Class See Also
Gets an array of error messages returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string[] Errors { get; }

Remarks

These are the error messages that are returned from Perforce.

See Also

P4BaseRecordSet Class


Warnings Property

P4BaseRecordSet..::.Warnings Property
P4BaseRecordSet Class See Also
Gets an array of warning messages returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string[] Warnings { get; }

Field Value

Array of warnings returned from Perforce.

Remarks

These are the warning messages that are returned from Perforce.

See Also

P4BaseRecordSet Class


P4Connection Class

P4Connection Class
Members See Also
A connection to a Perforce server instance.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4Connection : IDisposable

Remarks

The P4Connection class is the main player in P4.Net. This represents a connection to the Perforce server. Every utility that uses P4.Net will have some variation of the following code:

CopyC#
P4Connection p4 = new P4Connection();
p4.Connect();

// Run some commands
p4.Disconnect();

Rule number 1: Always remember to disconnect. This frees unmanaged memory, and cleanly disconnects from the Perforce server. P4Connection implements IDisposable, and the Dispose and Disconnect methods can be used interchangeably.

P4.Net is based off the command-line syntax (as are most other Perforce APIs). Almost all of the commands you issue in P4.Net will use the same arguments as the p4 client executable. For example, say you need to find the latest submitted changelist under a given path (//depot/path).

From the command line:

CopyC#
c:\> p4 changes -m1 -s submitted //depot/path/...

From P4.Net:

CopyC#
P4Connect p4 = new P4Connection();
p4.Connect();
P4Recordset changes = p4.Run("changes", "-m1", "-s", "submitted", "//depot/path/...");
p4.Disconnect();

If you don’t know what all the arguments for p4 changes mean, then p4 help changes is your best friend. The first step in building anything with P4.Net, is to know the exact command lines you’d run manually.

Inheritance Hierarchy

System..::.Object
P4API..::.P4Connection

See Also

P4Connection Members


P4Connection Members

[image]

P4.Net -- Managed API for Perforce
P4Connection Members
P4Connection Class Constructors Methods Properties Events See Also

The P4Connection type exposes the following members.

Constructors

Name | Description
P4Connection | Initializes a new instance of the P4Connection class.

Methods

Name | Description
Connect | Connect to the Perforce server
ConvertDate | Overloaded.
CreatePendingChangelist | Creates a new pending changelist.
Disconnect | Disconnect from the Perforce Server
Dispose | Calls Disconnect.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Fetch_Form | Fetch a form object from Perforce.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsServerCaseSensitive | Checks the case-sensitivity of the Perforce server.
IsValidConnection | Determines if the Perforce connection is valid.
Login | Login to the Perforce Server
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse_Form | Parse the raw text of a Perforce form into a P4Form object
PrintBinary | Print the contents of a file in Perforce to a byte array.
PrintStream | Overloaded.
PrintStreamEvents | Runs a print command, and raises events for each file printed.
PrintText | Print the contents of a file in Perforce to a string.
Run | Executes a Perforce command in tagged mode.
RunUnParsed | Executes a Perforce command in non-tagged mode.
Save_Form | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Api | Sets the client API protocol level.
CallingProgram | Get/Sets the name of the calling program.
CallingVersion | Gets/Sets the version of the calling program's version.
Charset | Gets/Sets the client character set.
Client | Gets/Sets the client workspace.
CWD | Gets/Sets the current working directory.
ExceptionLevel | Gets/Sets the Exception level when running Perforce commands.
Host | Gets/Sets the Host-name of the client.
MaxLockTime | Gets/Sets a value that overrides the defined MaxLockTime.
MaxResults | Gets/Sets a value that overrides the defined MaxResults.
MaxScanRows | Gets/Sets a value that overrides the defined MaxScanRows.
Password | Sets the password to conenct with.
Port | Gets/Sets the Perforce Server port.
ServerLevel | Checks the server level (version) of the Perforce server.
TicketFile | Sets the ticket file used for Authentication.
User | Gets/Sets the User login used to connect to Perforce.

Events

Name | Description
OnPrintEndFile | Raised from P4PrintStreamEvents after a file is printed.
OnPrintStream | Raised from P4PrintStreamEvents before a file is printed.
OnPrompt | Raised when Perforce is prompting for a response.

See Also

P4Connection Class


P4Connection Constructor

P4Connection Constructor
P4Connection Class See Also
Initializes a new instance of the P4Connection class.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4Connection()

See Also

P4Connection Class


P4Connection Methods

[image]

P4.Net -- Managed API for Perforce
P4Connection Methods
P4Connection Class See Also

The P4Connection type exposes the following methods.

Methods

Name | Description
Connect | Connect to the Perforce server
ConvertDate | Overloaded.
CreatePendingChangelist | Creates a new pending changelist.
Disconnect | Disconnect from the Perforce Server
Dispose | Calls Disconnect.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Fetch_Form | Fetch a form object from Perforce.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsServerCaseSensitive | Checks the case-sensitivity of the Perforce server.
IsValidConnection | Determines if the Perforce connection is valid.
Login | Login to the Perforce Server
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse_Form | Parse the raw text of a Perforce form into a P4Form object
PrintBinary | Print the contents of a file in Perforce to a byte array.
PrintStream | Overloaded.
PrintStreamEvents | Runs a print command, and raises events for each file printed.
PrintText | Print the contents of a file in Perforce to a string.
Run | Executes a Perforce command in tagged mode.
RunUnParsed | Executes a Perforce command in non-tagged mode.
Save_Form | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4Connection Class


Connect Method

P4Connection..::.Connect Method
P4Connection Class See Also
Connect to the Perforce server

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Connect()

See Also

P4Connection Class


ConvertDate Method

[image]

P4.Net -- Managed API for Perforce
P4Connection..::.ConvertDate Method
P4Connection Class See Also

Overload List

Name | Description
ConvertDate(DateTime) | Converts .Net DateTime to Perforce date (integer).
ConvertDate(Int32) | Converts Perforce date (integer) to .Net DateTime.
ConvertDate(String) | Converts Perforce date (integer value as a string) to .Net DateTime.

See Also

P4Connection Class
P4Connection Members


ConvertDate Method (DateTime)

P4Connection..::.ConvertDate Method (DateTime)
P4Connection Class See Also
Converts .Net DateTime to Perforce date (integer).

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int ConvertDate(
    DateTime date
)

Parameters

date
Type: System..::.DateTime

Remarks

The Perforce API returns most dates as an integer representing the number of seconds since 1/1/1970 in UTC. The command line client generally returns dates as strings in the Perforce server's time zone. The ConvertDate methods use the client's time zone for the offset.

See Also

P4Connection Class
ConvertDate Overload


ConvertDate Method (Int32)

P4Connection..::.ConvertDate Method (Int32)
P4Connection Class See Also
Converts Perforce date (integer) to .Net DateTime.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime ConvertDate(
    int p4Date
)

Parameters

p4Date
Type: System..::.Int32

Return Value

DateTime in .Net format.

Remarks

The Perforce API returns most dates as an integer representing the number of seconds since 1/1/1970 in UTC. The command line client generally returns dates as strings in the Perforce server's time zone. The ConvertDate methods use the client's time zone for the offset.

See Also

P4Connection Class
ConvertDate Overload


ConvertDate Method (String)

P4Connection..::.ConvertDate Method (String)
P4Connection Class See Also
Converts Perforce date (integer value as a string) to .Net DateTime.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime ConvertDate(
    string p4Date
)

Parameters

p4Date
Type: System..::.String

Remarks

The Perforce API returns most dates as an integer representing the number of seconds since 1/1/1970 in UTC. The command line client generally returns dates as strings in the Perforce server's time zone. The ConvertDate methods use the client's time zone for the offset.

See Also

P4Connection Class
ConvertDate Overload


CreatePendingChangelist Method

P4Connection..::.CreatePendingChangelist Method
P4Connection Class See Also
Creates a new pending changelist.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4PendingChangelist CreatePendingChangelist(
    string Description
)

Parameters

Description
Type: System..::.String
The description.

Return Value

P4PendingChangelist object representing the named pending changelist

See Also

P4Connection Class


Disconnect Method

P4Connection..::.Disconnect Method
P4Connection Class See Also
Disconnect from the Perforce Server

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Disconnect()

See Also

P4Connection Class


Dispose Method

P4Connection..::.Dispose Method
P4Connection Class See Also
Calls Disconnect.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

P4Connection Class


Fetch_Form Method

P4Connection..::.Fetch_Form Method
P4Connection Class See Also
Fetch a form object from Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4Form Fetch_Form(
    string FormCommand,
    params string[] Args
)

Parameters

FormCommand
Type: System..::.String
The form command.
Args
Type: array< System..::.String >[]()[]
The args.

Return Value

A Form object. The fields of the form can be read or updated. If you update a filed, you can save it with Save_Form.

Remarks

Forms are the things that pop-up in an editor when run from a command line. In P4.Net (and most other Perforce APIs), you do not need to parse/format the text manually. Instead, you can get/set the fields using the Fields and ArrayFields collections. The following is a list of common form commands:
  • client
  • branch
  • label
  • job
  • user
  • group
  • protect
  • triggers
  • branch
    • When fetching or saving a form, do not use the '-o' and '-i' flags. P4.Net will automatically include them.

    See Also

    P4Connection Class


IsServerCaseSensitive Method

P4Connection..::.IsServerCaseSensitive Method
P4Connection Class See Also
Checks the case-sensitivity of the Perforce server.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool IsServerCaseSensitive()

Return Value

True when the connected server is case-sensitive.

Remarks

This must be called after connecting to the server.

See Also

P4Connection Class


IsValidConnection Method

P4Connection..::.IsValidConnection Method
P4Connection Class See Also
Determines if the Perforce connection is valid.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public bool IsValidConnection(
    bool checkLogin,
    bool checkClient
)

Parameters

checkLogin
Type: System..::.Boolean
if set to true it will check if the user is logged in.
checkClient
Type: System..::.Boolean
if set to true it will verify the client exists.

Return Value

true if the connection is valid; otherwise, false.

Remarks

IsValidConnection performs the following 3 checks (depending on the arguments passed).
  • Runs p4 info, and verifies the server is valid.
  • If checkClient is true, verifies that p4 info returns a clientName that is not "*unknown*.
  • If checkLogin is true, verifies that p4 login -s does not have errors.

    • See Also

    P4Connection Class


Login Method

P4Connection..::.Login Method
P4Connection Class See Also
Login to the Perforce Server

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void Login(
    string password
)

Parameters

password
Type: System..::.String
The password.

See Also

P4Connection Class


Parse_Form Method

P4Connection..::.Parse_Form Method
P4Connection Class See Also
Parse the raw text of a Perforce form into a P4Form object

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4Form Parse_Form(
    string formCommand,
    string formContents
)

Parameters

formCommand
Type: System..::.String
The form command.
formContents
Type: System..::.String
Raw contents of the form spec.

Return Value

A P4Form object. The fields of the form can be read or updated. If you update a filed, you can save it with Save_Form.

Remarks

Forms are the things that pop-up in an editor when run from a command line. In P4.Net (and most other Perforce APIs), you do not need to parse/format the text manually. Instead, you can get/set the fields using the Fields and ArrayFields collections. The following is a list of common form commands:
  • client
  • branch
  • label
  • job
  • user
  • group
  • protect
  • triggers
  • branch
    • When fetching or saving a form, do not use the '-o' and '-i' flags. P4.Net will automatically include them.

    See Also

    P4Connection Class


PrintBinary Method

P4Connection..::.PrintBinary Method
P4Connection Class See Also
Print the contents of a file in Perforce to a byte array.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public byte[] PrintBinary(
    string depotPath
)

Parameters

depotPath
Type: System..::.String
Perforce path to the file.

Return Value

Contents of the file. Text files will be encoded with ANSI encodinge. Unicode files will be encoded as UTF-8 (regardless of P4CHARSET setting).

See Also

P4Connection Class


PrintStream Method

[image]

P4.Net -- Managed API for Perforce
P4Connection..::.PrintStream Method
P4Connection Class See Also

Overload List

Name | Description
PrintStream(Stream, String) | Prints the contents of a Perforce file to a Stream.
PrintStream(Stream, String, Encoding) | Prints the contents of a Perforce file to a Stream.

See Also

P4Connection Class
P4Connection Members


PrintStream Method (Stream, String)

P4Connection..::.PrintStream Method (Stream, String)
P4Connection Class See Also
Prints the contents of a Perforce file to a Stream.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void PrintStream(
    Stream stream,
    string depotPath
)

Parameters

stream
Type: System.IO..::.Stream
Writable stream to write the contents to.
depotPath
Type: System..::.String
Perforce path of the file to print.

Remarks

If a file is does not exist, a FileNotFound exception will be thrown (regardless of the ExceptionLevel setting).
Depot Path, Client Path or Local Path can generally be used for the argument depotPath (so long as the argument is valid for the
CopyC#
p4 print
 command line.
The stream argument can be any valid stream, so long as it is initialized and writable.

See Also

P4Connection Class
PrintStream Overload


PrintStream Method (Stream, String, Encoding)

P4Connection..::.PrintStream Method (Stream, String, Encoding)
P4Connection Class See Also
Prints the contents of a Perforce file to a Stream.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void PrintStream(
    Stream stream,
    string depotPath,
    Encoding encoding
)

Parameters

stream
Type: System.IO..::.Stream
Writable stream to write the contents to.
depotPath
Type: System..::.String
Perforce path of the file to print.
encoding
Type: System.Text..::.Encoding
Text encoding of the Stream.

Remarks

If a file is does not exist, a FileNotFound exception will be thrown (regardless of the ExceptionLevel setting).
Depot Path, Client Path or Local Path can generally be used for the argument depotPath (so long as the argument is valid for the
CopyC#
p4 print
 command line.
Encoding will only be applied to files with a Perforce type of 'text' or 'unicode'.
The stream argument can be any valid stream, so long as it is initialized and writable.

See Also

P4Connection Class
PrintStream Overload


PrintStreamEvents Method

P4Connection..::.PrintStreamEvents Method
P4Connection Class Example See Also
Runs a print command, and raises events for each file printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public void PrintStreamEvents(
    params string[] args
)

Parameters

args
Type: array< System..::.String >[]()[]
Arguments to the
CopyC#
p4 print
 command.

Remarks

This method is useful when you need to print several files with a single call to the Perforce server.

Examples

CopyC#
  See Also
P4Connection Class


PrintText Method

P4Connection..::.PrintText Method
P4Connection Class See Also
Print the contents of a file in Perforce to a string.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string PrintText(
    string depotPath
)

Parameters

depotPath
Type: System..::.String
Perforce path to the file.

Return Value

Contents of the file.

Remarks

Attempting to call PrintText on a binary file will likely cause corruption.
If a file is does not exist, a FileNotFound exception will be thrown (regardless of the ExceptionLevel setting).
Depot Path, Client Path or Local Path can generally be used for the argument depotPath (so long as the argument is valid for the
CopyC#
p4 print
 command line.

See Also

P4Connection Class


Run Method

P4Connection..::.Run Method
P4Connection Class See Also
Executes a Perforce command in tagged mode.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4RecordSet Run(
    string Command,
    params string[] Args
)

Parameters

Command
Type: System..::.String
The command.
Args
Type: array< System..::.String >[]()[]
The arguments to the Perforce command. Remember to use a dash (-) in front of all switches

Return Value

A P4Recordset containing the results of the command.

See Also

P4Connection Class


RunUnParsed Method

P4Connection..::.RunUnParsed Method
P4Connection Class See Also
Executes a Perforce command in non-tagged mode.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4UnParsedRecordSet RunUnParsed(
    string Command,
    params string[] Args
)

Parameters

Command
Type: System..::.String
The command.
Args
Type: array< System..::.String >[]()[]
The args.

Return Value

See Also

P4Connection Class


Save_Form Method

[image]

P4.Net -- Managed API for Perforce
P4Connection..::.Save_Form Method
P4Connection Class See Also

Overload List

Name | Description
Save_Form(P4Form) | Saves the form to Perforce.
Save_Form(String, String) | Saves the form to Perforce.
Save_Form(P4Form, Boolean) | Saves the form to Perforce.
Save_Form(String, String, Boolean) | Saves the form to Perforce.

See Also

P4Connection Class
P4Connection Members


Save_Form Method (P4Form)

P4Connection..::.Save_Form Method (P4Form)
P4Connection Class See Also
Saves the form to Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4UnParsedRecordSet Save_Form(
    P4Form Form
)

Parameters

Form
Type: P4API..::.P4Form
The P4Form object retrieved from Fetch_Form.

Return Value

P4UnParsedRecordSet. Output can be parsed to verify the form was processed correctly.

Remarks

Forms are the things that pop-up in an editor when run from a command line. In P4.Net (and most other Perforce APIs), you do not need to parse/format the text manually. Instead, you can get/set the fields using the Fields and ArrayFields collections. The following is a list of common form commands:
  • client
  • branch
  • label
  • job
  • user
  • group
  • protect
  • triggers
  • branch
    • When fetching or saving a form, do not use the '-o' and '-i' flags. P4.Net will automatically include them.

    See Also

    P4Connection Class
    Save_Form Overload


Save_Form Method (String, String)

P4Connection..::.Save_Form Method (String, String)
P4Connection Class See Also
Saves the form to Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4UnParsedRecordSet Save_Form(
    string formCommand,
    string formSpec
)

Parameters

formCommand
Type: System..::.String
The form command to run.
formSpec
Type: System..::.String
The formatted spec.

Return Value

P4UnParsedRecordSet. Output can be parsed to verify the form was processed correctly.

See Also

P4Connection Class
Save_Form Overload


Save_Form Method (P4Form, Boolean)

P4Connection..::.Save_Form Method (P4Form, Boolean)
P4Connection Class See Also
Saves the form to Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4UnParsedRecordSet Save_Form(
    P4Form Form,
    bool Force
)

Parameters

Form
Type: P4API..::.P4Form
The P4Form object retrieved from Fetch_Form.
Force
Type: System..::.Boolean
True to pass the '-f' flag when saving.

Return Value

P4UnParsedRecordSet. Output can be parsed to verify the form was processed correctly.

Remarks

Forms are the things that pop-up in an editor when run from a command line. In P4.Net (and most other Perforce APIs), you do not need to parse/format the text manually. Instead, you can get/set the fields using the Fields and ArrayFields collections. The following is a list of common form commands:
  • client
  • branch
  • label
  • job
  • user
  • group
  • protect
  • triggers
  • branch
    • When fetching or saving a form, do not use the '-o' and '-i' flags. P4.Net will automatically include them.

    See Also

    P4Connection Class
    Save_Form Overload


Save_Form Method (String, String, Boolean)

P4Connection..::.Save_Form Method (String, String, Boolean)
P4Connection Class See Also
Saves the form to Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4UnParsedRecordSet Save_Form(
    string formCommand,
    string formSpec,
    bool Force
)

Parameters

formCommand
Type: System..::.String
The form command to run.
formSpec
Type: System..::.String
The formatted spec.
Force
Type: System..::.Boolean
True to pass the '-f' flag when saving.

Return Value

P4UnParsedRecordSet. Output can be parsed to verify the form was processed correctly.

See Also

P4Connection Class
Save_Form Overload


P4Connection Properties

[image]

P4.Net -- Managed API for Perforce
P4Connection Properties
P4Connection Class See Also

The P4Connection type exposes the following properties.

Properties

Name | Description
Api | Sets the client API protocol level.
CallingProgram | Get/Sets the name of the calling program.
CallingVersion | Gets/Sets the version of the calling program's version.
Charset | Gets/Sets the client character set.
Client | Gets/Sets the client workspace.
CWD | Gets/Sets the current working directory.
ExceptionLevel | Gets/Sets the Exception level when running Perforce commands.
Host | Gets/Sets the Host-name of the client.
MaxLockTime | Gets/Sets a value that overrides the defined MaxLockTime.
MaxResults | Gets/Sets a value that overrides the defined MaxResults.
MaxScanRows | Gets/Sets a value that overrides the defined MaxScanRows.
Password | Sets the password to conenct with.
Port | Gets/Sets the Perforce Server port.
ServerLevel | Checks the server level (version) of the Perforce server.
TicketFile | Sets the ticket file used for Authentication.
User | Gets/Sets the User login used to connect to Perforce.

See Also

P4Connection Class


Api Property

P4Connection..::.Api Property
P4Connection Class See Also
Sets the client API protocol level.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Api { get; set; }

Field Value

The Perforce API level.

Remarks

Sets the API compatibility level desired. This is useful when writing scripts using Perforce commands that do not yet support tagged output. In these cases, upgrading to a later server that supports tagged output for the commands in question can break your script. Using this method allows you to lock your script to the output format of an older Perforce release and facilitate seamless upgrades. Note that this method must be called prior to calling Connect.
See the http://kb.perforce.com/P4dServerReference/ProtocolLevels/PerforceClientLevels for the API integer levels that correspond to each Perforce release.

See Also

P4Connection Class


CallingProgram Property

P4Connection..::.CallingProgram Property
P4Connection Class See Also
Get/Sets the name of the calling program.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string CallingProgram { get; set; }

Field Value

Defaults to "P4.Net API".

Remarks

This value is seen in p4 monitor and in the server log files.

See Also

P4Connection Class


CallingVersion Property

P4Connection..::.CallingVersion Property
P4Connection Class See Also
Gets/Sets the version of the calling program's version.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string CallingVersion { get; set; }

Field Value

Defaults to the assembly version of the P4API.dll.

Remarks

This value is seen in p4 monitor and the server log files.

See Also

P4Connection Class


Charset Property

P4Connection..::.Charset Property
P4Connection Class See Also
Gets/Sets the client character set.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Charset { get; set; }

Field Value

The client's charset.

Remarks

Defaults to the value set in your Perforce environment. After you've set Charset, you can unset (revert to the default) by setting to Charset to null.

See Also

P4Connection Class


Client Property

P4Connection..::.Client Property
P4Connection Class See Also
Gets/Sets the client workspace.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Client { get; set; }

Field Value

The client name.

Remarks

Many Perforce commands require a valid client spec to be set in order to run. Defaults to the value set in your Perforce environment. After you've set Client, you can unset (revert to the default) by setting to Client to null.

See Also

P4Connection Class


CWD Property

P4Connection..::.CWD Property
P4Connection Class See Also
Gets/Sets the current working directory.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string CWD { get; set; }

Field Value

The current working directory for the Perforce connection.

Remarks

Setting CWD can be used so that relative paths are specified. Keep in mind that changing the CWD also might cause P4CONFIG settings to change.

See Also

P4Connection Class


ExceptionLevel Property

P4Connection..::.ExceptionLevel Property
P4Connection Class See Also
Gets/Sets the Exception level when running Perforce commands.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4ExceptionLevels ExceptionLevel { get; set; }

Field Value

The exception level for the connection.

Remarks

This property controls when P4.Net will throw exceptions when the underlying Perforce commands raise errors and warnings.

The default is P4ExceptionLevels.NoExceptionOnWarnings

See Also

P4Connection Class


Host Property

P4Connection..::.Host Property
P4Connection Class See Also
Gets/Sets the Host-name of the client.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Host { get; set; }

Field Value

The client Host name.

Remarks

Forcing the Host to a different name is useful when using a client that was defined on a different host. Of course, that can cause issues with the client's have list, so use with caution.

See Also

P4Connection Class


MaxLockTime Property

P4Connection..::.MaxLockTime Property
P4Connection Class See Also
Gets/Sets a value that overrides the defined MaxLockTime.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int MaxLockTime { get; set; }

Field Value

Overrides the MaxLockTime defined at the server.

Remarks

Servers may set a limit for MaxLockTime for certain users. Set this value to override. A value of 0 indicates no override.

See Also

P4Connection Class


MaxResults Property

P4Connection..::.MaxResults Property
P4Connection Class See Also
Gets/Sets a value that overrides the defined MaxResults.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int MaxResults { get; set; }

Field Value

Overrides the MaxResults defined at the server.

Remarks

Servers may set a limit for MaxResults for certain users. Set this value to override. A value of 0 indicates no override.

See Also

P4Connection Class


MaxScanRows Property

P4Connection..::.MaxScanRows Property
P4Connection Class See Also
Gets/Sets a value that overrides the defined MaxScanRows.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int MaxScanRows { get; set; }

Field Value

Overrides the MaxScanRows defined at the server.

Remarks

Servers may set a limit for MaxScanRows for certain users. Set this value to override. A value of 0 indicates no override.

See Also

P4Connection Class


Password Property

P4Connection..::.Password Property
P4Connection Class See Also
Sets the password to conenct with.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Password { set; }

Field Value

The user's password.

Remarks

Do not set the literal password with a server running security level 2 or higher. For those servers, Use the Login method and/or a ticket in place of the Password.

See Also

P4Connection Class


Port Property

P4Connection..::.Port Property
P4Connection Class See Also
Gets/Sets the Perforce Server port.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Port { get; set; }

Field Value

The port.

Remarks

Defaults to the value set in your Perforce environment. Port can not be changed after running Connect (not even after a Disconnect). To connect to a server on another port, create a new instance of P4Connection.

See Also

P4Connection Class


ServerLevel Property

P4Connection..::.ServerLevel Property
P4Connection Class See Also
Checks the server level (version) of the Perforce server.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int ServerLevel { get; }

Field Value

The server's version level.

Return Value

The server's version level.

Remarks

See http://kb.perforce.com/P4dServerReference/ProtocolLevels/PerforceServerLevels for more informantion.

See Also

P4Connection Class


TicketFile Property

P4Connection..::.TicketFile Property
P4Connection Class See Also
Sets the ticket file used for Authentication.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string TicketFile { set; }

Field Value

Overrided the ticket file location.

Remarks

Use this to override the default location of the TicketFile.

See Also

P4Connection Class


User Property

P4Connection..::.User Property
P4Connection Class See Also
Gets/Sets the User login used to connect to Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string User { get; set; }

Field Value

The user.

Remarks

Defaults to the value set in your Perforce environment. After you've set User, you can unset (revert to the default) by setting to User to null.

See Also

P4Connection Class


P4Connection Events

[image]

P4.Net -- Managed API for Perforce
P4Connection Events
P4Connection Class See Also

The P4Connection type exposes the following events.

Events

Name | Description
OnPrintEndFile | Raised from P4PrintStreamEvents after a file is printed.
OnPrintStream | Raised from P4PrintStreamEvents before a file is printed.
OnPrompt | Raised when Perforce is prompting for a response.

See Also

P4Connection Class


OnPrintEndFile Event

P4Connection..::.OnPrintEndFile Event
P4Connection Class See Also
Raised from P4PrintStreamEvents after a file is printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public event OnPrintEndEventHandler OnPrintEndFile

Remarks

Use this event to close any streams that were created by the OnPrintStreamEventHandler event.

See Also

P4Connection Class


OnPrintStream Event

P4Connection..::.OnPrintStream Event
P4Connection Class See Also
Raised from P4PrintStreamEvents before a file is printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public event OnPrintStreamEventHandler OnPrintStream

Remarks

Handle this event to initialize a stream that P4API will write to.

See Also

P4Connection Class


OnPrompt Event

P4Connection..::.OnPrompt Event
P4Connection Class Example See Also
Raised when Perforce is prompting for a response.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public event OnPromptEventHandler OnPrompt

Remarks

Handle Perforce "prompts". Prompts are from commands that ask the user to respond, such as:
  • login
  • passwd
  • resolve (without an -a* switch)

    • Examples

    The following sample will change the user's password.
    CopyC#
    public class PasswordSetter
{
    private P4Connection _p4 = null;
    private string _oldPassword = "";
    private string _newPassword = "";
    PasswordSetter(P4Connection p4)
    {
        _p4 = p4;
    }

    public void SetPassword(string OldPassword, string NewPassword)
    {
        OnPromptEventHandler eh = new OnPromptEventHandler(OnPrompt);
        _p4.OnPrompt += eh;

        _oldPassword = OldPassword;
        _newPassword = NewPassword;

        //run passwd
        P4UnParsedRecordSet r = _p4.RunUnParsed("passwd");

        //Clear the event just in case
        _p4.OnPrompt -= eh;

        //Clear the passwords from memory
        _newPassword = "";
        _oldPassword = "";
    }

    private void OnPrompt(object sender, P4PromptEventArgs e)
    {
        switch (e.Message)
        {
            case ("Enter old password: "):
                e.Response = _oldPassword;
                break;
            case ("Enter new password: "):
                e.Response = _newPassword;
                break;
            case ("Re-enter new password: "):
                e.Response = _newPassword;
                break;
        }
    }
}

    See Also

    P4Connection Class


P4ExceptionLevels Enumeration

P4ExceptionLevels Enumeration
See Also
Defines the exception levels available in P4Connection.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public enum P4ExceptionLevels

Members

Member name | Description
NoExceptionOnWarnings | Exceptions will only be thrown when Perforce has errors. This is the default exception level.
NoExceptionOnErrors | Exceptions will never be thrown when Perforce has errors.
ExceptionOnBothErrorsAndWarnings | Exceptions will be thrown for both Errors and Warnings.

See Also


P4Form Class

P4Form Class
Members Example See Also
Represents a Perforce 'Form' object.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4Form : P4Record

Remarks

Forms are the things that pop-up in an editor when run from a command line. In P4.Net (and most other Perforce APIs), you do not need to parse/format the text manually. Instead, you can get/set the fields using the Fields and ArrayFields collections. The following is a list of common form commands:
  • client
  • branch
  • label
  • job
  • user
  • group
  • protect
  • triggers
  • branch
    • When fetching or saving a form, do not use the '-o' and '-i' flags. P4.Net will automatically include them.

    Examples

    The following example updates the current client. It changes the client root, and adds a line to the view.
    CopyC#
    P4Connection p4 = new P4Connection();
p4.Connect();

P4Form MyClient = p4.Fetch_Form("client");

//Change the root and properties
MyClient["Root"] = @"C:\p4\P4.NetClient";
MyClient["Description"] = "Created from P4.Net!";

//Fetch the clientName (for use later in building the view spec).
string clientName = MyClient["Client"];

// Build a new array, that has one more element than the current view
string[] NewView = new string[MyClient.ArrayFields["View"].Length + 1];

// Copy the existing view lines to the new array
MyClient.ArrayFields["View"].CopyTo(NewView,0);

// Set the new view line
NewView[NewView.Length - 1] = string.Format("//depot/newpath/... //{0}/newpath/...", clientName);

MyClient.ArrayFields["View"] = NewView;

// Save the form
P4UnParsedRecordSet MyResult = p4.Save_Form(MyClient);
p4.Disconnect();

    Inheritance Hierarchy

    System..::.Object
    P4API..::.P4Record
    P4API..::.P4Form

    See Also

    P4Form Members


P4Form Members

[image]

P4.Net -- Managed API for Perforce
P4Form Members
P4Form Class Methods Properties See Also

The P4Form type exposes the following members.

Methods

Name | Description
Clone | Copies the P4Form object into a new instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatSpec | Formats the P4Form as a formated Perforce spec.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromSpec | Parses a Perforce form without making a server connection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ArrayFields | Gets the ArrayFieldDictionary returned from the Perforce command. (Inherited from P4Record.)
Fields | Gets the FieldDictionary returned from the Perforce command. (Inherited from P4Record.)
FormCommand | Gets the form command.
Item | Returns the value of of the Field by key. This is the same as Fields[key]. (Inherited from P4Record.)
PermittedFields | Gets a StringCollection containing the names of all the allowable fields in the form.
SpecDef | The underlying C++ API 'specdef' defining the form.

See Also

P4Form Class


P4Form Methods

[image]

P4.Net -- Managed API for Perforce
P4Form Methods
P4Form Class See Also

The P4Form type exposes the following methods.

Methods

Name | Description
Clone | Copies the P4Form object into a new instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatSpec | Formats the P4Form as a formated Perforce spec.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromSpec | Parses a Perforce form without making a server connection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4Form Class


Clone Method

P4Form..::.Clone Method
P4Form Class See Also
Copies the P4Form object into a new instance.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4Form Clone()

Return Value

A copy of the P4Form object.

See Also

P4Form Class


FormatSpec Method

P4Form..::.FormatSpec Method
P4Form Class See Also
Formats the P4Form as a formated Perforce spec.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string FormatSpec()

Return Value

String of the formated form spec.

See Also

P4Form Class


LoadFromSpec Method

P4Form..::.LoadFromSpec Method
P4Form Class See Also
Parses a Perforce form without making a server connection.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public static P4Form LoadFromSpec(
    string formCommand,
    string specDef,
    string formContents,
    Encoding encoding
)

Parameters

formCommand
Type: System..::.String
The command that would otherwise be used to fetch the form.
specDef
Type: System..::.String
The Perforce 'specdef' for the form.
formContents
Type: System..::.String
The raw formated form text.
encoding
Type: System.Text..::.Encoding
Server encoding (either ANSI or UFT-8).

Return Value

A Perforce form object.

Remarks

LoadFromSpec can be used to parse a form without making a call to the server. LoadFromSpec can be useful in form triggers. It does require you to know the SpecDef to call, which can change when upgrading or changing the server configuration.

See Also

P4Form Class


P4Form Properties

[image]

P4.Net -- Managed API for Perforce
P4Form Properties
P4Form Class See Also

The P4Form type exposes the following properties.

Properties

Name | Description
ArrayFields | Gets the ArrayFieldDictionary returned from the Perforce command. (Inherited from P4Record.)
Fields | Gets the FieldDictionary returned from the Perforce command. (Inherited from P4Record.)
FormCommand | Gets the form command.
Item | Returns the value of of the Field by key. This is the same as Fields[key]. (Inherited from P4Record.)
PermittedFields | Gets a StringCollection containing the names of all the allowable fields in the form.
SpecDef | The underlying C++ API 'specdef' defining the form.

See Also

P4Form Class


FormCommand Property

P4Form..::.FormCommand Property
P4Form Class See Also
Gets the form command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string FormCommand { get; }

Field Value

The command that was executed when the form was run.

See Also

P4Form Class


PermittedFields Property

P4Form..::.PermittedFields Property
P4Form Class See Also
Gets a StringCollection containing the names of all the allowable fields in the form.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public StringCollection PermittedFields { get; }

Field Value

StringCollection containing the names of all the allowable fields in the form.

Remarks

The fields returned by PermittedFields are not necessarily included in Fields.Keys or ArrayFields.Keys. Perforce forms usually do not have keys for empty values.

See Also

P4Form Class


SpecDef Property

P4Form..::.SpecDef Property
P4Form Class See Also
The underlying C++ API 'specdef' defining the form.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string SpecDef { get; }

Field Value

The C++ 'specdef' that defines the format of the spec.

Remarks

The SpecDef is a formatted string that Perforce uses internally to parse forms. SpecDefs will vary by form, server version, and even with specific server configurations. In general, you should avoid using a SpecDef directly; however, in some cases you can avoid a server call by using the SpecDef.

See Also

P4Form Class


P4PendingChangelist Class

P4PendingChangelist Class
Members Example See Also
Represents a pending changelist from Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4PendingChangelist

Remarks

The P4PendindingChangelist object is used to submit files with P4.Net. The first step is to create a new pending changelist, then add the switches "-c", and "1234" (1234 is the changelist number) to all commands that are opening files. In P4.Net, there’s no straight-forward way to submit the default pending changelist. This is by design. If the client workspace has opened files in the default changelist before any P4.Net automation runs, those files will "come along for the ride" when you submit the default changelist. If the user has a JobView set, all jobs in that JobView will automatically be fixed when you submit the default changelist. Both of those behaviors are almost never desired, and I’ve found many scripts that have those bugs.

Examples

The following example demonstrates submiting files with P4PendingChangelist.
CopyC#
P4Connection p4 = new P4Connection();
p4.Connect();
P4PendingChangelist  cl = p4.CreatePendingChangelist("My New Changelist\nVery, Very bad description!\nShame on me!");
p4.Run("edit", "-c", cl.Number.ToString(), "//depot/path/foo.cs", "//depot/path/bar.cs");
// Do something to manipulate the files
cl.Submit();
p4.Disconnect();

Inheritance Hierarchy

System..::.Object
P4API..::.P4PendingChangelist

See Also

P4PendingChangelist Members


P4PendingChangelist Members

[image]

P4.Net -- Managed API for Perforce
P4PendingChangelist Members
P4PendingChangelist Class Methods Properties See Also

The P4PendingChangelist type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Submit | Submits the pending changelist to Perforce.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | Gets the pending changelist's description.
Number | Gets the pending changelist's number.

See Also

P4PendingChangelist Class


P4PendingChangelist Methods

[image]

P4.Net -- Managed API for Perforce
P4PendingChangelist Methods
P4PendingChangelist Class See Also

The P4PendingChangelist type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Submit | Submits the pending changelist to Perforce.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4PendingChangelist Class


Submit Method

P4PendingChangelist..::.Submit Method
P4PendingChangelist Class See Also
Submits the pending changelist to Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4UnParsedRecordSet Submit()

Return Value

P4UnParsedRecordSet with the results of the submit.

See Also

P4PendingChangelist Class


P4PendingChangelist Properties

[image]

P4.Net -- Managed API for Perforce
P4PendingChangelist Properties
P4PendingChangelist Class See Also

The P4PendingChangelist type exposes the following properties.

Properties

Name | Description
Description | Gets the pending changelist's description.
Number | Gets the pending changelist's number.

See Also

P4PendingChangelist Class


Description Property

P4PendingChangelist..::.Description Property
P4PendingChangelist Class See Also
Gets the pending changelist's description.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Description { get; }

Field Value

The description.

See Also

P4PendingChangelist Class


Number Property

P4PendingChangelist..::.Number Property
P4PendingChangelist Class See Also
Gets the pending changelist's number.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Number { get; }

Field Value

The changelist number.

See Also

P4PendingChangelist Class


P4PrintStreamEventArgs Class

P4PrintStreamEventArgs Class
Members See Also
EventArgs class to supply file details.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4PrintStreamEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
P4API..::.P4PrintStreamEventArgs

See Also

P4PrintStreamEventArgs Members


P4PrintStreamEventArgs Members

[image]

P4.Net -- Managed API for Perforce
P4PrintStreamEventArgs Members
P4PrintStreamEventArgs Class Methods Properties See Also

The P4PrintStreamEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | Submit action for the file being printed.
Change | The Perforce changelist number for the file being printed.
DepotFile | The Perforce depot path to the file being printed.
FileTime | The timestamp of the file being printed.
FileType | The Perforce file type of the file being printed.
TextEncoding | Encoding to be used for files with a Perforce type of 'text'.
UnicodeEncoding | Encoding to be used for files with a Perforce type of 'unicode'.

See Also

P4PrintStreamEventArgs Class


P4PrintStreamEventArgs Properties

[image]

P4.Net -- Managed API for Perforce
P4PrintStreamEventArgs Properties
P4PrintStreamEventArgs Class See Also

The P4PrintStreamEventArgs type exposes the following properties.

Properties

Name | Description
Action | Submit action for the file being printed.
Change | The Perforce changelist number for the file being printed.
DepotFile | The Perforce depot path to the file being printed.
FileTime | The timestamp of the file being printed.
FileType | The Perforce file type of the file being printed.
TextEncoding | Encoding to be used for files with a Perforce type of 'text'.
UnicodeEncoding | Encoding to be used for files with a Perforce type of 'unicode'.

See Also

P4PrintStreamEventArgs Class


Action Property

P4PrintStreamEventArgs..::.Action Property
P4PrintStreamEventArgs Class See Also
Submit action for the file being printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Action { get; }

Field Value

The last submit action for the file being printed.

See Also

P4PrintStreamEventArgs Class


Change Property

P4PrintStreamEventArgs..::.Change Property
P4PrintStreamEventArgs Class See Also
The Perforce changelist number for the file being printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public int Change { get; }

Field Value

The Perforce changelist number for the file being printed.

See Also

P4PrintStreamEventArgs Class


DepotFile Property

P4PrintStreamEventArgs..::.DepotFile Property
P4PrintStreamEventArgs Class See Also
The Perforce depot path to the file being printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string DepotFile { get; }

Field Value

The depot path to the file.

See Also

P4PrintStreamEventArgs Class


FileTime Property

P4PrintStreamEventArgs..::.FileTime Property
P4PrintStreamEventArgs Class See Also
The timestamp of the file being printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public DateTime FileTime { get; }

Field Value

The timestamp of the file being printed.

See Also

P4PrintStreamEventArgs Class


FileType Property

P4PrintStreamEventArgs..::.FileType Property
P4PrintStreamEventArgs Class See Also
The Perforce file type of the file being printed.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string FileType { get; }

Field Value

The Perforce filetype of the file being printed.

See Also

P4PrintStreamEventArgs Class


TextEncoding Property

P4PrintStreamEventArgs..::.TextEncoding Property
P4PrintStreamEventArgs Class See Also
Encoding to be used for files with a Perforce type of 'text'.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Encoding TextEncoding { get; set; }

Field Value

The encoding for Text Files being printed.

See Also

P4PrintStreamEventArgs Class


UnicodeEncoding Property

P4PrintStreamEventArgs..::.UnicodeEncoding Property
P4PrintStreamEventArgs Class See Also
Encoding to be used for files with a Perforce type of 'unicode'.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public Encoding UnicodeEncoding { get; set; }

Field Value

The encoding form unicode files being printed.

See Also

P4PrintStreamEventArgs Class


P4PromptEventArgs Class

P4PromptEventArgs Class
Members See Also
Arguments provided for an OnPrompt event.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4PromptEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
P4API..::.P4PromptEventArgs

See Also

P4PromptEventArgs Members


P4PromptEventArgs Members

[image]

P4.Net -- Managed API for Perforce
P4PromptEventArgs Members
P4PromptEventArgs Class Methods Properties See Also

The P4PromptEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Message | The message from Perforce.
Response | The value to respond to Perforce with.

See Also

P4PromptEventArgs Class


P4PromptEventArgs Properties

[image]

P4.Net -- Managed API for Perforce
P4PromptEventArgs Properties
P4PromptEventArgs Class See Also

The P4PromptEventArgs type exposes the following properties.

Properties

Name | Description
Message | The message from Perforce.
Response | The value to respond to Perforce with.

See Also

P4PromptEventArgs Class


Message Property

P4PromptEventArgs..::.Message Property
P4PromptEventArgs Class See Also
The message from Perforce.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Message { get; }

Field Value

The prompt message from Perforce.

See Also

P4PromptEventArgs Class


Response Property

P4PromptEventArgs..::.Response Property
P4PromptEventArgs Class See Also
The value to respond to Perforce with.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string Response { get; set; }

Field Value

The response to the Perforce command.

See Also

P4PromptEventArgs Class


P4Record Class

P4Record Class
Members See Also
P4Record is a dictionary-like object that provides a means of interpreting Perforce results.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4Record

Remarks

The Perforce api provides "parsed" output in the form of key-value pairs. Keys are always strings (case sensitive). From the raw api, the values come in 3 flavors:
  • Simple strings.
  • List of strings.
  • Sparse multi-demensional list of strings.
    • P4.Net does not yet handle the third type (which only comes from certain output of p4 filelog).

    To access simple string values by key, use the Fields property (or the default indexer).

    To access lists of strings by key, use the ArrayFields property.

    Inheritance Hierarchy

    System..::.Object
    P4API..::.P4Record
    P4API..::.P4Form

    See Also

    P4Record Members


P4Record Members

[image]

P4.Net -- Managed API for Perforce
P4Record Members
P4Record Class Methods Properties See Also

The P4Record type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ArrayFields | Gets the ArrayFieldDictionary returned from the Perforce command.
Fields | Gets the FieldDictionary returned from the Perforce command.
Item | Returns the value of of the Field by key. This is the same as Fields[key].

See Also

P4Record Class


P4Record Properties

[image]

P4.Net -- Managed API for Perforce
P4Record Properties
P4Record Class See Also

The P4Record type exposes the following properties.

Properties

Name | Description
ArrayFields | Gets the ArrayFieldDictionary returned from the Perforce command.
Fields | Gets the FieldDictionary returned from the Perforce command.
Item | Returns the value of of the Field by key. This is the same as Fields[key].

See Also

P4Record Class


ArrayFields Property

P4Record..::.ArrayFields Property
P4Record Class See Also
Gets the ArrayFieldDictionary returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ArrayFieldDictionary ArrayFields { get; }

Field Value

The array-value fields returned for the current record.

See Also

P4Record Class


Fields Property

P4Record..::.Fields Property
P4Record Class See Also
Gets the FieldDictionary returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public FieldDictionary Fields { get; }

Field Value

The single-value fields returned for the current record.

See Also

P4Record Class


Item Property

P4Record..::.Item Property
P4Record Class See Also
Returns the value of of the Field by key. This is the same as Fields[key].

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string this[
    string key
] { get; set; }

Parameters

key
Type: System..::.String
The key for

Field Value

The value for field 'key'.

Return Value

String value for the associated key.

See Also

P4Record Class


P4RecordSet Class

P4RecordSet Class
Members See Also
Provides output of a Perforce Command in "tagged" moded.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4RecordSet : P4BaseRecordSet, IEnumerable

Remarks

P4Recordset is an enumerable collection of P4Records that supply keyed access to information returned from Perforce.

Inheritance Hierarchy

System..::.Object
P4API..::.P4BaseRecordSet
P4API..::.P4RecordSet

See Also

P4RecordSet Members


P4RecordSet Members

[image]

P4.Net -- Managed API for Perforce
P4RecordSet Members
P4RecordSet Class Methods Properties See Also

The P4RecordSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasErrors | Checks the Recordset to determine if errors occured. (Inherited from P4BaseRecordSet.)
HasWarnings | Checks the Recordset to determine if warnings occured. (Inherited from P4BaseRecordSet.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorMessage | Gets an error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Errors | Gets an array of error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Item | Gets the record at the specified index.
Messages | Gets an array of string messages returned from the Perforce command.
Records | Gets an array of records returned from the Perforce command.
Warnings | Gets an array of warning messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)

See Also

P4RecordSet Class


P4RecordSet Properties

[image]

P4.Net -- Managed API for Perforce
P4RecordSet Properties
P4RecordSet Class See Also

The P4RecordSet type exposes the following properties.

Properties

Name | Description
ErrorMessage | Gets an error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Errors | Gets an array of error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Item | Gets the record at the specified index.
Messages | Gets an array of string messages returned from the Perforce command.
Records | Gets an array of records returned from the Perforce command.
Warnings | Gets an array of warning messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)

See Also

P4RecordSet Class


Item Property

P4RecordSet..::.Item Property
P4RecordSet Class See Also
Gets the record at the specified index.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4Record this[
    int Index
] { get; }

Parameters

Index
Type: System..::.Int32
Index of the record to get.

Field Value

Returns the record at 'Index'.

Return Value

P4Record

See Also

P4RecordSet Class


Messages Property

P4RecordSet..::.Messages Property
P4RecordSet Class See Also
Gets an array of string messages returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string[] Messages { get; }

Field Value

Array of informational messages returned from a Perforce command.

See Also

P4RecordSet Class


Records Property

P4RecordSet..::.Records Property
P4RecordSet Class See Also
Gets an array of records returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4Record[] Records { get; }

Field Value

Array of P4Records.

See Also

P4RecordSet Class


P4UnParsedRecordSet Class

P4UnParsedRecordSet Class
Members See Also
This class represents the "unparsed" output from a Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4UnParsedRecordSet : P4BaseRecordSet, IEnumerable

Remarks

In general P4UnParsedRecordSet will return an array of strings which is analagous to a line printed to stdout in p4.exe. Errors and Warnings are stored in the Errors and Warnings properties respectively.

Inheritance Hierarchy

System..::.Object
P4API..::.P4BaseRecordSet
P4API..::.P4UnParsedRecordSet

See Also

P4UnParsedRecordSet Members


P4UnParsedRecordSet Members

[image]

P4.Net -- Managed API for Perforce
P4UnParsedRecordSet Members
P4UnParsedRecordSet Class Methods Properties See Also

The P4UnParsedRecordSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasErrors | Checks the Recordset to determine if errors occured. (Inherited from P4BaseRecordSet.)
HasWarnings | Checks the Recordset to determine if warnings occured. (Inherited from P4BaseRecordSet.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorMessage | Gets an error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Errors | Gets an array of error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Item | Gets message at the specified index.
Messages | Gets array of messages returned from the Perforce command.
Warnings | Gets an array of warning messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)

See Also

P4UnParsedRecordSet Class


P4UnParsedRecordSet Properties

[image]

P4.Net -- Managed API for Perforce
P4UnParsedRecordSet Properties
P4UnParsedRecordSet Class See Also

The P4UnParsedRecordSet type exposes the following properties.

Properties

Name | Description
ErrorMessage | Gets an error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Errors | Gets an array of error messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)
Item | Gets message at the specified index.
Messages | Gets array of messages returned from the Perforce command.
Warnings | Gets an array of warning messages returned from the Perforce command. (Inherited from P4BaseRecordSet.)

See Also

P4UnParsedRecordSet Class


Item Property

P4UnParsedRecordSet..::.Item Property
P4UnParsedRecordSet Class See Also
Gets message at the specified index.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string this[
    int index
] { get; }

Parameters

index
Type: System..::.Int32
Index of the message.

Field Value

Message at 'index'.

Return Value

String message

Remarks

This is the same as running record.Messages[0];

See Also

P4UnParsedRecordSet Class


Messages Property

P4UnParsedRecordSet..::.Messages Property
P4UnParsedRecordSet Class See Also
Gets array of messages returned from the Perforce command.

Namespace: P4API
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public string[] Messages { get; }

Field Value

Array of messages returned from Perforce.

See Also

P4UnParsedRecordSet Class


P4API.Exceptions Namespace

P4API.Exceptions Namespace
Exceptions raised in P4API.

Classes

Class | Description
DiffNotImplemented | Support for diff (without -s* flag) not yet implemented
ErrorPauseCalled | ClientUser ErrorPause method was called. This in unsupported in P4.Net.
FileNotFound | Exception: File not found!
FormCommandException | Exception: Interactive 'Form' commands are unsupported in P4API. Use the 'Fetch_Form' and 'Save_Form' methods of the P4Connection object.
FormFetchException | Exception: Error attempting to fetch form.
FormParseException | Error parsing the form spec.
InvalidFormArgument | Exception: You can not use the '-o' and '-i' flags in Fetch_Form and Save_Form.
InvalidLogin | Exception: Invalid login credentials.
MergeNotImplemented | Support for merging not yet implemented
P4APIExceptions | Base exception for P4API.
PerforceInitializationError | Exception: Unable to connect to the Perforce Server!
RunException | Exception: Error running Perforce command!
RunUnParsedException | Exception: Error running Perforce command!
ServerAlreadyConnected | Exception: Changing the port when a server is connected is not allowed!
ServerNotConnected | Exception: Attempting to run a command while the Perforce Server is not connected!
ServerNotConnected_SetVar_AfterInit | Exception: Attempting to set a property that can not be set after the server is connected!
StreamNotWriteable | Exception: Can not write to stream.


DiffNotImplemented Class

DiffNotImplemented Class
Members See Also
Support for diff (without -s* flag) not yet implemented

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class DiffNotImplemented : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.DiffNotImplemented

See Also

DiffNotImplemented Members
P4API.Exceptions Namespace


DiffNotImplemented Members

[image]

P4.Net -- Managed API for Perforce
DiffNotImplemented Members
DiffNotImplemented Class Methods Properties See Also

The DiffNotImplemented type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DiffNotImplemented Class
P4API.Exceptions Namespace


DiffNotImplemented Properties

[image]

P4.Net -- Managed API for Perforce
DiffNotImplemented Properties
DiffNotImplemented Class See Also

The DiffNotImplemented type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DiffNotImplemented Class
P4API.Exceptions Namespace


Message Property

DiffNotImplemented..::.Message Property
DiffNotImplemented Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

DiffNotImplemented Class
P4API.Exceptions Namespace


ErrorPauseCalled Class

ErrorPauseCalled Class
Members See Also
ClientUser ErrorPause method was called. This in unsupported in P4.Net.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ErrorPauseCalled : P4APIExceptions

Remarks

If you see this, please let the curator know the steps to reproduce. This should not be reachable code.

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.ErrorPauseCalled

See Also

ErrorPauseCalled Members
P4API.Exceptions Namespace


ErrorPauseCalled Members

[image]

P4.Net -- Managed API for Perforce
ErrorPauseCalled Members
ErrorPauseCalled Class Constructors Methods Properties See Also

The ErrorPauseCalled type exposes the following members.

Constructors

Name | Description
ErrorPauseCalled |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ErrorPauseCalled Class
P4API.Exceptions Namespace


ErrorPauseCalled Constructor

ErrorPauseCalled Constructor
ErrorPauseCalled Class See Also
Initializes a new instance of the ErrorPauseCalled class.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public ErrorPauseCalled()

See Also

ErrorPauseCalled Class
P4API.Exceptions Namespace


ErrorPauseCalled Properties

[image]

P4.Net -- Managed API for Perforce
ErrorPauseCalled Properties
ErrorPauseCalled Class See Also

The ErrorPauseCalled type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ErrorPauseCalled Class
P4API.Exceptions Namespace


Message Property

ErrorPauseCalled..::.Message Property
ErrorPauseCalled Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

ErrorPauseCalled Class
P4API.Exceptions Namespace


FileNotFound Class

FileNotFound Class
Members See Also
Exception: File not found!

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class FileNotFound : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.FileNotFound

See Also

FileNotFound Members
P4API.Exceptions Namespace


FileNotFound Members

[image]

P4.Net -- Managed API for Perforce
FileNotFound Members
FileNotFound Class Methods Properties See Also

The FileNotFound type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileNotFound Class
P4API.Exceptions Namespace


FileNotFound Properties

[image]

P4.Net -- Managed API for Perforce
FileNotFound Properties
FileNotFound Class See Also

The FileNotFound type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileNotFound Class
P4API.Exceptions Namespace


Message Property

FileNotFound..::.Message Property
FileNotFound Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

FileNotFound Class
P4API.Exceptions Namespace


FormCommandException Class

FormCommandException Class
Members See Also
Exception: Interactive 'Form' commands are unsupported in P4API. Use the 'Fetch_Form' and 'Save_Form' methods of the P4Connection object.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class FormCommandException : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.FormCommandException

See Also

FormCommandException Members
P4API.Exceptions Namespace


FormCommandException Members

[image]

P4.Net -- Managed API for Perforce
FormCommandException Members
FormCommandException Class Methods Properties See Also

The FormCommandException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FormCommandException Class
P4API.Exceptions Namespace


FormCommandException Properties

[image]

P4.Net -- Managed API for Perforce
FormCommandException Properties
FormCommandException Class See Also

The FormCommandException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FormCommandException Class
P4API.Exceptions Namespace


Message Property

FormCommandException..::.Message Property
FormCommandException Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

FormCommandException Class
P4API.Exceptions Namespace


FormFetchException Class

FormFetchException Class
Members See Also
Exception: Error attempting to fetch form.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class FormFetchException : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.FormFetchException

See Also

FormFetchException Members
P4API.Exceptions Namespace


FormFetchException Members

[image]

P4.Net -- Managed API for Perforce
FormFetchException Members
FormFetchException Class Methods Properties See Also

The FormFetchException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FormFetchException Class
P4API.Exceptions Namespace


FormFetchException Properties

[image]

P4.Net -- Managed API for Perforce
FormFetchException Properties
FormFetchException Class See Also

The FormFetchException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FormFetchException Class
P4API.Exceptions Namespace


Message Property

FormFetchException..::.Message Property
FormFetchException Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

FormFetchException Class
P4API.Exceptions Namespace


FormParseException Class

FormParseException Class
Members See Also
Error parsing the form spec.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class FormParseException : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.FormParseException

See Also

FormParseException Members
P4API.Exceptions Namespace


FormParseException Members

[image]

P4.Net -- Managed API for Perforce
FormParseException Members
FormParseException Class Methods Properties See Also

The FormParseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FormParseException Class
P4API.Exceptions Namespace


FormParseException Properties

[image]

P4.Net -- Managed API for Perforce
FormParseException Properties
FormParseException Class See Also

The FormParseException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FormParseException Class
P4API.Exceptions Namespace


Message Property

FormParseException..::.Message Property
FormParseException Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

FormParseException Class
P4API.Exceptions Namespace


InvalidFormArgument Class

InvalidFormArgument Class
Members See Also
Exception: You can not use the '-o' and '-i' flags in Fetch_Form and Save_Form.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class InvalidFormArgument : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.InvalidFormArgument

See Also

InvalidFormArgument Members
P4API.Exceptions Namespace


InvalidFormArgument Members

[image]

P4.Net -- Managed API for Perforce
InvalidFormArgument Members
InvalidFormArgument Class Methods Properties See Also

The InvalidFormArgument type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidFormArgument Class
P4API.Exceptions Namespace


InvalidFormArgument Properties

[image]

P4.Net -- Managed API for Perforce
InvalidFormArgument Properties
InvalidFormArgument Class See Also

The InvalidFormArgument type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidFormArgument Class
P4API.Exceptions Namespace


Message Property

InvalidFormArgument..::.Message Property
InvalidFormArgument Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

InvalidFormArgument Class
P4API.Exceptions Namespace


InvalidLogin Class

InvalidLogin Class
Members See Also
Exception: Invalid login credentials.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class InvalidLogin : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.InvalidLogin

See Also

InvalidLogin Members
P4API.Exceptions Namespace


InvalidLogin Members

[image]

P4.Net -- Managed API for Perforce
InvalidLogin Members
InvalidLogin Class Methods Properties See Also

The InvalidLogin type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidLogin Class
P4API.Exceptions Namespace


InvalidLogin Properties

[image]

P4.Net -- Managed API for Perforce
InvalidLogin Properties
InvalidLogin Class See Also

The InvalidLogin type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidLogin Class
P4API.Exceptions Namespace


Message Property

InvalidLogin..::.Message Property
InvalidLogin Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

InvalidLogin Class
P4API.Exceptions Namespace


MergeNotImplemented Class

MergeNotImplemented Class
Members See Also
Support for merging not yet implemented

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class MergeNotImplemented : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.MergeNotImplemented

See Also

MergeNotImplemented Members
P4API.Exceptions Namespace


MergeNotImplemented Members

[image]

P4.Net -- Managed API for Perforce
MergeNotImplemented Members
MergeNotImplemented Class Methods Properties See Also

The MergeNotImplemented type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MergeNotImplemented Class
P4API.Exceptions Namespace


MergeNotImplemented Properties

[image]

P4.Net -- Managed API for Perforce
MergeNotImplemented Properties
MergeNotImplemented Class See Also

The MergeNotImplemented type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MergeNotImplemented Class
P4API.Exceptions Namespace


Message Property

MergeNotImplemented..::.Message Property
MergeNotImplemented Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

MergeNotImplemented Class
P4API.Exceptions Namespace


P4APIExceptions Class

P4APIExceptions Class
Members See Also
Base exception for P4API.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class P4APIExceptions : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.ServerNotConnected
P4API.Exceptions..::.ServerAlreadyConnected
P4API.Exceptions..::.InvalidLogin
P4API.Exceptions..::.ServerNotConnected_SetVar_AfterInit
P4API.Exceptions..::.InvalidFormArgument
P4API.Exceptions..::.PerforceInitializationError
P4API.Exceptions..::.FormParseException
P4API.Exceptions..::.DiffNotImplemented
P4API.Exceptions..::.MergeNotImplemented
P4API.Exceptions..::.FormFetchException
P4API.Exceptions..::.FormCommandException
P4API.Exceptions..::.RunUnParsedException
P4API.Exceptions..::.RunException
P4API.Exceptions..::.ErrorPauseCalled
P4API.Exceptions..::.FileNotFound
P4API.Exceptions..::.StreamNotWriteable

See Also

P4APIExceptions Members
P4API.Exceptions Namespace


P4APIExceptions Members

[image]

P4.Net -- Managed API for Perforce
P4APIExceptions Members
P4APIExceptions Class Methods Properties See Also

The P4APIExceptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides Exception ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4APIExceptions Class
P4API.Exceptions Namespace


P4APIExceptions Properties

[image]

P4.Net -- Managed API for Perforce
P4APIExceptions Properties
P4APIExceptions Class See Also

The P4APIExceptions type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides Exception ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4APIExceptions Class
P4API.Exceptions Namespace


Message Property

P4APIExceptions..::.Message Property
P4APIExceptions Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

P4APIExceptions Class
P4API.Exceptions Namespace


PerforceInitializationError Class

PerforceInitializationError Class
Members See Also
Exception: Unable to connect to the Perforce Server!

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class PerforceInitializationError : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.PerforceInitializationError

See Also

PerforceInitializationError Members
P4API.Exceptions Namespace


PerforceInitializationError Members

[image]

P4.Net -- Managed API for Perforce
PerforceInitializationError Members
PerforceInitializationError Class Methods Properties See Also

The PerforceInitializationError type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PerforceInitializationError Class
P4API.Exceptions Namespace


PerforceInitializationError Properties

[image]

P4.Net -- Managed API for Perforce
PerforceInitializationError Properties
PerforceInitializationError Class See Also

The PerforceInitializationError type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PerforceInitializationError Class
P4API.Exceptions Namespace


Message Property

PerforceInitializationError..::.Message Property
PerforceInitializationError Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

PerforceInitializationError Class
P4API.Exceptions Namespace


RunException Class

RunException Class
Members See Also
Exception: Error running Perforce command!

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class RunException : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.RunException

See Also

RunException Members
P4API.Exceptions Namespace


RunException Members

[image]

P4.Net -- Managed API for Perforce
RunException Members
RunException Class Methods Properties See Also

The RunException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RunException Class
P4API.Exceptions Namespace


RunException Properties

[image]

P4.Net -- Managed API for Perforce
RunException Properties
RunException Class See Also

The RunException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RunException Class
P4API.Exceptions Namespace


Message Property

RunException..::.Message Property
RunException Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

RunException Class
P4API.Exceptions Namespace


RunUnParsedException Class

RunUnParsedException Class
Members See Also
Exception: Error running Perforce command!

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class RunUnParsedException : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.RunUnParsedException

See Also

RunUnParsedException Members
P4API.Exceptions Namespace


RunUnParsedException Members

[image]

P4.Net -- Managed API for Perforce
RunUnParsedException Members
RunUnParsedException Class Methods Properties See Also

The RunUnParsedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Result | Gets the P4UnParsedRecordSet that would have been returned if an exception was not thrown.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RunUnParsedException Class
P4API.Exceptions Namespace


RunUnParsedException Properties

[image]

P4.Net -- Managed API for Perforce
RunUnParsedException Properties
RunUnParsedException Class See Also

The RunUnParsedException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Result | Gets the P4UnParsedRecordSet that would have been returned if an exception was not thrown.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RunUnParsedException Class
P4API.Exceptions Namespace


Message Property

RunUnParsedException..::.Message Property
RunUnParsedException Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

RunUnParsedException Class
P4API.Exceptions Namespace


Result Property

RunUnParsedException..::.Result Property
RunUnParsedException Class See Also
Gets the P4UnParsedRecordSet that would have been returned if an exception was not thrown.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public P4UnParsedRecordSet Result { get; }

See Also

RunUnParsedException Class
P4API.Exceptions Namespace


ServerAlreadyConnected Class

ServerAlreadyConnected Class
Members See Also
Exception: Changing the port when a server is connected is not allowed!

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ServerAlreadyConnected : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.ServerAlreadyConnected

See Also

ServerAlreadyConnected Members
P4API.Exceptions Namespace


ServerAlreadyConnected Members

[image]

P4.Net -- Managed API for Perforce
ServerAlreadyConnected Members
ServerAlreadyConnected Class Methods Properties See Also

The ServerAlreadyConnected type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerAlreadyConnected Class
P4API.Exceptions Namespace


ServerAlreadyConnected Properties

[image]

P4.Net -- Managed API for Perforce
ServerAlreadyConnected Properties
ServerAlreadyConnected Class See Also

The ServerAlreadyConnected type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerAlreadyConnected Class
P4API.Exceptions Namespace


Message Property

ServerAlreadyConnected..::.Message Property
ServerAlreadyConnected Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

ServerAlreadyConnected Class
P4API.Exceptions Namespace


ServerNotConnected Class

ServerNotConnected Class
Members See Also
Exception: Attempting to run a command while the Perforce Server is not connected!

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ServerNotConnected : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.ServerNotConnected

See Also

ServerNotConnected Members
P4API.Exceptions Namespace


ServerNotConnected Members

[image]

P4.Net -- Managed API for Perforce
ServerNotConnected Members
ServerNotConnected Class Methods Properties See Also

The ServerNotConnected type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerNotConnected Class
P4API.Exceptions Namespace


ServerNotConnected Properties

[image]

P4.Net -- Managed API for Perforce
ServerNotConnected Properties
ServerNotConnected Class See Also

The ServerNotConnected type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerNotConnected Class
P4API.Exceptions Namespace


Message Property

ServerNotConnected..::.Message Property
ServerNotConnected Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

ServerNotConnected Class
P4API.Exceptions Namespace


ServerNotConnected_SetVar_AfterInit Class

ServerNotConnected_SetVar_AfterInit Class
Members See Also
Exception: Attempting to set a property that can not be set after the server is connected!

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class ServerNotConnected_SetVar_AfterInit : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.ServerNotConnected_SetVar_AfterInit

See Also

ServerNotConnected_SetVar_AfterInit Members
P4API.Exceptions Namespace


ServerNotConnected_SetVar_AfterInit Members

[image]

P4.Net -- Managed API for Perforce
ServerNotConnected_SetVar_AfterInit Members
ServerNotConnected_SetVar_AfterInit Class Methods Properties See Also

The ServerNotConnected_SetVar_AfterInit type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerNotConnected_SetVar_AfterInit Class
P4API.Exceptions Namespace


ServerNotConnected_SetVar_AfterInit Properties

[image]

P4.Net -- Managed API for Perforce
ServerNotConnected_SetVar_AfterInit Properties
ServerNotConnected_SetVar_AfterInit Class See Also

The ServerNotConnected_SetVar_AfterInit type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServerNotConnected_SetVar_AfterInit Class
P4API.Exceptions Namespace


Message Property

ServerNotConnected_SetVar_AfterInit..::.Message Property
ServerNotConnected_SetVar_AfterInit Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

ServerNotConnected_SetVar_AfterInit Class
P4API.Exceptions Namespace


StreamNotWriteable Class

StreamNotWriteable Class
Members See Also
Exception: Can not write to stream.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public class StreamNotWriteable : P4APIExceptions

Inheritance Hierarchy

System..::.Object
System..::.Exception
P4API.Exceptions..::.P4APIExceptions
P4API.Exceptions..::.StreamNotWriteable

See Also

StreamNotWriteable Members
P4API.Exceptions Namespace


StreamNotWriteable Members

[image]

P4.Net -- Managed API for Perforce
StreamNotWriteable Members
StreamNotWriteable Class Constructors Methods Properties See Also

The StreamNotWriteable type exposes the following members.

Constructors

Name | Description
StreamNotWriteable |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

StreamNotWriteable Class
P4API.Exceptions Namespace


StreamNotWriteable Constructor

StreamNotWriteable Constructor
StreamNotWriteable Class See Also
Initializes a new instance of the StreamNotWriteable class.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public StreamNotWriteable()

See Also

StreamNotWriteable Class
P4API.Exceptions Namespace


StreamNotWriteable Properties

[image]

P4.Net -- Managed API for Perforce
StreamNotWriteable Properties
StreamNotWriteable Class See Also

The StreamNotWriteable type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets the error message for the exception. (Overrides P4APIExceptions ..::. Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

StreamNotWriteable Class
P4API.Exceptions Namespace


Message Property

StreamNotWriteable..::.Message Property
StreamNotWriteable Class See Also
Gets the error message for the exception.

Namespace: P4API.Exceptions
Assembly: p4api (in p4api)
Version: 1.0.0.0 (1.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

StreamNotWriteable Class
P4API.Exceptions Namespace


P4.Net Copyright

P4.Net Copyright

Copyright © 2007 Shawn Hladky

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.