P4 API.NET

[image]

Perforce .NET API
P4 API.NET
Send Feedback
P4API.NET, the Perforce derived API for .NET

Release compatibility of the P4API.NET

P4API.NET is subject to change from release to release, and is not guaranteed to be source-code compatible from one release to the next. However, clients that you create using P4API.NET can run against previous releases of the Perforce server and will probably run against later releases of the Perforce server.

Support for specific features depends on the version of server and P4API.NET that you use.

Purpose of P4API.NET

P4API.NET enables you to create client programs that interact with end users, send commands to a Perforce server and process data returned from the server.

Send comments on this topic to manual@perforce.com


Introduction

[image]

Perforce .NET API
Introduction
Send Feedback
Pre-requisites

For a project to use P4API.NET, p4api.net.dll and p4bridge.dll must be in the build output directory. On creation of a new console application, the Debug output location would be: ...\SolutionDir\ProjectDir\bin\Debug\. Next, add p4api.net.dll as a project reference by clicking Add Reference... on the References node of the project in the solution explorer in Visual Studio and browsing to the location of the newly added p4api.net.dll.

Using P4API.NET

Client programs interact with the Perforce server by:

  1. Initializing a connection.

  2. Sending commands.

  3. Closing the connection.

Initializing a connection

To connect to the Perforce server, your client application must call the Connect() method; for example:

CopyC#
// initialize the connection variables
// note: this is a connection without using a password
string uri = "localhost:6666";
string user = "admin";
string ws_client = "admin_space";

// define the server, repository and connection
Server server = new Server(new ServerAddress(uri));
Repository rep = new Repository(server);
Connection con = rep.Connection;

// use the connection variables for this connection
con.UserName = user;
con.Client = new Client();
con.Client.Name = ws_client;

// connect to the server
con.Connect(null);
CopyC#
// initialize the connection variables
// note: this is a connection without using a password
// that sets the application name and version.
// This information will appear when commands are
// recorded in the server log as
// [ProgramName/ProgramVersion]
string uri = "localhost:6666";
string user = "admin";
string ws_client = "admin_space";

// define the server, repository and connection
Server server = new Server(new ServerAddress(uri));
Repository rep = new Repository(server);
Connection con = rep.Connection;

// use the connection variables for this connection
con.UserName = user;
con.Client = new Client();
con.Client.Name = ws_client;

// set the program name and version
P4.Options options = new P4.Options();
options["ProgramName"] ="MyP4API.NET_APP";
options["ProgramVersion"] ="2015.1.105.4164";

// connect to the server
con.Connect(options);
CopyC#
// initialize the connection variables
// note: this is a connection using a password
string uri = "localhost:6666";
string user = "admin";
string ws_client = "admin_space";
string pass = "password";

// define the server, repository and connection
Server server = new Server(new ServerAddress(uri));
Repository rep = new Repository(server);
Connection con = rep.Connection;

// use the connection variables for this connection
con.UserName = user;
con.Client = new Client();
con.Client.Name = ws_client;

// connect to the server
con.Connect(null);

// login to the server to get credential
// (using null for options and user params)
Credential cred = con.Login(pass, null, null);

// get server metadata and check version
// (using null for options parameter)
ServerMetaData p4info = rep.GetServerMetaData(null);
ServerVersion version= p4info.Version;
string release = version.Major;

For information on SSL connections, refer to the TrustAndConnect method.

Setting Command Time Out

The Command Time Out duration defaults to 5 seconds. If a command times out, P4API.NET will throw a P4CommandTimeOutException. After a connection has been established the Command Time Out can be changed in Repository.Connection.CommandTimeout:

CopyC#
// initialize the connection variables
// note: this is a connection without using a password
string uri = "localhost:6666";
string user = "admin";
string ws_client = "admin_space";

// define the server, repository and connection
Server server = new Server(new ServerAddress(uri));
Repository rep = new Repository(server);
Connection con = rep.Connection;

// use the connection variables for this connection
con.UserName = user;
con.Client = new Client();
con.Client.Name = ws_client;

// connect to the server
con.Connect(null);

// change the Command Time Out to 20 seconds
con.CommandTimeout = TimeSpan.FromSeconds(20);

Sending commands

To send commands to the Perforce server, your client can use P4 API.NET methods; for example:

CopyC#
// set the options for the p4 changes command
string clientName = "admin_space";
int maxItems = 5;
string userName = "admin";
ChangesCmdOptions options = new ChangesCmdOptions(ChangesCmdFlags.LongDescription,
        clientName, maxItems, ChangeListStatus.None, userName);

// run the command against the current repository
IList<Changelist> changes = rep.getChangelists(options);

// changes will contain the data returned by the command
// p4 changes -L -c admin_space -m 5 -u admin
CopyC#
// set the options for the p4 edit command
string depotPath = "//depot/main/test.txt";
int changelist = 0;
// create FileSpec with null for ClientPath, LocalPath, and VersionSpec
FileSpec fileToCheckout = new FileSpec(new DepotPath(depotPath), null, null, null)
// using null for FileType
EditCmdOptions options = new EditCmdOptions(EditFilesCmdFlags.None, changelist, null);

// run the command with the current connection
IList<FileSpec> filesCheckedOut = con.Client.EditFiles(options, fileToCheckout);

// filesCheckedOut will contain the data returned by the command
// p4 edit //depot/main/test.txt
// and the file will be checked out in the default pending changelist
CopyC#
// set the options for the p4 submit command
// 0 to specify default pending changelist, null for changelist since we are using the default
string description = "update to test.txt";
// set reopen to false
ClientSubmitOptions clientOptions = new ClientSubmitOptions(false,SubmitType.SubmitUnchanged)
SubmitCmdOptions options = new SubmitCmdOptions(SubmitFilesCmdFlags.None,
                    0, null, description, clientOptions)
// create FileSpec with null for ClientPath, LocalPath, and VersionSpec
string depotPath = "//depot/main/test.txt";
FileSpec fileToSubmit = new FileSpec(new DepotPath(depotPath), null, null, null)

// run the command with the current connection
SubmitResults results= con.Client.SubmitFiles(options, fileToSubmit);

// results will contain the data returned by the command
// p4 submit -d "update to test.txt" //depot/main/test.txt

Closing the connection

To disconnect from the Perforce server, your client application must call the Disconnect() method; for example:

CopyC#
// disconnect from the server
con.Disconnect();

Running commands directly

To run commands that do not have methods in the .NET API, your client can use the P4Command.Run() method; for example:

CopyC#
// create a new command using parameters:
// repository, command, tagged, arguments
string file="//depot/main/test.txt";
P4Command cmd = new P4Command(rep, "attribute", true, file);
Options opts = new Options();
opts["-n"] = "fileID";
opts["-v"] = "1";

//run command and get results
P4CommandResult results = cmd.Run(opts);

// results will contain the data returned by the command
// p4 -ztag attribute -n fileID -v 1 //depot/main/test.txt

Running command methods is more useful when care about the results of the command and want them parsed for display or to be passed on to other commands. If command results are not important, running the command directly may be preferable.

Working with Options

Options have subclasses specific to particular commands. These dictionary objects can also be created directly, for example:

CopyC#
ClientCmdOptions clientOpts = new ClientCmdOptions(ClientCmdFlags.Output);

will create the same options as:

CopyC#
Options opts = new Options();
opts["-o"]=null;

A command run with either of these options will use the -o flag. Refer to the Options Constructors for details on specific options flags.

Note that some option flags are mutually exclusive and using them together will result in the same errors that would be returned from the command line. Some examples of proper usage:

CopyC#
// the SubmitCmdOptions class
public SubmitCmdOptions(SubmitFilesCmdFlags flags, int changelist, Changelist newChangelist,
string description, ClientSubmitOptions submitOptions)

// options for submitting from the default changelist
// the SubmitCmdOptions and ClientSubmitOptions can vary
SubmitCmdOptions submitOpts = new SubmitCmdOptions(SubmitFilesCmdFlags.None, 0, null, "submitting
from default changelist", new ClientSubmitOptions(false,SubmitType.SubmitUnchanged))

// options for submitting from a numbered changelist 16
// the SubmitCmdOptions and ClientSubmitOptions can vary
SubmitCmdOptions submitOpts = new SubmitCmdOptions(SubmitFilesCmdFlags.IncludeJobs, 16, null,
null, new ClientSubmitOptions(false,SubmitType.RevertUnchanged));

// options for submitting a new changelist using a changelist specification where change
// is a P4.Changelist
// the SubmitCmdOptions and ClientSubmitOptions can vary
SubmitCmdOptions submitOpts = new SubmitCmdOptions(SubmitFilesCmdFlags.ReopenFiles, 0, change,
null, new ClientSubmitOptions(true,SubmitType.SubmitUnchanged));

// options for submitting a shelved file from a numbered changelist 18
// the SubmitCmdOptions and ClientSubmitOptions can vary
SubmitCmdOptions submitOpts = new SubmitCmdOptions(Perforce.P4.SubmitFilesCmdFlags.SubmitShelved,
18, null, null, null);

Here is an example of improper usage of flags that are mutually exclusive:

CopyC#
// the SubmitCmdOptions class
public SubmitCmdOptions(SubmitFilesCmdFlags flags, int changelist, Changelist newChangelist,
string description, ClientSubmitOptions submitOptions)

// improper options for submitting from a numbered changelist 20
// the SubmitCmdOptions and ClientSubmitOptions can vary
SubmitCmdOptions submitOpts = new SubmitCmdOptions(SubmitFilesCmdFlags.None, 16, null,
"submitting change 20", new ClientSubmitOptions(false,SubmitType.RevertUnchanged));

The above options will return the error "Usage: submit [ -r -f option ] -c changelist#\n" because a changelist number and a description were specified and the -c and -d flags are mutually exclusive.

Building a FileSpec

Commands for working with files and paths will need a FileSpec or a list or an array of FileSpecs as an argument when running the command. A FileSpec consists of a PathSpec (or PathSpecs) and a VersionSpec. The PathSpecs can be DepotPaths, ClientPaths, and LocalPaths. The VersionSpec can be a revision or a revision range. Some examples:

CopyC#
// create a FileSpec for //depot/test.txt
// using new FileSpec(PathSpec path, VersionSpec version)
PathSpec path = new DepotPath("//depot/test.txt");
FileSpec depotFile = new FileSpec(path, null);

// create a FileSpec for //depot/test.txt#5
// using new FileSpec(PathSpec path, VersionSpec version)
path = new DepotPath("//depot/test.txt");
VersionSpec version = new Revision(5);
depotFile = new FileSpec(path, version);

// create a FileSpec for //depot/test.txt@16,@22
// (version range between changelists 16 and 22)
// using new FileSpec(PathSpec path, VersionSpec version)
path = new DepotPath("//depot/test.txt");
VersionSpec lowerChangeID = new ChangelistIdVersion(16);
VersionSpec upperChangeID = new ChangelistIdVersion(22);
version = new VersionRange(lowerChangeID,upperChangeID);
depotFile = new FileSpec(path, version);

// create a FileSpec for C:\Users\username\Depot\test.txt#head
// using new FileSpec(PathSpec path, VersionSpec version)
path = new LocalPath("C:\\Users\\username\\Depot\\test.txt");
version = new HeadRevision();
depotFile = new FileSpec(path, version);

// create a FileSpec for //depot/test.txt@labelName
// using new FileSpec(PathSpec path, VersionSpec version)
path = new DepotPath("//depot/test.txt");
version = new LabelNameVersion("labelName");
depotFile = new FileSpec(path, version);

// create a FileSpec for //depot/...@2013/5/27,@now
// (version range between 2013/5/27 and now)
// using new FileSpec(PathSpec path, VersionSpec version)
path = new DepotPath("//depot/...");
DateTimeVersion lowerTimeStamp = new DateTimeVersion(new DateTime(2013,5,27));
DateTimeVersion upperTimeStamp = new DateTimeVersion(DateTime.Now);
version = new VersionRange(lowerTimeStamp,upperTimeStamp);
depotFile = new FileSpec(path, version);

Refer to the VersionSpec class for additional revision types.

Error handling

If a command returns a null, there were likely errors. Errors have different severity levels and do not necessarily mean that a command has failed. P4 API.NET methods will throw a P4Exception if an error of severity E_FAILED or higher is returned. This setting can be changed in P4Exception.MinThrowLevel. For example:

CopyC#
// turn off P4Exceptions
P4Exception.MinThrowLevel = ErrorSeverity.E_NOEXC;

The following is an example of a command that will throw a P4Exception:

CopyC#
try
{
    // set options for client command
    ClientCmdOptions clientOpts = new ClientCmdOptions(ClientCmdFlags.Switch);

    // attempt to get label with p4 -s label testLabel
    Label label = rep.GetLabel("testLabel", null, clientOpts);
}
catch (P4Exception ex)
{
    // catch exception and display error message
    Console.WriteLine(ex.Message);
}

Because the error that the command returns is of severity E_FAILED an exception will be thrown. The Message displayed is: Usage: label [ -d -f -g -i -o -t template ] labelname Invalid option: -s. since there is no -s flag for p4 label.

This is an example of a command that will not throw a P4Exception:

CopyC#
// set options for client command
 try
{
    SyncFilesCmdOptions syncOpts = new SyncFilesCmdOptions(SyncFilesCmdFlags.None, 1);
    FileSpec depotFile = new FileSpec(new DepotPath("//depot/test.txt"), null, null, null);
    IList<FileSpec> syncedFiles = rep.Connection.Client.SyncFiles(syncOpts, depotFile);
}
catch (P4Exception ex)
{
    Console.WriteLine(ex.Message);
}

Because the error that the command returns is of severity E_WARN no exception will be thrown. The file, //depot/test.txt is already at the latest revision but the command has still succeeded with a warning of "//depot/test.txt - file(s) up-to-date." syncedFiles will be null.

Sample application: a console specification fetcher

This is a console application that connects to a Perforce server and returns Perforce specification information based on user input of 2 words: specification type, specification name. It uses Connection.Login(password) for working with a server at security level 3. Lower security levels should also work and connecting with a user without a password can be done by passing a blank string for password. There is minimal error handling for failed Perforce commands. Since -o is used, specifications that do not yet exist may be returned on entry of a non-existent specification name.

Create a new C# Console Application project and paste the following code into Program.cs:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using Perforce.P4;
namespace apiConsoleApplication
{
    class Program
    {
        static void Main()
        {
            string uri = "";
            string user = "";
            string workspace = "";
            string pass = "";

            bool exit = false;

            Server server = new Server(new ServerAddress(uri));
            Repository rep = new Repository(server);

            // establish a connection to a server
            while(rep.Connection.Status==ConnectionStatus.Disconnected)
            {
                // get user input for connection
                Console.WriteLine("port:");
                uri = Console.ReadLine();
                Console.WriteLine("");
                Console.WriteLine("user:");
                user = Console.ReadLine();
                Console.WriteLine("");
                Console.WriteLine("client:");
                workspace = Console.ReadLine();
                Console.WriteLine("");
                Console.WriteLine("password:");
                pass = Console.ReadLine();
                Console.WriteLine("");

                server = new Server(new ServerAddress(uri));
                rep = new Repository(server);
                Connection con = rep.Connection;
                con.UserName = user;
                con.Client = new Client();
                con.Client.Name = workspace;

                // connect
                bool connected = con.Connect(null);
                if (connected)
                {
                    try
                    {
                        // attempt a login
                        Credential cred = con.Login(pass);
                    }
                    catch (Exception ex)
                    {
                        Console.WriteLine(ex.Message);
                        con.Disconnect();
                        continue;
                    }
                    // get p4 info and show successful connection
                    ServerMetaData info = rep.GetServerMetaData(null);
                    Console.WriteLine("CONNECTED TO " + info.Address.Uri);
                    Console.WriteLine("");
                }
                else
                {
                    // retry the prompt for connection info
                    continue;
                }
            }

            while(rep.Connection.Status==ConnectionStatus.Connected&&!(exit))
            {
                Options opts= new Options();
                opts["-o"] = null;
                string input = Console.ReadLine();
                exit = (input == "exit");
                string[] command = input.Split(' ');
                switch (command[0])
                {
                        // on user input of job <job name> get job
                        // and output to console
                    case "job":
                        try
                        {
                            Job job = rep.GetJob(command[1], opts);
                            Console.WriteLine("");
                            Console.WriteLine(job.ToString());
                            Console.WriteLine("");
                            break;
                        }
                        catch (Exception ex)
                        {
                            Console.WriteLine("");
                            Console.WriteLine(ex.Message);
                            Console.WriteLine("");
                            break;
                        }

                        // on user input of change <change number> get
                        // change and output to console
                    case "change":
                        try
                        {
                            opts = new Options();
                            int id = 0;
                            int.TryParse(command[1], out id);

                            Changelist change = rep.GetChangelist(id, opts);
                            Console.WriteLine("");
                            Console.WriteLine(change.ToString());
                            Console.WriteLine("");
                            break;
                        }
                        catch (Exception ex)
                        {
                            Console.WriteLine("");
                            Console.WriteLine(ex.Message);
                            Console.WriteLine("");
                            break;
                        }

                        // on user input of client <client name> get
                        // client and output to console
                    case "client":
                        try
                        {
                            Client client = rep.GetClient(command[1]);
                            Console.WriteLine("");
                            Console.WriteLine(client.ToString());
                            Console.WriteLine("");
                            break;
                        }
                        catch (Exception ex)
                        {
                            Console.WriteLine("");
                            Console.WriteLine(ex.Message);
                            Console.WriteLine("");
                            break;
                        }

                        // on user input of label <label name> get
                        // label and output to console
                    case "label":
                        try
                        {
                            Label label = rep.GetLabel(command[1]);
                            Console.WriteLine("");
                            Console.WriteLine(label.ToString());
                            Console.WriteLine("");
                            break;
                        }
                        catch (Exception ex)
                        {
                            Console.WriteLine("");
                            Console.WriteLine(ex.Message);
                            Console.WriteLine("");
                            break;
                        }

                        // on user input of stream <stream path>get
                        // stream and output to console
                    case "stream":
                        try
                        {
                            Stream stream = rep.GetStream(command[1]);
                            Console.WriteLine("");
                            Console.WriteLine(stream.ToString());
                            Console.WriteLine("");
                            break;
                        }
                        catch (Exception ex)
                        {
                            Console.WriteLine("");
                            Console.WriteLine(ex.Message);
                            Console.WriteLine("");
                            break;
                        }

                        // on user input of branch <branch name> get
                        // branch and output to console
                    case "branch":
                        try
                        {
                            BranchSpec branch = rep.GetBranchSpec(command[1]);
                            Console.WriteLine("");
                            Console.WriteLine(branch.ToString());
                            Console.WriteLine("");
                            break;
                        }
                        catch (Exception ex)
                        {
                            Console.WriteLine("");
                            Console.WriteLine(ex.Message);
                            Console.WriteLine("");
                            break;
                        }
                }
            }
        }
    }
}


Getting more help

[image]

Perforce .NET API
Getting more help
Send Feedback

For more information about using Perforce, consult the following sources:

  • For additional information on P4 API.NET: Refer to the latest release notes or the README files included with the source and binary distributions

  • For information about Perforce commands: Refer to the latest Perforce Command Reference.

If you cannot find the answers to your question in this document, try these resources:

  • Technical documentation: http://www.perforce.com/perforce/technical.html.

  • Technical support: Call (510) 864-7400 or send email to support@perforce.com.

  • Perforce Knowledge Base: http://kb.perforce.com/.

Please send any comments about Perforce technical documentation, including this help system, to manual@perforce.com.


Perforce.P4 Namespace

[image]

Perforce .NET API
Perforce.P4 Namespace
Send Feedback

Classes

 | Class | Description
Public class | ActionVersion | A revision specifier that is a file action.
Public class | AddFilesCmdOptions | Add command options
Public class | BranchCmdOptions | Branch command options
Public class | BranchesCmdOptions | Branches command options
Public class | BranchSpec | A branch view specification in a Perforce repository.
Public class | ChangeCmdOptions | Change command options.
Public class | Changelist | A changelist specification in a Perforce repository.
Public class | ChangelistIdVersion | A revision specifier that is a changelist id.
Public class | ChangesCmdOptions | Changes command options.
Public class | Client | A client specification in a Perforce repository.
Public class | ClientCmdOptions | Client command options
Public class | ClientMetadata | Metadata from the client associated with a connection.
Public class | ClientNameVersion | A revision specifier that is a client name.
Public class | ClientPath | A path spec in client syntax.
Public class | ClientsCmdOptions | Clients command options
Public class | ClientSubmitOptions | Client options that define what to do with files upon submit.
Public class | Connection | Represents the logical connection between a specific Perforce Server instance and a specific client application.
Public class | CopyFilesCmdOptions | Copy command options.
Public class | Counter | A general-purpose counter or named variable in a Perforce repository.
Public class | CoutnerCmdOptions | Counter command options
Public class | Credential | Specifies user credentials for a specific connection.
Public class | DateTimeVersion | A revision specifier that is a date and time.
Public class | DeleteFilesCmdOptions | delete command options
Public class | Depot | A depot specification in a Perforce repository.
Public class | DepotCmdOptions | depot command options
Public class | DepotFileDiff | A diff between depot files in a Perforce repository.
Public class | DepotPath | A path spec in depot syntax.
Public class | DescribeCmdOptions | Options for the Describe command
Public class | EditCmdOptions | Options for the edit command
Public class | File | A versioned object that describes an individual file in a Perforce repository.
Public class | FileAnnotation | Correlates file lines with revision information.
Public class | FileHistory | Describes a Perforce file revision in detail, including the changelist number and associated description, action, user, etc. data.
Public class | FileIntegrationRecord | Represents submitted or pending integrations.
Public class | FileLineMatch | Specifies matching lines in Perforce managed files.
Public class | FilelogCmdOptions | Options for the filelog command.
Public class | FileMetaData | Metadata for a specific file stored in a Perforce repository.
Public class | FileResolveAction | Describes how, or if a file has been resolved.
Public class | FileResolveRecord | Specifies how file resolve operations were completed or will potentially be completed.
Public class | FilesCmdOptions | Files command options
Public class | FileSpec | Identifies one or more specific versioned objects in a Perforce repository.
Public class | FileSubmitRecord | Describes file submitted and file action performed.
Public class | FileType | Specifies a Perforce file type for a managed file.
Public class | Fix | Specifies a fix relationship between one or more jobs and one or more changelists.
Public class | FixJobsCmdOptions | Fix command options.
Public class | FormBase | Describes fields and comments in a Perforce specification.
Public class | FormSpec | Specifies structural and semantic metadata for form types.
Public class | GetDepotDirsCmdOptions | dirs command options
Public class | GetDepotFileDiffsCmdOptions | Diff2 command options
Public class | GetDepotFilesCmdOptions | Options for the files command
Public class | GetFileAnnotationsCmdOptions | Annotate command options
Public class | GetFileContentsCmdOptions | Print command options
Public class | GetFileHistoryCmdOptions | Filelog command options
Public class | GetFileLineMatchesCmdOptions | Grep command options
Public class | GetFileMetaDataCmdOptions | GetFileMetaData options (uses the fstat command)
Public class | GetFixesCmdOptions | Fixes command options
Public class | GetOpenedFilesOptions | GetOpenedFiles options
Public class | GetProtectionEntriesCmdOptions | Protects command options
Public class | GetProtectionTableCmdOptions | protect command options
Public class | GetReviewersCmdOptions | Reviews command options
Public class | GetStreamMetaDataCmdOptions | GetStreamMetaData command options
Public class | GetSubmittedIntegrationsCmdOptions | Integrated command options
Public class | GetTriggerTableCmdOptions | Triggers command options
Public class | GetTypeMapCmdOptions | GetTypeMap command options
Public class | Group | A user group on a Perforce Server, represented by a P4 Group spec.
Public class | GroupCmdOptions | Group command options.
Public class | GroupsCmdOptions | Groups command options.
Public class | HaveRevision | A revision specifier #have.
Public class | HeadRevision | A revision specifier #head.
Public class | InfoCmdOptions | Options for the Trust command
Public class | IntegrateFilesCmdOptions | Integrate command options
Public class | Job | A Job in the Repository.
Public class | JobCmdOptions | Job command options
Public class | JobsCmdOptions | Jobs command options
Public class | Label | A label specification in a Perforce repository.
Public class | LabelCmdOptions | Label command options
Public class | LabelNameVersion | A revision specifier that is a label name.
Public class | LabelsCmdOptions | Labels command options
Public class | LabelSyncCmdOptions | Labelsync command options
Public class | LocalPath | A path spec in local syntax.
Public class | LockCmdOptions | Lock command options
Public class | LogFile | Generic interface used to an event logger. In short, messages are logged by: 1) Level. The lower the level, the more sever the level, 0 fatal 1 error 2 warning 3 information 4+ debugging messages 2) Source. A string specifying the origin of the message, ie P4Server 3) Message. The text of the message.
Public class | LoginCmdOptions | Options for the login command.
Public class | LogoutCmdOptions | Options for the logout command.
Public class | MapEntry | A single entry in a view map.
Public class | MergeFilesCmdOptions | Merge command options.
Public class | MoveCmdOptions | Move command options
Public class | NoneRevision | A revision specifier #none.
Public class | Options | A generic list of command options and values.
Public class | OtherFileUser | Class summarizing the use of this file by another user.
Public class | OtherUsers | Specifies other users who have a particular file open.
Public class | P4CallBacks | Class wrapper for the definitions of delegates required to model the callbacks from the bridge dll.
Public class | P4CantCloseConnectionException |
Public class | P4ClientError | Class used to return a single error or warning from the bridge dll.
Public class | P4ClientErrorList | Class used to return a list of errors and warnings returned by a command.
Public class | P4ClientInfoMessage | Class used to return a info message from the bridge dll.
Public class | P4ClientInfoMessageList | Class used to return a list of info Messages returned by a command.
Public class | P4ClientMerge |
Public class | P4ClientResolve | Class containing the DLL imports for the P4Bridge DLL.
Public class | P4Command | Class wrapping command execution.
Public class | P4CommandCanceledException |
Public class | P4CommandResult | Class representing the results of executing a command on a Perforce Server.
Public class | P4CommandTimeOutException |
Public class | P4Exception | Base class for exceptions caused by run time errors from the server. They can be disabled, by setting the MinThrowLevel to ErrorSeverity.E_NOEXC.
Public class | P4HungCommandCancelException |
Public class | P4LostConnectionException |
Public class | P4MapApi | P4MapApi: .NET wrapper for the MapApi object in the p4api dll.
Public class | P4Server | P4Server Represents the connection to a Perforce Server using the the P4 Bridge DLL. It wraps the calls exported by the DLL and transforms the data types exported by the DLL as native C#.NET data types.
Public class | P4Server..::..CmdContactTimer |
Public class | P4TrustException |
Public class | PathSpec | Describes the path and path type in a file spec.
Public class | ProtectionEntry | Describes a protection entry (line) in a Perforce protection table.
Public class | ProtectionTable | Specifies resource access privileges for Perforce users for a specific Perforce repository.
Public class | ReopenCmdOptions | Options for the reopen command.
Public class | Repository | Represents a Perforce server and connection.
Public class | ResolveAnalysis |
Public class | ResolveCmdOptions | Options for the resolve command.
Public class | ResolvedCmdOptions | Options for Resolve command
Public class | RevertCmdOptions |
Public class | Revision | A revision specifier that is a single revision.
Public class | RevisionIntegrationSummary | Describes an integration, specifying the from file and how the integration was done.
Public class | Server | Represents a specific Perforce server.
Public class | ServerAddress | The address of the Perforce server.
Public class | ServerLicense | The Perforce server's license information.
Public class | ServerMetaData | Defines useful metadata about a Perforce server.
Public class | ServerMetaData..::..ServerTimeZone | Defines the UTC offset for the server.
Public class | ServerVersion | The Perforce server's version information.
Public class | ShelvedFile | Shelved file information from a Describe -S command
Public class | ShelvedInChangelistIdVersion | A revision specifier for a file that is shelved in a changelist id.
Public class | ShelveFilesCmdOptions | Shelve command options.
Public class | SimpleList<(Of <(<'T>)>)> |
Public class | SimpleListItem<(Of <(<'T>)>)> |
Public class | SpecField | Class representing a field in a FormSpec.
Public class | Stream | A stream specification in a Perforce repository.
Public class | StreamCmdOptions | Stream command options
Public class | StreamMetaData |
Public class | StreamsCmdOptions | Streams command options
Public class | StringList | Augment String List used mostly for passing of parameters to command.
Public class | SubmitCmdOptions | Submit command options
Public class | SubmitResults | Describes the results for a submit operation on one or more files.
Public class | SyncFilesCmdOptions | Sync command options.
Public class | TagCmdOptions | Tag command options
Public class | TaggedInfoItem | Base class for objects returned by a command as 'tagged' data.
Public class | TaggedObject | The tagged output of a command.
Public class | TaggedObjectList | A list of tagged objects.
Public class | Trigger | Describes an individual entry in the trigger table.
Public class | TriggerTable | Defines triggers on Perforce events.
Public class | TrustCmdOptions | Options for the Trust command
Public class | TypeMap | Defines a Perforce repository's default mapping between file names or locations and file types.
Public class | TypeMapEntry | Describes an individual entry in the Perforce repository's typemap.
Public class | UnlockFilesCmdOptions | Unlock command options.
Public class | UnshelveFilesCmdOptions | Unshelve command options.
Public class | User | A user on a Perforce Server, represented by a P4 User spec.
Public class | UserCmdOptions | User command options.
Public class | UsersCmdOptions | Users command options
Public class | VersionRange | A revision range specifier consisting of a lower and upper revision.
Public class | VersionSpec | Identifies a specific revision or revision range of a Perforce managed SCM resource.
Public class | ViewMap | Maps one or more Perforce file specs to zero, one, or more other Perforce file specs.

Interfaces

 | Interface | Description
Public interface | IKeepAlive | Allows a client to monitor the execution of a command. It allow the client to cancel the command if it takes to long to complete or display a UI to allow the user to cancel the command.

Delegates

 | Delegate | Description
Public delegate | Client..::..AutoResolveDelegate |
Public delegate | Client..::..ResolveFileDelegate |
Public delegate | LogFile..::..LogMessageDelgate |
Public delegate | P4CallBacks..::..BinaryResultsDelegate | Delegate definition for the binary results callback.
Public delegate | P4CallBacks..::..ErrorDelegate | Delegate definition for the error callback.
Public delegate | P4CallBacks..::..InfoResultsDelegate | Delegate definition for the info results callback.
Public delegate | P4CallBacks..::..LogMessageDelegate | Delegate definition for the Logging callback from the dll.
Public delegate | P4CallBacks..::..PromptDelegate | Delegate definition for the prompt callback.
Public delegate | P4CallBacks..::..ResolveADelegate | Delegate definition for the Resolve callback passing a CLientResolve object.
Public delegate | P4CallBacks..::..ResolveDelegate | Delegate definition for the Resolve callback passing a CLientMerge object.
Public delegate | P4CallBacks..::..TaggedOutputDelegate | Delegate definition for the tagged output delegate.
Public delegate | P4CallBacks..::..TextResultsDelegate | Delegate definition for the text results callback.
Public delegate | P4Server..::..BinaryResultsDelegate | Delegate used to send binary output as it is generated.
Public delegate | P4Server..::..CommandEchoDelegate | Delegate used to commands as they are executed.
Public delegate | P4Server..::..ErrorDelegate | Delegate used to send errors as they are generated.
Public delegate | P4Server..::..InfoResultsDelegate | Delegate used to send Info Results as they are generated.
Public delegate | P4Server..::..PromptHandlerDelegate | Delegate used to provide a custom handler for input prompts from the p4api.
Public delegate | P4Server..::..ResolveAHandlerDelegate | Delegate used to provide a custom handler for Resolve callbacks passing a ClientResolve object from the p4api.
Public delegate | P4Server..::..ResolveHandlerDelegate | Delegate used to provide a custom handler for Resolve callbacks passing a ClientMerge object from the p4api.
Public delegate | P4Server..::..TaggedOutputDelegate | Delegate used to send tagged output as it is generated.
Public delegate | P4Server..::..TextResultsDelegate | Delegate used to send Text Results as they are generated.

Enumerations

 | Enumeration | Description
Public enumeration | AddFilesCmdFlags | Flags for the add command.
Public enumeration | BaseFileType | Flags to define the base file type.
Public enumeration | BranchSpecCmdFlags | Flags for the branch command.
Public enumeration | BranchSpecsCmdFlags | Flags for the branches command.
Public enumeration | ChangeCmdFlags | Flags for the change command.
Public enumeration | ChangeListStatus | Flags for the status of a changelist.
Public enumeration | ChangesCmdFlags | Flags for the changes command.
Public enumeration | ClientCmdFlags | Flags for the client command.
Public enumeration | ClientOption | Flags to configure the client behavior.
Public enumeration | ClientsCmdFlags | Flags for the clients command.
Public enumeration | ConnectionStatus | Flags for the server connection status.
Public enumeration | CopyFilesCmdFlags | Flags for the copy command.
Public enumeration | CounterCmdFlags | Flags for the counter command.
Public enumeration | DeleteFilesCmdFlags | Flags for the delete command.
Public enumeration | DepotCmdFlags | Flags for the depot command.
Public enumeration | DepotType | The type of the depot.
Public enumeration | DescribeChangelistCmdFlags | Flags for the describe command.
Public enumeration | DiffType | The types of diffs returned by the server.
Public enumeration | DiffWhiteSpaceOptions | Diff whitespace options flags.
Public enumeration | EditFilesCmdFlags | Flags for the edit command.
Public enumeration | EntryType | The type of protection (user or group).
Public enumeration | ErrorGeneric |
Public enumeration | ErrorSeverity | Error severity levels.
Public enumeration | ErrorSubsystem |
Public enumeration | FileAction | Describes the pending or completed action related to open, resolve, or integration for a specific file.
Public enumeration | FileLogCmdFlags | Flags for the filelog command.
Public enumeration | FilesCmdFlags | Flags for the files command.
Public enumeration | FileTypeModifier | Flags to specify file type modifiers.
Public enumeration | FixAction | The fix action (Fixed or Unfixed).
Public enumeration | FixJobsCmdFlags | Flags for the fix command.
Public enumeration | GetDepotDirsCmdFlags | Flags for the dirs command.
Public enumeration | GetDepotFileDiffsCmdFlags | Flags for the diff2 command.
Public enumeration | GetDepotFilesCmdFlags | Flags for the files command.
Public enumeration | GetFileAnnotationsCmdFlags | Flags for the annotate command.
Public enumeration | GetFileContentsCmdFlags | Flags for the print command.
Public enumeration | GetFileHistoryCmdFlags | Flags for the filelog command.
Public enumeration | GetFileLineMatchesCmdFlags | Flags for the grep command.
Public enumeration | GetFileMetadataCmdFlags | Flags for the fstat command.
Public enumeration | GetFixesCmdFlags | Flags for the fixes command.
Public enumeration | GetOpenedFilesCmdFlags | Flags for the opened command.
Public enumeration | GetProtectionEntriesCmdFlags | Flags for the protects command.
Public enumeration | GetProtectionTableCmdFlags | Flags for the protect command.
Public enumeration | GetResolvedFilesCmdFlags | Flags for the resolved command.
Public enumeration | GetReviewersCmdFlags | Flags for the reviews command.
Public enumeration | GetStreamMetaDataCmdFlags | Flags for the istat command.
Public enumeration | GetSubmittedIntegrationsCmdFlags | Flags for the integrated command.
Public enumeration | GetTriggerTableCmdFlags | Flags for the triggers command.
Public enumeration | GetTypeMapCmdFlags | Flags for the typemap command.
Public enumeration | GroupCmdFlags | Flags for the group command.
Public enumeration | GroupsCmdFlags | Flags for the groups command.
Public enumeration | InfoCmdFlags | Flags for the info command.
Public enumeration | IntegrateFilesCmdFlags | Flags for the integrate command.
Public enumeration | JobCmdFlags | Flags for the job command.
Public enumeration | JobsCmdFlags | Flags for the jobs command.
Public enumeration | LabelCmdFlags | Flags for the label command.
Public enumeration | LabelsCmdFlags | Flags for the labels command.
Public enumeration | LabelSyncCmdFlags | Flags for the label sync command.
Public enumeration | LineEnd | Sets line-ending character(s) for client text files.
Public enumeration | LoginCmdFlags | Flags for the login command.
Public enumeration | LogoutCmdFlags | Flags for the logout command.
Public enumeration | MapType | Describes the mapping type.
Public enumeration | MatchType | Specifies whether this line match is an exact match, or a context (before or after) match.
Public enumeration | MergeFilesCmdFlags | Flags for the merge command.
Public enumeration | MoveFileCmdFlags | Flags for the move command.
Public enumeration | P4ClientMerge..::..MergeForce |
Public enumeration | P4ClientMerge..::..MergeStatus |
Public enumeration | P4ClientMerge..::..MergeType |
Public enumeration | P4MapApi..::..Direction | Specify the direction to perform the mapping.
Public enumeration | P4MapApi..::..Type | Type of the map entry, Include, Exclude, Overlay.
Public enumeration | ProtectionMode | The protection mode or rights associated with this entry.
Public enumeration | ResolveAction | The action used in resolving the file.
Public enumeration | ResolveFilesCmdFlags | Flags for the resolve command.
Public enumeration | ResolveOptions |
Public enumeration | ResolveSubtype |
Public enumeration | ResolveType |
Public enumeration | RevertFilesCmdFlags | Flags for the revert command.
Public enumeration | ServerState | The current state of a specific server.
Public enumeration | ShelveFilesCmdFlags | Flags for the shelve command.
Public enumeration | SpecFieldDataType | Field Data Type for a field in a form specification.
Public enumeration | SpecFieldFieldType | Field Type for a field in a form specification.
Public enumeration | StreamCmdFlags | Flags for the stream command.
Public enumeration | StreamMetaData..::..IntegAction |
Public enumeration | StreamOption | Flags to configure stream behavior.
Public enumeration | StreamsCmdFlags | Flags for the streams command.
Public enumeration | StreamType | Defines the expected flow of change between a stream and its parent.
Public enumeration | StringEnumCase | Defines the case for the StringEnum.
Public enumeration | SubmitFilesCmdFlags | Flags for the submit command.
Public enumeration | SubmitType | Flags to change submit behavior.
Public enumeration | SyncFilesCmdFlags | Flags for the sync command.
Public enumeration | TagFilesCmdFlags | Flags for the tag command.
Public enumeration | TriggerType | Defines whent he trigger is to execute.
Public enumeration | TrustCmdFlags | Flags for the trust command.
Public enumeration | UnlockFilesCmdFlags | Flags for the unlock command.
Public enumeration | UnshelveFilesCmdFlags | Flags for the unshelve command.
Public enumeration | UserCmdFlags | Flags for the user command.
Public enumeration | UsersCmdFlags | Flags for the users command.
Public enumeration | UserType | Defines the user type.


ActionVersion Class

[image]

Perforce .NET API
ActionVersion Class
Members See Also Send Feedback
A revision specifier that is a file action.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ActionVersion : VersionSpec
Visual Basic
Public Class ActionVersion _
    Inherits VersionSpec
Visual C++
public ref class ActionVersion : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..ActionVersion

See Also

ActionVersion Members
Perforce.P4 Namespace


ActionVersion Members

[image] [image]

Perforce .NET API
ActionVersion Members
ActionVersion Class Constructors Methods Properties See Also Send Feedback

The ActionVersion type exposes the following members.

Constructors

 | Name | Description
Public method | ActionVersion | Initializes a new instance of the ActionVersion class

Methods

 | Name | Description
Public method | Equals | Equals method for for ActionVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ActionVersion (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | Version | get Version as action

See Also

ActionVersion Class


ActionVersion Constructor

[image]

Perforce .NET API
ActionVersion Constructor
ActionVersion Class See Also Send Feedback
Initializes a new instance of the ActionVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ActionVersion(
    string Action
)
Visual Basic
Public Sub New ( _
    Action As String _
)
Visual C++
public:
ActionVersion(
    String^ Action
)

Parameters

Action
Type: System..::..String
The file action.///

See Also

ActionVersion Class


ActionVersion Methods

[image] [image]

Perforce .NET API
ActionVersion Methods
ActionVersion Class See Also Send Feedback

The ActionVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for ActionVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ActionVersion (Overrides VersionSpec..::..ToString()()()().)

See Also

ActionVersion Class


Equals Method

[image]

Perforce .NET API
ActionVersion..::..Equals Method
ActionVersion Class See Also Send Feedback
Equals method for for ActionVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get action type

Return Value

True/False

See Also

ActionVersion Class


ToString Method

[image]

Perforce .NET API
ActionVersion..::..ToString Method
ActionVersion Class See Also Send Feedback
ToString method for for ActionVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String action version

See Also

ActionVersion Class


ActionVersion Properties

[image] [image]

Perforce .NET API
ActionVersion Properties
ActionVersion Class See Also Send Feedback

The ActionVersion type exposes the following members.

Properties

 | Name | Description
Public property | Version | get Version as action

See Also

ActionVersion Class


Version Property

[image]

Perforce .NET API
ActionVersion..::..Version Property
ActionVersion Class See Also Send Feedback
get Version as action

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Version { get; private set; }
Visual Basic
Public Property Version As String
    Get
    Private Set
Visual C++
public:
property String^ Version {
    String^ get ();
    private: void set (String^ value);
}

See Also

ActionVersion Class


AddFilesCmdFlags Enumeration

[image]

Perforce .NET API
AddFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the add command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum AddFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration AddFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class AddFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Downgrade | 1 | As a shortcut to reverting and re-adding, you can use the -d flag to reopen currently-open files for add (downgrade) under the following circumstances: A file that is 'opened for edit' and is synced to the head revision, and the head revision has been deleted (or moved). A file that is 'opened for move/add' can be downgraded to add, which is useful when the source of the move has been deleted or moved. Typically, under these circumstances, your only alternative is to revert. In this case, breaking the move connection enables you to preserve any content changes in the new file and safely revert the source file (of the move).
KeepWildcards | 2 | To add files with filenames that contain wildcard characters, specify the -f flag. Filenames that contain the special characters '@', '#', '%' or '*' are reformatted to encode the characters using ASCII hexadecimal representation.
NoP4Ignore | 4 | The -I flag informs the client that it should not perform any ignore checking configured by P4IGNORE.
PreviewOnly | 132 | The -n flag, displays a preview of the specified add operation without changing any files or metadata.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


AddFilesCmdOptions Class

[image]

Perforce .NET API
AddFilesCmdOptions Class
Members See Also Send Feedback
Add command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class AddFilesCmdOptions : Options
Visual Basic
Public Class AddFilesCmdOptions _
    Inherits Options
Visual C++
public ref class AddFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..AddFilesCmdOptions

See Also

AddFilesCmdOptions Members


AddFilesCmdOptions Members

[image] [image]

Perforce .NET API
AddFilesCmdOptions Members
AddFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The AddFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | AddFilesCmdOptions | Options for the Add command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

AddFilesCmdOptions Class


AddFilesCmdOptions Constructor

[image]

Perforce .NET API
AddFilesCmdOptions Constructor
AddFilesCmdOptions Class See Also Send Feedback
Options for the Add command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public AddFilesCmdOptions(
    AddFilesCmdFlags flags,
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    flags As AddFilesCmdFlags, _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
AddFilesCmdOptions(
    AddFilesCmdFlags flags,
    int changeList,
    FileType^ fileType
)

Parameters

flags
Type: Perforce.P4..::..AddFilesCmdFlags
Flags for the command
changeList
Type: System..::..Int32
Optional changelist for the fies
fileType
Type: Perforce.P4..::..FileType
Optional file type for the files

Return Value

Remarks

p4 help add

add -- Open a new file to add it to the depot

p4 add [-c changelist#] [-d -f -I -n] [-t filetype] file ...

Open a file for adding to the depot. If the file exists on the
client, it is read to determine if it is text or binary. If it does
not exist, it is assumed to be text. To be added, the file must not
already reside in the depot, or it must be deleted at the current
head revision. Files can be deleted and re-added.

A 2012.1 client will ignore files that were to be added, if they
match an exclusion line specified in a P4IGNORE file.

To associate the open files with a specific pending changelist, use
the -c flag; if you omit the -c flag, the open files are associated
with the default changelist. If file is already open, it is moved
into the specified pending changelist. You cannot reopen a file for
add unless it is already open for add.

As a shortcut to reverting and re-adding, you can use the -d
flag to reopen currently-open files for add (downgrade) under
the following circumstances:

A file that is 'opened for edit' and is synced to the head
revision, and the head revision has been deleted (or moved).

A file that is 'opened for move/add' can be downgraded to add,
which is useful when the source of the move has been deleted
or moved. Typically, under these circumstances, your only
alternative is to revert. In this case, breaking the move
connection enables you to preserve any content changes in the
new file and safely revert the source file (of the move).

To specify file type, use the -t flag. By default, 'p4 add'
determines file type using the name-to-type mapping table managed
by 'p4 typemap' and by examining the file's contents and execute
permission bit. If the file type specified by -t or configured in
the typemap table is a partial filetype, the resulting modifier is
applied to the file type that is determined by 'p4 add'. For more
details, see 'p4 help filetypes'.

To add files with filenames that contain wildcard characters, specify
the -f flag. Filenames that contain the special characters '@', '#',
'%' or '*' are reformatted to encode the characters using ASCII
hexadecimal representation. After the files are added, you must
refer to them using the reformatted file name, because Perforce
does not recognize the local filesystem name.

The -I flag informs the client that it should not perform any ignore
checking configured by P4IGNORE.

The -n flag displays a preview of the specified add operation without
changing any files or metadata.

See Also

AddFilesCmdOptions Class


AddFilesCmdOptions Methods

[image] [image]

Perforce .NET API
AddFilesCmdOptions Methods
AddFilesCmdOptions Class See Also Send Feedback

The AddFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

AddFilesCmdOptions Class


AddFilesCmdOptions Properties

[image] [image]

Perforce .NET API
AddFilesCmdOptions Properties
AddFilesCmdOptions Class See Also Send Feedback

The AddFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

AddFilesCmdOptions Class


BaseFileType Enumeration

[image]

Perforce .NET API
BaseFileType Enumeration
See Also Send Feedback
Flags to define the base file type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum BaseFileType
Visual Basic
<FlagsAttribute> _
Public Enumeration BaseFileType
Visual C++
[FlagsAttribute]
public enum class BaseFileType

Members

Member name | Value | Description
Unspecified | 0 | An unspecified base file type.
Text | 1 | Client Use: newlines translated. Server Storage: deltas in RCS format.
Binary | 2 | Client Use: raw bytes. Server Storage: compressed binary.
Symlink | 4 | Client Use: symbolic link. Server Storage: deltas in RCS format.
Apple | 8 | Client Use: Mac resource + data. Server Storage: compressed AppleSingle.
Resource | 16 | Client Use: Mac resource fork. Server Storage: compressed binary.
Unicode | 32 | Client Use: newlines translated. Server Storage: deltas in RCS format stored as UTF-8.
UTF16 | 64 | Client Use: newlines translated client file UTF-16 Server Storage: deltas in RCS format stored as UTF-8 Files of type utf16 are stored in the depot in UTF-8. These files are in utf16 in the client workspace. The automatic type detection requires a BOM be present at the start of the file. Files without a BOM are assumed to be in client byte order. When utf16 files are written to a client, they are written with a BOM in client byte order.
UTF8 | 128 | Client Use: newlines translated. Server Storage: deltas in RCS format stored as UTF-8.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


BranchCmdOptions Class

[image]

Perforce .NET API
BranchCmdOptions Class
Members See Also Send Feedback
Branch command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class BranchCmdOptions : Options
Visual Basic
Public Class BranchCmdOptions _
    Inherits Options
Visual C++
public ref class BranchCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..BranchCmdOptions

See Also

BranchCmdOptions Members


BranchCmdOptions Members

[image] [image]

Perforce .NET API
BranchCmdOptions Members
BranchCmdOptions Class Constructors Methods Properties See Also Send Feedback

The BranchCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | BranchCmdOptions | Branch command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

BranchCmdOptions Class


BranchCmdOptions Constructor

[image]

Perforce .NET API
BranchCmdOptions Constructor
BranchCmdOptions Class See Also Send Feedback
Branch command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchCmdOptions(
    BranchSpecCmdFlags flags,
    string stream,
    string parent
)
Visual Basic
Public Sub New ( _
    flags As BranchSpecCmdFlags, _
    stream As String, _
    parent As String _
)
Visual C++
public:
BranchCmdOptions(
    BranchSpecCmdFlags flags,
    String^ stream,
    String^ parent
)

Parameters

flags
Type: Perforce.P4..::..BranchSpecCmdFlags
stream
Type: System..::..String
parent
Type: System..::..String

See Also

BranchCmdOptions Class


BranchCmdOptions Methods

[image] [image]

Perforce .NET API
BranchCmdOptions Methods
BranchCmdOptions Class See Also Send Feedback

The BranchCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

BranchCmdOptions Class


BranchCmdOptions Properties

[image] [image]

Perforce .NET API
BranchCmdOptions Properties
BranchCmdOptions Class See Also Send Feedback

The BranchCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

BranchCmdOptions Class


BranchesCmdOptions Class

[image]

Perforce .NET API
BranchesCmdOptions Class
Members See Also Send Feedback
Branches command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class BranchesCmdOptions : Options
Visual Basic
Public Class BranchesCmdOptions _
    Inherits Options
Visual C++
public ref class BranchesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..BranchesCmdOptions

See Also

BranchesCmdOptions Members


BranchesCmdOptions Members

[image] [image]

Perforce .NET API
BranchesCmdOptions Members
BranchesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The BranchesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | BranchesCmdOptions | Branches command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

BranchesCmdOptions Class


BranchesCmdOptions Constructor

[image]

Perforce .NET API
BranchesCmdOptions Constructor
BranchesCmdOptions Class See Also Send Feedback
Branches command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchesCmdOptions(
    BranchSpecsCmdFlags flags,
    string user,
    string nameFilter,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As BranchSpecsCmdFlags, _
    user As String, _
    nameFilter As String, _
    maxItems As Integer _
)
Visual C++
public:
BranchesCmdOptions(
    BranchSpecsCmdFlags flags,
    String^ user,
    String^ nameFilter,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..BranchSpecsCmdFlags
user
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32

See Also

BranchesCmdOptions Class


BranchesCmdOptions Methods

[image] [image]

Perforce .NET API
BranchesCmdOptions Methods
BranchesCmdOptions Class See Also Send Feedback

The BranchesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

BranchesCmdOptions Class


BranchesCmdOptions Properties

[image] [image]

Perforce .NET API
BranchesCmdOptions Properties
BranchesCmdOptions Class See Also Send Feedback

The BranchesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

BranchesCmdOptions Class


BranchSpec Class

[image]

Perforce .NET API
BranchSpec Class
Members See Also Send Feedback
A branch view specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class BranchSpec
Visual Basic
Public Class BranchSpec
Visual C++
public ref class BranchSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..BranchSpec

See Also

BranchSpec Members


BranchSpec Members

[image] [image]

Perforce .NET API
BranchSpec Members
BranchSpec Class Constructors Methods Properties See Also Send Feedback

The BranchSpec type exposes the following members.

Constructors

 | Name | Description
Public method | BranchSpec()()()() | A branch view specification in a Perforce repository.
Public method | BranchSpec(String, String, DateTime, DateTime, String, Boolean, ViewMap, FormSpec, String) | A branch view specification in a Perforce repository.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromBranchSpecCmdTaggedOutput | Read the fields from the tagged output of a branch command
Public method | FromBranchSpecsCmdTaggedOutput | Read the fields from the tagged output of a branches command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a branch specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Accessed | The date of the last command used with this spec.
Public property | Description | A description of the branch spec (optional).
Public property | Id | The branch spec name (read only).
Public property | Locked | When true, permits only the owner to change the spec.
Public property | Options | Obsolete. Flags to change the branch spec behavior.
Public property | Owner | The user who created this branch spec. Can be changed.
Public property | Spec | Specifies structural and semantic metadata for form types.
Public property | Updated | The date this branch spec was last modified.
Public property | ViewMap | Lines mapping of one view of depot files to another.

See Also

BranchSpec Class


BranchSpec Constructor

[image] [image]

Perforce .NET API
BranchSpec Constructor
BranchSpec Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BranchSpec()()()() | A branch view specification in a Perforce repository.
Public method | BranchSpec(String, String, DateTime, DateTime, String, Boolean, ViewMap, FormSpec, String) | A branch view specification in a Perforce repository.

See Also

BranchSpec Class
BranchSpec Members


BranchSpec Constructor

[image]

Perforce .NET API
BranchSpec Constructor
BranchSpec Class See Also Send Feedback
A branch view specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchSpec()
Visual Basic
Public Sub New
Visual C++
public:
BranchSpec()

See Also

BranchSpec Class
BranchSpec Overload


BranchSpec Constructor (String, String, DateTime, DateTime, String, Boolean, ViewMap, FormSpec, String)

[image]

Perforce .NET API
BranchSpec Constructor (String, String, DateTime, DateTime, String, Boolean, ViewMap, FormSpec, String)
BranchSpec Class See Also Send Feedback
A branch view specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchSpec(
    string id,
    string owner,
    DateTime updated,
    DateTime accessed,
    string description,
    bool locked,
    ViewMap viewmap,
    FormSpec spec,
    string options
)
Visual Basic
Public Sub New ( _
    id As String, _
    owner As String, _
    updated As DateTime, _
    accessed As DateTime, _
    description As String, _
    locked As Boolean, _
    viewmap As ViewMap, _
    spec As FormSpec, _
    options As String _
)
Visual C++
public:
BranchSpec(
    String^ id,
    String^ owner,
    DateTime updated,
    DateTime accessed,
    String^ description,
    bool locked,
    ViewMap^ viewmap,
    FormSpec^ spec,
    String^ options
)

Parameters

id
Type: System..::..String
The branch spec name (read only).
owner
Type: System..::..String
The user who created this branch spec.
updated
Type: System..::..DateTime
The date this branch spec was last modified.
accessed
Type: System..::..DateTime
The date of the last command used with this spec.
description
Type: System..::..String
A description of the branch spec (optional).
locked
Type: System..::..Boolean
When true, permits only the owner to change the spec.
viewmap
Type: Perforce.P4..::..ViewMap
Lines mapping of one view of depot files to another.
spec
Type: Perforce.P4..::..FormSpec
Specifies structural and semantic metadata for form types.
options
Type: System..::..String
Flags to change the branch spec behavior.

See Also

BranchSpec Class
BranchSpec Overload


BranchSpec Methods

[image] [image]

Perforce .NET API
BranchSpec Methods
BranchSpec Class See Also Send Feedback

The BranchSpec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromBranchSpecCmdTaggedOutput | Read the fields from the tagged output of a branch command
Public method | FromBranchSpecsCmdTaggedOutput | Read the fields from the tagged output of a branches command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a branch specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

See Also

BranchSpec Class


FromBranchSpecCmdTaggedOutput Method

[image]

Perforce .NET API
BranchSpec..::..FromBranchSpecCmdTaggedOutput Method
BranchSpec Class See Also Send Feedback
Read the fields from the tagged output of a branch command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromBranchSpecCmdTaggedOutput(
    TaggedObject objectInfo
)
Visual Basic
Public Sub FromBranchSpecCmdTaggedOutput ( _
    objectInfo As TaggedObject _
)
Visual C++
public:
void FromBranchSpecCmdTaggedOutput(
    TaggedObject^ objectInfo
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'branch' command

See Also

BranchSpec Class


FromBranchSpecsCmdTaggedOutput Method

[image]

Perforce .NET API
BranchSpec..::..FromBranchSpecsCmdTaggedOutput Method
BranchSpec Class See Also Send Feedback
Read the fields from the tagged output of a branches command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromBranchSpecsCmdTaggedOutput(
    TaggedObject objectInfo,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromBranchSpecsCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromBranchSpecsCmdTaggedOutput(
    TaggedObject^ objectInfo,
    String^ offset,
    bool dst_mismatch
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'branches' command
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

BranchSpec Class


Parse Method

[image]

Perforce .NET API
BranchSpec..::..Parse Method
BranchSpec Class See Also Send Feedback
Parse the fields from a branch specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
Text of the branch specification in server format

Return Value

See Also

BranchSpec Class


ToString Method

[image]

Perforce .NET API
BranchSpec..::..ToString Method
BranchSpec Class See Also Send Feedback
Convert to specification in server format

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

BranchSpec Class


BranchSpec Properties

[image] [image]

Perforce .NET API
BranchSpec Properties
BranchSpec Class See Also Send Feedback

The BranchSpec type exposes the following members.

Properties

 | Name | Description
Public property | Accessed | The date of the last command used with this spec.
Public property | Description | A description of the branch spec (optional).
Public property | Id | The branch spec name (read only).
Public property | Locked | When true, permits only the owner to change the spec.
Public property | Options | Obsolete. Flags to change the branch spec behavior.
Public property | Owner | The user who created this branch spec. Can be changed.
Public property | Spec | Specifies structural and semantic metadata for form types.
Public property | Updated | The date this branch spec was last modified.
Public property | ViewMap | Lines mapping of one view of depot files to another.

See Also

BranchSpec Class


Accessed Property

[image]

Perforce .NET API
BranchSpec..::..Accessed Property
BranchSpec Class See Also Send Feedback
The date of the last command used with this spec.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Accessed { get; set; }
Visual Basic
Public Property Accessed As DateTime
    Get
    Set
Visual C++
public:
property DateTime Accessed {
    DateTime get ();
    void set (DateTime value);
}

See Also

BranchSpec Class


Description Property

[image]

Perforce .NET API
BranchSpec..::..Description Property
BranchSpec Class See Also Send Feedback
A description of the branch spec (optional).

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

BranchSpec Class


Id Property

[image]

Perforce .NET API
BranchSpec..::..Id Property
BranchSpec Class See Also Send Feedback
The branch spec name (read only).

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

BranchSpec Class


Locked Property

[image]

Perforce .NET API
BranchSpec..::..Locked Property
BranchSpec Class See Also Send Feedback
When true, permits only the owner to change the spec.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Locked { get; set; }
Visual Basic
Public Property Locked As Boolean
    Get
    Set
Visual C++
public:
property bool Locked {
    bool get ();
    void set (bool value);
}

See Also

BranchSpec Class


Options Property

[image]

Perforce .NET API
BranchSpec..::..Options Property
BranchSpec Class See Also Send Feedback
Flags to change the branch spec behavior.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[ObsoleteAttribute("Use Locked Property")]
public string Options { get; set; }
Visual Basic
<ObsoleteAttribute("Use Locked Property")> _
Public Property Options As String
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use Locked Property")]
public:
property String^ Options {
    String^ get ();
    void set (String^ value);
}

See Also

BranchSpec Class


Owner Property

[image]

Perforce .NET API
BranchSpec..::..Owner Property
BranchSpec Class See Also Send Feedback
The user who created this branch spec. Can be changed.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Owner { get; set; }
Visual Basic
Public Property Owner As String
    Get
    Set
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

BranchSpec Class


Spec Property

[image]

Perforce .NET API
BranchSpec..::..Spec Property
BranchSpec Class See Also Send Feedback
Specifies structural and semantic metadata for form types.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

BranchSpec Class


Updated Property

[image]

Perforce .NET API
BranchSpec..::..Updated Property
BranchSpec Class See Also Send Feedback
The date this branch spec was last modified.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Updated { get; set; }
Visual Basic
Public Property Updated As DateTime
    Get
    Set
Visual C++
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}

See Also

BranchSpec Class


ViewMap Property

[image]

Perforce .NET API
BranchSpec..::..ViewMap Property
BranchSpec Class See Also Send Feedback
Lines mapping of one view of depot files to another.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap ViewMap { get; set; }
Visual Basic
Public Property ViewMap As ViewMap
    Get
    Set
Visual C++
public:
property ViewMap^ ViewMap {
    ViewMap^ get ();
    void set (ViewMap^ value);
}

See Also

BranchSpec Class


BranchSpecCmdFlags Enumeration

[image]

Perforce .NET API
BranchSpecCmdFlags Enumeration
See Also Send Feedback
Flags for the branch command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum BranchSpecCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration BranchSpecCmdFlags
Visual C++
[FlagsAttribute]
public enum class BranchSpecCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the named branch spec.
Output | 2 | The -o flag writes the branch spec to standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a branch specification from the standard input. The user's editor is not invoked.
Force | 8 | The -f flag enables a user with 'admin' privilege to delete the spec or set the 'last modified' date. By default, specs can be deleted only by their owner.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


BranchSpecsCmdFlags Enumeration

[image]

Perforce .NET API
BranchSpecsCmdFlags Enumeration
See Also Send Feedback
Flags for the branches command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum BranchSpecsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration BranchSpecsCmdFlags
Visual C++
[FlagsAttribute]
public enum class BranchSpecsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Time | 1 | The -t flag displays the time as well as the date.
IgnoreCase | 2 | The -e nameFilter flag lists branchspecs with a name that matches the nameFilter pattern, for example: -e 'branchspec*'. -E makes the matching case-insensitive.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ChangeCmdFlags Enumeration

[image]

Perforce .NET API
ChangeCmdFlags Enumeration
See Also Send Feedback
Flags for the change command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ChangeCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration ChangeCmdFlags
Visual C++
[FlagsAttribute]
public enum class ChangeCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes a pending changelist, if it has no opened files and no pending fixes associated with it. Use 'p4 opened -a' to report on opened files and 'p4 reopen' to move them to another changelist. Use 'p4 fixes -c changelist#' to report on pending fixes and 'p4 fix -d -c changelist# jobs...' to delete pending fixes. The changelist can be deleted only by the user and client who created it, or by a user with 'admin' privilege using the -f flag.
Output | 2 | The -o flag writes the changelist specification to the standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a changelist specification from the standard input. The user's editor is not invoked.
Force | 8 | The -f flag forces the update or deletion of other users' pending changelists. -f can also force the deletion of submitted changelists after they have been emptied of files using 'p4 obliterate'. By default, submitted changelists cannot be changed. The -f flag can also force display of the 'Description' field in a restricted changelist. The -f flag requires 'admin' access granted by 'p4 protect'. The -f and -u flags are mutually exclusive.
Update | 16 | The -u flag can force the update of a submitted change by the owner of the change. Only the Jobs, Type, and Description fields can be changed using the -u flag. The -f and -u flags cannot be used in the same change command.
IncludeJobs | 32 | The -s flag extends the list of jobs to include the fix status for each job. On new changelists, the fix status begins as the special status 'ignore', which, if left unchanged simply excludes the job from those being fixed. Otherwise, the fix status, like that applied with 'p4 fix -s', becomes the job's status when the changelist is committed. Note that this option exists to support integration with external defect trackers.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ChangeCmdOptions Class

[image]

Perforce .NET API
ChangeCmdOptions Class
Members See Also Send Feedback
Change command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ChangeCmdOptions : Options
Visual Basic
Public Class ChangeCmdOptions _
    Inherits Options
Visual C++
public ref class ChangeCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ChangeCmdOptions

See Also

ChangeCmdOptions Members


ChangeCmdOptions Members

[image] [image]

Perforce .NET API
ChangeCmdOptions Members
ChangeCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ChangeCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeCmdOptions(ChangeCmdFlags) | Change command options.
Public method | ChangeCmdOptions(ChangeCmdFlags, ChangeListType) | Change command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ChangeCmdOptions Class


ChangeCmdOptions Constructor

[image] [image]

Perforce .NET API
ChangeCmdOptions Constructor
ChangeCmdOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeCmdOptions(ChangeCmdFlags) | Change command options.
Public method | ChangeCmdOptions(ChangeCmdFlags, ChangeListType) | Change command options.

See Also

ChangeCmdOptions Class
ChangeCmdOptions Members


ChangeCmdOptions Constructor (ChangeCmdFlags)

[image]

Perforce .NET API
ChangeCmdOptions Constructor (ChangeCmdFlags)
ChangeCmdOptions Class See Also Send Feedback
Change command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ChangeCmdOptions(
    ChangeCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As ChangeCmdFlags _
)
Visual C++
public:
ChangeCmdOptions(
    ChangeCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..ChangeCmdFlags

Return Value

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

See Also

ChangeCmdOptions Class
ChangeCmdOptions Overload


ChangeCmdOptions Constructor (ChangeCmdFlags, )

[image]

Perforce .NET API
ChangeCmdOptions Constructor (ChangeCmdFlags, )
ChangeCmdOptions Class See Also Send Feedback
Change command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ChangeCmdOptions(
    ChangeCmdFlags flags,
    ChangeListType newType
)
Visual Basic
Public Sub New ( _
    flags As ChangeCmdFlags, _
    newType As ChangeListType _
)
Visual C++
public:
ChangeCmdOptions(
    ChangeCmdFlags flags,
    ChangeListType newType
)

Parameters

flags
Type: Perforce.P4..::..ChangeCmdFlags
newType
Type: ChangeListType

Return Value

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

See Also

ChangeCmdOptions Class
ChangeCmdOptions Overload


ChangeCmdOptions Methods

[image] [image]

Perforce .NET API
ChangeCmdOptions Methods
ChangeCmdOptions Class See Also Send Feedback

The ChangeCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ChangeCmdOptions Class


ChangeCmdOptions Properties

[image] [image]

Perforce .NET API
ChangeCmdOptions Properties
ChangeCmdOptions Class See Also Send Feedback

The ChangeCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ChangeCmdOptions Class


Changelist Class

[image]

Perforce .NET API
Changelist Class
Members See Also Send Feedback
A changelist specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Changelist
Visual Basic
Public Class Changelist
Visual C++
public ref class Changelist

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Changelist

See Also

Changelist Members


Changelist Members

[image] [image]

Perforce .NET API
Changelist Members
Changelist Class Constructors Methods Properties See Also Send Feedback

The Changelist type exposes the following members.

Constructors

 | Name | Description
Public method | Changelist()()()() | Create a new pending changelist
Public method | Changelist(Int32, Boolean) | Create a new numbered changelist

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixJobs(IList<(Of <<'(String>)>>), Options) |
Public method | FixJobs(IList<(Of <<'(Job>)>>), Options) |
Public method | FixJobs(Options, array<Job>[]()[][]) |
Public method | FixJobs(Options, array<String>[]()[][]) |
Public method | FromChangeCmdTaggedOutput(TaggedObject, String, Boolean) | Fill in the fields for the changelist using the tagged output of a "change' command
Public method | FromChangeCmdTaggedOutput(TaggedObject, Boolean, String, Boolean) | Fill in the fields for the changelist using the tagged output of a "change' command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a changelist specification
Public method | Submit |
Public method | ToString()()()() | Convert to specification in server format (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Convert to a string for display

Properties

 | Name | Description
Public property | ClientId |
Public property | Description |
Public property | Files |
Public property | Id |
Public property | Jobs |
Public property | ModifiedDate |
Public property | OwnerName |
Public property | Pending |
Public property | Shelved |
Public property | ShelvedFiles |
Public property | Spec |
Public property | Type |

See Also

Changelist Class


Changelist Constructor

[image] [image]

Perforce .NET API
Changelist Constructor
Changelist Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Changelist()()()() | Create a new pending changelist
Public method | Changelist(Int32, Boolean) | Create a new numbered changelist

See Also

Changelist Class
Changelist Members


Changelist Constructor

[image]

Perforce .NET API
Changelist Constructor
Changelist Class See Also Send Feedback
Create a new pending changelist

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist()
Visual Basic
Public Sub New
Visual C++
public:
Changelist()

See Also

Changelist Class
Changelist Overload


Changelist Constructor (Int32, Boolean)

[image]

Perforce .NET API
Changelist Constructor (Int32, Boolean)
Changelist Class See Also Send Feedback
Create a new numbered changelist

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist(
    int id,
    bool pending
)
Visual Basic
Public Sub New ( _
    id As Integer, _
    pending As Boolean _
)
Visual C++
public:
Changelist(
    int id,
    bool pending
)

Parameters

id
Type: System..::..Int32
pending
Type: System..::..Boolean

See Also

Changelist Class
Changelist Overload


Changelist Methods

[image] [image]

Perforce .NET API
Changelist Methods
Changelist Class See Also Send Feedback

The Changelist type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixJobs(IList<(Of <<'(String>)>>), Options) |
Public method | FixJobs(IList<(Of <<'(Job>)>>), Options) |
Public method | FixJobs(Options, array<Job>[]()[][]) |
Public method | FixJobs(Options, array<String>[]()[][]) |
Public method | FromChangeCmdTaggedOutput(TaggedObject, String, Boolean) | Fill in the fields for the changelist using the tagged output of a "change' command
Public method | FromChangeCmdTaggedOutput(TaggedObject, Boolean, String, Boolean) | Fill in the fields for the changelist using the tagged output of a "change' command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a changelist specification
Public method | Submit |
Public method | ToString()()()() | Convert to specification in server format (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Convert to a string for display

See Also

Changelist Class


FixJobs Method

[image] [image]

Perforce .NET API
Changelist..::..FixJobs Method
Changelist Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FixJobs(IList<(Of <<'(String>)>>), Options) |
Public method | FixJobs(IList<(Of <<'(Job>)>>), Options) |
Public method | FixJobs(Options, array<Job>[]()[][]) |
Public method | FixJobs(Options, array<String>[]()[][]) |

See Also

Changelist Class
Changelist Members


FixJobs Method (IList(String), Options)

[image]

Perforce .NET API
Changelist..::..FixJobs Method (IList<(Of <(<'String>)>)>, Options)
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Fix> FixJobs(
    IList<string> jobIds,
    Options options
)
Visual Basic
Public Function FixJobs ( _
    jobIds As IList(Of String), _
    options As Options _
) As IList(Of Fix)
Visual C++
public:
IList<Fix^>^ FixJobs(
    IList<String^>^ jobIds,
    Options^ options
)

Parameters

jobIds
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Changelist Class
FixJobs Overload


FixJobs Method (IList(Job), Options)

[image]

Perforce .NET API
Changelist..::..FixJobs Method (IList<(Of <(<'Job>)>)>, Options)
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Fix> FixJobs(
    IList<Job> jobs,
    Options options
)
Visual Basic
Public Function FixJobs ( _
    jobs As IList(Of Job), _
    options As Options _
) As IList(Of Fix)
Visual C++
public:
IList<Fix^>^ FixJobs(
    IList<Job^>^ jobs,
    Options^ options
)

Parameters

jobs
Type: System.Collections.Generic..::..IList <(Of <(<' Job >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Changelist Class
FixJobs Overload


FixJobs Method (Options, Job[])

[image]

Perforce .NET API
Changelist..::..FixJobs Method (Options, array<Job>[]()[][])
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Fix> FixJobs(
    Options options,
    params Job[] jobs
)
Visual Basic
Public Function FixJobs ( _
    options As Options, _
    ParamArray jobs As Job() _
) As IList(Of Fix)
Visual C++
public:
IList<Fix^>^ FixJobs(
    Options^ options,
    ... array<Job^>^ jobs
)

Parameters

options
Type: Perforce.P4..::..Options
jobs
Type: array< Perforce.P4..::..Job >[]()[][]

Return Value

Remarks

p4 help fix

fix -- Mark jobs as being fixed by the specified changelist

p4 fix [-d] [-s status] -c changelist# jobName ...

'p4 fix' marks each named job as being fixed by the changelist
number specified with -c. The changelist can be pending or
submitted and the jobs can be open or closed (fixed by another
changelist).

If the changelist has already been submitted and the job is still
open, then 'p4 fix' marks the job closed. If the changelist has not
been submitted and the job is still open, the job is closed when the
changelist is submitted. If the job is already closed, it remains
closed.

The -d flag deletes the specified fixes. This operation does not
otherwise affect the specified changelist or jobs.

The -s flag uses the specified status instead of the default defined
in the job specification.

The fix's status is reported by 'p4 fixes', and is related to the
job's status. Certain commands set the job's status to the fix's
status for each job associated with the change. When a job is fixed
by a submitted change, the job's status is set to match the fix
status. When a job is fixed by a pending change, the job's status
is set to match the fix status when the change is submitted. If the
fix's status is 'same', the job's status is left unchanged.

See Also

Changelist Class
FixJobs Overload


FixJobs Method (Options, String[])

[image]

Perforce .NET API
Changelist..::..FixJobs Method (Options, array<String>[]()[][])
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Fix> FixJobs(
    Options options,
    params string[] jobIds
)
Visual Basic
Public Function FixJobs ( _
    options As Options, _
    ParamArray jobIds As String() _
) As IList(Of Fix)
Visual C++
public:
IList<Fix^>^ FixJobs(
    Options^ options,
    ... array<String^>^ jobIds
)

Parameters

options
Type: Perforce.P4..::..Options
jobIds
Type: array< System..::..String >[]()[][]

Return Value

Remarks

p4 help fix

fix -- Mark jobs as being fixed by the specified changelist

p4 fix [-d] [-s status] -c changelist# jobName ...

'p4 fix' marks each named job as being fixed by the changelist
number specified with -c. The changelist can be pending or
submitted and the jobs can be open or closed (fixed by another
changelist).

If the changelist has already been submitted and the job is still
open, then 'p4 fix' marks the job closed. If the changelist has not
been submitted and the job is still open, the job is closed when the
changelist is submitted. If the job is already closed, it remains
closed.

The -d flag deletes the specified fixes. This operation does not
otherwise affect the specified changelist or jobs.

The -s flag uses the specified status instead of the default defined
in the job specification.

The fix's status is reported by 'p4 fixes', and is related to the
job's status. Certain commands set the job's status to the fix's
status for each job associated with the change. When a job is fixed
by a submitted change, the job's status is set to match the fix
status. When a job is fixed by a pending change, the job's status
is set to match the fix status when the change is submitted. If the
fix's status is 'same', the job's status is left unchanged.

See Also

Changelist Class
FixJobs Overload


FromChangeCmdTaggedOutput Method

[image] [image]

Perforce .NET API
Changelist..::..FromChangeCmdTaggedOutput Method
Changelist Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FromChangeCmdTaggedOutput(TaggedObject, String, Boolean) | Fill in the fields for the changelist using the tagged output of a "change' command
Public method | FromChangeCmdTaggedOutput(TaggedObject, Boolean, String, Boolean) | Fill in the fields for the changelist using the tagged output of a "change' command

See Also

Changelist Class
Changelist Members


FromChangeCmdTaggedOutput Method (TaggedObject, String, Boolean)

[image]

Perforce .NET API
Changelist..::..FromChangeCmdTaggedOutput Method (TaggedObject, String, Boolean)
Changelist Class See Also Send Feedback
Fill in the fields for the changelist using the tagged output of a "change' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromChangeCmdTaggedOutput(
    TaggedObject objectInfo,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromChangeCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromChangeCmdTaggedOutput(
    TaggedObject^ objectInfo,
    String^ offset,
    bool dst_mismatch
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
The tagged output of a "change' command
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Changelist Class
FromChangeCmdTaggedOutput Overload


FromChangeCmdTaggedOutput Method (TaggedObject, Boolean, String, Boolean)

[image]

Perforce .NET API
Changelist..::..FromChangeCmdTaggedOutput Method (TaggedObject, Boolean, String, Boolean)
Changelist Class See Also Send Feedback
Fill in the fields for the changelist using the tagged output of a "change' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromChangeCmdTaggedOutput(
    TaggedObject objectInfo,
    bool GetShelved,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromChangeCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    GetShelved As Boolean, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromChangeCmdTaggedOutput(
    TaggedObject^ objectInfo,
    bool GetShelved,
    String^ offset,
    bool dst_mismatch
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
The tagged output of a "change' command
GetShelved
Type: System..::..Boolean
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Changelist Class
FromChangeCmdTaggedOutput Overload


initialize Method

[image]

Perforce .NET API
Changelist..::..initialize Method
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void initialize(
    Connection connection
)
Visual Basic
Public Sub initialize ( _
    connection As Connection _
)
Visual C++
public:
void initialize(
    Connection^ connection
)

Parameters

connection
Type: Perforce.P4..::..Connection

See Also

Changelist Class


Parse Method

[image]

Perforce .NET API
Changelist..::..Parse Method
Changelist Class See Also Send Feedback
Parse the fields from a changelist specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
Text of the changelist specification in server format

Return Value

See Also

Changelist Class


Submit Method

[image]

Perforce .NET API
Changelist..::..Submit Method
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SubmitResults Submit(
    Options options
)
Visual Basic
Public Function Submit ( _
    options As Options _
) As SubmitResults
Visual C++
public:
SubmitResults^ Submit(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

See Also

Changelist Class


ToString Method

[image] [image]

Perforce .NET API
Changelist..::..ToString Method
Changelist Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Convert to specification in server format (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Convert to a string for display

See Also

Changelist Class
Changelist Members


ToString Method

[image]

Perforce .NET API
Changelist..::..ToString Method
Changelist Class See Also Send Feedback
Convert to specification in server format

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

Changelist Class
ToString Overload


ToString Method (Boolean)

[image]

Perforce .NET API
Changelist..::..ToString Method (Boolean)
Changelist Class See Also Send Feedback
Convert to a string for display

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ToString(
    bool includeTime
)
Visual Basic
Public Function ToString ( _
    includeTime As Boolean _
) As String
Visual C++
public:
String^ ToString(
    bool includeTime
)

Parameters

includeTime
Type: System..::..Boolean
Include the time as well as the date

Return Value

See Also

Changelist Class
ToString Overload


Changelist Properties

[image] [image]

Perforce .NET API
Changelist Properties
Changelist Class See Also Send Feedback

The Changelist type exposes the following members.

Properties

 | Name | Description
Public property | ClientId |
Public property | Description |
Public property | Files |
Public property | Id |
Public property | Jobs |
Public property | ModifiedDate |
Public property | OwnerName |
Public property | Pending |
Public property | Shelved |
Public property | ShelvedFiles |
Public property | Spec |
Public property | Type |

See Also

Changelist Class


ClientId Property

[image]

Perforce .NET API
Changelist..::..ClientId Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ClientId { get; set; }
Visual Basic
Public Property ClientId As String
    Get
    Set
Visual C++
public:
property String^ ClientId {
    String^ get ();
    void set (String^ value);
}

See Also

Changelist Class


Description Property

[image]

Perforce .NET API
Changelist..::..Description Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Changelist Class


Files Property

[image]

Perforce .NET API
Changelist..::..Files Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileMetaData> Files { get; set; }
Visual Basic
Public Property Files As IList(Of FileMetaData)
    Get
    Set
Visual C++
public:
property IList<FileMetaData^>^ Files {
    IList<FileMetaData^>^ get ();
    void set (IList<FileMetaData^>^ value);
}

See Also

Changelist Class


Id Property

[image]

Perforce .NET API
Changelist..::..Id Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Id { get; internal set; }
Visual Basic
Public Property Id As Integer
    Get
    Friend Set
Visual C++
public:
property int Id {
    int get ();
    internal: void set (int value);
}

See Also

Changelist Class


Jobs Property

[image]

Perforce .NET API
Changelist..::..Jobs Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, string> Jobs { get; set; }
Visual Basic
Public Property Jobs As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Jobs {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

See Also

Changelist Class


ModifiedDate Property

[image]

Perforce .NET API
Changelist..::..ModifiedDate Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime ModifiedDate { get; private set; }
Visual Basic
Public Property ModifiedDate As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime ModifiedDate {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

Changelist Class


OwnerName Property

[image]

Perforce .NET API
Changelist..::..OwnerName Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string OwnerName { get; set; }
Visual Basic
Public Property OwnerName As String
    Get
    Set
Visual C++
public:
property String^ OwnerName {
    String^ get ();
    void set (String^ value);
}

See Also

Changelist Class


Pending Property

[image]

Perforce .NET API
Changelist..::..Pending Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Pending { get; private set; }
Visual Basic
Public Property Pending As Boolean
    Get
    Private Set
Visual C++
public:
property bool Pending {
    bool get ();
    private: void set (bool value);
}

See Also

Changelist Class


Shelved Property

[image]

Perforce .NET API
Changelist..::..Shelved Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Shelved { get; set; }
Visual Basic
Public Property Shelved As Boolean
    Get
    Set
Visual C++
public:
property bool Shelved {
    bool get ();
    void set (bool value);
}

See Also

Changelist Class


ShelvedFiles Property

[image]

Perforce .NET API
Changelist..::..ShelvedFiles Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<ShelvedFile> ShelvedFiles { get; set; }
Visual Basic
Public Property ShelvedFiles As IList(Of ShelvedFile)
    Get
    Set
Visual C++
public:
property IList<ShelvedFile^>^ ShelvedFiles {
    IList<ShelvedFile^>^ get ();
    void set (IList<ShelvedFile^>^ value);
}

See Also

Changelist Class


Spec Property

[image]

Perforce .NET API
Changelist..::..Spec Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

Changelist Class


Type Property

[image]

Perforce .NET API
Changelist..::..Type Property
Changelist Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ChangeListType Type { get; set; }
Visual Basic
Public Property Type As ChangeListType
    Get
    Set
Visual C++
public:
property ChangeListType Type {
    ChangeListType get ();
    void set (ChangeListType value);
}

See Also

Changelist Class


ChangelistIdVersion Class

[image]

Perforce .NET API
ChangelistIdVersion Class
Members See Also Send Feedback
A revision specifier that is a changelist id.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ChangelistIdVersion : VersionSpec
Visual Basic
Public Class ChangelistIdVersion _
    Inherits VersionSpec
Visual C++
public ref class ChangelistIdVersion : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..ChangelistIdVersion

See Also

ChangelistIdVersion Members


ChangelistIdVersion Members

[image] [image]

Perforce .NET API
ChangelistIdVersion Members
ChangelistIdVersion Class Constructors Methods Properties See Also Send Feedback

The ChangelistIdVersion type exposes the following members.

Constructors

 | Name | Description
Public method | ChangelistIdVersion | Initializes a new instance of the ChangelistIdVersion class

Methods

 | Name | Description
Public method | Equals | Equals method for for ChangelistIdVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ChangelistIdVersion (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | ChanglistId | get Version as changelist

See Also

ChangelistIdVersion Class


ChangelistIdVersion Constructor

[image]

Perforce .NET API
ChangelistIdVersion Constructor
ChangelistIdVersion Class See Also Send Feedback
Initializes a new instance of the ChangelistIdVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ChangelistIdVersion(
    int Changelist
)
Visual Basic
Public Sub New ( _
    Changelist As Integer _
)
Visual C++
public:
ChangelistIdVersion(
    int Changelist
)

Parameters

Changelist
Type: System..::..Int32
The changelist.

See Also

ChangelistIdVersion Class


ChangelistIdVersion Methods

[image] [image]

Perforce .NET API
ChangelistIdVersion Methods
ChangelistIdVersion Class See Also Send Feedback

The ChangelistIdVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for ChangelistIdVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ChangelistIdVersion (Overrides VersionSpec..::..ToString()()()().)

See Also

ChangelistIdVersion Class


Equals Method

[image]

Perforce .NET API
ChangelistIdVersion..::..Equals Method
ChangelistIdVersion Class See Also Send Feedback
Equals method for for ChangelistIdVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get changelist

Return Value

True/False

See Also

ChangelistIdVersion Class


ToString Method

[image]

Perforce .NET API
ChangelistIdVersion..::..ToString Method
ChangelistIdVersion Class See Also Send Feedback
ToString method for for ChangelistIdVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String changelist version

See Also

ChangelistIdVersion Class


ChangelistIdVersion Properties

[image] [image]

Perforce .NET API
ChangelistIdVersion Properties
ChangelistIdVersion Class See Also Send Feedback

The ChangelistIdVersion type exposes the following members.

Properties

 | Name | Description
Public property | ChanglistId | get Version as changelist

See Also

ChangelistIdVersion Class


ChanglistId Property

[image]

Perforce .NET API
ChangelistIdVersion..::..ChanglistId Property
ChangelistIdVersion Class See Also Send Feedback
get Version as changelist

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChanglistId { get; private set; }
Visual Basic
Public Property ChanglistId As Integer
    Get
    Private Set
Visual C++
public:
property int ChanglistId {
    int get ();
    private: void set (int value);
}

See Also

ChangelistIdVersion Class


ChangeListStatus Enumeration

[image]

Perforce .NET API
ChangeListStatus Enumeration
See Also Send Feedback
Flags for the status of a changelist.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ChangeListStatus
Visual Basic
<FlagsAttribute> _
Public Enumeration ChangeListStatus
Visual C++
[FlagsAttribute]
public enum class ChangeListStatus

Members

Member name | Value | Description
None | 0 | No status specified.
Pending | 1 | Pending changelist.
Shelved | 2 | Shelved changelist.
Submitted | 4 | Submitted changelist.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ChangesCmdFlags Enumeration

[image]

Perforce .NET API
ChangesCmdFlags Enumeration
See Also Send Feedback
Flags for the changes command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ChangesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration ChangesCmdFlags
Visual C++
[FlagsAttribute]
public enum class ChangesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeIntegrated | 1 | The -i flag also includes any changelists integrated into the specified files.
IncludeTime | 2 | The -t flag displays the time as well as the date.
FullDescription | 4 | The -l flag displays the full text of the changelist descriptions.
LongDescription | 8 | The -L flag displays the changelist descriptions, truncated to 250 characters if longer.
ViewRestricted | 16 | The -f flag enables admin users to view restricted changes.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ChangesCmdOptions Class

[image]

Perforce .NET API
ChangesCmdOptions Class
Members See Also Send Feedback
Changes command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ChangesCmdOptions : Options
Visual Basic
Public Class ChangesCmdOptions _
    Inherits Options
Visual C++
public ref class ChangesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ChangesCmdOptions

See Also

ChangesCmdOptions Members


ChangesCmdOptions Members

[image] [image]

Perforce .NET API
ChangesCmdOptions Members
ChangesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ChangesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ChangesCmdOptions | Changes command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ChangesCmdOptions Class


ChangesCmdOptions Constructor

[image]

Perforce .NET API
ChangesCmdOptions Constructor
ChangesCmdOptions Class See Also Send Feedback
Changes command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ChangesCmdOptions(
    ChangesCmdFlags flags,
    string clientName,
    int maxItems,
    ChangeListStatus status,
    string userName
)
Visual Basic
Public Sub New ( _
    flags As ChangesCmdFlags, _
    clientName As String, _
    maxItems As Integer, _
    status As ChangeListStatus, _
    userName As String _
)
Visual C++
public:
ChangesCmdOptions(
    ChangesCmdFlags flags,
    String^ clientName,
    int maxItems,
    ChangeListStatus status,
    String^ userName
)

Parameters

flags
Type: Perforce.P4..::..ChangesCmdFlags
clientName
Type: System..::..String
maxItems
Type: System..::..Int32
status
Type: Perforce.P4..::..ChangeListStatus
userName
Type: System..::..String

Return Value

Remarks

p4 help changes

changes -- Display list of pending and submitted changelists
changelists -- synonym for 'changes'

p4 changes [options] [file[revRange] ...]

options: -i -t -l -L -f -c client -m max -s status -u user

Returns a list of all pending and submitted changelists currently
stored in the server.

If files are specified, 'p4 changes' lists only changelists that
affect those files. If the file specification includes a revision
range, 'p4 changes' lists only submitted changelists that affect
the specified revisions. See 'p4 help revisions' for details.

If files are not specified, 'p4 changes' limits its report
according to each change's type ('public' or 'restricted').
If a submitted or shelved change is restricted, the change is
not reported unless the user owns the change or has list
permission for at least one file in the change. Only the owner
of a restricted and pending (not shelved) change is permitted
to see it.

The -i flag also includes any changelists integrated into the
specified files.

The -t flag displays the time as well as the date.

The -l flag displays the full text of the changelist
descriptions.

The -L flag displays the changelist descriptions, truncated to 250
characters if longer.

The -f flag enables admin users to view restricted changes.

The -c client flag displays only submitted by the specified client.

The -m max flag limits changes to the 'max' most recent.

The -s status flag limits the output to changelists with the specified
status. Specify '-s pending', '-s shelved', or '-s submitted'.

The -u user flag displays only changes owned by the specified user.

See Also

ChangesCmdOptions Class


ChangesCmdOptions Methods

[image] [image]

Perforce .NET API
ChangesCmdOptions Methods
ChangesCmdOptions Class See Also Send Feedback

The ChangesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ChangesCmdOptions Class


ChangesCmdOptions Properties

[image] [image]

Perforce .NET API
ChangesCmdOptions Properties
ChangesCmdOptions Class See Also Send Feedback

The ChangesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ChangesCmdOptions Class


Client Class

[image]

Perforce .NET API
Client Class
Members See Also Send Feedback
A client specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Client
Visual Basic
Public Class Client
Visual C++
public ref class Client

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Client

See Also

Client Members


Client Members

[image] [image]

Perforce .NET API
Client Members
Client Class Constructors Methods Properties See Also Send Feedback

The Client type exposes the following members.

Constructors

 | Name | Description
Public method | Client | Initializes a new instance of the Client class

Methods

 | Name | Description
Public method | AddFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | AddFiles(Options, array<FileSpec>[]()[][]) |
Public method | CopyFiles(Options) |
Public method | CopyFiles(FileSpec, IList<(Of <<'(FileSpec>)>>), Options) |
Public method | CopyFiles(Options, FileSpec, array<FileSpec>[]()[][]) |
Public method | DeleteFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | DeleteFiles(Options, array<FileSpec>[]()[][]) |
Public method | EditFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | EditFiles(Options, array<FileSpec>[]()[][]) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatDateTime | Utility function to format a DateTime in the format expected in a spec
Public method | FromClientCmdTaggedOutput | Parse the tagged output of a 'client' command
Public method | FromClientsCmdTaggedOutput | Parse the tagged output of a 'clients' command
Public method | GetClientFileMappings(array<FileSpec>[]()[][]) |
Public method | GetClientFileMappings(IList<(Of <<'(FileSpec>)>>)) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolvedFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetResolvedFiles(Options, array<FileSpec>[]()[][]) |
Public method | GetSyncedFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetSyncedFiles(Options, array<FileSpec>[]()[][]) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize |
Public method | IntegrateFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | IntegrateFiles(Options, array<FileSpec>[]()[][]) |
Public method | IntegrateFiles(FileSpec, Options, array<FileSpec>[]()[][]) |
Public method | IntegrateFiles(IList<(Of <<'(FileSpec>)>>), FileSpec, Options) |
Public method | LabelSync(IList<(Of <<'(FileSpec>)>>), String, Options) |
Public method | LabelSync(Options, String, array<FileSpec>[]()[][]) |
Public method | LockFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | LockFiles(Options, array<FileSpec>[]()[][]) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFiles(Options) |
Public method | MergeFiles(FileSpec, IList<(Of <<'(FileSpec>)>>), Options) |
Public method | MergeFiles(Options, FileSpec, array<FileSpec>[]()[][]) |
Public method | MoveFiles |
Public method | Parse | Parse a client spec
Public method | ReopenFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ReopenFiles(Options, array<FileSpec>[]()[][]) |
Public method | ResolveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ResolveFiles(Options, array<FileSpec>[]()[][]) |
Public method | ResolveFiles(Client..::..ResolveFileDelegate, Options, array<FileSpec>[]()[][]) | Resolve files
Public method | RevertFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | RevertFiles(Options, array<FileSpec>[]()[][]) |
Public method | ShelveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ShelveFiles(Options, array<FileSpec>[]()[][]) |
Public method | SubmitFiles |
Public method | SyncFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | SyncFiles(Options, array<FileSpec>[]()[][]) |
Public method | ToString | Format as a client spec (Overrides Object..::..ToString()()()().)
Public method | UnlockFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | UnlockFiles(Options, array<FileSpec>[]()[][]) |
Public method | UnshelveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | UnshelveFiles(Options, array<FileSpec>[]()[][]) |

Properties

 | Name | Description
Public property | Accessed |
Public property | AltRoots |
Public property | Description |
Public property | Host |
Public property | Initialized |
Public property | LineEnd |
Public property | Name |
Public property | Options |
Public property | OwnerName |
Public property | Root |
Public property | ServerID |
Public property | Spec |
Public property | Stream |
Public property | StreamAtChange |
Public property | SubmitOptions |
Public property | Updated |
Public property | ViewMap |

See Also

Client Class


Client Constructor

[image]

Perforce .NET API
Client Constructor
Client Class See Also Send Feedback
Initializes a new instance of the Client class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Client()
Visual Basic
Public Sub New
Visual C++
public:
Client()

See Also

Client Class


Client Methods

[image] [image]

Perforce .NET API
Client Methods
Client Class See Also Send Feedback

The Client type exposes the following members.

Methods

 | Name | Description
Public method | AddFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | AddFiles(Options, array<FileSpec>[]()[][]) |
Public method | CopyFiles(Options) |
Public method | CopyFiles(FileSpec, IList<(Of <<'(FileSpec>)>>), Options) |
Public method | CopyFiles(Options, FileSpec, array<FileSpec>[]()[][]) |
Public method | DeleteFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | DeleteFiles(Options, array<FileSpec>[]()[][]) |
Public method | EditFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | EditFiles(Options, array<FileSpec>[]()[][]) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatDateTime | Utility function to format a DateTime in the format expected in a spec
Public method | FromClientCmdTaggedOutput | Parse the tagged output of a 'client' command
Public method | FromClientsCmdTaggedOutput | Parse the tagged output of a 'clients' command
Public method | GetClientFileMappings(array<FileSpec>[]()[][]) |
Public method | GetClientFileMappings(IList<(Of <<'(FileSpec>)>>)) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolvedFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetResolvedFiles(Options, array<FileSpec>[]()[][]) |
Public method | GetSyncedFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetSyncedFiles(Options, array<FileSpec>[]()[][]) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize |
Public method | IntegrateFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | IntegrateFiles(Options, array<FileSpec>[]()[][]) |
Public method | IntegrateFiles(FileSpec, Options, array<FileSpec>[]()[][]) |
Public method | IntegrateFiles(IList<(Of <<'(FileSpec>)>>), FileSpec, Options) |
Public method | LabelSync(IList<(Of <<'(FileSpec>)>>), String, Options) |
Public method | LabelSync(Options, String, array<FileSpec>[]()[][]) |
Public method | LockFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | LockFiles(Options, array<FileSpec>[]()[][]) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeFiles(Options) |
Public method | MergeFiles(FileSpec, IList<(Of <<'(FileSpec>)>>), Options) |
Public method | MergeFiles(Options, FileSpec, array<FileSpec>[]()[][]) |
Public method | MoveFiles |
Public method | Parse | Parse a client spec
Public method | ReopenFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ReopenFiles(Options, array<FileSpec>[]()[][]) |
Public method | ResolveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ResolveFiles(Options, array<FileSpec>[]()[][]) |
Public method | ResolveFiles(Client..::..ResolveFileDelegate, Options, array<FileSpec>[]()[][]) | Resolve files
Public method | RevertFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | RevertFiles(Options, array<FileSpec>[]()[][]) |
Public method | ShelveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ShelveFiles(Options, array<FileSpec>[]()[][]) |
Public method | SubmitFiles |
Public method | SyncFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | SyncFiles(Options, array<FileSpec>[]()[][]) |
Public method | ToString | Format as a client spec (Overrides Object..::..ToString()()()().)
Public method | UnlockFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | UnlockFiles(Options, array<FileSpec>[]()[][]) |
Public method | UnshelveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | UnshelveFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class


AddFiles Method

[image] [image]

Perforce .NET API
Client..::..AddFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | AddFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


AddFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..AddFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> AddFiles(
    IList<FileSpec> toFiles,
    Options options
)
Visual Basic
Public Function AddFiles ( _
    toFiles As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ AddFiles(
    IList<FileSpec^>^ toFiles,
    Options^ options
)

Parameters

toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
AddFiles Overload


AddFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..AddFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> AddFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function AddFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ AddFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help add

add -- Open a new file to add it to the depot

p4 add [-c changelist#] [-d -f -I -n] [-t filetype] file ...

Open a file for adding to the depot. If the file exists on the
client, it is read to determine if it is text or binary. If it does
not exist, it is assumed to be text. To be added, the file must not
already reside in the depot, or it must be deleted at the current
head revision. Files can be deleted and re-added.

A 2012.1 client will ignore files that were to be added, if they
match an exclusion line specified in a P4IGNORE file.

To associate the open files with a specific pending changelist, use
the -c flag; if you omit the -c flag, the open files are associated
with the default changelist. If file is already open, it is moved
into the specified pending changelist. You cannot reopen a file for
add unless it is already open for add.

As a shortcut to reverting and re-adding, you can use the -d
flag to reopen currently-open files for add (downgrade) under
the following circumstances:

A file that is 'opened for edit' and is synced to the head
revision, and the head revision has been deleted (or moved).

A file that is 'opened for move/add' can be downgraded to add,
which is useful when the source of the move has been deleted
or moved. Typically, under these circumstances, your only
alternative is to revert. In this case, breaking the move
connection enables you to preserve any content changes in the
new file and safely revert the source file (of the move).

To specify file type, use the -t flag. By default, 'p4 add'
determines file type using the name-to-type mapping table managed
by 'p4 typemap' and by examining the file's contents and execute
permission bit. If the file type specified by -t or configured in
the typemap table is a partial filetype, the resulting modifier is
applied to the file type that is determined by 'p4 add'. For more
details, see 'p4 help filetypes'.

To add files with filenames that contain wildcard characters, specify
the -f flag. Filenames that contain the special characters '@', '#',
'%' or '*' are reformatted to encode the characters using ASCII
hexadecimal representation. After the files are added, you must
refer to them using the reformatted file name, because Perforce
does not recognize the local filesystem name.

The -I flag informs the client that it should not perform any ignore
checking configured by P4IGNORE.

The -n flag displays a preview of the specified add operation without
changing any files or metadata.

See Also

Client Class
AddFiles Overload


CopyFiles Method

[image] [image]

Perforce .NET API
Client..::..CopyFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyFiles(Options) |
Public method | CopyFiles(FileSpec, IList<(Of <<'(FileSpec>)>>), Options) |
Public method | CopyFiles(Options, FileSpec, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


CopyFiles Method (Options)

[image]

Perforce .NET API
Client..::..CopyFiles Method (Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> CopyFiles(
    Options options
)
Visual Basic
Public Function CopyFiles ( _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ CopyFiles(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

See Also

Client Class
CopyFiles Overload


CopyFiles Method (FileSpec, IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..CopyFiles Method (FileSpec, IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> CopyFiles(
    FileSpec fromFile,
    IList<FileSpec> toFiles,
    Options options
)
Visual Basic
Public Function CopyFiles ( _
    fromFile As FileSpec, _
    toFiles As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ CopyFiles(
    FileSpec^ fromFile,
    IList<FileSpec^>^ toFiles,
    Options^ options
)

Parameters

fromFile
Type: Perforce.P4..::..FileSpec
toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
CopyFiles Overload


CopyFiles Method (Options, FileSpec, FileSpec[])

[image]

Perforce .NET API
Client..::..CopyFiles Method (Options, FileSpec, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> CopyFiles(
    Options options,
    FileSpec fromFile,
    params FileSpec[] toFiles
)
Visual Basic
Public Function CopyFiles ( _
    options As Options, _
    fromFile As FileSpec, _
    ParamArray toFiles As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ CopyFiles(
    Options^ options,
    FileSpec^ fromFile,
    ... array<FileSpec^>^ toFiles
)

Parameters

options
Type: Perforce.P4..::..Options
fromFile
Type: Perforce.P4..::..FileSpec
toFiles
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help copy

copy -- Copy one set of files to another

p4 copy [options] fromFile[rev] toFile
p4 copy [options] -b branch [-r] [toFile[rev] ...]
p4 copy [options] -b branch -s fromFile[rev] [toFile ...]
p4 copy [options] -S stream [-P parent] [-F] [-r] [toFile[rev] ...]

options: -c changelist# -f -n -v -m max -q

'p4 copy' copies one set of files (the 'source') into another (the
'target').

Using the client workspace as a staging area, 'p4 copy' makes the
target identical to the source by branching, replacing, or deleting
files. 'p4 submit' submits copied files to the depot. 'p4 revert'
can be used to revert copied files instead of submitting them. The
history of copied files can be shown with 'p4 filelog' or 'p4
integrated'.

Target files that are already identical to the source, or that are
outside of the client view, are not affected by 'p4 copy'. Opened,
non-identical target files cause 'p4 copy' to exit with a warning.
When 'p4 copy' creates or modifies files in the workspace, it leaves
them read-only; 'p4 edit' can make them writable. Files opened by
'p4 copy' do not need to be resolved.

Source and target files (fromFile and toFile) can be specified on
the 'p4 copy' command line or through a branch view. On the command
line, fromFile is the source file set and toFile is the target file
set. With a branch view, one or more toFile arguments can be given
to limit the scope of the target file set.

A revision specifier can be used to select the revision to copy; by
default, the head revision is copied. The revision specifier can be
used on fromFile, or on toFile, but not on both. When used on toFile,
it refers to source revisions, not to target revisions. A range may
not be used as a revision specifier. For revision syntax, see 'p4
help revisions'.

The -S flag makes 'p4 copy' copy from a stream to its parent.
Use -r with -S to reverse the copy direction. Note that to submit
copied stream files, the current client must be switched to the
target stream, or to a virtual child stream of the target stream.
The -S flag causes 'p4 copy' to use a generated branch view that
maps the stream to its parent. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. The -S flag also makes 'p4 copy' respect a stream's flow.

The -F flag can be used with -S to force copying against a stream's
expected flow. It can also force -S to generate a branch view based
on a virtual stream; the mapping itself refers to the underlying
real stream.

The -b flag makes 'p4 copy' use a user-defined branch view. (See
'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the user-defined branch view to be
treated as the target, per the branch view mapping. Optional toFile
arguments may be given to further restrict the scope of the target
file set. -r is ignored when -s is used.

The -c changelist# flag opens files in the designated (numbered)
pending changelist instead of the default changelist.

The -f flag forces the creation of extra revisions in order to
explicitly record that files have been copied. Deleted source files
will be copied if they do not exist in the target, and files that are
already identical will be copied if they are not connected by existing
integration records.

The -n flag displays a preview of the copy, without actually doing
anything.

The -m flag limits the actions to the first 'max' number of files.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

The -v flag causes a 'virtual' copy that does not modify client
workspace files. After submitting a virtual integration, 'p4 sync'
can be used to update the workspace.

'p4 copy' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Client Class
CopyFiles Overload


DeleteFiles Method

[image] [image]

Perforce .NET API
Client..::..DeleteFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | DeleteFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


DeleteFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..DeleteFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> DeleteFiles(
    IList<FileSpec> toFiles,
    Options options
)
Visual Basic
Public Function DeleteFiles ( _
    toFiles As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ DeleteFiles(
    IList<FileSpec^>^ toFiles,
    Options^ options
)

Parameters

toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
DeleteFiles Overload


DeleteFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..DeleteFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> DeleteFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function DeleteFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ DeleteFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help delete

delete -- Open an existing file for deletion from the depot

p4 delete [-c changelist#] [-n -v -k] file ...

Opens a depot file for deletion.
If the file is synced in the client workspace, it is removed. If a
pending changelist number is specified using with the -c flag, the
file is opened for delete in that changelist. Otherwise, it is opened
in the default pending changelist.

Files that are deleted generally do not appear on the have list.

The -n flag displays a preview of the operation without changing any
files or metadata.

The -k flag performs the delete on the server without modifying
client files. Use with caution, as an incorrect delete can cause
discrepancies between the state of the client and the corresponding
server metadata.

The -v flag enables you to delete files that are not synced to the
client workspace. The files should be specified using depot syntax;
since the files are not synced, client syntax or local syntax are
inappropriate and could introduce ambiguities in the file list.
Note, though, that if the files ARE synced, 'delete -v' will remove
the files from the client in addition to opening them for delete.
The preferred way to delete a set of files without transferring
them to your machine is: 'sync -k file...', then 'delete -k file...'

'p4 delete' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Client Class
DeleteFiles Overload


EditFiles Method

[image] [image]

Perforce .NET API
Client..::..EditFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | EditFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


EditFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..EditFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> EditFiles(
    IList<FileSpec> toFiles,
    Options options
)
Visual Basic
Public Function EditFiles ( _
    toFiles As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ EditFiles(
    IList<FileSpec^>^ toFiles,
    Options^ options
)

Parameters

toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
EditFiles Overload


EditFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..EditFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> EditFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function EditFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ EditFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help edit

edit -- Open an existing file for edit

p4 edit [-c changelist#] [-k -n] [-t filetype] file ...

Open an existing file for edit. The server records the fact that
the current user has opened the file in the current workspace, and
changes the file permission from read-only to read/write.

If -c changelist# is included, the file opened in the specified
pending changelist. If changelist number is omitted, the file is
opened in the 'default' changelist.

If -t filetype is specified, the file is assigned that Perforce
filetype. Otherwise, the filetype of the previous revision is reused.
If a partial filetype is specified, it is combined with the current
filetype.For details, see 'p4 help filetypes'.
Using a filetype of 'auto' will cause the filetype to be chosen
as if the file were being added, that is the typemap will be
considered and the file contents may be examined.

The -n flag previews the operation without changing any files or
metadata.

The -k flag updates metadata without transferring files to the
workspace. This option can be used to tell the server that files in
a client workspace are already editable, even if they are not in the
client view. Typically this flag is used to correct the Perforce
server when it is wrong about the state of files in the client
workspace, but incorrect use of this option can result in inaccurate
file status information.

'p4 edit' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Client Class
EditFiles Overload


FormatDateTime Method

[image]

Perforce .NET API
Client..::..FormatDateTime Method
Client Class See Also Send Feedback
Utility function to format a DateTime in the format expected in a spec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string FormatDateTime(
    DateTime dt
)
Visual Basic
Public Shared Function FormatDateTime ( _
    dt As DateTime _
) As String
Visual C++
public:
static String^ FormatDateTime(
    DateTime dt
)

Parameters

dt
Type: System..::..DateTime

Return Value

See Also

Client Class


FromClientCmdTaggedOutput Method

[image]

Perforce .NET API
Client..::..FromClientCmdTaggedOutput Method
Client Class See Also Send Feedback
Parse the tagged output of a 'client' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromClientCmdTaggedOutput(
    TaggedObject workspaceInfo
)
Visual Basic
Public Sub FromClientCmdTaggedOutput ( _
    workspaceInfo As TaggedObject _
)
Visual C++
public:
void FromClientCmdTaggedOutput(
    TaggedObject^ workspaceInfo
)

Parameters

workspaceInfo
Type: Perforce.P4..::..TaggedObject

See Also

Client Class


FromClientsCmdTaggedOutput Method

[image]

Perforce .NET API
Client..::..FromClientsCmdTaggedOutput Method
Client Class See Also Send Feedback
Parse the tagged output of a 'clients' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromClientsCmdTaggedOutput(
    TaggedObject workspaceInfo,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromClientsCmdTaggedOutput ( _
    workspaceInfo As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromClientsCmdTaggedOutput(
    TaggedObject^ workspaceInfo,
    String^ offset,
    bool dst_mismatch
)

Parameters

workspaceInfo
Type: Perforce.P4..::..TaggedObject
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Client Class


GetClientFileMappings Method

[image] [image]

Perforce .NET API
Client..::..GetClientFileMappings Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetClientFileMappings(array<FileSpec>[]()[][]) |
Public method | GetClientFileMappings(IList<(Of <<'(FileSpec>)>>)) |

See Also

Client Class
Client Members


GetClientFileMappings Method (FileSpec[])

[image]

Perforce .NET API
Client..::..GetClientFileMappings Method (array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> GetClientFileMappings(
    params FileSpec[] files
)
Visual Basic
Public Function GetClientFileMappings ( _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ GetClientFileMappings(
    ... array<FileSpec^>^ files
)

Parameters

files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help where

where -- Show how file names are mapped by the client view

p4 where [file ...]

Where shows how the specified files are mapped by the client view.
For each argument, three names are produced: the name in the depot,
the name on the client in Perforce syntax, and the name on the client
in local syntax.

If the file parameter is omitted, the mapping for all files in the
current directory and below) is returned.

Note that 'p4 where' does not determine where any real files reside.
It only displays the locations that are mapped by the client view.

See Also

Client Class
GetClientFileMappings Overload


GetClientFileMappings Method (IList(FileSpec))

[image]

Perforce .NET API
Client..::..GetClientFileMappings Method (IList<(Of <(<'FileSpec>)>)>)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> GetClientFileMappings(
    IList<FileSpec> Files
)
Visual Basic
Public Function GetClientFileMappings ( _
    Files As IList(Of FileSpec) _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ GetClientFileMappings(
    IList<FileSpec^>^ Files
)

Parameters

Files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>

Return Value

See Also

Client Class
GetClientFileMappings Overload


GetResolvedFiles Method

[image] [image]

Perforce .NET API
Client..::..GetResolvedFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetResolvedFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetResolvedFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


GetResolvedFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..GetResolvedFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileResolveRecord> GetResolvedFiles(
    IList<FileSpec> Files,
    Options options
)
Visual Basic
Public Function GetResolvedFiles ( _
    Files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileResolveRecord)
Visual C++
public:
IList<FileResolveRecord^>^ GetResolvedFiles(
    IList<FileSpec^>^ Files,
    Options^ options
)

Parameters

Files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Client Class
GetResolvedFiles Overload


GetResolvedFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..GetResolvedFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileResolveRecord> GetResolvedFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function GetResolvedFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileResolveRecord)
Visual C++
public:
IList<FileResolveRecord^>^ GetResolvedFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help resolved

resolved -- Show files that have been resolved but not submitted

p4 resolved [-o] [file ...]

'p4 resolved' lists file updates and integrations that have been
resolved but not yet submitted. To see unresolved integrations,
use 'p4 resolve -n'. To see already submitted integrations, use
'p4 integrated'.

If a depot file path is specified, the output lists resolves for
'theirs' files that match the specified path. If a client file
path is specified, the output lists resolves for 'yours' files
that match the specified path.

The -o flag reports the revision used as the base during the
resolve.

See Also

Client Class
GetResolvedFiles Overload


GetSyncedFiles Method

[image] [image]

Perforce .NET API
Client..::..GetSyncedFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSyncedFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetSyncedFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


GetSyncedFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..GetSyncedFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> GetSyncedFiles(
    IList<FileSpec> toFiles,
    Options options
)
Visual Basic
Public Function GetSyncedFiles ( _
    toFiles As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ GetSyncedFiles(
    IList<FileSpec^>^ toFiles,
    Options^ options
)

Parameters

toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
GetSyncedFiles Overload


GetSyncedFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..GetSyncedFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> GetSyncedFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function GetSyncedFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ GetSyncedFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help have

have -- List the revisions most recently synced to the current workspace

p4 have [file ...]

List revision numbers of the currently-synced files. If file name is
omitted, list all files synced to this client workspace.

The format is: depot-file#revision - client-file

See Also

Client Class
GetSyncedFiles Overload


Initialize Method

[image]

Perforce .NET API
Client..::..Initialize Method
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Initialize(
    Connection connection
)
Visual Basic
Public Sub Initialize ( _
    connection As Connection _
)
Visual C++
public:
void Initialize(
    Connection^ connection
)

Parameters

connection
Type: Perforce.P4..::..Connection

See Also

Client Class


IntegrateFiles Method

[image] [image]

Perforce .NET API
Client..::..IntegrateFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IntegrateFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | IntegrateFiles(Options, array<FileSpec>[]()[][]) |
Public method | IntegrateFiles(FileSpec, Options, array<FileSpec>[]()[][]) |
Public method | IntegrateFiles(IList<(Of <<'(FileSpec>)>>), FileSpec, Options) |

See Also

Client Class
Client Members


IntegrateFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..IntegrateFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> IntegrateFiles(
    IList<FileSpec> toFiles,
    Options options
)
Visual Basic
Public Function IntegrateFiles ( _
    toFiles As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ IntegrateFiles(
    IList<FileSpec^>^ toFiles,
    Options^ options
)

Parameters

toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
IntegrateFiles Overload


IntegrateFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..IntegrateFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> IntegrateFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function IntegrateFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ IntegrateFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help integrate

integrate -- Integrate one set of files into another

p4 integrate [options] fromFile[revRange] toFile
p4 integrate [options] -b branch [-r] [toFile[revRange] ...]
p4 integrate [options] -b branch -s fromFile[revRange] [toFile ...]
p4 integrate [options] -S stream [-r] [-P parent] [file[revRange] ...]

options: -c changelist# -Di -f -h -O<flags> -n -m max -R<flags> -q -v

'p4 integrate' integrates one set of files (the 'source') into
another (the 'target').

(See also 'p4 merge' and 'p4 copy', variants of 'p4 integrate' that
may be easier and more effective for the task at hand.)

Using the client workspace as a staging area, 'p4 integrate' adds and
deletes target files per changes in the source, and schedules all
other affected target files to be resolved. Target files outside of
the current client view are not affected. Source files need not be
within the client view.

'p4 resolve' must be used to merge file content, and to resolve
filename and filetype changes. 'p4 submit' commits integrated files
to the depot. Unresolved files may not be submitted. Integrations
can be shelved with 'p4 shelve' and abandoned with 'p4 revert'. The
commands 'p4 integrated' and 'p4 filelog' display integration history.

When 'p4 integrate' schedules a workspace file to be resolved, it
leaves it read-only. 'p4 resolve' can operate on a read-only file.
For other pre-submit changes, 'p4 edit' must be used to make the
file writable.

Source and target files can be specified either on the 'p4 integrate'
command line or through a branch view. On the command line, fromFile
is the source file set and toFile is the target file set. With a
branch view, one or more toFile arguments can be given to limit the
scope of the target file set.

revRange is a revision or a revision range that limits the span of
source history to be probed for unintegrated revisions. revRange
can be used on fromFile, or on toFile, but not on both. When used on
toFile, it refers to source revisions, not to target revisions. For
details about revision specifiers, see 'p4 help revisions'.

The -S flag makes 'p4 integrate' use a generated branch view that maps
a stream (or its underlying real stream) to its parent. With -r, the
direction of the mapping is reversed. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. Note that to submit integrated stream files, the current
client must be switched to the target stream, or to a virtual child
stream of the target stream.

The -b flag makes 'p4 integrate' use a user-defined branch view.
(See 'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the branch view to be treated as the
target, per the branch view mapping. Optional toFile arguments may
be given to further restrict the scope of the target file set. The
-r flag is ignored when -s is used.

Note that 'p4 integrate' automatically adusts source-to-target
mappings for moved and renamed files. (Adjustment occurs only if
the 'p4 move' command was used to move/rename files.) The scope of
source and target file sets must include both the old-named and the
new-named files for mappings to be adjusted. A filename resolve is
scheduled for each remapped file to allow the target to be moved to
match the source.

The -f flag forces integrate to ignore integration history and treat
all source revisions as unintegrated. It is meant to be used with
revRange to force reintegration of specific, previously integrated
revisions.

The -O flags cause more information to be output for each file opened:

-Ob Show the base revision for the merge (if any).
-Or Show the resolve(s) that are being scheduled.

The -R flags modify the way resolves are scheduled:

-Rb Schedules 'branch resolves' instead of branching new
target files automatically.

-Rd Schedules 'delete resolves' instead of deleting
target files automatically.

-Rs Skips cherry-picked revisions already integrated.
This can improve merge results, but can also cause
multiple resolves per file to be scheduled.

The -Di flag modifies the way deleted revisions are treated. If the
source file has been deleted and re-added, revisions that precede
the deletion will be considered to be part of the same source file.
By default, re-added files are considered to be unrelated to the
files of the same name that preceded them.

The -h flag leaves the target files at the revision currently synced
to the client (the '#have' revision). By default, target files are
automatically synced to the head revision by 'p4 integrate'.

The -m flag limits integration to the first 'max' number of files.

The -n flag displays a preview of integration, without actually
doing anything.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

If -c changelist# is specified, the files are opened in the
designated numbered pending changelist instead of the 'default'
changelist.

The -v flag causes a 'virtual' integration that does not modify
client workspace files unless target files need to be resolved.
After submitting a virtual integration, 'p4 sync' can be used to
update the workspace.

Integration is not supported for files with propagating attributes
from an edge server in a distributed environment. Depending on the
integration action, target, and source, either the integration or
resolve command will fail.

See Also

Client Class
IntegrateFiles Overload


IntegrateFiles Method (FileSpec, Options, FileSpec[])

[image]

Perforce .NET API
Client..::..IntegrateFiles Method (FileSpec, Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> IntegrateFiles(
    FileSpec fromFile,
    Options options,
    params FileSpec[] toFiles
)
Visual Basic
Public Function IntegrateFiles ( _
    fromFile As FileSpec, _
    options As Options, _
    ParamArray toFiles As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ IntegrateFiles(
    FileSpec^ fromFile,
    Options^ options,
    ... array<FileSpec^>^ toFiles
)

Parameters

fromFile
Type: Perforce.P4..::..FileSpec
options
Type: Perforce.P4..::..Options
toFiles
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help integrate

integrate -- Integrate one set of files into another

p4 integrate [options] fromFile[revRange] toFile
p4 integrate [options] -b branch [-r] [toFile[revRange] ...]
p4 integrate [options] -b branch -s fromFile[revRange] [toFile ...]
p4 integrate [options] -S stream [-r] [-P parent] [file[revRange] ...]

options: -c changelist# -Di -f -h -O<flags> -n -m max -R<flags> -q -v

'p4 integrate' integrates one set of files (the 'source') into
another (the 'target').

(See also 'p4 merge' and 'p4 copy', variants of 'p4 integrate' that
may be easier and more effective for the task at hand.)

Using the client workspace as a staging area, 'p4 integrate' adds and
deletes target files per changes in the source, and schedules all
other affected target files to be resolved. Target files outside of
the current client view are not affected. Source files need not be
within the client view.

'p4 resolve' must be used to merge file content, and to resolve
filename and filetype changes. 'p4 submit' commits integrated files
to the depot. Unresolved files may not be submitted. Integrations
can be shelved with 'p4 shelve' and abandoned with 'p4 revert'. The
commands 'p4 integrated' and 'p4 filelog' display integration history.

When 'p4 integrate' schedules a workspace file to be resolved, it
leaves it read-only. 'p4 resolve' can operate on a read-only file.
For other pre-submit changes, 'p4 edit' must be used to make the
file writable.

Source and target files can be specified either on the 'p4 integrate'
command line or through a branch view. On the command line, fromFile
is the source file set and toFile is the target file set. With a
branch view, one or more toFile arguments can be given to limit the
scope of the target file set.

revRange is a revision or a revision range that limits the span of
source history to be probed for unintegrated revisions. revRange
can be used on fromFile, or on toFile, but not on both. When used on
toFile, it refers to source revisions, not to target revisions. For
details about revision specifiers, see 'p4 help revisions'.

The -S flag makes 'p4 integrate' use a generated branch view that maps
a stream (or its underlying real stream) to its parent. With -r, the
direction of the mapping is reversed. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. Note that to submit integrated stream files, the current
client must be switched to the target stream, or to a virtual child
stream of the target stream.

The -b flag makes 'p4 integrate' use a user-defined branch view.
(See 'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the branch view to be treated as the
target, per the branch view mapping. Optional toFile arguments may
be given to further restrict the scope of the target file set. The
-r flag is ignored when -s is used.

Note that 'p4 integrate' automatically adusts source-to-target
mappings for moved and renamed files. (Adjustment occurs only if
the 'p4 move' command was used to move/rename files.) The scope of
source and target file sets must include both the old-named and the
new-named files for mappings to be adjusted. A filename resolve is
scheduled for each remapped file to allow the target to be moved to
match the source.

The -f flag forces integrate to ignore integration history and treat
all source revisions as unintegrated. It is meant to be used with
revRange to force reintegration of specific, previously integrated
revisions.

The -O flags cause more information to be output for each file opened:

-Ob Show the base revision for the merge (if any).
-Or Show the resolve(s) that are being scheduled.

The -R flags modify the way resolves are scheduled:

-Rb Schedules 'branch resolves' instead of branching new
target files automatically.

-Rd Schedules 'delete resolves' instead of deleting
target files automatically.

-Rs Skips cherry-picked revisions already integrated.
This can improve merge results, but can also cause
multiple resolves per file to be scheduled.

The -Di flag modifies the way deleted revisions are treated. If the
source file has been deleted and re-added, revisions that precede
the deletion will be considered to be part of the same source file.
By default, re-added files are considered to be unrelated to the
files of the same name that preceded them.

The -h flag leaves the target files at the revision currently synced
to the client (the '#have' revision). By default, target files are
automatically synced to the head revision by 'p4 integrate'.

The -m flag limits integration to the first 'max' number of files.

The -n flag displays a preview of integration, without actually
doing anything.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

If -c changelist# is specified, the files are opened in the
designated numbered pending changelist instead of the 'default'
changelist.

The -v flag causes a 'virtual' integration that does not modify
client workspace files unless target files need to be resolved.
After submitting a virtual integration, 'p4 sync' can be used to
update the workspace.

Integration is not supported for files with propagating attributes
from an edge server in a distributed environment. Depending on the
integration action, target, and source, either the integration or
resolve command will fail.

See Also

Client Class
IntegrateFiles Overload


IntegrateFiles Method (IList(FileSpec), FileSpec, Options)

[image]

Perforce .NET API
Client..::..IntegrateFiles Method (IList<(Of <(<'FileSpec>)>)>, FileSpec, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> IntegrateFiles(
    IList<FileSpec> toFiles,
    FileSpec fromFile,
    Options options
)
Visual Basic
Public Function IntegrateFiles ( _
    toFiles As IList(Of FileSpec), _
    fromFile As FileSpec, _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ IntegrateFiles(
    IList<FileSpec^>^ toFiles,
    FileSpec^ fromFile,
    Options^ options
)

Parameters

toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
fromFile
Type: Perforce.P4..::..FileSpec
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help integrate

integrate -- Integrate one set of files into another

p4 integrate [options] fromFile[revRange] toFile
p4 integrate [options] -b branch [-r] [toFile[revRange] ...]
p4 integrate [options] -b branch -s fromFile[revRange] [toFile ...]
p4 integrate [options] -S stream [-r] [-P parent] [file[revRange] ...]

options: -c changelist# -Di -f -h -O<flags> -n -m max -R<flags> -q -v

'p4 integrate' integrates one set of files (the 'source') into
another (the 'target').

(See also 'p4 merge' and 'p4 copy', variants of 'p4 integrate' that
may be easier and more effective for the task at hand.)

Using the client workspace as a staging area, 'p4 integrate' adds and
deletes target files per changes in the source, and schedules all
other affected target files to be resolved. Target files outside of
the current client view are not affected. Source files need not be
within the client view.

'p4 resolve' must be used to merge file content, and to resolve
filename and filetype changes. 'p4 submit' commits integrated files
to the depot. Unresolved files may not be submitted. Integrations
can be shelved with 'p4 shelve' and abandoned with 'p4 revert'. The
commands 'p4 integrated' and 'p4 filelog' display integration history.

When 'p4 integrate' schedules a workspace file to be resolved, it
leaves it read-only. 'p4 resolve' can operate on a read-only file.
For other pre-submit changes, 'p4 edit' must be used to make the
file writable.

Source and target files can be specified either on the 'p4 integrate'
command line or through a branch view. On the command line, fromFile
is the source file set and toFile is the target file set. With a
branch view, one or more toFile arguments can be given to limit the
scope of the target file set.

revRange is a revision or a revision range that limits the span of
source history to be probed for unintegrated revisions. revRange
can be used on fromFile, or on toFile, but not on both. When used on
toFile, it refers to source revisions, not to target revisions. For
details about revision specifiers, see 'p4 help revisions'.

The -S flag makes 'p4 integrate' use a generated branch view that maps
a stream (or its underlying real stream) to its parent. With -r, the
direction of the mapping is reversed. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. Note that to submit integrated stream files, the current
client must be switched to the target stream, or to a virtual child
stream of the target stream.

The -b flag makes 'p4 integrate' use a user-defined branch view.
(See 'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the branch view to be treated as the
target, per the branch view mapping. Optional toFile arguments may
be given to further restrict the scope of the target file set. The
-r flag is ignored when -s is used.

Note that 'p4 integrate' automatically adusts source-to-target
mappings for moved and renamed files. (Adjustment occurs only if
the 'p4 move' command was used to move/rename files.) The scope of
source and target file sets must include both the old-named and the
new-named files for mappings to be adjusted. A filename resolve is
scheduled for each remapped file to allow the target to be moved to
match the source.

The -f flag forces integrate to ignore integration history and treat
all source revisions as unintegrated. It is meant to be used with
revRange to force reintegration of specific, previously integrated
revisions.

The -O flags cause more information to be output for each file opened:

-Ob Show the base revision for the merge (if any).
-Or Show the resolve(s) that are being scheduled.

The -R flags modify the way resolves are scheduled:

-Rb Schedules 'branch resolves' instead of branching new
target files automatically.

-Rd Schedules 'delete resolves' instead of deleting
target files automatically.

-Rs Skips cherry-picked revisions already integrated.
This can improve merge results, but can also cause
multiple resolves per file to be scheduled.

The -Di flag modifies the way deleted revisions are treated. If the
source file has been deleted and re-added, revisions that precede
the deletion will be considered to be part of the same source file.
By default, re-added files are considered to be unrelated to the
files of the same name that preceded them.

The -h flag leaves the target files at the revision currently synced
to the client (the '#have' revision). By default, target files are
automatically synced to the head revision by 'p4 integrate'.

The -m flag limits integration to the first 'max' number of files.

The -n flag displays a preview of integration, without actually
doing anything.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

If -c changelist# is specified, the files are opened in the
designated numbered pending changelist instead of the 'default'
changelist.

The -v flag causes a 'virtual' integration that does not modify
client workspace files unless target files need to be resolved.
After submitting a virtual integration, 'p4 sync' can be used to
update the workspace.

Integration is not supported for files with propagating attributes
from an edge server in a distributed environment. Depending on the
integration action, target, and source, either the integration or
resolve command will fail.

See Also

Client Class
IntegrateFiles Overload


LabelSync Method

[image] [image]

Perforce .NET API
Client..::..LabelSync Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LabelSync(IList<(Of <<'(FileSpec>)>>), String, Options) |
Public method | LabelSync(Options, String, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


LabelSync Method (IList(FileSpec), String, Options)

[image]

Perforce .NET API
Client..::..LabelSync Method (IList<(Of <(<'FileSpec>)>)>, String, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> LabelSync(
    IList<FileSpec> toFiles,
    string labelName,
    Options options
)
Visual Basic
Public Function LabelSync ( _
    toFiles As IList(Of FileSpec), _
    labelName As String, _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ LabelSync(
    IList<FileSpec^>^ toFiles,
    String^ labelName,
    Options^ options
)

Parameters

toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
labelName
Type: System..::..String
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help labelsync

labelsync -- Apply the label to the contents of the client workspace

p4 labelsync [-a -d -g -n -q] -l label [file[revRange] ...]

Labelsync causes the specified label to reflect the current contents
of the client. It records the revision of each file currently synced.
The label's name can subsequently be used in a revision specification
as @label to refer to the revision of a file as stored in the label.

Without a file argument, labelsync causes the label to reflect the
contents of the whole client, by adding, deleting, and updating the
label. If a file is specified, labelsync updates the specified file.

If the file argument includes a revision specification, that revision
is used instead of the revision synced by the client. If the specified
revision is a deleted revision, the label includes that deleted
revision. See 'p4 help revisions' for details about specifying
revisions.

If the file argument includes a revision range specification,
only files selected by the revision range are updated, and the
highest revision in the range is used.

The -a flag adds the specified file to the label.

The -d deletes the specified file from the label, regardless of
revision.

The -n flag previews the operation without altering the label.

Only the owner of a label can run labelsync on that label. A label
that has its Options: field set to 'locked' cannot be updated. A
label without an owner can be labelsync'd by any user.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

The -g flag should be used on an Edge Server to update a global
label. Note that in this case, the client should be a global client.
Configuring rpl.labels.global=1 reverses this default and causes this
flag to have the opposite meaning.

See Also

Client Class
LabelSync Overload


LabelSync Method (Options, String, FileSpec[])

[image]

Perforce .NET API
Client..::..LabelSync Method (Options, String, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> LabelSync(
    Options options,
    string labelName,
    params FileSpec[] files
)
Visual Basic
Public Function LabelSync ( _
    options As Options, _
    labelName As String, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ LabelSync(
    Options^ options,
    String^ labelName,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
labelName
Type: System..::..String
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help labelsync

labelsync -- Apply the label to the contents of the client workspace

p4 labelsync [-a -d -g -n -q] -l label [file[revRange] ...]

Labelsync causes the specified label to reflect the current contents
of the client. It records the revision of each file currently synced.
The label's name can subsequently be used in a revision specification
as @label to refer to the revision of a file as stored in the label.

Without a file argument, labelsync causes the label to reflect the
contents of the whole client, by adding, deleting, and updating the
label. If a file is specified, labelsync updates the specified file.

If the file argument includes a revision specification, that revision
is used instead of the revision synced by the client. If the specified
revision is a deleted revision, the label includes that deleted
revision. See 'p4 help revisions' for details about specifying
revisions.

If the file argument includes a revision range specification,
only files selected by the revision range are updated, and the
highest revision in the range is used.

The -a flag adds the specified file to the label.

The -d deletes the specified file from the label, regardless of
revision.

The -n flag previews the operation without altering the label.

Only the owner of a label can run labelsync on that label. A label
that has its Options: field set to 'locked' cannot be updated. A
label without an owner can be labelsync'd by any user.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

The -g flag should be used on an Edge Server to update a global
label. Note that in this case, the client should be a global client.
Configuring rpl.labels.global=1 reverses this default and causes this
flag to have the opposite meaning.

See Also

Client Class
LabelSync Overload


LockFiles Method

[image] [image]

Perforce .NET API
Client..::..LockFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LockFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | LockFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


LockFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..LockFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> LockFiles(
    IList<FileSpec> files,
    Options options
)
Visual Basic
Public Function LockFiles ( _
    files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ LockFiles(
    IList<FileSpec^>^ files,
    Options^ options
)

Parameters

files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
LockFiles Overload


LockFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..LockFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> LockFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function LockFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ LockFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help lock

lock -- Lock an open file to prevent it from being submitted

p4 lock [-c changelist#] [file ...]

The specified files are locked in the depot, preventing any user
other than the current user on the current client from submitting
changes to the files. If a file is already locked, the lock request
is rejected. If no file names are specified, all files in the
specified changelist are locked. If changelist number is omitted,
files in the default changelist are locked.

See Also

Client Class
LockFiles Overload


MergeFiles Method

[image] [image]

Perforce .NET API
Client..::..MergeFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MergeFiles(Options) |
Public method | MergeFiles(FileSpec, IList<(Of <<'(FileSpec>)>>), Options) |
Public method | MergeFiles(Options, FileSpec, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


MergeFiles Method (Options)

[image]

Perforce .NET API
Client..::..MergeFiles Method (Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> MergeFiles(
    Options options
)
Visual Basic
Public Function MergeFiles ( _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ MergeFiles(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

See Also

Client Class
MergeFiles Overload


MergeFiles Method (FileSpec, IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..MergeFiles Method (FileSpec, IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> MergeFiles(
    FileSpec fromFile,
    IList<FileSpec> toFiles,
    Options options
)
Visual Basic
Public Function MergeFiles ( _
    fromFile As FileSpec, _
    toFiles As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ MergeFiles(
    FileSpec^ fromFile,
    IList<FileSpec^>^ toFiles,
    Options^ options
)

Parameters

fromFile
Type: Perforce.P4..::..FileSpec
toFiles
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
MergeFiles Overload


MergeFiles Method (Options, FileSpec, FileSpec[])

[image]

Perforce .NET API
Client..::..MergeFiles Method (Options, FileSpec, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> MergeFiles(
    Options options,
    FileSpec fromFile,
    params FileSpec[] toFiles
)
Visual Basic
Public Function MergeFiles ( _
    options As Options, _
    fromFile As FileSpec, _
    ParamArray toFiles As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ MergeFiles(
    Options^ options,
    FileSpec^ fromFile,
    ... array<FileSpec^>^ toFiles
)

Parameters

options
Type: Perforce.P4..::..Options
fromFile
Type: Perforce.P4..::..FileSpec
toFiles
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

Client Class
MergeFiles Overload


MoveFiles Method

[image]

Perforce .NET API
Client..::..MoveFiles Method
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> MoveFiles(
    FileSpec fromFile,
    FileSpec toFile,
    Options options
)
Visual Basic
Public Function MoveFiles ( _
    fromFile As FileSpec, _
    toFile As FileSpec, _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ MoveFiles(
    FileSpec^ fromFile,
    FileSpec^ toFile,
    Options^ options
)

Parameters

fromFile
Type: Perforce.P4..::..FileSpec
toFile
Type: Perforce.P4..::..FileSpec
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help move

move -- move file(s) from one location to another
rename -- synonym for 'move'

p4 move [-c changelist#] [-f -n -k] [-t filetype] fromFile toFile

Move takes an already opened file and moves it from one client
location to another, reopening it as a pending depot move. When
the file is submitted with 'p4 submit', its depot file is moved
accordingly.

Wildcards in fromFile and toFile must match. The fromFile must be
a file open for add or edit.

'p4 opened' lists pending moves. 'p4 diff' can compare a moved
client file with its depot original, 'p4 sync' can schedule an
update of a moved file, and 'p4 resolve' can resolve the update.

A client file can be moved many times before it is submitted.
Moving a file back to its original location will undo a pending
move, leaving unsubmitted content intact. Using 'p4 revert'
undoes the move and reverts the unsubmitted content.

If -c changelist# is specified, the file is reopened in the
specified pending changelist as well as being moved.

The -f flag forces a move to an existing target file. The file
must be synced and not opened. The originating source file will
no longer be synced to the client.

If -t filetype is specified, the file is assigned that filetype.
If the filetype is a partial filetype, the partial filetype is
combined with the current filetype. See 'p4 help filetypes'.

The -n flag previews the operation without moving files.

The -k flag performs the rename on the server without modifying
client files. Use with caution, as an incorrect move can cause
discrepancies between the state of the client and the corresponding
server metadata.

The 'move' command requires a release 2009.1 or newer client. The
'-f' flag requires a 2010.1 client.

See Also

Client Class


Parse Method

[image]

Perforce .NET API
Client..::..Parse Method
Client Class See Also Send Feedback
Parse a client spec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String

Return Value

See Also

Client Class


ReopenFiles Method

[image] [image]

Perforce .NET API
Client..::..ReopenFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReopenFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ReopenFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


ReopenFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..ReopenFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> ReopenFiles(
    IList<FileSpec> files,
    Options options
)
Visual Basic
Public Function ReopenFiles ( _
    files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ ReopenFiles(
    IList<FileSpec^>^ files,
    Options^ options
)

Parameters

files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
ReopenFiles Overload


ReopenFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..ReopenFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> ReopenFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function ReopenFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ ReopenFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help reopen

reopen -- Change the filetype of an open file or move it to
another changelist

p4 reopen [-c changelist#] [-t filetype] file ...

Reopen an open file for the current user in order to move it to a
different changelist or change its filetype.

The target changelist must exist; you cannot create a changelist by
reopening a file. To move a file to the default changelist, use
'p4 reopen -c default'.

If -t filetype is specified, the file is assigned that filetype. If
a partial filetype is specified, it is combined with the current
filetype. For details, see 'p4 help filetypes'.

See Also

Client Class
ReopenFiles Overload


ResolveFiles Method

[image] [image]

Perforce .NET API
Client..::..ResolveFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResolveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ResolveFiles(Options, array<FileSpec>[]()[][]) |
Public method | ResolveFiles(Client..::..ResolveFileDelegate, Options, array<FileSpec>[]()[][]) | Resolve files

See Also

Client Class
Client Members


ResolveFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..ResolveFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileResolveRecord> ResolveFiles(
    IList<FileSpec> files,
    Options options
)
Visual Basic
Public Function ResolveFiles ( _
    files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileResolveRecord)
Visual C++
public:
IList<FileResolveRecord^>^ ResolveFiles(
    IList<FileSpec^>^ files,
    Options^ options
)

Parameters

files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Client Class
ResolveFiles Overload


ResolveFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..ResolveFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileResolveRecord> ResolveFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function ResolveFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileResolveRecord)
Visual C++
public:
IList<FileResolveRecord^>^ ResolveFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

Client Class
ResolveFiles Overload


ResolveFiles Method (Client.ResolveFileDelegate, Options, FileSpec[])

[image]

Perforce .NET API
Client..::..ResolveFiles Method (Client..::..ResolveFileDelegate, Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback
Resolve files

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileResolveRecord> ResolveFiles(
    Client..::..ResolveFileDelegate resolveHandler,
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function ResolveFiles ( _
    resolveHandler As Client..::..ResolveFileDelegate, _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileResolveRecord)
Visual C++
public:
IList<FileResolveRecord^>^ ResolveFiles(
    Client..::..ResolveFileDelegate^ resolveHandler,
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

resolveHandler
Type: Perforce.P4..::..Client..::..ResolveFileDelegate
options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

The caller must either 1) set an automatic resolution (-as, -am.-af, -at, or -ay), 2) provide a callback function of type P4Server..::..PromptHandlerDelegate to respond to the prompts, or 3) provide a dictionary which contains responses to the prompts.

p4 help resolve

resolve -- Resolve integrations and updates to workspace files

p4 resolve [options] [file ...]

options: -A<flags> -a<flags> -d<flags> -f -n -N -o -t -v
-c changelist#

'p4 resolve' resolves changes to files in the client workspace.

'p4 resolve' works only on files that have been scheduled to be
resolved. The commands that can schedule resolves are: 'p4 sync',
'p4 update', 'p4 submit', 'p4 merge', and 'p4 integrate'. Files must
be resolved before they can be submitted.

Resolving involves two sets of files, a source and a target. The
target is a set of depot files that maps to opened files in the
client workspace. When resolving an integration, the source is a
different set of depot files than the target. When resolving an
update, the source is the same set of depot files as the target,
at a different revision.

The 'p4 resolve' file argument specifies the target. If the file
argument is omitted, all unresolved files are resolved.

Resolving can modify workspace files. To back up files, use 'p4
shelve' before using 'p4 resolve'.

The resolve process is a classic three-way merge. The participating
files are referred to as follows:

'yours' The target file open in the client workspace
'theirs' The source file in the depot
'base' The common ancestor; the highest revision of the
source file already accounted for in the target.
'merged' The merged result.

Filenames, filetypes, and text file content can be resolved by
accepting 'yours', 'theirs', or 'merged'. Branching, deletion, and
binary file content can be resolved by accepting either 'yours' or
'theirs'.

When resolving integrated changes, 'p4 resolve' distinguishes among
four results: entirely yours, entirely theirs, a pure merge, or an
edited merge. The distinction is recorded when resolved files are
submitted, and will be used by future commands to determine whether
integration is needed.

In all cases, accepting 'yours' leaves the target file in its current
state. The result of accepting 'theirs' is as follows:

Content: The target file content is overwritten.
Attribute: The target's attributes are replaced.
Branching: A new target is branched.
Deletion: The target file is deleted.
Filename: The target file is moved or renamed.
Filetype: The target file's type is changed.

For each unresolved change, the user is prompted to accept a result.
Content and non-content changes are resolved separately. For content,
'p4 resolve' places the merged result into a temporary file in the
client workspace. If there are any conflicts, the merged file contains
conflict markers that must be removed by the user.

'p4 resolve' displays a count of text diffs and conflicts, and offers
the following prompts:

Accept:
at Keep only changes to their file.
ay Keep only changes to your file.
* am Keep merged file.
* ae Keep merged and edited file.
* a Keep autoselected file.

Diff:
* dt See their changes alone.
* dy See your changes alone.
* dm See merged changes.
d Diff your file against merged file.

Edit:
et Edit their file (read only).
ey Edit your file (read/write).
* e Edit merged file (read/write).

Misc:
* m Run '$P4MERGE base theirs yours merged'.
(Runs '$P4MERGEUNICODE charset base theirs
yours merged' if set and the file is a
unicode file.)
s Skip this file.
h Print this help message.
^C Quit the resolve operation.

Options marked (*) appear only for text files. The suggested action
will be displayed in brackets.

The 'merge' (m) option enables you to invoke your own merge program, if
one is configured using the $P4MERGE environment variable. Four files
are passed to the program: the base, yours, theirs, and the temporary
file. The program is expected to write merge results to the temporary
file.

The -A flag can be used to limit the kind of resolving that will be
attempted; without it, everything is attempted:

-Aa Resolve attributes.
-Ab Resolve file branching.
-Ac Resolve file content changes.
-Ad Resolve file deletions.
-Am Resolve moved and renamed files.
-At Resolve filetype changes.
-AQ Resolve charset changes.

The -a flag puts 'p4 resolve' into automatic mode. The user is not
prompted, and files that can't be resolved automatically are skipped:

-as 'Safe' resolve; skip files that need merging.
-am Resolve by merging; skip files with conflicts.
-af Force acceptance of merged files with conflicts.
-at Force acceptance of theirs; overwrites yours.
-ay Force acceptance of yours; ignores theirs.

The -as flag causes the workspace file to be replaced with their file
only if theirs has changed and yours has not.

The -am flag causes the workspace file to be replaced with the result
of merging theirs with yours. If the merge detected conflicts, the
file is left untouched and unresolved.

The -af flag causes the workspace file to be replaced with the result
of merging theirs with yours, even if there were conflicts. This can
leave conflict markers in workspace files.

The -at flag resolves all files by copying theirs into yours. It
should be used with care, as it overwrites any changes made to the
file in the client workspace.

The -ay flag resolves all files by accepting yours and ignoring
theirs. It preserves the content of workspace files.

The -d flags can be used to control handling of whitespace and line
endings when merging files:

-db Ignore whitespace changes.
-dw Ignore whitespace altogether.
-dl Ignores line endings.

The -d flags are also passed to the diff options in the 'p4 resolve'
dialog. Additional -d flags that modify the diff output but do not
modify merge behavior include -dn (RCS), -dc (context), -ds (summary),
and -du (unified). Note that 'p4 resolve' uses text from the client
file if the files differ only in whitespace.

The -f flag enables previously resolved content to be resolved again.
By default, after files have been resolved, 'p4 resolve' does not
process them again.

The -n flag previews the operation without altering files.

The -N flag previews the operation with additional information about
any non-content resolve actions that are scheduled.

The -o flag displays the base file name and revision to be used
during the the merge.

The -t flag forces 'p4 resolve' to attempt a textual merge, even for
files with non-text (binary) types.

The -v flag causes 'p4 resolve' to insert markers for all changes,
not just conflicts.

The -c flag limits 'p4 resolve' to the files in changelist#.

'p4 resolve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Client Class
ResolveFiles Overload


RevertFiles Method

[image] [image]

Perforce .NET API
Client..::..RevertFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RevertFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | RevertFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


RevertFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..RevertFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> RevertFiles(
    IList<FileSpec> Files,
    Options options
)
Visual Basic
Public Function RevertFiles ( _
    Files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ RevertFiles(
    IList<FileSpec^>^ Files,
    Options^ options
)

Parameters

Files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Client Class
RevertFiles Overload


RevertFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..RevertFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> RevertFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function RevertFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ RevertFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
RevertFilesOptions
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help revert

revert -- Discard changes from an opened file

p4 revert [-a -n -k -w -c changelist# -C client] file ...

Revert an open file to the revision that was synced from the depot,
discarding any edits or integrations that have been made. You must
explicitly specify the files to be reverted. Files are removed from
the changelist in which they are open. Locked files are unlocked.

The -a flag reverts only files that are open for edit, add, or
integrate and are unchanged or missing. Files with pending
integration records are left open. The file arguments are optional
when -a is specified.

The -n flag displays a preview of the operation.

The -k flag marks the file as reverted in server metadata without
altering files in the client workspace.

The -w flag causes files that are open for add to be deleted from the
workspace when they are reverted.

The -c flag reverts files that are open in the specified changelist.

The -C flag allows a user to specify the workspace that has the file
opened rather than defaulting to the current client workspace. When
this option is used, the '-k' flag is also enabled and the check for
matching user is disabled. The -C flag requires 'admin' access, which
is granted by 'p4 protect'.

See Also

Client Class
RevertFiles Overload


ShelveFiles Method

[image] [image]

Perforce .NET API
Client..::..ShelveFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShelveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | ShelveFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


ShelveFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..ShelveFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> ShelveFiles(
    IList<FileSpec> Files,
    Options options
)
Visual Basic
Public Function ShelveFiles ( _
    Files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ ShelveFiles(
    IList<FileSpec^>^ Files,
    Options^ options
)

Parameters

Files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Client Class
ShelveFiles Overload


ShelveFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..ShelveFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> ShelveFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function ShelveFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ ShelveFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help shelve

shelve -- Store files from a pending changelist into the depot

p4 shelve [-p] [files]
p4 shelve [-a option] [-p] -i [-f | -r]
p4 shelve [-a option] [-p] -r -c changelist#
p4 shelve [-a option] [-p] -c changelist# [-f] [file ...]
p4 shelve -d -c changelist# [-f] [file ...]

'p4 shelve' creates, modifies or deletes shelved files in a pending
changelist. Shelved files remain in the depot until they are deleted
(using 'p4 shelve -d') or replaced by subsequent shelve commands.
After 'p4 shelve', the user can revert the files and restore them
later using 'p4 unshelve'. Other users can 'p4 unshelve' the stored
files into their own workspaces.

Files that have been shelved can be accessed by the 'p4 diff',
'p4 diff2', 'p4 files' and 'p4 print' commands using the revision
specification '@=change', where 'change' is the pending changelist
number.

By default, 'p4 shelve' creates a changelist, adds files from the
user's default changelist, then shelves those files in the depot.
The user is presented with a text changelist form displayed using
the editor configured using the $P4EDITOR environment variable.

If a file pattern is specified, 'p4 shelve' shelves the files that
match the pattern.

The -i flag reads the pending changelist specification with shelved
files from the standard input. The user's editor is not invoked.
To modify an existing changelist with shelved files, specify the
changelist number using the -c flag.

The -c flag specifies the pending changelist that contains shelved
files to be created, deleted, or modified. Only the user and client
of the pending changelist can add or modify its shelved files. Any
files specified by the file pattern must already be opened in the
specified changelist; use 'p4 reopen' to move an opened file from
one changelist to another.

The -f (force) flag must be used with the -c or -i flag to overwrite
any existing shelved files in a pending changelist.

The -r flag (used with -c or -i) enables you to replace all shelved
files in that changelist with the files opened in your own workspace
at that changelist number. Previously shelved files will be deleted.
Only the user and client workspace of the pending changelist can
replace its shelved files.

The -a flag enables you to handle unchanged files similarly to some
client submit options, namely 'submitunchanged' and 'leaveunchanged'.
The default behavior of shelving all files corresponds to the
'submitunchanged' option. The 'leaveunchanged' option only shelves
changed files, and then leaves the files opened in the pending
changelist on the client.

The -d flag (used with -c) deletes the shelved files in the specified
changelist so that they can no longer be unshelved. By default, only
the user and client of the pending changelist can delete its shelved
files. A user with 'admin' access can delete shelved files by including
the -f flag to force the operation.

The -p flag promotes a shelved change from an edge server to a commit
server where it can be accessed by other edge servers participating
in the distributed configuration. Once a shelved change has been
promoted, all subsequent local modifications to the shelf are also
pushed to the commit server and remain until the shelf is deleted.
Once a shelf has been created, the combination of flags '-p -c' will
promote the shelf without modification unless '-f' or '-r' are also
used to update the shelved files before promotion.

'p4 shelve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Client Class
ShelveFiles Overload


SubmitFiles Method

[image]

Perforce .NET API
Client..::..SubmitFiles Method
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SubmitResults SubmitFiles(
    Options options,
    FileSpec file
)
Visual Basic
Public Function SubmitFiles ( _
    options As Options, _
    file As FileSpec _
) As SubmitResults
Visual C++
public:
SubmitResults^ SubmitFiles(
    Options^ options,
    FileSpec^ file
)

Parameters

options
Type: Perforce.P4..::..Options
file
Type: Perforce.P4..::..FileSpec

Return Value

Remarks

p4 help submit

submit -- Submit open files to the depot

p4 submit [-r -s -f option --noretransfer 0|1]
p4 submit [-r -s -f option] file
p4 submit [-r -f option] -d description
p4 submit [-r -f option] -d description file
p4 submit [-r -f option --noretransfer 0|1] -c changelist#
p4 submit -e shelvedChange#
p4 submit -i [-r -s -f option]
--parallel=threads=N[,batch=N][,min=N]

'p4 submit' commits a pending changelist and its files to the depot.

By default, 'p4 submit' attempts to submit all files in the 'default'
changelist. Submit displays a dialog where you enter a description
of the change and, optionally, delete files from the list of files
to be checked in.

To add files to a changelist before submitting, use any of the
commands that open client workspace files: 'p4 add', 'p4 edit',
etc.

If the file parameter is specified, only files in the default
changelist that match the pattern are submitted.

Files in a stream path can be submitted only by client workspaces
dedicated to the stream. See 'p4 help client'.

Before committing a changelist, 'p4 submit' locks all the files being
submitted. If any file cannot be locked or submitted, the files are
left open in a numbered pending changelist. By default, the files in
a failed submit operation are left locked unless the
submit.unlocklocked configurable is set. Files are unlocked even if
they were manually locked prior to submit if submit fails when
submit.unlocklocked is set. 'p4 opened' shows unsubmitted files
and their changelists.

Submit is atomic: if the operation succeeds, all files are updated
in the depot. If the submit fails, no depot files are updated.

If submit fails, some or all of the files may have been copied to
the server. By default, retrying a failed submit will transfer all of
the files again unless the submit.noretransfer configurable is set.
If submit.noretransfer is set to 1, submit uses digest comparisons to
to detect if the files have already been transferred in order to
avoid file re-transfer when retrying a failed submit.

The --noretransfer flag is used to override the submit.noretransfer
configurable so the user can choose his preferred re-transfer
behavior during the current submit operation.

The -c flag submits the specified pending changelist instead of the
default changelist. Additional changelists can be created manually,
using the 'p4 change' command, or automatically as the result of a
failed attempt to submit the default changelist.

The -e flag submits a shelved changelist without transferring files
or modifying the workspace. The shelved change must be owned by
the person submitting the change, but the client may be different.
However, files shelved to a stream target may only be submitted by
a stream client that is mapped to the target stream. In addition,
files shelved to a non-stream target cannot be submitted by a stream
client. To submit a shelved change, all files in the shelved change
must be up to date and resolved. No files may be open in any workspace
at the same change number. Client submit options (ie revertUnchanged,
etc) will be ignored. If the submit is successful, the shelved change
and files are cleaned up, and are no longer available to be unshelved
or submitted.

The -d flag passes a description into the specified changelist rather
than displaying the changelist dialog for manual editing. This option
is useful for scripting, but does not allow you to add jobs or modify
the default changelist.

The -f flag enables you to override submit options that are configured
for the client that is submitting the changelist. This flag overrides
the -r (reopen)flag, if it is specified. See 'p4 help client' for
details about submit options.

The -i flag reads a changelist specification from the standard input.
The user's editor is not invoked.

The -r flag reopens submitted files in the default changelist after
submission.

The -s flag extends the list of jobs to include the fix status
for each job, which becomes the job's status when the changelist
is committed. See 'p4 help change' for details.

The --parallel flag specifies options for parallel file transfer. If
parallel file transfer has been enabled by setting the
net.parallel.max configurable, and if there are sufficient resources
across the system, a submit command may execute more rapidly by
transferring multiple files in parallel. Specify threads=N to request
files be sent concurrently, using N independent network connections.
The N threads grab work in batches; specify batch=N to control the
number of files in a batch. A submit that is too small will not
initiate parallel file transfers; specify min=N to control the
minimum number of files in a parallel submit. Requesting progress
indicators causes the --parallel flag to be ignored.

Using --parallel from an edge server allows parallel file transfer
from the edge server to the commit server. This uses standard pull
threads to transfer the files. Note that an adminstrator must insure
that pull threads can be run on the commit server. The address
used by the commit server to connect to the edge server must
be specified in the ExternalAddress field of the edge server spec.

Only 'submit -e' is supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Client Class


SyncFiles Method

[image] [image]

Perforce .NET API
Client..::..SyncFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SyncFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | SyncFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


SyncFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..SyncFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> SyncFiles(
    IList<FileSpec> Files,
    Options options
)
Visual Basic
Public Function SyncFiles ( _
    Files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ SyncFiles(
    IList<FileSpec^>^ Files,
    Options^ options
)

Parameters

Files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Client Class
SyncFiles Overload


SyncFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..SyncFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> SyncFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function SyncFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ SyncFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help sync

sync -- Synchronize the client with its view of the depot
flush -- synonym for 'sync -k'
update -- synonym for 'sync -s'

p4 sync [-f -L -n -N -k -q -r] [-m max] [file[revRange] ...]
p4 sync [-L -n -N -q -s] [-m max] [file[revRange] ...]
p4 sync [-L -n -N -p -q] [-m max] [file[revRange] ...]
--parallel=threads=N[,batch=N][,batchsize=N][,min=N][,minsize=N]

Sync updates the client workspace to reflect its current view (if
it has changed) and the current contents of the depot (if it has
changed). The client view maps client and depot file names and
locations.

Sync adds files that are in the client view and have not been
retrieved before. Sync deletes previously retrieved files that
are no longer in the client view or have been deleted from the
depot. Sync updates files that are still in the client view and
have been updated in the depot.

By default, sync affects all files in the client workspace. If file
arguments are given, sync limits its operation to those files.
The file arguments can contain wildcards.

If the file argument includes a revision specifier, then the given
revision is retrieved. Normally, the head revision is retrieved.
See 'p4 help revisions' for help specifying revisions.

If the file argument includes a revision range specification,
only files selected by the revision range are updated, and the
highest revision in the range is used.

Normally, sync does not overwrite workspace files that the user has
manually made writable. Setting the 'clobber' option in the
client specification disables this safety check.

The -f flag forces resynchronization even if the client already
has the file, and overwriting any writable files. This flag doesn't
affect open files.

The -L flag can be used with multiple file arguments that are in
full depot syntax and include a valid revision number. When this
flag is used the arguments are processed together by building an
internal table similar to a label. This file list processing is
significantly faster than having to call the internal query engine
for each individual file argument. However, the file argument syntax
is strict and the command will not run if an error is encountered.

The -n flag previews the operation without updating the workspace.

The -N flag also previews the operation without updating the
workspace, but reports only a summary of the work the sync would do.

The -k flag updates server metadata without syncing files. It is
intended to enable you to ensure that the server correctly reflects
the state of files in the workspace while avoiding a large data
transfer. Caution: an erroneous update can cause the server to
incorrectly reflect the state of the workspace.

The -p flag populates the client workspace, but does not update the
server to reflect those updates. Any file that is already synced or
opened will be bypassed with a warning message. This option is very
useful for build clients or when publishing content without the
need to track the state of the client workspace.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are not suppressed.

The -r flag allows open files which are mapped to new locations
in the depot to be reopened in the new location. By default, open
workspace files remain associated with the depot files that they were
originally opened as.

The -s flag adds a safety check before sending content to the client
workspace. This check uses MD5 digests to compare the content on the
clients workspace against content that was last synced. If the file
has been modified outside of Perforce's control then an error message
is displayed and the file is not overwritten. This check adds some
extra processing which will affect the performance of the operation.
Clients with 'allwrite' and 'noclobber' set do this check by default.

The -m flag limits sync to the first 'max' number of files. This
option is useful in conjunction with tagged output and the '-n'
flag, to preview how many files will be synced without transferring
all the file data.

The --parallel flag specifies options for parallel file transfer. If
your administrator has enabled parallel file transfer by setting the
net.parallel.max configurable, and if there are sufficient resources
across the system, a sync command may execute more rapidly by
transferring multiple files in parallel. Specify threads=N to request
files be sent concurrently, using N independent network connections.
The N threads grab work in batches; specify batch=N to control the
number of files in a batch, or batchsize=N to control the number of
bytes in a batch. A sync that is too small will not initiate parallel
file transfers; specify min=N to control the minimum number of files
in a parallel sync, or minsize=N to control the minimum number of
bytes in a parallel sync. Requesting progress indicators causes the
--parallel flag to be ignored.

See Also

Client Class
SyncFiles Overload


ToString Method

[image]

Perforce .NET API
Client..::..ToString Method
Client Class See Also Send Feedback
Format as a client spec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

Client Class


UnlockFiles Method

[image] [image]

Perforce .NET API
Client..::..UnlockFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnlockFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | UnlockFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


UnlockFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..UnlockFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> UnlockFiles(
    IList<FileSpec> Files,
    Options options
)
Visual Basic
Public Function UnlockFiles ( _
    Files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ UnlockFiles(
    IList<FileSpec^>^ Files,
    Options^ options
)

Parameters

Files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Client Class
UnlockFiles Overload


UnlockFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..UnlockFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> UnlockFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function UnlockFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ UnlockFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help unlock

unlock -- Release a locked file, leaving it open

p4 unlock [-c | -s changelist# | -x] [-f] [file ...]
p4 -c client unlock [-f] -r

'p4 unlock' releases locks on the specified files, which must be
open in the specified pending changelist. If you omit the changelist
number, the default changelist is assumed. If you omit the file name,
all locked files are unlocked.

The -s flag unlocks files from a shelved changelist caused by an
aborted 'submit -e' operation. The -c flag applies to opened files
in a pending changelist locked by 'p4 lock' or by a failed submit
of a change that is not shelved.

By default, files can be unlocked only by the changelist owner who
must also be the person who has the files locked. The -f flag
enables you to unlock files in changelists owned by other users.
The -f flag requires 'admin' access, which is granted by 'p4
protect'.

The -x option unlocks files that are opened 'exclusive' but are
orphaned (see 'p4 opened -x'). This option only applies to a
distributed installation where global tracking of these file types
is necessary across servers.

If a push command from a remote server to this server fails, files
can be left locked on this server, preventing other users from
submitting changes to those files. In this case, the user who issued
the push command can specify the -r flag with the name of the client
that was used on that remote server to unlock the files on this
server. An administrator can run 'unlock -f -r' as well.

See Also

Client Class
UnlockFiles Overload


UnshelveFiles Method

[image] [image]

Perforce .NET API
Client..::..UnshelveFiles Method
Client Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnshelveFiles(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | UnshelveFiles(Options, array<FileSpec>[]()[][]) |

See Also

Client Class
Client Members


UnshelveFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Client..::..UnshelveFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> UnshelveFiles(
    IList<FileSpec> Files,
    Options options
)
Visual Basic
Public Function UnshelveFiles ( _
    Files As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ UnshelveFiles(
    IList<FileSpec^>^ Files,
    Options^ options
)

Parameters

Files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

See Also

Client Class
UnshelveFiles Overload


UnshelveFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Client..::..UnshelveFiles Method (Options, array<FileSpec>[]()[][])
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> UnshelveFiles(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function UnshelveFiles ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ UnshelveFiles(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help unshelve

unshelve -- Restore shelved files from a pending change into a workspace

p4 unshelve -s changelist# [options] [file ...]
Options: [-f -n] [-c changelist#] [-b branch|-S stream [-P parent]]

'p4 unshelve' retrieves shelved files from the specified pending
changelist, opens them in a pending changelist and copies them
to the invoking user's workspace. Unshelving files from a pending
changelist is restricted by the user's permissions on the files.
A successful unshelve operation places the shelved files on the
user's workspace with the same open action and pending integration
history as if it had originated from that user and client.

Unshelving a file over an already opened file is permitted if both
shelved file and opened file are opened for 'edit'. In a distributed
environment, an additional requirement is that the shelve was created
on the same edge server. After unshelving, the workspace file is
flagged as unresolved, and 'p4 resolve' must be run to resolve the
differences between the shelved file and the workspace file.

Unshelving a file opened for 'add' when the file already exists
in the depot will result in the file being opened for edit. After
unshelving, the workspace file is flagged as unresolved, and
'p4 resolve' must be run to resolve the differences between the
shelved file and the depot file at the head revision. Note that
unshelving a file opened for 'add' over an already opened file is
not supported.

The -s flag specifies the number of the pending changelist that
contains the shelved files.

If a file pattern is specified, 'p4 unshelve' unshelves files that
match the pattern.

The -b flag specifies a branch spec that the shelved files will be
mapped through prior to being unshelved, allowing files to be shelved
in one branch and unshelved in another. As with unshelving into an
open file, it may be necessary to run 'p4 resolve'. In a distributed
environment, an additional requirement is that the shelve was created
on the same edge server.

The -S flag uses a generated branch view to map the shelved files
between the specified stream and its parent stream. The -P flag
can be used to generate the view using a parent stream other than
the actual parent.

The -c flag specifies the changelist to which files are unshelved.
By default, 'p4 unshelve' opens shelved files in the default
changelist.

The -f flag forces the clobbering of any writeable but unopened files
that are being unshelved.

The -n flag previews the operation without changing any files or
metadata.

'p4 unshelve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Client Class
UnshelveFiles Overload


Client Properties

[image] [image]

Perforce .NET API
Client Properties
Client Class See Also Send Feedback

The Client type exposes the following members.

Properties

 | Name | Description
Public property | Accessed |
Public property | AltRoots |
Public property | Description |
Public property | Host |
Public property | Initialized |
Public property | LineEnd |
Public property | Name |
Public property | Options |
Public property | OwnerName |
Public property | Root |
Public property | ServerID |
Public property | Spec |
Public property | Stream |
Public property | StreamAtChange |
Public property | SubmitOptions |
Public property | Updated |
Public property | ViewMap |

See Also

Client Class


Accessed Property

[image]

Perforce .NET API
Client..::..Accessed Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Accessed { get; set; }
Visual Basic
Public Property Accessed As DateTime
    Get
    Set
Visual C++
public:
property DateTime Accessed {
    DateTime get ();
    void set (DateTime value);
}

See Also

Client Class


AltRoots Property

[image]

Perforce .NET API
Client..::..AltRoots Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> AltRoots { get; set; }
Visual Basic
Public Property AltRoots As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ AltRoots {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

Client Class


Description Property

[image]

Perforce .NET API
Client..::..Description Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


Host Property

[image]

Perforce .NET API
Client..::..Host Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Host { get; set; }
Visual Basic
Public Property Host As String
    Get
    Set
Visual C++
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


Initialized Property

[image]

Perforce .NET API
Client..::..Initialized Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Initialized { get; set; }
Visual Basic
Public Property Initialized As Boolean
    Get
    Set
Visual C++
public:
property bool Initialized {
    bool get ();
    void set (bool value);
}

See Also

Client Class


LineEnd Property

[image]

Perforce .NET API
Client..::..LineEnd Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LineEnd LineEnd { get; set; }
Visual Basic
Public Property LineEnd As LineEnd
    Get
    Set
Visual C++
public:
property LineEnd LineEnd {
    LineEnd get ();
    void set (LineEnd value);
}

See Also

Client Class


Name Property

[image]

Perforce .NET API
Client..::..Name Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


Options Property

[image]

Perforce .NET API
Client..::..Options Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientOption Options { get; set; }
Visual Basic
Public Property Options As ClientOption
    Get
    Set
Visual C++
public:
property ClientOption Options {
    ClientOption get ();
    void set (ClientOption value);
}

See Also

Client Class


OwnerName Property

[image]

Perforce .NET API
Client..::..OwnerName Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string OwnerName { get; set; }
Visual Basic
Public Property OwnerName As String
    Get
    Set
Visual C++
public:
property String^ OwnerName {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


Root Property

[image]

Perforce .NET API
Client..::..Root Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


ServerID Property

[image]

Perforce .NET API
Client..::..ServerID Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ServerID { get; set; }
Visual Basic
Public Property ServerID As String
    Get
    Set
Visual C++
public:
property String^ ServerID {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


Spec Property

[image]

Perforce .NET API
Client..::..Spec Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

Client Class


Stream Property

[image]

Perforce .NET API
Client..::..Stream Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Stream { get; set; }
Visual Basic
Public Property Stream As String
    Get
    Set
Visual C++
public:
property String^ Stream {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


StreamAtChange Property

[image]

Perforce .NET API
Client..::..StreamAtChange Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string StreamAtChange { get; set; }
Visual Basic
Public Property StreamAtChange As String
    Get
    Set
Visual C++
public:
property String^ StreamAtChange {
    String^ get ();
    void set (String^ value);
}

See Also

Client Class


SubmitOptions Property

[image]

Perforce .NET API
Client..::..SubmitOptions Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientSubmitOptions SubmitOptions { get; set; }
Visual Basic
Public Property SubmitOptions As ClientSubmitOptions
    Get
    Set
Visual C++
public:
property ClientSubmitOptions^ SubmitOptions {
    ClientSubmitOptions^ get ();
    void set (ClientSubmitOptions^ value);
}

See Also

Client Class


Updated Property

[image]

Perforce .NET API
Client..::..Updated Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Updated { get; set; }
Visual Basic
Public Property Updated As DateTime
    Get
    Set
Visual C++
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}

See Also

Client Class


ViewMap Property

[image]

Perforce .NET API
Client..::..ViewMap Property
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap ViewMap { get; set; }
Visual Basic
Public Property ViewMap As ViewMap
    Get
    Set
Visual C++
public:
property ViewMap^ ViewMap {
    ViewMap^ get ();
    void set (ViewMap^ value);
}

See Also

Client Class


Client.AutoResolveDelegate Delegate

[image]

Perforce .NET API
Client..::..AutoResolveDelegate Delegate
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate P4ClientMerge..::..MergeStatus AutoResolveDelegate(
    P4ClientMerge..::..MergeForce mergeForce
)
Visual Basic
Public Delegate Function AutoResolveDelegate ( _
    mergeForce As P4ClientMerge..::..MergeForce _
) As P4ClientMerge..::..MergeStatus
Visual C++
public delegate P4ClientMerge..::..MergeStatus AutoResolveDelegate(
    P4ClientMerge..::..MergeForce mergeForce
)

Parameters

mergeForce
Type: Perforce.P4..::..P4ClientMerge..::..MergeForce

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


Client.ResolveFileDelegate Delegate

[image]

Perforce .NET API
Client..::..ResolveFileDelegate Delegate
Client Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate P4ClientMerge..::..MergeStatus ResolveFileDelegate(
    FileResolveRecord resolveRecord,
    Client..::..AutoResolveDelegate AutoResolve,
    string sourcePath,
    string targetPath,
    string basePath,
    string resultsPath
)
Visual Basic
Public Delegate Function ResolveFileDelegate ( _
    resolveRecord As FileResolveRecord, _
    AutoResolve As Client..::..AutoResolveDelegate, _
    sourcePath As String, _
    targetPath As String, _
    basePath As String, _
    resultsPath As String _
) As P4ClientMerge..::..MergeStatus
Visual C++
public delegate P4ClientMerge..::..MergeStatus ResolveFileDelegate(
    FileResolveRecord^ resolveRecord,
    Client..::..AutoResolveDelegate^ AutoResolve,
    String^ sourcePath,
    String^ targetPath,
    String^ basePath,
    String^ resultsPath
)

Parameters

resolveRecord
Type: Perforce.P4..::..FileResolveRecord
AutoResolve
Type: Perforce.P4..::..Client..::..AutoResolveDelegate
sourcePath
Type: System..::..String
targetPath
Type: System..::..String
basePath
Type: System..::..String
resultsPath
Type: System..::..String

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ClientCmdFlags Enumeration

[image]

Perforce .NET API
ClientCmdFlags Enumeration
See Also Send Feedback
Flags for the client command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ClientCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration ClientCmdFlags
Visual C++
[FlagsAttribute]
public enum class ClientCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the specified spec, as long as the client workspace has no opened files or pending changes. (See 'p4 help opened'.) The -f flag forces the delete.
Output | 2 | The -o flag writes the named client spec to the standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a client spec from the standard input. The user's editor is not invoked.
Force | 8 | The -f flag can force the updating of locked clients; normally locked clients can only be modified by their owner. -f also allows the last modified date to be set. The -f flag requires 'admin' access granted by 'p4 protect'.
Switch | 16 | The -s flag is used to switch an existing client spec's view without invoking the editor. It can be used with -S to switch to a stream view, or with -t to switch to a view defined in another client spec. Switching views is not allowed in a client that has opened files. The -f flag can be used with -s to force switching with opened files. View switching has no effect on files in a client workspace until 'p4 sync' is run.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ClientCmdOptions Class

[image]

Perforce .NET API
ClientCmdOptions Class
Members See Also Send Feedback
Client command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ClientCmdOptions : Options
Visual Basic
Public Class ClientCmdOptions _
    Inherits Options
Visual C++
public ref class ClientCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ClientCmdOptions

See Also

ClientCmdOptions Members


ClientCmdOptions Members

[image] [image]

Perforce .NET API
ClientCmdOptions Members
ClientCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ClientCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ClientCmdOptions(ClientCmdFlags) | Client command options.
Public method | ClientCmdOptions(ClientCmdFlags, String, String, Int32) | Client command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ClientCmdOptions Class


ClientCmdOptions Constructor

[image] [image]

Perforce .NET API
ClientCmdOptions Constructor
ClientCmdOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClientCmdOptions(ClientCmdFlags) | Client command options.
Public method | ClientCmdOptions(ClientCmdFlags, String, String, Int32) | Client command options.

See Also

ClientCmdOptions Class
ClientCmdOptions Members


ClientCmdOptions Constructor (ClientCmdFlags)

[image]

Perforce .NET API
ClientCmdOptions Constructor (ClientCmdFlags)
ClientCmdOptions Class See Also Send Feedback
Client command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientCmdOptions(
    ClientCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As ClientCmdFlags _
)
Visual C++
public:
ClientCmdOptions(
    ClientCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..ClientCmdFlags

Return Value

Remarks

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

See Also

ClientCmdOptions Class
ClientCmdOptions Overload


ClientCmdOptions Constructor (ClientCmdFlags, String, String, Int32)

[image]

Perforce .NET API
ClientCmdOptions Constructor (ClientCmdFlags, String, String, Int32)
ClientCmdOptions Class See Also Send Feedback
Client command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientCmdOptions(
    ClientCmdFlags flags,
    string template,
    string stream,
    int change
)
Visual Basic
Public Sub New ( _
    flags As ClientCmdFlags, _
    template As String, _
    stream As String, _
    change As Integer _
)
Visual C++
public:
ClientCmdOptions(
    ClientCmdFlags flags,
    String^ template,
    String^ stream,
    int change
)

Parameters

flags
Type: Perforce.P4..::..ClientCmdFlags
template
Type: System..::..String
stream
Type: System..::..String
change
Type: System..::..Int32

Return Value

Remarks

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

See Also

ClientCmdOptions Class
ClientCmdOptions Overload


ClientCmdOptions Methods

[image] [image]

Perforce .NET API
ClientCmdOptions Methods
ClientCmdOptions Class See Also Send Feedback

The ClientCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ClientCmdOptions Class


ClientCmdOptions Properties

[image] [image]

Perforce .NET API
ClientCmdOptions Properties
ClientCmdOptions Class See Also Send Feedback

The ClientCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ClientCmdOptions Class


ClientMetadata Class

[image]

Perforce .NET API
ClientMetadata Class
Members See Also Send Feedback
Metadata from the client associated with a connection.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ClientMetadata
Visual Basic
Public Class ClientMetadata
Visual C++
public ref class ClientMetadata

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ClientMetadata

See Also

ClientMetadata Members


ClientMetadata Members

[image] [image]

Perforce .NET API
ClientMetadata Members
ClientMetadata Class Constructors Methods Properties See Also Send Feedback

The ClientMetadata type exposes the following members.

Constructors

 | Name | Description
Public method | ClientMetadata()()()() | Initializes a new instance of the ClientMetadata class
Public method | ClientMetadata(String, String, String, String, String) | Initializes a new instance of the ClientMetadata class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGetClientMetadataCmdTaggedOutput | Read the fields from the tagged output of an info command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address |
Public property | CurrentDirectory |
Public property | HostName |
Public property | Name |
Public property | Root |

See Also

ClientMetadata Class


ClientMetadata Constructor

[image] [image]

Perforce .NET API
ClientMetadata Constructor
ClientMetadata Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClientMetadata()()()() | Initializes a new instance of the ClientMetadata class
Public method | ClientMetadata(String, String, String, String, String) | Initializes a new instance of the ClientMetadata class

See Also

ClientMetadata Class
ClientMetadata Members


ClientMetadata Constructor

[image]

Perforce .NET API
ClientMetadata Constructor
ClientMetadata Class See Also Send Feedback
Initializes a new instance of the ClientMetadata class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientMetadata()
Visual Basic
Public Sub New
Visual C++
public:
ClientMetadata()

See Also

ClientMetadata Class
ClientMetadata Overload


ClientMetadata Constructor (String, String, String, String, String)

[image]

Perforce .NET API
ClientMetadata Constructor (String, String, String, String, String)
ClientMetadata Class See Also Send Feedback
Initializes a new instance of the ClientMetadata class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientMetadata(
    string name,
    string hostname,
    string address,
    string currentdirectory,
    string root
)
Visual Basic
Public Sub New ( _
    name As String, _
    hostname As String, _
    address As String, _
    currentdirectory As String, _
    root As String _
)
Visual C++
public:
ClientMetadata(
    String^ name,
    String^ hostname,
    String^ address,
    String^ currentdirectory,
    String^ root
)

Parameters

name
Type: System..::..String
hostname
Type: System..::..String
address
Type: System..::..String
currentdirectory
Type: System..::..String
root
Type: System..::..String

See Also

ClientMetadata Class
ClientMetadata Overload


ClientMetadata Methods

[image] [image]

Perforce .NET API
ClientMetadata Methods
ClientMetadata Class See Also Send Feedback

The ClientMetadata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGetClientMetadataCmdTaggedOutput | Read the fields from the tagged output of an info command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientMetadata Class


FromGetClientMetadataCmdTaggedOutput Method

[image]

Perforce .NET API
ClientMetadata..::..FromGetClientMetadataCmdTaggedOutput Method
ClientMetadata Class See Also Send Feedback
Read the fields from the tagged output of an info command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromGetClientMetadataCmdTaggedOutput(
    TaggedObject objectInfo
)
Visual Basic
Public Sub FromGetClientMetadataCmdTaggedOutput ( _
    objectInfo As TaggedObject _
)
Visual C++
public:
void FromGetClientMetadataCmdTaggedOutput(
    TaggedObject^ objectInfo
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'info' command

See Also

ClientMetadata Class


ClientMetadata Properties

[image] [image]

Perforce .NET API
ClientMetadata Properties
ClientMetadata Class See Also Send Feedback

The ClientMetadata type exposes the following members.

Properties

 | Name | Description
Public property | Address |
Public property | CurrentDirectory |
Public property | HostName |
Public property | Name |
Public property | Root |

See Also

ClientMetadata Class


Address Property

[image]

Perforce .NET API
ClientMetadata..::..Address Property
ClientMetadata Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

See Also

ClientMetadata Class


CurrentDirectory Property

[image]

Perforce .NET API
ClientMetadata..::..CurrentDirectory Property
ClientMetadata Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string CurrentDirectory { get; set; }
Visual Basic
Public Property CurrentDirectory As String
    Get
    Set
Visual C++
public:
property String^ CurrentDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

ClientMetadata Class


HostName Property

[image]

Perforce .NET API
ClientMetadata..::..HostName Property
ClientMetadata Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string HostName { get; set; }
Visual Basic
Public Property HostName As String
    Get
    Set
Visual C++
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}

See Also

ClientMetadata Class


Name Property

[image]

Perforce .NET API
ClientMetadata..::..Name Property
ClientMetadata Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ClientMetadata Class


Root Property

[image]

Perforce .NET API
ClientMetadata..::..Root Property
ClientMetadata Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Root { get; set; }
Visual Basic
Public Property Root As String
    Get
    Set
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

See Also

ClientMetadata Class


ClientNameVersion Class

[image]

Perforce .NET API
ClientNameVersion Class
Members See Also Send Feedback
A revision specifier that is a client name.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ClientNameVersion : VersionSpec
Visual Basic
Public Class ClientNameVersion _
    Inherits VersionSpec
Visual C++
public ref class ClientNameVersion : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..ClientNameVersion

See Also

ClientNameVersion Members


ClientNameVersion Members

[image] [image]

Perforce .NET API
ClientNameVersion Members
ClientNameVersion Class Constructors Methods Properties See Also Send Feedback

The ClientNameVersion type exposes the following members.

Constructors

 | Name | Description
Public method | ClientNameVersion | Initializes a new instance of the ClientNameVersion class

Methods

 | Name | Description
Public method | Equals | Equals method for for ClientNameVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ClientNameVersion (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | Version | get Version as client name

See Also

ClientNameVersion Class


ClientNameVersion Constructor

[image]

Perforce .NET API
ClientNameVersion Constructor
ClientNameVersion Class See Also Send Feedback
Initializes a new instance of the ClientNameVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientNameVersion(
    string ClientName
)
Visual Basic
Public Sub New ( _
    ClientName As String _
)
Visual C++
public:
ClientNameVersion(
    String^ ClientName
)

Parameters

ClientName
Type: System..::..String
The client name.///

See Also

ClientNameVersion Class


ClientNameVersion Methods

[image] [image]

Perforce .NET API
ClientNameVersion Methods
ClientNameVersion Class See Also Send Feedback

The ClientNameVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for ClientNameVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ClientNameVersion (Overrides VersionSpec..::..ToString()()()().)

See Also

ClientNameVersion Class


Equals Method

[image]

Perforce .NET API
ClientNameVersion..::..Equals Method
ClientNameVersion Class See Also Send Feedback
Equals method for for ClientNameVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get client name

Return Value

True/False

See Also

ClientNameVersion Class


ToString Method

[image]

Perforce .NET API
ClientNameVersion..::..ToString Method
ClientNameVersion Class See Also Send Feedback
ToString method for for ClientNameVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String client name version

See Also

ClientNameVersion Class


ClientNameVersion Properties

[image] [image]

Perforce .NET API
ClientNameVersion Properties
ClientNameVersion Class See Also Send Feedback

The ClientNameVersion type exposes the following members.

Properties

 | Name | Description
Public property | Version | get Version as client name

See Also

ClientNameVersion Class


Version Property

[image]

Perforce .NET API
ClientNameVersion..::..Version Property
ClientNameVersion Class See Also Send Feedback
get Version as client name

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Version { get; private set; }
Visual Basic
Public Property Version As String
    Get
    Private Set
Visual C++
public:
property String^ Version {
    String^ get ();
    private: void set (String^ value);
}

See Also

ClientNameVersion Class


ClientOption Enumeration

[image]

Perforce .NET API
ClientOption Enumeration
See Also Send Feedback
Flags to configure the client behavior.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ClientOption
Visual Basic
<FlagsAttribute> _
Public Enumeration ClientOption
Visual C++
[FlagsAttribute]
public enum class ClientOption

Members

Member name | Value | Description
None | 0 | No options.
AllWrite | 1 | Leaves all files writable on the client; by default, only files opened by 'p4 edit' are writable. If set, files might be clobbered as a result of ignoring the clobber option.
Clobber | 2 | Permits 'p4 sync' to overwrite writable files on the client. noclobber is ignored if allwrite is set.
Compress | 4 | Compresses data sent between the client and server to speed up slow connections.
Locked | 8 | Allows only the client owner to use or change the client spec. Prevents the client spec from being deleted.
ModTime | 16 | Causes 'p4 sync' and 'p4 submit' to preserve file modification time, as with files with the +m type modifier. (See 'p4 help filetypes'.) With nomodtime, file timestamps are updated by sync and submit operations.
RmDir | 32 | Makes 'p4 sync' attempt to delete a workspace directory when all files in it are removed.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ClientPath Class

[image]

Perforce .NET API
ClientPath Class
Members See Also Send Feedback
A path spec in client syntax.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ClientPath : PathSpec
Visual Basic
Public Class ClientPath _
    Inherits PathSpec
Visual C++
public ref class ClientPath : public PathSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..PathSpec
Perforce.P4..::..ClientPath

See Also

ClientPath Members


ClientPath Members

[image] [image]

Perforce .NET API
ClientPath Members
ClientPath Class Constructors Methods Properties See Also Send Feedback

The ClientPath type exposes the following members.

Constructors

 | Name | Description
Public method | ClientPath | Initializes a new instance of the ClientPath class

Methods

 | Name | Description
Public method | Equals | (Overrides PathSpec..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName | (Inherited from PathSpec.)
Public method | GetFileName | (Inherited from PathSpec.)
Public method | GetHashCode | (Inherited from PathSpec.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot | (Inherited from PathSpec.)
Protected method | NormalizeLocal | (Inherited from PathSpec.)
Public method | ToString | (Inherited from PathSpec.)

Properties

 | Name | Description
Public property | Path | (Inherited from PathSpec.)

See Also

ClientPath Class


ClientPath Constructor

[image]

Perforce .NET API
ClientPath Constructor
ClientPath Class See Also Send Feedback
Initializes a new instance of the ClientPath class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientPath(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
ClientPath(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

ClientPath Class


ClientPath Methods

[image] [image]

Perforce .NET API
ClientPath Methods
ClientPath Class See Also Send Feedback

The ClientPath type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides PathSpec..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName | (Inherited from PathSpec.)
Public method | GetFileName | (Inherited from PathSpec.)
Public method | GetHashCode | (Inherited from PathSpec.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot | (Inherited from PathSpec.)
Protected method | NormalizeLocal | (Inherited from PathSpec.)
Public method | ToString | (Inherited from PathSpec.)

See Also

ClientPath Class


Equals Method

[image]

Perforce .NET API
ClientPath..::..Equals Method
ClientPath Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

ClientPath Class


ClientPath Properties

[image] [image]

Perforce .NET API
ClientPath Properties
ClientPath Class See Also Send Feedback

The ClientPath type exposes the following members.

Properties

 | Name | Description
Public property | Path | (Inherited from PathSpec.)

See Also

ClientPath Class


ClientsCmdFlags Enumeration

[image]

Perforce .NET API
ClientsCmdFlags Enumeration
See Also Send Feedback
Flags for the clients command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ClientsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration ClientsCmdFlags
Visual C++
[FlagsAttribute]
public enum class ClientsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeTime | 1 | The -t flag displays the time as well as the date.
IgnoreCase | 2 | The -e nameFilter flag lists workspaces with a name that matches the nameFilter pattern, for example: -e 'svr-dev-rel*'. -E makes the matching case-insensitive.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ClientsCmdOptions Class

[image]

Perforce .NET API
ClientsCmdOptions Class
Members See Also Send Feedback
Clients command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ClientsCmdOptions : Options
Visual Basic
Public Class ClientsCmdOptions _
    Inherits Options
Visual C++
public ref class ClientsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ClientsCmdOptions

See Also

ClientsCmdOptions Members


ClientsCmdOptions Members

[image] [image]

Perforce .NET API
ClientsCmdOptions Members
ClientsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ClientsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ClientsCmdOptions | Clients command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ClientsCmdOptions Class


ClientsCmdOptions Constructor

[image]

Perforce .NET API
ClientsCmdOptions Constructor
ClientsCmdOptions Class See Also Send Feedback
Clients command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientsCmdOptions(
    ClientsCmdFlags flags,
    string userName,
    string nameFilter,
    int maxItems,
    string stream
)
Visual Basic
Public Sub New ( _
    flags As ClientsCmdFlags, _
    userName As String, _
    nameFilter As String, _
    maxItems As Integer, _
    stream As String _
)
Visual C++
public:
ClientsCmdOptions(
    ClientsCmdFlags flags,
    String^ userName,
    String^ nameFilter,
    int maxItems,
    String^ stream
)

Parameters

flags
Type: Perforce.P4..::..ClientsCmdFlags
userName
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32
stream
Type: System..::..String

Return Value

Remarks

p4 help clients

clients -- Display list of clients
workspaces -- synonym for 'clients'

p4 clients [-t] [-u user] [[-e|-E] nameFilter -m max] [-S stream]
[-a | -s serverID]
p4 clients -U

Lists all client workspaces currently defined in the server.

The -t flag displays the time as well as the date.

The -u user flag lists client workspaces that are owned by the
specified user.

The -e nameFilter flag lists workspaces with a name that matches
the nameFilter pattern, for example: -e 'svr-dev-rel*'. The -e flag
uses the server's normal case-sensitivity rules. The -E flag makes
the matching case-insensitive, even on a case-sensitive server.

The -m max flag limits output to the specified number of workspaces.

The -S stream flag limits output to the client workspaces dedicated
to the stream.

The -U flag lists unloaded clients (see 'p4 help unload').

The -a flag specifies that all clients should be displayed, not just
those that are bound to this server.

The -s serverID flag specifies that only those clients bound to the
specified serverID should be displayed. On an Edge Server, the -s
flag defaults to the Edge Server's serverID.

See Also

ClientsCmdOptions Class


ClientsCmdOptions Methods

[image] [image]

Perforce .NET API
ClientsCmdOptions Methods
ClientsCmdOptions Class See Also Send Feedback

The ClientsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ClientsCmdOptions Class


ClientsCmdOptions Properties

[image] [image]

Perforce .NET API
ClientsCmdOptions Properties
ClientsCmdOptions Class See Also Send Feedback

The ClientsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ClientsCmdOptions Class


ClientSubmitOptions Class

[image]

Perforce .NET API
ClientSubmitOptions Class
Members See Also Send Feedback
Client options that define what to do with files upon submit.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ClientSubmitOptions
Visual Basic
Public Class ClientSubmitOptions
Visual C++
public ref class ClientSubmitOptions

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ClientSubmitOptions

See Also

ClientSubmitOptions Members


ClientSubmitOptions Members

[image] [image]

Perforce .NET API
ClientSubmitOptions Members
ClientSubmitOptions Class Constructors Methods Operators Properties See Also Send Feedback

The ClientSubmitOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ClientSubmitOptions()()()() | Initializes a new instance of the ClientSubmitOptions class
Public method | ClientSubmitOptions(String) | Initializes a new instance of the ClientSubmitOptions class
Public method | ClientSubmitOptions(Boolean, SubmitType) | Initializes a new instance of the ClientSubmitOptions class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse a client spec formatted string
Public method | ToString | Convert to a client spec formatted string (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (String to ClientSubmitOptions) |
Implicit Widening Implicit Implicit Implicit (ClientSubmitOptions to String) |

Properties

 | Name | Description
Public property | Reopen | Determines if the files is reopened upon submit.
Public property | SubmitType |

See Also

ClientSubmitOptions Class


ClientSubmitOptions Constructor

[image] [image]

Perforce .NET API
ClientSubmitOptions Constructor
ClientSubmitOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClientSubmitOptions()()()() | Initializes a new instance of the ClientSubmitOptions class
Public method | ClientSubmitOptions(String) | Initializes a new instance of the ClientSubmitOptions class
Public method | ClientSubmitOptions(Boolean, SubmitType) | Initializes a new instance of the ClientSubmitOptions class

See Also

ClientSubmitOptions Class
ClientSubmitOptions Members


ClientSubmitOptions Constructor

[image]

Perforce .NET API
ClientSubmitOptions Constructor
ClientSubmitOptions Class See Also Send Feedback
Initializes a new instance of the ClientSubmitOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientSubmitOptions()
Visual Basic
Public Sub New
Visual C++
public:
ClientSubmitOptions()

See Also

ClientSubmitOptions Class
ClientSubmitOptions Overload


ClientSubmitOptions Constructor (String)

[image]

Perforce .NET API
ClientSubmitOptions Constructor (String)
ClientSubmitOptions Class See Also Send Feedback
Initializes a new instance of the ClientSubmitOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientSubmitOptions(
    string spec
)
Visual Basic
Public Sub New ( _
    spec As String _
)
Visual C++
public:
ClientSubmitOptions(
    String^ spec
)

Parameters

spec
Type: System..::..String

See Also

ClientSubmitOptions Class
ClientSubmitOptions Overload


ClientSubmitOptions Constructor (Boolean, SubmitType)

[image]

Perforce .NET API
ClientSubmitOptions Constructor (Boolean, SubmitType)
ClientSubmitOptions Class See Also Send Feedback
Initializes a new instance of the ClientSubmitOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientSubmitOptions(
    bool reopen,
    SubmitType submitType
)
Visual Basic
Public Sub New ( _
    reopen As Boolean, _
    submitType As SubmitType _
)
Visual C++
public:
ClientSubmitOptions(
    bool reopen,
    SubmitType submitType
)

Parameters

reopen
Type: System..::..Boolean
submitType
Type: Perforce.P4..::..SubmitType

See Also

ClientSubmitOptions Class
ClientSubmitOptions Overload


ClientSubmitOptions Methods

[image] [image]

Perforce .NET API
ClientSubmitOptions Methods
ClientSubmitOptions Class See Also Send Feedback

The ClientSubmitOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse a client spec formatted string
Public method | ToString | Convert to a client spec formatted string (Overrides Object..::..ToString()()()().)

See Also

ClientSubmitOptions Class


Equals Method

[image]

Perforce .NET API
ClientSubmitOptions..::..Equals Method
ClientSubmitOptions Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

ClientSubmitOptions Class


Parse Method

[image]

Perforce .NET API
ClientSubmitOptions..::..Parse Method
ClientSubmitOptions Class See Also Send Feedback
Parse a client spec formatted string

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Parse(
    string spec
)
Visual Basic
Public Sub Parse ( _
    spec As String _
)
Visual C++
public:
void Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String

See Also

ClientSubmitOptions Class


ToString Method

[image]

Perforce .NET API
ClientSubmitOptions..::..ToString Method
ClientSubmitOptions Class See Also Send Feedback
Convert to a client spec formatted string

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

ClientSubmitOptions Class


ClientSubmitOptions Type Conversions

[image] [image]

Perforce .NET API
ClientSubmitOptions Type Conversions
ClientSubmitOptions Class See Also Send Feedback

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (String to ClientSubmitOptions) |
Implicit Widening Implicit Implicit Implicit (ClientSubmitOptions to String) |

See Also

ClientSubmitOptions Class


Implicit Conversion Operators

[image] [image]

Perforce .NET API
ClientSubmitOptions ImplicitWideningImplicitImplicitImplicit Conversion Operators
ClientSubmitOptions Class See Also Send Feedback

Overload List

Name | Description
Implicit Widening Implicit Implicit Implicit (String to ClientSubmitOptions) |
Implicit Widening Implicit Implicit Implicit (ClientSubmitOptions to String) |

See Also

ClientSubmitOptions Class
ClientSubmitOptions Members


Implicit Conversion (String to ClientSubmitOptions)

[image]

Perforce .NET API
ClientSubmitOptions ImplicitWideningImplicitImplicitImplicit Conversion (String to ClientSubmitOptions)
ClientSubmitOptions Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator ClientSubmitOptions (
    string s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As String _
) As ClientSubmitOptions
Visual C++
static implicit operator ClientSubmitOptions^ (
    String^ s
)

Parameters

s
Type: System..::..String

See Also

ClientSubmitOptions Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (ClientSubmitOptions to String)

[image]

Perforce .NET API
ClientSubmitOptions ImplicitWideningImplicitImplicitImplicit Conversion (ClientSubmitOptions to String)
ClientSubmitOptions Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator string (
    ClientSubmitOptions v
)
Visual Basic
Public Shared Widening Operator CType ( _
    v As ClientSubmitOptions _
) As String
Visual C++
static implicit operator String^ (
    ClientSubmitOptions^ v
)

Parameters

v
Type: Perforce.P4..::..ClientSubmitOptions

See Also

ClientSubmitOptions Class
ImplicitWideningImplicitImplicitImplicit Overload


ClientSubmitOptions Properties

[image] [image]

Perforce .NET API
ClientSubmitOptions Properties
ClientSubmitOptions Class See Also Send Feedback

The ClientSubmitOptions type exposes the following members.

Properties

 | Name | Description
Public property | Reopen | Determines if the files is reopened upon submit.
Public property | SubmitType |

See Also

ClientSubmitOptions Class


Reopen Property

[image]

Perforce .NET API
ClientSubmitOptions..::..Reopen Property
ClientSubmitOptions Class See Also Send Feedback
Determines if the files is reopened upon submit.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Reopen { get; set; }
Visual Basic
Public Property Reopen As Boolean
    Get
    Set
Visual C++
public:
property bool Reopen {
    bool get ();
    void set (bool value);
}

See Also

ClientSubmitOptions Class


SubmitType Property

[image]

Perforce .NET API
ClientSubmitOptions..::..SubmitType Property
ClientSubmitOptions Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SubmitType SubmitType { get; set; }
Visual Basic
Public Property SubmitType As SubmitType
    Get
    Set
Visual C++
public:
property SubmitType SubmitType {
    SubmitType get ();
    void set (SubmitType value);
}

See Also

ClientSubmitOptions Class


Connection Class

[image]

Perforce .NET API
Connection Class
Members See Also Send Feedback
Represents the logical connection between a specific Perforce Server instance and a specific client application.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Connection : IDisposable
Visual Basic
Public Class Connection _
    Implements IDisposable
Visual C++
public ref class Connection : IDisposable

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Connection

See Also

Connection Members


Connection Members

[image] [image]

Perforce .NET API
Connection Members
Connection Class Constructors Methods Properties Events See Also Send Feedback

The Connection type exposes the following members.

Constructors

 | Name | Description
Public method | Connection | Initializes a new instance of the Connection class

Methods

 | Name | Description
Public method | CancelCommand(UInt32) | Cancel a running command
Public method | CancelCommand(P4Command) | Cancel a running command
Public method | Connect |
Public method | CreateCommand | Create a P4Command that can be run on the connection
Public method | Disconnect()()()() |
Public method | Disconnect(Options) |
Public method | Dispose | Releases all resources used by the Connection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveTicket | Returns the ticket used by the current connection
Public method | GetExistingTicket | Get the existing ticket if any for a user on the secified server
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMapApi | Create a P4.P4MapApi object to be used on the current server connection
Public method | GetP4ConfigFile()()()() | The config file used by the connection (if any)
Public method | GetP4ConfigFile(String) | The config file that will be used by a given directory (if any)
Public method | GetP4EnvironmentVar | Get the value of an P4 environment variable
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFileIgnored | Is this file ignored based on the file specified by p4ignore (if any)
Public method | Login(String) | Automate the Login to the Perforce Server
Public method | Login(String, Options) | Login to the Perforce Server
Public method | Login(String, Boolean) |
Public method | Login(String, Options, String) | Run a Login on the Perforce Server
Public method | Logout | Logout of the Perforce server
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseConnection | Release the connection held by the bridge to the server. This will cause the bridge to call init before the next command is run, forcing it to reinitialize any cached connection settings.
Public method | SetClient |
Public method | SetP4EnvironmentVar | Set the value of an P4 environment variable
Public method | SetPassword(String, String) | Set the current user's password on the Perforce server.
Public method | SetPassword(String, String, String) | Set the a user's password on the Perforce server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Trust | Run the client side command trust
Public method | TrustAndConnect |

Properties

 | Name | Description
Public property | ApiLevel | What API level does the server support
Public property | CharacterSetName |
Public property | Client |
Public property | ClientMetadata |
Public property | CommandTimeout |
Public property | Credential |
Public property | CurrentWorkingDirectory |
Public property | KeepAlive | Callback to allow the client/user to cancel a long running command
Public property | KeepAliveDelay | Time for a command to run before allowing the client/user to cancel a long running command
Public property | LastResults | The results of the last command executed
Public property | Server |
Public property | Status |
Public property | UserName |

Events

 | Name | Description
Public event | CommandEcho |
Public event | ErrorReceived |
Public event | InfoResultsReceived |
Public event | TaggedOutputReceived |
Public event | TextResultsReceived |

See Also

Connection Class


Connection Constructor

[image]

Perforce .NET API
Connection Constructor
Connection Class See Also Send Feedback
Initializes a new instance of the Connection class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Connection(
    Server server
)
Visual Basic
Public Sub New ( _
    server As Server _
)
Visual C++
public:
Connection(
    Server^ server
)

Parameters

server
Type: Perforce.P4..::..Server

See Also

Connection Class


Connection Methods

[image] [image]

Perforce .NET API
Connection Methods
Connection Class See Also Send Feedback

The Connection type exposes the following members.

Methods

 | Name | Description
Public method | CancelCommand(UInt32) | Cancel a running command
Public method | CancelCommand(P4Command) | Cancel a running command
Public method | Connect |
Public method | CreateCommand | Create a P4Command that can be run on the connection
Public method | Disconnect()()()() |
Public method | Disconnect(Options) |
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveTicket | Returns the ticket used by the current connection
Public method | GetExistingTicket | Get the existing ticket if any for a user on the secified server
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMapApi | Create a P4.P4MapApi object to be used on the current server connection
Public method | GetP4ConfigFile()()()() | The config file used by the connection (if any)
Public method | GetP4ConfigFile(String) | The config file that will be used by a given directory (if any)
Public method | GetP4EnvironmentVar | Get the value of an P4 environment variable
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFileIgnored | Is this file ignored based on the file specified by p4ignore (if any)
Public method | Login(String) | Automate the Login to the Perforce Server
Public method | Login(String, Options) | Login to the Perforce Server
Public method | Login(String, Boolean) |
Public method | Login(String, Options, String) | Run a Login on the Perforce Server
Public method | Logout | Logout of the Perforce server
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReleaseConnection | Release the connection held by the bridge to the server. This will cause the bridge to call init before the next command is run, forcing it to reinitialize any cached connection settings.
Public method | SetClient |
Public method | SetP4EnvironmentVar | Set the value of an P4 environment variable
Public method | SetPassword(String, String) | Set the current user's password on the Perforce server.
Public method | SetPassword(String, String, String) | Set the a user's password on the Perforce server.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Trust | Run the client side command trust
Public method | TrustAndConnect |

See Also

Connection Class


CancelCommand Method

[image] [image]

Perforce .NET API
Connection..::..CancelCommand Method
Connection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CancelCommand(UInt32) | Cancel a running command
Public method | CancelCommand(P4Command) | Cancel a running command

See Also

Connection Class
Connection Members


CancelCommand Method (UInt32)

[image]

Perforce .NET API
Connection..::..CancelCommand Method (UInt32)
Connection Class See Also Send Feedback
Cancel a running command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void CancelCommand(
    uint CmdId
)
Visual Basic
Public Sub CancelCommand ( _
    CmdId As UInteger _
)
Visual C++
public:
void CancelCommand(
    unsigned int CmdId
)

Parameters

CmdId
Type: System..::..UInt32
Unique Id for the run of the command (P4Command.CommandId)

See Also

Connection Class
CancelCommand Overload


CancelCommand Method (P4Command)

[image]

Perforce .NET API
Connection..::..CancelCommand Method (P4Command)
Connection Class See Also Send Feedback
Cancel a running command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void CancelCommand(
    P4Command Cmd
)
Visual Basic
Public Sub CancelCommand ( _
    Cmd As P4Command _
)
Visual C++
public:
void CancelCommand(
    P4Command^ Cmd
)

Parameters

Cmd
Type: Perforce.P4..::..P4Command

See Also

Connection Class
CancelCommand Overload


Connect Method

[image]

Perforce .NET API
Connection..::..Connect Method
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Connect(
    Options options
)
Visual Basic
Public Function Connect ( _
    options As Options _
) As Boolean
Visual C++
public:
bool Connect(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

See Also

Connection Class


CreateCommand Method

[image]

Perforce .NET API
Connection..::..CreateCommand Method
Connection Class See Also Send Feedback
Create a P4Command that can be run on the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command CreateCommand(
    string cmd,
    bool tagged,
    params string[] args
)
Visual Basic
Public Function CreateCommand ( _
    cmd As String, _
    tagged As Boolean, _
    ParamArray args As String() _
) As P4Command
Visual C++
public:
P4Command^ CreateCommand(
    String^ cmd,
    bool tagged,
    ... array<String^>^ args
)

Parameters

cmd
Type: System..::..String
Command name, i.e. 'sync'
tagged
Type: System..::..Boolean
Flag to create tggged output
args
Type: array< System..::..String >[]()[][]
The arguments for the command

Return Value

See Also

Connection Class


Disconnect Method

[image] [image]

Perforce .NET API
Connection..::..Disconnect Method
Connection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Disconnect()()()() |
Public method | Disconnect(Options) |

See Also

Connection Class
Connection Members


Disconnect Method

[image]

Perforce .NET API
Connection..::..Disconnect Method
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Disconnect()
Visual Basic
Public Function Disconnect As Boolean
Visual C++
public:
bool Disconnect()

See Also

Connection Class
Disconnect Overload


Disconnect Method (Options)

[image]

Perforce .NET API
Connection..::..Disconnect Method (Options)
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Disconnect(
    Options options
)
Visual Basic
Public Function Disconnect ( _
    options As Options _
) As Boolean
Visual C++
public:
bool Disconnect(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

See Also

Connection Class
Disconnect Overload


Dispose Method

[image]

Perforce .NET API
Connection..::..Dispose Method
Connection Class See Also Send Feedback
Releases all resources used by the Connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Connection Class


GetActiveTicket Method

[image]

Perforce .NET API
Connection..::..GetActiveTicket Method
Connection Class See Also Send Feedback
Returns the ticket used by the current connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetActiveTicket()
Visual Basic
Public Function GetActiveTicket As String
Visual C++
public:
String^ GetActiveTicket()

Return Value

See Also

Connection Class


GetExistingTicket Method

[image]

Perforce .NET API
Connection..::..GetExistingTicket Method
Connection Class See Also Send Feedback
Get the existing ticket if any for a user on the secified server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetExistingTicket(
    string user
)
Visual Basic
Public Function GetExistingTicket ( _
    user As String _
) As String
Visual C++
public:
String^ GetExistingTicket(
    String^ user
)

Parameters

user
Type: System..::..String
user name

Return Value

See Also

Connection Class


GetMapApi Method

[image]

Perforce .NET API
Connection..::..GetMapApi Method
Connection Class See Also Send Feedback
Create a P4.P4MapApi object to be used on the current server connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4MapApi GetMapApi()
Visual Basic
Public Function GetMapApi As P4MapApi
Visual C++
public:
P4MapApi^ GetMapApi()

Return Value

See Also

Connection Class


GetP4ConfigFile Method

[image] [image]

Perforce .NET API
Connection..::..GetP4ConfigFile Method
Connection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetP4ConfigFile()()()() | The config file used by the connection (if any)
Public method | GetP4ConfigFile(String) | The config file that will be used by a given directory (if any)

See Also

Connection Class
Connection Members


GetP4ConfigFile Method

[image]

Perforce .NET API
Connection..::..GetP4ConfigFile Method
Connection Class See Also Send Feedback
The config file used by the connection (if any)

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetP4ConfigFile()
Visual Basic
Public Function GetP4ConfigFile As String
Visual C++
public:
String^ GetP4ConfigFile()

See Also

Connection Class
GetP4ConfigFile Overload


GetP4ConfigFile Method (String)

[image]

Perforce .NET API
Connection..::..GetP4ConfigFile Method (String)
Connection Class See Also Send Feedback
The config file that will be used by a given directory (if any)

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetP4ConfigFile(
    string cwd
)
Visual Basic
Public Function GetP4ConfigFile ( _
    cwd As String _
) As String
Visual C++
public:
String^ GetP4ConfigFile(
    String^ cwd
)

Parameters

cwd
Type: System..::..String

See Also

Connection Class
GetP4ConfigFile Overload


GetP4EnvironmentVar Method

[image]

Perforce .NET API
Connection..::..GetP4EnvironmentVar Method
Connection Class See Also Send Feedback
Get the value of an P4 environment variable

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetP4EnvironmentVar(
    string var
)
Visual Basic
Public Function GetP4EnvironmentVar ( _
    var As String _
) As String
Visual C++
public:
String^ GetP4EnvironmentVar(
    String^ var
)

Parameters

var
Type: System..::..String

Return Value

Remarks

equivalent of command line "p4 set var"

See Also

Connection Class


IsFileIgnored Method

[image]

Perforce .NET API
Connection..::..IsFileIgnored Method
Connection Class See Also Send Feedback
Is this file ignored based on the file specified by p4ignore (if any)

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsFileIgnored(
    string path
)
Visual Basic
Public Function IsFileIgnored ( _
    path As String _
) As Boolean
Visual C++
public:
bool IsFileIgnored(
    String^ path
)

Parameters

path
Type: System..::..String

Return Value

See Also

Connection Class


Login Method

[image] [image]

Perforce .NET API
Connection..::..Login Method
Connection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Login(String) | Automate the Login to the Perforce Server
Public method | Login(String, Options) | Login to the Perforce Server
Public method | Login(String, Boolean) |
Public method | Login(String, Options, String) | Run a Login on the Perforce Server

See Also

Connection Class
Connection Members


Login Method (String)

[image]

Perforce .NET API
Connection..::..Login Method (String)
Connection Class See Also Send Feedback
Automate the Login to the Perforce Server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Credential Login(
    string password
)
Visual Basic
Public Function Login ( _
    password As String _
) As Credential
Visual C++
public:
Credential^ Login(
    String^ password
)

Parameters

password
Type: System..::..String
User' password

Return Value

Success/Failure

Remarks

Runs the login process. If the server is using ticket based authentication, actually runs the logon three times. Once to login and update the ticket file, once to get the ticket from the server and finally once to get the ticket expiration data.

See Also

Connection Class
Login Overload


Login Method (String, Options)

[image]

Perforce .NET API
Connection..::..Login Method (String, Options)
Connection Class See Also Send Feedback
Login to the Perforce Server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Credential Login(
    string password,
    Options options
)
Visual Basic
Public Function Login ( _
    password As String, _
    options As Options _
) As Credential
Visual C++
public:
Credential^ Login(
    String^ password,
    Options^ options
)

Parameters

password
Type: System..::..String
User' password
options
Type: Perforce.P4..::..Options
Login options (see remarks in help file)

Return Value

Success/Failure

Remarks

p4 help login

login -- Log in to Perforce by obtaining a session ticket

p4 login [-a -p] [-h <host>] [user]
p4 login [-s]

The login command enables a user to access Perforce until the session
expires or the user logs out.

When a user logs in to Perforce, they are prompted for a password
If they enter the correct password, they are issued a ticket. The
ticket expires when the default timeout value has been reached and
is valid only for the host machine where the 'login' command was
executed (see below for exception).

The ticket can be used anywhere that a password can be used.

Example: p4 -P <ticket value> changes -m1

The -a flag causes the server to issue a ticket that is valid on all
host machines.

The -h flag causes the server to issue a ticket that is valid on the
specified host (IP address). This flag is typically used together
with the -p flag to acquire a ticket that can be used on a different
machine.

The -p flag displays the ticket, but does not store it on the client
machine.

The -s flag displays the status of the current ticket (if there is
one).

Specifying a username as an argument to 'p4 login' requires 'super'
access, which is granted by 'p4 protect'. In this case, 'p4 login'
does not prompt for the password (you must already be logged in).

See Also

Connection Class
Login Overload


Login Method (String, Boolean)

[image]

Perforce .NET API
Connection..::..Login Method (String, Boolean)
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Credential Login(
    string password,
    bool AllHostTicket
)
Visual Basic
Public Function Login ( _
    password As String, _
    AllHostTicket As Boolean _
) As Credential
Visual C++
public:
Credential^ Login(
    String^ password,
    bool AllHostTicket
)

Parameters

password
Type: System..::..String
AllHostTicket
Type: System..::..Boolean

See Also

Connection Class
Login Overload


Login Method (String, Options, String)

[image]

Perforce .NET API
Connection..::..Login Method (String, Options, String)
Connection Class See Also Send Feedback
Run a Login on the Perforce Server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Credential Login(
    string password,
    Options options,
    string user
)
Visual Basic
Public Function Login ( _
    password As String, _
    options As Options, _
    user As String _
) As Credential
Visual C++
public:
Credential^ Login(
    String^ password,
    Options^ options,
    String^ user
)

Parameters

password
Type: System..::..String
User' password
options
Type: Perforce.P4..::..Options
Login options (see remarks in help file)Login as user (see remarks in help file)
user
Type: System..::..String

Return Value

Success/Failure

Remarks

p4 help login

login -- Log in to Perforce by obtaining a session ticket

p4 login [-a -p] [-h <host>] [user]
p4 login [-s]

The login command enables a user to access Perforce until the session
expires or the user logs out.

When a user logs in to Perforce, they are prompted for a password
If they enter the correct password, they are issued a ticket. The
ticket expires when the default timeout value has been reached and
is valid only for the host machine where the 'login' command was
executed (see below for exception).

The ticket can be used anywhere that a password can be used.

Example: p4 -P <ticket value> changes -m1

The -a flag causes the server to issue a ticket that is valid on all
host machines.

The -h flag causes the server to issue a ticket that is valid on the
specified host (IP address). This flag is typically used together
with the -p flag to acquire a ticket that can be used on a different
machine.

The -p flag displays the ticket, but does not store it on the client
machine.

The -s flag displays the status of the current ticket (if there is
one).

Specifying a username as an argument to 'p4 login' requires 'super'
access, which is granted by 'p4 protect'. In this case, 'p4 login'
does not prompt for the password (you must already be logged in).

See Also

Connection Class
Login Overload


Logout Method

[image]

Perforce .NET API
Connection..::..Logout Method
Connection Class See Also Send Feedback
Logout of the Perforce server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Logout(
    Options options
)
Visual Basic
Public Function Logout ( _
    options As Options _
) As Boolean
Visual C++
public:
bool Logout(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options
Logout options (see remarks in help file)

Return Value

Success/Failure

Remarks

p4 help logout

logout -- Log out from Perforce by removing or invalidating a ticket.

p4 logout [-a] [user]

The logout command removes the ticket on the client. To resume using
Perforce, the user must log in again.

If you are logged in to Perforce from more than one machine, you can
log out of Perforce from all machines from which you were logged in
by specifying the -a flag. The -a flag invalidates the ticket on the
server. All of your Perforce tickets are invalidated and you are
logged out.

Specifying a username as an argument to 'p4 logout' requires 'super'
access, which is granted by 'p4 protect'. Note that the '-a' flag
must be used to effectively log out a user who has a valid ticket on
another machine.

See Also

Connection Class


ReleaseConnection Method

[image]

Perforce .NET API
Connection..::..ReleaseConnection Method
Connection Class See Also Send Feedback
Release the connection held by the bridge to the server. This will cause the bridge to call init before the next command is run, forcing it to reinitialize any cached connection settings.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void ReleaseConnection()
Visual Basic
Public Sub ReleaseConnection
Visual C++
public:
void ReleaseConnection()

See Also

Connection Class


SetClient Method

[image]

Perforce .NET API
Connection..::..SetClient Method
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void SetClient(
    string clientId
)
Visual Basic
Public Sub SetClient ( _
    clientId As String _
)
Visual C++
public:
void SetClient(
    String^ clientId
)

Parameters

clientId
Type: System..::..String

See Also

Connection Class


SetP4EnvironmentVar Method

[image]

Perforce .NET API
Connection..::..SetP4EnvironmentVar Method
Connection Class See Also Send Feedback
Set the value of an P4 environment variable

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void SetP4EnvironmentVar(
    string var,
    string val
)
Visual Basic
Public Sub SetP4EnvironmentVar ( _
    var As String, _
    val As String _
)
Visual C++
public:
void SetP4EnvironmentVar(
    String^ var,
    String^ val
)

Parameters

var
Type: System..::..String
val
Type: System..::..String

Remarks

equivalent ofcommand line "p4 set var=val"

See Also

Connection Class


SetPassword Method

[image] [image]

Perforce .NET API
Connection..::..SetPassword Method
Connection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPassword(String, String) | Set the current user's password on the Perforce server.
Public method | SetPassword(String, String, String) | Set the a user's password on the Perforce server.

See Also

Connection Class
Connection Members


SetPassword Method (String, String)

[image]

Perforce .NET API
Connection..::..SetPassword Method (String, String)
Connection Class See Also Send Feedback
Set the current user's password on the Perforce server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool SetPassword(
    string OldPassword,
    string NewPassword
)
Visual Basic
Public Function SetPassword ( _
    OldPassword As String, _
    NewPassword As String _
) As Boolean
Visual C++
public:
bool SetPassword(
    String^ OldPassword,
    String^ NewPassword
)

Parameters

OldPassword
Type: System..::..String
User's old password
NewPassword
Type: System..::..String
User's new password

Return Value

Success/Failure

Remarks

p4 help passwd

passwd -- Set the user's password on the server (and Windows client)

p4 passwd [-O oldPassword -P newPassword] [user]

'p4 passwd' sets the user's password on the server.

After a password is set for a user, the same password must be set on
the client in the environment variable $P4PASSWD to enable the user
to use all Perforce client applications on that machine. (On Windows,
you can use 'p4 passwd' to configure the password in the environment.)

'p4 passwd' prompts for both the old password and the new password
with character echoing turned off. To delete the password, set it to
an empty string.

The -O flag provides the old password, avoiding prompting. If you
specify -O, you must also specify -P.

The -P flag provides the new password, avoiding prompting.

If you are using ticket-based authentication, changing your password
automatically invalidates all of your tickets and logs you out.

Specifying a username as an argument to 'p4 passwd' requires 'super'
access granted by 'p4 protect'.

See Also

Connection Class
SetPassword Overload


SetPassword Method (String, String, String)

[image]

Perforce .NET API
Connection..::..SetPassword Method (String, String, String)
Connection Class See Also Send Feedback
Set the a user's password on the Perforce server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool SetPassword(
    string OldPassword,
    string NewPassword,
    string User
)
Visual Basic
Public Function SetPassword ( _
    OldPassword As String, _
    NewPassword As String, _
    User As String _
) As Boolean
Visual C++
public:
bool SetPassword(
    String^ OldPassword,
    String^ NewPassword,
    String^ User
)

Parameters

OldPassword
Type: System..::..String
User's old password
NewPassword
Type: System..::..String
User's new password
User
Type: System..::..String
User receiving new password

Return Value

Success/Failure

Remarks

p4 help passwd

passwd -- Set the user's password on the server (and Windows client)

p4 passwd [-O oldPassword -P newPassword] [user]

'p4 passwd' sets the user's password on the server.

After a password is set for a user, the same password must be set on
the client in the environment variable $P4PASSWD to enable the user
to use all Perforce client applications on that machine. (On Windows,
you can use 'p4 passwd' to configure the password in the environment.)

'p4 passwd' prompts for both the old password and the new password
with character echoing turned off. To delete the password, set it to
an empty string.

The -O flag provides the old password, avoiding prompting. If you
specify -O, you must also specify -P.

The -P flag provides the new password, avoiding prompting.

If you are using ticket-based authentication, changing your password
automatically invalidates all of your tickets and logs you out.

Specifying a username as an argument to 'p4 passwd' requires 'super'
access granted by 'p4 protect'.

See Also

Connection Class
SetPassword Overload


Trust Method

[image]

Perforce .NET API
Connection..::..Trust Method
Connection Class See Also Send Feedback
Run the client side command trust

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Trust(
    Options options,
    string fingerprint
)
Visual Basic
Public Function Trust ( _
    options As Options, _
    fingerprint As String _
) As Boolean
Visual C++
public:
bool Trust(
    Options^ options,
    String^ fingerprint
)

Parameters

options
Type: Perforce.P4..::..Options
trust options (see remarks in help file)
fingerprint
Type: System..::..String

Return Value

Success/Failure

Remarks

p4 trust -h

trust -- Establish trust of an SSL connection

p4 trust [ -l -y -n -d -f -r -i <fingerprint> ]

Establish trust of an SSL connection. This client command manages
the p4 trust file. This file contains fingerprints of the keys
received on ssl connections. When an SSL connection is made, this
file is examined to determine if the SSL connection has been used
before and if the key is the same as a previously seen key for that
connection. Establishing trust with a connection prevents undetected
communication interception (man-in-the-middle) attacks.

Most options are mutually exclusive. Only the -r and -f options
can be combined with the others.

The -l flag lists existing known fingerprints.

Without options, this command will make a connection to a server
and examine the key if present, if one cannot be found this command
will show a fingerprint and ask if this connection should be trusted.
If a fingerprint exists and does not match, an error that a possible
security problems exists will be displayed.

The -y flag will cause prompts to be automatically accepted.

The -n flag will cause prompts to be automatically refused.

The -d flag will remove an existing trusted fingerprint of a connection.

The -f flag will force the replacement of a mismatched fingerprint.

The -i flag will allow a specific fingerprint to be installed.

The -r flag specifies that a replacement fingerprint is to be
affected. Replacement fingerprints can be used in anticipation
of a server replacing its key. If a replacement fingerprint
exists for a connection and the primary fingerprint does not match
while the replacement fnigerprint does, the replacement fingerprint
will replace the primary. This flag can be combined with -l, -i,
or -d.

See Also

Connection Class


TrustAndConnect Method

[image]

Perforce .NET API
Connection..::..TrustAndConnect Method
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool TrustAndConnect(
    Options options,
    string trustFlag,
    string fingerprint
)
Visual Basic
Public Function TrustAndConnect ( _
    options As Options, _
    trustFlag As String, _
    fingerprint As String _
) As Boolean
Visual C++
public:
bool TrustAndConnect(
    Options^ options,
    String^ trustFlag,
    String^ fingerprint
)

Parameters

options
Type: Perforce.P4..::..Options
trustFlag
Type: System..::..String
fingerprint
Type: System..::..String

See Also

Connection Class


Connection Properties

[image] [image]

Perforce .NET API
Connection Properties
Connection Class See Also Send Feedback

The Connection type exposes the following members.

Properties

 | Name | Description
Public property | ApiLevel | What API level does the server support
Public property | CharacterSetName |
Public property | Client |
Public property | ClientMetadata |
Public property | CommandTimeout |
Public property | Credential |
Public property | CurrentWorkingDirectory |
Public property | KeepAlive | Callback to allow the client/user to cancel a long running command
Public property | KeepAliveDelay | Time for a command to run before allowing the client/user to cancel a long running command
Public property | LastResults | The results of the last command executed
Public property | Server |
Public property | Status |
Public property | UserName |

See Also

Connection Class


ApiLevel Property

[image]

Perforce .NET API
Connection..::..ApiLevel Property
Connection Class See Also Send Feedback
What API level does the server support

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ApiLevel { get; }
Visual Basic
Public ReadOnly Property ApiLevel As Integer
    Get
Visual C++
public:
property int ApiLevel {
    int get ();
}

See Also

Connection Class


CharacterSetName Property

[image]

Perforce .NET API
Connection..::..CharacterSetName Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string CharacterSetName { get; }
Visual Basic
Public ReadOnly Property CharacterSetName As String
    Get
Visual C++
public:
property String^ CharacterSetName {
    String^ get ();
}

See Also

Connection Class


Client Property

[image]

Perforce .NET API
Connection..::..Client Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Client Client { get; set; }
Visual Basic
Public Property Client As Client
    Get
    Set
Visual C++
public:
property Client^ Client {
    Client^ get ();
    void set (Client^ value);
}

See Also

Connection Class


ClientMetadata Property

[image]

Perforce .NET API
Connection..::..ClientMetadata Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientMetadata ClientMetadata { get; private set; }
Visual Basic
Public Property ClientMetadata As ClientMetadata
    Get
    Private Set
Visual C++
public:
property ClientMetadata^ ClientMetadata {
    ClientMetadata^ get ();
    private: void set (ClientMetadata^ value);
}

See Also

Connection Class


CommandTimeout Property

[image]

Perforce .NET API
Connection..::..CommandTimeout Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TimeSpan CommandTimeout { get; set; }
Visual Basic
Public Property CommandTimeout As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan CommandTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}

See Also

Connection Class


Credential Property

[image]

Perforce .NET API
Connection..::..Credential Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Credential Credential { get; set; }
Visual Basic
Public Property Credential As Credential
    Get
    Set
Visual C++
public:
property Credential^ Credential {
    Credential^ get ();
    void set (Credential^ value);
}

See Also

Connection Class


CurrentWorkingDirectory Property

[image]

Perforce .NET API
Connection..::..CurrentWorkingDirectory Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string CurrentWorkingDirectory { get; set; }
Visual Basic
Public Property CurrentWorkingDirectory As String
    Get
    Set
Visual C++
public:
property String^ CurrentWorkingDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

Connection Class


KeepAlive Property

[image]

Perforce .NET API
Connection..::..KeepAlive Property
Connection Class See Also Send Feedback
Callback to allow the client/user to cancel a long running command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IKeepAlive KeepAlive { get; set; }
Visual Basic
Public Property KeepAlive As IKeepAlive
    Get
    Set
Visual C++
public:
property IKeepAlive^ KeepAlive {
    IKeepAlive^ get ();
    void set (IKeepAlive^ value);
}

See Also

Connection Class


KeepAliveDelay Property

[image]

Perforce .NET API
Connection..::..KeepAliveDelay Property
Connection Class See Also Send Feedback
Time for a command to run before allowing the client/user to cancel a long running command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TimeSpan KeepAliveDelay { get; set; }
Visual Basic
Public Property KeepAliveDelay As TimeSpan
    Get
    Set
Visual C++
public:
property TimeSpan KeepAliveDelay {
    TimeSpan get ();
    void set (TimeSpan value);
}

See Also

Connection Class


LastResults Property

[image]

Perforce .NET API
Connection..::..LastResults Property
Connection Class See Also Send Feedback
The results of the last command executed

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandResult LastResults { get; }
Visual Basic
Public ReadOnly Property LastResults As P4CommandResult
    Get
Visual C++
public:
property P4CommandResult^ LastResults {
    P4CommandResult^ get ();
}

See Also

Connection Class


Server Property

[image]

Perforce .NET API
Connection..::..Server Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Server Server { get; private set; }
Visual Basic
Public Property Server As Server
    Get
    Private Set
Visual C++
public:
property Server^ Server {
    Server^ get ();
    private: void set (Server^ value);
}

See Also

Connection Class


Status Property

[image]

Perforce .NET API
Connection..::..Status Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ConnectionStatus Status { get; set; }
Visual Basic
Public Property Status As ConnectionStatus
    Get
    Set
Visual C++
public:
property ConnectionStatus Status {
    ConnectionStatus get ();
    void set (ConnectionStatus value);
}

See Also

Connection Class


UserName Property

[image]

Perforce .NET API
Connection..::..UserName Property
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

Connection Class


Connection Events

[image] [image]

Perforce .NET API
Connection Events
Connection Class See Also Send Feedback

The Connection type exposes the following members.

Events

 | Name | Description
Public event | CommandEcho |
Public event | ErrorReceived |
Public event | InfoResultsReceived |
Public event | TaggedOutputReceived |
Public event | TextResultsReceived |

See Also

Connection Class


CommandEcho Event

[image]

Perforce .NET API
Connection..::..CommandEcho Event
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..CommandEchoDelegate CommandEcho
Visual Basic
Public Event CommandEcho As P4Server..::..CommandEchoDelegate
Visual C++
public:
 event P4Server..::..CommandEchoDelegate^ CommandEcho {
    void add (P4Server..::..CommandEchoDelegate^ value);
    void remove (P4Server..::..CommandEchoDelegate^ value);
}

See Also

Connection Class


ErrorReceived Event

[image]

Perforce .NET API
Connection..::..ErrorReceived Event
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..ErrorDelegate ErrorReceived
Visual Basic
Public Event ErrorReceived As P4Server..::..ErrorDelegate
Visual C++
public:
 event P4Server..::..ErrorDelegate^ ErrorReceived {
    void add (P4Server..::..ErrorDelegate^ value);
    void remove (P4Server..::..ErrorDelegate^ value);
}

See Also

Connection Class


InfoResultsReceived Event

[image]

Perforce .NET API
Connection..::..InfoResultsReceived Event
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..InfoResultsDelegate InfoResultsReceived
Visual Basic
Public Event InfoResultsReceived As P4Server..::..InfoResultsDelegate
Visual C++
public:
 event P4Server..::..InfoResultsDelegate^ InfoResultsReceived {
    void add (P4Server..::..InfoResultsDelegate^ value);
    void remove (P4Server..::..InfoResultsDelegate^ value);
}

See Also

Connection Class


TaggedOutputReceived Event

[image]

Perforce .NET API
Connection..::..TaggedOutputReceived Event
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..TaggedOutputDelegate TaggedOutputReceived
Visual Basic
Public Event TaggedOutputReceived As P4Server..::..TaggedOutputDelegate
Visual C++
public:
 event P4Server..::..TaggedOutputDelegate^ TaggedOutputReceived {
    void add (P4Server..::..TaggedOutputDelegate^ value);
    void remove (P4Server..::..TaggedOutputDelegate^ value);
}

See Also

Connection Class


TextResultsReceived Event

[image]

Perforce .NET API
Connection..::..TextResultsReceived Event
Connection Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..TextResultsDelegate TextResultsReceived
Visual Basic
Public Event TextResultsReceived As P4Server..::..TextResultsDelegate
Visual C++
public:
 event P4Server..::..TextResultsDelegate^ TextResultsReceived {
    void add (P4Server..::..TextResultsDelegate^ value);
    void remove (P4Server..::..TextResultsDelegate^ value);
}

See Also

Connection Class


ConnectionStatus Enumeration

[image]

Perforce .NET API
ConnectionStatus Enumeration
See Also Send Feedback
Flags for the server connection status.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ConnectionStatus
Visual Basic
<FlagsAttribute> _
Public Enumeration ConnectionStatus
Visual C++
[FlagsAttribute]
public enum class ConnectionStatus

Members

Member name | Value | Description
Disconnected | 0 | Disconnected from server.
Connected | 1 | Connected to server.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


CopyFilesCmdFlags Enumeration

[image]

Perforce .NET API
CopyFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the copy command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum CopyFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration CopyFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class CopyFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Preview | 1 | The -n flag displays a preview of the copy, without actually doing anything.
Virtual | 2 | The -v flag causes a 'virtual' copy that does not modify client workspace files. After submitting a virtual integration, 'p4 sync' can be used to update the workspace.
Reverse | 4 | The -r flag causes the direction of the copy to be reversed when used with a branch (-b) or stream (-S) copy.
Force | 8 | The -F flag can be used with -S to force copying even though the stream does not expect a copy to occur in the direction indicated. Normally 'p4 copy' enforces the expected flow of change dictated by the stream's spec. The 'p4 istat' command summarizes a stream's expected flow of change.
SourceBranch | 16 | The -s flag can be used with -b to cause fromFile to be treated as the source, and both sides of the user-defined branch view to be treated as the target, per the branch view mapping. Optional toFile arguments may be given to further restrict the scope of the target file set. -r is ignored when -s is used.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


CopyFilesCmdOptions Class

[image]

Perforce .NET API
CopyFilesCmdOptions Class
Members See Also Send Feedback
Copy command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class CopyFilesCmdOptions : Options
Visual Basic
Public Class CopyFilesCmdOptions _
    Inherits Options
Visual C++
public ref class CopyFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..CopyFilesCmdOptions

See Also

CopyFilesCmdOptions Members


CopyFilesCmdOptions Members

[image] [image]

Perforce .NET API
CopyFilesCmdOptions Members
CopyFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The CopyFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CopyFilesCmdOptions | Copy command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

CopyFilesCmdOptions Class


CopyFilesCmdOptions Constructor

[image]

Perforce .NET API
CopyFilesCmdOptions Constructor
CopyFilesCmdOptions Class See Also Send Feedback
Copy command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public CopyFilesCmdOptions(
    CopyFilesCmdFlags flags,
    string branchName,
    string streamName,
    string parentStream,
    int changelistId,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As CopyFilesCmdFlags, _
    branchName As String, _
    streamName As String, _
    parentStream As String, _
    changelistId As Integer, _
    maxItems As Integer _
)
Visual C++
public:
CopyFilesCmdOptions(
    CopyFilesCmdFlags flags,
    String^ branchName,
    String^ streamName,
    String^ parentStream,
    int changelistId,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..CopyFilesCmdFlags
branchName
Type: System..::..String
streamName
Type: System..::..String
parentStream
Type: System..::..String
changelistId
Type: System..::..Int32
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help copy

copy -- Copy one set of files to another

p4 copy [options] fromFile[rev] toFile
p4 copy [options] -b branch [-r] [toFile[rev] ...]
p4 copy [options] -b branch -s fromFile[rev] [toFile ...]
p4 copy [options] -S stream [-P parent] [-F] [-r] [toFile[rev] ...]

options: -c changelist# -f -n -v -m max -q

'p4 copy' copies one set of files (the 'source') into another (the
'target').

Using the client workspace as a staging area, 'p4 copy' makes the
target identical to the source by branching, replacing, or deleting
files. 'p4 submit' submits copied files to the depot. 'p4 revert'
can be used to revert copied files instead of submitting them. The
history of copied files can be shown with 'p4 filelog' or 'p4
integrated'.

Target files that are already identical to the source, or that are
outside of the client view, are not affected by 'p4 copy'. Opened,
non-identical target files cause 'p4 copy' to exit with a warning.
When 'p4 copy' creates or modifies files in the workspace, it leaves
them read-only; 'p4 edit' can make them writable. Files opened by
'p4 copy' do not need to be resolved.

Source and target files (fromFile and toFile) can be specified on
the 'p4 copy' command line or through a branch view. On the command
line, fromFile is the source file set and toFile is the target file
set. With a branch view, one or more toFile arguments can be given
to limit the scope of the target file set.

A revision specifier can be used to select the revision to copy; by
default, the head revision is copied. The revision specifier can be
used on fromFile, or on toFile, but not on both. When used on toFile,
it refers to source revisions, not to target revisions. A range may
not be used as a revision specifier. For revision syntax, see 'p4
help revisions'.

The -S flag makes 'p4 copy' copy from a stream to its parent.
Use -r with -S to reverse the copy direction. Note that to submit
copied stream files, the current client must be switched to the
target stream, or to a virtual child stream of the target stream.
The -S flag causes 'p4 copy' to use a generated branch view that
maps the stream to its parent. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. The -S flag also makes 'p4 copy' respect a stream's flow.

The -F flag can be used with -S to force copying against a stream's
expected flow. It can also force -S to generate a branch view based
on a virtual stream; the mapping itself refers to the underlying
real stream.

The -b flag makes 'p4 copy' use a user-defined branch view. (See
'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the user-defined branch view to be
treated as the target, per the branch view mapping. Optional toFile
arguments may be given to further restrict the scope of the target
file set. -r is ignored when -s is used.

The -c changelist# flag opens files in the designated (numbered)
pending changelist instead of the default changelist.

The -f flag forces the creation of extra revisions in order to
explicitly record that files have been copied. Deleted source files
will be copied if they do not exist in the target, and files that are
already identical will be copied if they are not connected by existing
integration records.

The -n flag displays a preview of the copy, without actually doing
anything.

The -m flag limits the actions to the first 'max' number of files.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

The -v flag causes a 'virtual' copy that does not modify client
workspace files. After submitting a virtual integration, 'p4 sync'
can be used to update the workspace.

'p4 copy' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

CopyFilesCmdOptions Class


CopyFilesCmdOptions Methods

[image] [image]

Perforce .NET API
CopyFilesCmdOptions Methods
CopyFilesCmdOptions Class See Also Send Feedback

The CopyFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

CopyFilesCmdOptions Class


CopyFilesCmdOptions Properties

[image] [image]

Perforce .NET API
CopyFilesCmdOptions Properties
CopyFilesCmdOptions Class See Also Send Feedback

The CopyFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

CopyFilesCmdOptions Class


Counter Class

[image]

Perforce .NET API
Counter Class
Members See Also Send Feedback
A general-purpose counter or named variable in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Counter
Visual Basic
Public Class Counter
Visual C++
public ref class Counter

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Counter

See Also

Counter Members


Counter Members

[image] [image]

Perforce .NET API
Counter Members
Counter Class Constructors Methods Properties See Also Send Feedback

The Counter type exposes the following members.

Constructors

 | Name | Description
Public method | Counter | Initializes a new instance of the Counter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

Counter Class


Counter Constructor

[image]

Perforce .NET API
Counter Constructor
Counter Class See Also Send Feedback
Initializes a new instance of the Counter class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Counter(
    string name,
    string value
)
Visual Basic
Public Sub New ( _
    name As String, _
    value As String _
)
Visual C++
public:
Counter(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
value
Type: System..::..String

See Also

Counter Class


Counter Methods

[image] [image]

Perforce .NET API
Counter Methods
Counter Class See Also Send Feedback

The Counter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Counter Class


Counter Properties

[image] [image]

Perforce .NET API
Counter Properties
Counter Class See Also Send Feedback

The Counter type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

Counter Class


Name Property

[image]

Perforce .NET API
Counter..::..Name Property
Counter Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Counter Class


Value Property

[image]

Perforce .NET API
Counter..::..Value Property
Counter Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

Counter Class


CounterCmdFlags Enumeration

[image]

Perforce .NET API
CounterCmdFlags Enumeration
See Also Send Feedback
Flags for the counter command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum CounterCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration CounterCmdFlags
Visual C++
[FlagsAttribute]
public enum class CounterCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Set | 1 | The -f flag sets or deletes counters used by Perforce, which are listed by 'p4 help counters'. Important: Never set the 'change' counter to a value that is lower than its current value.
Delete | 2 | The -d flag deletes counters used by Perforce, which are listed by 'p4 help counters'. Important: Never set the 'change' counter to a value that is lower than its current value. must be used with -f.
Increment | 4 | The -i flag increments a counter by 1 and returns the new value. This option is used instead of a value argument and can only be used with numeric counters.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


CoutnerCmdOptions Class

[image]

Perforce .NET API
CoutnerCmdOptions Class
Members See Also Send Feedback
Counter command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class CoutnerCmdOptions : Options
Visual Basic
Public Class CoutnerCmdOptions _
    Inherits Options
Visual C++
public ref class CoutnerCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..CoutnerCmdOptions

See Also

CoutnerCmdOptions Members


CoutnerCmdOptions Members

[image] [image]

Perforce .NET API
CoutnerCmdOptions Members
CoutnerCmdOptions Class Constructors Methods Properties See Also Send Feedback

The CoutnerCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CoutnerCmdOptions | Counter command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

CoutnerCmdOptions Class


CoutnerCmdOptions Constructor

[image]

Perforce .NET API
CoutnerCmdOptions Constructor
CoutnerCmdOptions Class See Also Send Feedback
Counter command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public CoutnerCmdOptions(
    CounterCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As CounterCmdFlags _
)
Visual C++
public:
CoutnerCmdOptions(
    CounterCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..CounterCmdFlags

See Also

CoutnerCmdOptions Class


CoutnerCmdOptions Methods

[image] [image]

Perforce .NET API
CoutnerCmdOptions Methods
CoutnerCmdOptions Class See Also Send Feedback

The CoutnerCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

CoutnerCmdOptions Class


CoutnerCmdOptions Properties

[image] [image]

Perforce .NET API
CoutnerCmdOptions Properties
CoutnerCmdOptions Class See Also Send Feedback

The CoutnerCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

CoutnerCmdOptions Class


Credential Class

[image]

Perforce .NET API
Credential Class
Members See Also Send Feedback
Specifies user credentials for a specific connection.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Credential
Visual Basic
Public Class Credential
Visual C++
public ref class Credential

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Credential

See Also

Credential Members


Credential Members

[image] [image]

Perforce .NET API
Credential Members
Credential Class Methods Properties See Also Send Feedback

The Credential type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Expires |
Public property | Ticket |
Public property | TicketHost | Host Name used to store the ticket in the ticket file.

See Also

Credential Class


Credential Methods

[image] [image]

Perforce .NET API
Credential Methods
Credential Class See Also Send Feedback

The Credential type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

Credential Class


ToString Method

[image]

Perforce .NET API
Credential..::..ToString Method
Credential Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Credential Class


Credential Properties

[image] [image]

Perforce .NET API
Credential Properties
Credential Class See Also Send Feedback

The Credential type exposes the following members.

Properties

 | Name | Description
Public property | Expires |
Public property | Ticket |
Public property | TicketHost | Host Name used to store the ticket in the ticket file.

See Also

Credential Class


Expires Property

[image]

Perforce .NET API
Credential..::..Expires Property
Credential Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Expires { get; private set; }
Visual Basic
Public Property Expires As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Expires {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

Credential Class


Ticket Property

[image]

Perforce .NET API
Credential..::..Ticket Property
Credential Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Ticket { get; private set; }
Visual Basic
Public Property Ticket As String
    Get
    Private Set
Visual C++
public:
property String^ Ticket {
    String^ get ();
    private: void set (String^ value);
}

See Also

Credential Class


TicketHost Property

[image]

Perforce .NET API
Credential..::..TicketHost Property
Credential Class See Also Send Feedback
Host Name used to store the ticket in the ticket file.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TicketHost { get; set; }
Visual Basic
Public Property TicketHost As String
    Get
    Set
Visual C++
public:
property String^ TicketHost {
    String^ get ();
    void set (String^ value);
}

Remarks

The ticket is not always stored in the ticket file. If requested, the Login command will try to determine the name used in the ticket file to store the ticket. This is null if the ticket was not stored in the ticket file.

See Also

Credential Class


DateTimeVersion Class

[image]

Perforce .NET API
DateTimeVersion Class
Members See Also Send Feedback
A revision specifier that is a date and time.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class DateTimeVersion : VersionSpec
Visual Basic
Public Class DateTimeVersion _
    Inherits VersionSpec
Visual C++
public ref class DateTimeVersion : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..DateTimeVersion

See Also

DateTimeVersion Members


DateTimeVersion Members

[image] [image]

Perforce .NET API
DateTimeVersion Members
DateTimeVersion Class Constructors Methods Properties See Also Send Feedback

The DateTimeVersion type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeVersion | Initializes a new instance of the DateTimeVersion class

Methods

 | Name | Description
Public method | Equals | Equals method for for DateTimeVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for DateTimeVersion (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | Version | get Version as date/time

See Also

DateTimeVersion Class


DateTimeVersion Constructor

[image]

Perforce .NET API
DateTimeVersion Constructor
DateTimeVersion Class See Also Send Feedback
Initializes a new instance of the DateTimeVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTimeVersion(
    DateTime date
)
Visual Basic
Public Sub New ( _
    date As DateTime _
)
Visual C++
public:
DateTimeVersion(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date/time.

See Also

DateTimeVersion Class


DateTimeVersion Methods

[image] [image]

Perforce .NET API
DateTimeVersion Methods
DateTimeVersion Class See Also Send Feedback

The DateTimeVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for DateTimeVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for DateTimeVersion (Overrides VersionSpec..::..ToString()()()().)

See Also

DateTimeVersion Class


Equals Method

[image]

Perforce .NET API
DateTimeVersion..::..Equals Method
DateTimeVersion Class See Also Send Feedback
Equals method for for DateTimeVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get date/time

Return Value

True/False

See Also

DateTimeVersion Class


ToString Method

[image]

Perforce .NET API
DateTimeVersion..::..ToString Method
DateTimeVersion Class See Also Send Feedback
ToString method for for DateTimeVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String date/time version

See Also

DateTimeVersion Class


DateTimeVersion Properties

[image] [image]

Perforce .NET API
DateTimeVersion Properties
DateTimeVersion Class See Also Send Feedback

The DateTimeVersion type exposes the following members.

Properties

 | Name | Description
Public property | Version | get Version as date/time

See Also

DateTimeVersion Class


Version Property

[image]

Perforce .NET API
DateTimeVersion..::..Version Property
DateTimeVersion Class See Also Send Feedback
get Version as date/time

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Version { get; private set; }
Visual Basic
Public Property Version As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Version {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

DateTimeVersion Class


DeleteFilesCmdFlags Enumeration

[image]

Perforce .NET API
DeleteFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the delete command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum DeleteFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration DeleteFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class DeleteFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
PreviewOnly | 1 | The -n flag, displays a preview of the operation without changing any files or metadata.
DeleteUnsynced | 2 | The -v flag, enables you to delete files that are not synced to the client workspace.
ServerOnly | 4 | The -k flag performs the delete on the server without modifying client files. Use with caution, as an incorrect delete can cause discrepancies between the state of the client and the corresponding server metadata.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


DeleteFilesCmdOptions Class

[image]

Perforce .NET API
DeleteFilesCmdOptions Class
Members See Also Send Feedback
delete command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class DeleteFilesCmdOptions : Options
Visual Basic
Public Class DeleteFilesCmdOptions _
    Inherits Options
Visual C++
public ref class DeleteFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..DeleteFilesCmdOptions

See Also

DeleteFilesCmdOptions Members


DeleteFilesCmdOptions Members

[image] [image]

Perforce .NET API
DeleteFilesCmdOptions Members
DeleteFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The DeleteFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DeleteFilesCmdOptions | Options for the delete command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DeleteFilesCmdOptions Class


DeleteFilesCmdOptions Constructor

[image]

Perforce .NET API
DeleteFilesCmdOptions Constructor
DeleteFilesCmdOptions Class See Also Send Feedback
Options for the delete command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DeleteFilesCmdOptions(
    DeleteFilesCmdFlags flags,
    int changeList
)
Visual Basic
Public Sub New ( _
    flags As DeleteFilesCmdFlags, _
    changeList As Integer _
)
Visual C++
public:
DeleteFilesCmdOptions(
    DeleteFilesCmdFlags flags,
    int changeList
)

Parameters

flags
Type: Perforce.P4..::..DeleteFilesCmdFlags
changeList
Type: System..::..Int32

Return Value

Remarks

p4 help delete

delete -- Open an existing file for deletion from the depot

p4 delete [-c changelist#] [-n -v -k] file ...

Opens a depot file for deletion.
If the file is synced in the client workspace, it is removed. If a
pending changelist number is specified using with the -c flag, the
file is opened for delete in that changelist. Otherwise, it is opened
in the default pending changelist.

Files that are deleted generally do not appear on the have list.

The -n flag displays a preview of the operation without changing any
files or metadata.

The -k flag performs the delete on the server without modifying
client files. Use with caution, as an incorrect delete can cause
discrepancies between the state of the client and the corresponding
server metadata.

The -v flag enables you to delete files that are not synced to the
client workspace. The files should be specified using depot syntax;
since the files are not synced, client syntax or local syntax are
inappropriate and could introduce ambiguities in the file list.
Note, though, that if the files ARE synced, 'delete -v' will remove
the files from the client in addition to opening them for delete.
The preferred way to delete a set of files without transferring
them to your machine is: 'sync -k file...', then 'delete -k file...'

'p4 delete' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

DeleteFilesCmdOptions Class


DeleteFilesCmdOptions Methods

[image] [image]

Perforce .NET API
DeleteFilesCmdOptions Methods
DeleteFilesCmdOptions Class See Also Send Feedback

The DeleteFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DeleteFilesCmdOptions Class


DeleteFilesCmdOptions Properties

[image] [image]

Perforce .NET API
DeleteFilesCmdOptions Properties
DeleteFilesCmdOptions Class See Also Send Feedback

The DeleteFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DeleteFilesCmdOptions Class


Depot Class

[image]

Perforce .NET API
Depot Class
Members See Also Send Feedback
A depot specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Depot
Visual Basic
Public Class Depot
Visual C++
public ref class Depot

Remarks

p4 help depot

depot -- Create or edit a depot specification

p4 depot name
p4 depot -d [-f] name
p4 depot -o name
p4 depot -i

Create a new depot specification or edit an existing depot
specification. The specification form is put into a temporary file
and the editor (configured by the environment variable $P4EDITOR)
is invoked.

The depot specification contains the following fields:

Depot: The name of the depot. This name cannot be the same as
any branch, client, or label name.

Owner: The user who created this depot.

Date: The date that this specification was last modified.

Description: A short description of the depot (optional).

Type: One of the types: 'local', 'stream', 'remote', 'spec',
'archive', or 'unload'.

A 'local' depot (the default) is managed directly by
the server and its files reside in the server's root
directory.

A 'stream' depot is a local depot dedicated to the
storage of files in a stream.

A 'remote' depot refers to files in another Perforce
server.

A 'spec' depot automatically archives all edited forms
(branch, change, client, depot, group, job, jobspec,
protect, triggers, typemap, and user) in special,
read-only files. The files are named:
//depotname/formtype/name[suffix]. Updates to jobs made
by the 'p4 change', 'p4 fix', and 'p4 submit' commands
are also saved, but other automatic updates such as
as access times or opened files (for changes) are not.
A server can contain only one 'spec' depot.

A 'archive' depot defines a storage location to which
obsolete revisions may be relocated.

An 'unload' depot defines a storage location to which
database records may be unloaded and from which they
may be reloaded.

Address: For remote depots, the $P4PORT (connection address)
of the remote server.

Suffix: For spec depots, the optional suffix to be used
for generated paths. The default is '.p4s'.

Map: Path translation information, in the form of a file
pattern with a single ... in it. For local depots,
this path is relative to the server's root directory
or to server.depot.root if it has been configured
(Example: depot/...). For remote depots, this path
refers to the remote server's namespace
(Example: //depot/...).

SpecMap: For spec depots, the optional description of which
specs should be saved, as one or more patterns.

The -d flag deletes the specified depot. If any files reside in the
depot, they must be removed with 'p4 obliterate' before deleting the
depot. If any archive files remain in the depot directory, they may
be referenced by lazy copies in other depots; use 'p4 snap' to break
those linkages. Snap lazy copies prior to obliterating the old depot
files to allow the obliterate command to remove any unreferenced
archives from the depot directory. If the depot directory is not
empty, you must specify the -f flag to delete the depot.

The -o flag writes the depot specification to standard output. The
user's editor is not invoked.

The -i flag reads a depot specification from standard input. The
user's editor is not invoked.

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Depot

See Also

Depot Members


Depot Members

[image] [image]

Perforce .NET API
Depot Members
Depot Class Constructors Methods Properties See Also Send Feedback

The Depot type exposes the following members.

Constructors

 | Name | Description
Public method | Depot()()()() | Initializes a new instance of the Depot class
Public method | Depot(String, DepotType, DateTime, ServerAddress, String, String, String, String, FormSpec) | Initializes a new instance of the Depot class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromDepotCmdTaggedOutput | Read the fields from the tagged output of a depot command
Public method | FromDepotsCmdTaggedOutput | Read the fields from the tagged output of a depots command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a depot specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Address |
Public property | Description |
Public property | Id |
Public property | Map |
Public property | Modified |
Public property | Owner |
Public property | Spec |
Public property | Suffix |
Public property | Type |

See Also

Depot Class


Depot Constructor

[image] [image]

Perforce .NET API
Depot Constructor
Depot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Depot()()()() | Initializes a new instance of the Depot class
Public method | Depot(String, DepotType, DateTime, ServerAddress, String, String, String, String, FormSpec) | Initializes a new instance of the Depot class

See Also

Depot Class
Depot Members


Depot Constructor

[image]

Perforce .NET API
Depot Constructor
Depot Class See Also Send Feedback
Initializes a new instance of the Depot class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Depot()
Visual Basic
Public Sub New
Visual C++
public:
Depot()

See Also

Depot Class
Depot Overload


Depot Constructor (String, DepotType, DateTime, ServerAddress, String, String, String, String, FormSpec)

[image]

Perforce .NET API
Depot Constructor (String, DepotType, DateTime, ServerAddress, String, String, String, String, FormSpec)
Depot Class See Also Send Feedback
Initializes a new instance of the Depot class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Depot(
    string id,
    DepotType type,
    DateTime modified,
    ServerAddress address,
    string owner,
    string description,
    string suffix,
    string map,
    FormSpec spec
)
Visual Basic
Public Sub New ( _
    id As String, _
    type As DepotType, _
    modified As DateTime, _
    address As ServerAddress, _
    owner As String, _
    description As String, _
    suffix As String, _
    map As String, _
    spec As FormSpec _
)
Visual C++
public:
Depot(
    String^ id,
    DepotType type,
    DateTime modified,
    ServerAddress^ address,
    String^ owner,
    String^ description,
    String^ suffix,
    String^ map,
    FormSpec^ spec
)

Parameters

id
Type: System..::..String
type
Type: Perforce.P4..::..DepotType
modified
Type: System..::..DateTime
address
Type: Perforce.P4..::..ServerAddress
owner
Type: System..::..String
description
Type: System..::..String
suffix
Type: System..::..String
map
Type: System..::..String
spec
Type: Perforce.P4..::..FormSpec

See Also

Depot Class
Depot Overload


Depot Methods

[image] [image]

Perforce .NET API
Depot Methods
Depot Class See Also Send Feedback

The Depot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromDepotCmdTaggedOutput | Read the fields from the tagged output of a depot command
Public method | FromDepotsCmdTaggedOutput | Read the fields from the tagged output of a depots command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a depot specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

See Also

Depot Class


FromDepotCmdTaggedOutput Method

[image]

Perforce .NET API
Depot..::..FromDepotCmdTaggedOutput Method
Depot Class See Also Send Feedback
Read the fields from the tagged output of a depot command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromDepotCmdTaggedOutput(
    TaggedObject objectInfo
)
Visual Basic
Public Sub FromDepotCmdTaggedOutput ( _
    objectInfo As TaggedObject _
)
Visual C++
public:
void FromDepotCmdTaggedOutput(
    TaggedObject^ objectInfo
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'depot' command

See Also

Depot Class


FromDepotsCmdTaggedOutput Method

[image]

Perforce .NET API
Depot..::..FromDepotsCmdTaggedOutput Method
Depot Class See Also Send Feedback
Read the fields from the tagged output of a depots command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromDepotsCmdTaggedOutput(
    TaggedObject objectInfo,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromDepotsCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromDepotsCmdTaggedOutput(
    TaggedObject^ objectInfo,
    String^ offset,
    bool dst_mismatch
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'depots' command
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Depot Class


Parse Method

[image]

Perforce .NET API
Depot..::..Parse Method
Depot Class See Also Send Feedback
Parse the fields from a depot specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
Text of the depot specification in server format

Return Value

See Also

Depot Class


ToString Method

[image]

Perforce .NET API
Depot..::..ToString Method
Depot Class See Also Send Feedback
Convert to specification in server format

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

Depot Class


Depot Properties

[image] [image]

Perforce .NET API
Depot Properties
Depot Class See Also Send Feedback

The Depot type exposes the following members.

Properties

 | Name | Description
Public property | Address |
Public property | Description |
Public property | Id |
Public property | Map |
Public property | Modified |
Public property | Owner |
Public property | Spec |
Public property | Suffix |
Public property | Type |

See Also

Depot Class


Address Property

[image]

Perforce .NET API
Depot..::..Address Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerAddress Address { get; set; }
Visual Basic
Public Property Address As ServerAddress
    Get
    Set
Visual C++
public:
property ServerAddress^ Address {
    ServerAddress^ get ();
    void set (ServerAddress^ value);
}

See Also

Depot Class


Description Property

[image]

Perforce .NET API
Depot..::..Description Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Depot Class


Id Property

[image]

Perforce .NET API
Depot..::..Id Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Depot Class


Map Property

[image]

Perforce .NET API
Depot..::..Map Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Map { get; set; }
Visual Basic
Public Property Map As String
    Get
    Set
Visual C++
public:
property String^ Map {
    String^ get ();
    void set (String^ value);
}

See Also

Depot Class


Modified Property

[image]

Perforce .NET API
Depot..::..Modified Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Modified { get; set; }
Visual Basic
Public Property Modified As DateTime
    Get
    Set
Visual C++
public:
property DateTime Modified {
    DateTime get ();
    void set (DateTime value);
}

See Also

Depot Class


Owner Property

[image]

Perforce .NET API
Depot..::..Owner Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Owner { get; set; }
Visual Basic
Public Property Owner As String
    Get
    Set
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

Depot Class


Spec Property

[image]

Perforce .NET API
Depot..::..Spec Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

Depot Class


Suffix Property

[image]

Perforce .NET API
Depot..::..Suffix Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

See Also

Depot Class


Type Property

[image]

Perforce .NET API
Depot..::..Type Property
Depot Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotType Type { get; set; }
Visual Basic
Public Property Type As DepotType
    Get
    Set
Visual C++
public:
property DepotType Type {
    DepotType get ();
    void set (DepotType value);
}

See Also

Depot Class


DepotCmdFlags Enumeration

[image]

Perforce .NET API
DepotCmdFlags Enumeration
See Also Send Feedback
Flags for the depot command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum DepotCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration DepotCmdFlags
Visual C++
[FlagsAttribute]
public enum class DepotCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the specified depot. If any files reside in the depot, they must be removed with 'p4 obliterate' before deleting the depot.
Output | 2 | The -o flag writes the depot specification to the standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a depot specification from the standard input. The user's editor is not invoked.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


DepotCmdOptions Class

[image]

Perforce .NET API
DepotCmdOptions Class
Members See Also Send Feedback
depot command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class DepotCmdOptions : Options
Visual Basic
Public Class DepotCmdOptions _
    Inherits Options
Visual C++
public ref class DepotCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..DepotCmdOptions

See Also

DepotCmdOptions Members


DepotCmdOptions Members

[image] [image]

Perforce .NET API
DepotCmdOptions Members
DepotCmdOptions Class Constructors Methods Properties See Also Send Feedback

The DepotCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DepotCmdOptions | Options for the depot command

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DepotCmdOptions Class


DepotCmdOptions Constructor

[image]

Perforce .NET API
DepotCmdOptions Constructor
DepotCmdOptions Class See Also Send Feedback
Options for the depot command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotCmdOptions(
    DepotCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As DepotCmdFlags _
)
Visual C++
public:
DepotCmdOptions(
    DepotCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..DepotCmdFlags

See Also

DepotCmdOptions Class


DepotCmdOptions Methods

[image] [image]

Perforce .NET API
DepotCmdOptions Methods
DepotCmdOptions Class See Also Send Feedback

The DepotCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DepotCmdOptions Class


DepotCmdOptions Properties

[image] [image]

Perforce .NET API
DepotCmdOptions Properties
DepotCmdOptions Class See Also Send Feedback

The DepotCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DepotCmdOptions Class


DepotFileDiff Class

[image]

Perforce .NET API
DepotFileDiff Class
Members See Also Send Feedback
A diff between depot files in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class DepotFileDiff
Visual Basic
Public Class DepotFileDiff
Visual C++
public ref class DepotFileDiff

Remarks

p4 help diff2

diff2 -- Compare one set of depot files to another

p4 diff2 [options] fromFile[rev] toFile[rev]
p4 diff2 [options] -b branch [[fromFile[rev]] toFile[rev]]
p4 diff2 [options] -S stream [-P parent] [[fromFile[rev]] toFile[rev]]

options: -d<flags> -Od -q -t -u

'p4 diff2' runs on the server to compare one set of depot files (the
'source') to another (the 'target'). Source and target file sets
can be specified on the 'p4 diff2' command line or through a branch
view.

With a branch view, fromFile and toFile are optional; fromFile limits
the scope of the source file set, and toFile limits the scope of the
target. If only one file argument is given, it is assumed to be
toFile.

fromFile and toFile can include revision specifiers; by default, the
head revisions are diffed. See 'p4 help revisions' for details
about specifying file revisions.

'p4 diff2' precedes each diffed file pair with a header line of the
following form:

==== source#rev (type) - target#rev (type) ==== summary

A source or target file shown as '<none>' means there is no file
at the specified name or revision to pair with its counterpart.
The summary status is one of the following: 'identical' means file
contents and types are identical, 'types' means file contents are
identical but the types are different, and 'content' means file
contents are different.

The -b flag makes 'p4 diff2' use a user-defined branch view. (See
'p4 help branch'.) The left side of the branch view is the source
and the right side is the target.

The -S flag makes 'p4 diff2' use a generated branch view that maps
a stream (or its underlying real stream) to its parent. -P can be
used to generate the branch view using a parent stream other than
the stream's actual parent.

The -d<flags> modify the output of diffs as follows:

-dn (RCS)
-dc[n] (context)
-ds (summary)
-du[n] (unified)
-db (ignore whitespace changes)
-dw (ignore whitespace)
-dl (ignore line endings).

The optional argument to -dc/-du specifies number of context lines.

The -Od flag limits output to files that differ.

The -q omits files that have identical content and types and
suppresses the actual diff for all files.

The -t flag forces 'p4 diff2' to diff binary files.

The -u flag uses the GNU diff -u format and displays only files
that differ. The file names and dates are in Perforce syntax, but
the output can be used by the patch program.

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..DepotFileDiff

See Also

DepotFileDiff Members


DepotFileDiff Members

[image] [image]

Perforce .NET API
DepotFileDiff Members
DepotFileDiff Class Constructors Methods Properties See Also Send Feedback

The DepotFileDiff type exposes the following members.

Constructors

 | Name | Description
Public method | DepotFileDiff()()()() | Initializes a new instance of the DepotFileDiff class
Public method | DepotFileDiff(DiffType, FileSpec, FileSpec, String) | Initializes a new instance of the DepotFileDiff class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGetDepotFileDiffsCmdTaggedOutput | Read the fields from the tagged output of a diff2 command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Diff |
Public property | LeftFile |
Public property | RightFile |
Public property | Type |

See Also

DepotFileDiff Class


DepotFileDiff Constructor

[image] [image]

Perforce .NET API
DepotFileDiff Constructor
DepotFileDiff Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DepotFileDiff()()()() | Initializes a new instance of the DepotFileDiff class
Public method | DepotFileDiff(DiffType, FileSpec, FileSpec, String) | Initializes a new instance of the DepotFileDiff class

See Also

DepotFileDiff Class
DepotFileDiff Members


DepotFileDiff Constructor

[image]

Perforce .NET API
DepotFileDiff Constructor
DepotFileDiff Class See Also Send Feedback
Initializes a new instance of the DepotFileDiff class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotFileDiff()
Visual Basic
Public Sub New
Visual C++
public:
DepotFileDiff()

See Also

DepotFileDiff Class
DepotFileDiff Overload


DepotFileDiff Constructor (DiffType, FileSpec, FileSpec, String)

[image]

Perforce .NET API
DepotFileDiff Constructor (DiffType, FileSpec, FileSpec, String)
DepotFileDiff Class See Also Send Feedback
Initializes a new instance of the DepotFileDiff class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotFileDiff(
    DiffType type,
    FileSpec leftfile,
    FileSpec rightfile,
    string diff
)
Visual Basic
Public Sub New ( _
    type As DiffType, _
    leftfile As FileSpec, _
    rightfile As FileSpec, _
    diff As String _
)
Visual C++
public:
DepotFileDiff(
    DiffType type,
    FileSpec^ leftfile,
    FileSpec^ rightfile,
    String^ diff
)

Parameters

type
Type: Perforce.P4..::..DiffType
leftfile
Type: Perforce.P4..::..FileSpec
rightfile
Type: Perforce.P4..::..FileSpec
diff
Type: System..::..String

See Also

DepotFileDiff Class
DepotFileDiff Overload


DepotFileDiff Methods

[image] [image]

Perforce .NET API
DepotFileDiff Methods
DepotFileDiff Class See Also Send Feedback

The DepotFileDiff type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGetDepotFileDiffsCmdTaggedOutput | Read the fields from the tagged output of a diff2 command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DepotFileDiff Class


FromGetDepotFileDiffsCmdTaggedOutput Method

[image]

Perforce .NET API
DepotFileDiff..::..FromGetDepotFileDiffsCmdTaggedOutput Method
DepotFileDiff Class See Also Send Feedback
Read the fields from the tagged output of a diff2 command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromGetDepotFileDiffsCmdTaggedOutput(
    TaggedObject objectInfo,
    Connection connection,
    Options options
)
Visual Basic
Public Sub FromGetDepotFileDiffsCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    connection As Connection, _
    options As Options _
)
Visual C++
public:
void FromGetDepotFileDiffsCmdTaggedOutput(
    TaggedObject^ objectInfo,
    Connection^ connection,
    Options^ options
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'diff2' command
connection
Type: Perforce.P4..::..Connection
options
Type: Perforce.P4..::..Options

See Also

DepotFileDiff Class


DepotFileDiff Properties

[image] [image]

Perforce .NET API
DepotFileDiff Properties
DepotFileDiff Class See Also Send Feedback

The DepotFileDiff type exposes the following members.

Properties

 | Name | Description
Public property | Diff |
Public property | LeftFile |
Public property | RightFile |
Public property | Type |

See Also

DepotFileDiff Class


Diff Property

[image]

Perforce .NET API
DepotFileDiff..::..Diff Property
DepotFileDiff Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Diff { get; set; }
Visual Basic
Public Property Diff As String
    Get
    Set
Visual C++
public:
property String^ Diff {
    String^ get ();
    void set (String^ value);
}

See Also

DepotFileDiff Class


LeftFile Property

[image]

Perforce .NET API
DepotFileDiff..::..LeftFile Property
DepotFileDiff Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec LeftFile { get; set; }
Visual Basic
Public Property LeftFile As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ LeftFile {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

DepotFileDiff Class


RightFile Property

[image]

Perforce .NET API
DepotFileDiff..::..RightFile Property
DepotFileDiff Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec RightFile { get; set; }
Visual Basic
Public Property RightFile As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ RightFile {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

DepotFileDiff Class


Type Property

[image]

Perforce .NET API
DepotFileDiff..::..Type Property
DepotFileDiff Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DiffType Type { get; set; }
Visual Basic
Public Property Type As DiffType
    Get
    Set
Visual C++
public:
property DiffType Type {
    DiffType get ();
    void set (DiffType value);
}

See Also

DepotFileDiff Class


DepotPath Class

[image]

Perforce .NET API
DepotPath Class
Members See Also Send Feedback
A path spec in depot syntax.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class DepotPath : PathSpec
Visual Basic
Public Class DepotPath _
    Inherits PathSpec
Visual C++
public ref class DepotPath : public PathSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..PathSpec
Perforce.P4..::..DepotPath

See Also

DepotPath Members


DepotPath Members

[image] [image]

Perforce .NET API
DepotPath Members
DepotPath Class Constructors Methods Properties See Also Send Feedback

The DepotPath type exposes the following members.

Constructors

 | Name | Description
Public method | DepotPath | Initializes a new instance of the DepotPath class

Methods

 | Name | Description
Public method | Equals | (Overrides PathSpec..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName | (Inherited from PathSpec.)
Public method | GetFileName | (Inherited from PathSpec.)
Public method | GetHashCode | (Inherited from PathSpec.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot | (Inherited from PathSpec.)
Protected method | NormalizeLocal | (Inherited from PathSpec.)
Public method | ToString | (Inherited from PathSpec.)

Properties

 | Name | Description
Public property | Path | (Inherited from PathSpec.)

See Also

DepotPath Class


DepotPath Constructor

[image]

Perforce .NET API
DepotPath Constructor
DepotPath Class See Also Send Feedback
Initializes a new instance of the DepotPath class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotPath(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
DepotPath(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

DepotPath Class


DepotPath Methods

[image] [image]

Perforce .NET API
DepotPath Methods
DepotPath Class See Also Send Feedback

The DepotPath type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides PathSpec..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName | (Inherited from PathSpec.)
Public method | GetFileName | (Inherited from PathSpec.)
Public method | GetHashCode | (Inherited from PathSpec.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot | (Inherited from PathSpec.)
Protected method | NormalizeLocal | (Inherited from PathSpec.)
Public method | ToString | (Inherited from PathSpec.)

See Also

DepotPath Class


Equals Method

[image]

Perforce .NET API
DepotPath..::..Equals Method
DepotPath Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

DepotPath Class


DepotPath Properties

[image] [image]

Perforce .NET API
DepotPath Properties
DepotPath Class See Also Send Feedback

The DepotPath type exposes the following members.

Properties

 | Name | Description
Public property | Path | (Inherited from PathSpec.)

See Also

DepotPath Class


DepotType Enumeration

[image]

Perforce .NET API
DepotType Enumeration
See Also Send Feedback
The type of the depot.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum DepotType
Visual Basic
<FlagsAttribute> _
Public Enumeration DepotType
Visual C++
[FlagsAttribute]
public enum class DepotType

Members

Member name | Value | Description
Local | 0 | A 'local' depot (the default) is managed directly by the server and its files reside in the server's root directory.
Remote | 1 | A 'remote' depot refers to files in another Perforce server.
Spec | 2 | A 'spec' depot automatically archives all edited forms (branch, change, client, depot, group, job, jobspec, protect, triggers, typemap, and user) in special, read-only files. The files are named: //depotname/formtype/name[suffix]. Updates to jobs made by the 'p4 change', 'p4 fix', and 'p4 submit' commands are also saved, but other automatic updates such as as access times or opened files (for changes) are not. A server can contain only one 'spec' depot.
Stream | 4 | A 'stream' depot is a local depot dedicated to the storage of files in a stream.
Archive | 8 | An 'archive' depot defines a storage location to which obsolete revisions may be relocated.
Unload | 16 | An 'unload' depot defines a storage location to which database records may be unloaded and from which they may be reloaded.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


DescribeChangelistCmdFlags Enumeration

[image]

Perforce .NET API
DescribeChangelistCmdFlags Enumeration
See Also Send Feedback
Flags for the describe command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum DescribeChangelistCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration DescribeChangelistCmdFlags
Visual C++
[FlagsAttribute]
public enum class DescribeChangelistCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
RCS | 1 | The -d flag deletes the specified stream (unless the stream is referenced by child streams or stream clients).
Context | 2 | -dn RCS output.
Summary | 4 | -dc[n] context
Unified | 8 | -dc[n] context
IgnoreWhitespaceChanges | 16 | -dc[n] context
IgnoreWhitespace | 32 | -dc[n] context
IgnoreLineEndings | 64 | -dc[n] context
Omit | 128 | The -s flag omits the diffs of files that were updated.
Shelved | 256 | The -S flag lists files that are shelved for the specified changelist and displays diffs of the files against their previous revision.
Force | 512 | The -f flag forces display of the descriptions in a restricted change. The -f flag requires 'admin' access, which is granted using 'p4 protect'.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


DescribeCmdOptions Class

[image]

Perforce .NET API
DescribeCmdOptions Class
Members See Also Send Feedback
Options for the Describe command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class DescribeCmdOptions : Options
Visual Basic
Public Class DescribeCmdOptions _
    Inherits Options
Visual C++
public ref class DescribeCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..DescribeCmdOptions

See Also

DescribeCmdOptions Members


DescribeCmdOptions Members

[image] [image]

Perforce .NET API
DescribeCmdOptions Members
DescribeCmdOptions Class Constructors Methods Properties See Also Send Feedback

The DescribeCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DescribeCmdOptions | Options for the Describe command

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DescribeCmdOptions Class


DescribeCmdOptions Constructor

[image]

Perforce .NET API
DescribeCmdOptions Constructor
DescribeCmdOptions Class See Also Send Feedback
Options for the Describe command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DescribeCmdOptions(
    DescribeChangelistCmdFlags flags,
    int contextLines,
    int unifiedLines
)
Visual Basic
Public Sub New ( _
    flags As DescribeChangelistCmdFlags, _
    contextLines As Integer, _
    unifiedLines As Integer _
)
Visual C++
public:
DescribeCmdOptions(
    DescribeChangelistCmdFlags flags,
    int contextLines,
    int unifiedLines
)

Parameters

flags
Type: Perforce.P4..::..DescribeChangelistCmdFlags
contextLines
Type: System..::..Int32
unifiedLines
Type: System..::..Int32

Remarks

p4 help describe

describe -- Display a changelist description

p4 describe [-d<flags> -m -s -S -f -O] changelist# ...

Display a changelist description, including the changelist number,
user, client, date of submission, textual description, list of
affected files and diffs of files updated. Pending changelists
are indicated as 'pending' and file diffs are not displayed.

For restricted changelists, 'no permission' is displayed if the user
is not permitted to view the change (see 'p4 help change'). If a
submitted change is restricted, the description is hidden unless
the user is the owner of the change or has list permission for
at least one file in the change. If a shelved change is restricted,
the description is hidden unless the user is the owner of the change,
or has list permission to at least one file in the change and has
used the -S flag to request the shelved change. To view restricted
pending (not shelved) changes, the user must be the owner of the
change.

The -d<flags> passes one or more flags to the built-in diff routine
to modify the output: -dn (RCS), -dc[n] (context), -ds (summary),
-du[n] (unified), -db (ignore whitespace changes), -dw (ignore
whitespace), -dl (ignore line endings). The optional argument to
to -dc/-du specifies number of context lines.

The -s flag omits the diffs of files that were updated.

The -S flag lists files that are shelved for the specified changelist
and displays diffs of the files against their previous revision.
If the change is restricted, the description is displayed according
to the rules for shelved restricted changes described above.

The -f flag forces display of the descriptions in a restricted
change. The -f flag requires 'admin' access, which is granted
using 'p4 protect'.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -m flag limits files to the first 'max' number of files.

See Also

DescribeCmdOptions Class


DescribeCmdOptions Methods

[image] [image]

Perforce .NET API
DescribeCmdOptions Methods
DescribeCmdOptions Class See Also Send Feedback

The DescribeCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DescribeCmdOptions Class


DescribeCmdOptions Properties

[image] [image]

Perforce .NET API
DescribeCmdOptions Properties
DescribeCmdOptions Class See Also Send Feedback

The DescribeCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

DescribeCmdOptions Class


DiffType Enumeration

[image]

Perforce .NET API
DiffType Enumeration
See Also Send Feedback
The types of diffs returned by the server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum DiffType
Visual Basic
<FlagsAttribute> _
Public Enumeration DiffType
Visual C++
[FlagsAttribute]
public enum class DiffType

Members

Member name | Value | Description
Content | 0 | File contents are different.
FileType | 1 | File contents are identical but file types are different.
LeftOnly | 2 | The left file in the diff has no target file at the specified name or revision to pair with for a diff.
RightOnly | 4 | The right file in the diff has no source file at the specified name or revision to pair with for a diff.
Identical | 8 | File content and file types are identical.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


DiffWhiteSpaceOptions Enumeration

[image]

Perforce .NET API
DiffWhiteSpaceOptions Enumeration
See Also Send Feedback
Diff whitespace options flags.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum DiffWhiteSpaceOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration DiffWhiteSpaceOptions
Visual C++
[FlagsAttribute]
public enum class DiffWhiteSpaceOptions

Members

Member name | Value | Description
none | 0 | None
IgnoreWhitespaceChanges | 1 | -db Ignore Whitespace Changes
IgnoreWhitespace | 2 | -dw Ingore whitespace altogether.
IgnoreLineEndings | 4 | -dl Ignore Line Endings
RCS | 8 | -dn RCS
ShowContext | 16 | -dc[n] Show context of changes
ShowSummary | 32 | -ds Summary
ShowUnified | 64 | -du[n] Unified

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


EditCmdOptions Class

[image]

Perforce .NET API
EditCmdOptions Class
Members See Also Send Feedback
Options for the edit command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class EditCmdOptions : Options
Visual Basic
Public Class EditCmdOptions _
    Inherits Options
Visual C++
public ref class EditCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..EditCmdOptions

See Also

EditCmdOptions Members


EditCmdOptions Members

[image] [image]

Perforce .NET API
EditCmdOptions Members
EditCmdOptions Class Constructors Methods Properties See Also Send Feedback

The EditCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | EditCmdOptions | Options for the edit command

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

EditCmdOptions Class


EditCmdOptions Constructor

[image]

Perforce .NET API
EditCmdOptions Constructor
EditCmdOptions Class See Also Send Feedback
Options for the edit command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public EditCmdOptions(
    EditFilesCmdFlags flags,
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    flags As EditFilesCmdFlags, _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
EditCmdOptions(
    EditFilesCmdFlags flags,
    int changeList,
    FileType^ fileType
)

Parameters

flags
Type: Perforce.P4..::..EditFilesCmdFlags
changeList
Type: System..::..Int32
fileType
Type: Perforce.P4..::..FileType

Return Value

Remarks

p4 help edit

edit -- Open an existing file for edit

p4 edit [-c changelist#] [-k -n] [-t filetype] file ...

Open an existing file for edit. The server records the fact that
the current user has opened the file in the current workspace, and
changes the file permission from read-only to read/write.

If -c changelist# is included, the file opened in the specified
pending changelist. If changelist number is omitted, the file is
opened in the 'default' changelist.

If -t filetype is specified, the file is assigned that Perforce
filetype. Otherwise, the filetype of the previous revision is reused.
If a partial filetype is specified, it is combined with the current
filetype.For details, see 'p4 help filetypes'.
Using a filetype of 'auto' will cause the filetype to be chosen
as if the file were being added, that is the typemap will be
considered and the file contents may be examined.

The -n flag previews the operation without changing any files or
metadata.

The -k flag updates metadata without transferring files to the
workspace. This option can be used to tell the server that files in
a client workspace are already editable, even if they are not in the
client view. Typically this flag is used to correct the Perforce
server when it is wrong about the state of files in the client
workspace, but incorrect use of this option can result in inaccurate
file status information.

'p4 edit' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

EditCmdOptions Class


EditCmdOptions Methods

[image] [image]

Perforce .NET API
EditCmdOptions Methods
EditCmdOptions Class See Also Send Feedback

The EditCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

EditCmdOptions Class


EditCmdOptions Properties

[image] [image]

Perforce .NET API
EditCmdOptions Properties
EditCmdOptions Class See Also Send Feedback

The EditCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

EditCmdOptions Class


EditFilesCmdFlags Enumeration

[image]

Perforce .NET API
EditFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the edit command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum EditFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration EditFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class EditFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
PreviewOnly | 1 | The -n flag, previews the operation without changing any files or metadata.
ServerOnly | 2 | The -k flag, updates metadata without transferring files to the workspace.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


EntryType Enumeration

[image]

Perforce .NET API
EntryType Enumeration
See Also Send Feedback
The type of protection (user or group).

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum EntryType
Visual Basic
Public Enumeration EntryType
Visual C++
public enum class EntryType

Members

Member name | Value | Description
User | 0 |
Group | 1 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ErrorGeneric Enumeration

[image]

Perforce .NET API
ErrorGeneric Enumeration
See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum ErrorGeneric
Visual Basic
Public Enumeration ErrorGeneric
Visual C++
public enum class ErrorGeneric

Members

Member name | Value | Description
EV_NONE | 0 |
EV_USAGE | 1 |
EV_UNKNOWN | 2 |
EV_CONTEXT | 3 |
EV_ILLEGAL | 4 |
EV_NOTYET | 5 |
EV_PROTECT | 6 |
EV_EMPTY | 17 |
EV_FAULT | 33 |
EV_CLIENT | 34 |
EV_ADMIN | 35 |
EV_CONFIG | 36 |
EV_UPGRADE | 37 |
EV_COMM | 38 |
EV_TOOBIG | 39 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ErrorSeverity Enumeration

[image]

Perforce .NET API
ErrorSeverity Enumeration
See Also Send Feedback
Error severity levels.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum ErrorSeverity
Visual Basic
Public Enumeration ErrorSeverity
Visual C++
public enum class ErrorSeverity

Members

Member name | Value | Description
E_UNKNOWN | -1 | Unknown
E_EMPTY | 0 | nothing yet
E_INFO | 1 | something good happened
E_WARN | 2 | something not good happened
E_FAILED | 3 | user did something wrong
E_FATAL | 4 | system broken -- nothing can continue
E_NOEXC | 9999 | Used to turnoff exceptions

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ErrorSubsystem Enumeration

[image]

Perforce .NET API
ErrorSubsystem Enumeration
See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum ErrorSubsystem
Visual Basic
Public Enumeration ErrorSubsystem
Visual C++
public enum class ErrorSubsystem

Members

Member name | Value | Description
ES_OS | 0 |
ES_SUPP | 1 |
ES_LBR | 2 |
ES_RPC | 3 |
ES_DB | 4 |
ES_DBSUPP | 5 |
ES_DM | 6 |
ES_SERVER | 7 |
ES_CLIENT | 8 |
ES_INFO | 9 |
ES_HELP | 10 |
ES_SPEC | 11 |
ES_FTPD | 12 |
ES_BROKER | 13 |
ES_P4QT | 14 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


File Class

[image]

Perforce .NET API
File Class
Members See Also Send Feedback
A versioned object that describes an individual file in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class File : FileSpec
Visual Basic
Public Class File _
    Inherits FileSpec
Visual C++
public ref class File : public FileSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileSpec
Perforce.P4..::..File

See Also

File Members


File Members

[image] [image]

Perforce .NET API
File Members
File Class Constructors Methods Fields Properties See Also Send Feedback

The File type exposes the following members.

Constructors

 | Name | Description
Public method | File()()()() | Initializes a new instance of the File class
Public method | File(DepotPath, ClientPath, Revision, Revision, Int32, FileAction, FileType, DateTime, String, String) | Initializes a new instance of the File class

Methods

 | Name | Description
Public method | Equals | (Inherited from FileSpec.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromFilesCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFilesCmdTaggedData |
Public method | StripVersion | Create a copy of a filespec without a version (Inherited from FileSpec.)
Public method | ToEscapedString | (Inherited from FileSpec.)
Public method | ToString()()()() | (Overrides FileSpec..::..ToString()()()().)
Public method | ToString(Type) | (Inherited from FileSpec.)

Fields

 | Name | Description
Public field | Action |
Public field | ChangeId |
Public field | Client |
Public field | HaveRev |
Public field | SubmitTime |
Public field | Type |
Public field | User |

Properties

 | Name | Description
Public property | ClientPath | (Inherited from FileSpec.)
Public property | DepotPath | (Inherited from FileSpec.)
Public property | LocalPath | (Inherited from FileSpec.)
Public property | Version | (Inherited from FileSpec.)

See Also

File Class


File Constructor

[image] [image]

Perforce .NET API
File Constructor
File Class See Also Send Feedback

Overload List

 | Name | Description
Public method | File()()()() | Initializes a new instance of the File class
Public method | File(DepotPath, ClientPath, Revision, Revision, Int32, FileAction, FileType, DateTime, String, String) | Initializes a new instance of the File class

See Also

File Class
File Members


File Constructor

[image]

Perforce .NET API
File Constructor
File Class See Also Send Feedback
Initializes a new instance of the File class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public File()
Visual Basic
Public Sub New
Visual C++
public:
File()

See Also

File Class
File Overload


File Constructor (DepotPath, ClientPath, Revision, Revision, Int32, FileAction, FileType, DateTime, String, String)

[image]

Perforce .NET API
File Constructor (DepotPath, ClientPath, Revision, Revision, Int32, FileAction, FileType, DateTime, String, String)
File Class See Also Send Feedback
Initializes a new instance of the File class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public File(
    DepotPath depotPath,
    ClientPath clientPath,
    Revision rev,
    Revision haveRev,
    int change,
    FileAction action,
    FileType type,
    DateTime submittime,
    string user,
    string client
)
Visual Basic
Public Sub New ( _
    depotPath As DepotPath, _
    clientPath As ClientPath, _
    rev As Revision, _
    haveRev As Revision, _
    change As Integer, _
    action As FileAction, _
    type As FileType, _
    submittime As DateTime, _
    user As String, _
    client As String _
)
Visual C++
public:
File(
    DepotPath^ depotPath,
    ClientPath^ clientPath,
    Revision^ rev,
    Revision^ haveRev,
    int change,
    FileAction action,
    FileType^ type,
    DateTime submittime,
    String^ user,
    String^ client
)

Parameters

depotPath
Type: Perforce.P4..::..DepotPath
clientPath
Type: Perforce.P4..::..ClientPath
rev
Type: Perforce.P4..::..Revision
haveRev
Type: Perforce.P4..::..Revision
change
Type: System..::..Int32
action
Type: Perforce.P4..::..FileAction
type
Type: Perforce.P4..::..FileType
submittime
Type: System..::..DateTime
user
Type: System..::..String
client
Type: System..::..String

See Also

File Class
File Overload


File Fields

[image] [image]

Perforce .NET API
File Fields
File Class See Also Send Feedback

The File type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | ChangeId |
Public field | Client |
Public field | HaveRev |
Public field | SubmitTime |
Public field | Type |
Public field | User |

See Also

File Class


Action Field

[image]

Perforce .NET API
File..::..Action Field
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction Action
Visual Basic
Public Action As FileAction
Visual C++
public:
FileAction Action

See Also

File Class


ChangeId Field

[image]

Perforce .NET API
File..::..ChangeId Field
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChangeId
Visual Basic
Public ChangeId As Integer
Visual C++
public:
int ChangeId

See Also

File Class


Client Field

[image]

Perforce .NET API
File..::..Client Field
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Client
Visual Basic
Public Client As String
Visual C++
public:
String^ Client

See Also

File Class


HaveRev Field

[image]

Perforce .NET API
File..::..HaveRev Field
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Revision HaveRev
Visual Basic
Public HaveRev As Revision
Visual C++
public:
Revision^ HaveRev

See Also

File Class


SubmitTime Field

[image]

Perforce .NET API
File..::..SubmitTime Field
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime SubmitTime
Visual Basic
Public SubmitTime As DateTime
Visual C++
public:
DateTime SubmitTime

See Also

File Class


Type Field

[image]

Perforce .NET API
File..::..Type Field
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType Type
Visual Basic
Public Type As FileType
Visual C++
public:
FileType^ Type

See Also

File Class


User Field

[image]

Perforce .NET API
File..::..User Field
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string User
Visual Basic
Public User As String
Visual C++
public:
String^ User

See Also

File Class


File Methods

[image] [image]

Perforce .NET API
File Methods
File Class See Also Send Feedback

The File type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from FileSpec.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromFilesCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFilesCmdTaggedData |
Public method | StripVersion | Create a copy of a filespec without a version (Inherited from FileSpec.)
Public method | ToEscapedString | (Inherited from FileSpec.)
Public method | ToString()()()() | (Overrides FileSpec..::..ToString()()()().)
Public method | ToString(Type) | (Inherited from FileSpec.)

See Also

File Class


FromFilesCmdTaggedData Method

[image]

Perforce .NET API
File..::..FromFilesCmdTaggedData Method
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static File FromFilesCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Shared Function FromFilesCmdTaggedData ( _
    obj As TaggedObject _
) As File
Visual C++
public:
static File^ FromFilesCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

File Class


ParseFilesCmdTaggedData Method

[image]

Perforce .NET API
File..::..ParseFilesCmdTaggedData Method
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void ParseFilesCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Sub ParseFilesCmdTaggedData ( _
    obj As TaggedObject _
)
Visual C++
public:
void ParseFilesCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

File Class


ToString Method

[image] [image]

Perforce .NET API
File..::..ToString Method
File Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | (Overrides FileSpec..::..ToString()()()().)
Public method | ToString(Type) | (Inherited from FileSpec.)

See Also

File Class
File Members


ToString Method

[image]

Perforce .NET API
File..::..ToString Method
File Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

File Class
ToString Overload


File Properties

[image] [image]

Perforce .NET API
File Properties
File Class See Also Send Feedback

The File type exposes the following members.

Properties

 | Name | Description
Public property | ClientPath | (Inherited from FileSpec.)
Public property | DepotPath | (Inherited from FileSpec.)
Public property | LocalPath | (Inherited from FileSpec.)
Public property | Version | (Inherited from FileSpec.)

See Also

File Class


FileAction Enumeration

[image]

Perforce .NET API
FileAction Enumeration
See Also Send Feedback
Describes the pending or completed action related to open, resolve, or integration for a specific file.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum FileAction
Visual Basic
Public Enumeration FileAction
Visual C++
public enum class FileAction

Members

Member name | Value | Description
None | 0 | None.
Add | 1 | Opened for add.
Branch | 2 | Opened for branch.
Edit | 3 | Opened for edit.
Integrate | 4 | Opened for integrate.
Delete | 5 | File has been deleted.
DeleteFrom | 6 | file was integrated from partner-file, and partner-file had been previously deleted.
DeleteInto | 7 | file was integrated into partner-file, and file had been previously deleted.
Sync | 8 | File has been synced.
Updated | 9 | File has been updated.
Added | 10 | File has been added.
AddInto | 11 | file was integrated into previously nonexistent partner-file, and partner-file was reopened for add before submission.
Refreshed | 12 | File has been refreshed.
Ignored | 13 | File was integrated from partner-file, accepting yours.
IgnoredBy | 14 | File was integrated into partner-file, accepting yours.
Abandoned | 15 | File has been abandoned.
EditIgnored | 16 | None.
Move | 17 | File is opened for move.
MoveAdd | 18 | File has been added as part of a move.
MoveDelete | 19 | File has been deleted as part of a move.
MovedFrom | 20 | File was integrated from partner-file, accepting theirs and deleting the original.
MovedInto | 21 | File was integrated into partner-file, accepting merge.
Unresolved | 22 | File has not been resolved.
CopyFrom | 23 | File was integrated from partner-file, accepting theirs.
CopyInto | 24 | File was integrated into partner-file, accepting theirs.
MergeFrom | 25 | File was integrated from partner-file, accepting merge.
MergeInto | 26 | File was integrated into partner-file, accepting merge.
EditFrom | 27 | file was integrated from partner-file, and file was edited within the p4 resolve process. This allows you to determine whether the change should ever be integrated back; automated changes (merge from) needn't be, but original user edits (edit from) performed during the resolve should be.
EditInto | 28 | File was integrated into partner-file, and partner-file was reopened for edit before submission.
Purge | 29 | File was purged.
Import | 30 | File was imported.
BranchFrom | 31 | File did not previously exist; it was created as a copy of partner-file.
BranchInto | 32 | Partner-file did not previously exist; it was created as a copy of file.
Reverted | 33 | File was reverted.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


FileAnnotation Class

[image]

Perforce .NET API
FileAnnotation Class
Members See Also Send Feedback
Correlates file lines with revision information.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileAnnotation
Visual Basic
Public Class FileAnnotation
Visual C++
public ref class FileAnnotation

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileAnnotation

See Also

FileAnnotation Members


FileAnnotation Members

[image] [image]

Perforce .NET API
FileAnnotation Members
FileAnnotation Class Constructors Methods Properties See Also Send Feedback

The FileAnnotation type exposes the following members.

Constructors

 | Name | Description
Public method | FileAnnotation()()()() | Initializes a new instance of the FileAnnotation class
Public method | FileAnnotation(FileSpec, String) | Initializes a new instance of the FileAnnotation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | File |
Public property | Line |

See Also

FileAnnotation Class


FileAnnotation Constructor

[image] [image]

Perforce .NET API
FileAnnotation Constructor
FileAnnotation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileAnnotation()()()() | Initializes a new instance of the FileAnnotation class
Public method | FileAnnotation(FileSpec, String) | Initializes a new instance of the FileAnnotation class

See Also

FileAnnotation Class
FileAnnotation Members


FileAnnotation Constructor

[image]

Perforce .NET API
FileAnnotation Constructor
FileAnnotation Class See Also Send Feedback
Initializes a new instance of the FileAnnotation class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAnnotation()
Visual Basic
Public Sub New
Visual C++
public:
FileAnnotation()

See Also

FileAnnotation Class
FileAnnotation Overload


FileAnnotation Constructor (FileSpec, String)

[image]

Perforce .NET API
FileAnnotation Constructor (FileSpec, String)
FileAnnotation Class See Also Send Feedback
Initializes a new instance of the FileAnnotation class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAnnotation(
    FileSpec file,
    string line
)
Visual Basic
Public Sub New ( _
    file As FileSpec, _
    line As String _
)
Visual C++
public:
FileAnnotation(
    FileSpec^ file,
    String^ line
)

Parameters

file
Type: Perforce.P4..::..FileSpec
line
Type: System..::..String

See Also

FileAnnotation Class
FileAnnotation Overload


FileAnnotation Methods

[image] [image]

Perforce .NET API
FileAnnotation Methods
FileAnnotation Class See Also Send Feedback

The FileAnnotation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileAnnotation Class


FileAnnotation Properties

[image] [image]

Perforce .NET API
FileAnnotation Properties
FileAnnotation Class See Also Send Feedback

The FileAnnotation type exposes the following members.

Properties

 | Name | Description
Public property | File |
Public property | Line |

See Also

FileAnnotation Class


File Property

[image]

Perforce .NET API
FileAnnotation..::..File Property
FileAnnotation Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec File { get; set; }
Visual Basic
Public Property File As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ File {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

FileAnnotation Class


Line Property

[image]

Perforce .NET API
FileAnnotation..::..Line Property
FileAnnotation Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Line { get; set; }
Visual Basic
Public Property Line As String
    Get
    Set
Visual C++
public:
property String^ Line {
    String^ get ();
    void set (String^ value);
}

See Also

FileAnnotation Class


FileHistory Class

[image]

Perforce .NET API
FileHistory Class
Members See Also Send Feedback
Describes a Perforce file revision in detail, including the changelist number and associated description, action, user, etc. data.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileHistory
Visual Basic
Public Class FileHistory
Visual C++
public ref class FileHistory

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileHistory

See Also

FileHistory Members


FileHistory Members

[image] [image]

Perforce .NET API
FileHistory Members
FileHistory Class Constructors Methods Properties See Also Send Feedback

The FileHistory type exposes the following members.

Constructors

 | Name | Description
Public method | FileHistory | Initializes a new instance of the FileHistory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Convert to a string of the format ... #{rev} change {change} {action} on {date} {user}@{client} (type) '{desc}' (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Convert to a string of the format ... #{rev} change {change} {action} on {date}[ {time}] {user}@{client} (type) '{desc}'

Properties

 | Name | Description
Public property | Action |
Public property | ChangelistId |
Public property | ClientName |
Public property | Date |
Public property | DepotPath |
Public property | Description |
Public property | Digest |
Public property | FileSize |
Public property | FileType |
Public property | IntegrationSummaries |
Public property | Revision |
Public property | UserName |

See Also

FileHistory Class


FileHistory Constructor

[image]

Perforce .NET API
FileHistory Constructor
FileHistory Class See Also Send Feedback
Initializes a new instance of the FileHistory class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileHistory(
    int revision,
    int changelistid,
    FileAction action,
    DateTime date,
    string username,
    FileType filetype,
    string description,
    string digest,
    long filesize,
    PathSpec depotpath,
    string clientname,
    List<RevisionIntegrationSummary> integrationsummaries
)
Visual Basic
Public Sub New ( _
    revision As Integer, _
    changelistid As Integer, _
    action As FileAction, _
    date As DateTime, _
    username As String, _
    filetype As FileType, _
    description As String, _
    digest As String, _
    filesize As Long, _
    depotpath As PathSpec, _
    clientname As String, _
    integrationsummaries As List(Of RevisionIntegrationSummary) _
)
Visual C++
public:
FileHistory(
    int revision,
    int changelistid,
    FileAction action,
    DateTime date,
    String^ username,
    FileType^ filetype,
    String^ description,
    String^ digest,
    long long filesize,
    PathSpec^ depotpath,
    String^ clientname,
    List<RevisionIntegrationSummary^>^ integrationsummaries
)

Parameters

revision
Type: System..::..Int32
changelistid
Type: System..::..Int32
action
Type: Perforce.P4..::..FileAction
date
Type: System..::..DateTime
username
Type: System..::..String
filetype
Type: Perforce.P4..::..FileType
description
Type: System..::..String
digest
Type: System..::..String
filesize
Type: System..::..Int64
depotpath
Type: Perforce.P4..::..PathSpec
clientname
Type: System..::..String
integrationsummaries
Type: System.Collections.Generic..::..List <(Of <(<' RevisionIntegrationSummary >)>)>

See Also

FileHistory Class


FileHistory Methods

[image] [image]

Perforce .NET API
FileHistory Methods
FileHistory Class See Also Send Feedback

The FileHistory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Convert to a string of the format ... #{rev} change {change} {action} on {date} {user}@{client} (type) '{desc}' (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Convert to a string of the format ... #{rev} change {change} {action} on {date}[ {time}] {user}@{client} (type) '{desc}'

See Also

FileHistory Class


ToString Method

[image] [image]

Perforce .NET API
FileHistory..::..ToString Method
FileHistory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Convert to a string of the format ... #{rev} change {change} {action} on {date} {user}@{client} (type) '{desc}' (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Convert to a string of the format ... #{rev} change {change} {action} on {date}[ {time}] {user}@{client} (type) '{desc}'

See Also

FileHistory Class
FileHistory Members


ToString Method

[image]

Perforce .NET API
FileHistory..::..ToString Method
FileHistory Class See Also Send Feedback
Convert to a string of the format ... #{rev} change {change} {action} on {date} {user}@{client} (type) '{desc}'

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

FileHistory Class
ToString Overload


ToString Method (Boolean)

[image]

Perforce .NET API
FileHistory..::..ToString Method (Boolean)
FileHistory Class See Also Send Feedback
Convert to a string of the format ... #{rev} change {change} {action} on {date}[ {time}] {user}@{client} (type) '{desc}'

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ToString(
    bool includeTime
)
Visual Basic
Public Function ToString ( _
    includeTime As Boolean _
) As String
Visual C++
public:
String^ ToString(
    bool includeTime
)

Parameters

includeTime
Type: System..::..Boolean
Include the time as well as the date

Return Value

See Also

FileHistory Class
ToString Overload


FileHistory Properties

[image] [image]

Perforce .NET API
FileHistory Properties
FileHistory Class See Also Send Feedback

The FileHistory type exposes the following members.

Properties

 | Name | Description
Public property | Action |
Public property | ChangelistId |
Public property | ClientName |
Public property | Date |
Public property | DepotPath |
Public property | Description |
Public property | Digest |
Public property | FileSize |
Public property | FileType |
Public property | IntegrationSummaries |
Public property | Revision |
Public property | UserName |

See Also

FileHistory Class


Action Property

[image]

Perforce .NET API
FileHistory..::..Action Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction Action { get; set; }
Visual Basic
Public Property Action As FileAction
    Get
    Set
Visual C++
public:
property FileAction Action {
    FileAction get ();
    void set (FileAction value);
}

See Also

FileHistory Class


ChangelistId Property

[image]

Perforce .NET API
FileHistory..::..ChangelistId Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChangelistId { get; set; }
Visual Basic
Public Property ChangelistId As Integer
    Get
    Set
Visual C++
public:
property int ChangelistId {
    int get ();
    void set (int value);
}

See Also

FileHistory Class


ClientName Property

[image]

Perforce .NET API
FileHistory..::..ClientName Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ClientName { get; set; }
Visual Basic
Public Property ClientName As String
    Get
    Set
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

See Also

FileHistory Class


Date Property

[image]

Perforce .NET API
FileHistory..::..Date Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}

See Also

FileHistory Class


DepotPath Property

[image]

Perforce .NET API
FileHistory..::..DepotPath Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public PathSpec DepotPath { get; set; }
Visual Basic
Public Property DepotPath As PathSpec
    Get
    Set
Visual C++
public:
property PathSpec^ DepotPath {
    PathSpec^ get ();
    void set (PathSpec^ value);
}

See Also

FileHistory Class


Description Property

[image]

Perforce .NET API
FileHistory..::..Description Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

FileHistory Class


Digest Property

[image]

Perforce .NET API
FileHistory..::..Digest Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Digest { get; set; }
Visual Basic
Public Property Digest As String
    Get
    Set
Visual C++
public:
property String^ Digest {
    String^ get ();
    void set (String^ value);
}

See Also

FileHistory Class


FileSize Property

[image]

Perforce .NET API
FileHistory..::..FileSize Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public long FileSize { get; set; }
Visual Basic
Public Property FileSize As Long
    Get
    Set
Visual C++
public:
property long long FileSize {
    long long get ();
    void set (long long value);
}

See Also

FileHistory Class


FileType Property

[image]

Perforce .NET API
FileHistory..::..FileType Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType FileType { get; set; }
Visual Basic
Public Property FileType As FileType
    Get
    Set
Visual C++
public:
property FileType^ FileType {
    FileType^ get ();
    void set (FileType^ value);
}

See Also

FileHistory Class


IntegrationSummaries Property

[image]

Perforce .NET API
FileHistory..::..IntegrationSummaries Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<RevisionIntegrationSummary> IntegrationSummaries { get; set; }
Visual Basic
Public Property IntegrationSummaries As IList(Of RevisionIntegrationSummary)
    Get
    Set
Visual C++
public:
property IList<RevisionIntegrationSummary^>^ IntegrationSummaries {
    IList<RevisionIntegrationSummary^>^ get ();
    void set (IList<RevisionIntegrationSummary^>^ value);
}

See Also

FileHistory Class


Revision Property

[image]

Perforce .NET API
FileHistory..::..Revision Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Revision { get; set; }
Visual Basic
Public Property Revision As Integer
    Get
    Set
Visual C++
public:
property int Revision {
    int get ();
    void set (int value);
}

See Also

FileHistory Class


UserName Property

[image]

Perforce .NET API
FileHistory..::..UserName Property
FileHistory Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

FileHistory Class


FileIntegrationRecord Class

[image]

Perforce .NET API
FileIntegrationRecord Class
Members See Also Send Feedback
Represents submitted or pending integrations.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileIntegrationRecord
Visual Basic
Public Class FileIntegrationRecord
Visual C++
public ref class FileIntegrationRecord

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileIntegrationRecord

See Also

FileIntegrationRecord Members


FileIntegrationRecord Members

[image] [image]

Perforce .NET API
FileIntegrationRecord Members
FileIntegrationRecord Class Constructors Methods Properties See Also Send Feedback

The FileIntegrationRecord type exposes the following members.

Constructors

 | Name | Description
Public method | FileIntegrationRecord()()()() | Initializes a new instance of the FileIntegrationRecord class
Public method | FileIntegrationRecord(FileSpec, FileSpec, IntegrateAction, Int32) | Initializes a new instance of the FileIntegrationRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromIntegratedCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseIntegratedCmdTaggedData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChangeId |
Public property | FromFile |
Public property | How |
Public property | ToFile |

See Also

FileIntegrationRecord Class


FileIntegrationRecord Constructor

[image] [image]

Perforce .NET API
FileIntegrationRecord Constructor
FileIntegrationRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileIntegrationRecord()()()() | Initializes a new instance of the FileIntegrationRecord class
Public method | FileIntegrationRecord(FileSpec, FileSpec, IntegrateAction, Int32) | Initializes a new instance of the FileIntegrationRecord class

See Also

FileIntegrationRecord Class
FileIntegrationRecord Members


FileIntegrationRecord Constructor

[image]

Perforce .NET API
FileIntegrationRecord Constructor
FileIntegrationRecord Class See Also Send Feedback
Initializes a new instance of the FileIntegrationRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileIntegrationRecord()
Visual Basic
Public Sub New
Visual C++
public:
FileIntegrationRecord()

See Also

FileIntegrationRecord Class
FileIntegrationRecord Overload


FileIntegrationRecord Constructor (FileSpec, FileSpec, , Int32)

[image]

Perforce .NET API
FileIntegrationRecord Constructor (FileSpec, FileSpec, , Int32)
FileIntegrationRecord Class See Also Send Feedback
Initializes a new instance of the FileIntegrationRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileIntegrationRecord(
    FileSpec fromfile,
    FileSpec tofile,
    IntegrateAction how,
    int changeid
)
Visual Basic
Public Sub New ( _
    fromfile As FileSpec, _
    tofile As FileSpec, _
    how As IntegrateAction, _
    changeid As Integer _
)
Visual C++
public:
FileIntegrationRecord(
    FileSpec^ fromfile,
    FileSpec^ tofile,
    IntegrateAction how,
    int changeid
)

Parameters

fromfile
Type: Perforce.P4..::..FileSpec
tofile
Type: Perforce.P4..::..FileSpec
how
Type: IntegrateAction
changeid
Type: System..::..Int32

See Also

FileIntegrationRecord Class
FileIntegrationRecord Overload


FileIntegrationRecord Methods

[image] [image]

Perforce .NET API
FileIntegrationRecord Methods
FileIntegrationRecord Class See Also Send Feedback

The FileIntegrationRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromIntegratedCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseIntegratedCmdTaggedData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileIntegrationRecord Class


FromIntegratedCmdTaggedData Method

[image]

Perforce .NET API
FileIntegrationRecord..::..FromIntegratedCmdTaggedData Method
FileIntegrationRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileIntegrationRecord FromIntegratedCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Shared Function FromIntegratedCmdTaggedData ( _
    obj As TaggedObject _
) As FileIntegrationRecord
Visual C++
public:
static FileIntegrationRecord^ FromIntegratedCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileIntegrationRecord Class


ParseIntegratedCmdTaggedData Method

[image]

Perforce .NET API
FileIntegrationRecord..::..ParseIntegratedCmdTaggedData Method
FileIntegrationRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void ParseIntegratedCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Sub ParseIntegratedCmdTaggedData ( _
    obj As TaggedObject _
)
Visual C++
public:
void ParseIntegratedCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileIntegrationRecord Class


FileIntegrationRecord Properties

[image] [image]

Perforce .NET API
FileIntegrationRecord Properties
FileIntegrationRecord Class See Also Send Feedback

The FileIntegrationRecord type exposes the following members.

Properties

 | Name | Description
Public property | ChangeId |
Public property | FromFile |
Public property | How |
Public property | ToFile |

See Also

FileIntegrationRecord Class


ChangeId Property

[image]

Perforce .NET API
FileIntegrationRecord..::..ChangeId Property
FileIntegrationRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChangeId { get; set; }
Visual Basic
Public Property ChangeId As Integer
    Get
    Set
Visual C++
public:
property int ChangeId {
    int get ();
    void set (int value);
}

See Also

FileIntegrationRecord Class


FromFile Property

[image]

Perforce .NET API
FileIntegrationRecord..::..FromFile Property
FileIntegrationRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec FromFile { get; set; }
Visual Basic
Public Property FromFile As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ FromFile {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

FileIntegrationRecord Class


How Property

[image]

Perforce .NET API
FileIntegrationRecord..::..How Property
FileIntegrationRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IntegrateAction How { get; set; }
Visual Basic
Public Property How As IntegrateAction
    Get
    Set
Visual C++
public:
property IntegrateAction How {
    IntegrateAction get ();
    void set (IntegrateAction value);
}

See Also

FileIntegrationRecord Class


ToFile Property

[image]

Perforce .NET API
FileIntegrationRecord..::..ToFile Property
FileIntegrationRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec ToFile { get; set; }
Visual Basic
Public Property ToFile As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ ToFile {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

FileIntegrationRecord Class


FileLineMatch Class

[image]

Perforce .NET API
FileLineMatch Class
Members See Also Send Feedback
Specifies matching lines in Perforce managed files.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileLineMatch
Visual Basic
Public Class FileLineMatch
Visual C++
public ref class FileLineMatch

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileLineMatch

See Also

FileLineMatch Members


FileLineMatch Members

[image] [image]

Perforce .NET API
FileLineMatch Members
FileLineMatch Class Constructors Methods Fields See Also Send Feedback

The FileLineMatch type exposes the following members.

Constructors

 | Name | Description
Public method | FileLineMatch()()()() | Initializes a new instance of the FileLineMatch class
Public method | FileLineMatch(MatchType, String, Int32, FileSpec) | Initializes a new instance of the FileLineMatch class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromGrepCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseGrepCmdTaggedData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | FileSpec |
Public field | Line |
Public field | LineNumber |
Public field | Type |

See Also

FileLineMatch Class


FileLineMatch Constructor

[image] [image]

Perforce .NET API
FileLineMatch Constructor
FileLineMatch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileLineMatch()()()() | Initializes a new instance of the FileLineMatch class
Public method | FileLineMatch(MatchType, String, Int32, FileSpec) | Initializes a new instance of the FileLineMatch class

See Also

FileLineMatch Class
FileLineMatch Members


FileLineMatch Constructor

[image]

Perforce .NET API
FileLineMatch Constructor
FileLineMatch Class See Also Send Feedback
Initializes a new instance of the FileLineMatch class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileLineMatch()
Visual Basic
Public Sub New
Visual C++
public:
FileLineMatch()

See Also

FileLineMatch Class
FileLineMatch Overload


FileLineMatch Constructor (MatchType, String, Int32, FileSpec)

[image]

Perforce .NET API
FileLineMatch Constructor (MatchType, String, Int32, FileSpec)
FileLineMatch Class See Also Send Feedback
Initializes a new instance of the FileLineMatch class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileLineMatch(
    MatchType type,
    string line,
    int linenumber,
    FileSpec filespec
)
Visual Basic
Public Sub New ( _
    type As MatchType, _
    line As String, _
    linenumber As Integer, _
    filespec As FileSpec _
)
Visual C++
public:
FileLineMatch(
    MatchType type,
    String^ line,
    int linenumber,
    FileSpec^ filespec
)

Parameters

type
Type: Perforce.P4..::..MatchType
line
Type: System..::..String
linenumber
Type: System..::..Int32
filespec
Type: Perforce.P4..::..FileSpec

See Also

FileLineMatch Class
FileLineMatch Overload


FileLineMatch Fields

[image] [image]

Perforce .NET API
FileLineMatch Fields
FileLineMatch Class See Also Send Feedback

The FileLineMatch type exposes the following members.

Fields

 | Name | Description
Public field | FileSpec |
Public field | Line |
Public field | LineNumber |
Public field | Type |

See Also

FileLineMatch Class


FileSpec Field

[image]

Perforce .NET API
FileLineMatch..::..FileSpec Field
FileLineMatch Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec FileSpec
Visual Basic
Public FileSpec As FileSpec
Visual C++
public:
FileSpec^ FileSpec

See Also

FileLineMatch Class


Line Field

[image]

Perforce .NET API
FileLineMatch..::..Line Field
FileLineMatch Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Line
Visual Basic
Public Line As String
Visual C++
public:
String^ Line

See Also

FileLineMatch Class


LineNumber Field

[image]

Perforce .NET API
FileLineMatch..::..LineNumber Field
FileLineMatch Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int LineNumber
Visual Basic
Public LineNumber As Integer
Visual C++
public:
int LineNumber

See Also

FileLineMatch Class


Type Field

[image]

Perforce .NET API
FileLineMatch..::..Type Field
FileLineMatch Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public MatchType Type
Visual Basic
Public Type As MatchType
Visual C++
public:
MatchType Type

See Also

FileLineMatch Class


FileLineMatch Methods

[image] [image]

Perforce .NET API
FileLineMatch Methods
FileLineMatch Class See Also Send Feedback

The FileLineMatch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromGrepCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseGrepCmdTaggedData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileLineMatch Class


FromGrepCmdTaggedData Method

[image]

Perforce .NET API
FileLineMatch..::..FromGrepCmdTaggedData Method
FileLineMatch Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileLineMatch FromGrepCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Shared Function FromGrepCmdTaggedData ( _
    obj As TaggedObject _
) As FileLineMatch
Visual C++
public:
static FileLineMatch^ FromGrepCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileLineMatch Class


ParseGrepCmdTaggedData Method

[image]

Perforce .NET API
FileLineMatch..::..ParseGrepCmdTaggedData Method
FileLineMatch Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void ParseGrepCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Sub ParseGrepCmdTaggedData ( _
    obj As TaggedObject _
)
Visual C++
public:
void ParseGrepCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileLineMatch Class


FileLogCmdFlags Enumeration

[image]

Perforce .NET API
FileLogCmdFlags Enumeration
See Also Send Feedback
Flags for the filelog command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum FileLogCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration FileLogCmdFlags
Visual C++
[FlagsAttribute]
public enum class FileLogCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeInherited | 1 | The -i flag, includes inherited file history. If a file was created by branching (using 'p4 integrate'), filelog lists the revisions of the file's ancestors up to the branch points that led to the specified revision. File history inherited by renaming (using 'p4 move') is always displayed regardless of whether -i is specified.
DisplayContentHistory | 2 | The -h flag, displays file content history instead of file name history. The list includes revisions of other files that were branched or copied (using 'p4 integrate' and 'p4 resolve -at') to the specified revision. Revisions that were replaced by copying or branching are omitted, even if they are part of the history of the specified revision.
IncludeTime | 4 | The -t flag, displays the time as well as the date.
LongOutput | 8 | The -l flag lists the full text of the changelist descriptions.
TruncatedLongOutput | 16 | The -L flag lists the full text of the changelist descriptions, truncated to 250 characters if longer.
ShortForm | 32 | The -s flag displays a shortened form of filelog that omits non-contributory integrations.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


FilelogCmdOptions Class

[image]

Perforce .NET API
FilelogCmdOptions Class
Members See Also Send Feedback
Options for the filelog command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FilelogCmdOptions : Options
Visual Basic
Public Class FilelogCmdOptions _
    Inherits Options
Visual C++
public ref class FilelogCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..FilelogCmdOptions

See Also

FilelogCmdOptions Members


FilelogCmdOptions Members

[image] [image]

Perforce .NET API
FilelogCmdOptions Members
FilelogCmdOptions Class Constructors Methods Properties See Also Send Feedback

The FilelogCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FilelogCmdOptions | Options for the filelog command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FilelogCmdOptions Class


FilelogCmdOptions Constructor

[image]

Perforce .NET API
FilelogCmdOptions Constructor
FilelogCmdOptions Class See Also Send Feedback
Options for the filelog command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FilelogCmdOptions(
    FileLogCmdFlags flags,
    int changelistId,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As FileLogCmdFlags, _
    changelistId As Integer, _
    maxItems As Integer _
)
Visual C++
public:
FilelogCmdOptions(
    FileLogCmdFlags flags,
    int changelistId,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..FileLogCmdFlags
changelistId
Type: System..::..Int32
maxItems
Type: System..::..Int32

See Also

FilelogCmdOptions Class


FilelogCmdOptions Methods

[image] [image]

Perforce .NET API
FilelogCmdOptions Methods
FilelogCmdOptions Class See Also Send Feedback

The FilelogCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FilelogCmdOptions Class


FilelogCmdOptions Properties

[image] [image]

Perforce .NET API
FilelogCmdOptions Properties
FilelogCmdOptions Class See Also Send Feedback

The FilelogCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FilelogCmdOptions Class


FileMetaData Class

[image]

Perforce .NET API
FileMetaData Class
Members See Also Send Feedback
Metadata for a specific file stored in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileMetaData
Visual Basic
Public Class FileMetaData
Visual C++
public ref class FileMetaData

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileMetaData

See Also

FileMetaData Members


FileMetaData Members

[image] [image]

Perforce .NET API
FileMetaData Members
FileMetaData Class Constructors Methods Operators Properties See Also Send Feedback

The FileMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | FileMetaData()()()() | Initializes a new instance of the FileMetaData class
Public method | FileMetaData(File) | Initializes a new instance of the FileMetaData class
Public method | FileMetaData(DepotPath, Boolean, Boolean, FileAction, Int32, Int32, FileType, DateTime, DateTime, Int32, Int32, String, String, Int32, FileAction, FileType, String, Int32, Boolean, Boolean, Boolean, Int32, List<(Of <<'(String>)>>), Boolean, List<(Of <<'(String>)>>), List<(Of <<'(FileAction>)>>), List<(Of <<'(Int32>)>>), Boolean, List<(Of <<'(FileResolveAction>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Int64, String) | Initializes a new instance of the FileMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromFstatCmdTaggedData |
Public method | GetDirectoryName |
Public method | GetFileName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (File to FileMetaData) | Cast a FileSpec to FileMetatData
Implicit Widening Implicit Implicit Implicit (FileMetaData to FileSpec) |
Implicit Widening Implicit Implicit Implicit (FileSpec to FileMetaData) | Cast a FileSpec to FileMetatData

Properties

 | Name | Description
Public property | Action |
Public property | ActionOwner |
Public property | AttributeDigests |
Public property | Attributes |
Public property | AttributesProp |
Public property | Change |
Public property | ClientPath |
Public property | DepotPath | The location of the file in the depot
Public property | Desc |
Public property | Digest |
Public property | Directory |
Public property | FileSize |
Public property | HaveRev |
Public property | HeadAction |
Public property | HeadChange |
Public property | HeadModTime |
Public property | HeadRev |
Public property | HeadTime |
Public property | HeadType |
Public property | IsInClient |
Public property | IsInDepot |
Public property | IsMapped |
Public property | IsStale |
Public property | LocalPath | The location of the file in the client's file system, may be either a ClientPath or a LocalPath
Public property | MovedFile |
Public property | MovedRev |
Public property | OpenAttributes |
Public property | OpenAttributesProp |
Public property | OtherActions |
Public property | OtherChanges |
Public property | OtherLock |
Public property | OtherLockUserClients |
Public property | OtherOpen |
Public property | OtherOpenUserClients |
Public property | OtherUsers |
Public property | OurLock |
Public property | Reresolvable |
Public property | Resolved |
Public property | ResolveRecords |
Public property | Shelved |
Public property | TotalFileCount |
Public property | Type |
Public property | Unresolved |

See Also

FileMetaData Class


FileMetaData Constructor

[image] [image]

Perforce .NET API
FileMetaData Constructor
FileMetaData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileMetaData()()()() | Initializes a new instance of the FileMetaData class
Public method | FileMetaData(File) | Initializes a new instance of the FileMetaData class
Public method | FileMetaData(DepotPath, Boolean, Boolean, FileAction, Int32, Int32, FileType, DateTime, DateTime, Int32, Int32, String, String, Int32, FileAction, FileType, String, Int32, Boolean, Boolean, Boolean, Int32, List<(Of <<'(String>)>>), Boolean, List<(Of <<'(String>)>>), List<(Of <<'(FileAction>)>>), List<(Of <<'(Int32>)>>), Boolean, List<(Of <<'(FileResolveAction>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Dictionary<(Of <<'(String, Object>)>>), Int64, String) | Initializes a new instance of the FileMetaData class

See Also

FileMetaData Class
FileMetaData Members


FileMetaData Constructor

[image]

Perforce .NET API
FileMetaData Constructor
FileMetaData Class See Also Send Feedback
Initializes a new instance of the FileMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileMetaData()
Visual Basic
Public Sub New
Visual C++
public:
FileMetaData()

See Also

FileMetaData Class
FileMetaData Overload


FileMetaData Constructor (File)

[image]

Perforce .NET API
FileMetaData Constructor (File)
FileMetaData Class See Also Send Feedback
Initializes a new instance of the FileMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileMetaData(
    File f
)
Visual Basic
Public Sub New ( _
    f As File _
)
Visual C++
public:
FileMetaData(
    File^ f
)

Parameters

f
Type: Perforce.P4..::..File

See Also

FileMetaData Class
FileMetaData Overload


FileMetaData Constructor (DepotPath, Boolean, Boolean, FileAction, Int32, Int32, FileType, DateTime, DateTime, Int32, Int32, String, String, Int32, FileAction, FileType, String, Int32, Boolean, Boolean, Boolean, Int32, List(String), Boolean, List(String), List(FileAction), List(Int32), Boolean, List

[image]

Perforce .NET API
FileMetaData Constructor (DepotPath, Boolean, Boolean, FileAction, Int32, Int32, FileType, DateTime, DateTime, Int32, Int32, String, String, Int32, FileAction, FileType, String, Int32, Boolean, Boolean, Boolean, Int32, List<(Of <(<'String>)>)>, Boolean, List<(Of <(<'String>)>)>, List<(Of <(<'FileAction>)>)>, List<(Of <(<'Int32>)>)>, Boolean, List<(Of <(<'FileResolveAction>)>)>, Dictionary<(Of <(<'String, Object>)>)>, Dictionary<(Of <(<'String, Object>)>)>, Dictionary<(Of <(<'String, Object>)>)>, Dictionary<(Of <(<'String, Object>)>)>, Dictionary<(Of <(<'String, Object>)>)>, Int64, String)
FileMetaData Class See Also Send Feedback
Initializes a new instance of the FileMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileMetaData(
    DepotPath movedfile,
    bool ismapped,
    bool shelved,
    FileAction headaction,
    int headchange,
    int headrev,
    FileType headtype,
    DateTime headtime,
    DateTime headmodtime,
    int movedrev,
    int haverev,
    string desc,
    string digest,
    int filesize,
    FileAction action,
    FileType type,
    string actionowner,
    int change,
    bool resolved,
    bool unresolved,
    bool reresolvable,
    int otheropen,
    List<string> otheropenuserclients,
    bool otherlock,
    List<string> otherlockuserclients,
    List<FileAction> otheractions,
    List<int> otherchanges,
    bool ourlock,
    List<FileResolveAction> resolverecords,
    Dictionary<string, Object> attributes,
    Dictionary<string, Object> attributesprop,
    Dictionary<string, Object> attributedigests,
    Dictionary<string, Object> openattributes,
    Dictionary<string, Object> openattributesprop,
    long totalfilecount,
    string directory
)
Visual Basic
Public Sub New ( _
    movedfile As DepotPath, _
    ismapped As Boolean, _
    shelved As Boolean, _
    headaction As FileAction, _
    headchange As Integer, _
    headrev As Integer, _
    headtype As FileType, _
    headtime As DateTime, _
    headmodtime As DateTime, _
    movedrev As Integer, _
    haverev As Integer, _
    desc As String, _
    digest As String, _
    filesize As Integer, _
    action As FileAction, _
    type As FileType, _
    actionowner As String, _
    change As Integer, _
    resolved As Boolean, _
    unresolved As Boolean, _
    reresolvable As Boolean, _
    otheropen As Integer, _
    otheropenuserclients As List(Of String), _
    otherlock As Boolean, _
    otherlockuserclients As List(Of String), _
    otheractions As List(Of FileAction), _
    otherchanges As List(Of Integer), _
    ourlock As Boolean, _
    resolverecords As List(Of FileResolveAction), _
    attributes As Dictionary(Of String, Object), _
    attributesprop As Dictionary(Of String, Object), _
    attributedigests As Dictionary(Of String, Object), _
    openattributes As Dictionary(Of String, Object), _
    openattributesprop As Dictionary(Of String, Object), _
    totalfilecount As Long, _
    directory As String _
)
Visual C++
public:
FileMetaData(
    DepotPath^ movedfile,
    bool ismapped,
    bool shelved,
    FileAction headaction,
    int headchange,
    int headrev,
    FileType^ headtype,
    DateTime headtime,
    DateTime headmodtime,
    int movedrev,
    int haverev,
    String^ desc,
    String^ digest,
    int filesize,
    FileAction action,
    FileType^ type,
    String^ actionowner,
    int change,
    bool resolved,
    bool unresolved,
    bool reresolvable,
    int otheropen,
    List<String^>^ otheropenuserclients,
    bool otherlock,
    List<String^>^ otherlockuserclients,
    List<FileAction>^ otheractions,
    List<int>^ otherchanges,
    bool ourlock,
    List<FileResolveAction^>^ resolverecords,
    Dictionary<String^, Object^>^ attributes,
    Dictionary<String^, Object^>^ attributesprop,
    Dictionary<String^, Object^>^ attributedigests,
    Dictionary<String^, Object^>^ openattributes,
    Dictionary<String^, Object^>^ openattributesprop,
    long long totalfilecount,
    String^ directory
)

Parameters

movedfile
Type: Perforce.P4..::..DepotPath
ismapped
Type: System..::..Boolean
shelved
Type: System..::..Boolean
headaction
Type: Perforce.P4..::..FileAction
headchange
Type: System..::..Int32
headrev
Type: System..::..Int32
headtype
Type: Perforce.P4..::..FileType
headtime
Type: System..::..DateTime
headmodtime
Type: System..::..DateTime
movedrev
Type: System..::..Int32
haverev
Type: System..::..Int32
desc
Type: System..::..String
digest
Type: System..::..String
filesize
Type: System..::..Int32
action
Type: Perforce.P4..::..FileAction
type
Type: Perforce.P4..::..FileType
actionowner
Type: System..::..String
change
Type: System..::..Int32
resolved
Type: System..::..Boolean
unresolved
Type: System..::..Boolean
reresolvable
Type: System..::..Boolean
otheropen
Type: System..::..Int32
otheropenuserclients
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
otherlock
Type: System..::..Boolean
otherlockuserclients
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
otheractions
Type: System.Collections.Generic..::..List <(Of <(<' FileAction >)>)>
otherchanges
Type: System.Collections.Generic..::..List <(Of <(<' Int32 >)>)>
ourlock
Type: System..::..Boolean
resolverecords
Type: System.Collections.Generic..::..List <(Of <(<' FileResolveAction >)>)>
attributes
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
attributesprop
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
attributedigests
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
openattributes
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
openattributesprop
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
totalfilecount
Type: System..::..Int64
directory
Type: System..::..String

See Also

FileMetaData Class
FileMetaData Overload


FileMetaData Methods

[image] [image]

Perforce .NET API
FileMetaData Methods
FileMetaData Class See Also Send Feedback

The FileMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromFstatCmdTaggedData |
Public method | GetDirectoryName |
Public method | GetFileName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileMetaData Class


FromFstatCmdTaggedData Method

[image]

Perforce .NET API
FileMetaData..::..FromFstatCmdTaggedData Method
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromFstatCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Sub FromFstatCmdTaggedData ( _
    obj As TaggedObject _
)
Visual C++
public:
void FromFstatCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileMetaData Class


GetDirectoryName Method

[image]

Perforce .NET API
FileMetaData..::..GetDirectoryName Method
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetDirectoryName()
Visual Basic
Public Function GetDirectoryName As String
Visual C++
public:
String^ GetDirectoryName()

See Also

FileMetaData Class


GetFileName Method

[image]

Perforce .NET API
FileMetaData..::..GetFileName Method
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetFileName()
Visual Basic
Public Function GetFileName As String
Visual C++
public:
String^ GetFileName()

See Also

FileMetaData Class


FileMetaData Type Conversions

[image] [image]

Perforce .NET API
FileMetaData Type Conversions
FileMetaData Class See Also Send Feedback

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (File to FileMetaData) | Cast a FileSpec to FileMetatData
Implicit Widening Implicit Implicit Implicit (FileMetaData to FileSpec) |
Implicit Widening Implicit Implicit Implicit (FileSpec to FileMetaData) | Cast a FileSpec to FileMetatData

See Also

FileMetaData Class


Implicit Conversion Operators

[image] [image]

Perforce .NET API
FileMetaData ImplicitWideningImplicitImplicitImplicit Conversion Operators
FileMetaData Class See Also Send Feedback

Overload List

Name | Description
Implicit Widening Implicit Implicit Implicit (File to FileMetaData) | Cast a FileSpec to FileMetatData
Implicit Widening Implicit Implicit Implicit (FileMetaData to FileSpec) |
Implicit Widening Implicit Implicit Implicit (FileSpec to FileMetaData) | Cast a FileSpec to FileMetatData

See Also

FileMetaData Class
FileMetaData Members


Implicit Conversion (File to FileMetaData)

[image]

Perforce .NET API
FileMetaData ImplicitWideningImplicitImplicitImplicit Conversion (File to FileMetaData)
FileMetaData Class See Also Send Feedback
Cast a FileSpec to FileMetatData

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator FileMetaData (
    File f
)
Visual Basic
Public Shared Widening Operator CType ( _
    f As File _
) As FileMetaData
Visual C++
static implicit operator FileMetaData^ (
    File^ f
)

Parameters

f
Type: Perforce.P4..::..File

Return Value

See Also

FileMetaData Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (FileMetaData to FileSpec)

[image]

Perforce .NET API
FileMetaData ImplicitWideningImplicitImplicitImplicit Conversion (FileMetaData to FileSpec)
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator FileSpec (
    FileMetaData s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As FileMetaData _
) As FileSpec
Visual C++
static implicit operator FileSpec^ (
    FileMetaData^ s
)

Parameters

s
Type: Perforce.P4..::..FileMetaData

See Also

FileMetaData Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (FileSpec to FileMetaData)

[image]

Perforce .NET API
FileMetaData ImplicitWideningImplicitImplicitImplicit Conversion (FileSpec to FileMetaData)
FileMetaData Class See Also Send Feedback
Cast a FileSpec to FileMetatData

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator FileMetaData (
    FileSpec f
)
Visual Basic
Public Shared Widening Operator CType ( _
    f As FileSpec _
) As FileMetaData
Visual C++
static implicit operator FileMetaData^ (
    FileSpec^ f
)

Parameters

f
Type: Perforce.P4..::..FileSpec

Return Value

See Also

FileMetaData Class
ImplicitWideningImplicitImplicitImplicit Overload


FileMetaData Properties

[image] [image]

Perforce .NET API
FileMetaData Properties
FileMetaData Class See Also Send Feedback

The FileMetaData type exposes the following members.

Properties

 | Name | Description
Public property | Action |
Public property | ActionOwner |
Public property | AttributeDigests |
Public property | Attributes |
Public property | AttributesProp |
Public property | Change |
Public property | ClientPath |
Public property | DepotPath | The location of the file in the depot
Public property | Desc |
Public property | Digest |
Public property | Directory |
Public property | FileSize |
Public property | HaveRev |
Public property | HeadAction |
Public property | HeadChange |
Public property | HeadModTime |
Public property | HeadRev |
Public property | HeadTime |
Public property | HeadType |
Public property | IsInClient |
Public property | IsInDepot |
Public property | IsMapped |
Public property | IsStale |
Public property | LocalPath | The location of the file in the client's file system, may be either a ClientPath or a LocalPath
Public property | MovedFile |
Public property | MovedRev |
Public property | OpenAttributes |
Public property | OpenAttributesProp |
Public property | OtherActions |
Public property | OtherChanges |
Public property | OtherLock |
Public property | OtherLockUserClients |
Public property | OtherOpen |
Public property | OtherOpenUserClients |
Public property | OtherUsers |
Public property | OurLock |
Public property | Reresolvable |
Public property | Resolved |
Public property | ResolveRecords |
Public property | Shelved |
Public property | TotalFileCount |
Public property | Type |
Public property | Unresolved |

See Also

FileMetaData Class


Action Property

[image]

Perforce .NET API
FileMetaData..::..Action Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction Action { get; set; }
Visual Basic
Public Property Action As FileAction
    Get
    Set
Visual C++
public:
property FileAction Action {
    FileAction get ();
    void set (FileAction value);
}

See Also

FileMetaData Class


ActionOwner Property

[image]

Perforce .NET API
FileMetaData..::..ActionOwner Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ActionOwner { get; set; }
Visual Basic
Public Property ActionOwner As String
    Get
    Set
Visual C++
public:
property String^ ActionOwner {
    String^ get ();
    void set (String^ value);
}

See Also

FileMetaData Class


AttributeDigests Property

[image]

Perforce .NET API
FileMetaData..::..AttributeDigests Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, Object> AttributeDigests { get; set; }
Visual Basic
Public Property AttributeDigests As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ AttributeDigests {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

See Also

FileMetaData Class


Attributes Property

[image]

Perforce .NET API
FileMetaData..::..Attributes Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, Object> Attributes { get; set; }
Visual Basic
Public Property Attributes As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ Attributes {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

See Also

FileMetaData Class


AttributesProp Property

[image]

Perforce .NET API
FileMetaData..::..AttributesProp Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, Object> AttributesProp { get; set; }
Visual Basic
Public Property AttributesProp As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ AttributesProp {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

See Also

FileMetaData Class


Change Property

[image]

Perforce .NET API
FileMetaData..::..Change Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Change { get; set; }
Visual Basic
Public Property Change As Integer
    Get
    Set
Visual C++
public:
property int Change {
    int get ();
    void set (int value);
}

See Also

FileMetaData Class


ClientPath Property

[image]

Perforce .NET API
FileMetaData..::..ClientPath Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientPath ClientPath { get; set; }
Visual Basic
Public Property ClientPath As ClientPath
    Get
    Set
Visual C++
public:
property ClientPath^ ClientPath {
    ClientPath^ get ();
    void set (ClientPath^ value);
}

See Also

FileMetaData Class


DepotPath Property

[image]

Perforce .NET API
FileMetaData..::..DepotPath Property
FileMetaData Class See Also Send Feedback
The location of the file in the depot

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotPath DepotPath { get; set; }
Visual Basic
Public Property DepotPath As DepotPath
    Get
    Set
Visual C++
public:
property DepotPath^ DepotPath {
    DepotPath^ get ();
    void set (DepotPath^ value);
}

See Also

FileMetaData Class


Desc Property

[image]

Perforce .NET API
FileMetaData..::..Desc Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Desc { get; set; }
Visual Basic
Public Property Desc As String
    Get
    Set
Visual C++
public:
property String^ Desc {
    String^ get ();
    void set (String^ value);
}

See Also

FileMetaData Class


Digest Property

[image]

Perforce .NET API
FileMetaData..::..Digest Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Digest { get; set; }
Visual Basic
Public Property Digest As String
    Get
    Set
Visual C++
public:
property String^ Digest {
    String^ get ();
    void set (String^ value);
}

See Also

FileMetaData Class


Directory Property

[image]

Perforce .NET API
FileMetaData..::..Directory Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Directory { get; set; }
Visual Basic
Public Property Directory As String
    Get
    Set
Visual C++
public:
property String^ Directory {
    String^ get ();
    void set (String^ value);
}

See Also

FileMetaData Class


FileSize Property

[image]

Perforce .NET API
FileMetaData..::..FileSize Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public long FileSize { get; set; }
Visual Basic
Public Property FileSize As Long
    Get
    Set
Visual C++
public:
property long long FileSize {
    long long get ();
    void set (long long value);
}

See Also

FileMetaData Class


HaveRev Property

[image]

Perforce .NET API
FileMetaData..::..HaveRev Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int HaveRev { get; set; }
Visual Basic
Public Property HaveRev As Integer
    Get
    Set
Visual C++
public:
property int HaveRev {
    int get ();
    void set (int value);
}

See Also

FileMetaData Class


HeadAction Property

[image]

Perforce .NET API
FileMetaData..::..HeadAction Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction HeadAction { get; set; }
Visual Basic
Public Property HeadAction As FileAction
    Get
    Set
Visual C++
public:
property FileAction HeadAction {
    FileAction get ();
    void set (FileAction value);
}

See Also

FileMetaData Class


HeadChange Property

[image]

Perforce .NET API
FileMetaData..::..HeadChange Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int HeadChange { get; set; }
Visual Basic
Public Property HeadChange As Integer
    Get
    Set
Visual C++
public:
property int HeadChange {
    int get ();
    void set (int value);
}

See Also

FileMetaData Class


HeadModTime Property

[image]

Perforce .NET API
FileMetaData..::..HeadModTime Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime HeadModTime { get; set; }
Visual Basic
Public Property HeadModTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime HeadModTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

FileMetaData Class


HeadRev Property

[image]

Perforce .NET API
FileMetaData..::..HeadRev Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int HeadRev { get; set; }
Visual Basic
Public Property HeadRev As Integer
    Get
    Set
Visual C++
public:
property int HeadRev {
    int get ();
    void set (int value);
}

See Also

FileMetaData Class


HeadTime Property

[image]

Perforce .NET API
FileMetaData..::..HeadTime Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime HeadTime { get; set; }
Visual Basic
Public Property HeadTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime HeadTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

FileMetaData Class


HeadType Property

[image]

Perforce .NET API
FileMetaData..::..HeadType Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType HeadType { get; set; }
Visual Basic
Public Property HeadType As FileType
    Get
    Set
Visual C++
public:
property FileType^ HeadType {
    FileType^ get ();
    void set (FileType^ value);
}

See Also

FileMetaData Class


IsInClient Property

[image]

Perforce .NET API
FileMetaData..::..IsInClient Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsInClient { get; }
Visual Basic
Public ReadOnly Property IsInClient As Boolean
    Get
Visual C++
public:
property bool IsInClient {
    bool get ();
}

See Also

FileMetaData Class


IsInDepot Property

[image]

Perforce .NET API
FileMetaData..::..IsInDepot Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsInDepot { get; }
Visual Basic
Public ReadOnly Property IsInDepot As Boolean
    Get
Visual C++
public:
property bool IsInDepot {
    bool get ();
}

See Also

FileMetaData Class


IsMapped Property

[image]

Perforce .NET API
FileMetaData..::..IsMapped Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsMapped { get; set; }
Visual Basic
Public Property IsMapped As Boolean
    Get
    Set
Visual C++
public:
property bool IsMapped {
    bool get ();
    void set (bool value);
}

See Also

FileMetaData Class


IsStale Property

[image]

Perforce .NET API
FileMetaData..::..IsStale Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsStale { get; }
Visual Basic
Public ReadOnly Property IsStale As Boolean
    Get
Visual C++
public:
property bool IsStale {
    bool get ();
}

See Also

FileMetaData Class


LocalPath Property

[image]

Perforce .NET API
FileMetaData..::..LocalPath Property
FileMetaData Class See Also Send Feedback
The location of the file in the client's file system, may be either a ClientPath or a LocalPath

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LocalPath LocalPath { get; set; }
Visual Basic
Public Property LocalPath As LocalPath
    Get
    Set
Visual C++
public:
property LocalPath^ LocalPath {
    LocalPath^ get ();
    void set (LocalPath^ value);
}

See Also

FileMetaData Class


MovedFile Property

[image]

Perforce .NET API
FileMetaData..::..MovedFile Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotPath MovedFile { get; set; }
Visual Basic
Public Property MovedFile As DepotPath
    Get
    Set
Visual C++
public:
property DepotPath^ MovedFile {
    DepotPath^ get ();
    void set (DepotPath^ value);
}

See Also

FileMetaData Class


MovedRev Property

[image]

Perforce .NET API
FileMetaData..::..MovedRev Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int MovedRev { get; set; }
Visual Basic
Public Property MovedRev As Integer
    Get
    Set
Visual C++
public:
property int MovedRev {
    int get ();
    void set (int value);
}

See Also

FileMetaData Class


OpenAttributes Property

[image]

Perforce .NET API
FileMetaData..::..OpenAttributes Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, Object> OpenAttributes { get; set; }
Visual Basic
Public Property OpenAttributes As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ OpenAttributes {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

See Also

FileMetaData Class


OpenAttributesProp Property

[image]

Perforce .NET API
FileMetaData..::..OpenAttributesProp Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, Object> OpenAttributesProp { get; set; }
Visual Basic
Public Property OpenAttributesProp As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ OpenAttributesProp {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

See Also

FileMetaData Class


OtherActions Property

[image]

Perforce .NET API
FileMetaData..::..OtherActions Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileAction> OtherActions { get; set; }
Visual Basic
Public Property OtherActions As IList(Of FileAction)
    Get
    Set
Visual C++
public:
property IList<FileAction>^ OtherActions {
    IList<FileAction>^ get ();
    void set (IList<FileAction>^ value);
}

See Also

FileMetaData Class


OtherChanges Property

[image]

Perforce .NET API
FileMetaData..::..OtherChanges Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<int> OtherChanges { get; set; }
Visual Basic
Public Property OtherChanges As IList(Of Integer)
    Get
    Set
Visual C++
public:
property IList<int>^ OtherChanges {
    IList<int>^ get ();
    void set (IList<int>^ value);
}

See Also

FileMetaData Class


OtherLock Property

[image]

Perforce .NET API
FileMetaData..::..OtherLock Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool OtherLock { get; set; }
Visual Basic
Public Property OtherLock As Boolean
    Get
    Set
Visual C++
public:
property bool OtherLock {
    bool get ();
    void set (bool value);
}

See Also

FileMetaData Class


OtherLockUserClients Property

[image]

Perforce .NET API
FileMetaData..::..OtherLockUserClients Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> OtherLockUserClients { get; set; }
Visual Basic
Public Property OtherLockUserClients As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ OtherLockUserClients {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

FileMetaData Class


OtherOpen Property

[image]

Perforce .NET API
FileMetaData..::..OtherOpen Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int OtherOpen { get; set; }
Visual Basic
Public Property OtherOpen As Integer
    Get
    Set
Visual C++
public:
property int OtherOpen {
    int get ();
    void set (int value);
}

See Also

FileMetaData Class


OtherOpenUserClients Property

[image]

Perforce .NET API
FileMetaData..::..OtherOpenUserClients Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> OtherOpenUserClients { get; set; }
Visual Basic
Public Property OtherOpenUserClients As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ OtherOpenUserClients {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

FileMetaData Class


OtherUsers Property

[image]

Perforce .NET API
FileMetaData..::..OtherUsers Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public OtherUsers OtherUsers { get; set; }
Visual Basic
Public Property OtherUsers As OtherUsers
    Get
    Set
Visual C++
public:
property OtherUsers^ OtherUsers {
    OtherUsers^ get ();
    void set (OtherUsers^ value);
}

See Also

FileMetaData Class


OurLock Property

[image]

Perforce .NET API
FileMetaData..::..OurLock Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool OurLock { get; set; }
Visual Basic
Public Property OurLock As Boolean
    Get
    Set
Visual C++
public:
property bool OurLock {
    bool get ();
    void set (bool value);
}

See Also

FileMetaData Class


Reresolvable Property

[image]

Perforce .NET API
FileMetaData..::..Reresolvable Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Reresolvable { get; set; }
Visual Basic
Public Property Reresolvable As Boolean
    Get
    Set
Visual C++
public:
property bool Reresolvable {
    bool get ();
    void set (bool value);
}

See Also

FileMetaData Class


Resolved Property

[image]

Perforce .NET API
FileMetaData..::..Resolved Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Resolved { get; set; }
Visual Basic
Public Property Resolved As Boolean
    Get
    Set
Visual C++
public:
property bool Resolved {
    bool get ();
    void set (bool value);
}

See Also

FileMetaData Class


ResolveRecords Property

[image]

Perforce .NET API
FileMetaData..::..ResolveRecords Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileResolveAction> ResolveRecords { get; set; }
Visual Basic
Public Property ResolveRecords As IList(Of FileResolveAction)
    Get
    Set
Visual C++
public:
property IList<FileResolveAction^>^ ResolveRecords {
    IList<FileResolveAction^>^ get ();
    void set (IList<FileResolveAction^>^ value);
}

See Also

FileMetaData Class


Shelved Property

[image]

Perforce .NET API
FileMetaData..::..Shelved Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Shelved { get; set; }
Visual Basic
Public Property Shelved As Boolean
    Get
    Set
Visual C++
public:
property bool Shelved {
    bool get ();
    void set (bool value);
}

See Also

FileMetaData Class


TotalFileCount Property

[image]

Perforce .NET API
FileMetaData..::..TotalFileCount Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public long TotalFileCount { get; set; }
Visual Basic
Public Property TotalFileCount As Long
    Get
    Set
Visual C++
public:
property long long TotalFileCount {
    long long get ();
    void set (long long value);
}

See Also

FileMetaData Class


Type Property

[image]

Perforce .NET API
FileMetaData..::..Type Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType Type { get; set; }
Visual Basic
Public Property Type As FileType
    Get
    Set
Visual C++
public:
property FileType^ Type {
    FileType^ get ();
    void set (FileType^ value);
}

See Also

FileMetaData Class


Unresolved Property

[image]

Perforce .NET API
FileMetaData..::..Unresolved Property
FileMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Unresolved { get; set; }
Visual Basic
Public Property Unresolved As Boolean
    Get
    Set
Visual C++
public:
property bool Unresolved {
    bool get ();
    void set (bool value);
}

See Also

FileMetaData Class


FileResolveAction Class

[image]

Perforce .NET API
FileResolveAction Class
Members See Also Send Feedback
Describes how, or if a file has been resolved.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileResolveAction
Visual Basic
Public Class FileResolveAction
Visual C++
public ref class FileResolveAction

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileResolveAction

See Also

FileResolveAction Members


FileResolveAction Members

[image] [image]

Perforce .NET API
FileResolveAction Members
FileResolveAction Class Constructors Methods Properties See Also Send Feedback

The FileResolveAction type exposes the following members.

Constructors

 | Name | Description
Public method | FileResolveAction()()()() | Initializes a new instance of the FileResolveAction class
Public method | FileResolveAction(ResolveAction, FileSpec, FileSpec, Int32, Int32) | Initializes a new instance of the FileResolveAction class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ResolveAction |
Public property | ResolveBaseFile |
Public property | ResolveEndFromRev |
Public property | ResolveFromFile |
Public property | ResolveStartFromRev |

See Also

FileResolveAction Class


FileResolveAction Constructor

[image] [image]

Perforce .NET API
FileResolveAction Constructor
FileResolveAction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileResolveAction()()()() | Initializes a new instance of the FileResolveAction class
Public method | FileResolveAction(ResolveAction, FileSpec, FileSpec, Int32, Int32) | Initializes a new instance of the FileResolveAction class

See Also

FileResolveAction Class
FileResolveAction Members


FileResolveAction Constructor

[image]

Perforce .NET API
FileResolveAction Constructor
FileResolveAction Class See Also Send Feedback
Initializes a new instance of the FileResolveAction class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileResolveAction()
Visual Basic
Public Sub New
Visual C++
public:
FileResolveAction()

See Also

FileResolveAction Class
FileResolveAction Overload


FileResolveAction Constructor (ResolveAction, FileSpec, FileSpec, Int32, Int32)

[image]

Perforce .NET API
FileResolveAction Constructor (ResolveAction, FileSpec, FileSpec, Int32, Int32)
FileResolveAction Class See Also Send Feedback
Initializes a new instance of the FileResolveAction class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileResolveAction(
    ResolveAction resolveaction,
    FileSpec resolvebasefile,
    FileSpec resolvefromfile,
    int resolvestartfromrev,
    int resolveendfromrev
)
Visual Basic
Public Sub New ( _
    resolveaction As ResolveAction, _
    resolvebasefile As FileSpec, _
    resolvefromfile As FileSpec, _
    resolvestartfromrev As Integer, _
    resolveendfromrev As Integer _
)
Visual C++
public:
FileResolveAction(
    ResolveAction resolveaction,
    FileSpec^ resolvebasefile,
    FileSpec^ resolvefromfile,
    int resolvestartfromrev,
    int resolveendfromrev
)

Parameters

resolveaction
Type: Perforce.P4..::..ResolveAction
resolvebasefile
Type: Perforce.P4..::..FileSpec
resolvefromfile
Type: Perforce.P4..::..FileSpec
resolvestartfromrev
Type: System..::..Int32
resolveendfromrev
Type: System..::..Int32

See Also

FileResolveAction Class
FileResolveAction Overload


FileResolveAction Methods

[image] [image]

Perforce .NET API
FileResolveAction Methods
FileResolveAction Class See Also Send Feedback

The FileResolveAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileResolveAction Class


FileResolveAction Properties

[image] [image]

Perforce .NET API
FileResolveAction Properties
FileResolveAction Class See Also Send Feedback

The FileResolveAction type exposes the following members.

Properties

 | Name | Description
Public property | ResolveAction |
Public property | ResolveBaseFile |
Public property | ResolveEndFromRev |
Public property | ResolveFromFile |
Public property | ResolveStartFromRev |

See Also

FileResolveAction Class


ResolveAction Property

[image]

Perforce .NET API
FileResolveAction..::..ResolveAction Property
FileResolveAction Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveAction ResolveAction { get; set; }
Visual Basic
Public Property ResolveAction As ResolveAction
    Get
    Set
Visual C++
public:
property ResolveAction ResolveAction {
    ResolveAction get ();
    void set (ResolveAction value);
}

See Also

FileResolveAction Class


ResolveBaseFile Property

[image]

Perforce .NET API
FileResolveAction..::..ResolveBaseFile Property
FileResolveAction Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec ResolveBaseFile { get; set; }
Visual Basic
Public Property ResolveBaseFile As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ ResolveBaseFile {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

FileResolveAction Class


ResolveEndFromRev Property

[image]

Perforce .NET API
FileResolveAction..::..ResolveEndFromRev Property
FileResolveAction Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ResolveEndFromRev { get; set; }
Visual Basic
Public Property ResolveEndFromRev As Integer
    Get
    Set
Visual C++
public:
property int ResolveEndFromRev {
    int get ();
    void set (int value);
}

See Also

FileResolveAction Class


ResolveFromFile Property

[image]

Perforce .NET API
FileResolveAction..::..ResolveFromFile Property
FileResolveAction Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec ResolveFromFile { get; set; }
Visual Basic
Public Property ResolveFromFile As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ ResolveFromFile {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

FileResolveAction Class


ResolveStartFromRev Property

[image]

Perforce .NET API
FileResolveAction..::..ResolveStartFromRev Property
FileResolveAction Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ResolveStartFromRev { get; set; }
Visual Basic
Public Property ResolveStartFromRev As Integer
    Get
    Set
Visual C++
public:
property int ResolveStartFromRev {
    int get ();
    void set (int value);
}

See Also

FileResolveAction Class


FileResolveRecord Class

[image]

Perforce .NET API
FileResolveRecord Class
Members See Also Send Feedback
Specifies how file resolve operations were completed or will potentially be completed.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileResolveRecord
Visual Basic
Public Class FileResolveRecord
Visual C++
public ref class FileResolveRecord

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileResolveRecord

See Also

FileResolveRecord Members


FileResolveRecord Members

[image] [image]

Perforce .NET API
FileResolveRecord Members
FileResolveRecord Class Constructors Methods Properties See Also Send Feedback

The FileResolveRecord type exposes the following members.

Constructors

 | Name | Description
Public method | FileResolveRecord()()()() | Initializes a new instance of the FileResolveRecord class
Public method | FileResolveRecord(String) | Initializes a new instance of the FileResolveRecord class
Public method | FileResolveRecord(TaggedObject) | Initializes a new instance of the FileResolveRecord class
Public method | FileResolveRecord(FileAction, FileSpec, FileSpec) | Initializes a new instance of the FileResolveRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromMergeInfo(P4ClientInfoMessageList) |
 | FromMergeInfo(String, String, String) |
 | FromResolveCmdTaggedOutput |
 | FromResolvedCmdTaggedOutput |
Public method | FromTaggedOutput |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeRecords |
Public method | Parse |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action |
Public property | Analysis |
Public property | BaseFileSpec |
Public property | FromFileSpec |
Public property | LocalFilePath |
Public property | ResolveSubtype |
Public property | ResolveType |
Public property | Result |
Public property | Sumary |

See Also

FileResolveRecord Class


FileResolveRecord Constructor

[image] [image]

Perforce .NET API
FileResolveRecord Constructor
FileResolveRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileResolveRecord()()()() | Initializes a new instance of the FileResolveRecord class
Public method | FileResolveRecord(String) | Initializes a new instance of the FileResolveRecord class
Public method | FileResolveRecord(TaggedObject) | Initializes a new instance of the FileResolveRecord class
Public method | FileResolveRecord(FileAction, FileSpec, FileSpec) | Initializes a new instance of the FileResolveRecord class

See Also

FileResolveRecord Class
FileResolveRecord Members


FileResolveRecord Constructor

[image]

Perforce .NET API
FileResolveRecord Constructor
FileResolveRecord Class See Also Send Feedback
Initializes a new instance of the FileResolveRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileResolveRecord()
Visual Basic
Public Sub New
Visual C++
public:
FileResolveRecord()

See Also

FileResolveRecord Class
FileResolveRecord Overload


FileResolveRecord Constructor (String)

[image]

Perforce .NET API
FileResolveRecord Constructor (String)
FileResolveRecord Class See Also Send Feedback
Initializes a new instance of the FileResolveRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileResolveRecord(
    string spec
)
Visual Basic
Public Sub New ( _
    spec As String _
)
Visual C++
public:
FileResolveRecord(
    String^ spec
)

Parameters

spec
Type: System..::..String

See Also

FileResolveRecord Class
FileResolveRecord Overload


FileResolveRecord Constructor (TaggedObject)

[image]

Perforce .NET API
FileResolveRecord Constructor (TaggedObject)
FileResolveRecord Class See Also Send Feedback
Initializes a new instance of the FileResolveRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileResolveRecord(
    TaggedObject obj
)
Visual Basic
Public Sub New ( _
    obj As TaggedObject _
)
Visual C++
public:
FileResolveRecord(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileResolveRecord Class
FileResolveRecord Overload


FileResolveRecord Constructor (FileAction, FileSpec, FileSpec)

[image]

Perforce .NET API
FileResolveRecord Constructor (FileAction, FileSpec, FileSpec)
FileResolveRecord Class See Also Send Feedback
Initializes a new instance of the FileResolveRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileResolveRecord(
    FileAction action,
    FileSpec baseFile,
    FileSpec fromFile
)
Visual Basic
Public Sub New ( _
    action As FileAction, _
    baseFile As FileSpec, _
    fromFile As FileSpec _
)
Visual C++
public:
FileResolveRecord(
    FileAction action,
    FileSpec^ baseFile,
    FileSpec^ fromFile
)

Parameters

action
Type: Perforce.P4..::..FileAction
baseFile
Type: Perforce.P4..::..FileSpec
fromFile
Type: Perforce.P4..::..FileSpec

See Also

FileResolveRecord Class
FileResolveRecord Overload


FileResolveRecord Methods

[image] [image]

Perforce .NET API
FileResolveRecord Methods
FileResolveRecord Class See Also Send Feedback

The FileResolveRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromMergeInfo(P4ClientInfoMessageList) |
 | FromMergeInfo(String, String, String) |
 | FromResolveCmdTaggedOutput |
 | FromResolvedCmdTaggedOutput |
Public method | FromTaggedOutput |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeRecords |
Public method | Parse |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileResolveRecord Class


FromMergeInfo Method

[image] [image]

Perforce .NET API
FileResolveRecord..::..FromMergeInfo Method
FileResolveRecord Class See Also Send Feedback

Overload List

Name | Description
FromMergeInfo(P4ClientInfoMessageList) |
FromMergeInfo(String, String, String) |

See Also

FileResolveRecord Class
FileResolveRecord Members


FromMergeInfo Method (P4ClientInfoMessageList)

[image]

Perforce .NET API
FileResolveRecord..::..FromMergeInfo Method (P4ClientInfoMessageList)
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileResolveRecord FromMergeInfo(
    P4ClientInfoMessageList info
)
Visual Basic
Public Shared Function FromMergeInfo ( _
    info As P4ClientInfoMessageList _
) As FileResolveRecord
Visual C++
public:
static FileResolveRecord^ FromMergeInfo(
    P4ClientInfoMessageList^ info
)

Parameters

info
Type: Perforce.P4..::..P4ClientInfoMessageList

See Also

FileResolveRecord Class
FromMergeInfo Overload


FromMergeInfo Method (String, String, String)

[image]

Perforce .NET API
FileResolveRecord..::..FromMergeInfo Method (String, String, String)
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileResolveRecord FromMergeInfo(
    string l1,
    string l2,
    string l3
)
Visual Basic
Public Shared Function FromMergeInfo ( _
    l1 As String, _
    l2 As String, _
    l3 As String _
) As FileResolveRecord
Visual C++
public:
static FileResolveRecord^ FromMergeInfo(
    String^ l1,
    String^ l2,
    String^ l3
)

Parameters

l1
Type: System..::..String
l2
Type: System..::..String
l3
Type: System..::..String

See Also

FileResolveRecord Class
FromMergeInfo Overload


FromResolveCmdTaggedOutput Method

[image]

Perforce .NET API
FileResolveRecord..::..FromResolveCmdTaggedOutput Method
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileResolveRecord FromResolveCmdTaggedOutput(
    TaggedObject obj
)
Visual Basic
Public Shared Function FromResolveCmdTaggedOutput ( _
    obj As TaggedObject _
) As FileResolveRecord
Visual C++
public:
static FileResolveRecord^ FromResolveCmdTaggedOutput(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileResolveRecord Class


FromResolvedCmdTaggedOutput Method

[image]

Perforce .NET API
FileResolveRecord..::..FromResolvedCmdTaggedOutput Method
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileResolveRecord FromResolvedCmdTaggedOutput(
    TaggedObject obj
)
Visual Basic
Public Shared Function FromResolvedCmdTaggedOutput ( _
    obj As TaggedObject _
) As FileResolveRecord
Visual C++
public:
static FileResolveRecord^ FromResolvedCmdTaggedOutput(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileResolveRecord Class


FromTaggedOutput Method

[image]

Perforce .NET API
FileResolveRecord..::..FromTaggedOutput Method
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromTaggedOutput(
    TaggedObject obj
)
Visual Basic
Public Sub FromTaggedOutput ( _
    obj As TaggedObject _
)
Visual C++
public:
void FromTaggedOutput(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

FileResolveRecord Class


MergeRecords Method

[image]

Perforce .NET API
FileResolveRecord..::..MergeRecords Method
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void MergeRecords(
    FileResolveRecord Record1,
    FileResolveRecord Record2
)
Visual Basic
Public Shared Sub MergeRecords ( _
    Record1 As FileResolveRecord, _
    Record2 As FileResolveRecord _
)
Visual C++
public:
static void MergeRecords(
    FileResolveRecord^ Record1,
    FileResolveRecord^ Record2
)

Parameters

Record1
Type: Perforce.P4..::..FileResolveRecord
Record2
Type: Perforce.P4..::..FileResolveRecord

See Also

FileResolveRecord Class


Parse Method

[image]

Perforce .NET API
FileResolveRecord..::..Parse Method
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Parse(
    string spec
)
Visual Basic
Public Sub Parse ( _
    spec As String _
)
Visual C++
public:
void Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String

See Also

FileResolveRecord Class


FileResolveRecord Properties

[image] [image]

Perforce .NET API
FileResolveRecord Properties
FileResolveRecord Class See Also Send Feedback

The FileResolveRecord type exposes the following members.

Properties

 | Name | Description
Public property | Action |
Public property | Analysis |
Public property | BaseFileSpec |
Public property | FromFileSpec |
Public property | LocalFilePath |
Public property | ResolveSubtype |
Public property | ResolveType |
Public property | Result |
Public property | Sumary |

See Also

FileResolveRecord Class


Action Property

[image]

Perforce .NET API
FileResolveRecord..::..Action Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction Action { get; private set; }
Visual Basic
Public Property Action As FileAction
    Get
    Private Set
Visual C++
public:
property FileAction Action {
    FileAction get ();
    private: void set (FileAction value);
}

See Also

FileResolveRecord Class


Analysis Property

[image]

Perforce .NET API
FileResolveRecord..::..Analysis Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveAnalysis Analysis { get; set; }
Visual Basic
Public Property Analysis As ResolveAnalysis
    Get
    Set
Visual C++
public:
property ResolveAnalysis^ Analysis {
    ResolveAnalysis^ get ();
    void set (ResolveAnalysis^ value);
}

See Also

FileResolveRecord Class


BaseFileSpec Property

[image]

Perforce .NET API
FileResolveRecord..::..BaseFileSpec Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec BaseFileSpec { get; set; }
Visual Basic
Public Property BaseFileSpec As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ BaseFileSpec {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

FileResolveRecord Class


FromFileSpec Property

[image]

Perforce .NET API
FileResolveRecord..::..FromFileSpec Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec FromFileSpec { get; set; }
Visual Basic
Public Property FromFileSpec As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ FromFileSpec {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

FileResolveRecord Class


LocalFilePath Property

[image]

Perforce .NET API
FileResolveRecord..::..LocalFilePath Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LocalPath LocalFilePath { get; set; }
Visual Basic
Public Property LocalFilePath As LocalPath
    Get
    Set
Visual C++
public:
property LocalPath^ LocalFilePath {
    LocalPath^ get ();
    void set (LocalPath^ value);
}

See Also

FileResolveRecord Class


ResolveSubtype Property

[image]

Perforce .NET API
FileResolveRecord..::..ResolveSubtype Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveSubtype ResolveSubtype { get; private set; }
Visual Basic
Public Property ResolveSubtype As ResolveSubtype
    Get
    Private Set
Visual C++
public:
property ResolveSubtype ResolveSubtype {
    ResolveSubtype get ();
    private: void set (ResolveSubtype value);
}

See Also

FileResolveRecord Class


ResolveType Property

[image]

Perforce .NET API
FileResolveRecord..::..ResolveType Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveType ResolveType { get; private set; }
Visual Basic
Public Property ResolveType As ResolveType
    Get
    Private Set
Visual C++
public:
property ResolveType ResolveType {
    ResolveType get ();
    private: void set (ResolveType value);
}

See Also

FileResolveRecord Class


Result Property

[image]

Perforce .NET API
FileResolveRecord..::..Result Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Result { get; set; }
Visual Basic
Public Property Result As String
    Get
    Set
Visual C++
public:
property String^ Result {
    String^ get ();
    void set (String^ value);
}

See Also

FileResolveRecord Class


Sumary Property

[image]

Perforce .NET API
FileResolveRecord..::..Sumary Property
FileResolveRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Sumary { get; set; }
Visual Basic
Public Property Sumary As String
    Get
    Set
Visual C++
public:
property String^ Sumary {
    String^ get ();
    void set (String^ value);
}

See Also

FileResolveRecord Class


FilesCmdFlags Enumeration

[image]

Perforce .NET API
FilesCmdFlags Enumeration
See Also Send Feedback
Flags for the files command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum FilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration FilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class FilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllRevisions | 1 | The -a flag displays all revisions within the specific range, rather than just the highest revision in the range.
IncludeArchives | 2 | The -A flag displays files in archive depots.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


FilesCmdOptions Class

[image]

Perforce .NET API
FilesCmdOptions Class
Members See Also Send Feedback
Files command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FilesCmdOptions : Options
Visual Basic
Public Class FilesCmdOptions _
    Inherits Options
Visual C++
public ref class FilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..FilesCmdOptions

See Also

FilesCmdOptions Members


FilesCmdOptions Members

[image] [image]

Perforce .NET API
FilesCmdOptions Members
FilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The FilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FilesCmdOptions | Options for the files command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FilesCmdOptions Class


FilesCmdOptions Constructor

[image]

Perforce .NET API
FilesCmdOptions Constructor
FilesCmdOptions Class See Also Send Feedback
Options for the files command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FilesCmdOptions(
    FilesCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As FilesCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
FilesCmdOptions(
    FilesCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..FilesCmdFlags
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help Files

See Also

FilesCmdOptions Class


FilesCmdOptions Methods

[image] [image]

Perforce .NET API
FilesCmdOptions Methods
FilesCmdOptions Class See Also Send Feedback

The FilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FilesCmdOptions Class


FilesCmdOptions Properties

[image] [image]

Perforce .NET API
FilesCmdOptions Properties
FilesCmdOptions Class See Also Send Feedback

The FilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FilesCmdOptions Class


FileSpec Class

[image]

Perforce .NET API
FileSpec Class
Members See Also Send Feedback
Identifies one or more specific versioned objects in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileSpec
Visual Basic
Public Class FileSpec
Visual C++
public ref class FileSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileSpec
Perforce.P4..::..File

See Also

FileSpec Members


FileSpec Members

[image] [image]

Perforce .NET API
FileSpec Members
FileSpec Class Constructors Methods Properties See Also Send Feedback

The FileSpec type exposes the following members.

Constructors

 | Name | Description
Public method | FileSpec()()()() | Initializes a new instance of the FileSpec class
Public method | FileSpec(FileSpec) | Initializes a new instance of the FileSpec class
Public method | FileSpec(PathSpec, VersionSpec) | Initializes a new instance of the FileSpec class
Public method | FileSpec(DepotPath, ClientPath, LocalPath, VersionSpec) | Initializes a new instance of the FileSpec class

Methods

 | Name | Description
 | ClientSpec(String) |
 | ClientSpec(String, VersionSpec) |
 | ClientSpec(String, Int32) |
 | ClientSpecList | Create a list of FileSpec objects from a list of client paths
 | DepotSpec(String) |
 | DepotSpec(String, VersionSpec) |
 | DepotSpec(String, Int32) |
 | DepotSpecList | Create a list of FileSpec objects from a list of depot paths
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LocalSpec(String) |
 | LocalSpec(String, VersionSpec) |
 | LocalSpec(String, Int32) |
 | LocalSpecArray(IList<(Of <<'(String>)>>)) | Create an array of FileSpec objects from a list of local paths
 | LocalSpecArray(array<String>[]()[][]) | Create an array of FileSpec objects from a list of local paths
 | LocalSpecList(IList<(Of <<'(String>)>>)) | Create a list of FileSpec objects from a list of local paths
 | LocalSpecList(array<String>[]()[][]) | Create a list of FileSpec objects from a list of local paths
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StripVersion | Create a copy of a filespec without a version
 | ToEscapedLocalPaths | Copy the non-null entries into a new string array containing the local paths escaped for special characters
 | ToEscapedPaths | Copy the non-null entries into a new string array containing the paths escaped for special characters
Public method | ToEscapedString |
 | ToEscapedStrings(array<FileSpec>[]()[][]) | Copy the non-null entries into a new string array with the paths escaped for special characters
 | ToEscapedStrings(IList<(Of <<'(FileSpec>)>>)) | Copy the non-null entries into a new string array with the paths escaped for special characters
 | ToPaths | Copy the non-null entries into a new string array containing the paths.
Public method | ToString()()()() | (Overrides Object..::..ToString()()()().)
Public method | ToString(Type) |
 | ToStrings(array<FileSpec>[]()[][]) | Copy the non-null entries into a new string array.
 | ToStrings(IList<(Of <<'(FileSpec>)>>)) | Copy the non-null entries into a new string array.
 | UnversionedSpecList | Copies a list of FileSpec objects without vesions

Properties

 | Name | Description
Public property | ClientPath |
Public property | DepotPath |
Public property | LocalPath |
Public property | Version |

See Also

FileSpec Class


FileSpec Constructor

[image] [image]

Perforce .NET API
FileSpec Constructor
FileSpec Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileSpec()()()() | Initializes a new instance of the FileSpec class
Public method | FileSpec(FileSpec) | Initializes a new instance of the FileSpec class
Public method | FileSpec(PathSpec, VersionSpec) | Initializes a new instance of the FileSpec class
Public method | FileSpec(DepotPath, ClientPath, LocalPath, VersionSpec) | Initializes a new instance of the FileSpec class

See Also

FileSpec Class
FileSpec Members


FileSpec Constructor

[image]

Perforce .NET API
FileSpec Constructor
FileSpec Class See Also Send Feedback
Initializes a new instance of the FileSpec class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec()
Visual Basic
Public Sub New
Visual C++
public:
FileSpec()

See Also

FileSpec Class
FileSpec Overload


FileSpec Constructor (FileSpec)

[image]

Perforce .NET API
FileSpec Constructor (FileSpec)
FileSpec Class See Also Send Feedback
Initializes a new instance of the FileSpec class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec(
    FileSpec fs
)
Visual Basic
Public Sub New ( _
    fs As FileSpec _
)
Visual C++
public:
FileSpec(
    FileSpec^ fs
)

Parameters

fs
Type: Perforce.P4..::..FileSpec

See Also

FileSpec Class
FileSpec Overload


FileSpec Constructor (PathSpec, VersionSpec)

[image]

Perforce .NET API
FileSpec Constructor (PathSpec, VersionSpec)
FileSpec Class See Also Send Feedback
Initializes a new instance of the FileSpec class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec(
    PathSpec path,
    VersionSpec version
)
Visual Basic
Public Sub New ( _
    path As PathSpec, _
    version As VersionSpec _
)
Visual C++
public:
FileSpec(
    PathSpec^ path,
    VersionSpec^ version
)

Parameters

path
Type: Perforce.P4..::..PathSpec
version
Type: Perforce.P4..::..VersionSpec

See Also

FileSpec Class
FileSpec Overload


FileSpec Constructor (DepotPath, ClientPath, LocalPath, VersionSpec)

[image]

Perforce .NET API
FileSpec Constructor (DepotPath, ClientPath, LocalPath, VersionSpec)
FileSpec Class See Also Send Feedback
Initializes a new instance of the FileSpec class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec(
    DepotPath dp,
    ClientPath cp,
    LocalPath lp,
    VersionSpec version
)
Visual Basic
Public Sub New ( _
    dp As DepotPath, _
    cp As ClientPath, _
    lp As LocalPath, _
    version As VersionSpec _
)
Visual C++
public:
FileSpec(
    DepotPath^ dp,
    ClientPath^ cp,
    LocalPath^ lp,
    VersionSpec^ version
)

Parameters

dp
Type: Perforce.P4..::..DepotPath
cp
Type: Perforce.P4..::..ClientPath
lp
Type: Perforce.P4..::..LocalPath
version
Type: Perforce.P4..::..VersionSpec

See Also

FileSpec Class
FileSpec Overload


FileSpec Methods

[image] [image]

Perforce .NET API
FileSpec Methods
FileSpec Class See Also Send Feedback

The FileSpec type exposes the following members.

Methods

 | Name | Description
 | ClientSpec(String) |
 | ClientSpec(String, VersionSpec) |
 | ClientSpec(String, Int32) |
 | ClientSpecList | Create a list of FileSpec objects from a list of client paths
 | DepotSpec(String) |
 | DepotSpec(String, VersionSpec) |
 | DepotSpec(String, Int32) |
 | DepotSpecList | Create a list of FileSpec objects from a list of depot paths
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LocalSpec(String) |
 | LocalSpec(String, VersionSpec) |
 | LocalSpec(String, Int32) |
 | LocalSpecArray(IList<(Of <<'(String>)>>)) | Create an array of FileSpec objects from a list of local paths
 | LocalSpecArray(array<String>[]()[][]) | Create an array of FileSpec objects from a list of local paths
 | LocalSpecList(IList<(Of <<'(String>)>>)) | Create a list of FileSpec objects from a list of local paths
 | LocalSpecList(array<String>[]()[][]) | Create a list of FileSpec objects from a list of local paths
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StripVersion | Create a copy of a filespec without a version
 | ToEscapedLocalPaths | Copy the non-null entries into a new string array containing the local paths escaped for special characters
 | ToEscapedPaths | Copy the non-null entries into a new string array containing the paths escaped for special characters
Public method | ToEscapedString |
 | ToEscapedStrings(array<FileSpec>[]()[][]) | Copy the non-null entries into a new string array with the paths escaped for special characters
 | ToEscapedStrings(IList<(Of <<'(FileSpec>)>>)) | Copy the non-null entries into a new string array with the paths escaped for special characters
 | ToPaths | Copy the non-null entries into a new string array containing the paths.
Public method | ToString()()()() | (Overrides Object..::..ToString()()()().)
Public method | ToString(Type) |
 | ToStrings(array<FileSpec>[]()[][]) | Copy the non-null entries into a new string array.
 | ToStrings(IList<(Of <<'(FileSpec>)>>)) | Copy the non-null entries into a new string array.
 | UnversionedSpecList | Copies a list of FileSpec objects without vesions

See Also

FileSpec Class


ClientSpec Method

[image] [image]

Perforce .NET API
FileSpec..::..ClientSpec Method
FileSpec Class See Also Send Feedback

Overload List

Name | Description
ClientSpec(String) |
ClientSpec(String, VersionSpec) |
ClientSpec(String, Int32) |

See Also

FileSpec Class
FileSpec Members


ClientSpec Method (String)

[image]

Perforce .NET API
FileSpec..::..ClientSpec Method (String)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec ClientSpec(
    string path
)
Visual Basic
Public Shared Function ClientSpec ( _
    path As String _
) As FileSpec
Visual C++
public:
static FileSpec^ ClientSpec(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

FileSpec Class
ClientSpec Overload


ClientSpec Method (String, VersionSpec)

[image]

Perforce .NET API
FileSpec..::..ClientSpec Method (String, VersionSpec)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec ClientSpec(
    string path,
    VersionSpec ver
)
Visual Basic
Public Shared Function ClientSpec ( _
    path As String, _
    ver As VersionSpec _
) As FileSpec
Visual C++
public:
static FileSpec^ ClientSpec(
    String^ path,
    VersionSpec^ ver
)

Parameters

path
Type: System..::..String
ver
Type: Perforce.P4..::..VersionSpec

See Also

FileSpec Class
ClientSpec Overload


ClientSpec Method (String, Int32)

[image]

Perforce .NET API
FileSpec..::..ClientSpec Method (String, Int32)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec ClientSpec(
    string path,
    int rev
)
Visual Basic
Public Shared Function ClientSpec ( _
    path As String, _
    rev As Integer _
) As FileSpec
Visual C++
public:
static FileSpec^ ClientSpec(
    String^ path,
    int rev
)

Parameters

path
Type: System..::..String
rev
Type: System..::..Int32

See Also

FileSpec Class
ClientSpec Overload


ClientSpecList Method

[image]

Perforce .NET API
FileSpec..::..ClientSpecList Method
FileSpec Class See Also Send Feedback
Create a list of FileSpec objects from a list of client paths

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static IList<FileSpec> ClientSpecList(
    params string[] paths
)
Visual Basic
Public Shared Function ClientSpecList ( _
    ParamArray paths As String() _
) As IList(Of FileSpec)
Visual C++
public:
static IList<FileSpec^>^ ClientSpecList(
    ... array<String^>^ paths
)

Parameters

paths
Type: array< System..::..String >[]()[][]
List of paths

Return Value

List of FileSpec objects

See Also

FileSpec Class


DepotSpec Method

[image] [image]

Perforce .NET API
FileSpec..::..DepotSpec Method
FileSpec Class See Also Send Feedback

Overload List

Name | Description
DepotSpec(String) |
DepotSpec(String, VersionSpec) |
DepotSpec(String, Int32) |

See Also

FileSpec Class
FileSpec Members


DepotSpec Method (String)

[image]

Perforce .NET API
FileSpec..::..DepotSpec Method (String)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec DepotSpec(
    string path
)
Visual Basic
Public Shared Function DepotSpec ( _
    path As String _
) As FileSpec
Visual C++
public:
static FileSpec^ DepotSpec(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

FileSpec Class
DepotSpec Overload


DepotSpec Method (String, VersionSpec)

[image]

Perforce .NET API
FileSpec..::..DepotSpec Method (String, VersionSpec)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec DepotSpec(
    string path,
    VersionSpec ver
)
Visual Basic
Public Shared Function DepotSpec ( _
    path As String, _
    ver As VersionSpec _
) As FileSpec
Visual C++
public:
static FileSpec^ DepotSpec(
    String^ path,
    VersionSpec^ ver
)

Parameters

path
Type: System..::..String
ver
Type: Perforce.P4..::..VersionSpec

See Also

FileSpec Class
DepotSpec Overload


DepotSpec Method (String, Int32)

[image]

Perforce .NET API
FileSpec..::..DepotSpec Method (String, Int32)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec DepotSpec(
    string path,
    int rev
)
Visual Basic
Public Shared Function DepotSpec ( _
    path As String, _
    rev As Integer _
) As FileSpec
Visual C++
public:
static FileSpec^ DepotSpec(
    String^ path,
    int rev
)

Parameters

path
Type: System..::..String
rev
Type: System..::..Int32

See Also

FileSpec Class
DepotSpec Overload


DepotSpecList Method

[image]

Perforce .NET API
FileSpec..::..DepotSpecList Method
FileSpec Class See Also Send Feedback
Create a list of FileSpec objects from a list of depot paths

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static IList<FileSpec> DepotSpecList(
    params string[] paths
)
Visual Basic
Public Shared Function DepotSpecList ( _
    ParamArray paths As String() _
) As IList(Of FileSpec)
Visual C++
public:
static IList<FileSpec^>^ DepotSpecList(
    ... array<String^>^ paths
)

Parameters

paths
Type: array< System..::..String >[]()[][]
List of paths

Return Value

List of FileSpec objects

See Also

FileSpec Class


Equals Method

[image]

Perforce .NET API
FileSpec..::..Equals Method
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

FileSpec Class


LocalSpec Method

[image] [image]

Perforce .NET API
FileSpec..::..LocalSpec Method
FileSpec Class See Also Send Feedback

Overload List

Name | Description
LocalSpec(String) |
LocalSpec(String, VersionSpec) |
LocalSpec(String, Int32) |

See Also

FileSpec Class
FileSpec Members


LocalSpec Method (String)

[image]

Perforce .NET API
FileSpec..::..LocalSpec Method (String)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec LocalSpec(
    string path
)
Visual Basic
Public Shared Function LocalSpec ( _
    path As String _
) As FileSpec
Visual C++
public:
static FileSpec^ LocalSpec(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

FileSpec Class
LocalSpec Overload


LocalSpec Method (String, VersionSpec)

[image]

Perforce .NET API
FileSpec..::..LocalSpec Method (String, VersionSpec)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec LocalSpec(
    string path,
    VersionSpec ver
)
Visual Basic
Public Shared Function LocalSpec ( _
    path As String, _
    ver As VersionSpec _
) As FileSpec
Visual C++
public:
static FileSpec^ LocalSpec(
    String^ path,
    VersionSpec^ ver
)

Parameters

path
Type: System..::..String
ver
Type: Perforce.P4..::..VersionSpec

See Also

FileSpec Class
LocalSpec Overload


LocalSpec Method (String, Int32)

[image]

Perforce .NET API
FileSpec..::..LocalSpec Method (String, Int32)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec LocalSpec(
    string path,
    int rev
)
Visual Basic
Public Shared Function LocalSpec ( _
    path As String, _
    rev As Integer _
) As FileSpec
Visual C++
public:
static FileSpec^ LocalSpec(
    String^ path,
    int rev
)

Parameters

path
Type: System..::..String
rev
Type: System..::..Int32

See Also

FileSpec Class
LocalSpec Overload


LocalSpecArray Method

[image] [image]

Perforce .NET API
FileSpec..::..LocalSpecArray Method
FileSpec Class See Also Send Feedback

Overload List

Name | Description
LocalSpecArray(IList<(Of <<'(String>)>>)) | Create an array of FileSpec objects from a list of local paths
LocalSpecArray(array<String>[]()[][]) | Create an array of FileSpec objects from a list of local paths

See Also

FileSpec Class
FileSpec Members


LocalSpecArray Method (IList(String))

[image]

Perforce .NET API
FileSpec..::..LocalSpecArray Method (IList<(Of <(<'String>)>)>)
FileSpec Class See Also Send Feedback
Create an array of FileSpec objects from a list of local paths

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec[] LocalSpecArray(
    IList<string> paths
)
Visual Basic
Public Shared Function LocalSpecArray ( _
    paths As IList(Of String) _
) As FileSpec()
Visual C++
public:
static array<FileSpec^>^ LocalSpecArray(
    IList<String^>^ paths
)

Parameters

paths
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
List of paths

Return Value

List of FileSpec objects

See Also

FileSpec Class
LocalSpecArray Overload


LocalSpecArray Method (String[])

[image]

Perforce .NET API
FileSpec..::..LocalSpecArray Method (array<String>[]()[][])
FileSpec Class See Also Send Feedback
Create an array of FileSpec objects from a list of local paths

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FileSpec[] LocalSpecArray(
    params string[] paths
)
Visual Basic
Public Shared Function LocalSpecArray ( _
    ParamArray paths As String() _
) As FileSpec()
Visual C++
public:
static array<FileSpec^>^ LocalSpecArray(
    ... array<String^>^ paths
)

Parameters

paths
Type: array< System..::..String >[]()[][]
List of paths

Return Value

List of FileSpec objects

See Also

FileSpec Class
LocalSpecArray Overload


LocalSpecList Method

[image] [image]

Perforce .NET API
FileSpec..::..LocalSpecList Method
FileSpec Class See Also Send Feedback

Overload List

Name | Description
LocalSpecList(IList<(Of <<'(String>)>>)) | Create a list of FileSpec objects from a list of local paths
LocalSpecList(array<String>[]()[][]) | Create a list of FileSpec objects from a list of local paths

See Also

FileSpec Class
FileSpec Members


LocalSpecList Method (IList(String))

[image]

Perforce .NET API
FileSpec..::..LocalSpecList Method (IList<(Of <(<'String>)>)>)
FileSpec Class See Also Send Feedback
Create a list of FileSpec objects from a list of local paths

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static IList<FileSpec> LocalSpecList(
    IList<string> paths
)
Visual Basic
Public Shared Function LocalSpecList ( _
    paths As IList(Of String) _
) As IList(Of FileSpec)
Visual C++
public:
static IList<FileSpec^>^ LocalSpecList(
    IList<String^>^ paths
)

Parameters

paths
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
List of paths

Return Value

List of FileSpec objects

See Also

FileSpec Class
LocalSpecList Overload


LocalSpecList Method (String[])

[image]

Perforce .NET API
FileSpec..::..LocalSpecList Method (array<String>[]()[][])
FileSpec Class See Also Send Feedback
Create a list of FileSpec objects from a list of local paths

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static IList<FileSpec> LocalSpecList(
    params string[] paths
)
Visual Basic
Public Shared Function LocalSpecList ( _
    ParamArray paths As String() _
) As IList(Of FileSpec)
Visual C++
public:
static IList<FileSpec^>^ LocalSpecList(
    ... array<String^>^ paths
)

Parameters

paths
Type: array< System..::..String >[]()[][]
List of paths

Return Value

List of FileSpec objects

See Also

FileSpec Class
LocalSpecList Overload


StripVersion Method

[image]

Perforce .NET API
FileSpec..::..StripVersion Method
FileSpec Class See Also Send Feedback
Create a copy of a filespec without a version

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec StripVersion()
Visual Basic
Public Function StripVersion As FileSpec
Visual C++
public:
FileSpec^ StripVersion()

See Also

FileSpec Class


ToEscapedLocalPaths Method

[image]

Perforce .NET API
FileSpec..::..ToEscapedLocalPaths Method
FileSpec Class See Also Send Feedback
Copy the non-null entries into a new string array containing the local paths escaped for special characters

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToEscapedLocalPaths(
    params FileSpec[] list
)
Visual Basic
Public Shared Function ToEscapedLocalPaths ( _
    ParamArray list As FileSpec() _
) As String()
Visual C++
public:
static array<String^>^ ToEscapedLocalPaths(
    ... array<FileSpec^>^ list
)

Parameters

list
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

FileSpec Class


ToEscapedPaths Method

[image]

Perforce .NET API
FileSpec..::..ToEscapedPaths Method
FileSpec Class See Also Send Feedback
Copy the non-null entries into a new string array containing the paths escaped for special characters

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToEscapedPaths(
    params FileSpec[] list
)
Visual Basic
Public Shared Function ToEscapedPaths ( _
    ParamArray list As FileSpec() _
) As String()
Visual C++
public:
static array<String^>^ ToEscapedPaths(
    ... array<FileSpec^>^ list
)

Parameters

list
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

FileSpec Class


ToEscapedString Method

[image]

Perforce .NET API
FileSpec..::..ToEscapedString Method
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ToEscapedString()
Visual Basic
Public Function ToEscapedString As String
Visual C++
public:
String^ ToEscapedString()

See Also

FileSpec Class


ToEscapedStrings Method

[image] [image]

Perforce .NET API
FileSpec..::..ToEscapedStrings Method
FileSpec Class See Also Send Feedback

Overload List

Name | Description
ToEscapedStrings(array<FileSpec>[]()[][]) | Copy the non-null entries into a new string array with the paths escaped for special characters
ToEscapedStrings(IList<(Of <<'(FileSpec>)>>)) | Copy the non-null entries into a new string array with the paths escaped for special characters

See Also

FileSpec Class
FileSpec Members


ToEscapedStrings Method (FileSpec[])

[image]

Perforce .NET API
FileSpec..::..ToEscapedStrings Method (array<FileSpec>[]()[][])
FileSpec Class See Also Send Feedback
Copy the non-null entries into a new string array with the paths escaped for special characters

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToEscapedStrings(
    params FileSpec[] list
)
Visual Basic
Public Shared Function ToEscapedStrings ( _
    ParamArray list As FileSpec() _
) As String()
Visual C++
public:
static array<String^>^ ToEscapedStrings(
    ... array<FileSpec^>^ list
)

Parameters

list
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

FileSpec Class
ToEscapedStrings Overload


ToEscapedStrings Method (IList(FileSpec))

[image]

Perforce .NET API
FileSpec..::..ToEscapedStrings Method (IList<(Of <(<'FileSpec>)>)>)
FileSpec Class See Also Send Feedback
Copy the non-null entries into a new string array with the paths escaped for special characters

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToEscapedStrings(
    IList<FileSpec> list
)
Visual Basic
Public Shared Function ToEscapedStrings ( _
    list As IList(Of FileSpec) _
) As String()
Visual C++
public:
static array<String^>^ ToEscapedStrings(
    IList<FileSpec^>^ list
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>

See Also

FileSpec Class
ToEscapedStrings Overload


ToPaths Method

[image]

Perforce .NET API
FileSpec..::..ToPaths Method
FileSpec Class See Also Send Feedback
Copy the non-null entries into a new string array containing the paths.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToPaths(
    params FileSpec[] list
)
Visual Basic
Public Shared Function ToPaths ( _
    ParamArray list As FileSpec() _
) As String()
Visual C++
public:
static array<String^>^ ToPaths(
    ... array<FileSpec^>^ list
)

Parameters

list
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

FileSpec Class


ToString Method

[image] [image]

Perforce .NET API
FileSpec..::..ToString Method
FileSpec Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | (Overrides Object..::..ToString()()()().)
Public method | ToString(Type) |

See Also

FileSpec Class
FileSpec Members


ToString Method

[image]

Perforce .NET API
FileSpec..::..ToString Method
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

FileSpec Class
ToString Overload


ToString Method (Type)

[image]

Perforce .NET API
FileSpec..::..ToString Method (Type)
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ToString(
    Type pathType
)
Visual Basic
Public Function ToString ( _
    pathType As Type _
) As String
Visual C++
public:
String^ ToString(
    Type^ pathType
)

Parameters

pathType
Type: System..::..Type

See Also

FileSpec Class
ToString Overload


ToStrings Method

[image] [image]

Perforce .NET API
FileSpec..::..ToStrings Method
FileSpec Class See Also Send Feedback

Overload List

Name | Description
ToStrings(array<FileSpec>[]()[][]) | Copy the non-null entries into a new string array.
ToStrings(IList<(Of <<'(FileSpec>)>>)) | Copy the non-null entries into a new string array.

See Also

FileSpec Class
FileSpec Members


ToStrings Method (FileSpec[])

[image]

Perforce .NET API
FileSpec..::..ToStrings Method (array<FileSpec>[]()[][])
FileSpec Class See Also Send Feedback
Copy the non-null entries into a new string array.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToStrings(
    params FileSpec[] list
)
Visual Basic
Public Shared Function ToStrings ( _
    ParamArray list As FileSpec() _
) As String()
Visual C++
public:
static array<String^>^ ToStrings(
    ... array<FileSpec^>^ list
)

Parameters

list
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

FileSpec Class
ToStrings Overload


ToStrings Method (IList(FileSpec))

[image]

Perforce .NET API
FileSpec..::..ToStrings Method (IList<(Of <(<'FileSpec>)>)>)
FileSpec Class See Also Send Feedback
Copy the non-null entries into a new string array.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToStrings(
    IList<FileSpec> list
)
Visual Basic
Public Shared Function ToStrings ( _
    list As IList(Of FileSpec) _
) As String()
Visual C++
public:
static array<String^>^ ToStrings(
    IList<FileSpec^>^ list
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>

See Also

FileSpec Class
ToStrings Overload


UnversionedSpecList Method

[image]

Perforce .NET API
FileSpec..::..UnversionedSpecList Method
FileSpec Class See Also Send Feedback
Copies a list of FileSpec objects without vesions

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static IList<FileSpec> UnversionedSpecList(
    IList<FileSpec> specs
)
Visual Basic
Public Shared Function UnversionedSpecList ( _
    specs As IList(Of FileSpec) _
) As IList(Of FileSpec)
Visual C++
public:
static IList<FileSpec^>^ UnversionedSpecList(
    IList<FileSpec^>^ specs
)

Parameters

specs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
List of FileSpecs

Return Value

List of FileSpec objects

See Also

FileSpec Class


FileSpec Properties

[image] [image]

Perforce .NET API
FileSpec Properties
FileSpec Class See Also Send Feedback

The FileSpec type exposes the following members.

Properties

 | Name | Description
Public property | ClientPath |
Public property | DepotPath |
Public property | LocalPath |
Public property | Version |

See Also

FileSpec Class


ClientPath Property

[image]

Perforce .NET API
FileSpec..::..ClientPath Property
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientPath ClientPath { get; set; }
Visual Basic
Public Property ClientPath As ClientPath
    Get
    Set
Visual C++
public:
property ClientPath^ ClientPath {
    ClientPath^ get ();
    void set (ClientPath^ value);
}

See Also

FileSpec Class


DepotPath Property

[image]

Perforce .NET API
FileSpec..::..DepotPath Property
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotPath DepotPath { get; set; }
Visual Basic
Public Property DepotPath As DepotPath
    Get
    Set
Visual C++
public:
property DepotPath^ DepotPath {
    DepotPath^ get ();
    void set (DepotPath^ value);
}

See Also

FileSpec Class


LocalPath Property

[image]

Perforce .NET API
FileSpec..::..LocalPath Property
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LocalPath LocalPath { get; set; }
Visual Basic
Public Property LocalPath As LocalPath
    Get
    Set
Visual C++
public:
property LocalPath^ LocalPath {
    LocalPath^ get ();
    void set (LocalPath^ value);
}

See Also

FileSpec Class


Version Property

[image]

Perforce .NET API
FileSpec..::..Version Property
FileSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public VersionSpec Version { get; set; }
Visual Basic
Public Property Version As VersionSpec
    Get
    Set
Visual C++
public:
property VersionSpec^ Version {
    VersionSpec^ get ();
    void set (VersionSpec^ value);
}

See Also

FileSpec Class


FileSubmitRecord Class

[image]

Perforce .NET API
FileSubmitRecord Class
Members See Also Send Feedback
Describes file submitted and file action performed.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileSubmitRecord
Visual Basic
Public Class FileSubmitRecord
Visual C++
public ref class FileSubmitRecord

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileSubmitRecord

See Also

FileSubmitRecord Members


FileSubmitRecord Members

[image] [image]

Perforce .NET API
FileSubmitRecord Members
FileSubmitRecord Class Constructors Methods Properties See Also Send Feedback

The FileSubmitRecord type exposes the following members.

Constructors

 | Name | Description
Public method | FileSubmitRecord()()()() | Initializes a new instance of the FileSubmitRecord class
Public method | FileSubmitRecord(FileAction, FileSpec) | Initializes a new instance of the FileSubmitRecord class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action |
Public property | File |

See Also

FileSubmitRecord Class


FileSubmitRecord Constructor

[image] [image]

Perforce .NET API
FileSubmitRecord Constructor
FileSubmitRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileSubmitRecord()()()() | Initializes a new instance of the FileSubmitRecord class
Public method | FileSubmitRecord(FileAction, FileSpec) | Initializes a new instance of the FileSubmitRecord class

See Also

FileSubmitRecord Class
FileSubmitRecord Members


FileSubmitRecord Constructor

[image]

Perforce .NET API
FileSubmitRecord Constructor
FileSubmitRecord Class See Also Send Feedback
Initializes a new instance of the FileSubmitRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSubmitRecord()
Visual Basic
Public Sub New
Visual C++
public:
FileSubmitRecord()

See Also

FileSubmitRecord Class
FileSubmitRecord Overload


FileSubmitRecord Constructor (FileAction, FileSpec)

[image]

Perforce .NET API
FileSubmitRecord Constructor (FileAction, FileSpec)
FileSubmitRecord Class See Also Send Feedback
Initializes a new instance of the FileSubmitRecord class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSubmitRecord(
    FileAction action,
    FileSpec file
)
Visual Basic
Public Sub New ( _
    action As FileAction, _
    file As FileSpec _
)
Visual C++
public:
FileSubmitRecord(
    FileAction action,
    FileSpec^ file
)

Parameters

action
Type: Perforce.P4..::..FileAction
file
Type: Perforce.P4..::..FileSpec

See Also

FileSubmitRecord Class
FileSubmitRecord Overload


FileSubmitRecord Methods

[image] [image]

Perforce .NET API
FileSubmitRecord Methods
FileSubmitRecord Class See Also Send Feedback

The FileSubmitRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSubmitRecord Class


FileSubmitRecord Properties

[image] [image]

Perforce .NET API
FileSubmitRecord Properties
FileSubmitRecord Class See Also Send Feedback

The FileSubmitRecord type exposes the following members.

Properties

 | Name | Description
Public property | Action |
Public property | File |

See Also

FileSubmitRecord Class


Action Property

[image]

Perforce .NET API
FileSubmitRecord..::..Action Property
FileSubmitRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction Action { get; internal set; }
Visual Basic
Public Property Action As FileAction
    Get
    Friend Set
Visual C++
public:
property FileAction Action {
    FileAction get ();
    internal: void set (FileAction value);
}

See Also

FileSubmitRecord Class


File Property

[image]

Perforce .NET API
FileSubmitRecord..::..File Property
FileSubmitRecord Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec File { get; private set; }
Visual Basic
Public Property File As FileSpec
    Get
    Private Set
Visual C++
public:
property FileSpec^ File {
    FileSpec^ get ();
    private: void set (FileSpec^ value);
}

See Also

FileSubmitRecord Class


FileType Class

[image]

Perforce .NET API
FileType Class
Members See Also Send Feedback
Specifies a Perforce file type for a managed file.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FileType
Visual Basic
Public Class FileType
Visual C++
public ref class FileType

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FileType

See Also

FileType Members


FileType Members

[image] [image]

Perforce .NET API
FileType Members
FileType Class Constructors Methods Properties See Also Send Feedback

The FileType type exposes the following members.

Constructors

 | Name | Description
Public method | FileType(String) | Initializes a new instance of the FileType class
Public method | FileType(BaseFileType, FileTypeModifier) | Initializes a new instance of the FileType class
Public method | FileType(BaseFileType, FileTypeModifier, Int32) | Initializes a new instance of the FileType class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | BaseType |
Public property | Modifiers |
Public property | StoredRevs |

See Also

FileType Class


FileType Constructor

[image] [image]

Perforce .NET API
FileType Constructor
FileType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileType(String) | Initializes a new instance of the FileType class
Public method | FileType(BaseFileType, FileTypeModifier) | Initializes a new instance of the FileType class
Public method | FileType(BaseFileType, FileTypeModifier, Int32) | Initializes a new instance of the FileType class

See Also

FileType Class
FileType Members


FileType Constructor (String)

[image]

Perforce .NET API
FileType Constructor (String)
FileType Class See Also Send Feedback
Initializes a new instance of the FileType class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType(
    string spec
)
Visual Basic
Public Sub New ( _
    spec As String _
)
Visual C++
public:
FileType(
    String^ spec
)

Parameters

spec
Type: System..::..String

See Also

FileType Class
FileType Overload


FileType Constructor (BaseFileType, FileTypeModifier)

[image]

Perforce .NET API
FileType Constructor (BaseFileType, FileTypeModifier)
FileType Class See Also Send Feedback
Initializes a new instance of the FileType class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType(
    BaseFileType basetype,
    FileTypeModifier modifiers
)
Visual Basic
Public Sub New ( _
    basetype As BaseFileType, _
    modifiers As FileTypeModifier _
)
Visual C++
public:
FileType(
    BaseFileType basetype,
    FileTypeModifier modifiers
)

Parameters

basetype
Type: Perforce.P4..::..BaseFileType
modifiers
Type: Perforce.P4..::..FileTypeModifier

See Also

FileType Class
FileType Overload


FileType Constructor (BaseFileType, FileTypeModifier, Int32)

[image]

Perforce .NET API
FileType Constructor (BaseFileType, FileTypeModifier, Int32)
FileType Class See Also Send Feedback
Initializes a new instance of the FileType class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType(
    BaseFileType basetype,
    FileTypeModifier modifiers,
    int storedrevs
)
Visual Basic
Public Sub New ( _
    basetype As BaseFileType, _
    modifiers As FileTypeModifier, _
    storedrevs As Integer _
)
Visual C++
public:
FileType(
    BaseFileType basetype,
    FileTypeModifier modifiers,
    int storedrevs
)

Parameters

basetype
Type: Perforce.P4..::..BaseFileType
modifiers
Type: Perforce.P4..::..FileTypeModifier
storedrevs
Type: System..::..Int32

See Also

FileType Class
FileType Overload


FileType Methods

[image] [image]

Perforce .NET API
FileType Methods
FileType Class See Also Send Feedback

The FileType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

FileType Class


Equals Method

[image]

Perforce .NET API
FileType..::..Equals Method
FileType Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

FileType Class


ToString Method

[image]

Perforce .NET API
FileType..::..ToString Method
FileType Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

FileType Class


FileType Properties

[image] [image]

Perforce .NET API
FileType Properties
FileType Class See Also Send Feedback

The FileType type exposes the following members.

Properties

 | Name | Description
Public property | BaseType |
Public property | Modifiers |
Public property | StoredRevs |

See Also

FileType Class


BaseType Property

[image]

Perforce .NET API
FileType..::..BaseType Property
FileType Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BaseFileType BaseType { get; set; }
Visual Basic
Public Property BaseType As BaseFileType
    Get
    Set
Visual C++
public:
property BaseFileType BaseType {
    BaseFileType get ();
    void set (BaseFileType value);
}

See Also

FileType Class


Modifiers Property

[image]

Perforce .NET API
FileType..::..Modifiers Property
FileType Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileTypeModifier Modifiers { get; set; }
Visual Basic
Public Property Modifiers As FileTypeModifier
    Get
    Set
Visual C++
public:
property FileTypeModifier Modifiers {
    FileTypeModifier get ();
    void set (FileTypeModifier value);
}

See Also

FileType Class


StoredRevs Property

[image]

Perforce .NET API
FileType..::..StoredRevs Property
FileType Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int StoredRevs { get; set; }
Visual Basic
Public Property StoredRevs As Integer
    Get
    Set
Visual C++
public:
property int StoredRevs {
    int get ();
    void set (int value);
}

See Also

FileType Class


FileTypeModifier Enumeration

[image]

Perforce .NET API
FileTypeModifier Enumeration
See Also Send Feedback
Flags to specify file type modifiers.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum FileTypeModifier
Visual Basic
<FlagsAttribute> _
Public Enumeration FileTypeModifier
Visual C++
[FlagsAttribute]
public enum class FileTypeModifier

Members

Member name | Value | Description
None | 0 | No flags.
ModTime | 1 | +m always set modtime on client (overrides client's nomodtime).
Writable | 2 | +w always writable on client.
Exec | 4 | +x exec bit set on client.
KeywordsAll | 8 | +k $Keyword$ expansion of Id, Header, Author Date, DateTime, Change, File, Revision.
KeywordsLimited | 16 | +ko $Keyword$ expansion of ID, Header only.
ExclusiveOpen | 32 | +l exclusive open: disallow multiple opens.
CompressedFiles | 64 | +C server stores compressed file per revision.
RCSDeltaFiles | 128 | +D server stores deltas in RCS format.
FullRevisions | 256 | +F server stores full file per revision.
HeadrevOnly | 512 | +S server stores only single head revision.
NRevsOnly | 1024 |
ArchiveTrigger | 2048 | +X server runs archive trigger to access files

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


Fix Class

[image]

Perforce .NET API
Fix Class
Members See Also Send Feedback
Specifies a fix relationship between one or more jobs and one or more changelists.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Fix
Visual Basic
Public Class Fix
Visual C++
public ref class Fix

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Fix

See Also

Fix Members


Fix Members

[image] [image]

Perforce .NET API
Fix Members
Fix Class Constructors Methods Properties See Also Send Feedback

The Fix type exposes the following members.

Constructors

 | Name | Description
Public method | Fix()()()() | Initializes a new instance of the Fix class
Public method | Fix(String, Int32, DateTime, String, String, String, FixAction) | Initializes a new instance of the Fix class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromFixCmdTaggedOutput |
 | FromFixesCmdTaggedOutput |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFixesCmdTaggedData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action |
Public property | ChangeId |
Public property | ClientName |
Public property | Date |
Public property | JobId |
Public property | Status |
Public property | UserName |

See Also

Fix Class


Fix Constructor

[image] [image]

Perforce .NET API
Fix Constructor
Fix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Fix()()()() | Initializes a new instance of the Fix class
Public method | Fix(String, Int32, DateTime, String, String, String, FixAction) | Initializes a new instance of the Fix class

See Also

Fix Class
Fix Members


Fix Constructor

[image]

Perforce .NET API
Fix Constructor
Fix Class See Also Send Feedback
Initializes a new instance of the Fix class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Fix()
Visual Basic
Public Sub New
Visual C++
public:
Fix()

See Also

Fix Class
Fix Overload


Fix Constructor (String, Int32, DateTime, String, String, String, FixAction)

[image]

Perforce .NET API
Fix Constructor (String, Int32, DateTime, String, String, String, FixAction)
Fix Class See Also Send Feedback
Initializes a new instance of the Fix class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Fix(
    string jobid,
    int changeid,
    DateTime date,
    string clientname,
    string username,
    string status,
    FixAction action
)
Visual Basic
Public Sub New ( _
    jobid As String, _
    changeid As Integer, _
    date As DateTime, _
    clientname As String, _
    username As String, _
    status As String, _
    action As FixAction _
)
Visual C++
public:
Fix(
    String^ jobid,
    int changeid,
    DateTime date,
    String^ clientname,
    String^ username,
    String^ status,
    FixAction action
)

Parameters

jobid
Type: System..::..String
changeid
Type: System..::..Int32
date
Type: System..::..DateTime
clientname
Type: System..::..String
username
Type: System..::..String
status
Type: System..::..String
action
Type: Perforce.P4..::..FixAction

See Also

Fix Class
Fix Overload


Fix Methods

[image] [image]

Perforce .NET API
Fix Methods
Fix Class See Also Send Feedback

The Fix type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromFixCmdTaggedOutput |
 | FromFixesCmdTaggedOutput |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseFixesCmdTaggedData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Fix Class


FromFixCmdTaggedOutput Method

[image]

Perforce .NET API
Fix..::..FromFixCmdTaggedOutput Method
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static Fix FromFixCmdTaggedOutput(
    TaggedObject obj
)
Visual Basic
Public Shared Function FromFixCmdTaggedOutput ( _
    obj As TaggedObject _
) As Fix
Visual C++
public:
static Fix^ FromFixCmdTaggedOutput(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

Fix Class


FromFixesCmdTaggedOutput Method

[image]

Perforce .NET API
Fix..::..FromFixesCmdTaggedOutput Method
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static Fix FromFixesCmdTaggedOutput(
    TaggedObject obj,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Shared Function FromFixesCmdTaggedOutput ( _
    obj As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
) As Fix
Visual C++
public:
static Fix^ FromFixesCmdTaggedOutput(
    TaggedObject^ obj,
    String^ offset,
    bool dst_mismatch
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Fix Class


ParseFixesCmdTaggedData Method

[image]

Perforce .NET API
Fix..::..ParseFixesCmdTaggedData Method
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void ParseFixesCmdTaggedData(
    TaggedObject obj,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub ParseFixesCmdTaggedData ( _
    obj As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void ParseFixesCmdTaggedData(
    TaggedObject^ obj,
    String^ offset,
    bool dst_mismatch
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Fix Class


Fix Properties

[image] [image]

Perforce .NET API
Fix Properties
Fix Class See Also Send Feedback

The Fix type exposes the following members.

Properties

 | Name | Description
Public property | Action |
Public property | ChangeId |
Public property | ClientName |
Public property | Date |
Public property | JobId |
Public property | Status |
Public property | UserName |

See Also

Fix Class


Action Property

[image]

Perforce .NET API
Fix..::..Action Property
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FixAction Action { get; set; }
Visual Basic
Public Property Action As FixAction
    Get
    Set
Visual C++
public:
property FixAction Action {
    FixAction get ();
    void set (FixAction value);
}

See Also

Fix Class


ChangeId Property

[image]

Perforce .NET API
Fix..::..ChangeId Property
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChangeId { get; set; }
Visual Basic
Public Property ChangeId As Integer
    Get
    Set
Visual C++
public:
property int ChangeId {
    int get ();
    void set (int value);
}

See Also

Fix Class


ClientName Property

[image]

Perforce .NET API
Fix..::..ClientName Property
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ClientName { get; set; }
Visual Basic
Public Property ClientName As String
    Get
    Set
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

See Also

Fix Class


Date Property

[image]

Perforce .NET API
Fix..::..Date Property
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}

See Also

Fix Class


JobId Property

[image]

Perforce .NET API
Fix..::..JobId Property
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

See Also

Fix Class


Status Property

[image]

Perforce .NET API
Fix..::..Status Property
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

See Also

Fix Class


UserName Property

[image]

Perforce .NET API
Fix..::..UserName Property
Fix Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

Fix Class


FixAction Enumeration

[image]

Perforce .NET API
FixAction Enumeration
See Also Send Feedback
The fix action (Fixed or Unfixed).

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum FixAction
Visual Basic
<FlagsAttribute> _
Public Enumeration FixAction
Visual C++
[FlagsAttribute]
public enum class FixAction

Members

Member name | Value | Description
Fixed | 0 | Fixed
Unfixed | 1 | Fix removed

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


FixJobsCmdFlags Enumeration

[image]

Perforce .NET API
FixJobsCmdFlags Enumeration
See Also Send Feedback
Flags for the fix command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum FixJobsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration FixJobsCmdFlags
Visual C++
[FlagsAttribute]
public enum class FixJobsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the specified fixes. This operation does not otherwise affect the specified changelist or jobs.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


FixJobsCmdOptions Class

[image]

Perforce .NET API
FixJobsCmdOptions Class
Members See Also Send Feedback
Fix command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FixJobsCmdOptions : Options
Visual Basic
Public Class FixJobsCmdOptions _
    Inherits Options
Visual C++
public ref class FixJobsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..FixJobsCmdOptions

See Also

FixJobsCmdOptions Members


FixJobsCmdOptions Members

[image] [image]

Perforce .NET API
FixJobsCmdOptions Members
FixJobsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The FixJobsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FixJobsCmdOptions | Fix command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FixJobsCmdOptions Class


FixJobsCmdOptions Constructor

[image]

Perforce .NET API
FixJobsCmdOptions Constructor
FixJobsCmdOptions Class See Also Send Feedback
Fix command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FixJobsCmdOptions(
    FixJobsCmdFlags flags,
    int changelistId,
    string status
)
Visual Basic
Public Sub New ( _
    flags As FixJobsCmdFlags, _
    changelistId As Integer, _
    status As String _
)
Visual C++
public:
FixJobsCmdOptions(
    FixJobsCmdFlags flags,
    int changelistId,
    String^ status
)

Parameters

flags
Type: Perforce.P4..::..FixJobsCmdFlags
changelistId
Type: System..::..Int32
status
Type: System..::..String

Return Value

Remarks

p4 help fix

fix -- Mark jobs as being fixed by the specified changelist

p4 fix [-d] [-s status] -c changelist# jobName ...

'p4 fix' marks each named job as being fixed by the changelist
number specified with -c. The changelist can be pending or
submitted and the jobs can be open or closed (fixed by another
changelist).

If the changelist has already been submitted and the job is still
open, then 'p4 fix' marks the job closed. If the changelist has not
been submitted and the job is still open, the job is closed when the
changelist is submitted. If the job is already closed, it remains
closed.

The -d flag deletes the specified fixes. This operation does not
otherwise affect the specified changelist or jobs.

The -s flag uses the specified status instead of the default defined
in the job specification.

The fix's status is reported by 'p4 fixes', and is related to the
job's status. Certain commands set the job's status to the fix's
status for each job associated with the change. When a job is fixed
by a submitted change, the job's status is set to match the fix
status. When a job is fixed by a pending change, the job's status
is set to match the fix status when the change is submitted. If the
fix's status is 'same', the job's status is left unchanged.

See Also

FixJobsCmdOptions Class


FixJobsCmdOptions Methods

[image] [image]

Perforce .NET API
FixJobsCmdOptions Methods
FixJobsCmdOptions Class See Also Send Feedback

The FixJobsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FixJobsCmdOptions Class


FixJobsCmdOptions Properties

[image] [image]

Perforce .NET API
FixJobsCmdOptions Properties
FixJobsCmdOptions Class See Also Send Feedback

The FixJobsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

FixJobsCmdOptions Class


FormBase Class

[image]

Perforce .NET API
FormBase Class
Members See Also Send Feedback
Describes fields and comments in a Perforce specification.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FormBase : Dictionary<string, Object>
Visual Basic
Public Class FormBase _
    Inherits Dictionary(Of String, Object)
Visual C++
public ref class FormBase : public Dictionary<String^, Object^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
Perforce.P4..::..FormBase
Perforce.P4..::..Job

See Also

FormBase Members


FormBase Members

[image] [image]

Perforce .NET API
FormBase Members
FormBase Class Constructors Methods Properties See Also Send Feedback

The FormBase type exposes the following members.

Constructors

 | Name | Description
Public method | FormBase | Initializes a new instance of the FormBase class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
 | ConvertFromUTC |
 | ConvertUnixTime(Int64) | Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime
 | ConvertUnixTime(String) | Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime
 | DSTMismatch |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatDateTime | Utility function to format a DateTime in the format expected in a spec
 | FormatMultilineField | Utility to properly format multi-line fields in forms
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Parse | Parse a string specification in the server format into an object.
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ToString | Create a form specification from the fields that make up a form (Overrides Object..::..ToString()()()().)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

Properties

 | Name | Description
Public property | Comments |
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | IsFieldMultiLine |
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

See Also

FormBase Class


FormBase Constructor

[image]

Perforce .NET API
FormBase Constructor
FormBase Class See Also Send Feedback
Initializes a new instance of the FormBase class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormBase()
Visual Basic
Public Sub New
Visual C++
public:
FormBase()

See Also

FormBase Class


FormBase Methods

[image] [image]

Perforce .NET API
FormBase Methods
FormBase Class See Also Send Feedback

The FormBase type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
 | ConvertFromUTC |
 | ConvertUnixTime(Int64) | Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime
 | ConvertUnixTime(String) | Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime
 | DSTMismatch |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatDateTime | Utility function to format a DateTime in the format expected in a spec
 | FormatMultilineField | Utility to properly format multi-line fields in forms
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Parse | Parse a string specification in the server format into an object.
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ToString | Create a form specification from the fields that make up a form (Overrides Object..::..ToString()()()().)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

See Also

FormBase Class


ConvertFromUTC Method

[image]

Perforce .NET API
FormBase..::..ConvertFromUTC Method
FormBase Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static DateTime ConvertFromUTC(
    DateTime dt,
    string offset,
    bool DST_mistmatch
)
Visual Basic
Public Shared Function ConvertFromUTC ( _
    dt As DateTime, _
    offset As String, _
    DST_mistmatch As Boolean _
) As DateTime
Visual C++
public:
static DateTime ConvertFromUTC(
    DateTime dt,
    String^ offset,
    bool DST_mistmatch
)

Parameters

dt
Type: System..::..DateTime
offset
Type: System..::..String
DST_mistmatch
Type: System..::..Boolean

See Also

FormBase Class


ConvertUnixTime Method

[image] [image]

Perforce .NET API
FormBase..::..ConvertUnixTime Method
FormBase Class See Also Send Feedback

Overload List

Name | Description
ConvertUnixTime(Int64) | Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime
ConvertUnixTime(String) | Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime

See Also

FormBase Class
FormBase Members


ConvertUnixTime Method (Int64)

[image]

Perforce .NET API
FormBase..::..ConvertUnixTime Method (Int64)
FormBase Class See Also Send Feedback
Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static DateTime ConvertUnixTime(
    long unixTime
)
Visual Basic
Public Shared Function ConvertUnixTime ( _
    unixTime As Long _
) As DateTime
Visual C++
public:
static DateTime ConvertUnixTime(
    long long unixTime
)

Parameters

unixTime
Type: System..::..Int64

Return Value

See Also

FormBase Class
ConvertUnixTime Overload


ConvertUnixTime Method (String)

[image]

Perforce .NET API
FormBase..::..ConvertUnixTime Method (String)
FormBase Class See Also Send Feedback
Utility to convert a Unix time (Seconds past midnight 1/1/1970) to a DateTime

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static DateTime ConvertUnixTime(
    string unixTimeStr
)
Visual Basic
Public Shared Function ConvertUnixTime ( _
    unixTimeStr As String _
) As DateTime
Visual C++
public:
static DateTime ConvertUnixTime(
    String^ unixTimeStr
)

Parameters

unixTimeStr
Type: System..::..String
Unix time as a string

Return Value

See Also

FormBase Class
ConvertUnixTime Overload


DSTMismatch Method

[image]

Perforce .NET API
FormBase..::..DSTMismatch Method
FormBase Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool DSTMismatch(
    ServerMetaData smd
)
Visual Basic
Public Shared Function DSTMismatch ( _
    smd As ServerMetaData _
) As Boolean
Visual C++
public:
static bool DSTMismatch(
    ServerMetaData^ smd
)

Parameters

smd
Type: Perforce.P4..::..ServerMetaData

See Also

FormBase Class


FormatDateTime Method

[image]

Perforce .NET API
FormBase..::..FormatDateTime Method
FormBase Class See Also Send Feedback
Utility function to format a DateTime in the format expected in a spec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string FormatDateTime(
    DateTime dt
)
Visual Basic
Public Shared Function FormatDateTime ( _
    dt As DateTime _
) As String
Visual C++
public:
static String^ FormatDateTime(
    DateTime dt
)

Parameters

dt
Type: System..::..DateTime

Return Value

See Also

FormBase Class


FormatMultilineField Method

[image]

Perforce .NET API
FormBase..::..FormatMultilineField Method
FormBase Class See Also Send Feedback
Utility to properly format multi-line fields in forms

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string FormatMultilineField(
    string multiline
)
Visual Basic
Public Shared Function FormatMultilineField ( _
    multiline As String _
) As String
Visual C++
public:
static String^ FormatMultilineField(
    String^ multiline
)

Parameters

multiline
Type: System..::..String

Return Value

See Also

FormBase Class


Parse Method

[image]

Perforce .NET API
FormBase..::..Parse Method
FormBase Class See Also Send Feedback
Parse a string specification in the server format into an object.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public virtual bool Parse(
    string spec
)
Visual Basic
Public Overridable Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
virtual bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
String specification

Return Value

Success/Failure

Remarks

The base implementation parses the generic specification tag::value format into the underlying dictionary

See Also

FormBase Class


ToString Method

[image]

Perforce .NET API
FormBase..::..ToString Method
FormBase Class See Also Send Feedback
Create a form specification from the fields that make up a form

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

FormBase Class


FormBase Properties

[image] [image]

Perforce .NET API
FormBase Properties
FormBase Class See Also Send Feedback

The FormBase type exposes the following members.

Properties

 | Name | Description
Public property | Comments |
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | IsFieldMultiLine |
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

See Also

FormBase Class


Comments Property

[image]

Perforce .NET API
FormBase..::..Comments Property
FormBase Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

See Also

FormBase Class


IsFieldMultiLine Property

[image]

Perforce .NET API
FormBase..::..IsFieldMultiLine Property
FormBase Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, bool> IsFieldMultiLine { get; internal set; }
Visual Basic
Public Property IsFieldMultiLine As Dictionary(Of String, Boolean)
    Get
    Friend Set
Visual C++
public:
property Dictionary<String^, bool>^ IsFieldMultiLine {
    Dictionary<String^, bool>^ get ();
    internal: void set (Dictionary<String^, bool>^ value);
}

See Also

FormBase Class


FormSpec Class

[image]

Perforce .NET API
FormSpec Class
Members See Also Send Feedback
Specifies structural and semantic metadata for form types.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class FormSpec
Visual Basic
Public Class FormSpec
Visual C++
public ref class FormSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..FormSpec

See Also

FormSpec Members


FormSpec Members

[image] [image]

Perforce .NET API
FormSpec Members
FormSpec Class Constructors Methods Properties See Also Send Feedback

The FormSpec type exposes the following members.

Constructors

 | Name | Description
Public method | FormSpec()()()() | Create an empty FormSpec
Public method | FormSpec(List<(Of <<'(SpecField>)>>), Dictionary<(Of <<'(String, String>)>>), List<(Of <<'(String>)>>), List<(Of <<'(String>)>>), Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, String>)>>), String) | Create a FormSpec

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromSpecCmdTaggedOutput | Create a FormSpec from the tagged output of the 'spec' command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpecFieldDataType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comments | a single (possibly rather long) string (which may contain embedded newlines) containing comments to be optionally used in GUI or other representations of the form type.
Public property | FieldMap | Map, keyed by SpecField name, containing suitable allowed values for specific form fields.
Public property | Fields | List of all SpecField objects for all fields defined for this Form type.
Public property | Formats | List of "formats" for this form type.
Public property | Presets | Map, keyed by SpecField name, containing preset (default) values for specific form fields.
Public property | Values | Map, keyed by SpecField name, containing suitable allowed values for specific form fields.
Public property | Words | List of "words" for this form type.

See Also

FormSpec Class


FormSpec Constructor

[image] [image]

Perforce .NET API
FormSpec Constructor
FormSpec Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FormSpec()()()() | Create an empty FormSpec
Public method | FormSpec(List<(Of <<'(SpecField>)>>), Dictionary<(Of <<'(String, String>)>>), List<(Of <<'(String>)>>), List<(Of <<'(String>)>>), Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, String>)>>), String) | Create a FormSpec

See Also

FormSpec Class
FormSpec Members


FormSpec Constructor

[image]

Perforce .NET API
FormSpec Constructor
FormSpec Class See Also Send Feedback
Create an empty FormSpec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec()
Visual Basic
Public Sub New
Visual C++
public:
FormSpec()

See Also

FormSpec Class
FormSpec Overload


FormSpec Constructor (List(SpecField), Dictionary(String, String), List(String), List(String), Dictionary(String, String), Dictionary(String, String), String)

[image]

Perforce .NET API
FormSpec Constructor (List<(Of <(<'SpecField>)>)>, Dictionary<(Of <(<'String, String>)>)>, List<(Of <(<'String>)>)>, List<(Of <(<'String>)>)>, Dictionary<(Of <(<'String, String>)>)>, Dictionary<(Of <(<'String, String>)>)>, String)
FormSpec Class See Also Send Feedback
Create a FormSpec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec(
    List<SpecField> fields,
    Dictionary<string, string> fieldmap,
    List<string> words,
    List<string> formats,
    Dictionary<string, string> values,
    Dictionary<string, string> presets,
    string comments
)
Visual Basic
Public Sub New ( _
    fields As List(Of SpecField), _
    fieldmap As Dictionary(Of String, String), _
    words As List(Of String), _
    formats As List(Of String), _
    values As Dictionary(Of String, String), _
    presets As Dictionary(Of String, String), _
    comments As String _
)
Visual C++
public:
FormSpec(
    List<SpecField^>^ fields,
    Dictionary<String^, String^>^ fieldmap,
    List<String^>^ words,
    List<String^>^ formats,
    Dictionary<String^, String^>^ values,
    Dictionary<String^, String^>^ presets,
    String^ comments
)

Parameters

fields
Type: System.Collections.Generic..::..List <(Of <(<' SpecField >)>)>
fieldmap
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
words
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
formats
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
values
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
presets
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
comments
Type: System..::..String

See Also

FormSpec Class
FormSpec Overload


FormSpec Methods

[image] [image]

Perforce .NET API
FormSpec Methods
FormSpec Class See Also Send Feedback

The FormSpec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromSpecCmdTaggedOutput | Create a FormSpec from the tagged output of the 'spec' command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpecFieldDataType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormSpec Class


FromSpecCmdTaggedOutput Method

[image]

Perforce .NET API
FormSpec..::..FromSpecCmdTaggedOutput Method
FormSpec Class See Also Send Feedback
Create a FormSpec from the tagged output of the 'spec' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static FormSpec FromSpecCmdTaggedOutput(
    TaggedObject obj
)
Visual Basic
Public Shared Function FromSpecCmdTaggedOutput ( _
    obj As TaggedObject _
) As FormSpec
Visual C++
public:
static FormSpec^ FromSpecCmdTaggedOutput(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject
Tagged object returned by the 'spec' command

Return Value

See Also

FormSpec Class


GetSpecFieldDataType Method

[image]

Perforce .NET API
FormSpec..::..GetSpecFieldDataType Method
FormSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SpecFieldDataType GetSpecFieldDataType(
    FormSpec formspec,
    string key
)
Visual Basic
Public Function GetSpecFieldDataType ( _
    formspec As FormSpec, _
    key As String _
) As SpecFieldDataType
Visual C++
public:
SpecFieldDataType GetSpecFieldDataType(
    FormSpec^ formspec,
    String^ key
)

Parameters

formspec
Type: Perforce.P4..::..FormSpec
key
Type: System..::..String

See Also

FormSpec Class


FormSpec Properties

[image] [image]

Perforce .NET API
FormSpec Properties
FormSpec Class See Also Send Feedback

The FormSpec type exposes the following members.

Properties

 | Name | Description
Public property | Comments | a single (possibly rather long) string (which may contain embedded newlines) containing comments to be optionally used in GUI or other representations of the form type.
Public property | FieldMap | Map, keyed by SpecField name, containing suitable allowed values for specific form fields.
Public property | Fields | List of all SpecField objects for all fields defined for this Form type.
Public property | Formats | List of "formats" for this form type.
Public property | Presets | Map, keyed by SpecField name, containing preset (default) values for specific form fields.
Public property | Values | Map, keyed by SpecField name, containing suitable allowed values for specific form fields.
Public property | Words | List of "words" for this form type.

See Also

FormSpec Class


Comments Property

[image]

Perforce .NET API
FormSpec..::..Comments Property
FormSpec Class See Also Send Feedback
a single (possibly rather long) string (which may contain embedded newlines) containing comments to be optionally used in GUI or other representations of the form type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

See Also

FormSpec Class


FieldMap Property

[image]

Perforce .NET API
FormSpec..::..FieldMap Property
FormSpec Class See Also Send Feedback
Map, keyed by SpecField name, containing suitable allowed values for specific form fields.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, string> FieldMap { get; set; }
Visual Basic
Public Property FieldMap As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ FieldMap {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

See Also

FormSpec Class


Fields Property

[image]

Perforce .NET API
FormSpec..::..Fields Property
FormSpec Class See Also Send Feedback
List of all SpecField objects for all fields defined for this Form type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<SpecField> Fields { get; set; }
Visual Basic
Public Property Fields As IList(Of SpecField)
    Get
    Set
Visual C++
public:
property IList<SpecField^>^ Fields {
    IList<SpecField^>^ get ();
    void set (IList<SpecField^>^ value);
}

See Also

FormSpec Class


Formats Property

[image]

Perforce .NET API
FormSpec..::..Formats Property
FormSpec Class See Also Send Feedback
List of "formats" for this form type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> Formats { get; set; }
Visual Basic
Public Property Formats As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ Formats {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

FormSpec Class


Presets Property

[image]

Perforce .NET API
FormSpec..::..Presets Property
FormSpec Class See Also Send Feedback
Map, keyed by SpecField name, containing preset (default) values for specific form fields.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, string> Presets { get; set; }
Visual Basic
Public Property Presets As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Presets {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Remarks

See the main Perforce documentation for formats used here.

See Also

FormSpec Class


Values Property

[image]

Perforce .NET API
FormSpec..::..Values Property
FormSpec Class See Also Send Feedback
Map, keyed by SpecField name, containing suitable allowed values for specific form fields.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, string> Values { get; set; }
Visual Basic
Public Property Values As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Values {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Remarks

See the main Perforce documentation for formats used here.

See Also

FormSpec Class


Words Property

[image]

Perforce .NET API
FormSpec..::..Words Property
FormSpec Class See Also Send Feedback
List of "words" for this form type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> Words { get; set; }
Visual Basic
Public Property Words As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ Words {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

FormSpec Class


GetDepotDirsCmdFlags Enumeration

[image]

Perforce .NET API
GetDepotDirsCmdFlags Enumeration
See Also Send Feedback
Flags for the dirs command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetDepotDirsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetDepotDirsCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetDepotDirsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
CurrentClientOnly | 1 | The -C flag lists only directories that fall within the current client view.
IncludeDeletedFilesDirs | 2 | The -D flag includes directories containing only deleted files.
SyncedDirs | 4 | The -H flag lists directories containing files synced to the current client workspace.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetDepotDirsCmdOptions Class

[image]

Perforce .NET API
GetDepotDirsCmdOptions Class
Members See Also Send Feedback
dirs command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetDepotDirsCmdOptions : Options
Visual Basic
Public Class GetDepotDirsCmdOptions _
    Inherits Options
Visual C++
public ref class GetDepotDirsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetDepotDirsCmdOptions

See Also

GetDepotDirsCmdOptions Members


GetDepotDirsCmdOptions Members

[image] [image]

Perforce .NET API
GetDepotDirsCmdOptions Members
GetDepotDirsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetDepotDirsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetDepotDirsCmdOptions | Initializes a new instance of the GetDepotDirsCmdOptions class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotDirsCmdOptions Class


GetDepotDirsCmdOptions Constructor

[image]

Perforce .NET API
GetDepotDirsCmdOptions Constructor
GetDepotDirsCmdOptions Class See Also Send Feedback
Initializes a new instance of the GetDepotDirsCmdOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetDepotDirsCmdOptions(
    GetDepotDirsCmdFlags flags,
    string stream
)
Visual Basic
Public Sub New ( _
    flags As GetDepotDirsCmdFlags, _
    stream As String _
)
Visual C++
public:
GetDepotDirsCmdOptions(
    GetDepotDirsCmdFlags flags,
    String^ stream
)

Parameters

flags
Type: Perforce.P4..::..GetDepotDirsCmdFlags
stream
Type: System..::..String

See Also

GetDepotDirsCmdOptions Class


GetDepotDirsCmdOptions Methods

[image] [image]

Perforce .NET API
GetDepotDirsCmdOptions Methods
GetDepotDirsCmdOptions Class See Also Send Feedback

The GetDepotDirsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotDirsCmdOptions Class


GetDepotDirsCmdOptions Properties

[image] [image]

Perforce .NET API
GetDepotDirsCmdOptions Properties
GetDepotDirsCmdOptions Class See Also Send Feedback

The GetDepotDirsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotDirsCmdOptions Class


GetDepotFileDiffsCmdFlags Enumeration

[image]

Perforce .NET API
GetDepotFileDiffsCmdFlags Enumeration
See Also Send Feedback
Flags for the diff2 command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetDepotFileDiffsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetDepotFileDiffsCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetDepotFileDiffsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
RCS | 1 | -dn RCS output
Context | 2 | -dc[n] context
Summary | 4 | -ds summary
Unified | 8 | -du[n] unified
IgnoreWhitespaceChanges | 16 | -db ignore whitespace changes
IgnoreWhitespace | 32 | -dw ignore whitespace
IgnoreLineEndings | 64 | -dl ignore line endings
Limit | 128 | The -Od flag limits output to files that differ.
Supress | 256 | The -q omits files that have identical content and types and suppresses the actual diff for all files.
DiffBinary | 512 | The -t flag forces 'p4 diff2' to diff binary files.
GNU | 1024 | The -u flag uses the GNU diff -u format and displays only files that differ. The file names and dates are in Perforce syntax, but but the output can be used by the patch program.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetDepotFileDiffsCmdOptions Class

[image]

Perforce .NET API
GetDepotFileDiffsCmdOptions Class
Members See Also Send Feedback
Diff2 command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetDepotFileDiffsCmdOptions : Options
Visual Basic
Public Class GetDepotFileDiffsCmdOptions _
    Inherits Options
Visual C++
public ref class GetDepotFileDiffsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetDepotFileDiffsCmdOptions

See Also

GetDepotFileDiffsCmdOptions Members


GetDepotFileDiffsCmdOptions Members

[image] [image]

Perforce .NET API
GetDepotFileDiffsCmdOptions Members
GetDepotFileDiffsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetDepotFileDiffsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetDepotFileDiffsCmdOptions | Diff2 command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotFileDiffsCmdOptions Class


GetDepotFileDiffsCmdOptions Constructor

[image]

Perforce .NET API
GetDepotFileDiffsCmdOptions Constructor
GetDepotFileDiffsCmdOptions Class See Also Send Feedback
Diff2 command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetDepotFileDiffsCmdOptions(
    GetDepotFileDiffsCmdFlags flags,
    int contextLines,
    int unifiedLines,
    string branch,
    string stream,
    string parent
)
Visual Basic
Public Sub New ( _
    flags As GetDepotFileDiffsCmdFlags, _
    contextLines As Integer, _
    unifiedLines As Integer, _
    branch As String, _
    stream As String, _
    parent As String _
)
Visual C++
public:
GetDepotFileDiffsCmdOptions(
    GetDepotFileDiffsCmdFlags flags,
    int contextLines,
    int unifiedLines,
    String^ branch,
    String^ stream,
    String^ parent
)

Parameters

flags
Type: Perforce.P4..::..GetDepotFileDiffsCmdFlags
contextLines
Type: System..::..Int32
unifiedLines
Type: System..::..Int32
branch
Type: System..::..String
stream
Type: System..::..String
parent
Type: System..::..String

See Also

GetDepotFileDiffsCmdOptions Class


GetDepotFileDiffsCmdOptions Methods

[image] [image]

Perforce .NET API
GetDepotFileDiffsCmdOptions Methods
GetDepotFileDiffsCmdOptions Class See Also Send Feedback

The GetDepotFileDiffsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotFileDiffsCmdOptions Class


GetDepotFileDiffsCmdOptions Properties

[image] [image]

Perforce .NET API
GetDepotFileDiffsCmdOptions Properties
GetDepotFileDiffsCmdOptions Class See Also Send Feedback

The GetDepotFileDiffsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotFileDiffsCmdOptions Class


GetDepotFilesCmdFlags Enumeration

[image]

Perforce .NET API
GetDepotFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the files command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetDepotFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetDepotFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetDepotFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllRevisions | 1 | The -a flag displays all revisions within the specific range, rather than just the highest revision in the range.
InArchiveDepots | 2 | The -A flag displays files in archive depots.
NotDeleted | 4 | The -e flag displays files with an action of anything other than deleted, purged or archived. Typically this revision is always available to sync or integrate from.
InUnloadDepot | 8 | The -U option displays files in the unload depot (see 'p4 help unload' for more information about the unload depot).

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetDepotFilesCmdOptions Class

[image]

Perforce .NET API
GetDepotFilesCmdOptions Class
Members See Also Send Feedback
Options for the files command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetDepotFilesCmdOptions : Options
Visual Basic
Public Class GetDepotFilesCmdOptions _
    Inherits Options
Visual C++
public ref class GetDepotFilesCmdOptions : public Options

Remarks

p4 help files

files -- List files in the depot

p4 files [ -a ] [ -A ] [ -e ] [ -m max ] file[revRange] ...
p4 files -U unloadfile ...

List details about specified files: depot file name, revision,
file, type, change action and changelist number of the current
head revision. If client syntax is used to specify the file
argument, the client view mapping is used to determine the
corresponding depot files.

By default, the head revision is listed. If the file argument
specifies a revision, then all files at that revision are listed.
If the file argument specifies a revision range, the highest revision
in the range is used for each file. For details about specifying
revisions, see 'p4 help revisions'.

The -a flag displays all revisions within the specific range, rather
than just the highest revision in the range.

The -A flag displays files in archive depots.

The -e flag displays files with an action of anything other than
deleted, purged or archived. Typically this revision is always
available to sync or integrate from.

The -m flag limits files to the first 'max' number of files.

The -U option displays files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetDepotFilesCmdOptions

See Also

GetDepotFilesCmdOptions Members


GetDepotFilesCmdOptions Members

[image] [image]

Perforce .NET API
GetDepotFilesCmdOptions Members
GetDepotFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetDepotFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetDepotFilesCmdOptions | Initializes a new instance of the GetDepotFilesCmdOptions class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotFilesCmdOptions Class


GetDepotFilesCmdOptions Constructor

[image]

Perforce .NET API
GetDepotFilesCmdOptions Constructor
GetDepotFilesCmdOptions Class See Also Send Feedback
Initializes a new instance of the GetDepotFilesCmdOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetDepotFilesCmdOptions(
    GetDepotFilesCmdFlags flags,
    int maxFiles
)
Visual Basic
Public Sub New ( _
    flags As GetDepotFilesCmdFlags, _
    maxFiles As Integer _
)
Visual C++
public:
GetDepotFilesCmdOptions(
    GetDepotFilesCmdFlags flags,
    int maxFiles
)

Parameters

flags
Type: Perforce.P4..::..GetDepotFilesCmdFlags
maxFiles
Type: System..::..Int32

See Also

GetDepotFilesCmdOptions Class


GetDepotFilesCmdOptions Methods

[image] [image]

Perforce .NET API
GetDepotFilesCmdOptions Methods
GetDepotFilesCmdOptions Class See Also Send Feedback

The GetDepotFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotFilesCmdOptions Class


GetDepotFilesCmdOptions Properties

[image] [image]

Perforce .NET API
GetDepotFilesCmdOptions Properties
GetDepotFilesCmdOptions Class See Also Send Feedback

The GetDepotFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetDepotFilesCmdOptions Class


GetFileAnnotationsCmdFlags Enumeration

[image]

Perforce .NET API
GetFileAnnotationsCmdFlags Enumeration
See Also Send Feedback
Flags for the annotate command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetFileAnnotationsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetFileAnnotationsCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetFileAnnotationsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllResults | 1 | The -a flag includes both deleted files and lines no longer present at the head revision. In the latter case, both the starting and ending revision for each line is displayed.
UseChangeNumbers | 2 | The -c flag directs the annotate command to output changelist numbers rather than revision numbers for each line.
IgnoreWhitespaceChanges | 4 | -db Ignore Whitespace Changes
IgnoreWhitespace | 8 | -dw Ingore whitespace altogether.
IgnoreLineEndings | 16 | -dl Ignore Line Endings
FollowBranches | 32 | The -i flag follows branches. If a file was created by branching, 'p4 annotate' includes the revisions of the source file up to the branch point, just as 'p4 filelog -i' does. If a file has history prior to being created by branching (such as a file that was branched on top of a deleted file), -i ignores those prior revisions and follows the source. -i implies -c.
FollowIntegrations | 64 | The -I flag follows all integrations into the file. If a line was introduced into the file by a merge, the source of the merge is displayed as the changelist that introduced the line. If the source itself was the result of an integration, that source is used instead, and so on. -I implies -c.
Suppress | 128 | The -q flag suppresses the one-line header that is displayed by default for each file. This flag does not affect tagged output returned by a command. GetFileAnnotations runs in tagged mode.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetFileAnnotationsCmdOptions Class

[image]

Perforce .NET API
GetFileAnnotationsCmdOptions Class
Members See Also Send Feedback
Annotate command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetFileAnnotationsCmdOptions : Options
Visual Basic
Public Class GetFileAnnotationsCmdOptions _
    Inherits Options
Visual C++
public ref class GetFileAnnotationsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetFileAnnotationsCmdOptions

See Also

GetFileAnnotationsCmdOptions Members


GetFileAnnotationsCmdOptions Members

[image] [image]

Perforce .NET API
GetFileAnnotationsCmdOptions Members
GetFileAnnotationsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetFileAnnotationsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetFileAnnotationsCmdOptions | Annotate command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileAnnotationsCmdOptions Class


GetFileAnnotationsCmdOptions Constructor

[image]

Perforce .NET API
GetFileAnnotationsCmdOptions Constructor
GetFileAnnotationsCmdOptions Class See Also Send Feedback
Annotate command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetFileAnnotationsCmdOptions(
    GetFileAnnotationsCmdFlags flags,
    string localFile
)
Visual Basic
Public Sub New ( _
    flags As GetFileAnnotationsCmdFlags, _
    localFile As String _
)
Visual C++
public:
GetFileAnnotationsCmdOptions(
    GetFileAnnotationsCmdFlags flags,
    String^ localFile
)

Parameters

flags
Type: Perforce.P4..::..GetFileAnnotationsCmdFlags
localFile
Type: System..::..String

See Also

GetFileAnnotationsCmdOptions Class


GetFileAnnotationsCmdOptions Methods

[image] [image]

Perforce .NET API
GetFileAnnotationsCmdOptions Methods
GetFileAnnotationsCmdOptions Class See Also Send Feedback

The GetFileAnnotationsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileAnnotationsCmdOptions Class


GetFileAnnotationsCmdOptions Properties

[image] [image]

Perforce .NET API
GetFileAnnotationsCmdOptions Properties
GetFileAnnotationsCmdOptions Class See Also Send Feedback

The GetFileAnnotationsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileAnnotationsCmdOptions Class


GetFileContentsCmdFlags Enumeration

[image]

Perforce .NET API
GetFileContentsCmdFlags Enumeration
See Also Send Feedback
Flags for the print command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetFileContentsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetFileContentsCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetFileContentsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllRevisions | 1 | The -a flag prints all revisions within the specified range, rather than just the highest revision in the range.
Suppress | 2 | The -q flag suppresses the initial line that displays the file name and revision.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetFileContentsCmdOptions Class

[image]

Perforce .NET API
GetFileContentsCmdOptions Class
Members See Also Send Feedback
Print command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetFileContentsCmdOptions : Options
Visual Basic
Public Class GetFileContentsCmdOptions _
    Inherits Options
Visual C++
public ref class GetFileContentsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetFileContentsCmdOptions

See Also

GetFileContentsCmdOptions Members


GetFileContentsCmdOptions Members

[image] [image]

Perforce .NET API
GetFileContentsCmdOptions Members
GetFileContentsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetFileContentsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetFileContentsCmdOptions | Command options for GetFileContentsCmd()

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileContentsCmdOptions Class


GetFileContentsCmdOptions Constructor

[image]

Perforce .NET API
GetFileContentsCmdOptions Constructor
GetFileContentsCmdOptions Class See Also Send Feedback
Command options for GetFileContentsCmd()

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetFileContentsCmdOptions(
    GetFileContentsCmdFlags flags,
    string localFile
)
Visual Basic
Public Sub New ( _
    flags As GetFileContentsCmdFlags, _
    localFile As String _
)
Visual C++
public:
GetFileContentsCmdOptions(
    GetFileContentsCmdFlags flags,
    String^ localFile
)

Parameters

flags
Type: Perforce.P4..::..GetFileContentsCmdFlags
localFile
Type: System..::..String

Remarks

p4 help print

print -- Write a depot file to standard output

p4 print [-a -A -k -o localFile -q -m max] file[revRange] ...
p4 print -U unloadfile ...

Retrieve the contents of a depot file to the client's standard output.
The file is not synced. If file is specified using client syntax,
Perforce uses the client view to determine the corresponding depot
file.

By default, the head revision is printed. If the file argument
includes a revision, the specified revision is printed. If the
file argument has a revision range, then only files selected by
that revision range are printed, and the highest revision in the
range is printed. For details about revision specifiers, see 'p4
help revisions'.

The -a flag prints all revisions within the specified range, rather
than just the highest revision in the range.

The -A flag prints files in archive depots.

The -k flag suppresses keyword expansion.

The -o localFile flag redirects the output to the specified file on
the client filesystem.

The -q flag suppresses the initial line that displays the file name
and revision.

The -m flag limits print to the first 'max' number of files.

The -U option prints files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

See Also

GetFileContentsCmdOptions Class


GetFileContentsCmdOptions Methods

[image] [image]

Perforce .NET API
GetFileContentsCmdOptions Methods
GetFileContentsCmdOptions Class See Also Send Feedback

The GetFileContentsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileContentsCmdOptions Class


GetFileContentsCmdOptions Properties

[image] [image]

Perforce .NET API
GetFileContentsCmdOptions Properties
GetFileContentsCmdOptions Class See Also Send Feedback

The GetFileContentsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileContentsCmdOptions Class


GetFileHistoryCmdFlags Enumeration

[image]

Perforce .NET API
GetFileHistoryCmdFlags Enumeration
See Also Send Feedback
Flags for the filelog command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetFileHistoryCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetFileHistoryCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetFileHistoryCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeInherited | 1 | The -i flag includes inherited file history. If a file was created by branching (using 'p4 integrate'), filelog lists the revisions of the file's ancestors up to the branch points that led to the specified revision. File history inherited by renaming (using 'p4 move') is always displayed regardless of whether -i is specified.
ContentHistory | 2 | The -h flag displays file content history instead of file name history. The list includes revisions of other files that were branched or copied (using 'p4 integrate' and 'p4 resolve -at') to the specified revision. Revisions that were replaced by copying or branching are omitted, even if they are part of the history of the specified revision.
Time | 4 | The -t flag displays the time as well as the date.
FullDescription | 8 | The -l flag lists the full text of the changelist descriptions.
TruncatedDescription | 16 | The -L flag lists the full text of the changelist descriptions, truncated to 250 characters if longer.
Shortened | 32 | The -s flag displays a shortened form of filelog that omits non-contributory integrations.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetFileHistoryCmdOptions Class

[image]

Perforce .NET API
GetFileHistoryCmdOptions Class
Members See Also Send Feedback
Filelog command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetFileHistoryCmdOptions : Options
Visual Basic
Public Class GetFileHistoryCmdOptions _
    Inherits Options
Visual C++
public ref class GetFileHistoryCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetFileHistoryCmdOptions

See Also

GetFileHistoryCmdOptions Members


GetFileHistoryCmdOptions Members

[image] [image]

Perforce .NET API
GetFileHistoryCmdOptions Members
GetFileHistoryCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetFileHistoryCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetFileHistoryCmdOptions | Filelog command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileHistoryCmdOptions Class


GetFileHistoryCmdOptions Constructor

[image]

Perforce .NET API
GetFileHistoryCmdOptions Constructor
GetFileHistoryCmdOptions Class See Also Send Feedback
Filelog command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetFileHistoryCmdOptions(
    GetFileHistoryCmdFlags flags,
    int changeList,
    int maxRevs
)
Visual Basic
Public Sub New ( _
    flags As GetFileHistoryCmdFlags, _
    changeList As Integer, _
    maxRevs As Integer _
)
Visual C++
public:
GetFileHistoryCmdOptions(
    GetFileHistoryCmdFlags flags,
    int changeList,
    int maxRevs
)

Parameters

flags
Type: Perforce.P4..::..GetFileHistoryCmdFlags
changeList
Type: System..::..Int32
maxRevs
Type: System..::..Int32

See Also

GetFileHistoryCmdOptions Class


GetFileHistoryCmdOptions Methods

[image] [image]

Perforce .NET API
GetFileHistoryCmdOptions Methods
GetFileHistoryCmdOptions Class See Also Send Feedback

The GetFileHistoryCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileHistoryCmdOptions Class


GetFileHistoryCmdOptions Properties

[image] [image]

Perforce .NET API
GetFileHistoryCmdOptions Properties
GetFileHistoryCmdOptions Class See Also Send Feedback

The GetFileHistoryCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileHistoryCmdOptions Class


GetFileLineMatchesCmdFlags Enumeration

[image]

Perforce .NET API
GetFileLineMatchesCmdFlags Enumeration
See Also Send Feedback
Flags for the grep command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetFileLineMatchesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetFileLineMatchesCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetFileLineMatchesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllRevisions | 1 | The -a flag searches all revisions within the specified range. By default only the highest revision in the range is searched.
CaseInsensitive | 2 | The -i flag causes the pattern matching to be case-insensitive. By default, matching is case-sensitive.
IncludeLineNumbers | 4 | The -n flag displays the matching line number after the file revision number. By default, matches are displayed as revision#: <text>.
NonMatchingLines | 8 | The -v flag displays files with non-matching lines.
SearchBinaries | 16 | The -t flag searches binary files. By default, only text files are searched.
NameNoOutput | 32 | The -L flag displays the name of each selected file from which no output would normally have been displayed. Scanning stops on the first match.
NameMatchingText | 64 | The -l flag display the name of each selected file containing matching text. Scanning stops on the first match.
Supress | 128 | The -s flag suppresses error messages that result from abandoning files that have a maximum number of characters in a single line that are greater than 4096. By default, an error is reported when grep abandons such files.
FixedPattern | 256 | The -F flag is used to interpret the pattern as a fixed string.
RegularExpression | 512 | The -G flag is used to interpret the pattern as a regular expression.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetFileLineMatchesCmdOptions Class

[image]

Perforce .NET API
GetFileLineMatchesCmdOptions Class
Members See Also Send Feedback
Grep command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetFileLineMatchesCmdOptions : Options
Visual Basic
Public Class GetFileLineMatchesCmdOptions _
    Inherits Options
Visual C++
public ref class GetFileLineMatchesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetFileLineMatchesCmdOptions

See Also

GetFileLineMatchesCmdOptions Members


GetFileLineMatchesCmdOptions Members

[image] [image]

Perforce .NET API
GetFileLineMatchesCmdOptions Members
GetFileLineMatchesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetFileLineMatchesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetFileLineMatchesCmdOptions | Grep command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileLineMatchesCmdOptions Class


GetFileLineMatchesCmdOptions Constructor

[image]

Perforce .NET API
GetFileLineMatchesCmdOptions Constructor
GetFileLineMatchesCmdOptions Class See Also Send Feedback
Grep command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetFileLineMatchesCmdOptions(
    GetFileLineMatchesCmdFlags flags,
    int outputContext,
    int trailingContext,
    int leadingContext
)
Visual Basic
Public Sub New ( _
    flags As GetFileLineMatchesCmdFlags, _
    outputContext As Integer, _
    trailingContext As Integer, _
    leadingContext As Integer _
)
Visual C++
public:
GetFileLineMatchesCmdOptions(
    GetFileLineMatchesCmdFlags flags,
    int outputContext,
    int trailingContext,
    int leadingContext
)

Parameters

flags
Type: Perforce.P4..::..GetFileLineMatchesCmdFlags
outputContext
Type: System..::..Int32
trailingContext
Type: System..::..Int32
leadingContext
Type: System..::..Int32

See Also

GetFileLineMatchesCmdOptions Class


GetFileLineMatchesCmdOptions Methods

[image] [image]

Perforce .NET API
GetFileLineMatchesCmdOptions Methods
GetFileLineMatchesCmdOptions Class See Also Send Feedback

The GetFileLineMatchesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileLineMatchesCmdOptions Class


GetFileLineMatchesCmdOptions Properties

[image] [image]

Perforce .NET API
GetFileLineMatchesCmdOptions Properties
GetFileLineMatchesCmdOptions Class See Also Send Feedback

The GetFileLineMatchesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileLineMatchesCmdOptions Class


GetFileMetadataCmdFlags Enumeration

[image]

Perforce .NET API
GetFileMetadataCmdFlags Enumeration
See Also Send Feedback
Flags for the fstat command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetFileMetadataCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetFileMetadataCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetFileMetadataCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
MultiFileArgs | 1 | The -L flag can be used with multiple file arguments that are in full depot syntax and include a valid revision number. When this flag is used the arguments are processed together by building an internal table similar to a label. This file list processing is significantly faster than having to call the internal query engine for each individual file argument. However, the file argument syntax is strict and the command will not run if an error is encountered.
Reverse | 2 | The -r flag sorts the output in reverse order.
Attributes | 4 | -Oa output attributes set by 'p4 attribute'.
AttributeDigest | 8 | -Od output the digest of the attribute.
HexAttributes | 16 | -Oe output attribute values encoded as hex
AllRevisions | 32 | -Of output all revisions for the given files (this option suppresses other* and resolve* fields)
FileSize | 64 | -Ol output a fileSize and digest field for each revision (this may be expensive to compute)
LocalPath | 128 | -Op output the local file path in both Perforce syntax (//client/) as 'clientFile' and host form as 'path'
PendingInteg | 256 |
ExcludeClientData | 512 | -Os exclude client-related data from output
ClientMapped | 1024 | -Rc limit output to files mapped in the client view
Synced | 2048 | -Rh limit output to files synced to the client workspace
NotHeadRev | 4096 | -Rn limit output to files opened not at the head revision
Opened | 8192 | -Ro limit output to files opened
Resolved | 16384 | -Rr limit output to files opened that have been resolved
Shelved | 32768 | -Rs limit output to files shelved (requires -e)
NeedsResolve | 65536 | -Ru limit output to files opened that need resolving
FileTypeSort | 131072 | -St sort by filetype
DateSort | 262144 | -Sd sort by date
HeadRevSort | 524288 | -Sr sort by head revision
HaveRevSort | 1048576 | -Sh sort by have revision
FileSizeSort | 2097152 | -Ss sort by filesize
InUnloadDepot | 4194304 | -U displays information about unload files in the unload depot (see 'p4 help unload').

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetFileMetaDataCmdOptions Class

[image]

Perforce .NET API
GetFileMetaDataCmdOptions Class
Members See Also Send Feedback
GetFileMetaData options (uses the fstat command)

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetFileMetaDataCmdOptions : Options
Visual Basic
Public Class GetFileMetaDataCmdOptions _
    Inherits Options
Visual C++
public ref class GetFileMetaDataCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetFileMetaDataCmdOptions

See Also

GetFileMetaDataCmdOptions Members


GetFileMetaDataCmdOptions Members

[image] [image]

Perforce .NET API
GetFileMetaDataCmdOptions Members
GetFileMetaDataCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetFileMetaDataCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetFileMetaDataCmdOptions(GetFileMetadataCmdFlags, String, String, Int32, String, String) | Obsolete. Initializes a new instance of the GetFileMetaDataCmdOptions class
Public method | GetFileMetaDataCmdOptions(GetFileMetadataCmdFlags, String, String, Int32, String, String, String) | Initializes a new instance of the GetFileMetaDataCmdOptions class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileMetaDataCmdOptions Class


GetFileMetaDataCmdOptions Constructor

[image] [image]

Perforce .NET API
GetFileMetaDataCmdOptions Constructor
GetFileMetaDataCmdOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFileMetaDataCmdOptions(GetFileMetadataCmdFlags, String, String, Int32, String, String) | Obsolete. Initializes a new instance of the GetFileMetaDataCmdOptions class
Public method | GetFileMetaDataCmdOptions(GetFileMetadataCmdFlags, String, String, Int32, String, String, String) | Initializes a new instance of the GetFileMetaDataCmdOptions class

See Also

GetFileMetaDataCmdOptions Class
GetFileMetaDataCmdOptions Members


GetFileMetaDataCmdOptions Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String)

[image]

Perforce .NET API
GetFileMetaDataCmdOptions Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String)
GetFileMetaDataCmdOptions Class See Also Send Feedback
Initializes a new instance of the GetFileMetaDataCmdOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[ObsoleteAttribute("use GetFileMetaDataCmdOptions(GetFileMetadataCmdFlags flags, string filter, string taggedFields, int maxItems, string afterChangelist, string byChangelist, string attribPattern)")]
public GetFileMetaDataCmdOptions(
    GetFileMetadataCmdFlags flags,
    string filter,
    string taggedFields,
    int maxItems,
    string afterChangelist,
    string byChangelist
)
Visual Basic
<ObsoleteAttribute("use GetFileMetaDataCmdOptions(GetFileMetadataCmdFlags flags, string filter, string taggedFields, int maxItems, string afterChangelist, string byChangelist, string attribPattern)")> _
Public Sub New ( _
    flags As GetFileMetadataCmdFlags, _
    filter As String, _
    taggedFields As String, _
    maxItems As Integer, _
    afterChangelist As String, _
    byChangelist As String _
)
Visual C++
[ObsoleteAttribute(L"use GetFileMetaDataCmdOptions(GetFileMetadataCmdFlags flags, string filter, string taggedFields, int maxItems, string afterChangelist, string byChangelist, string attribPattern)")]
public:
GetFileMetaDataCmdOptions(
    GetFileMetadataCmdFlags flags,
    String^ filter,
    String^ taggedFields,
    int maxItems,
    String^ afterChangelist,
    String^ byChangelist
)

Parameters

flags
Type: Perforce.P4..::..GetFileMetadataCmdFlags
filter
Type: System..::..String
taggedFields
Type: System..::..String
maxItems
Type: System..::..Int32
afterChangelist
Type: System..::..String
byChangelist
Type: System..::..String

See Also

GetFileMetaDataCmdOptions Class
GetFileMetaDataCmdOptions Overload


GetFileMetaDataCmdOptions Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String, String)

[image]

Perforce .NET API
GetFileMetaDataCmdOptions Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String, String)
GetFileMetaDataCmdOptions Class See Also Send Feedback
Initializes a new instance of the GetFileMetaDataCmdOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetFileMetaDataCmdOptions(
    GetFileMetadataCmdFlags flags,
    string filter,
    string taggedFields,
    int maxItems,
    string afterChangelist,
    string byChangelist,
    string attribPattern
)
Visual Basic
Public Sub New ( _
    flags As GetFileMetadataCmdFlags, _
    filter As String, _
    taggedFields As String, _
    maxItems As Integer, _
    afterChangelist As String, _
    byChangelist As String, _
    attribPattern As String _
)
Visual C++
public:
GetFileMetaDataCmdOptions(
    GetFileMetadataCmdFlags flags,
    String^ filter,
    String^ taggedFields,
    int maxItems,
    String^ afterChangelist,
    String^ byChangelist,
    String^ attribPattern
)

Parameters

flags
Type: Perforce.P4..::..GetFileMetadataCmdFlags
filter
Type: System..::..String
taggedFields
Type: System..::..String
maxItems
Type: System..::..Int32
afterChangelist
Type: System..::..String
byChangelist
Type: System..::..String
attribPattern
Type: System..::..String

See Also

GetFileMetaDataCmdOptions Class
GetFileMetaDataCmdOptions Overload


GetFileMetaDataCmdOptions Methods

[image] [image]

Perforce .NET API
GetFileMetaDataCmdOptions Methods
GetFileMetaDataCmdOptions Class See Also Send Feedback

The GetFileMetaDataCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileMetaDataCmdOptions Class


GetFileMetaDataCmdOptions Properties

[image] [image]

Perforce .NET API
GetFileMetaDataCmdOptions Properties
GetFileMetaDataCmdOptions Class See Also Send Feedback

The GetFileMetaDataCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFileMetaDataCmdOptions Class


GetFixesCmdFlags Enumeration

[image]

Perforce .NET API
GetFixesCmdFlags Enumeration
See Also Send Feedback
Flags for the fixes command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetFixesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetFixesCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetFixesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeIntegrations | 1 | The -C flag lists only directories that fall within the current client view.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetFixesCmdOptions Class

[image]

Perforce .NET API
GetFixesCmdOptions Class
Members See Also Send Feedback
Fixes command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetFixesCmdOptions : Options
Visual Basic
Public Class GetFixesCmdOptions _
    Inherits Options
Visual C++
public ref class GetFixesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetFixesCmdOptions

See Also

GetFixesCmdOptions Members


GetFixesCmdOptions Members

[image] [image]

Perforce .NET API
GetFixesCmdOptions Members
GetFixesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetFixesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetFixesCmdOptions | Fixes command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFixesCmdOptions Class


GetFixesCmdOptions Constructor

[image]

Perforce .NET API
GetFixesCmdOptions Constructor
GetFixesCmdOptions Class See Also Send Feedback
Fixes command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetFixesCmdOptions(
    GetFixesCmdFlags flags,
    int changelistId,
    string jobId,
    int maxFixes
)
Visual Basic
Public Sub New ( _
    flags As GetFixesCmdFlags, _
    changelistId As Integer, _
    jobId As String, _
    maxFixes As Integer _
)
Visual C++
public:
GetFixesCmdOptions(
    GetFixesCmdFlags flags,
    int changelistId,
    String^ jobId,
    int maxFixes
)

Parameters

flags
Type: Perforce.P4..::..GetFixesCmdFlags
changelistId
Type: System..::..Int32
jobId
Type: System..::..String
maxFixes
Type: System..::..Int32

See Also

GetFixesCmdOptions Class


GetFixesCmdOptions Methods

[image] [image]

Perforce .NET API
GetFixesCmdOptions Methods
GetFixesCmdOptions Class See Also Send Feedback

The GetFixesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFixesCmdOptions Class


GetFixesCmdOptions Properties

[image] [image]

Perforce .NET API
GetFixesCmdOptions Properties
GetFixesCmdOptions Class See Also Send Feedback

The GetFixesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetFixesCmdOptions Class


GetOpenedFilesCmdFlags Enumeration

[image]

Perforce .NET API
GetOpenedFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the opened command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetOpenedFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetOpenedFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetOpenedFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllClients | 1 | The -a flag lists opened files in all clients. By default, only files opened by the current client are listed.
ShortOutput | 2 | The -s option produces 'short' and optimized output when used with the -a (all clients) option. For large repositories '-a' can take a long time when compared to '-as'.
Exclusive | 4 | The -x option lists files that are opened 'exclusive'. This option only applies to a distributed installation where global tracking of these file types is necessary across servers. The -x option implies the -a option.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetOpenedFilesOptions Class

[image]

Perforce .NET API
GetOpenedFilesOptions Class
Members See Also Send Feedback
GetOpenedFiles options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetOpenedFilesOptions : Options
Visual Basic
Public Class GetOpenedFilesOptions _
    Inherits Options
Visual C++
public ref class GetOpenedFilesOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetOpenedFilesOptions

See Also

GetOpenedFilesOptions Members


GetOpenedFilesOptions Members

[image] [image]

Perforce .NET API
GetOpenedFilesOptions Members
GetOpenedFilesOptions Class Constructors Methods Properties See Also Send Feedback

The GetOpenedFilesOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetOpenedFilesOptions | Options for GetOpenedFiles

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetOpenedFilesOptions Class


GetOpenedFilesOptions Constructor

[image]

Perforce .NET API
GetOpenedFilesOptions Constructor
GetOpenedFilesOptions Class See Also Send Feedback
Options for GetOpenedFiles

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetOpenedFilesOptions(
    GetOpenedFilesCmdFlags flags,
    string changelist,
    string client,
    string user,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As GetOpenedFilesCmdFlags, _
    changelist As String, _
    client As String, _
    user As String, _
    maxItems As Integer _
)
Visual C++
public:
GetOpenedFilesOptions(
    GetOpenedFilesCmdFlags flags,
    String^ changelist,
    String^ client,
    String^ user,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..GetOpenedFilesCmdFlags
changelist
Type: System..::..String
client
Type: System..::..String
user
Type: System..::..String
maxItems
Type: System..::..Int32

Remarks

p4 help opened

opened -- List open files and display file status

p4 opened [-a -c changelist# -C client -u user -m max -s] [file ...]
p4 opened [-a -x -m max ] [file ...]

Lists files currently opened in pending changelists, or, for
specified files, show whether they are currently opened or locked.
If the file specification is omitted, all files open in the current
client workspace are listed.

Files in shelved changelists are not displayed by this command. To
display shelved changelists, see 'p4 changes -s shelved'; to display
the files in those shelved changelists, see 'p4 describe -s -S'.

The -a flag lists opened files in all clients. By default, only
files opened by the current client are listed.

The -c changelist# flag lists files opened in the specified
changelist#.

The -C client flag lists files open in the specified client workspace.

The -u user flag lists files opened by the specified user.

The -m max flag limits output to the first 'max' number of files.

The -s option produces 'short' and optimized output when used with
the -a (all clients) option. For large repositories '-a' can take
a long time when compared to '-as'.

The -x option lists files that are opened 'exclusive'. This option
only applies to a distributed installation where global tracking of
these file types is necessary across servers. The -x option implies
the -a option.

See Also

GetOpenedFilesOptions Class


GetOpenedFilesOptions Methods

[image] [image]

Perforce .NET API
GetOpenedFilesOptions Methods
GetOpenedFilesOptions Class See Also Send Feedback

The GetOpenedFilesOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetOpenedFilesOptions Class


GetOpenedFilesOptions Properties

[image] [image]

Perforce .NET API
GetOpenedFilesOptions Properties
GetOpenedFilesOptions Class See Also Send Feedback

The GetOpenedFilesOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetOpenedFilesOptions Class


GetProtectionEntriesCmdFlags Enumeration

[image]

Perforce .NET API
GetProtectionEntriesCmdFlags Enumeration
See Also Send Feedback
Flags for the protects command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetProtectionEntriesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetProtectionEntriesCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetProtectionEntriesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllUsers | 1 | If the -a flag is specified, protection lines for all users are displayed. If the -g group flag or -u user flag is specified, protection lines for that group or user are displayed.
AccessSummary | 2 | If the -m flag is given, a single word summary of the maximum access level is reported. Note that this summary does not take exclusions into account.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetProtectionEntriesCmdOptions Class

[image]

Perforce .NET API
GetProtectionEntriesCmdOptions Class
Members See Also Send Feedback
Protects command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetProtectionEntriesCmdOptions : Options
Visual Basic
Public Class GetProtectionEntriesCmdOptions _
    Inherits Options
Visual C++
public ref class GetProtectionEntriesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetProtectionEntriesCmdOptions

See Also

GetProtectionEntriesCmdOptions Members


GetProtectionEntriesCmdOptions Members

[image] [image]

Perforce .NET API
GetProtectionEntriesCmdOptions Members
GetProtectionEntriesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetProtectionEntriesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetProtectionEntriesCmdOptions | Protects command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetProtectionEntriesCmdOptions Class


GetProtectionEntriesCmdOptions Constructor

[image]

Perforce .NET API
GetProtectionEntriesCmdOptions Constructor
GetProtectionEntriesCmdOptions Class See Also Send Feedback
Protects command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetProtectionEntriesCmdOptions(
    GetProtectionEntriesCmdFlags flags,
    string groupName,
    string userName,
    string hostName
)
Visual Basic
Public Sub New ( _
    flags As GetProtectionEntriesCmdFlags, _
    groupName As String, _
    userName As String, _
    hostName As String _
)
Visual C++
public:
GetProtectionEntriesCmdOptions(
    GetProtectionEntriesCmdFlags flags,
    String^ groupName,
    String^ userName,
    String^ hostName
)

Parameters

flags
Type: Perforce.P4..::..GetProtectionEntriesCmdFlags
groupName
Type: System..::..String
userName
Type: System..::..String
hostName
Type: System..::..String

See Also

GetProtectionEntriesCmdOptions Class


GetProtectionEntriesCmdOptions Methods

[image] [image]

Perforce .NET API
GetProtectionEntriesCmdOptions Methods
GetProtectionEntriesCmdOptions Class See Also Send Feedback

The GetProtectionEntriesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetProtectionEntriesCmdOptions Class


GetProtectionEntriesCmdOptions Properties

[image] [image]

Perforce .NET API
GetProtectionEntriesCmdOptions Properties
GetProtectionEntriesCmdOptions Class See Also Send Feedback

The GetProtectionEntriesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetProtectionEntriesCmdOptions Class


GetProtectionTableCmdFlags Enumeration

[image]

Perforce .NET API
GetProtectionTableCmdFlags Enumeration
See Also Send Feedback
Flags for the protect command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetProtectionTableCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetProtectionTableCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetProtectionTableCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Output | 1 | The -o flag writes the protection table to the standard output. The user's editor is not invoked.
Input | 2 | The -i flag writes the protection table from the standard input. The user's editor is not invoked.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetProtectionTableCmdOptions Class

[image]

Perforce .NET API
GetProtectionTableCmdOptions Class
Members See Also Send Feedback
protect command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetProtectionTableCmdOptions : Options
Visual Basic
Public Class GetProtectionTableCmdOptions _
    Inherits Options
Visual C++
public ref class GetProtectionTableCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetProtectionTableCmdOptions

See Also

GetProtectionTableCmdOptions Members


GetProtectionTableCmdOptions Members

[image] [image]

Perforce .NET API
GetProtectionTableCmdOptions Members
GetProtectionTableCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetProtectionTableCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetProtectionTableCmdOptions | protect command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetProtectionTableCmdOptions Class


GetProtectionTableCmdOptions Constructor

[image]

Perforce .NET API
GetProtectionTableCmdOptions Constructor
GetProtectionTableCmdOptions Class See Also Send Feedback
protect command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetProtectionTableCmdOptions(
    GetProtectionTableCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetProtectionTableCmdFlags _
)
Visual C++
public:
GetProtectionTableCmdOptions(
    GetProtectionTableCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetProtectionTableCmdFlags

See Also

GetProtectionTableCmdOptions Class


GetProtectionTableCmdOptions Methods

[image] [image]

Perforce .NET API
GetProtectionTableCmdOptions Methods
GetProtectionTableCmdOptions Class See Also Send Feedback

The GetProtectionTableCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetProtectionTableCmdOptions Class


GetProtectionTableCmdOptions Properties

[image] [image]

Perforce .NET API
GetProtectionTableCmdOptions Properties
GetProtectionTableCmdOptions Class See Also Send Feedback

The GetProtectionTableCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetProtectionTableCmdOptions Class


GetResolvedFilesCmdFlags Enumeration

[image]

Perforce .NET API
GetResolvedFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the resolved command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetResolvedFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetResolvedFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetResolvedFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeBaseRevision | 1 | The -r flag reopens submitted files in the default changelist after submission.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetReviewersCmdFlags Enumeration

[image]

Perforce .NET API
GetReviewersCmdFlags Enumeration
See Also Send Feedback
Flags for the reviews command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetReviewersCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetReviewersCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetReviewersCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetReviewersCmdOptions Class

[image]

Perforce .NET API
GetReviewersCmdOptions Class
Members See Also Send Feedback
Reviews command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetReviewersCmdOptions : Options
Visual Basic
Public Class GetReviewersCmdOptions _
    Inherits Options
Visual C++
public ref class GetReviewersCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetReviewersCmdOptions

See Also

GetReviewersCmdOptions Members


GetReviewersCmdOptions Members

[image] [image]

Perforce .NET API
GetReviewersCmdOptions Members
GetReviewersCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetReviewersCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetReviewersCmdOptions | Reviews command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetReviewersCmdOptions Class


GetReviewersCmdOptions Constructor

[image]

Perforce .NET API
GetReviewersCmdOptions Constructor
GetReviewersCmdOptions Class See Also Send Feedback
Reviews command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetReviewersCmdOptions(
    GetReviewersCmdFlags flags,
    int changelistId
)
Visual Basic
Public Sub New ( _
    flags As GetReviewersCmdFlags, _
    changelistId As Integer _
)
Visual C++
public:
GetReviewersCmdOptions(
    GetReviewersCmdFlags flags,
    int changelistId
)

Parameters

flags
Type: Perforce.P4..::..GetReviewersCmdFlags
changelistId
Type: System..::..Int32

See Also

GetReviewersCmdOptions Class


GetReviewersCmdOptions Methods

[image] [image]

Perforce .NET API
GetReviewersCmdOptions Methods
GetReviewersCmdOptions Class See Also Send Feedback

The GetReviewersCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetReviewersCmdOptions Class


GetReviewersCmdOptions Properties

[image] [image]

Perforce .NET API
GetReviewersCmdOptions Properties
GetReviewersCmdOptions Class See Also Send Feedback

The GetReviewersCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetReviewersCmdOptions Class


GetStreamMetaDataCmdFlags Enumeration

[image]

Perforce .NET API
GetStreamMetaDataCmdFlags Enumeration
See Also Send Feedback
Flags for the istat command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetStreamMetaDataCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetStreamMetaDataCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetStreamMetaDataCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Reverse | 1 | The -r flag shows the status of integration to the stream from its parent. By default, status of integration in the other direction is shown, from the stream to its parent.
All | 2 | The -a flag shows status of integration in both directions.
Refresh | 4 | The -c flag forces 'p4 istat' to assume the cache is stale; it causes a search for pending integrations. Use of this flag can impact server performance.
Cached | 8 | The -s flag shows cached state without refreshing stale data.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetStreamMetaDataCmdOptions Class

[image]

Perforce .NET API
GetStreamMetaDataCmdOptions Class
Members See Also Send Feedback
GetStreamMetaData command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetStreamMetaDataCmdOptions : Options
Visual Basic
Public Class GetStreamMetaDataCmdOptions _
    Inherits Options
Visual C++
public ref class GetStreamMetaDataCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetStreamMetaDataCmdOptions

See Also

GetStreamMetaDataCmdOptions Members


GetStreamMetaDataCmdOptions Members

[image] [image]

Perforce .NET API
GetStreamMetaDataCmdOptions Members
GetStreamMetaDataCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetStreamMetaDataCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetStreamMetaDataCmdOptions | Stream command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetStreamMetaDataCmdOptions Class


GetStreamMetaDataCmdOptions Constructor

[image]

Perforce .NET API
GetStreamMetaDataCmdOptions Constructor
GetStreamMetaDataCmdOptions Class See Also Send Feedback
Stream command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetStreamMetaDataCmdOptions(
    GetStreamMetaDataCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetStreamMetaDataCmdFlags _
)
Visual C++
public:
GetStreamMetaDataCmdOptions(
    GetStreamMetaDataCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetStreamMetaDataCmdFlags

See Also

GetStreamMetaDataCmdOptions Class


GetStreamMetaDataCmdOptions Methods

[image] [image]

Perforce .NET API
GetStreamMetaDataCmdOptions Methods
GetStreamMetaDataCmdOptions Class See Also Send Feedback

The GetStreamMetaDataCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetStreamMetaDataCmdOptions Class


GetStreamMetaDataCmdOptions Properties

[image] [image]

Perforce .NET API
GetStreamMetaDataCmdOptions Properties
GetStreamMetaDataCmdOptions Class See Also Send Feedback

The GetStreamMetaDataCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetStreamMetaDataCmdOptions Class


GetSubmittedIntegrationsCmdFlags Enumeration

[image]

Perforce .NET API
GetSubmittedIntegrationsCmdFlags Enumeration
See Also Send Feedback
Flags for the integrated command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetSubmittedIntegrationsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetSubmittedIntegrationsCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetSubmittedIntegrationsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
ReverseMappings | 1 | The -r flag reverses the mappings in the branch view, swapping the target files and source files. The -b branch flag is required.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetSubmittedIntegrationsCmdOptions Class

[image]

Perforce .NET API
GetSubmittedIntegrationsCmdOptions Class
Members See Also Send Feedback
Integrated command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetSubmittedIntegrationsCmdOptions : Options
Visual Basic
Public Class GetSubmittedIntegrationsCmdOptions _
    Inherits Options
Visual C++
public ref class GetSubmittedIntegrationsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetSubmittedIntegrationsCmdOptions

See Also

GetSubmittedIntegrationsCmdOptions Members


GetSubmittedIntegrationsCmdOptions Members

[image] [image]

Perforce .NET API
GetSubmittedIntegrationsCmdOptions Members
GetSubmittedIntegrationsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetSubmittedIntegrationsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetSubmittedIntegrationsCmdOptions | Integrated command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetSubmittedIntegrationsCmdOptions Class


GetSubmittedIntegrationsCmdOptions Constructor

[image]

Perforce .NET API
GetSubmittedIntegrationsCmdOptions Constructor
GetSubmittedIntegrationsCmdOptions Class See Also Send Feedback
Integrated command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetSubmittedIntegrationsCmdOptions(
    GetSubmittedIntegrationsCmdFlags flags,
    string branchSpec
)
Visual Basic
Public Sub New ( _
    flags As GetSubmittedIntegrationsCmdFlags, _
    branchSpec As String _
)
Visual C++
public:
GetSubmittedIntegrationsCmdOptions(
    GetSubmittedIntegrationsCmdFlags flags,
    String^ branchSpec
)

Parameters

flags
Type: Perforce.P4..::..GetSubmittedIntegrationsCmdFlags
branchSpec
Type: System..::..String

See Also

GetSubmittedIntegrationsCmdOptions Class


GetSubmittedIntegrationsCmdOptions Methods

[image] [image]

Perforce .NET API
GetSubmittedIntegrationsCmdOptions Methods
GetSubmittedIntegrationsCmdOptions Class See Also Send Feedback

The GetSubmittedIntegrationsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetSubmittedIntegrationsCmdOptions Class


GetSubmittedIntegrationsCmdOptions Properties

[image] [image]

Perforce .NET API
GetSubmittedIntegrationsCmdOptions Properties
GetSubmittedIntegrationsCmdOptions Class See Also Send Feedback

The GetSubmittedIntegrationsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetSubmittedIntegrationsCmdOptions Class


GetTriggerTableCmdFlags Enumeration

[image]

Perforce .NET API
GetTriggerTableCmdFlags Enumeration
See Also Send Feedback
Flags for the triggers command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetTriggerTableCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetTriggerTableCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetTriggerTableCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Output | 1 | The -o flag writes the trigger table to the standard output. The user's editor is not invoked.
Input | 2 | The -i flag writes the trigger table from the standard input. The user's editor is not invoked.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetTriggerTableCmdOptions Class

[image]

Perforce .NET API
GetTriggerTableCmdOptions Class
Members See Also Send Feedback
Triggers command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetTriggerTableCmdOptions : Options
Visual Basic
Public Class GetTriggerTableCmdOptions _
    Inherits Options
Visual C++
public ref class GetTriggerTableCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetTriggerTableCmdOptions

See Also

GetTriggerTableCmdOptions Members


GetTriggerTableCmdOptions Members

[image] [image]

Perforce .NET API
GetTriggerTableCmdOptions Members
GetTriggerTableCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetTriggerTableCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetTriggerTableCmdOptions | Triggers command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetTriggerTableCmdOptions Class


GetTriggerTableCmdOptions Constructor

[image]

Perforce .NET API
GetTriggerTableCmdOptions Constructor
GetTriggerTableCmdOptions Class See Also Send Feedback
Triggers command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetTriggerTableCmdOptions(
    GetTriggerTableCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetTriggerTableCmdFlags _
)
Visual C++
public:
GetTriggerTableCmdOptions(
    GetTriggerTableCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetTriggerTableCmdFlags

See Also

GetTriggerTableCmdOptions Class


GetTriggerTableCmdOptions Methods

[image] [image]

Perforce .NET API
GetTriggerTableCmdOptions Methods
GetTriggerTableCmdOptions Class See Also Send Feedback

The GetTriggerTableCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetTriggerTableCmdOptions Class


GetTriggerTableCmdOptions Properties

[image] [image]

Perforce .NET API
GetTriggerTableCmdOptions Properties
GetTriggerTableCmdOptions Class See Also Send Feedback

The GetTriggerTableCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetTriggerTableCmdOptions Class


GetTypeMapCmdFlags Enumeration

[image]

Perforce .NET API
GetTypeMapCmdFlags Enumeration
See Also Send Feedback
Flags for the typemap command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GetTypeMapCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GetTypeMapCmdFlags
Visual C++
[FlagsAttribute]
public enum class GetTypeMapCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Output | 1 | The -o flag writes the typemap table to the standard output. The user's editor is not invoked.
Input | 2 | The -i flag writes the typemap table from the standard input. The user's editor is not invoked.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GetTypeMapCmdOptions Class

[image]

Perforce .NET API
GetTypeMapCmdOptions Class
Members See Also Send Feedback
GetTypeMap command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GetTypeMapCmdOptions : Options
Visual Basic
Public Class GetTypeMapCmdOptions _
    Inherits Options
Visual C++
public ref class GetTypeMapCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GetTypeMapCmdOptions

See Also

GetTypeMapCmdOptions Members


GetTypeMapCmdOptions Members

[image] [image]

Perforce .NET API
GetTypeMapCmdOptions Members
GetTypeMapCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GetTypeMapCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GetTypeMapCmdOptions | GetTypeMap command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetTypeMapCmdOptions Class


GetTypeMapCmdOptions Constructor

[image]

Perforce .NET API
GetTypeMapCmdOptions Constructor
GetTypeMapCmdOptions Class See Also Send Feedback
GetTypeMap command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GetTypeMapCmdOptions(
    GetTypeMapCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetTypeMapCmdFlags _
)
Visual C++
public:
GetTypeMapCmdOptions(
    GetTypeMapCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetTypeMapCmdFlags

See Also

GetTypeMapCmdOptions Class


GetTypeMapCmdOptions Methods

[image] [image]

Perforce .NET API
GetTypeMapCmdOptions Methods
GetTypeMapCmdOptions Class See Also Send Feedback

The GetTypeMapCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetTypeMapCmdOptions Class


GetTypeMapCmdOptions Properties

[image] [image]

Perforce .NET API
GetTypeMapCmdOptions Properties
GetTypeMapCmdOptions Class See Also Send Feedback

The GetTypeMapCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GetTypeMapCmdOptions Class


Group Class

[image]

Perforce .NET API
Group Class
Members See Also Send Feedback
A user group on a Perforce Server, represented by a P4 Group spec.
A group specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Group
Visual Basic
Public Class Group
Visual C++
public ref class Group

Remarks

p4 help group

group -- Change members of user group

p4 group [-a|-A] name
p4 group -d [-a] name
p4 group -o name
p4 group -i [-a|-A]

Create a group or modify the membership of an existing group.
A group can contain users and other groups. The group specification
is put into a temporary file and the editor (configured by the
environment variable $P4EDITOR) is invoked.

A group exists when it has any users or other groups in it, and
ceases to exist if all users and groups in it are removed.

Each group has MaxResults, MaxScanRows, and MaxLockTime fields,
which limit the resources committed to operations performed by
members of the group. For these fields, 'unlimited' or 'unset'
means no limit for that group. An individual user's limit is the
highest of any group with a limit to which he belongs, unlimited if
any of his groups has 'unlimited' for that field, or unlimited
if he belongs to no group with a limit. See 'p4 help maxresults'
for more information on MaxResults, MaxScanRows and MaxLockTime.

Each group also has a Timeout field, which specifies how long (in
seconds) a 'p4 login' ticket remains valid. A value of 'unset' or
'unlimited' is equivalent to no timeout. An individual's timeout is
the highest of any group with a limit to which he belongs, unlimited
if any of his groups has 'unlimited' for the timeout value, or
unlimited if he belongs to no group with a limit. See 'p4 help login'
for more information.

Each group has a PasswordTimeout field, which determines how long a
password remains valid for members of the group.

A group may be synchronized with an LDAP group by setting the three
fields: LdapConfig, LdapSearchQuery and LdapUserAttribute. This takes
the LDAP configuration (see 'p4 ldap') specified by LdapConfig and uses
it to execute the query stored by LdapSearchQuery. The LDAP attribute
specified by LdapUserAttribute is taken to be user's username and is
added to the group's user list. At least one group owner must be set if
these LDAP fields are used. If the LDAP server requires login for
read-only queries, then the LDAP configuration must contain valid bind
credentials in the LDAP spec's SearchBindDN and SearchPasswd fields

The -d flag deletes a group.

The -o flag writes the group specification to standard output. The
user's editor is not invoked.

The -i flag reads a group specification from standard input. The
user's editor is not invoked. The new group specification replaces
the previous one.

The -a flag enables a user without 'super' access to modify the group
if that user is an 'owner' of that group. Group owners are specified
in the 'Owners' field of the group spec.

The -A flag enables a user with 'admin' access to add a new group.
Existing groups may not be modified when this flag is used.

All commands that require access granted by 'p4 protect' consider a
user's groups when calculating access levels.

'p4 group' requires 'super' access granted by 'p4 protect' unless
invoked with the '-a' or '-A' flag by a qualified user.

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Group

See Also

Group Members


Group Members

[image] [image]

Perforce .NET API
Group Members
Group Class Constructors Methods Properties See Also Send Feedback

The Group type exposes the following members.

Constructors

 | Name | Description
Public method | Group(String) | Create a group supplying the name.
Public method | Group(String, Int32, Int32, Int32, Int32, Int32, IList<(Of <<'(String>)>>), IList<(Of <<'(String>)>>), IList<(Of <<'(String>)>>), FormSpec) | Create a group providing all of the properties

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGroupCmdTaggedOutput | Read the fields from the tagged output of a group command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a group specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Id | The name of the group.
Public property | MaxLockTime | Limits the time (in milliseconds, unless 'unlimited' or 'unset') any one operation can lock any database table when scanning data.
Public property | MaxResults | Limits the rows (unless 'unlimited' or 'unset') any one operation can return to the client.
Public property | MaxScanRows | Limits the rows (unless 'unlimited' or 'unset') any one operation can scan from any one database table.
Public property | OwnerNames | Users allowed to change this group without requiring super access permission.
Public property | PasswordTimeout | A time (in seconds, unless 'unlimited' or 'unset') which determines how long a 'p4 password' password remains valid (default is unset).
Public property | Spec |
Public property | SubGroups | Other groups automatically included in this group.
Public property | TimeOut | A time (in seconds, unless 'unlimited' or 'unset') which determines how long a 'p4 login' session ticket remains valid (default is 12 hours).
Public property | UserNames | The users in the group.

See Also

Group Class


Group Constructor

[image] [image]

Perforce .NET API
Group Constructor
Group Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Group(String) | Create a group supplying the name.
Public method | Group(String, Int32, Int32, Int32, Int32, Int32, IList<(Of <<'(String>)>>), IList<(Of <<'(String>)>>), IList<(Of <<'(String>)>>), FormSpec) | Create a group providing all of the properties

See Also

Group Class
Group Members


Group Constructor (String)

[image]

Perforce .NET API
Group Constructor (String)
Group Class See Also Send Feedback
Create a group supplying the name.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)
Visual C++
public:
Group(
    String^ id
)

Parameters

id
Type: System..::..String

See Also

Group Class
Group Overload


Group Constructor (String, Int32, Int32, Int32, Int32, Int32, IList(String), IList(String), IList(String), FormSpec)

[image]

Perforce .NET API
Group Constructor (String, Int32, Int32, Int32, Int32, Int32, IList<(Of <(<'String>)>)>, IList<(Of <(<'String>)>)>, IList<(Of <(<'String>)>)>, FormSpec)
Group Class See Also Send Feedback
Create a group providing all of the properties

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group(
    string id,
    int maxResults,
    int maxScanRows,
    int maxLockTime,
    int timeOut,
    int passwordTimeout,
    IList<string> ownerNames,
    IList<string> userNames,
    IList<string> subGroups,
    FormSpec spec
)
Visual Basic
Public Sub New ( _
    id As String, _
    maxResults As Integer, _
    maxScanRows As Integer, _
    maxLockTime As Integer, _
    timeOut As Integer, _
    passwordTimeout As Integer, _
    ownerNames As IList(Of String), _
    userNames As IList(Of String), _
    subGroups As IList(Of String), _
    spec As FormSpec _
)
Visual C++
public:
Group(
    String^ id,
    int maxResults,
    int maxScanRows,
    int maxLockTime,
    int timeOut,
    int passwordTimeout,
    IList<String^>^ ownerNames,
    IList<String^>^ userNames,
    IList<String^>^ subGroups,
    FormSpec^ spec
)

Parameters

id
Type: System..::..String
maxResults
Type: System..::..Int32
maxScanRows
Type: System..::..Int32
maxLockTime
Type: System..::..Int32
timeOut
Type: System..::..Int32
passwordTimeout
Type: System..::..Int32
ownerNames
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
userNames
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
subGroups
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
spec
Type: Perforce.P4..::..FormSpec

See Also

Group Class
Group Overload


Group Methods

[image] [image]

Perforce .NET API
Group Methods
Group Class See Also Send Feedback

The Group type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGroupCmdTaggedOutput | Read the fields from the tagged output of a group command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a group specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

See Also

Group Class


FromGroupCmdTaggedOutput Method

[image]

Perforce .NET API
Group..::..FromGroupCmdTaggedOutput Method
Group Class See Also Send Feedback
Read the fields from the tagged output of a group command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromGroupCmdTaggedOutput(
    TaggedObject objectInfo
)
Visual Basic
Public Sub FromGroupCmdTaggedOutput ( _
    objectInfo As TaggedObject _
)
Visual C++
public:
void FromGroupCmdTaggedOutput(
    TaggedObject^ objectInfo
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'user' command

See Also

Group Class


Parse Method

[image]

Perforce .NET API
Group..::..Parse Method
Group Class See Also Send Feedback
Parse the fields from a group specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
Text of group user specification in server format

Return Value

Remarks

# A Perforce Group Specification. # # Group: The name of the group. # MaxResults: Limits the rows (unless 'unlimited' or 'unset') any one # operation can return to the client. # See 'p4 help maxresults'. # MaxScanRows: Limits the rows (unless 'unlimited' or 'unset') any one # operation can scan from any one database table. # See 'p4 help maxresults'. # MaxLockTime: Limits the time (in milliseconds, unless 'unlimited' or # 'unset') any one operation can lock any database table when # scanning data. See 'p4 help maxresults'. # Timeout: A time (in seconds, unless 'unlimited' or 'unset') # which determines how long a 'p4 login' # session ticket remains valid (default is 12 hours). # PasswordTimeout: # A time (in seconds, unless 'unlimited' or 'unset') # which determines how long a 'p4 password' # password remains valid (default is unset). # Subgroups: Other groups automatically included in this group. # Owners: Users allowed to change this group without requiring super # access permission. # Users: The users in the group. One per line.

See Also

Group Class


ToString Method

[image]

Perforce .NET API
Group..::..ToString Method
Group Class See Also Send Feedback
Convert to specification in server format

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The specification for the group

See Also

Group Class


Group Properties

[image] [image]

Perforce .NET API
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

 | Name | Description
Public property | Id | The name of the group.
Public property | MaxLockTime | Limits the time (in milliseconds, unless 'unlimited' or 'unset') any one operation can lock any database table when scanning data.
Public property | MaxResults | Limits the rows (unless 'unlimited' or 'unset') any one operation can return to the client.
Public property | MaxScanRows | Limits the rows (unless 'unlimited' or 'unset') any one operation can scan from any one database table.
Public property | OwnerNames | Users allowed to change this group without requiring super access permission.
Public property | PasswordTimeout | A time (in seconds, unless 'unlimited' or 'unset') which determines how long a 'p4 password' password remains valid (default is unset).
Public property | Spec |
Public property | SubGroups | Other groups automatically included in this group.
Public property | TimeOut | A time (in seconds, unless 'unlimited' or 'unset') which determines how long a 'p4 login' session ticket remains valid (default is 12 hours).
Public property | UserNames | The users in the group.

See Also

Group Class


Id Property

[image]

Perforce .NET API
Group..::..Id Property
Group Class See Also Send Feedback
The name of the group.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Id { get; internal set; }
Visual Basic
Public Property Id As String
    Get
    Friend Set
Visual C++
public:
property String^ Id {
    String^ get ();
    internal: void set (String^ value);
}

See Also

Group Class


MaxLockTime Property

[image]

Perforce .NET API
Group..::..MaxLockTime Property
Group Class See Also Send Feedback
Limits the time (in milliseconds, unless 'unlimited' or 'unset') any one operation can lock any database table when scanning data.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int MaxLockTime { get; set; }
Visual Basic
Public Property MaxLockTime As Integer
    Get
    Set
Visual C++
public:
property int MaxLockTime {
    int get ();
    void set (int value);
}

See Also

Group Class


MaxResults Property

[image]

Perforce .NET API
Group..::..MaxResults Property
Group Class See Also Send Feedback
Limits the rows (unless 'unlimited' or 'unset') any one operation can return to the client.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int MaxResults { get; set; }
Visual Basic
Public Property MaxResults As Integer
    Get
    Set
Visual C++
public:
property int MaxResults {
    int get ();
    void set (int value);
}

See Also

Group Class


MaxScanRows Property

[image]

Perforce .NET API
Group..::..MaxScanRows Property
Group Class See Also Send Feedback
Limits the rows (unless 'unlimited' or 'unset') any one operation can scan from any one database table.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int MaxScanRows { get; set; }
Visual Basic
Public Property MaxScanRows As Integer
    Get
    Set
Visual C++
public:
property int MaxScanRows {
    int get ();
    void set (int value);
}

See Also

Group Class


OwnerNames Property

[image]

Perforce .NET API
Group..::..OwnerNames Property
Group Class See Also Send Feedback
Users allowed to change this group without requiring super access permission.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> OwnerNames { get; set; }
Visual Basic
Public Property OwnerNames As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ OwnerNames {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

Group Class


PasswordTimeout Property

[image]

Perforce .NET API
Group..::..PasswordTimeout Property
Group Class See Also Send Feedback
A time (in seconds, unless 'unlimited' or 'unset') which determines how long a 'p4 password' password remains valid (default is unset).

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int PasswordTimeout { get; set; }
Visual Basic
Public Property PasswordTimeout As Integer
    Get
    Set
Visual C++
public:
property int PasswordTimeout {
    int get ();
    void set (int value);
}

See Also

Group Class


Spec Property

[image]

Perforce .NET API
Group..::..Spec Property
Group Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

Group Class


SubGroups Property

[image]

Perforce .NET API
Group..::..SubGroups Property
Group Class See Also Send Feedback
Other groups automatically included in this group.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> SubGroups { get; set; }
Visual Basic
Public Property SubGroups As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ SubGroups {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

Group Class


TimeOut Property

[image]

Perforce .NET API
Group..::..TimeOut Property
Group Class See Also Send Feedback
A time (in seconds, unless 'unlimited' or 'unset') which determines how long a 'p4 login' session ticket remains valid (default is 12 hours).

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int TimeOut { get; set; }
Visual Basic
Public Property TimeOut As Integer
    Get
    Set
Visual C++
public:
property int TimeOut {
    int get ();
    void set (int value);
}

See Also

Group Class


UserNames Property

[image]

Perforce .NET API
Group..::..UserNames Property
Group Class See Also Send Feedback
The users in the group.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> UserNames { get; set; }
Visual Basic
Public Property UserNames As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ UserNames {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

Group Class


GroupCmdFlags Enumeration

[image]

Perforce .NET API
GroupCmdFlags Enumeration
See Also Send Feedback
Flags for the group command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GroupCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GroupCmdFlags
Visual C++
[FlagsAttribute]
public enum class GroupCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes a pending changelist, if it has no opened files and no pending fixes associated with it. Use 'p4 opened -a' to report on opened files and 'p4 reopen' to move them to another changelist. Use 'p4 fixes -c changelist#' to report on pending fixes and 'p4 fix -d -c changelist# jobs...' to delete pending fixes. The changelist can be deleted only by the user and client who created it, or by a user with 'admin' privilege using the -f flag.
Output | 2 | The -o flag writes the changelist specification to the standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a changelist specification from the standard input. The user's editor is not invoked.
OwnerAccess | 8 | The -a flag enables a user without 'super' access to modify the group if that user is an 'owner' of that group. Group owners are specified in the 'Owners' field of the group spec.
AdminAdd | 16 | The -A flag enables a user with 'admin' access to add a new group. Existing groups may not be modified when this flag is used.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GroupCmdOptions Class

[image]

Perforce .NET API
GroupCmdOptions Class
Members See Also Send Feedback
Group command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GroupCmdOptions : Options
Visual Basic
Public Class GroupCmdOptions _
    Inherits Options
Visual C++
public ref class GroupCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GroupCmdOptions

See Also

GroupCmdOptions Members


GroupCmdOptions Members

[image] [image]

Perforce .NET API
GroupCmdOptions Members
GroupCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GroupCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GroupCmdOptions | Group command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GroupCmdOptions Class


GroupCmdOptions Constructor

[image]

Perforce .NET API
GroupCmdOptions Constructor
GroupCmdOptions Class See Also Send Feedback
Group command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GroupCmdOptions(
    GroupCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GroupCmdFlags _
)
Visual C++
public:
GroupCmdOptions(
    GroupCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GroupCmdFlags

Return Value

Remarks

p4 help group

group -- Change members of user group

p4 group [-a|-A] name
p4 group -d [-a] name
p4 group -o name
p4 group -i [-a|-A]

Create a group or modify the membership of an existing group.
A group can contain users and other groups. The group specification
is put into a temporary file and the editor (configured by the
environment variable $P4EDITOR) is invoked.

A group exists when it has any users or other groups in it, and
ceases to exist if all users and groups in it are removed.

Each group has MaxResults, MaxScanRows, and MaxLockTime fields,
which limit the resources committed to operations performed by
members of the group. For these fields, 'unlimited' or 'unset'
means no limit for that group. An individual user's limit is the
highest of any group with a limit to which he belongs, unlimited if
any of his groups has 'unlimited' for that field, or unlimited
if he belongs to no group with a limit. See 'p4 help maxresults'
for more information on MaxResults, MaxScanRows and MaxLockTime.

Each group also has a Timeout field, which specifies how long (in
seconds) a 'p4 login' ticket remains valid. A value of 'unset' or
'unlimited' is equivalent to no timeout. An individual's timeout is
the highest of any group with a limit to which he belongs, unlimited
if any of his groups has 'unlimited' for the timeout value, or
unlimited if he belongs to no group with a limit. See 'p4 help login'
for more information.

Each group has a PasswordTimeout field, which determines how long a
password remains valid for members of the group.

A group may be synchronized with an LDAP group by setting the three
fields: LdapConfig, LdapSearchQuery and LdapUserAttribute. This takes
the LDAP configuration (see 'p4 ldap') specified by LdapConfig and uses
it to execute the query stored by LdapSearchQuery. The LDAP attribute
specified by LdapUserAttribute is taken to be user's username and is
added to the group's user list. At least one group owner must be set if
these LDAP fields are used. If the LDAP server requires login for
read-only queries, then the LDAP configuration must contain valid bind
credentials in the LDAP spec's SearchBindDN and SearchPasswd fields

The -d flag deletes a group.

The -o flag writes the group specification to standard output. The
user's editor is not invoked.

The -i flag reads a group specification from standard input. The
user's editor is not invoked. The new group specification replaces
the previous one.

The -a flag enables a user without 'super' access to modify the group
if that user is an 'owner' of that group. Group owners are specified
in the 'Owners' field of the group spec.

The -A flag enables a user with 'admin' access to add a new group.
Existing groups may not be modified when this flag is used.

All commands that require access granted by 'p4 protect' consider a
user's groups when calculating access levels.

'p4 group' requires 'super' access granted by 'p4 protect' unless
invoked with the '-a' or '-A' flag by a qualified user.

See Also

GroupCmdOptions Class


GroupCmdOptions Methods

[image] [image]

Perforce .NET API
GroupCmdOptions Methods
GroupCmdOptions Class See Also Send Feedback

The GroupCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GroupCmdOptions Class


GroupCmdOptions Properties

[image] [image]

Perforce .NET API
GroupCmdOptions Properties
GroupCmdOptions Class See Also Send Feedback

The GroupCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GroupCmdOptions Class


GroupsCmdFlags Enumeration

[image]

Perforce .NET API
GroupsCmdFlags Enumeration
See Also Send Feedback
Flags for the groups command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum GroupsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration GroupsCmdFlags
Visual C++
[FlagsAttribute]
public enum class GroupsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeIndirect | 1 | The -i flag also displays groups that the user or group belongs to indirectly by means of membership in subgroups. (The group parameter for the command can be a user or group name)
IncludeAllValues | 2 | The -v flag displays the MaxResults, MaxScanRows, MaxLockTime, and Timeout values for the specified group.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


GroupsCmdOptions Class

[image]

Perforce .NET API
GroupsCmdOptions Class
Members See Also Send Feedback
Groups command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class GroupsCmdOptions : Options
Visual Basic
Public Class GroupsCmdOptions _
    Inherits Options
Visual C++
public ref class GroupsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..GroupsCmdOptions

See Also

GroupsCmdOptions Members


GroupsCmdOptions Members

[image] [image]

Perforce .NET API
GroupsCmdOptions Members
GroupsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The GroupsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GroupsCmdOptions | Initializes a new instance of the GroupsCmdOptions class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GroupsCmdOptions Class


GroupsCmdOptions Constructor

[image]

Perforce .NET API
GroupsCmdOptions Constructor
GroupsCmdOptions Class See Also Send Feedback
Initializes a new instance of the GroupsCmdOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public GroupsCmdOptions(
    GroupsCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As GroupsCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
GroupsCmdOptions(
    GroupsCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..GroupsCmdFlags
maxItems
Type: System..::..Int32

See Also

GroupsCmdOptions Class


GroupsCmdOptions Methods

[image] [image]

Perforce .NET API
GroupsCmdOptions Methods
GroupsCmdOptions Class See Also Send Feedback

The GroupsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GroupsCmdOptions Class


GroupsCmdOptions Properties

[image] [image]

Perforce .NET API
GroupsCmdOptions Properties
GroupsCmdOptions Class See Also Send Feedback

The GroupsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

GroupsCmdOptions Class


HaveRevision Class

[image]

Perforce .NET API
HaveRevision Class
Members See Also Send Feedback
A revision specifier #have.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class HaveRevision : VersionSpec
Visual Basic
Public Class HaveRevision _
    Inherits VersionSpec
Visual C++
public ref class HaveRevision : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..HaveRevision

See Also

HaveRevision Members


HaveRevision Members

[image] [image]

Perforce .NET API
HaveRevision Members
HaveRevision Class Constructors Methods See Also Send Feedback

The HaveRevision type exposes the following members.

Constructors

 | Name | Description
Public method | HaveRevision | Initializes a new instance of the HaveRevision class

Methods

 | Name | Description
Public method | Equals | Equals method for for HaveRevision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for HaveRevision (Overrides VersionSpec..::..ToString()()()().)

See Also

HaveRevision Class


HaveRevision Constructor

[image]

Perforce .NET API
HaveRevision Constructor
HaveRevision Class See Also Send Feedback
Initializes a new instance of the HaveRevision class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public HaveRevision()
Visual Basic
Public Sub New
Visual C++
public:
HaveRevision()

See Also

HaveRevision Class


HaveRevision Methods

[image] [image]

Perforce .NET API
HaveRevision Methods
HaveRevision Class See Also Send Feedback

The HaveRevision type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for HaveRevision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for HaveRevision (Overrides VersionSpec..::..ToString()()()().)

See Also

HaveRevision Class


Equals Method

[image]

Perforce .NET API
HaveRevision..::..Equals Method
HaveRevision Class See Also Send Feedback
Equals method for for HaveRevision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get have revision

Return Value

True/False

See Also

HaveRevision Class


ToString Method

[image]

Perforce .NET API
HaveRevision..::..ToString Method
HaveRevision Class See Also Send Feedback
ToString method for for HaveRevision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

#have

See Also

HaveRevision Class


HeadRevision Class

[image]

Perforce .NET API
HeadRevision Class
Members See Also Send Feedback
A revision specifier #head.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class HeadRevision : VersionSpec
Visual Basic
Public Class HeadRevision _
    Inherits VersionSpec
Visual C++
public ref class HeadRevision : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..HeadRevision

See Also

HeadRevision Members


HeadRevision Members

[image] [image]

Perforce .NET API
HeadRevision Members
HeadRevision Class Constructors Methods See Also Send Feedback

The HeadRevision type exposes the following members.

Constructors

 | Name | Description
Public method | HeadRevision | Initializes a new instance of the HeadRevision class

Methods

 | Name | Description
Public method | Equals | Equals method for for HeadRevision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for HeadRevision (Overrides VersionSpec..::..ToString()()()().)

See Also

HeadRevision Class


HeadRevision Constructor

[image]

Perforce .NET API
HeadRevision Constructor
HeadRevision Class See Also Send Feedback
Initializes a new instance of the HeadRevision class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public HeadRevision()
Visual Basic
Public Sub New
Visual C++
public:
HeadRevision()

See Also

HeadRevision Class


HeadRevision Methods

[image] [image]

Perforce .NET API
HeadRevision Methods
HeadRevision Class See Also Send Feedback

The HeadRevision type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for HeadRevision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for HeadRevision (Overrides VersionSpec..::..ToString()()()().)

See Also

HeadRevision Class


Equals Method

[image]

Perforce .NET API
HeadRevision..::..Equals Method
HeadRevision Class See Also Send Feedback
Equals method for for HeadRevision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get head revision

Return Value

True/False

See Also

HeadRevision Class


ToString Method

[image]

Perforce .NET API
HeadRevision..::..ToString Method
HeadRevision Class See Also Send Feedback
ToString method for for HeadRevision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

#head

See Also

HeadRevision Class


IKeepAlive Interface

[image]

Perforce .NET API
IKeepAlive Interface
Members See Also Send Feedback
Allows a client to monitor the execution of a command. It allow the client to cancel the command if it takes to long to complete or display a UI to allow the user to cancel the command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public interface IKeepAlive
Visual Basic
Public Interface IKeepAlive
Visual C++
public interface class IKeepAlive

See Also

IKeepAlive Members


IKeepAlive Members

[image] [image]

Perforce .NET API
IKeepAlive Members
IKeepAlive Interface Methods See Also Send Feedback

The IKeepAlive type exposes the following members.

Methods

 | Name | Description
Public method | CommandCompleted | The command has completed dismiss any UI or timeouts
Public method | StartQueryCancel | A command is starting

See Also

IKeepAlive Interface


IKeepAlive Methods

[image] [image]

Perforce .NET API
IKeepAlive Methods
IKeepAlive Interface See Also Send Feedback

The IKeepAlive type exposes the following members.

Methods

 | Name | Description
Public method | CommandCompleted | The command has completed dismiss any UI or timeouts
Public method | StartQueryCancel | A command is starting

See Also

IKeepAlive Interface


CommandCompleted Method

[image]

Perforce .NET API
IKeepAlive..::..CommandCompleted Method
IKeepAlive Interface See Also Send Feedback
The command has completed dismiss any UI or timeouts

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
void CommandCompleted(
    uint cmdId
)
Visual Basic
Sub CommandCompleted ( _
    cmdId As UInteger _
)
Visual C++
void CommandCompleted(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32
CmdId of the command that completed

Remarks

Note, it is OK for the API might send this multiple times with the, same cmdId to ensure that any UI displayed by the client iss dismissed.

See Also

IKeepAlive Interface


StartQueryCancel Method

[image]

Perforce .NET API
IKeepAlive..::..StartQueryCancel Method
IKeepAlive Interface See Also Send Feedback
A command is starting

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
bool StartQueryCancel(
    P4Server server,
    uint cmdId,
    Thread cmdRunThread,
    string cmdLine
)
Visual Basic
Function StartQueryCancel ( _
    server As P4Server, _
    cmdId As UInteger, _
    cmdRunThread As Thread, _
    cmdLine As String _
) As Boolean
Visual C++
bool StartQueryCancel(
    P4Server^ server,
    unsigned int cmdId,
    Thread^ cmdRunThread,
    String^ cmdLine
)

Parameters

server
Type: Perforce.P4..::..P4Server
Server running the command
cmdId
Type: System..::..UInt32
CmdId of the command
cmdRunThread
Type: System.Threading..::..Thread
cmdLine
Type: System..::..String
Command Line for the command for display purposes

Return Value

See Also

IKeepAlive Interface


InfoCmdFlags Enumeration

[image]

Perforce .NET API
InfoCmdFlags Enumeration
See Also Send Feedback
Flags for the info command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum InfoCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration InfoCmdFlags
Visual C++
[FlagsAttribute]
public enum class InfoCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Short | 1 | The -s option produces 'short' output that omits any information that requires a database lookup such as the client root).

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


InfoCmdOptions Class

[image]

Perforce .NET API
InfoCmdOptions Class
Members See Also Send Feedback
Options for the Trust command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class InfoCmdOptions : Options
Visual Basic
Public Class InfoCmdOptions _
    Inherits Options
Visual C++
public ref class InfoCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..InfoCmdOptions

See Also

InfoCmdOptions Members


InfoCmdOptions Members

[image] [image]

Perforce .NET API
InfoCmdOptions Members
InfoCmdOptions Class Constructors Methods Properties See Also Send Feedback

The InfoCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | InfoCmdOptions | Options for the Describe command

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

InfoCmdOptions Class


InfoCmdOptions Constructor

[image]

Perforce .NET API
InfoCmdOptions Constructor
InfoCmdOptions Class See Also Send Feedback
Options for the Describe command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public InfoCmdOptions(
    InfoCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As InfoCmdFlags _
)
Visual C++
public:
InfoCmdOptions(
    InfoCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..InfoCmdFlags

Remarks

p4 help info

info -- Display client/server information

p4 info [-s]

Info lists information about the current client (user name,
client name, applicable client root, client current directory,
and the client IP address) and some server information (server
IP address, server root, date, uptime, version and license data).

The -s option produces 'short' output that omits any information
that requires a database lookup such as the client root).

See Also

InfoCmdOptions Class


InfoCmdOptions Methods

[image] [image]

Perforce .NET API
InfoCmdOptions Methods
InfoCmdOptions Class See Also Send Feedback

The InfoCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

InfoCmdOptions Class


InfoCmdOptions Properties

[image] [image]

Perforce .NET API
InfoCmdOptions Properties
InfoCmdOptions Class See Also Send Feedback

The InfoCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

InfoCmdOptions Class


IntegrateFilesCmdFlags Enumeration

[image]

Perforce .NET API
IntegrateFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the integrate command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum IntegrateFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration IntegrateFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class IntegrateFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Force | 1 |
BranchIfTargetDeleted | 2 | -Dt If the target file has been deleted and the source file has changed, re-branch the source file on top of the target file.
DeleteIfSourceDeleted | 4 | -Ds If the source file has been deleted and the target file has changed, delete the target file.
IntegrateAllIfSourceDeleted | 8 | -Di If the source file has been deleted and re-added, attempt to integrate all outstanding revisions of the file, including revisions prior to the delete. By default, 'p4 integrate' only considers revisions since the last add.
LeaveHaveVersion | 16 | The -h flag leaves the target files at the revision currently synced to the client (the '#have' revision). By default, target files are automatically synced to the head revision by 'p4 integrate'.
IntegrateUnrelated | 32 |
DisplayBaseFile | 64 | The -o flag displays the base file name and revision that will be used in subsequent resolves if a resolve is needed.
PreviewIntegrationsOnly | 128 | The -n flag displays a preview of required integrations.
SwapSourceAndTarget | 256 | The -r flag reverses the mappings in the branch view, with the target files and source files exchanging place. The -b branch flag is required.
BidirectionalView | 512 |
PropogateType | 1024 |
DontCopyNewBranchFiles | 2048 | The -v flag speeds integration by not syncing newly-branched files to the client. The files can be synced after they are submitted.
BranchResolves | 4096 | -Rb Schedules 'branch resolves' instead of branching new target files automatically.
DeleteResolves | 8192 | -Rd Schedules 'delete resolves' instead of deleting target files automatically.
SkipRevisions | 16384 | -Rs Skips cherry-picked revisions already integrated. This can improve merge results, but can also cause multiple resolves per file to be scheduled.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


IntegrateFilesCmdOptions Class

[image]

Perforce .NET API
IntegrateFilesCmdOptions Class
Members See Also Send Feedback
Integrate command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class IntegrateFilesCmdOptions : Options
Visual Basic
Public Class IntegrateFilesCmdOptions _
    Inherits Options
Visual C++
public ref class IntegrateFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..IntegrateFilesCmdOptions

See Also

IntegrateFilesCmdOptions Members


IntegrateFilesCmdOptions Members

[image] [image]

Perforce .NET API
IntegrateFilesCmdOptions Members
IntegrateFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The IntegrateFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IntegrateFilesCmdOptions | Options for the integrate command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

IntegrateFilesCmdOptions Class


IntegrateFilesCmdOptions Constructor

[image]

Perforce .NET API
IntegrateFilesCmdOptions Constructor
IntegrateFilesCmdOptions Class See Also Send Feedback
Options for the integrate command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IntegrateFilesCmdOptions(
    IntegrateFilesCmdFlags flags,
    int changeList,
    int maxFiles,
    string branch,
    string stream,
    string parent
)
Visual Basic
Public Sub New ( _
    flags As IntegrateFilesCmdFlags, _
    changeList As Integer, _
    maxFiles As Integer, _
    branch As String, _
    stream As String, _
    parent As String _
)
Visual C++
public:
IntegrateFilesCmdOptions(
    IntegrateFilesCmdFlags flags,
    int changeList,
    int maxFiles,
    String^ branch,
    String^ stream,
    String^ parent
)

Parameters

flags
Type: Perforce.P4..::..IntegrateFilesCmdFlags
changeList
Type: System..::..Int32
maxFiles
Type: System..::..Int32
branch
Type: System..::..String
stream
Type: System..::..String
parent
Type: System..::..String

Return Value

Remarks

p4 help integrate

integrate -- Integrate one set of files into another

p4 integrate [options] fromFile[revRange] toFile
p4 integrate [options] -b branch [-r] [toFile[revRange] ...]
p4 integrate [options] -b branch -s fromFile[revRange] [toFile ...]
p4 integrate [options] -S stream [-r] [-P parent] [file[revRange] ...]

options: -c changelist# -Di -f -h -O<flags> -n -m max -R<flags> -q -v

'p4 integrate' integrates one set of files (the 'source') into
another (the 'target').

(See also 'p4 merge' and 'p4 copy', variants of 'p4 integrate' that
may be easier and more effective for the task at hand.)

Using the client workspace as a staging area, 'p4 integrate' adds and
deletes target files per changes in the source, and schedules all
other affected target files to be resolved. Target files outside of
the current client view are not affected. Source files need not be
within the client view.

'p4 resolve' must be used to merge file content, and to resolve
filename and filetype changes. 'p4 submit' commits integrated files
to the depot. Unresolved files may not be submitted. Integrations
can be shelved with 'p4 shelve' and abandoned with 'p4 revert'. The
commands 'p4 integrated' and 'p4 filelog' display integration history.

When 'p4 integrate' schedules a workspace file to be resolved, it
leaves it read-only. 'p4 resolve' can operate on a read-only file.
For other pre-submit changes, 'p4 edit' must be used to make the
file writable.

Source and target files can be specified either on the 'p4 integrate'
command line or through a branch view. On the command line, fromFile
is the source file set and toFile is the target file set. With a
branch view, one or more toFile arguments can be given to limit the
scope of the target file set.

revRange is a revision or a revision range that limits the span of
source history to be probed for unintegrated revisions. revRange
can be used on fromFile, or on toFile, but not on both. When used on
toFile, it refers to source revisions, not to target revisions. For
details about revision specifiers, see 'p4 help revisions'.

The -S flag makes 'p4 integrate' use a generated branch view that maps
a stream (or its underlying real stream) to its parent. With -r, the
direction of the mapping is reversed. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. Note that to submit integrated stream files, the current
client must be switched to the target stream, or to a virtual child
stream of the target stream.

The -b flag makes 'p4 integrate' use a user-defined branch view.
(See 'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the branch view to be treated as the
target, per the branch view mapping. Optional toFile arguments may
be given to further restrict the scope of the target file set. The
-r flag is ignored when -s is used.

Note that 'p4 integrate' automatically adusts source-to-target
mappings for moved and renamed files. (Adjustment occurs only if
the 'p4 move' command was used to move/rename files.) The scope of
source and target file sets must include both the old-named and the
new-named files for mappings to be adjusted. A filename resolve is
scheduled for each remapped file to allow the target to be moved to
match the source.

The -f flag forces integrate to ignore integration history and treat
all source revisions as unintegrated. It is meant to be used with
revRange to force reintegration of specific, previously integrated
revisions.

The -O flags cause more information to be output for each file opened:

-Ob Show the base revision for the merge (if any).
-Or Show the resolve(s) that are being scheduled.

The -R flags modify the way resolves are scheduled:

-Rb Schedules 'branch resolves' instead of branching new
target files automatically.

-Rd Schedules 'delete resolves' instead of deleting
target files automatically.

-Rs Skips cherry-picked revisions already integrated.
This can improve merge results, but can also cause
multiple resolves per file to be scheduled.

The -Di flag modifies the way deleted revisions are treated. If the
source file has been deleted and re-added, revisions that precede
the deletion will be considered to be part of the same source file.
By default, re-added files are considered to be unrelated to the
files of the same name that preceded them.

The -h flag leaves the target files at the revision currently synced
to the client (the '#have' revision). By default, target files are
automatically synced to the head revision by 'p4 integrate'.

The -m flag limits integration to the first 'max' number of files.

The -n flag displays a preview of integration, without actually
doing anything.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

If -c changelist# is specified, the files are opened in the
designated numbered pending changelist instead of the 'default'
changelist.

The -v flag causes a 'virtual' integration that does not modify
client workspace files unless target files need to be resolved.
After submitting a virtual integration, 'p4 sync' can be used to
update the workspace.

Integration is not supported for files with propagating attributes
from an edge server in a distributed environment. Depending on the
integration action, target, and source, either the integration or
resolve command will fail.

See Also

IntegrateFilesCmdOptions Class


IntegrateFilesCmdOptions Methods

[image] [image]

Perforce .NET API
IntegrateFilesCmdOptions Methods
IntegrateFilesCmdOptions Class See Also Send Feedback

The IntegrateFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

IntegrateFilesCmdOptions Class


IntegrateFilesCmdOptions Properties

[image] [image]

Perforce .NET API
IntegrateFilesCmdOptions Properties
IntegrateFilesCmdOptions Class See Also Send Feedback

The IntegrateFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

IntegrateFilesCmdOptions Class


Job Class

[image]

Perforce .NET API
Job Class
Members See Also Send Feedback
A Job in the Repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Job : FormBase
Visual Basic
Public Class Job _
    Inherits FormBase
Visual C++
public ref class Job : public FormBase

Remarks

A job specification has only one required field, "Job". If a Perforce installation uses a complex Job specification than the simple parsing and string formatting provided by the Form object cannot properly support the data, the Job object can subclassed to provide custom parsing and form generation
p4 help job

job -- Create or edit a job (defect) specification

p4 job [-f] [jobName]
p4 job -d jobName
p4 job -o [jobName]
p4 job -i [-f]

The 'p4 job' command creates and edits job specifications using an
ASCII form. A job is a defect, enhancement, or other unit of
intended work.The 'p4 fix' command associates changelists with jobs.

With no arguments, 'p4 job' creates an empty job specification
and invokes the user's editor. When the specification is saved,
a job name of the form jobNNNNNN is assigned. If the jobName
parameter is specified on the command line, the job is created or
opened for editing.

As jobs are entered or updated, all fields are indexed for searching
Text fields are broken into individual alphanumeric words (punctuation
and whitespace are ignored) and each word is case-folded and entered
into the word index. Date fields are converted to an internal
representation (seconds since 1970/01/01 00:00:00) and entered
into the date index.

The fields that compose a job are defined by the 'p4 jobspec' command.
Perforce provides a default job specification that you can edit.

The -d flag deletes the specified job. You cannot delete a job if
it has pending or submitted fixes associated with it.

The -o flag writes the job specification to the standard output.
The user's editor is not invoked.

The -i flag reads a job specification from the standard input. The
user's editor is not invoked.

The -f flag enables you set fields that are read-only by default.
The -f flag requires 'admin' access, which is granted using the
'p4 protect' command.

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
Perforce.P4..::..FormBase
Perforce.P4..::..Job

See Also

Job Members


Job Members

[image] [image]

Perforce .NET API
Job Members
Job Class Constructors Methods Properties See Also Send Feedback

The Job type exposes the following members.

Constructors

 | Name | Description
Public method | Job | Initializes a new instance of the Job class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromJobCmdTaggedOutput | Parse the tagged output of a 'job' command
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Parse | Parse a Job spec (Overrides FormBase..::..Parse(String).)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ToString | Convert to a Job specification (Overrides FormBase..::..ToString()()()().)
 | ToStrings(array<Job>[]()[][]) | Convert an array of Jobs to a list of JobIds to be passed as parameters to a command
 | ToStrings(IList<(Of <<'(Job>)>>)) | Convert the Job to a Spec Def
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

Properties

 | Name | Description
Public property | Comments | (Inherited from FormBase.)
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Id | The job name
Public property | IsFieldMultiLine | (Inherited from FormBase.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

See Also

Job Class


Job Constructor

[image]

Perforce .NET API
Job Constructor
Job Class See Also Send Feedback
Initializes a new instance of the Job class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Job()
Visual Basic
Public Sub New
Visual C++
public:
Job()

See Also

Job Class


Job Methods

[image] [image]

Perforce .NET API
Job Methods
Job Class See Also Send Feedback

The Job type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromJobCmdTaggedOutput | Parse the tagged output of a 'job' command
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | Parse | Parse a Job spec (Overrides FormBase..::..Parse(String).)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public method | ToString | Convert to a Job specification (Overrides FormBase..::..ToString()()()().)
 | ToStrings(array<Job>[]()[][]) | Convert an array of Jobs to a list of JobIds to be passed as parameters to a command
 | ToStrings(IList<(Of <<'(Job>)>>)) | Convert the Job to a Spec Def
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

See Also

Job Class


FromJobCmdTaggedOutput Method

[image]

Perforce .NET API
Job..::..FromJobCmdTaggedOutput Method
Job Class See Also Send Feedback
Parse the tagged output of a 'job' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public virtual void FromJobCmdTaggedOutput(
    TaggedObject obj
)
Visual Basic
Public Overridable Sub FromJobCmdTaggedOutput ( _
    obj As TaggedObject _
)
Visual C++
public:
virtual void FromJobCmdTaggedOutput(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

Job Class


Parse Method

[image]

Perforce .NET API
Job..::..Parse Method
Job Class See Also Send Feedback
Parse a Job spec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Parse(
    string spec
)
Visual Basic
Public Overrides Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
virtual bool Parse(
    String^ spec
) override

Parameters

spec
Type: System..::..String

See Also

Job Class


ToString Method

[image]

Perforce .NET API
Job..::..ToString Method
Job Class See Also Send Feedback
Convert to a Job specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

Job Class


ToStrings Method

[image] [image]

Perforce .NET API
Job..::..ToStrings Method
Job Class See Also Send Feedback

Overload List

Name | Description
ToStrings(array<Job>[]()[][]) | Convert an array of Jobs to a list of JobIds to be passed as parameters to a command
ToStrings(IList<(Of <<'(Job>)>>)) | Convert the Job to a Spec Def

See Also

Job Class
Job Members


ToStrings Method (Job[])

[image]

Perforce .NET API
Job..::..ToStrings Method (array<Job>[]()[][])
Job Class See Also Send Feedback
Convert an array of Jobs to a list of JobIds to be passed as parameters to a command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToStrings(
    Job[] list
)
Visual Basic
Public Shared Function ToStrings ( _
    list As Job() _
) As String()
Visual C++
public:
static array<String^>^ ToStrings(
    array<Job^>^ list
)

Parameters

list
Type: array< Perforce.P4..::..Job >[]()[][]

Return Value

See Also

Job Class
ToStrings Overload


ToStrings Method (IList(Job))

[image]

Perforce .NET API
Job..::..ToStrings Method (IList<(Of <(<'Job>)>)>)
Job Class See Also Send Feedback
Convert the Job to a Spec Def

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] ToStrings(
    IList<Job> list
)
Visual Basic
Public Shared Function ToStrings ( _
    list As IList(Of Job) _
) As String()
Visual C++
public:
static array<String^>^ ToStrings(
    IList<Job^>^ list
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<' Job >)>)>

Return Value

See Also

Job Class
ToStrings Overload


Job Properties

[image] [image]

Perforce .NET API
Job Properties
Job Class See Also Send Feedback

The Job type exposes the following members.

Properties

 | Name | Description
Public property | Comments | (Inherited from FormBase.)
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Id | The job name
Public property | IsFieldMultiLine | (Inherited from FormBase.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Object >)>)>.)

See Also

Job Class


Id Property

[image]

Perforce .NET API
Job..::..Id Property
Job Class See Also Send Feedback
The job name

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Job Class


JobCmdFlags Enumeration

[image]

Perforce .NET API
JobCmdFlags Enumeration
See Also Send Feedback
Flags for the job command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum JobCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration JobCmdFlags
Visual C++
[FlagsAttribute]
public enum class JobCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the specified job. You cannot delete a job if it has pending or submitted fixes associated with it.
Output | 2 | The -o flag writes the job specification to the standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a job specification from the standard input. The user's editor is not invoked.
Force | 8 | The -f flag enables you set fields that are read-only by default. The -f flag requires 'admin' access, which is granted using the 'p4 protect' command.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


JobCmdOptions Class

[image]

Perforce .NET API
JobCmdOptions Class
Members See Also Send Feedback
Job command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class JobCmdOptions : Options
Visual Basic
Public Class JobCmdOptions _
    Inherits Options
Visual C++
public ref class JobCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..JobCmdOptions

See Also

JobCmdOptions Members


JobCmdOptions Members

[image] [image]

Perforce .NET API
JobCmdOptions Members
JobCmdOptions Class Methods Properties See Also Send Feedback

The JobCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

JobCmdOptions Class


JobCmdOptions Methods

[image] [image]

Perforce .NET API
JobCmdOptions Methods
JobCmdOptions Class See Also Send Feedback

The JobCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

JobCmdOptions Class


JobCmdOptions Properties

[image] [image]

Perforce .NET API
JobCmdOptions Properties
JobCmdOptions Class See Also Send Feedback

The JobCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

JobCmdOptions Class


JobsCmdFlags Enumeration

[image]

Perforce .NET API
JobsCmdFlags Enumeration
See Also Send Feedback
Flags for the jobs command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum JobsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration JobsCmdFlags
Visual C++
[FlagsAttribute]
public enum class JobsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeIntegratedFixes | 1 | The -i flag includes any fixes made by changelists integrated into the specified files.
LongDescriptions | 2 | The -l flag produces long output with the full text of the job descriptions.
ReverseSort | 4 | The -r flag sorts the jobs in reverse order (by job name).
RebuildJobsTable | 8 | The -R flag rebuilds the jobs table and reindexes each job, which is necessary after upgrading to 98.2. 'p4 jobs -R' requires that that the user be an operator or have 'super' access granted by 'p4 protect'.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


JobsCmdOptions Class

[image]

Perforce .NET API
JobsCmdOptions Class
Members See Also Send Feedback
Jobs command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class JobsCmdOptions : Options
Visual Basic
Public Class JobsCmdOptions _
    Inherits Options
Visual C++
public ref class JobsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..JobsCmdOptions

See Also

JobsCmdOptions Members


JobsCmdOptions Members

[image] [image]

Perforce .NET API
JobsCmdOptions Members
JobsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The JobsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | JobsCmdOptions | Jobs command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

JobsCmdOptions Class


JobsCmdOptions Constructor

[image]

Perforce .NET API
JobsCmdOptions Constructor
JobsCmdOptions Class See Also Send Feedback
Jobs command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public JobsCmdOptions(
    JobsCmdFlags flags,
    string jobView,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As JobsCmdFlags, _
    jobView As String, _
    maxItems As Integer _
)
Visual C++
public:
JobsCmdOptions(
    JobsCmdFlags flags,
    String^ jobView,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..JobsCmdFlags
jobView
Type: System..::..String
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help jobs

jobs -- Display list of jobs

p4 jobs [-e jobview -i -l -m max -r] [file[revRange] ...]
p4 jobs -R

Lists jobs in the server. If a file specification is included, fixes
for submitted changelists affecting the specified files are listed.
The file specification can include wildcards and a revision range.
See 'p4 help revisions' for details about specifying revisions.

The -e flag lists jobs matching the expression specified in the
jobview parameter. For a description of jobview syntax, see 'p4 help
jobview'.

The -i flag includes any fixes made by changelists integrated into
the specified files.

The -l flag produces long output with the full text of the job
descriptions.

The -m max flag limits the output to the first 'max' jobs, ordered
by their job name.

The -r flag sorts the jobs in reverse order (by job name).

The -R flag rebuilds the jobs table and reindexes each job, which
is necessary after upgrading to 98.2. 'p4 jobs -R' requires that the
user be an operator or have 'super' access granted by 'p4 protect'.

See Also

JobsCmdOptions Class


JobsCmdOptions Methods

[image] [image]

Perforce .NET API
JobsCmdOptions Methods
JobsCmdOptions Class See Also Send Feedback

The JobsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

JobsCmdOptions Class


JobsCmdOptions Properties

[image] [image]

Perforce .NET API
JobsCmdOptions Properties
JobsCmdOptions Class See Also Send Feedback

The JobsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

JobsCmdOptions Class


Label Class

[image]

Perforce .NET API
Label Class
Members See Also Send Feedback
A label specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Label
Visual Basic
Public Class Label
Visual C++
public ref class Label

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Label

See Also

Label Members


Label Members

[image] [image]

Perforce .NET API
Label Members
Label Class Constructors Methods Properties See Also Send Feedback

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label()()()() | Initializes a new instance of the Label class
Public method | Label(String, String, DateTime, DateTime, String, Boolean, String, String, ViewMap, FormSpec, String) | Initializes a new instance of the Label class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromLabelCmdTaggedOutput | Read the fields from the tagged output of a label command
Public method | FromLabelsCmdTaggedOutput | Read the fields from the tagged output of a labels command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a label specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Access |
Public property | Autoreload |
Public property | Description |
Public property | Id |
Public property | IncludeAutoreloadOption |
Public property | Locked |
Public property | Options | Obsolete.
Public property | Owner |
Public property | Revision |
Public property | ServerId |
Public property | Spec |
Public property | Update |
Public property | ViewMap |

See Also

Label Class


Label Constructor

[image] [image]

Perforce .NET API
Label Constructor
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Label()()()() | Initializes a new instance of the Label class
Public method | Label(String, String, DateTime, DateTime, String, Boolean, String, String, ViewMap, FormSpec, String) | Initializes a new instance of the Label class

See Also

Label Class
Label Members


Label Constructor

[image]

Perforce .NET API
Label Constructor
Label Class See Also Send Feedback
Initializes a new instance of the Label class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Label()
Visual Basic
Public Sub New
Visual C++
public:
Label()

See Also

Label Class
Label Overload


Label Constructor (String, String, DateTime, DateTime, String, Boolean, String, String, ViewMap, FormSpec, String)

[image]

Perforce .NET API
Label Constructor (String, String, DateTime, DateTime, String, Boolean, String, String, ViewMap, FormSpec, String)
Label Class See Also Send Feedback
Initializes a new instance of the Label class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Label(
    string id,
    string owner,
    DateTime update,
    DateTime access,
    string description,
    bool locked,
    string revision,
    string serverid,
    ViewMap viewmap,
    FormSpec spec,
    string options
)
Visual Basic
Public Sub New ( _
    id As String, _
    owner As String, _
    update As DateTime, _
    access As DateTime, _
    description As String, _
    locked As Boolean, _
    revision As String, _
    serverid As String, _
    viewmap As ViewMap, _
    spec As FormSpec, _
    options As String _
)
Visual C++
public:
Label(
    String^ id,
    String^ owner,
    DateTime update,
    DateTime access,
    String^ description,
    bool locked,
    String^ revision,
    String^ serverid,
    ViewMap^ viewmap,
    FormSpec^ spec,
    String^ options
)

Parameters

id
Type: System..::..String
owner
Type: System..::..String
update
Type: System..::..DateTime
access
Type: System..::..DateTime
description
Type: System..::..String
locked
Type: System..::..Boolean
revision
Type: System..::..String
serverid
Type: System..::..String
viewmap
Type: Perforce.P4..::..ViewMap
spec
Type: Perforce.P4..::..FormSpec
options
Type: System..::..String

See Also

Label Class
Label Overload


Label Methods

[image] [image]

Perforce .NET API
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromLabelCmdTaggedOutput | Read the fields from the tagged output of a label command
Public method | FromLabelsCmdTaggedOutput | Read the fields from the tagged output of a labels command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a label specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

See Also

Label Class


FromLabelCmdTaggedOutput Method

[image]

Perforce .NET API
Label..::..FromLabelCmdTaggedOutput Method
Label Class See Also Send Feedback
Read the fields from the tagged output of a label command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromLabelCmdTaggedOutput(
    TaggedObject objectInfo
)
Visual Basic
Public Sub FromLabelCmdTaggedOutput ( _
    objectInfo As TaggedObject _
)
Visual C++
public:
void FromLabelCmdTaggedOutput(
    TaggedObject^ objectInfo
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'label' command

See Also

Label Class


FromLabelsCmdTaggedOutput Method

[image]

Perforce .NET API
Label..::..FromLabelsCmdTaggedOutput Method
Label Class See Also Send Feedback
Read the fields from the tagged output of a labels command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromLabelsCmdTaggedOutput(
    TaggedObject objectInfo,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromLabelsCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromLabelsCmdTaggedOutput(
    TaggedObject^ objectInfo,
    String^ offset,
    bool dst_mismatch
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'labels' command
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Label Class


Parse Method

[image]

Perforce .NET API
Label..::..Parse Method
Label Class See Also Send Feedback
Parse the fields from a label specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
Text of the label specification in server format

Return Value

See Also

Label Class


ToString Method

[image]

Perforce .NET API
Label..::..ToString Method
Label Class See Also Send Feedback
Convert to specification in server format

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

Label Class


Label Properties

[image] [image]

Perforce .NET API
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

 | Name | Description
Public property | Access |
Public property | Autoreload |
Public property | Description |
Public property | Id |
Public property | IncludeAutoreloadOption |
Public property | Locked |
Public property | Options | Obsolete.
Public property | Owner |
Public property | Revision |
Public property | ServerId |
Public property | Spec |
Public property | Update |
Public property | ViewMap |

See Also

Label Class


Access Property

[image]

Perforce .NET API
Label..::..Access Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Access { get; set; }
Visual Basic
Public Property Access As DateTime
    Get
    Set
Visual C++
public:
property DateTime Access {
    DateTime get ();
    void set (DateTime value);
}

See Also

Label Class


Autoreload Property

[image]

Perforce .NET API
Label..::..Autoreload Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Autoreload { get; set; }
Visual Basic
Public Property Autoreload As Boolean
    Get
    Set
Visual C++
public:
property bool Autoreload {
    bool get ();
    void set (bool value);
}

See Also

Label Class


Description Property

[image]

Perforce .NET API
Label..::..Description Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Label Class


Id Property

[image]

Perforce .NET API
Label..::..Id Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Label Class


IncludeAutoreloadOption Property

[image]

Perforce .NET API
Label..::..IncludeAutoreloadOption Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IncludeAutoreloadOption { get; set; }
Visual Basic
Public Property IncludeAutoreloadOption As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeAutoreloadOption {
    bool get ();
    void set (bool value);
}

See Also

Label Class


Locked Property

[image]

Perforce .NET API
Label..::..Locked Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Locked { get; set; }
Visual Basic
Public Property Locked As Boolean
    Get
    Set
Visual C++
public:
property bool Locked {
    bool get ();
    void set (bool value);
}

See Also

Label Class


Options Property

[image]

Perforce .NET API
Label..::..Options Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[ObsoleteAttribute("Use Locked Property")]
public string Options { get; set; }
Visual Basic
<ObsoleteAttribute("Use Locked Property")> _
Public Property Options As String
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use Locked Property")]
public:
property String^ Options {
    String^ get ();
    void set (String^ value);
}

See Also

Label Class


Owner Property

[image]

Perforce .NET API
Label..::..Owner Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Owner { get; set; }
Visual Basic
Public Property Owner As String
    Get
    Set
Visual C++
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}

See Also

Label Class


Revision Property

[image]

Perforce .NET API
Label..::..Revision Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Revision { get; set; }
Visual Basic
Public Property Revision As String
    Get
    Set
Visual C++
public:
property String^ Revision {
    String^ get ();
    void set (String^ value);
}

See Also

Label Class


ServerId Property

[image]

Perforce .NET API
Label..::..ServerId Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ServerId { get; set; }
Visual Basic
Public Property ServerId As String
    Get
    Set
Visual C++
public:
property String^ ServerId {
    String^ get ();
    void set (String^ value);
}

See Also

Label Class


Spec Property

[image]

Perforce .NET API
Label..::..Spec Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

Label Class


Update Property

[image]

Perforce .NET API
Label..::..Update Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Update { get; set; }
Visual Basic
Public Property Update As DateTime
    Get
    Set
Visual C++
public:
property DateTime Update {
    DateTime get ();
    void set (DateTime value);
}

See Also

Label Class


ViewMap Property

[image]

Perforce .NET API
Label..::..ViewMap Property
Label Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap ViewMap { get; set; }
Visual Basic
Public Property ViewMap As ViewMap
    Get
    Set
Visual C++
public:
property ViewMap^ ViewMap {
    ViewMap^ get ();
    void set (ViewMap^ value);
}

See Also

Label Class


LabelCmdFlags Enumeration

[image]

Perforce .NET API
LabelCmdFlags Enumeration
See Also Send Feedback
Flags for the label command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum LabelCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration LabelCmdFlags
Visual C++
[FlagsAttribute]
public enum class LabelCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the named label spec.
Output | 2 | The -o flag writes the label spec to standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a label specification from the standard input. The user's editor is not invoked.
Force | 8 | The -f flag forces the deletion of a label. By default, locked labels can only be deleted by their owner. The -f flag also permits the Last Modified date to be set. The -f flag requires 'admin' access, which is granted by 'p4 protect'.
Global | 16 | The -g flag should be used on an Edge Server to update a global label. Without -g, the label definition is visible only to users of this Edge Server. Configuring rpl.labels.global=1 reverses this default and causes this flag to have the opposite meaning.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


LabelCmdOptions Class

[image]

Perforce .NET API
LabelCmdOptions Class
Members See Also Send Feedback
Label command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LabelCmdOptions : Options
Visual Basic
Public Class LabelCmdOptions _
    Inherits Options
Visual C++
public ref class LabelCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..LabelCmdOptions

See Also

LabelCmdOptions Members


LabelCmdOptions Members

[image] [image]

Perforce .NET API
LabelCmdOptions Members
LabelCmdOptions Class Constructors Methods Properties See Also Send Feedback

The LabelCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LabelCmdOptions | Label command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelCmdOptions Class


LabelCmdOptions Constructor

[image]

Perforce .NET API
LabelCmdOptions Constructor
LabelCmdOptions Class See Also Send Feedback
Label command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LabelCmdOptions(
    LabelCmdFlags flags,
    string template
)
Visual Basic
Public Sub New ( _
    flags As LabelCmdFlags, _
    template As String _
)
Visual C++
public:
LabelCmdOptions(
    LabelCmdFlags flags,
    String^ template
)

Parameters

flags
Type: Perforce.P4..::..LabelCmdFlags
template
Type: System..::..String

See Also

LabelCmdOptions Class


LabelCmdOptions Methods

[image] [image]

Perforce .NET API
LabelCmdOptions Methods
LabelCmdOptions Class See Also Send Feedback

The LabelCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelCmdOptions Class


LabelCmdOptions Properties

[image] [image]

Perforce .NET API
LabelCmdOptions Properties
LabelCmdOptions Class See Also Send Feedback

The LabelCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelCmdOptions Class


LabelNameVersion Class

[image]

Perforce .NET API
LabelNameVersion Class
Members See Also Send Feedback
A revision specifier that is a label name.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LabelNameVersion : VersionSpec
Visual Basic
Public Class LabelNameVersion _
    Inherits VersionSpec
Visual C++
public ref class LabelNameVersion : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..LabelNameVersion

See Also

LabelNameVersion Members


LabelNameVersion Members

[image] [image]

Perforce .NET API
LabelNameVersion Members
LabelNameVersion Class Constructors Methods Properties See Also Send Feedback

The LabelNameVersion type exposes the following members.

Constructors

 | Name | Description
Public method | LabelNameVersion | Initializes a new instance of the LabelNameVersion class

Methods

 | Name | Description
Public method | Equals | Equals method for for LabelNameVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for LabelNameVersion (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | Version | get Version as label

See Also

LabelNameVersion Class


LabelNameVersion Constructor

[image]

Perforce .NET API
LabelNameVersion Constructor
LabelNameVersion Class See Also Send Feedback
Initializes a new instance of the LabelNameVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LabelNameVersion(
    string LabelName
)
Visual Basic
Public Sub New ( _
    LabelName As String _
)
Visual C++
public:
LabelNameVersion(
    String^ LabelName
)

Parameters

LabelName
Type: System..::..String
The label.

See Also

LabelNameVersion Class


LabelNameVersion Methods

[image] [image]

Perforce .NET API
LabelNameVersion Methods
LabelNameVersion Class See Also Send Feedback

The LabelNameVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for LabelNameVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for LabelNameVersion (Overrides VersionSpec..::..ToString()()()().)

See Also

LabelNameVersion Class


Equals Method

[image]

Perforce .NET API
LabelNameVersion..::..Equals Method
LabelNameVersion Class See Also Send Feedback
Equals method for for LabelNameVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get label

Return Value

True/False

See Also

LabelNameVersion Class


ToString Method

[image]

Perforce .NET API
LabelNameVersion..::..ToString Method
LabelNameVersion Class See Also Send Feedback
ToString method for for LabelNameVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String label version

See Also

LabelNameVersion Class


LabelNameVersion Properties

[image] [image]

Perforce .NET API
LabelNameVersion Properties
LabelNameVersion Class See Also Send Feedback

The LabelNameVersion type exposes the following members.

Properties

 | Name | Description
Public property | Version | get Version as label

See Also

LabelNameVersion Class


Version Property

[image]

Perforce .NET API
LabelNameVersion..::..Version Property
LabelNameVersion Class See Also Send Feedback
get Version as label

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Version { get; private set; }
Visual Basic
Public Property Version As String
    Get
    Private Set
Visual C++
public:
property String^ Version {
    String^ get ();
    private: void set (String^ value);
}

See Also

LabelNameVersion Class


LabelsCmdFlags Enumeration

[image]

Perforce .NET API
LabelsCmdFlags Enumeration
See Also Send Feedback
Flags for the labels command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum LabelsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration LabelsCmdFlags
Visual C++
[FlagsAttribute]
public enum class LabelsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Time | 1 | The -t flag displays the time as well as the date.
IgnoreCase | 2 | The -e nameFilter flag lists labels with a name that matches the nameFilter pattern, for example: -e 'label*'. -E makes the matching case-insensitive.
Unloaded | 4 | The -U flag lists unloaded labels (see 'p4 help unload').
All | 8 | The -a flag specifies that all labels should be displayed, not just those that are bound to this server.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


LabelsCmdOptions Class

[image]

Perforce .NET API
LabelsCmdOptions Class
Members See Also Send Feedback
Labels command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LabelsCmdOptions : Options
Visual Basic
Public Class LabelsCmdOptions _
    Inherits Options
Visual C++
public ref class LabelsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..LabelsCmdOptions

See Also

LabelsCmdOptions Members


LabelsCmdOptions Members

[image] [image]

Perforce .NET API
LabelsCmdOptions Members
LabelsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The LabelsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LabelsCmdOptions(LabelsCmdFlags, String, String, Int32, String) | Labels command options
Public method | LabelsCmdOptions(LabelsCmdFlags, String, String, Int32, String, String) | Labels command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelsCmdOptions Class


LabelsCmdOptions Constructor

[image] [image]

Perforce .NET API
LabelsCmdOptions Constructor
LabelsCmdOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LabelsCmdOptions(LabelsCmdFlags, String, String, Int32, String) | Labels command options
Public method | LabelsCmdOptions(LabelsCmdFlags, String, String, Int32, String, String) | Labels command options

See Also

LabelsCmdOptions Class
LabelsCmdOptions Members


LabelsCmdOptions Constructor (LabelsCmdFlags, String, String, Int32, String)

[image]

Perforce .NET API
LabelsCmdOptions Constructor (LabelsCmdFlags, String, String, Int32, String)
LabelsCmdOptions Class See Also Send Feedback
Labels command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LabelsCmdOptions(
    LabelsCmdFlags flags,
    string user,
    string nameFilter,
    int maxItems,
    string fileRevRange
)
Visual Basic
Public Sub New ( _
    flags As LabelsCmdFlags, _
    user As String, _
    nameFilter As String, _
    maxItems As Integer, _
    fileRevRange As String _
)
Visual C++
public:
LabelsCmdOptions(
    LabelsCmdFlags flags,
    String^ user,
    String^ nameFilter,
    int maxItems,
    String^ fileRevRange
)

Parameters

flags
Type: Perforce.P4..::..LabelsCmdFlags
user
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32
fileRevRange
Type: System..::..String

See Also

LabelsCmdOptions Class
LabelsCmdOptions Overload


LabelsCmdOptions Constructor (LabelsCmdFlags, String, String, Int32, String, String)

[image]

Perforce .NET API
LabelsCmdOptions Constructor (LabelsCmdFlags, String, String, Int32, String, String)
LabelsCmdOptions Class See Also Send Feedback
Labels command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LabelsCmdOptions(
    LabelsCmdFlags flags,
    string user,
    string nameFilter,
    int maxItems,
    string fileRevRange,
    string serverId
)
Visual Basic
Public Sub New ( _
    flags As LabelsCmdFlags, _
    user As String, _
    nameFilter As String, _
    maxItems As Integer, _
    fileRevRange As String, _
    serverId As String _
)
Visual C++
public:
LabelsCmdOptions(
    LabelsCmdFlags flags,
    String^ user,
    String^ nameFilter,
    int maxItems,
    String^ fileRevRange,
    String^ serverId
)

Parameters

flags
Type: Perforce.P4..::..LabelsCmdFlags
user
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32
fileRevRange
Type: System..::..String
serverId
Type: System..::..String

See Also

LabelsCmdOptions Class
LabelsCmdOptions Overload


LabelsCmdOptions Methods

[image] [image]

Perforce .NET API
LabelsCmdOptions Methods
LabelsCmdOptions Class See Also Send Feedback

The LabelsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelsCmdOptions Class


LabelsCmdOptions Properties

[image] [image]

Perforce .NET API
LabelsCmdOptions Properties
LabelsCmdOptions Class See Also Send Feedback

The LabelsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelsCmdOptions Class


LabelSyncCmdFlags Enumeration

[image]

Perforce .NET API
LabelSyncCmdFlags Enumeration
See Also Send Feedback
Flags for the label sync command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum LabelSyncCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration LabelSyncCmdFlags
Visual C++
[FlagsAttribute]
public enum class LabelSyncCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AddFile | 1 | The -a flag adds the specified file to the label.
DeleteFile | 2 | The -d deletes the specified file from the label, regardless of revision.
Preview | 4 | The -n flag previews the operation without altering the label.
Quiet | 8 | The -q flag suppresses normal output messages. Messages regarding errors or exceptional conditions are displayed.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


LabelSyncCmdOptions Class

[image]

Perforce .NET API
LabelSyncCmdOptions Class
Members See Also Send Feedback
Labelsync command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LabelSyncCmdOptions : Options
Visual Basic
Public Class LabelSyncCmdOptions _
    Inherits Options
Visual C++
public ref class LabelSyncCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..LabelSyncCmdOptions

See Also

LabelSyncCmdOptions Members


LabelSyncCmdOptions Members

[image] [image]

Perforce .NET API
LabelSyncCmdOptions Members
LabelSyncCmdOptions Class Constructors Methods Properties See Also Send Feedback

The LabelSyncCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LabelSyncCmdOptions | Options for the labelsync command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelSyncCmdOptions Class


LabelSyncCmdOptions Constructor

[image]

Perforce .NET API
LabelSyncCmdOptions Constructor
LabelSyncCmdOptions Class See Also Send Feedback
Options for the labelsync command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LabelSyncCmdOptions(
    LabelSyncCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As LabelSyncCmdFlags _
)
Visual C++
public:
LabelSyncCmdOptions(
    LabelSyncCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..LabelSyncCmdFlags

Return Value

Remarks

p4 help labelsync

labelsync -- Apply the label to the contents of the client workspace

p4 labelsync [-a -d -g -n -q] -l label [file[revRange] ...]

Labelsync causes the specified label to reflect the current contents
of the client. It records the revision of each file currently synced.
The label's name can subsequently be used in a revision specification
as @label to refer to the revision of a file as stored in the label.

Without a file argument, labelsync causes the label to reflect the
contents of the whole client, by adding, deleting, and updating the
label. If a file is specified, labelsync updates the specified file.

If the file argument includes a revision specification, that revision
is used instead of the revision synced by the client. If the specified
revision is a deleted revision, the label includes that deleted
revision. See 'p4 help revisions' for details about specifying
revisions.

If the file argument includes a revision range specification,
only files selected by the revision range are updated, and the
highest revision in the range is used.

The -a flag adds the specified file to the label.

The -d deletes the specified file from the label, regardless of
revision.

The -n flag previews the operation without altering the label.

Only the owner of a label can run labelsync on that label. A label
that has its Options: field set to 'locked' cannot be updated. A
label without an owner can be labelsync'd by any user.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

The -g flag should be used on an Edge Server to update a global
label. Note that in this case, the client should be a global client.
Configuring rpl.labels.global=1 reverses this default and causes this
flag to have the opposite meaning.

See Also

LabelSyncCmdOptions Class


LabelSyncCmdOptions Methods

[image] [image]

Perforce .NET API
LabelSyncCmdOptions Methods
LabelSyncCmdOptions Class See Also Send Feedback

The LabelSyncCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelSyncCmdOptions Class


LabelSyncCmdOptions Properties

[image] [image]

Perforce .NET API
LabelSyncCmdOptions Properties
LabelSyncCmdOptions Class See Also Send Feedback

The LabelSyncCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LabelSyncCmdOptions Class


LineEnd Enumeration

[image]

Perforce .NET API
LineEnd Enumeration
See Also Send Feedback
Sets line-ending character(s) for client text files.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum LineEnd
Visual Basic
<FlagsAttribute> _
Public Enumeration LineEnd
Visual C++
[FlagsAttribute]
public enum class LineEnd

Members

Member name | Value | Description
Local | 0 | mode that is native to the client (default).
Unix | 1 | linefeed: UNIX style.
Mac | 2 | carriage return: Macintosh style.
Win | 3 | carriage return-linefeed: Windows style.
Share | 4 | hybrid: writes UNIX style but reads UNIX, Mac or Windows style.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


LocalPath Class

[image]

Perforce .NET API
LocalPath Class
Members See Also Send Feedback
A path spec in local syntax.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LocalPath : PathSpec
Visual Basic
Public Class LocalPath _
    Inherits PathSpec
Visual C++
public ref class LocalPath : public PathSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..PathSpec
Perforce.P4..::..LocalPath

See Also

LocalPath Members


LocalPath Members

[image] [image]

Perforce .NET API
LocalPath Members
LocalPath Class Constructors Methods Properties See Also Send Feedback

The LocalPath type exposes the following members.

Constructors

 | Name | Description
Public method | LocalPath | Initializes a new instance of the LocalPath class

Methods

 | Name | Description
Public method | Equals | (Overrides PathSpec..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName | (Inherited from PathSpec.)
Public method | GetFileName | (Inherited from PathSpec.)
Public method | GetHashCode | (Inherited from PathSpec.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot | (Inherited from PathSpec.)
Protected method | NormalizeLocal | (Inherited from PathSpec.)
Public method | ToString | (Inherited from PathSpec.)

Properties

 | Name | Description
Public property | Path | (Inherited from PathSpec.)

See Also

LocalPath Class


LocalPath Constructor

[image]

Perforce .NET API
LocalPath Constructor
LocalPath Class See Also Send Feedback
Initializes a new instance of the LocalPath class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LocalPath(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
LocalPath(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

LocalPath Class


LocalPath Methods

[image] [image]

Perforce .NET API
LocalPath Methods
LocalPath Class See Also Send Feedback

The LocalPath type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides PathSpec..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName | (Inherited from PathSpec.)
Public method | GetFileName | (Inherited from PathSpec.)
Public method | GetHashCode | (Inherited from PathSpec.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot | (Inherited from PathSpec.)
Protected method | NormalizeLocal | (Inherited from PathSpec.)
Public method | ToString | (Inherited from PathSpec.)

See Also

LocalPath Class


Equals Method

[image]

Perforce .NET API
LocalPath..::..Equals Method
LocalPath Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

LocalPath Class


LocalPath Properties

[image] [image]

Perforce .NET API
LocalPath Properties
LocalPath Class See Also Send Feedback

The LocalPath type exposes the following members.

Properties

 | Name | Description
Public property | Path | (Inherited from PathSpec.)

See Also

LocalPath Class


LockCmdOptions Class

[image]

Perforce .NET API
LockCmdOptions Class
Members See Also Send Feedback
Lock command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LockCmdOptions : Options
Visual Basic
Public Class LockCmdOptions _
    Inherits Options
Visual C++
public ref class LockCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..LockCmdOptions

See Also

LockCmdOptions Members


LockCmdOptions Members

[image] [image]

Perforce .NET API
LockCmdOptions Members
LockCmdOptions Class Constructors Methods Properties See Also Send Feedback

The LockCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LockCmdOptions | Options for the lock command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LockCmdOptions Class


LockCmdOptions Constructor

[image]

Perforce .NET API
LockCmdOptions Constructor
LockCmdOptions Class See Also Send Feedback
Options for the lock command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LockCmdOptions(
    int changeList
)
Visual Basic
Public Sub New ( _
    changeList As Integer _
)
Visual C++
public:
LockCmdOptions(
    int changeList
)

Parameters

changeList
Type: System..::..Int32

Return Value

Remarks

p4 help lock

lock -- Lock an open file to prevent it from being submitted

p4 lock [-c changelist#] [file ...]

The specified files are locked in the depot, preventing any user
other than the current user on the current client from submitting
changes to the files. If a file is already locked, the lock request
is rejected. If no file names are specified, all files in the
specified changelist are locked. If changelist number is omitted,
files in the default changelist are locked.

See Also

LockCmdOptions Class


LockCmdOptions Methods

[image] [image]

Perforce .NET API
LockCmdOptions Methods
LockCmdOptions Class See Also Send Feedback

The LockCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LockCmdOptions Class


LockCmdOptions Properties

[image] [image]

Perforce .NET API
LockCmdOptions Properties
LockCmdOptions Class See Also Send Feedback

The LockCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LockCmdOptions Class


LogFile Class

[image]

Perforce .NET API
LogFile Class
Members See Also Send Feedback
Generic interface used to an event logger. In short, messages are logged by: 1) Level. The lower the level, the more sever the level, 0 fatal 1 error 2 warning 3 information 4+ debugging messages 2) Source. A string specifying the origin of the message, ie P4Server 3) Message. The text of the message.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LogFile
Visual Basic
Public Class LogFile
Visual C++
public ref class LogFile

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..LogFile

See Also

LogFile Members


LogFile Members

[image] [image]

Perforce .NET API
LogFile Members
LogFile Class Constructors Methods Fields See Also Send Feedback

The LogFile type exposes the following members.

Constructors

 | Name | Description
Public method | LogFile | Initializes a new instance of the LogFile class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LogException |
 | LogMessage |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetLoggingFunction |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ExternalLogFn |

See Also

LogFile Class


LogFile Constructor

[image]

Perforce .NET API
LogFile Constructor
LogFile Class See Also Send Feedback
Initializes a new instance of the LogFile class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LogFile()
Visual Basic
Public Sub New
Visual C++
public:
LogFile()

See Also

LogFile Class


LogFile Fields

[image] [image]

Perforce .NET API
LogFile Fields
LogFile Class See Also Send Feedback

The LogFile type exposes the following members.

Fields

Name | Description
ExternalLogFn |

See Also

LogFile Class


ExternalLogFn Field

[image]

Perforce .NET API
LogFile..::..ExternalLogFn Field
LogFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static LogFile..::..LogMessageDelgate ExternalLogFn
Visual Basic
Public Shared ExternalLogFn As LogFile..::..LogMessageDelgate
Visual C++
public:
static LogFile..::..LogMessageDelgate^ ExternalLogFn

See Also

LogFile Class


LogFile Methods

[image] [image]

Perforce .NET API
LogFile Methods
LogFile Class See Also Send Feedback

The LogFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LogException |
 | LogMessage |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetLoggingFunction |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogFile Class


LogException Method

[image]

Perforce .NET API
LogFile..::..LogException Method
LogFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void LogException(
    string category,
    Exception ex
)
Visual Basic
Public Shared Sub LogException ( _
    category As String, _
    ex As Exception _
)
Visual C++
public:
static void LogException(
    String^ category,
    Exception^ ex
)

Parameters

category
Type: System..::..String
ex
Type: System..::..Exception

See Also

LogFile Class


LogMessage Method

[image]

Perforce .NET API
LogFile..::..LogMessage Method
LogFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void LogMessage(
    int log_level,
    string source,
    string message
)
Visual Basic
Public Shared Sub LogMessage ( _
    log_level As Integer, _
    source As String, _
    message As String _
)
Visual C++
public:
static void LogMessage(
    int log_level,
    String^ source,
    String^ message
)

Parameters

log_level
Type: System..::..Int32
source
Type: System..::..String
message
Type: System..::..String

See Also

LogFile Class


SetLoggingFunction Method

[image]

Perforce .NET API
LogFile..::..SetLoggingFunction Method
LogFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void SetLoggingFunction(
    LogFile..::..LogMessageDelgate logFn
)
Visual Basic
Public Shared Sub SetLoggingFunction ( _
    logFn As LogFile..::..LogMessageDelgate _
)
Visual C++
public:
static void SetLoggingFunction(
    LogFile..::..LogMessageDelgate^ logFn
)

Parameters

logFn
Type: Perforce.P4..::..LogFile..::..LogMessageDelgate

See Also

LogFile Class


LogFile.LogMessageDelgate Delegate

[image]

Perforce .NET API
LogFile..::..LogMessageDelgate Delegate
LogFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void LogMessageDelgate(
    int log_level,
    string source,
    string message
)
Visual Basic
Public Delegate Sub LogMessageDelgate ( _
    log_level As Integer, _
    source As String, _
    message As String _
)
Visual C++
public delegate void LogMessageDelgate(
    int log_level,
    String^ source,
    String^ message
)

Parameters

log_level
Type: System..::..Int32
source
Type: System..::..String
message
Type: System..::..String

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


LoginCmdFlags Enumeration

[image]

Perforce .NET API
LoginCmdFlags Enumeration
See Also Send Feedback
Flags for the login command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum LoginCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration LoginCmdFlags
Visual C++
[FlagsAttribute]
public enum class LoginCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllHosts | 1 | The -a flag causes the server to issue a ticket that is valid on all host machines.
DisplayTicket | 2 | The -p flag displays the ticket, but does not store it on the client machine.
DisplayStatus | 4 | The -s flag displays the status of the current ticket (if there is one).

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


LoginCmdOptions Class

[image]

Perforce .NET API
LoginCmdOptions Class
Members See Also Send Feedback
Options for the login command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LoginCmdOptions : Options
Visual Basic
Public Class LoginCmdOptions _
    Inherits Options
Visual C++
public ref class LoginCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..LoginCmdOptions

See Also

LoginCmdOptions Members


LoginCmdOptions Members

[image] [image]

Perforce .NET API
LoginCmdOptions Members
LoginCmdOptions Class Constructors Methods Properties See Also Send Feedback

The LoginCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LoginCmdOptions | Options for the login command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LoginCmdOptions Class


LoginCmdOptions Constructor

[image]

Perforce .NET API
LoginCmdOptions Constructor
LoginCmdOptions Class See Also Send Feedback
Options for the login command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LoginCmdOptions(
    LoginCmdFlags flags,
    string host
)
Visual Basic
Public Sub New ( _
    flags As LoginCmdFlags, _
    host As String _
)
Visual C++
public:
LoginCmdOptions(
    LoginCmdFlags flags,
    String^ host
)

Parameters

flags
Type: Perforce.P4..::..LoginCmdFlags
host
Type: System..::..String

See Also

LoginCmdOptions Class


LoginCmdOptions Methods

[image] [image]

Perforce .NET API
LoginCmdOptions Methods
LoginCmdOptions Class See Also Send Feedback

The LoginCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LoginCmdOptions Class


LoginCmdOptions Properties

[image] [image]

Perforce .NET API
LoginCmdOptions Properties
LoginCmdOptions Class See Also Send Feedback

The LoginCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LoginCmdOptions Class


LogoutCmdFlags Enumeration

[image]

Perforce .NET API
LogoutCmdFlags Enumeration
See Also Send Feedback
Flags for the logout command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum LogoutCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration LogoutCmdFlags
Visual C++
[FlagsAttribute]
public enum class LogoutCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
AllHosts | 1 | The -a flag causes the server to issue a ticket that is valid on all host machines.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


LogoutCmdOptions Class

[image]

Perforce .NET API
LogoutCmdOptions Class
Members See Also Send Feedback
Options for the logout command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class LogoutCmdOptions : Options
Visual Basic
Public Class LogoutCmdOptions _
    Inherits Options
Visual C++
public ref class LogoutCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..LogoutCmdOptions

See Also

LogoutCmdOptions Members


LogoutCmdOptions Members

[image] [image]

Perforce .NET API
LogoutCmdOptions Members
LogoutCmdOptions Class Constructors Methods Properties See Also Send Feedback

The LogoutCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | LogoutCmdOptions | Options for the logout command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LogoutCmdOptions Class


LogoutCmdOptions Constructor

[image]

Perforce .NET API
LogoutCmdOptions Constructor
LogoutCmdOptions Class See Also Send Feedback
Options for the logout command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public LogoutCmdOptions(
    LogoutCmdFlags flags,
    string host
)
Visual Basic
Public Sub New ( _
    flags As LogoutCmdFlags, _
    host As String _
)
Visual C++
public:
LogoutCmdOptions(
    LogoutCmdFlags flags,
    String^ host
)

Parameters

flags
Type: Perforce.P4..::..LogoutCmdFlags
host
Type: System..::..String

See Also

LogoutCmdOptions Class


LogoutCmdOptions Methods

[image] [image]

Perforce .NET API
LogoutCmdOptions Methods
LogoutCmdOptions Class See Also Send Feedback

The LogoutCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LogoutCmdOptions Class


LogoutCmdOptions Properties

[image] [image]

Perforce .NET API
LogoutCmdOptions Properties
LogoutCmdOptions Class See Also Send Feedback

The LogoutCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

LogoutCmdOptions Class


MapEntry Class

[image]

Perforce .NET API
MapEntry Class
Members See Also Send Feedback
A single entry in a view map.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class MapEntry
Visual Basic
Public Class MapEntry
Visual C++
public ref class MapEntry

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..MapEntry

See Also

MapEntry Members


MapEntry Members

[image] [image]

Perforce .NET API
MapEntry Members
MapEntry Class Constructors Methods Properties See Also Send Feedback

The MapEntry type exposes the following members.

Constructors

 | Name | Description
Public method | MapEntry | Initializes a new instance of the MapEntry class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left |
Public property | Right |
Public property | Type |

See Also

MapEntry Class


MapEntry Constructor

[image]

Perforce .NET API
MapEntry Constructor
MapEntry Class See Also Send Feedback
Initializes a new instance of the MapEntry class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public MapEntry(
    MapType type,
    PathSpec left,
    PathSpec right
)
Visual Basic
Public Sub New ( _
    type As MapType, _
    left As PathSpec, _
    right As PathSpec _
)
Visual C++
public:
MapEntry(
    MapType type,
    PathSpec^ left,
    PathSpec^ right
)

Parameters

type
Type: Perforce.P4..::..MapType
left
Type: Perforce.P4..::..PathSpec
right
Type: Perforce.P4..::..PathSpec

See Also

MapEntry Class


MapEntry Methods

[image] [image]

Perforce .NET API
MapEntry Methods
MapEntry Class See Also Send Feedback

The MapEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapEntry Class


Equals Method

[image]

Perforce .NET API
MapEntry..::..Equals Method
MapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

MapEntry Class


MapEntry Properties

[image] [image]

Perforce .NET API
MapEntry Properties
MapEntry Class See Also Send Feedback

The MapEntry type exposes the following members.

Properties

 | Name | Description
Public property | Left |
Public property | Right |
Public property | Type |

See Also

MapEntry Class


Left Property

[image]

Perforce .NET API
MapEntry..::..Left Property
MapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public PathSpec Left { get; set; }
Visual Basic
Public Property Left As PathSpec
    Get
    Set
Visual C++
public:
property PathSpec^ Left {
    PathSpec^ get ();
    void set (PathSpec^ value);
}

See Also

MapEntry Class


Right Property

[image]

Perforce .NET API
MapEntry..::..Right Property
MapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public PathSpec Right { get; set; }
Visual Basic
Public Property Right As PathSpec
    Get
    Set
Visual C++
public:
property PathSpec^ Right {
    PathSpec^ get ();
    void set (PathSpec^ value);
}

See Also

MapEntry Class


Type Property

[image]

Perforce .NET API
MapEntry..::..Type Property
MapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public MapType Type { get; set; }
Visual Basic
Public Property Type As MapType
    Get
    Set
Visual C++
public:
property MapType Type {
    MapType get ();
    void set (MapType value);
}

See Also

MapEntry Class


MapType Enumeration

[image]

Perforce .NET API
MapType Enumeration
See Also Send Feedback
Describes the mapping type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum MapType
Visual Basic
Public Enumeration MapType
Visual C++
public enum class MapType

Members

Member name | Value | Description
None | 0 |
Include | 1 |
Exclude | 2 |
Overlay | 3 |
Share | 4 |
Isolate | 5 |
Import | 6 |
StreamPathExclude | 7 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


MatchType Enumeration

[image]

Perforce .NET API
MatchType Enumeration
See Also Send Feedback
Specifies whether this line match is an exact match, or a context (before or after) match.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum MatchType
Visual Basic
Public Enumeration MatchType
Visual C++
public enum class MatchType

Members

Member name | Value | Description
Match | 0 |
Before | 1 |
After | 2 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


MergeFilesCmdFlags Enumeration

[image]

Perforce .NET API
MergeFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the merge command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum MergeFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration MergeFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class MergeFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Preview | 1 | The -n flag displays a preview of the copy, without actually doing anything.
Reverse | 2 | The -r flag causes the direction of the copy to be reversed when used with a branch (-b) or stream (-S) copy.
Force | 4 | The -F flag can be used with -S to force copying even though the stream does not expect a copy to occur in the direction indicated. Normally 'p4 copy' enforces the expected flow of change dictated by the stream's spec. The 'p4 istat' command summarizes a stream's expected flow of change.
SourceBranch | 8 | The -s flag can be used with -b to cause fromFile to be treated as the source, and both sides of the user-defined branch view to be treated as the target, per the branch view mapping. Optional toFile arguments may be given to further restrict the scope of the target file set. -r is ignored when -s is used.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


MergeFilesCmdOptions Class

[image]

Perforce .NET API
MergeFilesCmdOptions Class
Members See Also Send Feedback
Merge command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class MergeFilesCmdOptions : Options
Visual Basic
Public Class MergeFilesCmdOptions _
    Inherits Options
Visual C++
public ref class MergeFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..MergeFilesCmdOptions

See Also

MergeFilesCmdOptions Members


MergeFilesCmdOptions Members

[image] [image]

Perforce .NET API
MergeFilesCmdOptions Members
MergeFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The MergeFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | MergeFilesCmdOptions | Initializes a new instance of the MergeFilesCmdOptions class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

MergeFilesCmdOptions Class


MergeFilesCmdOptions Constructor

[image]

Perforce .NET API
MergeFilesCmdOptions Constructor
MergeFilesCmdOptions Class See Also Send Feedback
Initializes a new instance of the MergeFilesCmdOptions class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public MergeFilesCmdOptions(
    MergeFilesCmdFlags flags,
    string branchName,
    string streamName,
    string parentStream,
    int changelistId,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As MergeFilesCmdFlags, _
    branchName As String, _
    streamName As String, _
    parentStream As String, _
    changelistId As Integer, _
    maxItems As Integer _
)
Visual C++
public:
MergeFilesCmdOptions(
    MergeFilesCmdFlags flags,
    String^ branchName,
    String^ streamName,
    String^ parentStream,
    int changelistId,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..MergeFilesCmdFlags
branchName
Type: System..::..String
streamName
Type: System..::..String
parentStream
Type: System..::..String
changelistId
Type: System..::..Int32
maxItems
Type: System..::..Int32

See Also

MergeFilesCmdOptions Class


MergeFilesCmdOptions Methods

[image] [image]

Perforce .NET API
MergeFilesCmdOptions Methods
MergeFilesCmdOptions Class See Also Send Feedback

The MergeFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

MergeFilesCmdOptions Class


MergeFilesCmdOptions Properties

[image] [image]

Perforce .NET API
MergeFilesCmdOptions Properties
MergeFilesCmdOptions Class See Also Send Feedback

The MergeFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

MergeFilesCmdOptions Class


MoveCmdOptions Class

[image]

Perforce .NET API
MoveCmdOptions Class
Members See Also Send Feedback
Move command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class MoveCmdOptions : Options
Visual Basic
Public Class MoveCmdOptions _
    Inherits Options
Visual C++
public ref class MoveCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..MoveCmdOptions

See Also

MoveCmdOptions Members


MoveCmdOptions Members

[image] [image]

Perforce .NET API
MoveCmdOptions Members
MoveCmdOptions Class Constructors Methods Properties See Also Send Feedback

The MoveCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | MoveCmdOptions | Options for the move command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

MoveCmdOptions Class


MoveCmdOptions Constructor

[image]

Perforce .NET API
MoveCmdOptions Constructor
MoveCmdOptions Class See Also Send Feedback
Options for the move command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public MoveCmdOptions(
    MoveFileCmdFlags flags,
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    flags As MoveFileCmdFlags, _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
MoveCmdOptions(
    MoveFileCmdFlags flags,
    int changeList,
    FileType^ fileType
)

Parameters

flags
Type: Perforce.P4..::..MoveFileCmdFlags
changeList
Type: System..::..Int32
fileType
Type: Perforce.P4..::..FileType

Return Value

Remarks

p4 help move

move -- move file(s) from one location to another
rename -- synonym for 'move'

p4 move [-c changelist#] [-f -n -k] [-t filetype] fromFile toFile

Move takes an already opened file and moves it from one client
location to another, reopening it as a pending depot move. When
the file is submitted with 'p4 submit', its depot file is moved
accordingly.

Wildcards in fromFile and toFile must match. The fromFile must be
a file open for add or edit.

'p4 opened' lists pending moves. 'p4 diff' can compare a moved
client file with its depot original, 'p4 sync' can schedule an
update of a moved file, and 'p4 resolve' can resolve the update.

A client file can be moved many times before it is submitted.
Moving a file back to its original location will undo a pending
move, leaving unsubmitted content intact. Using 'p4 revert'
undoes the move and reverts the unsubmitted content.

If -c changelist# is specified, the file is reopened in the
specified pending changelist as well as being moved.

The -f flag forces a move to an existing target file. The file
must be synced and not opened. The originating source file will
no longer be synced to the client.

If -t filetype is specified, the file is assigned that filetype.
If the filetype is a partial filetype, the partial filetype is
combined with the current filetype. See 'p4 help filetypes'.

The -n flag previews the operation without moving files.

The -k flag performs the rename on the server without modifying
client files. Use with caution, as an incorrect move can cause
discrepancies between the state of the client and the corresponding
server metadata.

The 'move' command requires a release 2009.1 or newer client. The
'-f' flag requires a 2010.1 client.

See Also

MoveCmdOptions Class


MoveCmdOptions Methods

[image] [image]

Perforce .NET API
MoveCmdOptions Methods
MoveCmdOptions Class See Also Send Feedback

The MoveCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

MoveCmdOptions Class


MoveCmdOptions Properties

[image] [image]

Perforce .NET API
MoveCmdOptions Properties
MoveCmdOptions Class See Also Send Feedback

The MoveCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

MoveCmdOptions Class


MoveFileCmdFlags Enumeration

[image]

Perforce .NET API
MoveFileCmdFlags Enumeration
See Also Send Feedback
Flags for the move command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum MoveFileCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration MoveFileCmdFlags
Visual C++
[FlagsAttribute]
public enum class MoveFileCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Force | 1 | The -f flag forces a move to an existing target file. The file must be synced and not opened. The originating source file will no longer be synced to the client.
Preview | 2 | The -n flag previews the operation without moving files.
ServerOnly | 4 | The -k flag performs the rename on the server without modifying client files. Use with caution, as an incorrect move can cause discrepancies between the state of the client and the corresponding server metadata.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


NoneRevision Class

[image]

Perforce .NET API
NoneRevision Class
Members See Also Send Feedback
A revision specifier #none.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class NoneRevision : VersionSpec
Visual Basic
Public Class NoneRevision _
    Inherits VersionSpec
Visual C++
public ref class NoneRevision : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..NoneRevision

See Also

NoneRevision Members


NoneRevision Members

[image] [image]

Perforce .NET API
NoneRevision Members
NoneRevision Class Constructors Methods See Also Send Feedback

The NoneRevision type exposes the following members.

Constructors

 | Name | Description
Public method | NoneRevision | Initializes a new instance of the NoneRevision class

Methods

 | Name | Description
Public method | Equals | Equals method for for NoneRevision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for NoneRevision (Overrides VersionSpec..::..ToString()()()().)

See Also

NoneRevision Class


NoneRevision Constructor

[image]

Perforce .NET API
NoneRevision Constructor
NoneRevision Class See Also Send Feedback
Initializes a new instance of the NoneRevision class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public NoneRevision()
Visual Basic
Public Sub New
Visual C++
public:
NoneRevision()

See Also

NoneRevision Class


NoneRevision Methods

[image] [image]

Perforce .NET API
NoneRevision Methods
NoneRevision Class See Also Send Feedback

The NoneRevision type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for NoneRevision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for NoneRevision (Overrides VersionSpec..::..ToString()()()().)

See Also

NoneRevision Class


Equals Method

[image]

Perforce .NET API
NoneRevision..::..Equals Method
NoneRevision Class See Also Send Feedback
Equals method for for NoneRevision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get none revision

Return Value

True/False

See Also

NoneRevision Class


ToString Method

[image]

Perforce .NET API
NoneRevision..::..ToString Method
NoneRevision Class See Also Send Feedback
ToString method for for NoneRevision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

#none

See Also

NoneRevision Class


Options Class

[image]

Perforce .NET API
Options Class
Members See Also Send Feedback
A generic list of command options and values.
Options for the resolve command
Options for the stream command
Options for the streams command
Options for the istat command
Options for the branch command
Options for the branches command
Options for the label command
Options for the labels command
Options for the labels command
Options for the diff2 command
Options for GetOpenedFiles
Options for the fstat command
Options for the files command
Options for the dirs command
Options for the print command
Options for the filelog command
Options for the annotate command
Options for the fixes command
Options for the grep command
Options for the integrated command
Options for the protects command
Options for the reviews command
Options for the triggers command
Options for the typemap command
Options for the protect command
Options for the counter command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Options : Dictionary<string, string>
Visual Basic
Public Class Options _
    Inherits Dictionary(Of String, String)
Visual C++
public ref class Options : public Dictionary<String^, String^>

Remarks

p4 help files

files -- List files in the depot

p4 files [ -a ] [ -A ] [ -e ] [ -m max ] file[revRange] ...
p4 files -U unloadfile ...

List details about specified files: depot file name, revision,
file, type, change action and changelist number of the current
head revision. If client syntax is used to specify the file
argument, the client view mapping is used to determine the
corresponding depot files.

By default, the head revision is listed. If the file argument
specifies a revision, then all files at that revision are listed.
If the file argument specifies a revision range, the highest revision
in the range is used for each file. For details about specifying
revisions, see 'p4 help revisions'.

The -a flag displays all revisions within the specific range, rather
than just the highest revision in the range.

The -A flag displays files in archive depots.

The -e flag displays files with an action of anything other than
deleted, purged or archived. Typically this revision is always
available to sync or integrate from.

The -m flag limits files to the first 'max' number of files.

The -U option displays files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..AddFilesCmdOptions
Perforce.P4..::..BranchCmdOptions
Perforce.P4..::..BranchesCmdOptions
Perforce.P4..::..ChangeCmdOptions
Perforce.P4..::..ChangesCmdOptions
Perforce.P4..::..ClientCmdOptions
Perforce.P4..::..ClientsCmdOptions
Perforce.P4..::..CopyFilesCmdOptions
Perforce.P4..::..CoutnerCmdOptions
Perforce.P4..::..DeleteFilesCmdOptions
Perforce.P4..::..DepotCmdOptions
Perforce.P4..::..DescribeCmdOptions
Perforce.P4..::..EditCmdOptions
Perforce.P4..::..FilelogCmdOptions
Perforce.P4..::..FilesCmdOptions
Perforce.P4..::..FixJobsCmdOptions
Perforce.P4..::..GetDepotDirsCmdOptions
Perforce.P4..::..GetDepotFileDiffsCmdOptions
Perforce.P4..::..GetDepotFilesCmdOptions
Perforce.P4..::..GetFileAnnotationsCmdOptions
Perforce.P4..::..GetFileContentsCmdOptions
Perforce.P4..::..GetFileHistoryCmdOptions
Perforce.P4..::..GetFileLineMatchesCmdOptions
Perforce.P4..::..GetFileMetaDataCmdOptions
Perforce.P4..::..GetFixesCmdOptions
Perforce.P4..::..GetOpenedFilesOptions
Perforce.P4..::..GetProtectionEntriesCmdOptions
Perforce.P4..::..GetProtectionTableCmdOptions
Perforce.P4..::..GetReviewersCmdOptions
Perforce.P4..::..GetStreamMetaDataCmdOptions
Perforce.P4..::..GetSubmittedIntegrationsCmdOptions
Perforce.P4..::..GetTriggerTableCmdOptions
Perforce.P4..::..GetTypeMapCmdOptions
Perforce.P4..::..GroupCmdOptions
Perforce.P4..::..GroupsCmdOptions
Perforce.P4..::..InfoCmdOptions
Perforce.P4..::..IntegrateFilesCmdOptions
Perforce.P4..::..JobCmdOptions
Perforce.P4..::..JobsCmdOptions
Perforce.P4..::..LabelCmdOptions
Perforce.P4..::..LabelsCmdOptions
Perforce.P4..::..LabelSyncCmdOptions
Perforce.P4..::..LockCmdOptions
Perforce.P4..::..LoginCmdOptions
Perforce.P4..::..LogoutCmdOptions
Perforce.P4..::..MergeFilesCmdOptions
Perforce.P4..::..MoveCmdOptions
Perforce.P4..::..ReopenCmdOptions
Perforce.P4..::..ResolveCmdOptions
Perforce.P4..::..ResolvedCmdOptions
Perforce.P4..::..RevertCmdOptions
Perforce.P4..::..ShelveFilesCmdOptions
Perforce.P4..::..StreamCmdOptions
Perforce.P4..::..StreamsCmdOptions
Perforce.P4..::..SubmitCmdOptions
Perforce.P4..::..SyncFilesCmdOptions
Perforce.P4..::..TagCmdOptions
Perforce.P4..::..TrustCmdOptions
Perforce.P4..::..UnlockFilesCmdOptions
Perforce.P4..::..UnshelveFilesCmdOptions
Perforce.P4..::..UserCmdOptions
Perforce.P4..::..UsersCmdOptions

See Also

Options Members


Options Members

[image] [image]

Perforce .NET API
Options Members
Options Class Constructors Methods Operators Properties See Also Send Feedback

The Options type exposes the following members.

Constructors

 | Name | Description
Public method | Options()()()() | Construct an blank Options object
Public method | Options(Int32) | Options for the lock command.
Public method | Options(ChangeCmdFlags) | Change command options.
Public method | Options(ClientCmdFlags) | Client command options.
Public method | Options(CounterCmdFlags) | Initializes a new instance of the Options class
Public method | Options(DepotCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetProtectionTableCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetResolvedFilesCmdFlags) | Resolved command options.
Public method | Options(GetStreamMetaDataCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetTriggerTableCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetTypeMapCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GroupCmdFlags) | Group command options.
Public method | Options(InfoCmdFlags) | Options for the trust command
Public method | Options(JobCmdFlags) | Options for job command.
Public method | Options(LabelSyncCmdFlags) | Options for the labelsync command.
Public method | Options(TrustCmdFlags) | Options for the trust command
Public method | Options(UserCmdFlags) | User command options.
Public method | Options(Int32, FileType) | Options for the reopen command.
Public method | Options(ChangeCmdFlags, ChangeListType) | Change command options.
Public method | Options(DeleteFilesCmdFlags, Int32) | Options for the delete command.
Public method | Options(FilesCmdFlags, Int32) | Options for the files command.
Public method | Options(GetDepotDirsCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(GetDepotFilesCmdFlags, Int32) | Initializes a new instance of the Options class
Public method | Options(GetFileAnnotationsCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(GetFileContentsCmdFlags, String) | Command options for GetFileContentsCmd()
Public method | Options(GetReviewersCmdFlags, Int32) | Initializes a new instance of the Options class
Public method | Options(GetSubmittedIntegrationsCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(GroupsCmdFlags, Int32) | Groups command options.
Public method | Options(LabelCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(LoginCmdFlags, String) | Options for the login command.
Public method | Options(LogoutCmdFlags, String) | Options for the logout command.
Public method | Options(ResolveFilesCmdFlags, Int32) | Options for the resolve command
Public method | Options(RevertFilesCmdFlags, Int32) | Revert command options.
Public method | Options(SyncFilesCmdFlags, Int32) | Sync command options.
Public method | Options(TagFilesCmdFlags, String) | Options for the tag command.
Public method | Options(UnlockFilesCmdFlags, Int32) | Unlock command options.
Public method | Options(UsersCmdFlags, Int32) | Users command options.
Public method | Options(AddFilesCmdFlags, Int32, FileType) | Options for the Add command.
Public method | Options(BranchSpecCmdFlags, String, String) | Initializes a new instance of the Options class
Public method | Options(DescribeChangelistCmdFlags, Int32, Int32) | Options for the Describe command
Public method | Options(EditFilesCmdFlags, Int32, FileType) | Options for the edit command
Public method | Options(FileLogCmdFlags, Int32, Int32) | Options for the filelog command.
Public method | Options(FixJobsCmdFlags, Int32, String) | Fix command options.
Public method | Options(GetFileHistoryCmdFlags, Int32, Int32) | Initializes a new instance of the Options class
Public method | Options(JobsCmdFlags, String, Int32) | Jobs command options.
Public method | Options(MoveFileCmdFlags, Int32, FileType) | Options for the move command.
Public method | Options(ShelveFilesCmdFlags, Changelist, Int32) | Shelve command options.
Public method | Options(StreamCmdFlags, String, String) | Initializes a new instance of the Options class
Public method | Options(UnshelveFilesCmdFlags, Int32, Int32) | Unshelve command options.
Public method | Options(BranchSpecsCmdFlags, String, String, Int32) | Initializes a new instance of the Options class
Public method | Options(ClientCmdFlags, String, String, Int32) | Client command options.
Public method | Options(GetFileLineMatchesCmdFlags, Int32, Int32, Int32) | Initializes a new instance of the Options class
Public method | Options(GetFixesCmdFlags, Int32, String, Int32) | Initializes a new instance of the Options class
Public method | Options(GetProtectionEntriesCmdFlags, String, String, String) | Initializes a new instance of the Options class
Public method | Options(ChangesCmdFlags, String, Int32, ChangeListStatus, String) | Changes command options.
Public method | Options(ClientsCmdFlags, String, String, Int32, String) | Clients command options.
Public method | Options(GetOpenedFilesCmdFlags, String, String, String, Int32) | Options for GetOpenedFiles
Public method | Options(LabelsCmdFlags, String, String, Int32, String) | Initializes a new instance of the Options class
Public method | Options(StreamsCmdFlags, String, String, String, Int32) | Initializes a new instance of the Options class
Public method | Options(SubmitFilesCmdFlags, Int32, Changelist, String, ClientSubmitOptions) | Submit command options
Public method | Options(CopyFilesCmdFlags, String, String, String, Int32, Int32) | Copy command options.
Public method | Options(GetDepotFileDiffsCmdFlags, Int32, Int32, String, String, String) | Initializes a new instance of the Options class
Public method | Options(GetFileMetadataCmdFlags, String, String, Int32, String, String) | Obsolete. Initializes a new instance of the Options class
Public method | Options(IntegrateFilesCmdFlags, Int32, Int32, String, String, String) | Options for the integrate command.
Public method | Options(LabelsCmdFlags, String, String, Int32, String, String) | Initializes a new instance of the Options class
Public method | Options(MergeFilesCmdFlags, String, String, String, Int32, Int32) | Initializes a new instance of the Options class
Public method | Options(GetFileMetadataCmdFlags, String, String, Int32, String, String, String) | Initializes a new instance of the Options class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | ToStringList |
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (Options to StringList) |

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

Options Class


Options Constructor

[image] [image]

Perforce .NET API
Options Constructor
Options Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Options()()()() | Construct an blank Options object
Public method | Options(Int32) | Options for the lock command.
Public method | Options(ChangeCmdFlags) | Change command options.
Public method | Options(ClientCmdFlags) | Client command options.
Public method | Options(CounterCmdFlags) | Initializes a new instance of the Options class
Public method | Options(DepotCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetProtectionTableCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetResolvedFilesCmdFlags) | Resolved command options.
Public method | Options(GetStreamMetaDataCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetTriggerTableCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GetTypeMapCmdFlags) | Initializes a new instance of the Options class
Public method | Options(GroupCmdFlags) | Group command options.
Public method | Options(InfoCmdFlags) | Options for the trust command
Public method | Options(JobCmdFlags) | Options for job command.
Public method | Options(LabelSyncCmdFlags) | Options for the labelsync command.
Public method | Options(TrustCmdFlags) | Options for the trust command
Public method | Options(UserCmdFlags) | User command options.
Public method | Options(Int32, FileType) | Options for the reopen command.
Public method | Options(ChangeCmdFlags, ChangeListType) | Change command options.
Public method | Options(DeleteFilesCmdFlags, Int32) | Options for the delete command.
Public method | Options(FilesCmdFlags, Int32) | Options for the files command.
Public method | Options(GetDepotDirsCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(GetDepotFilesCmdFlags, Int32) | Initializes a new instance of the Options class
Public method | Options(GetFileAnnotationsCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(GetFileContentsCmdFlags, String) | Command options for GetFileContentsCmd()
Public method | Options(GetReviewersCmdFlags, Int32) | Initializes a new instance of the Options class
Public method | Options(GetSubmittedIntegrationsCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(GroupsCmdFlags, Int32) | Groups command options.
Public method | Options(LabelCmdFlags, String) | Initializes a new instance of the Options class
Public method | Options(LoginCmdFlags, String) | Options for the login command.
Public method | Options(LogoutCmdFlags, String) | Options for the logout command.
Public method | Options(ResolveFilesCmdFlags, Int32) | Options for the resolve command
Public method | Options(RevertFilesCmdFlags, Int32) | Revert command options.
Public method | Options(SyncFilesCmdFlags, Int32) | Sync command options.
Public method | Options(TagFilesCmdFlags, String) | Options for the tag command.
Public method | Options(UnlockFilesCmdFlags, Int32) | Unlock command options.
Public method | Options(UsersCmdFlags, Int32) | Users command options.
Public method | Options(AddFilesCmdFlags, Int32, FileType) | Options for the Add command.
Public method | Options(BranchSpecCmdFlags, String, String) | Initializes a new instance of the Options class
Public method | Options(DescribeChangelistCmdFlags, Int32, Int32) | Options for the Describe command
Public method | Options(EditFilesCmdFlags, Int32, FileType) | Options for the edit command
Public method | Options(FileLogCmdFlags, Int32, Int32) | Options for the filelog command.
Public method | Options(FixJobsCmdFlags, Int32, String) | Fix command options.
Public method | Options(GetFileHistoryCmdFlags, Int32, Int32) | Initializes a new instance of the Options class
Public method | Options(JobsCmdFlags, String, Int32) | Jobs command options.
Public method | Options(MoveFileCmdFlags, Int32, FileType) | Options for the move command.
Public method | Options(ShelveFilesCmdFlags, Changelist, Int32) | Shelve command options.
Public method | Options(StreamCmdFlags, String, String) | Initializes a new instance of the Options class
Public method | Options(UnshelveFilesCmdFlags, Int32, Int32) | Unshelve command options.
Public method | Options(BranchSpecsCmdFlags, String, String, Int32) | Initializes a new instance of the Options class
Public method | Options(ClientCmdFlags, String, String, Int32) | Client command options.
Public method | Options(GetFileLineMatchesCmdFlags, Int32, Int32, Int32) | Initializes a new instance of the Options class
Public method | Options(GetFixesCmdFlags, Int32, String, Int32) | Initializes a new instance of the Options class
Public method | Options(GetProtectionEntriesCmdFlags, String, String, String) | Initializes a new instance of the Options class
Public method | Options(ChangesCmdFlags, String, Int32, ChangeListStatus, String) | Changes command options.
Public method | Options(ClientsCmdFlags, String, String, Int32, String) | Clients command options.
Public method | Options(GetOpenedFilesCmdFlags, String, String, String, Int32) | Options for GetOpenedFiles
Public method | Options(LabelsCmdFlags, String, String, Int32, String) | Initializes a new instance of the Options class
Public method | Options(StreamsCmdFlags, String, String, String, Int32) | Initializes a new instance of the Options class
Public method | Options(SubmitFilesCmdFlags, Int32, Changelist, String, ClientSubmitOptions) | Submit command options
Public method | Options(CopyFilesCmdFlags, String, String, String, Int32, Int32) | Copy command options.
Public method | Options(GetDepotFileDiffsCmdFlags, Int32, Int32, String, String, String) | Initializes a new instance of the Options class
Public method | Options(GetFileMetadataCmdFlags, String, String, Int32, String, String) | Obsolete. Initializes a new instance of the Options class
Public method | Options(IntegrateFilesCmdFlags, Int32, Int32, String, String, String) | Options for the integrate command.
Public method | Options(LabelsCmdFlags, String, String, Int32, String, String) | Initializes a new instance of the Options class
Public method | Options(MergeFilesCmdFlags, String, String, String, Int32, Int32) | Initializes a new instance of the Options class
Public method | Options(GetFileMetadataCmdFlags, String, String, Int32, String, String, String) | Initializes a new instance of the Options class

See Also

Options Class
Options Members


Options Constructor

[image]

Perforce .NET API
Options Constructor
Options Class See Also Send Feedback
Construct an blank Options object

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options()
Visual Basic
Public Sub New
Visual C++
public:
Options()

See Also

Options Class
Options Overload


Options Constructor (Int32)

[image]

Perforce .NET API
Options Constructor (Int32)
Options Class See Also Send Feedback
Options for the lock command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    int changeList
)
Visual Basic
Public Sub New ( _
    changeList As Integer _
)
Visual C++
public:
Options(
    int changeList
)

Parameters

changeList
Type: System..::..Int32

Return Value

Remarks

p4 help lock

lock -- Lock an open file to prevent it from being submitted

p4 lock [-c changelist#] [file ...]

The specified files are locked in the depot, preventing any user
other than the current user on the current client from submitting
changes to the files. If a file is already locked, the lock request
is rejected. If no file names are specified, all files in the
specified changelist are locked. If changelist number is omitted,
files in the default changelist are locked.

See Also

Options Class
Options Overload


Options Constructor (ChangeCmdFlags)

[image]

Perforce .NET API
Options Constructor (ChangeCmdFlags)
Options Class See Also Send Feedback
Change command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ChangeCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As ChangeCmdFlags _
)
Visual C++
public:
Options(
    ChangeCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..ChangeCmdFlags

Return Value

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

See Also

Options Class
Options Overload


Options Constructor (ClientCmdFlags)

[image]

Perforce .NET API
Options Constructor (ClientCmdFlags)
Options Class See Also Send Feedback
Client command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ClientCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As ClientCmdFlags _
)
Visual C++
public:
Options(
    ClientCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..ClientCmdFlags

Return Value

Remarks

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

See Also

Options Class
Options Overload


Options Constructor (CounterCmdFlags)

[image]

Perforce .NET API
Options Constructor (CounterCmdFlags)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    CounterCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As CounterCmdFlags _
)
Visual C++
public:
Options(
    CounterCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..CounterCmdFlags

See Also

Options Class
Options Overload


Options Constructor (DepotCmdFlags)

[image]

Perforce .NET API
Options Constructor (DepotCmdFlags)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    DepotCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As DepotCmdFlags _
)
Visual C++
public:
Options(
    DepotCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..DepotCmdFlags

See Also

Options Class
Options Overload


Options Constructor (GetProtectionTableCmdFlags)

[image]

Perforce .NET API
Options Constructor (GetProtectionTableCmdFlags)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetProtectionTableCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetProtectionTableCmdFlags _
)
Visual C++
public:
Options(
    GetProtectionTableCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetProtectionTableCmdFlags

See Also

Options Class
Options Overload


Options Constructor (GetResolvedFilesCmdFlags)

[image]

Perforce .NET API
Options Constructor (GetResolvedFilesCmdFlags)
Options Class See Also Send Feedback
Resolved command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetResolvedFilesCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetResolvedFilesCmdFlags _
)
Visual C++
public:
Options(
    GetResolvedFilesCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetResolvedFilesCmdFlags

Return Value

Remarks

p4 help resolved

resolved -- Show files that have been resolved but not submitted

p4 resolved [-o] [file ...]

'p4 resolved' lists file updates and integrations that have been
resolved but not yet submitted. To see unresolved integrations,
use 'p4 resolve -n'. To see already submitted integrations, use
'p4 integrated'.

If a depot file path is specified, the output lists resolves for
'theirs' files that match the specified path. If a client file
path is specified, the output lists resolves for 'yours' files
that match the specified path.

The -o flag reports the revision used as the base during the
resolve.

See Also

Options Class
Options Overload


Options Constructor (GetStreamMetaDataCmdFlags)

[image]

Perforce .NET API
Options Constructor (GetStreamMetaDataCmdFlags)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetStreamMetaDataCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetStreamMetaDataCmdFlags _
)
Visual C++
public:
Options(
    GetStreamMetaDataCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetStreamMetaDataCmdFlags

See Also

Options Class
Options Overload


Options Constructor (GetTriggerTableCmdFlags)

[image]

Perforce .NET API
Options Constructor (GetTriggerTableCmdFlags)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetTriggerTableCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetTriggerTableCmdFlags _
)
Visual C++
public:
Options(
    GetTriggerTableCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetTriggerTableCmdFlags

See Also

Options Class
Options Overload


Options Constructor (GetTypeMapCmdFlags)

[image]

Perforce .NET API
Options Constructor (GetTypeMapCmdFlags)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetTypeMapCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetTypeMapCmdFlags _
)
Visual C++
public:
Options(
    GetTypeMapCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetTypeMapCmdFlags

See Also

Options Class
Options Overload


Options Constructor (GroupCmdFlags)

[image]

Perforce .NET API
Options Constructor (GroupCmdFlags)
Options Class See Also Send Feedback
Group command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GroupCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GroupCmdFlags _
)
Visual C++
public:
Options(
    GroupCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GroupCmdFlags

Return Value

Remarks

p4 help group

group -- Change members of user group

p4 group [-a|-A] name
p4 group -d [-a] name
p4 group -o name
p4 group -i [-a|-A]

Create a group or modify the membership of an existing group.
A group can contain users and other groups. The group specification
is put into a temporary file and the editor (configured by the
environment variable $P4EDITOR) is invoked.

A group exists when it has any users or other groups in it, and
ceases to exist if all users and groups in it are removed.

Each group has MaxResults, MaxScanRows, and MaxLockTime fields,
which limit the resources committed to operations performed by
members of the group. For these fields, 'unlimited' or 'unset'
means no limit for that group. An individual user's limit is the
highest of any group with a limit to which he belongs, unlimited if
any of his groups has 'unlimited' for that field, or unlimited
if he belongs to no group with a limit. See 'p4 help maxresults'
for more information on MaxResults, MaxScanRows and MaxLockTime.

Each group also has a Timeout field, which specifies how long (in
seconds) a 'p4 login' ticket remains valid. A value of 'unset' or
'unlimited' is equivalent to no timeout. An individual's timeout is
the highest of any group with a limit to which he belongs, unlimited
if any of his groups has 'unlimited' for the timeout value, or
unlimited if he belongs to no group with a limit. See 'p4 help login'
for more information.

Each group has a PasswordTimeout field, which determines how long a
password remains valid for members of the group.

A group may be synchronized with an LDAP group by setting the three
fields: LdapConfig, LdapSearchQuery and LdapUserAttribute. This takes
the LDAP configuration (see 'p4 ldap') specified by LdapConfig and uses
it to execute the query stored by LdapSearchQuery. The LDAP attribute
specified by LdapUserAttribute is taken to be user's username and is
added to the group's user list. At least one group owner must be set if
these LDAP fields are used. If the LDAP server requires login for
read-only queries, then the LDAP configuration must contain valid bind
credentials in the LDAP spec's SearchBindDN and SearchPasswd fields

The -d flag deletes a group.

The -o flag writes the group specification to standard output. The
user's editor is not invoked.

The -i flag reads a group specification from standard input. The
user's editor is not invoked. The new group specification replaces
the previous one.

The -a flag enables a user without 'super' access to modify the group
if that user is an 'owner' of that group. Group owners are specified
in the 'Owners' field of the group spec.

The -A flag enables a user with 'admin' access to add a new group.
Existing groups may not be modified when this flag is used.

All commands that require access granted by 'p4 protect' consider a
user's groups when calculating access levels.

'p4 group' requires 'super' access granted by 'p4 protect' unless
invoked with the '-a' or '-A' flag by a qualified user.

See Also

Options Class
Options Overload


Options Constructor (InfoCmdFlags)

[image]

Perforce .NET API
Options Constructor (InfoCmdFlags)
Options Class See Also Send Feedback
Options for the trust command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    InfoCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As InfoCmdFlags _
)
Visual C++
public:
Options(
    InfoCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..InfoCmdFlags

Remarks

p4 help info

info -- Display client/server information

p4 info [-s]

Info lists information about the current client (user name,
client name, applicable client root, client current directory,
and the client IP address) and some server information (server
IP address, server root, date, uptime, version and license data).

The -s option produces 'short' output that omits any information
that requires a database lookup such as the client root).

See Also

Options Class
Options Overload


Options Constructor (JobCmdFlags)

[image]

Perforce .NET API
Options Constructor (JobCmdFlags)
Options Class See Also Send Feedback
Options for job command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    JobCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As JobCmdFlags _
)
Visual C++
public:
Options(
    JobCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..JobCmdFlags

Return Value

Remarks

p4 help job

job -- Create or edit a job (defect) specification

p4 job [-f] [jobName]
p4 job -d jobName
p4 job -o [jobName]
p4 job -i [-f]

The 'p4 job' command creates and edits job specifications using an
ASCII form. A job is a defect, enhancement, or other unit of
intended work.The 'p4 fix' command associates changelists with jobs.

With no arguments, 'p4 job' creates an empty job specification
and invokes the user's editor. When the specification is saved,
a job name of the form jobNNNNNN is assigned. If the jobName
parameter is specified on the command line, the job is created or
opened for editing.

As jobs are entered or updated, all fields are indexed for searching
Text fields are broken into individual alphanumeric words (punctuation
and whitespace are ignored) and each word is case-folded and entered
into the word index. Date fields are converted to an internal
representation (seconds since 1970/01/01 00:00:00) and entered
into the date index.

The fields that compose a job are defined by the 'p4 jobspec' command.
Perforce provides a default job specification that you can edit.

The -d flag deletes the specified job. You cannot delete a job if
it has pending or submitted fixes associated with it.

The -o flag writes the job specification to the standard output.
The user's editor is not invoked.

The -i flag reads a job specification from the standard input. The
user's editor is not invoked.

The -f flag enables you set fields that are read-only by default.
The -f flag requires 'admin' access, which is granted using the
'p4 protect' command.

See Also

Options Class
Options Overload


Options Constructor (LabelSyncCmdFlags)

[image]

Perforce .NET API
Options Constructor (LabelSyncCmdFlags)
Options Class See Also Send Feedback
Options for the labelsync command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    LabelSyncCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As LabelSyncCmdFlags _
)
Visual C++
public:
Options(
    LabelSyncCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..LabelSyncCmdFlags

Return Value

Remarks

p4 help labelsync

labelsync -- Apply the label to the contents of the client workspace

p4 labelsync [-a -d -g -n -q] -l label [file[revRange] ...]

Labelsync causes the specified label to reflect the current contents
of the client. It records the revision of each file currently synced.
The label's name can subsequently be used in a revision specification
as @label to refer to the revision of a file as stored in the label.

Without a file argument, labelsync causes the label to reflect the
contents of the whole client, by adding, deleting, and updating the
label. If a file is specified, labelsync updates the specified file.

If the file argument includes a revision specification, that revision
is used instead of the revision synced by the client. If the specified
revision is a deleted revision, the label includes that deleted
revision. See 'p4 help revisions' for details about specifying
revisions.

If the file argument includes a revision range specification,
only files selected by the revision range are updated, and the
highest revision in the range is used.

The -a flag adds the specified file to the label.

The -d deletes the specified file from the label, regardless of
revision.

The -n flag previews the operation without altering the label.

Only the owner of a label can run labelsync on that label. A label
that has its Options: field set to 'locked' cannot be updated. A
label without an owner can be labelsync'd by any user.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

The -g flag should be used on an Edge Server to update a global
label. Note that in this case, the client should be a global client.
Configuring rpl.labels.global=1 reverses this default and causes this
flag to have the opposite meaning.

See Also

Options Class
Options Overload


Options Constructor (TrustCmdFlags)

[image]

Perforce .NET API
Options Constructor (TrustCmdFlags)
Options Class See Also Send Feedback
Options for the trust command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    TrustCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As TrustCmdFlags _
)
Visual C++
public:
Options(
    TrustCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..TrustCmdFlags

Remarks

p4 trust -h

trust -- Establish trust of an SSL connection

p4 trust [ -l -y -n -d -f -r -i <fingerprint> ]

Establish trust of an SSL connection. This client command manages
the p4 trust file. This file contains fingerprints of the keys
received on ssl connections. When an SSL connection is made, this
file is examined to determine if the SSL connection has been used
before and if the key is the same as a previously seen key for that
connection. Establishing trust with a connection prevents undetected
communication interception (man-in-the-middle) attacks.

Most options are mutually exclusive. Only the -r and -f options
can be combined with the others.

The -l flag lists existing known fingerprints.

Without options, this command will make a connection to a server
and examine the key if present, if one cannot be found this command
will show a fingerprint and ask if this connection should be trusted.
If a fingerprint exists and does not match, an error that a possible
security problems exists will be displayed.

The -y flag will cause prompts to be automatically accepted.

The -n flag will cause prompts to be automatically refused.

The -d flag will remove an existing trusted fingerprint of a connection.

The -f flag will force the replacement of a mismatched fingerprint.

The -i flag will allow a specific fingerprint to be installed.

The -r flag specifies that a replacement fingerprint is to be
affected. Replacement fingerprints can be used in anticipation
of a server replacing its key. If a replacement fingerprint
exists for a connection and the primary fingerprint does not match
while the replacement fingerprint does, the replacement fingerprint
will replace the primary. This flag can be combined with -l, -i,
or -d.

See Also

Options Class
Options Overload


Options Constructor (UserCmdFlags)

[image]

Perforce .NET API
Options Constructor (UserCmdFlags)
Options Class See Also Send Feedback
User command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    UserCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As UserCmdFlags _
)
Visual C++
public:
Options(
    UserCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..UserCmdFlags

Return Value

Remarks

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

See Also

Options Class
Options Overload


Options Constructor (Int32, FileType)

[image]

Perforce .NET API
Options Constructor (Int32, FileType)
Options Class See Also Send Feedback
Options for the reopen command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
Options(
    int changeList,
    FileType^ fileType
)

Parameters

changeList
Type: System..::..Int32
fileType
Type: Perforce.P4..::..FileType

Return Value

Remarks

p4 help reopen

reopen -- Change the filetype of an open file or move it to
another changelist

p4 reopen [-c changelist#] [-t filetype] file ...

Reopen an open file for the current user in order to move it to a
different changelist or change its filetype.

The target changelist must exist; you cannot create a changelist by
reopening a file. To move a file to the default changelist, use
'p4 reopen -c default'.

If -t filetype is specified, the file is assigned that filetype. If
a partial filetype is specified, it is combined with the current
filetype. For details, see 'p4 help filetypes'.

See Also

Options Class
Options Overload


Options Constructor (ChangeCmdFlags, )

[image]

Perforce .NET API
Options Constructor (ChangeCmdFlags, )
Options Class See Also Send Feedback
Change command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ChangeCmdFlags flags,
    ChangeListType newType
)
Visual Basic
Public Sub New ( _
    flags As ChangeCmdFlags, _
    newType As ChangeListType _
)
Visual C++
public:
Options(
    ChangeCmdFlags flags,
    ChangeListType newType
)

Parameters

flags
Type: Perforce.P4..::..ChangeCmdFlags
newType
Type: ChangeListType

Return Value

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

See Also

Options Class
Options Overload


Options Constructor (DeleteFilesCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (DeleteFilesCmdFlags, Int32)
Options Class See Also Send Feedback
Options for the delete command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    DeleteFilesCmdFlags flags,
    int changeList
)
Visual Basic
Public Sub New ( _
    flags As DeleteFilesCmdFlags, _
    changeList As Integer _
)
Visual C++
public:
Options(
    DeleteFilesCmdFlags flags,
    int changeList
)

Parameters

flags
Type: Perforce.P4..::..DeleteFilesCmdFlags
changeList
Type: System..::..Int32

Return Value

Remarks

p4 help delete

delete -- Open an existing file for deletion from the depot

p4 delete [-c changelist#] [-n -v -k] file ...

Opens a depot file for deletion.
If the file is synced in the client workspace, it is removed. If a
pending changelist number is specified using with the -c flag, the
file is opened for delete in that changelist. Otherwise, it is opened
in the default pending changelist.

Files that are deleted generally do not appear on the have list.

The -n flag displays a preview of the operation without changing any
files or metadata.

The -k flag performs the delete on the server without modifying
client files. Use with caution, as an incorrect delete can cause
discrepancies between the state of the client and the corresponding
server metadata.

The -v flag enables you to delete files that are not synced to the
client workspace. The files should be specified using depot syntax;
since the files are not synced, client syntax or local syntax are
inappropriate and could introduce ambiguities in the file list.
Note, though, that if the files ARE synced, 'delete -v' will remove
the files from the client in addition to opening them for delete.
The preferred way to delete a set of files without transferring
them to your machine is: 'sync -k file...', then 'delete -k file...'

'p4 delete' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Options Class
Options Overload


Options Constructor (FilesCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (FilesCmdFlags, Int32)
Options Class See Also Send Feedback
Options for the files command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    FilesCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As FilesCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    FilesCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..FilesCmdFlags
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help Files

See Also

Options Class
Options Overload


Options Constructor (GetDepotDirsCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (GetDepotDirsCmdFlags, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetDepotDirsCmdFlags flags,
    string stream
)
Visual Basic
Public Sub New ( _
    flags As GetDepotDirsCmdFlags, _
    stream As String _
)
Visual C++
public:
Options(
    GetDepotDirsCmdFlags flags,
    String^ stream
)

Parameters

flags
Type: Perforce.P4..::..GetDepotDirsCmdFlags
stream
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (GetDepotFilesCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (GetDepotFilesCmdFlags, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetDepotFilesCmdFlags flags,
    int maxFiles
)
Visual Basic
Public Sub New ( _
    flags As GetDepotFilesCmdFlags, _
    maxFiles As Integer _
)
Visual C++
public:
Options(
    GetDepotFilesCmdFlags flags,
    int maxFiles
)

Parameters

flags
Type: Perforce.P4..::..GetDepotFilesCmdFlags
maxFiles
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (GetFileAnnotationsCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (GetFileAnnotationsCmdFlags, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetFileAnnotationsCmdFlags flags,
    string localFile
)
Visual Basic
Public Sub New ( _
    flags As GetFileAnnotationsCmdFlags, _
    localFile As String _
)
Visual C++
public:
Options(
    GetFileAnnotationsCmdFlags flags,
    String^ localFile
)

Parameters

flags
Type: Perforce.P4..::..GetFileAnnotationsCmdFlags
localFile
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (GetFileContentsCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (GetFileContentsCmdFlags, String)
Options Class See Also Send Feedback
Command options for GetFileContentsCmd()

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetFileContentsCmdFlags flags,
    string localFile
)
Visual Basic
Public Sub New ( _
    flags As GetFileContentsCmdFlags, _
    localFile As String _
)
Visual C++
public:
Options(
    GetFileContentsCmdFlags flags,
    String^ localFile
)

Parameters

flags
Type: Perforce.P4..::..GetFileContentsCmdFlags
localFile
Type: System..::..String

Remarks

p4 help print

print -- Write a depot file to standard output

p4 print [-a -A -k -o localFile -q -m max] file[revRange] ...
p4 print -U unloadfile ...

Retrieve the contents of a depot file to the client's standard output.
The file is not synced. If file is specified using client syntax,
Perforce uses the client view to determine the corresponding depot
file.

By default, the head revision is printed. If the file argument
includes a revision, the specified revision is printed. If the
file argument has a revision range, then only files selected by
that revision range are printed, and the highest revision in the
range is printed. For details about revision specifiers, see 'p4
help revisions'.

The -a flag prints all revisions within the specified range, rather
than just the highest revision in the range.

The -A flag prints files in archive depots.

The -k flag suppresses keyword expansion.

The -o localFile flag redirects the output to the specified file on
the client filesystem.

The -q flag suppresses the initial line that displays the file name
and revision.

The -m flag limits print to the first 'max' number of files.

The -U option prints files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

See Also

Options Class
Options Overload


Options Constructor (GetReviewersCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (GetReviewersCmdFlags, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetReviewersCmdFlags flags,
    int changelistId
)
Visual Basic
Public Sub New ( _
    flags As GetReviewersCmdFlags, _
    changelistId As Integer _
)
Visual C++
public:
Options(
    GetReviewersCmdFlags flags,
    int changelistId
)

Parameters

flags
Type: Perforce.P4..::..GetReviewersCmdFlags
changelistId
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (GetSubmittedIntegrationsCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (GetSubmittedIntegrationsCmdFlags, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetSubmittedIntegrationsCmdFlags flags,
    string branchSpec
)
Visual Basic
Public Sub New ( _
    flags As GetSubmittedIntegrationsCmdFlags, _
    branchSpec As String _
)
Visual C++
public:
Options(
    GetSubmittedIntegrationsCmdFlags flags,
    String^ branchSpec
)

Parameters

flags
Type: Perforce.P4..::..GetSubmittedIntegrationsCmdFlags
branchSpec
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (GroupsCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (GroupsCmdFlags, Int32)
Options Class See Also Send Feedback
Groups command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GroupsCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As GroupsCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    GroupsCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..GroupsCmdFlags
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help groups

groups -- List groups (of users)

p4 groups [-m max] [-v] [group]
p4 groups [-m max] [-i [-v]] user | group
p4 groups [-m max] [-g | -u | -o] name

The first form lists all user groups defined in the server, or just
the specified group.

The second form displays subgroup relationships. If a user argument is
specified, only groups containing that user are displayed. If a group
argument is specified, only groups containing the group are displayed.

The third form is useful when there are groups and users with the
same name, or when requesting all groups owned by a certain user.

The -i flag also displays groups that the user or group belongs to
indirectly by means of membership in subgroups.

The -m max flag limits output to the specified number of groups.

The -v flag displays the MaxResults, MaxScanRows, MaxLockTime, and
Timeout values for each group that is displayed.

The -g flag indicates that the 'name' argument is a group.

The -u flag indicates that the 'name' argument is a user.

The -o flag indicates that the 'name' argument is an owner.

See Also

Options Class
Options Overload


Options Constructor (LabelCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (LabelCmdFlags, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    LabelCmdFlags flags,
    string template
)
Visual Basic
Public Sub New ( _
    flags As LabelCmdFlags, _
    template As String _
)
Visual C++
public:
Options(
    LabelCmdFlags flags,
    String^ template
)

Parameters

flags
Type: Perforce.P4..::..LabelCmdFlags
template
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (LoginCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (LoginCmdFlags, String)
Options Class See Also Send Feedback
Options for the login command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    LoginCmdFlags flags,
    string host
)
Visual Basic
Public Sub New ( _
    flags As LoginCmdFlags, _
    host As String _
)
Visual C++
public:
Options(
    LoginCmdFlags flags,
    String^ host
)

Parameters

flags
Type: Perforce.P4..::..LoginCmdFlags
host
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (LogoutCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (LogoutCmdFlags, String)
Options Class See Also Send Feedback
Options for the logout command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    LogoutCmdFlags flags,
    string host
)
Visual Basic
Public Sub New ( _
    flags As LogoutCmdFlags, _
    host As String _
)
Visual C++
public:
Options(
    LogoutCmdFlags flags,
    String^ host
)

Parameters

flags
Type: Perforce.P4..::..LogoutCmdFlags
host
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (ResolveFilesCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (ResolveFilesCmdFlags, Int32)
Options Class See Also Send Feedback
Options for the resolve command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ResolveFilesCmdFlags flags,
    int changeList
)
Visual Basic
Public Sub New ( _
    flags As ResolveFilesCmdFlags, _
    changeList As Integer _
)
Visual C++
public:
Options(
    ResolveFilesCmdFlags flags,
    int changeList
)

Parameters

flags
Type: Perforce.P4..::..ResolveFilesCmdFlags
changeList
Type: System..::..Int32

Remarks

p4 help resolve

resolve -- Resolve integrations and updates to workspace files

p4 resolve [options] [file ...]

options: -A<flags> -a<flags> -d<flags> -f -n -N -o -t -v
-c changelist#

'p4 resolve' resolves changes to files in the client workspace.

'p4 resolve' works only on files that have been scheduled to be
resolved. The commands that can schedule resolves are: 'p4 sync',
'p4 update', 'p4 submit', 'p4 merge', and 'p4 integrate'. Files must
be resolved before they can be submitted.

Resolving involves two sets of files, a source and a target. The
target is a set of depot files that maps to opened files in the
client workspace. When resolving an integration, the source is a
different set of depot files than the target. When resolving an
update, the source is the same set of depot files as the target,
at a different revision.

The 'p4 resolve' file argument specifies the target. If the file
argument is omitted, all unresolved files are resolved.

Resolving can modify workspace files. To back up files, use 'p4
shelve' before using 'p4 resolve'.

The resolve process is a classic three-way merge. The participating
files are referred to as follows:

'yours' The target file open in the client workspace
'theirs' The source file in the depot
'base' The common ancestor; the highest revision of the
source file already accounted for in the target.
'merged' The merged result.

Filenames, filetypes, and text file content can be resolved by
accepting 'yours', 'theirs', or 'merged'. Branching, deletion, and
binary file content can be resolved by accepting either 'yours' or
'theirs'.

When resolving integrated changes, 'p4 resolve' distinguishes among
four results: entirely yours, entirely theirs, a pure merge, or an
edited merge. The distinction is recorded when resolved files are
submitted, and will be used by future commands to determine whether
integration is needed.

In all cases, accepting 'yours' leaves the target file in its current
state. The result of accepting 'theirs' is as follows:

Content: The target file content is overwritten.
Attribute: The target's attributes are replaced.
Branching: A new target is branched.
Deletion: The target file is deleted.
Filename: The target file is moved or renamed.
Filetype: The target file's type is changed.

For each unresolved change, the user is prompted to accept a result.
Content and non-content changes are resolved separately. For content,
'p4 resolve' places the merged result into a temporary file in the
client workspace. If there are any conflicts, the merged file contains
conflict markers that must be removed by the user.

'p4 resolve' displays a count of text diffs and conflicts, and offers
the following prompts:

Accept:
at Keep only changes to their file.
ay Keep only changes to your file.
* am Keep merged file.
* ae Keep merged and edited file.
* a Keep autoselected file.

Diff:
* dt See their changes alone.
* dy See your changes alone.
* dm See merged changes.
d Diff your file against merged file.

Edit:
et Edit their file (read only).
ey Edit your file (read/write).
* e Edit merged file (read/write).

Misc:
* m Run '$P4MERGE base theirs yours merged'.
(Runs '$P4MERGEUNICODE charset base theirs
yours merged' if set and the file is a
unicode file.)
s Skip this file.
h Print this help message.
^C Quit the resolve operation.

Options marked (*) appear only for text files. The suggested action
will be displayed in brackets.

The 'merge' (m) option enables you to invoke your own merge program, if
one is configured using the $P4MERGE environment variable. Four files
are passed to the program: the base, yours, theirs, and the temporary
file. The program is expected to write merge results to the temporary
file.

The -A flag can be used to limit the kind of resolving that will be
attempted; without it, everything is attempted:

-Aa Resolve attributes.
-Ab Resolve file branching.
-Ac Resolve file content changes.
-Ad Resolve file deletions.
-Am Resolve moved and renamed files.
-At Resolve filetype changes.
-AQ Resolve charset changes.

The -a flag puts 'p4 resolve' into automatic mode. The user is not
prompted, and files that can't be resolved automatically are skipped:

-as 'Safe' resolve; skip files that need merging.
-am Resolve by merging; skip files with conflicts.
-af Force acceptance of merged files with conflicts.
-at Force acceptance of theirs; overwrites yours.
-ay Force acceptance of yours; ignores theirs.

The -as flag causes the workspace file to be replaced with their file
only if theirs has changed and yours has not.

The -am flag causes the workspace file to be replaced with the result
of merging theirs with yours. If the merge detected conflicts, the
file is left untouched and unresolved.

The -af flag causes the workspace file to be replaced with the result
of merging theirs with yours, even if there were conflicts. This can
leave conflict markers in workspace files.

The -at flag resolves all files by copying theirs into yours. It
should be used with care, as it overwrites any changes made to the
file in the client workspace.

The -ay flag resolves all files by accepting yours and ignoring
theirs. It preserves the content of workspace files.

The -d flags can be used to control handling of whitespace and line
endings when merging files:

-db Ignore whitespace changes.
-dw Ignore whitespace altogether.
-dl Ignores line endings.

The -d flags are also passed to the diff options in the 'p4 resolve'
dialog. Additional -d flags that modify the diff output but do not
modify merge behavior include -dn (RCS), -dc (context), -ds (summary),
and -du (unified). Note that 'p4 resolve' uses text from the client
file if the files differ only in whitespace.

The -f flag enables previously resolved content to be resolved again.
By default, after files have been resolved, 'p4 resolve' does not
process them again.

The -n flag previews the operation without altering files.

The -N flag previews the operation with additional information about
any non-content resolve actions that are scheduled.

The -o flag displays the base file name and revision to be used
during the the merge.

The -t flag forces 'p4 resolve' to attempt a textual merge, even for
files with non-text (binary) types.

The -v flag causes 'p4 resolve' to insert markers for all changes,
not just conflicts.

The -c flag limits 'p4 resolve' to the files in changelist#.

'p4 resolve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Options Class
Options Overload


Options Constructor (RevertFilesCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (RevertFilesCmdFlags, Int32)
Options Class See Also Send Feedback
Revert command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    RevertFilesCmdFlags flags,
    int changelist
)
Visual Basic
Public Sub New ( _
    flags As RevertFilesCmdFlags, _
    changelist As Integer _
)
Visual C++
public:
Options(
    RevertFilesCmdFlags flags,
    int changelist
)

Parameters

flags
Type: Perforce.P4..::..RevertFilesCmdFlags
changelist
Type: System..::..Int32

Return Value

Remarks

p4 help revert

revert -- Discard changes from an opened file

p4 revert [-a -n -k -w -c changelist# -C client] file ...

Revert an open file to the revision that was synced from the depot,
discarding any edits or integrations that have been made. You must
explicitly specify the files to be reverted. Files are removed from
the changelist in which they are open. Locked files are unlocked.

The -a flag reverts only files that are open for edit, add, or
integrate and are unchanged or missing. Files with pending
integration records are left open. The file arguments are optional
when -a is specified.

The -n flag displays a preview of the operation.

The -k flag marks the file as reverted in server metadata without
altering files in the client workspace.

The -w flag causes files that are open for add to be deleted from the
workspace when they are reverted.

The -c flag reverts files that are open in the specified changelist.

The -C flag allows a user to specify the workspace that has the file
opened rather than defaulting to the current client workspace. When
this option is used, the '-k' flag is also enabled and the check for
matching user is disabled. The -C flag requires 'admin' access, which
is granted by 'p4 protect'.

See Also

Options Class
Options Overload


Options Constructor (SyncFilesCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (SyncFilesCmdFlags, Int32)
Options Class See Also Send Feedback
Sync command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    SyncFilesCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As SyncFilesCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    SyncFilesCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..SyncFilesCmdFlags
maxItems
Type: System..::..Int32

Remarks

p4 help sync

sync -- Synchronize the client with its view of the depot
flush -- synonym for 'sync -k'
update -- synonym for 'sync -s'

p4 sync [-f -L -n -N -k -q -r] [-m max] [file[revRange] ...]
p4 sync [-L -n -N -q -s] [-m max] [file[revRange] ...]
p4 sync [-L -n -N -p -q] [-m max] [file[revRange] ...]
--parallel=threads=N[,batch=N][,batchsize=N][,min=N][,minsize=N]

Sync updates the client workspace to reflect its current view (if
it has changed) and the current contents of the depot (if it has
changed). The client view maps client and depot file names and
locations.

Sync adds files that are in the client view and have not been
retrieved before. Sync deletes previously retrieved files that
are no longer in the client view or have been deleted from the
depot. Sync updates files that are still in the client view and
have been updated in the depot.

By default, sync affects all files in the client workspace. If file
arguments are given, sync limits its operation to those files.
The file arguments can contain wildcards.

If the file argument includes a revision specifier, then the given
revision is retrieved. Normally, the head revision is retrieved.
See 'p4 help revisions' for help specifying revisions.

If the file argument includes a revision range specification,
only files selected by the revision range are updated, and the
highest revision in the range is used.

Normally, sync does not overwrite workspace files that the user has
manually made writable. Setting the 'clobber' option in the
client specification disables this safety check.

The -f flag forces resynchronization even if the client already
has the file, and overwriting any writable files. This flag doesn't
affect open files.

The -L flag can be used with multiple file arguments that are in
full depot syntax and include a valid revision number. When this
flag is used the arguments are processed together by building an
internal table similar to a label. This file list processing is
significantly faster than having to call the internal query engine
for each individual file argument. However, the file argument syntax
is strict and the command will not run if an error is encountered.

The -n flag previews the operation without updating the workspace.

The -N flag also previews the operation without updating the
workspace, but reports only a summary of the work the sync would do.

The -k flag updates server metadata without syncing files. It is
intended to enable you to ensure that the server correctly reflects
the state of files in the workspace while avoiding a large data
transfer. Caution: an erroneous update can cause the server to
incorrectly reflect the state of the workspace.

The -p flag populates the client workspace, but does not update the
server to reflect those updates. Any file that is already synced or
opened will be bypassed with a warning message. This option is very
useful for build clients or when publishing content without the
need to track the state of the client workspace.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are not suppressed.

The -r flag allows open files which are mapped to new locations
in the depot to be reopened in the new location. By default, open
workspace files remain associated with the depot files that they were
originally opened as.

The -s flag adds a safety check before sending content to the client
workspace. This check uses MD5 digests to compare the content on the
clients workspace against content that was last synced. If the file
has been modified outside of Perforce's control then an error message
is displayed and the file is not overwritten. This check adds some
extra processing which will affect the performance of the operation.
Clients with 'allwrite' and 'noclobber' set do this check by default.

The -m flag limits sync to the first 'max' number of files. This
option is useful in conjunction with tagged output and the '-n'
flag, to preview how many files will be synced without transferring
all the file data.

The --parallel flag specifies options for parallel file transfer. If
your administrator has enabled parallel file transfer by setting the
net.parallel.max configurable, and if there are sufficient resources
across the system, a sync command may execute more rapidly by
transferring multiple files in parallel. Specify threads=N to request
files be sent concurrently, using N independent network connections.
The N threads grab work in batches; specify batch=N to control the
number of files in a batch, or batchsize=N to control the number of
bytes in a batch. A sync that is too small will not initiate parallel
file transfers; specify min=N to control the minimum number of files
in a parallel sync, or minsize=N to control the minimum number of
bytes in a parallel sync. Requesting progress indicators causes the
--parallel flag to be ignored.

See Also

Options Class
Options Overload


Options Constructor (TagFilesCmdFlags, String)

[image]

Perforce .NET API
Options Constructor (TagFilesCmdFlags, String)
Options Class See Also Send Feedback
Options for the tag command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    TagFilesCmdFlags flags,
    string label
)
Visual Basic
Public Sub New ( _
    flags As TagFilesCmdFlags, _
    label As String _
)
Visual C++
public:
Options(
    TagFilesCmdFlags flags,
    String^ label
)

Parameters

flags
Type: Perforce.P4..::..TagFilesCmdFlags
label
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (UnlockFilesCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (UnlockFilesCmdFlags, Int32)
Options Class See Also Send Feedback
Unlock command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    UnlockFilesCmdFlags flags,
    int changelistId
)
Visual Basic
Public Sub New ( _
    flags As UnlockFilesCmdFlags, _
    changelistId As Integer _
)
Visual C++
public:
Options(
    UnlockFilesCmdFlags flags,
    int changelistId
)

Parameters

flags
Type: Perforce.P4..::..UnlockFilesCmdFlags
changelistId
Type: System..::..Int32

Return Value

Remarks

p4 help unlock

unlock -- Release a locked file, leaving it open

p4 unlock [-c | -s changelist# | -x] [-f] [file ...]
p4 -c client unlock [-f] -r

'p4 unlock' releases locks on the specified files, which must be
open in the specified pending changelist. If you omit the changelist
number, the default changelist is assumed. If you omit the file name,
all locked files are unlocked.

The -s flag unlocks files from a shelved changelist caused by an
aborted 'submit -e' operation. The -c flag applies to opened files
in a pending changelist locked by 'p4 lock' or by a failed submit
of a change that is not shelved.

By default, files can be unlocked only by the changelist owner who
must also be the person who has the files locked. The -f flag
enables you to unlock files in changelists owned by other users.
The -f flag requires 'admin' access, which is granted by 'p4
protect'.

The -x option unlocks files that are opened 'exclusive' but are
orphaned (see 'p4 opened -x'). This option only applies to a
distributed installation where global tracking of these file types
is necessary across servers.

If a push command from a remote server to this server fails, files
can be left locked on this server, preventing other users from
submitting changes to those files. In this case, the user who issued
the push command can specify the -r flag with the name of the client
that was used on that remote server to unlock the files on this
server. An administrator can run 'unlock -f -r' as well.

See Also

Options Class
Options Overload


Options Constructor (UsersCmdFlags, Int32)

[image]

Perforce .NET API
Options Constructor (UsersCmdFlags, Int32)
Options Class See Also Send Feedback
Users command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    UsersCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As UsersCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    UsersCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..UsersCmdFlags
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help users

users -- List Perforce users

p4 users [-l -a -r -c] [-m max] [user ...]

Lists all Perforce users or users that match the 'user' argument.
The report includes the last time that each user accessed the system.

The -m max flag limits output to the first 'max' number of users.

The -a flag includes service and operator users in the output.

The -l flag includes additional information in the output. The -l
flag requires 'super' access, which is granted by 'p4 protect'.

The -r and -c flags are only allowed on replica servers. When
-r is given only users who have used a replica are reported and
when -c is given only the user information from the central server
is reported. Otherwise on a replica server, the user list will
be slightly different from the master server as the user access times
will reflect replica usage or master usage whichever is newer.

See Also

Options Class
Options Overload


Options Constructor (AddFilesCmdFlags, Int32, FileType)

[image]

Perforce .NET API
Options Constructor (AddFilesCmdFlags, Int32, FileType)
Options Class See Also Send Feedback
Options for the Add command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    AddFilesCmdFlags flags,
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    flags As AddFilesCmdFlags, _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
Options(
    AddFilesCmdFlags flags,
    int changeList,
    FileType^ fileType
)

Parameters

flags
Type: Perforce.P4..::..AddFilesCmdFlags
Flags for the command
changeList
Type: System..::..Int32
Optional changelist for the fies
fileType
Type: Perforce.P4..::..FileType
Optional file type for the files

Return Value

Remarks

p4 help add

add -- Open a new file to add it to the depot

p4 add [-c changelist#] [-d -f -I -n] [-t filetype] file ...

Open a file for adding to the depot. If the file exists on the
client, it is read to determine if it is text or binary. If it does
not exist, it is assumed to be text. To be added, the file must not
already reside in the depot, or it must be deleted at the current
head revision. Files can be deleted and re-added.

A 2012.1 client will ignore files that were to be added, if they
match an exclusion line specified in a P4IGNORE file.

To associate the open files with a specific pending changelist, use
the -c flag; if you omit the -c flag, the open files are associated
with the default changelist. If file is already open, it is moved
into the specified pending changelist. You cannot reopen a file for
add unless it is already open for add.

As a shortcut to reverting and re-adding, you can use the -d
flag to reopen currently-open files for add (downgrade) under
the following circumstances:

A file that is 'opened for edit' and is synced to the head
revision, and the head revision has been deleted (or moved).

A file that is 'opened for move/add' can be downgraded to add,
which is useful when the source of the move has been deleted
or moved. Typically, under these circumstances, your only
alternative is to revert. In this case, breaking the move
connection enables you to preserve any content changes in the
new file and safely revert the source file (of the move).

To specify file type, use the -t flag. By default, 'p4 add'
determines file type using the name-to-type mapping table managed
by 'p4 typemap' and by examining the file's contents and execute
permission bit. If the file type specified by -t or configured in
the typemap table is a partial filetype, the resulting modifier is
applied to the file type that is determined by 'p4 add'. For more
details, see 'p4 help filetypes'.

To add files with filenames that contain wildcard characters, specify
the -f flag. Filenames that contain the special characters '@', '#',
'%' or '*' are reformatted to encode the characters using ASCII
hexadecimal representation. After the files are added, you must
refer to them using the reformatted file name, because Perforce
does not recognize the local filesystem name.

The -I flag informs the client that it should not perform any ignore
checking configured by P4IGNORE.

The -n flag displays a preview of the specified add operation without
changing any files or metadata.

See Also

Options Class
Options Overload


Options Constructor (BranchSpecCmdFlags, String, String)

[image]

Perforce .NET API
Options Constructor (BranchSpecCmdFlags, String, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    BranchSpecCmdFlags flags,
    string stream,
    string parent
)
Visual Basic
Public Sub New ( _
    flags As BranchSpecCmdFlags, _
    stream As String, _
    parent As String _
)
Visual C++
public:
Options(
    BranchSpecCmdFlags flags,
    String^ stream,
    String^ parent
)

Parameters

flags
Type: Perforce.P4..::..BranchSpecCmdFlags
stream
Type: System..::..String
parent
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (DescribeChangelistCmdFlags, Int32, Int32)

[image]

Perforce .NET API
Options Constructor (DescribeChangelistCmdFlags, Int32, Int32)
Options Class See Also Send Feedback
Options for the Describe command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    DescribeChangelistCmdFlags flags,
    int contextLines,
    int unifiedLines
)
Visual Basic
Public Sub New ( _
    flags As DescribeChangelistCmdFlags, _
    contextLines As Integer, _
    unifiedLines As Integer _
)
Visual C++
public:
Options(
    DescribeChangelistCmdFlags flags,
    int contextLines,
    int unifiedLines
)

Parameters

flags
Type: Perforce.P4..::..DescribeChangelistCmdFlags
contextLines
Type: System..::..Int32
unifiedLines
Type: System..::..Int32

Remarks

p4 help describe

describe -- Display a changelist description

p4 describe [-d<flags> -m -s -S -f -O] changelist# ...

Display a changelist description, including the changelist number,
user, client, date of submission, textual description, list of
affected files and diffs of files updated. Pending changelists
are indicated as 'pending' and file diffs are not displayed.

For restricted changelists, 'no permission' is displayed if the user
is not permitted to view the change (see 'p4 help change'). If a
submitted change is restricted, the description is hidden unless
the user is the owner of the change or has list permission for
at least one file in the change. If a shelved change is restricted,
the description is hidden unless the user is the owner of the change,
or has list permission to at least one file in the change and has
used the -S flag to request the shelved change. To view restricted
pending (not shelved) changes, the user must be the owner of the
change.

The -d<flags> passes one or more flags to the built-in diff routine
to modify the output: -dn (RCS), -dc[n] (context), -ds (summary),
-du[n] (unified), -db (ignore whitespace changes), -dw (ignore
whitespace), -dl (ignore line endings). The optional argument to
to -dc/-du specifies number of context lines.

The -s flag omits the diffs of files that were updated.

The -S flag lists files that are shelved for the specified changelist
and displays diffs of the files against their previous revision.
If the change is restricted, the description is displayed according
to the rules for shelved restricted changes described above.

The -f flag forces display of the descriptions in a restricted
change. The -f flag requires 'admin' access, which is granted
using 'p4 protect'.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -m flag limits files to the first 'max' number of files.

See Also

Options Class
Options Overload


Options Constructor (EditFilesCmdFlags, Int32, FileType)

[image]

Perforce .NET API
Options Constructor (EditFilesCmdFlags, Int32, FileType)
Options Class See Also Send Feedback
Options for the edit command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    EditFilesCmdFlags flags,
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    flags As EditFilesCmdFlags, _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
Options(
    EditFilesCmdFlags flags,
    int changeList,
    FileType^ fileType
)

Parameters

flags
Type: Perforce.P4..::..EditFilesCmdFlags
changeList
Type: System..::..Int32
fileType
Type: Perforce.P4..::..FileType

Return Value

Remarks

p4 help edit

edit -- Open an existing file for edit

p4 edit [-c changelist#] [-k -n] [-t filetype] file ...

Open an existing file for edit. The server records the fact that
the current user has opened the file in the current workspace, and
changes the file permission from read-only to read/write.

If -c changelist# is included, the file opened in the specified
pending changelist. If changelist number is omitted, the file is
opened in the 'default' changelist.

If -t filetype is specified, the file is assigned that Perforce
filetype. Otherwise, the filetype of the previous revision is reused.
If a partial filetype is specified, it is combined with the current
filetype.For details, see 'p4 help filetypes'.
Using a filetype of 'auto' will cause the filetype to be chosen
as if the file were being added, that is the typemap will be
considered and the file contents may be examined.

The -n flag previews the operation without changing any files or
metadata.

The -k flag updates metadata without transferring files to the
workspace. This option can be used to tell the server that files in
a client workspace are already editable, even if they are not in the
client view. Typically this flag is used to correct the Perforce
server when it is wrong about the state of files in the client
workspace, but incorrect use of this option can result in inaccurate
file status information.

'p4 edit' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Options Class
Options Overload


Options Constructor (FileLogCmdFlags, Int32, Int32)

[image]

Perforce .NET API
Options Constructor (FileLogCmdFlags, Int32, Int32)
Options Class See Also Send Feedback
Options for the filelog command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    FileLogCmdFlags flags,
    int changelistId,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As FileLogCmdFlags, _
    changelistId As Integer, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    FileLogCmdFlags flags,
    int changelistId,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..FileLogCmdFlags
changelistId
Type: System..::..Int32
maxItems
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (FixJobsCmdFlags, Int32, String)

[image]

Perforce .NET API
Options Constructor (FixJobsCmdFlags, Int32, String)
Options Class See Also Send Feedback
Fix command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    FixJobsCmdFlags flags,
    int changelistId,
    string status
)
Visual Basic
Public Sub New ( _
    flags As FixJobsCmdFlags, _
    changelistId As Integer, _
    status As String _
)
Visual C++
public:
Options(
    FixJobsCmdFlags flags,
    int changelistId,
    String^ status
)

Parameters

flags
Type: Perforce.P4..::..FixJobsCmdFlags
changelistId
Type: System..::..Int32
status
Type: System..::..String

Return Value

Remarks

p4 help fix

fix -- Mark jobs as being fixed by the specified changelist

p4 fix [-d] [-s status] -c changelist# jobName ...

'p4 fix' marks each named job as being fixed by the changelist
number specified with -c. The changelist can be pending or
submitted and the jobs can be open or closed (fixed by another
changelist).

If the changelist has already been submitted and the job is still
open, then 'p4 fix' marks the job closed. If the changelist has not
been submitted and the job is still open, the job is closed when the
changelist is submitted. If the job is already closed, it remains
closed.

The -d flag deletes the specified fixes. This operation does not
otherwise affect the specified changelist or jobs.

The -s flag uses the specified status instead of the default defined
in the job specification.

The fix's status is reported by 'p4 fixes', and is related to the
job's status. Certain commands set the job's status to the fix's
status for each job associated with the change. When a job is fixed
by a submitted change, the job's status is set to match the fix
status. When a job is fixed by a pending change, the job's status
is set to match the fix status when the change is submitted. If the
fix's status is 'same', the job's status is left unchanged.

See Also

Options Class
Options Overload


Options Constructor (GetFileHistoryCmdFlags, Int32, Int32)

[image]

Perforce .NET API
Options Constructor (GetFileHistoryCmdFlags, Int32, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetFileHistoryCmdFlags flags,
    int changeList,
    int maxRevs
)
Visual Basic
Public Sub New ( _
    flags As GetFileHistoryCmdFlags, _
    changeList As Integer, _
    maxRevs As Integer _
)
Visual C++
public:
Options(
    GetFileHistoryCmdFlags flags,
    int changeList,
    int maxRevs
)

Parameters

flags
Type: Perforce.P4..::..GetFileHistoryCmdFlags
changeList
Type: System..::..Int32
maxRevs
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (JobsCmdFlags, String, Int32)

[image]

Perforce .NET API
Options Constructor (JobsCmdFlags, String, Int32)
Options Class See Also Send Feedback
Jobs command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    JobsCmdFlags flags,
    string jobView,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As JobsCmdFlags, _
    jobView As String, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    JobsCmdFlags flags,
    String^ jobView,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..JobsCmdFlags
jobView
Type: System..::..String
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help jobs

jobs -- Display list of jobs

p4 jobs [-e jobview -i -l -m max -r] [file[revRange] ...]
p4 jobs -R

Lists jobs in the server. If a file specification is included, fixes
for submitted changelists affecting the specified files are listed.
The file specification can include wildcards and a revision range.
See 'p4 help revisions' for details about specifying revisions.

The -e flag lists jobs matching the expression specified in the
jobview parameter. For a description of jobview syntax, see 'p4 help
jobview'.

The -i flag includes any fixes made by changelists integrated into
the specified files.

The -l flag produces long output with the full text of the job
descriptions.

The -m max flag limits the output to the first 'max' jobs, ordered
by their job name.

The -r flag sorts the jobs in reverse order (by job name).

The -R flag rebuilds the jobs table and reindexes each job, which
is necessary after upgrading to 98.2. 'p4 jobs -R' requires that the
user be an operator or have 'super' access granted by 'p4 protect'.

See Also

Options Class
Options Overload


Options Constructor (MoveFileCmdFlags, Int32, FileType)

[image]

Perforce .NET API
Options Constructor (MoveFileCmdFlags, Int32, FileType)
Options Class See Also Send Feedback
Options for the move command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    MoveFileCmdFlags flags,
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    flags As MoveFileCmdFlags, _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
Options(
    MoveFileCmdFlags flags,
    int changeList,
    FileType^ fileType
)

Parameters

flags
Type: Perforce.P4..::..MoveFileCmdFlags
changeList
Type: System..::..Int32
fileType
Type: Perforce.P4..::..FileType

Return Value

Remarks

p4 help move

move -- move file(s) from one location to another
rename -- synonym for 'move'

p4 move [-c changelist#] [-f -n -k] [-t filetype] fromFile toFile

Move takes an already opened file and moves it from one client
location to another, reopening it as a pending depot move. When
the file is submitted with 'p4 submit', its depot file is moved
accordingly.

Wildcards in fromFile and toFile must match. The fromFile must be
a file open for add or edit.

'p4 opened' lists pending moves. 'p4 diff' can compare a moved
client file with its depot original, 'p4 sync' can schedule an
update of a moved file, and 'p4 resolve' can resolve the update.

A client file can be moved many times before it is submitted.
Moving a file back to its original location will undo a pending
move, leaving unsubmitted content intact. Using 'p4 revert'
undoes the move and reverts the unsubmitted content.

If -c changelist# is specified, the file is reopened in the
specified pending changelist as well as being moved.

The -f flag forces a move to an existing target file. The file
must be synced and not opened. The originating source file will
no longer be synced to the client.

If -t filetype is specified, the file is assigned that filetype.
If the filetype is a partial filetype, the partial filetype is
combined with the current filetype. See 'p4 help filetypes'.

The -n flag previews the operation without moving files.

The -k flag performs the rename on the server without modifying
client files. Use with caution, as an incorrect move can cause
discrepancies between the state of the client and the corresponding
server metadata.

The 'move' command requires a release 2009.1 or newer client. The
'-f' flag requires a 2010.1 client.

See Also

Options Class
Options Overload


Options Constructor (ShelveFilesCmdFlags, Changelist, Int32)

[image]

Perforce .NET API
Options Constructor (ShelveFilesCmdFlags, Changelist, Int32)
Options Class See Also Send Feedback
Shelve command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ShelveFilesCmdFlags flags,
    Changelist newChangelist,
    int changelistId
)
Visual Basic
Public Sub New ( _
    flags As ShelveFilesCmdFlags, _
    newChangelist As Changelist, _
    changelistId As Integer _
)
Visual C++
public:
Options(
    ShelveFilesCmdFlags flags,
    Changelist^ newChangelist,
    int changelistId
)

Parameters

flags
Type: Perforce.P4..::..ShelveFilesCmdFlags
newChangelist
Type: Perforce.P4..::..Changelist
changelistId
Type: System..::..Int32

Return Value

Remarks

p4 help shelve

shelve -- Store files from a pending changelist into the depot

p4 shelve [-p] [files]
p4 shelve [-a option] [-p] -i [-f | -r]
p4 shelve [-a option] [-p] -r -c changelist#
p4 shelve [-a option] [-p] -c changelist# [-f] [file ...]
p4 shelve -d -c changelist# [-f] [file ...]

'p4 shelve' creates, modifies or deletes shelved files in a pending
changelist. Shelved files remain in the depot until they are deleted
(using 'p4 shelve -d') or replaced by subsequent shelve commands.
After 'p4 shelve', the user can revert the files and restore them
later using 'p4 unshelve'. Other users can 'p4 unshelve' the stored
files into their own workspaces.

Files that have been shelved can be accessed by the 'p4 diff',
'p4 diff2', 'p4 files' and 'p4 print' commands using the revision
specification '@=change', where 'change' is the pending changelist
number.

By default, 'p4 shelve' creates a changelist, adds files from the
user's default changelist, then shelves those files in the depot.
The user is presented with a text changelist form displayed using
the editor configured using the $P4EDITOR environment variable.

If a file pattern is specified, 'p4 shelve' shelves the files that
match the pattern.

The -i flag reads the pending changelist specification with shelved
files from the standard input. The user's editor is not invoked.
To modify an existing changelist with shelved files, specify the
changelist number using the -c flag.

The -c flag specifies the pending changelist that contains shelved
files to be created, deleted, or modified. Only the user and client
of the pending changelist can add or modify its shelved files. Any
files specified by the file pattern must already be opened in the
specified changelist; use 'p4 reopen' to move an opened file from
one changelist to another.

The -f (force) flag must be used with the -c or -i flag to overwrite
any existing shelved files in a pending changelist.

The -r flag (used with -c or -i) enables you to replace all shelved
files in that changelist with the files opened in your own workspace
at that changelist number. Previously shelved files will be deleted.
Only the user and client workspace of the pending changelist can
replace its shelved files.

The -a flag enables you to handle unchanged files similarly to some
client submit options, namely 'submitunchanged' and 'leaveunchanged'.
The default behavior of shelving all files corresponds to the
'submitunchanged' option. The 'leaveunchanged' option only shelves
changed files, and then leaves the files opened in the pending
changelist on the client.

The -d flag (used with -c) deletes the shelved files in the specified
changelist so that they can no longer be unshelved. By default, only
the user and client of the pending changelist can delete its shelved
files. A user with 'admin' access can delete shelved files by including
the -f flag to force the operation.

The -p flag promotes a shelved change from an edge server to a commit
server where it can be accessed by other edge servers participating
in the distributed configuration. Once a shelved change has been
promoted, all subsequent local modifications to the shelf are also
pushed to the commit server and remain until the shelf is deleted.
Once a shelf has been created, the combination of flags '-p -c' will
promote the shelf without modification unless '-f' or '-r' are also
used to update the shelved files before promotion.

'p4 shelve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Options Class
Options Overload


Options Constructor (StreamCmdFlags, String, String)

[image]

Perforce .NET API
Options Constructor (StreamCmdFlags, String, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    StreamCmdFlags flags,
    string parent,
    string type
)
Visual Basic
Public Sub New ( _
    flags As StreamCmdFlags, _
    parent As String, _
    type As String _
)
Visual C++
public:
Options(
    StreamCmdFlags flags,
    String^ parent,
    String^ type
)

Parameters

flags
Type: Perforce.P4..::..StreamCmdFlags
parent
Type: System..::..String
type
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (UnshelveFilesCmdFlags, Int32, Int32)

[image]

Perforce .NET API
Options Constructor (UnshelveFilesCmdFlags, Int32, Int32)
Options Class See Also Send Feedback
Unshelve command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    UnshelveFilesCmdFlags flags,
    int changelistId,
    int newChangelistId
)
Visual Basic
Public Sub New ( _
    flags As UnshelveFilesCmdFlags, _
    changelistId As Integer, _
    newChangelistId As Integer _
)
Visual C++
public:
Options(
    UnshelveFilesCmdFlags flags,
    int changelistId,
    int newChangelistId
)

Parameters

flags
Type: Perforce.P4..::..UnshelveFilesCmdFlags
changelistId
Type: System..::..Int32
newChangelistId
Type: System..::..Int32

Return Value

Remarks

p4 help unshelve

unshelve -- Restore shelved files from a pending change into a workspace

p4 unshelve -s changelist# [options] [file ...]
Options: [-f -n] [-c changelist#] [-b branch|-S stream [-P parent]]

'p4 unshelve' retrieves shelved files from the specified pending
changelist, opens them in a pending changelist and copies them
to the invoking user's workspace. Unshelving files from a pending
changelist is restricted by the user's permissions on the files.
A successful unshelve operation places the shelved files on the
user's workspace with the same open action and pending integration
history as if it had originated from that user and client.

Unshelving a file over an already opened file is permitted if both
shelved file and opened file are opened for 'edit'. In a distributed
environment, an additional requirement is that the shelve was created
on the same edge server. After unshelving, the workspace file is
flagged as unresolved, and 'p4 resolve' must be run to resolve the
differences between the shelved file and the workspace file.

Unshelving a file opened for 'add' when the file already exists
in the depot will result in the file being opened for edit. After
unshelving, the workspace file is flagged as unresolved, and
'p4 resolve' must be run to resolve the differences between the
shelved file and the depot file at the head revision. Note that
unshelving a file opened for 'add' over an already opened file is
not supported.

The -s flag specifies the number of the pending changelist that
contains the shelved files.

If a file pattern is specified, 'p4 unshelve' unshelves files that
match the pattern.

The -b flag specifies a branch spec that the shelved files will be
mapped through prior to being unshelved, allowing files to be shelved
in one branch and unshelved in another. As with unshelving into an
open file, it may be necessary to run 'p4 resolve'. In a distributed
environment, an additional requirement is that the shelve was created
on the same edge server.

The -S flag uses a generated branch view to map the shelved files
between the specified stream and its parent stream. The -P flag
can be used to generate the view using a parent stream other than
the actual parent.

The -c flag specifies the changelist to which files are unshelved.
By default, 'p4 unshelve' opens shelved files in the default
changelist.

The -f flag forces the clobbering of any writeable but unopened files
that are being unshelved.

The -n flag previews the operation without changing any files or
metadata.

'p4 unshelve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Options Class
Options Overload


Options Constructor (BranchSpecsCmdFlags, String, String, Int32)

[image]

Perforce .NET API
Options Constructor (BranchSpecsCmdFlags, String, String, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    BranchSpecsCmdFlags flags,
    string user,
    string nameFilter,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As BranchSpecsCmdFlags, _
    user As String, _
    nameFilter As String, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    BranchSpecsCmdFlags flags,
    String^ user,
    String^ nameFilter,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..BranchSpecsCmdFlags
user
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (ClientCmdFlags, String, String, Int32)

[image]

Perforce .NET API
Options Constructor (ClientCmdFlags, String, String, Int32)
Options Class See Also Send Feedback
Client command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ClientCmdFlags flags,
    string template,
    string stream,
    int change
)
Visual Basic
Public Sub New ( _
    flags As ClientCmdFlags, _
    template As String, _
    stream As String, _
    change As Integer _
)
Visual C++
public:
Options(
    ClientCmdFlags flags,
    String^ template,
    String^ stream,
    int change
)

Parameters

flags
Type: Perforce.P4..::..ClientCmdFlags
template
Type: System..::..String
stream
Type: System..::..String
change
Type: System..::..Int32

Return Value

Remarks

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

See Also

Options Class
Options Overload


Options Constructor (GetFileLineMatchesCmdFlags, Int32, Int32, Int32)

[image]

Perforce .NET API
Options Constructor (GetFileLineMatchesCmdFlags, Int32, Int32, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetFileLineMatchesCmdFlags flags,
    int outputContext,
    int trailingContext,
    int leadingContext
)
Visual Basic
Public Sub New ( _
    flags As GetFileLineMatchesCmdFlags, _
    outputContext As Integer, _
    trailingContext As Integer, _
    leadingContext As Integer _
)
Visual C++
public:
Options(
    GetFileLineMatchesCmdFlags flags,
    int outputContext,
    int trailingContext,
    int leadingContext
)

Parameters

flags
Type: Perforce.P4..::..GetFileLineMatchesCmdFlags
outputContext
Type: System..::..Int32
trailingContext
Type: System..::..Int32
leadingContext
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (GetFixesCmdFlags, Int32, String, Int32)

[image]

Perforce .NET API
Options Constructor (GetFixesCmdFlags, Int32, String, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetFixesCmdFlags flags,
    int changelistId,
    string jobId,
    int maxFixes
)
Visual Basic
Public Sub New ( _
    flags As GetFixesCmdFlags, _
    changelistId As Integer, _
    jobId As String, _
    maxFixes As Integer _
)
Visual C++
public:
Options(
    GetFixesCmdFlags flags,
    int changelistId,
    String^ jobId,
    int maxFixes
)

Parameters

flags
Type: Perforce.P4..::..GetFixesCmdFlags
changelistId
Type: System..::..Int32
jobId
Type: System..::..String
maxFixes
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (GetProtectionEntriesCmdFlags, String, String, String)

[image]

Perforce .NET API
Options Constructor (GetProtectionEntriesCmdFlags, String, String, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetProtectionEntriesCmdFlags flags,
    string groupName,
    string userName,
    string hostName
)
Visual Basic
Public Sub New ( _
    flags As GetProtectionEntriesCmdFlags, _
    groupName As String, _
    userName As String, _
    hostName As String _
)
Visual C++
public:
Options(
    GetProtectionEntriesCmdFlags flags,
    String^ groupName,
    String^ userName,
    String^ hostName
)

Parameters

flags
Type: Perforce.P4..::..GetProtectionEntriesCmdFlags
groupName
Type: System..::..String
userName
Type: System..::..String
hostName
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (ChangesCmdFlags, String, Int32, ChangeListStatus, String)

[image]

Perforce .NET API
Options Constructor (ChangesCmdFlags, String, Int32, ChangeListStatus, String)
Options Class See Also Send Feedback
Changes command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ChangesCmdFlags flags,
    string clientName,
    int maxItems,
    ChangeListStatus status,
    string userName
)
Visual Basic
Public Sub New ( _
    flags As ChangesCmdFlags, _
    clientName As String, _
    maxItems As Integer, _
    status As ChangeListStatus, _
    userName As String _
)
Visual C++
public:
Options(
    ChangesCmdFlags flags,
    String^ clientName,
    int maxItems,
    ChangeListStatus status,
    String^ userName
)

Parameters

flags
Type: Perforce.P4..::..ChangesCmdFlags
clientName
Type: System..::..String
maxItems
Type: System..::..Int32
status
Type: Perforce.P4..::..ChangeListStatus
userName
Type: System..::..String

Return Value

Remarks

p4 help changes

changes -- Display list of pending and submitted changelists
changelists -- synonym for 'changes'

p4 changes [options] [file[revRange] ...]

options: -i -t -l -L -f -c client -m max -s status -u user

Returns a list of all pending and submitted changelists currently
stored in the server.

If files are specified, 'p4 changes' lists only changelists that
affect those files. If the file specification includes a revision
range, 'p4 changes' lists only submitted changelists that affect
the specified revisions. See 'p4 help revisions' for details.

If files are not specified, 'p4 changes' limits its report
according to each change's type ('public' or 'restricted').
If a submitted or shelved change is restricted, the change is
not reported unless the user owns the change or has list
permission for at least one file in the change. Only the owner
of a restricted and pending (not shelved) change is permitted
to see it.

The -i flag also includes any changelists integrated into the
specified files.

The -t flag displays the time as well as the date.

The -l flag displays the full text of the changelist
descriptions.

The -L flag displays the changelist descriptions, truncated to 250
characters if longer.

The -f flag enables admin users to view restricted changes.

The -c client flag displays only submitted by the specified client.

The -m max flag limits changes to the 'max' most recent.

The -s status flag limits the output to changelists with the specified
status. Specify '-s pending', '-s shelved', or '-s submitted'.

The -u user flag displays only changes owned by the specified user.

See Also

Options Class
Options Overload


Options Constructor (ClientsCmdFlags, String, String, Int32, String)

[image]

Perforce .NET API
Options Constructor (ClientsCmdFlags, String, String, Int32, String)
Options Class See Also Send Feedback
Clients command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    ClientsCmdFlags flags,
    string userName,
    string nameFilter,
    int maxItems,
    string stream
)
Visual Basic
Public Sub New ( _
    flags As ClientsCmdFlags, _
    userName As String, _
    nameFilter As String, _
    maxItems As Integer, _
    stream As String _
)
Visual C++
public:
Options(
    ClientsCmdFlags flags,
    String^ userName,
    String^ nameFilter,
    int maxItems,
    String^ stream
)

Parameters

flags
Type: Perforce.P4..::..ClientsCmdFlags
userName
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32
stream
Type: System..::..String

Return Value

Remarks

p4 help clients

clients -- Display list of clients
workspaces -- synonym for 'clients'

p4 clients [-t] [-u user] [[-e|-E] nameFilter -m max] [-S stream]
[-a | -s serverID]
p4 clients -U

Lists all client workspaces currently defined in the server.

The -t flag displays the time as well as the date.

The -u user flag lists client workspaces that are owned by the
specified user.

The -e nameFilter flag lists workspaces with a name that matches
the nameFilter pattern, for example: -e 'svr-dev-rel*'. The -e flag
uses the server's normal case-sensitivity rules. The -E flag makes
the matching case-insensitive, even on a case-sensitive server.

The -m max flag limits output to the specified number of workspaces.

The -S stream flag limits output to the client workspaces dedicated
to the stream.

The -U flag lists unloaded clients (see 'p4 help unload').

The -a flag specifies that all clients should be displayed, not just
those that are bound to this server.

The -s serverID flag specifies that only those clients bound to the
specified serverID should be displayed. On an Edge Server, the -s
flag defaults to the Edge Server's serverID.

See Also

Options Class
Options Overload


Options Constructor (GetOpenedFilesCmdFlags, String, String, String, Int32)

[image]

Perforce .NET API
Options Constructor (GetOpenedFilesCmdFlags, String, String, String, Int32)
Options Class See Also Send Feedback
Options for GetOpenedFiles

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetOpenedFilesCmdFlags flags,
    string changelist,
    string client,
    string user,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As GetOpenedFilesCmdFlags, _
    changelist As String, _
    client As String, _
    user As String, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    GetOpenedFilesCmdFlags flags,
    String^ changelist,
    String^ client,
    String^ user,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..GetOpenedFilesCmdFlags
changelist
Type: System..::..String
client
Type: System..::..String
user
Type: System..::..String
maxItems
Type: System..::..Int32

Remarks

p4 help opened

opened -- List open files and display file status

p4 opened [-a -c changelist# -C client -u user -m max -s] [file ...]
p4 opened [-a -x -m max ] [file ...]

Lists files currently opened in pending changelists, or, for
specified files, show whether they are currently opened or locked.
If the file specification is omitted, all files open in the current
client workspace are listed.

Files in shelved changelists are not displayed by this command. To
display shelved changelists, see 'p4 changes -s shelved'; to display
the files in those shelved changelists, see 'p4 describe -s -S'.

The -a flag lists opened files in all clients. By default, only
files opened by the current client are listed.

The -c changelist# flag lists files opened in the specified
changelist#.

The -C client flag lists files open in the specified client workspace.

The -u user flag lists files opened by the specified user.

The -m max flag limits output to the first 'max' number of files.

The -s option produces 'short' and optimized output when used with
the -a (all clients) option. For large repositories '-a' can take
a long time when compared to '-as'.

The -x option lists files that are opened 'exclusive'. This option
only applies to a distributed installation where global tracking of
these file types is necessary across servers. The -x option implies
the -a option.

See Also

Options Class
Options Overload


Options Constructor (LabelsCmdFlags, String, String, Int32, String)

[image]

Perforce .NET API
Options Constructor (LabelsCmdFlags, String, String, Int32, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    LabelsCmdFlags flags,
    string user,
    string nameFilter,
    int maxItems,
    string fileRevRange
)
Visual Basic
Public Sub New ( _
    flags As LabelsCmdFlags, _
    user As String, _
    nameFilter As String, _
    maxItems As Integer, _
    fileRevRange As String _
)
Visual C++
public:
Options(
    LabelsCmdFlags flags,
    String^ user,
    String^ nameFilter,
    int maxItems,
    String^ fileRevRange
)

Parameters

flags
Type: Perforce.P4..::..LabelsCmdFlags
user
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32
fileRevRange
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (StreamsCmdFlags, String, String, String, Int32)

[image]

Perforce .NET API
Options Constructor (StreamsCmdFlags, String, String, String, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    StreamsCmdFlags flags,
    string filter,
    string tagged,
    string streampath,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As StreamsCmdFlags, _
    filter As String, _
    tagged As String, _
    streampath As String, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    StreamsCmdFlags flags,
    String^ filter,
    String^ tagged,
    String^ streampath,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..StreamsCmdFlags
filter
Type: System..::..String
tagged
Type: System..::..String
streampath
Type: System..::..String
maxItems
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (SubmitFilesCmdFlags, Int32, Changelist, String, ClientSubmitOptions)

[image]

Perforce .NET API
Options Constructor (SubmitFilesCmdFlags, Int32, Changelist, String, ClientSubmitOptions)
Options Class See Also Send Feedback
Submit command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    SubmitFilesCmdFlags flags,
    int changelist,
    Changelist newChangelist,
    string description,
    ClientSubmitOptions submitOptions
)
Visual Basic
Public Sub New ( _
    flags As SubmitFilesCmdFlags, _
    changelist As Integer, _
    newChangelist As Changelist, _
    description As String, _
    submitOptions As ClientSubmitOptions _
)
Visual C++
public:
Options(
    SubmitFilesCmdFlags flags,
    int changelist,
    Changelist^ newChangelist,
    String^ description,
    ClientSubmitOptions^ submitOptions
)

Parameters

flags
Type: Perforce.P4..::..SubmitFilesCmdFlags
changelist
Type: System..::..Int32
newChangelist
Type: Perforce.P4..::..Changelist
description
Type: System..::..String
submitOptions
Type: Perforce.P4..::..ClientSubmitOptions

Return Value

Remarks

p4 help submit

submit -- Submit open files to the depot

p4 submit [-r -s -f option --noretransfer 0|1]
p4 submit [-r -s -f option] file
p4 submit [-r -f option] -d description
p4 submit [-r -f option] -d description file
p4 submit [-r -f option --noretransfer 0|1] -c changelist#
p4 submit -e shelvedChange#
p4 submit -i [-r -s -f option]
--parallel=threads=N[,batch=N][,min=N]

'p4 submit' commits a pending changelist and its files to the depot.

By default, 'p4 submit' attempts to submit all files in the 'default'
changelist. Submit displays a dialog where you enter a description
of the change and, optionally, delete files from the list of files
to be checked in.

To add files to a changelist before submitting, use any of the
commands that open client workspace files: 'p4 add', 'p4 edit',
etc.

If the file parameter is specified, only files in the default
changelist that match the pattern are submitted.

Files in a stream path can be submitted only by client workspaces
dedicated to the stream. See 'p4 help client'.

Before committing a changelist, 'p4 submit' locks all the files being
submitted. If any file cannot be locked or submitted, the files are
left open in a numbered pending changelist. By default, the files in
a failed submit operation are left locked unless the
submit.unlocklocked configurable is set. Files are unlocked even if
they were manually locked prior to submit if submit fails when
submit.unlocklocked is set. 'p4 opened' shows unsubmitted files
and their changelists.

Submit is atomic: if the operation succeeds, all files are updated
in the depot. If the submit fails, no depot files are updated.

If submit fails, some or all of the files may have been copied to
the server. By default, retrying a failed submit will transfer all of
the files again unless the submit.noretransfer configurable is set.
If submit.noretransfer is set to 1, submit uses digest comparisons to
to detect if the files have already been transferred in order to
avoid file re-transfer when retrying a failed submit.

The --noretransfer flag is used to override the submit.noretransfer
configurable so the user can choose his preferred re-transfer
behavior during the current submit operation.

The -c flag submits the specified pending changelist instead of the
default changelist. Additional changelists can be created manually,
using the 'p4 change' command, or automatically as the result of a
failed attempt to submit the default changelist.

The -e flag submits a shelved changelist without transferring files
or modifying the workspace. The shelved change must be owned by
the person submitting the change, but the client may be different.
However, files shelved to a stream target may only be submitted by
a stream client that is mapped to the target stream. In addition,
files shelved to a non-stream target cannot be submitted by a stream
client. To submit a shelved change, all files in the shelved change
must be up to date and resolved. No files may be open in any workspace
at the same change number. Client submit options (ie revertUnchanged,
etc) will be ignored. If the submit is successful, the shelved change
and files are cleaned up, and are no longer available to be unshelved
or submitted.

The -d flag passes a description into the specified changelist rather
than displaying the changelist dialog for manual editing. This option
is useful for scripting, but does not allow you to add jobs or modify
the default changelist.

The -f flag enables you to override submit options that are configured
for the client that is submitting the changelist. This flag overrides
the -r (reopen)flag, if it is specified. See 'p4 help client' for
details about submit options.

The -i flag reads a changelist specification from the standard input.
The user's editor is not invoked.

The -r flag reopens submitted files in the default changelist after
submission.

The -s flag extends the list of jobs to include the fix status
for each job, which becomes the job's status when the changelist
is committed. See 'p4 help change' for details.

The --parallel flag specifies options for parallel file transfer. If
parallel file transfer has been enabled by setting the
net.parallel.max configurable, and if there are sufficient resources
across the system, a submit command may execute more rapidly by
transferring multiple files in parallel. Specify threads=N to request
files be sent concurrently, using N independent network connections.
The N threads grab work in batches; specify batch=N to control the
number of files in a batch. A submit that is too small will not
initiate parallel file transfers; specify min=N to control the
minimum number of files in a parallel submit. Requesting progress
indicators causes the --parallel flag to be ignored.

Using --parallel from an edge server allows parallel file transfer
from the edge server to the commit server. This uses standard pull
threads to transfer the files. Note that an adminstrator must insure
that pull threads can be run on the commit server. The address
used by the commit server to connect to the edge server must
be specified in the ExternalAddress field of the edge server spec.

Only 'submit -e' is supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Options Class
Options Overload


Options Constructor (CopyFilesCmdFlags, String, String, String, Int32, Int32)

[image]

Perforce .NET API
Options Constructor (CopyFilesCmdFlags, String, String, String, Int32, Int32)
Options Class See Also Send Feedback
Copy command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    CopyFilesCmdFlags flags,
    string branchName,
    string streamName,
    string parentStream,
    int changelistId,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As CopyFilesCmdFlags, _
    branchName As String, _
    streamName As String, _
    parentStream As String, _
    changelistId As Integer, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    CopyFilesCmdFlags flags,
    String^ branchName,
    String^ streamName,
    String^ parentStream,
    int changelistId,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..CopyFilesCmdFlags
branchName
Type: System..::..String
streamName
Type: System..::..String
parentStream
Type: System..::..String
changelistId
Type: System..::..Int32
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help copy

copy -- Copy one set of files to another

p4 copy [options] fromFile[rev] toFile
p4 copy [options] -b branch [-r] [toFile[rev] ...]
p4 copy [options] -b branch -s fromFile[rev] [toFile ...]
p4 copy [options] -S stream [-P parent] [-F] [-r] [toFile[rev] ...]

options: -c changelist# -f -n -v -m max -q

'p4 copy' copies one set of files (the 'source') into another (the
'target').

Using the client workspace as a staging area, 'p4 copy' makes the
target identical to the source by branching, replacing, or deleting
files. 'p4 submit' submits copied files to the depot. 'p4 revert'
can be used to revert copied files instead of submitting them. The
history of copied files can be shown with 'p4 filelog' or 'p4
integrated'.

Target files that are already identical to the source, or that are
outside of the client view, are not affected by 'p4 copy'. Opened,
non-identical target files cause 'p4 copy' to exit with a warning.
When 'p4 copy' creates or modifies files in the workspace, it leaves
them read-only; 'p4 edit' can make them writable. Files opened by
'p4 copy' do not need to be resolved.

Source and target files (fromFile and toFile) can be specified on
the 'p4 copy' command line or through a branch view. On the command
line, fromFile is the source file set and toFile is the target file
set. With a branch view, one or more toFile arguments can be given
to limit the scope of the target file set.

A revision specifier can be used to select the revision to copy; by
default, the head revision is copied. The revision specifier can be
used on fromFile, or on toFile, but not on both. When used on toFile,
it refers to source revisions, not to target revisions. A range may
not be used as a revision specifier. For revision syntax, see 'p4
help revisions'.

The -S flag makes 'p4 copy' copy from a stream to its parent.
Use -r with -S to reverse the copy direction. Note that to submit
copied stream files, the current client must be switched to the
target stream, or to a virtual child stream of the target stream.
The -S flag causes 'p4 copy' to use a generated branch view that
maps the stream to its parent. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. The -S flag also makes 'p4 copy' respect a stream's flow.

The -F flag can be used with -S to force copying against a stream's
expected flow. It can also force -S to generate a branch view based
on a virtual stream; the mapping itself refers to the underlying
real stream.

The -b flag makes 'p4 copy' use a user-defined branch view. (See
'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the user-defined branch view to be
treated as the target, per the branch view mapping. Optional toFile
arguments may be given to further restrict the scope of the target
file set. -r is ignored when -s is used.

The -c changelist# flag opens files in the designated (numbered)
pending changelist instead of the default changelist.

The -f flag forces the creation of extra revisions in order to
explicitly record that files have been copied. Deleted source files
will be copied if they do not exist in the target, and files that are
already identical will be copied if they are not connected by existing
integration records.

The -n flag displays a preview of the copy, without actually doing
anything.

The -m flag limits the actions to the first 'max' number of files.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

The -v flag causes a 'virtual' copy that does not modify client
workspace files. After submitting a virtual integration, 'p4 sync'
can be used to update the workspace.

'p4 copy' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

Options Class
Options Overload


Options Constructor (GetDepotFileDiffsCmdFlags, Int32, Int32, String, String, String)

[image]

Perforce .NET API
Options Constructor (GetDepotFileDiffsCmdFlags, Int32, Int32, String, String, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetDepotFileDiffsCmdFlags flags,
    int contextLines,
    int unifiedLines,
    string branch,
    string stream,
    string parent
)
Visual Basic
Public Sub New ( _
    flags As GetDepotFileDiffsCmdFlags, _
    contextLines As Integer, _
    unifiedLines As Integer, _
    branch As String, _
    stream As String, _
    parent As String _
)
Visual C++
public:
Options(
    GetDepotFileDiffsCmdFlags flags,
    int contextLines,
    int unifiedLines,
    String^ branch,
    String^ stream,
    String^ parent
)

Parameters

flags
Type: Perforce.P4..::..GetDepotFileDiffsCmdFlags
contextLines
Type: System..::..Int32
unifiedLines
Type: System..::..Int32
branch
Type: System..::..String
stream
Type: System..::..String
parent
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String)

[image]

Perforce .NET API
Options Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[ObsoleteAttribute("use Options(GetFileMetadataCmdFlags flags, string filter, string taggedFields, int maxItems, string afterChangelist, string byChangelist, string attribPattern)")]
public Options(
    GetFileMetadataCmdFlags flags,
    string filter,
    string taggedFields,
    int maxItems,
    string afterChangelist,
    string byChangelist
)
Visual Basic
<ObsoleteAttribute("use Options(GetFileMetadataCmdFlags flags, string filter, string taggedFields, int maxItems, string afterChangelist, string byChangelist, string attribPattern)")> _
Public Sub New ( _
    flags As GetFileMetadataCmdFlags, _
    filter As String, _
    taggedFields As String, _
    maxItems As Integer, _
    afterChangelist As String, _
    byChangelist As String _
)
Visual C++
[ObsoleteAttribute(L"use Options(GetFileMetadataCmdFlags flags, string filter, string taggedFields, int maxItems, string afterChangelist, string byChangelist, string attribPattern)")]
public:
Options(
    GetFileMetadataCmdFlags flags,
    String^ filter,
    String^ taggedFields,
    int maxItems,
    String^ afterChangelist,
    String^ byChangelist
)

Parameters

flags
Type: Perforce.P4..::..GetFileMetadataCmdFlags
filter
Type: System..::..String
taggedFields
Type: System..::..String
maxItems
Type: System..::..Int32
afterChangelist
Type: System..::..String
byChangelist
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (IntegrateFilesCmdFlags, Int32, Int32, String, String, String)

[image]

Perforce .NET API
Options Constructor (IntegrateFilesCmdFlags, Int32, Int32, String, String, String)
Options Class See Also Send Feedback
Options for the integrate command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    IntegrateFilesCmdFlags flags,
    int changeList,
    int maxFiles,
    string branch,
    string stream,
    string parent
)
Visual Basic
Public Sub New ( _
    flags As IntegrateFilesCmdFlags, _
    changeList As Integer, _
    maxFiles As Integer, _
    branch As String, _
    stream As String, _
    parent As String _
)
Visual C++
public:
Options(
    IntegrateFilesCmdFlags flags,
    int changeList,
    int maxFiles,
    String^ branch,
    String^ stream,
    String^ parent
)

Parameters

flags
Type: Perforce.P4..::..IntegrateFilesCmdFlags
changeList
Type: System..::..Int32
maxFiles
Type: System..::..Int32
branch
Type: System..::..String
stream
Type: System..::..String
parent
Type: System..::..String

Return Value

Remarks

p4 help integrate

integrate -- Integrate one set of files into another

p4 integrate [options] fromFile[revRange] toFile
p4 integrate [options] -b branch [-r] [toFile[revRange] ...]
p4 integrate [options] -b branch -s fromFile[revRange] [toFile ...]
p4 integrate [options] -S stream [-r] [-P parent] [file[revRange] ...]

options: -c changelist# -Di -f -h -O<flags> -n -m max -R<flags> -q -v

'p4 integrate' integrates one set of files (the 'source') into
another (the 'target').

(See also 'p4 merge' and 'p4 copy', variants of 'p4 integrate' that
may be easier and more effective for the task at hand.)

Using the client workspace as a staging area, 'p4 integrate' adds and
deletes target files per changes in the source, and schedules all
other affected target files to be resolved. Target files outside of
the current client view are not affected. Source files need not be
within the client view.

'p4 resolve' must be used to merge file content, and to resolve
filename and filetype changes. 'p4 submit' commits integrated files
to the depot. Unresolved files may not be submitted. Integrations
can be shelved with 'p4 shelve' and abandoned with 'p4 revert'. The
commands 'p4 integrated' and 'p4 filelog' display integration history.

When 'p4 integrate' schedules a workspace file to be resolved, it
leaves it read-only. 'p4 resolve' can operate on a read-only file.
For other pre-submit changes, 'p4 edit' must be used to make the
file writable.

Source and target files can be specified either on the 'p4 integrate'
command line or through a branch view. On the command line, fromFile
is the source file set and toFile is the target file set. With a
branch view, one or more toFile arguments can be given to limit the
scope of the target file set.

revRange is a revision or a revision range that limits the span of
source history to be probed for unintegrated revisions. revRange
can be used on fromFile, or on toFile, but not on both. When used on
toFile, it refers to source revisions, not to target revisions. For
details about revision specifiers, see 'p4 help revisions'.

The -S flag makes 'p4 integrate' use a generated branch view that maps
a stream (or its underlying real stream) to its parent. With -r, the
direction of the mapping is reversed. -P can be used to generate the
branch view using a parent stream other than the stream's actual
parent. Note that to submit integrated stream files, the current
client must be switched to the target stream, or to a virtual child
stream of the target stream.

The -b flag makes 'p4 integrate' use a user-defined branch view.
(See 'p4 help branch'.) The source is the left side of the branch view
and the target is the right side. With -r, the direction is reversed.

The -s flag can be used with -b to cause fromFile to be treated as
the source, and both sides of the branch view to be treated as the
target, per the branch view mapping. Optional toFile arguments may
be given to further restrict the scope of the target file set. The
-r flag is ignored when -s is used.

Note that 'p4 integrate' automatically adusts source-to-target
mappings for moved and renamed files. (Adjustment occurs only if
the 'p4 move' command was used to move/rename files.) The scope of
source and target file sets must include both the old-named and the
new-named files for mappings to be adjusted. A filename resolve is
scheduled for each remapped file to allow the target to be moved to
match the source.

The -f flag forces integrate to ignore integration history and treat
all source revisions as unintegrated. It is meant to be used with
revRange to force reintegration of specific, previously integrated
revisions.

The -O flags cause more information to be output for each file opened:

-Ob Show the base revision for the merge (if any).
-Or Show the resolve(s) that are being scheduled.

The -R flags modify the way resolves are scheduled:

-Rb Schedules 'branch resolves' instead of branching new
target files automatically.

-Rd Schedules 'delete resolves' instead of deleting
target files automatically.

-Rs Skips cherry-picked revisions already integrated.
This can improve merge results, but can also cause
multiple resolves per file to be scheduled.

The -Di flag modifies the way deleted revisions are treated. If the
source file has been deleted and re-added, revisions that precede
the deletion will be considered to be part of the same source file.
By default, re-added files are considered to be unrelated to the
files of the same name that preceded them.

The -h flag leaves the target files at the revision currently synced
to the client (the '#have' revision). By default, target files are
automatically synced to the head revision by 'p4 integrate'.

The -m flag limits integration to the first 'max' number of files.

The -n flag displays a preview of integration, without actually
doing anything.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are displayed.

If -c changelist# is specified, the files are opened in the
designated numbered pending changelist instead of the 'default'
changelist.

The -v flag causes a 'virtual' integration that does not modify
client workspace files unless target files need to be resolved.
After submitting a virtual integration, 'p4 sync' can be used to
update the workspace.

Integration is not supported for files with propagating attributes
from an edge server in a distributed environment. Depending on the
integration action, target, and source, either the integration or
resolve command will fail.

See Also

Options Class
Options Overload


Options Constructor (LabelsCmdFlags, String, String, Int32, String, String)

[image]

Perforce .NET API
Options Constructor (LabelsCmdFlags, String, String, Int32, String, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    LabelsCmdFlags flags,
    string user,
    string nameFilter,
    int maxItems,
    string fileRevRange,
    string serverId
)
Visual Basic
Public Sub New ( _
    flags As LabelsCmdFlags, _
    user As String, _
    nameFilter As String, _
    maxItems As Integer, _
    fileRevRange As String, _
    serverId As String _
)
Visual C++
public:
Options(
    LabelsCmdFlags flags,
    String^ user,
    String^ nameFilter,
    int maxItems,
    String^ fileRevRange,
    String^ serverId
)

Parameters

flags
Type: Perforce.P4..::..LabelsCmdFlags
user
Type: System..::..String
nameFilter
Type: System..::..String
maxItems
Type: System..::..Int32
fileRevRange
Type: System..::..String
serverId
Type: System..::..String

See Also

Options Class
Options Overload


Options Constructor (MergeFilesCmdFlags, String, String, String, Int32, Int32)

[image]

Perforce .NET API
Options Constructor (MergeFilesCmdFlags, String, String, String, Int32, Int32)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    MergeFilesCmdFlags flags,
    string branchName,
    string streamName,
    string parentStream,
    int changelistId,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As MergeFilesCmdFlags, _
    branchName As String, _
    streamName As String, _
    parentStream As String, _
    changelistId As Integer, _
    maxItems As Integer _
)
Visual C++
public:
Options(
    MergeFilesCmdFlags flags,
    String^ branchName,
    String^ streamName,
    String^ parentStream,
    int changelistId,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..MergeFilesCmdFlags
branchName
Type: System..::..String
streamName
Type: System..::..String
parentStream
Type: System..::..String
changelistId
Type: System..::..Int32
maxItems
Type: System..::..Int32

See Also

Options Class
Options Overload


Options Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String, String)

[image]

Perforce .NET API
Options Constructor (GetFileMetadataCmdFlags, String, String, Int32, String, String, String)
Options Class See Also Send Feedback
Initializes a new instance of the Options class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Options(
    GetFileMetadataCmdFlags flags,
    string filter,
    string taggedFields,
    int maxItems,
    string afterChangelist,
    string byChangelist,
    string attribPattern
)
Visual Basic
Public Sub New ( _
    flags As GetFileMetadataCmdFlags, _
    filter As String, _
    taggedFields As String, _
    maxItems As Integer, _
    afterChangelist As String, _
    byChangelist As String, _
    attribPattern As String _
)
Visual C++
public:
Options(
    GetFileMetadataCmdFlags flags,
    String^ filter,
    String^ taggedFields,
    int maxItems,
    String^ afterChangelist,
    String^ byChangelist,
    String^ attribPattern
)

Parameters

flags
Type: Perforce.P4..::..GetFileMetadataCmdFlags
filter
Type: System..::..String
taggedFields
Type: System..::..String
maxItems
Type: System..::..Int32
afterChangelist
Type: System..::..String
byChangelist
Type: System..::..String
attribPattern
Type: System..::..String

See Also

Options Class
Options Overload


Options Methods

[image] [image]

Perforce .NET API
Options Methods
Options Class See Also Send Feedback

The Options type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | ToStringList |
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

Options Class


ToString Method

[image]

Perforce .NET API
Options..::..ToString Method
Options Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Options Class


ToStringList Method

[image]

Perforce .NET API
Options..::..ToStringList Method
Options Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StringList ToStringList()
Visual Basic
Public Function ToStringList As StringList
Visual C++
public:
StringList^ ToStringList()

See Also

Options Class


Options Type Conversions

[image] [image]

Perforce .NET API
Options Type Conversions
Options Class See Also Send Feedback

The Options type exposes the following members.

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (Options to StringList) |

See Also

Options Class


Implicit Conversion (Options to StringList)

[image]

Perforce .NET API
Options ImplicitWideningImplicitImplicitImplicit Conversion (Options to StringList)
Options Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator StringList (
    Options o
)
Visual Basic
Public Shared Widening Operator CType ( _
    o As Options _
) As StringList
Visual C++
static implicit operator StringList^ (
    Options^ o
)

Parameters

o
Type: Perforce.P4..::..Options

See Also

Options Class


Options Properties

[image] [image]

Perforce .NET API
Options Properties
Options Class See Also Send Feedback

The Options type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

Options Class


OtherFileUser Class

[image]

Perforce .NET API
OtherFileUser Class
Members See Also Send Feedback
Class summarizing the use of this file by another user.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class OtherFileUser
Visual Basic
Public Class OtherFileUser
Visual C++
public ref class OtherFileUser

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..OtherFileUser

See Also

OtherFileUser Members


OtherFileUser Members

[image] [image]

Perforce .NET API
OtherFileUser Members
OtherFileUser Class Constructors Methods Properties See Also Send Feedback

The OtherFileUser type exposes the following members.

Constructors

 | Name | Description
Public method | OtherFileUser | Initializes a new instance of the OtherFileUser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action |
Public property | ChangelistId |
Public property | Client |
Public property | ClientName |
Public property | hasLock |
Public property | UserName |

See Also

OtherFileUser Class


OtherFileUser Constructor

[image]

Perforce .NET API
OtherFileUser Constructor
OtherFileUser Class See Also Send Feedback
Initializes a new instance of the OtherFileUser class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public OtherFileUser()
Visual Basic
Public Sub New
Visual C++
public:
OtherFileUser()

See Also

OtherFileUser Class


OtherFileUser Methods

[image] [image]

Perforce .NET API
OtherFileUser Methods
OtherFileUser Class See Also Send Feedback

The OtherFileUser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OtherFileUser Class


OtherFileUser Properties

[image] [image]

Perforce .NET API
OtherFileUser Properties
OtherFileUser Class See Also Send Feedback

The OtherFileUser type exposes the following members.

Properties

 | Name | Description
Public property | Action |
Public property | ChangelistId |
Public property | Client |
Public property | ClientName |
Public property | hasLock |
Public property | UserName |

See Also

OtherFileUser Class


Action Property

[image]

Perforce .NET API
OtherFileUser..::..Action Property
OtherFileUser Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction Action { get; set; }
Visual Basic
Public Property Action As FileAction
    Get
    Set
Visual C++
public:
property FileAction Action {
    FileAction get ();
    void set (FileAction value);
}

See Also

OtherFileUser Class


ChangelistId Property

[image]

Perforce .NET API
OtherFileUser..::..ChangelistId Property
OtherFileUser Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChangelistId { get; set; }
Visual Basic
Public Property ChangelistId As Integer
    Get
    Set
Visual C++
public:
property int ChangelistId {
    int get ();
    void set (int value);
}

See Also

OtherFileUser Class


Client Property

[image]

Perforce .NET API
OtherFileUser..::..Client Property
OtherFileUser Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Client { get; set; }
Visual Basic
Public Property Client As String
    Get
    Set
Visual C++
public:
property String^ Client {
    String^ get ();
    void set (String^ value);
}

See Also

OtherFileUser Class


ClientName Property

[image]

Perforce .NET API
OtherFileUser..::..ClientName Property
OtherFileUser Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ClientName { get; set; }
Visual Basic
Public Property ClientName As String
    Get
    Set
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

See Also

OtherFileUser Class


hasLock Property

[image]

Perforce .NET API
OtherFileUser..::..hasLock Property
OtherFileUser Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool hasLock { get; set; }
Visual Basic
Public Property hasLock As Boolean
    Get
    Set
Visual C++
public:
property bool hasLock {
    bool get ();
    void set (bool value);
}

See Also

OtherFileUser Class


UserName Property

[image]

Perforce .NET API
OtherFileUser..::..UserName Property
OtherFileUser Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

OtherFileUser Class


OtherUsers Class

[image]

Perforce .NET API
OtherUsers Class
Members See Also Send Feedback
Specifies other users who have a particular file open.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class OtherUsers : Dictionary<string, OtherFileUser>
Visual Basic
Public Class OtherUsers _
    Inherits Dictionary(Of String, OtherFileUser)
Visual C++
public ref class OtherUsers : public Dictionary<String^, OtherFileUser^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, OtherFileUser >)>)>
Perforce.P4..::..OtherUsers

See Also

OtherUsers Members


OtherUsers Members

[image] [image]

Perforce .NET API
OtherUsers Members
OtherUsers Class Constructors Methods Properties See Also Send Feedback

The OtherUsers type exposes the following members.

Constructors

 | Name | Description
Public method | OtherUsers | Initializes a new instance of the OtherUsers class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public property | Item |
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)

See Also

OtherUsers Class


OtherUsers Constructor

[image]

Perforce .NET API
OtherUsers Constructor
OtherUsers Class See Also Send Feedback
Initializes a new instance of the OtherUsers class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public OtherUsers()
Visual Basic
Public Sub New
Visual C++
public:
OtherUsers()

See Also

OtherUsers Class


OtherUsers Methods

[image] [image]

Perforce .NET API
OtherUsers Methods
OtherUsers Class See Also Send Feedback

The OtherUsers type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)

See Also

OtherUsers Class


OtherUsers Properties

[image] [image]

Perforce .NET API
OtherUsers Properties
OtherUsers Class See Also Send Feedback

The OtherUsers type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public property | Item |
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, OtherFileUser >)>)>.)

See Also

OtherUsers Class


Item Property

[image]

Perforce .NET API
OtherUsers..::..Item Property
OtherUsers Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public OtherFileUser this[
    string key
] { get; set; }
Visual Basic
Public Default Property Item ( _
    key As String _
) As OtherFileUser
    Get
    Set
Visual C++
public:
property OtherFileUser^ default[String^ key] {
    OtherFileUser^ get (String^ key);
    void set (String^ key, OtherFileUser^ value);
}

Parameters

key
Type: System..::..String

See Also

OtherUsers Class


P4CallBacks Class

[image]

Perforce .NET API
P4CallBacks Class
Members See Also Send Feedback
Class wrapper for the definitions of delegates required to model the callbacks from the bridge dll.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4CallBacks
Visual Basic
Public Class P4CallBacks
Visual C++
public ref class P4CallBacks

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4CallBacks

See Also

P4CallBacks Members


P4CallBacks Members

[image] [image]

Perforce .NET API
P4CallBacks Members
P4CallBacks Class Constructors Methods See Also Send Feedback

The P4CallBacks type exposes the following members.

Constructors

 | Name | Description
Public method | P4CallBacks | Initializes a new instance of the P4CallBacks class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4CallBacks Class


P4CallBacks Constructor

[image]

Perforce .NET API
P4CallBacks Constructor
P4CallBacks Class See Also Send Feedback
Initializes a new instance of the P4CallBacks class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CallBacks()
Visual Basic
Public Sub New
Visual C++
public:
P4CallBacks()

See Also

P4CallBacks Class


P4CallBacks Methods

[image] [image]

Perforce .NET API
P4CallBacks Methods
P4CallBacks Class See Also Send Feedback

The P4CallBacks type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4CallBacks Class


P4CallBacks.BinaryResultsDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..BinaryResultsDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the binary results callback.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void BinaryResultsDelegate(
    uint cmdID,
    IntPtr data,
    int count
)
Visual Basic
Public Delegate Sub BinaryResultsDelegate ( _
    cmdID As UInteger, _
    data As IntPtr, _
    count As Integer _
)
Visual C++
public delegate void BinaryResultsDelegate(
    unsigned int cmdID,
    IntPtr data,
    int count
)

Parameters

cmdID
Type: System..::..UInt32
Id if the command making the callback
data
Type: System..::..IntPtr
Binary data generated by the command
count
Type: System..::..Int32
The size in bytes of the data

Remarks

If this callback is used, the binary output generated by a command will be delivered by one or more call to the supplied delegate. It multiple calls are made, the entire output is obtained by concatenating the data from each call.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.ErrorDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..ErrorDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the error callback.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void ErrorDelegate(
    uint cmdID,
    int severity,
    int errorId,
    IntPtr info
)
Visual Basic
Public Delegate Sub ErrorDelegate ( _
    cmdID As UInteger, _
    severity As Integer, _
    errorId As Integer, _
    info As IntPtr _
)
Visual C++
public delegate void ErrorDelegate(
    unsigned int cmdID,
    int severity,
    int errorId,
    IntPtr info
)

Parameters

cmdID
Type: System..::..UInt32
Id if the command making the callback
severity
Type: System..::..Int32
Severity of the error
errorId
Type: System..::..Int32
info
Type: System..::..IntPtr
Error Message

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.InfoResultsDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..InfoResultsDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the info results callback.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void InfoResultsDelegate(
    uint cmdID,
    int msgID,
    int level,
    IntPtr info
)
Visual Basic
Public Delegate Sub InfoResultsDelegate ( _
    cmdID As UInteger, _
    msgID As Integer, _
    level As Integer, _
    info As IntPtr _
)
Visual C++
public delegate void InfoResultsDelegate(
    unsigned int cmdID,
    int msgID,
    int level,
    IntPtr info
)

Parameters

cmdID
Type: System..::..UInt32
Id of the command making the callback
msgID
Type: System..::..Int32
Unique Id of the message from the server
level
Type: System..::..Int32
info
Type: System..::..IntPtr

Remarks

The "info" results generally are the output of commands that are run not using tagged protocol

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.LogMessageDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..LogMessageDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the Logging callback from the dll.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void LogMessageDelegate(
    int log_level,
    string file,
    int line,
    string message
)
Visual Basic
Public Delegate Sub LogMessageDelegate ( _
    log_level As Integer, _
    file As String, _
    line As Integer, _
    message As String _
)
Visual C++
public delegate void LogMessageDelegate(
    int log_level,
    String^ file,
    int line,
    String^ message
)

Parameters

log_level
Type: System..::..Int32
Log Level Lower values are more serious than higher values.
file
Type: System..::..String
Name of the cpp file containing the call.
line
Type: System..::..Int32
Line number in the cpp file of the call.
message
Type: System..::..String
Descriptive message to be logged.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.PromptDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..PromptDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the prompt callback.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void PromptDelegate(
    uint cmdID,
    IntPtr msg,
    IntPtr rspBuf,
    int bufSz,
    bool dispayText
)
Visual Basic
Public Delegate Sub PromptDelegate ( _
    cmdID As UInteger, _
    msg As IntPtr, _
    rspBuf As IntPtr, _
    bufSz As Integer, _
    dispayText As Boolean _
)
Visual C++
public delegate void PromptDelegate(
    unsigned int cmdID,
    IntPtr msg,
    IntPtr rspBuf,
    int bufSz,
    bool dispayText
)

Parameters

cmdID
Type: System..::..UInt32
Id if the command making the callback
msg
Type: System..::..IntPtr
Prompt message from the server
rspBuf
Type: System..::..IntPtr
Character buffer to receive the response
bufSz
Type: System..::..Int32
Size of the buffer
dispayText
Type: System..::..Boolean
Display flog

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.ResolveADelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..ResolveADelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the Resolve callback passing a CLientResolve object.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate int ResolveADelegate(
    uint cmdID,
    IntPtr Resolver,
    bool preview
)
Visual Basic
Public Delegate Function ResolveADelegate ( _
    cmdID As UInteger, _
    Resolver As IntPtr, _
    preview As Boolean _
) As Integer
Visual C++
public delegate int ResolveADelegate(
    unsigned int cmdID,
    IntPtr Resolver,
    bool preview
)

Parameters

cmdID
Type: System..::..UInt32
Id if the command making the callback
Resolver
Type: System..::..IntPtr
P4ClientReslove used to handle the resolve
preview
Type: System..::..Boolean
Preview only

Return Value

Resolve result

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.ResolveDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..ResolveDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the Resolve callback passing a CLientMerge object.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate int ResolveDelegate(
    uint cmdID,
    IntPtr Merger
)
Visual Basic
Public Delegate Function ResolveDelegate ( _
    cmdID As UInteger, _
    Merger As IntPtr _
) As Integer
Visual C++
public delegate int ResolveDelegate(
    unsigned int cmdID,
    IntPtr Merger
)

Parameters

cmdID
Type: System..::..UInt32
Merger
Type: System..::..IntPtr
P4ClientMerge used to handle the resolve

Return Value

Resolve result

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.TaggedOutputDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..TaggedOutputDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the tagged output delegate.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void TaggedOutputDelegate(
    uint cmdID,
    int objID,
    string key,
    IntPtr value
)
Visual Basic
Public Delegate Sub TaggedOutputDelegate ( _
    cmdID As UInteger, _
    objID As Integer, _
    key As String, _
    value As IntPtr _
)
Visual C++
public delegate void TaggedOutputDelegate(
    unsigned int cmdID,
    int objID,
    String^ key,
    IntPtr value
)

Parameters

cmdID
Type: System..::..UInt32
Id if the command making the callback
objID
Type: System..::..Int32
Object ID for the object
key
Type: System..::..String
The Key of this Key:Value pair
value
Type: System..::..IntPtr
The Key of this Key:Value pair

Remarks

Each call of this delegate by the bridge provides a single Key:Value pair for the current object. When all the Key:Value pairs for an object have been sent, the bridge will make one final call with null for the values of the key and value to signify it is complete. Each object generated by a command will have an object ID that unique for that command.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CallBacks.TextResultsDelegate Delegate

[image]

Perforce .NET API
P4CallBacks..::..TextResultsDelegate Delegate
P4CallBacks Class See Also Send Feedback
Delegate definition for the text results callback.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void TextResultsDelegate(
    uint cmdID,
    IntPtr info
)
Visual Basic
Public Delegate Sub TextResultsDelegate ( _
    cmdID As UInteger, _
    info As IntPtr _
)
Visual C++
public delegate void TextResultsDelegate(
    unsigned int cmdID,
    IntPtr info
)

Parameters

cmdID
Type: System..::..UInt32
Id if the command making the callback
info
Type: System..::..IntPtr
Text output produced by the command

Remarks

If this callback is used, the text output generated by a command will be delivered by one or more call to the supplied delegate. It multiple calls are made, the entire text is obtained by concatenating the text from each call.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4CantCloseConnectionException Class

[image]

Perforce .NET API
P4CantCloseConnectionException Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4CantCloseConnectionException : P4Exception
Visual Basic
Public Class P4CantCloseConnectionException _
    Inherits P4Exception
Visual C++
public ref class P4CantCloseConnectionException : public P4Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Perforce.P4..::..P4Exception
Perforce.P4..::..P4CantCloseConnectionException

See Also

P4CantCloseConnectionException Members


P4CantCloseConnectionException Members

[image] [image]

Perforce .NET API
P4CantCloseConnectionException Members
P4CantCloseConnectionException Class Constructors Methods Properties Events See Also Send Feedback

The P4CantCloseConnectionException type exposes the following members.

Constructors

 | Name | Description
Public method | P4CantCloseConnectionException | Initializes a new instance of the P4CantCloseConnectionException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4CantCloseConnectionException Class


P4CantCloseConnectionException Constructor

[image]

Perforce .NET API
P4CantCloseConnectionException Constructor
P4CantCloseConnectionException Class See Also Send Feedback
Initializes a new instance of the P4CantCloseConnectionException class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CantCloseConnectionException()
Visual Basic
Public Sub New
Visual C++
public:
P4CantCloseConnectionException()

See Also

P4CantCloseConnectionException Class


P4CantCloseConnectionException Methods

[image] [image]

Perforce .NET API
P4CantCloseConnectionException Methods
P4CantCloseConnectionException Class See Also Send Feedback

The P4CantCloseConnectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

P4CantCloseConnectionException Class


P4CantCloseConnectionException Properties

[image] [image]

Perforce .NET API
P4CantCloseConnectionException Properties
P4CantCloseConnectionException Class See Also Send Feedback

The P4CantCloseConnectionException type exposes the following members.

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4CantCloseConnectionException Class


P4CantCloseConnectionException Events

[image] [image]

Perforce .NET API
P4CantCloseConnectionException Events
P4CantCloseConnectionException Class See Also Send Feedback

The P4CantCloseConnectionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4CantCloseConnectionException Class


P4ClientError Class

[image]

Perforce .NET API
P4ClientError Class
Members See Also Send Feedback
Class used to return a single error or warning from the bridge dll.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4ClientError
Visual Basic
Public Class P4ClientError
Visual C++
public ref class P4ClientError

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4ClientError

See Also

P4ClientError Members


P4ClientError Members

[image] [image]

Perforce .NET API
P4ClientError Members
P4ClientError Class Constructors Methods Fields See Also Send Feedback

The P4ClientError type exposes the following members.

Constructors

 | Name | Description
Public method | P4ClientError(ErrorSeverity, String) | Create a new ClientError
Public method | P4ClientError(P4Server, IntPtr) | Create a new ClientError

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorOf |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBadPasswdError |
 | IsLoginError |
 | IsSSLError |
 | IsTCPError |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Format the error in the form [ErrorLevel] Message (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
 | clientUpdate |
Public field | ErrorCode | Generic code for the error
Public field | ErrorMessage | Descriptive error message
 | MsgClient_BadFlag |
 | MsgClient_BadMarshalInput |
 | MsgClient_BadSignature |
 | MsgClient_CantEdit |
 | MsgClient_CantFindApp |
 | MsgClient_CheckFileAssume |
 | MsgClient_CheckFileAssumeWild |
 | MsgClient_CheckFileCant |
 | MsgClient_CheckFileSubst |
 | MsgClient_ClobberFile |
 | MsgClient_Confirm |
 | MsgClient_ConfirmEdit |
 | MsgClient_ConfirmMarkers |
 | MsgClient_Connect |
 | MsgClient_DigestMisMatch |
 | MsgClient_Eof |
 | MsgClient_Fatal |
 | MsgClient_FileExists |
 | MsgClient_FileOpenError |
 | MsgClient_LineTooLong |
 | MsgClient_LoginPrintTicket |
 | MsgClient_Memory |
 | MsgClient_MergeMsg2 |
 | MsgClient_MergeMsg3 |
 | MsgClient_MergeMsg32 |
 | MsgClient_MergePrompt |
 | MsgClient_MergePrompt2 |
 | MsgClient_MergePrompt2Edit |
 | MsgClient_MkDir |
 | MsgClient_NoMerger |
 | MsgClient_NonTextFileMerge |
 | MsgClient_NoSuchFile |
 | MsgClient_NotUnderPath |
 | MsgClient_ResolveManually |
 | MsgClient_ToolCmdCreate |
 | MsgClient_ToolCmdSend |
 | MsgClient_ToolServer |
 | MsgClient_ToolServer2 |
 | MsgClient_ZCResolve |
 | MsgDb_AddressChanged |
 | MsgDb_BadIPservice |
 | MsgDb_CaseMismatch |
 | MsgDb_CheckpointNoOverwrite |
 | MsgDb_Checksum |
 | MsgDb_ClientGone |
 | MsgDb_CommandCancelled |
 | MsgDb_DbOpen |
 | MsgDb_DbStat |
 | MsgDb_Delete |
 | MsgDb_DelNoLock |
 | MsgDb_Duplicate |
 | MsgDb_EndXact |
 | MsgDb_ExtraDots |
 | MsgDb_ExtraStars |
 | MsgDb_Field2Many |
 | MsgDb_FieldBadIndex |
 | MsgDb_FieldBadVal |
 | MsgDb_FieldMissing |
 | MsgDb_FieldOptBad |
 | MsgDb_FieldTypeBad |
 | MsgDb_FieldUnknown |
 | MsgDb_FieldWords |
 | MsgDb_GetFormat |
 | MsgDb_GetNoGet |
 | MsgDb_InternalUsage |
 | MsgDb_JnlBadMarker |
 | MsgDb_JnlBadVers |
 | MsgDb_JnlCaseUsageBad |
 | MsgDb_JnlDeleteFailed |
 | MsgDb_JnlEnd |
 | MsgDb_JnlFileBad |
 | MsgDb_JnlNoName |
 | MsgDb_JnlNoTVers |
 | MsgDb_JnlNoVers |
 | MsgDb_JnlNum2Big |
 | MsgDb_JnlOct2Long |
 | MsgDb_JnlOctSize |
 | MsgDb_JnlOpcode |
 | MsgDb_JnlQuoting |
 | MsgDb_JnlReplay |
 | MsgDb_JnlSeqBad |
 | MsgDb_JnlVersionError |
 | MsgDb_JnlVersionMismatch |
 | MsgDb_JnlWord2Big |
 | MsgDb_Juxtaposed |
 | MsgDb_KeyTooBig |
 | MsgDb_LicenseBad |
 | MsgDb_LicenseExp |
 | MsgDb_LicenseNeedsApplication |
 | MsgDb_LicenseRead |
 | MsgDb_LineNo |
 | MsgDb_Locking |
 | MsgDb_LockOrder |
 | MsgDb_LockUpgrade |
 | MsgDb_MapCheckFail |
 | MsgDb_MaxMemory |
 | MsgDb_MaxResults |
 | MsgDb_MaxScanRows |
 | MsgDb_MustExpire |
 | MsgDb_NoEndQuote |
 | MsgDb_NotUnderClient |
 | MsgDb_NotUnderRoot |
 | MsgDb_ParseErr |
 | MsgDb_PlatPre972 |
 | MsgDb_Read |
 | MsgDb_ReadNoLock |
 | MsgDb_Scan |
 | MsgDb_ScanFormat |
 | MsgDb_ScanNoLock |
 | MsgDb_ServerTooNew |
 | MsgDb_Stumblebum |
 | MsgDb_SupportExp |
 | MsgDb_Syntax |
 | MsgDb_TableCheckSum |
 | MsgDb_TableObsolete |
 | MsgDb_TableUnknown |
 | MsgDb_TooWild |
 | MsgDb_TooWild2 |
 | MsgDb_TreeAllocation |
 | MsgDb_TreeAlreadyUpgraded |
 | MsgDb_TreeCorrupt |
 | MsgDb_TreeInternal |
 | MsgDb_TreeNewerVersion |
 | MsgDb_TreeNotOpened |
 | MsgDb_TreeNotSupported |
 | MsgDb_TreeOlderVersion |
 | MsgDb_ValidationFoundProblems |
 | MsgDb_WildMismatch |
 | MsgDb_Write |
 | MsgDb_WriteNoLock |
 | MsgDb_WrongApp |
 | MsgDb_XactOutstandingRestart |
 | MsgDm_AddHaveVsRev |
 | MsgDm_AdminLockDataEx |
 | MsgDm_AdminLockDataSh |
 | MsgDm_AdminPasswordData |
 | MsgDm_AdminSpecData |
 | MsgDm_AlreadyCommitted |
 | MsgDm_AlreadyUnloaded |
 | MsgDm_AnnotateTooBig |
 | MsgDm_ArchiveFailed |
 | MsgDm_AtMostOne |
 | MsgDm_BadAtRev |
 | MsgDm_BadCaller |
 | MsgDm_BadChange |
 | MsgDm_BadDigest |
 | MsgDm_BadIntegFlag |
 | MsgDm_BadJobPresets |
 | MsgDm_BadJobTemplate |
 | MsgDm_BadJobView |
 | MsgDm_BadMappedFileName |
 | MsgDm_BadMaxResult |
 | MsgDm_BadMaxScanRow |
 | MsgDm_BadOpenFlag |
 | MsgDm_BadOption |
 | MsgDm_BadRevision |
 | MsgDm_BadRevPend |
 | MsgDm_BadRevRel |
 | MsgDm_BadRevSpec |
 | MsgDm_BadSequence |
 | MsgDm_BadSpecType |
 | MsgDm_BadStorageCombo |
 | MsgDm_BadTemplate |
 | MsgDm_BadTimeout |
 | MsgDm_BadType |
 | MsgDm_BadTypeAuto |
 | MsgDm_BadTypeCombo |
 | MsgDm_BadTypeMod |
 | MsgDm_BadTypePartial |
 | MsgDm_BadVersionCount |
 | MsgDm_BindingNotAllowed |
 | MsgDm_BoundToOtherServer |
 | MsgDm_BucketAdd |
 | MsgDm_BucketNoFilesToArchive |
 | MsgDm_BucketNoFilesToPurge |
 | MsgDm_BucketNoFilesToRestore |
 | MsgDm_BucketPurge |
 | MsgDm_BucketRestore |
 | MsgDm_BucketSkipBranched |
 | MsgDm_BucketSkipBucketed |
 | MsgDm_BucketSkipHead |
 | MsgDm_BucketSkipLazy |
 | MsgDm_BucketSkipType |
 | MsgDm_CachePurgeFile |
 | MsgDm_CantChangeUnloadedOpt |
 | MsgDm_CantChangeUser |
 | MsgDm_CantChangeUserType |
 | MsgDm_CantFindChange |
 | MsgDm_CantOpenHere |
 | MsgDm_ChangeCreated |
 | MsgDm_ChangeDeleteHasFiles |
 | MsgDm_ChangeDeleteHasFix |
 | MsgDm_ChangeDeleteOpen |
 | MsgDm_ChangeDeleteShelved |
 | MsgDm_ChangeDeleteSuccess |
 | MsgDm_ChangeExists |
 | MsgDm_ChangeNotOwner |
 | MsgDm_ChangeNotShelved |
 | MsgDm_ChangesData |
 | MsgDm_ChangesDataPending |
 | MsgDm_ChangeUpdated |
 | MsgDm_CheckFailed |
 | MsgDm_ClassicSwitch |
 | MsgDm_ClientBoundToServer |
 | MsgDm_ClientTooOld |
 | MsgDm_CommandCancelled |
 | MsgDm_CommittedNoPerm |
 | MsgDm_ConcurrentFileChange |
 | MsgDm_ConfigData |
 | MsgDm_ConfigWasNotSet |
 | MsgDm_CopyChangeSummary |
 | MsgDm_CopyMapSummary |
 | MsgDm_CopyMoveExTo |
 | MsgDm_CopyMoveMapFrom |
 | MsgDm_CopyMoveNoFrom |
 | MsgDm_CopyOpenTarget |
 | MsgDm_CountersData |
 | MsgDm_DbFailed |
 | MsgDm_DeleteMoved |
 | MsgDm_DepotDelete |
 | MsgDm_DepotHasStreams |
 | MsgDm_DepotMapInvalid |
 | MsgDm_DepotMissing |
 | MsgDm_DepotNoChange |
 | MsgDm_DepotNotSpec |
 | MsgDm_DepotNotStream |
 | MsgDm_DepotSave |
 | MsgDm_DepotsData |
 | MsgDm_DepotsDataExtra |
 | MsgDm_DepotSpecDup |
 | MsgDm_DepotUnloadDup |
 | MsgDm_DepotVsDomains |
 | MsgDm_DescMissing |
 | MsgDm_DescribeChange |
 | MsgDm_DescribeChangePending |
 | MsgDm_DescribeData |
 | MsgDm_DescribeDiff |
 | MsgDm_DescribeMove |
 | MsgDm_DfltBranchView |
 | MsgDm_Diff2DataContent |
 | MsgDm_Diff2DataIdentical |
 | MsgDm_Diff2DataLeft |
 | MsgDm_Diff2DataRight |
 | MsgDm_Diff2DataRightPre041 |
 | MsgDm_Diff2DataTypes |
 | MsgDm_Diff2DataUnified |
 | MsgDm_Diff2DataUnifiedDiffer |
 | MsgDm_DiffData |
 | MsgDm_DirsData |
 | MsgDm_DiskSpaceEstimated |
 | MsgDm_DiskSpaceMinimum |
 | MsgDm_DomainDelete |
 | MsgDm_DomainIsUnloaded |
 | MsgDm_DomainNoChange |
 | MsgDm_DomainSave |
 | MsgDm_DomainsData |
 | MsgDm_DomainsDataClient |
 | MsgDm_DomainSwitch |
 | MsgDm_DupExists |
 | MsgDm_DupLocked |
 | MsgDm_DupOK |
 | MsgDm_EditSpecNoChange |
 | MsgDm_EditSpecSave |
 | MsgDm_EmbSpecChar |
 | MsgDm_EmbWild |
 | MsgDm_EmptyFileName |
 | MsgDm_EmptyRelate |
 | MsgDm_EmptyResults |
 | MsgDm_ErrorInSpec |
 | MsgDm_ExABOVECHANGE |
 | MsgDm_ExABOVEDATE |
 | MsgDm_ExABOVEHAVE |
 | MsgDm_ExABOVELABEL |
 | MsgDm_ExABOVEREVISION |
 | MsgDm_ExARCHIVES |
 | MsgDm_ExATACTION |
 | MsgDm_ExATCHANGE |
 | MsgDm_ExATDATE |
 | MsgDm_ExATHAVE |
 | MsgDm_ExATLABEL |
 | MsgDm_ExATREVISION |
 | MsgDm_ExATTEXT |
 | MsgDm_ExBELOWCHANGE |
 | MsgDm_ExBELOWDATE |
 | MsgDm_ExBELOWHAVE |
 | MsgDm_ExBELOWLABEL |
 | MsgDm_ExBELOWREVISION |
 | MsgDm_ExBVIEW |
 | MsgDm_ExCHANGE |
 | MsgDm_ExDIFF |
 | MsgDm_ExDIFFPre101 |
 | MsgDm_ExDIGESTED |
 | MsgDm_ExFILE |
 | MsgDm_ExHAVE |
 | MsgDm_ExINTEGED |
 | MsgDm_ExINTEGMOVEDEL |
 | MsgDm_ExINTEGPEND |
 | MsgDm_ExINTEGPERM |
 | MsgDm_ExLABEL |
 | MsgDm_ExLABSYNC |
 | MsgDm_ExOPENALL |
 | MsgDm_ExOPENCHANGE |
 | MsgDm_ExOPENCLIENT |
 | MsgDm_ExOPENDFLT |
 | MsgDm_ExOPENNOTEDIT |
 | MsgDm_ExPROPERTY |
 | MsgDm_ExPROTECT |
 | MsgDm_ExPROTECT2 |
 | MsgDm_ExPROTNAME |
 | MsgDm_ExPROTNAME2 |
 | MsgDm_ExRESOLVED |
 | MsgDm_ExSTREAM |
 | MsgDm_ExSVIEW |
 | MsgDm_ExTOINTEG |
 | MsgDm_ExTORECONCILE |
 | MsgDm_ExTORESOLVE |
 | MsgDm_ExTORETYPE |
 | MsgDm_ExTOUNSHELVE |
 | MsgDm_ExTVIEW |
 | MsgDm_ExUNLOCKCHANGE |
 | MsgDm_ExUPTODATE |
 | MsgDm_ExUSER |
 | MsgDm_ExVIEW |
 | MsgDm_ExVIEW2 |
 | MsgDm_FieldCount |
 | MsgDm_FieldMissing |
 | MsgDm_FilelogData |
 | MsgDm_FilelogInteg |
 | MsgDm_FilelogRevDefault |
 | MsgDm_FilelogRevMessage |
 | MsgDm_FilesData |
 | MsgDm_FilesDiskUsage |
 | MsgDm_FilesDiskUsageHuman |
 | MsgDm_FilesSummary |
 | MsgDm_FilesSummaryHuman |
 | MsgDm_FiltersReplicaOnly |
 | MsgDm_FixAdd |
 | MsgDm_FixAddDefault |
 | MsgDm_FixBadVal |
 | MsgDm_FixDelete |
 | MsgDm_FixesData |
 | MsgDm_FixesDataDefault |
 | MsgDm_GrepFileOutput |
 | MsgDm_GrepLineTooLong |
 | MsgDm_GrepMaxRevs |
 | MsgDm_GrepOutput |
 | MsgDm_GrepSeparator |
 | MsgDm_GrepWithLineNumber |
 | MsgDm_GroupCreated |
 | MsgDm_GroupDeleted |
 | MsgDm_GroupExists |
 | MsgDm_GroupNotCreated |
 | MsgDm_GroupNotOwner |
 | MsgDm_GroupNotUpdated |
 | MsgDm_GroupsData |
 | MsgDm_GroupsDataVerbose |
 | MsgDm_GroupUpdated |
 | MsgDm_HaveData |
 | MsgDm_HaveVsRev |
 | MsgDm_IdEmbeddedNul |
 | MsgDm_IdEmpty |
 | MsgDm_IdHasComma |
 | MsgDm_IdHasDash |
 | MsgDm_IdHasPercent |
 | MsgDm_IdHasRev |
 | MsgDm_IdHasSlash |
 | MsgDm_IdNonPrint |
 | MsgDm_IdNullDir |
 | MsgDm_IdNumber |
 | MsgDm_IdRelPath |
 | MsgDm_IdTooLong |
 | MsgDm_IdWild |
 | MsgDm_ImportNotUnder |
 | MsgDm_InfoDomain |
 | MsgDm_InfoUnknownDomain |
 | MsgDm_IntegAlreadyOpened |
 | MsgDm_IntegBadAction |
 | MsgDm_IntegBadAncestor |
 | MsgDm_IntegBadBase |
 | MsgDm_IntegBadClient |
 | MsgDm_IntegBadUser |
 | MsgDm_IntegBaselessMove |
 | MsgDm_IntegCantAdd |
 | MsgDm_IntegCantModify |
 | MsgDm_IntegedData |
 | MsgDm_IntegIncompatable |
 | MsgDm_IntegIntoReadOnly |
 | MsgDm_IntegMovedNoAccess |
 | MsgDm_IntegMovedNoFrom |
 | MsgDm_IntegMovedNoFromS |
 | MsgDm_IntegMovedOutScope |
 | MsgDm_IntegMovedUnmapped |
 | MsgDm_IntegMustSync |
 | MsgDm_IntegNotHandled |
 | MsgDm_IntegOpenOkay |
 | MsgDm_IntegOpenOkayBase |
 | MsgDm_IntegPreviewResolve |
 | MsgDm_IntegPreviewResolved |
 | MsgDm_IntegPreviewResolveMove |
 | MsgDm_IntegSyncBranch |
 | MsgDm_IntegSyncDelete |
 | MsgDm_IntegSyncIntegBase |
 | MsgDm_IntegTooVirtual |
 | MsgDm_IntegVsRev |
 | MsgDm_IntegVsShelve |
 | MsgDm_IntegVsWork |
 | MsgDm_IntegXOpened |
 | MsgDm_InvalidEscape |
 | MsgDm_InvalidParent |
 | MsgDm_InvalidStreamFmt |
 | MsgDm_InvalidType |
 | MsgDm_JobDelete |
 | MsgDm_JobDeleteHasFix |
 | MsgDm_JobDescMissing |
 | MsgDm_JobDescription |
 | MsgDm_JobFieldAlways |
 | MsgDm_JobFieldReadOnly |
 | MsgDm_JobHasChanged |
 | MsgDm_JobName101 |
 | MsgDm_JobNameJob |
 | MsgDm_JobNameMissing |
 | MsgDm_JobNoChange |
 | MsgDm_JobSave |
 | MsgDm_LabelHasRev |
 | MsgDm_LabelLocked |
 | MsgDm_LabelLoop |
 | MsgDm_LabelNoSync |
 | MsgDm_LabelOwner |
 | MsgDm_LabelSyncAdd |
 | MsgDm_LabelSyncDelete |
 | MsgDm_LabelSyncReplace |
 | MsgDm_LabelSyncUpdate |
 | MsgDm_LameCodes |
 | MsgDm_LicensedClients |
 | MsgDm_LicensedUsers |
 | MsgDm_LicenseNoChange |
 | MsgDm_LicenseSave |
 | MsgDm_LimitBadArg |
 | MsgDm_LineTooLong |
 | MsgDm_LockAlready |
 | MsgDm_LockAlreadyOther |
 | MsgDm_LockBadUnicode |
 | MsgDm_LockedClient |
 | MsgDm_LockedDelete |
 | MsgDm_LockedHost |
 | MsgDm_LockedUpdate |
 | MsgDm_LockNoPermission |
 | MsgDm_LockSuccess |
 | MsgDm_LockUtf16NotSupp |
 | MsgDm_LocWild |
 | MsgDm_LoggerData |
 | MsgDm_ManyRevSpec |
 | MsgDm_MapNoListAccess |
 | MsgDm_MapNotUnder |
 | MsgDm_MaxLockTime |
 | MsgDm_MaxResults |
 | MsgDm_MaxScanRows |
 | MsgDm_MayNotBeNegative |
 | MsgDm_MergeBadBase |
 | MsgDm_MissingDesc |
 | MsgDm_MissingStream |
 | MsgDm_MonitorCantTerminate |
 | MsgDm_MonitorClear |
 | MsgDm_MonitorData |
 | MsgDm_MonitorPause |
 | MsgDm_MonitorResume |
 | MsgDm_MonitorTerminate |
 | MsgDm_MoveBadAction |
 | MsgDm_MoveDeleted |
 | MsgDm_MoveExists |
 | MsgDm_MoveMisMatch |
 | MsgDm_MoveNeedForce |
 | MsgDm_MoveNoInteg |
 | MsgDm_MoveNoMatch |
 | MsgDm_MoveNotResolved |
 | MsgDm_MoveNotSynced |
 | MsgDm_MoveReadOnly |
 | MsgDm_MoveSuccess |
 | MsgDm_MultiWordDefault |
 | MsgDm_MustBeNumeric |
 | MsgDm_MustForceUnloadDepot |
 | MsgDm_NameChanged |
 | MsgDm_NeedClient |
 | MsgDm_NeedJobUpgrade |
 | MsgDm_NeedsUpgrades |
 | MsgDm_NoArchive |
 | MsgDm_NoCheckin |
 | MsgDm_NoClearText |
 | MsgDm_NoClient |
 | MsgDm_NoCodeZero |
 | MsgDm_NoDefault |
 | MsgDm_NoDelete |
 | MsgDm_NoDepot |
 | MsgDm_NoDepotTypeChange |
 | MsgDm_NoIntegHavemaps |
 | MsgDm_NoIntegOverlays |
 | MsgDm_NoModComChange |
 | MsgDm_NoNextRev |
 | MsgDm_NoNotOp |
 | MsgDm_NoPerms |
 | MsgDm_NoPrevRev |
 | MsgDm_NoProtect |
 | MsgDm_NoRev |
 | MsgDm_NoRevisionOverwrite |
 | MsgDm_NoRevRange |
 | MsgDm_NoRmtInterop |
 | MsgDm_NoStreamAtChange |
 | MsgDm_NoSuchChange |
 | MsgDm_NoSuchConfig |
 | MsgDm_NoSuchCounter |
 | MsgDm_NoSuchDepot |
 | MsgDm_NoSuchDepot2 |
 | MsgDm_NoSuchDomain |
 | MsgDm_NoSuchDomain2 |
 | MsgDm_NoSuchFix |
 | MsgDm_NoSuchGroup |
 | MsgDm_NoSuchJob |
 | MsgDm_NoSuchJob2 |
 | MsgDm_NoSuchKey |
 | MsgDm_NoSuchProperty |
 | MsgDm_NoSuchRelease |
 | MsgDm_NoSuchResource |
 | MsgDm_NoSuchServer |
 | MsgDm_NoSuchServerlog |
 | MsgDm_NotAsService |
 | MsgDm_NotBoundToServer |
 | MsgDm_NotBucket |
 | MsgDm_NotClientOrLabel |
 | MsgDm_NotStreamReady |
 | MsgDm_NotThatCounter |
 | MsgDm_NotUnderClient |
 | MsgDm_NotUnderRoot |
 | MsgDm_NotUnloaded |
 | MsgDm_NoUnloadedAutoLabel |
 | MsgDm_OpenAlready |
 | MsgDm_OpenAttrRO |
 | MsgDm_OpenBadAction |
 | MsgDm_OpenBadChange |
 | MsgDm_OpenBadClient |
 | MsgDm_OpenBadType |
 | MsgDm_OpenBadUser |
 | MsgDm_OpenCantDeleted |
 | MsgDm_OpenCantExists |
 | MsgDm_OpenedData |
 | MsgDm_OpenedDataS |
 | MsgDm_OpenedDelete |
 | MsgDm_OpenedLocked |
 | MsgDm_OpenedLockedS |
 | MsgDm_OpenedOther |
 | MsgDm_OpenedOtherLocked |
 | MsgDm_OpenedOtherLockedS |
 | MsgDm_OpenedOtherS |
 | MsgDm_OpenedSwitch |
 | MsgDm_OpenedTaskSwitch |
 | MsgDm_OpenedXData |
 | MsgDm_OpenedXDataS |
 | MsgDm_OpenedXOther |
 | MsgDm_OpenedXOtherS |
 | MsgDm_OpenExclLocked |
 | MsgDm_OpenExclOrphaned |
 | MsgDm_OpenExclOther |
 | MsgDm_OpenFilesCantChange |
 | MsgDm_OpenFilesCantChangeUser |
 | MsgDm_OpenIsLocked |
 | MsgDm_OpenIsOpened |
 | MsgDm_OpenMustResolve |
 | MsgDm_OpenOtherDepot |
 | MsgDm_OpenReadOnly |
 | MsgDm_OpenReOpen |
 | MsgDm_OpenSuccess |
 | MsgDm_OpenTaskNotMapped |
 | MsgDm_OpenUpToDate |
 | MsgDm_OpenWarnChangeMap |
 | MsgDm_OpenWarnDeleted |
 | MsgDm_OpenWarnExists |
 | MsgDm_OpenWarnFileNotMapped |
 | MsgDm_OpenWarnMoved |
 | MsgDm_OpenWarnOpenNotStream |
 | MsgDm_OpenWarnOpenStream |
 | MsgDm_OpenWarnPurged |
 | MsgDm_OpenXOpened |
 | MsgDm_OpenXOpenedFailed |
 | MsgDm_OperatorNotAllowed |
 | MsgDm_OutOfSequence |
 | MsgDm_OwnerCantChange |
 | MsgDm_ParallelNotEnabled |
 | MsgDm_ParallelOptions |
 | MsgDm_Passwd982 |
 | MsgDm_PastUpgrade |
 | MsgDm_PathNotUnder |
 | MsgDm_PendingDelete |
 | MsgDm_PendingNoPerm |
 | MsgDm_PopulateDesc |
 | MsgDm_PopulateInvalidStream |
 | MsgDm_PopulateMultipleStreams |
 | MsgDm_PopulateTargetExists |
 | MsgDm_PopulateTargetMixed |
 | MsgDm_PosWild |
 | MsgDm_PropertyAllData |
 | MsgDm_PropertyData |
 | MsgDm_PropertyDataGroup |
 | MsgDm_PropertyDataUser |
 | MsgDm_ProtectedCodes |
 | MsgDm_ProtectNoChange |
 | MsgDm_ProtectSave |
 | MsgDm_ProtectsData |
 | MsgDm_ProtectsEmpty |
 | MsgDm_ProtectsMaxData |
 | MsgDm_ProtectsNoSuper |
 | MsgDm_PurgeActiveTask |
 | MsgDm_PurgeCheck |
 | MsgDm_PurgeData |
 | MsgDm_PurgeDeleted |
 | MsgDm_PurgeFirst |
 | MsgDm_PurgeNoRecords |
 | MsgDm_PurgeSnapData |
 | MsgDm_ReconcileBadName |
 | MsgDm_ReconcileNeedForce |
 | MsgDm_ReferClient |
 | MsgDm_ReleaseAbandon |
 | MsgDm_ReleaseClear |
 | MsgDm_ReleaseDelete |
 | MsgDm_ReleaseHasMoved |
 | MsgDm_ReleaseHasPending |
 | MsgDm_ReleaseNotOwner |
 | MsgDm_ReleaseRevert |
 | MsgDm_ReleaseUnlockAbandon |
 | MsgDm_ReleaseUnlockClear |
 | MsgDm_ReleaseUnlockDelete |
 | MsgDm_ReleaseUnlockRevert |
 | MsgDm_ReloadData |
 | MsgDm_ReloadFirst |
 | MsgDm_ReloadNotOwner |
 | MsgDm_ReloadSuspicious |
 | MsgDm_RemoteChangeExists |
 | MsgDm_RemoteChangeMissing |
 | MsgDm_RemoteDomainExists |
 | MsgDm_RemoteDomainMissing |
 | MsgDm_ReopenBadType |
 | MsgDm_ReopenCharSet |
 | MsgDm_ReopenData |
 | MsgDm_ReopenDataNoChange |
 | MsgDm_Resolve2WayRaw |
 | MsgDm_Resolve3WayRaw |
 | MsgDm_Resolve3WayText |
 | MsgDm_Resolve3WayTextBase |
 | MsgDm_ResolveAction |
 | MsgDm_ResolveActionMove |
 | MsgDm_ResolveCharset |
 | MsgDm_ResolveCharsetActionT |
 | MsgDm_ResolveCharsetActionY |
 | MsgDm_ResolvedAction |
 | MsgDm_ResolvedActionMove |
 | MsgDm_ResolvedData |
 | MsgDm_ResolvedDataBase |
 | MsgDm_ResolveDelete |
 | MsgDm_ResolveDoBranch |
 | MsgDm_ResolveDoBranchActionT |
 | MsgDm_ResolveDoBranchActionY |
 | MsgDm_ResolveDoDelete |
 | MsgDm_ResolveDoDeleteActionT |
 | MsgDm_ResolveDoDeleteActionY |
 | MsgDm_ResolveFiletype |
 | MsgDm_ResolveFiletypeAction |
 | MsgDm_ResolveMove |
 | MsgDm_ResolveMoveAction |
 | MsgDm_ResolveMustIgnore |
 | MsgDm_ResolveShelveDelete |
 | MsgDm_ResolveTrait |
 | MsgDm_ResolveTraitActionM |
 | MsgDm_ResolveTraitActionT |
 | MsgDm_ResolveTraitActionY |
 | MsgDm_ResourceAlreadyLocked |
 | MsgDm_RetypeData |
 | MsgDm_ReviewData |
 | MsgDm_ReviewsData |
 | MsgDm_RevVsRevCx |
 | MsgDm_RmtAddChangeFailed |
 | MsgDm_RmtAddDomainFailed |
 | MsgDm_RmtAuthFailed |
 | MsgDm_RmtDeleteChangeFailed |
 | MsgDm_RmtDeleteDomainFailed |
 | MsgDm_RmtError |
 | MsgDm_RmtExclusiveLockFailed |
 | MsgDm_RmtJournalWaitFailed |
 | MsgDm_RmtSequenceFailed |
 | MsgDm_SameCode |
 | MsgDm_SameTag |
 | MsgDm_SemiInDefault |
 | MsgDm_ServerDelete |
 | MsgDm_ServerNoChange |
 | MsgDm_ServerSave |
 | MsgDm_ServersData |
 | MsgDm_ServerTypeMismatch |
 | MsgDm_ServerViewMap |
 | MsgDm_ServiceNotProvided |
 | MsgDm_ServiceUserLogin |
 | MsgDm_ShelveCantUpdate |
 | MsgDm_ShelvedDelete |
 | MsgDm_ShelvedHasWorking |
 | MsgDm_ShelveIncompatible |
 | MsgDm_ShelveLocked |
 | MsgDm_ShelveMaxFiles |
 | MsgDm_ShelveNeedsResolve |
 | MsgDm_ShelveNoPerm |
 | MsgDm_ShelveNotChanged |
 | MsgDm_ShelveOpenResolves |
 | MsgDm_ShelveUnlocked |
 | MsgDm_SnapFirst |
 | MsgDm_SpecDeleted |
 | MsgDm_SpecNoChange |
 | MsgDm_SpecNotDefined |
 | MsgDm_SpecSave |
 | MsgDm_StatusSuccess |
 | MsgDm_StreamBadConvert |
 | MsgDm_StreamConverted |
 | MsgDm_StreamDepthErr |
 | MsgDm_StreamDoubleSlash |
 | MsgDm_StreamEndSlash |
 | MsgDm_StreamEqDepot |
 | MsgDm_StreamHasChildren |
 | MsgDm_StreamHasClients |
 | MsgDm_StreamIncompatibleC |
 | MsgDm_StreamIncompatibleP |
 | MsgDm_StreamIsMainline |
 | MsgDm_StreamIsUnloaded |
 | MsgDm_StreamIsVirtual |
 | MsgDm_StreamNested |
 | MsgDm_StreamNoConvert |
 | MsgDm_StreamNoFlow |
 | MsgDm_StreamNoReparent |
 | MsgDm_StreamNotOwner |
 | MsgDm_StreamOverflow |
 | MsgDm_StreamOwnerReq |
 | MsgDm_StreamOwnerUpdate |
 | MsgDm_StreamParentIsTask |
 | MsgDm_StreamPathRooted |
 | MsgDm_StreamPathSlash |
 | MsgDm_StreamRootErr |
 | MsgDm_StreamsData |
 | MsgDm_StreamTargetExists |
 | MsgDm_StreamVsDomains |
 | MsgDm_SubmitChanges |
 | MsgDm_SubmitMovedToDefault |
 | MsgDm_SubmitMustResolve |
 | MsgDm_SubmitNewResolve |
 | MsgDm_SubmitRefresh |
 | MsgDm_SubmitResolve |
 | MsgDm_SubmitReverted |
 | MsgDm_SubmitTransfer |
 | MsgDm_SubmitUpToDate |
 | MsgDm_SubmitWasAdd |
 | MsgDm_SubmitWasDelete |
 | MsgDm_SubmitWasDeleteCanReadd |
 | MsgDm_SyncAdd |
 | MsgDm_SyncCantDelete |
 | MsgDm_SyncCantPublishIsOpen |
 | MsgDm_SyncCantPublishOnHave |
 | MsgDm_SyncCantReplace |
 | MsgDm_SyncDelete |
 | MsgDm_SyncIndexOutOfBounds |
 | MsgDm_SyncIntegBackwards |
 | MsgDm_SyncIntegDelete |
 | MsgDm_SyncIntegUpdate |
 | MsgDm_SyncMissingMoveSource |
 | MsgDm_SyncNotSafeAdd |
 | MsgDm_SyncNotSafeDelete |
 | MsgDm_SyncNotSafeReplace |
 | MsgDm_SyncNotSafeUpdate |
 | MsgDm_SyncRefresh |
 | MsgDm_SyncReplace |
 | MsgDm_SyncResolve |
 | MsgDm_SyncUpdate |
 | MsgDm_SyncUptodate |
 | MsgDm_TheseCantChange |
 | MsgDm_TooManyClients |
 | MsgDm_TooManyCommitServers |
 | MsgDm_TooManyRoots |
 | MsgDm_TooManyUsers |
 | MsgDm_TooOld |
 | MsgDm_TraitCleared |
 | MsgDm_TraitIsOpen |
 | MsgDm_TraitNotSet |
 | MsgDm_TraitSet |
 | MsgDm_TriggerNoArchiveType |
 | MsgDm_TriggerNoChange |
 | MsgDm_TriggerNoDepotFile |
 | MsgDm_TriggerSave |
 | MsgDm_TryDelClient |
 | MsgDm_TryDelUser |
 | MsgDm_TryEvalLicense |
 | MsgDm_TwistedMap |
 | MsgDm_TypeMapNoChange |
 | MsgDm_TypeMapSave |
 | MsgDm_Unicode |
 | MsgDm_UnidentifiedServer |
 | MsgDm_UnknownReplicationMode |
 | MsgDm_UnknownReplicationTarget |
 | MsgDm_UnloadData |
 | MsgDm_UnloadDepotMissing |
 | MsgDm_UnloadNotOwner |
 | MsgDm_UnloadNotPossible |
 | MsgDm_UnLockAlready |
 | MsgDm_UnLockAlreadyOther |
 | MsgDm_UnLockSuccess |
 | MsgDm_UnshelveBadAction |
 | MsgDm_UnshelveBadAdd |
 | MsgDm_UnshelveBadClientView |
 | MsgDm_UnshelveBadEdit |
 | MsgDm_UnshelveFromRemote |
 | MsgDm_UnshelveIsLocked |
 | MsgDm_UnshelveNotTask |
 | MsgDm_UnshelveResolve |
 | MsgDm_UnshelveSuccess |
 | MsgDm_UseConfigure |
 | MsgDm_UserCantChange |
 | MsgDm_UserCantDelete |
 | MsgDm_UserDelete |
 | MsgDm_UserNoChange |
 | MsgDm_UserNotExist |
 | MsgDm_UserOrGroup |
 | MsgDm_UserSave |
 | MsgDm_UsersData |
 | MsgDm_UsersDataLong |
 | MsgDm_VerifyData |
 | MsgDm_VerifyDataProblem |
 | MsgDm_WhereData |
 | MsgDm_WildAdd |
 | MsgDm_WildAddTripleDots |
 | MsgDm_WorkingVsLocked |
 | MsgDm_WrongClient |
 | MsgDm_WrongDomain |
 | MsgDm_WrongUser |
 | MsgDm_WrongUserDelete |
 | MsgHelp_HelpAdd |
 | MsgHelp_HelpAdmin |
 | MsgHelp_HelpAdministration |
 | MsgHelp_HelpAnnotate |
 | MsgHelp_HelpArchive |
 | MsgHelp_HelpAttribute |
 | MsgHelp_HelpBranch |
 | MsgHelp_HelpBranches |
 | MsgHelp_HelpBroker |
 | MsgHelp_HelpBrowse |
 | MsgHelp_HelpBuildserver |
 | MsgHelp_HelpCachepurge |
 | MsgHelp_HelpChange |
 | MsgHelp_HelpChanges |
 | MsgHelp_HelpCharset |
 | MsgHelp_HelpClient |
 | MsgHelp_HelpClients |
 | MsgHelp_HelpCluster |
 | MsgHelp_HelpCommandments |
 | MsgHelp_HelpCommands |
 | MsgHelp_HelpConfigurables |
 | MsgHelp_HelpConfigure |
 | MsgHelp_HelpCopy |
 | MsgHelp_HelpCounter |
 | MsgHelp_HelpCounters |
 | MsgHelp_HelpCredits |
 | MsgHelp_HelpCstat |
 | MsgHelp_HelpDbpack |
 | MsgHelp_HelpDbschema |
 | MsgHelp_HelpDbstat |
 | MsgHelp_HelpDbverify |
 | MsgHelp_HelpDelete |
 | MsgHelp_HelpDepot |
 | MsgHelp_HelpDepots |
 | MsgHelp_HelpDescribe |
 | MsgHelp_HelpDiff |
 | MsgHelp_HelpDiff2 |
 | MsgHelp_HelpDirs |
 | MsgHelp_HelpDiskspace |
 | MsgHelp_HelpDistributed |
 | MsgHelp_HelpDuplicate |
 | MsgHelp_HelpEdit |
 | MsgHelp_HelpEnvironment |
 | MsgHelp_HelpExport |
 | MsgHelp_HelpFilelog |
 | MsgHelp_HelpFiles |
 | MsgHelp_HelpFiletypes |
 | MsgHelp_HelpFix |
 | MsgHelp_HelpFixes |
 | MsgHelp_HelpForwardingreplica |
 | MsgHelp_HelpFstat |
 | MsgHelp_HelpGrep |
 | MsgHelp_HelpGroup |
 | MsgHelp_HelpGroups |
 | MsgHelp_HelpHave |
 | MsgHelp_HelpHelp |
 | MsgHelp_HelpIndex |
 | MsgHelp_HelpInfo |
 | MsgHelp_HelpInteg |
 | MsgHelp_HelpInteg3 |
 | MsgHelp_HelpInteged |
 | MsgHelp_HelpInterchanges |
 | MsgHelp_HelpIstat |
 | MsgHelp_HelpJob |
 | MsgHelp_HelpJobs |
 | MsgHelp_HelpJobSpec |
 | MsgHelp_HelpJobView |
 | MsgHelp_HelpJournaldbchecksums |
 | MsgHelp_HelpJournals |
 | MsgHelp_HelpKey |
 | MsgHelp_HelpKeys |
 | MsgHelp_HelpLabel |
 | MsgHelp_HelpLabels |
 | MsgHelp_HelpLabelsync |
 | MsgHelp_HelpLegal |
 | MsgHelp_HelpLicense |
 | MsgHelp_HelpList |
 | MsgHelp_HelpLock |
 | MsgHelp_HelpLockstat |
 | MsgHelp_HelpLogappend |
 | MsgHelp_HelpLogger |
 | MsgHelp_HelpLogin |
 | MsgHelp_HelpLogout |
 | MsgHelp_HelpLogparse |
 | MsgHelp_HelpLogrotate |
 | MsgHelp_HelpLogschema |
 | MsgHelp_HelpLogstat |
 | MsgHelp_HelpLogtail |
 | MsgHelp_HelpMaxResults |
 | MsgHelp_HelpMerge |
 | MsgHelp_HelpMerge3 |
 | MsgHelp_HelpMonitor |
 | MsgHelp_HelpMove |
 | MsgHelp_HelpNetworkAddress |
 | MsgHelp_HelpObliterate |
 | MsgHelp_HelpOpened |
 | MsgHelp_HelpPasswd |
 | MsgHelp_HelpPerforce |
 | MsgHelp_HelpPing |
 | MsgHelp_HelpPopulate |
 | MsgHelp_HelpPrint |
 | MsgHelp_HelpProperty |
 | MsgHelp_HelpProtect |
 | MsgHelp_HelpProtects |
 | MsgHelp_HelpProxy |
 | MsgHelp_HelpPull |
 | MsgHelp_HelpReconcile |
 | MsgHelp_HelpReload |
 | MsgHelp_HelpRename |
 | MsgHelp_HelpRenameUser |
 | MsgHelp_HelpReopen |
 | MsgHelp_HelpReplicate |
 | MsgHelp_HelpReplication |
 | MsgHelp_HelpResolve |
 | MsgHelp_HelpResolved |
 | MsgHelp_HelpRestore |
 | MsgHelp_HelpRetype |
 | MsgHelp_HelpRevert |
 | MsgHelp_HelpReview |
 | MsgHelp_HelpReviews |
 | MsgHelp_HelpRevisions |
 | MsgHelp_HelpSearch |
 | MsgHelp_HelpServer |
 | MsgHelp_HelpServerid |
 | MsgHelp_HelpServers |
 | MsgHelp_HelpSet |
 | MsgHelp_HelpShelve |
 | MsgHelp_HelpSimple |
 | MsgHelp_HelpSizes |
 | MsgHelp_HelpSnap |
 | MsgHelp_HelpSpec |
 | MsgHelp_HelpStream |
 | MsgHelp_HelpStreamintro |
 | MsgHelp_HelpStreams |
 | MsgHelp_HelpSubmit |
 | MsgHelp_HelpSync |
 | MsgHelp_HelpTag |
 | MsgHelp_HelpTickets |
 | MsgHelp_HelpTrigger |
 | MsgHelp_HelpTriggers |
 | MsgHelp_HelpTrust |
 | MsgHelp_HelpTunables |
 | MsgHelp_HelpTypeMap |
 | MsgHelp_HelpUndoc |
 | MsgHelp_HelpUnload |
 | MsgHelp_HelpUnlock |
 | MsgHelp_HelpUnshelve |
 | MsgHelp_HelpUsage |
 | MsgHelp_HelpUser |
 | MsgHelp_HelpUsers |
 | MsgHelp_HelpVerify |
 | MsgHelp_HelpViews |
 | MsgHelp_HelpWhere |
 | MsgHelp_HelpZeroConf |
 | MsgHelp_NoHelp |
 | MsgHelp_ResolveUserHelp |
 | MsgLbr_After |
 | MsgLbr_AlreadyOpen |
 | MsgLbr_BadKeyword |
 | MsgLbr_BadType1 |
 | MsgLbr_Checkin |
 | MsgLbr_Checkout |
 | MsgLbr_Commit |
 | MsgLbr_Diff |
 | MsgLbr_Edit0 |
 | MsgLbr_Edit1 |
 | MsgLbr_Edit2 |
 | MsgLbr_Empty |
 | MsgLbr_EofAt |
 | MsgLbr_ExpDesc |
 | MsgLbr_Expect |
 | MsgLbr_ExpEof |
 | MsgLbr_ExpRev |
 | MsgLbr_ExpSemi |
 | MsgLbr_FmtLbrStat |
 | MsgLbr_FmtLbrStat2 |
 | MsgLbr_FmtLbrStat3 |
 | MsgLbr_LbrOpenFail |
 | MsgLbr_Lock |
 | MsgLbr_Loop |
 | MsgLbr_Mangled |
 | MsgLbr_MkDir |
 | MsgLbr_NoBranch |
 | MsgLbr_NoBrRev |
 | MsgLbr_NoRev |
 | MsgLbr_NoRev3 |
 | MsgLbr_NoRevDel |
 | MsgLbr_Parse |
 | MsgLbr_Purged |
 | MsgLbr_RcsTooBig |
 | MsgLbr_RevLess |
 | MsgLbr_ScriptFailed |
 | MsgLbr_TooBig |
 | MsgOs_ChmodBetrayal |
 | MsgOs_Deleted |
 | MsgOs_EmptyFork |
 | MsgOs_NameTooLong |
 | MsgOs_Net |
 | MsgOs_NetUn |
 | MsgOs_NoSuch |
 | MsgOs_Sys |
 | MsgOs_Sys2 |
 | MsgOs_SysUn |
 | MsgOs_SysUn2 |
 | MsgOs_TooMany |
 | MsgRpc_Break |
 | MsgRpc_Closed |
 | MsgRpc_HostKeyMismatch |
 | MsgRpc_HostKeyUnknown |
 | MsgRpc_Listen |
 | MsgRpc_MaxWait |
 | MsgRpc_NameResolve |
 | MsgRpc_NoPoss |
 | MsgRpc_NotP4 |
 | MsgRpc_Operat |
 | MsgRpc_PxRemoteSvrFail |
 | MsgRpc_Read |
 | MsgRpc_Reconn |
 | MsgRpc_Select |
 | MsgRpc_ServiceNoTrust |
 | MsgRpc_SslAccept |
 | MsgRpc_SslBadDir |
 | MsgRpc_SslBadFsSecurity |
 | MsgRpc_SslBadKeyFile |
 | MsgRpc_SslCertBadDates |
 | MsgRpc_SslCertGen |
 | MsgRpc_SslCfgExpire |
 | MsgRpc_SslCfgUnits |
 | MsgRpc_SslCleartext |
 | MsgRpc_SslClose |
 | MsgRpc_SslConnect |
 | MsgRpc_SslCredsBadOwner |
 | MsgRpc_SslCtx |
 | MsgRpc_SslDirHasCreds |
 | MsgRpc_SslFailGetExpire |
 | MsgRpc_SslGetPubKey |
 | MsgRpc_SslInit |
 | MsgRpc_SslInvalid |
 | MsgRpc_SslKeyNotRSA |
 | MsgRpc_SslLibMismatch |
 | MsgRpc_SslListen |
 | MsgRpc_SslNoCredentials |
 | MsgRpc_SslNoSsl |
 | MsgRpc_SslRecv |
 | MsgRpc_SslSend |
 | MsgRpc_SslShutdown |
 | MsgRpc_Stdio |
 | MsgRpc_TcpAccept |
 | MsgRpc_TcpConnect |
 | MsgRpc_TcpHost |
 | MsgRpc_TcpListen |
 | MsgRpc_TcpPeerSsl |
 | MsgRpc_TcpPortInvalid |
 | MsgRpc_TcpRecv |
 | MsgRpc_TcpSend |
 | MsgRpc_TcpService |
 | MsgRpc_TooBig |
 | MsgRpc_Unconn |
 | MsgRpc_UnixDomainOpen |
 | MsgRpc_UnReg |
 | MsgRpc_WakeupAttempt |
 | MsgRpc_WakeupInit |
 | MsgRpc_ZksDisconnect |
 | MsgRpc_ZksInit |
 | MsgRpc_ZksRecv |
 | MsgRpc_ZksSend |
 | MsgRpc_ZksState |
 | MsgServer_ActionResolve111 |
 | MsgServer_AddDelete |
 | MsgServer_AdminNoSpecDepot |
 | MsgServer_AdminNoSuchSpec |
 | MsgServer_AdminNothingLocked |
 | MsgServer_AdminNothingLogged |
 | MsgServer_AdminPasswordNoPasswords |
 | MsgServer_AdminPasswordNoSuchUser |
 | MsgServer_AdminReplicaCkp |
 | MsgServer_AdminSizeData |
 | MsgServer_AttrNoPropEdge |
 | MsgServer_BadCheckpointNum |
 | MsgServer_BadCommand |
 | MsgServer_BadExtraFlag |
 | MsgServer_BadImport |
 | MsgServer_BadIPAddr |
 | MsgServer_BadJnlFlag |
 | MsgServer_BadJournalNum |
 | MsgServer_BadPassword |
 | MsgServer_BadPassword0 |
 | MsgServer_BadPassword1 |
 | MsgServer_BadPCache |
 | MsgServer_BadRoot |
 | MsgServer_BadServicePack |
 | MsgServer_BadSortOption |
 | MsgServer_BadTransfers |
 | MsgServer_BadTriggerOutput |
 | MsgServer_BFNoOverwriteLocal |
 | MsgServer_BoundClientExists |
 | MsgServer_BoundClientServerID |
 | MsgServer_CacheAlreadyPurged |
 | MsgServer_CantAuthenticate |
 | MsgServer_CantChangeOther |
 | MsgServer_CantOpen |
 | MsgServer_CantRevertToPurged |
 | MsgServer_CantUnloadLocked |
 | MsgServer_ChangeNotLocal |
 | MsgServer_ChangeNotSubmitted |
 | MsgServer_ChangesShelved |
 | MsgServer_ClientBadHost |
 | MsgServer_ClientOpFailed |
 | MsgServer_ClientTooOld |
 | MsgServer_ClusterCannotWriteJournal |
 | MsgServer_ClusterNotAllowed |
 | MsgServer_CommandCancelled |
 | MsgServer_CommandDisabled |
 | MsgServer_CommandUnsupported |
 | MsgServer_CommunicationLoop |
 | MsgServer_ConfigureNone |
 | MsgServer_ConfigureServerNone |
 | MsgServer_ConfigureSet |
 | MsgServer_ConfigureUnSet |
 | MsgServer_ConnectBroken |
 | MsgServer_CopyDoNothing |
 | MsgServer_CopyNeedsMergeFirst |
 | MsgServer_CopyWrongDirection |
 | MsgServer_CouldntLock |
 | MsgServer_CounterDelete |
 | MsgServer_CounterGet |
 | MsgServer_CounterNotNumeric |
 | MsgServer_CounterSet |
 | MsgServer_CounterWarning |
 | MsgServer_CreatingDb |
 | MsgServer_CurJournalButNotJournaling |
 | MsgServer_DeltaLine1 |
 | MsgServer_DeltaLine2 |
 | MsgServer_DescribeAffected |
 | MsgServer_DescribeDifferences |
 | MsgServer_DescribeEmpty |
 | MsgServer_DescribeFixed |
 | MsgServer_DescribeMovedFiles |
 | MsgServer_DescribeShelved |
 | MsgServer_Diff2BadArgs |
 | MsgServer_Diff2Differ |
 | MsgServer_DiffCmp |
 | MsgServer_DiffList |
 | MsgServer_DigestMisMatch |
 | MsgServer_DirsWild |
 | MsgServer_DomainIsLocal |
 | MsgServer_DontRenameSelf |
 | MsgServer_DumpNameIsADbName |
 | MsgServer_EmptyTypeList |
 | MsgServer_ErrorInSpec |
 | MsgServer_ErrorPingParam |
 | MsgServer_ErrorPingProtocol |
 | MsgServer_ExtraIDUsage |
 | MsgServer_GotLocked |
 | MsgServer_GotUnlocked |
 | MsgServer_GotUnresolved |
 | MsgServer_GrepContextTooLarge |
 | MsgServer_GrepIllegalContext |
 | MsgServer_HandshakeFailed |
 | MsgServer_HelpSeeRename |
 | MsgServer_IllegalCommand |
 | MsgServer_ImportReport |
 | MsgServer_IndexOutput |
 | MsgServer_InfoAuthServer |
 | MsgServer_InfoBadClient |
 | MsgServer_InfoBadUser |
 | MsgServer_InfoCaseHandling |
 | MsgServer_InfoChangeServer |
 | MsgServer_InfoClient |
 | MsgServer_InfoClientAddress |
 | MsgServer_InfoClientRoot |
 | MsgServer_InfoDirectory |
 | MsgServer_InfoDiskSpace |
 | MsgServer_InfoHost |
 | MsgServer_InfoMinClient |
 | MsgServer_InfoPeerAddress |
 | MsgServer_InfoPingCount |
 | MsgServer_InfoPingCountB |
 | MsgServer_InfoPingTime |
 | MsgServer_InfoPingTimeB |
 | MsgServer_InfoProxyAddress |
 | MsgServer_InfoProxyCertExpire |
 | MsgServer_InfoProxyEncryption |
 | MsgServer_InfoProxyVersion |
 | MsgServer_InfoServerAddress |
 | MsgServer_InfoServerCertExpire |
 | MsgServer_InfoServerDate |
 | MsgServer_InfoServerEncryption |
 | MsgServer_InfoServerID |
 | MsgServer_InfoServerLicense |
 | MsgServer_InfoServerLicenseIp |
 | MsgServer_InfoServerRoot |
 | MsgServer_InfoServerUptime |
 | MsgServer_InfoServerVersion |
 | MsgServer_InfoStream |
 | MsgServer_InfoUnknownClient |
 | MsgServer_InfoUser |
 | MsgServer_InsecureReplica |
 | MsgServer_IntegIsTask |
 | MsgServer_InvalidConfigValue |
 | MsgServer_InvalidNesting |
 | MsgServer_InvalidServerChain |
 | MsgServer_InvalidStartupCommand |
 | MsgServer_IstatInvalid |
 | MsgServer_JobRebuilt |
 | MsgServer_Jobs982Win |
 | MsgServer_JobsDashS |
 | MsgServer_JournalCounterMismatch |
 | MsgServer_JournalFilterBad |
 | MsgServer_JournalorCheckpointRequired |
 | MsgServer_KeyDelete |
 | MsgServer_KeyNotNumeric |
 | MsgServer_KeySet |
 | MsgServer_LbrCheckin |
 | MsgServer_LbrCheckout |
 | MsgServer_LbrDiff |
 | MsgServer_LbrDigest |
 | MsgServer_LbrFileSize |
 | MsgServer_LbrMerge |
 | MsgServer_LbrNoTrigger |
 | MsgServer_LogCommand |
 | MsgServer_LogEstimates |
 | MsgServer_LoggedOut |
 | MsgServer_Login032 |
 | MsgServer_Login042 |
 | MsgServer_Login072 |
 | MsgServer_LoginExpired |
 | MsgServer_LoginGoodTill |
 | MsgServer_LoginNoTicket |
 | MsgServer_LoginNotRequired |
 | MsgServer_LoginPrintTicket |
 | MsgServer_LoginUser |
 | MsgServer_LogoutUser |
 | MsgServer_LogtailNoLog |
 | MsgServer_MaxLicensedFiles |
 | MsgServer_MaxUnLicensedFiles |
 | MsgServer_MergesPending |
 | MsgServer_MergeWrongDirection |
 | MsgServer_MetaDumpFailed |
 | MsgServer_MimAttack |
 | MsgServer_MissingReplicationMode |
 | MsgServer_MonitorBadId |
 | MsgServer_MonitorDisabled |
 | MsgServer_MonitorNoLockinfo |
 | MsgServer_Move091 |
 | MsgServer_Move101 |
 | MsgServer_MoveRejected |
 | MsgServer_MustSetPassword |
 | MsgServer_NeedFilePath |
 | MsgServer_NewUserExists |
 | MsgServer_NewUserHasChanges |
 | MsgServer_NewUserHasDomains |
 | MsgServer_No973Wingui |
 | MsgServer_NoAuthFileCount |
 | MsgServer_NoAuthServiceOnly |
 | MsgServer_NoCentralLicense |
 | MsgServer_NoCkptName |
 | MsgServer_NoClearText |
 | MsgServer_NoCustomSpec |
 | MsgServer_NoDefaultShelve |
 | MsgServer_NoDefaultSubmit |
 | MsgServer_NoDumpName |
 | MsgServer_NoInteg |
 | MsgServer_NoProxyAuth |
 | MsgServer_NoReparentingTask |
 | MsgServer_NoServerID |
 | MsgServer_NoShelve |
 | MsgServer_NoShelveDelete |
 | MsgServer_NoSubmit |
 | MsgServer_NoSuchField |
 | MsgServer_NoSuchTransfer |
 | MsgServer_NoSuchUser |
 | MsgServer_NoSuppASflag |
 | MsgServer_NoSuppVflag |
 | MsgServer_NotACommitServer |
 | MsgServer_NotAsService |
 | MsgServer_NotClusterMaster |
 | MsgServer_NotClusterReplica |
 | MsgServer_NotClusterService |
 | MsgServer_NotDistributed |
 | MsgServer_NotEdgeLocal |
 | MsgServer_NoTicketSupport |
 | MsgServer_NotInCluster |
 | MsgServer_NotStreamOwner |
 | MsgServer_NotStreamReady |
 | MsgServer_NotThisConfigVar |
 | MsgServer_NoUserLogs |
 | MsgServer_NoValidLicense |
 | MsgServer_OldDiffClient |
 | MsgServer_OldReconcileClient |
 | MsgServer_OnlyOneFilter |
 | MsgServer_OperationDate |
 | MsgServer_OperationFailed |
 | MsgServer_P4TARGETWasSet |
 | MsgServer_Password032 |
 | MsgServer_Password982 |
 | MsgServer_Password991 |
 | MsgServer_PasswordDelete |
 | MsgServer_PasswordExpired |
 | MsgServer_PasswordNoChange |
 | MsgServer_PasswordSave |
 | MsgServer_PasswordTooLong |
 | MsgServer_PasswordTooShort |
 | MsgServer_PasswordTooShort2 |
 | MsgServer_PasswordTooSimple |
 | MsgServer_PopulateAborted |
 | MsgServer_PopulateComplete |
 | MsgServer_PopulateIsVirtual |
 | MsgServer_PortMissing |
 | MsgServer_PropertyAdd |
 | MsgServer_PropertyDelete |
 | MsgServer_ProxyChain |
 | MsgServer_ProxyDelivered |
 | MsgServer_ProxyNoRemote |
 | MsgServer_ProxyUpdateFail |
 | MsgServer_PullCommandRunning |
 | MsgServer_PullJournalDate |
 | MsgServer_PullJournalSummary |
 | MsgServer_PullNotReplica |
 | MsgServer_PullOnDemand |
 | MsgServer_PullTransferChange |
 | MsgServer_PullTransferPending |
 | MsgServer_PullTransferSummary |
 | MsgServer_PurgeBadOption |
 | MsgServer_PurgeOptGone |
 | MsgServer_PurgeReport |
 | MsgServer_PurgeWarning |
 | MsgServer_QuiesceFailed |
 | MsgServer_Quiescing |
 | MsgServer_ReDowngrade |
 | MsgServer_RemoteInvalidCmd |
 | MsgServer_RemoteNotAllowed |
 | MsgServer_ReopenNotOwnerCL |
 | MsgServer_ReplicaBadOption |
 | MsgServer_ReplicaNoUpgrade |
 | MsgServer_ReplicaRestricted |
 | MsgServer_ReplicaServerTime |
 | MsgServer_ReplicaWrongClient |
 | MsgServer_ReplicaWrongLabel |
 | MsgServer_ReplicaWrongServer |
 | MsgServer_ReplicaXferFailed |
 | MsgServer_RequiresJournaling |
 | MsgServer_ResolvedFile |
 | MsgServer_ResolvedSkipped |
 | MsgServer_ResolveOptAuto |
 | MsgServer_ResolveOptHelp |
 | MsgServer_ResolveOptMerge |
 | MsgServer_ResolveOptSkip |
 | MsgServer_ResolveOptTheirs |
 | MsgServer_ResolveOptYours |
 | MsgServer_ResolveOrRevert |
 | MsgServer_ResolvePromptMerge |
 | MsgServer_ResolvePromptTheirs |
 | MsgServer_ResolvePromptType |
 | MsgServer_ResolvePromptYours |
 | MsgServer_ResolveTampered |
 | MsgServer_ResolveUserError |
 | MsgServer_ResolveUserPrompt |
 | MsgServer_ResolveUserPrompt2 |
 | MsgServer_Restarted |
 | MsgServer_Restarting |
 | MsgServer_RetypeInvalidTempobj |
 | MsgServer_RmtAuthFailed |
 | MsgServer_SearchResult |
 | MsgServer_ServerID |
 | MsgServer_ServerIDAlreadySet |
 | MsgServer_ServerTooOld |
 | MsgServer_ServiceNotProvided |
 | MsgServer_ShelveAborted |
 | MsgServer_ShelveBegin |
 | MsgServer_ShelveComplete |
 | MsgServer_ShelveDelete |
 | MsgServer_ShelveMaxSize |
 | MsgServer_ShelveTriggersFailed |
 | MsgServer_ShelveXOpen |
 | MsgServer_Shutdown |
 | MsgServer_SkippedJnls |
 | MsgServer_SnapReport |
 | MsgServer_SpecArchiveWarning |
 | MsgServer_SpecCheckTriggers |
 | MsgServer_SpecNotCorrect |
 | MsgServer_SSOfailed |
 | MsgServer_SSOInvalid |
 | MsgServer_SSONoEnv |
 | MsgServer_Startup |
 | MsgServer_StartupCommandError |
 | MsgServer_SubmitAborted |
 | MsgServer_SubmitBegin |
 | MsgServer_SubmitComplete |
 | MsgServer_SubmitDataChanged |
 | MsgServer_SubmitFailed |
 | MsgServer_SubmitIsShelved |
 | MsgServer_SubmitLocking |
 | MsgServer_SubmitNeedsShelved |
 | MsgServer_SubmitRenamed |
 | MsgServer_SubmitShelvedAborted |
 | MsgServer_SubmitShelvedFailed |
 | MsgServer_SubmitShelvedHasTask |
 | MsgServer_SubmitTampered |
 | MsgServer_TargetAccessFailed |
 | MsgServer_TemporaryLabelInfo |
 | MsgServer_TicketOnly |
 | MsgServer_TooManyCommands |
 | MsgServer_TooManySortTraits |
 | MsgServer_TrackCommand |
 | MsgServer_TransferCancelled |
 | MsgServer_TransferNotReplica |
 | MsgServer_TriggerFailed |
 | MsgServer_TriggerOutput |
 | MsgServer_TriggersFailed |
 | MsgServer_TZMismatch |
 | MsgServer_Unicode |
 | MsgServer_Unicode2 |
 | MsgServer_UnknownReplicationMode |
 | MsgServer_UnknownReplicationTarget |
 | MsgServer_Unlicensed |
 | MsgServer_UnloadDepotMissing |
 | MsgServer_UnloadOtherUser |
 | MsgServer_UnshelveFileChanged |
 | MsgServer_UnshelveNotOwner |
 | MsgServer_Usage |
 | MsgServer_UseAdmin |
 | MsgServer_UseAdminCheckpoint |
 | MsgServer_UseAdminCopyin |
 | MsgServer_UseAdminCopyout |
 | MsgServer_UseAdminDBSigs |
 | MsgServer_UseAdminImport |
 | MsgServer_UseAdminJournal |
 | MsgServer_UseAdminResetPassword |
 | MsgServer_UseAdminSpecDepot |
 | MsgServer_UseAnnotate |
 | MsgServer_UseArchive |
 | MsgServer_UseBranch |
 | MsgServer_UseBranchd |
 | MsgServer_UseBranches |
 | MsgServer_UseBranchi |
 | MsgServer_UseBrancho |
 | MsgServer_UseCachepurge |
 | MsgServer_UseChange |
 | MsgServer_UseChanged |
 | MsgServer_UseChangei |
 | MsgServer_UseChangeo |
 | MsgServer_UseChanges |
 | MsgServer_UseChanget |
 | MsgServer_UseChangeU |
 | MsgServer_UseChangeUt |
 | MsgServer_UseClean |
 | MsgServer_UseClient |
 | MsgServer_UseClientd |
 | MsgServer_UseClienti |
 | MsgServer_UseCliento |
 | MsgServer_UseClients |
 | MsgServer_UseClientS |
 | MsgServer_UseCluster |
 | MsgServer_UseConfigure |
 | MsgServer_UseCopy |
 | MsgServer_UseCopyb |
 | MsgServer_UseCopyS |
 | MsgServer_UseCounter |
 | MsgServer_UseCounteri |
 | MsgServer_UseCounters |
 | MsgServer_UseCstat |
 | MsgServer_UseDbpack |
 | MsgServer_UseDbstat |
 | MsgServer_UseDbverify |
 | MsgServer_UseDepot |
 | MsgServer_UseDepotd |
 | MsgServer_UseDepoti |
 | MsgServer_UseDepoto |
 | MsgServer_UseDepots |
 | MsgServer_UseDescribe |
 | MsgServer_UseDiff |
 | MsgServer_UseDiff2 |
 | MsgServer_UseDiff2b |
 | MsgServer_UseDiff2n |
 | MsgServer_UseDiff2S |
 | MsgServer_UseDirs |
 | MsgServer_UseDiskspace |
 | MsgServer_UseDomainClients |
 | MsgServer_UseDomains |
 | MsgServer_UseDup |
 | MsgServer_UseExport |
 | MsgServer_UseFilelog |
 | MsgServer_UseFiles |
 | MsgServer_UseFix |
 | MsgServer_UseFixes |
 | MsgServer_UseFstat |
 | MsgServer_UseGrep |
 | MsgServer_UseGroup |
 | MsgServer_UseGroupd |
 | MsgServer_UseGroupi |
 | MsgServer_UseGroupo |
 | MsgServer_UseGroups |
 | MsgServer_UseHave |
 | MsgServer_UseHelp |
 | MsgServer_UseIndex |
 | MsgServer_UseInfo |
 | MsgServer_UseInteg |
 | MsgServer_UseIntegb |
 | MsgServer_UseInteged |
 | MsgServer_UseIntegS |
 | MsgServer_UseInterChanges |
 | MsgServer_UseInterChangesb |
 | MsgServer_UseInterChangesS |
 | MsgServer_UseIstat |
 | MsgServer_UseJob |
 | MsgServer_UseJobd |
 | MsgServer_UseJobi |
 | MsgServer_UseJobo |
 | MsgServer_UseJobs |
 | MsgServer_UseJobSpec |
 | MsgServer_UseJournals |
 | MsgServer_UseJournalWait |
 | MsgServer_UseKey |
 | MsgServer_UseKeyi |
 | MsgServer_UseKeys |
 | MsgServer_UseLabel |
 | MsgServer_UseLabeld |
 | MsgServer_UseLabeli |
 | MsgServer_UseLabelo |
 | MsgServer_UseLabels |
 | MsgServer_UseLabelSync |
 | MsgServer_UseLicense |
 | MsgServer_UseList |
 | MsgServer_UseLock |
 | MsgServer_UseLockstat |
 | MsgServer_UseLogAppend |
 | MsgServer_UseLogger |
 | MsgServer_UseLogin |
 | MsgServer_UseLogout |
 | MsgServer_UseLogParse |
 | MsgServer_UseLogRotate |
 | MsgServer_UseLogSchema |
 | MsgServer_UseLogstat |
 | MsgServer_UseLogtail |
 | MsgServer_UseMain |
 | MsgServer_UseMerge |
 | MsgServer_UseMergeb |
 | MsgServer_UseMergeS |
 | MsgServer_UseMonitor |
 | MsgServer_UseMonitorc |
 | MsgServer_UseMonitorf |
 | MsgServer_UseMonitorP |
 | MsgServer_UseMonitorR |
 | MsgServer_UseMonitors |
 | MsgServer_UseMove |
 | MsgServer_UseOpen |
 | MsgServer_UseOpen2 |
 | MsgServer_UseOpened |
 | MsgServer_UseOpened2 |
 | MsgServer_UsePasswd |
 | MsgServer_UsePing |
 | MsgServer_UsePopulate |
 | MsgServer_UsePopulateb |
 | MsgServer_UsePopulateS |
 | MsgServer_UsePrint |
 | MsgServer_UseProperty |
 | MsgServer_UseProtect |
 | MsgServer_UseProtects |
 | MsgServer_UseProxy |
 | MsgServer_UseProxyInfo |
 | MsgServer_UsePull |
 | MsgServer_UsePurge |
 | MsgServer_UseReconcile |
 | MsgServer_UseRelease |
 | MsgServer_UseReload |
 | MsgServer_UseRenameUser |
 | MsgServer_UseReopen |
 | MsgServer_UseResolve |
 | MsgServer_UseResolved |
 | MsgServer_UseRestore |
 | MsgServer_UseRetype |
 | MsgServer_UseReview |
 | MsgServer_UseReviews |
 | MsgServer_UserRenamed |
 | MsgServer_UsersCRNotBoth |
 | MsgServer_UsersCRNotReplica |
 | MsgServer_UseSearch |
 | MsgServer_UseServer |
 | MsgServer_UseServerd |
 | MsgServer_UseServeri |
 | MsgServer_UseServerid |
 | MsgServer_UseServero |
 | MsgServer_UseServers |
 | MsgServer_UseShelve |
 | MsgServer_UseShelvec |
 | MsgServer_UseShelvei |
 | MsgServer_UseShelveNoOpts |
 | MsgServer_UseShelver |
 | MsgServer_UseSizes |
 | MsgServer_UseSnap |
 | MsgServer_UseSpec |
 | MsgServer_UseStatus |
 | MsgServer_UseStream |
 | MsgServer_UseStreamc |
 | MsgServer_UseStreamd |
 | MsgServer_UseStreami |
 | MsgServer_UseStreamo |
 | MsgServer_UseStreams |
 | MsgServer_UseSubmit |
 | MsgServer_UseSubmitc |
 | MsgServer_UseSubmitd |
 | MsgServer_UseSubmite |
 | MsgServer_UseSync |
 | MsgServer_UseSyncp |
 | MsgServer_UseSyncs |
 | MsgServer_UseTag |
 | MsgServer_UseTrait |
 | MsgServer_UseTraiti |
 | MsgServer_UseTransmit |
 | MsgServer_UseTriggers |
 | MsgServer_UseTunables |
 | MsgServer_UseTypeMap |
 | MsgServer_UseUnload |
 | MsgServer_UseUnlock |
 | MsgServer_UseUnshelve |
 | MsgServer_UseUser |
 | MsgServer_UseUserd |
 | MsgServer_UseUseri |
 | MsgServer_UseUsero |
 | MsgServer_UseUsers |
 | MsgServer_UseVerify |
 | MsgServer_UseWhere |
 | MsgServer_VersionedStream |
 | MsgServer_WeakPassword |
 | MsgServer_ZFlagsConflict |
 | MsgSpec_SpecBranch |
 | MsgSpec_SpecChange |
 | MsgSpec_SpecClient |
 | MsgSpec_SpecDepot |
 | MsgSpec_SpecEditSpec |
 | MsgSpec_SpecGroup |
 | MsgSpec_SpecJob |
 | MsgSpec_SpecLabel |
 | MsgSpec_SpecLicense |
 | MsgSpec_SpecProtect |
 | MsgSpec_SpecServer |
 | MsgSpec_SpecStream |
 | MsgSpec_SpecTrigger |
 | MsgSpec_SpecTypeMap |
 | MsgSpec_SpecUser |
 | MsgSupp_BadMangleParams |
 | MsgSupp_BadOS |
 | MsgSupp_ConvertFailed |
 | MsgSupp_Deflate |
 | MsgSupp_DeflateEnd |
 | MsgSupp_DeflateInit |
 | MsgSupp_ExtraArg |
 | MsgSupp_HidesVar |
 | MsgSupp_Inflate |
 | MsgSupp_InflateInit |
 | MsgSupp_Invalid |
 | MsgSupp_InvalidCharset |
 | MsgSupp_InvalidDate |
 | MsgSupp_MagicHeader |
 | MsgSupp_Needs2Arg |
 | MsgSupp_NeedsArg |
 | MsgSupp_NeedsNonNegArg |
 | MsgSupp_NoP4Config |
 | MsgSupp_NoParm |
 | MsgSupp_NoSuchVariable |
 | MsgSupp_NotImplemented |
 | MsgSupp_NoTrans |
 | MsgSupp_NoTransVar |
 | MsgSupp_NoUnixReg |
 | MsgSupp_OptionAcceptFlags |
 | MsgSupp_OptionAdministrator |
 | MsgSupp_OptionAfterContext |
 | MsgSupp_OptionAll |
 | MsgSupp_OptionAllClients |
 | MsgSupp_OptionAllUsers |
 | MsgSupp_OptionAppend |
 | MsgSupp_OptionArchive |
 | MsgSupp_OptionArchiveData |
 | MsgSupp_OptionArguments |
 | MsgSupp_OptionAttrPattern |
 | MsgSupp_OptionBackoff |
 | MsgSupp_OptionBasicRegexp |
 | MsgSupp_OptionBatchsize |
 | MsgSupp_OptionBeforeContext |
 | MsgSupp_OptionBinaryAsText |
 | MsgSupp_OptionBlocksize |
 | MsgSupp_OptionBranch |
 | MsgSupp_OptionBrief |
 | MsgSupp_OptionBypassFlow |
 | MsgSupp_OptionCentralUsers |
 | MsgSupp_OptionChange |
 | MsgSupp_OptionChangeStatus |
 | MsgSupp_OptionChangeType |
 | MsgSupp_OptionChangeUpdate |
 | MsgSupp_OptionChangeUser |
 | MsgSupp_OptionCharset |
 | MsgSupp_OptionCheckSize |
 | MsgSupp_OptionClient |
 | MsgSupp_OptionClientName |
 | MsgSupp_OptionCmdCharset |
 | MsgSupp_OptionCompress |
 | MsgSupp_OptionCompressCkp |
 | MsgSupp_OptionContent |
 | MsgSupp_OptionContext |
 | MsgSupp_OptionCounter |
 | MsgSupp_OptionData |
 | MsgSupp_OptionDate |
 | MsgSupp_OptionDelete |
 | MsgSupp_OptionDeleteFlags |
 | MsgSupp_OptionDepot |
 | MsgSupp_OptionDescription |
 | MsgSupp_OptionDiffFlags |
 | MsgSupp_OptionDiffListFlag |
 | MsgSupp_OptionDirectory |
 | MsgSupp_OptionDowngrade |
 | MsgSupp_OptionEncoded |
 | MsgSupp_OptionEnvironment |
 | MsgSupp_OptionEqual |
 | MsgSupp_OptionEstimates |
 | MsgSupp_OptionExcludeTables |
 | MsgSupp_OptionExclusive |
 | MsgSupp_OptionExists |
 | MsgSupp_OptionExpression |
 | MsgSupp_OptionExtendedRegexp |
 | MsgSupp_OptionFile |
 | MsgSupp_OptionFileCharset |
 | MsgSupp_OptionFilesWithMatches |
 | MsgSupp_OptionFilesWithoutMatch |
 | MsgSupp_OptionFiletype |
 | MsgSupp_OptionFilter |
 | MsgSupp_OptionFixedStrings |
 | MsgSupp_OptionFixStatus |
 | MsgSupp_OptionFollowBranch |
 | MsgSupp_OptionFollowInteg |
 | MsgSupp_OptionForce |
 | MsgSupp_OptionForceFlag |
 | MsgSupp_OptionForceText |
 | MsgSupp_OptionFrom |
 | MsgSupp_OptionFullBranch |
 | MsgSupp_OptionGenerate |
 | MsgSupp_OptionGlobal |
 | MsgSupp_OptionGroupName |
 | MsgSupp_OptionHelp |
 | MsgSupp_OptionHistogram |
 | MsgSupp_OptionHost |
 | MsgSupp_OptionHostName |
 | MsgSupp_OptionHuman1000 |
 | MsgSupp_OptionHuman1024 |
 | MsgSupp_OptionIgnoreCase |
 | MsgSupp_OptionIncrement |
 | MsgSupp_OptionInherited |
 | MsgSupp_OptionInput |
 | MsgSupp_OptionInputFile |
 | MsgSupp_OptionInputValue |
 | MsgSupp_OptionIntegFlags |
 | MsgSupp_OptionInvertMatch |
 | MsgSupp_OptionIsGroup |
 | MsgSupp_OptionIsOwner |
 | MsgSupp_OptionIsUser |
 | MsgSupp_OptionJob |
 | MsgSupp_OptionJournalPosition |
 | MsgSupp_OptionJournalPrefix |
 | MsgSupp_OptionKeepClient |
 | MsgSupp_OptionKeepHave |
 | MsgSupp_OptionKeepHead |
 | MsgSupp_OptionLabelName |
 | MsgSupp_OptionLeaveKeywords |
 | MsgSupp_OptionLimitClient |
 | MsgSupp_OptionLineNumber |
 | MsgSupp_OptionLocal |
 | MsgSupp_OptionLocked |
 | MsgSupp_OptionLoginStatus |
 | MsgSupp_OptionLogName |
 | MsgSupp_OptionLong |
 | MsgSupp_OptionMax |
 | MsgSupp_OptionMaxAccess |
 | MsgSupp_OptionMessageType |
 | MsgSupp_OptionName |
 | MsgSupp_OptionNo |
 | MsgSupp_OptionNoArchive |
 | MsgSupp_OptionNoCaseExpr |
 | MsgSupp_OptionNoIgnore |
 | MsgSupp_OptionNoMessages |
 | MsgSupp_OptionNoRejournal |
 | MsgSupp_OptionOmitLazy |
 | MsgSupp_OptionOmitMoved |
 | MsgSupp_OptionOmitPromoted |
 | MsgSupp_OptionOpenAdd |
 | MsgSupp_OptionOpenDelete |
 | MsgSupp_OptionOpenEdit |
 | MsgSupp_OptionOriginal |
 | MsgSupp_OptionOutput |
 | MsgSupp_OptionOutputBase |
 | MsgSupp_OptionOutputFile |
 | MsgSupp_OptionOutputFlags |
 | MsgSupp_OptionOwner |
 | MsgSupp_OptionParallel |
 | MsgSupp_OptionParent |
 | MsgSupp_OptionPassword |
 | MsgSupp_OptionPerlRegexp |
 | MsgSupp_OptionPidFile |
 | MsgSupp_OptionPort |
 | MsgSupp_OptionPreview |
 | MsgSupp_OptionPreviewNC |
 | MsgSupp_OptionPrint |
 | MsgSupp_OptionProgress |
 | MsgSupp_OptionPromote |
 | MsgSupp_OptionPropagating |
 | MsgSupp_OptionPublish |
 | MsgSupp_OptionPullServerid |
 | MsgSupp_OptionPurge |
 | MsgSupp_OptionQuiet |
 | MsgSupp_OptionRebuild |
 | MsgSupp_OptionRegexp |
 | MsgSupp_OptionReopen |
 | MsgSupp_OptionRepeat |
 | MsgSupp_OptionReplace |
 | MsgSupp_OptionReplacement |
 | MsgSupp_OptionReplicaUsers |
 | MsgSupp_OptionResolveFlags |
 | MsgSupp_OptionRestrictFlags |
 | MsgSupp_OptionRetries |
 | MsgSupp_OptionReverse |
 | MsgSupp_OptionRevision |
 | MsgSupp_OptionRunOnMaster |
 | MsgSupp_OptionSafe |
 | MsgSupp_OptionSequence |
 | MsgSupp_OptionServerid |
 | MsgSupp_OptionService |
 | MsgSupp_OptionShelf |
 | MsgSupp_OptionShelved |
 | MsgSupp_OptionShelveOpts |
 | MsgSupp_OptionShort |
 | MsgSupp_OptionShowChange |
 | MsgSupp_OptionShowFiles |
 | MsgSupp_OptionShowFlags |
 | MsgSupp_OptionShowTime |
 | MsgSupp_OptionSortFlags |
 | MsgSupp_OptionSourceFile |
 | MsgSupp_OptionSpecFixStatus |
 | MsgSupp_OptionSpecType |
 | MsgSupp_OptionStartPosition |
 | MsgSupp_OptionStatus |
 | MsgSupp_OptionStream |
 | MsgSupp_OptionStreamName |
 | MsgSupp_OptionStreamType |
 | MsgSupp_OptionSubmitOpts |
 | MsgSupp_OptionSubmitShelf |
 | MsgSupp_OptionSummary |
 | MsgSupp_OptionSwitch |
 | MsgSupp_OptionSystem |
 | MsgSupp_OptionTableName |
 | MsgSupp_OptionTableNotUnlocked |
 | MsgSupp_OptionTags |
 | MsgSupp_OptionTamper |
 | MsgSupp_OptionTaskStatus |
 | MsgSupp_OptionTemplate |
 | MsgSupp_OptionTemporary |
 | MsgSupp_OptionTo |
 | MsgSupp_OptionTransfer |
 | MsgSupp_OptionUnchanged |
 | MsgSupp_OptionUnified |
 | MsgSupp_OptionUnload |
 | MsgSupp_OptionUnloadAll |
 | MsgSupp_OptionUpdate |
 | MsgSupp_OptionUsage |
 | MsgSupp_OptionUseList |
 | MsgSupp_OptionUseModTime |
 | MsgSupp_OptionUser |
 | MsgSupp_OptionValue |
 | MsgSupp_OptionVariable |
 | MsgSupp_OptionVerbose |
 | MsgSupp_OptionVerify |
 | MsgSupp_OptionVersion |
 | MsgSupp_OptionVirtual |
 | MsgSupp_OptionVirtualStream |
 | MsgSupp_OptionWipe |
 | MsgSupp_OptionXargs |
 | MsgSupp_OptionYes |
 | MsgSupp_PartialChar |
 | MsgSupp_RegexError |
 | MsgSupp_TooMany |
 | MsgSupp_Usage |
 | MsgSupp_VariableData |
 | MsgSupp_WrongArg |
 | MsgSupp_ZCBrowseFailed |
 | MsgSupp_ZCInvalidName |
 | MsgSupp_ZCLoadLibFailed |
 | MsgSupp_ZCNameConflict |
 | MsgSupp_ZCRegistryFailed |
 | MsgSupp_ZCRequireName |
Public field | SeverityLevel | How severe is the error
 | usage |
 | Usage |

See Also

P4ClientError Class


P4ClientError Constructor

[image] [image]

Perforce .NET API
P4ClientError Constructor
P4ClientError Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4ClientError(ErrorSeverity, String) | Create a new ClientError
Public method | P4ClientError(P4Server, IntPtr) | Create a new ClientError

See Also

P4ClientError Class
P4ClientError Members


P4ClientError Constructor (ErrorSeverity, String)

[image]

Perforce .NET API
P4ClientError Constructor (ErrorSeverity, String)
P4ClientError Class See Also Send Feedback
Create a new ClientError

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientError(
    ErrorSeverity severityLevel,
    string errorMessage
)
Visual Basic
Public Sub New ( _
    severityLevel As ErrorSeverity, _
    errorMessage As String _
)
Visual C++
public:
P4ClientError(
    ErrorSeverity severityLevel,
    String^ errorMessage
)

Parameters

severityLevel
Type: Perforce.P4..::..ErrorSeverity
errorMessage
Type: System..::..String

See Also

P4ClientError Class
P4ClientError Overload


P4ClientError Constructor (P4Server, IntPtr)

[image]

Perforce .NET API
P4ClientError Constructor (P4Server, IntPtr)
P4ClientError Class See Also Send Feedback
Create a new ClientError

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientError(
    P4Server p4Server,
    IntPtr pErr
)
Visual Basic
Public Sub New ( _
    p4Server As P4Server, _
    pErr As IntPtr _
)
Visual C++
public:
P4ClientError(
    P4Server^ p4Server,
    IntPtr pErr
)

Parameters

p4Server
Type: Perforce.P4..::..P4Server
pErr
Type: System..::..IntPtr

See Also

P4ClientError Class
P4ClientError Overload


P4ClientError Fields

[image] [image]

Perforce .NET API
P4ClientError Fields
P4ClientError Class See Also Send Feedback

The P4ClientError type exposes the following members.

Fields

 | Name | Description
 | clientUpdate |
Public field | ErrorCode | Generic code for the error
Public field | ErrorMessage | Descriptive error message
 | MsgClient_BadFlag |
 | MsgClient_BadMarshalInput |
 | MsgClient_BadSignature |
 | MsgClient_CantEdit |
 | MsgClient_CantFindApp |
 | MsgClient_CheckFileAssume |
 | MsgClient_CheckFileAssumeWild |
 | MsgClient_CheckFileCant |
 | MsgClient_CheckFileSubst |
 | MsgClient_ClobberFile |
 | MsgClient_Confirm |
 | MsgClient_ConfirmEdit |
 | MsgClient_ConfirmMarkers |
 | MsgClient_Connect |
 | MsgClient_DigestMisMatch |
 | MsgClient_Eof |
 | MsgClient_Fatal |
 | MsgClient_FileExists |
 | MsgClient_FileOpenError |
 | MsgClient_LineTooLong |
 | MsgClient_LoginPrintTicket |
 | MsgClient_Memory |
 | MsgClient_MergeMsg2 |
 | MsgClient_MergeMsg3 |
 | MsgClient_MergeMsg32 |
 | MsgClient_MergePrompt |
 | MsgClient_MergePrompt2 |
 | MsgClient_MergePrompt2Edit |
 | MsgClient_MkDir |
 | MsgClient_NoMerger |
 | MsgClient_NonTextFileMerge |
 | MsgClient_NoSuchFile |
 | MsgClient_NotUnderPath |
 | MsgClient_ResolveManually |
 | MsgClient_ToolCmdCreate |
 | MsgClient_ToolCmdSend |
 | MsgClient_ToolServer |
 | MsgClient_ToolServer2 |
 | MsgClient_ZCResolve |
 | MsgDb_AddressChanged |
 | MsgDb_BadIPservice |
 | MsgDb_CaseMismatch |
 | MsgDb_CheckpointNoOverwrite |
 | MsgDb_Checksum |
 | MsgDb_ClientGone |
 | MsgDb_CommandCancelled |
 | MsgDb_DbOpen |
 | MsgDb_DbStat |
 | MsgDb_Delete |
 | MsgDb_DelNoLock |
 | MsgDb_Duplicate |
 | MsgDb_EndXact |
 | MsgDb_ExtraDots |
 | MsgDb_ExtraStars |
 | MsgDb_Field2Many |
 | MsgDb_FieldBadIndex |
 | MsgDb_FieldBadVal |
 | MsgDb_FieldMissing |
 | MsgDb_FieldOptBad |
 | MsgDb_FieldTypeBad |
 | MsgDb_FieldUnknown |
 | MsgDb_FieldWords |
 | MsgDb_GetFormat |
 | MsgDb_GetNoGet |
 | MsgDb_InternalUsage |
 | MsgDb_JnlBadMarker |
 | MsgDb_JnlBadVers |
 | MsgDb_JnlCaseUsageBad |
 | MsgDb_JnlDeleteFailed |
 | MsgDb_JnlEnd |
 | MsgDb_JnlFileBad |
 | MsgDb_JnlNoName |
 | MsgDb_JnlNoTVers |
 | MsgDb_JnlNoVers |
 | MsgDb_JnlNum2Big |
 | MsgDb_JnlOct2Long |
 | MsgDb_JnlOctSize |
 | MsgDb_JnlOpcode |
 | MsgDb_JnlQuoting |
 | MsgDb_JnlReplay |
 | MsgDb_JnlSeqBad |
 | MsgDb_JnlVersionError |
 | MsgDb_JnlVersionMismatch |
 | MsgDb_JnlWord2Big |
 | MsgDb_Juxtaposed |
 | MsgDb_KeyTooBig |
 | MsgDb_LicenseBad |
 | MsgDb_LicenseExp |
 | MsgDb_LicenseNeedsApplication |
 | MsgDb_LicenseRead |
 | MsgDb_LineNo |
 | MsgDb_Locking |
 | MsgDb_LockOrder |
 | MsgDb_LockUpgrade |
 | MsgDb_MapCheckFail |
 | MsgDb_MaxMemory |
 | MsgDb_MaxResults |
 | MsgDb_MaxScanRows |
 | MsgDb_MustExpire |
 | MsgDb_NoEndQuote |
 | MsgDb_NotUnderClient |
 | MsgDb_NotUnderRoot |
 | MsgDb_ParseErr |
 | MsgDb_PlatPre972 |
 | MsgDb_Read |
 | MsgDb_ReadNoLock |
 | MsgDb_Scan |
 | MsgDb_ScanFormat |
 | MsgDb_ScanNoLock |
 | MsgDb_ServerTooNew |
 | MsgDb_Stumblebum |
 | MsgDb_SupportExp |
 | MsgDb_Syntax |
 | MsgDb_TableCheckSum |
 | MsgDb_TableObsolete |
 | MsgDb_TableUnknown |
 | MsgDb_TooWild |
 | MsgDb_TooWild2 |
 | MsgDb_TreeAllocation |
 | MsgDb_TreeAlreadyUpgraded |
 | MsgDb_TreeCorrupt |
 | MsgDb_TreeInternal |
 | MsgDb_TreeNewerVersion |
 | MsgDb_TreeNotOpened |
 | MsgDb_TreeNotSupported |
 | MsgDb_TreeOlderVersion |
 | MsgDb_ValidationFoundProblems |
 | MsgDb_WildMismatch |
 | MsgDb_Write |
 | MsgDb_WriteNoLock |
 | MsgDb_WrongApp |
 | MsgDb_XactOutstandingRestart |
 | MsgDm_AddHaveVsRev |
 | MsgDm_AdminLockDataEx |
 | MsgDm_AdminLockDataSh |
 | MsgDm_AdminPasswordData |
 | MsgDm_AdminSpecData |
 | MsgDm_AlreadyCommitted |
 | MsgDm_AlreadyUnloaded |
 | MsgDm_AnnotateTooBig |
 | MsgDm_ArchiveFailed |
 | MsgDm_AtMostOne |
 | MsgDm_BadAtRev |
 | MsgDm_BadCaller |
 | MsgDm_BadChange |
 | MsgDm_BadDigest |
 | MsgDm_BadIntegFlag |
 | MsgDm_BadJobPresets |
 | MsgDm_BadJobTemplate |
 | MsgDm_BadJobView |
 | MsgDm_BadMappedFileName |
 | MsgDm_BadMaxResult |
 | MsgDm_BadMaxScanRow |
 | MsgDm_BadOpenFlag |
 | MsgDm_BadOption |
 | MsgDm_BadRevision |
 | MsgDm_BadRevPend |
 | MsgDm_BadRevRel |
 | MsgDm_BadRevSpec |
 | MsgDm_BadSequence |
 | MsgDm_BadSpecType |
 | MsgDm_BadStorageCombo |
 | MsgDm_BadTemplate |
 | MsgDm_BadTimeout |
 | MsgDm_BadType |
 | MsgDm_BadTypeAuto |
 | MsgDm_BadTypeCombo |
 | MsgDm_BadTypeMod |
 | MsgDm_BadTypePartial |
 | MsgDm_BadVersionCount |
 | MsgDm_BindingNotAllowed |
 | MsgDm_BoundToOtherServer |
 | MsgDm_BucketAdd |
 | MsgDm_BucketNoFilesToArchive |
 | MsgDm_BucketNoFilesToPurge |
 | MsgDm_BucketNoFilesToRestore |
 | MsgDm_BucketPurge |
 | MsgDm_BucketRestore |
 | MsgDm_BucketSkipBranched |
 | MsgDm_BucketSkipBucketed |
 | MsgDm_BucketSkipHead |
 | MsgDm_BucketSkipLazy |
 | MsgDm_BucketSkipType |
 | MsgDm_CachePurgeFile |
 | MsgDm_CantChangeUnloadedOpt |
 | MsgDm_CantChangeUser |
 | MsgDm_CantChangeUserType |
 | MsgDm_CantFindChange |
 | MsgDm_CantOpenHere |
 | MsgDm_ChangeCreated |
 | MsgDm_ChangeDeleteHasFiles |
 | MsgDm_ChangeDeleteHasFix |
 | MsgDm_ChangeDeleteOpen |
 | MsgDm_ChangeDeleteShelved |
 | MsgDm_ChangeDeleteSuccess |
 | MsgDm_ChangeExists |
 | MsgDm_ChangeNotOwner |
 | MsgDm_ChangeNotShelved |
 | MsgDm_ChangesData |
 | MsgDm_ChangesDataPending |
 | MsgDm_ChangeUpdated |
 | MsgDm_CheckFailed |
 | MsgDm_ClassicSwitch |
 | MsgDm_ClientBoundToServer |
 | MsgDm_ClientTooOld |
 | MsgDm_CommandCancelled |
 | MsgDm_CommittedNoPerm |
 | MsgDm_ConcurrentFileChange |
 | MsgDm_ConfigData |
 | MsgDm_ConfigWasNotSet |
 | MsgDm_CopyChangeSummary |
 | MsgDm_CopyMapSummary |
 | MsgDm_CopyMoveExTo |
 | MsgDm_CopyMoveMapFrom |
 | MsgDm_CopyMoveNoFrom |
 | MsgDm_CopyOpenTarget |
 | MsgDm_CountersData |
 | MsgDm_DbFailed |
 | MsgDm_DeleteMoved |
 | MsgDm_DepotDelete |
 | MsgDm_DepotHasStreams |
 | MsgDm_DepotMapInvalid |
 | MsgDm_DepotMissing |
 | MsgDm_DepotNoChange |
 | MsgDm_DepotNotSpec |
 | MsgDm_DepotNotStream |
 | MsgDm_DepotSave |
 | MsgDm_DepotsData |
 | MsgDm_DepotsDataExtra |
 | MsgDm_DepotSpecDup |
 | MsgDm_DepotUnloadDup |
 | MsgDm_DepotVsDomains |
 | MsgDm_DescMissing |
 | MsgDm_DescribeChange |
 | MsgDm_DescribeChangePending |
 | MsgDm_DescribeData |
 | MsgDm_DescribeDiff |
 | MsgDm_DescribeMove |
 | MsgDm_DfltBranchView |
 | MsgDm_Diff2DataContent |
 | MsgDm_Diff2DataIdentical |
 | MsgDm_Diff2DataLeft |
 | MsgDm_Diff2DataRight |
 | MsgDm_Diff2DataRightPre041 |
 | MsgDm_Diff2DataTypes |
 | MsgDm_Diff2DataUnified |
 | MsgDm_Diff2DataUnifiedDiffer |
 | MsgDm_DiffData |
 | MsgDm_DirsData |
 | MsgDm_DiskSpaceEstimated |
 | MsgDm_DiskSpaceMinimum |
 | MsgDm_DomainDelete |
 | MsgDm_DomainIsUnloaded |
 | MsgDm_DomainNoChange |
 | MsgDm_DomainSave |
 | MsgDm_DomainsData |
 | MsgDm_DomainsDataClient |
 | MsgDm_DomainSwitch |
 | MsgDm_DupExists |
 | MsgDm_DupLocked |
 | MsgDm_DupOK |
 | MsgDm_EditSpecNoChange |
 | MsgDm_EditSpecSave |
 | MsgDm_EmbSpecChar |
 | MsgDm_EmbWild |
 | MsgDm_EmptyFileName |
 | MsgDm_EmptyRelate |
 | MsgDm_EmptyResults |
 | MsgDm_ErrorInSpec |
 | MsgDm_ExABOVECHANGE |
 | MsgDm_ExABOVEDATE |
 | MsgDm_ExABOVEHAVE |
 | MsgDm_ExABOVELABEL |
 | MsgDm_ExABOVEREVISION |
 | MsgDm_ExARCHIVES |
 | MsgDm_ExATACTION |
 | MsgDm_ExATCHANGE |
 | MsgDm_ExATDATE |
 | MsgDm_ExATHAVE |
 | MsgDm_ExATLABEL |
 | MsgDm_ExATREVISION |
 | MsgDm_ExATTEXT |
 | MsgDm_ExBELOWCHANGE |
 | MsgDm_ExBELOWDATE |
 | MsgDm_ExBELOWHAVE |
 | MsgDm_ExBELOWLABEL |
 | MsgDm_ExBELOWREVISION |
 | MsgDm_ExBVIEW |
 | MsgDm_ExCHANGE |
 | MsgDm_ExDIFF |
 | MsgDm_ExDIFFPre101 |
 | MsgDm_ExDIGESTED |
 | MsgDm_ExFILE |
 | MsgDm_ExHAVE |
 | MsgDm_ExINTEGED |
 | MsgDm_ExINTEGMOVEDEL |
 | MsgDm_ExINTEGPEND |
 | MsgDm_ExINTEGPERM |
 | MsgDm_ExLABEL |
 | MsgDm_ExLABSYNC |
 | MsgDm_ExOPENALL |
 | MsgDm_ExOPENCHANGE |
 | MsgDm_ExOPENCLIENT |
 | MsgDm_ExOPENDFLT |
 | MsgDm_ExOPENNOTEDIT |
 | MsgDm_ExPROPERTY |
 | MsgDm_ExPROTECT |
 | MsgDm_ExPROTECT2 |
 | MsgDm_ExPROTNAME |
 | MsgDm_ExPROTNAME2 |
 | MsgDm_ExRESOLVED |
 | MsgDm_ExSTREAM |
 | MsgDm_ExSVIEW |
 | MsgDm_ExTOINTEG |
 | MsgDm_ExTORECONCILE |
 | MsgDm_ExTORESOLVE |
 | MsgDm_ExTORETYPE |
 | MsgDm_ExTOUNSHELVE |
 | MsgDm_ExTVIEW |
 | MsgDm_ExUNLOCKCHANGE |
 | MsgDm_ExUPTODATE |
 | MsgDm_ExUSER |
 | MsgDm_ExVIEW |
 | MsgDm_ExVIEW2 |
 | MsgDm_FieldCount |
 | MsgDm_FieldMissing |
 | MsgDm_FilelogData |
 | MsgDm_FilelogInteg |
 | MsgDm_FilelogRevDefault |
 | MsgDm_FilelogRevMessage |
 | MsgDm_FilesData |
 | MsgDm_FilesDiskUsage |
 | MsgDm_FilesDiskUsageHuman |
 | MsgDm_FilesSummary |
 | MsgDm_FilesSummaryHuman |
 | MsgDm_FiltersReplicaOnly |
 | MsgDm_FixAdd |
 | MsgDm_FixAddDefault |
 | MsgDm_FixBadVal |
 | MsgDm_FixDelete |
 | MsgDm_FixesData |
 | MsgDm_FixesDataDefault |
 | MsgDm_GrepFileOutput |
 | MsgDm_GrepLineTooLong |
 | MsgDm_GrepMaxRevs |
 | MsgDm_GrepOutput |
 | MsgDm_GrepSeparator |
 | MsgDm_GrepWithLineNumber |
 | MsgDm_GroupCreated |
 | MsgDm_GroupDeleted |
 | MsgDm_GroupExists |
 | MsgDm_GroupNotCreated |
 | MsgDm_GroupNotOwner |
 | MsgDm_GroupNotUpdated |
 | MsgDm_GroupsData |
 | MsgDm_GroupsDataVerbose |
 | MsgDm_GroupUpdated |
 | MsgDm_HaveData |
 | MsgDm_HaveVsRev |
 | MsgDm_IdEmbeddedNul |
 | MsgDm_IdEmpty |
 | MsgDm_IdHasComma |
 | MsgDm_IdHasDash |
 | MsgDm_IdHasPercent |
 | MsgDm_IdHasRev |
 | MsgDm_IdHasSlash |
 | MsgDm_IdNonPrint |
 | MsgDm_IdNullDir |
 | MsgDm_IdNumber |
 | MsgDm_IdRelPath |
 | MsgDm_IdTooLong |
 | MsgDm_IdWild |
 | MsgDm_ImportNotUnder |
 | MsgDm_InfoDomain |
 | MsgDm_InfoUnknownDomain |
 | MsgDm_IntegAlreadyOpened |
 | MsgDm_IntegBadAction |
 | MsgDm_IntegBadAncestor |
 | MsgDm_IntegBadBase |
 | MsgDm_IntegBadClient |
 | MsgDm_IntegBadUser |
 | MsgDm_IntegBaselessMove |
 | MsgDm_IntegCantAdd |
 | MsgDm_IntegCantModify |
 | MsgDm_IntegedData |
 | MsgDm_IntegIncompatable |
 | MsgDm_IntegIntoReadOnly |
 | MsgDm_IntegMovedNoAccess |
 | MsgDm_IntegMovedNoFrom |
 | MsgDm_IntegMovedNoFromS |
 | MsgDm_IntegMovedOutScope |
 | MsgDm_IntegMovedUnmapped |
 | MsgDm_IntegMustSync |
 | MsgDm_IntegNotHandled |
 | MsgDm_IntegOpenOkay |
 | MsgDm_IntegOpenOkayBase |
 | MsgDm_IntegPreviewResolve |
 | MsgDm_IntegPreviewResolved |
 | MsgDm_IntegPreviewResolveMove |
 | MsgDm_IntegSyncBranch |
 | MsgDm_IntegSyncDelete |
 | MsgDm_IntegSyncIntegBase |
 | MsgDm_IntegTooVirtual |
 | MsgDm_IntegVsRev |
 | MsgDm_IntegVsShelve |
 | MsgDm_IntegVsWork |
 | MsgDm_IntegXOpened |
 | MsgDm_InvalidEscape |
 | MsgDm_InvalidParent |
 | MsgDm_InvalidStreamFmt |
 | MsgDm_InvalidType |
 | MsgDm_JobDelete |
 | MsgDm_JobDeleteHasFix |
 | MsgDm_JobDescMissing |
 | MsgDm_JobDescription |
 | MsgDm_JobFieldAlways |
 | MsgDm_JobFieldReadOnly |
 | MsgDm_JobHasChanged |
 | MsgDm_JobName101 |
 | MsgDm_JobNameJob |
 | MsgDm_JobNameMissing |
 | MsgDm_JobNoChange |
 | MsgDm_JobSave |
 | MsgDm_LabelHasRev |
 | MsgDm_LabelLocked |
 | MsgDm_LabelLoop |
 | MsgDm_LabelNoSync |
 | MsgDm_LabelOwner |
 | MsgDm_LabelSyncAdd |
 | MsgDm_LabelSyncDelete |
 | MsgDm_LabelSyncReplace |
 | MsgDm_LabelSyncUpdate |
 | MsgDm_LameCodes |
 | MsgDm_LicensedClients |
 | MsgDm_LicensedUsers |
 | MsgDm_LicenseNoChange |
 | MsgDm_LicenseSave |
 | MsgDm_LimitBadArg |
 | MsgDm_LineTooLong |
 | MsgDm_LockAlready |
 | MsgDm_LockAlreadyOther |
 | MsgDm_LockBadUnicode |
 | MsgDm_LockedClient |
 | MsgDm_LockedDelete |
 | MsgDm_LockedHost |
 | MsgDm_LockedUpdate |
 | MsgDm_LockNoPermission |
 | MsgDm_LockSuccess |
 | MsgDm_LockUtf16NotSupp |
 | MsgDm_LocWild |
 | MsgDm_LoggerData |
 | MsgDm_ManyRevSpec |
 | MsgDm_MapNoListAccess |
 | MsgDm_MapNotUnder |
 | MsgDm_MaxLockTime |
 | MsgDm_MaxResults |
 | MsgDm_MaxScanRows |
 | MsgDm_MayNotBeNegative |
 | MsgDm_MergeBadBase |
 | MsgDm_MissingDesc |
 | MsgDm_MissingStream |
 | MsgDm_MonitorCantTerminate |
 | MsgDm_MonitorClear |
 | MsgDm_MonitorData |
 | MsgDm_MonitorPause |
 | MsgDm_MonitorResume |
 | MsgDm_MonitorTerminate |
 | MsgDm_MoveBadAction |
 | MsgDm_MoveDeleted |
 | MsgDm_MoveExists |
 | MsgDm_MoveMisMatch |
 | MsgDm_MoveNeedForce |
 | MsgDm_MoveNoInteg |
 | MsgDm_MoveNoMatch |
 | MsgDm_MoveNotResolved |
 | MsgDm_MoveNotSynced |
 | MsgDm_MoveReadOnly |
 | MsgDm_MoveSuccess |
 | MsgDm_MultiWordDefault |
 | MsgDm_MustBeNumeric |
 | MsgDm_MustForceUnloadDepot |
 | MsgDm_NameChanged |
 | MsgDm_NeedClient |
 | MsgDm_NeedJobUpgrade |
 | MsgDm_NeedsUpgrades |
 | MsgDm_NoArchive |
 | MsgDm_NoCheckin |
 | MsgDm_NoClearText |
 | MsgDm_NoClient |
 | MsgDm_NoCodeZero |
 | MsgDm_NoDefault |
 | MsgDm_NoDelete |
 | MsgDm_NoDepot |
 | MsgDm_NoDepotTypeChange |
 | MsgDm_NoIntegHavemaps |
 | MsgDm_NoIntegOverlays |
 | MsgDm_NoModComChange |
 | MsgDm_NoNextRev |
 | MsgDm_NoNotOp |
 | MsgDm_NoPerms |
 | MsgDm_NoPrevRev |
 | MsgDm_NoProtect |
 | MsgDm_NoRev |
 | MsgDm_NoRevisionOverwrite |
 | MsgDm_NoRevRange |
 | MsgDm_NoRmtInterop |
 | MsgDm_NoStreamAtChange |
 | MsgDm_NoSuchChange |
 | MsgDm_NoSuchConfig |
 | MsgDm_NoSuchCounter |
 | MsgDm_NoSuchDepot |
 | MsgDm_NoSuchDepot2 |
 | MsgDm_NoSuchDomain |
 | MsgDm_NoSuchDomain2 |
 | MsgDm_NoSuchFix |
 | MsgDm_NoSuchGroup |
 | MsgDm_NoSuchJob |
 | MsgDm_NoSuchJob2 |
 | MsgDm_NoSuchKey |
 | MsgDm_NoSuchProperty |
 | MsgDm_NoSuchRelease |
 | MsgDm_NoSuchResource |
 | MsgDm_NoSuchServer |
 | MsgDm_NoSuchServerlog |
 | MsgDm_NotAsService |
 | MsgDm_NotBoundToServer |
 | MsgDm_NotBucket |
 | MsgDm_NotClientOrLabel |
 | MsgDm_NotStreamReady |
 | MsgDm_NotThatCounter |
 | MsgDm_NotUnderClient |
 | MsgDm_NotUnderRoot |
 | MsgDm_NotUnloaded |
 | MsgDm_NoUnloadedAutoLabel |
 | MsgDm_OpenAlready |
 | MsgDm_OpenAttrRO |
 | MsgDm_OpenBadAction |
 | MsgDm_OpenBadChange |
 | MsgDm_OpenBadClient |
 | MsgDm_OpenBadType |
 | MsgDm_OpenBadUser |
 | MsgDm_OpenCantDeleted |
 | MsgDm_OpenCantExists |
 | MsgDm_OpenedData |
 | MsgDm_OpenedDataS |
 | MsgDm_OpenedDelete |
 | MsgDm_OpenedLocked |
 | MsgDm_OpenedLockedS |
 | MsgDm_OpenedOther |
 | MsgDm_OpenedOtherLocked |
 | MsgDm_OpenedOtherLockedS |
 | MsgDm_OpenedOtherS |
 | MsgDm_OpenedSwitch |
 | MsgDm_OpenedTaskSwitch |
 | MsgDm_OpenedXData |
 | MsgDm_OpenedXDataS |
 | MsgDm_OpenedXOther |
 | MsgDm_OpenedXOtherS |
 | MsgDm_OpenExclLocked |
 | MsgDm_OpenExclOrphaned |
 | MsgDm_OpenExclOther |
 | MsgDm_OpenFilesCantChange |
 | MsgDm_OpenFilesCantChangeUser |
 | MsgDm_OpenIsLocked |
 | MsgDm_OpenIsOpened |
 | MsgDm_OpenMustResolve |
 | MsgDm_OpenOtherDepot |
 | MsgDm_OpenReadOnly |
 | MsgDm_OpenReOpen |
 | MsgDm_OpenSuccess |
 | MsgDm_OpenTaskNotMapped |
 | MsgDm_OpenUpToDate |
 | MsgDm_OpenWarnChangeMap |
 | MsgDm_OpenWarnDeleted |
 | MsgDm_OpenWarnExists |
 | MsgDm_OpenWarnFileNotMapped |
 | MsgDm_OpenWarnMoved |
 | MsgDm_OpenWarnOpenNotStream |
 | MsgDm_OpenWarnOpenStream |
 | MsgDm_OpenWarnPurged |
 | MsgDm_OpenXOpened |
 | MsgDm_OpenXOpenedFailed |
 | MsgDm_OperatorNotAllowed |
 | MsgDm_OutOfSequence |
 | MsgDm_OwnerCantChange |
 | MsgDm_ParallelNotEnabled |
 | MsgDm_ParallelOptions |
 | MsgDm_Passwd982 |
 | MsgDm_PastUpgrade |
 | MsgDm_PathNotUnder |
 | MsgDm_PendingDelete |
 | MsgDm_PendingNoPerm |
 | MsgDm_PopulateDesc |
 | MsgDm_PopulateInvalidStream |
 | MsgDm_PopulateMultipleStreams |
 | MsgDm_PopulateTargetExists |
 | MsgDm_PopulateTargetMixed |
 | MsgDm_PosWild |
 | MsgDm_PropertyAllData |
 | MsgDm_PropertyData |
 | MsgDm_PropertyDataGroup |
 | MsgDm_PropertyDataUser |
 | MsgDm_ProtectedCodes |
 | MsgDm_ProtectNoChange |
 | MsgDm_ProtectSave |
 | MsgDm_ProtectsData |
 | MsgDm_ProtectsEmpty |
 | MsgDm_ProtectsMaxData |
 | MsgDm_ProtectsNoSuper |
 | MsgDm_PurgeActiveTask |
 | MsgDm_PurgeCheck |
 | MsgDm_PurgeData |
 | MsgDm_PurgeDeleted |
 | MsgDm_PurgeFirst |
 | MsgDm_PurgeNoRecords |
 | MsgDm_PurgeSnapData |
 | MsgDm_ReconcileBadName |
 | MsgDm_ReconcileNeedForce |
 | MsgDm_ReferClient |
 | MsgDm_ReleaseAbandon |
 | MsgDm_ReleaseClear |
 | MsgDm_ReleaseDelete |
 | MsgDm_ReleaseHasMoved |
 | MsgDm_ReleaseHasPending |
 | MsgDm_ReleaseNotOwner |
 | MsgDm_ReleaseRevert |
 | MsgDm_ReleaseUnlockAbandon |
 | MsgDm_ReleaseUnlockClear |
 | MsgDm_ReleaseUnlockDelete |
 | MsgDm_ReleaseUnlockRevert |
 | MsgDm_ReloadData |
 | MsgDm_ReloadFirst |
 | MsgDm_ReloadNotOwner |
 | MsgDm_ReloadSuspicious |
 | MsgDm_RemoteChangeExists |
 | MsgDm_RemoteChangeMissing |
 | MsgDm_RemoteDomainExists |
 | MsgDm_RemoteDomainMissing |
 | MsgDm_ReopenBadType |
 | MsgDm_ReopenCharSet |
 | MsgDm_ReopenData |
 | MsgDm_ReopenDataNoChange |
 | MsgDm_Resolve2WayRaw |
 | MsgDm_Resolve3WayRaw |
 | MsgDm_Resolve3WayText |
 | MsgDm_Resolve3WayTextBase |
 | MsgDm_ResolveAction |
 | MsgDm_ResolveActionMove |
 | MsgDm_ResolveCharset |
 | MsgDm_ResolveCharsetActionT |
 | MsgDm_ResolveCharsetActionY |
 | MsgDm_ResolvedAction |
 | MsgDm_ResolvedActionMove |
 | MsgDm_ResolvedData |
 | MsgDm_ResolvedDataBase |
 | MsgDm_ResolveDelete |
 | MsgDm_ResolveDoBranch |
 | MsgDm_ResolveDoBranchActionT |
 | MsgDm_ResolveDoBranchActionY |
 | MsgDm_ResolveDoDelete |
 | MsgDm_ResolveDoDeleteActionT |
 | MsgDm_ResolveDoDeleteActionY |
 | MsgDm_ResolveFiletype |
 | MsgDm_ResolveFiletypeAction |
 | MsgDm_ResolveMove |
 | MsgDm_ResolveMoveAction |
 | MsgDm_ResolveMustIgnore |
 | MsgDm_ResolveShelveDelete |
 | MsgDm_ResolveTrait |
 | MsgDm_ResolveTraitActionM |
 | MsgDm_ResolveTraitActionT |
 | MsgDm_ResolveTraitActionY |
 | MsgDm_ResourceAlreadyLocked |
 | MsgDm_RetypeData |
 | MsgDm_ReviewData |
 | MsgDm_ReviewsData |
 | MsgDm_RevVsRevCx |
 | MsgDm_RmtAddChangeFailed |
 | MsgDm_RmtAddDomainFailed |
 | MsgDm_RmtAuthFailed |
 | MsgDm_RmtDeleteChangeFailed |
 | MsgDm_RmtDeleteDomainFailed |
 | MsgDm_RmtError |
 | MsgDm_RmtExclusiveLockFailed |
 | MsgDm_RmtJournalWaitFailed |
 | MsgDm_RmtSequenceFailed |
 | MsgDm_SameCode |
 | MsgDm_SameTag |
 | MsgDm_SemiInDefault |
 | MsgDm_ServerDelete |
 | MsgDm_ServerNoChange |
 | MsgDm_ServerSave |
 | MsgDm_ServersData |
 | MsgDm_ServerTypeMismatch |
 | MsgDm_ServerViewMap |
 | MsgDm_ServiceNotProvided |
 | MsgDm_ServiceUserLogin |
 | MsgDm_ShelveCantUpdate |
 | MsgDm_ShelvedDelete |
 | MsgDm_ShelvedHasWorking |
 | MsgDm_ShelveIncompatible |
 | MsgDm_ShelveLocked |
 | MsgDm_ShelveMaxFiles |
 | MsgDm_ShelveNeedsResolve |
 | MsgDm_ShelveNoPerm |
 | MsgDm_ShelveNotChanged |
 | MsgDm_ShelveOpenResolves |
 | MsgDm_ShelveUnlocked |
 | MsgDm_SnapFirst |
 | MsgDm_SpecDeleted |
 | MsgDm_SpecNoChange |
 | MsgDm_SpecNotDefined |
 | MsgDm_SpecSave |
 | MsgDm_StatusSuccess |
 | MsgDm_StreamBadConvert |
 | MsgDm_StreamConverted |
 | MsgDm_StreamDepthErr |
 | MsgDm_StreamDoubleSlash |
 | MsgDm_StreamEndSlash |
 | MsgDm_StreamEqDepot |
 | MsgDm_StreamHasChildren |
 | MsgDm_StreamHasClients |
 | MsgDm_StreamIncompatibleC |
 | MsgDm_StreamIncompatibleP |
 | MsgDm_StreamIsMainline |
 | MsgDm_StreamIsUnloaded |
 | MsgDm_StreamIsVirtual |
 | MsgDm_StreamNested |
 | MsgDm_StreamNoConvert |
 | MsgDm_StreamNoFlow |
 | MsgDm_StreamNoReparent |
 | MsgDm_StreamNotOwner |
 | MsgDm_StreamOverflow |
 | MsgDm_StreamOwnerReq |
 | MsgDm_StreamOwnerUpdate |
 | MsgDm_StreamParentIsTask |
 | MsgDm_StreamPathRooted |
 | MsgDm_StreamPathSlash |
 | MsgDm_StreamRootErr |
 | MsgDm_StreamsData |
 | MsgDm_StreamTargetExists |
 | MsgDm_StreamVsDomains |
 | MsgDm_SubmitChanges |
 | MsgDm_SubmitMovedToDefault |
 | MsgDm_SubmitMustResolve |
 | MsgDm_SubmitNewResolve |
 | MsgDm_SubmitRefresh |
 | MsgDm_SubmitResolve |
 | MsgDm_SubmitReverted |
 | MsgDm_SubmitTransfer |
 | MsgDm_SubmitUpToDate |
 | MsgDm_SubmitWasAdd |
 | MsgDm_SubmitWasDelete |
 | MsgDm_SubmitWasDeleteCanReadd |
 | MsgDm_SyncAdd |
 | MsgDm_SyncCantDelete |
 | MsgDm_SyncCantPublishIsOpen |
 | MsgDm_SyncCantPublishOnHave |
 | MsgDm_SyncCantReplace |
 | MsgDm_SyncDelete |
 | MsgDm_SyncIndexOutOfBounds |
 | MsgDm_SyncIntegBackwards |
 | MsgDm_SyncIntegDelete |
 | MsgDm_SyncIntegUpdate |
 | MsgDm_SyncMissingMoveSource |
 | MsgDm_SyncNotSafeAdd |
 | MsgDm_SyncNotSafeDelete |
 | MsgDm_SyncNotSafeReplace |
 | MsgDm_SyncNotSafeUpdate |
 | MsgDm_SyncRefresh |
 | MsgDm_SyncReplace |
 | MsgDm_SyncResolve |
 | MsgDm_SyncUpdate |
 | MsgDm_SyncUptodate |
 | MsgDm_TheseCantChange |
 | MsgDm_TooManyClients |
 | MsgDm_TooManyCommitServers |
 | MsgDm_TooManyRoots |
 | MsgDm_TooManyUsers |
 | MsgDm_TooOld |
 | MsgDm_TraitCleared |
 | MsgDm_TraitIsOpen |
 | MsgDm_TraitNotSet |
 | MsgDm_TraitSet |
 | MsgDm_TriggerNoArchiveType |
 | MsgDm_TriggerNoChange |
 | MsgDm_TriggerNoDepotFile |
 | MsgDm_TriggerSave |
 | MsgDm_TryDelClient |
 | MsgDm_TryDelUser |
 | MsgDm_TryEvalLicense |
 | MsgDm_TwistedMap |
 | MsgDm_TypeMapNoChange |
 | MsgDm_TypeMapSave |
 | MsgDm_Unicode |
 | MsgDm_UnidentifiedServer |
 | MsgDm_UnknownReplicationMode |
 | MsgDm_UnknownReplicationTarget |
 | MsgDm_UnloadData |
 | MsgDm_UnloadDepotMissing |
 | MsgDm_UnloadNotOwner |
 | MsgDm_UnloadNotPossible |
 | MsgDm_UnLockAlready |
 | MsgDm_UnLockAlreadyOther |
 | MsgDm_UnLockSuccess |
 | MsgDm_UnshelveBadAction |
 | MsgDm_UnshelveBadAdd |
 | MsgDm_UnshelveBadClientView |
 | MsgDm_UnshelveBadEdit |
 | MsgDm_UnshelveFromRemote |
 | MsgDm_UnshelveIsLocked |
 | MsgDm_UnshelveNotTask |
 | MsgDm_UnshelveResolve |
 | MsgDm_UnshelveSuccess |
 | MsgDm_UseConfigure |
 | MsgDm_UserCantChange |
 | MsgDm_UserCantDelete |
 | MsgDm_UserDelete |
 | MsgDm_UserNoChange |
 | MsgDm_UserNotExist |
 | MsgDm_UserOrGroup |
 | MsgDm_UserSave |
 | MsgDm_UsersData |
 | MsgDm_UsersDataLong |
 | MsgDm_VerifyData |
 | MsgDm_VerifyDataProblem |
 | MsgDm_WhereData |
 | MsgDm_WildAdd |
 | MsgDm_WildAddTripleDots |
 | MsgDm_WorkingVsLocked |
 | MsgDm_WrongClient |
 | MsgDm_WrongDomain |
 | MsgDm_WrongUser |
 | MsgDm_WrongUserDelete |
 | MsgHelp_HelpAdd |
 | MsgHelp_HelpAdmin |
 | MsgHelp_HelpAdministration |
 | MsgHelp_HelpAnnotate |
 | MsgHelp_HelpArchive |
 | MsgHelp_HelpAttribute |
 | MsgHelp_HelpBranch |
 | MsgHelp_HelpBranches |
 | MsgHelp_HelpBroker |
 | MsgHelp_HelpBrowse |
 | MsgHelp_HelpBuildserver |
 | MsgHelp_HelpCachepurge |
 | MsgHelp_HelpChange |
 | MsgHelp_HelpChanges |
 | MsgHelp_HelpCharset |
 | MsgHelp_HelpClient |
 | MsgHelp_HelpClients |
 | MsgHelp_HelpCluster |
 | MsgHelp_HelpCommandments |
 | MsgHelp_HelpCommands |
 | MsgHelp_HelpConfigurables |
 | MsgHelp_HelpConfigure |
 | MsgHelp_HelpCopy |
 | MsgHelp_HelpCounter |
 | MsgHelp_HelpCounters |
 | MsgHelp_HelpCredits |
 | MsgHelp_HelpCstat |
 | MsgHelp_HelpDbpack |
 | MsgHelp_HelpDbschema |
 | MsgHelp_HelpDbstat |
 | MsgHelp_HelpDbverify |
 | MsgHelp_HelpDelete |
 | MsgHelp_HelpDepot |
 | MsgHelp_HelpDepots |
 | MsgHelp_HelpDescribe |
 | MsgHelp_HelpDiff |
 | MsgHelp_HelpDiff2 |
 | MsgHelp_HelpDirs |
 | MsgHelp_HelpDiskspace |
 | MsgHelp_HelpDistributed |
 | MsgHelp_HelpDuplicate |
 | MsgHelp_HelpEdit |
 | MsgHelp_HelpEnvironment |
 | MsgHelp_HelpExport |
 | MsgHelp_HelpFilelog |
 | MsgHelp_HelpFiles |
 | MsgHelp_HelpFiletypes |
 | MsgHelp_HelpFix |
 | MsgHelp_HelpFixes |
 | MsgHelp_HelpForwardingreplica |
 | MsgHelp_HelpFstat |
 | MsgHelp_HelpGrep |
 | MsgHelp_HelpGroup |
 | MsgHelp_HelpGroups |
 | MsgHelp_HelpHave |
 | MsgHelp_HelpHelp |
 | MsgHelp_HelpIndex |
 | MsgHelp_HelpInfo |
 | MsgHelp_HelpInteg |
 | MsgHelp_HelpInteg3 |
 | MsgHelp_HelpInteged |
 | MsgHelp_HelpInterchanges |
 | MsgHelp_HelpIstat |
 | MsgHelp_HelpJob |
 | MsgHelp_HelpJobs |
 | MsgHelp_HelpJobSpec |
 | MsgHelp_HelpJobView |
 | MsgHelp_HelpJournaldbchecksums |
 | MsgHelp_HelpJournals |
 | MsgHelp_HelpKey |
 | MsgHelp_HelpKeys |
 | MsgHelp_HelpLabel |
 | MsgHelp_HelpLabels |
 | MsgHelp_HelpLabelsync |
 | MsgHelp_HelpLegal |
 | MsgHelp_HelpLicense |
 | MsgHelp_HelpList |
 | MsgHelp_HelpLock |
 | MsgHelp_HelpLockstat |
 | MsgHelp_HelpLogappend |
 | MsgHelp_HelpLogger |
 | MsgHelp_HelpLogin |
 | MsgHelp_HelpLogout |
 | MsgHelp_HelpLogparse |
 | MsgHelp_HelpLogrotate |
 | MsgHelp_HelpLogschema |
 | MsgHelp_HelpLogstat |
 | MsgHelp_HelpLogtail |
 | MsgHelp_HelpMaxResults |
 | MsgHelp_HelpMerge |
 | MsgHelp_HelpMerge3 |
 | MsgHelp_HelpMonitor |
 | MsgHelp_HelpMove |
 | MsgHelp_HelpNetworkAddress |
 | MsgHelp_HelpObliterate |
 | MsgHelp_HelpOpened |
 | MsgHelp_HelpPasswd |
 | MsgHelp_HelpPerforce |
 | MsgHelp_HelpPing |
 | MsgHelp_HelpPopulate |
 | MsgHelp_HelpPrint |
 | MsgHelp_HelpProperty |
 | MsgHelp_HelpProtect |
 | MsgHelp_HelpProtects |
 | MsgHelp_HelpProxy |
 | MsgHelp_HelpPull |
 | MsgHelp_HelpReconcile |
 | MsgHelp_HelpReload |
 | MsgHelp_HelpRename |
 | MsgHelp_HelpRenameUser |
 | MsgHelp_HelpReopen |
 | MsgHelp_HelpReplicate |
 | MsgHelp_HelpReplication |
 | MsgHelp_HelpResolve |
 | MsgHelp_HelpResolved |
 | MsgHelp_HelpRestore |
 | MsgHelp_HelpRetype |
 | MsgHelp_HelpRevert |
 | MsgHelp_HelpReview |
 | MsgHelp_HelpReviews |
 | MsgHelp_HelpRevisions |
 | MsgHelp_HelpSearch |
 | MsgHelp_HelpServer |
 | MsgHelp_HelpServerid |
 | MsgHelp_HelpServers |
 | MsgHelp_HelpSet |
 | MsgHelp_HelpShelve |
 | MsgHelp_HelpSimple |
 | MsgHelp_HelpSizes |
 | MsgHelp_HelpSnap |
 | MsgHelp_HelpSpec |
 | MsgHelp_HelpStream |
 | MsgHelp_HelpStreamintro |
 | MsgHelp_HelpStreams |
 | MsgHelp_HelpSubmit |
 | MsgHelp_HelpSync |
 | MsgHelp_HelpTag |
 | MsgHelp_HelpTickets |
 | MsgHelp_HelpTrigger |
 | MsgHelp_HelpTriggers |
 | MsgHelp_HelpTrust |
 | MsgHelp_HelpTunables |
 | MsgHelp_HelpTypeMap |
 | MsgHelp_HelpUndoc |
 | MsgHelp_HelpUnload |
 | MsgHelp_HelpUnlock |
 | MsgHelp_HelpUnshelve |
 | MsgHelp_HelpUsage |
 | MsgHelp_HelpUser |
 | MsgHelp_HelpUsers |
 | MsgHelp_HelpVerify |
 | MsgHelp_HelpViews |
 | MsgHelp_HelpWhere |
 | MsgHelp_HelpZeroConf |
 | MsgHelp_NoHelp |
 | MsgHelp_ResolveUserHelp |
 | MsgLbr_After |
 | MsgLbr_AlreadyOpen |
 | MsgLbr_BadKeyword |
 | MsgLbr_BadType1 |
 | MsgLbr_Checkin |
 | MsgLbr_Checkout |
 | MsgLbr_Commit |
 | MsgLbr_Diff |
 | MsgLbr_Edit0 |
 | MsgLbr_Edit1 |
 | MsgLbr_Edit2 |
 | MsgLbr_Empty |
 | MsgLbr_EofAt |
 | MsgLbr_ExpDesc |
 | MsgLbr_Expect |
 | MsgLbr_ExpEof |
 | MsgLbr_ExpRev |
 | MsgLbr_ExpSemi |
 | MsgLbr_FmtLbrStat |
 | MsgLbr_FmtLbrStat2 |
 | MsgLbr_FmtLbrStat3 |
 | MsgLbr_LbrOpenFail |
 | MsgLbr_Lock |
 | MsgLbr_Loop |
 | MsgLbr_Mangled |
 | MsgLbr_MkDir |
 | MsgLbr_NoBranch |
 | MsgLbr_NoBrRev |
 | MsgLbr_NoRev |
 | MsgLbr_NoRev3 |
 | MsgLbr_NoRevDel |
 | MsgLbr_Parse |
 | MsgLbr_Purged |
 | MsgLbr_RcsTooBig |
 | MsgLbr_RevLess |
 | MsgLbr_ScriptFailed |
 | MsgLbr_TooBig |
 | MsgOs_ChmodBetrayal |
 | MsgOs_Deleted |
 | MsgOs_EmptyFork |
 | MsgOs_NameTooLong |
 | MsgOs_Net |
 | MsgOs_NetUn |
 | MsgOs_NoSuch |
 | MsgOs_Sys |
 | MsgOs_Sys2 |
 | MsgOs_SysUn |
 | MsgOs_SysUn2 |
 | MsgOs_TooMany |
 | MsgRpc_Break |
 | MsgRpc_Closed |
 | MsgRpc_HostKeyMismatch |
 | MsgRpc_HostKeyUnknown |
 | MsgRpc_Listen |
 | MsgRpc_MaxWait |
 | MsgRpc_NameResolve |
 | MsgRpc_NoPoss |
 | MsgRpc_NotP4 |
 | MsgRpc_Operat |
 | MsgRpc_PxRemoteSvrFail |
 | MsgRpc_Read |
 | MsgRpc_Reconn |
 | MsgRpc_Select |
 | MsgRpc_ServiceNoTrust |
 | MsgRpc_SslAccept |
 | MsgRpc_SslBadDir |
 | MsgRpc_SslBadFsSecurity |
 | MsgRpc_SslBadKeyFile |
 | MsgRpc_SslCertBadDates |
 | MsgRpc_SslCertGen |
 | MsgRpc_SslCfgExpire |
 | MsgRpc_SslCfgUnits |
 | MsgRpc_SslCleartext |
 | MsgRpc_SslClose |
 | MsgRpc_SslConnect |
 | MsgRpc_SslCredsBadOwner |
 | MsgRpc_SslCtx |
 | MsgRpc_SslDirHasCreds |
 | MsgRpc_SslFailGetExpire |
 | MsgRpc_SslGetPubKey |
 | MsgRpc_SslInit |
 | MsgRpc_SslInvalid |
 | MsgRpc_SslKeyNotRSA |
 | MsgRpc_SslLibMismatch |
 | MsgRpc_SslListen |
 | MsgRpc_SslNoCredentials |
 | MsgRpc_SslNoSsl |
 | MsgRpc_SslRecv |
 | MsgRpc_SslSend |
 | MsgRpc_SslShutdown |
 | MsgRpc_Stdio |
 | MsgRpc_TcpAccept |
 | MsgRpc_TcpConnect |
 | MsgRpc_TcpHost |
 | MsgRpc_TcpListen |
 | MsgRpc_TcpPeerSsl |
 | MsgRpc_TcpPortInvalid |
 | MsgRpc_TcpRecv |
 | MsgRpc_TcpSend |
 | MsgRpc_TcpService |
 | MsgRpc_TooBig |
 | MsgRpc_Unconn |
 | MsgRpc_UnixDomainOpen |
 | MsgRpc_UnReg |
 | MsgRpc_WakeupAttempt |
 | MsgRpc_WakeupInit |
 | MsgRpc_ZksDisconnect |
 | MsgRpc_ZksInit |
 | MsgRpc_ZksRecv |
 | MsgRpc_ZksSend |
 | MsgRpc_ZksState |
 | MsgServer_ActionResolve111 |
 | MsgServer_AddDelete |
 | MsgServer_AdminNoSpecDepot |
 | MsgServer_AdminNoSuchSpec |
 | MsgServer_AdminNothingLocked |
 | MsgServer_AdminNothingLogged |
 | MsgServer_AdminPasswordNoPasswords |
 | MsgServer_AdminPasswordNoSuchUser |
 | MsgServer_AdminReplicaCkp |
 | MsgServer_AdminSizeData |
 | MsgServer_AttrNoPropEdge |
 | MsgServer_BadCheckpointNum |
 | MsgServer_BadCommand |
 | MsgServer_BadExtraFlag |
 | MsgServer_BadImport |
 | MsgServer_BadIPAddr |
 | MsgServer_BadJnlFlag |
 | MsgServer_BadJournalNum |
 | MsgServer_BadPassword |
 | MsgServer_BadPassword0 |
 | MsgServer_BadPassword1 |
 | MsgServer_BadPCache |
 | MsgServer_BadRoot |
 | MsgServer_BadServicePack |
 | MsgServer_BadSortOption |
 | MsgServer_BadTransfers |
 | MsgServer_BadTriggerOutput |
 | MsgServer_BFNoOverwriteLocal |
 | MsgServer_BoundClientExists |
 | MsgServer_BoundClientServerID |
 | MsgServer_CacheAlreadyPurged |
 | MsgServer_CantAuthenticate |
 | MsgServer_CantChangeOther |
 | MsgServer_CantOpen |
 | MsgServer_CantRevertToPurged |
 | MsgServer_CantUnloadLocked |
 | MsgServer_ChangeNotLocal |
 | MsgServer_ChangeNotSubmitted |
 | MsgServer_ChangesShelved |
 | MsgServer_ClientBadHost |
 | MsgServer_ClientOpFailed |
 | MsgServer_ClientTooOld |
 | MsgServer_ClusterCannotWriteJournal |
 | MsgServer_ClusterNotAllowed |
 | MsgServer_CommandCancelled |
 | MsgServer_CommandDisabled |
 | MsgServer_CommandUnsupported |
 | MsgServer_CommunicationLoop |
 | MsgServer_ConfigureNone |
 | MsgServer_ConfigureServerNone |
 | MsgServer_ConfigureSet |
 | MsgServer_ConfigureUnSet |
 | MsgServer_ConnectBroken |
 | MsgServer_CopyDoNothing |
 | MsgServer_CopyNeedsMergeFirst |
 | MsgServer_CopyWrongDirection |
 | MsgServer_CouldntLock |
 | MsgServer_CounterDelete |
 | MsgServer_CounterGet |
 | MsgServer_CounterNotNumeric |
 | MsgServer_CounterSet |
 | MsgServer_CounterWarning |
 | MsgServer_CreatingDb |
 | MsgServer_CurJournalButNotJournaling |
 | MsgServer_DeltaLine1 |
 | MsgServer_DeltaLine2 |
 | MsgServer_DescribeAffected |
 | MsgServer_DescribeDifferences |
 | MsgServer_DescribeEmpty |
 | MsgServer_DescribeFixed |
 | MsgServer_DescribeMovedFiles |
 | MsgServer_DescribeShelved |
 | MsgServer_Diff2BadArgs |
 | MsgServer_Diff2Differ |
 | MsgServer_DiffCmp |
 | MsgServer_DiffList |
 | MsgServer_DigestMisMatch |
 | MsgServer_DirsWild |
 | MsgServer_DomainIsLocal |
 | MsgServer_DontRenameSelf |
 | MsgServer_DumpNameIsADbName |
 | MsgServer_EmptyTypeList |
 | MsgServer_ErrorInSpec |
 | MsgServer_ErrorPingParam |
 | MsgServer_ErrorPingProtocol |
 | MsgServer_ExtraIDUsage |
 | MsgServer_GotLocked |
 | MsgServer_GotUnlocked |
 | MsgServer_GotUnresolved |
 | MsgServer_GrepContextTooLarge |
 | MsgServer_GrepIllegalContext |
 | MsgServer_HandshakeFailed |
 | MsgServer_HelpSeeRename |
 | MsgServer_IllegalCommand |
 | MsgServer_ImportReport |
 | MsgServer_IndexOutput |
 | MsgServer_InfoAuthServer |
 | MsgServer_InfoBadClient |
 | MsgServer_InfoBadUser |
 | MsgServer_InfoCaseHandling |
 | MsgServer_InfoChangeServer |
 | MsgServer_InfoClient |
 | MsgServer_InfoClientAddress |
 | MsgServer_InfoClientRoot |
 | MsgServer_InfoDirectory |
 | MsgServer_InfoDiskSpace |
 | MsgServer_InfoHost |
 | MsgServer_InfoMinClient |
 | MsgServer_InfoPeerAddress |
 | MsgServer_InfoPingCount |
 | MsgServer_InfoPingCountB |
 | MsgServer_InfoPingTime |
 | MsgServer_InfoPingTimeB |
 | MsgServer_InfoProxyAddress |
 | MsgServer_InfoProxyCertExpire |
 | MsgServer_InfoProxyEncryption |
 | MsgServer_InfoProxyVersion |
 | MsgServer_InfoServerAddress |
 | MsgServer_InfoServerCertExpire |
 | MsgServer_InfoServerDate |
 | MsgServer_InfoServerEncryption |
 | MsgServer_InfoServerID |
 | MsgServer_InfoServerLicense |
 | MsgServer_InfoServerLicenseIp |
 | MsgServer_InfoServerRoot |
 | MsgServer_InfoServerUptime |
 | MsgServer_InfoServerVersion |
 | MsgServer_InfoStream |
 | MsgServer_InfoUnknownClient |
 | MsgServer_InfoUser |
 | MsgServer_InsecureReplica |
 | MsgServer_IntegIsTask |
 | MsgServer_InvalidConfigValue |
 | MsgServer_InvalidNesting |
 | MsgServer_InvalidServerChain |
 | MsgServer_InvalidStartupCommand |
 | MsgServer_IstatInvalid |
 | MsgServer_JobRebuilt |
 | MsgServer_Jobs982Win |
 | MsgServer_JobsDashS |
 | MsgServer_JournalCounterMismatch |
 | MsgServer_JournalFilterBad |
 | MsgServer_JournalorCheckpointRequired |
 | MsgServer_KeyDelete |
 | MsgServer_KeyNotNumeric |
 | MsgServer_KeySet |
 | MsgServer_LbrCheckin |
 | MsgServer_LbrCheckout |
 | MsgServer_LbrDiff |
 | MsgServer_LbrDigest |
 | MsgServer_LbrFileSize |
 | MsgServer_LbrMerge |
 | MsgServer_LbrNoTrigger |
 | MsgServer_LogCommand |
 | MsgServer_LogEstimates |
 | MsgServer_LoggedOut |
 | MsgServer_Login032 |
 | MsgServer_Login042 |
 | MsgServer_Login072 |
 | MsgServer_LoginExpired |
 | MsgServer_LoginGoodTill |
 | MsgServer_LoginNoTicket |
 | MsgServer_LoginNotRequired |
 | MsgServer_LoginPrintTicket |
 | MsgServer_LoginUser |
 | MsgServer_LogoutUser |
 | MsgServer_LogtailNoLog |
 | MsgServer_MaxLicensedFiles |
 | MsgServer_MaxUnLicensedFiles |
 | MsgServer_MergesPending |
 | MsgServer_MergeWrongDirection |
 | MsgServer_MetaDumpFailed |
 | MsgServer_MimAttack |
 | MsgServer_MissingReplicationMode |
 | MsgServer_MonitorBadId |
 | MsgServer_MonitorDisabled |
 | MsgServer_MonitorNoLockinfo |
 | MsgServer_Move091 |
 | MsgServer_Move101 |
 | MsgServer_MoveRejected |
 | MsgServer_MustSetPassword |
 | MsgServer_NeedFilePath |
 | MsgServer_NewUserExists |
 | MsgServer_NewUserHasChanges |
 | MsgServer_NewUserHasDomains |
 | MsgServer_No973Wingui |
 | MsgServer_NoAuthFileCount |
 | MsgServer_NoAuthServiceOnly |
 | MsgServer_NoCentralLicense |
 | MsgServer_NoCkptName |
 | MsgServer_NoClearText |
 | MsgServer_NoCustomSpec |
 | MsgServer_NoDefaultShelve |
 | MsgServer_NoDefaultSubmit |
 | MsgServer_NoDumpName |
 | MsgServer_NoInteg |
 | MsgServer_NoProxyAuth |
 | MsgServer_NoReparentingTask |
 | MsgServer_NoServerID |
 | MsgServer_NoShelve |
 | MsgServer_NoShelveDelete |
 | MsgServer_NoSubmit |
 | MsgServer_NoSuchField |
 | MsgServer_NoSuchTransfer |
 | MsgServer_NoSuchUser |
 | MsgServer_NoSuppASflag |
 | MsgServer_NoSuppVflag |
 | MsgServer_NotACommitServer |
 | MsgServer_NotAsService |
 | MsgServer_NotClusterMaster |
 | MsgServer_NotClusterReplica |
 | MsgServer_NotClusterService |
 | MsgServer_NotDistributed |
 | MsgServer_NotEdgeLocal |
 | MsgServer_NoTicketSupport |
 | MsgServer_NotInCluster |
 | MsgServer_NotStreamOwner |
 | MsgServer_NotStreamReady |
 | MsgServer_NotThisConfigVar |
 | MsgServer_NoUserLogs |
 | MsgServer_NoValidLicense |
 | MsgServer_OldDiffClient |
 | MsgServer_OldReconcileClient |
 | MsgServer_OnlyOneFilter |
 | MsgServer_OperationDate |
 | MsgServer_OperationFailed |
 | MsgServer_P4TARGETWasSet |
 | MsgServer_Password032 |
 | MsgServer_Password982 |
 | MsgServer_Password991 |
 | MsgServer_PasswordDelete |
 | MsgServer_PasswordExpired |
 | MsgServer_PasswordNoChange |
 | MsgServer_PasswordSave |
 | MsgServer_PasswordTooLong |
 | MsgServer_PasswordTooShort |
 | MsgServer_PasswordTooShort2 |
 | MsgServer_PasswordTooSimple |
 | MsgServer_PopulateAborted |
 | MsgServer_PopulateComplete |
 | MsgServer_PopulateIsVirtual |
 | MsgServer_PortMissing |
 | MsgServer_PropertyAdd |
 | MsgServer_PropertyDelete |
 | MsgServer_ProxyChain |
 | MsgServer_ProxyDelivered |
 | MsgServer_ProxyNoRemote |
 | MsgServer_ProxyUpdateFail |
 | MsgServer_PullCommandRunning |
 | MsgServer_PullJournalDate |
 | MsgServer_PullJournalSummary |
 | MsgServer_PullNotReplica |
 | MsgServer_PullOnDemand |
 | MsgServer_PullTransferChange |
 | MsgServer_PullTransferPending |
 | MsgServer_PullTransferSummary |
 | MsgServer_PurgeBadOption |
 | MsgServer_PurgeOptGone |
 | MsgServer_PurgeReport |
 | MsgServer_PurgeWarning |
 | MsgServer_QuiesceFailed |
 | MsgServer_Quiescing |
 | MsgServer_ReDowngrade |
 | MsgServer_RemoteInvalidCmd |
 | MsgServer_RemoteNotAllowed |
 | MsgServer_ReopenNotOwnerCL |
 | MsgServer_ReplicaBadOption |
 | MsgServer_ReplicaNoUpgrade |
 | MsgServer_ReplicaRestricted |
 | MsgServer_ReplicaServerTime |
 | MsgServer_ReplicaWrongClient |
 | MsgServer_ReplicaWrongLabel |
 | MsgServer_ReplicaWrongServer |
 | MsgServer_ReplicaXferFailed |
 | MsgServer_RequiresJournaling |
 | MsgServer_ResolvedFile |
 | MsgServer_ResolvedSkipped |
 | MsgServer_ResolveOptAuto |
 | MsgServer_ResolveOptHelp |
 | MsgServer_ResolveOptMerge |
 | MsgServer_ResolveOptSkip |
 | MsgServer_ResolveOptTheirs |
 | MsgServer_ResolveOptYours |
 | MsgServer_ResolveOrRevert |
 | MsgServer_ResolvePromptMerge |
 | MsgServer_ResolvePromptTheirs |
 | MsgServer_ResolvePromptType |
 | MsgServer_ResolvePromptYours |
 | MsgServer_ResolveTampered |
 | MsgServer_ResolveUserError |
 | MsgServer_ResolveUserPrompt |
 | MsgServer_ResolveUserPrompt2 |
 | MsgServer_Restarted |
 | MsgServer_Restarting |
 | MsgServer_RetypeInvalidTempobj |
 | MsgServer_RmtAuthFailed |
 | MsgServer_SearchResult |
 | MsgServer_ServerID |
 | MsgServer_ServerIDAlreadySet |
 | MsgServer_ServerTooOld |
 | MsgServer_ServiceNotProvided |
 | MsgServer_ShelveAborted |
 | MsgServer_ShelveBegin |
 | MsgServer_ShelveComplete |
 | MsgServer_ShelveDelete |
 | MsgServer_ShelveMaxSize |
 | MsgServer_ShelveTriggersFailed |
 | MsgServer_ShelveXOpen |
 | MsgServer_Shutdown |
 | MsgServer_SkippedJnls |
 | MsgServer_SnapReport |
 | MsgServer_SpecArchiveWarning |
 | MsgServer_SpecCheckTriggers |
 | MsgServer_SpecNotCorrect |
 | MsgServer_SSOfailed |
 | MsgServer_SSOInvalid |
 | MsgServer_SSONoEnv |
 | MsgServer_Startup |
 | MsgServer_StartupCommandError |
 | MsgServer_SubmitAborted |
 | MsgServer_SubmitBegin |
 | MsgServer_SubmitComplete |
 | MsgServer_SubmitDataChanged |
 | MsgServer_SubmitFailed |
 | MsgServer_SubmitIsShelved |
 | MsgServer_SubmitLocking |
 | MsgServer_SubmitNeedsShelved |
 | MsgServer_SubmitRenamed |
 | MsgServer_SubmitShelvedAborted |
 | MsgServer_SubmitShelvedFailed |
 | MsgServer_SubmitShelvedHasTask |
 | MsgServer_SubmitTampered |
 | MsgServer_TargetAccessFailed |
 | MsgServer_TemporaryLabelInfo |
 | MsgServer_TicketOnly |
 | MsgServer_TooManyCommands |
 | MsgServer_TooManySortTraits |
 | MsgServer_TrackCommand |
 | MsgServer_TransferCancelled |
 | MsgServer_TransferNotReplica |
 | MsgServer_TriggerFailed |
 | MsgServer_TriggerOutput |
 | MsgServer_TriggersFailed |
 | MsgServer_TZMismatch |
 | MsgServer_Unicode |
 | MsgServer_Unicode2 |
 | MsgServer_UnknownReplicationMode |
 | MsgServer_UnknownReplicationTarget |
 | MsgServer_Unlicensed |
 | MsgServer_UnloadDepotMissing |
 | MsgServer_UnloadOtherUser |
 | MsgServer_UnshelveFileChanged |
 | MsgServer_UnshelveNotOwner |
 | MsgServer_Usage |
 | MsgServer_UseAdmin |
 | MsgServer_UseAdminCheckpoint |
 | MsgServer_UseAdminCopyin |
 | MsgServer_UseAdminCopyout |
 | MsgServer_UseAdminDBSigs |
 | MsgServer_UseAdminImport |
 | MsgServer_UseAdminJournal |
 | MsgServer_UseAdminResetPassword |
 | MsgServer_UseAdminSpecDepot |
 | MsgServer_UseAnnotate |
 | MsgServer_UseArchive |
 | MsgServer_UseBranch |
 | MsgServer_UseBranchd |
 | MsgServer_UseBranches |
 | MsgServer_UseBranchi |
 | MsgServer_UseBrancho |
 | MsgServer_UseCachepurge |
 | MsgServer_UseChange |
 | MsgServer_UseChanged |
 | MsgServer_UseChangei |
 | MsgServer_UseChangeo |
 | MsgServer_UseChanges |
 | MsgServer_UseChanget |
 | MsgServer_UseChangeU |
 | MsgServer_UseChangeUt |
 | MsgServer_UseClean |
 | MsgServer_UseClient |
 | MsgServer_UseClientd |
 | MsgServer_UseClienti |
 | MsgServer_UseCliento |
 | MsgServer_UseClients |
 | MsgServer_UseClientS |
 | MsgServer_UseCluster |
 | MsgServer_UseConfigure |
 | MsgServer_UseCopy |
 | MsgServer_UseCopyb |
 | MsgServer_UseCopyS |
 | MsgServer_UseCounter |
 | MsgServer_UseCounteri |
 | MsgServer_UseCounters |
 | MsgServer_UseCstat |
 | MsgServer_UseDbpack |
 | MsgServer_UseDbstat |
 | MsgServer_UseDbverify |
 | MsgServer_UseDepot |
 | MsgServer_UseDepotd |
 | MsgServer_UseDepoti |
 | MsgServer_UseDepoto |
 | MsgServer_UseDepots |
 | MsgServer_UseDescribe |
 | MsgServer_UseDiff |
 | MsgServer_UseDiff2 |
 | MsgServer_UseDiff2b |
 | MsgServer_UseDiff2n |
 | MsgServer_UseDiff2S |
 | MsgServer_UseDirs |
 | MsgServer_UseDiskspace |
 | MsgServer_UseDomainClients |
 | MsgServer_UseDomains |
 | MsgServer_UseDup |
 | MsgServer_UseExport |
 | MsgServer_UseFilelog |
 | MsgServer_UseFiles |
 | MsgServer_UseFix |
 | MsgServer_UseFixes |
 | MsgServer_UseFstat |
 | MsgServer_UseGrep |
 | MsgServer_UseGroup |
 | MsgServer_UseGroupd |
 | MsgServer_UseGroupi |
 | MsgServer_UseGroupo |
 | MsgServer_UseGroups |
 | MsgServer_UseHave |
 | MsgServer_UseHelp |
 | MsgServer_UseIndex |
 | MsgServer_UseInfo |
 | MsgServer_UseInteg |
 | MsgServer_UseIntegb |
 | MsgServer_UseInteged |
 | MsgServer_UseIntegS |
 | MsgServer_UseInterChanges |
 | MsgServer_UseInterChangesb |
 | MsgServer_UseInterChangesS |
 | MsgServer_UseIstat |
 | MsgServer_UseJob |
 | MsgServer_UseJobd |
 | MsgServer_UseJobi |
 | MsgServer_UseJobo |
 | MsgServer_UseJobs |
 | MsgServer_UseJobSpec |
 | MsgServer_UseJournals |
 | MsgServer_UseJournalWait |
 | MsgServer_UseKey |
 | MsgServer_UseKeyi |
 | MsgServer_UseKeys |
 | MsgServer_UseLabel |
 | MsgServer_UseLabeld |
 | MsgServer_UseLabeli |
 | MsgServer_UseLabelo |
 | MsgServer_UseLabels |
 | MsgServer_UseLabelSync |
 | MsgServer_UseLicense |
 | MsgServer_UseList |
 | MsgServer_UseLock |
 | MsgServer_UseLockstat |
 | MsgServer_UseLogAppend |
 | MsgServer_UseLogger |
 | MsgServer_UseLogin |
 | MsgServer_UseLogout |
 | MsgServer_UseLogParse |
 | MsgServer_UseLogRotate |
 | MsgServer_UseLogSchema |
 | MsgServer_UseLogstat |
 | MsgServer_UseLogtail |
 | MsgServer_UseMain |
 | MsgServer_UseMerge |
 | MsgServer_UseMergeb |
 | MsgServer_UseMergeS |
 | MsgServer_UseMonitor |
 | MsgServer_UseMonitorc |
 | MsgServer_UseMonitorf |
 | MsgServer_UseMonitorP |
 | MsgServer_UseMonitorR |
 | MsgServer_UseMonitors |
 | MsgServer_UseMove |
 | MsgServer_UseOpen |
 | MsgServer_UseOpen2 |
 | MsgServer_UseOpened |
 | MsgServer_UseOpened2 |
 | MsgServer_UsePasswd |
 | MsgServer_UsePing |
 | MsgServer_UsePopulate |
 | MsgServer_UsePopulateb |
 | MsgServer_UsePopulateS |
 | MsgServer_UsePrint |
 | MsgServer_UseProperty |
 | MsgServer_UseProtect |
 | MsgServer_UseProtects |
 | MsgServer_UseProxy |
 | MsgServer_UseProxyInfo |
 | MsgServer_UsePull |
 | MsgServer_UsePurge |
 | MsgServer_UseReconcile |
 | MsgServer_UseRelease |
 | MsgServer_UseReload |
 | MsgServer_UseRenameUser |
 | MsgServer_UseReopen |
 | MsgServer_UseResolve |
 | MsgServer_UseResolved |
 | MsgServer_UseRestore |
 | MsgServer_UseRetype |
 | MsgServer_UseReview |
 | MsgServer_UseReviews |
 | MsgServer_UserRenamed |
 | MsgServer_UsersCRNotBoth |
 | MsgServer_UsersCRNotReplica |
 | MsgServer_UseSearch |
 | MsgServer_UseServer |
 | MsgServer_UseServerd |
 | MsgServer_UseServeri |
 | MsgServer_UseServerid |
 | MsgServer_UseServero |
 | MsgServer_UseServers |
 | MsgServer_UseShelve |
 | MsgServer_UseShelvec |
 | MsgServer_UseShelvei |
 | MsgServer_UseShelveNoOpts |
 | MsgServer_UseShelver |
 | MsgServer_UseSizes |
 | MsgServer_UseSnap |
 | MsgServer_UseSpec |
 | MsgServer_UseStatus |
 | MsgServer_UseStream |
 | MsgServer_UseStreamc |
 | MsgServer_UseStreamd |
 | MsgServer_UseStreami |
 | MsgServer_UseStreamo |
 | MsgServer_UseStreams |
 | MsgServer_UseSubmit |
 | MsgServer_UseSubmitc |
 | MsgServer_UseSubmitd |
 | MsgServer_UseSubmite |
 | MsgServer_UseSync |
 | MsgServer_UseSyncp |
 | MsgServer_UseSyncs |
 | MsgServer_UseTag |
 | MsgServer_UseTrait |
 | MsgServer_UseTraiti |
 | MsgServer_UseTransmit |
 | MsgServer_UseTriggers |
 | MsgServer_UseTunables |
 | MsgServer_UseTypeMap |
 | MsgServer_UseUnload |
 | MsgServer_UseUnlock |
 | MsgServer_UseUnshelve |
 | MsgServer_UseUser |
 | MsgServer_UseUserd |
 | MsgServer_UseUseri |
 | MsgServer_UseUsero |
 | MsgServer_UseUsers |
 | MsgServer_UseVerify |
 | MsgServer_UseWhere |
 | MsgServer_VersionedStream |
 | MsgServer_WeakPassword |
 | MsgServer_ZFlagsConflict |
 | MsgSpec_SpecBranch |
 | MsgSpec_SpecChange |
 | MsgSpec_SpecClient |
 | MsgSpec_SpecDepot |
 | MsgSpec_SpecEditSpec |
 | MsgSpec_SpecGroup |
 | MsgSpec_SpecJob |
 | MsgSpec_SpecLabel |
 | MsgSpec_SpecLicense |
 | MsgSpec_SpecProtect |
 | MsgSpec_SpecServer |
 | MsgSpec_SpecStream |
 | MsgSpec_SpecTrigger |
 | MsgSpec_SpecTypeMap |
 | MsgSpec_SpecUser |
 | MsgSupp_BadMangleParams |
 | MsgSupp_BadOS |
 | MsgSupp_ConvertFailed |
 | MsgSupp_Deflate |
 | MsgSupp_DeflateEnd |
 | MsgSupp_DeflateInit |
 | MsgSupp_ExtraArg |
 | MsgSupp_HidesVar |
 | MsgSupp_Inflate |
 | MsgSupp_InflateInit |
 | MsgSupp_Invalid |
 | MsgSupp_InvalidCharset |
 | MsgSupp_InvalidDate |
 | MsgSupp_MagicHeader |
 | MsgSupp_Needs2Arg |
 | MsgSupp_NeedsArg |
 | MsgSupp_NeedsNonNegArg |
 | MsgSupp_NoP4Config |
 | MsgSupp_NoParm |
 | MsgSupp_NoSuchVariable |
 | MsgSupp_NotImplemented |
 | MsgSupp_NoTrans |
 | MsgSupp_NoTransVar |
 | MsgSupp_NoUnixReg |
 | MsgSupp_OptionAcceptFlags |
 | MsgSupp_OptionAdministrator |
 | MsgSupp_OptionAfterContext |
 | MsgSupp_OptionAll |
 | MsgSupp_OptionAllClients |
 | MsgSupp_OptionAllUsers |
 | MsgSupp_OptionAppend |
 | MsgSupp_OptionArchive |
 | MsgSupp_OptionArchiveData |
 | MsgSupp_OptionArguments |
 | MsgSupp_OptionAttrPattern |
 | MsgSupp_OptionBackoff |
 | MsgSupp_OptionBasicRegexp |
 | MsgSupp_OptionBatchsize |
 | MsgSupp_OptionBeforeContext |
 | MsgSupp_OptionBinaryAsText |
 | MsgSupp_OptionBlocksize |
 | MsgSupp_OptionBranch |
 | MsgSupp_OptionBrief |
 | MsgSupp_OptionBypassFlow |
 | MsgSupp_OptionCentralUsers |
 | MsgSupp_OptionChange |
 | MsgSupp_OptionChangeStatus |
 | MsgSupp_OptionChangeType |
 | MsgSupp_OptionChangeUpdate |
 | MsgSupp_OptionChangeUser |
 | MsgSupp_OptionCharset |
 | MsgSupp_OptionCheckSize |
 | MsgSupp_OptionClient |
 | MsgSupp_OptionClientName |
 | MsgSupp_OptionCmdCharset |
 | MsgSupp_OptionCompress |
 | MsgSupp_OptionCompressCkp |
 | MsgSupp_OptionContent |
 | MsgSupp_OptionContext |
 | MsgSupp_OptionCounter |
 | MsgSupp_OptionData |
 | MsgSupp_OptionDate |
 | MsgSupp_OptionDelete |
 | MsgSupp_OptionDeleteFlags |
 | MsgSupp_OptionDepot |
 | MsgSupp_OptionDescription |
 | MsgSupp_OptionDiffFlags |
 | MsgSupp_OptionDiffListFlag |
 | MsgSupp_OptionDirectory |
 | MsgSupp_OptionDowngrade |
 | MsgSupp_OptionEncoded |
 | MsgSupp_OptionEnvironment |
 | MsgSupp_OptionEqual |
 | MsgSupp_OptionEstimates |
 | MsgSupp_OptionExcludeTables |
 | MsgSupp_OptionExclusive |
 | MsgSupp_OptionExists |
 | MsgSupp_OptionExpression |
 | MsgSupp_OptionExtendedRegexp |
 | MsgSupp_OptionFile |
 | MsgSupp_OptionFileCharset |
 | MsgSupp_OptionFilesWithMatches |
 | MsgSupp_OptionFilesWithoutMatch |
 | MsgSupp_OptionFiletype |
 | MsgSupp_OptionFilter |
 | MsgSupp_OptionFixedStrings |
 | MsgSupp_OptionFixStatus |
 | MsgSupp_OptionFollowBranch |
 | MsgSupp_OptionFollowInteg |
 | MsgSupp_OptionForce |
 | MsgSupp_OptionForceFlag |
 | MsgSupp_OptionForceText |
 | MsgSupp_OptionFrom |
 | MsgSupp_OptionFullBranch |
 | MsgSupp_OptionGenerate |
 | MsgSupp_OptionGlobal |
 | MsgSupp_OptionGroupName |
 | MsgSupp_OptionHelp |
 | MsgSupp_OptionHistogram |
 | MsgSupp_OptionHost |
 | MsgSupp_OptionHostName |
 | MsgSupp_OptionHuman1000 |
 | MsgSupp_OptionHuman1024 |
 | MsgSupp_OptionIgnoreCase |
 | MsgSupp_OptionIncrement |
 | MsgSupp_OptionInherited |
 | MsgSupp_OptionInput |
 | MsgSupp_OptionInputFile |
 | MsgSupp_OptionInputValue |
 | MsgSupp_OptionIntegFlags |
 | MsgSupp_OptionInvertMatch |
 | MsgSupp_OptionIsGroup |
 | MsgSupp_OptionIsOwner |
 | MsgSupp_OptionIsUser |
 | MsgSupp_OptionJob |
 | MsgSupp_OptionJournalPosition |
 | MsgSupp_OptionJournalPrefix |
 | MsgSupp_OptionKeepClient |
 | MsgSupp_OptionKeepHave |
 | MsgSupp_OptionKeepHead |
 | MsgSupp_OptionLabelName |
 | MsgSupp_OptionLeaveKeywords |
 | MsgSupp_OptionLimitClient |
 | MsgSupp_OptionLineNumber |
 | MsgSupp_OptionLocal |
 | MsgSupp_OptionLocked |
 | MsgSupp_OptionLoginStatus |
 | MsgSupp_OptionLogName |
 | MsgSupp_OptionLong |
 | MsgSupp_OptionMax |
 | MsgSupp_OptionMaxAccess |
 | MsgSupp_OptionMessageType |
 | MsgSupp_OptionName |
 | MsgSupp_OptionNo |
 | MsgSupp_OptionNoArchive |
 | MsgSupp_OptionNoCaseExpr |
 | MsgSupp_OptionNoIgnore |
 | MsgSupp_OptionNoMessages |
 | MsgSupp_OptionNoRejournal |
 | MsgSupp_OptionOmitLazy |
 | MsgSupp_OptionOmitMoved |
 | MsgSupp_OptionOmitPromoted |
 | MsgSupp_OptionOpenAdd |
 | MsgSupp_OptionOpenDelete |
 | MsgSupp_OptionOpenEdit |
 | MsgSupp_OptionOriginal |
 | MsgSupp_OptionOutput |
 | MsgSupp_OptionOutputBase |
 | MsgSupp_OptionOutputFile |
 | MsgSupp_OptionOutputFlags |
 | MsgSupp_OptionOwner |
 | MsgSupp_OptionParallel |
 | MsgSupp_OptionParent |
 | MsgSupp_OptionPassword |
 | MsgSupp_OptionPerlRegexp |
 | MsgSupp_OptionPidFile |
 | MsgSupp_OptionPort |
 | MsgSupp_OptionPreview |
 | MsgSupp_OptionPreviewNC |
 | MsgSupp_OptionPrint |
 | MsgSupp_OptionProgress |
 | MsgSupp_OptionPromote |
 | MsgSupp_OptionPropagating |
 | MsgSupp_OptionPublish |
 | MsgSupp_OptionPullServerid |
 | MsgSupp_OptionPurge |
 | MsgSupp_OptionQuiet |
 | MsgSupp_OptionRebuild |
 | MsgSupp_OptionRegexp |
 | MsgSupp_OptionReopen |
 | MsgSupp_OptionRepeat |
 | MsgSupp_OptionReplace |
 | MsgSupp_OptionReplacement |
 | MsgSupp_OptionReplicaUsers |
 | MsgSupp_OptionResolveFlags |
 | MsgSupp_OptionRestrictFlags |
 | MsgSupp_OptionRetries |
 | MsgSupp_OptionReverse |
 | MsgSupp_OptionRevision |
 | MsgSupp_OptionRunOnMaster |
 | MsgSupp_OptionSafe |
 | MsgSupp_OptionSequence |
 | MsgSupp_OptionServerid |
 | MsgSupp_OptionService |
 | MsgSupp_OptionShelf |
 | MsgSupp_OptionShelved |
 | MsgSupp_OptionShelveOpts |
 | MsgSupp_OptionShort |
 | MsgSupp_OptionShowChange |
 | MsgSupp_OptionShowFiles |
 | MsgSupp_OptionShowFlags |
 | MsgSupp_OptionShowTime |
 | MsgSupp_OptionSortFlags |
 | MsgSupp_OptionSourceFile |
 | MsgSupp_OptionSpecFixStatus |
 | MsgSupp_OptionSpecType |
 | MsgSupp_OptionStartPosition |
 | MsgSupp_OptionStatus |
 | MsgSupp_OptionStream |
 | MsgSupp_OptionStreamName |
 | MsgSupp_OptionStreamType |
 | MsgSupp_OptionSubmitOpts |
 | MsgSupp_OptionSubmitShelf |
 | MsgSupp_OptionSummary |
 | MsgSupp_OptionSwitch |
 | MsgSupp_OptionSystem |
 | MsgSupp_OptionTableName |
 | MsgSupp_OptionTableNotUnlocked |
 | MsgSupp_OptionTags |
 | MsgSupp_OptionTamper |
 | MsgSupp_OptionTaskStatus |
 | MsgSupp_OptionTemplate |
 | MsgSupp_OptionTemporary |
 | MsgSupp_OptionTo |
 | MsgSupp_OptionTransfer |
 | MsgSupp_OptionUnchanged |
 | MsgSupp_OptionUnified |
 | MsgSupp_OptionUnload |
 | MsgSupp_OptionUnloadAll |
 | MsgSupp_OptionUpdate |
 | MsgSupp_OptionUsage |
 | MsgSupp_OptionUseList |
 | MsgSupp_OptionUseModTime |
 | MsgSupp_OptionUser |
 | MsgSupp_OptionValue |
 | MsgSupp_OptionVariable |
 | MsgSupp_OptionVerbose |
 | MsgSupp_OptionVerify |
 | MsgSupp_OptionVersion |
 | MsgSupp_OptionVirtual |
 | MsgSupp_OptionVirtualStream |
 | MsgSupp_OptionWipe |
 | MsgSupp_OptionXargs |
 | MsgSupp_OptionYes |
 | MsgSupp_PartialChar |
 | MsgSupp_RegexError |
 | MsgSupp_TooMany |
 | MsgSupp_Usage |
 | MsgSupp_VariableData |
 | MsgSupp_WrongArg |
 | MsgSupp_ZCBrowseFailed |
 | MsgSupp_ZCInvalidName |
 | MsgSupp_ZCLoadLibFailed |
 | MsgSupp_ZCNameConflict |
 | MsgSupp_ZCRegistryFailed |
 | MsgSupp_ZCRequireName |
Public field | SeverityLevel | How severe is the error
 | usage |
 | Usage |

See Also

P4ClientError Class


clientUpdate Field

[image]

Perforce .NET API
P4ClientError..::..clientUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int clientUpdate
Visual Basic
Public Shared clientUpdate As Integer
Visual C++
public:
static int clientUpdate

See Also

P4ClientError Class


ErrorCode Field

[image]

Perforce .NET API
P4ClientError..::..ErrorCode Field
P4ClientError Class See Also Send Feedback
Generic code for the error

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ErrorCode
Visual Basic
Public ErrorCode As Integer
Visual C++
public:
int ErrorCode

See Also

P4ClientError Class


ErrorMessage Field

[image]

Perforce .NET API
P4ClientError..::..ErrorMessage Field
P4ClientError Class See Also Send Feedback
Descriptive error message

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ErrorMessage
Visual Basic
Public ErrorMessage As String
Visual C++
public:
String^ ErrorMessage

See Also

P4ClientError Class


MsgClient_BadFlag Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_BadFlag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_BadFlag
Visual Basic
Public Shared MsgClient_BadFlag As Integer
Visual C++
public:
static int MsgClient_BadFlag

See Also

P4ClientError Class


MsgClient_BadMarshalInput Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_BadMarshalInput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_BadMarshalInput
Visual Basic
Public Shared MsgClient_BadMarshalInput As Integer
Visual C++
public:
static int MsgClient_BadMarshalInput

See Also

P4ClientError Class


MsgClient_BadSignature Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_BadSignature Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_BadSignature
Visual Basic
Public Shared MsgClient_BadSignature As Integer
Visual C++
public:
static int MsgClient_BadSignature

See Also

P4ClientError Class


MsgClient_CantEdit Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_CantEdit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_CantEdit
Visual Basic
Public Shared MsgClient_CantEdit As Integer
Visual C++
public:
static int MsgClient_CantEdit

See Also

P4ClientError Class


MsgClient_CantFindApp Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_CantFindApp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_CantFindApp
Visual Basic
Public Shared MsgClient_CantFindApp As Integer
Visual C++
public:
static int MsgClient_CantFindApp

See Also

P4ClientError Class


MsgClient_CheckFileAssume Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_CheckFileAssume Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_CheckFileAssume
Visual Basic
Public Shared MsgClient_CheckFileAssume As Integer
Visual C++
public:
static int MsgClient_CheckFileAssume

See Also

P4ClientError Class


MsgClient_CheckFileAssumeWild Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_CheckFileAssumeWild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_CheckFileAssumeWild
Visual Basic
Public Shared MsgClient_CheckFileAssumeWild As Integer
Visual C++
public:
static int MsgClient_CheckFileAssumeWild

See Also

P4ClientError Class


MsgClient_CheckFileCant Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_CheckFileCant Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_CheckFileCant
Visual Basic
Public Shared MsgClient_CheckFileCant As Integer
Visual C++
public:
static int MsgClient_CheckFileCant

See Also

P4ClientError Class


MsgClient_CheckFileSubst Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_CheckFileSubst Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_CheckFileSubst
Visual Basic
Public Shared MsgClient_CheckFileSubst As Integer
Visual C++
public:
static int MsgClient_CheckFileSubst

See Also

P4ClientError Class


MsgClient_ClobberFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ClobberFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ClobberFile
Visual Basic
Public Shared MsgClient_ClobberFile As Integer
Visual C++
public:
static int MsgClient_ClobberFile

See Also

P4ClientError Class


MsgClient_Confirm Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_Confirm Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_Confirm
Visual Basic
Public Shared MsgClient_Confirm As Integer
Visual C++
public:
static int MsgClient_Confirm

See Also

P4ClientError Class


MsgClient_ConfirmEdit Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ConfirmEdit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ConfirmEdit
Visual Basic
Public Shared MsgClient_ConfirmEdit As Integer
Visual C++
public:
static int MsgClient_ConfirmEdit

See Also

P4ClientError Class


MsgClient_ConfirmMarkers Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ConfirmMarkers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ConfirmMarkers
Visual Basic
Public Shared MsgClient_ConfirmMarkers As Integer
Visual C++
public:
static int MsgClient_ConfirmMarkers

See Also

P4ClientError Class


MsgClient_Connect Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_Connect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_Connect
Visual Basic
Public Shared MsgClient_Connect As Integer
Visual C++
public:
static int MsgClient_Connect

See Also

P4ClientError Class


MsgClient_DigestMisMatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_DigestMisMatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_DigestMisMatch
Visual Basic
Public Shared MsgClient_DigestMisMatch As Integer
Visual C++
public:
static int MsgClient_DigestMisMatch

See Also

P4ClientError Class


MsgClient_Eof Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_Eof Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_Eof
Visual Basic
Public Shared MsgClient_Eof As Integer
Visual C++
public:
static int MsgClient_Eof

See Also

P4ClientError Class


MsgClient_Fatal Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_Fatal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_Fatal
Visual Basic
Public Shared MsgClient_Fatal As Integer
Visual C++
public:
static int MsgClient_Fatal

See Also

P4ClientError Class


MsgClient_FileExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_FileExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_FileExists
Visual Basic
Public Shared MsgClient_FileExists As Integer
Visual C++
public:
static int MsgClient_FileExists

See Also

P4ClientError Class


MsgClient_FileOpenError Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_FileOpenError Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_FileOpenError
Visual Basic
Public Shared MsgClient_FileOpenError As Integer
Visual C++
public:
static int MsgClient_FileOpenError

See Also

P4ClientError Class


MsgClient_LineTooLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_LineTooLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_LineTooLong
Visual Basic
Public Shared MsgClient_LineTooLong As Integer
Visual C++
public:
static int MsgClient_LineTooLong

See Also

P4ClientError Class


MsgClient_LoginPrintTicket Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_LoginPrintTicket Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_LoginPrintTicket
Visual Basic
Public Shared MsgClient_LoginPrintTicket As Integer
Visual C++
public:
static int MsgClient_LoginPrintTicket

See Also

P4ClientError Class


MsgClient_Memory Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_Memory Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_Memory
Visual Basic
Public Shared MsgClient_Memory As Integer
Visual C++
public:
static int MsgClient_Memory

See Also

P4ClientError Class


MsgClient_MergeMsg2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_MergeMsg2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_MergeMsg2
Visual Basic
Public Shared MsgClient_MergeMsg2 As Integer
Visual C++
public:
static int MsgClient_MergeMsg2

See Also

P4ClientError Class


MsgClient_MergeMsg3 Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_MergeMsg3 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_MergeMsg3
Visual Basic
Public Shared MsgClient_MergeMsg3 As Integer
Visual C++
public:
static int MsgClient_MergeMsg3

See Also

P4ClientError Class


MsgClient_MergeMsg32 Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_MergeMsg32 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_MergeMsg32
Visual Basic
Public Shared MsgClient_MergeMsg32 As Integer
Visual C++
public:
static int MsgClient_MergeMsg32

See Also

P4ClientError Class


MsgClient_MergePrompt Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_MergePrompt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_MergePrompt
Visual Basic
Public Shared MsgClient_MergePrompt As Integer
Visual C++
public:
static int MsgClient_MergePrompt

See Also

P4ClientError Class


MsgClient_MergePrompt2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_MergePrompt2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_MergePrompt2
Visual Basic
Public Shared MsgClient_MergePrompt2 As Integer
Visual C++
public:
static int MsgClient_MergePrompt2

See Also

P4ClientError Class


MsgClient_MergePrompt2Edit Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_MergePrompt2Edit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_MergePrompt2Edit
Visual Basic
Public Shared MsgClient_MergePrompt2Edit As Integer
Visual C++
public:
static int MsgClient_MergePrompt2Edit

See Also

P4ClientError Class


MsgClient_MkDir Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_MkDir Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_MkDir
Visual Basic
Public Shared MsgClient_MkDir As Integer
Visual C++
public:
static int MsgClient_MkDir

See Also

P4ClientError Class


MsgClient_NoMerger Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_NoMerger Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_NoMerger
Visual Basic
Public Shared MsgClient_NoMerger As Integer
Visual C++
public:
static int MsgClient_NoMerger

See Also

P4ClientError Class


MsgClient_NonTextFileMerge Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_NonTextFileMerge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_NonTextFileMerge
Visual Basic
Public Shared MsgClient_NonTextFileMerge As Integer
Visual C++
public:
static int MsgClient_NonTextFileMerge

See Also

P4ClientError Class


MsgClient_NoSuchFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_NoSuchFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_NoSuchFile
Visual Basic
Public Shared MsgClient_NoSuchFile As Integer
Visual C++
public:
static int MsgClient_NoSuchFile

See Also

P4ClientError Class


MsgClient_NotUnderPath Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_NotUnderPath Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_NotUnderPath
Visual Basic
Public Shared MsgClient_NotUnderPath As Integer
Visual C++
public:
static int MsgClient_NotUnderPath

See Also

P4ClientError Class


MsgClient_ResolveManually Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ResolveManually Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ResolveManually
Visual Basic
Public Shared MsgClient_ResolveManually As Integer
Visual C++
public:
static int MsgClient_ResolveManually

See Also

P4ClientError Class


MsgClient_ToolCmdCreate Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ToolCmdCreate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ToolCmdCreate
Visual Basic
Public Shared MsgClient_ToolCmdCreate As Integer
Visual C++
public:
static int MsgClient_ToolCmdCreate

See Also

P4ClientError Class


MsgClient_ToolCmdSend Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ToolCmdSend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ToolCmdSend
Visual Basic
Public Shared MsgClient_ToolCmdSend As Integer
Visual C++
public:
static int MsgClient_ToolCmdSend

See Also

P4ClientError Class


MsgClient_ToolServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ToolServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ToolServer
Visual Basic
Public Shared MsgClient_ToolServer As Integer
Visual C++
public:
static int MsgClient_ToolServer

See Also

P4ClientError Class


MsgClient_ToolServer2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ToolServer2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ToolServer2
Visual Basic
Public Shared MsgClient_ToolServer2 As Integer
Visual C++
public:
static int MsgClient_ToolServer2

See Also

P4ClientError Class


MsgClient_ZCResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgClient_ZCResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgClient_ZCResolve
Visual Basic
Public Shared MsgClient_ZCResolve As Integer
Visual C++
public:
static int MsgClient_ZCResolve

See Also

P4ClientError Class


MsgDb_AddressChanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_AddressChanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_AddressChanged
Visual Basic
Public Shared MsgDb_AddressChanged As Integer
Visual C++
public:
static int MsgDb_AddressChanged

See Also

P4ClientError Class


MsgDb_BadIPservice Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_BadIPservice Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_BadIPservice
Visual Basic
Public Shared MsgDb_BadIPservice As Integer
Visual C++
public:
static int MsgDb_BadIPservice

See Also

P4ClientError Class


MsgDb_CaseMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_CaseMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_CaseMismatch
Visual Basic
Public Shared MsgDb_CaseMismatch As Integer
Visual C++
public:
static int MsgDb_CaseMismatch

See Also

P4ClientError Class


MsgDb_CheckpointNoOverwrite Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_CheckpointNoOverwrite Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_CheckpointNoOverwrite
Visual Basic
Public Shared MsgDb_CheckpointNoOverwrite As Integer
Visual C++
public:
static int MsgDb_CheckpointNoOverwrite

See Also

P4ClientError Class


MsgDb_Checksum Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Checksum Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Checksum
Visual Basic
Public Shared MsgDb_Checksum As Integer
Visual C++
public:
static int MsgDb_Checksum

See Also

P4ClientError Class


MsgDb_ClientGone Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ClientGone Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ClientGone
Visual Basic
Public Shared MsgDb_ClientGone As Integer
Visual C++
public:
static int MsgDb_ClientGone

See Also

P4ClientError Class


MsgDb_CommandCancelled Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_CommandCancelled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_CommandCancelled
Visual Basic
Public Shared MsgDb_CommandCancelled As Integer
Visual C++
public:
static int MsgDb_CommandCancelled

See Also

P4ClientError Class


MsgDb_DbOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_DbOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_DbOpen
Visual Basic
Public Shared MsgDb_DbOpen As Integer
Visual C++
public:
static int MsgDb_DbOpen

See Also

P4ClientError Class


MsgDb_DbStat Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_DbStat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_DbStat
Visual Basic
Public Shared MsgDb_DbStat As Integer
Visual C++
public:
static int MsgDb_DbStat

See Also

P4ClientError Class


MsgDb_Delete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Delete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Delete
Visual Basic
Public Shared MsgDb_Delete As Integer
Visual C++
public:
static int MsgDb_Delete

See Also

P4ClientError Class


MsgDb_DelNoLock Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_DelNoLock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_DelNoLock
Visual Basic
Public Shared MsgDb_DelNoLock As Integer
Visual C++
public:
static int MsgDb_DelNoLock

See Also

P4ClientError Class


MsgDb_Duplicate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Duplicate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Duplicate
Visual Basic
Public Shared MsgDb_Duplicate As Integer
Visual C++
public:
static int MsgDb_Duplicate

See Also

P4ClientError Class


MsgDb_EndXact Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_EndXact Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_EndXact
Visual Basic
Public Shared MsgDb_EndXact As Integer
Visual C++
public:
static int MsgDb_EndXact

See Also

P4ClientError Class


MsgDb_ExtraDots Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ExtraDots Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ExtraDots
Visual Basic
Public Shared MsgDb_ExtraDots As Integer
Visual C++
public:
static int MsgDb_ExtraDots

See Also

P4ClientError Class


MsgDb_ExtraStars Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ExtraStars Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ExtraStars
Visual Basic
Public Shared MsgDb_ExtraStars As Integer
Visual C++
public:
static int MsgDb_ExtraStars

See Also

P4ClientError Class


MsgDb_Field2Many Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Field2Many Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Field2Many
Visual Basic
Public Shared MsgDb_Field2Many As Integer
Visual C++
public:
static int MsgDb_Field2Many

See Also

P4ClientError Class


MsgDb_FieldBadIndex Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_FieldBadIndex Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_FieldBadIndex
Visual Basic
Public Shared MsgDb_FieldBadIndex As Integer
Visual C++
public:
static int MsgDb_FieldBadIndex

See Also

P4ClientError Class


MsgDb_FieldBadVal Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_FieldBadVal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_FieldBadVal
Visual Basic
Public Shared MsgDb_FieldBadVal As Integer
Visual C++
public:
static int MsgDb_FieldBadVal

See Also

P4ClientError Class


MsgDb_FieldMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_FieldMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_FieldMissing
Visual Basic
Public Shared MsgDb_FieldMissing As Integer
Visual C++
public:
static int MsgDb_FieldMissing

See Also

P4ClientError Class


MsgDb_FieldOptBad Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_FieldOptBad Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_FieldOptBad
Visual Basic
Public Shared MsgDb_FieldOptBad As Integer
Visual C++
public:
static int MsgDb_FieldOptBad

See Also

P4ClientError Class


MsgDb_FieldTypeBad Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_FieldTypeBad Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_FieldTypeBad
Visual Basic
Public Shared MsgDb_FieldTypeBad As Integer
Visual C++
public:
static int MsgDb_FieldTypeBad

See Also

P4ClientError Class


MsgDb_FieldUnknown Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_FieldUnknown Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_FieldUnknown
Visual Basic
Public Shared MsgDb_FieldUnknown As Integer
Visual C++
public:
static int MsgDb_FieldUnknown

See Also

P4ClientError Class


MsgDb_FieldWords Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_FieldWords Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_FieldWords
Visual Basic
Public Shared MsgDb_FieldWords As Integer
Visual C++
public:
static int MsgDb_FieldWords

See Also

P4ClientError Class


MsgDb_GetFormat Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_GetFormat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_GetFormat
Visual Basic
Public Shared MsgDb_GetFormat As Integer
Visual C++
public:
static int MsgDb_GetFormat

See Also

P4ClientError Class


MsgDb_GetNoGet Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_GetNoGet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_GetNoGet
Visual Basic
Public Shared MsgDb_GetNoGet As Integer
Visual C++
public:
static int MsgDb_GetNoGet

See Also

P4ClientError Class


MsgDb_InternalUsage Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_InternalUsage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_InternalUsage
Visual Basic
Public Shared MsgDb_InternalUsage As Integer
Visual C++
public:
static int MsgDb_InternalUsage

See Also

P4ClientError Class


MsgDb_JnlBadMarker Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlBadMarker Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlBadMarker
Visual Basic
Public Shared MsgDb_JnlBadMarker As Integer
Visual C++
public:
static int MsgDb_JnlBadMarker

See Also

P4ClientError Class


MsgDb_JnlBadVers Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlBadVers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlBadVers
Visual Basic
Public Shared MsgDb_JnlBadVers As Integer
Visual C++
public:
static int MsgDb_JnlBadVers

See Also

P4ClientError Class


MsgDb_JnlCaseUsageBad Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlCaseUsageBad Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlCaseUsageBad
Visual Basic
Public Shared MsgDb_JnlCaseUsageBad As Integer
Visual C++
public:
static int MsgDb_JnlCaseUsageBad

See Also

P4ClientError Class


MsgDb_JnlDeleteFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlDeleteFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlDeleteFailed
Visual Basic
Public Shared MsgDb_JnlDeleteFailed As Integer
Visual C++
public:
static int MsgDb_JnlDeleteFailed

See Also

P4ClientError Class


MsgDb_JnlEnd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlEnd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlEnd
Visual Basic
Public Shared MsgDb_JnlEnd As Integer
Visual C++
public:
static int MsgDb_JnlEnd

See Also

P4ClientError Class


MsgDb_JnlFileBad Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlFileBad Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlFileBad
Visual Basic
Public Shared MsgDb_JnlFileBad As Integer
Visual C++
public:
static int MsgDb_JnlFileBad

See Also

P4ClientError Class


MsgDb_JnlNoName Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlNoName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlNoName
Visual Basic
Public Shared MsgDb_JnlNoName As Integer
Visual C++
public:
static int MsgDb_JnlNoName

See Also

P4ClientError Class


MsgDb_JnlNoTVers Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlNoTVers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlNoTVers
Visual Basic
Public Shared MsgDb_JnlNoTVers As Integer
Visual C++
public:
static int MsgDb_JnlNoTVers

See Also

P4ClientError Class


MsgDb_JnlNoVers Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlNoVers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlNoVers
Visual Basic
Public Shared MsgDb_JnlNoVers As Integer
Visual C++
public:
static int MsgDb_JnlNoVers

See Also

P4ClientError Class


MsgDb_JnlNum2Big Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlNum2Big Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlNum2Big
Visual Basic
Public Shared MsgDb_JnlNum2Big As Integer
Visual C++
public:
static int MsgDb_JnlNum2Big

See Also

P4ClientError Class


MsgDb_JnlOct2Long Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlOct2Long Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlOct2Long
Visual Basic
Public Shared MsgDb_JnlOct2Long As Integer
Visual C++
public:
static int MsgDb_JnlOct2Long

See Also

P4ClientError Class


MsgDb_JnlOctSize Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlOctSize Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlOctSize
Visual Basic
Public Shared MsgDb_JnlOctSize As Integer
Visual C++
public:
static int MsgDb_JnlOctSize

See Also

P4ClientError Class


MsgDb_JnlOpcode Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlOpcode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlOpcode
Visual Basic
Public Shared MsgDb_JnlOpcode As Integer
Visual C++
public:
static int MsgDb_JnlOpcode

See Also

P4ClientError Class


MsgDb_JnlQuoting Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlQuoting Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlQuoting
Visual Basic
Public Shared MsgDb_JnlQuoting As Integer
Visual C++
public:
static int MsgDb_JnlQuoting

See Also

P4ClientError Class


MsgDb_JnlReplay Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlReplay Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlReplay
Visual Basic
Public Shared MsgDb_JnlReplay As Integer
Visual C++
public:
static int MsgDb_JnlReplay

See Also

P4ClientError Class


MsgDb_JnlSeqBad Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlSeqBad Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlSeqBad
Visual Basic
Public Shared MsgDb_JnlSeqBad As Integer
Visual C++
public:
static int MsgDb_JnlSeqBad

See Also

P4ClientError Class


MsgDb_JnlVersionError Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlVersionError Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlVersionError
Visual Basic
Public Shared MsgDb_JnlVersionError As Integer
Visual C++
public:
static int MsgDb_JnlVersionError

See Also

P4ClientError Class


MsgDb_JnlVersionMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlVersionMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlVersionMismatch
Visual Basic
Public Shared MsgDb_JnlVersionMismatch As Integer
Visual C++
public:
static int MsgDb_JnlVersionMismatch

See Also

P4ClientError Class


MsgDb_JnlWord2Big Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_JnlWord2Big Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_JnlWord2Big
Visual Basic
Public Shared MsgDb_JnlWord2Big As Integer
Visual C++
public:
static int MsgDb_JnlWord2Big

See Also

P4ClientError Class


MsgDb_Juxtaposed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Juxtaposed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Juxtaposed
Visual Basic
Public Shared MsgDb_Juxtaposed As Integer
Visual C++
public:
static int MsgDb_Juxtaposed

See Also

P4ClientError Class


MsgDb_KeyTooBig Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_KeyTooBig Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_KeyTooBig
Visual Basic
Public Shared MsgDb_KeyTooBig As Integer
Visual C++
public:
static int MsgDb_KeyTooBig

See Also

P4ClientError Class


MsgDb_LicenseBad Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_LicenseBad Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_LicenseBad
Visual Basic
Public Shared MsgDb_LicenseBad As Integer
Visual C++
public:
static int MsgDb_LicenseBad

See Also

P4ClientError Class


MsgDb_LicenseExp Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_LicenseExp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_LicenseExp
Visual Basic
Public Shared MsgDb_LicenseExp As Integer
Visual C++
public:
static int MsgDb_LicenseExp

See Also

P4ClientError Class


MsgDb_LicenseNeedsApplication Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_LicenseNeedsApplication Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_LicenseNeedsApplication
Visual Basic
Public Shared MsgDb_LicenseNeedsApplication As Integer
Visual C++
public:
static int MsgDb_LicenseNeedsApplication

See Also

P4ClientError Class


MsgDb_LicenseRead Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_LicenseRead Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_LicenseRead
Visual Basic
Public Shared MsgDb_LicenseRead As Integer
Visual C++
public:
static int MsgDb_LicenseRead

See Also

P4ClientError Class


MsgDb_LineNo Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_LineNo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_LineNo
Visual Basic
Public Shared MsgDb_LineNo As Integer
Visual C++
public:
static int MsgDb_LineNo

See Also

P4ClientError Class


MsgDb_Locking Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Locking Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Locking
Visual Basic
Public Shared MsgDb_Locking As Integer
Visual C++
public:
static int MsgDb_Locking

See Also

P4ClientError Class


MsgDb_LockOrder Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_LockOrder Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_LockOrder
Visual Basic
Public Shared MsgDb_LockOrder As Integer
Visual C++
public:
static int MsgDb_LockOrder

See Also

P4ClientError Class


MsgDb_LockUpgrade Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_LockUpgrade Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_LockUpgrade
Visual Basic
Public Shared MsgDb_LockUpgrade As Integer
Visual C++
public:
static int MsgDb_LockUpgrade

See Also

P4ClientError Class


MsgDb_MapCheckFail Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_MapCheckFail Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_MapCheckFail
Visual Basic
Public Shared MsgDb_MapCheckFail As Integer
Visual C++
public:
static int MsgDb_MapCheckFail

See Also

P4ClientError Class


MsgDb_MaxMemory Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_MaxMemory Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_MaxMemory
Visual Basic
Public Shared MsgDb_MaxMemory As Integer
Visual C++
public:
static int MsgDb_MaxMemory

See Also

P4ClientError Class


MsgDb_MaxResults Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_MaxResults Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_MaxResults
Visual Basic
Public Shared MsgDb_MaxResults As Integer
Visual C++
public:
static int MsgDb_MaxResults

See Also

P4ClientError Class


MsgDb_MaxScanRows Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_MaxScanRows Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_MaxScanRows
Visual Basic
Public Shared MsgDb_MaxScanRows As Integer
Visual C++
public:
static int MsgDb_MaxScanRows

See Also

P4ClientError Class


MsgDb_MustExpire Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_MustExpire Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_MustExpire
Visual Basic
Public Shared MsgDb_MustExpire As Integer
Visual C++
public:
static int MsgDb_MustExpire

See Also

P4ClientError Class


MsgDb_NoEndQuote Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_NoEndQuote Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_NoEndQuote
Visual Basic
Public Shared MsgDb_NoEndQuote As Integer
Visual C++
public:
static int MsgDb_NoEndQuote

See Also

P4ClientError Class


MsgDb_NotUnderClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_NotUnderClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_NotUnderClient
Visual Basic
Public Shared MsgDb_NotUnderClient As Integer
Visual C++
public:
static int MsgDb_NotUnderClient

See Also

P4ClientError Class


MsgDb_NotUnderRoot Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_NotUnderRoot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_NotUnderRoot
Visual Basic
Public Shared MsgDb_NotUnderRoot As Integer
Visual C++
public:
static int MsgDb_NotUnderRoot

See Also

P4ClientError Class


MsgDb_ParseErr Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ParseErr Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ParseErr
Visual Basic
Public Shared MsgDb_ParseErr As Integer
Visual C++
public:
static int MsgDb_ParseErr

See Also

P4ClientError Class


MsgDb_PlatPre972 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_PlatPre972 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_PlatPre972
Visual Basic
Public Shared MsgDb_PlatPre972 As Integer
Visual C++
public:
static int MsgDb_PlatPre972

See Also

P4ClientError Class


MsgDb_Read Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Read Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Read
Visual Basic
Public Shared MsgDb_Read As Integer
Visual C++
public:
static int MsgDb_Read

See Also

P4ClientError Class


MsgDb_ReadNoLock Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ReadNoLock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ReadNoLock
Visual Basic
Public Shared MsgDb_ReadNoLock As Integer
Visual C++
public:
static int MsgDb_ReadNoLock

See Also

P4ClientError Class


MsgDb_Scan Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Scan Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Scan
Visual Basic
Public Shared MsgDb_Scan As Integer
Visual C++
public:
static int MsgDb_Scan

See Also

P4ClientError Class


MsgDb_ScanFormat Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ScanFormat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ScanFormat
Visual Basic
Public Shared MsgDb_ScanFormat As Integer
Visual C++
public:
static int MsgDb_ScanFormat

See Also

P4ClientError Class


MsgDb_ScanNoLock Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ScanNoLock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ScanNoLock
Visual Basic
Public Shared MsgDb_ScanNoLock As Integer
Visual C++
public:
static int MsgDb_ScanNoLock

See Also

P4ClientError Class


MsgDb_ServerTooNew Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ServerTooNew Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ServerTooNew
Visual Basic
Public Shared MsgDb_ServerTooNew As Integer
Visual C++
public:
static int MsgDb_ServerTooNew

See Also

P4ClientError Class


MsgDb_Stumblebum Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Stumblebum Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Stumblebum
Visual Basic
Public Shared MsgDb_Stumblebum As Integer
Visual C++
public:
static int MsgDb_Stumblebum

See Also

P4ClientError Class


MsgDb_SupportExp Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_SupportExp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_SupportExp
Visual Basic
Public Shared MsgDb_SupportExp As Integer
Visual C++
public:
static int MsgDb_SupportExp

See Also

P4ClientError Class


MsgDb_Syntax Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Syntax Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Syntax
Visual Basic
Public Shared MsgDb_Syntax As Integer
Visual C++
public:
static int MsgDb_Syntax

See Also

P4ClientError Class


MsgDb_TableCheckSum Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TableCheckSum Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TableCheckSum
Visual Basic
Public Shared MsgDb_TableCheckSum As Integer
Visual C++
public:
static int MsgDb_TableCheckSum

See Also

P4ClientError Class


MsgDb_TableObsolete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TableObsolete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TableObsolete
Visual Basic
Public Shared MsgDb_TableObsolete As Integer
Visual C++
public:
static int MsgDb_TableObsolete

See Also

P4ClientError Class


MsgDb_TableUnknown Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TableUnknown Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TableUnknown
Visual Basic
Public Shared MsgDb_TableUnknown As Integer
Visual C++
public:
static int MsgDb_TableUnknown

See Also

P4ClientError Class


MsgDb_TooWild Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TooWild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TooWild
Visual Basic
Public Shared MsgDb_TooWild As Integer
Visual C++
public:
static int MsgDb_TooWild

See Also

P4ClientError Class


MsgDb_TooWild2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TooWild2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TooWild2
Visual Basic
Public Shared MsgDb_TooWild2 As Integer
Visual C++
public:
static int MsgDb_TooWild2

See Also

P4ClientError Class


MsgDb_TreeAllocation Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeAllocation Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeAllocation
Visual Basic
Public Shared MsgDb_TreeAllocation As Integer
Visual C++
public:
static int MsgDb_TreeAllocation

See Also

P4ClientError Class


MsgDb_TreeAlreadyUpgraded Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeAlreadyUpgraded Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeAlreadyUpgraded
Visual Basic
Public Shared MsgDb_TreeAlreadyUpgraded As Integer
Visual C++
public:
static int MsgDb_TreeAlreadyUpgraded

See Also

P4ClientError Class


MsgDb_TreeCorrupt Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeCorrupt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeCorrupt
Visual Basic
Public Shared MsgDb_TreeCorrupt As Integer
Visual C++
public:
static int MsgDb_TreeCorrupt

See Also

P4ClientError Class


MsgDb_TreeInternal Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeInternal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeInternal
Visual Basic
Public Shared MsgDb_TreeInternal As Integer
Visual C++
public:
static int MsgDb_TreeInternal

See Also

P4ClientError Class


MsgDb_TreeNewerVersion Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeNewerVersion Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeNewerVersion
Visual Basic
Public Shared MsgDb_TreeNewerVersion As Integer
Visual C++
public:
static int MsgDb_TreeNewerVersion

See Also

P4ClientError Class


MsgDb_TreeNotOpened Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeNotOpened Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeNotOpened
Visual Basic
Public Shared MsgDb_TreeNotOpened As Integer
Visual C++
public:
static int MsgDb_TreeNotOpened

See Also

P4ClientError Class


MsgDb_TreeNotSupported Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeNotSupported Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeNotSupported
Visual Basic
Public Shared MsgDb_TreeNotSupported As Integer
Visual C++
public:
static int MsgDb_TreeNotSupported

See Also

P4ClientError Class


MsgDb_TreeOlderVersion Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_TreeOlderVersion Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_TreeOlderVersion
Visual Basic
Public Shared MsgDb_TreeOlderVersion As Integer
Visual C++
public:
static int MsgDb_TreeOlderVersion

See Also

P4ClientError Class


MsgDb_ValidationFoundProblems Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_ValidationFoundProblems Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_ValidationFoundProblems
Visual Basic
Public Shared MsgDb_ValidationFoundProblems As Integer
Visual C++
public:
static int MsgDb_ValidationFoundProblems

See Also

P4ClientError Class


MsgDb_WildMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_WildMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_WildMismatch
Visual Basic
Public Shared MsgDb_WildMismatch As Integer
Visual C++
public:
static int MsgDb_WildMismatch

See Also

P4ClientError Class


MsgDb_Write Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_Write Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_Write
Visual Basic
Public Shared MsgDb_Write As Integer
Visual C++
public:
static int MsgDb_Write

See Also

P4ClientError Class


MsgDb_WriteNoLock Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_WriteNoLock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_WriteNoLock
Visual Basic
Public Shared MsgDb_WriteNoLock As Integer
Visual C++
public:
static int MsgDb_WriteNoLock

See Also

P4ClientError Class


MsgDb_WrongApp Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_WrongApp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_WrongApp
Visual Basic
Public Shared MsgDb_WrongApp As Integer
Visual C++
public:
static int MsgDb_WrongApp

See Also

P4ClientError Class


MsgDb_XactOutstandingRestart Field

[image]

Perforce .NET API
P4ClientError..::..MsgDb_XactOutstandingRestart Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDb_XactOutstandingRestart
Visual Basic
Public Shared MsgDb_XactOutstandingRestart As Integer
Visual C++
public:
static int MsgDb_XactOutstandingRestart

See Also

P4ClientError Class


MsgDm_AddHaveVsRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AddHaveVsRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AddHaveVsRev
Visual Basic
Public Shared MsgDm_AddHaveVsRev As Integer
Visual C++
public:
static int MsgDm_AddHaveVsRev

See Also

P4ClientError Class


MsgDm_AdminLockDataEx Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AdminLockDataEx Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AdminLockDataEx
Visual Basic
Public Shared MsgDm_AdminLockDataEx As Integer
Visual C++
public:
static int MsgDm_AdminLockDataEx

See Also

P4ClientError Class


MsgDm_AdminLockDataSh Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AdminLockDataSh Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AdminLockDataSh
Visual Basic
Public Shared MsgDm_AdminLockDataSh As Integer
Visual C++
public:
static int MsgDm_AdminLockDataSh

See Also

P4ClientError Class


MsgDm_AdminPasswordData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AdminPasswordData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AdminPasswordData
Visual Basic
Public Shared MsgDm_AdminPasswordData As Integer
Visual C++
public:
static int MsgDm_AdminPasswordData

See Also

P4ClientError Class


MsgDm_AdminSpecData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AdminSpecData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AdminSpecData
Visual Basic
Public Shared MsgDm_AdminSpecData As Integer
Visual C++
public:
static int MsgDm_AdminSpecData

See Also

P4ClientError Class


MsgDm_AlreadyCommitted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AlreadyCommitted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AlreadyCommitted
Visual Basic
Public Shared MsgDm_AlreadyCommitted As Integer
Visual C++
public:
static int MsgDm_AlreadyCommitted

See Also

P4ClientError Class


MsgDm_AlreadyUnloaded Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AlreadyUnloaded Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AlreadyUnloaded
Visual Basic
Public Shared MsgDm_AlreadyUnloaded As Integer
Visual C++
public:
static int MsgDm_AlreadyUnloaded

See Also

P4ClientError Class


MsgDm_AnnotateTooBig Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AnnotateTooBig Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AnnotateTooBig
Visual Basic
Public Shared MsgDm_AnnotateTooBig As Integer
Visual C++
public:
static int MsgDm_AnnotateTooBig

See Also

P4ClientError Class


MsgDm_ArchiveFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ArchiveFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ArchiveFailed
Visual Basic
Public Shared MsgDm_ArchiveFailed As Integer
Visual C++
public:
static int MsgDm_ArchiveFailed

See Also

P4ClientError Class


MsgDm_AtMostOne Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_AtMostOne Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_AtMostOne
Visual Basic
Public Shared MsgDm_AtMostOne As Integer
Visual C++
public:
static int MsgDm_AtMostOne

See Also

P4ClientError Class


MsgDm_BadAtRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadAtRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadAtRev
Visual Basic
Public Shared MsgDm_BadAtRev As Integer
Visual C++
public:
static int MsgDm_BadAtRev

See Also

P4ClientError Class


MsgDm_BadCaller Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadCaller Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadCaller
Visual Basic
Public Shared MsgDm_BadCaller As Integer
Visual C++
public:
static int MsgDm_BadCaller

See Also

P4ClientError Class


MsgDm_BadChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadChange
Visual Basic
Public Shared MsgDm_BadChange As Integer
Visual C++
public:
static int MsgDm_BadChange

See Also

P4ClientError Class


MsgDm_BadDigest Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadDigest Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadDigest
Visual Basic
Public Shared MsgDm_BadDigest As Integer
Visual C++
public:
static int MsgDm_BadDigest

See Also

P4ClientError Class


MsgDm_BadIntegFlag Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadIntegFlag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadIntegFlag
Visual Basic
Public Shared MsgDm_BadIntegFlag As Integer
Visual C++
public:
static int MsgDm_BadIntegFlag

See Also

P4ClientError Class


MsgDm_BadJobPresets Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadJobPresets Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadJobPresets
Visual Basic
Public Shared MsgDm_BadJobPresets As Integer
Visual C++
public:
static int MsgDm_BadJobPresets

See Also

P4ClientError Class


MsgDm_BadJobTemplate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadJobTemplate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadJobTemplate
Visual Basic
Public Shared MsgDm_BadJobTemplate As Integer
Visual C++
public:
static int MsgDm_BadJobTemplate

See Also

P4ClientError Class


MsgDm_BadJobView Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadJobView Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadJobView
Visual Basic
Public Shared MsgDm_BadJobView As Integer
Visual C++
public:
static int MsgDm_BadJobView

See Also

P4ClientError Class


MsgDm_BadMappedFileName Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadMappedFileName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadMappedFileName
Visual Basic
Public Shared MsgDm_BadMappedFileName As Integer
Visual C++
public:
static int MsgDm_BadMappedFileName

See Also

P4ClientError Class


MsgDm_BadMaxResult Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadMaxResult Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadMaxResult
Visual Basic
Public Shared MsgDm_BadMaxResult As Integer
Visual C++
public:
static int MsgDm_BadMaxResult

See Also

P4ClientError Class


MsgDm_BadMaxScanRow Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadMaxScanRow Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadMaxScanRow
Visual Basic
Public Shared MsgDm_BadMaxScanRow As Integer
Visual C++
public:
static int MsgDm_BadMaxScanRow

See Also

P4ClientError Class


MsgDm_BadOpenFlag Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadOpenFlag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadOpenFlag
Visual Basic
Public Shared MsgDm_BadOpenFlag As Integer
Visual C++
public:
static int MsgDm_BadOpenFlag

See Also

P4ClientError Class


MsgDm_BadOption Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadOption Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadOption
Visual Basic
Public Shared MsgDm_BadOption As Integer
Visual C++
public:
static int MsgDm_BadOption

See Also

P4ClientError Class


MsgDm_BadRevision Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadRevision Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadRevision
Visual Basic
Public Shared MsgDm_BadRevision As Integer
Visual C++
public:
static int MsgDm_BadRevision

See Also

P4ClientError Class


MsgDm_BadRevPend Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadRevPend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadRevPend
Visual Basic
Public Shared MsgDm_BadRevPend As Integer
Visual C++
public:
static int MsgDm_BadRevPend

See Also

P4ClientError Class


MsgDm_BadRevRel Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadRevRel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadRevRel
Visual Basic
Public Shared MsgDm_BadRevRel As Integer
Visual C++
public:
static int MsgDm_BadRevRel

See Also

P4ClientError Class


MsgDm_BadRevSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadRevSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadRevSpec
Visual Basic
Public Shared MsgDm_BadRevSpec As Integer
Visual C++
public:
static int MsgDm_BadRevSpec

See Also

P4ClientError Class


MsgDm_BadSequence Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadSequence Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadSequence
Visual Basic
Public Shared MsgDm_BadSequence As Integer
Visual C++
public:
static int MsgDm_BadSequence

See Also

P4ClientError Class


MsgDm_BadSpecType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadSpecType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadSpecType
Visual Basic
Public Shared MsgDm_BadSpecType As Integer
Visual C++
public:
static int MsgDm_BadSpecType

See Also

P4ClientError Class


MsgDm_BadStorageCombo Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadStorageCombo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadStorageCombo
Visual Basic
Public Shared MsgDm_BadStorageCombo As Integer
Visual C++
public:
static int MsgDm_BadStorageCombo

See Also

P4ClientError Class


MsgDm_BadTemplate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadTemplate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadTemplate
Visual Basic
Public Shared MsgDm_BadTemplate As Integer
Visual C++
public:
static int MsgDm_BadTemplate

See Also

P4ClientError Class


MsgDm_BadTimeout Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadTimeout Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadTimeout
Visual Basic
Public Shared MsgDm_BadTimeout As Integer
Visual C++
public:
static int MsgDm_BadTimeout

See Also

P4ClientError Class


MsgDm_BadType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadType
Visual Basic
Public Shared MsgDm_BadType As Integer
Visual C++
public:
static int MsgDm_BadType

See Also

P4ClientError Class


MsgDm_BadTypeAuto Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadTypeAuto Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadTypeAuto
Visual Basic
Public Shared MsgDm_BadTypeAuto As Integer
Visual C++
public:
static int MsgDm_BadTypeAuto

See Also

P4ClientError Class


MsgDm_BadTypeCombo Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadTypeCombo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadTypeCombo
Visual Basic
Public Shared MsgDm_BadTypeCombo As Integer
Visual C++
public:
static int MsgDm_BadTypeCombo

See Also

P4ClientError Class


MsgDm_BadTypeMod Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadTypeMod Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadTypeMod
Visual Basic
Public Shared MsgDm_BadTypeMod As Integer
Visual C++
public:
static int MsgDm_BadTypeMod

See Also

P4ClientError Class


MsgDm_BadTypePartial Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadTypePartial Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadTypePartial
Visual Basic
Public Shared MsgDm_BadTypePartial As Integer
Visual C++
public:
static int MsgDm_BadTypePartial

See Also

P4ClientError Class


MsgDm_BadVersionCount Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BadVersionCount Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BadVersionCount
Visual Basic
Public Shared MsgDm_BadVersionCount As Integer
Visual C++
public:
static int MsgDm_BadVersionCount

See Also

P4ClientError Class


MsgDm_BindingNotAllowed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BindingNotAllowed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BindingNotAllowed
Visual Basic
Public Shared MsgDm_BindingNotAllowed As Integer
Visual C++
public:
static int MsgDm_BindingNotAllowed

See Also

P4ClientError Class


MsgDm_BoundToOtherServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BoundToOtherServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BoundToOtherServer
Visual Basic
Public Shared MsgDm_BoundToOtherServer As Integer
Visual C++
public:
static int MsgDm_BoundToOtherServer

See Also

P4ClientError Class


MsgDm_BucketAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketAdd
Visual Basic
Public Shared MsgDm_BucketAdd As Integer
Visual C++
public:
static int MsgDm_BucketAdd

See Also

P4ClientError Class


MsgDm_BucketNoFilesToArchive Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketNoFilesToArchive Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketNoFilesToArchive
Visual Basic
Public Shared MsgDm_BucketNoFilesToArchive As Integer
Visual C++
public:
static int MsgDm_BucketNoFilesToArchive

See Also

P4ClientError Class


MsgDm_BucketNoFilesToPurge Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketNoFilesToPurge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketNoFilesToPurge
Visual Basic
Public Shared MsgDm_BucketNoFilesToPurge As Integer
Visual C++
public:
static int MsgDm_BucketNoFilesToPurge

See Also

P4ClientError Class


MsgDm_BucketNoFilesToRestore Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketNoFilesToRestore Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketNoFilesToRestore
Visual Basic
Public Shared MsgDm_BucketNoFilesToRestore As Integer
Visual C++
public:
static int MsgDm_BucketNoFilesToRestore

See Also

P4ClientError Class


MsgDm_BucketPurge Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketPurge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketPurge
Visual Basic
Public Shared MsgDm_BucketPurge As Integer
Visual C++
public:
static int MsgDm_BucketPurge

See Also

P4ClientError Class


MsgDm_BucketRestore Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketRestore Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketRestore
Visual Basic
Public Shared MsgDm_BucketRestore As Integer
Visual C++
public:
static int MsgDm_BucketRestore

See Also

P4ClientError Class


MsgDm_BucketSkipBranched Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketSkipBranched Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketSkipBranched
Visual Basic
Public Shared MsgDm_BucketSkipBranched As Integer
Visual C++
public:
static int MsgDm_BucketSkipBranched

See Also

P4ClientError Class


MsgDm_BucketSkipBucketed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketSkipBucketed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketSkipBucketed
Visual Basic
Public Shared MsgDm_BucketSkipBucketed As Integer
Visual C++
public:
static int MsgDm_BucketSkipBucketed

See Also

P4ClientError Class


MsgDm_BucketSkipHead Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketSkipHead Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketSkipHead
Visual Basic
Public Shared MsgDm_BucketSkipHead As Integer
Visual C++
public:
static int MsgDm_BucketSkipHead

See Also

P4ClientError Class


MsgDm_BucketSkipLazy Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketSkipLazy Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketSkipLazy
Visual Basic
Public Shared MsgDm_BucketSkipLazy As Integer
Visual C++
public:
static int MsgDm_BucketSkipLazy

See Also

P4ClientError Class


MsgDm_BucketSkipType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_BucketSkipType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_BucketSkipType
Visual Basic
Public Shared MsgDm_BucketSkipType As Integer
Visual C++
public:
static int MsgDm_BucketSkipType

See Also

P4ClientError Class


MsgDm_CachePurgeFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CachePurgeFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CachePurgeFile
Visual Basic
Public Shared MsgDm_CachePurgeFile As Integer
Visual C++
public:
static int MsgDm_CachePurgeFile

See Also

P4ClientError Class


MsgDm_CantChangeUnloadedOpt Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CantChangeUnloadedOpt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CantChangeUnloadedOpt
Visual Basic
Public Shared MsgDm_CantChangeUnloadedOpt As Integer
Visual C++
public:
static int MsgDm_CantChangeUnloadedOpt

See Also

P4ClientError Class


MsgDm_CantChangeUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CantChangeUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CantChangeUser
Visual Basic
Public Shared MsgDm_CantChangeUser As Integer
Visual C++
public:
static int MsgDm_CantChangeUser

See Also

P4ClientError Class


MsgDm_CantChangeUserType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CantChangeUserType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CantChangeUserType
Visual Basic
Public Shared MsgDm_CantChangeUserType As Integer
Visual C++
public:
static int MsgDm_CantChangeUserType

See Also

P4ClientError Class


MsgDm_CantFindChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CantFindChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CantFindChange
Visual Basic
Public Shared MsgDm_CantFindChange As Integer
Visual C++
public:
static int MsgDm_CantFindChange

See Also

P4ClientError Class


MsgDm_CantOpenHere Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CantOpenHere Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CantOpenHere
Visual Basic
Public Shared MsgDm_CantOpenHere As Integer
Visual C++
public:
static int MsgDm_CantOpenHere

See Also

P4ClientError Class


MsgDm_ChangeCreated Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeCreated Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeCreated
Visual Basic
Public Shared MsgDm_ChangeCreated As Integer
Visual C++
public:
static int MsgDm_ChangeCreated

See Also

P4ClientError Class


MsgDm_ChangeDeleteHasFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeDeleteHasFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeDeleteHasFiles
Visual Basic
Public Shared MsgDm_ChangeDeleteHasFiles As Integer
Visual C++
public:
static int MsgDm_ChangeDeleteHasFiles

See Also

P4ClientError Class


MsgDm_ChangeDeleteHasFix Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeDeleteHasFix Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeDeleteHasFix
Visual Basic
Public Shared MsgDm_ChangeDeleteHasFix As Integer
Visual C++
public:
static int MsgDm_ChangeDeleteHasFix

See Also

P4ClientError Class


MsgDm_ChangeDeleteOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeDeleteOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeDeleteOpen
Visual Basic
Public Shared MsgDm_ChangeDeleteOpen As Integer
Visual C++
public:
static int MsgDm_ChangeDeleteOpen

See Also

P4ClientError Class


MsgDm_ChangeDeleteShelved Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeDeleteShelved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeDeleteShelved
Visual Basic
Public Shared MsgDm_ChangeDeleteShelved As Integer
Visual C++
public:
static int MsgDm_ChangeDeleteShelved

See Also

P4ClientError Class


MsgDm_ChangeDeleteSuccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeDeleteSuccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeDeleteSuccess
Visual Basic
Public Shared MsgDm_ChangeDeleteSuccess As Integer
Visual C++
public:
static int MsgDm_ChangeDeleteSuccess

See Also

P4ClientError Class


MsgDm_ChangeExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeExists
Visual Basic
Public Shared MsgDm_ChangeExists As Integer
Visual C++
public:
static int MsgDm_ChangeExists

See Also

P4ClientError Class


MsgDm_ChangeNotOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeNotOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeNotOwner
Visual Basic
Public Shared MsgDm_ChangeNotOwner As Integer
Visual C++
public:
static int MsgDm_ChangeNotOwner

See Also

P4ClientError Class


MsgDm_ChangeNotShelved Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeNotShelved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeNotShelved
Visual Basic
Public Shared MsgDm_ChangeNotShelved As Integer
Visual C++
public:
static int MsgDm_ChangeNotShelved

See Also

P4ClientError Class


MsgDm_ChangesData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangesData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangesData
Visual Basic
Public Shared MsgDm_ChangesData As Integer
Visual C++
public:
static int MsgDm_ChangesData

See Also

P4ClientError Class


MsgDm_ChangesDataPending Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangesDataPending Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangesDataPending
Visual Basic
Public Shared MsgDm_ChangesDataPending As Integer
Visual C++
public:
static int MsgDm_ChangesDataPending

See Also

P4ClientError Class


MsgDm_ChangeUpdated Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ChangeUpdated Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ChangeUpdated
Visual Basic
Public Shared MsgDm_ChangeUpdated As Integer
Visual C++
public:
static int MsgDm_ChangeUpdated

See Also

P4ClientError Class


MsgDm_CheckFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CheckFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CheckFailed
Visual Basic
Public Shared MsgDm_CheckFailed As Integer
Visual C++
public:
static int MsgDm_CheckFailed

See Also

P4ClientError Class


MsgDm_ClassicSwitch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ClassicSwitch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ClassicSwitch
Visual Basic
Public Shared MsgDm_ClassicSwitch As Integer
Visual C++
public:
static int MsgDm_ClassicSwitch

See Also

P4ClientError Class


MsgDm_ClientBoundToServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ClientBoundToServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ClientBoundToServer
Visual Basic
Public Shared MsgDm_ClientBoundToServer As Integer
Visual C++
public:
static int MsgDm_ClientBoundToServer

See Also

P4ClientError Class


MsgDm_ClientTooOld Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ClientTooOld Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ClientTooOld
Visual Basic
Public Shared MsgDm_ClientTooOld As Integer
Visual C++
public:
static int MsgDm_ClientTooOld

See Also

P4ClientError Class


MsgDm_CommandCancelled Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CommandCancelled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CommandCancelled
Visual Basic
Public Shared MsgDm_CommandCancelled As Integer
Visual C++
public:
static int MsgDm_CommandCancelled

See Also

P4ClientError Class


MsgDm_CommittedNoPerm Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CommittedNoPerm Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CommittedNoPerm
Visual Basic
Public Shared MsgDm_CommittedNoPerm As Integer
Visual C++
public:
static int MsgDm_CommittedNoPerm

See Also

P4ClientError Class


MsgDm_ConcurrentFileChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ConcurrentFileChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ConcurrentFileChange
Visual Basic
Public Shared MsgDm_ConcurrentFileChange As Integer
Visual C++
public:
static int MsgDm_ConcurrentFileChange

See Also

P4ClientError Class


MsgDm_ConfigData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ConfigData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ConfigData
Visual Basic
Public Shared MsgDm_ConfigData As Integer
Visual C++
public:
static int MsgDm_ConfigData

See Also

P4ClientError Class


MsgDm_ConfigWasNotSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ConfigWasNotSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ConfigWasNotSet
Visual Basic
Public Shared MsgDm_ConfigWasNotSet As Integer
Visual C++
public:
static int MsgDm_ConfigWasNotSet

See Also

P4ClientError Class


MsgDm_CopyChangeSummary Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CopyChangeSummary Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CopyChangeSummary
Visual Basic
Public Shared MsgDm_CopyChangeSummary As Integer
Visual C++
public:
static int MsgDm_CopyChangeSummary

See Also

P4ClientError Class


MsgDm_CopyMapSummary Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CopyMapSummary Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CopyMapSummary
Visual Basic
Public Shared MsgDm_CopyMapSummary As Integer
Visual C++
public:
static int MsgDm_CopyMapSummary

See Also

P4ClientError Class


MsgDm_CopyMoveExTo Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CopyMoveExTo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CopyMoveExTo
Visual Basic
Public Shared MsgDm_CopyMoveExTo As Integer
Visual C++
public:
static int MsgDm_CopyMoveExTo

See Also

P4ClientError Class


MsgDm_CopyMoveMapFrom Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CopyMoveMapFrom Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CopyMoveMapFrom
Visual Basic
Public Shared MsgDm_CopyMoveMapFrom As Integer
Visual C++
public:
static int MsgDm_CopyMoveMapFrom

See Also

P4ClientError Class


MsgDm_CopyMoveNoFrom Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CopyMoveNoFrom Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CopyMoveNoFrom
Visual Basic
Public Shared MsgDm_CopyMoveNoFrom As Integer
Visual C++
public:
static int MsgDm_CopyMoveNoFrom

See Also

P4ClientError Class


MsgDm_CopyOpenTarget Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CopyOpenTarget Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CopyOpenTarget
Visual Basic
Public Shared MsgDm_CopyOpenTarget As Integer
Visual C++
public:
static int MsgDm_CopyOpenTarget

See Also

P4ClientError Class


MsgDm_CountersData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_CountersData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_CountersData
Visual Basic
Public Shared MsgDm_CountersData As Integer
Visual C++
public:
static int MsgDm_CountersData

See Also

P4ClientError Class


MsgDm_DbFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DbFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DbFailed
Visual Basic
Public Shared MsgDm_DbFailed As Integer
Visual C++
public:
static int MsgDm_DbFailed

See Also

P4ClientError Class


MsgDm_DeleteMoved Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DeleteMoved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DeleteMoved
Visual Basic
Public Shared MsgDm_DeleteMoved As Integer
Visual C++
public:
static int MsgDm_DeleteMoved

See Also

P4ClientError Class


MsgDm_DepotDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotDelete
Visual Basic
Public Shared MsgDm_DepotDelete As Integer
Visual C++
public:
static int MsgDm_DepotDelete

See Also

P4ClientError Class


MsgDm_DepotHasStreams Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotHasStreams Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotHasStreams
Visual Basic
Public Shared MsgDm_DepotHasStreams As Integer
Visual C++
public:
static int MsgDm_DepotHasStreams

See Also

P4ClientError Class


MsgDm_DepotMapInvalid Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotMapInvalid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotMapInvalid
Visual Basic
Public Shared MsgDm_DepotMapInvalid As Integer
Visual C++
public:
static int MsgDm_DepotMapInvalid

See Also

P4ClientError Class


MsgDm_DepotMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotMissing
Visual Basic
Public Shared MsgDm_DepotMissing As Integer
Visual C++
public:
static int MsgDm_DepotMissing

See Also

P4ClientError Class


MsgDm_DepotNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotNoChange
Visual Basic
Public Shared MsgDm_DepotNoChange As Integer
Visual C++
public:
static int MsgDm_DepotNoChange

See Also

P4ClientError Class


MsgDm_DepotNotSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotNotSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotNotSpec
Visual Basic
Public Shared MsgDm_DepotNotSpec As Integer
Visual C++
public:
static int MsgDm_DepotNotSpec

See Also

P4ClientError Class


MsgDm_DepotNotStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotNotStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotNotStream
Visual Basic
Public Shared MsgDm_DepotNotStream As Integer
Visual C++
public:
static int MsgDm_DepotNotStream

See Also

P4ClientError Class


MsgDm_DepotSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotSave
Visual Basic
Public Shared MsgDm_DepotSave As Integer
Visual C++
public:
static int MsgDm_DepotSave

See Also

P4ClientError Class


MsgDm_DepotsData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotsData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotsData
Visual Basic
Public Shared MsgDm_DepotsData As Integer
Visual C++
public:
static int MsgDm_DepotsData

See Also

P4ClientError Class


MsgDm_DepotsDataExtra Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotsDataExtra Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotsDataExtra
Visual Basic
Public Shared MsgDm_DepotsDataExtra As Integer
Visual C++
public:
static int MsgDm_DepotsDataExtra

See Also

P4ClientError Class


MsgDm_DepotSpecDup Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotSpecDup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotSpecDup
Visual Basic
Public Shared MsgDm_DepotSpecDup As Integer
Visual C++
public:
static int MsgDm_DepotSpecDup

See Also

P4ClientError Class


MsgDm_DepotUnloadDup Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotUnloadDup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotUnloadDup
Visual Basic
Public Shared MsgDm_DepotUnloadDup As Integer
Visual C++
public:
static int MsgDm_DepotUnloadDup

See Also

P4ClientError Class


MsgDm_DepotVsDomains Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DepotVsDomains Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DepotVsDomains
Visual Basic
Public Shared MsgDm_DepotVsDomains As Integer
Visual C++
public:
static int MsgDm_DepotVsDomains

See Also

P4ClientError Class


MsgDm_DescMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DescMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DescMissing
Visual Basic
Public Shared MsgDm_DescMissing As Integer
Visual C++
public:
static int MsgDm_DescMissing

See Also

P4ClientError Class


MsgDm_DescribeChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DescribeChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DescribeChange
Visual Basic
Public Shared MsgDm_DescribeChange As Integer
Visual C++
public:
static int MsgDm_DescribeChange

See Also

P4ClientError Class


MsgDm_DescribeChangePending Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DescribeChangePending Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DescribeChangePending
Visual Basic
Public Shared MsgDm_DescribeChangePending As Integer
Visual C++
public:
static int MsgDm_DescribeChangePending

See Also

P4ClientError Class


MsgDm_DescribeData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DescribeData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DescribeData
Visual Basic
Public Shared MsgDm_DescribeData As Integer
Visual C++
public:
static int MsgDm_DescribeData

See Also

P4ClientError Class


MsgDm_DescribeDiff Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DescribeDiff Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DescribeDiff
Visual Basic
Public Shared MsgDm_DescribeDiff As Integer
Visual C++
public:
static int MsgDm_DescribeDiff

See Also

P4ClientError Class


MsgDm_DescribeMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DescribeMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DescribeMove
Visual Basic
Public Shared MsgDm_DescribeMove As Integer
Visual C++
public:
static int MsgDm_DescribeMove

See Also

P4ClientError Class


MsgDm_DfltBranchView Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DfltBranchView Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DfltBranchView
Visual Basic
Public Shared MsgDm_DfltBranchView As Integer
Visual C++
public:
static int MsgDm_DfltBranchView

See Also

P4ClientError Class


MsgDm_Diff2DataContent Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataContent Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataContent
Visual Basic
Public Shared MsgDm_Diff2DataContent As Integer
Visual C++
public:
static int MsgDm_Diff2DataContent

See Also

P4ClientError Class


MsgDm_Diff2DataIdentical Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataIdentical Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataIdentical
Visual Basic
Public Shared MsgDm_Diff2DataIdentical As Integer
Visual C++
public:
static int MsgDm_Diff2DataIdentical

See Also

P4ClientError Class


MsgDm_Diff2DataLeft Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataLeft Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataLeft
Visual Basic
Public Shared MsgDm_Diff2DataLeft As Integer
Visual C++
public:
static int MsgDm_Diff2DataLeft

See Also

P4ClientError Class


MsgDm_Diff2DataRight Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataRight Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataRight
Visual Basic
Public Shared MsgDm_Diff2DataRight As Integer
Visual C++
public:
static int MsgDm_Diff2DataRight

See Also

P4ClientError Class


MsgDm_Diff2DataRightPre041 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataRightPre041 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataRightPre041
Visual Basic
Public Shared MsgDm_Diff2DataRightPre041 As Integer
Visual C++
public:
static int MsgDm_Diff2DataRightPre041

See Also

P4ClientError Class


MsgDm_Diff2DataTypes Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataTypes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataTypes
Visual Basic
Public Shared MsgDm_Diff2DataTypes As Integer
Visual C++
public:
static int MsgDm_Diff2DataTypes

See Also

P4ClientError Class


MsgDm_Diff2DataUnified Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataUnified Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataUnified
Visual Basic
Public Shared MsgDm_Diff2DataUnified As Integer
Visual C++
public:
static int MsgDm_Diff2DataUnified

See Also

P4ClientError Class


MsgDm_Diff2DataUnifiedDiffer Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Diff2DataUnifiedDiffer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Diff2DataUnifiedDiffer
Visual Basic
Public Shared MsgDm_Diff2DataUnifiedDiffer As Integer
Visual C++
public:
static int MsgDm_Diff2DataUnifiedDiffer

See Also

P4ClientError Class


MsgDm_DiffData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DiffData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DiffData
Visual Basic
Public Shared MsgDm_DiffData As Integer
Visual C++
public:
static int MsgDm_DiffData

See Also

P4ClientError Class


MsgDm_DirsData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DirsData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DirsData
Visual Basic
Public Shared MsgDm_DirsData As Integer
Visual C++
public:
static int MsgDm_DirsData

See Also

P4ClientError Class


MsgDm_DiskSpaceEstimated Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DiskSpaceEstimated Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DiskSpaceEstimated
Visual Basic
Public Shared MsgDm_DiskSpaceEstimated As Integer
Visual C++
public:
static int MsgDm_DiskSpaceEstimated

See Also

P4ClientError Class


MsgDm_DiskSpaceMinimum Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DiskSpaceMinimum Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DiskSpaceMinimum
Visual Basic
Public Shared MsgDm_DiskSpaceMinimum As Integer
Visual C++
public:
static int MsgDm_DiskSpaceMinimum

See Also

P4ClientError Class


MsgDm_DomainDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DomainDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DomainDelete
Visual Basic
Public Shared MsgDm_DomainDelete As Integer
Visual C++
public:
static int MsgDm_DomainDelete

See Also

P4ClientError Class


MsgDm_DomainIsUnloaded Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DomainIsUnloaded Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DomainIsUnloaded
Visual Basic
Public Shared MsgDm_DomainIsUnloaded As Integer
Visual C++
public:
static int MsgDm_DomainIsUnloaded

See Also

P4ClientError Class


MsgDm_DomainNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DomainNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DomainNoChange
Visual Basic
Public Shared MsgDm_DomainNoChange As Integer
Visual C++
public:
static int MsgDm_DomainNoChange

See Also

P4ClientError Class


MsgDm_DomainSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DomainSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DomainSave
Visual Basic
Public Shared MsgDm_DomainSave As Integer
Visual C++
public:
static int MsgDm_DomainSave

See Also

P4ClientError Class


MsgDm_DomainsData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DomainsData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DomainsData
Visual Basic
Public Shared MsgDm_DomainsData As Integer
Visual C++
public:
static int MsgDm_DomainsData

See Also

P4ClientError Class


MsgDm_DomainsDataClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DomainsDataClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DomainsDataClient
Visual Basic
Public Shared MsgDm_DomainsDataClient As Integer
Visual C++
public:
static int MsgDm_DomainsDataClient

See Also

P4ClientError Class


MsgDm_DomainSwitch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DomainSwitch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DomainSwitch
Visual Basic
Public Shared MsgDm_DomainSwitch As Integer
Visual C++
public:
static int MsgDm_DomainSwitch

See Also

P4ClientError Class


MsgDm_DupExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DupExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DupExists
Visual Basic
Public Shared MsgDm_DupExists As Integer
Visual C++
public:
static int MsgDm_DupExists

See Also

P4ClientError Class


MsgDm_DupLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DupLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DupLocked
Visual Basic
Public Shared MsgDm_DupLocked As Integer
Visual C++
public:
static int MsgDm_DupLocked

See Also

P4ClientError Class


MsgDm_DupOK Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_DupOK Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_DupOK
Visual Basic
Public Shared MsgDm_DupOK As Integer
Visual C++
public:
static int MsgDm_DupOK

See Also

P4ClientError Class


MsgDm_EditSpecNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_EditSpecNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_EditSpecNoChange
Visual Basic
Public Shared MsgDm_EditSpecNoChange As Integer
Visual C++
public:
static int MsgDm_EditSpecNoChange

See Also

P4ClientError Class


MsgDm_EditSpecSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_EditSpecSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_EditSpecSave
Visual Basic
Public Shared MsgDm_EditSpecSave As Integer
Visual C++
public:
static int MsgDm_EditSpecSave

See Also

P4ClientError Class


MsgDm_EmbSpecChar Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_EmbSpecChar Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_EmbSpecChar
Visual Basic
Public Shared MsgDm_EmbSpecChar As Integer
Visual C++
public:
static int MsgDm_EmbSpecChar

See Also

P4ClientError Class


MsgDm_EmbWild Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_EmbWild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_EmbWild
Visual Basic
Public Shared MsgDm_EmbWild As Integer
Visual C++
public:
static int MsgDm_EmbWild

See Also

P4ClientError Class


MsgDm_EmptyFileName Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_EmptyFileName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_EmptyFileName
Visual Basic
Public Shared MsgDm_EmptyFileName As Integer
Visual C++
public:
static int MsgDm_EmptyFileName

See Also

P4ClientError Class


MsgDm_EmptyRelate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_EmptyRelate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_EmptyRelate
Visual Basic
Public Shared MsgDm_EmptyRelate As Integer
Visual C++
public:
static int MsgDm_EmptyRelate

See Also

P4ClientError Class


MsgDm_EmptyResults Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_EmptyResults Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_EmptyResults
Visual Basic
Public Shared MsgDm_EmptyResults As Integer
Visual C++
public:
static int MsgDm_EmptyResults

See Also

P4ClientError Class


MsgDm_ErrorInSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ErrorInSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ErrorInSpec
Visual Basic
Public Shared MsgDm_ErrorInSpec As Integer
Visual C++
public:
static int MsgDm_ErrorInSpec

See Also

P4ClientError Class


MsgDm_ExABOVECHANGE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExABOVECHANGE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExABOVECHANGE
Visual Basic
Public Shared MsgDm_ExABOVECHANGE As Integer
Visual C++
public:
static int MsgDm_ExABOVECHANGE

See Also

P4ClientError Class


MsgDm_ExABOVEDATE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExABOVEDATE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExABOVEDATE
Visual Basic
Public Shared MsgDm_ExABOVEDATE As Integer
Visual C++
public:
static int MsgDm_ExABOVEDATE

See Also

P4ClientError Class


MsgDm_ExABOVEHAVE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExABOVEHAVE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExABOVEHAVE
Visual Basic
Public Shared MsgDm_ExABOVEHAVE As Integer
Visual C++
public:
static int MsgDm_ExABOVEHAVE

See Also

P4ClientError Class


MsgDm_ExABOVELABEL Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExABOVELABEL Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExABOVELABEL
Visual Basic
Public Shared MsgDm_ExABOVELABEL As Integer
Visual C++
public:
static int MsgDm_ExABOVELABEL

See Also

P4ClientError Class


MsgDm_ExABOVEREVISION Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExABOVEREVISION Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExABOVEREVISION
Visual Basic
Public Shared MsgDm_ExABOVEREVISION As Integer
Visual C++
public:
static int MsgDm_ExABOVEREVISION

See Also

P4ClientError Class


MsgDm_ExARCHIVES Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExARCHIVES Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExARCHIVES
Visual Basic
Public Shared MsgDm_ExARCHIVES As Integer
Visual C++
public:
static int MsgDm_ExARCHIVES

See Also

P4ClientError Class


MsgDm_ExATACTION Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExATACTION Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExATACTION
Visual Basic
Public Shared MsgDm_ExATACTION As Integer
Visual C++
public:
static int MsgDm_ExATACTION

See Also

P4ClientError Class


MsgDm_ExATCHANGE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExATCHANGE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExATCHANGE
Visual Basic
Public Shared MsgDm_ExATCHANGE As Integer
Visual C++
public:
static int MsgDm_ExATCHANGE

See Also

P4ClientError Class


MsgDm_ExATDATE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExATDATE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExATDATE
Visual Basic
Public Shared MsgDm_ExATDATE As Integer
Visual C++
public:
static int MsgDm_ExATDATE

See Also

P4ClientError Class


MsgDm_ExATHAVE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExATHAVE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExATHAVE
Visual Basic
Public Shared MsgDm_ExATHAVE As Integer
Visual C++
public:
static int MsgDm_ExATHAVE

See Also

P4ClientError Class


MsgDm_ExATLABEL Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExATLABEL Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExATLABEL
Visual Basic
Public Shared MsgDm_ExATLABEL As Integer
Visual C++
public:
static int MsgDm_ExATLABEL

See Also

P4ClientError Class


MsgDm_ExATREVISION Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExATREVISION Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExATREVISION
Visual Basic
Public Shared MsgDm_ExATREVISION As Integer
Visual C++
public:
static int MsgDm_ExATREVISION

See Also

P4ClientError Class


MsgDm_ExATTEXT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExATTEXT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExATTEXT
Visual Basic
Public Shared MsgDm_ExATTEXT As Integer
Visual C++
public:
static int MsgDm_ExATTEXT

See Also

P4ClientError Class


MsgDm_ExBELOWCHANGE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExBELOWCHANGE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExBELOWCHANGE
Visual Basic
Public Shared MsgDm_ExBELOWCHANGE As Integer
Visual C++
public:
static int MsgDm_ExBELOWCHANGE

See Also

P4ClientError Class


MsgDm_ExBELOWDATE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExBELOWDATE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExBELOWDATE
Visual Basic
Public Shared MsgDm_ExBELOWDATE As Integer
Visual C++
public:
static int MsgDm_ExBELOWDATE

See Also

P4ClientError Class


MsgDm_ExBELOWHAVE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExBELOWHAVE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExBELOWHAVE
Visual Basic
Public Shared MsgDm_ExBELOWHAVE As Integer
Visual C++
public:
static int MsgDm_ExBELOWHAVE

See Also

P4ClientError Class


MsgDm_ExBELOWLABEL Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExBELOWLABEL Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExBELOWLABEL
Visual Basic
Public Shared MsgDm_ExBELOWLABEL As Integer
Visual C++
public:
static int MsgDm_ExBELOWLABEL

See Also

P4ClientError Class


MsgDm_ExBELOWREVISION Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExBELOWREVISION Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExBELOWREVISION
Visual Basic
Public Shared MsgDm_ExBELOWREVISION As Integer
Visual C++
public:
static int MsgDm_ExBELOWREVISION

See Also

P4ClientError Class


MsgDm_ExBVIEW Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExBVIEW Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExBVIEW
Visual Basic
Public Shared MsgDm_ExBVIEW As Integer
Visual C++
public:
static int MsgDm_ExBVIEW

See Also

P4ClientError Class


MsgDm_ExCHANGE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExCHANGE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExCHANGE
Visual Basic
Public Shared MsgDm_ExCHANGE As Integer
Visual C++
public:
static int MsgDm_ExCHANGE

See Also

P4ClientError Class


MsgDm_ExDIFF Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExDIFF Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExDIFF
Visual Basic
Public Shared MsgDm_ExDIFF As Integer
Visual C++
public:
static int MsgDm_ExDIFF

See Also

P4ClientError Class


MsgDm_ExDIFFPre101 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExDIFFPre101 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExDIFFPre101
Visual Basic
Public Shared MsgDm_ExDIFFPre101 As Integer
Visual C++
public:
static int MsgDm_ExDIFFPre101

See Also

P4ClientError Class


MsgDm_ExDIGESTED Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExDIGESTED Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExDIGESTED
Visual Basic
Public Shared MsgDm_ExDIGESTED As Integer
Visual C++
public:
static int MsgDm_ExDIGESTED

See Also

P4ClientError Class


MsgDm_ExFILE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExFILE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExFILE
Visual Basic
Public Shared MsgDm_ExFILE As Integer
Visual C++
public:
static int MsgDm_ExFILE

See Also

P4ClientError Class


MsgDm_ExHAVE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExHAVE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExHAVE
Visual Basic
Public Shared MsgDm_ExHAVE As Integer
Visual C++
public:
static int MsgDm_ExHAVE

See Also

P4ClientError Class


MsgDm_ExINTEGED Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExINTEGED Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExINTEGED
Visual Basic
Public Shared MsgDm_ExINTEGED As Integer
Visual C++
public:
static int MsgDm_ExINTEGED

See Also

P4ClientError Class


MsgDm_ExINTEGMOVEDEL Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExINTEGMOVEDEL Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExINTEGMOVEDEL
Visual Basic
Public Shared MsgDm_ExINTEGMOVEDEL As Integer
Visual C++
public:
static int MsgDm_ExINTEGMOVEDEL

See Also

P4ClientError Class


MsgDm_ExINTEGPEND Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExINTEGPEND Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExINTEGPEND
Visual Basic
Public Shared MsgDm_ExINTEGPEND As Integer
Visual C++
public:
static int MsgDm_ExINTEGPEND

See Also

P4ClientError Class


MsgDm_ExINTEGPERM Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExINTEGPERM Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExINTEGPERM
Visual Basic
Public Shared MsgDm_ExINTEGPERM As Integer
Visual C++
public:
static int MsgDm_ExINTEGPERM

See Also

P4ClientError Class


MsgDm_ExLABEL Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExLABEL Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExLABEL
Visual Basic
Public Shared MsgDm_ExLABEL As Integer
Visual C++
public:
static int MsgDm_ExLABEL

See Also

P4ClientError Class


MsgDm_ExLABSYNC Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExLABSYNC Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExLABSYNC
Visual Basic
Public Shared MsgDm_ExLABSYNC As Integer
Visual C++
public:
static int MsgDm_ExLABSYNC

See Also

P4ClientError Class


MsgDm_ExOPENALL Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExOPENALL Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExOPENALL
Visual Basic
Public Shared MsgDm_ExOPENALL As Integer
Visual C++
public:
static int MsgDm_ExOPENALL

See Also

P4ClientError Class


MsgDm_ExOPENCHANGE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExOPENCHANGE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExOPENCHANGE
Visual Basic
Public Shared MsgDm_ExOPENCHANGE As Integer
Visual C++
public:
static int MsgDm_ExOPENCHANGE

See Also

P4ClientError Class


MsgDm_ExOPENCLIENT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExOPENCLIENT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExOPENCLIENT
Visual Basic
Public Shared MsgDm_ExOPENCLIENT As Integer
Visual C++
public:
static int MsgDm_ExOPENCLIENT

See Also

P4ClientError Class


MsgDm_ExOPENDFLT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExOPENDFLT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExOPENDFLT
Visual Basic
Public Shared MsgDm_ExOPENDFLT As Integer
Visual C++
public:
static int MsgDm_ExOPENDFLT

See Also

P4ClientError Class


MsgDm_ExOPENNOTEDIT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExOPENNOTEDIT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExOPENNOTEDIT
Visual Basic
Public Shared MsgDm_ExOPENNOTEDIT As Integer
Visual C++
public:
static int MsgDm_ExOPENNOTEDIT

See Also

P4ClientError Class


MsgDm_ExPROPERTY Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExPROPERTY Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExPROPERTY
Visual Basic
Public Shared MsgDm_ExPROPERTY As Integer
Visual C++
public:
static int MsgDm_ExPROPERTY

See Also

P4ClientError Class


MsgDm_ExPROTECT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExPROTECT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExPROTECT
Visual Basic
Public Shared MsgDm_ExPROTECT As Integer
Visual C++
public:
static int MsgDm_ExPROTECT

See Also

P4ClientError Class


MsgDm_ExPROTECT2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExPROTECT2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExPROTECT2
Visual Basic
Public Shared MsgDm_ExPROTECT2 As Integer
Visual C++
public:
static int MsgDm_ExPROTECT2

See Also

P4ClientError Class


MsgDm_ExPROTNAME Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExPROTNAME Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExPROTNAME
Visual Basic
Public Shared MsgDm_ExPROTNAME As Integer
Visual C++
public:
static int MsgDm_ExPROTNAME

See Also

P4ClientError Class


MsgDm_ExPROTNAME2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExPROTNAME2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExPROTNAME2
Visual Basic
Public Shared MsgDm_ExPROTNAME2 As Integer
Visual C++
public:
static int MsgDm_ExPROTNAME2

See Also

P4ClientError Class


MsgDm_ExRESOLVED Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExRESOLVED Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExRESOLVED
Visual Basic
Public Shared MsgDm_ExRESOLVED As Integer
Visual C++
public:
static int MsgDm_ExRESOLVED

See Also

P4ClientError Class


MsgDm_ExSTREAM Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExSTREAM Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExSTREAM
Visual Basic
Public Shared MsgDm_ExSTREAM As Integer
Visual C++
public:
static int MsgDm_ExSTREAM

See Also

P4ClientError Class


MsgDm_ExSVIEW Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExSVIEW Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExSVIEW
Visual Basic
Public Shared MsgDm_ExSVIEW As Integer
Visual C++
public:
static int MsgDm_ExSVIEW

See Also

P4ClientError Class


MsgDm_ExTOINTEG Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExTOINTEG Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExTOINTEG
Visual Basic
Public Shared MsgDm_ExTOINTEG As Integer
Visual C++
public:
static int MsgDm_ExTOINTEG

See Also

P4ClientError Class


MsgDm_ExTORECONCILE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExTORECONCILE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExTORECONCILE
Visual Basic
Public Shared MsgDm_ExTORECONCILE As Integer
Visual C++
public:
static int MsgDm_ExTORECONCILE

See Also

P4ClientError Class


MsgDm_ExTORESOLVE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExTORESOLVE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExTORESOLVE
Visual Basic
Public Shared MsgDm_ExTORESOLVE As Integer
Visual C++
public:
static int MsgDm_ExTORESOLVE

See Also

P4ClientError Class


MsgDm_ExTORETYPE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExTORETYPE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExTORETYPE
Visual Basic
Public Shared MsgDm_ExTORETYPE As Integer
Visual C++
public:
static int MsgDm_ExTORETYPE

See Also

P4ClientError Class


MsgDm_ExTOUNSHELVE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExTOUNSHELVE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExTOUNSHELVE
Visual Basic
Public Shared MsgDm_ExTOUNSHELVE As Integer
Visual C++
public:
static int MsgDm_ExTOUNSHELVE

See Also

P4ClientError Class


MsgDm_ExTVIEW Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExTVIEW Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExTVIEW
Visual Basic
Public Shared MsgDm_ExTVIEW As Integer
Visual C++
public:
static int MsgDm_ExTVIEW

See Also

P4ClientError Class


MsgDm_ExUNLOCKCHANGE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExUNLOCKCHANGE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExUNLOCKCHANGE
Visual Basic
Public Shared MsgDm_ExUNLOCKCHANGE As Integer
Visual C++
public:
static int MsgDm_ExUNLOCKCHANGE

See Also

P4ClientError Class


MsgDm_ExUPTODATE Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExUPTODATE Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExUPTODATE
Visual Basic
Public Shared MsgDm_ExUPTODATE As Integer
Visual C++
public:
static int MsgDm_ExUPTODATE

See Also

P4ClientError Class


MsgDm_ExUSER Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExUSER Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExUSER
Visual Basic
Public Shared MsgDm_ExUSER As Integer
Visual C++
public:
static int MsgDm_ExUSER

See Also

P4ClientError Class


MsgDm_ExVIEW Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExVIEW Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExVIEW
Visual Basic
Public Shared MsgDm_ExVIEW As Integer
Visual C++
public:
static int MsgDm_ExVIEW

See Also

P4ClientError Class


MsgDm_ExVIEW2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ExVIEW2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ExVIEW2
Visual Basic
Public Shared MsgDm_ExVIEW2 As Integer
Visual C++
public:
static int MsgDm_ExVIEW2

See Also

P4ClientError Class


MsgDm_FieldCount Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FieldCount Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FieldCount
Visual Basic
Public Shared MsgDm_FieldCount As Integer
Visual C++
public:
static int MsgDm_FieldCount

See Also

P4ClientError Class


MsgDm_FieldMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FieldMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FieldMissing
Visual Basic
Public Shared MsgDm_FieldMissing As Integer
Visual C++
public:
static int MsgDm_FieldMissing

See Also

P4ClientError Class


MsgDm_FilelogData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilelogData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilelogData
Visual Basic
Public Shared MsgDm_FilelogData As Integer
Visual C++
public:
static int MsgDm_FilelogData

See Also

P4ClientError Class


MsgDm_FilelogInteg Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilelogInteg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilelogInteg
Visual Basic
Public Shared MsgDm_FilelogInteg As Integer
Visual C++
public:
static int MsgDm_FilelogInteg

See Also

P4ClientError Class


MsgDm_FilelogRevDefault Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilelogRevDefault Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilelogRevDefault
Visual Basic
Public Shared MsgDm_FilelogRevDefault As Integer
Visual C++
public:
static int MsgDm_FilelogRevDefault

See Also

P4ClientError Class


MsgDm_FilelogRevMessage Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilelogRevMessage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilelogRevMessage
Visual Basic
Public Shared MsgDm_FilelogRevMessage As Integer
Visual C++
public:
static int MsgDm_FilelogRevMessage

See Also

P4ClientError Class


MsgDm_FilesData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilesData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilesData
Visual Basic
Public Shared MsgDm_FilesData As Integer
Visual C++
public:
static int MsgDm_FilesData

See Also

P4ClientError Class


MsgDm_FilesDiskUsage Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilesDiskUsage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilesDiskUsage
Visual Basic
Public Shared MsgDm_FilesDiskUsage As Integer
Visual C++
public:
static int MsgDm_FilesDiskUsage

See Also

P4ClientError Class


MsgDm_FilesDiskUsageHuman Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilesDiskUsageHuman Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilesDiskUsageHuman
Visual Basic
Public Shared MsgDm_FilesDiskUsageHuman As Integer
Visual C++
public:
static int MsgDm_FilesDiskUsageHuman

See Also

P4ClientError Class


MsgDm_FilesSummary Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilesSummary Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilesSummary
Visual Basic
Public Shared MsgDm_FilesSummary As Integer
Visual C++
public:
static int MsgDm_FilesSummary

See Also

P4ClientError Class


MsgDm_FilesSummaryHuman Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FilesSummaryHuman Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FilesSummaryHuman
Visual Basic
Public Shared MsgDm_FilesSummaryHuman As Integer
Visual C++
public:
static int MsgDm_FilesSummaryHuman

See Also

P4ClientError Class


MsgDm_FiltersReplicaOnly Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FiltersReplicaOnly Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FiltersReplicaOnly
Visual Basic
Public Shared MsgDm_FiltersReplicaOnly As Integer
Visual C++
public:
static int MsgDm_FiltersReplicaOnly

See Also

P4ClientError Class


MsgDm_FixAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FixAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FixAdd
Visual Basic
Public Shared MsgDm_FixAdd As Integer
Visual C++
public:
static int MsgDm_FixAdd

See Also

P4ClientError Class


MsgDm_FixAddDefault Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FixAddDefault Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FixAddDefault
Visual Basic
Public Shared MsgDm_FixAddDefault As Integer
Visual C++
public:
static int MsgDm_FixAddDefault

See Also

P4ClientError Class


MsgDm_FixBadVal Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FixBadVal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FixBadVal
Visual Basic
Public Shared MsgDm_FixBadVal As Integer
Visual C++
public:
static int MsgDm_FixBadVal

See Also

P4ClientError Class


MsgDm_FixDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FixDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FixDelete
Visual Basic
Public Shared MsgDm_FixDelete As Integer
Visual C++
public:
static int MsgDm_FixDelete

See Also

P4ClientError Class


MsgDm_FixesData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FixesData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FixesData
Visual Basic
Public Shared MsgDm_FixesData As Integer
Visual C++
public:
static int MsgDm_FixesData

See Also

P4ClientError Class


MsgDm_FixesDataDefault Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_FixesDataDefault Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_FixesDataDefault
Visual Basic
Public Shared MsgDm_FixesDataDefault As Integer
Visual C++
public:
static int MsgDm_FixesDataDefault

See Also

P4ClientError Class


MsgDm_GrepFileOutput Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GrepFileOutput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GrepFileOutput
Visual Basic
Public Shared MsgDm_GrepFileOutput As Integer
Visual C++
public:
static int MsgDm_GrepFileOutput

See Also

P4ClientError Class


MsgDm_GrepLineTooLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GrepLineTooLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GrepLineTooLong
Visual Basic
Public Shared MsgDm_GrepLineTooLong As Integer
Visual C++
public:
static int MsgDm_GrepLineTooLong

See Also

P4ClientError Class


MsgDm_GrepMaxRevs Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GrepMaxRevs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GrepMaxRevs
Visual Basic
Public Shared MsgDm_GrepMaxRevs As Integer
Visual C++
public:
static int MsgDm_GrepMaxRevs

See Also

P4ClientError Class


MsgDm_GrepOutput Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GrepOutput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GrepOutput
Visual Basic
Public Shared MsgDm_GrepOutput As Integer
Visual C++
public:
static int MsgDm_GrepOutput

See Also

P4ClientError Class


MsgDm_GrepSeparator Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GrepSeparator Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GrepSeparator
Visual Basic
Public Shared MsgDm_GrepSeparator As Integer
Visual C++
public:
static int MsgDm_GrepSeparator

See Also

P4ClientError Class


MsgDm_GrepWithLineNumber Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GrepWithLineNumber Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GrepWithLineNumber
Visual Basic
Public Shared MsgDm_GrepWithLineNumber As Integer
Visual C++
public:
static int MsgDm_GrepWithLineNumber

See Also

P4ClientError Class


MsgDm_GroupCreated Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupCreated Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupCreated
Visual Basic
Public Shared MsgDm_GroupCreated As Integer
Visual C++
public:
static int MsgDm_GroupCreated

See Also

P4ClientError Class


MsgDm_GroupDeleted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupDeleted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupDeleted
Visual Basic
Public Shared MsgDm_GroupDeleted As Integer
Visual C++
public:
static int MsgDm_GroupDeleted

See Also

P4ClientError Class


MsgDm_GroupExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupExists
Visual Basic
Public Shared MsgDm_GroupExists As Integer
Visual C++
public:
static int MsgDm_GroupExists

See Also

P4ClientError Class


MsgDm_GroupNotCreated Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupNotCreated Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupNotCreated
Visual Basic
Public Shared MsgDm_GroupNotCreated As Integer
Visual C++
public:
static int MsgDm_GroupNotCreated

See Also

P4ClientError Class


MsgDm_GroupNotOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupNotOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupNotOwner
Visual Basic
Public Shared MsgDm_GroupNotOwner As Integer
Visual C++
public:
static int MsgDm_GroupNotOwner

See Also

P4ClientError Class


MsgDm_GroupNotUpdated Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupNotUpdated Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupNotUpdated
Visual Basic
Public Shared MsgDm_GroupNotUpdated As Integer
Visual C++
public:
static int MsgDm_GroupNotUpdated

See Also

P4ClientError Class


MsgDm_GroupsData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupsData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupsData
Visual Basic
Public Shared MsgDm_GroupsData As Integer
Visual C++
public:
static int MsgDm_GroupsData

See Also

P4ClientError Class


MsgDm_GroupsDataVerbose Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupsDataVerbose Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupsDataVerbose
Visual Basic
Public Shared MsgDm_GroupsDataVerbose As Integer
Visual C++
public:
static int MsgDm_GroupsDataVerbose

See Also

P4ClientError Class


MsgDm_GroupUpdated Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_GroupUpdated Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_GroupUpdated
Visual Basic
Public Shared MsgDm_GroupUpdated As Integer
Visual C++
public:
static int MsgDm_GroupUpdated

See Also

P4ClientError Class


MsgDm_HaveData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_HaveData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_HaveData
Visual Basic
Public Shared MsgDm_HaveData As Integer
Visual C++
public:
static int MsgDm_HaveData

See Also

P4ClientError Class


MsgDm_HaveVsRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_HaveVsRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_HaveVsRev
Visual Basic
Public Shared MsgDm_HaveVsRev As Integer
Visual C++
public:
static int MsgDm_HaveVsRev

See Also

P4ClientError Class


MsgDm_IdEmbeddedNul Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdEmbeddedNul Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdEmbeddedNul
Visual Basic
Public Shared MsgDm_IdEmbeddedNul As Integer
Visual C++
public:
static int MsgDm_IdEmbeddedNul

See Also

P4ClientError Class


MsgDm_IdEmpty Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdEmpty Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdEmpty
Visual Basic
Public Shared MsgDm_IdEmpty As Integer
Visual C++
public:
static int MsgDm_IdEmpty

See Also

P4ClientError Class


MsgDm_IdHasComma Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdHasComma Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdHasComma
Visual Basic
Public Shared MsgDm_IdHasComma As Integer
Visual C++
public:
static int MsgDm_IdHasComma

See Also

P4ClientError Class


MsgDm_IdHasDash Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdHasDash Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdHasDash
Visual Basic
Public Shared MsgDm_IdHasDash As Integer
Visual C++
public:
static int MsgDm_IdHasDash

See Also

P4ClientError Class


MsgDm_IdHasPercent Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdHasPercent Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdHasPercent
Visual Basic
Public Shared MsgDm_IdHasPercent As Integer
Visual C++
public:
static int MsgDm_IdHasPercent

See Also

P4ClientError Class


MsgDm_IdHasRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdHasRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdHasRev
Visual Basic
Public Shared MsgDm_IdHasRev As Integer
Visual C++
public:
static int MsgDm_IdHasRev

See Also

P4ClientError Class


MsgDm_IdHasSlash Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdHasSlash Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdHasSlash
Visual Basic
Public Shared MsgDm_IdHasSlash As Integer
Visual C++
public:
static int MsgDm_IdHasSlash

See Also

P4ClientError Class


MsgDm_IdNonPrint Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdNonPrint Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdNonPrint
Visual Basic
Public Shared MsgDm_IdNonPrint As Integer
Visual C++
public:
static int MsgDm_IdNonPrint

See Also

P4ClientError Class


MsgDm_IdNullDir Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdNullDir Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdNullDir
Visual Basic
Public Shared MsgDm_IdNullDir As Integer
Visual C++
public:
static int MsgDm_IdNullDir

See Also

P4ClientError Class


MsgDm_IdNumber Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdNumber Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdNumber
Visual Basic
Public Shared MsgDm_IdNumber As Integer
Visual C++
public:
static int MsgDm_IdNumber

See Also

P4ClientError Class


MsgDm_IdRelPath Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdRelPath Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdRelPath
Visual Basic
Public Shared MsgDm_IdRelPath As Integer
Visual C++
public:
static int MsgDm_IdRelPath

See Also

P4ClientError Class


MsgDm_IdTooLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdTooLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdTooLong
Visual Basic
Public Shared MsgDm_IdTooLong As Integer
Visual C++
public:
static int MsgDm_IdTooLong

See Also

P4ClientError Class


MsgDm_IdWild Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IdWild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IdWild
Visual Basic
Public Shared MsgDm_IdWild As Integer
Visual C++
public:
static int MsgDm_IdWild

See Also

P4ClientError Class


MsgDm_ImportNotUnder Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ImportNotUnder Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ImportNotUnder
Visual Basic
Public Shared MsgDm_ImportNotUnder As Integer
Visual C++
public:
static int MsgDm_ImportNotUnder

See Also

P4ClientError Class


MsgDm_InfoDomain Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_InfoDomain Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_InfoDomain
Visual Basic
Public Shared MsgDm_InfoDomain As Integer
Visual C++
public:
static int MsgDm_InfoDomain

See Also

P4ClientError Class


MsgDm_InfoUnknownDomain Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_InfoUnknownDomain Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_InfoUnknownDomain
Visual Basic
Public Shared MsgDm_InfoUnknownDomain As Integer
Visual C++
public:
static int MsgDm_InfoUnknownDomain

See Also

P4ClientError Class


MsgDm_IntegAlreadyOpened Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegAlreadyOpened Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegAlreadyOpened
Visual Basic
Public Shared MsgDm_IntegAlreadyOpened As Integer
Visual C++
public:
static int MsgDm_IntegAlreadyOpened

See Also

P4ClientError Class


MsgDm_IntegBadAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegBadAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegBadAction
Visual Basic
Public Shared MsgDm_IntegBadAction As Integer
Visual C++
public:
static int MsgDm_IntegBadAction

See Also

P4ClientError Class


MsgDm_IntegBadAncestor Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegBadAncestor Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegBadAncestor
Visual Basic
Public Shared MsgDm_IntegBadAncestor As Integer
Visual C++
public:
static int MsgDm_IntegBadAncestor

See Also

P4ClientError Class


MsgDm_IntegBadBase Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegBadBase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegBadBase
Visual Basic
Public Shared MsgDm_IntegBadBase As Integer
Visual C++
public:
static int MsgDm_IntegBadBase

See Also

P4ClientError Class


MsgDm_IntegBadClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegBadClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegBadClient
Visual Basic
Public Shared MsgDm_IntegBadClient As Integer
Visual C++
public:
static int MsgDm_IntegBadClient

See Also

P4ClientError Class


MsgDm_IntegBadUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegBadUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegBadUser
Visual Basic
Public Shared MsgDm_IntegBadUser As Integer
Visual C++
public:
static int MsgDm_IntegBadUser

See Also

P4ClientError Class


MsgDm_IntegBaselessMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegBaselessMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegBaselessMove
Visual Basic
Public Shared MsgDm_IntegBaselessMove As Integer
Visual C++
public:
static int MsgDm_IntegBaselessMove

See Also

P4ClientError Class


MsgDm_IntegCantAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegCantAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegCantAdd
Visual Basic
Public Shared MsgDm_IntegCantAdd As Integer
Visual C++
public:
static int MsgDm_IntegCantAdd

See Also

P4ClientError Class


MsgDm_IntegCantModify Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegCantModify Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegCantModify
Visual Basic
Public Shared MsgDm_IntegCantModify As Integer
Visual C++
public:
static int MsgDm_IntegCantModify

See Also

P4ClientError Class


MsgDm_IntegedData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegedData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegedData
Visual Basic
Public Shared MsgDm_IntegedData As Integer
Visual C++
public:
static int MsgDm_IntegedData

See Also

P4ClientError Class


MsgDm_IntegIncompatable Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegIncompatable Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegIncompatable
Visual Basic
Public Shared MsgDm_IntegIncompatable As Integer
Visual C++
public:
static int MsgDm_IntegIncompatable

See Also

P4ClientError Class


MsgDm_IntegIntoReadOnly Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegIntoReadOnly Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegIntoReadOnly
Visual Basic
Public Shared MsgDm_IntegIntoReadOnly As Integer
Visual C++
public:
static int MsgDm_IntegIntoReadOnly

See Also

P4ClientError Class


MsgDm_IntegMovedNoAccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegMovedNoAccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegMovedNoAccess
Visual Basic
Public Shared MsgDm_IntegMovedNoAccess As Integer
Visual C++
public:
static int MsgDm_IntegMovedNoAccess

See Also

P4ClientError Class


MsgDm_IntegMovedNoFrom Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegMovedNoFrom Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegMovedNoFrom
Visual Basic
Public Shared MsgDm_IntegMovedNoFrom As Integer
Visual C++
public:
static int MsgDm_IntegMovedNoFrom

See Also

P4ClientError Class


MsgDm_IntegMovedNoFromS Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegMovedNoFromS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegMovedNoFromS
Visual Basic
Public Shared MsgDm_IntegMovedNoFromS As Integer
Visual C++
public:
static int MsgDm_IntegMovedNoFromS

See Also

P4ClientError Class


MsgDm_IntegMovedOutScope Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegMovedOutScope Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegMovedOutScope
Visual Basic
Public Shared MsgDm_IntegMovedOutScope As Integer
Visual C++
public:
static int MsgDm_IntegMovedOutScope

See Also

P4ClientError Class


MsgDm_IntegMovedUnmapped Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegMovedUnmapped Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegMovedUnmapped
Visual Basic
Public Shared MsgDm_IntegMovedUnmapped As Integer
Visual C++
public:
static int MsgDm_IntegMovedUnmapped

See Also

P4ClientError Class


MsgDm_IntegMustSync Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegMustSync Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegMustSync
Visual Basic
Public Shared MsgDm_IntegMustSync As Integer
Visual C++
public:
static int MsgDm_IntegMustSync

See Also

P4ClientError Class


MsgDm_IntegNotHandled Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegNotHandled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegNotHandled
Visual Basic
Public Shared MsgDm_IntegNotHandled As Integer
Visual C++
public:
static int MsgDm_IntegNotHandled

See Also

P4ClientError Class


MsgDm_IntegOpenOkay Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegOpenOkay Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegOpenOkay
Visual Basic
Public Shared MsgDm_IntegOpenOkay As Integer
Visual C++
public:
static int MsgDm_IntegOpenOkay

See Also

P4ClientError Class


MsgDm_IntegOpenOkayBase Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegOpenOkayBase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegOpenOkayBase
Visual Basic
Public Shared MsgDm_IntegOpenOkayBase As Integer
Visual C++
public:
static int MsgDm_IntegOpenOkayBase

See Also

P4ClientError Class


MsgDm_IntegPreviewResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegPreviewResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegPreviewResolve
Visual Basic
Public Shared MsgDm_IntegPreviewResolve As Integer
Visual C++
public:
static int MsgDm_IntegPreviewResolve

See Also

P4ClientError Class


MsgDm_IntegPreviewResolved Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegPreviewResolved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegPreviewResolved
Visual Basic
Public Shared MsgDm_IntegPreviewResolved As Integer
Visual C++
public:
static int MsgDm_IntegPreviewResolved

See Also

P4ClientError Class


MsgDm_IntegPreviewResolveMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegPreviewResolveMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegPreviewResolveMove
Visual Basic
Public Shared MsgDm_IntegPreviewResolveMove As Integer
Visual C++
public:
static int MsgDm_IntegPreviewResolveMove

See Also

P4ClientError Class


MsgDm_IntegSyncBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegSyncBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegSyncBranch
Visual Basic
Public Shared MsgDm_IntegSyncBranch As Integer
Visual C++
public:
static int MsgDm_IntegSyncBranch

See Also

P4ClientError Class


MsgDm_IntegSyncDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegSyncDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegSyncDelete
Visual Basic
Public Shared MsgDm_IntegSyncDelete As Integer
Visual C++
public:
static int MsgDm_IntegSyncDelete

See Also

P4ClientError Class


MsgDm_IntegSyncIntegBase Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegSyncIntegBase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegSyncIntegBase
Visual Basic
Public Shared MsgDm_IntegSyncIntegBase As Integer
Visual C++
public:
static int MsgDm_IntegSyncIntegBase

See Also

P4ClientError Class


MsgDm_IntegTooVirtual Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegTooVirtual Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegTooVirtual
Visual Basic
Public Shared MsgDm_IntegTooVirtual As Integer
Visual C++
public:
static int MsgDm_IntegTooVirtual

See Also

P4ClientError Class


MsgDm_IntegVsRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegVsRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegVsRev
Visual Basic
Public Shared MsgDm_IntegVsRev As Integer
Visual C++
public:
static int MsgDm_IntegVsRev

See Also

P4ClientError Class


MsgDm_IntegVsShelve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegVsShelve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegVsShelve
Visual Basic
Public Shared MsgDm_IntegVsShelve As Integer
Visual C++
public:
static int MsgDm_IntegVsShelve

See Also

P4ClientError Class


MsgDm_IntegVsWork Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegVsWork Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegVsWork
Visual Basic
Public Shared MsgDm_IntegVsWork As Integer
Visual C++
public:
static int MsgDm_IntegVsWork

See Also

P4ClientError Class


MsgDm_IntegXOpened Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_IntegXOpened Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_IntegXOpened
Visual Basic
Public Shared MsgDm_IntegXOpened As Integer
Visual C++
public:
static int MsgDm_IntegXOpened

See Also

P4ClientError Class


MsgDm_InvalidEscape Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_InvalidEscape Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_InvalidEscape
Visual Basic
Public Shared MsgDm_InvalidEscape As Integer
Visual C++
public:
static int MsgDm_InvalidEscape

See Also

P4ClientError Class


MsgDm_InvalidParent Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_InvalidParent Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_InvalidParent
Visual Basic
Public Shared MsgDm_InvalidParent As Integer
Visual C++
public:
static int MsgDm_InvalidParent

See Also

P4ClientError Class


MsgDm_InvalidStreamFmt Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_InvalidStreamFmt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_InvalidStreamFmt
Visual Basic
Public Shared MsgDm_InvalidStreamFmt As Integer
Visual C++
public:
static int MsgDm_InvalidStreamFmt

See Also

P4ClientError Class


MsgDm_InvalidType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_InvalidType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_InvalidType
Visual Basic
Public Shared MsgDm_InvalidType As Integer
Visual C++
public:
static int MsgDm_InvalidType

See Also

P4ClientError Class


MsgDm_JobDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobDelete
Visual Basic
Public Shared MsgDm_JobDelete As Integer
Visual C++
public:
static int MsgDm_JobDelete

See Also

P4ClientError Class


MsgDm_JobDeleteHasFix Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobDeleteHasFix Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobDeleteHasFix
Visual Basic
Public Shared MsgDm_JobDeleteHasFix As Integer
Visual C++
public:
static int MsgDm_JobDeleteHasFix

See Also

P4ClientError Class


MsgDm_JobDescMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobDescMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobDescMissing
Visual Basic
Public Shared MsgDm_JobDescMissing As Integer
Visual C++
public:
static int MsgDm_JobDescMissing

See Also

P4ClientError Class


MsgDm_JobDescription Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobDescription Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobDescription
Visual Basic
Public Shared MsgDm_JobDescription As Integer
Visual C++
public:
static int MsgDm_JobDescription

See Also

P4ClientError Class


MsgDm_JobFieldAlways Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobFieldAlways Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobFieldAlways
Visual Basic
Public Shared MsgDm_JobFieldAlways As Integer
Visual C++
public:
static int MsgDm_JobFieldAlways

See Also

P4ClientError Class


MsgDm_JobFieldReadOnly Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobFieldReadOnly Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobFieldReadOnly
Visual Basic
Public Shared MsgDm_JobFieldReadOnly As Integer
Visual C++
public:
static int MsgDm_JobFieldReadOnly

See Also

P4ClientError Class


MsgDm_JobHasChanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobHasChanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobHasChanged
Visual Basic
Public Shared MsgDm_JobHasChanged As Integer
Visual C++
public:
static int MsgDm_JobHasChanged

See Also

P4ClientError Class


MsgDm_JobName101 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobName101 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobName101
Visual Basic
Public Shared MsgDm_JobName101 As Integer
Visual C++
public:
static int MsgDm_JobName101

See Also

P4ClientError Class


MsgDm_JobNameJob Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobNameJob Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobNameJob
Visual Basic
Public Shared MsgDm_JobNameJob As Integer
Visual C++
public:
static int MsgDm_JobNameJob

See Also

P4ClientError Class


MsgDm_JobNameMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobNameMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobNameMissing
Visual Basic
Public Shared MsgDm_JobNameMissing As Integer
Visual C++
public:
static int MsgDm_JobNameMissing

See Also

P4ClientError Class


MsgDm_JobNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobNoChange
Visual Basic
Public Shared MsgDm_JobNoChange As Integer
Visual C++
public:
static int MsgDm_JobNoChange

See Also

P4ClientError Class


MsgDm_JobSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_JobSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_JobSave
Visual Basic
Public Shared MsgDm_JobSave As Integer
Visual C++
public:
static int MsgDm_JobSave

See Also

P4ClientError Class


MsgDm_LabelHasRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelHasRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelHasRev
Visual Basic
Public Shared MsgDm_LabelHasRev As Integer
Visual C++
public:
static int MsgDm_LabelHasRev

See Also

P4ClientError Class


MsgDm_LabelLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelLocked
Visual Basic
Public Shared MsgDm_LabelLocked As Integer
Visual C++
public:
static int MsgDm_LabelLocked

See Also

P4ClientError Class


MsgDm_LabelLoop Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelLoop Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelLoop
Visual Basic
Public Shared MsgDm_LabelLoop As Integer
Visual C++
public:
static int MsgDm_LabelLoop

See Also

P4ClientError Class


MsgDm_LabelNoSync Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelNoSync Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelNoSync
Visual Basic
Public Shared MsgDm_LabelNoSync As Integer
Visual C++
public:
static int MsgDm_LabelNoSync

See Also

P4ClientError Class


MsgDm_LabelOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelOwner
Visual Basic
Public Shared MsgDm_LabelOwner As Integer
Visual C++
public:
static int MsgDm_LabelOwner

See Also

P4ClientError Class


MsgDm_LabelSyncAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelSyncAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelSyncAdd
Visual Basic
Public Shared MsgDm_LabelSyncAdd As Integer
Visual C++
public:
static int MsgDm_LabelSyncAdd

See Also

P4ClientError Class


MsgDm_LabelSyncDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelSyncDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelSyncDelete
Visual Basic
Public Shared MsgDm_LabelSyncDelete As Integer
Visual C++
public:
static int MsgDm_LabelSyncDelete

See Also

P4ClientError Class


MsgDm_LabelSyncReplace Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelSyncReplace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelSyncReplace
Visual Basic
Public Shared MsgDm_LabelSyncReplace As Integer
Visual C++
public:
static int MsgDm_LabelSyncReplace

See Also

P4ClientError Class


MsgDm_LabelSyncUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LabelSyncUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LabelSyncUpdate
Visual Basic
Public Shared MsgDm_LabelSyncUpdate As Integer
Visual C++
public:
static int MsgDm_LabelSyncUpdate

See Also

P4ClientError Class


MsgDm_LameCodes Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LameCodes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LameCodes
Visual Basic
Public Shared MsgDm_LameCodes As Integer
Visual C++
public:
static int MsgDm_LameCodes

See Also

P4ClientError Class


MsgDm_LicensedClients Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LicensedClients Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LicensedClients
Visual Basic
Public Shared MsgDm_LicensedClients As Integer
Visual C++
public:
static int MsgDm_LicensedClients

See Also

P4ClientError Class


MsgDm_LicensedUsers Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LicensedUsers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LicensedUsers
Visual Basic
Public Shared MsgDm_LicensedUsers As Integer
Visual C++
public:
static int MsgDm_LicensedUsers

See Also

P4ClientError Class


MsgDm_LicenseNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LicenseNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LicenseNoChange
Visual Basic
Public Shared MsgDm_LicenseNoChange As Integer
Visual C++
public:
static int MsgDm_LicenseNoChange

See Also

P4ClientError Class


MsgDm_LicenseSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LicenseSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LicenseSave
Visual Basic
Public Shared MsgDm_LicenseSave As Integer
Visual C++
public:
static int MsgDm_LicenseSave

See Also

P4ClientError Class


MsgDm_LimitBadArg Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LimitBadArg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LimitBadArg
Visual Basic
Public Shared MsgDm_LimitBadArg As Integer
Visual C++
public:
static int MsgDm_LimitBadArg

See Also

P4ClientError Class


MsgDm_LineTooLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LineTooLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LineTooLong
Visual Basic
Public Shared MsgDm_LineTooLong As Integer
Visual C++
public:
static int MsgDm_LineTooLong

See Also

P4ClientError Class


MsgDm_LockAlready Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockAlready Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockAlready
Visual Basic
Public Shared MsgDm_LockAlready As Integer
Visual C++
public:
static int MsgDm_LockAlready

See Also

P4ClientError Class


MsgDm_LockAlreadyOther Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockAlreadyOther Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockAlreadyOther
Visual Basic
Public Shared MsgDm_LockAlreadyOther As Integer
Visual C++
public:
static int MsgDm_LockAlreadyOther

See Also

P4ClientError Class


MsgDm_LockBadUnicode Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockBadUnicode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockBadUnicode
Visual Basic
Public Shared MsgDm_LockBadUnicode As Integer
Visual C++
public:
static int MsgDm_LockBadUnicode

See Also

P4ClientError Class


MsgDm_LockedClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockedClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockedClient
Visual Basic
Public Shared MsgDm_LockedClient As Integer
Visual C++
public:
static int MsgDm_LockedClient

See Also

P4ClientError Class


MsgDm_LockedDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockedDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockedDelete
Visual Basic
Public Shared MsgDm_LockedDelete As Integer
Visual C++
public:
static int MsgDm_LockedDelete

See Also

P4ClientError Class


MsgDm_LockedHost Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockedHost Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockedHost
Visual Basic
Public Shared MsgDm_LockedHost As Integer
Visual C++
public:
static int MsgDm_LockedHost

See Also

P4ClientError Class


MsgDm_LockedUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockedUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockedUpdate
Visual Basic
Public Shared MsgDm_LockedUpdate As Integer
Visual C++
public:
static int MsgDm_LockedUpdate

See Also

P4ClientError Class


MsgDm_LockNoPermission Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockNoPermission Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockNoPermission
Visual Basic
Public Shared MsgDm_LockNoPermission As Integer
Visual C++
public:
static int MsgDm_LockNoPermission

See Also

P4ClientError Class


MsgDm_LockSuccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockSuccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockSuccess
Visual Basic
Public Shared MsgDm_LockSuccess As Integer
Visual C++
public:
static int MsgDm_LockSuccess

See Also

P4ClientError Class


MsgDm_LockUtf16NotSupp Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LockUtf16NotSupp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LockUtf16NotSupp
Visual Basic
Public Shared MsgDm_LockUtf16NotSupp As Integer
Visual C++
public:
static int MsgDm_LockUtf16NotSupp

See Also

P4ClientError Class


MsgDm_LocWild Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LocWild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LocWild
Visual Basic
Public Shared MsgDm_LocWild As Integer
Visual C++
public:
static int MsgDm_LocWild

See Also

P4ClientError Class


MsgDm_LoggerData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_LoggerData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_LoggerData
Visual Basic
Public Shared MsgDm_LoggerData As Integer
Visual C++
public:
static int MsgDm_LoggerData

See Also

P4ClientError Class


MsgDm_ManyRevSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ManyRevSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ManyRevSpec
Visual Basic
Public Shared MsgDm_ManyRevSpec As Integer
Visual C++
public:
static int MsgDm_ManyRevSpec

See Also

P4ClientError Class


MsgDm_MapNoListAccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MapNoListAccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MapNoListAccess
Visual Basic
Public Shared MsgDm_MapNoListAccess As Integer
Visual C++
public:
static int MsgDm_MapNoListAccess

See Also

P4ClientError Class


MsgDm_MapNotUnder Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MapNotUnder Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MapNotUnder
Visual Basic
Public Shared MsgDm_MapNotUnder As Integer
Visual C++
public:
static int MsgDm_MapNotUnder

See Also

P4ClientError Class


MsgDm_MaxLockTime Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MaxLockTime Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MaxLockTime
Visual Basic
Public Shared MsgDm_MaxLockTime As Integer
Visual C++
public:
static int MsgDm_MaxLockTime

See Also

P4ClientError Class


MsgDm_MaxResults Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MaxResults Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MaxResults
Visual Basic
Public Shared MsgDm_MaxResults As Integer
Visual C++
public:
static int MsgDm_MaxResults

See Also

P4ClientError Class


MsgDm_MaxScanRows Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MaxScanRows Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MaxScanRows
Visual Basic
Public Shared MsgDm_MaxScanRows As Integer
Visual C++
public:
static int MsgDm_MaxScanRows

See Also

P4ClientError Class


MsgDm_MayNotBeNegative Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MayNotBeNegative Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MayNotBeNegative
Visual Basic
Public Shared MsgDm_MayNotBeNegative As Integer
Visual C++
public:
static int MsgDm_MayNotBeNegative

See Also

P4ClientError Class


MsgDm_MergeBadBase Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MergeBadBase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MergeBadBase
Visual Basic
Public Shared MsgDm_MergeBadBase As Integer
Visual C++
public:
static int MsgDm_MergeBadBase

See Also

P4ClientError Class


MsgDm_MissingDesc Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MissingDesc Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MissingDesc
Visual Basic
Public Shared MsgDm_MissingDesc As Integer
Visual C++
public:
static int MsgDm_MissingDesc

See Also

P4ClientError Class


MsgDm_MissingStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MissingStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MissingStream
Visual Basic
Public Shared MsgDm_MissingStream As Integer
Visual C++
public:
static int MsgDm_MissingStream

See Also

P4ClientError Class


MsgDm_MonitorCantTerminate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MonitorCantTerminate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MonitorCantTerminate
Visual Basic
Public Shared MsgDm_MonitorCantTerminate As Integer
Visual C++
public:
static int MsgDm_MonitorCantTerminate

See Also

P4ClientError Class


MsgDm_MonitorClear Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MonitorClear Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MonitorClear
Visual Basic
Public Shared MsgDm_MonitorClear As Integer
Visual C++
public:
static int MsgDm_MonitorClear

See Also

P4ClientError Class


MsgDm_MonitorData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MonitorData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MonitorData
Visual Basic
Public Shared MsgDm_MonitorData As Integer
Visual C++
public:
static int MsgDm_MonitorData

See Also

P4ClientError Class


MsgDm_MonitorPause Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MonitorPause Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MonitorPause
Visual Basic
Public Shared MsgDm_MonitorPause As Integer
Visual C++
public:
static int MsgDm_MonitorPause

See Also

P4ClientError Class


MsgDm_MonitorResume Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MonitorResume Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MonitorResume
Visual Basic
Public Shared MsgDm_MonitorResume As Integer
Visual C++
public:
static int MsgDm_MonitorResume

See Also

P4ClientError Class


MsgDm_MonitorTerminate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MonitorTerminate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MonitorTerminate
Visual Basic
Public Shared MsgDm_MonitorTerminate As Integer
Visual C++
public:
static int MsgDm_MonitorTerminate

See Also

P4ClientError Class


MsgDm_MoveBadAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveBadAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveBadAction
Visual Basic
Public Shared MsgDm_MoveBadAction As Integer
Visual C++
public:
static int MsgDm_MoveBadAction

See Also

P4ClientError Class


MsgDm_MoveDeleted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveDeleted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveDeleted
Visual Basic
Public Shared MsgDm_MoveDeleted As Integer
Visual C++
public:
static int MsgDm_MoveDeleted

See Also

P4ClientError Class


MsgDm_MoveExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveExists
Visual Basic
Public Shared MsgDm_MoveExists As Integer
Visual C++
public:
static int MsgDm_MoveExists

See Also

P4ClientError Class


MsgDm_MoveMisMatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveMisMatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveMisMatch
Visual Basic
Public Shared MsgDm_MoveMisMatch As Integer
Visual C++
public:
static int MsgDm_MoveMisMatch

See Also

P4ClientError Class


MsgDm_MoveNeedForce Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveNeedForce Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveNeedForce
Visual Basic
Public Shared MsgDm_MoveNeedForce As Integer
Visual C++
public:
static int MsgDm_MoveNeedForce

See Also

P4ClientError Class


MsgDm_MoveNoInteg Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveNoInteg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveNoInteg
Visual Basic
Public Shared MsgDm_MoveNoInteg As Integer
Visual C++
public:
static int MsgDm_MoveNoInteg

See Also

P4ClientError Class


MsgDm_MoveNoMatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveNoMatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveNoMatch
Visual Basic
Public Shared MsgDm_MoveNoMatch As Integer
Visual C++
public:
static int MsgDm_MoveNoMatch

See Also

P4ClientError Class


MsgDm_MoveNotResolved Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveNotResolved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveNotResolved
Visual Basic
Public Shared MsgDm_MoveNotResolved As Integer
Visual C++
public:
static int MsgDm_MoveNotResolved

See Also

P4ClientError Class


MsgDm_MoveNotSynced Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveNotSynced Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveNotSynced
Visual Basic
Public Shared MsgDm_MoveNotSynced As Integer
Visual C++
public:
static int MsgDm_MoveNotSynced

See Also

P4ClientError Class


MsgDm_MoveReadOnly Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveReadOnly Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveReadOnly
Visual Basic
Public Shared MsgDm_MoveReadOnly As Integer
Visual C++
public:
static int MsgDm_MoveReadOnly

See Also

P4ClientError Class


MsgDm_MoveSuccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MoveSuccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MoveSuccess
Visual Basic
Public Shared MsgDm_MoveSuccess As Integer
Visual C++
public:
static int MsgDm_MoveSuccess

See Also

P4ClientError Class


MsgDm_MultiWordDefault Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MultiWordDefault Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MultiWordDefault
Visual Basic
Public Shared MsgDm_MultiWordDefault As Integer
Visual C++
public:
static int MsgDm_MultiWordDefault

See Also

P4ClientError Class


MsgDm_MustBeNumeric Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MustBeNumeric Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MustBeNumeric
Visual Basic
Public Shared MsgDm_MustBeNumeric As Integer
Visual C++
public:
static int MsgDm_MustBeNumeric

See Also

P4ClientError Class


MsgDm_MustForceUnloadDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_MustForceUnloadDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_MustForceUnloadDepot
Visual Basic
Public Shared MsgDm_MustForceUnloadDepot As Integer
Visual C++
public:
static int MsgDm_MustForceUnloadDepot

See Also

P4ClientError Class


MsgDm_NameChanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NameChanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NameChanged
Visual Basic
Public Shared MsgDm_NameChanged As Integer
Visual C++
public:
static int MsgDm_NameChanged

See Also

P4ClientError Class


MsgDm_NeedClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NeedClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NeedClient
Visual Basic
Public Shared MsgDm_NeedClient As Integer
Visual C++
public:
static int MsgDm_NeedClient

See Also

P4ClientError Class


MsgDm_NeedJobUpgrade Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NeedJobUpgrade Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NeedJobUpgrade
Visual Basic
Public Shared MsgDm_NeedJobUpgrade As Integer
Visual C++
public:
static int MsgDm_NeedJobUpgrade

See Also

P4ClientError Class


MsgDm_NeedsUpgrades Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NeedsUpgrades Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NeedsUpgrades
Visual Basic
Public Shared MsgDm_NeedsUpgrades As Integer
Visual C++
public:
static int MsgDm_NeedsUpgrades

See Also

P4ClientError Class


MsgDm_NoArchive Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoArchive Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoArchive
Visual Basic
Public Shared MsgDm_NoArchive As Integer
Visual C++
public:
static int MsgDm_NoArchive

See Also

P4ClientError Class


MsgDm_NoCheckin Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoCheckin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoCheckin
Visual Basic
Public Shared MsgDm_NoCheckin As Integer
Visual C++
public:
static int MsgDm_NoCheckin

See Also

P4ClientError Class


MsgDm_NoClearText Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoClearText Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoClearText
Visual Basic
Public Shared MsgDm_NoClearText As Integer
Visual C++
public:
static int MsgDm_NoClearText

See Also

P4ClientError Class


MsgDm_NoClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoClient
Visual Basic
Public Shared MsgDm_NoClient As Integer
Visual C++
public:
static int MsgDm_NoClient

See Also

P4ClientError Class


MsgDm_NoCodeZero Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoCodeZero Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoCodeZero
Visual Basic
Public Shared MsgDm_NoCodeZero As Integer
Visual C++
public:
static int MsgDm_NoCodeZero

See Also

P4ClientError Class


MsgDm_NoDefault Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoDefault Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoDefault
Visual Basic
Public Shared MsgDm_NoDefault As Integer
Visual C++
public:
static int MsgDm_NoDefault

See Also

P4ClientError Class


MsgDm_NoDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoDelete
Visual Basic
Public Shared MsgDm_NoDelete As Integer
Visual C++
public:
static int MsgDm_NoDelete

See Also

P4ClientError Class


MsgDm_NoDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoDepot
Visual Basic
Public Shared MsgDm_NoDepot As Integer
Visual C++
public:
static int MsgDm_NoDepot

See Also

P4ClientError Class


MsgDm_NoDepotTypeChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoDepotTypeChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoDepotTypeChange
Visual Basic
Public Shared MsgDm_NoDepotTypeChange As Integer
Visual C++
public:
static int MsgDm_NoDepotTypeChange

See Also

P4ClientError Class


MsgDm_NoIntegHavemaps Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoIntegHavemaps Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoIntegHavemaps
Visual Basic
Public Shared MsgDm_NoIntegHavemaps As Integer
Visual C++
public:
static int MsgDm_NoIntegHavemaps

See Also

P4ClientError Class


MsgDm_NoIntegOverlays Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoIntegOverlays Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoIntegOverlays
Visual Basic
Public Shared MsgDm_NoIntegOverlays As Integer
Visual C++
public:
static int MsgDm_NoIntegOverlays

See Also

P4ClientError Class


MsgDm_NoModComChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoModComChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoModComChange
Visual Basic
Public Shared MsgDm_NoModComChange As Integer
Visual C++
public:
static int MsgDm_NoModComChange

See Also

P4ClientError Class


MsgDm_NoNextRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoNextRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoNextRev
Visual Basic
Public Shared MsgDm_NoNextRev As Integer
Visual C++
public:
static int MsgDm_NoNextRev

See Also

P4ClientError Class


MsgDm_NoNotOp Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoNotOp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoNotOp
Visual Basic
Public Shared MsgDm_NoNotOp As Integer
Visual C++
public:
static int MsgDm_NoNotOp

See Also

P4ClientError Class


MsgDm_NoPerms Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoPerms Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoPerms
Visual Basic
Public Shared MsgDm_NoPerms As Integer
Visual C++
public:
static int MsgDm_NoPerms

See Also

P4ClientError Class


MsgDm_NoPrevRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoPrevRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoPrevRev
Visual Basic
Public Shared MsgDm_NoPrevRev As Integer
Visual C++
public:
static int MsgDm_NoPrevRev

See Also

P4ClientError Class


MsgDm_NoProtect Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoProtect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoProtect
Visual Basic
Public Shared MsgDm_NoProtect As Integer
Visual C++
public:
static int MsgDm_NoProtect

See Also

P4ClientError Class


MsgDm_NoRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoRev
Visual Basic
Public Shared MsgDm_NoRev As Integer
Visual C++
public:
static int MsgDm_NoRev

See Also

P4ClientError Class


MsgDm_NoRevisionOverwrite Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoRevisionOverwrite Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoRevisionOverwrite
Visual Basic
Public Shared MsgDm_NoRevisionOverwrite As Integer
Visual C++
public:
static int MsgDm_NoRevisionOverwrite

See Also

P4ClientError Class


MsgDm_NoRevRange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoRevRange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoRevRange
Visual Basic
Public Shared MsgDm_NoRevRange As Integer
Visual C++
public:
static int MsgDm_NoRevRange

See Also

P4ClientError Class


MsgDm_NoRmtInterop Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoRmtInterop Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoRmtInterop
Visual Basic
Public Shared MsgDm_NoRmtInterop As Integer
Visual C++
public:
static int MsgDm_NoRmtInterop

See Also

P4ClientError Class


MsgDm_NoStreamAtChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoStreamAtChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoStreamAtChange
Visual Basic
Public Shared MsgDm_NoStreamAtChange As Integer
Visual C++
public:
static int MsgDm_NoStreamAtChange

See Also

P4ClientError Class


MsgDm_NoSuchChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchChange
Visual Basic
Public Shared MsgDm_NoSuchChange As Integer
Visual C++
public:
static int MsgDm_NoSuchChange

See Also

P4ClientError Class


MsgDm_NoSuchConfig Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchConfig Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchConfig
Visual Basic
Public Shared MsgDm_NoSuchConfig As Integer
Visual C++
public:
static int MsgDm_NoSuchConfig

See Also

P4ClientError Class


MsgDm_NoSuchCounter Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchCounter Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchCounter
Visual Basic
Public Shared MsgDm_NoSuchCounter As Integer
Visual C++
public:
static int MsgDm_NoSuchCounter

See Also

P4ClientError Class


MsgDm_NoSuchDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchDepot
Visual Basic
Public Shared MsgDm_NoSuchDepot As Integer
Visual C++
public:
static int MsgDm_NoSuchDepot

See Also

P4ClientError Class


MsgDm_NoSuchDepot2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchDepot2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchDepot2
Visual Basic
Public Shared MsgDm_NoSuchDepot2 As Integer
Visual C++
public:
static int MsgDm_NoSuchDepot2

See Also

P4ClientError Class


MsgDm_NoSuchDomain Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchDomain Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchDomain
Visual Basic
Public Shared MsgDm_NoSuchDomain As Integer
Visual C++
public:
static int MsgDm_NoSuchDomain

See Also

P4ClientError Class


MsgDm_NoSuchDomain2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchDomain2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchDomain2
Visual Basic
Public Shared MsgDm_NoSuchDomain2 As Integer
Visual C++
public:
static int MsgDm_NoSuchDomain2

See Also

P4ClientError Class


MsgDm_NoSuchFix Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchFix Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchFix
Visual Basic
Public Shared MsgDm_NoSuchFix As Integer
Visual C++
public:
static int MsgDm_NoSuchFix

See Also

P4ClientError Class


MsgDm_NoSuchGroup Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchGroup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchGroup
Visual Basic
Public Shared MsgDm_NoSuchGroup As Integer
Visual C++
public:
static int MsgDm_NoSuchGroup

See Also

P4ClientError Class


MsgDm_NoSuchJob Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchJob Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchJob
Visual Basic
Public Shared MsgDm_NoSuchJob As Integer
Visual C++
public:
static int MsgDm_NoSuchJob

See Also

P4ClientError Class


MsgDm_NoSuchJob2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchJob2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchJob2
Visual Basic
Public Shared MsgDm_NoSuchJob2 As Integer
Visual C++
public:
static int MsgDm_NoSuchJob2

See Also

P4ClientError Class


MsgDm_NoSuchKey Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchKey Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchKey
Visual Basic
Public Shared MsgDm_NoSuchKey As Integer
Visual C++
public:
static int MsgDm_NoSuchKey

See Also

P4ClientError Class


MsgDm_NoSuchProperty Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchProperty Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchProperty
Visual Basic
Public Shared MsgDm_NoSuchProperty As Integer
Visual C++
public:
static int MsgDm_NoSuchProperty

See Also

P4ClientError Class


MsgDm_NoSuchRelease Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchRelease Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchRelease
Visual Basic
Public Shared MsgDm_NoSuchRelease As Integer
Visual C++
public:
static int MsgDm_NoSuchRelease

See Also

P4ClientError Class


MsgDm_NoSuchResource Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchResource Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchResource
Visual Basic
Public Shared MsgDm_NoSuchResource As Integer
Visual C++
public:
static int MsgDm_NoSuchResource

See Also

P4ClientError Class


MsgDm_NoSuchServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchServer
Visual Basic
Public Shared MsgDm_NoSuchServer As Integer
Visual C++
public:
static int MsgDm_NoSuchServer

See Also

P4ClientError Class


MsgDm_NoSuchServerlog Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoSuchServerlog Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoSuchServerlog
Visual Basic
Public Shared MsgDm_NoSuchServerlog As Integer
Visual C++
public:
static int MsgDm_NoSuchServerlog

See Also

P4ClientError Class


MsgDm_NotAsService Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotAsService Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotAsService
Visual Basic
Public Shared MsgDm_NotAsService As Integer
Visual C++
public:
static int MsgDm_NotAsService

See Also

P4ClientError Class


MsgDm_NotBoundToServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotBoundToServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotBoundToServer
Visual Basic
Public Shared MsgDm_NotBoundToServer As Integer
Visual C++
public:
static int MsgDm_NotBoundToServer

See Also

P4ClientError Class


MsgDm_NotBucket Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotBucket Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotBucket
Visual Basic
Public Shared MsgDm_NotBucket As Integer
Visual C++
public:
static int MsgDm_NotBucket

See Also

P4ClientError Class


MsgDm_NotClientOrLabel Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotClientOrLabel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotClientOrLabel
Visual Basic
Public Shared MsgDm_NotClientOrLabel As Integer
Visual C++
public:
static int MsgDm_NotClientOrLabel

See Also

P4ClientError Class


MsgDm_NotStreamReady Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotStreamReady Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotStreamReady
Visual Basic
Public Shared MsgDm_NotStreamReady As Integer
Visual C++
public:
static int MsgDm_NotStreamReady

See Also

P4ClientError Class


MsgDm_NotThatCounter Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotThatCounter Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotThatCounter
Visual Basic
Public Shared MsgDm_NotThatCounter As Integer
Visual C++
public:
static int MsgDm_NotThatCounter

See Also

P4ClientError Class


MsgDm_NotUnderClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotUnderClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotUnderClient
Visual Basic
Public Shared MsgDm_NotUnderClient As Integer
Visual C++
public:
static int MsgDm_NotUnderClient

See Also

P4ClientError Class


MsgDm_NotUnderRoot Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotUnderRoot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotUnderRoot
Visual Basic
Public Shared MsgDm_NotUnderRoot As Integer
Visual C++
public:
static int MsgDm_NotUnderRoot

See Also

P4ClientError Class


MsgDm_NotUnloaded Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NotUnloaded Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NotUnloaded
Visual Basic
Public Shared MsgDm_NotUnloaded As Integer
Visual C++
public:
static int MsgDm_NotUnloaded

See Also

P4ClientError Class


MsgDm_NoUnloadedAutoLabel Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_NoUnloadedAutoLabel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_NoUnloadedAutoLabel
Visual Basic
Public Shared MsgDm_NoUnloadedAutoLabel As Integer
Visual C++
public:
static int MsgDm_NoUnloadedAutoLabel

See Also

P4ClientError Class


MsgDm_OpenAlready Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenAlready Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenAlready
Visual Basic
Public Shared MsgDm_OpenAlready As Integer
Visual C++
public:
static int MsgDm_OpenAlready

See Also

P4ClientError Class


MsgDm_OpenAttrRO Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenAttrRO Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenAttrRO
Visual Basic
Public Shared MsgDm_OpenAttrRO As Integer
Visual C++
public:
static int MsgDm_OpenAttrRO

See Also

P4ClientError Class


MsgDm_OpenBadAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenBadAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenBadAction
Visual Basic
Public Shared MsgDm_OpenBadAction As Integer
Visual C++
public:
static int MsgDm_OpenBadAction

See Also

P4ClientError Class


MsgDm_OpenBadChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenBadChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenBadChange
Visual Basic
Public Shared MsgDm_OpenBadChange As Integer
Visual C++
public:
static int MsgDm_OpenBadChange

See Also

P4ClientError Class


MsgDm_OpenBadClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenBadClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenBadClient
Visual Basic
Public Shared MsgDm_OpenBadClient As Integer
Visual C++
public:
static int MsgDm_OpenBadClient

See Also

P4ClientError Class


MsgDm_OpenBadType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenBadType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenBadType
Visual Basic
Public Shared MsgDm_OpenBadType As Integer
Visual C++
public:
static int MsgDm_OpenBadType

See Also

P4ClientError Class


MsgDm_OpenBadUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenBadUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenBadUser
Visual Basic
Public Shared MsgDm_OpenBadUser As Integer
Visual C++
public:
static int MsgDm_OpenBadUser

See Also

P4ClientError Class


MsgDm_OpenCantDeleted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenCantDeleted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenCantDeleted
Visual Basic
Public Shared MsgDm_OpenCantDeleted As Integer
Visual C++
public:
static int MsgDm_OpenCantDeleted

See Also

P4ClientError Class


MsgDm_OpenCantExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenCantExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenCantExists
Visual Basic
Public Shared MsgDm_OpenCantExists As Integer
Visual C++
public:
static int MsgDm_OpenCantExists

See Also

P4ClientError Class


MsgDm_OpenedData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedData
Visual Basic
Public Shared MsgDm_OpenedData As Integer
Visual C++
public:
static int MsgDm_OpenedData

See Also

P4ClientError Class


MsgDm_OpenedDataS Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedDataS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedDataS
Visual Basic
Public Shared MsgDm_OpenedDataS As Integer
Visual C++
public:
static int MsgDm_OpenedDataS

See Also

P4ClientError Class


MsgDm_OpenedDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedDelete
Visual Basic
Public Shared MsgDm_OpenedDelete As Integer
Visual C++
public:
static int MsgDm_OpenedDelete

See Also

P4ClientError Class


MsgDm_OpenedLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedLocked
Visual Basic
Public Shared MsgDm_OpenedLocked As Integer
Visual C++
public:
static int MsgDm_OpenedLocked

See Also

P4ClientError Class


MsgDm_OpenedLockedS Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedLockedS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedLockedS
Visual Basic
Public Shared MsgDm_OpenedLockedS As Integer
Visual C++
public:
static int MsgDm_OpenedLockedS

See Also

P4ClientError Class


MsgDm_OpenedOther Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedOther Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedOther
Visual Basic
Public Shared MsgDm_OpenedOther As Integer
Visual C++
public:
static int MsgDm_OpenedOther

See Also

P4ClientError Class


MsgDm_OpenedOtherLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedOtherLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedOtherLocked
Visual Basic
Public Shared MsgDm_OpenedOtherLocked As Integer
Visual C++
public:
static int MsgDm_OpenedOtherLocked

See Also

P4ClientError Class


MsgDm_OpenedOtherLockedS Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedOtherLockedS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedOtherLockedS
Visual Basic
Public Shared MsgDm_OpenedOtherLockedS As Integer
Visual C++
public:
static int MsgDm_OpenedOtherLockedS

See Also

P4ClientError Class


MsgDm_OpenedOtherS Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedOtherS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedOtherS
Visual Basic
Public Shared MsgDm_OpenedOtherS As Integer
Visual C++
public:
static int MsgDm_OpenedOtherS

See Also

P4ClientError Class


MsgDm_OpenedSwitch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedSwitch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedSwitch
Visual Basic
Public Shared MsgDm_OpenedSwitch As Integer
Visual C++
public:
static int MsgDm_OpenedSwitch

See Also

P4ClientError Class


MsgDm_OpenedTaskSwitch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedTaskSwitch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedTaskSwitch
Visual Basic
Public Shared MsgDm_OpenedTaskSwitch As Integer
Visual C++
public:
static int MsgDm_OpenedTaskSwitch

See Also

P4ClientError Class


MsgDm_OpenedXData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedXData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedXData
Visual Basic
Public Shared MsgDm_OpenedXData As Integer
Visual C++
public:
static int MsgDm_OpenedXData

See Also

P4ClientError Class


MsgDm_OpenedXDataS Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedXDataS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedXDataS
Visual Basic
Public Shared MsgDm_OpenedXDataS As Integer
Visual C++
public:
static int MsgDm_OpenedXDataS

See Also

P4ClientError Class


MsgDm_OpenedXOther Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedXOther Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedXOther
Visual Basic
Public Shared MsgDm_OpenedXOther As Integer
Visual C++
public:
static int MsgDm_OpenedXOther

See Also

P4ClientError Class


MsgDm_OpenedXOtherS Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenedXOtherS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenedXOtherS
Visual Basic
Public Shared MsgDm_OpenedXOtherS As Integer
Visual C++
public:
static int MsgDm_OpenedXOtherS

See Also

P4ClientError Class


MsgDm_OpenExclLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenExclLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenExclLocked
Visual Basic
Public Shared MsgDm_OpenExclLocked As Integer
Visual C++
public:
static int MsgDm_OpenExclLocked

See Also

P4ClientError Class


MsgDm_OpenExclOrphaned Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenExclOrphaned Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenExclOrphaned
Visual Basic
Public Shared MsgDm_OpenExclOrphaned As Integer
Visual C++
public:
static int MsgDm_OpenExclOrphaned

See Also

P4ClientError Class


MsgDm_OpenExclOther Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenExclOther Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenExclOther
Visual Basic
Public Shared MsgDm_OpenExclOther As Integer
Visual C++
public:
static int MsgDm_OpenExclOther

See Also

P4ClientError Class


MsgDm_OpenFilesCantChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenFilesCantChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenFilesCantChange
Visual Basic
Public Shared MsgDm_OpenFilesCantChange As Integer
Visual C++
public:
static int MsgDm_OpenFilesCantChange

See Also

P4ClientError Class


MsgDm_OpenFilesCantChangeUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenFilesCantChangeUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenFilesCantChangeUser
Visual Basic
Public Shared MsgDm_OpenFilesCantChangeUser As Integer
Visual C++
public:
static int MsgDm_OpenFilesCantChangeUser

See Also

P4ClientError Class


MsgDm_OpenIsLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenIsLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenIsLocked
Visual Basic
Public Shared MsgDm_OpenIsLocked As Integer
Visual C++
public:
static int MsgDm_OpenIsLocked

See Also

P4ClientError Class


MsgDm_OpenIsOpened Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenIsOpened Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenIsOpened
Visual Basic
Public Shared MsgDm_OpenIsOpened As Integer
Visual C++
public:
static int MsgDm_OpenIsOpened

See Also

P4ClientError Class


MsgDm_OpenMustResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenMustResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenMustResolve
Visual Basic
Public Shared MsgDm_OpenMustResolve As Integer
Visual C++
public:
static int MsgDm_OpenMustResolve

See Also

P4ClientError Class


MsgDm_OpenOtherDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenOtherDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenOtherDepot
Visual Basic
Public Shared MsgDm_OpenOtherDepot As Integer
Visual C++
public:
static int MsgDm_OpenOtherDepot

See Also

P4ClientError Class


MsgDm_OpenReadOnly Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenReadOnly Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenReadOnly
Visual Basic
Public Shared MsgDm_OpenReadOnly As Integer
Visual C++
public:
static int MsgDm_OpenReadOnly

See Also

P4ClientError Class


MsgDm_OpenReOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenReOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenReOpen
Visual Basic
Public Shared MsgDm_OpenReOpen As Integer
Visual C++
public:
static int MsgDm_OpenReOpen

See Also

P4ClientError Class


MsgDm_OpenSuccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenSuccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenSuccess
Visual Basic
Public Shared MsgDm_OpenSuccess As Integer
Visual C++
public:
static int MsgDm_OpenSuccess

See Also

P4ClientError Class


MsgDm_OpenTaskNotMapped Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenTaskNotMapped Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenTaskNotMapped
Visual Basic
Public Shared MsgDm_OpenTaskNotMapped As Integer
Visual C++
public:
static int MsgDm_OpenTaskNotMapped

See Also

P4ClientError Class


MsgDm_OpenUpToDate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenUpToDate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenUpToDate
Visual Basic
Public Shared MsgDm_OpenUpToDate As Integer
Visual C++
public:
static int MsgDm_OpenUpToDate

See Also

P4ClientError Class


MsgDm_OpenWarnChangeMap Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnChangeMap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnChangeMap
Visual Basic
Public Shared MsgDm_OpenWarnChangeMap As Integer
Visual C++
public:
static int MsgDm_OpenWarnChangeMap

See Also

P4ClientError Class


MsgDm_OpenWarnDeleted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnDeleted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnDeleted
Visual Basic
Public Shared MsgDm_OpenWarnDeleted As Integer
Visual C++
public:
static int MsgDm_OpenWarnDeleted

See Also

P4ClientError Class


MsgDm_OpenWarnExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnExists
Visual Basic
Public Shared MsgDm_OpenWarnExists As Integer
Visual C++
public:
static int MsgDm_OpenWarnExists

See Also

P4ClientError Class


MsgDm_OpenWarnFileNotMapped Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnFileNotMapped Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnFileNotMapped
Visual Basic
Public Shared MsgDm_OpenWarnFileNotMapped As Integer
Visual C++
public:
static int MsgDm_OpenWarnFileNotMapped

See Also

P4ClientError Class


MsgDm_OpenWarnMoved Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnMoved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnMoved
Visual Basic
Public Shared MsgDm_OpenWarnMoved As Integer
Visual C++
public:
static int MsgDm_OpenWarnMoved

See Also

P4ClientError Class


MsgDm_OpenWarnOpenNotStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnOpenNotStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnOpenNotStream
Visual Basic
Public Shared MsgDm_OpenWarnOpenNotStream As Integer
Visual C++
public:
static int MsgDm_OpenWarnOpenNotStream

See Also

P4ClientError Class


MsgDm_OpenWarnOpenStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnOpenStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnOpenStream
Visual Basic
Public Shared MsgDm_OpenWarnOpenStream As Integer
Visual C++
public:
static int MsgDm_OpenWarnOpenStream

See Also

P4ClientError Class


MsgDm_OpenWarnPurged Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenWarnPurged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenWarnPurged
Visual Basic
Public Shared MsgDm_OpenWarnPurged As Integer
Visual C++
public:
static int MsgDm_OpenWarnPurged

See Also

P4ClientError Class


MsgDm_OpenXOpened Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenXOpened Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenXOpened
Visual Basic
Public Shared MsgDm_OpenXOpened As Integer
Visual C++
public:
static int MsgDm_OpenXOpened

See Also

P4ClientError Class


MsgDm_OpenXOpenedFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OpenXOpenedFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OpenXOpenedFailed
Visual Basic
Public Shared MsgDm_OpenXOpenedFailed As Integer
Visual C++
public:
static int MsgDm_OpenXOpenedFailed

See Also

P4ClientError Class


MsgDm_OperatorNotAllowed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OperatorNotAllowed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OperatorNotAllowed
Visual Basic
Public Shared MsgDm_OperatorNotAllowed As Integer
Visual C++
public:
static int MsgDm_OperatorNotAllowed

See Also

P4ClientError Class


MsgDm_OutOfSequence Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OutOfSequence Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OutOfSequence
Visual Basic
Public Shared MsgDm_OutOfSequence As Integer
Visual C++
public:
static int MsgDm_OutOfSequence

See Also

P4ClientError Class


MsgDm_OwnerCantChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_OwnerCantChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_OwnerCantChange
Visual Basic
Public Shared MsgDm_OwnerCantChange As Integer
Visual C++
public:
static int MsgDm_OwnerCantChange

See Also

P4ClientError Class


MsgDm_ParallelNotEnabled Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ParallelNotEnabled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ParallelNotEnabled
Visual Basic
Public Shared MsgDm_ParallelNotEnabled As Integer
Visual C++
public:
static int MsgDm_ParallelNotEnabled

See Also

P4ClientError Class


MsgDm_ParallelOptions Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ParallelOptions Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ParallelOptions
Visual Basic
Public Shared MsgDm_ParallelOptions As Integer
Visual C++
public:
static int MsgDm_ParallelOptions

See Also

P4ClientError Class


MsgDm_Passwd982 Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Passwd982 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Passwd982
Visual Basic
Public Shared MsgDm_Passwd982 As Integer
Visual C++
public:
static int MsgDm_Passwd982

See Also

P4ClientError Class


MsgDm_PastUpgrade Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PastUpgrade Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PastUpgrade
Visual Basic
Public Shared MsgDm_PastUpgrade As Integer
Visual C++
public:
static int MsgDm_PastUpgrade

See Also

P4ClientError Class


MsgDm_PathNotUnder Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PathNotUnder Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PathNotUnder
Visual Basic
Public Shared MsgDm_PathNotUnder As Integer
Visual C++
public:
static int MsgDm_PathNotUnder

See Also

P4ClientError Class


MsgDm_PendingDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PendingDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PendingDelete
Visual Basic
Public Shared MsgDm_PendingDelete As Integer
Visual C++
public:
static int MsgDm_PendingDelete

See Also

P4ClientError Class


MsgDm_PendingNoPerm Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PendingNoPerm Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PendingNoPerm
Visual Basic
Public Shared MsgDm_PendingNoPerm As Integer
Visual C++
public:
static int MsgDm_PendingNoPerm

See Also

P4ClientError Class


MsgDm_PopulateDesc Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PopulateDesc Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PopulateDesc
Visual Basic
Public Shared MsgDm_PopulateDesc As Integer
Visual C++
public:
static int MsgDm_PopulateDesc

See Also

P4ClientError Class


MsgDm_PopulateInvalidStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PopulateInvalidStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PopulateInvalidStream
Visual Basic
Public Shared MsgDm_PopulateInvalidStream As Integer
Visual C++
public:
static int MsgDm_PopulateInvalidStream

See Also

P4ClientError Class


MsgDm_PopulateMultipleStreams Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PopulateMultipleStreams Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PopulateMultipleStreams
Visual Basic
Public Shared MsgDm_PopulateMultipleStreams As Integer
Visual C++
public:
static int MsgDm_PopulateMultipleStreams

See Also

P4ClientError Class


MsgDm_PopulateTargetExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PopulateTargetExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PopulateTargetExists
Visual Basic
Public Shared MsgDm_PopulateTargetExists As Integer
Visual C++
public:
static int MsgDm_PopulateTargetExists

See Also

P4ClientError Class


MsgDm_PopulateTargetMixed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PopulateTargetMixed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PopulateTargetMixed
Visual Basic
Public Shared MsgDm_PopulateTargetMixed As Integer
Visual C++
public:
static int MsgDm_PopulateTargetMixed

See Also

P4ClientError Class


MsgDm_PosWild Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PosWild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PosWild
Visual Basic
Public Shared MsgDm_PosWild As Integer
Visual C++
public:
static int MsgDm_PosWild

See Also

P4ClientError Class


MsgDm_PropertyAllData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PropertyAllData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PropertyAllData
Visual Basic
Public Shared MsgDm_PropertyAllData As Integer
Visual C++
public:
static int MsgDm_PropertyAllData

See Also

P4ClientError Class


MsgDm_PropertyData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PropertyData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PropertyData
Visual Basic
Public Shared MsgDm_PropertyData As Integer
Visual C++
public:
static int MsgDm_PropertyData

See Also

P4ClientError Class


MsgDm_PropertyDataGroup Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PropertyDataGroup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PropertyDataGroup
Visual Basic
Public Shared MsgDm_PropertyDataGroup As Integer
Visual C++
public:
static int MsgDm_PropertyDataGroup

See Also

P4ClientError Class


MsgDm_PropertyDataUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PropertyDataUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PropertyDataUser
Visual Basic
Public Shared MsgDm_PropertyDataUser As Integer
Visual C++
public:
static int MsgDm_PropertyDataUser

See Also

P4ClientError Class


MsgDm_ProtectedCodes Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ProtectedCodes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ProtectedCodes
Visual Basic
Public Shared MsgDm_ProtectedCodes As Integer
Visual C++
public:
static int MsgDm_ProtectedCodes

See Also

P4ClientError Class


MsgDm_ProtectNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ProtectNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ProtectNoChange
Visual Basic
Public Shared MsgDm_ProtectNoChange As Integer
Visual C++
public:
static int MsgDm_ProtectNoChange

See Also

P4ClientError Class


MsgDm_ProtectSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ProtectSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ProtectSave
Visual Basic
Public Shared MsgDm_ProtectSave As Integer
Visual C++
public:
static int MsgDm_ProtectSave

See Also

P4ClientError Class


MsgDm_ProtectsData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ProtectsData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ProtectsData
Visual Basic
Public Shared MsgDm_ProtectsData As Integer
Visual C++
public:
static int MsgDm_ProtectsData

See Also

P4ClientError Class


MsgDm_ProtectsEmpty Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ProtectsEmpty Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ProtectsEmpty
Visual Basic
Public Shared MsgDm_ProtectsEmpty As Integer
Visual C++
public:
static int MsgDm_ProtectsEmpty

See Also

P4ClientError Class


MsgDm_ProtectsMaxData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ProtectsMaxData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ProtectsMaxData
Visual Basic
Public Shared MsgDm_ProtectsMaxData As Integer
Visual C++
public:
static int MsgDm_ProtectsMaxData

See Also

P4ClientError Class


MsgDm_ProtectsNoSuper Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ProtectsNoSuper Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ProtectsNoSuper
Visual Basic
Public Shared MsgDm_ProtectsNoSuper As Integer
Visual C++
public:
static int MsgDm_ProtectsNoSuper

See Also

P4ClientError Class


MsgDm_PurgeActiveTask Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PurgeActiveTask Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PurgeActiveTask
Visual Basic
Public Shared MsgDm_PurgeActiveTask As Integer
Visual C++
public:
static int MsgDm_PurgeActiveTask

See Also

P4ClientError Class


MsgDm_PurgeCheck Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PurgeCheck Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PurgeCheck
Visual Basic
Public Shared MsgDm_PurgeCheck As Integer
Visual C++
public:
static int MsgDm_PurgeCheck

See Also

P4ClientError Class


MsgDm_PurgeData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PurgeData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PurgeData
Visual Basic
Public Shared MsgDm_PurgeData As Integer
Visual C++
public:
static int MsgDm_PurgeData

See Also

P4ClientError Class


MsgDm_PurgeDeleted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PurgeDeleted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PurgeDeleted
Visual Basic
Public Shared MsgDm_PurgeDeleted As Integer
Visual C++
public:
static int MsgDm_PurgeDeleted

See Also

P4ClientError Class


MsgDm_PurgeFirst Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PurgeFirst Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PurgeFirst
Visual Basic
Public Shared MsgDm_PurgeFirst As Integer
Visual C++
public:
static int MsgDm_PurgeFirst

See Also

P4ClientError Class


MsgDm_PurgeNoRecords Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PurgeNoRecords Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PurgeNoRecords
Visual Basic
Public Shared MsgDm_PurgeNoRecords As Integer
Visual C++
public:
static int MsgDm_PurgeNoRecords

See Also

P4ClientError Class


MsgDm_PurgeSnapData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_PurgeSnapData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_PurgeSnapData
Visual Basic
Public Shared MsgDm_PurgeSnapData As Integer
Visual C++
public:
static int MsgDm_PurgeSnapData

See Also

P4ClientError Class


MsgDm_ReconcileBadName Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReconcileBadName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReconcileBadName
Visual Basic
Public Shared MsgDm_ReconcileBadName As Integer
Visual C++
public:
static int MsgDm_ReconcileBadName

See Also

P4ClientError Class


MsgDm_ReconcileNeedForce Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReconcileNeedForce Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReconcileNeedForce
Visual Basic
Public Shared MsgDm_ReconcileNeedForce As Integer
Visual C++
public:
static int MsgDm_ReconcileNeedForce

See Also

P4ClientError Class


MsgDm_ReferClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReferClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReferClient
Visual Basic
Public Shared MsgDm_ReferClient As Integer
Visual C++
public:
static int MsgDm_ReferClient

See Also

P4ClientError Class


MsgDm_ReleaseAbandon Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseAbandon Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseAbandon
Visual Basic
Public Shared MsgDm_ReleaseAbandon As Integer
Visual C++
public:
static int MsgDm_ReleaseAbandon

See Also

P4ClientError Class


MsgDm_ReleaseClear Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseClear Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseClear
Visual Basic
Public Shared MsgDm_ReleaseClear As Integer
Visual C++
public:
static int MsgDm_ReleaseClear

See Also

P4ClientError Class


MsgDm_ReleaseDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseDelete
Visual Basic
Public Shared MsgDm_ReleaseDelete As Integer
Visual C++
public:
static int MsgDm_ReleaseDelete

See Also

P4ClientError Class


MsgDm_ReleaseHasMoved Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseHasMoved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseHasMoved
Visual Basic
Public Shared MsgDm_ReleaseHasMoved As Integer
Visual C++
public:
static int MsgDm_ReleaseHasMoved

See Also

P4ClientError Class


MsgDm_ReleaseHasPending Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseHasPending Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseHasPending
Visual Basic
Public Shared MsgDm_ReleaseHasPending As Integer
Visual C++
public:
static int MsgDm_ReleaseHasPending

See Also

P4ClientError Class


MsgDm_ReleaseNotOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseNotOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseNotOwner
Visual Basic
Public Shared MsgDm_ReleaseNotOwner As Integer
Visual C++
public:
static int MsgDm_ReleaseNotOwner

See Also

P4ClientError Class


MsgDm_ReleaseRevert Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseRevert Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseRevert
Visual Basic
Public Shared MsgDm_ReleaseRevert As Integer
Visual C++
public:
static int MsgDm_ReleaseRevert

See Also

P4ClientError Class


MsgDm_ReleaseUnlockAbandon Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseUnlockAbandon Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseUnlockAbandon
Visual Basic
Public Shared MsgDm_ReleaseUnlockAbandon As Integer
Visual C++
public:
static int MsgDm_ReleaseUnlockAbandon

See Also

P4ClientError Class


MsgDm_ReleaseUnlockClear Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseUnlockClear Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseUnlockClear
Visual Basic
Public Shared MsgDm_ReleaseUnlockClear As Integer
Visual C++
public:
static int MsgDm_ReleaseUnlockClear

See Also

P4ClientError Class


MsgDm_ReleaseUnlockDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseUnlockDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseUnlockDelete
Visual Basic
Public Shared MsgDm_ReleaseUnlockDelete As Integer
Visual C++
public:
static int MsgDm_ReleaseUnlockDelete

See Also

P4ClientError Class


MsgDm_ReleaseUnlockRevert Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReleaseUnlockRevert Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReleaseUnlockRevert
Visual Basic
Public Shared MsgDm_ReleaseUnlockRevert As Integer
Visual C++
public:
static int MsgDm_ReleaseUnlockRevert

See Also

P4ClientError Class


MsgDm_ReloadData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReloadData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReloadData
Visual Basic
Public Shared MsgDm_ReloadData As Integer
Visual C++
public:
static int MsgDm_ReloadData

See Also

P4ClientError Class


MsgDm_ReloadFirst Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReloadFirst Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReloadFirst
Visual Basic
Public Shared MsgDm_ReloadFirst As Integer
Visual C++
public:
static int MsgDm_ReloadFirst

See Also

P4ClientError Class


MsgDm_ReloadNotOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReloadNotOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReloadNotOwner
Visual Basic
Public Shared MsgDm_ReloadNotOwner As Integer
Visual C++
public:
static int MsgDm_ReloadNotOwner

See Also

P4ClientError Class


MsgDm_ReloadSuspicious Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReloadSuspicious Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReloadSuspicious
Visual Basic
Public Shared MsgDm_ReloadSuspicious As Integer
Visual C++
public:
static int MsgDm_ReloadSuspicious

See Also

P4ClientError Class


MsgDm_RemoteChangeExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RemoteChangeExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RemoteChangeExists
Visual Basic
Public Shared MsgDm_RemoteChangeExists As Integer
Visual C++
public:
static int MsgDm_RemoteChangeExists

See Also

P4ClientError Class


MsgDm_RemoteChangeMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RemoteChangeMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RemoteChangeMissing
Visual Basic
Public Shared MsgDm_RemoteChangeMissing As Integer
Visual C++
public:
static int MsgDm_RemoteChangeMissing

See Also

P4ClientError Class


MsgDm_RemoteDomainExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RemoteDomainExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RemoteDomainExists
Visual Basic
Public Shared MsgDm_RemoteDomainExists As Integer
Visual C++
public:
static int MsgDm_RemoteDomainExists

See Also

P4ClientError Class


MsgDm_RemoteDomainMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RemoteDomainMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RemoteDomainMissing
Visual Basic
Public Shared MsgDm_RemoteDomainMissing As Integer
Visual C++
public:
static int MsgDm_RemoteDomainMissing

See Also

P4ClientError Class


MsgDm_ReopenBadType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReopenBadType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReopenBadType
Visual Basic
Public Shared MsgDm_ReopenBadType As Integer
Visual C++
public:
static int MsgDm_ReopenBadType

See Also

P4ClientError Class


MsgDm_ReopenCharSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReopenCharSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReopenCharSet
Visual Basic
Public Shared MsgDm_ReopenCharSet As Integer
Visual C++
public:
static int MsgDm_ReopenCharSet

See Also

P4ClientError Class


MsgDm_ReopenData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReopenData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReopenData
Visual Basic
Public Shared MsgDm_ReopenData As Integer
Visual C++
public:
static int MsgDm_ReopenData

See Also

P4ClientError Class


MsgDm_ReopenDataNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReopenDataNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReopenDataNoChange
Visual Basic
Public Shared MsgDm_ReopenDataNoChange As Integer
Visual C++
public:
static int MsgDm_ReopenDataNoChange

See Also

P4ClientError Class


MsgDm_Resolve2WayRaw Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Resolve2WayRaw Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Resolve2WayRaw
Visual Basic
Public Shared MsgDm_Resolve2WayRaw As Integer
Visual C++
public:
static int MsgDm_Resolve2WayRaw

See Also

P4ClientError Class


MsgDm_Resolve3WayRaw Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Resolve3WayRaw Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Resolve3WayRaw
Visual Basic
Public Shared MsgDm_Resolve3WayRaw As Integer
Visual C++
public:
static int MsgDm_Resolve3WayRaw

See Also

P4ClientError Class


MsgDm_Resolve3WayText Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Resolve3WayText Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Resolve3WayText
Visual Basic
Public Shared MsgDm_Resolve3WayText As Integer
Visual C++
public:
static int MsgDm_Resolve3WayText

See Also

P4ClientError Class


MsgDm_Resolve3WayTextBase Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Resolve3WayTextBase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Resolve3WayTextBase
Visual Basic
Public Shared MsgDm_Resolve3WayTextBase As Integer
Visual C++
public:
static int MsgDm_Resolve3WayTextBase

See Also

P4ClientError Class


MsgDm_ResolveAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveAction
Visual Basic
Public Shared MsgDm_ResolveAction As Integer
Visual C++
public:
static int MsgDm_ResolveAction

See Also

P4ClientError Class


MsgDm_ResolveActionMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveActionMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveActionMove
Visual Basic
Public Shared MsgDm_ResolveActionMove As Integer
Visual C++
public:
static int MsgDm_ResolveActionMove

See Also

P4ClientError Class


MsgDm_ResolveCharset Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveCharset Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveCharset
Visual Basic
Public Shared MsgDm_ResolveCharset As Integer
Visual C++
public:
static int MsgDm_ResolveCharset

See Also

P4ClientError Class


MsgDm_ResolveCharsetActionT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveCharsetActionT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveCharsetActionT
Visual Basic
Public Shared MsgDm_ResolveCharsetActionT As Integer
Visual C++
public:
static int MsgDm_ResolveCharsetActionT

See Also

P4ClientError Class


MsgDm_ResolveCharsetActionY Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveCharsetActionY Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveCharsetActionY
Visual Basic
Public Shared MsgDm_ResolveCharsetActionY As Integer
Visual C++
public:
static int MsgDm_ResolveCharsetActionY

See Also

P4ClientError Class


MsgDm_ResolvedAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolvedAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolvedAction
Visual Basic
Public Shared MsgDm_ResolvedAction As Integer
Visual C++
public:
static int MsgDm_ResolvedAction

See Also

P4ClientError Class


MsgDm_ResolvedActionMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolvedActionMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolvedActionMove
Visual Basic
Public Shared MsgDm_ResolvedActionMove As Integer
Visual C++
public:
static int MsgDm_ResolvedActionMove

See Also

P4ClientError Class


MsgDm_ResolvedData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolvedData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolvedData
Visual Basic
Public Shared MsgDm_ResolvedData As Integer
Visual C++
public:
static int MsgDm_ResolvedData

See Also

P4ClientError Class


MsgDm_ResolvedDataBase Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolvedDataBase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolvedDataBase
Visual Basic
Public Shared MsgDm_ResolvedDataBase As Integer
Visual C++
public:
static int MsgDm_ResolvedDataBase

See Also

P4ClientError Class


MsgDm_ResolveDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveDelete
Visual Basic
Public Shared MsgDm_ResolveDelete As Integer
Visual C++
public:
static int MsgDm_ResolveDelete

See Also

P4ClientError Class


MsgDm_ResolveDoBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveDoBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveDoBranch
Visual Basic
Public Shared MsgDm_ResolveDoBranch As Integer
Visual C++
public:
static int MsgDm_ResolveDoBranch

See Also

P4ClientError Class


MsgDm_ResolveDoBranchActionT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveDoBranchActionT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveDoBranchActionT
Visual Basic
Public Shared MsgDm_ResolveDoBranchActionT As Integer
Visual C++
public:
static int MsgDm_ResolveDoBranchActionT

See Also

P4ClientError Class


MsgDm_ResolveDoBranchActionY Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveDoBranchActionY Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveDoBranchActionY
Visual Basic
Public Shared MsgDm_ResolveDoBranchActionY As Integer
Visual C++
public:
static int MsgDm_ResolveDoBranchActionY

See Also

P4ClientError Class


MsgDm_ResolveDoDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveDoDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveDoDelete
Visual Basic
Public Shared MsgDm_ResolveDoDelete As Integer
Visual C++
public:
static int MsgDm_ResolveDoDelete

See Also

P4ClientError Class


MsgDm_ResolveDoDeleteActionT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveDoDeleteActionT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveDoDeleteActionT
Visual Basic
Public Shared MsgDm_ResolveDoDeleteActionT As Integer
Visual C++
public:
static int MsgDm_ResolveDoDeleteActionT

See Also

P4ClientError Class


MsgDm_ResolveDoDeleteActionY Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveDoDeleteActionY Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveDoDeleteActionY
Visual Basic
Public Shared MsgDm_ResolveDoDeleteActionY As Integer
Visual C++
public:
static int MsgDm_ResolveDoDeleteActionY

See Also

P4ClientError Class


MsgDm_ResolveFiletype Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveFiletype Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveFiletype
Visual Basic
Public Shared MsgDm_ResolveFiletype As Integer
Visual C++
public:
static int MsgDm_ResolveFiletype

See Also

P4ClientError Class


MsgDm_ResolveFiletypeAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveFiletypeAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveFiletypeAction
Visual Basic
Public Shared MsgDm_ResolveFiletypeAction As Integer
Visual C++
public:
static int MsgDm_ResolveFiletypeAction

See Also

P4ClientError Class


MsgDm_ResolveMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveMove
Visual Basic
Public Shared MsgDm_ResolveMove As Integer
Visual C++
public:
static int MsgDm_ResolveMove

See Also

P4ClientError Class


MsgDm_ResolveMoveAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveMoveAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveMoveAction
Visual Basic
Public Shared MsgDm_ResolveMoveAction As Integer
Visual C++
public:
static int MsgDm_ResolveMoveAction

See Also

P4ClientError Class


MsgDm_ResolveMustIgnore Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveMustIgnore Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveMustIgnore
Visual Basic
Public Shared MsgDm_ResolveMustIgnore As Integer
Visual C++
public:
static int MsgDm_ResolveMustIgnore

See Also

P4ClientError Class


MsgDm_ResolveShelveDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveShelveDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveShelveDelete
Visual Basic
Public Shared MsgDm_ResolveShelveDelete As Integer
Visual C++
public:
static int MsgDm_ResolveShelveDelete

See Also

P4ClientError Class


MsgDm_ResolveTrait Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveTrait Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveTrait
Visual Basic
Public Shared MsgDm_ResolveTrait As Integer
Visual C++
public:
static int MsgDm_ResolveTrait

See Also

P4ClientError Class


MsgDm_ResolveTraitActionM Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveTraitActionM Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveTraitActionM
Visual Basic
Public Shared MsgDm_ResolveTraitActionM As Integer
Visual C++
public:
static int MsgDm_ResolveTraitActionM

See Also

P4ClientError Class


MsgDm_ResolveTraitActionT Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveTraitActionT Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveTraitActionT
Visual Basic
Public Shared MsgDm_ResolveTraitActionT As Integer
Visual C++
public:
static int MsgDm_ResolveTraitActionT

See Also

P4ClientError Class


MsgDm_ResolveTraitActionY Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResolveTraitActionY Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResolveTraitActionY
Visual Basic
Public Shared MsgDm_ResolveTraitActionY As Integer
Visual C++
public:
static int MsgDm_ResolveTraitActionY

See Also

P4ClientError Class


MsgDm_ResourceAlreadyLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ResourceAlreadyLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ResourceAlreadyLocked
Visual Basic
Public Shared MsgDm_ResourceAlreadyLocked As Integer
Visual C++
public:
static int MsgDm_ResourceAlreadyLocked

See Also

P4ClientError Class


MsgDm_RetypeData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RetypeData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RetypeData
Visual Basic
Public Shared MsgDm_RetypeData As Integer
Visual C++
public:
static int MsgDm_RetypeData

See Also

P4ClientError Class


MsgDm_ReviewData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReviewData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReviewData
Visual Basic
Public Shared MsgDm_ReviewData As Integer
Visual C++
public:
static int MsgDm_ReviewData

See Also

P4ClientError Class


MsgDm_ReviewsData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ReviewsData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ReviewsData
Visual Basic
Public Shared MsgDm_ReviewsData As Integer
Visual C++
public:
static int MsgDm_ReviewsData

See Also

P4ClientError Class


MsgDm_RevVsRevCx Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RevVsRevCx Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RevVsRevCx
Visual Basic
Public Shared MsgDm_RevVsRevCx As Integer
Visual C++
public:
static int MsgDm_RevVsRevCx

See Also

P4ClientError Class


MsgDm_RmtAddChangeFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtAddChangeFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtAddChangeFailed
Visual Basic
Public Shared MsgDm_RmtAddChangeFailed As Integer
Visual C++
public:
static int MsgDm_RmtAddChangeFailed

See Also

P4ClientError Class


MsgDm_RmtAddDomainFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtAddDomainFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtAddDomainFailed
Visual Basic
Public Shared MsgDm_RmtAddDomainFailed As Integer
Visual C++
public:
static int MsgDm_RmtAddDomainFailed

See Also

P4ClientError Class


MsgDm_RmtAuthFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtAuthFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtAuthFailed
Visual Basic
Public Shared MsgDm_RmtAuthFailed As Integer
Visual C++
public:
static int MsgDm_RmtAuthFailed

See Also

P4ClientError Class


MsgDm_RmtDeleteChangeFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtDeleteChangeFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtDeleteChangeFailed
Visual Basic
Public Shared MsgDm_RmtDeleteChangeFailed As Integer
Visual C++
public:
static int MsgDm_RmtDeleteChangeFailed

See Also

P4ClientError Class


MsgDm_RmtDeleteDomainFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtDeleteDomainFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtDeleteDomainFailed
Visual Basic
Public Shared MsgDm_RmtDeleteDomainFailed As Integer
Visual C++
public:
static int MsgDm_RmtDeleteDomainFailed

See Also

P4ClientError Class


MsgDm_RmtError Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtError Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtError
Visual Basic
Public Shared MsgDm_RmtError As Integer
Visual C++
public:
static int MsgDm_RmtError

See Also

P4ClientError Class


MsgDm_RmtExclusiveLockFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtExclusiveLockFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtExclusiveLockFailed
Visual Basic
Public Shared MsgDm_RmtExclusiveLockFailed As Integer
Visual C++
public:
static int MsgDm_RmtExclusiveLockFailed

See Also

P4ClientError Class


MsgDm_RmtJournalWaitFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtJournalWaitFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtJournalWaitFailed
Visual Basic
Public Shared MsgDm_RmtJournalWaitFailed As Integer
Visual C++
public:
static int MsgDm_RmtJournalWaitFailed

See Also

P4ClientError Class


MsgDm_RmtSequenceFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_RmtSequenceFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_RmtSequenceFailed
Visual Basic
Public Shared MsgDm_RmtSequenceFailed As Integer
Visual C++
public:
static int MsgDm_RmtSequenceFailed

See Also

P4ClientError Class


MsgDm_SameCode Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SameCode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SameCode
Visual Basic
Public Shared MsgDm_SameCode As Integer
Visual C++
public:
static int MsgDm_SameCode

See Also

P4ClientError Class


MsgDm_SameTag Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SameTag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SameTag
Visual Basic
Public Shared MsgDm_SameTag As Integer
Visual C++
public:
static int MsgDm_SameTag

See Also

P4ClientError Class


MsgDm_SemiInDefault Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SemiInDefault Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SemiInDefault
Visual Basic
Public Shared MsgDm_SemiInDefault As Integer
Visual C++
public:
static int MsgDm_SemiInDefault

See Also

P4ClientError Class


MsgDm_ServerDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServerDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServerDelete
Visual Basic
Public Shared MsgDm_ServerDelete As Integer
Visual C++
public:
static int MsgDm_ServerDelete

See Also

P4ClientError Class


MsgDm_ServerNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServerNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServerNoChange
Visual Basic
Public Shared MsgDm_ServerNoChange As Integer
Visual C++
public:
static int MsgDm_ServerNoChange

See Also

P4ClientError Class


MsgDm_ServerSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServerSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServerSave
Visual Basic
Public Shared MsgDm_ServerSave As Integer
Visual C++
public:
static int MsgDm_ServerSave

See Also

P4ClientError Class


MsgDm_ServersData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServersData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServersData
Visual Basic
Public Shared MsgDm_ServersData As Integer
Visual C++
public:
static int MsgDm_ServersData

See Also

P4ClientError Class


MsgDm_ServerTypeMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServerTypeMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServerTypeMismatch
Visual Basic
Public Shared MsgDm_ServerTypeMismatch As Integer
Visual C++
public:
static int MsgDm_ServerTypeMismatch

See Also

P4ClientError Class


MsgDm_ServerViewMap Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServerViewMap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServerViewMap
Visual Basic
Public Shared MsgDm_ServerViewMap As Integer
Visual C++
public:
static int MsgDm_ServerViewMap

See Also

P4ClientError Class


MsgDm_ServiceNotProvided Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServiceNotProvided Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServiceNotProvided
Visual Basic
Public Shared MsgDm_ServiceNotProvided As Integer
Visual C++
public:
static int MsgDm_ServiceNotProvided

See Also

P4ClientError Class


MsgDm_ServiceUserLogin Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ServiceUserLogin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ServiceUserLogin
Visual Basic
Public Shared MsgDm_ServiceUserLogin As Integer
Visual C++
public:
static int MsgDm_ServiceUserLogin

See Also

P4ClientError Class


MsgDm_ShelveCantUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveCantUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveCantUpdate
Visual Basic
Public Shared MsgDm_ShelveCantUpdate As Integer
Visual C++
public:
static int MsgDm_ShelveCantUpdate

See Also

P4ClientError Class


MsgDm_ShelvedDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelvedDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelvedDelete
Visual Basic
Public Shared MsgDm_ShelvedDelete As Integer
Visual C++
public:
static int MsgDm_ShelvedDelete

See Also

P4ClientError Class


MsgDm_ShelvedHasWorking Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelvedHasWorking Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelvedHasWorking
Visual Basic
Public Shared MsgDm_ShelvedHasWorking As Integer
Visual C++
public:
static int MsgDm_ShelvedHasWorking

See Also

P4ClientError Class


MsgDm_ShelveIncompatible Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveIncompatible Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveIncompatible
Visual Basic
Public Shared MsgDm_ShelveIncompatible As Integer
Visual C++
public:
static int MsgDm_ShelveIncompatible

See Also

P4ClientError Class


MsgDm_ShelveLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveLocked
Visual Basic
Public Shared MsgDm_ShelveLocked As Integer
Visual C++
public:
static int MsgDm_ShelveLocked

See Also

P4ClientError Class


MsgDm_ShelveMaxFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveMaxFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveMaxFiles
Visual Basic
Public Shared MsgDm_ShelveMaxFiles As Integer
Visual C++
public:
static int MsgDm_ShelveMaxFiles

See Also

P4ClientError Class


MsgDm_ShelveNeedsResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveNeedsResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveNeedsResolve
Visual Basic
Public Shared MsgDm_ShelveNeedsResolve As Integer
Visual C++
public:
static int MsgDm_ShelveNeedsResolve

See Also

P4ClientError Class


MsgDm_ShelveNoPerm Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveNoPerm Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveNoPerm
Visual Basic
Public Shared MsgDm_ShelveNoPerm As Integer
Visual C++
public:
static int MsgDm_ShelveNoPerm

See Also

P4ClientError Class


MsgDm_ShelveNotChanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveNotChanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveNotChanged
Visual Basic
Public Shared MsgDm_ShelveNotChanged As Integer
Visual C++
public:
static int MsgDm_ShelveNotChanged

See Also

P4ClientError Class


MsgDm_ShelveOpenResolves Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveOpenResolves Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveOpenResolves
Visual Basic
Public Shared MsgDm_ShelveOpenResolves As Integer
Visual C++
public:
static int MsgDm_ShelveOpenResolves

See Also

P4ClientError Class


MsgDm_ShelveUnlocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_ShelveUnlocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_ShelveUnlocked
Visual Basic
Public Shared MsgDm_ShelveUnlocked As Integer
Visual C++
public:
static int MsgDm_ShelveUnlocked

See Also

P4ClientError Class


MsgDm_SnapFirst Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SnapFirst Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SnapFirst
Visual Basic
Public Shared MsgDm_SnapFirst As Integer
Visual C++
public:
static int MsgDm_SnapFirst

See Also

P4ClientError Class


MsgDm_SpecDeleted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SpecDeleted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SpecDeleted
Visual Basic
Public Shared MsgDm_SpecDeleted As Integer
Visual C++
public:
static int MsgDm_SpecDeleted

See Also

P4ClientError Class


MsgDm_SpecNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SpecNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SpecNoChange
Visual Basic
Public Shared MsgDm_SpecNoChange As Integer
Visual C++
public:
static int MsgDm_SpecNoChange

See Also

P4ClientError Class


MsgDm_SpecNotDefined Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SpecNotDefined Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SpecNotDefined
Visual Basic
Public Shared MsgDm_SpecNotDefined As Integer
Visual C++
public:
static int MsgDm_SpecNotDefined

See Also

P4ClientError Class


MsgDm_SpecSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SpecSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SpecSave
Visual Basic
Public Shared MsgDm_SpecSave As Integer
Visual C++
public:
static int MsgDm_SpecSave

See Also

P4ClientError Class


MsgDm_StatusSuccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StatusSuccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StatusSuccess
Visual Basic
Public Shared MsgDm_StatusSuccess As Integer
Visual C++
public:
static int MsgDm_StatusSuccess

See Also

P4ClientError Class


MsgDm_StreamBadConvert Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamBadConvert Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamBadConvert
Visual Basic
Public Shared MsgDm_StreamBadConvert As Integer
Visual C++
public:
static int MsgDm_StreamBadConvert

See Also

P4ClientError Class


MsgDm_StreamConverted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamConverted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamConverted
Visual Basic
Public Shared MsgDm_StreamConverted As Integer
Visual C++
public:
static int MsgDm_StreamConverted

See Also

P4ClientError Class


MsgDm_StreamDepthErr Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamDepthErr Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamDepthErr
Visual Basic
Public Shared MsgDm_StreamDepthErr As Integer
Visual C++
public:
static int MsgDm_StreamDepthErr

See Also

P4ClientError Class


MsgDm_StreamDoubleSlash Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamDoubleSlash Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamDoubleSlash
Visual Basic
Public Shared MsgDm_StreamDoubleSlash As Integer
Visual C++
public:
static int MsgDm_StreamDoubleSlash

See Also

P4ClientError Class


MsgDm_StreamEndSlash Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamEndSlash Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamEndSlash
Visual Basic
Public Shared MsgDm_StreamEndSlash As Integer
Visual C++
public:
static int MsgDm_StreamEndSlash

See Also

P4ClientError Class


MsgDm_StreamEqDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamEqDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamEqDepot
Visual Basic
Public Shared MsgDm_StreamEqDepot As Integer
Visual C++
public:
static int MsgDm_StreamEqDepot

See Also

P4ClientError Class


MsgDm_StreamHasChildren Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamHasChildren Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamHasChildren
Visual Basic
Public Shared MsgDm_StreamHasChildren As Integer
Visual C++
public:
static int MsgDm_StreamHasChildren

See Also

P4ClientError Class


MsgDm_StreamHasClients Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamHasClients Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamHasClients
Visual Basic
Public Shared MsgDm_StreamHasClients As Integer
Visual C++
public:
static int MsgDm_StreamHasClients

See Also

P4ClientError Class


MsgDm_StreamIncompatibleC Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamIncompatibleC Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamIncompatibleC
Visual Basic
Public Shared MsgDm_StreamIncompatibleC As Integer
Visual C++
public:
static int MsgDm_StreamIncompatibleC

See Also

P4ClientError Class


MsgDm_StreamIncompatibleP Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamIncompatibleP Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamIncompatibleP
Visual Basic
Public Shared MsgDm_StreamIncompatibleP As Integer
Visual C++
public:
static int MsgDm_StreamIncompatibleP

See Also

P4ClientError Class


MsgDm_StreamIsMainline Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamIsMainline Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamIsMainline
Visual Basic
Public Shared MsgDm_StreamIsMainline As Integer
Visual C++
public:
static int MsgDm_StreamIsMainline

See Also

P4ClientError Class


MsgDm_StreamIsUnloaded Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamIsUnloaded Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamIsUnloaded
Visual Basic
Public Shared MsgDm_StreamIsUnloaded As Integer
Visual C++
public:
static int MsgDm_StreamIsUnloaded

See Also

P4ClientError Class


MsgDm_StreamIsVirtual Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamIsVirtual Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamIsVirtual
Visual Basic
Public Shared MsgDm_StreamIsVirtual As Integer
Visual C++
public:
static int MsgDm_StreamIsVirtual

See Also

P4ClientError Class


MsgDm_StreamNested Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamNested Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamNested
Visual Basic
Public Shared MsgDm_StreamNested As Integer
Visual C++
public:
static int MsgDm_StreamNested

See Also

P4ClientError Class


MsgDm_StreamNoConvert Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamNoConvert Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamNoConvert
Visual Basic
Public Shared MsgDm_StreamNoConvert As Integer
Visual C++
public:
static int MsgDm_StreamNoConvert

See Also

P4ClientError Class


MsgDm_StreamNoFlow Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamNoFlow Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamNoFlow
Visual Basic
Public Shared MsgDm_StreamNoFlow As Integer
Visual C++
public:
static int MsgDm_StreamNoFlow

See Also

P4ClientError Class


MsgDm_StreamNoReparent Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamNoReparent Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamNoReparent
Visual Basic
Public Shared MsgDm_StreamNoReparent As Integer
Visual C++
public:
static int MsgDm_StreamNoReparent

See Also

P4ClientError Class


MsgDm_StreamNotOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamNotOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamNotOwner
Visual Basic
Public Shared MsgDm_StreamNotOwner As Integer
Visual C++
public:
static int MsgDm_StreamNotOwner

See Also

P4ClientError Class


MsgDm_StreamOverflow Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamOverflow Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamOverflow
Visual Basic
Public Shared MsgDm_StreamOverflow As Integer
Visual C++
public:
static int MsgDm_StreamOverflow

See Also

P4ClientError Class


MsgDm_StreamOwnerReq Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamOwnerReq Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamOwnerReq
Visual Basic
Public Shared MsgDm_StreamOwnerReq As Integer
Visual C++
public:
static int MsgDm_StreamOwnerReq

See Also

P4ClientError Class


MsgDm_StreamOwnerUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamOwnerUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamOwnerUpdate
Visual Basic
Public Shared MsgDm_StreamOwnerUpdate As Integer
Visual C++
public:
static int MsgDm_StreamOwnerUpdate

See Also

P4ClientError Class


MsgDm_StreamParentIsTask Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamParentIsTask Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamParentIsTask
Visual Basic
Public Shared MsgDm_StreamParentIsTask As Integer
Visual C++
public:
static int MsgDm_StreamParentIsTask

See Also

P4ClientError Class


MsgDm_StreamPathRooted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamPathRooted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamPathRooted
Visual Basic
Public Shared MsgDm_StreamPathRooted As Integer
Visual C++
public:
static int MsgDm_StreamPathRooted

See Also

P4ClientError Class


MsgDm_StreamPathSlash Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamPathSlash Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamPathSlash
Visual Basic
Public Shared MsgDm_StreamPathSlash As Integer
Visual C++
public:
static int MsgDm_StreamPathSlash

See Also

P4ClientError Class


MsgDm_StreamRootErr Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamRootErr Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamRootErr
Visual Basic
Public Shared MsgDm_StreamRootErr As Integer
Visual C++
public:
static int MsgDm_StreamRootErr

See Also

P4ClientError Class


MsgDm_StreamsData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamsData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamsData
Visual Basic
Public Shared MsgDm_StreamsData As Integer
Visual C++
public:
static int MsgDm_StreamsData

See Also

P4ClientError Class


MsgDm_StreamTargetExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamTargetExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamTargetExists
Visual Basic
Public Shared MsgDm_StreamTargetExists As Integer
Visual C++
public:
static int MsgDm_StreamTargetExists

See Also

P4ClientError Class


MsgDm_StreamVsDomains Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_StreamVsDomains Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_StreamVsDomains
Visual Basic
Public Shared MsgDm_StreamVsDomains As Integer
Visual C++
public:
static int MsgDm_StreamVsDomains

See Also

P4ClientError Class


MsgDm_SubmitChanges Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitChanges Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitChanges
Visual Basic
Public Shared MsgDm_SubmitChanges As Integer
Visual C++
public:
static int MsgDm_SubmitChanges

See Also

P4ClientError Class


MsgDm_SubmitMovedToDefault Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitMovedToDefault Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitMovedToDefault
Visual Basic
Public Shared MsgDm_SubmitMovedToDefault As Integer
Visual C++
public:
static int MsgDm_SubmitMovedToDefault

See Also

P4ClientError Class


MsgDm_SubmitMustResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitMustResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitMustResolve
Visual Basic
Public Shared MsgDm_SubmitMustResolve As Integer
Visual C++
public:
static int MsgDm_SubmitMustResolve

See Also

P4ClientError Class


MsgDm_SubmitNewResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitNewResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitNewResolve
Visual Basic
Public Shared MsgDm_SubmitNewResolve As Integer
Visual C++
public:
static int MsgDm_SubmitNewResolve

See Also

P4ClientError Class


MsgDm_SubmitRefresh Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitRefresh Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitRefresh
Visual Basic
Public Shared MsgDm_SubmitRefresh As Integer
Visual C++
public:
static int MsgDm_SubmitRefresh

See Also

P4ClientError Class


MsgDm_SubmitResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitResolve
Visual Basic
Public Shared MsgDm_SubmitResolve As Integer
Visual C++
public:
static int MsgDm_SubmitResolve

See Also

P4ClientError Class


MsgDm_SubmitReverted Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitReverted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitReverted
Visual Basic
Public Shared MsgDm_SubmitReverted As Integer
Visual C++
public:
static int MsgDm_SubmitReverted

See Also

P4ClientError Class


MsgDm_SubmitTransfer Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitTransfer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitTransfer
Visual Basic
Public Shared MsgDm_SubmitTransfer As Integer
Visual C++
public:
static int MsgDm_SubmitTransfer

See Also

P4ClientError Class


MsgDm_SubmitUpToDate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitUpToDate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitUpToDate
Visual Basic
Public Shared MsgDm_SubmitUpToDate As Integer
Visual C++
public:
static int MsgDm_SubmitUpToDate

See Also

P4ClientError Class


MsgDm_SubmitWasAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitWasAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitWasAdd
Visual Basic
Public Shared MsgDm_SubmitWasAdd As Integer
Visual C++
public:
static int MsgDm_SubmitWasAdd

See Also

P4ClientError Class


MsgDm_SubmitWasDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitWasDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitWasDelete
Visual Basic
Public Shared MsgDm_SubmitWasDelete As Integer
Visual C++
public:
static int MsgDm_SubmitWasDelete

See Also

P4ClientError Class


MsgDm_SubmitWasDeleteCanReadd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SubmitWasDeleteCanReadd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SubmitWasDeleteCanReadd
Visual Basic
Public Shared MsgDm_SubmitWasDeleteCanReadd As Integer
Visual C++
public:
static int MsgDm_SubmitWasDeleteCanReadd

See Also

P4ClientError Class


MsgDm_SyncAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncAdd
Visual Basic
Public Shared MsgDm_SyncAdd As Integer
Visual C++
public:
static int MsgDm_SyncAdd

See Also

P4ClientError Class


MsgDm_SyncCantDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncCantDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncCantDelete
Visual Basic
Public Shared MsgDm_SyncCantDelete As Integer
Visual C++
public:
static int MsgDm_SyncCantDelete

See Also

P4ClientError Class


MsgDm_SyncCantPublishIsOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncCantPublishIsOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncCantPublishIsOpen
Visual Basic
Public Shared MsgDm_SyncCantPublishIsOpen As Integer
Visual C++
public:
static int MsgDm_SyncCantPublishIsOpen

See Also

P4ClientError Class


MsgDm_SyncCantPublishOnHave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncCantPublishOnHave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncCantPublishOnHave
Visual Basic
Public Shared MsgDm_SyncCantPublishOnHave As Integer
Visual C++
public:
static int MsgDm_SyncCantPublishOnHave

See Also

P4ClientError Class


MsgDm_SyncCantReplace Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncCantReplace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncCantReplace
Visual Basic
Public Shared MsgDm_SyncCantReplace As Integer
Visual C++
public:
static int MsgDm_SyncCantReplace

See Also

P4ClientError Class


MsgDm_SyncDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncDelete
Visual Basic
Public Shared MsgDm_SyncDelete As Integer
Visual C++
public:
static int MsgDm_SyncDelete

See Also

P4ClientError Class


MsgDm_SyncIndexOutOfBounds Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncIndexOutOfBounds Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncIndexOutOfBounds
Visual Basic
Public Shared MsgDm_SyncIndexOutOfBounds As Integer
Visual C++
public:
static int MsgDm_SyncIndexOutOfBounds

See Also

P4ClientError Class


MsgDm_SyncIntegBackwards Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncIntegBackwards Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncIntegBackwards
Visual Basic
Public Shared MsgDm_SyncIntegBackwards As Integer
Visual C++
public:
static int MsgDm_SyncIntegBackwards

See Also

P4ClientError Class


MsgDm_SyncIntegDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncIntegDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncIntegDelete
Visual Basic
Public Shared MsgDm_SyncIntegDelete As Integer
Visual C++
public:
static int MsgDm_SyncIntegDelete

See Also

P4ClientError Class


MsgDm_SyncIntegUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncIntegUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncIntegUpdate
Visual Basic
Public Shared MsgDm_SyncIntegUpdate As Integer
Visual C++
public:
static int MsgDm_SyncIntegUpdate

See Also

P4ClientError Class


MsgDm_SyncMissingMoveSource Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncMissingMoveSource Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncMissingMoveSource
Visual Basic
Public Shared MsgDm_SyncMissingMoveSource As Integer
Visual C++
public:
static int MsgDm_SyncMissingMoveSource

See Also

P4ClientError Class


MsgDm_SyncNotSafeAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncNotSafeAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncNotSafeAdd
Visual Basic
Public Shared MsgDm_SyncNotSafeAdd As Integer
Visual C++
public:
static int MsgDm_SyncNotSafeAdd

See Also

P4ClientError Class


MsgDm_SyncNotSafeDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncNotSafeDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncNotSafeDelete
Visual Basic
Public Shared MsgDm_SyncNotSafeDelete As Integer
Visual C++
public:
static int MsgDm_SyncNotSafeDelete

See Also

P4ClientError Class


MsgDm_SyncNotSafeReplace Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncNotSafeReplace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncNotSafeReplace
Visual Basic
Public Shared MsgDm_SyncNotSafeReplace As Integer
Visual C++
public:
static int MsgDm_SyncNotSafeReplace

See Also

P4ClientError Class


MsgDm_SyncNotSafeUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncNotSafeUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncNotSafeUpdate
Visual Basic
Public Shared MsgDm_SyncNotSafeUpdate As Integer
Visual C++
public:
static int MsgDm_SyncNotSafeUpdate

See Also

P4ClientError Class


MsgDm_SyncRefresh Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncRefresh Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncRefresh
Visual Basic
Public Shared MsgDm_SyncRefresh As Integer
Visual C++
public:
static int MsgDm_SyncRefresh

See Also

P4ClientError Class


MsgDm_SyncReplace Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncReplace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncReplace
Visual Basic
Public Shared MsgDm_SyncReplace As Integer
Visual C++
public:
static int MsgDm_SyncReplace

See Also

P4ClientError Class


MsgDm_SyncResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncResolve
Visual Basic
Public Shared MsgDm_SyncResolve As Integer
Visual C++
public:
static int MsgDm_SyncResolve

See Also

P4ClientError Class


MsgDm_SyncUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncUpdate
Visual Basic
Public Shared MsgDm_SyncUpdate As Integer
Visual C++
public:
static int MsgDm_SyncUpdate

See Also

P4ClientError Class


MsgDm_SyncUptodate Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_SyncUptodate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_SyncUptodate
Visual Basic
Public Shared MsgDm_SyncUptodate As Integer
Visual C++
public:
static int MsgDm_SyncUptodate

See Also

P4ClientError Class


MsgDm_TheseCantChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TheseCantChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TheseCantChange
Visual Basic
Public Shared MsgDm_TheseCantChange As Integer
Visual C++
public:
static int MsgDm_TheseCantChange

See Also

P4ClientError Class


MsgDm_TooManyClients Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TooManyClients Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TooManyClients
Visual Basic
Public Shared MsgDm_TooManyClients As Integer
Visual C++
public:
static int MsgDm_TooManyClients

See Also

P4ClientError Class


MsgDm_TooManyCommitServers Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TooManyCommitServers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TooManyCommitServers
Visual Basic
Public Shared MsgDm_TooManyCommitServers As Integer
Visual C++
public:
static int MsgDm_TooManyCommitServers

See Also

P4ClientError Class


MsgDm_TooManyRoots Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TooManyRoots Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TooManyRoots
Visual Basic
Public Shared MsgDm_TooManyRoots As Integer
Visual C++
public:
static int MsgDm_TooManyRoots

See Also

P4ClientError Class


MsgDm_TooManyUsers Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TooManyUsers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TooManyUsers
Visual Basic
Public Shared MsgDm_TooManyUsers As Integer
Visual C++
public:
static int MsgDm_TooManyUsers

See Also

P4ClientError Class


MsgDm_TooOld Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TooOld Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TooOld
Visual Basic
Public Shared MsgDm_TooOld As Integer
Visual C++
public:
static int MsgDm_TooOld

See Also

P4ClientError Class


MsgDm_TraitCleared Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TraitCleared Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TraitCleared
Visual Basic
Public Shared MsgDm_TraitCleared As Integer
Visual C++
public:
static int MsgDm_TraitCleared

See Also

P4ClientError Class


MsgDm_TraitIsOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TraitIsOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TraitIsOpen
Visual Basic
Public Shared MsgDm_TraitIsOpen As Integer
Visual C++
public:
static int MsgDm_TraitIsOpen

See Also

P4ClientError Class


MsgDm_TraitNotSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TraitNotSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TraitNotSet
Visual Basic
Public Shared MsgDm_TraitNotSet As Integer
Visual C++
public:
static int MsgDm_TraitNotSet

See Also

P4ClientError Class


MsgDm_TraitSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TraitSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TraitSet
Visual Basic
Public Shared MsgDm_TraitSet As Integer
Visual C++
public:
static int MsgDm_TraitSet

See Also

P4ClientError Class


MsgDm_TriggerNoArchiveType Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TriggerNoArchiveType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TriggerNoArchiveType
Visual Basic
Public Shared MsgDm_TriggerNoArchiveType As Integer
Visual C++
public:
static int MsgDm_TriggerNoArchiveType

See Also

P4ClientError Class


MsgDm_TriggerNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TriggerNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TriggerNoChange
Visual Basic
Public Shared MsgDm_TriggerNoChange As Integer
Visual C++
public:
static int MsgDm_TriggerNoChange

See Also

P4ClientError Class


MsgDm_TriggerNoDepotFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TriggerNoDepotFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TriggerNoDepotFile
Visual Basic
Public Shared MsgDm_TriggerNoDepotFile As Integer
Visual C++
public:
static int MsgDm_TriggerNoDepotFile

See Also

P4ClientError Class


MsgDm_TriggerSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TriggerSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TriggerSave
Visual Basic
Public Shared MsgDm_TriggerSave As Integer
Visual C++
public:
static int MsgDm_TriggerSave

See Also

P4ClientError Class


MsgDm_TryDelClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TryDelClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TryDelClient
Visual Basic
Public Shared MsgDm_TryDelClient As Integer
Visual C++
public:
static int MsgDm_TryDelClient

See Also

P4ClientError Class


MsgDm_TryDelUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TryDelUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TryDelUser
Visual Basic
Public Shared MsgDm_TryDelUser As Integer
Visual C++
public:
static int MsgDm_TryDelUser

See Also

P4ClientError Class


MsgDm_TryEvalLicense Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TryEvalLicense Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TryEvalLicense
Visual Basic
Public Shared MsgDm_TryEvalLicense As Integer
Visual C++
public:
static int MsgDm_TryEvalLicense

See Also

P4ClientError Class


MsgDm_TwistedMap Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TwistedMap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TwistedMap
Visual Basic
Public Shared MsgDm_TwistedMap As Integer
Visual C++
public:
static int MsgDm_TwistedMap

See Also

P4ClientError Class


MsgDm_TypeMapNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TypeMapNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TypeMapNoChange
Visual Basic
Public Shared MsgDm_TypeMapNoChange As Integer
Visual C++
public:
static int MsgDm_TypeMapNoChange

See Also

P4ClientError Class


MsgDm_TypeMapSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_TypeMapSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_TypeMapSave
Visual Basic
Public Shared MsgDm_TypeMapSave As Integer
Visual C++
public:
static int MsgDm_TypeMapSave

See Also

P4ClientError Class


MsgDm_Unicode Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_Unicode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_Unicode
Visual Basic
Public Shared MsgDm_Unicode As Integer
Visual C++
public:
static int MsgDm_Unicode

See Also

P4ClientError Class


MsgDm_UnidentifiedServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnidentifiedServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnidentifiedServer
Visual Basic
Public Shared MsgDm_UnidentifiedServer As Integer
Visual C++
public:
static int MsgDm_UnidentifiedServer

See Also

P4ClientError Class


MsgDm_UnknownReplicationMode Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnknownReplicationMode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnknownReplicationMode
Visual Basic
Public Shared MsgDm_UnknownReplicationMode As Integer
Visual C++
public:
static int MsgDm_UnknownReplicationMode

See Also

P4ClientError Class


MsgDm_UnknownReplicationTarget Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnknownReplicationTarget Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnknownReplicationTarget
Visual Basic
Public Shared MsgDm_UnknownReplicationTarget As Integer
Visual C++
public:
static int MsgDm_UnknownReplicationTarget

See Also

P4ClientError Class


MsgDm_UnloadData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnloadData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnloadData
Visual Basic
Public Shared MsgDm_UnloadData As Integer
Visual C++
public:
static int MsgDm_UnloadData

See Also

P4ClientError Class


MsgDm_UnloadDepotMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnloadDepotMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnloadDepotMissing
Visual Basic
Public Shared MsgDm_UnloadDepotMissing As Integer
Visual C++
public:
static int MsgDm_UnloadDepotMissing

See Also

P4ClientError Class


MsgDm_UnloadNotOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnloadNotOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnloadNotOwner
Visual Basic
Public Shared MsgDm_UnloadNotOwner As Integer
Visual C++
public:
static int MsgDm_UnloadNotOwner

See Also

P4ClientError Class


MsgDm_UnloadNotPossible Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnloadNotPossible Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnloadNotPossible
Visual Basic
Public Shared MsgDm_UnloadNotPossible As Integer
Visual C++
public:
static int MsgDm_UnloadNotPossible

See Also

P4ClientError Class


MsgDm_UnLockAlready Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnLockAlready Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnLockAlready
Visual Basic
Public Shared MsgDm_UnLockAlready As Integer
Visual C++
public:
static int MsgDm_UnLockAlready

See Also

P4ClientError Class


MsgDm_UnLockAlreadyOther Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnLockAlreadyOther Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnLockAlreadyOther
Visual Basic
Public Shared MsgDm_UnLockAlreadyOther As Integer
Visual C++
public:
static int MsgDm_UnLockAlreadyOther

See Also

P4ClientError Class


MsgDm_UnLockSuccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnLockSuccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnLockSuccess
Visual Basic
Public Shared MsgDm_UnLockSuccess As Integer
Visual C++
public:
static int MsgDm_UnLockSuccess

See Also

P4ClientError Class


MsgDm_UnshelveBadAction Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveBadAction Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveBadAction
Visual Basic
Public Shared MsgDm_UnshelveBadAction As Integer
Visual C++
public:
static int MsgDm_UnshelveBadAction

See Also

P4ClientError Class


MsgDm_UnshelveBadAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveBadAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveBadAdd
Visual Basic
Public Shared MsgDm_UnshelveBadAdd As Integer
Visual C++
public:
static int MsgDm_UnshelveBadAdd

See Also

P4ClientError Class


MsgDm_UnshelveBadClientView Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveBadClientView Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveBadClientView
Visual Basic
Public Shared MsgDm_UnshelveBadClientView As Integer
Visual C++
public:
static int MsgDm_UnshelveBadClientView

See Also

P4ClientError Class


MsgDm_UnshelveBadEdit Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveBadEdit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveBadEdit
Visual Basic
Public Shared MsgDm_UnshelveBadEdit As Integer
Visual C++
public:
static int MsgDm_UnshelveBadEdit

See Also

P4ClientError Class


MsgDm_UnshelveFromRemote Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveFromRemote Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveFromRemote
Visual Basic
Public Shared MsgDm_UnshelveFromRemote As Integer
Visual C++
public:
static int MsgDm_UnshelveFromRemote

See Also

P4ClientError Class


MsgDm_UnshelveIsLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveIsLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveIsLocked
Visual Basic
Public Shared MsgDm_UnshelveIsLocked As Integer
Visual C++
public:
static int MsgDm_UnshelveIsLocked

See Also

P4ClientError Class


MsgDm_UnshelveNotTask Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveNotTask Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveNotTask
Visual Basic
Public Shared MsgDm_UnshelveNotTask As Integer
Visual C++
public:
static int MsgDm_UnshelveNotTask

See Also

P4ClientError Class


MsgDm_UnshelveResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveResolve
Visual Basic
Public Shared MsgDm_UnshelveResolve As Integer
Visual C++
public:
static int MsgDm_UnshelveResolve

See Also

P4ClientError Class


MsgDm_UnshelveSuccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UnshelveSuccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UnshelveSuccess
Visual Basic
Public Shared MsgDm_UnshelveSuccess As Integer
Visual C++
public:
static int MsgDm_UnshelveSuccess

See Also

P4ClientError Class


MsgDm_UseConfigure Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UseConfigure Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UseConfigure
Visual Basic
Public Shared MsgDm_UseConfigure As Integer
Visual C++
public:
static int MsgDm_UseConfigure

See Also

P4ClientError Class


MsgDm_UserCantChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UserCantChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UserCantChange
Visual Basic
Public Shared MsgDm_UserCantChange As Integer
Visual C++
public:
static int MsgDm_UserCantChange

See Also

P4ClientError Class


MsgDm_UserCantDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UserCantDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UserCantDelete
Visual Basic
Public Shared MsgDm_UserCantDelete As Integer
Visual C++
public:
static int MsgDm_UserCantDelete

See Also

P4ClientError Class


MsgDm_UserDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UserDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UserDelete
Visual Basic
Public Shared MsgDm_UserDelete As Integer
Visual C++
public:
static int MsgDm_UserDelete

See Also

P4ClientError Class


MsgDm_UserNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UserNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UserNoChange
Visual Basic
Public Shared MsgDm_UserNoChange As Integer
Visual C++
public:
static int MsgDm_UserNoChange

See Also

P4ClientError Class


MsgDm_UserNotExist Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UserNotExist Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UserNotExist
Visual Basic
Public Shared MsgDm_UserNotExist As Integer
Visual C++
public:
static int MsgDm_UserNotExist

See Also

P4ClientError Class


MsgDm_UserOrGroup Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UserOrGroup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UserOrGroup
Visual Basic
Public Shared MsgDm_UserOrGroup As Integer
Visual C++
public:
static int MsgDm_UserOrGroup

See Also

P4ClientError Class


MsgDm_UserSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UserSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UserSave
Visual Basic
Public Shared MsgDm_UserSave As Integer
Visual C++
public:
static int MsgDm_UserSave

See Also

P4ClientError Class


MsgDm_UsersData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UsersData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UsersData
Visual Basic
Public Shared MsgDm_UsersData As Integer
Visual C++
public:
static int MsgDm_UsersData

See Also

P4ClientError Class


MsgDm_UsersDataLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_UsersDataLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_UsersDataLong
Visual Basic
Public Shared MsgDm_UsersDataLong As Integer
Visual C++
public:
static int MsgDm_UsersDataLong

See Also

P4ClientError Class


MsgDm_VerifyData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_VerifyData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_VerifyData
Visual Basic
Public Shared MsgDm_VerifyData As Integer
Visual C++
public:
static int MsgDm_VerifyData

See Also

P4ClientError Class


MsgDm_VerifyDataProblem Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_VerifyDataProblem Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_VerifyDataProblem
Visual Basic
Public Shared MsgDm_VerifyDataProblem As Integer
Visual C++
public:
static int MsgDm_VerifyDataProblem

See Also

P4ClientError Class


MsgDm_WhereData Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WhereData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WhereData
Visual Basic
Public Shared MsgDm_WhereData As Integer
Visual C++
public:
static int MsgDm_WhereData

See Also

P4ClientError Class


MsgDm_WildAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WildAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WildAdd
Visual Basic
Public Shared MsgDm_WildAdd As Integer
Visual C++
public:
static int MsgDm_WildAdd

See Also

P4ClientError Class


MsgDm_WildAddTripleDots Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WildAddTripleDots Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WildAddTripleDots
Visual Basic
Public Shared MsgDm_WildAddTripleDots As Integer
Visual C++
public:
static int MsgDm_WildAddTripleDots

See Also

P4ClientError Class


MsgDm_WorkingVsLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WorkingVsLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WorkingVsLocked
Visual Basic
Public Shared MsgDm_WorkingVsLocked As Integer
Visual C++
public:
static int MsgDm_WorkingVsLocked

See Also

P4ClientError Class


MsgDm_WrongClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WrongClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WrongClient
Visual Basic
Public Shared MsgDm_WrongClient As Integer
Visual C++
public:
static int MsgDm_WrongClient

See Also

P4ClientError Class


MsgDm_WrongDomain Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WrongDomain Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WrongDomain
Visual Basic
Public Shared MsgDm_WrongDomain As Integer
Visual C++
public:
static int MsgDm_WrongDomain

See Also

P4ClientError Class


MsgDm_WrongUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WrongUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WrongUser
Visual Basic
Public Shared MsgDm_WrongUser As Integer
Visual C++
public:
static int MsgDm_WrongUser

See Also

P4ClientError Class


MsgDm_WrongUserDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgDm_WrongUserDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgDm_WrongUserDelete
Visual Basic
Public Shared MsgDm_WrongUserDelete As Integer
Visual C++
public:
static int MsgDm_WrongUserDelete

See Also

P4ClientError Class


MsgHelp_HelpAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpAdd
Visual Basic
Public Shared MsgHelp_HelpAdd As Integer
Visual C++
public:
static int MsgHelp_HelpAdd

See Also

P4ClientError Class


MsgHelp_HelpAdmin Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpAdmin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpAdmin
Visual Basic
Public Shared MsgHelp_HelpAdmin As Integer
Visual C++
public:
static int MsgHelp_HelpAdmin

See Also

P4ClientError Class


MsgHelp_HelpAdministration Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpAdministration Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpAdministration
Visual Basic
Public Shared MsgHelp_HelpAdministration As Integer
Visual C++
public:
static int MsgHelp_HelpAdministration

See Also

P4ClientError Class


MsgHelp_HelpAnnotate Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpAnnotate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpAnnotate
Visual Basic
Public Shared MsgHelp_HelpAnnotate As Integer
Visual C++
public:
static int MsgHelp_HelpAnnotate

See Also

P4ClientError Class


MsgHelp_HelpArchive Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpArchive Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpArchive
Visual Basic
Public Shared MsgHelp_HelpArchive As Integer
Visual C++
public:
static int MsgHelp_HelpArchive

See Also

P4ClientError Class


MsgHelp_HelpAttribute Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpAttribute Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpAttribute
Visual Basic
Public Shared MsgHelp_HelpAttribute As Integer
Visual C++
public:
static int MsgHelp_HelpAttribute

See Also

P4ClientError Class


MsgHelp_HelpBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpBranch
Visual Basic
Public Shared MsgHelp_HelpBranch As Integer
Visual C++
public:
static int MsgHelp_HelpBranch

See Also

P4ClientError Class


MsgHelp_HelpBranches Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpBranches Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpBranches
Visual Basic
Public Shared MsgHelp_HelpBranches As Integer
Visual C++
public:
static int MsgHelp_HelpBranches

See Also

P4ClientError Class


MsgHelp_HelpBroker Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpBroker Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpBroker
Visual Basic
Public Shared MsgHelp_HelpBroker As Integer
Visual C++
public:
static int MsgHelp_HelpBroker

See Also

P4ClientError Class


MsgHelp_HelpBrowse Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpBrowse Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpBrowse
Visual Basic
Public Shared MsgHelp_HelpBrowse As Integer
Visual C++
public:
static int MsgHelp_HelpBrowse

See Also

P4ClientError Class


MsgHelp_HelpBuildserver Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpBuildserver Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpBuildserver
Visual Basic
Public Shared MsgHelp_HelpBuildserver As Integer
Visual C++
public:
static int MsgHelp_HelpBuildserver

See Also

P4ClientError Class


MsgHelp_HelpCachepurge Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCachepurge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCachepurge
Visual Basic
Public Shared MsgHelp_HelpCachepurge As Integer
Visual C++
public:
static int MsgHelp_HelpCachepurge

See Also

P4ClientError Class


MsgHelp_HelpChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpChange
Visual Basic
Public Shared MsgHelp_HelpChange As Integer
Visual C++
public:
static int MsgHelp_HelpChange

See Also

P4ClientError Class


MsgHelp_HelpChanges Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpChanges Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpChanges
Visual Basic
Public Shared MsgHelp_HelpChanges As Integer
Visual C++
public:
static int MsgHelp_HelpChanges

See Also

P4ClientError Class


MsgHelp_HelpCharset Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCharset Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCharset
Visual Basic
Public Shared MsgHelp_HelpCharset As Integer
Visual C++
public:
static int MsgHelp_HelpCharset

See Also

P4ClientError Class


MsgHelp_HelpClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpClient
Visual Basic
Public Shared MsgHelp_HelpClient As Integer
Visual C++
public:
static int MsgHelp_HelpClient

See Also

P4ClientError Class


MsgHelp_HelpClients Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpClients Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpClients
Visual Basic
Public Shared MsgHelp_HelpClients As Integer
Visual C++
public:
static int MsgHelp_HelpClients

See Also

P4ClientError Class


MsgHelp_HelpCluster Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCluster Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCluster
Visual Basic
Public Shared MsgHelp_HelpCluster As Integer
Visual C++
public:
static int MsgHelp_HelpCluster

See Also

P4ClientError Class


MsgHelp_HelpCommandments Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCommandments Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCommandments
Visual Basic
Public Shared MsgHelp_HelpCommandments As Integer
Visual C++
public:
static int MsgHelp_HelpCommandments

See Also

P4ClientError Class


MsgHelp_HelpCommands Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCommands Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCommands
Visual Basic
Public Shared MsgHelp_HelpCommands As Integer
Visual C++
public:
static int MsgHelp_HelpCommands

See Also

P4ClientError Class


MsgHelp_HelpConfigurables Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpConfigurables Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpConfigurables
Visual Basic
Public Shared MsgHelp_HelpConfigurables As Integer
Visual C++
public:
static int MsgHelp_HelpConfigurables

See Also

P4ClientError Class


MsgHelp_HelpConfigure Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpConfigure Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpConfigure
Visual Basic
Public Shared MsgHelp_HelpConfigure As Integer
Visual C++
public:
static int MsgHelp_HelpConfigure

See Also

P4ClientError Class


MsgHelp_HelpCopy Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCopy Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCopy
Visual Basic
Public Shared MsgHelp_HelpCopy As Integer
Visual C++
public:
static int MsgHelp_HelpCopy

See Also

P4ClientError Class


MsgHelp_HelpCounter Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCounter Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCounter
Visual Basic
Public Shared MsgHelp_HelpCounter As Integer
Visual C++
public:
static int MsgHelp_HelpCounter

See Also

P4ClientError Class


MsgHelp_HelpCounters Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCounters Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCounters
Visual Basic
Public Shared MsgHelp_HelpCounters As Integer
Visual C++
public:
static int MsgHelp_HelpCounters

See Also

P4ClientError Class


MsgHelp_HelpCredits Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCredits Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCredits
Visual Basic
Public Shared MsgHelp_HelpCredits As Integer
Visual C++
public:
static int MsgHelp_HelpCredits

See Also

P4ClientError Class


MsgHelp_HelpCstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpCstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpCstat
Visual Basic
Public Shared MsgHelp_HelpCstat As Integer
Visual C++
public:
static int MsgHelp_HelpCstat

See Also

P4ClientError Class


MsgHelp_HelpDbpack Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDbpack Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDbpack
Visual Basic
Public Shared MsgHelp_HelpDbpack As Integer
Visual C++
public:
static int MsgHelp_HelpDbpack

See Also

P4ClientError Class


MsgHelp_HelpDbschema Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDbschema Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDbschema
Visual Basic
Public Shared MsgHelp_HelpDbschema As Integer
Visual C++
public:
static int MsgHelp_HelpDbschema

See Also

P4ClientError Class


MsgHelp_HelpDbstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDbstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDbstat
Visual Basic
Public Shared MsgHelp_HelpDbstat As Integer
Visual C++
public:
static int MsgHelp_HelpDbstat

See Also

P4ClientError Class


MsgHelp_HelpDbverify Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDbverify Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDbverify
Visual Basic
Public Shared MsgHelp_HelpDbverify As Integer
Visual C++
public:
static int MsgHelp_HelpDbverify

See Also

P4ClientError Class


MsgHelp_HelpDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDelete
Visual Basic
Public Shared MsgHelp_HelpDelete As Integer
Visual C++
public:
static int MsgHelp_HelpDelete

See Also

P4ClientError Class


MsgHelp_HelpDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDepot
Visual Basic
Public Shared MsgHelp_HelpDepot As Integer
Visual C++
public:
static int MsgHelp_HelpDepot

See Also

P4ClientError Class


MsgHelp_HelpDepots Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDepots Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDepots
Visual Basic
Public Shared MsgHelp_HelpDepots As Integer
Visual C++
public:
static int MsgHelp_HelpDepots

See Also

P4ClientError Class


MsgHelp_HelpDescribe Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDescribe Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDescribe
Visual Basic
Public Shared MsgHelp_HelpDescribe As Integer
Visual C++
public:
static int MsgHelp_HelpDescribe

See Also

P4ClientError Class


MsgHelp_HelpDiff Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDiff Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDiff
Visual Basic
Public Shared MsgHelp_HelpDiff As Integer
Visual C++
public:
static int MsgHelp_HelpDiff

See Also

P4ClientError Class


MsgHelp_HelpDiff2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDiff2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDiff2
Visual Basic
Public Shared MsgHelp_HelpDiff2 As Integer
Visual C++
public:
static int MsgHelp_HelpDiff2

See Also

P4ClientError Class


MsgHelp_HelpDirs Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDirs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDirs
Visual Basic
Public Shared MsgHelp_HelpDirs As Integer
Visual C++
public:
static int MsgHelp_HelpDirs

See Also

P4ClientError Class


MsgHelp_HelpDiskspace Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDiskspace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDiskspace
Visual Basic
Public Shared MsgHelp_HelpDiskspace As Integer
Visual C++
public:
static int MsgHelp_HelpDiskspace

See Also

P4ClientError Class


MsgHelp_HelpDistributed Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDistributed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDistributed
Visual Basic
Public Shared MsgHelp_HelpDistributed As Integer
Visual C++
public:
static int MsgHelp_HelpDistributed

See Also

P4ClientError Class


MsgHelp_HelpDuplicate Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpDuplicate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpDuplicate
Visual Basic
Public Shared MsgHelp_HelpDuplicate As Integer
Visual C++
public:
static int MsgHelp_HelpDuplicate

See Also

P4ClientError Class


MsgHelp_HelpEdit Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpEdit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpEdit
Visual Basic
Public Shared MsgHelp_HelpEdit As Integer
Visual C++
public:
static int MsgHelp_HelpEdit

See Also

P4ClientError Class


MsgHelp_HelpEnvironment Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpEnvironment Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpEnvironment
Visual Basic
Public Shared MsgHelp_HelpEnvironment As Integer
Visual C++
public:
static int MsgHelp_HelpEnvironment

See Also

P4ClientError Class


MsgHelp_HelpExport Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpExport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpExport
Visual Basic
Public Shared MsgHelp_HelpExport As Integer
Visual C++
public:
static int MsgHelp_HelpExport

See Also

P4ClientError Class


MsgHelp_HelpFilelog Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpFilelog Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpFilelog
Visual Basic
Public Shared MsgHelp_HelpFilelog As Integer
Visual C++
public:
static int MsgHelp_HelpFilelog

See Also

P4ClientError Class


MsgHelp_HelpFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpFiles
Visual Basic
Public Shared MsgHelp_HelpFiles As Integer
Visual C++
public:
static int MsgHelp_HelpFiles

See Also

P4ClientError Class


MsgHelp_HelpFiletypes Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpFiletypes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpFiletypes
Visual Basic
Public Shared MsgHelp_HelpFiletypes As Integer
Visual C++
public:
static int MsgHelp_HelpFiletypes

See Also

P4ClientError Class


MsgHelp_HelpFix Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpFix Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpFix
Visual Basic
Public Shared MsgHelp_HelpFix As Integer
Visual C++
public:
static int MsgHelp_HelpFix

See Also

P4ClientError Class


MsgHelp_HelpFixes Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpFixes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpFixes
Visual Basic
Public Shared MsgHelp_HelpFixes As Integer
Visual C++
public:
static int MsgHelp_HelpFixes

See Also

P4ClientError Class


MsgHelp_HelpForwardingreplica Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpForwardingreplica Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpForwardingreplica
Visual Basic
Public Shared MsgHelp_HelpForwardingreplica As Integer
Visual C++
public:
static int MsgHelp_HelpForwardingreplica

See Also

P4ClientError Class


MsgHelp_HelpFstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpFstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpFstat
Visual Basic
Public Shared MsgHelp_HelpFstat As Integer
Visual C++
public:
static int MsgHelp_HelpFstat

See Also

P4ClientError Class


MsgHelp_HelpGrep Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpGrep Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpGrep
Visual Basic
Public Shared MsgHelp_HelpGrep As Integer
Visual C++
public:
static int MsgHelp_HelpGrep

See Also

P4ClientError Class


MsgHelp_HelpGroup Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpGroup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpGroup
Visual Basic
Public Shared MsgHelp_HelpGroup As Integer
Visual C++
public:
static int MsgHelp_HelpGroup

See Also

P4ClientError Class


MsgHelp_HelpGroups Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpGroups Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpGroups
Visual Basic
Public Shared MsgHelp_HelpGroups As Integer
Visual C++
public:
static int MsgHelp_HelpGroups

See Also

P4ClientError Class


MsgHelp_HelpHave Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpHave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpHave
Visual Basic
Public Shared MsgHelp_HelpHave As Integer
Visual C++
public:
static int MsgHelp_HelpHave

See Also

P4ClientError Class


MsgHelp_HelpHelp Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpHelp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpHelp
Visual Basic
Public Shared MsgHelp_HelpHelp As Integer
Visual C++
public:
static int MsgHelp_HelpHelp

See Also

P4ClientError Class


MsgHelp_HelpIndex Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpIndex Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpIndex
Visual Basic
Public Shared MsgHelp_HelpIndex As Integer
Visual C++
public:
static int MsgHelp_HelpIndex

See Also

P4ClientError Class


MsgHelp_HelpInfo Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpInfo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpInfo
Visual Basic
Public Shared MsgHelp_HelpInfo As Integer
Visual C++
public:
static int MsgHelp_HelpInfo

See Also

P4ClientError Class


MsgHelp_HelpInteg Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpInteg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpInteg
Visual Basic
Public Shared MsgHelp_HelpInteg As Integer
Visual C++
public:
static int MsgHelp_HelpInteg

See Also

P4ClientError Class


MsgHelp_HelpInteg3 Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpInteg3 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpInteg3
Visual Basic
Public Shared MsgHelp_HelpInteg3 As Integer
Visual C++
public:
static int MsgHelp_HelpInteg3

See Also

P4ClientError Class


MsgHelp_HelpInteged Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpInteged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpInteged
Visual Basic
Public Shared MsgHelp_HelpInteged As Integer
Visual C++
public:
static int MsgHelp_HelpInteged

See Also

P4ClientError Class


MsgHelp_HelpInterchanges Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpInterchanges Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpInterchanges
Visual Basic
Public Shared MsgHelp_HelpInterchanges As Integer
Visual C++
public:
static int MsgHelp_HelpInterchanges

See Also

P4ClientError Class


MsgHelp_HelpIstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpIstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpIstat
Visual Basic
Public Shared MsgHelp_HelpIstat As Integer
Visual C++
public:
static int MsgHelp_HelpIstat

See Also

P4ClientError Class


MsgHelp_HelpJob Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpJob Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpJob
Visual Basic
Public Shared MsgHelp_HelpJob As Integer
Visual C++
public:
static int MsgHelp_HelpJob

See Also

P4ClientError Class


MsgHelp_HelpJobs Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpJobs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpJobs
Visual Basic
Public Shared MsgHelp_HelpJobs As Integer
Visual C++
public:
static int MsgHelp_HelpJobs

See Also

P4ClientError Class


MsgHelp_HelpJobSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpJobSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpJobSpec
Visual Basic
Public Shared MsgHelp_HelpJobSpec As Integer
Visual C++
public:
static int MsgHelp_HelpJobSpec

See Also

P4ClientError Class


MsgHelp_HelpJobView Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpJobView Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpJobView
Visual Basic
Public Shared MsgHelp_HelpJobView As Integer
Visual C++
public:
static int MsgHelp_HelpJobView

See Also

P4ClientError Class


MsgHelp_HelpJournaldbchecksums Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpJournaldbchecksums Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpJournaldbchecksums
Visual Basic
Public Shared MsgHelp_HelpJournaldbchecksums As Integer
Visual C++
public:
static int MsgHelp_HelpJournaldbchecksums

See Also

P4ClientError Class


MsgHelp_HelpJournals Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpJournals Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpJournals
Visual Basic
Public Shared MsgHelp_HelpJournals As Integer
Visual C++
public:
static int MsgHelp_HelpJournals

See Also

P4ClientError Class


MsgHelp_HelpKey Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpKey Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpKey
Visual Basic
Public Shared MsgHelp_HelpKey As Integer
Visual C++
public:
static int MsgHelp_HelpKey

See Also

P4ClientError Class


MsgHelp_HelpKeys Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpKeys Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpKeys
Visual Basic
Public Shared MsgHelp_HelpKeys As Integer
Visual C++
public:
static int MsgHelp_HelpKeys

See Also

P4ClientError Class


MsgHelp_HelpLabel Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLabel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLabel
Visual Basic
Public Shared MsgHelp_HelpLabel As Integer
Visual C++
public:
static int MsgHelp_HelpLabel

See Also

P4ClientError Class


MsgHelp_HelpLabels Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLabels Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLabels
Visual Basic
Public Shared MsgHelp_HelpLabels As Integer
Visual C++
public:
static int MsgHelp_HelpLabels

See Also

P4ClientError Class


MsgHelp_HelpLabelsync Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLabelsync Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLabelsync
Visual Basic
Public Shared MsgHelp_HelpLabelsync As Integer
Visual C++
public:
static int MsgHelp_HelpLabelsync

See Also

P4ClientError Class


MsgHelp_HelpLegal Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLegal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLegal
Visual Basic
Public Shared MsgHelp_HelpLegal As Integer
Visual C++
public:
static int MsgHelp_HelpLegal

See Also

P4ClientError Class


MsgHelp_HelpLicense Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLicense Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLicense
Visual Basic
Public Shared MsgHelp_HelpLicense As Integer
Visual C++
public:
static int MsgHelp_HelpLicense

See Also

P4ClientError Class


MsgHelp_HelpList Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpList Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpList
Visual Basic
Public Shared MsgHelp_HelpList As Integer
Visual C++
public:
static int MsgHelp_HelpList

See Also

P4ClientError Class


MsgHelp_HelpLock Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLock
Visual Basic
Public Shared MsgHelp_HelpLock As Integer
Visual C++
public:
static int MsgHelp_HelpLock

See Also

P4ClientError Class


MsgHelp_HelpLockstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLockstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLockstat
Visual Basic
Public Shared MsgHelp_HelpLockstat As Integer
Visual C++
public:
static int MsgHelp_HelpLockstat

See Also

P4ClientError Class


MsgHelp_HelpLogappend Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogappend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogappend
Visual Basic
Public Shared MsgHelp_HelpLogappend As Integer
Visual C++
public:
static int MsgHelp_HelpLogappend

See Also

P4ClientError Class


MsgHelp_HelpLogger Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogger Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogger
Visual Basic
Public Shared MsgHelp_HelpLogger As Integer
Visual C++
public:
static int MsgHelp_HelpLogger

See Also

P4ClientError Class


MsgHelp_HelpLogin Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogin
Visual Basic
Public Shared MsgHelp_HelpLogin As Integer
Visual C++
public:
static int MsgHelp_HelpLogin

See Also

P4ClientError Class


MsgHelp_HelpLogout Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogout Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogout
Visual Basic
Public Shared MsgHelp_HelpLogout As Integer
Visual C++
public:
static int MsgHelp_HelpLogout

See Also

P4ClientError Class


MsgHelp_HelpLogparse Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogparse Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogparse
Visual Basic
Public Shared MsgHelp_HelpLogparse As Integer
Visual C++
public:
static int MsgHelp_HelpLogparse

See Also

P4ClientError Class


MsgHelp_HelpLogrotate Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogrotate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogrotate
Visual Basic
Public Shared MsgHelp_HelpLogrotate As Integer
Visual C++
public:
static int MsgHelp_HelpLogrotate

See Also

P4ClientError Class


MsgHelp_HelpLogschema Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogschema Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogschema
Visual Basic
Public Shared MsgHelp_HelpLogschema As Integer
Visual C++
public:
static int MsgHelp_HelpLogschema

See Also

P4ClientError Class


MsgHelp_HelpLogstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogstat
Visual Basic
Public Shared MsgHelp_HelpLogstat As Integer
Visual C++
public:
static int MsgHelp_HelpLogstat

See Also

P4ClientError Class


MsgHelp_HelpLogtail Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpLogtail Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpLogtail
Visual Basic
Public Shared MsgHelp_HelpLogtail As Integer
Visual C++
public:
static int MsgHelp_HelpLogtail

See Also

P4ClientError Class


MsgHelp_HelpMaxResults Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpMaxResults Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpMaxResults
Visual Basic
Public Shared MsgHelp_HelpMaxResults As Integer
Visual C++
public:
static int MsgHelp_HelpMaxResults

See Also

P4ClientError Class


MsgHelp_HelpMerge Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpMerge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpMerge
Visual Basic
Public Shared MsgHelp_HelpMerge As Integer
Visual C++
public:
static int MsgHelp_HelpMerge

See Also

P4ClientError Class


MsgHelp_HelpMerge3 Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpMerge3 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpMerge3
Visual Basic
Public Shared MsgHelp_HelpMerge3 As Integer
Visual C++
public:
static int MsgHelp_HelpMerge3

See Also

P4ClientError Class


MsgHelp_HelpMonitor Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpMonitor Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpMonitor
Visual Basic
Public Shared MsgHelp_HelpMonitor As Integer
Visual C++
public:
static int MsgHelp_HelpMonitor

See Also

P4ClientError Class


MsgHelp_HelpMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpMove
Visual Basic
Public Shared MsgHelp_HelpMove As Integer
Visual C++
public:
static int MsgHelp_HelpMove

See Also

P4ClientError Class


MsgHelp_HelpNetworkAddress Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpNetworkAddress Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpNetworkAddress
Visual Basic
Public Shared MsgHelp_HelpNetworkAddress As Integer
Visual C++
public:
static int MsgHelp_HelpNetworkAddress

See Also

P4ClientError Class


MsgHelp_HelpObliterate Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpObliterate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpObliterate
Visual Basic
Public Shared MsgHelp_HelpObliterate As Integer
Visual C++
public:
static int MsgHelp_HelpObliterate

See Also

P4ClientError Class


MsgHelp_HelpOpened Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpOpened Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpOpened
Visual Basic
Public Shared MsgHelp_HelpOpened As Integer
Visual C++
public:
static int MsgHelp_HelpOpened

See Also

P4ClientError Class


MsgHelp_HelpPasswd Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpPasswd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpPasswd
Visual Basic
Public Shared MsgHelp_HelpPasswd As Integer
Visual C++
public:
static int MsgHelp_HelpPasswd

See Also

P4ClientError Class


MsgHelp_HelpPerforce Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpPerforce Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpPerforce
Visual Basic
Public Shared MsgHelp_HelpPerforce As Integer
Visual C++
public:
static int MsgHelp_HelpPerforce

See Also

P4ClientError Class


MsgHelp_HelpPing Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpPing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpPing
Visual Basic
Public Shared MsgHelp_HelpPing As Integer
Visual C++
public:
static int MsgHelp_HelpPing

See Also

P4ClientError Class


MsgHelp_HelpPopulate Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpPopulate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpPopulate
Visual Basic
Public Shared MsgHelp_HelpPopulate As Integer
Visual C++
public:
static int MsgHelp_HelpPopulate

See Also

P4ClientError Class


MsgHelp_HelpPrint Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpPrint Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpPrint
Visual Basic
Public Shared MsgHelp_HelpPrint As Integer
Visual C++
public:
static int MsgHelp_HelpPrint

See Also

P4ClientError Class


MsgHelp_HelpProperty Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpProperty Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpProperty
Visual Basic
Public Shared MsgHelp_HelpProperty As Integer
Visual C++
public:
static int MsgHelp_HelpProperty

See Also

P4ClientError Class


MsgHelp_HelpProtect Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpProtect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpProtect
Visual Basic
Public Shared MsgHelp_HelpProtect As Integer
Visual C++
public:
static int MsgHelp_HelpProtect

See Also

P4ClientError Class


MsgHelp_HelpProtects Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpProtects Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpProtects
Visual Basic
Public Shared MsgHelp_HelpProtects As Integer
Visual C++
public:
static int MsgHelp_HelpProtects

See Also

P4ClientError Class


MsgHelp_HelpProxy Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpProxy Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpProxy
Visual Basic
Public Shared MsgHelp_HelpProxy As Integer
Visual C++
public:
static int MsgHelp_HelpProxy

See Also

P4ClientError Class


MsgHelp_HelpPull Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpPull Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpPull
Visual Basic
Public Shared MsgHelp_HelpPull As Integer
Visual C++
public:
static int MsgHelp_HelpPull

See Also

P4ClientError Class


MsgHelp_HelpReconcile Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpReconcile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpReconcile
Visual Basic
Public Shared MsgHelp_HelpReconcile As Integer
Visual C++
public:
static int MsgHelp_HelpReconcile

See Also

P4ClientError Class


MsgHelp_HelpReload Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpReload Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpReload
Visual Basic
Public Shared MsgHelp_HelpReload As Integer
Visual C++
public:
static int MsgHelp_HelpReload

See Also

P4ClientError Class


MsgHelp_HelpRename Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpRename Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpRename
Visual Basic
Public Shared MsgHelp_HelpRename As Integer
Visual C++
public:
static int MsgHelp_HelpRename

See Also

P4ClientError Class


MsgHelp_HelpRenameUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpRenameUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpRenameUser
Visual Basic
Public Shared MsgHelp_HelpRenameUser As Integer
Visual C++
public:
static int MsgHelp_HelpRenameUser

See Also

P4ClientError Class


MsgHelp_HelpReopen Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpReopen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpReopen
Visual Basic
Public Shared MsgHelp_HelpReopen As Integer
Visual C++
public:
static int MsgHelp_HelpReopen

See Also

P4ClientError Class


MsgHelp_HelpReplicate Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpReplicate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpReplicate
Visual Basic
Public Shared MsgHelp_HelpReplicate As Integer
Visual C++
public:
static int MsgHelp_HelpReplicate

See Also

P4ClientError Class


MsgHelp_HelpReplication Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpReplication Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpReplication
Visual Basic
Public Shared MsgHelp_HelpReplication As Integer
Visual C++
public:
static int MsgHelp_HelpReplication

See Also

P4ClientError Class


MsgHelp_HelpResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpResolve
Visual Basic
Public Shared MsgHelp_HelpResolve As Integer
Visual C++
public:
static int MsgHelp_HelpResolve

See Also

P4ClientError Class


MsgHelp_HelpResolved Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpResolved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpResolved
Visual Basic
Public Shared MsgHelp_HelpResolved As Integer
Visual C++
public:
static int MsgHelp_HelpResolved

See Also

P4ClientError Class


MsgHelp_HelpRestore Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpRestore Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpRestore
Visual Basic
Public Shared MsgHelp_HelpRestore As Integer
Visual C++
public:
static int MsgHelp_HelpRestore

See Also

P4ClientError Class


MsgHelp_HelpRetype Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpRetype Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpRetype
Visual Basic
Public Shared MsgHelp_HelpRetype As Integer
Visual C++
public:
static int MsgHelp_HelpRetype

See Also

P4ClientError Class


MsgHelp_HelpRevert Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpRevert Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpRevert
Visual Basic
Public Shared MsgHelp_HelpRevert As Integer
Visual C++
public:
static int MsgHelp_HelpRevert

See Also

P4ClientError Class


MsgHelp_HelpReview Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpReview Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpReview
Visual Basic
Public Shared MsgHelp_HelpReview As Integer
Visual C++
public:
static int MsgHelp_HelpReview

See Also

P4ClientError Class


MsgHelp_HelpReviews Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpReviews Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpReviews
Visual Basic
Public Shared MsgHelp_HelpReviews As Integer
Visual C++
public:
static int MsgHelp_HelpReviews

See Also

P4ClientError Class


MsgHelp_HelpRevisions Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpRevisions Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpRevisions
Visual Basic
Public Shared MsgHelp_HelpRevisions As Integer
Visual C++
public:
static int MsgHelp_HelpRevisions

See Also

P4ClientError Class


MsgHelp_HelpSearch Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSearch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSearch
Visual Basic
Public Shared MsgHelp_HelpSearch As Integer
Visual C++
public:
static int MsgHelp_HelpSearch

See Also

P4ClientError Class


MsgHelp_HelpServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpServer
Visual Basic
Public Shared MsgHelp_HelpServer As Integer
Visual C++
public:
static int MsgHelp_HelpServer

See Also

P4ClientError Class


MsgHelp_HelpServerid Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpServerid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpServerid
Visual Basic
Public Shared MsgHelp_HelpServerid As Integer
Visual C++
public:
static int MsgHelp_HelpServerid

See Also

P4ClientError Class


MsgHelp_HelpServers Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpServers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpServers
Visual Basic
Public Shared MsgHelp_HelpServers As Integer
Visual C++
public:
static int MsgHelp_HelpServers

See Also

P4ClientError Class


MsgHelp_HelpSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSet
Visual Basic
Public Shared MsgHelp_HelpSet As Integer
Visual C++
public:
static int MsgHelp_HelpSet

See Also

P4ClientError Class


MsgHelp_HelpShelve Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpShelve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpShelve
Visual Basic
Public Shared MsgHelp_HelpShelve As Integer
Visual C++
public:
static int MsgHelp_HelpShelve

See Also

P4ClientError Class


MsgHelp_HelpSimple Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSimple Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSimple
Visual Basic
Public Shared MsgHelp_HelpSimple As Integer
Visual C++
public:
static int MsgHelp_HelpSimple

See Also

P4ClientError Class


MsgHelp_HelpSizes Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSizes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSizes
Visual Basic
Public Shared MsgHelp_HelpSizes As Integer
Visual C++
public:
static int MsgHelp_HelpSizes

See Also

P4ClientError Class


MsgHelp_HelpSnap Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSnap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSnap
Visual Basic
Public Shared MsgHelp_HelpSnap As Integer
Visual C++
public:
static int MsgHelp_HelpSnap

See Also

P4ClientError Class


MsgHelp_HelpSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSpec
Visual Basic
Public Shared MsgHelp_HelpSpec As Integer
Visual C++
public:
static int MsgHelp_HelpSpec

See Also

P4ClientError Class


MsgHelp_HelpStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpStream
Visual Basic
Public Shared MsgHelp_HelpStream As Integer
Visual C++
public:
static int MsgHelp_HelpStream

See Also

P4ClientError Class


MsgHelp_HelpStreamintro Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpStreamintro Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpStreamintro
Visual Basic
Public Shared MsgHelp_HelpStreamintro As Integer
Visual C++
public:
static int MsgHelp_HelpStreamintro

See Also

P4ClientError Class


MsgHelp_HelpStreams Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpStreams Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpStreams
Visual Basic
Public Shared MsgHelp_HelpStreams As Integer
Visual C++
public:
static int MsgHelp_HelpStreams

See Also

P4ClientError Class


MsgHelp_HelpSubmit Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSubmit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSubmit
Visual Basic
Public Shared MsgHelp_HelpSubmit As Integer
Visual C++
public:
static int MsgHelp_HelpSubmit

See Also

P4ClientError Class


MsgHelp_HelpSync Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpSync Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpSync
Visual Basic
Public Shared MsgHelp_HelpSync As Integer
Visual C++
public:
static int MsgHelp_HelpSync

See Also

P4ClientError Class


MsgHelp_HelpTag Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpTag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpTag
Visual Basic
Public Shared MsgHelp_HelpTag As Integer
Visual C++
public:
static int MsgHelp_HelpTag

See Also

P4ClientError Class


MsgHelp_HelpTickets Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpTickets Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpTickets
Visual Basic
Public Shared MsgHelp_HelpTickets As Integer
Visual C++
public:
static int MsgHelp_HelpTickets

See Also

P4ClientError Class


MsgHelp_HelpTrigger Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpTrigger Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpTrigger
Visual Basic
Public Shared MsgHelp_HelpTrigger As Integer
Visual C++
public:
static int MsgHelp_HelpTrigger

See Also

P4ClientError Class


MsgHelp_HelpTriggers Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpTriggers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpTriggers
Visual Basic
Public Shared MsgHelp_HelpTriggers As Integer
Visual C++
public:
static int MsgHelp_HelpTriggers

See Also

P4ClientError Class


MsgHelp_HelpTrust Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpTrust Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpTrust
Visual Basic
Public Shared MsgHelp_HelpTrust As Integer
Visual C++
public:
static int MsgHelp_HelpTrust

See Also

P4ClientError Class


MsgHelp_HelpTunables Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpTunables Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpTunables
Visual Basic
Public Shared MsgHelp_HelpTunables As Integer
Visual C++
public:
static int MsgHelp_HelpTunables

See Also

P4ClientError Class


MsgHelp_HelpTypeMap Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpTypeMap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpTypeMap
Visual Basic
Public Shared MsgHelp_HelpTypeMap As Integer
Visual C++
public:
static int MsgHelp_HelpTypeMap

See Also

P4ClientError Class


MsgHelp_HelpUndoc Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpUndoc Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpUndoc
Visual Basic
Public Shared MsgHelp_HelpUndoc As Integer
Visual C++
public:
static int MsgHelp_HelpUndoc

See Also

P4ClientError Class


MsgHelp_HelpUnload Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpUnload Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpUnload
Visual Basic
Public Shared MsgHelp_HelpUnload As Integer
Visual C++
public:
static int MsgHelp_HelpUnload

See Also

P4ClientError Class


MsgHelp_HelpUnlock Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpUnlock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpUnlock
Visual Basic
Public Shared MsgHelp_HelpUnlock As Integer
Visual C++
public:
static int MsgHelp_HelpUnlock

See Also

P4ClientError Class


MsgHelp_HelpUnshelve Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpUnshelve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpUnshelve
Visual Basic
Public Shared MsgHelp_HelpUnshelve As Integer
Visual C++
public:
static int MsgHelp_HelpUnshelve

See Also

P4ClientError Class


MsgHelp_HelpUsage Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpUsage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpUsage
Visual Basic
Public Shared MsgHelp_HelpUsage As Integer
Visual C++
public:
static int MsgHelp_HelpUsage

See Also

P4ClientError Class


MsgHelp_HelpUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpUser
Visual Basic
Public Shared MsgHelp_HelpUser As Integer
Visual C++
public:
static int MsgHelp_HelpUser

See Also

P4ClientError Class


MsgHelp_HelpUsers Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpUsers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpUsers
Visual Basic
Public Shared MsgHelp_HelpUsers As Integer
Visual C++
public:
static int MsgHelp_HelpUsers

See Also

P4ClientError Class


MsgHelp_HelpVerify Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpVerify Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpVerify
Visual Basic
Public Shared MsgHelp_HelpVerify As Integer
Visual C++
public:
static int MsgHelp_HelpVerify

See Also

P4ClientError Class


MsgHelp_HelpViews Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpViews Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpViews
Visual Basic
Public Shared MsgHelp_HelpViews As Integer
Visual C++
public:
static int MsgHelp_HelpViews

See Also

P4ClientError Class


MsgHelp_HelpWhere Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpWhere Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpWhere
Visual Basic
Public Shared MsgHelp_HelpWhere As Integer
Visual C++
public:
static int MsgHelp_HelpWhere

See Also

P4ClientError Class


MsgHelp_HelpZeroConf Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_HelpZeroConf Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_HelpZeroConf
Visual Basic
Public Shared MsgHelp_HelpZeroConf As Integer
Visual C++
public:
static int MsgHelp_HelpZeroConf

See Also

P4ClientError Class


MsgHelp_NoHelp Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_NoHelp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_NoHelp
Visual Basic
Public Shared MsgHelp_NoHelp As Integer
Visual C++
public:
static int MsgHelp_NoHelp

See Also

P4ClientError Class


MsgHelp_ResolveUserHelp Field

[image]

Perforce .NET API
P4ClientError..::..MsgHelp_ResolveUserHelp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgHelp_ResolveUserHelp
Visual Basic
Public Shared MsgHelp_ResolveUserHelp As Integer
Visual C++
public:
static int MsgHelp_ResolveUserHelp

See Also

P4ClientError Class


MsgLbr_After Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_After Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_After
Visual Basic
Public Shared MsgLbr_After As Integer
Visual C++
public:
static int MsgLbr_After

See Also

P4ClientError Class


MsgLbr_AlreadyOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_AlreadyOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_AlreadyOpen
Visual Basic
Public Shared MsgLbr_AlreadyOpen As Integer
Visual C++
public:
static int MsgLbr_AlreadyOpen

See Also

P4ClientError Class


MsgLbr_BadKeyword Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_BadKeyword Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_BadKeyword
Visual Basic
Public Shared MsgLbr_BadKeyword As Integer
Visual C++
public:
static int MsgLbr_BadKeyword

See Also

P4ClientError Class


MsgLbr_BadType1 Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_BadType1 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_BadType1
Visual Basic
Public Shared MsgLbr_BadType1 As Integer
Visual C++
public:
static int MsgLbr_BadType1

See Also

P4ClientError Class


MsgLbr_Checkin Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Checkin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Checkin
Visual Basic
Public Shared MsgLbr_Checkin As Integer
Visual C++
public:
static int MsgLbr_Checkin

See Also

P4ClientError Class


MsgLbr_Checkout Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Checkout Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Checkout
Visual Basic
Public Shared MsgLbr_Checkout As Integer
Visual C++
public:
static int MsgLbr_Checkout

See Also

P4ClientError Class


MsgLbr_Commit Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Commit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Commit
Visual Basic
Public Shared MsgLbr_Commit As Integer
Visual C++
public:
static int MsgLbr_Commit

See Also

P4ClientError Class


MsgLbr_Diff Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Diff Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Diff
Visual Basic
Public Shared MsgLbr_Diff As Integer
Visual C++
public:
static int MsgLbr_Diff

See Also

P4ClientError Class


MsgLbr_Edit0 Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Edit0 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Edit0
Visual Basic
Public Shared MsgLbr_Edit0 As Integer
Visual C++
public:
static int MsgLbr_Edit0

See Also

P4ClientError Class


MsgLbr_Edit1 Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Edit1 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Edit1
Visual Basic
Public Shared MsgLbr_Edit1 As Integer
Visual C++
public:
static int MsgLbr_Edit1

See Also

P4ClientError Class


MsgLbr_Edit2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Edit2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Edit2
Visual Basic
Public Shared MsgLbr_Edit2 As Integer
Visual C++
public:
static int MsgLbr_Edit2

See Also

P4ClientError Class


MsgLbr_Empty Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Empty Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Empty
Visual Basic
Public Shared MsgLbr_Empty As Integer
Visual C++
public:
static int MsgLbr_Empty

See Also

P4ClientError Class


MsgLbr_EofAt Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_EofAt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_EofAt
Visual Basic
Public Shared MsgLbr_EofAt As Integer
Visual C++
public:
static int MsgLbr_EofAt

See Also

P4ClientError Class


MsgLbr_ExpDesc Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_ExpDesc Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_ExpDesc
Visual Basic
Public Shared MsgLbr_ExpDesc As Integer
Visual C++
public:
static int MsgLbr_ExpDesc

See Also

P4ClientError Class


MsgLbr_Expect Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Expect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Expect
Visual Basic
Public Shared MsgLbr_Expect As Integer
Visual C++
public:
static int MsgLbr_Expect

See Also

P4ClientError Class


MsgLbr_ExpEof Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_ExpEof Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_ExpEof
Visual Basic
Public Shared MsgLbr_ExpEof As Integer
Visual C++
public:
static int MsgLbr_ExpEof

See Also

P4ClientError Class


MsgLbr_ExpRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_ExpRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_ExpRev
Visual Basic
Public Shared MsgLbr_ExpRev As Integer
Visual C++
public:
static int MsgLbr_ExpRev

See Also

P4ClientError Class


MsgLbr_ExpSemi Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_ExpSemi Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_ExpSemi
Visual Basic
Public Shared MsgLbr_ExpSemi As Integer
Visual C++
public:
static int MsgLbr_ExpSemi

See Also

P4ClientError Class


MsgLbr_FmtLbrStat Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_FmtLbrStat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_FmtLbrStat
Visual Basic
Public Shared MsgLbr_FmtLbrStat As Integer
Visual C++
public:
static int MsgLbr_FmtLbrStat

See Also

P4ClientError Class


MsgLbr_FmtLbrStat2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_FmtLbrStat2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_FmtLbrStat2
Visual Basic
Public Shared MsgLbr_FmtLbrStat2 As Integer
Visual C++
public:
static int MsgLbr_FmtLbrStat2

See Also

P4ClientError Class


MsgLbr_FmtLbrStat3 Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_FmtLbrStat3 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_FmtLbrStat3
Visual Basic
Public Shared MsgLbr_FmtLbrStat3 As Integer
Visual C++
public:
static int MsgLbr_FmtLbrStat3

See Also

P4ClientError Class


MsgLbr_LbrOpenFail Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_LbrOpenFail Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_LbrOpenFail
Visual Basic
Public Shared MsgLbr_LbrOpenFail As Integer
Visual C++
public:
static int MsgLbr_LbrOpenFail

See Also

P4ClientError Class


MsgLbr_Lock Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Lock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Lock
Visual Basic
Public Shared MsgLbr_Lock As Integer
Visual C++
public:
static int MsgLbr_Lock

See Also

P4ClientError Class


MsgLbr_Loop Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Loop Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Loop
Visual Basic
Public Shared MsgLbr_Loop As Integer
Visual C++
public:
static int MsgLbr_Loop

See Also

P4ClientError Class


MsgLbr_Mangled Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Mangled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Mangled
Visual Basic
Public Shared MsgLbr_Mangled As Integer
Visual C++
public:
static int MsgLbr_Mangled

See Also

P4ClientError Class


MsgLbr_MkDir Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_MkDir Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_MkDir
Visual Basic
Public Shared MsgLbr_MkDir As Integer
Visual C++
public:
static int MsgLbr_MkDir

See Also

P4ClientError Class


MsgLbr_NoBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_NoBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_NoBranch
Visual Basic
Public Shared MsgLbr_NoBranch As Integer
Visual C++
public:
static int MsgLbr_NoBranch

See Also

P4ClientError Class


MsgLbr_NoBrRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_NoBrRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_NoBrRev
Visual Basic
Public Shared MsgLbr_NoBrRev As Integer
Visual C++
public:
static int MsgLbr_NoBrRev

See Also

P4ClientError Class


MsgLbr_NoRev Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_NoRev Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_NoRev
Visual Basic
Public Shared MsgLbr_NoRev As Integer
Visual C++
public:
static int MsgLbr_NoRev

See Also

P4ClientError Class


MsgLbr_NoRev3 Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_NoRev3 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_NoRev3
Visual Basic
Public Shared MsgLbr_NoRev3 As Integer
Visual C++
public:
static int MsgLbr_NoRev3

See Also

P4ClientError Class


MsgLbr_NoRevDel Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_NoRevDel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_NoRevDel
Visual Basic
Public Shared MsgLbr_NoRevDel As Integer
Visual C++
public:
static int MsgLbr_NoRevDel

See Also

P4ClientError Class


MsgLbr_Parse Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Parse Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Parse
Visual Basic
Public Shared MsgLbr_Parse As Integer
Visual C++
public:
static int MsgLbr_Parse

See Also

P4ClientError Class


MsgLbr_Purged Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_Purged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_Purged
Visual Basic
Public Shared MsgLbr_Purged As Integer
Visual C++
public:
static int MsgLbr_Purged

See Also

P4ClientError Class


MsgLbr_RcsTooBig Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_RcsTooBig Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_RcsTooBig
Visual Basic
Public Shared MsgLbr_RcsTooBig As Integer
Visual C++
public:
static int MsgLbr_RcsTooBig

See Also

P4ClientError Class


MsgLbr_RevLess Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_RevLess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_RevLess
Visual Basic
Public Shared MsgLbr_RevLess As Integer
Visual C++
public:
static int MsgLbr_RevLess

See Also

P4ClientError Class


MsgLbr_ScriptFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_ScriptFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_ScriptFailed
Visual Basic
Public Shared MsgLbr_ScriptFailed As Integer
Visual C++
public:
static int MsgLbr_ScriptFailed

See Also

P4ClientError Class


MsgLbr_TooBig Field

[image]

Perforce .NET API
P4ClientError..::..MsgLbr_TooBig Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgLbr_TooBig
Visual Basic
Public Shared MsgLbr_TooBig As Integer
Visual C++
public:
static int MsgLbr_TooBig

See Also

P4ClientError Class


MsgOs_ChmodBetrayal Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_ChmodBetrayal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_ChmodBetrayal
Visual Basic
Public Shared MsgOs_ChmodBetrayal As Integer
Visual C++
public:
static int MsgOs_ChmodBetrayal

See Also

P4ClientError Class


MsgOs_Deleted Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_Deleted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_Deleted
Visual Basic
Public Shared MsgOs_Deleted As Integer
Visual C++
public:
static int MsgOs_Deleted

See Also

P4ClientError Class


MsgOs_EmptyFork Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_EmptyFork Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_EmptyFork
Visual Basic
Public Shared MsgOs_EmptyFork As Integer
Visual C++
public:
static int MsgOs_EmptyFork

See Also

P4ClientError Class


MsgOs_NameTooLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_NameTooLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_NameTooLong
Visual Basic
Public Shared MsgOs_NameTooLong As Integer
Visual C++
public:
static int MsgOs_NameTooLong

See Also

P4ClientError Class


MsgOs_Net Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_Net Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_Net
Visual Basic
Public Shared MsgOs_Net As Integer
Visual C++
public:
static int MsgOs_Net

See Also

P4ClientError Class


MsgOs_NetUn Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_NetUn Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_NetUn
Visual Basic
Public Shared MsgOs_NetUn As Integer
Visual C++
public:
static int MsgOs_NetUn

See Also

P4ClientError Class


MsgOs_NoSuch Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_NoSuch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_NoSuch
Visual Basic
Public Shared MsgOs_NoSuch As Integer
Visual C++
public:
static int MsgOs_NoSuch

See Also

P4ClientError Class


MsgOs_Sys Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_Sys Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_Sys
Visual Basic
Public Shared MsgOs_Sys As Integer
Visual C++
public:
static int MsgOs_Sys

See Also

P4ClientError Class


MsgOs_Sys2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_Sys2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_Sys2
Visual Basic
Public Shared MsgOs_Sys2 As Integer
Visual C++
public:
static int MsgOs_Sys2

See Also

P4ClientError Class


MsgOs_SysUn Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_SysUn Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_SysUn
Visual Basic
Public Shared MsgOs_SysUn As Integer
Visual C++
public:
static int MsgOs_SysUn

See Also

P4ClientError Class


MsgOs_SysUn2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_SysUn2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_SysUn2
Visual Basic
Public Shared MsgOs_SysUn2 As Integer
Visual C++
public:
static int MsgOs_SysUn2

See Also

P4ClientError Class


MsgOs_TooMany Field

[image]

Perforce .NET API
P4ClientError..::..MsgOs_TooMany Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgOs_TooMany
Visual Basic
Public Shared MsgOs_TooMany As Integer
Visual C++
public:
static int MsgOs_TooMany

See Also

P4ClientError Class


MsgRpc_Break Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Break Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Break
Visual Basic
Public Shared MsgRpc_Break As Integer
Visual C++
public:
static int MsgRpc_Break

See Also

P4ClientError Class


MsgRpc_Closed Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Closed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Closed
Visual Basic
Public Shared MsgRpc_Closed As Integer
Visual C++
public:
static int MsgRpc_Closed

See Also

P4ClientError Class


MsgRpc_HostKeyMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_HostKeyMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_HostKeyMismatch
Visual Basic
Public Shared MsgRpc_HostKeyMismatch As Integer
Visual C++
public:
static int MsgRpc_HostKeyMismatch

See Also

P4ClientError Class


MsgRpc_HostKeyUnknown Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_HostKeyUnknown Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_HostKeyUnknown
Visual Basic
Public Shared MsgRpc_HostKeyUnknown As Integer
Visual C++
public:
static int MsgRpc_HostKeyUnknown

See Also

P4ClientError Class


MsgRpc_Listen Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Listen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Listen
Visual Basic
Public Shared MsgRpc_Listen As Integer
Visual C++
public:
static int MsgRpc_Listen

See Also

P4ClientError Class


MsgRpc_MaxWait Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_MaxWait Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_MaxWait
Visual Basic
Public Shared MsgRpc_MaxWait As Integer
Visual C++
public:
static int MsgRpc_MaxWait

See Also

P4ClientError Class


MsgRpc_NameResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_NameResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_NameResolve
Visual Basic
Public Shared MsgRpc_NameResolve As Integer
Visual C++
public:
static int MsgRpc_NameResolve

See Also

P4ClientError Class


MsgRpc_NoPoss Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_NoPoss Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_NoPoss
Visual Basic
Public Shared MsgRpc_NoPoss As Integer
Visual C++
public:
static int MsgRpc_NoPoss

See Also

P4ClientError Class


MsgRpc_NotP4 Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_NotP4 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_NotP4
Visual Basic
Public Shared MsgRpc_NotP4 As Integer
Visual C++
public:
static int MsgRpc_NotP4

See Also

P4ClientError Class


MsgRpc_Operat Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Operat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Operat
Visual Basic
Public Shared MsgRpc_Operat As Integer
Visual C++
public:
static int MsgRpc_Operat

See Also

P4ClientError Class


MsgRpc_PxRemoteSvrFail Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_PxRemoteSvrFail Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_PxRemoteSvrFail
Visual Basic
Public Shared MsgRpc_PxRemoteSvrFail As Integer
Visual C++
public:
static int MsgRpc_PxRemoteSvrFail

See Also

P4ClientError Class


MsgRpc_Read Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Read Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Read
Visual Basic
Public Shared MsgRpc_Read As Integer
Visual C++
public:
static int MsgRpc_Read

See Also

P4ClientError Class


MsgRpc_Reconn Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Reconn Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Reconn
Visual Basic
Public Shared MsgRpc_Reconn As Integer
Visual C++
public:
static int MsgRpc_Reconn

See Also

P4ClientError Class


MsgRpc_Select Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Select Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Select
Visual Basic
Public Shared MsgRpc_Select As Integer
Visual C++
public:
static int MsgRpc_Select

See Also

P4ClientError Class


MsgRpc_ServiceNoTrust Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_ServiceNoTrust Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_ServiceNoTrust
Visual Basic
Public Shared MsgRpc_ServiceNoTrust As Integer
Visual C++
public:
static int MsgRpc_ServiceNoTrust

See Also

P4ClientError Class


MsgRpc_SslAccept Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslAccept Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslAccept
Visual Basic
Public Shared MsgRpc_SslAccept As Integer
Visual C++
public:
static int MsgRpc_SslAccept

See Also

P4ClientError Class


MsgRpc_SslBadDir Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslBadDir Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslBadDir
Visual Basic
Public Shared MsgRpc_SslBadDir As Integer
Visual C++
public:
static int MsgRpc_SslBadDir

See Also

P4ClientError Class


MsgRpc_SslBadFsSecurity Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslBadFsSecurity Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslBadFsSecurity
Visual Basic
Public Shared MsgRpc_SslBadFsSecurity As Integer
Visual C++
public:
static int MsgRpc_SslBadFsSecurity

See Also

P4ClientError Class


MsgRpc_SslBadKeyFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslBadKeyFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslBadKeyFile
Visual Basic
Public Shared MsgRpc_SslBadKeyFile As Integer
Visual C++
public:
static int MsgRpc_SslBadKeyFile

See Also

P4ClientError Class


MsgRpc_SslCertBadDates Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslCertBadDates Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslCertBadDates
Visual Basic
Public Shared MsgRpc_SslCertBadDates As Integer
Visual C++
public:
static int MsgRpc_SslCertBadDates

See Also

P4ClientError Class


MsgRpc_SslCertGen Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslCertGen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslCertGen
Visual Basic
Public Shared MsgRpc_SslCertGen As Integer
Visual C++
public:
static int MsgRpc_SslCertGen

See Also

P4ClientError Class


MsgRpc_SslCfgExpire Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslCfgExpire Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslCfgExpire
Visual Basic
Public Shared MsgRpc_SslCfgExpire As Integer
Visual C++
public:
static int MsgRpc_SslCfgExpire

See Also

P4ClientError Class


MsgRpc_SslCfgUnits Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslCfgUnits Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslCfgUnits
Visual Basic
Public Shared MsgRpc_SslCfgUnits As Integer
Visual C++
public:
static int MsgRpc_SslCfgUnits

See Also

P4ClientError Class


MsgRpc_SslCleartext Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslCleartext Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslCleartext
Visual Basic
Public Shared MsgRpc_SslCleartext As Integer
Visual C++
public:
static int MsgRpc_SslCleartext

See Also

P4ClientError Class


MsgRpc_SslClose Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslClose Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslClose
Visual Basic
Public Shared MsgRpc_SslClose As Integer
Visual C++
public:
static int MsgRpc_SslClose

See Also

P4ClientError Class


MsgRpc_SslConnect Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslConnect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslConnect
Visual Basic
Public Shared MsgRpc_SslConnect As Integer
Visual C++
public:
static int MsgRpc_SslConnect

See Also

P4ClientError Class


MsgRpc_SslCredsBadOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslCredsBadOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslCredsBadOwner
Visual Basic
Public Shared MsgRpc_SslCredsBadOwner As Integer
Visual C++
public:
static int MsgRpc_SslCredsBadOwner

See Also

P4ClientError Class


MsgRpc_SslCtx Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslCtx Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslCtx
Visual Basic
Public Shared MsgRpc_SslCtx As Integer
Visual C++
public:
static int MsgRpc_SslCtx

See Also

P4ClientError Class


MsgRpc_SslDirHasCreds Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslDirHasCreds Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslDirHasCreds
Visual Basic
Public Shared MsgRpc_SslDirHasCreds As Integer
Visual C++
public:
static int MsgRpc_SslDirHasCreds

See Also

P4ClientError Class


MsgRpc_SslFailGetExpire Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslFailGetExpire Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslFailGetExpire
Visual Basic
Public Shared MsgRpc_SslFailGetExpire As Integer
Visual C++
public:
static int MsgRpc_SslFailGetExpire

See Also

P4ClientError Class


MsgRpc_SslGetPubKey Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslGetPubKey Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslGetPubKey
Visual Basic
Public Shared MsgRpc_SslGetPubKey As Integer
Visual C++
public:
static int MsgRpc_SslGetPubKey

See Also

P4ClientError Class


MsgRpc_SslInit Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslInit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslInit
Visual Basic
Public Shared MsgRpc_SslInit As Integer
Visual C++
public:
static int MsgRpc_SslInit

See Also

P4ClientError Class


MsgRpc_SslInvalid Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslInvalid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslInvalid
Visual Basic
Public Shared MsgRpc_SslInvalid As Integer
Visual C++
public:
static int MsgRpc_SslInvalid

See Also

P4ClientError Class


MsgRpc_SslKeyNotRSA Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslKeyNotRSA Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslKeyNotRSA
Visual Basic
Public Shared MsgRpc_SslKeyNotRSA As Integer
Visual C++
public:
static int MsgRpc_SslKeyNotRSA

See Also

P4ClientError Class


MsgRpc_SslLibMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslLibMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslLibMismatch
Visual Basic
Public Shared MsgRpc_SslLibMismatch As Integer
Visual C++
public:
static int MsgRpc_SslLibMismatch

See Also

P4ClientError Class


MsgRpc_SslListen Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslListen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslListen
Visual Basic
Public Shared MsgRpc_SslListen As Integer
Visual C++
public:
static int MsgRpc_SslListen

See Also

P4ClientError Class


MsgRpc_SslNoCredentials Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslNoCredentials Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslNoCredentials
Visual Basic
Public Shared MsgRpc_SslNoCredentials As Integer
Visual C++
public:
static int MsgRpc_SslNoCredentials

See Also

P4ClientError Class


MsgRpc_SslNoSsl Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslNoSsl Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslNoSsl
Visual Basic
Public Shared MsgRpc_SslNoSsl As Integer
Visual C++
public:
static int MsgRpc_SslNoSsl

See Also

P4ClientError Class


MsgRpc_SslRecv Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslRecv Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslRecv
Visual Basic
Public Shared MsgRpc_SslRecv As Integer
Visual C++
public:
static int MsgRpc_SslRecv

See Also

P4ClientError Class


MsgRpc_SslSend Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslSend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslSend
Visual Basic
Public Shared MsgRpc_SslSend As Integer
Visual C++
public:
static int MsgRpc_SslSend

See Also

P4ClientError Class


MsgRpc_SslShutdown Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_SslShutdown Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_SslShutdown
Visual Basic
Public Shared MsgRpc_SslShutdown As Integer
Visual C++
public:
static int MsgRpc_SslShutdown

See Also

P4ClientError Class


MsgRpc_Stdio Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Stdio Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Stdio
Visual Basic
Public Shared MsgRpc_Stdio As Integer
Visual C++
public:
static int MsgRpc_Stdio

See Also

P4ClientError Class


MsgRpc_TcpAccept Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpAccept Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpAccept
Visual Basic
Public Shared MsgRpc_TcpAccept As Integer
Visual C++
public:
static int MsgRpc_TcpAccept

See Also

P4ClientError Class


MsgRpc_TcpConnect Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpConnect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpConnect
Visual Basic
Public Shared MsgRpc_TcpConnect As Integer
Visual C++
public:
static int MsgRpc_TcpConnect

See Also

P4ClientError Class


MsgRpc_TcpHost Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpHost Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpHost
Visual Basic
Public Shared MsgRpc_TcpHost As Integer
Visual C++
public:
static int MsgRpc_TcpHost

See Also

P4ClientError Class


MsgRpc_TcpListen Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpListen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpListen
Visual Basic
Public Shared MsgRpc_TcpListen As Integer
Visual C++
public:
static int MsgRpc_TcpListen

See Also

P4ClientError Class


MsgRpc_TcpPeerSsl Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpPeerSsl Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpPeerSsl
Visual Basic
Public Shared MsgRpc_TcpPeerSsl As Integer
Visual C++
public:
static int MsgRpc_TcpPeerSsl

See Also

P4ClientError Class


MsgRpc_TcpPortInvalid Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpPortInvalid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpPortInvalid
Visual Basic
Public Shared MsgRpc_TcpPortInvalid As Integer
Visual C++
public:
static int MsgRpc_TcpPortInvalid

See Also

P4ClientError Class


MsgRpc_TcpRecv Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpRecv Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpRecv
Visual Basic
Public Shared MsgRpc_TcpRecv As Integer
Visual C++
public:
static int MsgRpc_TcpRecv

See Also

P4ClientError Class


MsgRpc_TcpSend Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpSend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpSend
Visual Basic
Public Shared MsgRpc_TcpSend As Integer
Visual C++
public:
static int MsgRpc_TcpSend

See Also

P4ClientError Class


MsgRpc_TcpService Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TcpService Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TcpService
Visual Basic
Public Shared MsgRpc_TcpService As Integer
Visual C++
public:
static int MsgRpc_TcpService

See Also

P4ClientError Class


MsgRpc_TooBig Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_TooBig Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_TooBig
Visual Basic
Public Shared MsgRpc_TooBig As Integer
Visual C++
public:
static int MsgRpc_TooBig

See Also

P4ClientError Class


MsgRpc_Unconn Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_Unconn Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_Unconn
Visual Basic
Public Shared MsgRpc_Unconn As Integer
Visual C++
public:
static int MsgRpc_Unconn

See Also

P4ClientError Class


MsgRpc_UnixDomainOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_UnixDomainOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_UnixDomainOpen
Visual Basic
Public Shared MsgRpc_UnixDomainOpen As Integer
Visual C++
public:
static int MsgRpc_UnixDomainOpen

See Also

P4ClientError Class


MsgRpc_UnReg Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_UnReg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_UnReg
Visual Basic
Public Shared MsgRpc_UnReg As Integer
Visual C++
public:
static int MsgRpc_UnReg

See Also

P4ClientError Class


MsgRpc_WakeupAttempt Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_WakeupAttempt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_WakeupAttempt
Visual Basic
Public Shared MsgRpc_WakeupAttempt As Integer
Visual C++
public:
static int MsgRpc_WakeupAttempt

See Also

P4ClientError Class


MsgRpc_WakeupInit Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_WakeupInit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_WakeupInit
Visual Basic
Public Shared MsgRpc_WakeupInit As Integer
Visual C++
public:
static int MsgRpc_WakeupInit

See Also

P4ClientError Class


MsgRpc_ZksDisconnect Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_ZksDisconnect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_ZksDisconnect
Visual Basic
Public Shared MsgRpc_ZksDisconnect As Integer
Visual C++
public:
static int MsgRpc_ZksDisconnect

See Also

P4ClientError Class


MsgRpc_ZksInit Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_ZksInit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_ZksInit
Visual Basic
Public Shared MsgRpc_ZksInit As Integer
Visual C++
public:
static int MsgRpc_ZksInit

See Also

P4ClientError Class


MsgRpc_ZksRecv Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_ZksRecv Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_ZksRecv
Visual Basic
Public Shared MsgRpc_ZksRecv As Integer
Visual C++
public:
static int MsgRpc_ZksRecv

See Also

P4ClientError Class


MsgRpc_ZksSend Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_ZksSend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_ZksSend
Visual Basic
Public Shared MsgRpc_ZksSend As Integer
Visual C++
public:
static int MsgRpc_ZksSend

See Also

P4ClientError Class


MsgRpc_ZksState Field

[image]

Perforce .NET API
P4ClientError..::..MsgRpc_ZksState Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgRpc_ZksState
Visual Basic
Public Shared MsgRpc_ZksState As Integer
Visual C++
public:
static int MsgRpc_ZksState

See Also

P4ClientError Class


MsgServer_ActionResolve111 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ActionResolve111 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ActionResolve111
Visual Basic
Public Shared MsgServer_ActionResolve111 As Integer
Visual C++
public:
static int MsgServer_ActionResolve111

See Also

P4ClientError Class


MsgServer_AddDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AddDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AddDelete
Visual Basic
Public Shared MsgServer_AddDelete As Integer
Visual C++
public:
static int MsgServer_AddDelete

See Also

P4ClientError Class


MsgServer_AdminNoSpecDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminNoSpecDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminNoSpecDepot
Visual Basic
Public Shared MsgServer_AdminNoSpecDepot As Integer
Visual C++
public:
static int MsgServer_AdminNoSpecDepot

See Also

P4ClientError Class


MsgServer_AdminNoSuchSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminNoSuchSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminNoSuchSpec
Visual Basic
Public Shared MsgServer_AdminNoSuchSpec As Integer
Visual C++
public:
static int MsgServer_AdminNoSuchSpec

See Also

P4ClientError Class


MsgServer_AdminNothingLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminNothingLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminNothingLocked
Visual Basic
Public Shared MsgServer_AdminNothingLocked As Integer
Visual C++
public:
static int MsgServer_AdminNothingLocked

See Also

P4ClientError Class


MsgServer_AdminNothingLogged Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminNothingLogged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminNothingLogged
Visual Basic
Public Shared MsgServer_AdminNothingLogged As Integer
Visual C++
public:
static int MsgServer_AdminNothingLogged

See Also

P4ClientError Class


MsgServer_AdminPasswordNoPasswords Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminPasswordNoPasswords Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminPasswordNoPasswords
Visual Basic
Public Shared MsgServer_AdminPasswordNoPasswords As Integer
Visual C++
public:
static int MsgServer_AdminPasswordNoPasswords

See Also

P4ClientError Class


MsgServer_AdminPasswordNoSuchUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminPasswordNoSuchUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminPasswordNoSuchUser
Visual Basic
Public Shared MsgServer_AdminPasswordNoSuchUser As Integer
Visual C++
public:
static int MsgServer_AdminPasswordNoSuchUser

See Also

P4ClientError Class


MsgServer_AdminReplicaCkp Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminReplicaCkp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminReplicaCkp
Visual Basic
Public Shared MsgServer_AdminReplicaCkp As Integer
Visual C++
public:
static int MsgServer_AdminReplicaCkp

See Also

P4ClientError Class


MsgServer_AdminSizeData Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AdminSizeData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AdminSizeData
Visual Basic
Public Shared MsgServer_AdminSizeData As Integer
Visual C++
public:
static int MsgServer_AdminSizeData

See Also

P4ClientError Class


MsgServer_AttrNoPropEdge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_AttrNoPropEdge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_AttrNoPropEdge
Visual Basic
Public Shared MsgServer_AttrNoPropEdge As Integer
Visual C++
public:
static int MsgServer_AttrNoPropEdge

See Also

P4ClientError Class


MsgServer_BadCheckpointNum Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadCheckpointNum Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadCheckpointNum
Visual Basic
Public Shared MsgServer_BadCheckpointNum As Integer
Visual C++
public:
static int MsgServer_BadCheckpointNum

See Also

P4ClientError Class


MsgServer_BadCommand Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadCommand Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadCommand
Visual Basic
Public Shared MsgServer_BadCommand As Integer
Visual C++
public:
static int MsgServer_BadCommand

See Also

P4ClientError Class


MsgServer_BadExtraFlag Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadExtraFlag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadExtraFlag
Visual Basic
Public Shared MsgServer_BadExtraFlag As Integer
Visual C++
public:
static int MsgServer_BadExtraFlag

See Also

P4ClientError Class


MsgServer_BadImport Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadImport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadImport
Visual Basic
Public Shared MsgServer_BadImport As Integer
Visual C++
public:
static int MsgServer_BadImport

See Also

P4ClientError Class


MsgServer_BadIPAddr Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadIPAddr Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadIPAddr
Visual Basic
Public Shared MsgServer_BadIPAddr As Integer
Visual C++
public:
static int MsgServer_BadIPAddr

See Also

P4ClientError Class


MsgServer_BadJnlFlag Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadJnlFlag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadJnlFlag
Visual Basic
Public Shared MsgServer_BadJnlFlag As Integer
Visual C++
public:
static int MsgServer_BadJnlFlag

See Also

P4ClientError Class


MsgServer_BadJournalNum Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadJournalNum Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadJournalNum
Visual Basic
Public Shared MsgServer_BadJournalNum As Integer
Visual C++
public:
static int MsgServer_BadJournalNum

See Also

P4ClientError Class


MsgServer_BadPassword Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadPassword Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadPassword
Visual Basic
Public Shared MsgServer_BadPassword As Integer
Visual C++
public:
static int MsgServer_BadPassword

See Also

P4ClientError Class


MsgServer_BadPassword0 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadPassword0 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadPassword0
Visual Basic
Public Shared MsgServer_BadPassword0 As Integer
Visual C++
public:
static int MsgServer_BadPassword0

See Also

P4ClientError Class


MsgServer_BadPassword1 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadPassword1 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadPassword1
Visual Basic
Public Shared MsgServer_BadPassword1 As Integer
Visual C++
public:
static int MsgServer_BadPassword1

See Also

P4ClientError Class


MsgServer_BadPCache Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadPCache Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadPCache
Visual Basic
Public Shared MsgServer_BadPCache As Integer
Visual C++
public:
static int MsgServer_BadPCache

See Also

P4ClientError Class


MsgServer_BadRoot Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadRoot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadRoot
Visual Basic
Public Shared MsgServer_BadRoot As Integer
Visual C++
public:
static int MsgServer_BadRoot

See Also

P4ClientError Class


MsgServer_BadServicePack Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadServicePack Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadServicePack
Visual Basic
Public Shared MsgServer_BadServicePack As Integer
Visual C++
public:
static int MsgServer_BadServicePack

See Also

P4ClientError Class


MsgServer_BadSortOption Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadSortOption Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadSortOption
Visual Basic
Public Shared MsgServer_BadSortOption As Integer
Visual C++
public:
static int MsgServer_BadSortOption

See Also

P4ClientError Class


MsgServer_BadTransfers Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadTransfers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadTransfers
Visual Basic
Public Shared MsgServer_BadTransfers As Integer
Visual C++
public:
static int MsgServer_BadTransfers

See Also

P4ClientError Class


MsgServer_BadTriggerOutput Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BadTriggerOutput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BadTriggerOutput
Visual Basic
Public Shared MsgServer_BadTriggerOutput As Integer
Visual C++
public:
static int MsgServer_BadTriggerOutput

See Also

P4ClientError Class


MsgServer_BFNoOverwriteLocal Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BFNoOverwriteLocal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BFNoOverwriteLocal
Visual Basic
Public Shared MsgServer_BFNoOverwriteLocal As Integer
Visual C++
public:
static int MsgServer_BFNoOverwriteLocal

See Also

P4ClientError Class


MsgServer_BoundClientExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BoundClientExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BoundClientExists
Visual Basic
Public Shared MsgServer_BoundClientExists As Integer
Visual C++
public:
static int MsgServer_BoundClientExists

See Also

P4ClientError Class


MsgServer_BoundClientServerID Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_BoundClientServerID Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_BoundClientServerID
Visual Basic
Public Shared MsgServer_BoundClientServerID As Integer
Visual C++
public:
static int MsgServer_BoundClientServerID

See Also

P4ClientError Class


MsgServer_CacheAlreadyPurged Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CacheAlreadyPurged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CacheAlreadyPurged
Visual Basic
Public Shared MsgServer_CacheAlreadyPurged As Integer
Visual C++
public:
static int MsgServer_CacheAlreadyPurged

See Also

P4ClientError Class


MsgServer_CantAuthenticate Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CantAuthenticate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CantAuthenticate
Visual Basic
Public Shared MsgServer_CantAuthenticate As Integer
Visual C++
public:
static int MsgServer_CantAuthenticate

See Also

P4ClientError Class


MsgServer_CantChangeOther Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CantChangeOther Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CantChangeOther
Visual Basic
Public Shared MsgServer_CantChangeOther As Integer
Visual C++
public:
static int MsgServer_CantChangeOther

See Also

P4ClientError Class


MsgServer_CantOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CantOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CantOpen
Visual Basic
Public Shared MsgServer_CantOpen As Integer
Visual C++
public:
static int MsgServer_CantOpen

See Also

P4ClientError Class


MsgServer_CantRevertToPurged Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CantRevertToPurged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CantRevertToPurged
Visual Basic
Public Shared MsgServer_CantRevertToPurged As Integer
Visual C++
public:
static int MsgServer_CantRevertToPurged

See Also

P4ClientError Class


MsgServer_CantUnloadLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CantUnloadLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CantUnloadLocked
Visual Basic
Public Shared MsgServer_CantUnloadLocked As Integer
Visual C++
public:
static int MsgServer_CantUnloadLocked

See Also

P4ClientError Class


MsgServer_ChangeNotLocal Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ChangeNotLocal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ChangeNotLocal
Visual Basic
Public Shared MsgServer_ChangeNotLocal As Integer
Visual C++
public:
static int MsgServer_ChangeNotLocal

See Also

P4ClientError Class


MsgServer_ChangeNotSubmitted Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ChangeNotSubmitted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ChangeNotSubmitted
Visual Basic
Public Shared MsgServer_ChangeNotSubmitted As Integer
Visual C++
public:
static int MsgServer_ChangeNotSubmitted

See Also

P4ClientError Class


MsgServer_ChangesShelved Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ChangesShelved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ChangesShelved
Visual Basic
Public Shared MsgServer_ChangesShelved As Integer
Visual C++
public:
static int MsgServer_ChangesShelved

See Also

P4ClientError Class


MsgServer_ClientBadHost Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ClientBadHost Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ClientBadHost
Visual Basic
Public Shared MsgServer_ClientBadHost As Integer
Visual C++
public:
static int MsgServer_ClientBadHost

See Also

P4ClientError Class


MsgServer_ClientOpFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ClientOpFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ClientOpFailed
Visual Basic
Public Shared MsgServer_ClientOpFailed As Integer
Visual C++
public:
static int MsgServer_ClientOpFailed

See Also

P4ClientError Class


MsgServer_ClientTooOld Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ClientTooOld Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ClientTooOld
Visual Basic
Public Shared MsgServer_ClientTooOld As Integer
Visual C++
public:
static int MsgServer_ClientTooOld

See Also

P4ClientError Class


MsgServer_ClusterCannotWriteJournal Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ClusterCannotWriteJournal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ClusterCannotWriteJournal
Visual Basic
Public Shared MsgServer_ClusterCannotWriteJournal As Integer
Visual C++
public:
static int MsgServer_ClusterCannotWriteJournal

See Also

P4ClientError Class


MsgServer_ClusterNotAllowed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ClusterNotAllowed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ClusterNotAllowed
Visual Basic
Public Shared MsgServer_ClusterNotAllowed As Integer
Visual C++
public:
static int MsgServer_ClusterNotAllowed

See Also

P4ClientError Class


MsgServer_CommandCancelled Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CommandCancelled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CommandCancelled
Visual Basic
Public Shared MsgServer_CommandCancelled As Integer
Visual C++
public:
static int MsgServer_CommandCancelled

See Also

P4ClientError Class


MsgServer_CommandDisabled Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CommandDisabled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CommandDisabled
Visual Basic
Public Shared MsgServer_CommandDisabled As Integer
Visual C++
public:
static int MsgServer_CommandDisabled

See Also

P4ClientError Class


MsgServer_CommandUnsupported Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CommandUnsupported Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CommandUnsupported
Visual Basic
Public Shared MsgServer_CommandUnsupported As Integer
Visual C++
public:
static int MsgServer_CommandUnsupported

See Also

P4ClientError Class


MsgServer_CommunicationLoop Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CommunicationLoop Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CommunicationLoop
Visual Basic
Public Shared MsgServer_CommunicationLoop As Integer
Visual C++
public:
static int MsgServer_CommunicationLoop

See Also

P4ClientError Class


MsgServer_ConfigureNone Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ConfigureNone Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ConfigureNone
Visual Basic
Public Shared MsgServer_ConfigureNone As Integer
Visual C++
public:
static int MsgServer_ConfigureNone

See Also

P4ClientError Class


MsgServer_ConfigureServerNone Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ConfigureServerNone Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ConfigureServerNone
Visual Basic
Public Shared MsgServer_ConfigureServerNone As Integer
Visual C++
public:
static int MsgServer_ConfigureServerNone

See Also

P4ClientError Class


MsgServer_ConfigureSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ConfigureSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ConfigureSet
Visual Basic
Public Shared MsgServer_ConfigureSet As Integer
Visual C++
public:
static int MsgServer_ConfigureSet

See Also

P4ClientError Class


MsgServer_ConfigureUnSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ConfigureUnSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ConfigureUnSet
Visual Basic
Public Shared MsgServer_ConfigureUnSet As Integer
Visual C++
public:
static int MsgServer_ConfigureUnSet

See Also

P4ClientError Class


MsgServer_ConnectBroken Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ConnectBroken Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ConnectBroken
Visual Basic
Public Shared MsgServer_ConnectBroken As Integer
Visual C++
public:
static int MsgServer_ConnectBroken

See Also

P4ClientError Class


MsgServer_CopyDoNothing Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CopyDoNothing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CopyDoNothing
Visual Basic
Public Shared MsgServer_CopyDoNothing As Integer
Visual C++
public:
static int MsgServer_CopyDoNothing

See Also

P4ClientError Class


MsgServer_CopyNeedsMergeFirst Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CopyNeedsMergeFirst Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CopyNeedsMergeFirst
Visual Basic
Public Shared MsgServer_CopyNeedsMergeFirst As Integer
Visual C++
public:
static int MsgServer_CopyNeedsMergeFirst

See Also

P4ClientError Class


MsgServer_CopyWrongDirection Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CopyWrongDirection Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CopyWrongDirection
Visual Basic
Public Shared MsgServer_CopyWrongDirection As Integer
Visual C++
public:
static int MsgServer_CopyWrongDirection

See Also

P4ClientError Class


MsgServer_CouldntLock Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CouldntLock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CouldntLock
Visual Basic
Public Shared MsgServer_CouldntLock As Integer
Visual C++
public:
static int MsgServer_CouldntLock

See Also

P4ClientError Class


MsgServer_CounterDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CounterDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CounterDelete
Visual Basic
Public Shared MsgServer_CounterDelete As Integer
Visual C++
public:
static int MsgServer_CounterDelete

See Also

P4ClientError Class


MsgServer_CounterGet Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CounterGet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CounterGet
Visual Basic
Public Shared MsgServer_CounterGet As Integer
Visual C++
public:
static int MsgServer_CounterGet

See Also

P4ClientError Class


MsgServer_CounterNotNumeric Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CounterNotNumeric Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CounterNotNumeric
Visual Basic
Public Shared MsgServer_CounterNotNumeric As Integer
Visual C++
public:
static int MsgServer_CounterNotNumeric

See Also

P4ClientError Class


MsgServer_CounterSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CounterSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CounterSet
Visual Basic
Public Shared MsgServer_CounterSet As Integer
Visual C++
public:
static int MsgServer_CounterSet

See Also

P4ClientError Class


MsgServer_CounterWarning Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CounterWarning Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CounterWarning
Visual Basic
Public Shared MsgServer_CounterWarning As Integer
Visual C++
public:
static int MsgServer_CounterWarning

See Also

P4ClientError Class


MsgServer_CreatingDb Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CreatingDb Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CreatingDb
Visual Basic
Public Shared MsgServer_CreatingDb As Integer
Visual C++
public:
static int MsgServer_CreatingDb

See Also

P4ClientError Class


MsgServer_CurJournalButNotJournaling Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_CurJournalButNotJournaling Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_CurJournalButNotJournaling
Visual Basic
Public Shared MsgServer_CurJournalButNotJournaling As Integer
Visual C++
public:
static int MsgServer_CurJournalButNotJournaling

See Also

P4ClientError Class


MsgServer_DeltaLine1 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DeltaLine1 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DeltaLine1
Visual Basic
Public Shared MsgServer_DeltaLine1 As Integer
Visual C++
public:
static int MsgServer_DeltaLine1

See Also

P4ClientError Class


MsgServer_DeltaLine2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DeltaLine2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DeltaLine2
Visual Basic
Public Shared MsgServer_DeltaLine2 As Integer
Visual C++
public:
static int MsgServer_DeltaLine2

See Also

P4ClientError Class


MsgServer_DescribeAffected Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DescribeAffected Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DescribeAffected
Visual Basic
Public Shared MsgServer_DescribeAffected As Integer
Visual C++
public:
static int MsgServer_DescribeAffected

See Also

P4ClientError Class


MsgServer_DescribeDifferences Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DescribeDifferences Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DescribeDifferences
Visual Basic
Public Shared MsgServer_DescribeDifferences As Integer
Visual C++
public:
static int MsgServer_DescribeDifferences

See Also

P4ClientError Class


MsgServer_DescribeEmpty Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DescribeEmpty Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DescribeEmpty
Visual Basic
Public Shared MsgServer_DescribeEmpty As Integer
Visual C++
public:
static int MsgServer_DescribeEmpty

See Also

P4ClientError Class


MsgServer_DescribeFixed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DescribeFixed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DescribeFixed
Visual Basic
Public Shared MsgServer_DescribeFixed As Integer
Visual C++
public:
static int MsgServer_DescribeFixed

See Also

P4ClientError Class


MsgServer_DescribeMovedFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DescribeMovedFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DescribeMovedFiles
Visual Basic
Public Shared MsgServer_DescribeMovedFiles As Integer
Visual C++
public:
static int MsgServer_DescribeMovedFiles

See Also

P4ClientError Class


MsgServer_DescribeShelved Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DescribeShelved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DescribeShelved
Visual Basic
Public Shared MsgServer_DescribeShelved As Integer
Visual C++
public:
static int MsgServer_DescribeShelved

See Also

P4ClientError Class


MsgServer_Diff2BadArgs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Diff2BadArgs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Diff2BadArgs
Visual Basic
Public Shared MsgServer_Diff2BadArgs As Integer
Visual C++
public:
static int MsgServer_Diff2BadArgs

See Also

P4ClientError Class


MsgServer_Diff2Differ Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Diff2Differ Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Diff2Differ
Visual Basic
Public Shared MsgServer_Diff2Differ As Integer
Visual C++
public:
static int MsgServer_Diff2Differ

See Also

P4ClientError Class


MsgServer_DiffCmp Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DiffCmp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DiffCmp
Visual Basic
Public Shared MsgServer_DiffCmp As Integer
Visual C++
public:
static int MsgServer_DiffCmp

See Also

P4ClientError Class


MsgServer_DiffList Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DiffList Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DiffList
Visual Basic
Public Shared MsgServer_DiffList As Integer
Visual C++
public:
static int MsgServer_DiffList

See Also

P4ClientError Class


MsgServer_DigestMisMatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DigestMisMatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DigestMisMatch
Visual Basic
Public Shared MsgServer_DigestMisMatch As Integer
Visual C++
public:
static int MsgServer_DigestMisMatch

See Also

P4ClientError Class


MsgServer_DirsWild Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DirsWild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DirsWild
Visual Basic
Public Shared MsgServer_DirsWild As Integer
Visual C++
public:
static int MsgServer_DirsWild

See Also

P4ClientError Class


MsgServer_DomainIsLocal Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DomainIsLocal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DomainIsLocal
Visual Basic
Public Shared MsgServer_DomainIsLocal As Integer
Visual C++
public:
static int MsgServer_DomainIsLocal

See Also

P4ClientError Class


MsgServer_DontRenameSelf Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DontRenameSelf Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DontRenameSelf
Visual Basic
Public Shared MsgServer_DontRenameSelf As Integer
Visual C++
public:
static int MsgServer_DontRenameSelf

See Also

P4ClientError Class


MsgServer_DumpNameIsADbName Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_DumpNameIsADbName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_DumpNameIsADbName
Visual Basic
Public Shared MsgServer_DumpNameIsADbName As Integer
Visual C++
public:
static int MsgServer_DumpNameIsADbName

See Also

P4ClientError Class


MsgServer_EmptyTypeList Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_EmptyTypeList Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_EmptyTypeList
Visual Basic
Public Shared MsgServer_EmptyTypeList As Integer
Visual C++
public:
static int MsgServer_EmptyTypeList

See Also

P4ClientError Class


MsgServer_ErrorInSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ErrorInSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ErrorInSpec
Visual Basic
Public Shared MsgServer_ErrorInSpec As Integer
Visual C++
public:
static int MsgServer_ErrorInSpec

See Also

P4ClientError Class


MsgServer_ErrorPingParam Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ErrorPingParam Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ErrorPingParam
Visual Basic
Public Shared MsgServer_ErrorPingParam As Integer
Visual C++
public:
static int MsgServer_ErrorPingParam

See Also

P4ClientError Class


MsgServer_ErrorPingProtocol Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ErrorPingProtocol Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ErrorPingProtocol
Visual Basic
Public Shared MsgServer_ErrorPingProtocol As Integer
Visual C++
public:
static int MsgServer_ErrorPingProtocol

See Also

P4ClientError Class


MsgServer_ExtraIDUsage Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ExtraIDUsage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ExtraIDUsage
Visual Basic
Public Shared MsgServer_ExtraIDUsage As Integer
Visual C++
public:
static int MsgServer_ExtraIDUsage

See Also

P4ClientError Class


MsgServer_GotLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_GotLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_GotLocked
Visual Basic
Public Shared MsgServer_GotLocked As Integer
Visual C++
public:
static int MsgServer_GotLocked

See Also

P4ClientError Class


MsgServer_GotUnlocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_GotUnlocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_GotUnlocked
Visual Basic
Public Shared MsgServer_GotUnlocked As Integer
Visual C++
public:
static int MsgServer_GotUnlocked

See Also

P4ClientError Class


MsgServer_GotUnresolved Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_GotUnresolved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_GotUnresolved
Visual Basic
Public Shared MsgServer_GotUnresolved As Integer
Visual C++
public:
static int MsgServer_GotUnresolved

See Also

P4ClientError Class


MsgServer_GrepContextTooLarge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_GrepContextTooLarge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_GrepContextTooLarge
Visual Basic
Public Shared MsgServer_GrepContextTooLarge As Integer
Visual C++
public:
static int MsgServer_GrepContextTooLarge

See Also

P4ClientError Class


MsgServer_GrepIllegalContext Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_GrepIllegalContext Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_GrepIllegalContext
Visual Basic
Public Shared MsgServer_GrepIllegalContext As Integer
Visual C++
public:
static int MsgServer_GrepIllegalContext

See Also

P4ClientError Class


MsgServer_HandshakeFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_HandshakeFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_HandshakeFailed
Visual Basic
Public Shared MsgServer_HandshakeFailed As Integer
Visual C++
public:
static int MsgServer_HandshakeFailed

See Also

P4ClientError Class


MsgServer_HelpSeeRename Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_HelpSeeRename Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_HelpSeeRename
Visual Basic
Public Shared MsgServer_HelpSeeRename As Integer
Visual C++
public:
static int MsgServer_HelpSeeRename

See Also

P4ClientError Class


MsgServer_IllegalCommand Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_IllegalCommand Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_IllegalCommand
Visual Basic
Public Shared MsgServer_IllegalCommand As Integer
Visual C++
public:
static int MsgServer_IllegalCommand

See Also

P4ClientError Class


MsgServer_ImportReport Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ImportReport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ImportReport
Visual Basic
Public Shared MsgServer_ImportReport As Integer
Visual C++
public:
static int MsgServer_ImportReport

See Also

P4ClientError Class


MsgServer_IndexOutput Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_IndexOutput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_IndexOutput
Visual Basic
Public Shared MsgServer_IndexOutput As Integer
Visual C++
public:
static int MsgServer_IndexOutput

See Also

P4ClientError Class


MsgServer_InfoAuthServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoAuthServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoAuthServer
Visual Basic
Public Shared MsgServer_InfoAuthServer As Integer
Visual C++
public:
static int MsgServer_InfoAuthServer

See Also

P4ClientError Class


MsgServer_InfoBadClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoBadClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoBadClient
Visual Basic
Public Shared MsgServer_InfoBadClient As Integer
Visual C++
public:
static int MsgServer_InfoBadClient

See Also

P4ClientError Class


MsgServer_InfoBadUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoBadUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoBadUser
Visual Basic
Public Shared MsgServer_InfoBadUser As Integer
Visual C++
public:
static int MsgServer_InfoBadUser

See Also

P4ClientError Class


MsgServer_InfoCaseHandling Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoCaseHandling Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoCaseHandling
Visual Basic
Public Shared MsgServer_InfoCaseHandling As Integer
Visual C++
public:
static int MsgServer_InfoCaseHandling

See Also

P4ClientError Class


MsgServer_InfoChangeServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoChangeServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoChangeServer
Visual Basic
Public Shared MsgServer_InfoChangeServer As Integer
Visual C++
public:
static int MsgServer_InfoChangeServer

See Also

P4ClientError Class


MsgServer_InfoClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoClient
Visual Basic
Public Shared MsgServer_InfoClient As Integer
Visual C++
public:
static int MsgServer_InfoClient

See Also

P4ClientError Class


MsgServer_InfoClientAddress Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoClientAddress Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoClientAddress
Visual Basic
Public Shared MsgServer_InfoClientAddress As Integer
Visual C++
public:
static int MsgServer_InfoClientAddress

See Also

P4ClientError Class


MsgServer_InfoClientRoot Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoClientRoot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoClientRoot
Visual Basic
Public Shared MsgServer_InfoClientRoot As Integer
Visual C++
public:
static int MsgServer_InfoClientRoot

See Also

P4ClientError Class


MsgServer_InfoDirectory Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoDirectory Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoDirectory
Visual Basic
Public Shared MsgServer_InfoDirectory As Integer
Visual C++
public:
static int MsgServer_InfoDirectory

See Also

P4ClientError Class


MsgServer_InfoDiskSpace Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoDiskSpace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoDiskSpace
Visual Basic
Public Shared MsgServer_InfoDiskSpace As Integer
Visual C++
public:
static int MsgServer_InfoDiskSpace

See Also

P4ClientError Class


MsgServer_InfoHost Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoHost Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoHost
Visual Basic
Public Shared MsgServer_InfoHost As Integer
Visual C++
public:
static int MsgServer_InfoHost

See Also

P4ClientError Class


MsgServer_InfoMinClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoMinClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoMinClient
Visual Basic
Public Shared MsgServer_InfoMinClient As Integer
Visual C++
public:
static int MsgServer_InfoMinClient

See Also

P4ClientError Class


MsgServer_InfoPeerAddress Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoPeerAddress Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoPeerAddress
Visual Basic
Public Shared MsgServer_InfoPeerAddress As Integer
Visual C++
public:
static int MsgServer_InfoPeerAddress

See Also

P4ClientError Class


MsgServer_InfoPingCount Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoPingCount Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoPingCount
Visual Basic
Public Shared MsgServer_InfoPingCount As Integer
Visual C++
public:
static int MsgServer_InfoPingCount

See Also

P4ClientError Class


MsgServer_InfoPingCountB Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoPingCountB Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoPingCountB
Visual Basic
Public Shared MsgServer_InfoPingCountB As Integer
Visual C++
public:
static int MsgServer_InfoPingCountB

See Also

P4ClientError Class


MsgServer_InfoPingTime Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoPingTime Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoPingTime
Visual Basic
Public Shared MsgServer_InfoPingTime As Integer
Visual C++
public:
static int MsgServer_InfoPingTime

See Also

P4ClientError Class


MsgServer_InfoPingTimeB Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoPingTimeB Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoPingTimeB
Visual Basic
Public Shared MsgServer_InfoPingTimeB As Integer
Visual C++
public:
static int MsgServer_InfoPingTimeB

See Also

P4ClientError Class


MsgServer_InfoProxyAddress Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoProxyAddress Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoProxyAddress
Visual Basic
Public Shared MsgServer_InfoProxyAddress As Integer
Visual C++
public:
static int MsgServer_InfoProxyAddress

See Also

P4ClientError Class


MsgServer_InfoProxyCertExpire Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoProxyCertExpire Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoProxyCertExpire
Visual Basic
Public Shared MsgServer_InfoProxyCertExpire As Integer
Visual C++
public:
static int MsgServer_InfoProxyCertExpire

See Also

P4ClientError Class


MsgServer_InfoProxyEncryption Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoProxyEncryption Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoProxyEncryption
Visual Basic
Public Shared MsgServer_InfoProxyEncryption As Integer
Visual C++
public:
static int MsgServer_InfoProxyEncryption

See Also

P4ClientError Class


MsgServer_InfoProxyVersion Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoProxyVersion Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoProxyVersion
Visual Basic
Public Shared MsgServer_InfoProxyVersion As Integer
Visual C++
public:
static int MsgServer_InfoProxyVersion

See Also

P4ClientError Class


MsgServer_InfoServerAddress Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerAddress Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerAddress
Visual Basic
Public Shared MsgServer_InfoServerAddress As Integer
Visual C++
public:
static int MsgServer_InfoServerAddress

See Also

P4ClientError Class


MsgServer_InfoServerCertExpire Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerCertExpire Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerCertExpire
Visual Basic
Public Shared MsgServer_InfoServerCertExpire As Integer
Visual C++
public:
static int MsgServer_InfoServerCertExpire

See Also

P4ClientError Class


MsgServer_InfoServerDate Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerDate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerDate
Visual Basic
Public Shared MsgServer_InfoServerDate As Integer
Visual C++
public:
static int MsgServer_InfoServerDate

See Also

P4ClientError Class


MsgServer_InfoServerEncryption Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerEncryption Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerEncryption
Visual Basic
Public Shared MsgServer_InfoServerEncryption As Integer
Visual C++
public:
static int MsgServer_InfoServerEncryption

See Also

P4ClientError Class


MsgServer_InfoServerID Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerID Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerID
Visual Basic
Public Shared MsgServer_InfoServerID As Integer
Visual C++
public:
static int MsgServer_InfoServerID

See Also

P4ClientError Class


MsgServer_InfoServerLicense Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerLicense Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerLicense
Visual Basic
Public Shared MsgServer_InfoServerLicense As Integer
Visual C++
public:
static int MsgServer_InfoServerLicense

See Also

P4ClientError Class


MsgServer_InfoServerLicenseIp Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerLicenseIp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerLicenseIp
Visual Basic
Public Shared MsgServer_InfoServerLicenseIp As Integer
Visual C++
public:
static int MsgServer_InfoServerLicenseIp

See Also

P4ClientError Class


MsgServer_InfoServerRoot Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerRoot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerRoot
Visual Basic
Public Shared MsgServer_InfoServerRoot As Integer
Visual C++
public:
static int MsgServer_InfoServerRoot

See Also

P4ClientError Class


MsgServer_InfoServerUptime Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerUptime Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerUptime
Visual Basic
Public Shared MsgServer_InfoServerUptime As Integer
Visual C++
public:
static int MsgServer_InfoServerUptime

See Also

P4ClientError Class


MsgServer_InfoServerVersion Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoServerVersion Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoServerVersion
Visual Basic
Public Shared MsgServer_InfoServerVersion As Integer
Visual C++
public:
static int MsgServer_InfoServerVersion

See Also

P4ClientError Class


MsgServer_InfoStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoStream
Visual Basic
Public Shared MsgServer_InfoStream As Integer
Visual C++
public:
static int MsgServer_InfoStream

See Also

P4ClientError Class


MsgServer_InfoUnknownClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoUnknownClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoUnknownClient
Visual Basic
Public Shared MsgServer_InfoUnknownClient As Integer
Visual C++
public:
static int MsgServer_InfoUnknownClient

See Also

P4ClientError Class


MsgServer_InfoUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InfoUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InfoUser
Visual Basic
Public Shared MsgServer_InfoUser As Integer
Visual C++
public:
static int MsgServer_InfoUser

See Also

P4ClientError Class


MsgServer_InsecureReplica Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InsecureReplica Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InsecureReplica
Visual Basic
Public Shared MsgServer_InsecureReplica As Integer
Visual C++
public:
static int MsgServer_InsecureReplica

See Also

P4ClientError Class


MsgServer_IntegIsTask Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_IntegIsTask Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_IntegIsTask
Visual Basic
Public Shared MsgServer_IntegIsTask As Integer
Visual C++
public:
static int MsgServer_IntegIsTask

See Also

P4ClientError Class


MsgServer_InvalidConfigValue Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InvalidConfigValue Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InvalidConfigValue
Visual Basic
Public Shared MsgServer_InvalidConfigValue As Integer
Visual C++
public:
static int MsgServer_InvalidConfigValue

See Also

P4ClientError Class


MsgServer_InvalidNesting Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InvalidNesting Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InvalidNesting
Visual Basic
Public Shared MsgServer_InvalidNesting As Integer
Visual C++
public:
static int MsgServer_InvalidNesting

See Also

P4ClientError Class


MsgServer_InvalidServerChain Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InvalidServerChain Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InvalidServerChain
Visual Basic
Public Shared MsgServer_InvalidServerChain As Integer
Visual C++
public:
static int MsgServer_InvalidServerChain

See Also

P4ClientError Class


MsgServer_InvalidStartupCommand Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_InvalidStartupCommand Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_InvalidStartupCommand
Visual Basic
Public Shared MsgServer_InvalidStartupCommand As Integer
Visual C++
public:
static int MsgServer_InvalidStartupCommand

See Also

P4ClientError Class


MsgServer_IstatInvalid Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_IstatInvalid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_IstatInvalid
Visual Basic
Public Shared MsgServer_IstatInvalid As Integer
Visual C++
public:
static int MsgServer_IstatInvalid

See Also

P4ClientError Class


MsgServer_JobRebuilt Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_JobRebuilt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_JobRebuilt
Visual Basic
Public Shared MsgServer_JobRebuilt As Integer
Visual C++
public:
static int MsgServer_JobRebuilt

See Also

P4ClientError Class


MsgServer_Jobs982Win Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Jobs982Win Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Jobs982Win
Visual Basic
Public Shared MsgServer_Jobs982Win As Integer
Visual C++
public:
static int MsgServer_Jobs982Win

See Also

P4ClientError Class


MsgServer_JobsDashS Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_JobsDashS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_JobsDashS
Visual Basic
Public Shared MsgServer_JobsDashS As Integer
Visual C++
public:
static int MsgServer_JobsDashS

See Also

P4ClientError Class


MsgServer_JournalCounterMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_JournalCounterMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_JournalCounterMismatch
Visual Basic
Public Shared MsgServer_JournalCounterMismatch As Integer
Visual C++
public:
static int MsgServer_JournalCounterMismatch

See Also

P4ClientError Class


MsgServer_JournalFilterBad Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_JournalFilterBad Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_JournalFilterBad
Visual Basic
Public Shared MsgServer_JournalFilterBad As Integer
Visual C++
public:
static int MsgServer_JournalFilterBad

See Also

P4ClientError Class


MsgServer_JournalorCheckpointRequired Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_JournalorCheckpointRequired Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_JournalorCheckpointRequired
Visual Basic
Public Shared MsgServer_JournalorCheckpointRequired As Integer
Visual C++
public:
static int MsgServer_JournalorCheckpointRequired

See Also

P4ClientError Class


MsgServer_KeyDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_KeyDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_KeyDelete
Visual Basic
Public Shared MsgServer_KeyDelete As Integer
Visual C++
public:
static int MsgServer_KeyDelete

See Also

P4ClientError Class


MsgServer_KeyNotNumeric Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_KeyNotNumeric Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_KeyNotNumeric
Visual Basic
Public Shared MsgServer_KeyNotNumeric As Integer
Visual C++
public:
static int MsgServer_KeyNotNumeric

See Also

P4ClientError Class


MsgServer_KeySet Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_KeySet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_KeySet
Visual Basic
Public Shared MsgServer_KeySet As Integer
Visual C++
public:
static int MsgServer_KeySet

See Also

P4ClientError Class


MsgServer_LbrCheckin Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LbrCheckin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LbrCheckin
Visual Basic
Public Shared MsgServer_LbrCheckin As Integer
Visual C++
public:
static int MsgServer_LbrCheckin

See Also

P4ClientError Class


MsgServer_LbrCheckout Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LbrCheckout Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LbrCheckout
Visual Basic
Public Shared MsgServer_LbrCheckout As Integer
Visual C++
public:
static int MsgServer_LbrCheckout

See Also

P4ClientError Class


MsgServer_LbrDiff Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LbrDiff Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LbrDiff
Visual Basic
Public Shared MsgServer_LbrDiff As Integer
Visual C++
public:
static int MsgServer_LbrDiff

See Also

P4ClientError Class


MsgServer_LbrDigest Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LbrDigest Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LbrDigest
Visual Basic
Public Shared MsgServer_LbrDigest As Integer
Visual C++
public:
static int MsgServer_LbrDigest

See Also

P4ClientError Class


MsgServer_LbrFileSize Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LbrFileSize Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LbrFileSize
Visual Basic
Public Shared MsgServer_LbrFileSize As Integer
Visual C++
public:
static int MsgServer_LbrFileSize

See Also

P4ClientError Class


MsgServer_LbrMerge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LbrMerge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LbrMerge
Visual Basic
Public Shared MsgServer_LbrMerge As Integer
Visual C++
public:
static int MsgServer_LbrMerge

See Also

P4ClientError Class


MsgServer_LbrNoTrigger Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LbrNoTrigger Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LbrNoTrigger
Visual Basic
Public Shared MsgServer_LbrNoTrigger As Integer
Visual C++
public:
static int MsgServer_LbrNoTrigger

See Also

P4ClientError Class


MsgServer_LogCommand Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LogCommand Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LogCommand
Visual Basic
Public Shared MsgServer_LogCommand As Integer
Visual C++
public:
static int MsgServer_LogCommand

See Also

P4ClientError Class


MsgServer_LogEstimates Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LogEstimates Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LogEstimates
Visual Basic
Public Shared MsgServer_LogEstimates As Integer
Visual C++
public:
static int MsgServer_LogEstimates

See Also

P4ClientError Class


MsgServer_LoggedOut Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LoggedOut Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LoggedOut
Visual Basic
Public Shared MsgServer_LoggedOut As Integer
Visual C++
public:
static int MsgServer_LoggedOut

See Also

P4ClientError Class


MsgServer_Login032 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Login032 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Login032
Visual Basic
Public Shared MsgServer_Login032 As Integer
Visual C++
public:
static int MsgServer_Login032

See Also

P4ClientError Class


MsgServer_Login042 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Login042 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Login042
Visual Basic
Public Shared MsgServer_Login042 As Integer
Visual C++
public:
static int MsgServer_Login042

See Also

P4ClientError Class


MsgServer_Login072 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Login072 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Login072
Visual Basic
Public Shared MsgServer_Login072 As Integer
Visual C++
public:
static int MsgServer_Login072

See Also

P4ClientError Class


MsgServer_LoginExpired Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LoginExpired Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LoginExpired
Visual Basic
Public Shared MsgServer_LoginExpired As Integer
Visual C++
public:
static int MsgServer_LoginExpired

See Also

P4ClientError Class


MsgServer_LoginGoodTill Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LoginGoodTill Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LoginGoodTill
Visual Basic
Public Shared MsgServer_LoginGoodTill As Integer
Visual C++
public:
static int MsgServer_LoginGoodTill

See Also

P4ClientError Class


MsgServer_LoginNoTicket Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LoginNoTicket Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LoginNoTicket
Visual Basic
Public Shared MsgServer_LoginNoTicket As Integer
Visual C++
public:
static int MsgServer_LoginNoTicket

See Also

P4ClientError Class


MsgServer_LoginNotRequired Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LoginNotRequired Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LoginNotRequired
Visual Basic
Public Shared MsgServer_LoginNotRequired As Integer
Visual C++
public:
static int MsgServer_LoginNotRequired

See Also

P4ClientError Class


MsgServer_LoginPrintTicket Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LoginPrintTicket Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LoginPrintTicket
Visual Basic
Public Shared MsgServer_LoginPrintTicket As Integer
Visual C++
public:
static int MsgServer_LoginPrintTicket

See Also

P4ClientError Class


MsgServer_LoginUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LoginUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LoginUser
Visual Basic
Public Shared MsgServer_LoginUser As Integer
Visual C++
public:
static int MsgServer_LoginUser

See Also

P4ClientError Class


MsgServer_LogoutUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LogoutUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LogoutUser
Visual Basic
Public Shared MsgServer_LogoutUser As Integer
Visual C++
public:
static int MsgServer_LogoutUser

See Also

P4ClientError Class


MsgServer_LogtailNoLog Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_LogtailNoLog Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_LogtailNoLog
Visual Basic
Public Shared MsgServer_LogtailNoLog As Integer
Visual C++
public:
static int MsgServer_LogtailNoLog

See Also

P4ClientError Class


MsgServer_MaxLicensedFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MaxLicensedFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MaxLicensedFiles
Visual Basic
Public Shared MsgServer_MaxLicensedFiles As Integer
Visual C++
public:
static int MsgServer_MaxLicensedFiles

See Also

P4ClientError Class


MsgServer_MaxUnLicensedFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MaxUnLicensedFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MaxUnLicensedFiles
Visual Basic
Public Shared MsgServer_MaxUnLicensedFiles As Integer
Visual C++
public:
static int MsgServer_MaxUnLicensedFiles

See Also

P4ClientError Class


MsgServer_MergesPending Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MergesPending Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MergesPending
Visual Basic
Public Shared MsgServer_MergesPending As Integer
Visual C++
public:
static int MsgServer_MergesPending

See Also

P4ClientError Class


MsgServer_MergeWrongDirection Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MergeWrongDirection Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MergeWrongDirection
Visual Basic
Public Shared MsgServer_MergeWrongDirection As Integer
Visual C++
public:
static int MsgServer_MergeWrongDirection

See Also

P4ClientError Class


MsgServer_MetaDumpFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MetaDumpFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MetaDumpFailed
Visual Basic
Public Shared MsgServer_MetaDumpFailed As Integer
Visual C++
public:
static int MsgServer_MetaDumpFailed

See Also

P4ClientError Class


MsgServer_MimAttack Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MimAttack Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MimAttack
Visual Basic
Public Shared MsgServer_MimAttack As Integer
Visual C++
public:
static int MsgServer_MimAttack

See Also

P4ClientError Class


MsgServer_MissingReplicationMode Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MissingReplicationMode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MissingReplicationMode
Visual Basic
Public Shared MsgServer_MissingReplicationMode As Integer
Visual C++
public:
static int MsgServer_MissingReplicationMode

See Also

P4ClientError Class


MsgServer_MonitorBadId Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MonitorBadId Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MonitorBadId
Visual Basic
Public Shared MsgServer_MonitorBadId As Integer
Visual C++
public:
static int MsgServer_MonitorBadId

See Also

P4ClientError Class


MsgServer_MonitorDisabled Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MonitorDisabled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MonitorDisabled
Visual Basic
Public Shared MsgServer_MonitorDisabled As Integer
Visual C++
public:
static int MsgServer_MonitorDisabled

See Also

P4ClientError Class


MsgServer_MonitorNoLockinfo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MonitorNoLockinfo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MonitorNoLockinfo
Visual Basic
Public Shared MsgServer_MonitorNoLockinfo As Integer
Visual C++
public:
static int MsgServer_MonitorNoLockinfo

See Also

P4ClientError Class


MsgServer_Move091 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Move091 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Move091
Visual Basic
Public Shared MsgServer_Move091 As Integer
Visual C++
public:
static int MsgServer_Move091

See Also

P4ClientError Class


MsgServer_Move101 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Move101 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Move101
Visual Basic
Public Shared MsgServer_Move101 As Integer
Visual C++
public:
static int MsgServer_Move101

See Also

P4ClientError Class


MsgServer_MoveRejected Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MoveRejected Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MoveRejected
Visual Basic
Public Shared MsgServer_MoveRejected As Integer
Visual C++
public:
static int MsgServer_MoveRejected

See Also

P4ClientError Class


MsgServer_MustSetPassword Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_MustSetPassword Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_MustSetPassword
Visual Basic
Public Shared MsgServer_MustSetPassword As Integer
Visual C++
public:
static int MsgServer_MustSetPassword

See Also

P4ClientError Class


MsgServer_NeedFilePath Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NeedFilePath Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NeedFilePath
Visual Basic
Public Shared MsgServer_NeedFilePath As Integer
Visual C++
public:
static int MsgServer_NeedFilePath

See Also

P4ClientError Class


MsgServer_NewUserExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NewUserExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NewUserExists
Visual Basic
Public Shared MsgServer_NewUserExists As Integer
Visual C++
public:
static int MsgServer_NewUserExists

See Also

P4ClientError Class


MsgServer_NewUserHasChanges Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NewUserHasChanges Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NewUserHasChanges
Visual Basic
Public Shared MsgServer_NewUserHasChanges As Integer
Visual C++
public:
static int MsgServer_NewUserHasChanges

See Also

P4ClientError Class


MsgServer_NewUserHasDomains Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NewUserHasDomains Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NewUserHasDomains
Visual Basic
Public Shared MsgServer_NewUserHasDomains As Integer
Visual C++
public:
static int MsgServer_NewUserHasDomains

See Also

P4ClientError Class


MsgServer_No973Wingui Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_No973Wingui Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_No973Wingui
Visual Basic
Public Shared MsgServer_No973Wingui As Integer
Visual C++
public:
static int MsgServer_No973Wingui

See Also

P4ClientError Class


MsgServer_NoAuthFileCount Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoAuthFileCount Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoAuthFileCount
Visual Basic
Public Shared MsgServer_NoAuthFileCount As Integer
Visual C++
public:
static int MsgServer_NoAuthFileCount

See Also

P4ClientError Class


MsgServer_NoAuthServiceOnly Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoAuthServiceOnly Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoAuthServiceOnly
Visual Basic
Public Shared MsgServer_NoAuthServiceOnly As Integer
Visual C++
public:
static int MsgServer_NoAuthServiceOnly

See Also

P4ClientError Class


MsgServer_NoCentralLicense Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoCentralLicense Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoCentralLicense
Visual Basic
Public Shared MsgServer_NoCentralLicense As Integer
Visual C++
public:
static int MsgServer_NoCentralLicense

See Also

P4ClientError Class


MsgServer_NoCkptName Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoCkptName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoCkptName
Visual Basic
Public Shared MsgServer_NoCkptName As Integer
Visual C++
public:
static int MsgServer_NoCkptName

See Also

P4ClientError Class


MsgServer_NoClearText Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoClearText Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoClearText
Visual Basic
Public Shared MsgServer_NoClearText As Integer
Visual C++
public:
static int MsgServer_NoClearText

See Also

P4ClientError Class


MsgServer_NoCustomSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoCustomSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoCustomSpec
Visual Basic
Public Shared MsgServer_NoCustomSpec As Integer
Visual C++
public:
static int MsgServer_NoCustomSpec

See Also

P4ClientError Class


MsgServer_NoDefaultShelve Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoDefaultShelve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoDefaultShelve
Visual Basic
Public Shared MsgServer_NoDefaultShelve As Integer
Visual C++
public:
static int MsgServer_NoDefaultShelve

See Also

P4ClientError Class


MsgServer_NoDefaultSubmit Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoDefaultSubmit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoDefaultSubmit
Visual Basic
Public Shared MsgServer_NoDefaultSubmit As Integer
Visual C++
public:
static int MsgServer_NoDefaultSubmit

See Also

P4ClientError Class


MsgServer_NoDumpName Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoDumpName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoDumpName
Visual Basic
Public Shared MsgServer_NoDumpName As Integer
Visual C++
public:
static int MsgServer_NoDumpName

See Also

P4ClientError Class


MsgServer_NoInteg Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoInteg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoInteg
Visual Basic
Public Shared MsgServer_NoInteg As Integer
Visual C++
public:
static int MsgServer_NoInteg

See Also

P4ClientError Class


MsgServer_NoProxyAuth Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoProxyAuth Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoProxyAuth
Visual Basic
Public Shared MsgServer_NoProxyAuth As Integer
Visual C++
public:
static int MsgServer_NoProxyAuth

See Also

P4ClientError Class


MsgServer_NoReparentingTask Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoReparentingTask Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoReparentingTask
Visual Basic
Public Shared MsgServer_NoReparentingTask As Integer
Visual C++
public:
static int MsgServer_NoReparentingTask

See Also

P4ClientError Class


MsgServer_NoServerID Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoServerID Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoServerID
Visual Basic
Public Shared MsgServer_NoServerID As Integer
Visual C++
public:
static int MsgServer_NoServerID

See Also

P4ClientError Class


MsgServer_NoShelve Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoShelve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoShelve
Visual Basic
Public Shared MsgServer_NoShelve As Integer
Visual C++
public:
static int MsgServer_NoShelve

See Also

P4ClientError Class


MsgServer_NoShelveDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoShelveDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoShelveDelete
Visual Basic
Public Shared MsgServer_NoShelveDelete As Integer
Visual C++
public:
static int MsgServer_NoShelveDelete

See Also

P4ClientError Class


MsgServer_NoSubmit Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoSubmit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoSubmit
Visual Basic
Public Shared MsgServer_NoSubmit As Integer
Visual C++
public:
static int MsgServer_NoSubmit

See Also

P4ClientError Class


MsgServer_NoSuchField Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoSuchField Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoSuchField
Visual Basic
Public Shared MsgServer_NoSuchField As Integer
Visual C++
public:
static int MsgServer_NoSuchField

See Also

P4ClientError Class


MsgServer_NoSuchTransfer Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoSuchTransfer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoSuchTransfer
Visual Basic
Public Shared MsgServer_NoSuchTransfer As Integer
Visual C++
public:
static int MsgServer_NoSuchTransfer

See Also

P4ClientError Class


MsgServer_NoSuchUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoSuchUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoSuchUser
Visual Basic
Public Shared MsgServer_NoSuchUser As Integer
Visual C++
public:
static int MsgServer_NoSuchUser

See Also

P4ClientError Class


MsgServer_NoSuppASflag Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoSuppASflag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoSuppASflag
Visual Basic
Public Shared MsgServer_NoSuppASflag As Integer
Visual C++
public:
static int MsgServer_NoSuppASflag

See Also

P4ClientError Class


MsgServer_NoSuppVflag Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoSuppVflag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoSuppVflag
Visual Basic
Public Shared MsgServer_NoSuppVflag As Integer
Visual C++
public:
static int MsgServer_NoSuppVflag

See Also

P4ClientError Class


MsgServer_NotACommitServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotACommitServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotACommitServer
Visual Basic
Public Shared MsgServer_NotACommitServer As Integer
Visual C++
public:
static int MsgServer_NotACommitServer

See Also

P4ClientError Class


MsgServer_NotAsService Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotAsService Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotAsService
Visual Basic
Public Shared MsgServer_NotAsService As Integer
Visual C++
public:
static int MsgServer_NotAsService

See Also

P4ClientError Class


MsgServer_NotClusterMaster Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotClusterMaster Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotClusterMaster
Visual Basic
Public Shared MsgServer_NotClusterMaster As Integer
Visual C++
public:
static int MsgServer_NotClusterMaster

See Also

P4ClientError Class


MsgServer_NotClusterReplica Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotClusterReplica Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotClusterReplica
Visual Basic
Public Shared MsgServer_NotClusterReplica As Integer
Visual C++
public:
static int MsgServer_NotClusterReplica

See Also

P4ClientError Class


MsgServer_NotClusterService Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotClusterService Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotClusterService
Visual Basic
Public Shared MsgServer_NotClusterService As Integer
Visual C++
public:
static int MsgServer_NotClusterService

See Also

P4ClientError Class


MsgServer_NotDistributed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotDistributed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotDistributed
Visual Basic
Public Shared MsgServer_NotDistributed As Integer
Visual C++
public:
static int MsgServer_NotDistributed

See Also

P4ClientError Class


MsgServer_NotEdgeLocal Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotEdgeLocal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotEdgeLocal
Visual Basic
Public Shared MsgServer_NotEdgeLocal As Integer
Visual C++
public:
static int MsgServer_NotEdgeLocal

See Also

P4ClientError Class


MsgServer_NoTicketSupport Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoTicketSupport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoTicketSupport
Visual Basic
Public Shared MsgServer_NoTicketSupport As Integer
Visual C++
public:
static int MsgServer_NoTicketSupport

See Also

P4ClientError Class


MsgServer_NotInCluster Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotInCluster Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotInCluster
Visual Basic
Public Shared MsgServer_NotInCluster As Integer
Visual C++
public:
static int MsgServer_NotInCluster

See Also

P4ClientError Class


MsgServer_NotStreamOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotStreamOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotStreamOwner
Visual Basic
Public Shared MsgServer_NotStreamOwner As Integer
Visual C++
public:
static int MsgServer_NotStreamOwner

See Also

P4ClientError Class


MsgServer_NotStreamReady Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotStreamReady Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotStreamReady
Visual Basic
Public Shared MsgServer_NotStreamReady As Integer
Visual C++
public:
static int MsgServer_NotStreamReady

See Also

P4ClientError Class


MsgServer_NotThisConfigVar Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NotThisConfigVar Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NotThisConfigVar
Visual Basic
Public Shared MsgServer_NotThisConfigVar As Integer
Visual C++
public:
static int MsgServer_NotThisConfigVar

See Also

P4ClientError Class


MsgServer_NoUserLogs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoUserLogs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoUserLogs
Visual Basic
Public Shared MsgServer_NoUserLogs As Integer
Visual C++
public:
static int MsgServer_NoUserLogs

See Also

P4ClientError Class


MsgServer_NoValidLicense Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_NoValidLicense Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_NoValidLicense
Visual Basic
Public Shared MsgServer_NoValidLicense As Integer
Visual C++
public:
static int MsgServer_NoValidLicense

See Also

P4ClientError Class


MsgServer_OldDiffClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_OldDiffClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_OldDiffClient
Visual Basic
Public Shared MsgServer_OldDiffClient As Integer
Visual C++
public:
static int MsgServer_OldDiffClient

See Also

P4ClientError Class


MsgServer_OldReconcileClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_OldReconcileClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_OldReconcileClient
Visual Basic
Public Shared MsgServer_OldReconcileClient As Integer
Visual C++
public:
static int MsgServer_OldReconcileClient

See Also

P4ClientError Class


MsgServer_OnlyOneFilter Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_OnlyOneFilter Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_OnlyOneFilter
Visual Basic
Public Shared MsgServer_OnlyOneFilter As Integer
Visual C++
public:
static int MsgServer_OnlyOneFilter

See Also

P4ClientError Class


MsgServer_OperationDate Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_OperationDate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_OperationDate
Visual Basic
Public Shared MsgServer_OperationDate As Integer
Visual C++
public:
static int MsgServer_OperationDate

See Also

P4ClientError Class


MsgServer_OperationFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_OperationFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_OperationFailed
Visual Basic
Public Shared MsgServer_OperationFailed As Integer
Visual C++
public:
static int MsgServer_OperationFailed

See Also

P4ClientError Class


MsgServer_P4TARGETWasSet Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_P4TARGETWasSet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_P4TARGETWasSet
Visual Basic
Public Shared MsgServer_P4TARGETWasSet As Integer
Visual C++
public:
static int MsgServer_P4TARGETWasSet

See Also

P4ClientError Class


MsgServer_Password032 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Password032 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Password032
Visual Basic
Public Shared MsgServer_Password032 As Integer
Visual C++
public:
static int MsgServer_Password032

See Also

P4ClientError Class


MsgServer_Password982 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Password982 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Password982
Visual Basic
Public Shared MsgServer_Password982 As Integer
Visual C++
public:
static int MsgServer_Password982

See Also

P4ClientError Class


MsgServer_Password991 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Password991 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Password991
Visual Basic
Public Shared MsgServer_Password991 As Integer
Visual C++
public:
static int MsgServer_Password991

See Also

P4ClientError Class


MsgServer_PasswordDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordDelete
Visual Basic
Public Shared MsgServer_PasswordDelete As Integer
Visual C++
public:
static int MsgServer_PasswordDelete

See Also

P4ClientError Class


MsgServer_PasswordExpired Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordExpired Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordExpired
Visual Basic
Public Shared MsgServer_PasswordExpired As Integer
Visual C++
public:
static int MsgServer_PasswordExpired

See Also

P4ClientError Class


MsgServer_PasswordNoChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordNoChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordNoChange
Visual Basic
Public Shared MsgServer_PasswordNoChange As Integer
Visual C++
public:
static int MsgServer_PasswordNoChange

See Also

P4ClientError Class


MsgServer_PasswordSave Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordSave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordSave
Visual Basic
Public Shared MsgServer_PasswordSave As Integer
Visual C++
public:
static int MsgServer_PasswordSave

See Also

P4ClientError Class


MsgServer_PasswordTooLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordTooLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordTooLong
Visual Basic
Public Shared MsgServer_PasswordTooLong As Integer
Visual C++
public:
static int MsgServer_PasswordTooLong

See Also

P4ClientError Class


MsgServer_PasswordTooShort Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordTooShort Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordTooShort
Visual Basic
Public Shared MsgServer_PasswordTooShort As Integer
Visual C++
public:
static int MsgServer_PasswordTooShort

See Also

P4ClientError Class


MsgServer_PasswordTooShort2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordTooShort2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordTooShort2
Visual Basic
Public Shared MsgServer_PasswordTooShort2 As Integer
Visual C++
public:
static int MsgServer_PasswordTooShort2

See Also

P4ClientError Class


MsgServer_PasswordTooSimple Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PasswordTooSimple Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PasswordTooSimple
Visual Basic
Public Shared MsgServer_PasswordTooSimple As Integer
Visual C++
public:
static int MsgServer_PasswordTooSimple

See Also

P4ClientError Class


MsgServer_PopulateAborted Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PopulateAborted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PopulateAborted
Visual Basic
Public Shared MsgServer_PopulateAborted As Integer
Visual C++
public:
static int MsgServer_PopulateAborted

See Also

P4ClientError Class


MsgServer_PopulateComplete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PopulateComplete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PopulateComplete
Visual Basic
Public Shared MsgServer_PopulateComplete As Integer
Visual C++
public:
static int MsgServer_PopulateComplete

See Also

P4ClientError Class


MsgServer_PopulateIsVirtual Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PopulateIsVirtual Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PopulateIsVirtual
Visual Basic
Public Shared MsgServer_PopulateIsVirtual As Integer
Visual C++
public:
static int MsgServer_PopulateIsVirtual

See Also

P4ClientError Class


MsgServer_PortMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PortMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PortMissing
Visual Basic
Public Shared MsgServer_PortMissing As Integer
Visual C++
public:
static int MsgServer_PortMissing

See Also

P4ClientError Class


MsgServer_PropertyAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PropertyAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PropertyAdd
Visual Basic
Public Shared MsgServer_PropertyAdd As Integer
Visual C++
public:
static int MsgServer_PropertyAdd

See Also

P4ClientError Class


MsgServer_PropertyDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PropertyDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PropertyDelete
Visual Basic
Public Shared MsgServer_PropertyDelete As Integer
Visual C++
public:
static int MsgServer_PropertyDelete

See Also

P4ClientError Class


MsgServer_ProxyChain Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ProxyChain Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ProxyChain
Visual Basic
Public Shared MsgServer_ProxyChain As Integer
Visual C++
public:
static int MsgServer_ProxyChain

See Also

P4ClientError Class


MsgServer_ProxyDelivered Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ProxyDelivered Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ProxyDelivered
Visual Basic
Public Shared MsgServer_ProxyDelivered As Integer
Visual C++
public:
static int MsgServer_ProxyDelivered

See Also

P4ClientError Class


MsgServer_ProxyNoRemote Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ProxyNoRemote Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ProxyNoRemote
Visual Basic
Public Shared MsgServer_ProxyNoRemote As Integer
Visual C++
public:
static int MsgServer_ProxyNoRemote

See Also

P4ClientError Class


MsgServer_ProxyUpdateFail Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ProxyUpdateFail Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ProxyUpdateFail
Visual Basic
Public Shared MsgServer_ProxyUpdateFail As Integer
Visual C++
public:
static int MsgServer_ProxyUpdateFail

See Also

P4ClientError Class


MsgServer_PullCommandRunning Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullCommandRunning Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullCommandRunning
Visual Basic
Public Shared MsgServer_PullCommandRunning As Integer
Visual C++
public:
static int MsgServer_PullCommandRunning

See Also

P4ClientError Class


MsgServer_PullJournalDate Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullJournalDate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullJournalDate
Visual Basic
Public Shared MsgServer_PullJournalDate As Integer
Visual C++
public:
static int MsgServer_PullJournalDate

See Also

P4ClientError Class


MsgServer_PullJournalSummary Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullJournalSummary Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullJournalSummary
Visual Basic
Public Shared MsgServer_PullJournalSummary As Integer
Visual C++
public:
static int MsgServer_PullJournalSummary

See Also

P4ClientError Class


MsgServer_PullNotReplica Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullNotReplica Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullNotReplica
Visual Basic
Public Shared MsgServer_PullNotReplica As Integer
Visual C++
public:
static int MsgServer_PullNotReplica

See Also

P4ClientError Class


MsgServer_PullOnDemand Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullOnDemand Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullOnDemand
Visual Basic
Public Shared MsgServer_PullOnDemand As Integer
Visual C++
public:
static int MsgServer_PullOnDemand

See Also

P4ClientError Class


MsgServer_PullTransferChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullTransferChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullTransferChange
Visual Basic
Public Shared MsgServer_PullTransferChange As Integer
Visual C++
public:
static int MsgServer_PullTransferChange

See Also

P4ClientError Class


MsgServer_PullTransferPending Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullTransferPending Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullTransferPending
Visual Basic
Public Shared MsgServer_PullTransferPending As Integer
Visual C++
public:
static int MsgServer_PullTransferPending

See Also

P4ClientError Class


MsgServer_PullTransferSummary Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PullTransferSummary Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PullTransferSummary
Visual Basic
Public Shared MsgServer_PullTransferSummary As Integer
Visual C++
public:
static int MsgServer_PullTransferSummary

See Also

P4ClientError Class


MsgServer_PurgeBadOption Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PurgeBadOption Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PurgeBadOption
Visual Basic
Public Shared MsgServer_PurgeBadOption As Integer
Visual C++
public:
static int MsgServer_PurgeBadOption

See Also

P4ClientError Class


MsgServer_PurgeOptGone Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PurgeOptGone Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PurgeOptGone
Visual Basic
Public Shared MsgServer_PurgeOptGone As Integer
Visual C++
public:
static int MsgServer_PurgeOptGone

See Also

P4ClientError Class


MsgServer_PurgeReport Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PurgeReport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PurgeReport
Visual Basic
Public Shared MsgServer_PurgeReport As Integer
Visual C++
public:
static int MsgServer_PurgeReport

See Also

P4ClientError Class


MsgServer_PurgeWarning Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_PurgeWarning Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_PurgeWarning
Visual Basic
Public Shared MsgServer_PurgeWarning As Integer
Visual C++
public:
static int MsgServer_PurgeWarning

See Also

P4ClientError Class


MsgServer_QuiesceFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_QuiesceFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_QuiesceFailed
Visual Basic
Public Shared MsgServer_QuiesceFailed As Integer
Visual C++
public:
static int MsgServer_QuiesceFailed

See Also

P4ClientError Class


MsgServer_Quiescing Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Quiescing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Quiescing
Visual Basic
Public Shared MsgServer_Quiescing As Integer
Visual C++
public:
static int MsgServer_Quiescing

See Also

P4ClientError Class


MsgServer_ReDowngrade Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReDowngrade Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReDowngrade
Visual Basic
Public Shared MsgServer_ReDowngrade As Integer
Visual C++
public:
static int MsgServer_ReDowngrade

See Also

P4ClientError Class


MsgServer_RemoteInvalidCmd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_RemoteInvalidCmd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_RemoteInvalidCmd
Visual Basic
Public Shared MsgServer_RemoteInvalidCmd As Integer
Visual C++
public:
static int MsgServer_RemoteInvalidCmd

See Also

P4ClientError Class


MsgServer_RemoteNotAllowed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_RemoteNotAllowed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_RemoteNotAllowed
Visual Basic
Public Shared MsgServer_RemoteNotAllowed As Integer
Visual C++
public:
static int MsgServer_RemoteNotAllowed

See Also

P4ClientError Class


MsgServer_ReopenNotOwnerCL Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReopenNotOwnerCL Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReopenNotOwnerCL
Visual Basic
Public Shared MsgServer_ReopenNotOwnerCL As Integer
Visual C++
public:
static int MsgServer_ReopenNotOwnerCL

See Also

P4ClientError Class


MsgServer_ReplicaBadOption Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaBadOption Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaBadOption
Visual Basic
Public Shared MsgServer_ReplicaBadOption As Integer
Visual C++
public:
static int MsgServer_ReplicaBadOption

See Also

P4ClientError Class


MsgServer_ReplicaNoUpgrade Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaNoUpgrade Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaNoUpgrade
Visual Basic
Public Shared MsgServer_ReplicaNoUpgrade As Integer
Visual C++
public:
static int MsgServer_ReplicaNoUpgrade

See Also

P4ClientError Class


MsgServer_ReplicaRestricted Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaRestricted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaRestricted
Visual Basic
Public Shared MsgServer_ReplicaRestricted As Integer
Visual C++
public:
static int MsgServer_ReplicaRestricted

See Also

P4ClientError Class


MsgServer_ReplicaServerTime Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaServerTime Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaServerTime
Visual Basic
Public Shared MsgServer_ReplicaServerTime As Integer
Visual C++
public:
static int MsgServer_ReplicaServerTime

See Also

P4ClientError Class


MsgServer_ReplicaWrongClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaWrongClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaWrongClient
Visual Basic
Public Shared MsgServer_ReplicaWrongClient As Integer
Visual C++
public:
static int MsgServer_ReplicaWrongClient

See Also

P4ClientError Class


MsgServer_ReplicaWrongLabel Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaWrongLabel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaWrongLabel
Visual Basic
Public Shared MsgServer_ReplicaWrongLabel As Integer
Visual C++
public:
static int MsgServer_ReplicaWrongLabel

See Also

P4ClientError Class


MsgServer_ReplicaWrongServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaWrongServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaWrongServer
Visual Basic
Public Shared MsgServer_ReplicaWrongServer As Integer
Visual C++
public:
static int MsgServer_ReplicaWrongServer

See Also

P4ClientError Class


MsgServer_ReplicaXferFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ReplicaXferFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ReplicaXferFailed
Visual Basic
Public Shared MsgServer_ReplicaXferFailed As Integer
Visual C++
public:
static int MsgServer_ReplicaXferFailed

See Also

P4ClientError Class


MsgServer_RequiresJournaling Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_RequiresJournaling Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_RequiresJournaling
Visual Basic
Public Shared MsgServer_RequiresJournaling As Integer
Visual C++
public:
static int MsgServer_RequiresJournaling

See Also

P4ClientError Class


MsgServer_ResolvedFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolvedFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolvedFile
Visual Basic
Public Shared MsgServer_ResolvedFile As Integer
Visual C++
public:
static int MsgServer_ResolvedFile

See Also

P4ClientError Class


MsgServer_ResolvedSkipped Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolvedSkipped Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolvedSkipped
Visual Basic
Public Shared MsgServer_ResolvedSkipped As Integer
Visual C++
public:
static int MsgServer_ResolvedSkipped

See Also

P4ClientError Class


MsgServer_ResolveOptAuto Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveOptAuto Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveOptAuto
Visual Basic
Public Shared MsgServer_ResolveOptAuto As Integer
Visual C++
public:
static int MsgServer_ResolveOptAuto

See Also

P4ClientError Class


MsgServer_ResolveOptHelp Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveOptHelp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveOptHelp
Visual Basic
Public Shared MsgServer_ResolveOptHelp As Integer
Visual C++
public:
static int MsgServer_ResolveOptHelp

See Also

P4ClientError Class


MsgServer_ResolveOptMerge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveOptMerge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveOptMerge
Visual Basic
Public Shared MsgServer_ResolveOptMerge As Integer
Visual C++
public:
static int MsgServer_ResolveOptMerge

See Also

P4ClientError Class


MsgServer_ResolveOptSkip Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveOptSkip Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveOptSkip
Visual Basic
Public Shared MsgServer_ResolveOptSkip As Integer
Visual C++
public:
static int MsgServer_ResolveOptSkip

See Also

P4ClientError Class


MsgServer_ResolveOptTheirs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveOptTheirs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveOptTheirs
Visual Basic
Public Shared MsgServer_ResolveOptTheirs As Integer
Visual C++
public:
static int MsgServer_ResolveOptTheirs

See Also

P4ClientError Class


MsgServer_ResolveOptYours Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveOptYours Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveOptYours
Visual Basic
Public Shared MsgServer_ResolveOptYours As Integer
Visual C++
public:
static int MsgServer_ResolveOptYours

See Also

P4ClientError Class


MsgServer_ResolveOrRevert Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveOrRevert Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveOrRevert
Visual Basic
Public Shared MsgServer_ResolveOrRevert As Integer
Visual C++
public:
static int MsgServer_ResolveOrRevert

See Also

P4ClientError Class


MsgServer_ResolvePromptMerge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolvePromptMerge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolvePromptMerge
Visual Basic
Public Shared MsgServer_ResolvePromptMerge As Integer
Visual C++
public:
static int MsgServer_ResolvePromptMerge

See Also

P4ClientError Class


MsgServer_ResolvePromptTheirs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolvePromptTheirs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolvePromptTheirs
Visual Basic
Public Shared MsgServer_ResolvePromptTheirs As Integer
Visual C++
public:
static int MsgServer_ResolvePromptTheirs

See Also

P4ClientError Class


MsgServer_ResolvePromptType Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolvePromptType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolvePromptType
Visual Basic
Public Shared MsgServer_ResolvePromptType As Integer
Visual C++
public:
static int MsgServer_ResolvePromptType

See Also

P4ClientError Class


MsgServer_ResolvePromptYours Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolvePromptYours Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolvePromptYours
Visual Basic
Public Shared MsgServer_ResolvePromptYours As Integer
Visual C++
public:
static int MsgServer_ResolvePromptYours

See Also

P4ClientError Class


MsgServer_ResolveTampered Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveTampered Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveTampered
Visual Basic
Public Shared MsgServer_ResolveTampered As Integer
Visual C++
public:
static int MsgServer_ResolveTampered

See Also

P4ClientError Class


MsgServer_ResolveUserError Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveUserError Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveUserError
Visual Basic
Public Shared MsgServer_ResolveUserError As Integer
Visual C++
public:
static int MsgServer_ResolveUserError

See Also

P4ClientError Class


MsgServer_ResolveUserPrompt Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveUserPrompt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveUserPrompt
Visual Basic
Public Shared MsgServer_ResolveUserPrompt As Integer
Visual C++
public:
static int MsgServer_ResolveUserPrompt

See Also

P4ClientError Class


MsgServer_ResolveUserPrompt2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ResolveUserPrompt2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ResolveUserPrompt2
Visual Basic
Public Shared MsgServer_ResolveUserPrompt2 As Integer
Visual C++
public:
static int MsgServer_ResolveUserPrompt2

See Also

P4ClientError Class


MsgServer_Restarted Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Restarted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Restarted
Visual Basic
Public Shared MsgServer_Restarted As Integer
Visual C++
public:
static int MsgServer_Restarted

See Also

P4ClientError Class


MsgServer_Restarting Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Restarting Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Restarting
Visual Basic
Public Shared MsgServer_Restarting As Integer
Visual C++
public:
static int MsgServer_Restarting

See Also

P4ClientError Class


MsgServer_RetypeInvalidTempobj Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_RetypeInvalidTempobj Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_RetypeInvalidTempobj
Visual Basic
Public Shared MsgServer_RetypeInvalidTempobj As Integer
Visual C++
public:
static int MsgServer_RetypeInvalidTempobj

See Also

P4ClientError Class


MsgServer_RmtAuthFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_RmtAuthFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_RmtAuthFailed
Visual Basic
Public Shared MsgServer_RmtAuthFailed As Integer
Visual C++
public:
static int MsgServer_RmtAuthFailed

See Also

P4ClientError Class


MsgServer_SearchResult Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SearchResult Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SearchResult
Visual Basic
Public Shared MsgServer_SearchResult As Integer
Visual C++
public:
static int MsgServer_SearchResult

See Also

P4ClientError Class


MsgServer_ServerID Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ServerID Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ServerID
Visual Basic
Public Shared MsgServer_ServerID As Integer
Visual C++
public:
static int MsgServer_ServerID

See Also

P4ClientError Class


MsgServer_ServerIDAlreadySet Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ServerIDAlreadySet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ServerIDAlreadySet
Visual Basic
Public Shared MsgServer_ServerIDAlreadySet As Integer
Visual C++
public:
static int MsgServer_ServerIDAlreadySet

See Also

P4ClientError Class


MsgServer_ServerTooOld Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ServerTooOld Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ServerTooOld
Visual Basic
Public Shared MsgServer_ServerTooOld As Integer
Visual C++
public:
static int MsgServer_ServerTooOld

See Also

P4ClientError Class


MsgServer_ServiceNotProvided Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ServiceNotProvided Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ServiceNotProvided
Visual Basic
Public Shared MsgServer_ServiceNotProvided As Integer
Visual C++
public:
static int MsgServer_ServiceNotProvided

See Also

P4ClientError Class


MsgServer_ShelveAborted Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ShelveAborted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ShelveAborted
Visual Basic
Public Shared MsgServer_ShelveAborted As Integer
Visual C++
public:
static int MsgServer_ShelveAborted

See Also

P4ClientError Class


MsgServer_ShelveBegin Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ShelveBegin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ShelveBegin
Visual Basic
Public Shared MsgServer_ShelveBegin As Integer
Visual C++
public:
static int MsgServer_ShelveBegin

See Also

P4ClientError Class


MsgServer_ShelveComplete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ShelveComplete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ShelveComplete
Visual Basic
Public Shared MsgServer_ShelveComplete As Integer
Visual C++
public:
static int MsgServer_ShelveComplete

See Also

P4ClientError Class


MsgServer_ShelveDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ShelveDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ShelveDelete
Visual Basic
Public Shared MsgServer_ShelveDelete As Integer
Visual C++
public:
static int MsgServer_ShelveDelete

See Also

P4ClientError Class


MsgServer_ShelveMaxSize Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ShelveMaxSize Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ShelveMaxSize
Visual Basic
Public Shared MsgServer_ShelveMaxSize As Integer
Visual C++
public:
static int MsgServer_ShelveMaxSize

See Also

P4ClientError Class


MsgServer_ShelveTriggersFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ShelveTriggersFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ShelveTriggersFailed
Visual Basic
Public Shared MsgServer_ShelveTriggersFailed As Integer
Visual C++
public:
static int MsgServer_ShelveTriggersFailed

See Also

P4ClientError Class


MsgServer_ShelveXOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ShelveXOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ShelveXOpen
Visual Basic
Public Shared MsgServer_ShelveXOpen As Integer
Visual C++
public:
static int MsgServer_ShelveXOpen

See Also

P4ClientError Class


MsgServer_Shutdown Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Shutdown Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Shutdown
Visual Basic
Public Shared MsgServer_Shutdown As Integer
Visual C++
public:
static int MsgServer_Shutdown

See Also

P4ClientError Class


MsgServer_SkippedJnls Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SkippedJnls Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SkippedJnls
Visual Basic
Public Shared MsgServer_SkippedJnls As Integer
Visual C++
public:
static int MsgServer_SkippedJnls

See Also

P4ClientError Class


MsgServer_SnapReport Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SnapReport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SnapReport
Visual Basic
Public Shared MsgServer_SnapReport As Integer
Visual C++
public:
static int MsgServer_SnapReport

See Also

P4ClientError Class


MsgServer_SpecArchiveWarning Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SpecArchiveWarning Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SpecArchiveWarning
Visual Basic
Public Shared MsgServer_SpecArchiveWarning As Integer
Visual C++
public:
static int MsgServer_SpecArchiveWarning

See Also

P4ClientError Class


MsgServer_SpecCheckTriggers Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SpecCheckTriggers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SpecCheckTriggers
Visual Basic
Public Shared MsgServer_SpecCheckTriggers As Integer
Visual C++
public:
static int MsgServer_SpecCheckTriggers

See Also

P4ClientError Class


MsgServer_SpecNotCorrect Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SpecNotCorrect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SpecNotCorrect
Visual Basic
Public Shared MsgServer_SpecNotCorrect As Integer
Visual C++
public:
static int MsgServer_SpecNotCorrect

See Also

P4ClientError Class


MsgServer_SSOfailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SSOfailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SSOfailed
Visual Basic
Public Shared MsgServer_SSOfailed As Integer
Visual C++
public:
static int MsgServer_SSOfailed

See Also

P4ClientError Class


MsgServer_SSOInvalid Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SSOInvalid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SSOInvalid
Visual Basic
Public Shared MsgServer_SSOInvalid As Integer
Visual C++
public:
static int MsgServer_SSOInvalid

See Also

P4ClientError Class


MsgServer_SSONoEnv Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SSONoEnv Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SSONoEnv
Visual Basic
Public Shared MsgServer_SSONoEnv As Integer
Visual C++
public:
static int MsgServer_SSONoEnv

See Also

P4ClientError Class


MsgServer_Startup Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Startup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Startup
Visual Basic
Public Shared MsgServer_Startup As Integer
Visual C++
public:
static int MsgServer_Startup

See Also

P4ClientError Class


MsgServer_StartupCommandError Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_StartupCommandError Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_StartupCommandError
Visual Basic
Public Shared MsgServer_StartupCommandError As Integer
Visual C++
public:
static int MsgServer_StartupCommandError

See Also

P4ClientError Class


MsgServer_SubmitAborted Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitAborted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitAborted
Visual Basic
Public Shared MsgServer_SubmitAborted As Integer
Visual C++
public:
static int MsgServer_SubmitAborted

See Also

P4ClientError Class


MsgServer_SubmitBegin Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitBegin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitBegin
Visual Basic
Public Shared MsgServer_SubmitBegin As Integer
Visual C++
public:
static int MsgServer_SubmitBegin

See Also

P4ClientError Class


MsgServer_SubmitComplete Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitComplete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitComplete
Visual Basic
Public Shared MsgServer_SubmitComplete As Integer
Visual C++
public:
static int MsgServer_SubmitComplete

See Also

P4ClientError Class


MsgServer_SubmitDataChanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitDataChanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitDataChanged
Visual Basic
Public Shared MsgServer_SubmitDataChanged As Integer
Visual C++
public:
static int MsgServer_SubmitDataChanged

See Also

P4ClientError Class


MsgServer_SubmitFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitFailed
Visual Basic
Public Shared MsgServer_SubmitFailed As Integer
Visual C++
public:
static int MsgServer_SubmitFailed

See Also

P4ClientError Class


MsgServer_SubmitIsShelved Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitIsShelved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitIsShelved
Visual Basic
Public Shared MsgServer_SubmitIsShelved As Integer
Visual C++
public:
static int MsgServer_SubmitIsShelved

See Also

P4ClientError Class


MsgServer_SubmitLocking Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitLocking Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitLocking
Visual Basic
Public Shared MsgServer_SubmitLocking As Integer
Visual C++
public:
static int MsgServer_SubmitLocking

See Also

P4ClientError Class


MsgServer_SubmitNeedsShelved Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitNeedsShelved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitNeedsShelved
Visual Basic
Public Shared MsgServer_SubmitNeedsShelved As Integer
Visual C++
public:
static int MsgServer_SubmitNeedsShelved

See Also

P4ClientError Class


MsgServer_SubmitRenamed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitRenamed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitRenamed
Visual Basic
Public Shared MsgServer_SubmitRenamed As Integer
Visual C++
public:
static int MsgServer_SubmitRenamed

See Also

P4ClientError Class


MsgServer_SubmitShelvedAborted Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitShelvedAborted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitShelvedAborted
Visual Basic
Public Shared MsgServer_SubmitShelvedAborted As Integer
Visual C++
public:
static int MsgServer_SubmitShelvedAborted

See Also

P4ClientError Class


MsgServer_SubmitShelvedFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitShelvedFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitShelvedFailed
Visual Basic
Public Shared MsgServer_SubmitShelvedFailed As Integer
Visual C++
public:
static int MsgServer_SubmitShelvedFailed

See Also

P4ClientError Class


MsgServer_SubmitShelvedHasTask Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitShelvedHasTask Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitShelvedHasTask
Visual Basic
Public Shared MsgServer_SubmitShelvedHasTask As Integer
Visual C++
public:
static int MsgServer_SubmitShelvedHasTask

See Also

P4ClientError Class


MsgServer_SubmitTampered Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_SubmitTampered Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_SubmitTampered
Visual Basic
Public Shared MsgServer_SubmitTampered As Integer
Visual C++
public:
static int MsgServer_SubmitTampered

See Also

P4ClientError Class


MsgServer_TargetAccessFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TargetAccessFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TargetAccessFailed
Visual Basic
Public Shared MsgServer_TargetAccessFailed As Integer
Visual C++
public:
static int MsgServer_TargetAccessFailed

See Also

P4ClientError Class


MsgServer_TemporaryLabelInfo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TemporaryLabelInfo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TemporaryLabelInfo
Visual Basic
Public Shared MsgServer_TemporaryLabelInfo As Integer
Visual C++
public:
static int MsgServer_TemporaryLabelInfo

See Also

P4ClientError Class


MsgServer_TicketOnly Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TicketOnly Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TicketOnly
Visual Basic
Public Shared MsgServer_TicketOnly As Integer
Visual C++
public:
static int MsgServer_TicketOnly

See Also

P4ClientError Class


MsgServer_TooManyCommands Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TooManyCommands Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TooManyCommands
Visual Basic
Public Shared MsgServer_TooManyCommands As Integer
Visual C++
public:
static int MsgServer_TooManyCommands

See Also

P4ClientError Class


MsgServer_TooManySortTraits Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TooManySortTraits Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TooManySortTraits
Visual Basic
Public Shared MsgServer_TooManySortTraits As Integer
Visual C++
public:
static int MsgServer_TooManySortTraits

See Also

P4ClientError Class


MsgServer_TrackCommand Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TrackCommand Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TrackCommand
Visual Basic
Public Shared MsgServer_TrackCommand As Integer
Visual C++
public:
static int MsgServer_TrackCommand

See Also

P4ClientError Class


MsgServer_TransferCancelled Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TransferCancelled Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TransferCancelled
Visual Basic
Public Shared MsgServer_TransferCancelled As Integer
Visual C++
public:
static int MsgServer_TransferCancelled

See Also

P4ClientError Class


MsgServer_TransferNotReplica Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TransferNotReplica Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TransferNotReplica
Visual Basic
Public Shared MsgServer_TransferNotReplica As Integer
Visual C++
public:
static int MsgServer_TransferNotReplica

See Also

P4ClientError Class


MsgServer_TriggerFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TriggerFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TriggerFailed
Visual Basic
Public Shared MsgServer_TriggerFailed As Integer
Visual C++
public:
static int MsgServer_TriggerFailed

See Also

P4ClientError Class


MsgServer_TriggerOutput Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TriggerOutput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TriggerOutput
Visual Basic
Public Shared MsgServer_TriggerOutput As Integer
Visual C++
public:
static int MsgServer_TriggerOutput

See Also

P4ClientError Class


MsgServer_TriggersFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TriggersFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TriggersFailed
Visual Basic
Public Shared MsgServer_TriggersFailed As Integer
Visual C++
public:
static int MsgServer_TriggersFailed

See Also

P4ClientError Class


MsgServer_TZMismatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_TZMismatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_TZMismatch
Visual Basic
Public Shared MsgServer_TZMismatch As Integer
Visual C++
public:
static int MsgServer_TZMismatch

See Also

P4ClientError Class


MsgServer_Unicode Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Unicode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Unicode
Visual Basic
Public Shared MsgServer_Unicode As Integer
Visual C++
public:
static int MsgServer_Unicode

See Also

P4ClientError Class


MsgServer_Unicode2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Unicode2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Unicode2
Visual Basic
Public Shared MsgServer_Unicode2 As Integer
Visual C++
public:
static int MsgServer_Unicode2

See Also

P4ClientError Class


MsgServer_UnknownReplicationMode Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UnknownReplicationMode Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UnknownReplicationMode
Visual Basic
Public Shared MsgServer_UnknownReplicationMode As Integer
Visual C++
public:
static int MsgServer_UnknownReplicationMode

See Also

P4ClientError Class


MsgServer_UnknownReplicationTarget Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UnknownReplicationTarget Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UnknownReplicationTarget
Visual Basic
Public Shared MsgServer_UnknownReplicationTarget As Integer
Visual C++
public:
static int MsgServer_UnknownReplicationTarget

See Also

P4ClientError Class


MsgServer_Unlicensed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Unlicensed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Unlicensed
Visual Basic
Public Shared MsgServer_Unlicensed As Integer
Visual C++
public:
static int MsgServer_Unlicensed

See Also

P4ClientError Class


MsgServer_UnloadDepotMissing Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UnloadDepotMissing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UnloadDepotMissing
Visual Basic
Public Shared MsgServer_UnloadDepotMissing As Integer
Visual C++
public:
static int MsgServer_UnloadDepotMissing

See Also

P4ClientError Class


MsgServer_UnloadOtherUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UnloadOtherUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UnloadOtherUser
Visual Basic
Public Shared MsgServer_UnloadOtherUser As Integer
Visual C++
public:
static int MsgServer_UnloadOtherUser

See Also

P4ClientError Class


MsgServer_UnshelveFileChanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UnshelveFileChanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UnshelveFileChanged
Visual Basic
Public Shared MsgServer_UnshelveFileChanged As Integer
Visual C++
public:
static int MsgServer_UnshelveFileChanged

See Also

P4ClientError Class


MsgServer_UnshelveNotOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UnshelveNotOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UnshelveNotOwner
Visual Basic
Public Shared MsgServer_UnshelveNotOwner As Integer
Visual C++
public:
static int MsgServer_UnshelveNotOwner

See Also

P4ClientError Class


MsgServer_Usage Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_Usage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_Usage
Visual Basic
Public Shared MsgServer_Usage As Integer
Visual C++
public:
static int MsgServer_Usage

See Also

P4ClientError Class


MsgServer_UseAdmin Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdmin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdmin
Visual Basic
Public Shared MsgServer_UseAdmin As Integer
Visual C++
public:
static int MsgServer_UseAdmin

See Also

P4ClientError Class


MsgServer_UseAdminCheckpoint Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminCheckpoint Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminCheckpoint
Visual Basic
Public Shared MsgServer_UseAdminCheckpoint As Integer
Visual C++
public:
static int MsgServer_UseAdminCheckpoint

See Also

P4ClientError Class


MsgServer_UseAdminCopyin Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminCopyin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminCopyin
Visual Basic
Public Shared MsgServer_UseAdminCopyin As Integer
Visual C++
public:
static int MsgServer_UseAdminCopyin

See Also

P4ClientError Class


MsgServer_UseAdminCopyout Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminCopyout Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminCopyout
Visual Basic
Public Shared MsgServer_UseAdminCopyout As Integer
Visual C++
public:
static int MsgServer_UseAdminCopyout

See Also

P4ClientError Class


MsgServer_UseAdminDBSigs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminDBSigs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminDBSigs
Visual Basic
Public Shared MsgServer_UseAdminDBSigs As Integer
Visual C++
public:
static int MsgServer_UseAdminDBSigs

See Also

P4ClientError Class


MsgServer_UseAdminImport Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminImport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminImport
Visual Basic
Public Shared MsgServer_UseAdminImport As Integer
Visual C++
public:
static int MsgServer_UseAdminImport

See Also

P4ClientError Class


MsgServer_UseAdminJournal Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminJournal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminJournal
Visual Basic
Public Shared MsgServer_UseAdminJournal As Integer
Visual C++
public:
static int MsgServer_UseAdminJournal

See Also

P4ClientError Class


MsgServer_UseAdminResetPassword Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminResetPassword Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminResetPassword
Visual Basic
Public Shared MsgServer_UseAdminResetPassword As Integer
Visual C++
public:
static int MsgServer_UseAdminResetPassword

See Also

P4ClientError Class


MsgServer_UseAdminSpecDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAdminSpecDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAdminSpecDepot
Visual Basic
Public Shared MsgServer_UseAdminSpecDepot As Integer
Visual C++
public:
static int MsgServer_UseAdminSpecDepot

See Also

P4ClientError Class


MsgServer_UseAnnotate Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseAnnotate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseAnnotate
Visual Basic
Public Shared MsgServer_UseAnnotate As Integer
Visual C++
public:
static int MsgServer_UseAnnotate

See Also

P4ClientError Class


MsgServer_UseArchive Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseArchive Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseArchive
Visual Basic
Public Shared MsgServer_UseArchive As Integer
Visual C++
public:
static int MsgServer_UseArchive

See Also

P4ClientError Class


MsgServer_UseBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseBranch
Visual Basic
Public Shared MsgServer_UseBranch As Integer
Visual C++
public:
static int MsgServer_UseBranch

See Also

P4ClientError Class


MsgServer_UseBranchd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseBranchd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseBranchd
Visual Basic
Public Shared MsgServer_UseBranchd As Integer
Visual C++
public:
static int MsgServer_UseBranchd

See Also

P4ClientError Class


MsgServer_UseBranches Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseBranches Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseBranches
Visual Basic
Public Shared MsgServer_UseBranches As Integer
Visual C++
public:
static int MsgServer_UseBranches

See Also

P4ClientError Class


MsgServer_UseBranchi Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseBranchi Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseBranchi
Visual Basic
Public Shared MsgServer_UseBranchi As Integer
Visual C++
public:
static int MsgServer_UseBranchi

See Also

P4ClientError Class


MsgServer_UseBrancho Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseBrancho Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseBrancho
Visual Basic
Public Shared MsgServer_UseBrancho As Integer
Visual C++
public:
static int MsgServer_UseBrancho

See Also

P4ClientError Class


MsgServer_UseCachepurge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCachepurge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCachepurge
Visual Basic
Public Shared MsgServer_UseCachepurge As Integer
Visual C++
public:
static int MsgServer_UseCachepurge

See Also

P4ClientError Class


MsgServer_UseChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChange
Visual Basic
Public Shared MsgServer_UseChange As Integer
Visual C++
public:
static int MsgServer_UseChange

See Also

P4ClientError Class


MsgServer_UseChanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChanged
Visual Basic
Public Shared MsgServer_UseChanged As Integer
Visual C++
public:
static int MsgServer_UseChanged

See Also

P4ClientError Class


MsgServer_UseChangei Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChangei Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChangei
Visual Basic
Public Shared MsgServer_UseChangei As Integer
Visual C++
public:
static int MsgServer_UseChangei

See Also

P4ClientError Class


MsgServer_UseChangeo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChangeo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChangeo
Visual Basic
Public Shared MsgServer_UseChangeo As Integer
Visual C++
public:
static int MsgServer_UseChangeo

See Also

P4ClientError Class


MsgServer_UseChanges Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChanges Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChanges
Visual Basic
Public Shared MsgServer_UseChanges As Integer
Visual C++
public:
static int MsgServer_UseChanges

See Also

P4ClientError Class


MsgServer_UseChanget Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChanget Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChanget
Visual Basic
Public Shared MsgServer_UseChanget As Integer
Visual C++
public:
static int MsgServer_UseChanget

See Also

P4ClientError Class


MsgServer_UseChangeU Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChangeU Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChangeU
Visual Basic
Public Shared MsgServer_UseChangeU As Integer
Visual C++
public:
static int MsgServer_UseChangeU

See Also

P4ClientError Class


MsgServer_UseChangeUt Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseChangeUt Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseChangeUt
Visual Basic
Public Shared MsgServer_UseChangeUt As Integer
Visual C++
public:
static int MsgServer_UseChangeUt

See Also

P4ClientError Class


MsgServer_UseClean Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseClean Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseClean
Visual Basic
Public Shared MsgServer_UseClean As Integer
Visual C++
public:
static int MsgServer_UseClean

See Also

P4ClientError Class


MsgServer_UseClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseClient
Visual Basic
Public Shared MsgServer_UseClient As Integer
Visual C++
public:
static int MsgServer_UseClient

See Also

P4ClientError Class


MsgServer_UseClientd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseClientd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseClientd
Visual Basic
Public Shared MsgServer_UseClientd As Integer
Visual C++
public:
static int MsgServer_UseClientd

See Also

P4ClientError Class


MsgServer_UseClienti Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseClienti Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseClienti
Visual Basic
Public Shared MsgServer_UseClienti As Integer
Visual C++
public:
static int MsgServer_UseClienti

See Also

P4ClientError Class


MsgServer_UseCliento Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCliento Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCliento
Visual Basic
Public Shared MsgServer_UseCliento As Integer
Visual C++
public:
static int MsgServer_UseCliento

See Also

P4ClientError Class


MsgServer_UseClientS Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseClientS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseClientS
Visual Basic
Public Shared MsgServer_UseClientS As Integer
Visual C++
public:
static int MsgServer_UseClientS

See Also

P4ClientError Class


MsgServer_UseCluster Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCluster Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCluster
Visual Basic
Public Shared MsgServer_UseCluster As Integer
Visual C++
public:
static int MsgServer_UseCluster

See Also

P4ClientError Class


MsgServer_UseConfigure Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseConfigure Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseConfigure
Visual Basic
Public Shared MsgServer_UseConfigure As Integer
Visual C++
public:
static int MsgServer_UseConfigure

See Also

P4ClientError Class


MsgServer_UseCopy Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCopy Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCopy
Visual Basic
Public Shared MsgServer_UseCopy As Integer
Visual C++
public:
static int MsgServer_UseCopy

See Also

P4ClientError Class


MsgServer_UseCopyb Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCopyb Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCopyb
Visual Basic
Public Shared MsgServer_UseCopyb As Integer
Visual C++
public:
static int MsgServer_UseCopyb

See Also

P4ClientError Class


MsgServer_UseCopyS Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCopyS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCopyS
Visual Basic
Public Shared MsgServer_UseCopyS As Integer
Visual C++
public:
static int MsgServer_UseCopyS

See Also

P4ClientError Class


MsgServer_UseCounter Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCounter Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCounter
Visual Basic
Public Shared MsgServer_UseCounter As Integer
Visual C++
public:
static int MsgServer_UseCounter

See Also

P4ClientError Class


MsgServer_UseCounteri Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCounteri Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCounteri
Visual Basic
Public Shared MsgServer_UseCounteri As Integer
Visual C++
public:
static int MsgServer_UseCounteri

See Also

P4ClientError Class


MsgServer_UseCounters Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCounters Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCounters
Visual Basic
Public Shared MsgServer_UseCounters As Integer
Visual C++
public:
static int MsgServer_UseCounters

See Also

P4ClientError Class


MsgServer_UseCstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseCstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseCstat
Visual Basic
Public Shared MsgServer_UseCstat As Integer
Visual C++
public:
static int MsgServer_UseCstat

See Also

P4ClientError Class


MsgServer_UseDbpack Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDbpack Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDbpack
Visual Basic
Public Shared MsgServer_UseDbpack As Integer
Visual C++
public:
static int MsgServer_UseDbpack

See Also

P4ClientError Class


MsgServer_UseDbstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDbstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDbstat
Visual Basic
Public Shared MsgServer_UseDbstat As Integer
Visual C++
public:
static int MsgServer_UseDbstat

See Also

P4ClientError Class


MsgServer_UseDbverify Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDbverify Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDbverify
Visual Basic
Public Shared MsgServer_UseDbverify As Integer
Visual C++
public:
static int MsgServer_UseDbverify

See Also

P4ClientError Class


MsgServer_UseDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDepot
Visual Basic
Public Shared MsgServer_UseDepot As Integer
Visual C++
public:
static int MsgServer_UseDepot

See Also

P4ClientError Class


MsgServer_UseDepotd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDepotd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDepotd
Visual Basic
Public Shared MsgServer_UseDepotd As Integer
Visual C++
public:
static int MsgServer_UseDepotd

See Also

P4ClientError Class


MsgServer_UseDepoti Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDepoti Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDepoti
Visual Basic
Public Shared MsgServer_UseDepoti As Integer
Visual C++
public:
static int MsgServer_UseDepoti

See Also

P4ClientError Class


MsgServer_UseDepoto Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDepoto Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDepoto
Visual Basic
Public Shared MsgServer_UseDepoto As Integer
Visual C++
public:
static int MsgServer_UseDepoto

See Also

P4ClientError Class


MsgServer_UseDepots Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDepots Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDepots
Visual Basic
Public Shared MsgServer_UseDepots As Integer
Visual C++
public:
static int MsgServer_UseDepots

See Also

P4ClientError Class


MsgServer_UseDescribe Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDescribe Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDescribe
Visual Basic
Public Shared MsgServer_UseDescribe As Integer
Visual C++
public:
static int MsgServer_UseDescribe

See Also

P4ClientError Class


MsgServer_UseDiff Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDiff Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDiff
Visual Basic
Public Shared MsgServer_UseDiff As Integer
Visual C++
public:
static int MsgServer_UseDiff

See Also

P4ClientError Class


MsgServer_UseDiff2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDiff2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDiff2
Visual Basic
Public Shared MsgServer_UseDiff2 As Integer
Visual C++
public:
static int MsgServer_UseDiff2

See Also

P4ClientError Class


MsgServer_UseDiff2b Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDiff2b Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDiff2b
Visual Basic
Public Shared MsgServer_UseDiff2b As Integer
Visual C++
public:
static int MsgServer_UseDiff2b

See Also

P4ClientError Class


MsgServer_UseDiff2n Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDiff2n Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDiff2n
Visual Basic
Public Shared MsgServer_UseDiff2n As Integer
Visual C++
public:
static int MsgServer_UseDiff2n

See Also

P4ClientError Class


MsgServer_UseDiff2S Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDiff2S Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDiff2S
Visual Basic
Public Shared MsgServer_UseDiff2S As Integer
Visual C++
public:
static int MsgServer_UseDiff2S

See Also

P4ClientError Class


MsgServer_UseDirs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDirs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDirs
Visual Basic
Public Shared MsgServer_UseDirs As Integer
Visual C++
public:
static int MsgServer_UseDirs

See Also

P4ClientError Class


MsgServer_UseDiskspace Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDiskspace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDiskspace
Visual Basic
Public Shared MsgServer_UseDiskspace As Integer
Visual C++
public:
static int MsgServer_UseDiskspace

See Also

P4ClientError Class


MsgServer_UseDomainClients Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDomainClients Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDomainClients
Visual Basic
Public Shared MsgServer_UseDomainClients As Integer
Visual C++
public:
static int MsgServer_UseDomainClients

See Also

P4ClientError Class


MsgServer_UseDomains Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDomains Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDomains
Visual Basic
Public Shared MsgServer_UseDomains As Integer
Visual C++
public:
static int MsgServer_UseDomains

See Also

P4ClientError Class


MsgServer_UseDup Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseDup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseDup
Visual Basic
Public Shared MsgServer_UseDup As Integer
Visual C++
public:
static int MsgServer_UseDup

See Also

P4ClientError Class


MsgServer_UseExport Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseExport Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseExport
Visual Basic
Public Shared MsgServer_UseExport As Integer
Visual C++
public:
static int MsgServer_UseExport

See Also

P4ClientError Class


MsgServer_UseFilelog Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseFilelog Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseFilelog
Visual Basic
Public Shared MsgServer_UseFilelog As Integer
Visual C++
public:
static int MsgServer_UseFilelog

See Also

P4ClientError Class


MsgServer_UseFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseFiles
Visual Basic
Public Shared MsgServer_UseFiles As Integer
Visual C++
public:
static int MsgServer_UseFiles

See Also

P4ClientError Class


MsgServer_UseFix Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseFix Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseFix
Visual Basic
Public Shared MsgServer_UseFix As Integer
Visual C++
public:
static int MsgServer_UseFix

See Also

P4ClientError Class


MsgServer_UseFixes Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseFixes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseFixes
Visual Basic
Public Shared MsgServer_UseFixes As Integer
Visual C++
public:
static int MsgServer_UseFixes

See Also

P4ClientError Class


MsgServer_UseFstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseFstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseFstat
Visual Basic
Public Shared MsgServer_UseFstat As Integer
Visual C++
public:
static int MsgServer_UseFstat

See Also

P4ClientError Class


MsgServer_UseGrep Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseGrep Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseGrep
Visual Basic
Public Shared MsgServer_UseGrep As Integer
Visual C++
public:
static int MsgServer_UseGrep

See Also

P4ClientError Class


MsgServer_UseGroup Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseGroup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseGroup
Visual Basic
Public Shared MsgServer_UseGroup As Integer
Visual C++
public:
static int MsgServer_UseGroup

See Also

P4ClientError Class


MsgServer_UseGroupd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseGroupd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseGroupd
Visual Basic
Public Shared MsgServer_UseGroupd As Integer
Visual C++
public:
static int MsgServer_UseGroupd

See Also

P4ClientError Class


MsgServer_UseGroupi Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseGroupi Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseGroupi
Visual Basic
Public Shared MsgServer_UseGroupi As Integer
Visual C++
public:
static int MsgServer_UseGroupi

See Also

P4ClientError Class


MsgServer_UseGroupo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseGroupo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseGroupo
Visual Basic
Public Shared MsgServer_UseGroupo As Integer
Visual C++
public:
static int MsgServer_UseGroupo

See Also

P4ClientError Class


MsgServer_UseGroups Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseGroups Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseGroups
Visual Basic
Public Shared MsgServer_UseGroups As Integer
Visual C++
public:
static int MsgServer_UseGroups

See Also

P4ClientError Class


MsgServer_UseHave Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseHave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseHave
Visual Basic
Public Shared MsgServer_UseHave As Integer
Visual C++
public:
static int MsgServer_UseHave

See Also

P4ClientError Class


MsgServer_UseHelp Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseHelp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseHelp
Visual Basic
Public Shared MsgServer_UseHelp As Integer
Visual C++
public:
static int MsgServer_UseHelp

See Also

P4ClientError Class


MsgServer_UseIndex Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseIndex Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseIndex
Visual Basic
Public Shared MsgServer_UseIndex As Integer
Visual C++
public:
static int MsgServer_UseIndex

See Also

P4ClientError Class


MsgServer_UseInfo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseInfo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseInfo
Visual Basic
Public Shared MsgServer_UseInfo As Integer
Visual C++
public:
static int MsgServer_UseInfo

See Also

P4ClientError Class


MsgServer_UseInteg Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseInteg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseInteg
Visual Basic
Public Shared MsgServer_UseInteg As Integer
Visual C++
public:
static int MsgServer_UseInteg

See Also

P4ClientError Class


MsgServer_UseIntegb Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseIntegb Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseIntegb
Visual Basic
Public Shared MsgServer_UseIntegb As Integer
Visual C++
public:
static int MsgServer_UseIntegb

See Also

P4ClientError Class


MsgServer_UseInteged Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseInteged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseInteged
Visual Basic
Public Shared MsgServer_UseInteged As Integer
Visual C++
public:
static int MsgServer_UseInteged

See Also

P4ClientError Class


MsgServer_UseIntegS Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseIntegS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseIntegS
Visual Basic
Public Shared MsgServer_UseIntegS As Integer
Visual C++
public:
static int MsgServer_UseIntegS

See Also

P4ClientError Class


MsgServer_UseInterChanges Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseInterChanges Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseInterChanges
Visual Basic
Public Shared MsgServer_UseInterChanges As Integer
Visual C++
public:
static int MsgServer_UseInterChanges

See Also

P4ClientError Class


MsgServer_UseInterChangesb Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseInterChangesb Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseInterChangesb
Visual Basic
Public Shared MsgServer_UseInterChangesb As Integer
Visual C++
public:
static int MsgServer_UseInterChangesb

See Also

P4ClientError Class


MsgServer_UseInterChangesS Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseInterChangesS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseInterChangesS
Visual Basic
Public Shared MsgServer_UseInterChangesS As Integer
Visual C++
public:
static int MsgServer_UseInterChangesS

See Also

P4ClientError Class


MsgServer_UseIstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseIstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseIstat
Visual Basic
Public Shared MsgServer_UseIstat As Integer
Visual C++
public:
static int MsgServer_UseIstat

See Also

P4ClientError Class


MsgServer_UseJob Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJob Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJob
Visual Basic
Public Shared MsgServer_UseJob As Integer
Visual C++
public:
static int MsgServer_UseJob

See Also

P4ClientError Class


MsgServer_UseJobd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJobd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJobd
Visual Basic
Public Shared MsgServer_UseJobd As Integer
Visual C++
public:
static int MsgServer_UseJobd

See Also

P4ClientError Class


MsgServer_UseJobi Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJobi Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJobi
Visual Basic
Public Shared MsgServer_UseJobi As Integer
Visual C++
public:
static int MsgServer_UseJobi

See Also

P4ClientError Class


MsgServer_UseJobo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJobo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJobo
Visual Basic
Public Shared MsgServer_UseJobo As Integer
Visual C++
public:
static int MsgServer_UseJobo

See Also

P4ClientError Class


MsgServer_UseJobs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJobs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJobs
Visual Basic
Public Shared MsgServer_UseJobs As Integer
Visual C++
public:
static int MsgServer_UseJobs

See Also

P4ClientError Class


MsgServer_UseJobSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJobSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJobSpec
Visual Basic
Public Shared MsgServer_UseJobSpec As Integer
Visual C++
public:
static int MsgServer_UseJobSpec

See Also

P4ClientError Class


MsgServer_UseJournals Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJournals Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJournals
Visual Basic
Public Shared MsgServer_UseJournals As Integer
Visual C++
public:
static int MsgServer_UseJournals

See Also

P4ClientError Class


MsgServer_UseJournalWait Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseJournalWait Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseJournalWait
Visual Basic
Public Shared MsgServer_UseJournalWait As Integer
Visual C++
public:
static int MsgServer_UseJournalWait

See Also

P4ClientError Class


MsgServer_UseKey Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseKey Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseKey
Visual Basic
Public Shared MsgServer_UseKey As Integer
Visual C++
public:
static int MsgServer_UseKey

See Also

P4ClientError Class


MsgServer_UseKeyi Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseKeyi Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseKeyi
Visual Basic
Public Shared MsgServer_UseKeyi As Integer
Visual C++
public:
static int MsgServer_UseKeyi

See Also

P4ClientError Class


MsgServer_UseKeys Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseKeys Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseKeys
Visual Basic
Public Shared MsgServer_UseKeys As Integer
Visual C++
public:
static int MsgServer_UseKeys

See Also

P4ClientError Class


MsgServer_UseLabel Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLabel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLabel
Visual Basic
Public Shared MsgServer_UseLabel As Integer
Visual C++
public:
static int MsgServer_UseLabel

See Also

P4ClientError Class


MsgServer_UseLabeld Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLabeld Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLabeld
Visual Basic
Public Shared MsgServer_UseLabeld As Integer
Visual C++
public:
static int MsgServer_UseLabeld

See Also

P4ClientError Class


MsgServer_UseLabeli Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLabeli Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLabeli
Visual Basic
Public Shared MsgServer_UseLabeli As Integer
Visual C++
public:
static int MsgServer_UseLabeli

See Also

P4ClientError Class


MsgServer_UseLabelo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLabelo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLabelo
Visual Basic
Public Shared MsgServer_UseLabelo As Integer
Visual C++
public:
static int MsgServer_UseLabelo

See Also

P4ClientError Class


MsgServer_UseLabels Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLabels Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLabels
Visual Basic
Public Shared MsgServer_UseLabels As Integer
Visual C++
public:
static int MsgServer_UseLabels

See Also

P4ClientError Class


MsgServer_UseLabelSync Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLabelSync Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLabelSync
Visual Basic
Public Shared MsgServer_UseLabelSync As Integer
Visual C++
public:
static int MsgServer_UseLabelSync

See Also

P4ClientError Class


MsgServer_UseLicense Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLicense Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLicense
Visual Basic
Public Shared MsgServer_UseLicense As Integer
Visual C++
public:
static int MsgServer_UseLicense

See Also

P4ClientError Class


MsgServer_UseList Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseList Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseList
Visual Basic
Public Shared MsgServer_UseList As Integer
Visual C++
public:
static int MsgServer_UseList

See Also

P4ClientError Class


MsgServer_UseLock Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLock
Visual Basic
Public Shared MsgServer_UseLock As Integer
Visual C++
public:
static int MsgServer_UseLock

See Also

P4ClientError Class


MsgServer_UseLockstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLockstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLockstat
Visual Basic
Public Shared MsgServer_UseLockstat As Integer
Visual C++
public:
static int MsgServer_UseLockstat

See Also

P4ClientError Class


MsgServer_UseLogAppend Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogAppend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogAppend
Visual Basic
Public Shared MsgServer_UseLogAppend As Integer
Visual C++
public:
static int MsgServer_UseLogAppend

See Also

P4ClientError Class


MsgServer_UseLogger Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogger Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogger
Visual Basic
Public Shared MsgServer_UseLogger As Integer
Visual C++
public:
static int MsgServer_UseLogger

See Also

P4ClientError Class


MsgServer_UseLogin Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogin Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogin
Visual Basic
Public Shared MsgServer_UseLogin As Integer
Visual C++
public:
static int MsgServer_UseLogin

See Also

P4ClientError Class


MsgServer_UseLogout Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogout Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogout
Visual Basic
Public Shared MsgServer_UseLogout As Integer
Visual C++
public:
static int MsgServer_UseLogout

See Also

P4ClientError Class


MsgServer_UseLogParse Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogParse Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogParse
Visual Basic
Public Shared MsgServer_UseLogParse As Integer
Visual C++
public:
static int MsgServer_UseLogParse

See Also

P4ClientError Class


MsgServer_UseLogRotate Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogRotate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogRotate
Visual Basic
Public Shared MsgServer_UseLogRotate As Integer
Visual C++
public:
static int MsgServer_UseLogRotate

See Also

P4ClientError Class


MsgServer_UseLogSchema Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogSchema Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogSchema
Visual Basic
Public Shared MsgServer_UseLogSchema As Integer
Visual C++
public:
static int MsgServer_UseLogSchema

See Also

P4ClientError Class


MsgServer_UseLogstat Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogstat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogstat
Visual Basic
Public Shared MsgServer_UseLogstat As Integer
Visual C++
public:
static int MsgServer_UseLogstat

See Also

P4ClientError Class


MsgServer_UseLogtail Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseLogtail Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseLogtail
Visual Basic
Public Shared MsgServer_UseLogtail As Integer
Visual C++
public:
static int MsgServer_UseLogtail

See Also

P4ClientError Class


MsgServer_UseMain Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMain Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMain
Visual Basic
Public Shared MsgServer_UseMain As Integer
Visual C++
public:
static int MsgServer_UseMain

See Also

P4ClientError Class


MsgServer_UseMerge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMerge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMerge
Visual Basic
Public Shared MsgServer_UseMerge As Integer
Visual C++
public:
static int MsgServer_UseMerge

See Also

P4ClientError Class


MsgServer_UseMergeb Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMergeb Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMergeb
Visual Basic
Public Shared MsgServer_UseMergeb As Integer
Visual C++
public:
static int MsgServer_UseMergeb

See Also

P4ClientError Class


MsgServer_UseMergeS Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMergeS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMergeS
Visual Basic
Public Shared MsgServer_UseMergeS As Integer
Visual C++
public:
static int MsgServer_UseMergeS

See Also

P4ClientError Class


MsgServer_UseMonitor Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMonitor Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMonitor
Visual Basic
Public Shared MsgServer_UseMonitor As Integer
Visual C++
public:
static int MsgServer_UseMonitor

See Also

P4ClientError Class


MsgServer_UseMonitorc Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMonitorc Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMonitorc
Visual Basic
Public Shared MsgServer_UseMonitorc As Integer
Visual C++
public:
static int MsgServer_UseMonitorc

See Also

P4ClientError Class


MsgServer_UseMonitorf Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMonitorf Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMonitorf
Visual Basic
Public Shared MsgServer_UseMonitorf As Integer
Visual C++
public:
static int MsgServer_UseMonitorf

See Also

P4ClientError Class


MsgServer_UseMonitorP Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMonitorP Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMonitorP
Visual Basic
Public Shared MsgServer_UseMonitorP As Integer
Visual C++
public:
static int MsgServer_UseMonitorP

See Also

P4ClientError Class


MsgServer_UseMonitorR Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMonitorR Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMonitorR
Visual Basic
Public Shared MsgServer_UseMonitorR As Integer
Visual C++
public:
static int MsgServer_UseMonitorR

See Also

P4ClientError Class


MsgServer_UseMonitors Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMonitors Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMonitors
Visual Basic
Public Shared MsgServer_UseMonitors As Integer
Visual C++
public:
static int MsgServer_UseMonitors

See Also

P4ClientError Class


MsgServer_UseMove Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseMove Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseMove
Visual Basic
Public Shared MsgServer_UseMove As Integer
Visual C++
public:
static int MsgServer_UseMove

See Also

P4ClientError Class


MsgServer_UseOpen Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseOpen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseOpen
Visual Basic
Public Shared MsgServer_UseOpen As Integer
Visual C++
public:
static int MsgServer_UseOpen

See Also

P4ClientError Class


MsgServer_UseOpen2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseOpen2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseOpen2
Visual Basic
Public Shared MsgServer_UseOpen2 As Integer
Visual C++
public:
static int MsgServer_UseOpen2

See Also

P4ClientError Class


MsgServer_UseOpened Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseOpened Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseOpened
Visual Basic
Public Shared MsgServer_UseOpened As Integer
Visual C++
public:
static int MsgServer_UseOpened

See Also

P4ClientError Class


MsgServer_UseOpened2 Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseOpened2 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseOpened2
Visual Basic
Public Shared MsgServer_UseOpened2 As Integer
Visual C++
public:
static int MsgServer_UseOpened2

See Also

P4ClientError Class


MsgServer_UsePasswd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePasswd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePasswd
Visual Basic
Public Shared MsgServer_UsePasswd As Integer
Visual C++
public:
static int MsgServer_UsePasswd

See Also

P4ClientError Class


MsgServer_UsePing Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePing Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePing
Visual Basic
Public Shared MsgServer_UsePing As Integer
Visual C++
public:
static int MsgServer_UsePing

See Also

P4ClientError Class


MsgServer_UsePopulate Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePopulate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePopulate
Visual Basic
Public Shared MsgServer_UsePopulate As Integer
Visual C++
public:
static int MsgServer_UsePopulate

See Also

P4ClientError Class


MsgServer_UsePopulateb Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePopulateb Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePopulateb
Visual Basic
Public Shared MsgServer_UsePopulateb As Integer
Visual C++
public:
static int MsgServer_UsePopulateb

See Also

P4ClientError Class


MsgServer_UsePopulateS Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePopulateS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePopulateS
Visual Basic
Public Shared MsgServer_UsePopulateS As Integer
Visual C++
public:
static int MsgServer_UsePopulateS

See Also

P4ClientError Class


MsgServer_UsePrint Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePrint Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePrint
Visual Basic
Public Shared MsgServer_UsePrint As Integer
Visual C++
public:
static int MsgServer_UsePrint

See Also

P4ClientError Class


MsgServer_UseProperty Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseProperty Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseProperty
Visual Basic
Public Shared MsgServer_UseProperty As Integer
Visual C++
public:
static int MsgServer_UseProperty

See Also

P4ClientError Class


MsgServer_UseProtect Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseProtect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseProtect
Visual Basic
Public Shared MsgServer_UseProtect As Integer
Visual C++
public:
static int MsgServer_UseProtect

See Also

P4ClientError Class


MsgServer_UseProtects Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseProtects Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseProtects
Visual Basic
Public Shared MsgServer_UseProtects As Integer
Visual C++
public:
static int MsgServer_UseProtects

See Also

P4ClientError Class


MsgServer_UseProxy Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseProxy Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseProxy
Visual Basic
Public Shared MsgServer_UseProxy As Integer
Visual C++
public:
static int MsgServer_UseProxy

See Also

P4ClientError Class


MsgServer_UseProxyInfo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseProxyInfo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseProxyInfo
Visual Basic
Public Shared MsgServer_UseProxyInfo As Integer
Visual C++
public:
static int MsgServer_UseProxyInfo

See Also

P4ClientError Class


MsgServer_UsePull Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePull Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePull
Visual Basic
Public Shared MsgServer_UsePull As Integer
Visual C++
public:
static int MsgServer_UsePull

See Also

P4ClientError Class


MsgServer_UsePurge Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsePurge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsePurge
Visual Basic
Public Shared MsgServer_UsePurge As Integer
Visual C++
public:
static int MsgServer_UsePurge

See Also

P4ClientError Class


MsgServer_UseReconcile Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseReconcile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseReconcile
Visual Basic
Public Shared MsgServer_UseReconcile As Integer
Visual C++
public:
static int MsgServer_UseReconcile

See Also

P4ClientError Class


MsgServer_UseRelease Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseRelease Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseRelease
Visual Basic
Public Shared MsgServer_UseRelease As Integer
Visual C++
public:
static int MsgServer_UseRelease

See Also

P4ClientError Class


MsgServer_UseReload Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseReload Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseReload
Visual Basic
Public Shared MsgServer_UseReload As Integer
Visual C++
public:
static int MsgServer_UseReload

See Also

P4ClientError Class


MsgServer_UseRenameUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseRenameUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseRenameUser
Visual Basic
Public Shared MsgServer_UseRenameUser As Integer
Visual C++
public:
static int MsgServer_UseRenameUser

See Also

P4ClientError Class


MsgServer_UseReopen Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseReopen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseReopen
Visual Basic
Public Shared MsgServer_UseReopen As Integer
Visual C++
public:
static int MsgServer_UseReopen

See Also

P4ClientError Class


MsgServer_UseResolve Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseResolve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseResolve
Visual Basic
Public Shared MsgServer_UseResolve As Integer
Visual C++
public:
static int MsgServer_UseResolve

See Also

P4ClientError Class


MsgServer_UseResolved Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseResolved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseResolved
Visual Basic
Public Shared MsgServer_UseResolved As Integer
Visual C++
public:
static int MsgServer_UseResolved

See Also

P4ClientError Class


MsgServer_UseRestore Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseRestore Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseRestore
Visual Basic
Public Shared MsgServer_UseRestore As Integer
Visual C++
public:
static int MsgServer_UseRestore

See Also

P4ClientError Class


MsgServer_UseRetype Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseRetype Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseRetype
Visual Basic
Public Shared MsgServer_UseRetype As Integer
Visual C++
public:
static int MsgServer_UseRetype

See Also

P4ClientError Class


MsgServer_UseReview Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseReview Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseReview
Visual Basic
Public Shared MsgServer_UseReview As Integer
Visual C++
public:
static int MsgServer_UseReview

See Also

P4ClientError Class


MsgServer_UseReviews Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseReviews Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseReviews
Visual Basic
Public Shared MsgServer_UseReviews As Integer
Visual C++
public:
static int MsgServer_UseReviews

See Also

P4ClientError Class


MsgServer_UserRenamed Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UserRenamed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UserRenamed
Visual Basic
Public Shared MsgServer_UserRenamed As Integer
Visual C++
public:
static int MsgServer_UserRenamed

See Also

P4ClientError Class


MsgServer_UsersCRNotBoth Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsersCRNotBoth Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsersCRNotBoth
Visual Basic
Public Shared MsgServer_UsersCRNotBoth As Integer
Visual C++
public:
static int MsgServer_UsersCRNotBoth

See Also

P4ClientError Class


MsgServer_UsersCRNotReplica Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UsersCRNotReplica Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UsersCRNotReplica
Visual Basic
Public Shared MsgServer_UsersCRNotReplica As Integer
Visual C++
public:
static int MsgServer_UsersCRNotReplica

See Also

P4ClientError Class


MsgServer_UseSearch Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSearch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSearch
Visual Basic
Public Shared MsgServer_UseSearch As Integer
Visual C++
public:
static int MsgServer_UseSearch

See Also

P4ClientError Class


MsgServer_UseServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseServer
Visual Basic
Public Shared MsgServer_UseServer As Integer
Visual C++
public:
static int MsgServer_UseServer

See Also

P4ClientError Class


MsgServer_UseServerd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseServerd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseServerd
Visual Basic
Public Shared MsgServer_UseServerd As Integer
Visual C++
public:
static int MsgServer_UseServerd

See Also

P4ClientError Class


MsgServer_UseServeri Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseServeri Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseServeri
Visual Basic
Public Shared MsgServer_UseServeri As Integer
Visual C++
public:
static int MsgServer_UseServeri

See Also

P4ClientError Class


MsgServer_UseServerid Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseServerid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseServerid
Visual Basic
Public Shared MsgServer_UseServerid As Integer
Visual C++
public:
static int MsgServer_UseServerid

See Also

P4ClientError Class


MsgServer_UseServero Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseServero Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseServero
Visual Basic
Public Shared MsgServer_UseServero As Integer
Visual C++
public:
static int MsgServer_UseServero

See Also

P4ClientError Class


MsgServer_UseServers Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseServers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseServers
Visual Basic
Public Shared MsgServer_UseServers As Integer
Visual C++
public:
static int MsgServer_UseServers

See Also

P4ClientError Class


MsgServer_UseShelve Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseShelve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseShelve
Visual Basic
Public Shared MsgServer_UseShelve As Integer
Visual C++
public:
static int MsgServer_UseShelve

See Also

P4ClientError Class


MsgServer_UseShelvec Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseShelvec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseShelvec
Visual Basic
Public Shared MsgServer_UseShelvec As Integer
Visual C++
public:
static int MsgServer_UseShelvec

See Also

P4ClientError Class


MsgServer_UseShelvei Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseShelvei Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseShelvei
Visual Basic
Public Shared MsgServer_UseShelvei As Integer
Visual C++
public:
static int MsgServer_UseShelvei

See Also

P4ClientError Class


MsgServer_UseShelveNoOpts Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseShelveNoOpts Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseShelveNoOpts
Visual Basic
Public Shared MsgServer_UseShelveNoOpts As Integer
Visual C++
public:
static int MsgServer_UseShelveNoOpts

See Also

P4ClientError Class


MsgServer_UseShelver Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseShelver Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseShelver
Visual Basic
Public Shared MsgServer_UseShelver As Integer
Visual C++
public:
static int MsgServer_UseShelver

See Also

P4ClientError Class


MsgServer_UseSizes Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSizes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSizes
Visual Basic
Public Shared MsgServer_UseSizes As Integer
Visual C++
public:
static int MsgServer_UseSizes

See Also

P4ClientError Class


MsgServer_UseSnap Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSnap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSnap
Visual Basic
Public Shared MsgServer_UseSnap As Integer
Visual C++
public:
static int MsgServer_UseSnap

See Also

P4ClientError Class


MsgServer_UseSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSpec
Visual Basic
Public Shared MsgServer_UseSpec As Integer
Visual C++
public:
static int MsgServer_UseSpec

See Also

P4ClientError Class


MsgServer_UseStatus Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseStatus Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseStatus
Visual Basic
Public Shared MsgServer_UseStatus As Integer
Visual C++
public:
static int MsgServer_UseStatus

See Also

P4ClientError Class


MsgServer_UseStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseStream
Visual Basic
Public Shared MsgServer_UseStream As Integer
Visual C++
public:
static int MsgServer_UseStream

See Also

P4ClientError Class


MsgServer_UseStreamc Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseStreamc Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseStreamc
Visual Basic
Public Shared MsgServer_UseStreamc As Integer
Visual C++
public:
static int MsgServer_UseStreamc

See Also

P4ClientError Class


MsgServer_UseStreamd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseStreamd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseStreamd
Visual Basic
Public Shared MsgServer_UseStreamd As Integer
Visual C++
public:
static int MsgServer_UseStreamd

See Also

P4ClientError Class


MsgServer_UseStreami Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseStreami Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseStreami
Visual Basic
Public Shared MsgServer_UseStreami As Integer
Visual C++
public:
static int MsgServer_UseStreami

See Also

P4ClientError Class


MsgServer_UseStreamo Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseStreamo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseStreamo
Visual Basic
Public Shared MsgServer_UseStreamo As Integer
Visual C++
public:
static int MsgServer_UseStreamo

See Also

P4ClientError Class


MsgServer_UseStreams Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseStreams Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseStreams
Visual Basic
Public Shared MsgServer_UseStreams As Integer
Visual C++
public:
static int MsgServer_UseStreams

See Also

P4ClientError Class


MsgServer_UseSubmit Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSubmit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSubmit
Visual Basic
Public Shared MsgServer_UseSubmit As Integer
Visual C++
public:
static int MsgServer_UseSubmit

See Also

P4ClientError Class


MsgServer_UseSubmitc Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSubmitc Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSubmitc
Visual Basic
Public Shared MsgServer_UseSubmitc As Integer
Visual C++
public:
static int MsgServer_UseSubmitc

See Also

P4ClientError Class


MsgServer_UseSubmitd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSubmitd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSubmitd
Visual Basic
Public Shared MsgServer_UseSubmitd As Integer
Visual C++
public:
static int MsgServer_UseSubmitd

See Also

P4ClientError Class


MsgServer_UseSubmite Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSubmite Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSubmite
Visual Basic
Public Shared MsgServer_UseSubmite As Integer
Visual C++
public:
static int MsgServer_UseSubmite

See Also

P4ClientError Class


MsgServer_UseSync Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSync Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSync
Visual Basic
Public Shared MsgServer_UseSync As Integer
Visual C++
public:
static int MsgServer_UseSync

See Also

P4ClientError Class


MsgServer_UseSyncp Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSyncp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSyncp
Visual Basic
Public Shared MsgServer_UseSyncp As Integer
Visual C++
public:
static int MsgServer_UseSyncp

See Also

P4ClientError Class


MsgServer_UseSyncs Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseSyncs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseSyncs
Visual Basic
Public Shared MsgServer_UseSyncs As Integer
Visual C++
public:
static int MsgServer_UseSyncs

See Also

P4ClientError Class


MsgServer_UseTag Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseTag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseTag
Visual Basic
Public Shared MsgServer_UseTag As Integer
Visual C++
public:
static int MsgServer_UseTag

See Also

P4ClientError Class


MsgServer_UseTrait Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseTrait Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseTrait
Visual Basic
Public Shared MsgServer_UseTrait As Integer
Visual C++
public:
static int MsgServer_UseTrait

See Also

P4ClientError Class


MsgServer_UseTraiti Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseTraiti Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseTraiti
Visual Basic
Public Shared MsgServer_UseTraiti As Integer
Visual C++
public:
static int MsgServer_UseTraiti

See Also

P4ClientError Class


MsgServer_UseTransmit Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseTransmit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseTransmit
Visual Basic
Public Shared MsgServer_UseTransmit As Integer
Visual C++
public:
static int MsgServer_UseTransmit

See Also

P4ClientError Class


MsgServer_UseTriggers Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseTriggers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseTriggers
Visual Basic
Public Shared MsgServer_UseTriggers As Integer
Visual C++
public:
static int MsgServer_UseTriggers

See Also

P4ClientError Class


MsgServer_UseTunables Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseTunables Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseTunables
Visual Basic
Public Shared MsgServer_UseTunables As Integer
Visual C++
public:
static int MsgServer_UseTunables

See Also

P4ClientError Class


MsgServer_UseTypeMap Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseTypeMap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseTypeMap
Visual Basic
Public Shared MsgServer_UseTypeMap As Integer
Visual C++
public:
static int MsgServer_UseTypeMap

See Also

P4ClientError Class


MsgServer_UseUnload Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUnload Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUnload
Visual Basic
Public Shared MsgServer_UseUnload As Integer
Visual C++
public:
static int MsgServer_UseUnload

See Also

P4ClientError Class


MsgServer_UseUnlock Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUnlock Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUnlock
Visual Basic
Public Shared MsgServer_UseUnlock As Integer
Visual C++
public:
static int MsgServer_UseUnlock

See Also

P4ClientError Class


MsgServer_UseUnshelve Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUnshelve Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUnshelve
Visual Basic
Public Shared MsgServer_UseUnshelve As Integer
Visual C++
public:
static int MsgServer_UseUnshelve

See Also

P4ClientError Class


MsgServer_UseUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUser
Visual Basic
Public Shared MsgServer_UseUser As Integer
Visual C++
public:
static int MsgServer_UseUser

See Also

P4ClientError Class


MsgServer_UseUserd Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUserd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUserd
Visual Basic
Public Shared MsgServer_UseUserd As Integer
Visual C++
public:
static int MsgServer_UseUserd

See Also

P4ClientError Class


MsgServer_UseUseri Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUseri Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUseri
Visual Basic
Public Shared MsgServer_UseUseri As Integer
Visual C++
public:
static int MsgServer_UseUseri

See Also

P4ClientError Class


MsgServer_UseUsero Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUsero Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUsero
Visual Basic
Public Shared MsgServer_UseUsero As Integer
Visual C++
public:
static int MsgServer_UseUsero

See Also

P4ClientError Class


MsgServer_UseUsers Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseUsers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseUsers
Visual Basic
Public Shared MsgServer_UseUsers As Integer
Visual C++
public:
static int MsgServer_UseUsers

See Also

P4ClientError Class


MsgServer_UseVerify Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseVerify Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseVerify
Visual Basic
Public Shared MsgServer_UseVerify As Integer
Visual C++
public:
static int MsgServer_UseVerify

See Also

P4ClientError Class


MsgServer_UseWhere Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_UseWhere Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_UseWhere
Visual Basic
Public Shared MsgServer_UseWhere As Integer
Visual C++
public:
static int MsgServer_UseWhere

See Also

P4ClientError Class


MsgServer_VersionedStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_VersionedStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_VersionedStream
Visual Basic
Public Shared MsgServer_VersionedStream As Integer
Visual C++
public:
static int MsgServer_VersionedStream

See Also

P4ClientError Class


MsgServer_WeakPassword Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_WeakPassword Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_WeakPassword
Visual Basic
Public Shared MsgServer_WeakPassword As Integer
Visual C++
public:
static int MsgServer_WeakPassword

See Also

P4ClientError Class


MsgServer_ZFlagsConflict Field

[image]

Perforce .NET API
P4ClientError..::..MsgServer_ZFlagsConflict Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgServer_ZFlagsConflict
Visual Basic
Public Shared MsgServer_ZFlagsConflict As Integer
Visual C++
public:
static int MsgServer_ZFlagsConflict

See Also

P4ClientError Class


MsgSpec_SpecBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecBranch
Visual Basic
Public Shared MsgSpec_SpecBranch As Integer
Visual C++
public:
static int MsgSpec_SpecBranch

See Also

P4ClientError Class


MsgSpec_SpecChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecChange
Visual Basic
Public Shared MsgSpec_SpecChange As Integer
Visual C++
public:
static int MsgSpec_SpecChange

See Also

P4ClientError Class


MsgSpec_SpecClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecClient
Visual Basic
Public Shared MsgSpec_SpecClient As Integer
Visual C++
public:
static int MsgSpec_SpecClient

See Also

P4ClientError Class


MsgSpec_SpecDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecDepot
Visual Basic
Public Shared MsgSpec_SpecDepot As Integer
Visual C++
public:
static int MsgSpec_SpecDepot

See Also

P4ClientError Class


MsgSpec_SpecEditSpec Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecEditSpec Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecEditSpec
Visual Basic
Public Shared MsgSpec_SpecEditSpec As Integer
Visual C++
public:
static int MsgSpec_SpecEditSpec

See Also

P4ClientError Class


MsgSpec_SpecGroup Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecGroup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecGroup
Visual Basic
Public Shared MsgSpec_SpecGroup As Integer
Visual C++
public:
static int MsgSpec_SpecGroup

See Also

P4ClientError Class


MsgSpec_SpecJob Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecJob Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecJob
Visual Basic
Public Shared MsgSpec_SpecJob As Integer
Visual C++
public:
static int MsgSpec_SpecJob

See Also

P4ClientError Class


MsgSpec_SpecLabel Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecLabel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecLabel
Visual Basic
Public Shared MsgSpec_SpecLabel As Integer
Visual C++
public:
static int MsgSpec_SpecLabel

See Also

P4ClientError Class


MsgSpec_SpecLicense Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecLicense Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecLicense
Visual Basic
Public Shared MsgSpec_SpecLicense As Integer
Visual C++
public:
static int MsgSpec_SpecLicense

See Also

P4ClientError Class


MsgSpec_SpecProtect Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecProtect Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecProtect
Visual Basic
Public Shared MsgSpec_SpecProtect As Integer
Visual C++
public:
static int MsgSpec_SpecProtect

See Also

P4ClientError Class


MsgSpec_SpecServer Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecServer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecServer
Visual Basic
Public Shared MsgSpec_SpecServer As Integer
Visual C++
public:
static int MsgSpec_SpecServer

See Also

P4ClientError Class


MsgSpec_SpecStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecStream
Visual Basic
Public Shared MsgSpec_SpecStream As Integer
Visual C++
public:
static int MsgSpec_SpecStream

See Also

P4ClientError Class


MsgSpec_SpecTrigger Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecTrigger Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecTrigger
Visual Basic
Public Shared MsgSpec_SpecTrigger As Integer
Visual C++
public:
static int MsgSpec_SpecTrigger

See Also

P4ClientError Class


MsgSpec_SpecTypeMap Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecTypeMap Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecTypeMap
Visual Basic
Public Shared MsgSpec_SpecTypeMap As Integer
Visual C++
public:
static int MsgSpec_SpecTypeMap

See Also

P4ClientError Class


MsgSpec_SpecUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgSpec_SpecUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSpec_SpecUser
Visual Basic
Public Shared MsgSpec_SpecUser As Integer
Visual C++
public:
static int MsgSpec_SpecUser

See Also

P4ClientError Class


MsgSupp_BadMangleParams Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_BadMangleParams Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_BadMangleParams
Visual Basic
Public Shared MsgSupp_BadMangleParams As Integer
Visual C++
public:
static int MsgSupp_BadMangleParams

See Also

P4ClientError Class


MsgSupp_BadOS Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_BadOS Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_BadOS
Visual Basic
Public Shared MsgSupp_BadOS As Integer
Visual C++
public:
static int MsgSupp_BadOS

See Also

P4ClientError Class


MsgSupp_ConvertFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ConvertFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ConvertFailed
Visual Basic
Public Shared MsgSupp_ConvertFailed As Integer
Visual C++
public:
static int MsgSupp_ConvertFailed

See Also

P4ClientError Class


MsgSupp_Deflate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_Deflate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_Deflate
Visual Basic
Public Shared MsgSupp_Deflate As Integer
Visual C++
public:
static int MsgSupp_Deflate

See Also

P4ClientError Class


MsgSupp_DeflateEnd Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_DeflateEnd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_DeflateEnd
Visual Basic
Public Shared MsgSupp_DeflateEnd As Integer
Visual C++
public:
static int MsgSupp_DeflateEnd

See Also

P4ClientError Class


MsgSupp_DeflateInit Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_DeflateInit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_DeflateInit
Visual Basic
Public Shared MsgSupp_DeflateInit As Integer
Visual C++
public:
static int MsgSupp_DeflateInit

See Also

P4ClientError Class


MsgSupp_ExtraArg Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ExtraArg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ExtraArg
Visual Basic
Public Shared MsgSupp_ExtraArg As Integer
Visual C++
public:
static int MsgSupp_ExtraArg

See Also

P4ClientError Class


MsgSupp_HidesVar Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_HidesVar Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_HidesVar
Visual Basic
Public Shared MsgSupp_HidesVar As Integer
Visual C++
public:
static int MsgSupp_HidesVar

See Also

P4ClientError Class


MsgSupp_Inflate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_Inflate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_Inflate
Visual Basic
Public Shared MsgSupp_Inflate As Integer
Visual C++
public:
static int MsgSupp_Inflate

See Also

P4ClientError Class


MsgSupp_InflateInit Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_InflateInit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_InflateInit
Visual Basic
Public Shared MsgSupp_InflateInit As Integer
Visual C++
public:
static int MsgSupp_InflateInit

See Also

P4ClientError Class


MsgSupp_Invalid Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_Invalid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_Invalid
Visual Basic
Public Shared MsgSupp_Invalid As Integer
Visual C++
public:
static int MsgSupp_Invalid

See Also

P4ClientError Class


MsgSupp_InvalidCharset Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_InvalidCharset Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_InvalidCharset
Visual Basic
Public Shared MsgSupp_InvalidCharset As Integer
Visual C++
public:
static int MsgSupp_InvalidCharset

See Also

P4ClientError Class


MsgSupp_InvalidDate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_InvalidDate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_InvalidDate
Visual Basic
Public Shared MsgSupp_InvalidDate As Integer
Visual C++
public:
static int MsgSupp_InvalidDate

See Also

P4ClientError Class


MsgSupp_MagicHeader Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_MagicHeader Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_MagicHeader
Visual Basic
Public Shared MsgSupp_MagicHeader As Integer
Visual C++
public:
static int MsgSupp_MagicHeader

See Also

P4ClientError Class


MsgSupp_Needs2Arg Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_Needs2Arg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_Needs2Arg
Visual Basic
Public Shared MsgSupp_Needs2Arg As Integer
Visual C++
public:
static int MsgSupp_Needs2Arg

See Also

P4ClientError Class


MsgSupp_NeedsArg Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NeedsArg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NeedsArg
Visual Basic
Public Shared MsgSupp_NeedsArg As Integer
Visual C++
public:
static int MsgSupp_NeedsArg

See Also

P4ClientError Class


MsgSupp_NeedsNonNegArg Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NeedsNonNegArg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NeedsNonNegArg
Visual Basic
Public Shared MsgSupp_NeedsNonNegArg As Integer
Visual C++
public:
static int MsgSupp_NeedsNonNegArg

See Also

P4ClientError Class


MsgSupp_NoP4Config Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NoP4Config Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NoP4Config
Visual Basic
Public Shared MsgSupp_NoP4Config As Integer
Visual C++
public:
static int MsgSupp_NoP4Config

See Also

P4ClientError Class


MsgSupp_NoParm Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NoParm Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NoParm
Visual Basic
Public Shared MsgSupp_NoParm As Integer
Visual C++
public:
static int MsgSupp_NoParm

See Also

P4ClientError Class


MsgSupp_NoSuchVariable Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NoSuchVariable Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NoSuchVariable
Visual Basic
Public Shared MsgSupp_NoSuchVariable As Integer
Visual C++
public:
static int MsgSupp_NoSuchVariable

See Also

P4ClientError Class


MsgSupp_NotImplemented Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NotImplemented Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NotImplemented
Visual Basic
Public Shared MsgSupp_NotImplemented As Integer
Visual C++
public:
static int MsgSupp_NotImplemented

See Also

P4ClientError Class


MsgSupp_NoTrans Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NoTrans Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NoTrans
Visual Basic
Public Shared MsgSupp_NoTrans As Integer
Visual C++
public:
static int MsgSupp_NoTrans

See Also

P4ClientError Class


MsgSupp_NoTransVar Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NoTransVar Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NoTransVar
Visual Basic
Public Shared MsgSupp_NoTransVar As Integer
Visual C++
public:
static int MsgSupp_NoTransVar

See Also

P4ClientError Class


MsgSupp_NoUnixReg Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_NoUnixReg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_NoUnixReg
Visual Basic
Public Shared MsgSupp_NoUnixReg As Integer
Visual C++
public:
static int MsgSupp_NoUnixReg

See Also

P4ClientError Class


MsgSupp_OptionAcceptFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAcceptFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAcceptFlags
Visual Basic
Public Shared MsgSupp_OptionAcceptFlags As Integer
Visual C++
public:
static int MsgSupp_OptionAcceptFlags

See Also

P4ClientError Class


MsgSupp_OptionAdministrator Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAdministrator Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAdministrator
Visual Basic
Public Shared MsgSupp_OptionAdministrator As Integer
Visual C++
public:
static int MsgSupp_OptionAdministrator

See Also

P4ClientError Class


MsgSupp_OptionAfterContext Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAfterContext Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAfterContext
Visual Basic
Public Shared MsgSupp_OptionAfterContext As Integer
Visual C++
public:
static int MsgSupp_OptionAfterContext

See Also

P4ClientError Class


MsgSupp_OptionAll Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAll Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAll
Visual Basic
Public Shared MsgSupp_OptionAll As Integer
Visual C++
public:
static int MsgSupp_OptionAll

See Also

P4ClientError Class


MsgSupp_OptionAllClients Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAllClients Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAllClients
Visual Basic
Public Shared MsgSupp_OptionAllClients As Integer
Visual C++
public:
static int MsgSupp_OptionAllClients

See Also

P4ClientError Class


MsgSupp_OptionAllUsers Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAllUsers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAllUsers
Visual Basic
Public Shared MsgSupp_OptionAllUsers As Integer
Visual C++
public:
static int MsgSupp_OptionAllUsers

See Also

P4ClientError Class


MsgSupp_OptionAppend Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAppend Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAppend
Visual Basic
Public Shared MsgSupp_OptionAppend As Integer
Visual C++
public:
static int MsgSupp_OptionAppend

See Also

P4ClientError Class


MsgSupp_OptionArchive Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionArchive Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionArchive
Visual Basic
Public Shared MsgSupp_OptionArchive As Integer
Visual C++
public:
static int MsgSupp_OptionArchive

See Also

P4ClientError Class


MsgSupp_OptionArchiveData Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionArchiveData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionArchiveData
Visual Basic
Public Shared MsgSupp_OptionArchiveData As Integer
Visual C++
public:
static int MsgSupp_OptionArchiveData

See Also

P4ClientError Class


MsgSupp_OptionArguments Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionArguments Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionArguments
Visual Basic
Public Shared MsgSupp_OptionArguments As Integer
Visual C++
public:
static int MsgSupp_OptionArguments

See Also

P4ClientError Class


MsgSupp_OptionAttrPattern Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionAttrPattern Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionAttrPattern
Visual Basic
Public Shared MsgSupp_OptionAttrPattern As Integer
Visual C++
public:
static int MsgSupp_OptionAttrPattern

See Also

P4ClientError Class


MsgSupp_OptionBackoff Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBackoff Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBackoff
Visual Basic
Public Shared MsgSupp_OptionBackoff As Integer
Visual C++
public:
static int MsgSupp_OptionBackoff

See Also

P4ClientError Class


MsgSupp_OptionBasicRegexp Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBasicRegexp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBasicRegexp
Visual Basic
Public Shared MsgSupp_OptionBasicRegexp As Integer
Visual C++
public:
static int MsgSupp_OptionBasicRegexp

See Also

P4ClientError Class


MsgSupp_OptionBatchsize Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBatchsize Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBatchsize
Visual Basic
Public Shared MsgSupp_OptionBatchsize As Integer
Visual C++
public:
static int MsgSupp_OptionBatchsize

See Also

P4ClientError Class


MsgSupp_OptionBeforeContext Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBeforeContext Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBeforeContext
Visual Basic
Public Shared MsgSupp_OptionBeforeContext As Integer
Visual C++
public:
static int MsgSupp_OptionBeforeContext

See Also

P4ClientError Class


MsgSupp_OptionBinaryAsText Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBinaryAsText Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBinaryAsText
Visual Basic
Public Shared MsgSupp_OptionBinaryAsText As Integer
Visual C++
public:
static int MsgSupp_OptionBinaryAsText

See Also

P4ClientError Class


MsgSupp_OptionBlocksize Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBlocksize Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBlocksize
Visual Basic
Public Shared MsgSupp_OptionBlocksize As Integer
Visual C++
public:
static int MsgSupp_OptionBlocksize

See Also

P4ClientError Class


MsgSupp_OptionBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBranch
Visual Basic
Public Shared MsgSupp_OptionBranch As Integer
Visual C++
public:
static int MsgSupp_OptionBranch

See Also

P4ClientError Class


MsgSupp_OptionBrief Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBrief Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBrief
Visual Basic
Public Shared MsgSupp_OptionBrief As Integer
Visual C++
public:
static int MsgSupp_OptionBrief

See Also

P4ClientError Class


MsgSupp_OptionBypassFlow Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionBypassFlow Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionBypassFlow
Visual Basic
Public Shared MsgSupp_OptionBypassFlow As Integer
Visual C++
public:
static int MsgSupp_OptionBypassFlow

See Also

P4ClientError Class


MsgSupp_OptionCentralUsers Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionCentralUsers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionCentralUsers
Visual Basic
Public Shared MsgSupp_OptionCentralUsers As Integer
Visual C++
public:
static int MsgSupp_OptionCentralUsers

See Also

P4ClientError Class


MsgSupp_OptionChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionChange
Visual Basic
Public Shared MsgSupp_OptionChange As Integer
Visual C++
public:
static int MsgSupp_OptionChange

See Also

P4ClientError Class


MsgSupp_OptionChangeStatus Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionChangeStatus Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionChangeStatus
Visual Basic
Public Shared MsgSupp_OptionChangeStatus As Integer
Visual C++
public:
static int MsgSupp_OptionChangeStatus

See Also

P4ClientError Class


MsgSupp_OptionChangeType Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionChangeType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionChangeType
Visual Basic
Public Shared MsgSupp_OptionChangeType As Integer
Visual C++
public:
static int MsgSupp_OptionChangeType

See Also

P4ClientError Class


MsgSupp_OptionChangeUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionChangeUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionChangeUpdate
Visual Basic
Public Shared MsgSupp_OptionChangeUpdate As Integer
Visual C++
public:
static int MsgSupp_OptionChangeUpdate

See Also

P4ClientError Class


MsgSupp_OptionChangeUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionChangeUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionChangeUser
Visual Basic
Public Shared MsgSupp_OptionChangeUser As Integer
Visual C++
public:
static int MsgSupp_OptionChangeUser

See Also

P4ClientError Class


MsgSupp_OptionCharset Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionCharset Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionCharset
Visual Basic
Public Shared MsgSupp_OptionCharset As Integer
Visual C++
public:
static int MsgSupp_OptionCharset

See Also

P4ClientError Class


MsgSupp_OptionCheckSize Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionCheckSize Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionCheckSize
Visual Basic
Public Shared MsgSupp_OptionCheckSize As Integer
Visual C++
public:
static int MsgSupp_OptionCheckSize

See Also

P4ClientError Class


MsgSupp_OptionClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionClient
Visual Basic
Public Shared MsgSupp_OptionClient As Integer
Visual C++
public:
static int MsgSupp_OptionClient

See Also

P4ClientError Class


MsgSupp_OptionClientName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionClientName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionClientName
Visual Basic
Public Shared MsgSupp_OptionClientName As Integer
Visual C++
public:
static int MsgSupp_OptionClientName

See Also

P4ClientError Class


MsgSupp_OptionCmdCharset Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionCmdCharset Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionCmdCharset
Visual Basic
Public Shared MsgSupp_OptionCmdCharset As Integer
Visual C++
public:
static int MsgSupp_OptionCmdCharset

See Also

P4ClientError Class


MsgSupp_OptionCompress Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionCompress Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionCompress
Visual Basic
Public Shared MsgSupp_OptionCompress As Integer
Visual C++
public:
static int MsgSupp_OptionCompress

See Also

P4ClientError Class


MsgSupp_OptionCompressCkp Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionCompressCkp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionCompressCkp
Visual Basic
Public Shared MsgSupp_OptionCompressCkp As Integer
Visual C++
public:
static int MsgSupp_OptionCompressCkp

See Also

P4ClientError Class


MsgSupp_OptionContent Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionContent Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionContent
Visual Basic
Public Shared MsgSupp_OptionContent As Integer
Visual C++
public:
static int MsgSupp_OptionContent

See Also

P4ClientError Class


MsgSupp_OptionContext Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionContext Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionContext
Visual Basic
Public Shared MsgSupp_OptionContext As Integer
Visual C++
public:
static int MsgSupp_OptionContext

See Also

P4ClientError Class


MsgSupp_OptionCounter Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionCounter Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionCounter
Visual Basic
Public Shared MsgSupp_OptionCounter As Integer
Visual C++
public:
static int MsgSupp_OptionCounter

See Also

P4ClientError Class


MsgSupp_OptionData Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionData
Visual Basic
Public Shared MsgSupp_OptionData As Integer
Visual C++
public:
static int MsgSupp_OptionData

See Also

P4ClientError Class


MsgSupp_OptionDate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDate
Visual Basic
Public Shared MsgSupp_OptionDate As Integer
Visual C++
public:
static int MsgSupp_OptionDate

See Also

P4ClientError Class


MsgSupp_OptionDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDelete
Visual Basic
Public Shared MsgSupp_OptionDelete As Integer
Visual C++
public:
static int MsgSupp_OptionDelete

See Also

P4ClientError Class


MsgSupp_OptionDeleteFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDeleteFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDeleteFlags
Visual Basic
Public Shared MsgSupp_OptionDeleteFlags As Integer
Visual C++
public:
static int MsgSupp_OptionDeleteFlags

See Also

P4ClientError Class


MsgSupp_OptionDepot Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDepot Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDepot
Visual Basic
Public Shared MsgSupp_OptionDepot As Integer
Visual C++
public:
static int MsgSupp_OptionDepot

See Also

P4ClientError Class


MsgSupp_OptionDescription Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDescription Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDescription
Visual Basic
Public Shared MsgSupp_OptionDescription As Integer
Visual C++
public:
static int MsgSupp_OptionDescription

See Also

P4ClientError Class


MsgSupp_OptionDiffFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDiffFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDiffFlags
Visual Basic
Public Shared MsgSupp_OptionDiffFlags As Integer
Visual C++
public:
static int MsgSupp_OptionDiffFlags

See Also

P4ClientError Class


MsgSupp_OptionDiffListFlag Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDiffListFlag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDiffListFlag
Visual Basic
Public Shared MsgSupp_OptionDiffListFlag As Integer
Visual C++
public:
static int MsgSupp_OptionDiffListFlag

See Also

P4ClientError Class


MsgSupp_OptionDirectory Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDirectory Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDirectory
Visual Basic
Public Shared MsgSupp_OptionDirectory As Integer
Visual C++
public:
static int MsgSupp_OptionDirectory

See Also

P4ClientError Class


MsgSupp_OptionDowngrade Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionDowngrade Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionDowngrade
Visual Basic
Public Shared MsgSupp_OptionDowngrade As Integer
Visual C++
public:
static int MsgSupp_OptionDowngrade

See Also

P4ClientError Class


MsgSupp_OptionEncoded Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionEncoded Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionEncoded
Visual Basic
Public Shared MsgSupp_OptionEncoded As Integer
Visual C++
public:
static int MsgSupp_OptionEncoded

See Also

P4ClientError Class


MsgSupp_OptionEnvironment Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionEnvironment Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionEnvironment
Visual Basic
Public Shared MsgSupp_OptionEnvironment As Integer
Visual C++
public:
static int MsgSupp_OptionEnvironment

See Also

P4ClientError Class


MsgSupp_OptionEqual Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionEqual Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionEqual
Visual Basic
Public Shared MsgSupp_OptionEqual As Integer
Visual C++
public:
static int MsgSupp_OptionEqual

See Also

P4ClientError Class


MsgSupp_OptionEstimates Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionEstimates Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionEstimates
Visual Basic
Public Shared MsgSupp_OptionEstimates As Integer
Visual C++
public:
static int MsgSupp_OptionEstimates

See Also

P4ClientError Class


MsgSupp_OptionExcludeTables Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionExcludeTables Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionExcludeTables
Visual Basic
Public Shared MsgSupp_OptionExcludeTables As Integer
Visual C++
public:
static int MsgSupp_OptionExcludeTables

See Also

P4ClientError Class


MsgSupp_OptionExclusive Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionExclusive Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionExclusive
Visual Basic
Public Shared MsgSupp_OptionExclusive As Integer
Visual C++
public:
static int MsgSupp_OptionExclusive

See Also

P4ClientError Class


MsgSupp_OptionExists Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionExists Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionExists
Visual Basic
Public Shared MsgSupp_OptionExists As Integer
Visual C++
public:
static int MsgSupp_OptionExists

See Also

P4ClientError Class


MsgSupp_OptionExpression Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionExpression Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionExpression
Visual Basic
Public Shared MsgSupp_OptionExpression As Integer
Visual C++
public:
static int MsgSupp_OptionExpression

See Also

P4ClientError Class


MsgSupp_OptionExtendedRegexp Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionExtendedRegexp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionExtendedRegexp
Visual Basic
Public Shared MsgSupp_OptionExtendedRegexp As Integer
Visual C++
public:
static int MsgSupp_OptionExtendedRegexp

See Also

P4ClientError Class


MsgSupp_OptionFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFile
Visual Basic
Public Shared MsgSupp_OptionFile As Integer
Visual C++
public:
static int MsgSupp_OptionFile

See Also

P4ClientError Class


MsgSupp_OptionFileCharset Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFileCharset Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFileCharset
Visual Basic
Public Shared MsgSupp_OptionFileCharset As Integer
Visual C++
public:
static int MsgSupp_OptionFileCharset

See Also

P4ClientError Class


MsgSupp_OptionFilesWithMatches Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFilesWithMatches Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFilesWithMatches
Visual Basic
Public Shared MsgSupp_OptionFilesWithMatches As Integer
Visual C++
public:
static int MsgSupp_OptionFilesWithMatches

See Also

P4ClientError Class


MsgSupp_OptionFilesWithoutMatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFilesWithoutMatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFilesWithoutMatch
Visual Basic
Public Shared MsgSupp_OptionFilesWithoutMatch As Integer
Visual C++
public:
static int MsgSupp_OptionFilesWithoutMatch

See Also

P4ClientError Class


MsgSupp_OptionFiletype Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFiletype Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFiletype
Visual Basic
Public Shared MsgSupp_OptionFiletype As Integer
Visual C++
public:
static int MsgSupp_OptionFiletype

See Also

P4ClientError Class


MsgSupp_OptionFilter Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFilter Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFilter
Visual Basic
Public Shared MsgSupp_OptionFilter As Integer
Visual C++
public:
static int MsgSupp_OptionFilter

See Also

P4ClientError Class


MsgSupp_OptionFixedStrings Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFixedStrings Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFixedStrings
Visual Basic
Public Shared MsgSupp_OptionFixedStrings As Integer
Visual C++
public:
static int MsgSupp_OptionFixedStrings

See Also

P4ClientError Class


MsgSupp_OptionFixStatus Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFixStatus Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFixStatus
Visual Basic
Public Shared MsgSupp_OptionFixStatus As Integer
Visual C++
public:
static int MsgSupp_OptionFixStatus

See Also

P4ClientError Class


MsgSupp_OptionFollowBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFollowBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFollowBranch
Visual Basic
Public Shared MsgSupp_OptionFollowBranch As Integer
Visual C++
public:
static int MsgSupp_OptionFollowBranch

See Also

P4ClientError Class


MsgSupp_OptionFollowInteg Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFollowInteg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFollowInteg
Visual Basic
Public Shared MsgSupp_OptionFollowInteg As Integer
Visual C++
public:
static int MsgSupp_OptionFollowInteg

See Also

P4ClientError Class


MsgSupp_OptionForce Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionForce Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionForce
Visual Basic
Public Shared MsgSupp_OptionForce As Integer
Visual C++
public:
static int MsgSupp_OptionForce

See Also

P4ClientError Class


MsgSupp_OptionForceFlag Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionForceFlag Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionForceFlag
Visual Basic
Public Shared MsgSupp_OptionForceFlag As Integer
Visual C++
public:
static int MsgSupp_OptionForceFlag

See Also

P4ClientError Class


MsgSupp_OptionForceText Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionForceText Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionForceText
Visual Basic
Public Shared MsgSupp_OptionForceText As Integer
Visual C++
public:
static int MsgSupp_OptionForceText

See Also

P4ClientError Class


MsgSupp_OptionFrom Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFrom Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFrom
Visual Basic
Public Shared MsgSupp_OptionFrom As Integer
Visual C++
public:
static int MsgSupp_OptionFrom

See Also

P4ClientError Class


MsgSupp_OptionFullBranch Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionFullBranch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionFullBranch
Visual Basic
Public Shared MsgSupp_OptionFullBranch As Integer
Visual C++
public:
static int MsgSupp_OptionFullBranch

See Also

P4ClientError Class


MsgSupp_OptionGenerate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionGenerate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionGenerate
Visual Basic
Public Shared MsgSupp_OptionGenerate As Integer
Visual C++
public:
static int MsgSupp_OptionGenerate

See Also

P4ClientError Class


MsgSupp_OptionGlobal Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionGlobal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionGlobal
Visual Basic
Public Shared MsgSupp_OptionGlobal As Integer
Visual C++
public:
static int MsgSupp_OptionGlobal

See Also

P4ClientError Class


MsgSupp_OptionGroupName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionGroupName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionGroupName
Visual Basic
Public Shared MsgSupp_OptionGroupName As Integer
Visual C++
public:
static int MsgSupp_OptionGroupName

See Also

P4ClientError Class


MsgSupp_OptionHelp Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionHelp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionHelp
Visual Basic
Public Shared MsgSupp_OptionHelp As Integer
Visual C++
public:
static int MsgSupp_OptionHelp

See Also

P4ClientError Class


MsgSupp_OptionHistogram Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionHistogram Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionHistogram
Visual Basic
Public Shared MsgSupp_OptionHistogram As Integer
Visual C++
public:
static int MsgSupp_OptionHistogram

See Also

P4ClientError Class


MsgSupp_OptionHost Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionHost Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionHost
Visual Basic
Public Shared MsgSupp_OptionHost As Integer
Visual C++
public:
static int MsgSupp_OptionHost

See Also

P4ClientError Class


MsgSupp_OptionHostName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionHostName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionHostName
Visual Basic
Public Shared MsgSupp_OptionHostName As Integer
Visual C++
public:
static int MsgSupp_OptionHostName

See Also

P4ClientError Class


MsgSupp_OptionHuman1000 Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionHuman1000 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionHuman1000
Visual Basic
Public Shared MsgSupp_OptionHuman1000 As Integer
Visual C++
public:
static int MsgSupp_OptionHuman1000

See Also

P4ClientError Class


MsgSupp_OptionHuman1024 Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionHuman1024 Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionHuman1024
Visual Basic
Public Shared MsgSupp_OptionHuman1024 As Integer
Visual C++
public:
static int MsgSupp_OptionHuman1024

See Also

P4ClientError Class


MsgSupp_OptionIgnoreCase Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionIgnoreCase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionIgnoreCase
Visual Basic
Public Shared MsgSupp_OptionIgnoreCase As Integer
Visual C++
public:
static int MsgSupp_OptionIgnoreCase

See Also

P4ClientError Class


MsgSupp_OptionIncrement Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionIncrement Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionIncrement
Visual Basic
Public Shared MsgSupp_OptionIncrement As Integer
Visual C++
public:
static int MsgSupp_OptionIncrement

See Also

P4ClientError Class


MsgSupp_OptionInherited Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionInherited Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionInherited
Visual Basic
Public Shared MsgSupp_OptionInherited As Integer
Visual C++
public:
static int MsgSupp_OptionInherited

See Also

P4ClientError Class


MsgSupp_OptionInput Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionInput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionInput
Visual Basic
Public Shared MsgSupp_OptionInput As Integer
Visual C++
public:
static int MsgSupp_OptionInput

See Also

P4ClientError Class


MsgSupp_OptionInputFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionInputFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionInputFile
Visual Basic
Public Shared MsgSupp_OptionInputFile As Integer
Visual C++
public:
static int MsgSupp_OptionInputFile

See Also

P4ClientError Class


MsgSupp_OptionInputValue Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionInputValue Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionInputValue
Visual Basic
Public Shared MsgSupp_OptionInputValue As Integer
Visual C++
public:
static int MsgSupp_OptionInputValue

See Also

P4ClientError Class


MsgSupp_OptionIntegFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionIntegFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionIntegFlags
Visual Basic
Public Shared MsgSupp_OptionIntegFlags As Integer
Visual C++
public:
static int MsgSupp_OptionIntegFlags

See Also

P4ClientError Class


MsgSupp_OptionInvertMatch Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionInvertMatch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionInvertMatch
Visual Basic
Public Shared MsgSupp_OptionInvertMatch As Integer
Visual C++
public:
static int MsgSupp_OptionInvertMatch

See Also

P4ClientError Class


MsgSupp_OptionIsGroup Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionIsGroup Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionIsGroup
Visual Basic
Public Shared MsgSupp_OptionIsGroup As Integer
Visual C++
public:
static int MsgSupp_OptionIsGroup

See Also

P4ClientError Class


MsgSupp_OptionIsOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionIsOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionIsOwner
Visual Basic
Public Shared MsgSupp_OptionIsOwner As Integer
Visual C++
public:
static int MsgSupp_OptionIsOwner

See Also

P4ClientError Class


MsgSupp_OptionIsUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionIsUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionIsUser
Visual Basic
Public Shared MsgSupp_OptionIsUser As Integer
Visual C++
public:
static int MsgSupp_OptionIsUser

See Also

P4ClientError Class


MsgSupp_OptionJob Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionJob Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionJob
Visual Basic
Public Shared MsgSupp_OptionJob As Integer
Visual C++
public:
static int MsgSupp_OptionJob

See Also

P4ClientError Class


MsgSupp_OptionJournalPosition Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionJournalPosition Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionJournalPosition
Visual Basic
Public Shared MsgSupp_OptionJournalPosition As Integer
Visual C++
public:
static int MsgSupp_OptionJournalPosition

See Also

P4ClientError Class


MsgSupp_OptionJournalPrefix Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionJournalPrefix Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionJournalPrefix
Visual Basic
Public Shared MsgSupp_OptionJournalPrefix As Integer
Visual C++
public:
static int MsgSupp_OptionJournalPrefix

See Also

P4ClientError Class


MsgSupp_OptionKeepClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionKeepClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionKeepClient
Visual Basic
Public Shared MsgSupp_OptionKeepClient As Integer
Visual C++
public:
static int MsgSupp_OptionKeepClient

See Also

P4ClientError Class


MsgSupp_OptionKeepHave Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionKeepHave Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionKeepHave
Visual Basic
Public Shared MsgSupp_OptionKeepHave As Integer
Visual C++
public:
static int MsgSupp_OptionKeepHave

See Also

P4ClientError Class


MsgSupp_OptionKeepHead Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionKeepHead Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionKeepHead
Visual Basic
Public Shared MsgSupp_OptionKeepHead As Integer
Visual C++
public:
static int MsgSupp_OptionKeepHead

See Also

P4ClientError Class


MsgSupp_OptionLabelName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLabelName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLabelName
Visual Basic
Public Shared MsgSupp_OptionLabelName As Integer
Visual C++
public:
static int MsgSupp_OptionLabelName

See Also

P4ClientError Class


MsgSupp_OptionLeaveKeywords Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLeaveKeywords Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLeaveKeywords
Visual Basic
Public Shared MsgSupp_OptionLeaveKeywords As Integer
Visual C++
public:
static int MsgSupp_OptionLeaveKeywords

See Also

P4ClientError Class


MsgSupp_OptionLimitClient Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLimitClient Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLimitClient
Visual Basic
Public Shared MsgSupp_OptionLimitClient As Integer
Visual C++
public:
static int MsgSupp_OptionLimitClient

See Also

P4ClientError Class


MsgSupp_OptionLineNumber Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLineNumber Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLineNumber
Visual Basic
Public Shared MsgSupp_OptionLineNumber As Integer
Visual C++
public:
static int MsgSupp_OptionLineNumber

See Also

P4ClientError Class


MsgSupp_OptionLocal Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLocal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLocal
Visual Basic
Public Shared MsgSupp_OptionLocal As Integer
Visual C++
public:
static int MsgSupp_OptionLocal

See Also

P4ClientError Class


MsgSupp_OptionLocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLocked
Visual Basic
Public Shared MsgSupp_OptionLocked As Integer
Visual C++
public:
static int MsgSupp_OptionLocked

See Also

P4ClientError Class


MsgSupp_OptionLoginStatus Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLoginStatus Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLoginStatus
Visual Basic
Public Shared MsgSupp_OptionLoginStatus As Integer
Visual C++
public:
static int MsgSupp_OptionLoginStatus

See Also

P4ClientError Class


MsgSupp_OptionLogName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLogName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLogName
Visual Basic
Public Shared MsgSupp_OptionLogName As Integer
Visual C++
public:
static int MsgSupp_OptionLogName

See Also

P4ClientError Class


MsgSupp_OptionLong Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionLong Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionLong
Visual Basic
Public Shared MsgSupp_OptionLong As Integer
Visual C++
public:
static int MsgSupp_OptionLong

See Also

P4ClientError Class


MsgSupp_OptionMax Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionMax Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionMax
Visual Basic
Public Shared MsgSupp_OptionMax As Integer
Visual C++
public:
static int MsgSupp_OptionMax

See Also

P4ClientError Class


MsgSupp_OptionMaxAccess Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionMaxAccess Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionMaxAccess
Visual Basic
Public Shared MsgSupp_OptionMaxAccess As Integer
Visual C++
public:
static int MsgSupp_OptionMaxAccess

See Also

P4ClientError Class


MsgSupp_OptionMessageType Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionMessageType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionMessageType
Visual Basic
Public Shared MsgSupp_OptionMessageType As Integer
Visual C++
public:
static int MsgSupp_OptionMessageType

See Also

P4ClientError Class


MsgSupp_OptionName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionName
Visual Basic
Public Shared MsgSupp_OptionName As Integer
Visual C++
public:
static int MsgSupp_OptionName

See Also

P4ClientError Class


MsgSupp_OptionNo Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionNo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionNo
Visual Basic
Public Shared MsgSupp_OptionNo As Integer
Visual C++
public:
static int MsgSupp_OptionNo

See Also

P4ClientError Class


MsgSupp_OptionNoArchive Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionNoArchive Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionNoArchive
Visual Basic
Public Shared MsgSupp_OptionNoArchive As Integer
Visual C++
public:
static int MsgSupp_OptionNoArchive

See Also

P4ClientError Class


MsgSupp_OptionNoCaseExpr Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionNoCaseExpr Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionNoCaseExpr
Visual Basic
Public Shared MsgSupp_OptionNoCaseExpr As Integer
Visual C++
public:
static int MsgSupp_OptionNoCaseExpr

See Also

P4ClientError Class


MsgSupp_OptionNoIgnore Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionNoIgnore Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionNoIgnore
Visual Basic
Public Shared MsgSupp_OptionNoIgnore As Integer
Visual C++
public:
static int MsgSupp_OptionNoIgnore

See Also

P4ClientError Class


MsgSupp_OptionNoMessages Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionNoMessages Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionNoMessages
Visual Basic
Public Shared MsgSupp_OptionNoMessages As Integer
Visual C++
public:
static int MsgSupp_OptionNoMessages

See Also

P4ClientError Class


MsgSupp_OptionNoRejournal Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionNoRejournal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionNoRejournal
Visual Basic
Public Shared MsgSupp_OptionNoRejournal As Integer
Visual C++
public:
static int MsgSupp_OptionNoRejournal

See Also

P4ClientError Class


MsgSupp_OptionOmitLazy Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOmitLazy Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOmitLazy
Visual Basic
Public Shared MsgSupp_OptionOmitLazy As Integer
Visual C++
public:
static int MsgSupp_OptionOmitLazy

See Also

P4ClientError Class


MsgSupp_OptionOmitMoved Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOmitMoved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOmitMoved
Visual Basic
Public Shared MsgSupp_OptionOmitMoved As Integer
Visual C++
public:
static int MsgSupp_OptionOmitMoved

See Also

P4ClientError Class


MsgSupp_OptionOmitPromoted Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOmitPromoted Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOmitPromoted
Visual Basic
Public Shared MsgSupp_OptionOmitPromoted As Integer
Visual C++
public:
static int MsgSupp_OptionOmitPromoted

See Also

P4ClientError Class


MsgSupp_OptionOpenAdd Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOpenAdd Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOpenAdd
Visual Basic
Public Shared MsgSupp_OptionOpenAdd As Integer
Visual C++
public:
static int MsgSupp_OptionOpenAdd

See Also

P4ClientError Class


MsgSupp_OptionOpenDelete Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOpenDelete Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOpenDelete
Visual Basic
Public Shared MsgSupp_OptionOpenDelete As Integer
Visual C++
public:
static int MsgSupp_OptionOpenDelete

See Also

P4ClientError Class


MsgSupp_OptionOpenEdit Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOpenEdit Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOpenEdit
Visual Basic
Public Shared MsgSupp_OptionOpenEdit As Integer
Visual C++
public:
static int MsgSupp_OptionOpenEdit

See Also

P4ClientError Class


MsgSupp_OptionOriginal Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOriginal Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOriginal
Visual Basic
Public Shared MsgSupp_OptionOriginal As Integer
Visual C++
public:
static int MsgSupp_OptionOriginal

See Also

P4ClientError Class


MsgSupp_OptionOutput Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOutput Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOutput
Visual Basic
Public Shared MsgSupp_OptionOutput As Integer
Visual C++
public:
static int MsgSupp_OptionOutput

See Also

P4ClientError Class


MsgSupp_OptionOutputBase Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOutputBase Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOutputBase
Visual Basic
Public Shared MsgSupp_OptionOutputBase As Integer
Visual C++
public:
static int MsgSupp_OptionOutputBase

See Also

P4ClientError Class


MsgSupp_OptionOutputFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOutputFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOutputFile
Visual Basic
Public Shared MsgSupp_OptionOutputFile As Integer
Visual C++
public:
static int MsgSupp_OptionOutputFile

See Also

P4ClientError Class


MsgSupp_OptionOutputFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOutputFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOutputFlags
Visual Basic
Public Shared MsgSupp_OptionOutputFlags As Integer
Visual C++
public:
static int MsgSupp_OptionOutputFlags

See Also

P4ClientError Class


MsgSupp_OptionOwner Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionOwner Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionOwner
Visual Basic
Public Shared MsgSupp_OptionOwner As Integer
Visual C++
public:
static int MsgSupp_OptionOwner

See Also

P4ClientError Class


MsgSupp_OptionParallel Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionParallel Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionParallel
Visual Basic
Public Shared MsgSupp_OptionParallel As Integer
Visual C++
public:
static int MsgSupp_OptionParallel

See Also

P4ClientError Class


MsgSupp_OptionParent Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionParent Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionParent
Visual Basic
Public Shared MsgSupp_OptionParent As Integer
Visual C++
public:
static int MsgSupp_OptionParent

See Also

P4ClientError Class


MsgSupp_OptionPassword Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPassword Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPassword
Visual Basic
Public Shared MsgSupp_OptionPassword As Integer
Visual C++
public:
static int MsgSupp_OptionPassword

See Also

P4ClientError Class


MsgSupp_OptionPerlRegexp Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPerlRegexp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPerlRegexp
Visual Basic
Public Shared MsgSupp_OptionPerlRegexp As Integer
Visual C++
public:
static int MsgSupp_OptionPerlRegexp

See Also

P4ClientError Class


MsgSupp_OptionPidFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPidFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPidFile
Visual Basic
Public Shared MsgSupp_OptionPidFile As Integer
Visual C++
public:
static int MsgSupp_OptionPidFile

See Also

P4ClientError Class


MsgSupp_OptionPort Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPort Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPort
Visual Basic
Public Shared MsgSupp_OptionPort As Integer
Visual C++
public:
static int MsgSupp_OptionPort

See Also

P4ClientError Class


MsgSupp_OptionPreview Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPreview Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPreview
Visual Basic
Public Shared MsgSupp_OptionPreview As Integer
Visual C++
public:
static int MsgSupp_OptionPreview

See Also

P4ClientError Class


MsgSupp_OptionPreviewNC Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPreviewNC Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPreviewNC
Visual Basic
Public Shared MsgSupp_OptionPreviewNC As Integer
Visual C++
public:
static int MsgSupp_OptionPreviewNC

See Also

P4ClientError Class


MsgSupp_OptionPrint Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPrint Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPrint
Visual Basic
Public Shared MsgSupp_OptionPrint As Integer
Visual C++
public:
static int MsgSupp_OptionPrint

See Also

P4ClientError Class


MsgSupp_OptionProgress Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionProgress Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionProgress
Visual Basic
Public Shared MsgSupp_OptionProgress As Integer
Visual C++
public:
static int MsgSupp_OptionProgress

See Also

P4ClientError Class


MsgSupp_OptionPromote Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPromote Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPromote
Visual Basic
Public Shared MsgSupp_OptionPromote As Integer
Visual C++
public:
static int MsgSupp_OptionPromote

See Also

P4ClientError Class


MsgSupp_OptionPropagating Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPropagating Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPropagating
Visual Basic
Public Shared MsgSupp_OptionPropagating As Integer
Visual C++
public:
static int MsgSupp_OptionPropagating

See Also

P4ClientError Class


MsgSupp_OptionPublish Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPublish Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPublish
Visual Basic
Public Shared MsgSupp_OptionPublish As Integer
Visual C++
public:
static int MsgSupp_OptionPublish

See Also

P4ClientError Class


MsgSupp_OptionPullServerid Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPullServerid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPullServerid
Visual Basic
Public Shared MsgSupp_OptionPullServerid As Integer
Visual C++
public:
static int MsgSupp_OptionPullServerid

See Also

P4ClientError Class


MsgSupp_OptionPurge Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionPurge Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionPurge
Visual Basic
Public Shared MsgSupp_OptionPurge As Integer
Visual C++
public:
static int MsgSupp_OptionPurge

See Also

P4ClientError Class


MsgSupp_OptionQuiet Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionQuiet Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionQuiet
Visual Basic
Public Shared MsgSupp_OptionQuiet As Integer
Visual C++
public:
static int MsgSupp_OptionQuiet

See Also

P4ClientError Class


MsgSupp_OptionRebuild Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionRebuild Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionRebuild
Visual Basic
Public Shared MsgSupp_OptionRebuild As Integer
Visual C++
public:
static int MsgSupp_OptionRebuild

See Also

P4ClientError Class


MsgSupp_OptionRegexp Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionRegexp Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionRegexp
Visual Basic
Public Shared MsgSupp_OptionRegexp As Integer
Visual C++
public:
static int MsgSupp_OptionRegexp

See Also

P4ClientError Class


MsgSupp_OptionReopen Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionReopen Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionReopen
Visual Basic
Public Shared MsgSupp_OptionReopen As Integer
Visual C++
public:
static int MsgSupp_OptionReopen

See Also

P4ClientError Class


MsgSupp_OptionRepeat Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionRepeat Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionRepeat
Visual Basic
Public Shared MsgSupp_OptionRepeat As Integer
Visual C++
public:
static int MsgSupp_OptionRepeat

See Also

P4ClientError Class


MsgSupp_OptionReplace Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionReplace Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionReplace
Visual Basic
Public Shared MsgSupp_OptionReplace As Integer
Visual C++
public:
static int MsgSupp_OptionReplace

See Also

P4ClientError Class


MsgSupp_OptionReplacement Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionReplacement Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionReplacement
Visual Basic
Public Shared MsgSupp_OptionReplacement As Integer
Visual C++
public:
static int MsgSupp_OptionReplacement

See Also

P4ClientError Class


MsgSupp_OptionReplicaUsers Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionReplicaUsers Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionReplicaUsers
Visual Basic
Public Shared MsgSupp_OptionReplicaUsers As Integer
Visual C++
public:
static int MsgSupp_OptionReplicaUsers

See Also

P4ClientError Class


MsgSupp_OptionResolveFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionResolveFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionResolveFlags
Visual Basic
Public Shared MsgSupp_OptionResolveFlags As Integer
Visual C++
public:
static int MsgSupp_OptionResolveFlags

See Also

P4ClientError Class


MsgSupp_OptionRestrictFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionRestrictFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionRestrictFlags
Visual Basic
Public Shared MsgSupp_OptionRestrictFlags As Integer
Visual C++
public:
static int MsgSupp_OptionRestrictFlags

See Also

P4ClientError Class


MsgSupp_OptionRetries Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionRetries Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionRetries
Visual Basic
Public Shared MsgSupp_OptionRetries As Integer
Visual C++
public:
static int MsgSupp_OptionRetries

See Also

P4ClientError Class


MsgSupp_OptionReverse Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionReverse Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionReverse
Visual Basic
Public Shared MsgSupp_OptionReverse As Integer
Visual C++
public:
static int MsgSupp_OptionReverse

See Also

P4ClientError Class


MsgSupp_OptionRevision Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionRevision Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionRevision
Visual Basic
Public Shared MsgSupp_OptionRevision As Integer
Visual C++
public:
static int MsgSupp_OptionRevision

See Also

P4ClientError Class


MsgSupp_OptionRunOnMaster Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionRunOnMaster Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionRunOnMaster
Visual Basic
Public Shared MsgSupp_OptionRunOnMaster As Integer
Visual C++
public:
static int MsgSupp_OptionRunOnMaster

See Also

P4ClientError Class


MsgSupp_OptionSafe Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSafe Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSafe
Visual Basic
Public Shared MsgSupp_OptionSafe As Integer
Visual C++
public:
static int MsgSupp_OptionSafe

See Also

P4ClientError Class


MsgSupp_OptionSequence Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSequence Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSequence
Visual Basic
Public Shared MsgSupp_OptionSequence As Integer
Visual C++
public:
static int MsgSupp_OptionSequence

See Also

P4ClientError Class


MsgSupp_OptionServerid Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionServerid Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionServerid
Visual Basic
Public Shared MsgSupp_OptionServerid As Integer
Visual C++
public:
static int MsgSupp_OptionServerid

See Also

P4ClientError Class


MsgSupp_OptionService Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionService Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionService
Visual Basic
Public Shared MsgSupp_OptionService As Integer
Visual C++
public:
static int MsgSupp_OptionService

See Also

P4ClientError Class


MsgSupp_OptionShelf Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShelf Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShelf
Visual Basic
Public Shared MsgSupp_OptionShelf As Integer
Visual C++
public:
static int MsgSupp_OptionShelf

See Also

P4ClientError Class


MsgSupp_OptionShelved Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShelved Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShelved
Visual Basic
Public Shared MsgSupp_OptionShelved As Integer
Visual C++
public:
static int MsgSupp_OptionShelved

See Also

P4ClientError Class


MsgSupp_OptionShelveOpts Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShelveOpts Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShelveOpts
Visual Basic
Public Shared MsgSupp_OptionShelveOpts As Integer
Visual C++
public:
static int MsgSupp_OptionShelveOpts

See Also

P4ClientError Class


MsgSupp_OptionShort Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShort Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShort
Visual Basic
Public Shared MsgSupp_OptionShort As Integer
Visual C++
public:
static int MsgSupp_OptionShort

See Also

P4ClientError Class


MsgSupp_OptionShowChange Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShowChange Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShowChange
Visual Basic
Public Shared MsgSupp_OptionShowChange As Integer
Visual C++
public:
static int MsgSupp_OptionShowChange

See Also

P4ClientError Class


MsgSupp_OptionShowFiles Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShowFiles Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShowFiles
Visual Basic
Public Shared MsgSupp_OptionShowFiles As Integer
Visual C++
public:
static int MsgSupp_OptionShowFiles

See Also

P4ClientError Class


MsgSupp_OptionShowFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShowFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShowFlags
Visual Basic
Public Shared MsgSupp_OptionShowFlags As Integer
Visual C++
public:
static int MsgSupp_OptionShowFlags

See Also

P4ClientError Class


MsgSupp_OptionShowTime Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionShowTime Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionShowTime
Visual Basic
Public Shared MsgSupp_OptionShowTime As Integer
Visual C++
public:
static int MsgSupp_OptionShowTime

See Also

P4ClientError Class


MsgSupp_OptionSortFlags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSortFlags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSortFlags
Visual Basic
Public Shared MsgSupp_OptionSortFlags As Integer
Visual C++
public:
static int MsgSupp_OptionSortFlags

See Also

P4ClientError Class


MsgSupp_OptionSourceFile Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSourceFile Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSourceFile
Visual Basic
Public Shared MsgSupp_OptionSourceFile As Integer
Visual C++
public:
static int MsgSupp_OptionSourceFile

See Also

P4ClientError Class


MsgSupp_OptionSpecFixStatus Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSpecFixStatus Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSpecFixStatus
Visual Basic
Public Shared MsgSupp_OptionSpecFixStatus As Integer
Visual C++
public:
static int MsgSupp_OptionSpecFixStatus

See Also

P4ClientError Class


MsgSupp_OptionSpecType Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSpecType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSpecType
Visual Basic
Public Shared MsgSupp_OptionSpecType As Integer
Visual C++
public:
static int MsgSupp_OptionSpecType

See Also

P4ClientError Class


MsgSupp_OptionStartPosition Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionStartPosition Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionStartPosition
Visual Basic
Public Shared MsgSupp_OptionStartPosition As Integer
Visual C++
public:
static int MsgSupp_OptionStartPosition

See Also

P4ClientError Class


MsgSupp_OptionStatus Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionStatus Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionStatus
Visual Basic
Public Shared MsgSupp_OptionStatus As Integer
Visual C++
public:
static int MsgSupp_OptionStatus

See Also

P4ClientError Class


MsgSupp_OptionStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionStream
Visual Basic
Public Shared MsgSupp_OptionStream As Integer
Visual C++
public:
static int MsgSupp_OptionStream

See Also

P4ClientError Class


MsgSupp_OptionStreamName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionStreamName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionStreamName
Visual Basic
Public Shared MsgSupp_OptionStreamName As Integer
Visual C++
public:
static int MsgSupp_OptionStreamName

See Also

P4ClientError Class


MsgSupp_OptionStreamType Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionStreamType Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionStreamType
Visual Basic
Public Shared MsgSupp_OptionStreamType As Integer
Visual C++
public:
static int MsgSupp_OptionStreamType

See Also

P4ClientError Class


MsgSupp_OptionSubmitOpts Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSubmitOpts Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSubmitOpts
Visual Basic
Public Shared MsgSupp_OptionSubmitOpts As Integer
Visual C++
public:
static int MsgSupp_OptionSubmitOpts

See Also

P4ClientError Class


MsgSupp_OptionSubmitShelf Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSubmitShelf Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSubmitShelf
Visual Basic
Public Shared MsgSupp_OptionSubmitShelf As Integer
Visual C++
public:
static int MsgSupp_OptionSubmitShelf

See Also

P4ClientError Class


MsgSupp_OptionSummary Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSummary Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSummary
Visual Basic
Public Shared MsgSupp_OptionSummary As Integer
Visual C++
public:
static int MsgSupp_OptionSummary

See Also

P4ClientError Class


MsgSupp_OptionSwitch Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSwitch Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSwitch
Visual Basic
Public Shared MsgSupp_OptionSwitch As Integer
Visual C++
public:
static int MsgSupp_OptionSwitch

See Also

P4ClientError Class


MsgSupp_OptionSystem Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionSystem Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionSystem
Visual Basic
Public Shared MsgSupp_OptionSystem As Integer
Visual C++
public:
static int MsgSupp_OptionSystem

See Also

P4ClientError Class


MsgSupp_OptionTableName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTableName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTableName
Visual Basic
Public Shared MsgSupp_OptionTableName As Integer
Visual C++
public:
static int MsgSupp_OptionTableName

See Also

P4ClientError Class


MsgSupp_OptionTableNotUnlocked Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTableNotUnlocked Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTableNotUnlocked
Visual Basic
Public Shared MsgSupp_OptionTableNotUnlocked As Integer
Visual C++
public:
static int MsgSupp_OptionTableNotUnlocked

See Also

P4ClientError Class


MsgSupp_OptionTags Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTags Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTags
Visual Basic
Public Shared MsgSupp_OptionTags As Integer
Visual C++
public:
static int MsgSupp_OptionTags

See Also

P4ClientError Class


MsgSupp_OptionTamper Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTamper Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTamper
Visual Basic
Public Shared MsgSupp_OptionTamper As Integer
Visual C++
public:
static int MsgSupp_OptionTamper

See Also

P4ClientError Class


MsgSupp_OptionTaskStatus Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTaskStatus Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTaskStatus
Visual Basic
Public Shared MsgSupp_OptionTaskStatus As Integer
Visual C++
public:
static int MsgSupp_OptionTaskStatus

See Also

P4ClientError Class


MsgSupp_OptionTemplate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTemplate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTemplate
Visual Basic
Public Shared MsgSupp_OptionTemplate As Integer
Visual C++
public:
static int MsgSupp_OptionTemplate

See Also

P4ClientError Class


MsgSupp_OptionTemporary Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTemporary Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTemporary
Visual Basic
Public Shared MsgSupp_OptionTemporary As Integer
Visual C++
public:
static int MsgSupp_OptionTemporary

See Also

P4ClientError Class


MsgSupp_OptionTo Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTo Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTo
Visual Basic
Public Shared MsgSupp_OptionTo As Integer
Visual C++
public:
static int MsgSupp_OptionTo

See Also

P4ClientError Class


MsgSupp_OptionTransfer Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionTransfer Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionTransfer
Visual Basic
Public Shared MsgSupp_OptionTransfer As Integer
Visual C++
public:
static int MsgSupp_OptionTransfer

See Also

P4ClientError Class


MsgSupp_OptionUnchanged Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUnchanged Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUnchanged
Visual Basic
Public Shared MsgSupp_OptionUnchanged As Integer
Visual C++
public:
static int MsgSupp_OptionUnchanged

See Also

P4ClientError Class


MsgSupp_OptionUnified Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUnified Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUnified
Visual Basic
Public Shared MsgSupp_OptionUnified As Integer
Visual C++
public:
static int MsgSupp_OptionUnified

See Also

P4ClientError Class


MsgSupp_OptionUnload Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUnload Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUnload
Visual Basic
Public Shared MsgSupp_OptionUnload As Integer
Visual C++
public:
static int MsgSupp_OptionUnload

See Also

P4ClientError Class


MsgSupp_OptionUnloadAll Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUnloadAll Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUnloadAll
Visual Basic
Public Shared MsgSupp_OptionUnloadAll As Integer
Visual C++
public:
static int MsgSupp_OptionUnloadAll

See Also

P4ClientError Class


MsgSupp_OptionUpdate Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUpdate Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUpdate
Visual Basic
Public Shared MsgSupp_OptionUpdate As Integer
Visual C++
public:
static int MsgSupp_OptionUpdate

See Also

P4ClientError Class


MsgSupp_OptionUsage Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUsage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUsage
Visual Basic
Public Shared MsgSupp_OptionUsage As Integer
Visual C++
public:
static int MsgSupp_OptionUsage

See Also

P4ClientError Class


MsgSupp_OptionUseList Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUseList Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUseList
Visual Basic
Public Shared MsgSupp_OptionUseList As Integer
Visual C++
public:
static int MsgSupp_OptionUseList

See Also

P4ClientError Class


MsgSupp_OptionUseModTime Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUseModTime Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUseModTime
Visual Basic
Public Shared MsgSupp_OptionUseModTime As Integer
Visual C++
public:
static int MsgSupp_OptionUseModTime

See Also

P4ClientError Class


MsgSupp_OptionUser Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionUser Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionUser
Visual Basic
Public Shared MsgSupp_OptionUser As Integer
Visual C++
public:
static int MsgSupp_OptionUser

See Also

P4ClientError Class


MsgSupp_OptionValue Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionValue Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionValue
Visual Basic
Public Shared MsgSupp_OptionValue As Integer
Visual C++
public:
static int MsgSupp_OptionValue

See Also

P4ClientError Class


MsgSupp_OptionVariable Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionVariable Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionVariable
Visual Basic
Public Shared MsgSupp_OptionVariable As Integer
Visual C++
public:
static int MsgSupp_OptionVariable

See Also

P4ClientError Class


MsgSupp_OptionVerbose Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionVerbose Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionVerbose
Visual Basic
Public Shared MsgSupp_OptionVerbose As Integer
Visual C++
public:
static int MsgSupp_OptionVerbose

See Also

P4ClientError Class


MsgSupp_OptionVerify Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionVerify Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionVerify
Visual Basic
Public Shared MsgSupp_OptionVerify As Integer
Visual C++
public:
static int MsgSupp_OptionVerify

See Also

P4ClientError Class


MsgSupp_OptionVersion Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionVersion Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionVersion
Visual Basic
Public Shared MsgSupp_OptionVersion As Integer
Visual C++
public:
static int MsgSupp_OptionVersion

See Also

P4ClientError Class


MsgSupp_OptionVirtual Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionVirtual Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionVirtual
Visual Basic
Public Shared MsgSupp_OptionVirtual As Integer
Visual C++
public:
static int MsgSupp_OptionVirtual

See Also

P4ClientError Class


MsgSupp_OptionVirtualStream Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionVirtualStream Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionVirtualStream
Visual Basic
Public Shared MsgSupp_OptionVirtualStream As Integer
Visual C++
public:
static int MsgSupp_OptionVirtualStream

See Also

P4ClientError Class


MsgSupp_OptionWipe Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionWipe Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionWipe
Visual Basic
Public Shared MsgSupp_OptionWipe As Integer
Visual C++
public:
static int MsgSupp_OptionWipe

See Also

P4ClientError Class


MsgSupp_OptionXargs Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionXargs Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionXargs
Visual Basic
Public Shared MsgSupp_OptionXargs As Integer
Visual C++
public:
static int MsgSupp_OptionXargs

See Also

P4ClientError Class


MsgSupp_OptionYes Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_OptionYes Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_OptionYes
Visual Basic
Public Shared MsgSupp_OptionYes As Integer
Visual C++
public:
static int MsgSupp_OptionYes

See Also

P4ClientError Class


MsgSupp_PartialChar Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_PartialChar Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_PartialChar
Visual Basic
Public Shared MsgSupp_PartialChar As Integer
Visual C++
public:
static int MsgSupp_PartialChar

See Also

P4ClientError Class


MsgSupp_RegexError Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_RegexError Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_RegexError
Visual Basic
Public Shared MsgSupp_RegexError As Integer
Visual C++
public:
static int MsgSupp_RegexError

See Also

P4ClientError Class


MsgSupp_TooMany Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_TooMany Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_TooMany
Visual Basic
Public Shared MsgSupp_TooMany As Integer
Visual C++
public:
static int MsgSupp_TooMany

See Also

P4ClientError Class


MsgSupp_Usage Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_Usage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_Usage
Visual Basic
Public Shared MsgSupp_Usage As Integer
Visual C++
public:
static int MsgSupp_Usage

See Also

P4ClientError Class


MsgSupp_VariableData Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_VariableData Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_VariableData
Visual Basic
Public Shared MsgSupp_VariableData As Integer
Visual C++
public:
static int MsgSupp_VariableData

See Also

P4ClientError Class


MsgSupp_WrongArg Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_WrongArg Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_WrongArg
Visual Basic
Public Shared MsgSupp_WrongArg As Integer
Visual C++
public:
static int MsgSupp_WrongArg

See Also

P4ClientError Class


MsgSupp_ZCBrowseFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ZCBrowseFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ZCBrowseFailed
Visual Basic
Public Shared MsgSupp_ZCBrowseFailed As Integer
Visual C++
public:
static int MsgSupp_ZCBrowseFailed

See Also

P4ClientError Class


MsgSupp_ZCInvalidName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ZCInvalidName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ZCInvalidName
Visual Basic
Public Shared MsgSupp_ZCInvalidName As Integer
Visual C++
public:
static int MsgSupp_ZCInvalidName

See Also

P4ClientError Class


MsgSupp_ZCLoadLibFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ZCLoadLibFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ZCLoadLibFailed
Visual Basic
Public Shared MsgSupp_ZCLoadLibFailed As Integer
Visual C++
public:
static int MsgSupp_ZCLoadLibFailed

See Also

P4ClientError Class


MsgSupp_ZCNameConflict Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ZCNameConflict Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ZCNameConflict
Visual Basic
Public Shared MsgSupp_ZCNameConflict As Integer
Visual C++
public:
static int MsgSupp_ZCNameConflict

See Also

P4ClientError Class


MsgSupp_ZCRegistryFailed Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ZCRegistryFailed Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ZCRegistryFailed
Visual Basic
Public Shared MsgSupp_ZCRegistryFailed As Integer
Visual C++
public:
static int MsgSupp_ZCRegistryFailed

See Also

P4ClientError Class


MsgSupp_ZCRequireName Field

[image]

Perforce .NET API
P4ClientError..::..MsgSupp_ZCRequireName Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int MsgSupp_ZCRequireName
Visual Basic
Public Shared MsgSupp_ZCRequireName As Integer
Visual C++
public:
static int MsgSupp_ZCRequireName

See Also

P4ClientError Class


SeverityLevel Field

[image]

Perforce .NET API
P4ClientError..::..SeverityLevel Field
P4ClientError Class See Also Send Feedback
How severe is the error

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ErrorSeverity SeverityLevel
Visual Basic
Public SeverityLevel As ErrorSeverity
Visual C++
public:
ErrorSeverity SeverityLevel

See Also

P4ClientError Class


Usage Field

[image]

Perforce .NET API
P4ClientError..::..Usage Field
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int Usage
Visual Basic
Public Shared Usage As Integer
Visual C++
public:
static int Usage

See Also

P4ClientError Class


P4ClientError Methods

[image] [image]

Perforce .NET API
P4ClientError Methods
P4ClientError Class See Also Send Feedback

The P4ClientError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorOf |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBadPasswdError |
 | IsLoginError |
 | IsSSLError |
 | IsTCPError |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Format the error in the form [ErrorLevel] Message (Overrides Object..::..ToString()()()().)

See Also

P4ClientError Class


ErrorOf Method

[image]

Perforce .NET API
P4ClientError..::..ErrorOf Method
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int ErrorOf(
    ErrorSubsystem sub,
    int cod,
    ErrorSeverity sev,
    ErrorGeneric gen,
    int arg
)
Visual Basic
Public Shared Function ErrorOf ( _
    sub As ErrorSubsystem, _
    cod As Integer, _
    sev As ErrorSeverity, _
    gen As ErrorGeneric, _
    arg As Integer _
) As Integer
Visual C++
public:
static int ErrorOf(
    ErrorSubsystem sub,
    int cod,
    ErrorSeverity sev,
    ErrorGeneric gen,
    int arg
)

Parameters

sub
Type: Perforce.P4..::..ErrorSubsystem
cod
Type: System..::..Int32
sev
Type: Perforce.P4..::..ErrorSeverity
gen
Type: Perforce.P4..::..ErrorGeneric
arg
Type: System..::..Int32

See Also

P4ClientError Class


IsBadPasswdError Method

[image]

Perforce .NET API
P4ClientError..::..IsBadPasswdError Method
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool IsBadPasswdError(
    int errorNum
)
Visual Basic
Public Shared Function IsBadPasswdError ( _
    errorNum As Integer _
) As Boolean
Visual C++
public:
static bool IsBadPasswdError(
    int errorNum
)

Parameters

errorNum
Type: System..::..Int32

See Also

P4ClientError Class


IsLoginError Method

[image]

Perforce .NET API
P4ClientError..::..IsLoginError Method
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool IsLoginError(
    int errorNum
)
Visual Basic
Public Shared Function IsLoginError ( _
    errorNum As Integer _
) As Boolean
Visual C++
public:
static bool IsLoginError(
    int errorNum
)

Parameters

errorNum
Type: System..::..Int32

See Also

P4ClientError Class


IsSSLError Method

[image]

Perforce .NET API
P4ClientError..::..IsSSLError Method
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool IsSSLError(
    int errorNum
)
Visual Basic
Public Shared Function IsSSLError ( _
    errorNum As Integer _
) As Boolean
Visual C++
public:
static bool IsSSLError(
    int errorNum
)

Parameters

errorNum
Type: System..::..Int32

See Also

P4ClientError Class


IsTCPError Method

[image]

Perforce .NET API
P4ClientError..::..IsTCPError Method
P4ClientError Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool IsTCPError(
    int errorNum
)
Visual Basic
Public Shared Function IsTCPError ( _
    errorNum As Integer _
) As Boolean
Visual C++
public:
static bool IsTCPError(
    int errorNum
)

Parameters

errorNum
Type: System..::..Int32

See Also

P4ClientError Class


ToString Method

[image]

Perforce .NET API
P4ClientError..::..ToString Method
P4ClientError Class See Also Send Feedback
Format the error in the form [ErrorLevel] Message

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

P4ClientError Class


P4ClientErrorList Class

[image]

Perforce .NET API
P4ClientErrorList Class
Members See Also Send Feedback
Class used to return a list of errors and warnings returned by a command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4ClientErrorList : List<P4ClientError>
Visual Basic
Public Class P4ClientErrorList _
    Inherits List(Of P4ClientError)
Visual C++
public ref class P4ClientErrorList : public List<P4ClientError^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' P4ClientError >)>)>
Perforce.P4..::..P4ClientErrorList

See Also

P4ClientErrorList Members


P4ClientErrorList Members

[image] [image]

Perforce .NET API
P4ClientErrorList Members
P4ClientErrorList Class Constructors Methods Operators Properties See Also Send Feedback

The P4ClientErrorList type exposes the following members.

Constructors

 | Name | Description
Public method | P4ClientErrorList(P4Server, IntPtr) | Read the error list from the server
Public method | P4ClientErrorList(P4Server, UInt32) | Create a list from the current error results on the server

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (P4ClientErrorList to String) | Cast the errors to a String. Each error is separated by \r\n
Implicit Widening Implicit Implicit Implicit (P4ClientErrorList to array<String>[]()[][]) | Cast the errors to a String[]

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class


P4ClientErrorList Constructor

[image] [image]

Perforce .NET API
P4ClientErrorList Constructor
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4ClientErrorList(P4Server, IntPtr) | Read the error list from the server
Public method | P4ClientErrorList(P4Server, UInt32) | Create a list from the current error results on the server

See Also

P4ClientErrorList Class
P4ClientErrorList Members


P4ClientErrorList Constructor (P4Server, IntPtr)

[image]

Perforce .NET API
P4ClientErrorList Constructor (P4Server, IntPtr)
P4ClientErrorList Class See Also Send Feedback
Read the error list from the server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientErrorList(
    P4Server p4Server,
    IntPtr pObj
)
Visual Basic
Public Sub New ( _
    p4Server As P4Server, _
    pObj As IntPtr _
)
Visual C++
public:
P4ClientErrorList(
    P4Server^ p4Server,
    IntPtr pObj
)

Parameters

p4Server
Type: Perforce.P4..::..P4Server
pObj
Type: System..::..IntPtr

See Also

P4ClientErrorList Class
P4ClientErrorList Overload


P4ClientErrorList Constructor (P4Server, UInt32)

[image]

Perforce .NET API
P4ClientErrorList Constructor (P4Server, UInt32)
P4ClientErrorList Class See Also Send Feedback
Create a list from the current error results on the server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientErrorList(
    P4Server p4Server,
    uint cmdId
)
Visual Basic
Public Sub New ( _
    p4Server As P4Server, _
    cmdId As UInteger _
)
Visual C++
public:
P4ClientErrorList(
    P4Server^ p4Server,
    unsigned int cmdId
)

Parameters

p4Server
Type: Perforce.P4..::..P4Server
Perforce Server
cmdId
Type: System..::..UInt32

See Also

P4ClientErrorList Class
P4ClientErrorList Overload


P4ClientErrorList Methods

[image] [image]

Perforce .NET API
P4ClientErrorList Methods
P4ClientErrorList Class See Also Send Feedback

The P4ClientErrorList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class


BinarySearch Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..BinarySearch Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


CopyTo Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..CopyTo Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


FindIndex Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..FindIndex Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


FindLastIndex Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..FindLastIndex Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


IndexOf Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..IndexOf Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


LastIndexOf Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..LastIndexOf Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


Reverse Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..Reverse Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


Sort Method

[image] [image]

Perforce .NET API
P4ClientErrorList..::..Sort Method
P4ClientErrorList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class
P4ClientErrorList Members


P4ClientErrorList Type Conversions

[image] [image]

Perforce .NET API
P4ClientErrorList Type Conversions
P4ClientErrorList Class See Also Send Feedback

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (P4ClientErrorList to String) | Cast the errors to a String. Each error is separated by \r\n
Implicit Widening Implicit Implicit Implicit (P4ClientErrorList to array<String>[]()[][]) | Cast the errors to a String[]

See Also

P4ClientErrorList Class


Implicit Conversion Operators

[image] [image]

Perforce .NET API
P4ClientErrorList ImplicitWideningImplicitImplicitImplicit Conversion Operators
P4ClientErrorList Class See Also Send Feedback

Overload List

Name | Description
Implicit Widening Implicit Implicit Implicit (P4ClientErrorList to String) | Cast the errors to a String. Each error is separated by \r\n
Implicit Widening Implicit Implicit Implicit (P4ClientErrorList to array<String>[]()[][]) | Cast the errors to a String[]

See Also

P4ClientErrorList Class
P4ClientErrorList Members


Implicit Conversion (P4ClientErrorList to String)

[image]

Perforce .NET API
P4ClientErrorList ImplicitWideningImplicitImplicitImplicit Conversion (P4ClientErrorList to String)
P4ClientErrorList Class See Also Send Feedback
Cast the errors to a String. Each error is separated by \r\n

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator string (
    P4ClientErrorList l
)
Visual Basic
Public Shared Widening Operator CType ( _
    l As P4ClientErrorList _
) As String
Visual C++
static implicit operator String^ (
    P4ClientErrorList^ l
)

Parameters

l
Type: Perforce.P4..::..P4ClientErrorList
the list to cast

Return Value

See Also

P4ClientErrorList Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (P4ClientErrorList to String[])

[image]

Perforce .NET API
P4ClientErrorList ImplicitWideningImplicitImplicitImplicit Conversion (P4ClientErrorList to array<String>[]()[][])
P4ClientErrorList Class See Also Send Feedback
Cast the errors to a String[]

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator string[] (
    P4ClientErrorList l
)
Visual Basic
Public Shared Widening Operator CType ( _
    l As P4ClientErrorList _
) As String()
Visual C++
static implicit operator array<String^>^ (
    P4ClientErrorList^ l
)

Parameters

l
Type: Perforce.P4..::..P4ClientErrorList
the list to cast

Return Value

See Also

P4ClientErrorList Class
ImplicitWideningImplicitImplicitImplicit Overload


P4ClientErrorList Properties

[image] [image]

Perforce .NET API
P4ClientErrorList Properties
P4ClientErrorList Class See Also Send Feedback

The P4ClientErrorList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientError >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' P4ClientError >)>)>.)

See Also

P4ClientErrorList Class


P4ClientInfoMessage Class

[image]

Perforce .NET API
P4ClientInfoMessage Class
Members See Also Send Feedback
Class used to return a info message from the bridge dll.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4ClientInfoMessage
Visual Basic
Public Class P4ClientInfoMessage
Visual C++
public ref class P4ClientInfoMessage

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4ClientInfoMessage

See Also

P4ClientInfoMessage Members


P4ClientInfoMessage Members

[image] [image]

Perforce .NET API
P4ClientInfoMessage Members
P4ClientInfoMessage Class Constructors Methods Fields See Also Send Feedback

The P4ClientInfoMessage type exposes the following members.

Constructors

 | Name | Description
Public method | P4ClientInfoMessage(P4Server, IntPtr) | Create a new P4ClientInfoMessage
Public method | P4ClientInfoMessage(Int32, Int32, String) | Initializes a new instance of the P4ClientInfoMessage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | Message | Message
Public field | MessageCode | Generic code for the message
Public field | MessageLevel | Message level

See Also

P4ClientInfoMessage Class


P4ClientInfoMessage Constructor

[image] [image]

Perforce .NET API
P4ClientInfoMessage Constructor
P4ClientInfoMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4ClientInfoMessage(P4Server, IntPtr) | Create a new P4ClientInfoMessage
Public method | P4ClientInfoMessage(Int32, Int32, String) | Initializes a new instance of the P4ClientInfoMessage class

See Also

P4ClientInfoMessage Class
P4ClientInfoMessage Members


P4ClientInfoMessage Constructor (P4Server, IntPtr)

[image]

Perforce .NET API
P4ClientInfoMessage Constructor (P4Server, IntPtr)
P4ClientInfoMessage Class See Also Send Feedback
Create a new P4ClientInfoMessage

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessage(
    P4Server p4Server,
    IntPtr pMsg
)
Visual Basic
Public Sub New ( _
    p4Server As P4Server, _
    pMsg As IntPtr _
)
Visual C++
public:
P4ClientInfoMessage(
    P4Server^ p4Server,
    IntPtr pMsg
)

Parameters

p4Server
Type: Perforce.P4..::..P4Server
pMsg
Type: System..::..IntPtr

See Also

P4ClientInfoMessage Class
P4ClientInfoMessage Overload


P4ClientInfoMessage Constructor (Int32, Int32, String)

[image]

Perforce .NET API
P4ClientInfoMessage Constructor (Int32, Int32, String)
P4ClientInfoMessage Class See Also Send Feedback
Initializes a new instance of the P4ClientInfoMessage class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessage(
    int msgCode,
    int level,
    string message
)
Visual Basic
Public Sub New ( _
    msgCode As Integer, _
    level As Integer, _
    message As String _
)
Visual C++
public:
P4ClientInfoMessage(
    int msgCode,
    int level,
    String^ message
)

Parameters

msgCode
Type: System..::..Int32
level
Type: System..::..Int32
message
Type: System..::..String

See Also

P4ClientInfoMessage Class
P4ClientInfoMessage Overload


P4ClientInfoMessage Fields

[image] [image]

Perforce .NET API
P4ClientInfoMessage Fields
P4ClientInfoMessage Class See Also Send Feedback

The P4ClientInfoMessage type exposes the following members.

Fields

 | Name | Description
Public field | Message | Message
Public field | MessageCode | Generic code for the message
Public field | MessageLevel | Message level

See Also

P4ClientInfoMessage Class


Message Field

[image]

Perforce .NET API
P4ClientInfoMessage..::..Message Field
P4ClientInfoMessage Class See Also Send Feedback
Message

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Message
Visual Basic
Public Message As String
Visual C++
public:
String^ Message

See Also

P4ClientInfoMessage Class


MessageCode Field

[image]

Perforce .NET API
P4ClientInfoMessage..::..MessageCode Field
P4ClientInfoMessage Class See Also Send Feedback
Generic code for the message

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int MessageCode
Visual Basic
Public MessageCode As Integer
Visual C++
public:
int MessageCode

See Also

P4ClientInfoMessage Class


MessageLevel Field

[image]

Perforce .NET API
P4ClientInfoMessage..::..MessageLevel Field
P4ClientInfoMessage Class See Also Send Feedback
Message level

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int MessageLevel
Visual Basic
Public MessageLevel As Integer
Visual C++
public:
int MessageLevel

See Also

P4ClientInfoMessage Class


P4ClientInfoMessage Methods

[image] [image]

Perforce .NET API
P4ClientInfoMessage Methods
P4ClientInfoMessage Class See Also Send Feedback

The P4ClientInfoMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

P4ClientInfoMessage Class


ToString Method

[image]

Perforce .NET API
P4ClientInfoMessage..::..ToString Method
P4ClientInfoMessage Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

P4ClientInfoMessage Class


P4ClientInfoMessageList Class

[image]

Perforce .NET API
P4ClientInfoMessageList Class
Members See Also Send Feedback
Class used to return a list of info Messages returned by a command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4ClientInfoMessageList : List<P4ClientInfoMessage>
Visual Basic
Public Class P4ClientInfoMessageList _
    Inherits List(Of P4ClientInfoMessage)
Visual C++
public ref class P4ClientInfoMessageList : public List<P4ClientInfoMessage^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' P4ClientInfoMessage >)>)>
Perforce.P4..::..P4ClientInfoMessageList

See Also

P4ClientInfoMessageList Members


P4ClientInfoMessageList Members

[image] [image]

Perforce .NET API
P4ClientInfoMessageList Members
P4ClientInfoMessageList Class Constructors Methods Operators Properties See Also Send Feedback

The P4ClientInfoMessageList type exposes the following members.

Constructors

 | Name | Description
Public method | P4ClientInfoMessageList(P4Server, UInt32) | Create a list from the current error results on the server
Public method | P4ClientInfoMessageList(P4Server, IntPtr, Int32) | Read the error list from the server

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (P4ClientInfoMessageList to String) | Cast the errors to a String. Each error is separated by \r\n
Implicit Widening Implicit Implicit Implicit (P4ClientInfoMessageList to array<String>[]()[][]) | Cast the messages to a String[]

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class


P4ClientInfoMessageList Constructor

[image] [image]

Perforce .NET API
P4ClientInfoMessageList Constructor
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4ClientInfoMessageList(P4Server, UInt32) | Create a list from the current error results on the server
Public method | P4ClientInfoMessageList(P4Server, IntPtr, Int32) | Read the error list from the server

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


P4ClientInfoMessageList Constructor (P4Server, UInt32)

[image]

Perforce .NET API
P4ClientInfoMessageList Constructor (P4Server, UInt32)
P4ClientInfoMessageList Class See Also Send Feedback
Create a list from the current error results on the server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessageList(
    P4Server p4Server,
    uint cmdId
)
Visual Basic
Public Sub New ( _
    p4Server As P4Server, _
    cmdId As UInteger _
)
Visual C++
public:
P4ClientInfoMessageList(
    P4Server^ p4Server,
    unsigned int cmdId
)

Parameters

p4Server
Type: Perforce.P4..::..P4Server
Perforce Server
cmdId
Type: System..::..UInt32

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Overload


P4ClientInfoMessageList Constructor (P4Server, IntPtr, Int32)

[image]

Perforce .NET API
P4ClientInfoMessageList Constructor (P4Server, IntPtr, Int32)
P4ClientInfoMessageList Class See Also Send Feedback
Read the error list from the server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessageList(
    P4Server p4Server,
    IntPtr pObj,
    int Count
)
Visual Basic
Public Sub New ( _
    p4Server As P4Server, _
    pObj As IntPtr, _
    Count As Integer _
)
Visual C++
public:
P4ClientInfoMessageList(
    P4Server^ p4Server,
    IntPtr pObj,
    int Count
)

Parameters

p4Server
Type: Perforce.P4..::..P4Server
pObj
Type: System..::..IntPtr
Count
Type: System..::..Int32

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Overload


P4ClientInfoMessageList Methods

[image] [image]

Perforce .NET API
P4ClientInfoMessageList Methods
P4ClientInfoMessageList Class See Also Send Feedback

The P4ClientInfoMessageList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class


BinarySearch Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..BinarySearch Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


CopyTo Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..CopyTo Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


FindIndex Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..FindIndex Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


FindLastIndex Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..FindLastIndex Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


IndexOf Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..IndexOf Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


LastIndexOf Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..LastIndexOf Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


Reverse Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..Reverse Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


Sort Method

[image] [image]

Perforce .NET API
P4ClientInfoMessageList..::..Sort Method
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


P4ClientInfoMessageList Type Conversions

[image] [image]

Perforce .NET API
P4ClientInfoMessageList Type Conversions
P4ClientInfoMessageList Class See Also Send Feedback

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (P4ClientInfoMessageList to String) | Cast the errors to a String. Each error is separated by \r\n
Implicit Widening Implicit Implicit Implicit (P4ClientInfoMessageList to array<String>[]()[][]) | Cast the messages to a String[]

See Also

P4ClientInfoMessageList Class


Implicit Conversion Operators

[image] [image]

Perforce .NET API
P4ClientInfoMessageList ImplicitWideningImplicitImplicitImplicit Conversion Operators
P4ClientInfoMessageList Class See Also Send Feedback

Overload List

Name | Description
Implicit Widening Implicit Implicit Implicit (P4ClientInfoMessageList to String) | Cast the errors to a String. Each error is separated by \r\n
Implicit Widening Implicit Implicit Implicit (P4ClientInfoMessageList to array<String>[]()[][]) | Cast the messages to a String[]

See Also

P4ClientInfoMessageList Class
P4ClientInfoMessageList Members


Implicit Conversion (P4ClientInfoMessageList to String)

[image]

Perforce .NET API
P4ClientInfoMessageList ImplicitWideningImplicitImplicitImplicit Conversion (P4ClientInfoMessageList to String)
P4ClientInfoMessageList Class See Also Send Feedback
Cast the errors to a String. Each error is separated by \r\n

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator string (
    P4ClientInfoMessageList l
)
Visual Basic
Public Shared Widening Operator CType ( _
    l As P4ClientInfoMessageList _
) As String
Visual C++
static implicit operator String^ (
    P4ClientInfoMessageList^ l
)

Parameters

l
Type: Perforce.P4..::..P4ClientInfoMessageList
the list to cast

Return Value

See Also

P4ClientInfoMessageList Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (P4ClientInfoMessageList to String[])

[image]

Perforce .NET API
P4ClientInfoMessageList ImplicitWideningImplicitImplicitImplicit Conversion (P4ClientInfoMessageList to array<String>[]()[][])
P4ClientInfoMessageList Class See Also Send Feedback
Cast the messages to a String[]

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator string[] (
    P4ClientInfoMessageList l
)
Visual Basic
Public Shared Widening Operator CType ( _
    l As P4ClientInfoMessageList _
) As String()
Visual C++
static implicit operator array<String^>^ (
    P4ClientInfoMessageList^ l
)

Parameters

l
Type: Perforce.P4..::..P4ClientInfoMessageList
the list to cast

Return Value

See Also

P4ClientInfoMessageList Class
ImplicitWideningImplicitImplicitImplicit Overload


P4ClientInfoMessageList Properties

[image] [image]

Perforce .NET API
P4ClientInfoMessageList Properties
P4ClientInfoMessageList Class See Also Send Feedback

The P4ClientInfoMessageList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' P4ClientInfoMessage >)>)>.)

See Also

P4ClientInfoMessageList Class


P4ClientMerge Class

[image]

Perforce .NET API
P4ClientMerge Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4ClientMerge
Visual Basic
Public Class P4ClientMerge
Visual C++
public ref class P4ClientMerge

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4ClientMerge

See Also

P4ClientMerge Members


P4ClientMerge Members

[image] [image]

Perforce .NET API
P4ClientMerge Members
P4ClientMerge Class Constructors Methods See Also Send Feedback

The P4ClientMerge type exposes the following members.

Constructors

 | Name | Description
Public method | P4ClientMerge | Initializes a new instance of the P4ClientMerge class

Methods

 | Name | Description
Public method | AutoResolve |
Public method | DetectResolve |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseFile |
Public method | GetBothChunks |
Public method | GetConflictChunks |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastError |
Public method | GetMergeDigest |
Public method | GetResultFile |
Public method | GetTheirChunks |
Public method | GetTheirDigest |
Public method | GetTheirFile |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetYourChunks |
Public method | GetYourDigest |
Public method | GetYourFile |
Public method | IsAcceptable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resolve |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4ClientMerge Class


P4ClientMerge Constructor

[image]

Perforce .NET API
P4ClientMerge Constructor
P4ClientMerge Class See Also Send Feedback
Initializes a new instance of the P4ClientMerge class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientMerge(
    P4Server pserver,
    IntPtr p
)
Visual Basic
Public Sub New ( _
    pserver As P4Server, _
    p As IntPtr _
)
Visual C++
public:
P4ClientMerge(
    P4Server^ pserver,
    IntPtr p
)

Parameters

pserver
Type: Perforce.P4..::..P4Server
p
Type: System..::..IntPtr

See Also

P4ClientMerge Class


P4ClientMerge Methods

[image] [image]

Perforce .NET API
P4ClientMerge Methods
P4ClientMerge Class See Also Send Feedback

The P4ClientMerge type exposes the following members.

Methods

 | Name | Description
Public method | AutoResolve |
Public method | DetectResolve |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseFile |
Public method | GetBothChunks |
Public method | GetConflictChunks |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastError |
Public method | GetMergeDigest |
Public method | GetResultFile |
Public method | GetTheirChunks |
Public method | GetTheirDigest |
Public method | GetTheirFile |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetYourChunks |
Public method | GetYourDigest |
Public method | GetYourFile |
Public method | IsAcceptable |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resolve |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4ClientMerge Class


AutoResolve Method

[image]

Perforce .NET API
P4ClientMerge..::..AutoResolve Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientMerge..::..MergeStatus AutoResolve(
    P4ClientMerge..::..MergeForce forceMerge
)
Visual Basic
Public Function AutoResolve ( _
    forceMerge As P4ClientMerge..::..MergeForce _
) As P4ClientMerge..::..MergeStatus
Visual C++
public:
P4ClientMerge..::..MergeStatus AutoResolve(
    P4ClientMerge..::..MergeForce forceMerge
)

Parameters

forceMerge
Type: Perforce.P4..::..P4ClientMerge..::..MergeForce

See Also

P4ClientMerge Class


DetectResolve Method

[image]

Perforce .NET API
P4ClientMerge..::..DetectResolve Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientMerge..::..MergeStatus DetectResolve()
Visual Basic
Public Function DetectResolve As P4ClientMerge..::..MergeStatus
Visual C++
public:
P4ClientMerge..::..MergeStatus DetectResolve()

See Also

P4ClientMerge Class


GetBaseFile Method

[image]

Perforce .NET API
P4ClientMerge..::..GetBaseFile Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetBaseFile()
Visual Basic
Public Function GetBaseFile As String
Visual C++
public:
String^ GetBaseFile()

See Also

P4ClientMerge Class


GetBothChunks Method

[image]

Perforce .NET API
P4ClientMerge..::..GetBothChunks Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int GetBothChunks()
Visual Basic
Public Function GetBothChunks As Integer
Visual C++
public:
int GetBothChunks()

See Also

P4ClientMerge Class


GetConflictChunks Method

[image]

Perforce .NET API
P4ClientMerge..::..GetConflictChunks Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int GetConflictChunks()
Visual Basic
Public Function GetConflictChunks As Integer
Visual C++
public:
int GetConflictChunks()

See Also

P4ClientMerge Class


GetLastError Method

[image]

Perforce .NET API
P4ClientMerge..::..GetLastError Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientError GetLastError(
    IntPtr pObj
)
Visual Basic
Public Function GetLastError ( _
    pObj As IntPtr _
) As P4ClientError
Visual C++
public:
P4ClientError^ GetLastError(
    IntPtr pObj
)

Parameters

pObj
Type: System..::..IntPtr

See Also

P4ClientMerge Class


GetMergeDigest Method

[image]

Perforce .NET API
P4ClientMerge..::..GetMergeDigest Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetMergeDigest(
    IntPtr pObj
)
Visual Basic
Public Function GetMergeDigest ( _
    pObj As IntPtr _
) As String
Visual C++
public:
String^ GetMergeDigest(
    IntPtr pObj
)

Parameters

pObj
Type: System..::..IntPtr

See Also

P4ClientMerge Class


GetResultFile Method

[image]

Perforce .NET API
P4ClientMerge..::..GetResultFile Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetResultFile()
Visual Basic
Public Function GetResultFile As String
Visual C++
public:
String^ GetResultFile()

See Also

P4ClientMerge Class


GetTheirChunks Method

[image]

Perforce .NET API
P4ClientMerge..::..GetTheirChunks Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int GetTheirChunks()
Visual Basic
Public Function GetTheirChunks As Integer
Visual C++
public:
int GetTheirChunks()

See Also

P4ClientMerge Class


GetTheirDigest Method

[image]

Perforce .NET API
P4ClientMerge..::..GetTheirDigest Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetTheirDigest()
Visual Basic
Public Function GetTheirDigest As String
Visual C++
public:
String^ GetTheirDigest()

See Also

P4ClientMerge Class


GetTheirFile Method

[image]

Perforce .NET API
P4ClientMerge..::..GetTheirFile Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetTheirFile()
Visual Basic
Public Function GetTheirFile As String
Visual C++
public:
String^ GetTheirFile()

See Also

P4ClientMerge Class


GetYourChunks Method

[image]

Perforce .NET API
P4ClientMerge..::..GetYourChunks Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int GetYourChunks()
Visual Basic
Public Function GetYourChunks As Integer
Visual C++
public:
int GetYourChunks()

See Also

P4ClientMerge Class


GetYourDigest Method

[image]

Perforce .NET API
P4ClientMerge..::..GetYourDigest Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetYourDigest()
Visual Basic
Public Function GetYourDigest As String
Visual C++
public:
String^ GetYourDigest()

See Also

P4ClientMerge Class


GetYourFile Method

[image]

Perforce .NET API
P4ClientMerge..::..GetYourFile Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetYourFile()
Visual Basic
Public Function GetYourFile As String
Visual C++
public:
String^ GetYourFile()

See Also

P4ClientMerge Class


IsAcceptable Method

[image]

Perforce .NET API
P4ClientMerge..::..IsAcceptable Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsAcceptable()
Visual Basic
Public Function IsAcceptable As Boolean
Visual C++
public:
bool IsAcceptable()

See Also

P4ClientMerge Class


Resolve Method

[image]

Perforce .NET API
P4ClientMerge..::..Resolve Method
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientMerge..::..MergeStatus Resolve()
Visual Basic
Public Function Resolve As P4ClientMerge..::..MergeStatus
Visual C++
public:
P4ClientMerge..::..MergeStatus Resolve()

See Also

P4ClientMerge Class


P4ClientMerge.MergeForce Enumeration

[image]

Perforce .NET API
P4ClientMerge..::..MergeForce Enumeration
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum MergeForce
Visual Basic
Public Enumeration MergeForce
Visual C++
public enum class MergeForce

Members

Member name | Value | Description
CMF_AUTO | 0 |
CMF_SAFE | 1 |
CMF_FORCE | 2 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4ClientMerge.MergeStatus Enumeration

[image]

Perforce .NET API
P4ClientMerge..::..MergeStatus Enumeration
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum MergeStatus
Visual Basic
Public Enumeration MergeStatus
Visual C++
public enum class MergeStatus

Members

Member name | Value | Description
CMS_NONE | -1 |
CMS_QUIT | 0 |
CMS_SKIP | 1 |
CMS_MERGED | 2 |
CMS_EDIT | 3 |
CMS_THEIRS | 4 |
CMS_YOURS | 5 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4ClientMerge.MergeType Enumeration

[image]

Perforce .NET API
P4ClientMerge..::..MergeType Enumeration
P4ClientMerge Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum MergeType
Visual Basic
Public Enumeration MergeType
Visual C++
public enum class MergeType

Members

Member name | Value | Description
CMT_BINARY | 0 |
CMT_3WAY | 1 |
CMT_2WAY | 2 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4ClientResolve Class

[image]

Perforce .NET API
P4ClientResolve Class
Members See Also Send Feedback
Class containing the DLL imports for the P4Bridge DLL.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4ClientResolve
Visual Basic
Public Class P4ClientResolve
Visual C++
public ref class P4ClientResolve

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4ClientResolve

See Also

P4ClientResolve Members


P4ClientResolve Members

[image] [image]

Perforce .NET API
P4ClientResolve Members
P4ClientResolve Class Constructors Methods Properties See Also Send Feedback

The P4ClientResolve type exposes the following members.

Constructors

 | Name | Description
Public method | P4ClientResolve | Initializes a new instance of the P4ClientResolve class

Methods

 | Name | Description
Public method | AutoResolve |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastError |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resolve |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoOpt |
Public property | Help |
Public property | HelpOpt |
Public property | MergeAction |
Public property | MergeOpt |
Public property | MergePrompt |
Public property | Prompt |
Public property | ResolveType |
Public property | SkipOpt |
Public property | TheirAction |
Public property | TheirOpt |
Public property | TheirPrompt |
Public property | TypePrompt |
Public property | UsageError |
Public property | YoursAction |
Public property | YoursOpt |
Public property | YoursPrompt |

See Also

P4ClientResolve Class


P4ClientResolve Constructor

[image]

Perforce .NET API
P4ClientResolve Constructor
P4ClientResolve Class See Also Send Feedback
Initializes a new instance of the P4ClientResolve class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientResolve(
    P4Server pserver,
    IntPtr p
)
Visual Basic
Public Sub New ( _
    pserver As P4Server, _
    p As IntPtr _
)
Visual C++
public:
P4ClientResolve(
    P4Server^ pserver,
    IntPtr p
)

Parameters

pserver
Type: Perforce.P4..::..P4Server
p
Type: System..::..IntPtr

See Also

P4ClientResolve Class


P4ClientResolve Methods

[image] [image]

Perforce .NET API
P4ClientResolve Methods
P4ClientResolve Class See Also Send Feedback

The P4ClientResolve type exposes the following members.

Methods

 | Name | Description
Public method | AutoResolve |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastError |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resolve |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4ClientResolve Class


AutoResolve Method

[image]

Perforce .NET API
P4ClientResolve..::..AutoResolve Method
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientMerge..::..MergeStatus AutoResolve(
    P4ClientMerge..::..MergeForce force
)
Visual Basic
Public Function AutoResolve ( _
    force As P4ClientMerge..::..MergeForce _
) As P4ClientMerge..::..MergeStatus
Visual C++
public:
P4ClientMerge..::..MergeStatus AutoResolve(
    P4ClientMerge..::..MergeForce force
)

Parameters

force
Type: Perforce.P4..::..P4ClientMerge..::..MergeForce

See Also

P4ClientResolve Class


GetLastError Method

[image]

Perforce .NET API
P4ClientResolve..::..GetLastError Method
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientError GetLastError()
Visual Basic
Public Function GetLastError As P4ClientError
Visual C++
public:
P4ClientError^ GetLastError()

See Also

P4ClientResolve Class


Resolve Method

[image]

Perforce .NET API
P4ClientResolve..::..Resolve Method
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientMerge..::..MergeStatus Resolve(
    bool preview
)
Visual Basic
Public Function Resolve ( _
    preview As Boolean _
) As P4ClientMerge..::..MergeStatus
Visual C++
public:
P4ClientMerge..::..MergeStatus Resolve(
    bool preview
)

Parameters

preview
Type: System..::..Boolean

See Also

P4ClientResolve Class


P4ClientResolve Properties

[image] [image]

Perforce .NET API
P4ClientResolve Properties
P4ClientResolve Class See Also Send Feedback

The P4ClientResolve type exposes the following members.

Properties

 | Name | Description
Public property | AutoOpt |
Public property | Help |
Public property | HelpOpt |
Public property | MergeAction |
Public property | MergeOpt |
Public property | MergePrompt |
Public property | Prompt |
Public property | ResolveType |
Public property | SkipOpt |
Public property | TheirAction |
Public property | TheirOpt |
Public property | TheirPrompt |
Public property | TypePrompt |
Public property | UsageError |
Public property | YoursAction |
Public property | YoursOpt |
Public property | YoursPrompt |

See Also

P4ClientResolve Class


AutoOpt Property

[image]

Perforce .NET API
P4ClientResolve..::..AutoOpt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string AutoOpt { get; }
Visual Basic
Public ReadOnly Property AutoOpt As String
    Get
Visual C++
public:
property String^ AutoOpt {
    String^ get ();
}

See Also

P4ClientResolve Class


Help Property

[image]

Perforce .NET API
P4ClientResolve..::..Help Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Help { get; }
Visual Basic
Public ReadOnly Property Help As String
    Get
Visual C++
public:
property String^ Help {
    String^ get ();
}

See Also

P4ClientResolve Class


HelpOpt Property

[image]

Perforce .NET API
P4ClientResolve..::..HelpOpt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string HelpOpt { get; }
Visual Basic
Public ReadOnly Property HelpOpt As String
    Get
Visual C++
public:
property String^ HelpOpt {
    String^ get ();
}

See Also

P4ClientResolve Class


MergeAction Property

[image]

Perforce .NET API
P4ClientResolve..::..MergeAction Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string MergeAction { get; }
Visual Basic
Public ReadOnly Property MergeAction As String
    Get
Visual C++
public:
property String^ MergeAction {
    String^ get ();
}

See Also

P4ClientResolve Class


MergeOpt Property

[image]

Perforce .NET API
P4ClientResolve..::..MergeOpt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string MergeOpt { get; }
Visual Basic
Public ReadOnly Property MergeOpt As String
    Get
Visual C++
public:
property String^ MergeOpt {
    String^ get ();
}

See Also

P4ClientResolve Class


MergePrompt Property

[image]

Perforce .NET API
P4ClientResolve..::..MergePrompt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string MergePrompt { get; }
Visual Basic
Public ReadOnly Property MergePrompt As String
    Get
Visual C++
public:
property String^ MergePrompt {
    String^ get ();
}

See Also

P4ClientResolve Class


Prompt Property

[image]

Perforce .NET API
P4ClientResolve..::..Prompt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Prompt { get; }
Visual Basic
Public ReadOnly Property Prompt As String
    Get
Visual C++
public:
property String^ Prompt {
    String^ get ();
}

See Also

P4ClientResolve Class


ResolveType Property

[image]

Perforce .NET API
P4ClientResolve..::..ResolveType Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ResolveType { get; }
Visual Basic
Public ReadOnly Property ResolveType As String
    Get
Visual C++
public:
property String^ ResolveType {
    String^ get ();
}

See Also

P4ClientResolve Class


SkipOpt Property

[image]

Perforce .NET API
P4ClientResolve..::..SkipOpt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string SkipOpt { get; }
Visual Basic
Public ReadOnly Property SkipOpt As String
    Get
Visual C++
public:
property String^ SkipOpt {
    String^ get ();
}

See Also

P4ClientResolve Class


TheirAction Property

[image]

Perforce .NET API
P4ClientResolve..::..TheirAction Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TheirAction { get; }
Visual Basic
Public ReadOnly Property TheirAction As String
    Get
Visual C++
public:
property String^ TheirAction {
    String^ get ();
}

See Also

P4ClientResolve Class


TheirOpt Property

[image]

Perforce .NET API
P4ClientResolve..::..TheirOpt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TheirOpt { get; }
Visual Basic
Public ReadOnly Property TheirOpt As String
    Get
Visual C++
public:
property String^ TheirOpt {
    String^ get ();
}

See Also

P4ClientResolve Class


TheirPrompt Property

[image]

Perforce .NET API
P4ClientResolve..::..TheirPrompt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TheirPrompt { get; }
Visual Basic
Public ReadOnly Property TheirPrompt As String
    Get
Visual C++
public:
property String^ TheirPrompt {
    String^ get ();
}

See Also

P4ClientResolve Class


TypePrompt Property

[image]

Perforce .NET API
P4ClientResolve..::..TypePrompt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TypePrompt { get; }
Visual Basic
Public ReadOnly Property TypePrompt As String
    Get
Visual C++
public:
property String^ TypePrompt {
    String^ get ();
}

See Also

P4ClientResolve Class


UsageError Property

[image]

Perforce .NET API
P4ClientResolve..::..UsageError Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string UsageError { get; }
Visual Basic
Public ReadOnly Property UsageError As String
    Get
Visual C++
public:
property String^ UsageError {
    String^ get ();
}

See Also

P4ClientResolve Class


YoursAction Property

[image]

Perforce .NET API
P4ClientResolve..::..YoursAction Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string YoursAction { get; }
Visual Basic
Public ReadOnly Property YoursAction As String
    Get
Visual C++
public:
property String^ YoursAction {
    String^ get ();
}

See Also

P4ClientResolve Class


YoursOpt Property

[image]

Perforce .NET API
P4ClientResolve..::..YoursOpt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string YoursOpt { get; }
Visual Basic
Public ReadOnly Property YoursOpt As String
    Get
Visual C++
public:
property String^ YoursOpt {
    String^ get ();
}

See Also

P4ClientResolve Class


YoursPrompt Property

[image]

Perforce .NET API
P4ClientResolve..::..YoursPrompt Property
P4ClientResolve Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string YoursPrompt { get; }
Visual Basic
Public ReadOnly Property YoursPrompt As String
    Get
Visual C++
public:
property String^ YoursPrompt {
    String^ get ();
}

See Also

P4ClientResolve Class


P4Command Class

[image]

Perforce .NET API
P4Command Class
Members See Also Send Feedback
Class wrapping command execution.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4Command : IDisposable
Visual Basic
Public Class P4Command _
    Implements IDisposable
Visual C++
public ref class P4Command : IDisposable

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4Command

See Also

P4Command Members


P4Command Members

[image] [image]

Perforce .NET API
P4Command Members
P4Command Class Constructors Methods Fields Properties See Also Send Feedback

The P4Command type exposes the following members.

Constructors

 | Name | Description
Public method | P4Command(P4Server) | Create a new command
Public method | P4Command(P4Server, P4Server..::..PromptHandlerDelegate) | Create a new command
Public method | P4Command(Connection, String, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(P4Server, String, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(Repository, String, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(P4Server, String, P4Server..::..PromptHandlerDelegate, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(Repository, String, P4Server..::..PromptHandlerDelegate, Boolean, array<String>[]()[][]) | Constructer

Methods

 | Name | Description
Public method | Dispose | Dispose of any resources
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run()()()() | Run the command using the existing arguments
Public method | Run(StringList) | Run the command supplying additional arguments
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | infoResultsCallbackFn | Capture info results so they can be reformatted

Properties

 | Name | Description
Public property | Args | Arguments for the command
Public property | BinaryOutput | Get the binary from the command execution
Public property | Cmd | Command String i.e 'submit'
Public property | CmdPromptHandler |
Public property | CmdResolveAHandler |
Public property | CmdResolveHandler |
Public property | CommandId | Unique Id set each time command is run
Public property | Connection |
Public property | DataSet | Data to be processed by the command
Public property | ErrorOutput | Get the error results from the command execution
Public property | InfoOutput | Get the info results from the command execution
Public property | pServer |
Public property | Responses | Dictionary of responses to prompts from the server, where the key is the expected prompt from the server and the value is the desired response.
Public property | Tagged | Run in tagged protocol
Public property | TaggedOutput | Get the tagged results from the command execution
Public property | TextOutput | Get the text output from the command execution

See Also

P4Command Class


P4Command Constructor

[image] [image]

Perforce .NET API
P4Command Constructor
P4Command Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4Command(P4Server) | Create a new command
Public method | P4Command(P4Server, P4Server..::..PromptHandlerDelegate) | Create a new command
Public method | P4Command(Connection, String, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(P4Server, String, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(Repository, String, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(P4Server, String, P4Server..::..PromptHandlerDelegate, Boolean, array<String>[]()[][]) | Constructer
Public method | P4Command(Repository, String, P4Server..::..PromptHandlerDelegate, Boolean, array<String>[]()[][]) | Constructer

See Also

P4Command Class
P4Command Members


P4Command Constructor (P4Server)

[image]

Perforce .NET API
P4Command Constructor (P4Server)
P4Command Class See Also Send Feedback
Create a new command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command(
    P4Server server
)
Visual Basic
Public Sub New ( _
    server As P4Server _
)
Visual C++
public:
P4Command(
    P4Server^ server
)

Parameters

server
Type: Perforce.P4..::..P4Server

See Also

P4Command Class
P4Command Overload


P4Command Constructor (P4Server, P4Server.PromptHandlerDelegate)

[image]

Perforce .NET API
P4Command Constructor (P4Server, P4Server..::..PromptHandlerDelegate)
P4Command Class See Also Send Feedback
Create a new command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command(
    P4Server server,
    P4Server..::..PromptHandlerDelegate promptHandler
)
Visual Basic
Public Sub New ( _
    server As P4Server, _
    promptHandler As P4Server..::..PromptHandlerDelegate _
)
Visual C++
public:
P4Command(
    P4Server^ server,
    P4Server..::..PromptHandlerDelegate^ promptHandler
)

Parameters

server
Type: Perforce.P4..::..P4Server
promptHandler
Type: Perforce.P4..::..P4Server..::..PromptHandlerDelegate

See Also

P4Command Class
P4Command Overload


P4Command Constructor (Connection, String, Boolean, String[])

[image]

Perforce .NET API
P4Command Constructor (Connection, String, Boolean, array<String>[]()[][])
P4Command Class See Also Send Feedback
Constructer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command(
    Connection connection,
    string command,
    bool taggedOutput,
    params string[] arguments
)
Visual Basic
Public Sub New ( _
    connection As Connection, _
    command As String, _
    taggedOutput As Boolean, _
    ParamArray arguments As String() _
)
Visual C++
public:
P4Command(
    Connection^ connection,
    String^ command,
    bool taggedOutput,
    ... array<String^>^ arguments
)

Parameters

connection
Type: Perforce.P4..::..Connection
Connection to the target Repository
command
Type: System..::..String
Command String i.e 'submit'
taggedOutput
Type: System..::..Boolean
Run in tagged protocol
arguments
Type: array< System..::..String >[]()[][]
Arguments for the command

See Also

P4Command Class
P4Command Overload


P4Command Constructor (P4Server, String, Boolean, String[])

[image]

Perforce .NET API
P4Command Constructor (P4Server, String, Boolean, array<String>[]()[][])
P4Command Class See Also Send Feedback
Constructer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command(
    P4Server server,
    string command,
    bool taggedOutput,
    params string[] arguments
)
Visual Basic
Public Sub New ( _
    server As P4Server, _
    command As String, _
    taggedOutput As Boolean, _
    ParamArray arguments As String() _
)
Visual C++
public:
P4Command(
    P4Server^ server,
    String^ command,
    bool taggedOutput,
    ... array<String^>^ arguments
)

Parameters

server
Type: Perforce.P4..::..P4Server
Target P4Server
command
Type: System..::..String
Command String i.e 'submit'
taggedOutput
Type: System..::..Boolean
Run in tagged protocol
arguments
Type: array< System..::..String >[]()[][]
Arguments for the command

See Also

P4Command Class
P4Command Overload


P4Command Constructor (Repository, String, Boolean, String[])

[image]

Perforce .NET API
P4Command Constructor (Repository, String, Boolean, array<String>[]()[][])
P4Command Class See Also Send Feedback
Constructer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command(
    Repository repository,
    string command,
    bool taggedOutput,
    params string[] arguments
)
Visual Basic
Public Sub New ( _
    repository As Repository, _
    command As String, _
    taggedOutput As Boolean, _
    ParamArray arguments As String() _
)
Visual C++
public:
P4Command(
    Repository^ repository,
    String^ command,
    bool taggedOutput,
    ... array<String^>^ arguments
)

Parameters

repository
Type: Perforce.P4..::..Repository
Target Repository
command
Type: System..::..String
Command String i.e 'submit'
taggedOutput
Type: System..::..Boolean
Run in tagged protocol
arguments
Type: array< System..::..String >[]()[][]
Arguments for the command

See Also

P4Command Class
P4Command Overload


P4Command Constructor (P4Server, String, P4Server.PromptHandlerDelegate, Boolean, String[])

[image]

Perforce .NET API
P4Command Constructor (P4Server, String, P4Server..::..PromptHandlerDelegate, Boolean, array<String>[]()[][])
P4Command Class See Also Send Feedback
Constructer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command(
    P4Server server,
    string command,
    P4Server..::..PromptHandlerDelegate promptHandler,
    bool taggedOutput,
    params string[] arguments
)
Visual Basic
Public Sub New ( _
    server As P4Server, _
    command As String, _
    promptHandler As P4Server..::..PromptHandlerDelegate, _
    taggedOutput As Boolean, _
    ParamArray arguments As String() _
)
Visual C++
public:
P4Command(
    P4Server^ server,
    String^ command,
    P4Server..::..PromptHandlerDelegate^ promptHandler,
    bool taggedOutput,
    ... array<String^>^ arguments
)

Parameters

server
Type: Perforce.P4..::..P4Server
Target P4Server
command
Type: System..::..String
Command String i.e 'submit'
promptHandler
Type: Perforce.P4..::..P4Server..::..PromptHandlerDelegate
taggedOutput
Type: System..::..Boolean
Run in tagged protocol
arguments
Type: array< System..::..String >[]()[][]
Arguments for the command

See Also

P4Command Class
P4Command Overload


P4Command Constructor (Repository, String, P4Server.PromptHandlerDelegate, Boolean, String[])

[image]

Perforce .NET API
P4Command Constructor (Repository, String, P4Server..::..PromptHandlerDelegate, Boolean, array<String>[]()[][])
P4Command Class See Also Send Feedback
Constructer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Command(
    Repository repository,
    string command,
    P4Server..::..PromptHandlerDelegate promptHandler,
    bool taggedOutput,
    params string[] arguments
)
Visual Basic
Public Sub New ( _
    repository As Repository, _
    command As String, _
    promptHandler As P4Server..::..PromptHandlerDelegate, _
    taggedOutput As Boolean, _
    ParamArray arguments As String() _
)
Visual C++
public:
P4Command(
    Repository^ repository,
    String^ command,
    P4Server..::..PromptHandlerDelegate^ promptHandler,
    bool taggedOutput,
    ... array<String^>^ arguments
)

Parameters

repository
Type: Perforce.P4..::..Repository
Target Repository
command
Type: System..::..String
Command String i.e 'submit'
promptHandler
Type: Perforce.P4..::..P4Server..::..PromptHandlerDelegate
taggedOutput
Type: System..::..Boolean
Run in tagged protocol
arguments
Type: array< System..::..String >[]()[][]
Arguments for the command

See Also

P4Command Class
P4Command Overload


P4Command Fields

[image] [image]

Perforce .NET API
P4Command Fields
P4Command Class See Also Send Feedback

The P4Command type exposes the following members.

Fields

 | Name | Description
Public field | infoResultsCallbackFn | Capture info results so they can be reformatted

See Also

P4Command Class


infoResultsCallbackFn Field

[image]

Perforce .NET API
P4Command..::..infoResultsCallbackFn Field
P4Command Class See Also Send Feedback
Capture info results so they can be reformatted

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server..::..InfoResultsDelegate infoResultsCallbackFn
Visual Basic
Public infoResultsCallbackFn As P4Server..::..InfoResultsDelegate
Visual C++
public:
P4Server..::..InfoResultsDelegate^ infoResultsCallbackFn

See Also

P4Command Class


P4Command Methods

[image] [image]

Perforce .NET API
P4Command Methods
P4Command Class See Also Send Feedback

The P4Command type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose of any resources
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run()()()() | Run the command using the existing arguments
Public method | Run(StringList) | Run the command supplying additional arguments
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4Command Class


Dispose Method

[image]

Perforce .NET API
P4Command..::..Dispose Method
P4Command Class See Also Send Feedback
Dispose of any resources

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

P4Command Class


Run Method

[image] [image]

Perforce .NET API
P4Command..::..Run Method
P4Command Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Run()()()() | Run the command using the existing arguments
Public method | Run(StringList) | Run the command supplying additional arguments

See Also

P4Command Class
P4Command Members


Run Method

[image]

Perforce .NET API
P4Command..::..Run Method
P4Command Class See Also Send Feedback
Run the command using the existing arguments

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandResult Run()
Visual Basic
Public Function Run As P4CommandResult
Visual C++
public:
P4CommandResult^ Run()

Return Value

See Also

P4Command Class
Run Overload


Run Method (StringList)

[image]

Perforce .NET API
P4Command..::..Run Method (StringList)
P4Command Class See Also Send Feedback
Run the command supplying additional arguments

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandResult Run(
    StringList flags
)
Visual Basic
Public Function Run ( _
    flags As StringList _
) As P4CommandResult
Visual C++
public:
P4CommandResult^ Run(
    StringList^ flags
)

Parameters

flags
Type: Perforce.P4..::..StringList
Additional arguments inserted in front of the current arguments

Return Value

Success/Failure

See Also

P4Command Class
Run Overload


P4Command Properties

[image] [image]

Perforce .NET API
P4Command Properties
P4Command Class See Also Send Feedback

The P4Command type exposes the following members.

Properties

 | Name | Description
Public property | Args | Arguments for the command
Public property | BinaryOutput | Get the binary from the command execution
Public property | Cmd | Command String i.e 'submit'
Public property | CmdPromptHandler |
Public property | CmdResolveAHandler |
Public property | CmdResolveHandler |
Public property | CommandId | Unique Id set each time command is run
Public property | Connection |
Public property | DataSet | Data to be processed by the command
Public property | ErrorOutput | Get the error results from the command execution
Public property | InfoOutput | Get the info results from the command execution
Public property | pServer |
Public property | Responses | Dictionary of responses to prompts from the server, where the key is the expected prompt from the server and the value is the desired response.
Public property | Tagged | Run in tagged protocol
Public property | TaggedOutput | Get the tagged results from the command execution
Public property | TextOutput | Get the text output from the command execution

See Also

P4Command Class


Args Property

[image]

Perforce .NET API
P4Command..::..Args Property
P4Command Class See Also Send Feedback
Arguments for the command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StringList Args { get; set; }
Visual Basic
Public Property Args As StringList
    Get
    Set
Visual C++
public:
property StringList^ Args {
    StringList^ get ();
    void set (StringList^ value);
}

See Also

P4Command Class


BinaryOutput Property

[image]

Perforce .NET API
P4Command..::..BinaryOutput Property
P4Command Class See Also Send Feedback
Get the binary from the command execution

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public byte[] BinaryOutput { get; }
Visual Basic
Public ReadOnly Property BinaryOutput As Byte()
    Get
Visual C++
public:
property array<unsigned char>^ BinaryOutput {
    array<unsigned char>^ get ();
}

See Also

P4Command Class


Cmd Property

[image]

Perforce .NET API
P4Command..::..Cmd Property
P4Command Class See Also Send Feedback
Command String i.e 'submit'

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Cmd { get; set; }
Visual Basic
Public Property Cmd As String
    Get
    Set
Visual C++
public:
property String^ Cmd {
    String^ get ();
    void set (String^ value);
}

See Also

P4Command Class


CmdPromptHandler Property

[image]

Perforce .NET API
P4Command..::..CmdPromptHandler Property
P4Command Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server..::..PromptHandlerDelegate CmdPromptHandler { get; set; }
Visual Basic
Public Property CmdPromptHandler As P4Server..::..PromptHandlerDelegate
    Get
    Set
Visual C++
public:
property P4Server..::..PromptHandlerDelegate^ CmdPromptHandler {
    P4Server..::..PromptHandlerDelegate^ get ();
    void set (P4Server..::..PromptHandlerDelegate^ value);
}

See Also

P4Command Class


CmdResolveAHandler Property

[image]

Perforce .NET API
P4Command..::..CmdResolveAHandler Property
P4Command Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server..::..ResolveAHandlerDelegate CmdResolveAHandler { get; set; }
Visual Basic
Public Property CmdResolveAHandler As P4Server..::..ResolveAHandlerDelegate
    Get
    Set
Visual C++
public:
property P4Server..::..ResolveAHandlerDelegate^ CmdResolveAHandler {
    P4Server..::..ResolveAHandlerDelegate^ get ();
    void set (P4Server..::..ResolveAHandlerDelegate^ value);
}

See Also

P4Command Class


CmdResolveHandler Property

[image]

Perforce .NET API
P4Command..::..CmdResolveHandler Property
P4Command Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server..::..ResolveHandlerDelegate CmdResolveHandler { get; set; }
Visual Basic
Public Property CmdResolveHandler As P4Server..::..ResolveHandlerDelegate
    Get
    Set
Visual C++
public:
property P4Server..::..ResolveHandlerDelegate^ CmdResolveHandler {
    P4Server..::..ResolveHandlerDelegate^ get ();
    void set (P4Server..::..ResolveHandlerDelegate^ value);
}

See Also

P4Command Class


CommandId Property

[image]

Perforce .NET API
P4Command..::..CommandId Property
P4Command Class See Also Send Feedback
Unique Id set each time command is run

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public uint CommandId { get; private set; }
Visual Basic
Public Property CommandId As UInteger
    Get
    Private Set
Visual C++
public:
property unsigned int CommandId {
    unsigned int get ();
    private: void set (unsigned int value);
}

See Also

P4Command Class


Connection Property

[image]

Perforce .NET API
P4Command..::..Connection Property
P4Command Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Connection Connection { get; private set; }
Visual Basic
Public Property Connection As Connection
    Get
    Private Set
Visual C++
public:
property Connection^ Connection {
    Connection^ get ();
    private: void set (Connection^ value);
}

See Also

P4Command Class


DataSet Property

[image]

Perforce .NET API
P4Command..::..DataSet Property
P4Command Class See Also Send Feedback
Data to be processed by the command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string DataSet { get; set; }
Visual Basic
Public Property DataSet As String
    Get
    Set
Visual C++
public:
property String^ DataSet {
    String^ get ();
    void set (String^ value);
}

See Also

P4Command Class


ErrorOutput Property

[image]

Perforce .NET API
P4Command..::..ErrorOutput Property
P4Command Class See Also Send Feedback
Get the error results from the command execution

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientErrorList ErrorOutput { get; }
Visual Basic
Public ReadOnly Property ErrorOutput As P4ClientErrorList
    Get
Visual C++
public:
property P4ClientErrorList^ ErrorOutput {
    P4ClientErrorList^ get ();
}

See Also

P4Command Class


InfoOutput Property

[image]

Perforce .NET API
P4Command..::..InfoOutput Property
P4Command Class See Also Send Feedback
Get the info results from the command execution

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessageList InfoOutput { get; }
Visual Basic
Public ReadOnly Property InfoOutput As P4ClientInfoMessageList
    Get
Visual C++
public:
property P4ClientInfoMessageList^ InfoOutput {
    P4ClientInfoMessageList^ get ();
}

See Also

P4Command Class


pServer Property

[image]

Perforce .NET API
P4Command..::..pServer Property
P4Command Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server pServer { get; private set; }
Visual Basic
Public Property pServer As P4Server
    Get
    Private Set
Visual C++
public:
property P4Server^ pServer {
    P4Server^ get ();
    private: void set (P4Server^ value);
}

See Also

P4Command Class


Responses Property

[image]

Perforce .NET API
P4Command..::..Responses Property
P4Command Class See Also Send Feedback
Dictionary of responses to prompts from the server, where the key is the expected prompt from the server and the value is the desired response.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Dictionary<string, string> Responses { get; set; }
Visual Basic
Public Property Responses As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Responses {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

See Also

P4Command Class


Tagged Property

[image]

Perforce .NET API
P4Command..::..Tagged Property
P4Command Class See Also Send Feedback
Run in tagged protocol

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Tagged { get; set; }
Visual Basic
Public Property Tagged As Boolean
    Get
    Set
Visual C++
public:
property bool Tagged {
    bool get ();
    void set (bool value);
}

See Also

P4Command Class


TaggedOutput Property

[image]

Perforce .NET API
P4Command..::..TaggedOutput Property
P4Command Class See Also Send Feedback
Get the tagged results from the command execution

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObjectList TaggedOutput { get; }
Visual Basic
Public ReadOnly Property TaggedOutput As TaggedObjectList
    Get
Visual C++
public:
property TaggedObjectList^ TaggedOutput {
    TaggedObjectList^ get ();
}

See Also

P4Command Class


TextOutput Property

[image]

Perforce .NET API
P4Command..::..TextOutput Property
P4Command Class See Also Send Feedback
Get the text output from the command execution

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TextOutput { get; }
Visual Basic
Public ReadOnly Property TextOutput As String
    Get
Visual C++
public:
property String^ TextOutput {
    String^ get ();
}

See Also

P4Command Class


P4CommandCanceledException Class

[image]

Perforce .NET API
P4CommandCanceledException Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4CommandCanceledException : P4Exception
Visual Basic
Public Class P4CommandCanceledException _
    Inherits P4Exception
Visual C++
public ref class P4CommandCanceledException : public P4Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Perforce.P4..::..P4Exception
Perforce.P4..::..P4CommandCanceledException

See Also

P4CommandCanceledException Members


P4CommandCanceledException Members

[image] [image]

Perforce .NET API
P4CommandCanceledException Members
P4CommandCanceledException Class Constructors Methods Properties Events See Also Send Feedback

The P4CommandCanceledException type exposes the following members.

Constructors

 | Name | Description
Public method | P4CommandCanceledException | Initializes a new instance of the P4CommandCanceledException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4CommandCanceledException Class


P4CommandCanceledException Constructor

[image]

Perforce .NET API
P4CommandCanceledException Constructor
P4CommandCanceledException Class See Also Send Feedback
Initializes a new instance of the P4CommandCanceledException class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandCanceledException(
    string nMessage
)
Visual Basic
Public Sub New ( _
    nMessage As String _
)
Visual C++
public:
P4CommandCanceledException(
    String^ nMessage
)

Parameters

nMessage
Type: System..::..String

See Also

P4CommandCanceledException Class


P4CommandCanceledException Methods

[image] [image]

Perforce .NET API
P4CommandCanceledException Methods
P4CommandCanceledException Class See Also Send Feedback

The P4CommandCanceledException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

P4CommandCanceledException Class


P4CommandCanceledException Properties

[image] [image]

Perforce .NET API
P4CommandCanceledException Properties
P4CommandCanceledException Class See Also Send Feedback

The P4CommandCanceledException type exposes the following members.

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4CommandCanceledException Class


P4CommandCanceledException Events

[image] [image]

Perforce .NET API
P4CommandCanceledException Events
P4CommandCanceledException Class See Also Send Feedback

The P4CommandCanceledException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4CommandCanceledException Class


P4CommandResult Class

[image]

Perforce .NET API
P4CommandResult Class
Members See Also Send Feedback
Class representing the results of executing a command on a Perforce Server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4CommandResult
Visual Basic
Public Class P4CommandResult
Visual C++
public ref class P4CommandResult

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4CommandResult

See Also

P4CommandResult Members


P4CommandResult Members

[image] [image]

Perforce .NET API
P4CommandResult Members
P4CommandResult Class Constructors Methods Properties See Also Send Feedback

The P4CommandResult type exposes the following members.

Constructors

 | Name | Description
Public method | P4CommandResult(P4Command) | Create a P4CommandResult by running a command
Public method | P4CommandResult(P4Command, StringList) | Create a P4CommandResult by running a command

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BinaryOutput | The binary output of the command
Public property | Cmd | The command that was run
Public property | CmdArgs | The arguments for command that was run
Public property | ErrorList | The errors (if any) of the command execution
Public property | InfoOutput | The info results (if any) of the command execution
Public property | Success | Did the command not return any errors?
Public property | TaggedOutput | The tagged output of the command
Public property | TextOutput | The text output from the command
Public property | TimeStamp | The time the command completed and the results were collected.

See Also

P4CommandResult Class


P4CommandResult Constructor

[image] [image]

Perforce .NET API
P4CommandResult Constructor
P4CommandResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4CommandResult(P4Command) | Create a P4CommandResult by running a command
Public method | P4CommandResult(P4Command, StringList) | Create a P4CommandResult by running a command

See Also

P4CommandResult Class
P4CommandResult Members


P4CommandResult Constructor (P4Command)

[image]

Perforce .NET API
P4CommandResult Constructor (P4Command)
P4CommandResult Class See Also Send Feedback
Create a P4CommandResult by running a command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandResult(
    P4Command cmd
)
Visual Basic
Public Sub New ( _
    cmd As P4Command _
)
Visual C++
public:
P4CommandResult(
    P4Command^ cmd
)

Parameters

cmd
Type: Perforce.P4..::..P4Command
Command to run

See Also

P4CommandResult Class
P4CommandResult Overload


P4CommandResult Constructor (P4Command, StringList)

[image]

Perforce .NET API
P4CommandResult Constructor (P4Command, StringList)
P4CommandResult Class See Also Send Feedback
Create a P4CommandResult by running a command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandResult(
    P4Command cmd,
    StringList flags
)
Visual Basic
Public Sub New ( _
    cmd As P4Command, _
    flags As StringList _
)
Visual C++
public:
P4CommandResult(
    P4Command^ cmd,
    StringList^ flags
)

Parameters

cmd
Type: Perforce.P4..::..P4Command
Command to run
flags
Type: Perforce.P4..::..StringList
Flags for the command

See Also

P4CommandResult Class
P4CommandResult Overload


P4CommandResult Methods

[image] [image]

Perforce .NET API
P4CommandResult Methods
P4CommandResult Class See Also Send Feedback

The P4CommandResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4CommandResult Class


P4CommandResult Properties

[image] [image]

Perforce .NET API
P4CommandResult Properties
P4CommandResult Class See Also Send Feedback

The P4CommandResult type exposes the following members.

Properties

 | Name | Description
Public property | BinaryOutput | The binary output of the command
Public property | Cmd | The command that was run
Public property | CmdArgs | The arguments for command that was run
Public property | ErrorList | The errors (if any) of the command execution
Public property | InfoOutput | The info results (if any) of the command execution
Public property | Success | Did the command not return any errors?
Public property | TaggedOutput | The tagged output of the command
Public property | TextOutput | The text output from the command
Public property | TimeStamp | The time the command completed and the results were collected.

See Also

P4CommandResult Class


BinaryOutput Property

[image]

Perforce .NET API
P4CommandResult..::..BinaryOutput Property
P4CommandResult Class See Also Send Feedback
The binary output of the command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public byte[] BinaryOutput { get; }
Visual Basic
Public ReadOnly Property BinaryOutput As Byte()
    Get
Visual C++
public:
property array<unsigned char>^ BinaryOutput {
    array<unsigned char>^ get ();
}

See Also

P4CommandResult Class


Cmd Property

[image]

Perforce .NET API
P4CommandResult..::..Cmd Property
P4CommandResult Class See Also Send Feedback
The command that was run

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Cmd { get; }
Visual Basic
Public ReadOnly Property Cmd As String
    Get
Visual C++
public:
property String^ Cmd {
    String^ get ();
}

See Also

P4CommandResult Class


CmdArgs Property

[image]

Perforce .NET API
P4CommandResult..::..CmdArgs Property
P4CommandResult Class See Also Send Feedback
The arguments for command that was run

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string[] CmdArgs { get; }
Visual Basic
Public ReadOnly Property CmdArgs As String()
    Get
Visual C++
public:
property array<String^>^ CmdArgs {
    array<String^>^ get ();
}

See Also

P4CommandResult Class


ErrorList Property

[image]

Perforce .NET API
P4CommandResult..::..ErrorList Property
P4CommandResult Class See Also Send Feedback
The errors (if any) of the command execution

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientErrorList ErrorList { get; }
Visual Basic
Public ReadOnly Property ErrorList As P4ClientErrorList
    Get
Visual C++
public:
property P4ClientErrorList^ ErrorList {
    P4ClientErrorList^ get ();
}

See Also

P4CommandResult Class


InfoOutput Property

[image]

Perforce .NET API
P4CommandResult..::..InfoOutput Property
P4CommandResult Class See Also Send Feedback
The info results (if any) of the command execution

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessageList InfoOutput { get; }
Visual Basic
Public ReadOnly Property InfoOutput As P4ClientInfoMessageList
    Get
Visual C++
public:
property P4ClientInfoMessageList^ InfoOutput {
    P4ClientInfoMessageList^ get ();
}

See Also

P4CommandResult Class


Success Property

[image]

Perforce .NET API
P4CommandResult..::..Success Property
P4CommandResult Class See Also Send Feedback
Did the command not return any errors?

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Success { get; }
Visual Basic
Public ReadOnly Property Success As Boolean
    Get
Visual C++
public:
property bool Success {
    bool get ();
}

See Also

P4CommandResult Class


TaggedOutput Property

[image]

Perforce .NET API
P4CommandResult..::..TaggedOutput Property
P4CommandResult Class See Also Send Feedback
The tagged output of the command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObjectList TaggedOutput { get; }
Visual Basic
Public ReadOnly Property TaggedOutput As TaggedObjectList
    Get
Visual C++
public:
property TaggedObjectList^ TaggedOutput {
    TaggedObjectList^ get ();
}

See Also

P4CommandResult Class


TextOutput Property

[image]

Perforce .NET API
P4CommandResult..::..TextOutput Property
P4CommandResult Class See Also Send Feedback
The text output from the command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TextOutput { get; }
Visual Basic
Public ReadOnly Property TextOutput As String
    Get
Visual C++
public:
property String^ TextOutput {
    String^ get ();
}

See Also

P4CommandResult Class


TimeStamp Property

[image]

Perforce .NET API
P4CommandResult..::..TimeStamp Property
P4CommandResult Class See Also Send Feedback
The time the command completed and the results were collected.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime TimeStamp { get; private set; }
Visual Basic
Public Property TimeStamp As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime TimeStamp {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

P4CommandResult Class


P4CommandTimeOutException Class

[image]

Perforce .NET API
P4CommandTimeOutException Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4CommandTimeOutException : P4Exception
Visual Basic
Public Class P4CommandTimeOutException _
    Inherits P4Exception
Visual C++
public ref class P4CommandTimeOutException : public P4Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Perforce.P4..::..P4Exception
Perforce.P4..::..P4CommandTimeOutException

See Also

P4CommandTimeOutException Members


P4CommandTimeOutException Members

[image] [image]

Perforce .NET API
P4CommandTimeOutException Members
P4CommandTimeOutException Class Constructors Methods Properties Events See Also Send Feedback

The P4CommandTimeOutException type exposes the following members.

Constructors

 | Name | Description
Public method | P4CommandTimeOutException | Initializes a new instance of the P4CommandTimeOutException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4CommandTimeOutException Class


P4CommandTimeOutException Constructor

[image]

Perforce .NET API
P4CommandTimeOutException Constructor
P4CommandTimeOutException Class See Also Send Feedback
Initializes a new instance of the P4CommandTimeOutException class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandTimeOutException(
    ErrorSeverity nLevel,
    string nMessage
)
Visual Basic
Public Sub New ( _
    nLevel As ErrorSeverity, _
    nMessage As String _
)
Visual C++
public:
P4CommandTimeOutException(
    ErrorSeverity nLevel,
    String^ nMessage
)

Parameters

nLevel
Type: Perforce.P4..::..ErrorSeverity
nMessage
Type: System..::..String

See Also

P4CommandTimeOutException Class


P4CommandTimeOutException Methods

[image] [image]

Perforce .NET API
P4CommandTimeOutException Methods
P4CommandTimeOutException Class See Also Send Feedback

The P4CommandTimeOutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

P4CommandTimeOutException Class


P4CommandTimeOutException Properties

[image] [image]

Perforce .NET API
P4CommandTimeOutException Properties
P4CommandTimeOutException Class See Also Send Feedback

The P4CommandTimeOutException type exposes the following members.

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4CommandTimeOutException Class


P4CommandTimeOutException Events

[image] [image]

Perforce .NET API
P4CommandTimeOutException Events
P4CommandTimeOutException Class See Also Send Feedback

The P4CommandTimeOutException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4CommandTimeOutException Class


P4Exception Class

[image]

Perforce .NET API
P4Exception Class
Members See Also Send Feedback
Base class for exceptions caused by run time errors from the server. They can be disabled, by setting the MinThrowLevel to ErrorSeverity.E_NOEXC.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4Exception : Exception
Visual Basic
Public Class P4Exception _
    Inherits Exception
Visual C++
public ref class P4Exception : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Perforce.P4..::..P4Exception
Perforce.P4..::..P4CantCloseConnectionException
Perforce.P4..::..P4CommandCanceledException
Perforce.P4..::..P4CommandTimeOutException
Perforce.P4..::..P4HungCommandCancelException
Perforce.P4..::..P4LostConnectionException
Perforce.P4..::..P4TrustException

See Also

P4Exception Members


P4Exception Members

[image] [image]

Perforce .NET API
P4Exception Members
P4Exception Class Constructors Methods Properties Events See Also Send Feedback

The P4Exception type exposes the following members.

Constructors

 | Name | Description
Public method | P4Exception(P4ClientError) | Create a new P4Exception
Public method | P4Exception(P4ClientErrorList) | Create a list of new P4Exceptions
Public method | P4Exception(ErrorSeverity, String) | Create a new P4Exception
Public method | P4Exception(String, array<String>[]()[][], P4ClientError) | Create a new P4Exception
Public method | P4Exception(String, array<String>[]()[][], P4ClientErrorList) | Create a list of new P4Exceptions
Public method | P4Exception(ErrorSeverity, String, P4Exception) | Create a new P4Exception
Public method | P4Exception(String, array<String>[]()[][], ErrorSeverity, String) | Create a new P4Exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Throw(P4ClientError) | Create and throw an exception if it exceeds the MinThrowLevel
 | Throw(ErrorSeverity, String) | Create and throw an exception if it exceeds the MinThrowLevel
 | Throw(String, array<String>[]()[][], P4ClientError) | Create and throw an exception if it exceeds the MinThrowLevel
 | Throw(String, array<String>[]()[][], ErrorSeverity, String) | Create and throw an exception if it exceeds the MinThrowLevel
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CmdLine | Error message
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message
Public property | ErrorCode | Error number from the C++ API
Public property | ErrorLevel | Severity of the error
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Overrides Exception..::..Message.)
 | MinThrowLevel | Minimum error to cause an exception to be thrown
Public property | NextError | If more than one error was returned by a command, the next error in the list.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4Exception Class


P4Exception Constructor

[image] [image]

Perforce .NET API
P4Exception Constructor
P4Exception Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4Exception(P4ClientError) | Create a new P4Exception
Public method | P4Exception(P4ClientErrorList) | Create a list of new P4Exceptions
Public method | P4Exception(ErrorSeverity, String) | Create a new P4Exception
Public method | P4Exception(String, array<String>[]()[][], P4ClientError) | Create a new P4Exception
Public method | P4Exception(String, array<String>[]()[][], P4ClientErrorList) | Create a list of new P4Exceptions
Public method | P4Exception(ErrorSeverity, String, P4Exception) | Create a new P4Exception
Public method | P4Exception(String, array<String>[]()[][], ErrorSeverity, String) | Create a new P4Exception

See Also

P4Exception Class
P4Exception Members


P4Exception Constructor (P4ClientError)

[image]

Perforce .NET API
P4Exception Constructor (P4ClientError)
P4Exception Class See Also Send Feedback
Create a new P4Exception

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception(
    P4ClientError error
)
Visual Basic
Public Sub New ( _
    error As P4ClientError _
)
Visual C++
public:
P4Exception(
    P4ClientError^ error
)

Parameters

error
Type: Perforce.P4..::..P4ClientError
Client error causing the exception

See Also

P4Exception Class
P4Exception Overload


P4Exception Constructor (P4ClientErrorList)

[image]

Perforce .NET API
P4Exception Constructor (P4ClientErrorList)
P4Exception Class See Also Send Feedback
Create a list of new P4Exceptions

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception(
    P4ClientErrorList errors
)
Visual Basic
Public Sub New ( _
    errors As P4ClientErrorList _
)
Visual C++
public:
P4Exception(
    P4ClientErrorList^ errors
)

Parameters

errors
Type: Perforce.P4..::..P4ClientErrorList
The list of errors which caused the exception

See Also

P4Exception Class
P4Exception Overload


P4Exception Constructor (ErrorSeverity, String)

[image]

Perforce .NET API
P4Exception Constructor (ErrorSeverity, String)
P4Exception Class See Also Send Feedback
Create a new P4Exception

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception(
    ErrorSeverity nLevel,
    string nMessage
)
Visual Basic
Public Sub New ( _
    nLevel As ErrorSeverity, _
    nMessage As String _
)
Visual C++
public:
P4Exception(
    ErrorSeverity nLevel,
    String^ nMessage
)

Parameters

nLevel
Type: Perforce.P4..::..ErrorSeverity
Severity level
nMessage
Type: System..::..String
Error message

See Also

P4Exception Class
P4Exception Overload


P4Exception Constructor (String, String[], P4ClientError)

[image]

Perforce .NET API
P4Exception Constructor (String, array<String>[]()[][], P4ClientError)
P4Exception Class See Also Send Feedback
Create a new P4Exception

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception(
    string cmd,
    string[] args,
    P4ClientError error
)
Visual Basic
Public Sub New ( _
    cmd As String, _
    args As String(), _
    error As P4ClientError _
)
Visual C++
public:
P4Exception(
    String^ cmd,
    array<String^>^ args,
    P4ClientError^ error
)

Parameters

cmd
Type: System..::..String
args
Type: array< System..::..String >[]()[][]
error
Type: Perforce.P4..::..P4ClientError
Client error causing the exception

See Also

P4Exception Class
P4Exception Overload


P4Exception Constructor (String, String[], P4ClientErrorList)

[image]

Perforce .NET API
P4Exception Constructor (String, array<String>[]()[][], P4ClientErrorList)
P4Exception Class See Also Send Feedback
Create a list of new P4Exceptions

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception(
    string cmd,
    string[] args,
    P4ClientErrorList errors
)
Visual Basic
Public Sub New ( _
    cmd As String, _
    args As String(), _
    errors As P4ClientErrorList _
)
Visual C++
public:
P4Exception(
    String^ cmd,
    array<String^>^ args,
    P4ClientErrorList^ errors
)

Parameters

cmd
Type: System..::..String
args
Type: array< System..::..String >[]()[][]
errors
Type: Perforce.P4..::..P4ClientErrorList
The list of errors which caused the exception

See Also

P4Exception Class
P4Exception Overload


P4Exception Constructor (ErrorSeverity, String, P4Exception)

[image]

Perforce .NET API
P4Exception Constructor (ErrorSeverity, String, P4Exception)
P4Exception Class See Also Send Feedback
Create a new P4Exception

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception(
    ErrorSeverity nLevel,
    string nMessage,
    P4Exception NextError
)
Visual Basic
Public Sub New ( _
    nLevel As ErrorSeverity, _
    nMessage As String, _
    NextError As P4Exception _
)
Visual C++
public:
P4Exception(
    ErrorSeverity nLevel,
    String^ nMessage,
    P4Exception^ NextError
)

Parameters

nLevel
Type: Perforce.P4..::..ErrorSeverity
Severity level
nMessage
Type: System..::..String
Error message
NextError
Type: Perforce.P4..::..P4Exception
Next error in sequence

See Also

P4Exception Class
P4Exception Overload


P4Exception Constructor (String, String[], ErrorSeverity, String)

[image]

Perforce .NET API
P4Exception Constructor (String, array<String>[]()[][], ErrorSeverity, String)
P4Exception Class See Also Send Feedback
Create a new P4Exception

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception(
    string cmd,
    string[] args,
    ErrorSeverity nLevel,
    string nMessage
)
Visual Basic
Public Sub New ( _
    cmd As String, _
    args As String(), _
    nLevel As ErrorSeverity, _
    nMessage As String _
)
Visual C++
public:
P4Exception(
    String^ cmd,
    array<String^>^ args,
    ErrorSeverity nLevel,
    String^ nMessage
)

Parameters

cmd
Type: System..::..String
args
Type: array< System..::..String >[]()[][]
nLevel
Type: Perforce.P4..::..ErrorSeverity
Severity level
nMessage
Type: System..::..String
Error message

See Also

P4Exception Class
P4Exception Overload


P4Exception Methods

[image] [image]

Perforce .NET API
P4Exception Methods
P4Exception Class See Also Send Feedback

The P4Exception type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Throw(P4ClientError) | Create and throw an exception if it exceeds the MinThrowLevel
 | Throw(ErrorSeverity, String) | Create and throw an exception if it exceeds the MinThrowLevel
 | Throw(String, array<String>[]()[][], P4ClientError) | Create and throw an exception if it exceeds the MinThrowLevel
 | Throw(String, array<String>[]()[][], ErrorSeverity, String) | Create and throw an exception if it exceeds the MinThrowLevel
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

P4Exception Class


Throw Method

[image] [image]

Perforce .NET API
P4Exception..::..Throw Method
P4Exception Class See Also Send Feedback

Overload List

Name | Description
Throw(P4ClientError) | Create and throw an exception if it exceeds the MinThrowLevel
Throw(ErrorSeverity, String) | Create and throw an exception if it exceeds the MinThrowLevel
Throw(String, array<String>[]()[][], P4ClientError) | Create and throw an exception if it exceeds the MinThrowLevel
Throw(String, array<String>[]()[][], ErrorSeverity, String) | Create and throw an exception if it exceeds the MinThrowLevel

See Also

P4Exception Class
P4Exception Members


Throw Method (P4ClientError)

[image]

Perforce .NET API
P4Exception..::..Throw Method (P4ClientError)
P4Exception Class See Also Send Feedback
Create and throw an exception if it exceeds the MinThrowLevel

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void Throw(
    P4ClientError error
)
Visual Basic
Public Shared Sub Throw ( _
    error As P4ClientError _
)
Visual C++
public:
static void Throw(
    P4ClientError^ error
)

Parameters

error
Type: Perforce.P4..::..P4ClientError
Client error causing the exception

See Also

P4Exception Class
Throw Overload


Throw Method (ErrorSeverity, String)

[image]

Perforce .NET API
P4Exception..::..Throw Method (ErrorSeverity, String)
P4Exception Class See Also Send Feedback
Create and throw an exception if it exceeds the MinThrowLevel

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void Throw(
    ErrorSeverity nLevel,
    string nMessage
)
Visual Basic
Public Shared Sub Throw ( _
    nLevel As ErrorSeverity, _
    nMessage As String _
)
Visual C++
public:
static void Throw(
    ErrorSeverity nLevel,
    String^ nMessage
)

Parameters

nLevel
Type: Perforce.P4..::..ErrorSeverity
Severity level
nMessage
Type: System..::..String
Error message

See Also

P4Exception Class
Throw Overload


Throw Method (String, String[], P4ClientError)

[image]

Perforce .NET API
P4Exception..::..Throw Method (String, array<String>[]()[][], P4ClientError)
P4Exception Class See Also Send Feedback
Create and throw an exception if it exceeds the MinThrowLevel

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void Throw(
    string cmd,
    string[] args,
    P4ClientError error
)
Visual Basic
Public Shared Sub Throw ( _
    cmd As String, _
    args As String(), _
    error As P4ClientError _
)
Visual C++
public:
static void Throw(
    String^ cmd,
    array<String^>^ args,
    P4ClientError^ error
)

Parameters

cmd
Type: System..::..String
args
Type: array< System..::..String >[]()[][]
error
Type: Perforce.P4..::..P4ClientError
Client error causing the exception

See Also

P4Exception Class
Throw Overload


Throw Method (String, String[], ErrorSeverity, String)

[image]

Perforce .NET API
P4Exception..::..Throw Method (String, array<String>[]()[][], ErrorSeverity, String)
P4Exception Class See Also Send Feedback
Create and throw an exception if it exceeds the MinThrowLevel

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void Throw(
    string cmd,
    string[] args,
    ErrorSeverity nLevel,
    string nMessage
)
Visual Basic
Public Shared Sub Throw ( _
    cmd As String, _
    args As String(), _
    nLevel As ErrorSeverity, _
    nMessage As String _
)
Visual C++
public:
static void Throw(
    String^ cmd,
    array<String^>^ args,
    ErrorSeverity nLevel,
    String^ nMessage
)

Parameters

cmd
Type: System..::..String
args
Type: array< System..::..String >[]()[][]
nLevel
Type: Perforce.P4..::..ErrorSeverity
Severity level
nMessage
Type: System..::..String
Error message

See Also

P4Exception Class
Throw Overload


P4Exception Properties

[image] [image]

Perforce .NET API
P4Exception Properties
P4Exception Class See Also Send Feedback

The P4Exception type exposes the following members.

Properties

 | Name | Description
Public property | CmdLine | Error message
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message
Public property | ErrorCode | Error number from the C++ API
Public property | ErrorLevel | Severity of the error
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Overrides Exception..::..Message.)
 | MinThrowLevel | Minimum error to cause an exception to be thrown
Public property | NextError | If more than one error was returned by a command, the next error in the list.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4Exception Class


CmdLine Property

[image]

Perforce .NET API
P4Exception..::..CmdLine Property
P4Exception Class See Also Send Feedback
Error message

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string CmdLine { get; }
Visual Basic
Public ReadOnly Property CmdLine As String
    Get
Visual C++
public:
property String^ CmdLine {
    String^ get ();
}

See Also

P4Exception Class


Details Property

[image]

Perforce .NET API
P4Exception..::..Details Property
P4Exception Class See Also Send Feedback
Error message

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessageList Details { get; }
Visual Basic
Public ReadOnly Property Details As P4ClientInfoMessageList
    Get
Visual C++
public:
property P4ClientInfoMessageList^ Details {
    P4ClientInfoMessageList^ get ();
}

See Also

P4Exception Class


ErrorCode Property

[image]

Perforce .NET API
P4Exception..::..ErrorCode Property
P4Exception Class See Also Send Feedback
Error number from the C++ API

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ErrorCode { get; }
Visual Basic
Public ReadOnly Property ErrorCode As Integer
    Get
Visual C++
public:
property int ErrorCode {
    int get ();
}

See Also

P4Exception Class


ErrorLevel Property

[image]

Perforce .NET API
P4Exception..::..ErrorLevel Property
P4Exception Class See Also Send Feedback
Severity of the error

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ErrorSeverity ErrorLevel { get; }
Visual Basic
Public ReadOnly Property ErrorLevel As ErrorSeverity
    Get
Visual C++
public:
property ErrorSeverity ErrorLevel {
    ErrorSeverity get ();
}

See Also

P4Exception Class


Message Property

[image]

Perforce .NET API
P4Exception..::..Message Property
P4Exception Class See Also Send Feedback
Error message

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

See Also

P4Exception Class


MinThrowLevel Property

[image]

Perforce .NET API
P4Exception..::..MinThrowLevel Property
P4Exception Class See Also Send Feedback
Minimum error to cause an exception to be thrown

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static ErrorSeverity MinThrowLevel { get; set; }
Visual Basic
Public Shared Property MinThrowLevel As ErrorSeverity
    Get
    Set
Visual C++
public:
static property ErrorSeverity MinThrowLevel {
    ErrorSeverity get ();
    void set (ErrorSeverity value);
}

See Also

P4Exception Class


NextError Property

[image]

Perforce .NET API
P4Exception..::..NextError Property
P4Exception Class See Also Send Feedback
If more than one error was returned by a command, the next error in the list.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Exception NextError { get; }
Visual Basic
Public ReadOnly Property NextError As P4Exception
    Get
Visual C++
public:
property P4Exception^ NextError {
    P4Exception^ get ();
}

See Also

P4Exception Class


P4Exception Events

[image] [image]

Perforce .NET API
P4Exception Events
P4Exception Class See Also Send Feedback

The P4Exception type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4Exception Class


P4HungCommandCancelException Class

[image]

Perforce .NET API
P4HungCommandCancelException Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4HungCommandCancelException : P4Exception
Visual Basic
Public Class P4HungCommandCancelException _
    Inherits P4Exception
Visual C++
public ref class P4HungCommandCancelException : public P4Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Perforce.P4..::..P4Exception
Perforce.P4..::..P4HungCommandCancelException

See Also

P4HungCommandCancelException Members


P4HungCommandCancelException Members

[image] [image]

Perforce .NET API
P4HungCommandCancelException Members
P4HungCommandCancelException Class Constructors Methods Properties Events See Also Send Feedback

The P4HungCommandCancelException type exposes the following members.

Constructors

 | Name | Description
Public method | P4HungCommandCancelException | Initializes a new instance of the P4HungCommandCancelException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4HungCommandCancelException Class


P4HungCommandCancelException Constructor

[image]

Perforce .NET API
P4HungCommandCancelException Constructor
P4HungCommandCancelException Class See Also Send Feedback
Initializes a new instance of the P4HungCommandCancelException class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4HungCommandCancelException(
    string nMessage
)
Visual Basic
Public Sub New ( _
    nMessage As String _
)
Visual C++
public:
P4HungCommandCancelException(
    String^ nMessage
)

Parameters

nMessage
Type: System..::..String

See Also

P4HungCommandCancelException Class


P4HungCommandCancelException Methods

[image] [image]

Perforce .NET API
P4HungCommandCancelException Methods
P4HungCommandCancelException Class See Also Send Feedback

The P4HungCommandCancelException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

P4HungCommandCancelException Class


P4HungCommandCancelException Properties

[image] [image]

Perforce .NET API
P4HungCommandCancelException Properties
P4HungCommandCancelException Class See Also Send Feedback

The P4HungCommandCancelException type exposes the following members.

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4HungCommandCancelException Class


P4HungCommandCancelException Events

[image] [image]

Perforce .NET API
P4HungCommandCancelException Events
P4HungCommandCancelException Class See Also Send Feedback

The P4HungCommandCancelException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4HungCommandCancelException Class


P4LostConnectionException Class

[image]

Perforce .NET API
P4LostConnectionException Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4LostConnectionException : P4Exception
Visual Basic
Public Class P4LostConnectionException _
    Inherits P4Exception
Visual C++
public ref class P4LostConnectionException : public P4Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Perforce.P4..::..P4Exception
Perforce.P4..::..P4LostConnectionException

See Also

P4LostConnectionException Members


P4LostConnectionException Members

[image] [image]

Perforce .NET API
P4LostConnectionException Members
P4LostConnectionException Class Constructors Methods Properties Events See Also Send Feedback

The P4LostConnectionException type exposes the following members.

Constructors

 | Name | Description
Public method | P4LostConnectionException | Initializes a new instance of the P4LostConnectionException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4LostConnectionException Class


P4LostConnectionException Constructor

[image]

Perforce .NET API
P4LostConnectionException Constructor
P4LostConnectionException Class See Also Send Feedback
Initializes a new instance of the P4LostConnectionException class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4LostConnectionException(
    ErrorSeverity nLevel,
    string nMessage
)
Visual Basic
Public Sub New ( _
    nLevel As ErrorSeverity, _
    nMessage As String _
)
Visual C++
public:
P4LostConnectionException(
    ErrorSeverity nLevel,
    String^ nMessage
)

Parameters

nLevel
Type: Perforce.P4..::..ErrorSeverity
nMessage
Type: System..::..String

See Also

P4LostConnectionException Class


P4LostConnectionException Methods

[image] [image]

Perforce .NET API
P4LostConnectionException Methods
P4LostConnectionException Class See Also Send Feedback

The P4LostConnectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

P4LostConnectionException Class


P4LostConnectionException Properties

[image] [image]

Perforce .NET API
P4LostConnectionException Properties
P4LostConnectionException Class See Also Send Feedback

The P4LostConnectionException type exposes the following members.

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4LostConnectionException Class


P4LostConnectionException Events

[image] [image]

Perforce .NET API
P4LostConnectionException Events
P4LostConnectionException Class See Also Send Feedback

The P4LostConnectionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4LostConnectionException Class


P4MapApi Class

[image]

Perforce .NET API
P4MapApi Class
Members See Also Send Feedback
P4MapApi: .NET wrapper for the MapApi object in the p4api dll.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4MapApi : IDisposable
Visual Basic
Public Class P4MapApi _
    Implements IDisposable
Visual C++
public ref class P4MapApi : IDisposable

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4MapApi

See Also

P4MapApi Members


P4MapApi Members

[image] [image]

Perforce .NET API
P4MapApi Members
P4MapApi Class Constructors Methods Properties See Also Send Feedback

The P4MapApi type exposes the following members.

Constructors

 | Name | Description
Public method | P4MapApi(Boolean) | Create a new P4MapApi
Public method | P4MapApi(P4Server) | Create a new P4MapApi

Methods

 | Name | Description
Public method | Clear | Clear all the data in the map
Public method | Dispose | Free the wrapped native object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Delete the P4MapApi object and free the native object from the dll. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeft | Return the left side of the specified entry in the map
Public method | GetRight | Return the right side of the specified entry in the map
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(Int32) | Return the type of the specified entry in the map
Public method | Insert(String, P4MapApi..::..Type) | Adds a new entry in the map
Public method | Insert(String, String, P4MapApi..::..Type) | Adds a new entry in the map
 | Join(P4MapApi, P4MapApi) | Combine two MapApis to create a new MapApi
 | Join(P4MapApi, P4MapApi..::..Direction, P4MapApi, P4MapApi..::..Direction) | Combine two MapApis to create a new MapApi
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translate a file path from on side of the mapping to the other

Properties

 | Name | Description
Public property | Count | The number of entries in the map

See Also

P4MapApi Class


P4MapApi Constructor

[image] [image]

Perforce .NET API
P4MapApi Constructor
P4MapApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4MapApi(Boolean) | Create a new P4MapApi
Public method | P4MapApi(P4Server) | Create a new P4MapApi

See Also

P4MapApi Class
P4MapApi Members


P4MapApi Constructor (Boolean)

[image]

Perforce .NET API
P4MapApi Constructor (Boolean)
P4MapApi Class See Also Send Feedback
Create a new P4MapApi

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4MapApi(
    bool useUnicode
)
Visual Basic
Public Sub New ( _
    useUnicode As Boolean _
)
Visual C++
public:
P4MapApi(
    bool useUnicode
)

Parameters

useUnicode
Type: System..::..Boolean

Remarks

The server is needed to know whether or not it is necessary to translate strings to/from Unicode

See Also

P4MapApi Class
P4MapApi Overload


P4MapApi Constructor (P4Server)

[image]

Perforce .NET API
P4MapApi Constructor (P4Server)
P4MapApi Class See Also Send Feedback
Create a new P4MapApi

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4MapApi(
    P4Server pserver
)
Visual Basic
Public Sub New ( _
    pserver As P4Server _
)
Visual C++
public:
P4MapApi(
    P4Server^ pserver
)

Parameters

pserver
Type: Perforce.P4..::..P4Server
The P4Server on which the map will be used

Remarks

The server is needed to know whether or not it is necessary to translate strings to/from Unicode

See Also

P4MapApi Class
P4MapApi Overload


P4MapApi Methods

[image] [image]

Perforce .NET API
P4MapApi Methods
P4MapApi Class See Also Send Feedback

The P4MapApi type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clear all the data in the map
Public method | Dispose | Free the wrapped native object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Delete the P4MapApi object and free the native object from the dll. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeft | Return the left side of the specified entry in the map
Public method | GetRight | Return the right side of the specified entry in the map
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(Int32) | Return the type of the specified entry in the map
Public method | Insert(String, P4MapApi..::..Type) | Adds a new entry in the map
Public method | Insert(String, String, P4MapApi..::..Type) | Adds a new entry in the map
 | Join(P4MapApi, P4MapApi) | Combine two MapApis to create a new MapApi
 | Join(P4MapApi, P4MapApi..::..Direction, P4MapApi, P4MapApi..::..Direction) | Combine two MapApis to create a new MapApi
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Translate | Translate a file path from on side of the mapping to the other

See Also

P4MapApi Class


Clear Method

[image]

Perforce .NET API
P4MapApi..::..Clear Method
P4MapApi Class See Also Send Feedback
Clear all the data in the map

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

P4MapApi Class


Dispose Method

[image]

Perforce .NET API
P4MapApi..::..Dispose Method
P4MapApi Class See Also Send Feedback
Free the wrapped native object

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

P4MapApi Class


Finalize Method

[image]

Perforce .NET API
P4MapApi..::..Finalize Method
P4MapApi Class See Also Send Feedback
Delete the P4MapApi object and free the native object from the dll.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

P4MapApi Class


GetLeft Method

[image]

Perforce .NET API
P4MapApi..::..GetLeft Method
P4MapApi Class See Also Send Feedback
Return the left side of the specified entry in the map

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetLeft(
    int idx
)
Visual Basic
Public Function GetLeft ( _
    idx As Integer _
) As String
Visual C++
public:
String^ GetLeft(
    int idx
)

Parameters

idx
Type: System..::..Int32
Index of the desired entry

Return Value

String representing the left side of the entry

See Also

P4MapApi Class


GetRight Method

[image]

Perforce .NET API
P4MapApi..::..GetRight Method
P4MapApi Class See Also Send Feedback
Return the right side of the specified entry in the map

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetRight(
    int idx
)
Visual Basic
Public Function GetRight ( _
    idx As Integer _
) As String
Visual C++
public:
String^ GetRight(
    int idx
)

Parameters

idx
Type: System..::..Int32
Index of the desired entry

Return Value

String representing the right side of the entry

See Also

P4MapApi Class


GetType Method

[image] [image]

Perforce .NET API
P4MapApi..::..GetType Method
P4MapApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetType(Int32) | Return the type of the specified entry in the map

See Also

P4MapApi Class
P4MapApi Members


GetType Method (Int32)

[image]

Perforce .NET API
P4MapApi..::..GetType Method (Int32)
P4MapApi Class See Also Send Feedback
Return the type of the specified entry in the map

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4MapApi..::..Type GetType(
    int idx
)
Visual Basic
Public Function GetType ( _
    idx As Integer _
) As P4MapApi..::..Type
Visual C++
public:
P4MapApi..::..Type GetType(
    int idx
)

Parameters

idx
Type: System..::..Int32
Index of the desired entry

Return Value

The P4MapApi.Type enumeration for the type of the entry

See Also

P4MapApi Class
GetType Overload


Insert Method

[image] [image]

Perforce .NET API
P4MapApi..::..Insert Method
P4MapApi Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(String, P4MapApi..::..Type) | Adds a new entry in the map
Public method | Insert(String, String, P4MapApi..::..Type) | Adds a new entry in the map

See Also

P4MapApi Class
P4MapApi Members


Insert Method (String, P4MapApi.Type)

[image]

Perforce .NET API
P4MapApi..::..Insert Method (String, P4MapApi..::..Type)
P4MapApi Class See Also Send Feedback
Adds a new entry in the map

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Insert(
    string lr,
    P4MapApi..::..Type t
)
Visual Basic
Public Sub Insert ( _
    lr As String, _
    t As P4MapApi..::..Type _
)
Visual C++
public:
void Insert(
    String^ lr,
    P4MapApi..::..Type t
)

Parameters

lr
Type: System..::..String
String representing both the the left and right sides of the new entry
t
Type: Perforce.P4..::..P4MapApi..::..Type
Type of the new entry

See Also

P4MapApi Class
Insert Overload


Insert Method (String, String, P4MapApi.Type)

[image]

Perforce .NET API
P4MapApi..::..Insert Method (String, String, P4MapApi..::..Type)
P4MapApi Class See Also Send Feedback
Adds a new entry in the map

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Insert(
    string left,
    string right,
    P4MapApi..::..Type type
)
Visual Basic
Public Sub Insert ( _
    left As String, _
    right As String, _
    type As P4MapApi..::..Type _
)
Visual C++
public:
void Insert(
    String^ left,
    String^ right,
    P4MapApi..::..Type type
)

Parameters

left
Type: System..::..String
String representing the the left side of the new entry
right
Type: System..::..String
String representing the the right side of the new entry
type
Type: Perforce.P4..::..P4MapApi..::..Type
Type of the new entry

See Also

P4MapApi Class
Insert Overload


Join Method

[image] [image]

Perforce .NET API
P4MapApi..::..Join Method
P4MapApi Class See Also Send Feedback

Overload List

Name | Description
Join(P4MapApi, P4MapApi) | Combine two MapApis to create a new MapApi
Join(P4MapApi, P4MapApi..::..Direction, P4MapApi, P4MapApi..::..Direction) | Combine two MapApis to create a new MapApi

See Also

P4MapApi Class
P4MapApi Members


Join Method (P4MapApi, P4MapApi)

[image]

Perforce .NET API
P4MapApi..::..Join Method (P4MapApi, P4MapApi)
P4MapApi Class See Also Send Feedback
Combine two MapApis to create a new MapApi

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static P4MapApi Join(
    P4MapApi left,
    P4MapApi right
)
Visual Basic
Public Shared Function Join ( _
    left As P4MapApi, _
    right As P4MapApi _
) As P4MapApi
Visual C++
public:
static P4MapApi^ Join(
    P4MapApi^ left,
    P4MapApi^ right
)

Parameters

left
Type: Perforce.P4..::..P4MapApi
Pointer to the first map
right
Type: Perforce.P4..::..P4MapApi
Pointer to the second map

Return Value

See Also

P4MapApi Class
Join Overload


Join Method (P4MapApi, P4MapApi.Direction, P4MapApi, P4MapApi.Direction)

[image]

Perforce .NET API
P4MapApi..::..Join Method (P4MapApi, P4MapApi..::..Direction, P4MapApi, P4MapApi..::..Direction)
P4MapApi Class See Also Send Feedback
Combine two MapApis to create a new MapApi

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static P4MapApi Join(
    P4MapApi left,
    P4MapApi..::..Direction leftDir,
    P4MapApi right,
    P4MapApi..::..Direction rightDir
)
Visual Basic
Public Shared Function Join ( _
    left As P4MapApi, _
    leftDir As P4MapApi..::..Direction, _
    right As P4MapApi, _
    rightDir As P4MapApi..::..Direction _
) As P4MapApi
Visual C++
public:
static P4MapApi^ Join(
    P4MapApi^ left,
    P4MapApi..::..Direction leftDir,
    P4MapApi^ right,
    P4MapApi..::..Direction rightDir
)

Parameters

left
Type: Perforce.P4..::..P4MapApi
Pointer to the first map
leftDir
Type: Perforce.P4..::..P4MapApi..::..Direction
Orientation of the first map
right
Type: Perforce.P4..::..P4MapApi
Pointer to the second map
rightDir
Type: Perforce.P4..::..P4MapApi..::..Direction
Orientation of the second map

Return Value

See Also

P4MapApi Class
Join Overload


Translate Method

[image]

Perforce .NET API
P4MapApi..::..Translate Method
P4MapApi Class See Also Send Feedback
Translate a file path from on side of the mapping to the other

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Translate(
    string path,
    P4MapApi..::..Direction direction
)
Visual Basic
Public Function Translate ( _
    path As String, _
    direction As P4MapApi..::..Direction _
) As String
Visual C++
public:
String^ Translate(
    String^ path,
    P4MapApi..::..Direction direction
)

Parameters

path
Type: System..::..String
The path to translate
direction
Type: Perforce.P4..::..P4MapApi..::..Direction
The direction to perform the translation L->R or R->L

Return Value

Translated path, Null if no translation (path is not mapped)

See Also

P4MapApi Class


P4MapApi Properties

[image] [image]

Perforce .NET API
P4MapApi Properties
P4MapApi Class See Also Send Feedback

The P4MapApi type exposes the following members.

Properties

 | Name | Description
Public property | Count | The number of entries in the map

See Also

P4MapApi Class


Count Property

[image]

Perforce .NET API
P4MapApi..::..Count Property
P4MapApi Class See Also Send Feedback
The number of entries in the map

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

P4MapApi Class


P4MapApi.Direction Enumeration

[image]

Perforce .NET API
P4MapApi..::..Direction Enumeration
P4MapApi Class See Also Send Feedback
Specify the direction to perform the mapping.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum Direction
Visual Basic
<FlagsAttribute> _
Public Enumeration Direction
Visual C++
[FlagsAttribute]
public enum class Direction

Members

Member name | Value | Description
LeftRight | 0 | Map from left to right
RightLeft | 1 | Map from right to left

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4MapApi.Type Enumeration

[image]

Perforce .NET API
P4MapApi..::..Type Enumeration
P4MapApi Class See Also Send Feedback
Type of the map entry, Include, Exclude, Overlay.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum Type
Visual Basic
<FlagsAttribute> _
Public Enumeration Type
Visual C++
[FlagsAttribute]
public enum class Type

Members

Member name | Value | Description
Include | 0 | Include the indicated mapping
Exclude | 1 | Exclude the indicated mapping
Overlay | 2 | Overlay the indicated mapping

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server Class

[image]

Perforce .NET API
P4Server Class
Members See Also Send Feedback
P4Server Represents the connection to a Perforce Server using the the P4 Bridge DLL. It wraps the calls exported by the DLL and transforms the data types exported by the DLL as native C#.NET data types.
P4Server Represents the connection to a Perforce Server using the the P4 Bridge DLL. It wraps the calls exported by the DLL and transforms the data types exported by the DLL as native C#.NET data types.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4Server : IDisposable
Visual Basic
Public Class P4Server _
    Implements IDisposable
Visual C++
public ref class P4Server : IDisposable

Remarks

This file contains the internal data a methods that are not part of the public interface

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4Server

See Also

P4Server Members


P4Server Members

[image] [image]

Perforce .NET API
P4Server Members
P4Server Class Constructors Methods Fields Properties Events See Also Send Feedback

The P4Server type exposes the following members.

Constructors

 | Name | Description
Public method | P4Server(String) | Create a P4BridgeServer using the PUC specified by the environment or a p4config file if one exists.
Public method | P4Server(String, String, String, String) | Create a P4BridgeServer used to connect to the specified P4Server
Public method | P4Server(String, String, String, String, String, String, String) | Create a P4BridgeServer used to connect to the specified P4Server

Methods

 | Name | Description
Public method | CancelCommand | Cancel a running command
Public method | Close | Close the connection to a P4 Server
Public method | ContinueRunCmdTimer |
Public method | Disconnect |
Public method | Dispose()()()() | For IDispose
Public method | Dispose(Boolean) | Releases the unmanaged resources used by the P4Server and optionally releases the managed resources
Public method | EchoCommand(String) | Broadcast a string on the CommandEcho event
Public method | EchoCommand(String, StringList) | Broadcast a the command line (cmd and args) on the CommandEcho event
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalizer (Overrides Object..::..Finalize()()()().)
Public method | FreeConnections | Free the UI created for a command after it is no longer needed
 | Get | Get an environment setting used by the server, such as user, client, ..
Public method | GetBinaryResults | Get the complete binary results for the last command
Public method | getCmdId |
 | GetConfig | The config file that will be used by a given directory
Public method | GetDataSet |
Public method | GetErrorResults | Get a list of errors (if any) generated by a command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInfoResults | Get the information messages generated by the previous command
Public method | GetTaggedOutput | Get the tagged output generated by a command
Public method | GetTextResults | Get the complete text results for the last command
 | GetTicket | Use the C++ API to find an existing ticket if a file will be ignored
 | GetTicketFile | Use the C++ API to determine the path of the ticket file
 | GetTicketFileCredential | Use the C++ API to find an existing ticket if a file will be ignored
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCommandPaused |
 | IsIgnored | Use the C++ API to determine if a file will be ignored
Public method | Login | Run a login command on the server
Public method | Logout | Run a logout command on the server
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PauseRunCmdTimer |
Public method | Reconnect | Reconnect to the server in the event the connection is lost
Public method | ReleaseConnection | Release the UI created for a command after it has been completed
Public method | RunCommand | Run a P4 command on the P4 Server
 | Set | Set an environment setting used by the server, such as user, client, ..
Public method | SetConnectionData | The parameters used by the connection
Public method | SetDataSet | The data set for use by a command
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | IdleDisconnectWaitTime |
Public field | KeepAliveDelay | Time for a command to run before allowing the client/user to cancel;
Public field | PromptHandler | Delegate used to process prompts for input from the server.
Public field | ResolveAHandler | Delegate used to provide a custom handler for Resolve callbacks passing a ClientResolve object from the p4api.
Public field | ResolveHandler | Delegate used to provide a custom handler for Resolve callbacks passing a ClientMerge object from the p4api.
Public field | RunCmdTimeout |

Properties

 | Name | Description
Public property | ApiLevel | What API level does the server support
Public property | CharacterSet | The character set used by the connection
Public property | Client | The client workspace used by the connection
Public property | Config | The config file used by the connection
Public property | ConnectionError | Get the error message generated by the previous connection (if any) from the bridge dll.
 | ConnectionErrorInt | Get the error message generated by the previous connection (if any)
Public property | CurrentWorkingDirectory | The current working directory (cwd) used by the p4 server
Public property | KeepAlive |
Public property | LastResults | The results of the last command executed on this thread
Public property | Password | The user's password used by the connection
Public property | Port | The hostname:port used by the connection
Public property | ProgramName | The program name used by the connection
Public property | ProgramVersion | The program version used by the connection
Public property | ReqiresLogin | The server requires a client to use the login command to pass credentials.
Public property | RunCmdTimout | Obsolete.
Public property | User | The user name used by the connection
Public property | UseUnicode | Need to use Unicode when marshalling to/from the P4 server
 | Version | Get the version of the p4.net assembly

Events

 | Name | Description
Public event | BinaryResultsReceived | Broadcast event for binary data
Public event | CommandEcho | Broadcast event for text results
Public event | ErrorReceived | Broadcast errors received
Public event | InfoResultsReceived | Broadcast event for info results
Public event | TaggedOutputReceived | Event to broadcast tagged output
Public event | TextResultsReceived | Broadcast event for text results

See Also

P4Server Class


P4Server Constructor

[image] [image]

Perforce .NET API
P4Server Constructor
P4Server Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4Server(String) | Create a P4BridgeServer using the PUC specified by the environment or a p4config file if one exists.
Public method | P4Server(String, String, String, String) | Create a P4BridgeServer used to connect to the specified P4Server
Public method | P4Server(String, String, String, String, String, String, String) | Create a P4BridgeServer used to connect to the specified P4Server

See Also

P4Server Class
P4Server Members


P4Server Constructor (String)

[image]

Perforce .NET API
P4Server Constructor (String)
P4Server Class See Also Send Feedback
Create a P4BridgeServer using the PUC specified by the environment or a p4config file if one exists.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server(
    string cwd
)
Visual Basic
Public Sub New ( _
    cwd As String _
)
Visual C++
public:
P4Server(
    String^ cwd
)

Parameters

cwd
Type: System..::..String
Current working Directory. Can be null/blank if not connecting to the Perforce server using a P4Config file.

See Also

P4Server Class
P4Server Overload


P4Server Constructor (String, String, String, String)

[image]

Perforce .NET API
P4Server Constructor (String, String, String, String)
P4Server Class See Also Send Feedback
Create a P4BridgeServer used to connect to the specified P4Server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server(
    string server,
    string user,
    string pass,
    string ws_client
)
Visual Basic
Public Sub New ( _
    server As String, _
    user As String, _
    pass As String, _
    ws_client As String _
)
Visual C++
public:
P4Server(
    String^ server,
    String^ user,
    String^ pass,
    String^ ws_client
)

Parameters

server
Type: System..::..String
Host:port for the P4 server.
user
Type: System..::..String
User name for the login. Can be null/blank if only running commands that do not require a login.
pass
Type: System..::..String
Password for the login. Can be null/blank if only running commands that do not require a login.
ws_client
Type: System..::..String
Workspace (client) to be used by the connection. Can be null/blank if only running commands that do not require a login.

See Also

P4Server Class
P4Server Overload


P4Server Constructor (String, String, String, String, String, String, String)

[image]

Perforce .NET API
P4Server Constructor (String, String, String, String, String, String, String)
P4Server Class See Also Send Feedback
Create a P4BridgeServer used to connect to the specified P4Server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server(
    string server,
    string user,
    string pass,
    string ws_client,
    string cwd,
    string trust_flag,
    string fingerprint
)
Visual Basic
Public Sub New ( _
    server As String, _
    user As String, _
    pass As String, _
    ws_client As String, _
    cwd As String, _
    trust_flag As String, _
    fingerprint As String _
)
Visual C++
public:
P4Server(
    String^ server,
    String^ user,
    String^ pass,
    String^ ws_client,
    String^ cwd,
    String^ trust_flag,
    String^ fingerprint
)

Parameters

server
Type: System..::..String
Host:port for the P4 server.
user
Type: System..::..String
User name for the login. Can be null/blank if only running commands that do not require a login.
pass
Type: System..::..String
Password for the login. Can be null/blank if only running commands that do not require a login.
ws_client
Type: System..::..String
Workspace (client) to be used by the connection. Can be null/blank if only running commands that do not require a login.
cwd
Type: System..::..String
trust_flag
Type: System..::..String
fingerprint
Type: System..::..String

See Also

P4Server Class
P4Server Overload


P4Server Fields

[image] [image]

Perforce .NET API
P4Server Fields
P4Server Class See Also Send Feedback

The P4Server type exposes the following members.

Fields

 | Name | Description
Public field | IdleDisconnectWaitTime |
Public field | KeepAliveDelay | Time for a command to run before allowing the client/user to cancel;
Public field | PromptHandler | Delegate used to process prompts for input from the server.
Public field | ResolveAHandler | Delegate used to provide a custom handler for Resolve callbacks passing a ClientResolve object from the p4api.
Public field | ResolveHandler | Delegate used to provide a custom handler for Resolve callbacks passing a ClientMerge object from the p4api.
Public field | RunCmdTimeout |

See Also

P4Server Class


IdleDisconnectWaitTime Field

[image]

Perforce .NET API
P4Server..::..IdleDisconnectWaitTime Field
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public double IdleDisconnectWaitTime
Visual Basic
Public IdleDisconnectWaitTime As Double
Visual C++
public:
double IdleDisconnectWaitTime

See Also

P4Server Class


KeepAliveDelay Field

[image]

Perforce .NET API
P4Server..::..KeepAliveDelay Field
P4Server Class See Also Send Feedback
Time for a command to run before allowing the client/user to cancel;

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TimeSpan KeepAliveDelay
Visual Basic
Public KeepAliveDelay As TimeSpan
Visual C++
public:
TimeSpan KeepAliveDelay

See Also

P4Server Class


PromptHandler Field

[image]

Perforce .NET API
P4Server..::..PromptHandler Field
P4Server Class See Also Send Feedback
Delegate used to process prompts for input from the server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server..::..PromptHandlerDelegate PromptHandler
Visual Basic
Public PromptHandler As P4Server..::..PromptHandlerDelegate
Visual C++
public:
P4Server..::..PromptHandlerDelegate^ PromptHandler

See Also

P4Server Class


ResolveAHandler Field

[image]

Perforce .NET API
P4Server..::..ResolveAHandler Field
P4Server Class See Also Send Feedback
Delegate used to provide a custom handler for Resolve callbacks passing a ClientResolve object from the p4api.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server..::..ResolveAHandlerDelegate ResolveAHandler
Visual Basic
Public ResolveAHandler As P4Server..::..ResolveAHandlerDelegate
Visual C++
public:
P4Server..::..ResolveAHandlerDelegate^ ResolveAHandler

See Also

P4Server Class


ResolveHandler Field

[image]

Perforce .NET API
P4Server..::..ResolveHandler Field
P4Server Class See Also Send Feedback
Delegate used to provide a custom handler for Resolve callbacks passing a ClientMerge object from the p4api.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4Server..::..ResolveHandlerDelegate ResolveHandler
Visual Basic
Public ResolveHandler As P4Server..::..ResolveHandlerDelegate
Visual C++
public:
P4Server..::..ResolveHandlerDelegate^ ResolveHandler

See Also

P4Server Class


RunCmdTimeout Field

[image]

Perforce .NET API
P4Server..::..RunCmdTimeout Field
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TimeSpan RunCmdTimeout
Visual Basic
Public RunCmdTimeout As TimeSpan
Visual C++
public:
TimeSpan RunCmdTimeout

See Also

P4Server Class


P4Server Methods

[image] [image]

Perforce .NET API
P4Server Methods
P4Server Class See Also Send Feedback

The P4Server type exposes the following members.

Methods

 | Name | Description
Public method | CancelCommand | Cancel a running command
Public method | Close | Close the connection to a P4 Server
Public method | ContinueRunCmdTimer |
Public method | Disconnect |
Public method | Dispose()()()() | For IDispose
Public method | Dispose(Boolean) |
Public method | EchoCommand(String) | Broadcast a string on the CommandEcho event
Public method | EchoCommand(String, StringList) | Broadcast a the command line (cmd and args) on the CommandEcho event
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Finalizer (Overrides Object..::..Finalize()()()().)
Public method | FreeConnections | Free the UI created for a command after it is no longer needed
 | Get | Get an environment setting used by the server, such as user, client, ..
Public method | GetBinaryResults | Get the complete binary results for the last command
Public method | getCmdId |
 | GetConfig | The config file that will be used by a given directory
Public method | GetDataSet |
Public method | GetErrorResults | Get a list of errors (if any) generated by a command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInfoResults | Get the information messages generated by the previous command
Public method | GetTaggedOutput | Get the tagged output generated by a command
Public method | GetTextResults | Get the complete text results for the last command
 | GetTicket | Use the C++ API to find an existing ticket if a file will be ignored
 | GetTicketFile | Use the C++ API to determine the path of the ticket file
 | GetTicketFileCredential | Use the C++ API to find an existing ticket if a file will be ignored
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCommandPaused |
 | IsIgnored | Use the C++ API to determine if a file will be ignored
Public method | Login | Run a login command on the server
Public method | Logout | Run a logout command on the server
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PauseRunCmdTimer |
Public method | Reconnect | Reconnect to the server in the event the connection is lost
Public method | ReleaseConnection | Release the UI created for a command after it has been completed
Public method | RunCommand | Run a P4 command on the P4 Server
 | Set | Set an environment setting used by the server, such as user, client, ..
Public method | SetConnectionData | The parameters used by the connection
Public method | SetDataSet | The data set for use by a command
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4Server Class


CancelCommand Method

[image]

Perforce .NET API
P4Server..::..CancelCommand Method
P4Server Class See Also Send Feedback
Cancel a running command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void CancelCommand(
    uint CmdId
)
Visual Basic
Public Sub CancelCommand ( _
    CmdId As UInteger _
)
Visual C++
public:
void CancelCommand(
    unsigned int CmdId
)

Parameters

CmdId
Type: System..::..UInt32
Unique Id for the run of the command

See Also

P4Server Class


Close Method

[image]

Perforce .NET API
P4Server..::..Close Method
P4Server Class See Also Send Feedback
Close the connection to a P4 Server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

Remarks

Called by the Dispose() method

See Also

P4Server Class


ContinueRunCmdTimer Method

[image]

Perforce .NET API
P4Server..::..ContinueRunCmdTimer Method
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void ContinueRunCmdTimer(
    uint cmdId
)
Visual Basic
Public Sub ContinueRunCmdTimer ( _
    cmdId As UInteger _
)
Visual C++
public:
void ContinueRunCmdTimer(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

See Also

P4Server Class


Disconnect Method

[image]

Perforce .NET API
P4Server..::..Disconnect Method
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect
Visual C++
public:
void Disconnect()

See Also

P4Server Class


Dispose Method

[image] [image]

Perforce .NET API
P4Server..::..Dispose Method
P4Server Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | For IDispose
Public method | Dispose(Boolean) | Releases the unmanaged resources used by the P4Server and optionally releases the managed resources

See Also

P4Server Class
P4Server Members


Dispose Method

[image]

Perforce .NET API
P4Server..::..Dispose Method
P4Server Class See Also Send Feedback
For IDispose

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

P4Server Class
Dispose Overload


Dispose Method (Boolean)

[image]

Perforce .NET API
P4Server..::..Dispose Method (Boolean)
P4Server Class See Also Send Feedback
Releases the unmanaged resources used by the P4Server and optionally releases the managed resources

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Dispose(
    bool disposing
)
Visual Basic
Public Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
public:
void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

P4Server Class
Dispose Overload


EchoCommand Method

[image] [image]

Perforce .NET API
P4Server..::..EchoCommand Method
P4Server Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EchoCommand(String) | Broadcast a string on the CommandEcho event
Public method | EchoCommand(String, StringList) | Broadcast a the command line (cmd and args) on the CommandEcho event

See Also

P4Server Class
P4Server Members


EchoCommand Method (String)

[image]

Perforce .NET API
P4Server..::..EchoCommand Method (String)
P4Server Class See Also Send Feedback
Broadcast a string on the CommandEcho event

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void EchoCommand(
    string str
)
Visual Basic
Public Sub EchoCommand ( _
    str As String _
)
Visual C++
public:
void EchoCommand(
    String^ str
)

Parameters

str
Type: System..::..String
The string.

Remarks

Used to echo command data back to the client

See Also

P4Server Class
EchoCommand Overload


EchoCommand Method (String, StringList)

[image]

Perforce .NET API
P4Server..::..EchoCommand Method (String, StringList)
P4Server Class See Also Send Feedback
Broadcast a the command line (cmd and args) on the CommandEcho event

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void EchoCommand(
    string cmd,
    StringList args
)
Visual Basic
Public Sub EchoCommand ( _
    cmd As String, _
    args As StringList _
)
Visual C++
public:
void EchoCommand(
    String^ cmd,
    StringList^ args
)

Parameters

cmd
Type: System..::..String
The P4 command.
args
Type: Perforce.P4..::..StringList
The flags and parameters for the command.

Remarks

Used to echo an executed command line back to the client

See Also

P4Server Class
EchoCommand Overload


Finalize Method

[image]

Perforce .NET API
P4Server..::..Finalize Method
P4Server Class See Also Send Feedback
Finalizer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

P4Server Class


FreeConnections Method

[image]

Perforce .NET API
P4Server..::..FreeConnections Method
P4Server Class See Also Send Feedback
Free the UI created for a command after it is no longer needed

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int FreeConnections()
Visual Basic
Public Function FreeConnections As Integer
Visual C++
public:
int FreeConnections()

See Also

P4Server Class


Get Method

[image]

Perforce .NET API
P4Server..::..Get Method
P4Server Class See Also Send Feedback
Get an environment setting used by the server, such as user, client, ..

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string Get(
    string var
)
Visual Basic
Public Shared Function Get ( _
    var As String _
) As String
Visual C++
public:
static String^ Get(
    String^ var
)

Parameters

var
Type: System..::..String
The name of the environment varible

Return Value

See Also

P4Server Class


GetBinaryResults Method

[image]

Perforce .NET API
P4Server..::..GetBinaryResults Method
P4Server Class See Also Send Feedback
Get the complete binary results for the last command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public byte[] GetBinaryResults(
    uint cmdId
)
Visual Basic
Public Function GetBinaryResults ( _
    cmdId As UInteger _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetBinaryResults(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

Return Value

The binary data

See Also

P4Server Class


getCmdId Method

[image]

Perforce .NET API
P4Server..::..getCmdId Method
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public uint getCmdId()
Visual Basic
Public Function getCmdId As UInteger
Visual C++
public:
unsigned int getCmdId()

See Also

P4Server Class


GetConfig Method

[image]

Perforce .NET API
P4Server..::..GetConfig Method
P4Server Class See Also Send Feedback
The config file that will be used by a given directory

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string GetConfig(
    string cwd
)
Visual Basic
Public Shared Function GetConfig ( _
    cwd As String _
) As String
Visual C++
public:
static String^ GetConfig(
    String^ cwd
)

Parameters

cwd
Type: System..::..String

See Also

P4Server Class


GetDataSet Method

[image]

Perforce .NET API
P4Server..::..GetDataSet Method
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetDataSet(
    uint cmdId
)
Visual Basic
Public Function GetDataSet ( _
    cmdId As UInteger _
) As String
Visual C++
public:
String^ GetDataSet(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

See Also

P4Server Class


GetErrorResults Method

[image]

Perforce .NET API
P4Server..::..GetErrorResults Method
P4Server Class See Also Send Feedback
Get a list of errors (if any) generated by a command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientErrorList GetErrorResults(
    uint cmdId
)
Visual Basic
Public Function GetErrorResults ( _
    cmdId As UInteger _
) As P4ClientErrorList
Visual C++
public:
P4ClientErrorList^ GetErrorResults(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

Return Value

A list of P4ClientErrors, null if no errors

See Also

P4Server Class


GetInfoResults Method

[image]

Perforce .NET API
P4Server..::..GetInfoResults Method
P4Server Class See Also Send Feedback
Get the information messages generated by the previous command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientInfoMessageList GetInfoResults(
    uint cmdId
)
Visual Basic
Public Function GetInfoResults ( _
    cmdId As UInteger _
) As P4ClientInfoMessageList
Visual C++
public:
P4ClientInfoMessageList^ GetInfoResults(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

Return Value

List of messages

Remarks

Each message is formatted as follows l:Message text where l is a single digit representing the message level

See Also

P4Server Class


GetTaggedOutput Method

[image]

Perforce .NET API
P4Server..::..GetTaggedOutput Method
P4Server Class See Also Send Feedback
Get the tagged output generated by a command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObjectList GetTaggedOutput(
    uint cmdId
)
Visual Basic
Public Function GetTaggedOutput ( _
    cmdId As UInteger _
) As TaggedObjectList
Visual C++
public:
TaggedObjectList^ GetTaggedOutput(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

Return Value

A list of TaggedObjects comprising the tagged output.

See Also

P4Server Class


GetTextResults Method

[image]

Perforce .NET API
P4Server..::..GetTextResults Method
P4Server Class See Also Send Feedback
Get the complete text results for the last command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetTextResults(
    uint cmdID
)
Visual Basic
Public Function GetTextResults ( _
    cmdID As UInteger _
) As String
Visual C++
public:
String^ GetTextResults(
    unsigned int cmdID
)

Parameters

cmdID
Type: System..::..UInt32

Return Value

See Also

P4Server Class


GetTicket Method

[image]

Perforce .NET API
P4Server..::..GetTicket Method
P4Server Class See Also Send Feedback
Use the C++ API to find an existing ticket if a file will be ignored

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string GetTicket(
    string port,
    string user
)
Visual Basic
Public Shared Function GetTicket ( _
    port As String, _
    user As String _
) As String
Visual C++
public:
static String^ GetTicket(
    String^ port,
    String^ user
)

Parameters

port
Type: System..::..String
server:port for the connection
user
Type: System..::..String
user name for the connection

Return Value

The existing ticket if any

See Also

P4Server Class


GetTicketFile Method

[image]

Perforce .NET API
P4Server..::..GetTicketFile Method
P4Server Class See Also Send Feedback
Use the C++ API to determine the path of the ticket file

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string GetTicketFile()
Visual Basic
Public Shared Function GetTicketFile As String
Visual C++
public:
static String^ GetTicketFile()

Return Value

The path for the ticket file

See Also

P4Server Class


GetTicketFileCredential Method

[image]

Perforce .NET API
P4Server..::..GetTicketFileCredential Method
P4Server Class See Also Send Feedback
Use the C++ API to find an existing ticket if a file will be ignored

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static Credential GetTicketFileCredential(
    string port,
    string user
)
Visual Basic
Public Shared Function GetTicketFileCredential ( _
    port As String, _
    user As String _
) As Credential
Visual C++
public:
static Credential^ GetTicketFileCredential(
    String^ port,
    String^ user
)

Parameters

port
Type: System..::..String
server:port for the connection
user
Type: System..::..String
user name for the connection

Return Value

The existing ticket if any

See Also

P4Server Class


IsCommandPaused Method

[image]

Perforce .NET API
P4Server..::..IsCommandPaused Method
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsCommandPaused(
    uint cmdId
)
Visual Basic
Public Function IsCommandPaused ( _
    cmdId As UInteger _
) As Boolean
Visual C++
public:
bool IsCommandPaused(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

See Also

P4Server Class


IsIgnored Method

[image]

Perforce .NET API
P4Server..::..IsIgnored Method
P4Server Class See Also Send Feedback
Use the C++ API to determine if a file will be ignored

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool IsIgnored(
    string path
)
Visual Basic
Public Shared Function IsIgnored ( _
    path As String _
) As Boolean
Visual C++
public:
static bool IsIgnored(
    String^ path
)

Parameters

path
Type: System..::..String
The local path of the file

Return Value

true if the file will be ignored

See Also

P4Server Class


Login Method

[image]

Perforce .NET API
P4Server..::..Login Method
P4Server Class See Also Send Feedback
Run a login command on the server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Login(
    string password,
    StringList options
)
Visual Basic
Public Function Login ( _
    password As String, _
    options As StringList _
) As Boolean
Visual C++
public:
bool Login(
    String^ password,
    StringList^ options
)

Parameters

password
Type: System..::..String
User's password
options
Type: Perforce.P4..::..StringList

Return Value

Success/Failure

Remarks

If the server requires a login (security level >= 3), this will prompt for the password. If login is not required, the command will just return with a result saying that login is not required.

See Also

P4Server Class


Logout Method

[image]

Perforce .NET API
P4Server..::..Logout Method
P4Server Class See Also Send Feedback
Run a logout command on the server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Logout(
    StringList options
)
Visual Basic
Public Function Logout ( _
    options As StringList _
) As Boolean
Visual C++
public:
bool Logout(
    StringList^ options
)

Parameters

options
Type: Perforce.P4..::..StringList
The -a flag invalidates the ticket on the server.

Return Value

Success/Failure

Remarks

If the server requires a login (security level >= 3), this will logout the user and remove the local ticket.

See Also

P4Server Class


PauseRunCmdTimer Method

[image]

Perforce .NET API
P4Server..::..PauseRunCmdTimer Method
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void PauseRunCmdTimer(
    uint cmdId
)
Visual Basic
Public Sub PauseRunCmdTimer ( _
    cmdId As UInteger _
)
Visual C++
public:
void PauseRunCmdTimer(
    unsigned int cmdId
)

Parameters

cmdId
Type: System..::..UInt32

See Also

P4Server Class


Reconnect Method

[image]

Perforce .NET API
P4Server..::..Reconnect Method
P4Server Class See Also Send Feedback
Reconnect to the server in the event the connection is lost

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Reconnect()
Visual Basic
Public Sub Reconnect
Visual C++
public:
void Reconnect()

See Also

P4Server Class


ReleaseConnection Method

[image]

Perforce .NET API
P4Server..::..ReleaseConnection Method
P4Server Class See Also Send Feedback
Release the UI created for a command after it has been completed

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void ReleaseConnection(
    uint CmdId
)
Visual Basic
Public Sub ReleaseConnection ( _
    CmdId As UInteger _
)
Visual C++
public:
void ReleaseConnection(
    unsigned int CmdId
)

Parameters

CmdId
Type: System..::..UInt32

See Also

P4Server Class


RunCommand Method

[image]

Perforce .NET API
P4Server..::..RunCommand Method
P4Server Class See Also Send Feedback
Run a P4 command on the P4 Server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool RunCommand(
    string cmd,
    uint cmdId,
    bool tagged,
    string[] args,
    int argc
)
Visual Basic
Public Function RunCommand ( _
    cmd As String, _
    cmdId As UInteger, _
    tagged As Boolean, _
    args As String(), _
    argc As Integer _
) As Boolean
Visual C++
public:
bool RunCommand(
    String^ cmd,
    unsigned int cmdId,
    bool tagged,
    array<String^>^ args,
    int argc
)

Parameters

cmd
Type: System..::..String
Command code
cmdId
Type: System..::..UInt32
tagged
Type: System..::..Boolean
Use tagged output for the results
args
Type: array< System..::..String >[]()[][]
Arguments for the command
argc
Type: System..::..Int32
Argument count

Return Value

Success/Failure

Remarks

If the command fails, the error output will contain one or more errors generated by the P4 server.

See Also

P4Server Class


Set Method

[image]

Perforce .NET API
P4Server..::..Set Method
P4Server Class See Also Send Feedback
Set an environment setting used by the server, such as user, client, ..

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static void Set(
    string var,
    string val
)
Visual Basic
Public Shared Sub Set ( _
    var As String, _
    val As String _
)
Visual C++
public:
static void Set(
    String^ var,
    String^ val
)

Parameters

var
Type: System..::..String
The name of the environment variable
val
Type: System..::..String
The new value for the environment variable

Return Value

See Also

P4Server Class


SetConnectionData Method

[image]

Perforce .NET API
P4Server..::..SetConnectionData Method
P4Server Class See Also Send Feedback
The parameters used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void SetConnectionData(
    string port,
    string user,
    string password,
    string client
)
Visual Basic
Public Sub SetConnectionData ( _
    port As String, _
    user As String, _
    password As String, _
    client As String _
)
Visual C++
public:
void SetConnectionData(
    String^ port,
    String^ user,
    String^ password,
    String^ client
)

Parameters

port
Type: System..::..String
user
Type: System..::..String
password
Type: System..::..String
client
Type: System..::..String

Remarks

The properties, client, port, user, and password, represent the criteria used to connect to a P4 server. If one or more is changed, the bridge will drop the current connection if any and attempt to connect to the (possibly different) P4 server when the next command is executed. If it is desirable to validate the connection, execute a command.

See Also

P4Server Class


SetDataSet Method

[image]

Perforce .NET API
P4Server..::..SetDataSet Method
P4Server Class See Also Send Feedback
The data set for use by a command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void SetDataSet(
    uint cmdId,
    string value
)
Visual Basic
Public Sub SetDataSet ( _
    cmdId As UInteger, _
    value As String _
)
Visual C++
public:
void SetDataSet(
    unsigned int cmdId,
    String^ value
)

Parameters

cmdId
Type: System..::..UInt32
value
Type: System..::..String

Remarks

If a command requires data not passed on the command line, such as a client spec, it is passed to the P$ server by setting the data set in the P4 api.

See Also

P4Server Class


P4Server Properties

[image] [image]

Perforce .NET API
P4Server Properties
P4Server Class See Also Send Feedback

The P4Server type exposes the following members.

Properties

 | Name | Description
Public property | ApiLevel | What API level does the server support
Public property | CharacterSet | The character set used by the connection
Public property | Client | The client workspace used by the connection
Public property | Config | The config file used by the connection
Public property | ConnectionError | Get the error message generated by the previous connection (if any) from the bridge dll.
 | ConnectionErrorInt | Get the error message generated by the previous connection (if any)
Public property | CurrentWorkingDirectory | The current working directory (cwd) used by the p4 server
Public property | KeepAlive |
Public property | LastResults | The results of the last command executed on this thread
Public property | Password | The user's password used by the connection
Public property | Port | The hostname:port used by the connection
Public property | ProgramName | The program name used by the connection
Public property | ProgramVersion | The program version used by the connection
Public property | ReqiresLogin | The server requires a client to use the login command to pass credentials.
Public property | RunCmdTimout | Obsolete.
Public property | User | The user name used by the connection
Public property | UseUnicode | Need to use Unicode when marshalling to/from the P4 server
 | Version | Get the version of the p4.net assembly

See Also

P4Server Class


ApiLevel Property

[image]

Perforce .NET API
P4Server..::..ApiLevel Property
P4Server Class See Also Send Feedback
What API level does the server support

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ApiLevel { get; }
Visual Basic
Public ReadOnly Property ApiLevel As Integer
    Get
Visual C++
public:
property int ApiLevel {
    int get ();
}

See Also

P4Server Class


CharacterSet Property

[image]

Perforce .NET API
P4Server..::..CharacterSet Property
P4Server Class See Also Send Feedback
The character set used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string CharacterSet { get; }
Visual Basic
Public ReadOnly Property CharacterSet As String
    Get
Visual C++
public:
property String^ CharacterSet {
    String^ get ();
}

Remarks

The character set used to connect to Unicode servers is set by the bridge dll automatically (possibly overridden by P4CHARSET) based on the current Windows code page.

See Also

P4Server Class


Client Property

[image]

Perforce .NET API
P4Server..::..Client Property
P4Server Class See Also Send Feedback
The client workspace used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Client { get; set; }
Visual Basic
Public Property Client As String
    Get
    Set
Visual C++
public:
property String^ Client {
    String^ get ();
    void set (String^ value);
}

Remarks

The properties, client, port, user, and password, represent the criteria used to connect to a P4 server. If one or more is changed, the bridge will drop the current connection if any and attempt to connect to the (possibly different) P4 server when the next command is executed. If it is desirable to validate the connection, execute a command.

See Also

P4Server Class


Config Property

[image]

Perforce .NET API
P4Server..::..Config Property
P4Server Class See Also Send Feedback
The config file used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Config { get; }
Visual Basic
Public ReadOnly Property Config As String
    Get
Visual C++
public:
property String^ Config {
    String^ get ();
}

See Also

P4Server Class


ConnectionError Property

[image]

Perforce .NET API
P4Server..::..ConnectionError Property
P4Server Class See Also Send Feedback
Get the error message generated by the previous connection (if any) from the bridge dll.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientError ConnectionError { get; private set; }
Visual Basic
Public Property ConnectionError As P4ClientError
    Get
    Private Set
Visual C++
public:
property P4ClientError^ ConnectionError {
    P4ClientError^ get ();
    private: void set (P4ClientError^ value);
}

See Also

P4Server Class


ConnectionErrorInt Property

[image]

Perforce .NET API
P4Server..::..ConnectionErrorInt Property
P4Server Class See Also Send Feedback
Get the error message generated by the previous connection (if any)

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static P4ClientError ConnectionErrorInt { get; }
Visual Basic
Public Shared ReadOnly Property ConnectionErrorInt As P4ClientError
    Get
Visual C++
public:
static property P4ClientError^ ConnectionErrorInt {
    P4ClientError^ get ();
}

See Also

P4Server Class


CurrentWorkingDirectory Property

[image]

Perforce .NET API
P4Server..::..CurrentWorkingDirectory Property
P4Server Class See Also Send Feedback
The current working directory (cwd) used by the p4 server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string CurrentWorkingDirectory { get; set; }
Visual Basic
Public Property CurrentWorkingDirectory As String
    Get
    Set
Visual C++
public:
property String^ CurrentWorkingDirectory {
    String^ get ();
    void set (String^ value);
}

Remarks

The properties, client, port, user, and password, represent the criteria used to connect to a P4 server. If one or more is changed, the bridge will drop the current connection if any and attempt to connect to the (possibly different) P4 server when the next command is executed. If it is desirable to validate the connection, execute a command.

See Also

P4Server Class


KeepAlive Property

[image]

Perforce .NET API
P4Server..::..KeepAlive Property
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IKeepAlive KeepAlive { get; set; }
Visual Basic
Public Property KeepAlive As IKeepAlive
    Get
    Set
Visual C++
public:
property IKeepAlive^ KeepAlive {
    IKeepAlive^ get ();
    void set (IKeepAlive^ value);
}

See Also

P4Server Class


LastResults Property

[image]

Perforce .NET API
P4Server..::..LastResults Property
P4Server Class See Also Send Feedback
The results of the last command executed on this thread

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4CommandResult LastResults { get; internal set; }
Visual Basic
Public Property LastResults As P4CommandResult
    Get
    Friend Set
Visual C++
public:
property P4CommandResult^ LastResults {
    P4CommandResult^ get ();
    internal: void set (P4CommandResult^ value);
}

See Also

P4Server Class


Password Property

[image]

Perforce .NET API
P4Server..::..Password Property
P4Server Class See Also Send Feedback
The user's password used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Remarks

The properties, client, port, user, and password, represent the criteria used to connect to a P4 server. If one or more is changed, the bridge will drop the current connection if any and attempt to connect to the (possibly different) P4 server when the next command is executed. If it is desirable to validate the connection, execute a command.

See Also

P4Server Class


Port Property

[image]

Perforce .NET API
P4Server..::..Port Property
P4Server Class See Also Send Feedback
The hostname:port used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Port { get; set; }
Visual Basic
Public Property Port As String
    Get
    Set
Visual C++
public:
property String^ Port {
    String^ get ();
    void set (String^ value);
}

Remarks

The properties, client, port, user, and password, represent the criteria used to connect to a P4 server. If one or more is changed, the bridge will drop the current connection if any and attempt to connect to the (possibly different) P4 server when the next command is executed. If it is desirable to validate the connection, execute a command.

See Also

P4Server Class


ProgramName Property

[image]

Perforce .NET API
P4Server..::..ProgramName Property
P4Server Class See Also Send Feedback
The program name used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ProgramName { get; set; }
Visual Basic
Public Property ProgramName As String
    Get
    Set
Visual C++
public:
property String^ ProgramName {
    String^ get ();
    void set (String^ value);
}

Remarks

The program name and version are recorded in the server logs when accessed by the client

See Also

P4Server Class


ProgramVersion Property

[image]

Perforce .NET API
P4Server..::..ProgramVersion Property
P4Server Class See Also Send Feedback
The program version used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ProgramVersion { get; set; }
Visual Basic
Public Property ProgramVersion As String
    Get
    Set
Visual C++
public:
property String^ ProgramVersion {
    String^ get ();
    void set (String^ value);
}

Remarks

The program name and version are recorded in the server logs when accessed by the client

See Also

P4Server Class


ReqiresLogin Property

[image]

Perforce .NET API
P4Server..::..ReqiresLogin Property
P4Server Class See Also Send Feedback
The server requires a client to use the login command to pass credentials.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool ReqiresLogin { get; }
Visual Basic
Public ReadOnly Property ReqiresLogin As Boolean
    Get
Visual C++
public:
property bool ReqiresLogin {
    bool get ();
}

See Also

P4Server Class


RunCmdTimout Property

[image]

Perforce .NET API
P4Server..::..RunCmdTimout Property
P4Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[ObsoleteAttribute("Use RunCmdTimeout")]
public TimeSpan RunCmdTimout { get; set; }
Visual Basic
<ObsoleteAttribute("Use RunCmdTimeout")> _
Public Property RunCmdTimout As TimeSpan
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Use RunCmdTimeout")]
public:
property TimeSpan RunCmdTimout {
    TimeSpan get ();
    void set (TimeSpan value);
}

See Also

P4Server Class


User Property

[image]

Perforce .NET API
P4Server..::..User Property
P4Server Class See Also Send Feedback
The user name used by the connection

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string User { get; set; }
Visual Basic
Public Property User As String
    Get
    Set
Visual C++
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}

Remarks

The properties, client, port, user, and password, represent the criteria used to connect to a P4 server. If one or more is changed, the bridge will drop the current connection if any and attempt to connect to the (possibly different) P4 server when the next command is executed. If it is desirable to validate the connection, execute a command.

See Also

P4Server Class


UseUnicode Property

[image]

Perforce .NET API
P4Server..::..UseUnicode Property
P4Server Class See Also Send Feedback
Need to use Unicode when marshalling to/from the P4 server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool UseUnicode { get; }
Visual Basic
Public ReadOnly Property UseUnicode As Boolean
    Get
Visual C++
public:
property bool UseUnicode {
    bool get ();
}

See Also

P4Server Class


Version Property

[image]

Perforce .NET API
P4Server..::..Version Property
P4Server Class See Also Send Feedback
Get the version of the p4.net assembly

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static Version Version { get; }
Visual Basic
Public Shared ReadOnly Property Version As Version
    Get
Visual C++
public:
static property Version^ Version {
    Version^ get ();
}

See Also

P4Server Class


P4Server Events

[image] [image]

Perforce .NET API
P4Server Events
P4Server Class See Also Send Feedback

The P4Server type exposes the following members.

Events

 | Name | Description
Public event | BinaryResultsReceived | Broadcast event for binary data
Public event | CommandEcho | Broadcast event for text results
Public event | ErrorReceived | Broadcast errors received
Public event | InfoResultsReceived | Broadcast event for info results
Public event | TaggedOutputReceived | Event to broadcast tagged output
Public event | TextResultsReceived | Broadcast event for text results

See Also

P4Server Class


BinaryResultsReceived Event

[image]

Perforce .NET API
P4Server..::..BinaryResultsReceived Event
P4Server Class See Also Send Feedback
Broadcast event for binary data

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..BinaryResultsDelegate BinaryResultsReceived
Visual Basic
Public Event BinaryResultsReceived As P4Server..::..BinaryResultsDelegate
Visual C++
public:
 event P4Server..::..BinaryResultsDelegate^ BinaryResultsReceived {
    void add (P4Server..::..BinaryResultsDelegate^ value);
    void remove (P4Server..::..BinaryResultsDelegate^ value);
}

See Also

P4Server Class


CommandEcho Event

[image]

Perforce .NET API
P4Server..::..CommandEcho Event
P4Server Class See Also Send Feedback
Broadcast event for text results

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..CommandEchoDelegate CommandEcho
Visual Basic
Public Event CommandEcho As P4Server..::..CommandEchoDelegate
Visual C++
public:
 event P4Server..::..CommandEchoDelegate^ CommandEcho {
    void add (P4Server..::..CommandEchoDelegate^ value);
    void remove (P4Server..::..CommandEchoDelegate^ value);
}

See Also

P4Server Class


ErrorReceived Event

[image]

Perforce .NET API
P4Server..::..ErrorReceived Event
P4Server Class See Also Send Feedback
Broadcast errors received

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..ErrorDelegate ErrorReceived
Visual Basic
Public Event ErrorReceived As P4Server..::..ErrorDelegate
Visual C++
public:
 event P4Server..::..ErrorDelegate^ ErrorReceived {
    void add (P4Server..::..ErrorDelegate^ value);
    void remove (P4Server..::..ErrorDelegate^ value);
}

See Also

P4Server Class


InfoResultsReceived Event

[image]

Perforce .NET API
P4Server..::..InfoResultsReceived Event
P4Server Class See Also Send Feedback
Broadcast event for info results

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..InfoResultsDelegate InfoResultsReceived
Visual Basic
Public Event InfoResultsReceived As P4Server..::..InfoResultsDelegate
Visual C++
public:
 event P4Server..::..InfoResultsDelegate^ InfoResultsReceived {
    void add (P4Server..::..InfoResultsDelegate^ value);
    void remove (P4Server..::..InfoResultsDelegate^ value);
}

See Also

P4Server Class


TaggedOutputReceived Event

[image]

Perforce .NET API
P4Server..::..TaggedOutputReceived Event
P4Server Class See Also Send Feedback
Event to broadcast tagged output

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..TaggedOutputDelegate TaggedOutputReceived
Visual Basic
Public Event TaggedOutputReceived As P4Server..::..TaggedOutputDelegate
Visual C++
public:
 event P4Server..::..TaggedOutputDelegate^ TaggedOutputReceived {
    void add (P4Server..::..TaggedOutputDelegate^ value);
    void remove (P4Server..::..TaggedOutputDelegate^ value);
}

See Also

P4Server Class


TextResultsReceived Event

[image]

Perforce .NET API
P4Server..::..TextResultsReceived Event
P4Server Class See Also Send Feedback
Broadcast event for text results

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public event P4Server..::..TextResultsDelegate TextResultsReceived
Visual Basic
Public Event TextResultsReceived As P4Server..::..TextResultsDelegate
Visual C++
public:
 event P4Server..::..TextResultsDelegate^ TextResultsReceived {
    void add (P4Server..::..TextResultsDelegate^ value);
    void remove (P4Server..::..TextResultsDelegate^ value);
}

See Also

P4Server Class


P4Server.BinaryResultsDelegate Delegate

[image]

Perforce .NET API
P4Server..::..BinaryResultsDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to send binary output as it is generated.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void BinaryResultsDelegate(
    uint cmdId,
    byte[] data
)
Visual Basic
Public Delegate Sub BinaryResultsDelegate ( _
    cmdId As UInteger, _
    data As Byte() _
)
Visual C++
public delegate void BinaryResultsDelegate(
    unsigned int cmdId,
    array<unsigned char>^ data
)

Parameters

cmdId
Type: System..::..UInt32
data
Type: array< System..::..Byte >[]()[][]
Binary data generated by a command

Remarks

This delegate will send a block of data for each call received by the callback from the bridge dll.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.CmdContactTimer Class

[image]

Perforce .NET API
P4Server..::..CmdContactTimer Class
P4Server Class Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class CmdContactTimer : IDisposable
Visual Basic
Public Class CmdContactTimer _
    Implements IDisposable
Visual C++
public ref class CmdContactTimer : IDisposable

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..P4Server..::..CmdContactTimer

See Also

P4Server..::..CmdContactTimer Members


P4Server.CmdContactTimer Members

[image] [image]

Perforce .NET API
P4Server..::..CmdContactTimer Members
P4Server..::..CmdContactTimer Class Constructors Methods Properties See Also Send Feedback

P4Server Represents the connection to a Perforce Server using the the P4 Bridge DLL. It wraps the calls exported by the DLL and transforms the data types exported by the DLL as native C#.NET data types.
P4Server Represents the connection to a Perforce Server using the the P4 Bridge DLL. It wraps the calls exported by the DLL and transforms the data types exported by the DLL as native C#.NET data types.

The P4Server..::..CmdContactTimer type exposes the following members.

Constructors

 | Name | Description
Public method | P4Server..::..CmdContactTimer | Initializes a new instance of the P4Server..::..CmdContactTimer class

Methods

 | Name | Description
Public method | Continue |
Public method | Dispose | Releases all resources used by the P4Server..::..CmdContactTimer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OverDue |
Public method | Pause |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPaused |

See Also

P4Server..::..CmdContactTimer Class


P4Server.CmdContactTimer Constructor

[image]

Perforce .NET API
P4Server..::..CmdContactTimer Constructor
P4Server..::..CmdContactTimer Class See Also Send Feedback
Initializes a new instance of the P4Server..::..CmdContactTimer class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public CmdContactTimer(
    Dictionary<uint, P4Server..::..CmdContactTimer> runCmdLastContactMap,
    uint _cmdId
)
Visual Basic
Public Sub New ( _
    runCmdLastContactMap As Dictionary(Of UInteger, P4Server..::..CmdContactTimer), _
    _cmdId As UInteger _
)
Visual C++
public:
CmdContactTimer(
    Dictionary<unsigned int, P4Server..::..CmdContactTimer^>^ runCmdLastContactMap,
    unsigned int _cmdId
)

Parameters

runCmdLastContactMap
Type: System.Collections.Generic..::..Dictionary <(Of <(<' UInt32, P4Server..::..CmdContactTimer >)>)>
_cmdId
Type: System..::..UInt32

See Also

P4Server..::..CmdContactTimer Class


P4Server.CmdContactTimer Methods

[image] [image]

Perforce .NET API
P4Server..::..CmdContactTimer Methods
P4Server..::..CmdContactTimer Class See Also Send Feedback

The P4Server..::..CmdContactTimer type exposes the following members.

Methods

 | Name | Description
Public method | Continue |
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OverDue |
Public method | Pause |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

P4Server..::..CmdContactTimer Class


Continue Method

[image]

Perforce .NET API
P4Server..::..CmdContactTimer..::..Continue Method
P4Server..::..CmdContactTimer Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Continue()
Visual Basic
Public Sub Continue
Visual C++
public:
void Continue()

See Also

P4Server..::..CmdContactTimer Class


Dispose Method

[image]

Perforce .NET API
P4Server..::..CmdContactTimer..::..Dispose Method
P4Server..::..CmdContactTimer Class See Also Send Feedback
Releases all resources used by the P4Server..::..CmdContactTimer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

P4Server..::..CmdContactTimer Class


OverDue Method

[image]

Perforce .NET API
P4Server..::..CmdContactTimer..::..OverDue Method
P4Server..::..CmdContactTimer Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool OverDue(
    TimeSpan RunCmdTimeout
)
Visual Basic
Public Function OverDue ( _
    RunCmdTimeout As TimeSpan _
) As Boolean
Visual C++
public:
bool OverDue(
    TimeSpan RunCmdTimeout
)

Parameters

RunCmdTimeout
Type: System..::..TimeSpan

See Also

P4Server..::..CmdContactTimer Class


Pause Method

[image]

Perforce .NET API
P4Server..::..CmdContactTimer..::..Pause Method
P4Server..::..CmdContactTimer Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Pause()
Visual Basic
Public Sub Pause
Visual C++
public:
void Pause()

See Also

P4Server..::..CmdContactTimer Class


P4Server.CmdContactTimer Properties

[image] [image]

Perforce .NET API
P4Server..::..CmdContactTimer Properties
P4Server..::..CmdContactTimer Class See Also Send Feedback

The P4Server..::..CmdContactTimer type exposes the following members.

Properties

 | Name | Description
Public property | IsPaused |

See Also

P4Server..::..CmdContactTimer Class


IsPaused Property

[image]

Perforce .NET API
P4Server..::..CmdContactTimer..::..IsPaused Property
P4Server..::..CmdContactTimer Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IsPaused { get; }
Visual Basic
Public ReadOnly Property IsPaused As Boolean
    Get
Visual C++
public:
property bool IsPaused {
    bool get ();
}

See Also

P4Server..::..CmdContactTimer Class


P4Server.CommandEchoDelegate Delegate

[image]

Perforce .NET API
P4Server..::..CommandEchoDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to commands as they are executed.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void CommandEchoDelegate(
    string data
)
Visual Basic
Public Delegate Sub CommandEchoDelegate ( _
    data As String _
)
Visual C++
public delegate void CommandEchoDelegate(
    String^ data
)

Parameters

data
Type: System..::..String
Command line executed by the command

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.ErrorDelegate Delegate

[image]

Perforce .NET API
P4Server..::..ErrorDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to send errors as they are generated.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void ErrorDelegate(
    uint cmdId,
    int severity,
    int errorNumber,
    string data
)
Visual Basic
Public Delegate Sub ErrorDelegate ( _
    cmdId As UInteger, _
    severity As Integer, _
    errorNumber As Integer, _
    data As String _
)
Visual C++
public delegate void ErrorDelegate(
    unsigned int cmdId,
    int severity,
    int errorNumber,
    String^ data
)

Parameters

cmdId
Type: System..::..UInt32
Command Id of the command causing the error
severity
Type: System..::..Int32
Severity of the error
errorNumber
Type: System..::..Int32
Error number for the error
data
Type: System..::..String
Error message

Remarks

This delegate will send a block of data for each call received by the callback from the bridge dll.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.InfoResultsDelegate Delegate

[image]

Perforce .NET API
P4Server..::..InfoResultsDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to send Info Results as they are generated.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void InfoResultsDelegate(
    uint cmdId,
    int msgId,
    int level,
    string data
)
Visual Basic
Public Delegate Sub InfoResultsDelegate ( _
    cmdId As UInteger, _
    msgId As Integer, _
    level As Integer, _
    data As String _
)
Visual C++
public delegate void InfoResultsDelegate(
    unsigned int cmdId,
    int msgId,
    int level,
    String^ data
)

Parameters

cmdId
Type: System..::..UInt32
msgId
Type: System..::..Int32
level
Type: System..::..Int32
Server supplied message level
data
Type: System..::..String
Server supplied message data

Remarks

This delegate will send a block of data for each call received by the callback from the bridge dll.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.PromptHandlerDelegate Delegate

[image]

Perforce .NET API
P4Server..::..PromptHandlerDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to provide a custom handler for input prompts from the p4api.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate string PromptHandlerDelegate(
    uint cmdId,
    string msg,
    bool displayText
)
Visual Basic
Public Delegate Function PromptHandlerDelegate ( _
    cmdId As UInteger, _
    msg As String, _
    displayText As Boolean _
) As String
Visual C++
public delegate String^ PromptHandlerDelegate(
    unsigned int cmdId,
    String^ msg,
    bool displayText
)

Parameters

cmdId
Type: System..::..UInt32
msg
Type: System..::..String
displayText
Type: System..::..Boolean

Return Value

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.ResolveAHandlerDelegate Delegate

[image]

Perforce .NET API
P4Server..::..ResolveAHandlerDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to provide a custom handler for Resolve callbacks passing a ClientResolve object from the p4api.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate P4ClientMerge..::..MergeStatus ResolveAHandlerDelegate(
    uint cmdId,
    P4ClientResolve Resolver
)
Visual Basic
Public Delegate Function ResolveAHandlerDelegate ( _
    cmdId As UInteger, _
    Resolver As P4ClientResolve _
) As P4ClientMerge..::..MergeStatus
Visual C++
public delegate P4ClientMerge..::..MergeStatus ResolveAHandlerDelegate(
    unsigned int cmdId,
    P4ClientResolve^ Resolver
)

Parameters

cmdId
Type: System..::..UInt32
Resolver
Type: Perforce.P4..::..P4ClientResolve

Return Value

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.ResolveHandlerDelegate Delegate

[image]

Perforce .NET API
P4Server..::..ResolveHandlerDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to provide a custom handler for Resolve callbacks passing a ClientMerge object from the p4api.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate P4ClientMerge..::..MergeStatus ResolveHandlerDelegate(
    uint cmdId,
    P4ClientMerge Merger
)
Visual Basic
Public Delegate Function ResolveHandlerDelegate ( _
    cmdId As UInteger, _
    Merger As P4ClientMerge _
) As P4ClientMerge..::..MergeStatus
Visual C++
public delegate P4ClientMerge..::..MergeStatus ResolveHandlerDelegate(
    unsigned int cmdId,
    P4ClientMerge^ Merger
)

Parameters

cmdId
Type: System..::..UInt32
Merger
Type: Perforce.P4..::..P4ClientMerge

Return Value

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.TaggedOutputDelegate Delegate

[image]

Perforce .NET API
P4Server..::..TaggedOutputDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to send tagged output as it is generated.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void TaggedOutputDelegate(
    uint cmdId,
    int ObjId,
    TaggedObject Obj
)
Visual Basic
Public Delegate Sub TaggedOutputDelegate ( _
    cmdId As UInteger, _
    ObjId As Integer, _
    Obj As TaggedObject _
)
Visual C++
public delegate void TaggedOutputDelegate(
    unsigned int cmdId,
    int ObjId,
    TaggedObject^ Obj
)

Parameters

cmdId
Type: System..::..UInt32
ObjId
Type: System..::..Int32
Obj
Type: Perforce.P4..::..TaggedObject

Remarks

This delegate will send a complete object after all of its fields have been received by the callback from the bridge dll.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4Server.TextResultsDelegate Delegate

[image]

Perforce .NET API
P4Server..::..TextResultsDelegate Delegate
P4Server Class See Also Send Feedback
Delegate used to send Text Results as they are generated.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public delegate void TextResultsDelegate(
    uint cmdId,
    string data
)
Visual Basic
Public Delegate Sub TextResultsDelegate ( _
    cmdId As UInteger, _
    data As String _
)
Visual C++
public delegate void TextResultsDelegate(
    unsigned int cmdId,
    String^ data
)

Parameters

cmdId
Type: System..::..UInt32
data
Type: System..::..String
Text results generated by the command

Remarks

This delegate will send a block of data for each call received by the callback from the bridge dll.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


P4TrustException Class

[image]

Perforce .NET API
P4TrustException Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class P4TrustException : P4Exception
Visual Basic
Public Class P4TrustException _
    Inherits P4Exception
Visual C++
public ref class P4TrustException : public P4Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Perforce.P4..::..P4Exception
Perforce.P4..::..P4TrustException

See Also

P4TrustException Members


P4TrustException Members

[image] [image]

Perforce .NET API
P4TrustException Members
P4TrustException Class Constructors Methods Properties Events See Also Send Feedback

The P4TrustException type exposes the following members.

Constructors

 | Name | Description
Public method | P4TrustException()()()() | Initializes a new instance of the P4TrustException class
Public method | P4TrustException(ErrorSeverity, String) | Initializes a new instance of the P4TrustException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4TrustException Class


P4TrustException Constructor

[image] [image]

Perforce .NET API
P4TrustException Constructor
P4TrustException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | P4TrustException()()()() | Initializes a new instance of the P4TrustException class
Public method | P4TrustException(ErrorSeverity, String) | Initializes a new instance of the P4TrustException class

See Also

P4TrustException Class
P4TrustException Members


P4TrustException Constructor

[image]

Perforce .NET API
P4TrustException Constructor
P4TrustException Class See Also Send Feedback
Initializes a new instance of the P4TrustException class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4TrustException()
Visual Basic
Public Sub New
Visual C++
public:
P4TrustException()

See Also

P4TrustException Class
P4TrustException Overload


P4TrustException Constructor (ErrorSeverity, String)

[image]

Perforce .NET API
P4TrustException Constructor (ErrorSeverity, String)
P4TrustException Class See Also Send Feedback
Initializes a new instance of the P4TrustException class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4TrustException(
    ErrorSeverity nLevel,
    string nMessage
)
Visual Basic
Public Sub New ( _
    nLevel As ErrorSeverity, _
    nMessage As String _
)
Visual C++
public:
P4TrustException(
    ErrorSeverity nLevel,
    String^ nMessage
)

Parameters

nLevel
Type: Perforce.P4..::..ErrorSeverity
nMessage
Type: System..::..String

See Also

P4TrustException Class
P4TrustException Overload


P4TrustException Methods

[image] [image]

Perforce .NET API
P4TrustException Methods
P4TrustException Class See Also Send Feedback

The P4TrustException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

P4TrustException Class


P4TrustException Properties

[image] [image]

Perforce .NET API
P4TrustException Properties
P4TrustException Class See Also Send Feedback

The P4TrustException type exposes the following members.

Properties

 | Name | Description
Public property | CmdLine | Error message (Inherited from P4Exception.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Details | Error message (Inherited from P4Exception.)
Public property | ErrorCode | Error number from the C++ API (Inherited from P4Exception.)
Public property | ErrorLevel | Severity of the error (Inherited from P4Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Error message (Inherited from P4Exception.)
Public property | NextError | If more than one error was returned by a command, the next error in the list. (Inherited from P4Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

P4TrustException Class


P4TrustException Events

[image] [image]

Perforce .NET API
P4TrustException Events
P4TrustException Class See Also Send Feedback

The P4TrustException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

P4TrustException Class


PathSpec Class

[image]

Perforce .NET API
PathSpec Class
Members See Also Send Feedback
Describes the path and path type in a file spec.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public abstract class PathSpec
Visual Basic
Public MustInherit Class PathSpec
Visual C++
public ref class PathSpec abstract

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..PathSpec
Perforce.P4..::..ClientPath
Perforce.P4..::..DepotPath
Perforce.P4..::..LocalPath

See Also

PathSpec Members


PathSpec Members

[image] [image]

Perforce .NET API
PathSpec Members
PathSpec Class Constructors Methods Operators Properties See Also Send Feedback

The PathSpec type exposes the following members.

Constructors

 | Name | Description
Protected method | PathSpec()()()() | Initializes a new instance of the PathSpec class
Public method | PathSpec(String) | Initializes a new instance of the PathSpec class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
 | EscapePath | Escape a string.
 | EscapePaths(IList<(Of <<'(String>)>>)) | Escape a list of strings.
 | EscapePaths(array<String>[]()[][]) | Escape an array of strings.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName |
Public method | GetFileName |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot |
Protected method | NormalizeLocal |
Public method | ToString | (Overrides Object..::..ToString()()()().)
 | UnescapePath | Unescape a string.
 | UnescapePaths(IList<(Of <<'(String>)>>)) | Unescape a list of strings.
 | UnescapePaths(array<String>[]()[][]) | Unescape an array of strings.

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (PathSpec to FileSpec) |

Properties

 | Name | Description
Public property | Path |

See Also

PathSpec Class


PathSpec Constructor

[image] [image]

Perforce .NET API
PathSpec Constructor
PathSpec Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | PathSpec()()()() | Initializes a new instance of the PathSpec class
Public method | PathSpec(String) | Initializes a new instance of the PathSpec class

See Also

PathSpec Class
PathSpec Members


PathSpec Constructor

[image]

Perforce .NET API
PathSpec Constructor
PathSpec Class See Also Send Feedback
Initializes a new instance of the PathSpec class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
protected PathSpec()
Visual Basic
Protected Sub New
Visual C++
protected:
PathSpec()

See Also

PathSpec Class
PathSpec Overload


PathSpec Constructor (String)

[image]

Perforce .NET API
PathSpec Constructor (String)
PathSpec Class See Also Send Feedback
Initializes a new instance of the PathSpec class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public PathSpec(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
PathSpec(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

PathSpec Class
PathSpec Overload


PathSpec Methods

[image] [image]

Perforce .NET API
PathSpec Methods
PathSpec Class See Also Send Feedback

The PathSpec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
 | EscapePath | Escape a string.
 | EscapePaths(IList<(Of <<'(String>)>>)) | Escape a list of strings.
 | EscapePaths(array<String>[]()[][]) | Escape an array of strings.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDirectoryName |
Public method | GetFileName |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NormalizeDepot |
Protected method | NormalizeLocal |
Public method | ToString | (Overrides Object..::..ToString()()()().)
 | UnescapePath | Unescape a string.
 | UnescapePaths(IList<(Of <<'(String>)>>)) | Unescape a list of strings.
 | UnescapePaths(array<String>[]()[][]) | Unescape an array of strings.

See Also

PathSpec Class


Equals Method

[image]

Perforce .NET API
PathSpec..::..Equals Method
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

PathSpec Class


EscapePath Method

[image]

Perforce .NET API
PathSpec..::..EscapePath Method
PathSpec Class See Also Send Feedback
Escape a string.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string EscapePath(
    string p
)
Visual Basic
Public Shared Function EscapePath ( _
    p As String _
) As String
Visual C++
public:
static String^ EscapePath(
    String^ p
)

Parameters

p
Type: System..::..String

See Also

PathSpec Class


EscapePaths Method

[image] [image]

Perforce .NET API
PathSpec..::..EscapePaths Method
PathSpec Class See Also Send Feedback

Overload List

Name | Description
EscapePaths(IList<(Of <<'(String>)>>)) | Escape a list of strings.
EscapePaths(array<String>[]()[][]) | Escape an array of strings.

See Also

PathSpec Class
PathSpec Members


EscapePaths Method (IList(String))

[image]

Perforce .NET API
PathSpec..::..EscapePaths Method (IList<(Of <(<'String>)>)>)
PathSpec Class See Also Send Feedback
Escape a list of strings.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static IList<string> EscapePaths(
    IList<string> Paths
)
Visual Basic
Public Shared Function EscapePaths ( _
    Paths As IList(Of String) _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ EscapePaths(
    IList<String^>^ Paths
)

Parameters

Paths
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
Path to escape

See Also

PathSpec Class
EscapePaths Overload


EscapePaths Method (String[])

[image]

Perforce .NET API
PathSpec..::..EscapePaths Method (array<String>[]()[][])
PathSpec Class See Also Send Feedback
Escape an array of strings.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] EscapePaths(
    string[] Paths
)
Visual Basic
Public Shared Function EscapePaths ( _
    Paths As String() _
) As String()
Visual C++
public:
static array<String^>^ EscapePaths(
    array<String^>^ Paths
)

Parameters

Paths
Type: array< System..::..String >[]()[][]
Paths to escape

See Also

PathSpec Class
EscapePaths Overload


GetDirectoryName Method

[image]

Perforce .NET API
PathSpec..::..GetDirectoryName Method
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetDirectoryName()
Visual Basic
Public Function GetDirectoryName As String
Visual C++
public:
String^ GetDirectoryName()

See Also

PathSpec Class


GetFileName Method

[image]

Perforce .NET API
PathSpec..::..GetFileName Method
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string GetFileName()
Visual Basic
Public Function GetFileName As String
Visual C++
public:
String^ GetFileName()

See Also

PathSpec Class


GetHashCode Method

[image]

Perforce .NET API
PathSpec..::..GetHashCode Method
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

PathSpec Class


NormalizeDepot Method

[image]

Perforce .NET API
PathSpec..::..NormalizeDepot Method
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
protected string NormalizeDepot(
    string path
)
Visual Basic
Protected Function NormalizeDepot ( _
    path As String _
) As String
Visual C++
protected:
String^ NormalizeDepot(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

PathSpec Class


NormalizeLocal Method

[image]

Perforce .NET API
PathSpec..::..NormalizeLocal Method
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
protected string NormalizeLocal(
    string path
)
Visual Basic
Protected Function NormalizeLocal ( _
    path As String _
) As String
Visual C++
protected:
String^ NormalizeLocal(
    String^ path
)

Parameters

path
Type: System..::..String

See Also

PathSpec Class


ToString Method

[image]

Perforce .NET API
PathSpec..::..ToString Method
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

PathSpec Class


UnescapePath Method

[image]

Perforce .NET API
PathSpec..::..UnescapePath Method
PathSpec Class See Also Send Feedback
Unescape a string.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string UnescapePath(
    string p
)
Visual Basic
Public Shared Function UnescapePath ( _
    p As String _
) As String
Visual C++
public:
static String^ UnescapePath(
    String^ p
)

Parameters

p
Type: System..::..String

See Also

PathSpec Class


UnescapePaths Method

[image] [image]

Perforce .NET API
PathSpec..::..UnescapePaths Method
PathSpec Class See Also Send Feedback

Overload List

Name | Description
UnescapePaths(IList<(Of <<'(String>)>>)) | Unescape a list of strings.
UnescapePaths(array<String>[]()[][]) | Unescape an array of strings.

See Also

PathSpec Class
PathSpec Members


UnescapePaths Method (IList(String))

[image]

Perforce .NET API
PathSpec..::..UnescapePaths Method (IList<(Of <(<'String>)>)>)
PathSpec Class See Also Send Feedback
Unescape a list of strings.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static IList<string> UnescapePaths(
    IList<string> Paths
)
Visual Basic
Public Shared Function UnescapePaths ( _
    Paths As IList(Of String) _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ UnescapePaths(
    IList<String^>^ Paths
)

Parameters

Paths
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>

See Also

PathSpec Class
UnescapePaths Overload


UnescapePaths Method (String[])

[image]

Perforce .NET API
PathSpec..::..UnescapePaths Method (array<String>[]()[][])
PathSpec Class See Also Send Feedback
Unescape an array of strings.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] UnescapePaths(
    string[] Paths
)
Visual Basic
Public Shared Function UnescapePaths ( _
    Paths As String() _
) As String()
Visual C++
public:
static array<String^>^ UnescapePaths(
    array<String^>^ Paths
)

Parameters

Paths
Type: array< System..::..String >[]()[][]
Paths to unescape

See Also

PathSpec Class
UnescapePaths Overload


PathSpec Type Conversions

[image] [image]

Perforce .NET API
PathSpec Type Conversions
PathSpec Class See Also Send Feedback

The PathSpec type exposes the following members.

Operators

Name | Description
Implicit Widening Implicit Implicit Implicit (PathSpec to FileSpec) |

See Also

PathSpec Class


Implicit Conversion (PathSpec to FileSpec)

[image]

Perforce .NET API
PathSpec ImplicitWideningImplicitImplicitImplicit Conversion (PathSpec to FileSpec)
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator FileSpec (
    PathSpec s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As PathSpec _
) As FileSpec
Visual C++
static implicit operator FileSpec^ (
    PathSpec^ s
)

Parameters

s
Type: Perforce.P4..::..PathSpec

See Also

PathSpec Class


PathSpec Properties

[image] [image]

Perforce .NET API
PathSpec Properties
PathSpec Class See Also Send Feedback

The PathSpec type exposes the following members.

Properties

 | Name | Description
Public property | Path |

See Also

PathSpec Class


Path Property

[image]

Perforce .NET API
PathSpec..::..Path Property
PathSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Path { get; protected set; }
Visual Basic
Public Property Path As String
    Get
    Protected Set
Visual C++
public:
property String^ Path {
    String^ get ();
    protected: void set (String^ value);
}

See Also

PathSpec Class


ProtectionEntry Class

[image]

Perforce .NET API
ProtectionEntry Class
Members See Also Send Feedback
Describes a protection entry (line) in a Perforce protection table.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ProtectionEntry
Visual Basic
Public Class ProtectionEntry
Visual C++
public ref class ProtectionEntry

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ProtectionEntry

See Also

ProtectionEntry Members


ProtectionEntry Members

[image] [image]

Perforce .NET API
ProtectionEntry Members
ProtectionEntry Class Constructors Methods Properties See Also Send Feedback

The ProtectionEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ProtectionEntry | Initializes a new instance of the ProtectionEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Host |
Public property | Mode |
Public property | Name |
Public property | Path |
Public property | Type |

See Also

ProtectionEntry Class


ProtectionEntry Constructor

[image]

Perforce .NET API
ProtectionEntry Constructor
ProtectionEntry Class See Also Send Feedback
Initializes a new instance of the ProtectionEntry class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ProtectionEntry(
    ProtectionMode mode,
    EntryType type,
    string name,
    string host,
    string path
)
Visual Basic
Public Sub New ( _
    mode As ProtectionMode, _
    type As EntryType, _
    name As String, _
    host As String, _
    path As String _
)
Visual C++
public:
ProtectionEntry(
    ProtectionMode mode,
    EntryType type,
    String^ name,
    String^ host,
    String^ path
)

Parameters

mode
Type: Perforce.P4..::..ProtectionMode
type
Type: Perforce.P4..::..EntryType
name
Type: System..::..String
host
Type: System..::..String
path
Type: System..::..String

See Also

ProtectionEntry Class


ProtectionEntry Methods

[image] [image]

Perforce .NET API
ProtectionEntry Methods
ProtectionEntry Class See Also Send Feedback

The ProtectionEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProtectionEntry Class


ProtectionEntry Properties

[image] [image]

Perforce .NET API
ProtectionEntry Properties
ProtectionEntry Class See Also Send Feedback

The ProtectionEntry type exposes the following members.

Properties

 | Name | Description
Public property | Host |
Public property | Mode |
Public property | Name |
Public property | Path |
Public property | Type |

See Also

ProtectionEntry Class


Host Property

[image]

Perforce .NET API
ProtectionEntry..::..Host Property
ProtectionEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Host { get; set; }
Visual Basic
Public Property Host As String
    Get
    Set
Visual C++
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

See Also

ProtectionEntry Class


Mode Property

[image]

Perforce .NET API
ProtectionEntry..::..Mode Property
ProtectionEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ProtectionMode Mode { get; set; }
Visual Basic
Public Property Mode As ProtectionMode
    Get
    Set
Visual C++
public:
property ProtectionMode Mode {
    ProtectionMode get ();
    void set (ProtectionMode value);
}

See Also

ProtectionEntry Class


Name Property

[image]

Perforce .NET API
ProtectionEntry..::..Name Property
ProtectionEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ProtectionEntry Class


Path Property

[image]

Perforce .NET API
ProtectionEntry..::..Path Property
ProtectionEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

ProtectionEntry Class


Type Property

[image]

Perforce .NET API
ProtectionEntry..::..Type Property
ProtectionEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public EntryType Type { get; set; }
Visual Basic
Public Property Type As EntryType
    Get
    Set
Visual C++
public:
property EntryType Type {
    EntryType get ();
    void set (EntryType value);
}

See Also

ProtectionEntry Class


ProtectionMode Enumeration

[image]

Perforce .NET API
ProtectionMode Enumeration
See Also Send Feedback
The protection mode or rights associated with this entry.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum ProtectionMode
Visual Basic
Public Enumeration ProtectionMode
Visual C++
public enum class ProtectionMode

Members

Member name | Value | Description
List | 0 |
Read | 1 |
Open | 2 |
Write | 3 |
Admin | 4 |
Super | 5 |
Review | 6 |
ReadRights | 7 |
BranchRights | 8 |
OpenRights | 9 |
WriteRights | 10 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ProtectionTable Class

[image]

Perforce .NET API
ProtectionTable Class
Members See Also Send Feedback
Specifies resource access privileges for Perforce users for a specific Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ProtectionTable : List<ProtectionEntry>
Visual Basic
Public Class ProtectionTable _
    Inherits List(Of ProtectionEntry)
Visual C++
public ref class ProtectionTable : public List<ProtectionEntry^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' ProtectionEntry >)>)>
Perforce.P4..::..ProtectionTable

See Also

ProtectionTable Members


ProtectionTable Members

[image] [image]

Perforce .NET API
ProtectionTable Members
ProtectionTable Class Constructors Methods Properties See Also Send Feedback

The ProtectionTable type exposes the following members.

Constructors

 | Name | Description
Public method | ProtectionTable | Initializes a new instance of the ProtectionTable class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public property | Entry |
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class


ProtectionTable Constructor

[image]

Perforce .NET API
ProtectionTable Constructor
ProtectionTable Class See Also Send Feedback
Initializes a new instance of the ProtectionTable class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ProtectionTable(
    ProtectionEntry entry
)
Visual Basic
Public Sub New ( _
    entry As ProtectionEntry _
)
Visual C++
public:
ProtectionTable(
    ProtectionEntry^ entry
)

Parameters

entry
Type: Perforce.P4..::..ProtectionEntry

See Also

ProtectionTable Class


ProtectionTable Methods

[image] [image]

Perforce .NET API
ProtectionTable Methods
ProtectionTable Class See Also Send Feedback

The ProtectionTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class


BinarySearch Method

[image] [image]

Perforce .NET API
ProtectionTable..::..BinarySearch Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


CopyTo Method

[image] [image]

Perforce .NET API
ProtectionTable..::..CopyTo Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


FindIndex Method

[image] [image]

Perforce .NET API
ProtectionTable..::..FindIndex Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


FindLastIndex Method

[image] [image]

Perforce .NET API
ProtectionTable..::..FindLastIndex Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


IndexOf Method

[image] [image]

Perforce .NET API
ProtectionTable..::..IndexOf Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


LastIndexOf Method

[image] [image]

Perforce .NET API
ProtectionTable..::..LastIndexOf Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


Reverse Method

[image] [image]

Perforce .NET API
ProtectionTable..::..Reverse Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


Sort Method

[image] [image]

Perforce .NET API
ProtectionTable..::..Sort Method
ProtectionTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class
ProtectionTable Members


ProtectionTable Properties

[image] [image]

Perforce .NET API
ProtectionTable Properties
ProtectionTable Class See Also Send Feedback

The ProtectionTable type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)
Public property | Entry |
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' ProtectionEntry >)>)>.)

See Also

ProtectionTable Class


Entry Property

[image]

Perforce .NET API
ProtectionTable..::..Entry Property
ProtectionTable Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ProtectionEntry Entry { get; set; }
Visual Basic
Public Property Entry As ProtectionEntry
    Get
    Set
Visual C++
public:
property ProtectionEntry^ Entry {
    ProtectionEntry^ get ();
    void set (ProtectionEntry^ value);
}

See Also

ProtectionTable Class


ReopenCmdOptions Class

[image]

Perforce .NET API
ReopenCmdOptions Class
Members See Also Send Feedback
Options for the reopen command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ReopenCmdOptions : Options
Visual Basic
Public Class ReopenCmdOptions _
    Inherits Options
Visual C++
public ref class ReopenCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ReopenCmdOptions

See Also

ReopenCmdOptions Members


ReopenCmdOptions Members

[image] [image]

Perforce .NET API
ReopenCmdOptions Members
ReopenCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ReopenCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ReopenCmdOptions | Options for the reopen command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ReopenCmdOptions Class


ReopenCmdOptions Constructor

[image]

Perforce .NET API
ReopenCmdOptions Constructor
ReopenCmdOptions Class See Also Send Feedback
Options for the reopen command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ReopenCmdOptions(
    int changeList,
    FileType fileType
)
Visual Basic
Public Sub New ( _
    changeList As Integer, _
    fileType As FileType _
)
Visual C++
public:
ReopenCmdOptions(
    int changeList,
    FileType^ fileType
)

Parameters

changeList
Type: System..::..Int32
fileType
Type: Perforce.P4..::..FileType

Return Value

Remarks

p4 help reopen

reopen -- Change the filetype of an open file or move it to
another changelist

p4 reopen [-c changelist#] [-t filetype] file ...

Reopen an open file for the current user in order to move it to a
different changelist or change its filetype.

The target changelist must exist; you cannot create a changelist by
reopening a file. To move a file to the default changelist, use
'p4 reopen -c default'.

If -t filetype is specified, the file is assigned that filetype. If
a partial filetype is specified, it is combined with the current
filetype. For details, see 'p4 help filetypes'.

See Also

ReopenCmdOptions Class


ReopenCmdOptions Methods

[image] [image]

Perforce .NET API
ReopenCmdOptions Methods
ReopenCmdOptions Class See Also Send Feedback

The ReopenCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ReopenCmdOptions Class


ReopenCmdOptions Properties

[image] [image]

Perforce .NET API
ReopenCmdOptions Properties
ReopenCmdOptions Class See Also Send Feedback

The ReopenCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ReopenCmdOptions Class


Repository Class

[image]

Perforce .NET API
Repository Class
Members See Also Send Feedback
Represents a Perforce server and connection.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Repository : IDisposable
Visual Basic
Public Class Repository _
    Implements IDisposable
Visual C++
public ref class Repository : IDisposable

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Repository

See Also

Repository Members


Repository Members

[image] [image]

Perforce .NET API
Repository Members
Repository Class Constructors Methods Properties See Also Send Feedback

The Repository type exposes the following members.

Constructors

 | Name | Description
Public method | Repository | Create a repository on the specified server.

Methods

 | Name | Description
Public method | CreateBranchSpec(BranchSpec) | Create a new branch in the repository.
Public method | CreateBranchSpec(BranchSpec, Options) | Create a new branch in the repository.
Public method | CreateChangelist(Changelist) | Create a new change in the repository.
Public method | CreateChangelist(Changelist, Options) | Create a new changelist in the repository.
Public method | CreateClient(Client) | Create a new client in the repository.
Public method | CreateClient(Client, Options) | Create a new client in the repository.
Public method | CreateDepot(Depot) | Create a new depot in the repository.
Public method | CreateDepot(Depot, Options) | Create a new depot in the repository.
Public method | CreateGroup(Group) | Create a new group in the repository.
Public method | CreateGroup(Group, Options) | Create a new group in the repository.
Public method | CreateJob(Job) | Create a new job in the repository.
Public method | CreateJob(Job, Options) | Create a new job in the repository.
Public method | CreateLabel(Label) | Create a new label in the repository.
Public method | CreateLabel(Label, Options) | Create a new label in the repository.
Public method | CreateStream(Stream) | Create a new stream in the repository.
Public method | CreateStream(Stream, Options) | Create a new stream in the repository.
Public method | CreateUser(User) | Create a new user in the repository.
Public method | CreateUser(User, Options) | Create a new user in the repository.
Public method | DeleteBranchSpec | Delete a branch from the repository
Public method | DeleteChangelist | Delete a change from the repository
Public method | DeleteClient | Delete a client from the repository
Public method | DeleteCounter | Delete a Perforce counter from the repository.
Public method | DeleteDepot | Delete a depot from the repository
Public method | DeleteGroup | Delete a group from the repository
Public method | DeleteJob | Delete a job from the repository
Public method | DeleteLabel | Delete a label from the repository
Public method | DeleteStream | Delete a stream from the repository
Public method | DeleteUser | Delete a user from the repository
Public method | Dispose | Releases all resources used by the Repository
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBranchSpec(String) |
Public method | GetBranchSpec(String, String, String, Options) | Get the record for an existing branch from the repository.
Public method | GetBranchSpecs | Get a list of branches from the repository
Public method | GetChangelist(Int32) | Get the record for an existing change from the repository.
Public method | GetChangelist(Int32, Options) | Get the record for an existing change from the repository.
Public method | GetChangelists | Get a list of changes from the repository
Public method | GetClient(String) | Get the record for an existing client from the repository.
Public method | GetClient(String, Options) | Get the record for an existing client from the repository.
Public method | GetClientMetadata | Get client application information.
Public method | GetClients | Get a list of clients from the repository
Public method | GetCounter | Get a named Perforce counter value from the repository.
Public method | GetCounters | Get the Perforce counters for this repository.
Public method | GetDepot(String) | Get the record for an existing depot from the repository.
Public method | GetDepot(String, Options) | Get the record for an existing depot from the repository.
Public method | GetDepotDirs(IList<(Of <<'(String>)>>), Options) | List selected directory paths in the repository.
Public method | GetDepotDirs(Options, array<String>[]()[][]) | List selected directory paths in the repository.
Public method | GetDepotFileDiffs | Get content and existence diff details for two depot files.
Public method | GetDepotFiles | Return a list of FileSpecs of files in the depot that correspond to the passed-in FileSpecs.
Public method | GetDepots | Get a list of depots from the repository
Public method | GetFileAnnotations | Return FileAnnotation objects for the listed FileSpecs.
Public method | GetFileContents(IList<(Of <<'(FileSpec>)>>), Options) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContents(Options, array<FileSpec>[]()[][]) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContentsEx(IList<(Of <<'(FileSpec>)>>), Options) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContentsEx(Options, array<FileSpec>[]()[][]) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileHistory(IList<(Of <<'(FileSpec>)>>), Options) | Get the revision history data for the passed-in file specs.
Public method | GetFileHistory(Options, array<FileSpec>[]()[][]) | Get the revision history data for the passed-in file specs.
Public method | GetFileLineMatches | Get a list of matching lines in the passed-in file specs.
Public method | GetFileMetaData(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetFileMetaData(Options, array<FileSpec>[]()[][]) |
Public method | GetFiles(IList<(Of <<'(FileSpec>)>>), Options) | Return a list of Files in the depot that correspond to the passed-in FileSpecs.
Public method | GetFiles(Options, array<FileSpec>[]()[][]) | Return a list of Files in the depot that correspond to the passed-in FileSpecs.
Public method | GetFixes | List fixes affecting files and / or jobs and / or changelists.
Public method | GetFormSpec | Get a FormSpec of the specified form type.
Public method | GetGroup(String) | Get the record for an existing group from the repository.
Public method | GetGroup(String, Options) | Get the record for an existing group from the repository.
Public method | GetGroups | Get a list of groups from the repository
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJob(String) | Get the record for an existing job from the repository.
Public method | GetJob(String, Options) | Get the record for an existing job from the repository.
Public method | GetJobs | Get a list of jobs from the repository
Public method | GetLabel(String) | Get the record for an existing label from the repository.
Public method | GetLabel(String, String, Options) | Get the record for an existing label from the repository.
Public method | GetLabels | Get a list of labels from the repository
Public method | GetOpenedFiles | Return a list of Files opened by users / clients.
Public method | GetProtectionEntries | Get a list of Perforce protection entries for the passed-in file specs
Public method | GetProtectionTable | Get the repository's protection table.
Public method | GetReviewers | List Perforce users assigned to review files.
Public method | GetServerMetaData()()()() | Obsolete.
Public method | GetServerMetaData(Options) | Get server information.
Public method | GetStream(String) | Get the record for an existing stream from the repository.
Public method | GetStream(String, String, Options) | Get the record for an existing stream from the repository.
Public method | GetStreamMetaData | Get the integration status for a stream in the repository
Public method | GetStreams |
Public method | GetSubmittedIntegrations | Get a list of submitted integrations for the passed-in file specs.
Public method | GetTriggerTable | Get the repository's trigger table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeMap | Get the repository's type map.
Public method | GetUser(String) | Get the record for an existing user from the repository.
Public method | GetUser(String, Options) | Get the record for an existing user from the repository.
Public method | GetUsers(IList<(Of <<'(String>)>>), Options) | Get a list of users from the repository
Public method | GetUsers(Options, array<String>[]()[][]) | Get a list of users from the repository
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewChangelist |
Public method | TagFiles | Tag depot files with the passed-in label.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBranchSpec | Update the record for a branch in the repository
Public method | UpdateChangelist(Changelist) | Update the record for a change in the repository
Public method | UpdateChangelist(Changelist, Options) | Update the record for a change in the repository
Public method | UpdateClient | Update the record for a client in the repository
Public method | UpdateDepot | Update the record for a depot in the repository
Public method | UpdateGroup(Group) | Update the record for a group in the repository
Public method | UpdateGroup(Group, Options) | Update the record for a group in the repository
Public method | UpdateJob | Update the record for a job in the repository
Public method | UpdateLabel | Update the record for a label in the repository
Public method | UpdateStream(Stream) | Update the record for a stream in the repository
Public method | UpdateStream(Stream, Options) | Update the record for a stream in the repository
Public method | UpdateSubmittedChangelist(Changelist) | Update the record for a submitted change in the repository
Public method | UpdateSubmittedChangelist(Changelist, Options) | Update the record for a submitted change in the repository
Public method | UpdateUser(User) | Update the record for a user in the repository
Public method | UpdateUser(User, Options) | Update the record for a user in the repository

Properties

 | Name | Description
Public property | Connection | Represents the logical connection between a specific Perforce Server instance and a specific client application.
Public property | Server | Represents a specific Perforce server.

See Also

Repository Class


Repository Constructor

[image]

Perforce .NET API
Repository Constructor
Repository Class See Also Send Feedback
Create a repository on the specified server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Repository(
    Server server
)
Visual Basic
Public Sub New ( _
    server As Server _
)
Visual C++
public:
Repository(
    Server^ server
)

Parameters

server
Type: Perforce.P4..::..Server
The repository server.

See Also

Repository Class


Repository Methods

[image] [image]

Perforce .NET API
Repository Methods
Repository Class See Also Send Feedback

The Repository type exposes the following members.

Methods

 | Name | Description
Public method | CreateBranchSpec(BranchSpec) | Create a new branch in the repository.
Public method | CreateBranchSpec(BranchSpec, Options) | Create a new branch in the repository.
Public method | CreateChangelist(Changelist) | Create a new change in the repository.
Public method | CreateChangelist(Changelist, Options) | Create a new changelist in the repository.
Public method | CreateClient(Client) | Create a new client in the repository.
Public method | CreateClient(Client, Options) | Create a new client in the repository.
Public method | CreateDepot(Depot) | Create a new depot in the repository.
Public method | CreateDepot(Depot, Options) | Create a new depot in the repository.
Public method | CreateGroup(Group) | Create a new group in the repository.
Public method | CreateGroup(Group, Options) | Create a new group in the repository.
Public method | CreateJob(Job) | Create a new job in the repository.
Public method | CreateJob(Job, Options) | Create a new job in the repository.
Public method | CreateLabel(Label) | Create a new label in the repository.
Public method | CreateLabel(Label, Options) | Create a new label in the repository.
Public method | CreateStream(Stream) | Create a new stream in the repository.
Public method | CreateStream(Stream, Options) | Create a new stream in the repository.
Public method | CreateUser(User) | Create a new user in the repository.
Public method | CreateUser(User, Options) | Create a new user in the repository.
Public method | DeleteBranchSpec | Delete a branch from the repository
Public method | DeleteChangelist | Delete a change from the repository
Public method | DeleteClient | Delete a client from the repository
Public method | DeleteCounter | Delete a Perforce counter from the repository.
Public method | DeleteDepot | Delete a depot from the repository
Public method | DeleteGroup | Delete a group from the repository
Public method | DeleteJob | Delete a job from the repository
Public method | DeleteLabel | Delete a label from the repository
Public method | DeleteStream | Delete a stream from the repository
Public method | DeleteUser | Delete a user from the repository
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBranchSpec(String) |
Public method | GetBranchSpec(String, String, String, Options) | Get the record for an existing branch from the repository.
Public method | GetBranchSpecs | Get a list of branches from the repository
Public method | GetChangelist(Int32) | Get the record for an existing change from the repository.
Public method | GetChangelist(Int32, Options) | Get the record for an existing change from the repository.
Public method | GetChangelists | Get a list of changes from the repository
Public method | GetClient(String) | Get the record for an existing client from the repository.
Public method | GetClient(String, Options) | Get the record for an existing client from the repository.
Public method | GetClientMetadata | Get client application information.
Public method | GetClients | Get a list of clients from the repository
Public method | GetCounter | Get a named Perforce counter value from the repository.
Public method | GetCounters | Get the Perforce counters for this repository.
Public method | GetDepot(String) | Get the record for an existing depot from the repository.
Public method | GetDepot(String, Options) | Get the record for an existing depot from the repository.
Public method | GetDepotDirs(IList<(Of <<'(String>)>>), Options) | List selected directory paths in the repository.
Public method | GetDepotDirs(Options, array<String>[]()[][]) | List selected directory paths in the repository.
Public method | GetDepotFileDiffs | Get content and existence diff details for two depot files.
Public method | GetDepotFiles | Return a list of FileSpecs of files in the depot that correspond to the passed-in FileSpecs.
Public method | GetDepots | Get a list of depots from the repository
Public method | GetFileAnnotations | Return FileAnnotation objects for the listed FileSpecs.
Public method | GetFileContents(IList<(Of <<'(FileSpec>)>>), Options) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContents(Options, array<FileSpec>[]()[][]) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContentsEx(IList<(Of <<'(FileSpec>)>>), Options) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContentsEx(Options, array<FileSpec>[]()[][]) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileHistory(IList<(Of <<'(FileSpec>)>>), Options) | Get the revision history data for the passed-in file specs.
Public method | GetFileHistory(Options, array<FileSpec>[]()[][]) | Get the revision history data for the passed-in file specs.
Public method | GetFileLineMatches | Get a list of matching lines in the passed-in file specs.
Public method | GetFileMetaData(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetFileMetaData(Options, array<FileSpec>[]()[][]) |
Public method | GetFiles(IList<(Of <<'(FileSpec>)>>), Options) | Return a list of Files in the depot that correspond to the passed-in FileSpecs.
Public method | GetFiles(Options, array<FileSpec>[]()[][]) | Return a list of Files in the depot that correspond to the passed-in FileSpecs.
Public method | GetFixes | List fixes affecting files and / or jobs and / or changelists.
Public method | GetFormSpec | Get a FormSpec of the specified form type.
Public method | GetGroup(String) | Get the record for an existing group from the repository.
Public method | GetGroup(String, Options) | Get the record for an existing group from the repository.
Public method | GetGroups | Get a list of groups from the repository
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJob(String) | Get the record for an existing job from the repository.
Public method | GetJob(String, Options) | Get the record for an existing job from the repository.
Public method | GetJobs | Get a list of jobs from the repository
Public method | GetLabel(String) | Get the record for an existing label from the repository.
Public method | GetLabel(String, String, Options) | Get the record for an existing label from the repository.
Public method | GetLabels | Get a list of labels from the repository
Public method | GetOpenedFiles | Return a list of Files opened by users / clients.
Public method | GetProtectionEntries | Get a list of Perforce protection entries for the passed-in file specs
Public method | GetProtectionTable | Get the repository's protection table.
Public method | GetReviewers | List Perforce users assigned to review files.
Public method | GetServerMetaData()()()() | Obsolete.
Public method | GetServerMetaData(Options) | Get server information.
Public method | GetStream(String) | Get the record for an existing stream from the repository.
Public method | GetStream(String, String, Options) | Get the record for an existing stream from the repository.
Public method | GetStreamMetaData | Get the integration status for a stream in the repository
Public method | GetStreams |
Public method | GetSubmittedIntegrations | Get a list of submitted integrations for the passed-in file specs.
Public method | GetTriggerTable | Get the repository's trigger table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeMap | Get the repository's type map.
Public method | GetUser(String) | Get the record for an existing user from the repository.
Public method | GetUser(String, Options) | Get the record for an existing user from the repository.
Public method | GetUsers(IList<(Of <<'(String>)>>), Options) | Get a list of users from the repository
Public method | GetUsers(Options, array<String>[]()[][]) | Get a list of users from the repository
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewChangelist |
Public method | TagFiles | Tag depot files with the passed-in label.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBranchSpec | Update the record for a branch in the repository
Public method | UpdateChangelist(Changelist) | Update the record for a change in the repository
Public method | UpdateChangelist(Changelist, Options) | Update the record for a change in the repository
Public method | UpdateClient | Update the record for a client in the repository
Public method | UpdateDepot | Update the record for a depot in the repository
Public method | UpdateGroup(Group) | Update the record for a group in the repository
Public method | UpdateGroup(Group, Options) | Update the record for a group in the repository
Public method | UpdateJob | Update the record for a job in the repository
Public method | UpdateLabel | Update the record for a label in the repository
Public method | UpdateStream(Stream) | Update the record for a stream in the repository
Public method | UpdateStream(Stream, Options) | Update the record for a stream in the repository
Public method | UpdateSubmittedChangelist(Changelist) | Update the record for a submitted change in the repository
Public method | UpdateSubmittedChangelist(Changelist, Options) | Update the record for a submitted change in the repository
Public method | UpdateUser(User) | Update the record for a user in the repository
Public method | UpdateUser(User, Options) | Update the record for a user in the repository

See Also

Repository Class


CreateBranchSpec Method

[image] [image]

Perforce .NET API
Repository..::..CreateBranchSpec Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBranchSpec(BranchSpec) | Create a new branch in the repository.
Public method | CreateBranchSpec(BranchSpec, Options) | Create a new branch in the repository.

See Also

Repository Class
Repository Members


CreateBranchSpec Method (BranchSpec)

[image]

Perforce .NET API
Repository..::..CreateBranchSpec Method (BranchSpec)
Repository Class Example See Also Send Feedback
Create a new branch in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchSpec CreateBranchSpec(
    BranchSpec branch
)
Visual Basic
Public Function CreateBranchSpec ( _
    branch As BranchSpec _
) As BranchSpec
Visual C++
public:
BranchSpec^ CreateBranchSpec(
    BranchSpec^ branch
)

Parameters

branch
Type: Perforce.P4..::..BranchSpec
Branch specification for the new branch

Return Value

The Branch object if new branch was created, null if creation failed

Examples

To create a basic branch spec:
CopyC#
BranchSpec newBranchSpec = new BranchSpec();
newBranchSpec.Id = "newBranchSpec";
newBranchSpec.ViewMap = new ViewMap();
string v0 = "//depot/main/... //depot/rel1/...";
newBranchSpec.ViewMap.Add(v0);
_repository.CreateBranchSpec(newBranchSpec);

See Also

Repository Class
CreateBranchSpec Overload


CreateBranchSpec Method (BranchSpec, Options)

[image]

Perforce .NET API
Repository..::..CreateBranchSpec Method (BranchSpec, Options)
Repository Class Example See Also Send Feedback
Create a new branch in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchSpec CreateBranchSpec(
    BranchSpec branch,
    Options options
)
Visual Basic
Public Function CreateBranchSpec ( _
    branch As BranchSpec, _
    options As Options _
) As BranchSpec
Visual C++
public:
BranchSpec^ CreateBranchSpec(
    BranchSpec^ branch,
    Options^ options
)

Parameters

branch
Type: Perforce.P4..::..BranchSpec
Branch specification for the new branch
options
Type: Perforce.P4..::..Options
The '-i' flag is required when creating a new branch

Return Value

The Branch object if new branch was created, null if creation failed

Remarks

p4 help branch

branch -- Create, modify, or delete a branch view specification

p4 branch [-f] name
p4 branch -d [-f] name
p4 branch [ -S stream ] [ -P parent ] -o name
p4 branch -i [-f]

A branch specification ('spec') is a named, user-defined mapping of
depot files to depot files. It can be used with most of the commands
that operate on two sets of files ('copy', 'merge', 'integrate',
'diff2', etc.)

Creating a branch spec does not branch files. To branch files, use
'p4 copy', with or without a branch spec.

The 'branch' command puts the branch spec into a temporary file and
invokes the editor configured by the environment variable $P4EDITOR.
Saving the file creates or modifies the branch spec.

The branch spec contains the following fields:

Branch: The branch spec name (read only).

Owner: The user who created this branch spec. Can be changed.

Update: The date this branch spec was last modified.

Access: The date of the last command used with this spec.

Description: A description of the branch spec (optional).

Options: Flags to change the branch spec behavior. The defaults
are marked with *.

locked Permits only the owner to change the spec.
unlocked * Prevents the branch spec from being deleted.

View: Lines mapping of one view of depot files to another.
Both the left and right-hand sides of the mappings refer
to the depot namespace. See 'p4 help views' for more on
view syntax.

New branch specs are created with a default view that maps all depot
files to themselves. This view must be changed before the branch
spec can be saved.

The -d flag deletes the named branch spec.

The -o flag writes the branch spec to standard output. The user's
editor is not invoked.

The -i flag causes a branch spec to be read from the standard input.
The user's editor is not invoked.

The -f flag enables a user with 'admin' privilege to delete the spec
or set the 'last modified' date. By default, specs can be deleted
only by their owner.

A branch spec can also be used to expose the internally generated
mapping of a stream to its parent. (See 'p4 help stream' and 'p4
help streamintro'.)

The -S stream flag will expose the internally generated mapping.
The -P flag may be used with -S to treat the stream as if it were a
child of a different parent. The -o flag is required with -S.

Examples

To create a branch spec [-i]:
CopyC#
BranchSpec newBranchSpec = new BranchSpec();
newBranchSpec.Id = "newBranchSpec";
newBranchSpec.Owner = "admin";
newBranchSpec.Description = " created by perforce";
newBranchSpec.ViewMap = new ViewMap();
string v0 = "//depot/main/... //depot/rel1/...";
string v1 = "//depot/main/... //depot/rel2/...";
string v2 = "//depot/dev/... //depot/main/...";
newBranchSpec.ViewMap.Add(v0);
newBranchSpec.ViewMap.Add(v1);
newBranchSpec.ViewMap.Add(v2);
Options opts = new Options(BranchSpecCmdFlags.Input);
_repository.CreateBranchSpec(newBranchSpec, opts);

See Also

Repository Class
CreateBranchSpec Overload
Perforce.P4 Namespace
Perforce.P4..::..BranchSpecCmdFlags


CreateChangelist Method

[image] [image]

Perforce .NET API
Repository..::..CreateChangelist Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateChangelist(Changelist) | Create a new change in the repository.
Public method | CreateChangelist(Changelist, Options) | Create a new changelist in the repository.

See Also

Repository Class
Repository Members


CreateChangelist Method (Changelist)

[image]

Perforce .NET API
Repository..::..CreateChangelist Method (Changelist)
Repository Class Example See Also Send Feedback
Create a new change in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist CreateChangelist(
    Changelist change
)
Visual Basic
Public Function CreateChangelist ( _
    change As Changelist _
) As Changelist
Visual C++
public:
Changelist^ CreateChangelist(
    Changelist^ change
)

Parameters

change
Type: Perforce.P4..::..Changelist
Changelist specification for the new change

Return Value

The Changelist object if new change was created, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To create a new changelist:
CopyC#
Changelist c = new Changelist();
c = Repository.CreateChangelist(c, null);

See Also

Repository Class
CreateChangelist Overload


CreateChangelist Method (Changelist, Options)

[image]

Perforce .NET API
Repository..::..CreateChangelist Method (Changelist, Options)
Repository Class Example See Also Send Feedback
Create a new changelist in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist CreateChangelist(
    Changelist change,
    Options options
)
Visual Basic
Public Function CreateChangelist ( _
    change As Changelist, _
    options As Options _
) As Changelist
Visual C++
public:
Changelist^ CreateChangelist(
    Changelist^ change,
    Options^ options
)

Parameters

change
Type: Perforce.P4..::..Changelist
Changelist specification for the new changelist
options
Type: Perforce.P4..::..Options
'-s', '-f', -u flags are valid when creating a new changelist

Return Value

The Changelist object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To create a new changelist:
CopyC#
Changelist c = new Changelist();
c = Repository.CreateChangelist(c, null);
 To create a new restricted changelist:
CopyC#
Changelist c = new Changelist();
c.Type = ChangeListType.Restricted;
c = Repository.CreateChangelist(c, null);

See Also

Repository Class
CreateChangelist Overload
Perforce.P4 Namespace
Perforce.P4..::..ChangeCmdFlags


CreateClient Method

[image] [image]

Perforce .NET API
Repository..::..CreateClient Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateClient(Client) | Create a new client in the repository.
Public method | CreateClient(Client, Options) | Create a new client in the repository.

See Also

Repository Class
Repository Members


CreateClient Method (Client)

[image]

Perforce .NET API
Repository..::..CreateClient Method (Client)
Repository Class Example See Also Send Feedback
Create a new client in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Client CreateClient(
    Client client
)
Visual Basic
Public Function CreateClient ( _
    client As Client _
) As Client
Visual C++
public:
Client^ CreateClient(
    Client^ client
)

Parameters

client
Type: Perforce.P4..::..Client
Client specification for the new user

Return Value

The Client object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

Examples

To create a client named main_ws:
CopyC#
Client c = Repository.GetClient("main_ws");
c.OwnerName= "bsmith";
c.Description = "client for main dev";
Repository.CreateClient(c);
 To create a client named main_ws using existing admin_main_ws as a template:
CopyC#
ClientCmdOptions opts =
new ClientCmdOptions(ClientCmdFlags.None, "admin_main_ws", null, 0);
Client c = Repository.GetClient("main_ws",opts);
Repository.CreateClient(c);
 To create a streams client named main_ws for the mainline stream //MobileApp/Main:
CopyC#
ClientCmdOptions opts =
new ClientCmdOptions(ClientCmdFlags.None, null, "//MobileApp/Main", 0);
Client c = Repository.GetClient("main_ws",opts);
Repository.CreateClient(c);

See Also

Repository Class
CreateClient Overload


CreateClient Method (Client, Options)

[image]

Perforce .NET API
Repository..::..CreateClient Method (Client, Options)
Repository Class Example See Also Send Feedback
Create a new client in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Client CreateClient(
    Client client,
    Options options
)
Visual Basic
Public Function CreateClient ( _
    client As Client, _
    options As Options _
) As Client
Visual C++
public:
Client^ CreateClient(
    Client^ client,
    Options^ options
)

Parameters

client
Type: Perforce.P4..::..Client
Client specification for the new user
options
Type: Perforce.P4..::..Options
The '-i' flags is required when creating a new user

Return Value

The Client object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

Examples

To create a client named main_ws:
CopyC#
Client c = Repository.GetClient("main_ws");
c.OwnerName= "bsmith";
c.Description = "client for main dev";
Repository.CreateClient(c, null);
 To create a client named main_ws using existing admin_main_ws as a template:
CopyC#
ClientCmdOptions opts =
new ClientCmdOptions(ClientCmdFlags.None, "admin_main_ws", null, 0);
Client c = Repository.GetClient("main_ws",opts);
Repository.CreateClient(c, null);
 To create a streams client named main_ws for the mainline stream //MobileApp/Main:
CopyC#
ClientCmdOptions opts =
new ClientCmdOptions(ClientCmdFlags.None, null, "//MobileApp/Main", 0);
Client c = Repository.GetClient("main_ws",opts);
Repository.CreateClient(c, null);

See Also

Repository Class
CreateClient Overload
Perforce.P4 Namespace
Perforce.P4..::..ClientCmdFlags


CreateDepot Method

[image] [image]

Perforce .NET API
Repository..::..CreateDepot Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDepot(Depot) | Create a new depot in the repository.
Public method | CreateDepot(Depot, Options) | Create a new depot in the repository.

See Also

Repository Class
Repository Members


CreateDepot Method (Depot)

[image]

Perforce .NET API
Repository..::..CreateDepot Method (Depot)
Repository Class Example See Also Send Feedback
Create a new depot in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Depot CreateDepot(
    Depot depot
)
Visual Basic
Public Function CreateDepot ( _
    depot As Depot _
) As Depot
Visual C++
public:
Depot^ CreateDepot(
    Depot^ depot
)

Parameters

depot
Type: Perforce.P4..::..Depot
Depot specification for the new depot

Return Value

The Depot object if new depot was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help depot

depot -- Create or edit a depot specification

p4 depot name
p4 depot -d [-f] name
p4 depot -o name
p4 depot -i

Create a new depot specification or edit an existing depot
specification. The specification form is put into a temporary file
and the editor (configured by the environment variable $P4EDITOR)
is invoked.

The depot specification contains the following fields:

Depot: The name of the depot. This name cannot be the same as
any branch, client, or label name.

Owner: The user who created this depot.

Date: The date that this specification was last modified.

Description: A short description of the depot (optional).

Type: One of the types: 'local', 'stream', 'remote', 'spec',
'archive', or 'unload'.

A 'local' depot (the default) is managed directly by
the server and its files reside in the server's root
directory.

A 'stream' depot is a local depot dedicated to the
storage of files in a stream.

A 'remote' depot refers to files in another Perforce
server.

A 'spec' depot automatically archives all edited forms
(branch, change, client, depot, group, job, jobspec,
protect, triggers, typemap, and user) in special,
read-only files. The files are named:
//depotname/formtype/name[suffix]. Updates to jobs made
by the 'p4 change', 'p4 fix', and 'p4 submit' commands
are also saved, but other automatic updates such as
as access times or opened files (for changes) are not.
A server can contain only one 'spec' depot.

A 'archive' depot defines a storage location to which
obsolete revisions may be relocated.

An 'unload' depot defines a storage location to which
database records may be unloaded and from which they
may be reloaded.

Address: For remote depots, the $P4PORT (connection address)
of the remote server.

Suffix: For spec depots, the optional suffix to be used
for generated paths. The default is '.p4s'.

Map: Path translation information, in the form of a file
pattern with a single ... in it. For local depots,
this path is relative to the server's root directory
or to server.depot.root if it has been configured
(Example: depot/...). For remote depots, this path
refers to the remote server's namespace
(Example: //depot/...).

SpecMap: For spec depots, the optional description of which
specs should be saved, as one or more patterns.

The -d flag deletes the specified depot. If any files reside in the
depot, they must be removed with 'p4 obliterate' before deleting the
depot. If any archive files remain in the depot directory, they may
be referenced by lazy copies in other depots; use 'p4 snap' to break
those linkages. Snap lazy copies prior to obliterating the old depot
files to allow the obliterate command to remove any unreferenced
archives from the depot directory. If the depot directory is not
empty, you must specify the -f flag to delete the depot.

The -o flag writes the depot specification to standard output. The
user's editor is not invoked.

The -i flag reads a depot specification from standard input. The
user's editor is not invoked.

Examples

To create a streams depot named MobileApp:
CopyC#
Depot d = new Depot();

d.Id = "MobileApp";
d.Description = "Stream depot for mobile app project";
d.Owner = "admin";
d.Type = DepotType.Stream;
d.Map = "MobileApp/...";

Depot MobileApp = Repository.CreateDepot(d);

See Also

Repository Class
CreateDepot Overload


CreateDepot Method (Depot, Options)

[image]

Perforce .NET API
Repository..::..CreateDepot Method (Depot, Options)
Repository Class Example See Also Send Feedback
Create a new depot in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Depot CreateDepot(
    Depot depot,
    Options options
)
Visual Basic
Public Function CreateDepot ( _
    depot As Depot, _
    options As Options _
) As Depot
Visual C++
public:
Depot^ CreateDepot(
    Depot^ depot,
    Options^ options
)

Parameters

depot
Type: Perforce.P4..::..Depot
Depot specification for the new depot
options
Type: Perforce.P4..::..Options
The '-i' flag is required when creating a new depot

Return Value

The Depot object if new depot was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help depot

depot -- Create or edit a depot specification

p4 depot name
p4 depot -d [-f] name
p4 depot -o name
p4 depot -i

Create a new depot specification or edit an existing depot
specification. The specification form is put into a temporary file
and the editor (configured by the environment variable $P4EDITOR)
is invoked.

The depot specification contains the following fields:

Depot: The name of the depot. This name cannot be the same as
any branch, client, or label name.

Owner: The user who created this depot.

Date: The date that this specification was last modified.

Description: A short description of the depot (optional).

Type: One of the types: 'local', 'stream', 'remote', 'spec',
'archive', or 'unload'.

A 'local' depot (the default) is managed directly by
the server and its files reside in the server's root
directory.

A 'stream' depot is a local depot dedicated to the
storage of files in a stream.

A 'remote' depot refers to files in another Perforce
server.

A 'spec' depot automatically archives all edited forms
(branch, change, client, depot, group, job, jobspec,
protect, triggers, typemap, and user) in special,
read-only files. The files are named:
//depotname/formtype/name[suffix]. Updates to jobs made
by the 'p4 change', 'p4 fix', and 'p4 submit' commands
are also saved, but other automatic updates such as
as access times or opened files (for changes) are not.
A server can contain only one 'spec' depot.

A 'archive' depot defines a storage location to which
obsolete revisions may be relocated.

An 'unload' depot defines a storage location to which
database records may be unloaded and from which they
may be reloaded.

Address: For remote depots, the $P4PORT (connection address)
of the remote server.

Suffix: For spec depots, the optional suffix to be used
for generated paths. The default is '.p4s'.

Map: Path translation information, in the form of a file
pattern with a single ... in it. For local depots,
this path is relative to the server's root directory
or to server.depot.root if it has been configured
(Example: depot/...). For remote depots, this path
refers to the remote server's namespace
(Example: //depot/...).

SpecMap: For spec depots, the optional description of which
specs should be saved, as one or more patterns.

The -d flag deletes the specified depot. If any files reside in the
depot, they must be removed with 'p4 obliterate' before deleting the
depot. If any archive files remain in the depot directory, they may
be referenced by lazy copies in other depots; use 'p4 snap' to break
those linkages. Snap lazy copies prior to obliterating the old depot
files to allow the obliterate command to remove any unreferenced
archives from the depot directory. If the depot directory is not
empty, you must specify the -f flag to delete the depot.

The -o flag writes the depot specification to standard output. The
user's editor is not invoked.

The -i flag reads a depot specification from standard input. The
user's editor is not invoked.

Examples

To create a streams depot named MobileApp:
CopyC#
Depot d = new Depot();

d.Id = "MobileApp";
d.Description = "Stream depot for mobile app project";
d.Owner = "admin";
d.Type = DepotType.Stream;
d.Map = "MobileApp/...";

Depot MobileApp = Repository.CreateDepot(d, null);

See Also

Repository Class
CreateDepot Overload
Perforce.P4 Namespace
Perforce.P4..::..DepotCmdFlags


CreateGroup Method

[image] [image]

Perforce .NET API
Repository..::..CreateGroup Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGroup(Group) | Create a new group in the repository.
Public method | CreateGroup(Group, Options) | Create a new group in the repository.

See Also

Repository Class
Repository Members


CreateGroup Method (Group)

[image]

Perforce .NET API
Repository..::..CreateGroup Method (Group)
Repository Class Example See Also Send Feedback
Create a new group in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group CreateGroup(
    Group group
)
Visual Basic
Public Function CreateGroup ( _
    group As Group _
) As Group
Visual C++
public:
Group^ CreateGroup(
    Group^ group
)

Parameters

group
Type: Perforce.P4..::..Group
Group specification for the new group

Return Value

The Group object if new group was created, null if creation failed

Examples

To create the group 'Mygroup' with the owner 'Bob' and a users 'Ted' and 'Alex':
CopyC#
string targetGroup = "Mygroup";
Group group = new Group();
group.Id = targetGroup;
group.UserNames = new  List<string> { "Ted", "Alex" };
group.OwnerNames = new  List<string> { "Bob" };
_repository.CreateGroup(group);

See Also

Repository Class
CreateGroup Overload


CreateGroup Method (Group, Options)

[image]

Perforce .NET API
Repository..::..CreateGroup Method (Group, Options)
Repository Class Example See Also Send Feedback
Create a new group in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group CreateGroup(
    Group group,
    Options options
)
Visual Basic
Public Function CreateGroup ( _
    group As Group, _
    options As Options _
) As Group
Visual C++
public:
Group^ CreateGroup(
    Group^ group,
    Options^ options
)

Parameters

group
Type: Perforce.P4..::..Group
Group specification for the new group
options
Type: Perforce.P4..::..Options
The '-i' flags are required when creating a new group

Return Value

The Group object if new group was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help group

group -- Change members of user group

p4 group [-a|-A] name
p4 group -d [-a] name
p4 group -o name
p4 group -i [-a|-A]

Create a group or modify the membership of an existing group.
A group can contain users and other groups. The group specification
is put into a temporary file and the editor (configured by the
environment variable $P4EDITOR) is invoked.

A group exists when it has any users or other groups in it, and
ceases to exist if all users and groups in it are removed.

Each group has MaxResults, MaxScanRows, and MaxLockTime fields,
which limit the resources committed to operations performed by
members of the group. For these fields, 'unlimited' or 'unset'
means no limit for that group. An individual user's limit is the
highest of any group with a limit to which he belongs, unlimited if
any of his groups has 'unlimited' for that field, or unlimited
if he belongs to no group with a limit. See 'p4 help maxresults'
for more information on MaxResults, MaxScanRows and MaxLockTime.

Each group also has a Timeout field, which specifies how long (in
seconds) a 'p4 login' ticket remains valid. A value of 'unset' or
'unlimited' is equivalent to no timeout. An individual's timeout is
the highest of any group with a limit to which he belongs, unlimited
if any of his groups has 'unlimited' for the timeout value, or
unlimited if he belongs to no group with a limit. See 'p4 help login'
for more information.

Each group has a PasswordTimeout field, which determines how long a
password remains valid for members of the group.

A group may be synchronized with an LDAP group by setting the three
fields: LdapConfig, LdapSearchQuery and LdapUserAttribute. This takes
the LDAP configuration (see 'p4 ldap') specified by LdapConfig and uses
it to execute the query stored by LdapSearchQuery. The LDAP attribute
specified by LdapUserAttribute is taken to be user's username and is
added to the group's user list. At least one group owner must be set if
these LDAP fields are used. If the LDAP server requires login for
read-only queries, then the LDAP configuration must contain valid bind
credentials in the LDAP spec's SearchBindDN and SearchPasswd fields

The -d flag deletes a group.

The -o flag writes the group specification to standard output. The
user's editor is not invoked.

The -i flag reads a group specification from standard input. The
user's editor is not invoked. The new group specification replaces
the previous one.

The -a flag enables a user without 'super' access to modify the group
if that user is an 'owner' of that group. Group owners are specified
in the 'Owners' field of the group spec.

The -A flag enables a user with 'admin' access to add a new group.
Existing groups may not be modified when this flag is used.

All commands that require access granted by 'p4 protect' consider a
user's groups when calculating access levels.

'p4 group' requires 'super' access granted by 'p4 protect' unless
invoked with the '-a' or '-A' flag by a qualified user.

Examples

To create the group 'Mygroup' with the owner 'Bob' and a user 'Ted' when connected as super user:
CopyC#
string targetGroup = "Mygroup";
Group group = new Group();
group.Id = targetGroup;
group.UserNames = new  List<string> { "Ted" };
group.OwnerNames = new List<string> { "Bob" };
_repository.CreateGroup(group, null);
 To create a group "everyone" when connected as a user with admin level rights:
CopyC#
string targetGroup = "everyone";
Group group = new Group();
group.Id = targetGroup;
group.UserNames = new  List<string> { "Ted" };
group.OwnerNames = new List<string> { "Bob" };
_repository.CreateGroup(group, new Options(GroupCmdFlags.AdminAdd));

See Also

Repository Class
CreateGroup Overload
Perforce.P4 Namespace
Perforce.P4..::..GroupCmdFlags


CreateJob Method

[image] [image]

Perforce .NET API
Repository..::..CreateJob Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateJob(Job) | Create a new job in the repository.
Public method | CreateJob(Job, Options) | Create a new job in the repository.

See Also

Repository Class
Repository Members


CreateJob Method (Job)

[image]

Perforce .NET API
Repository..::..CreateJob Method (Job)
Repository Class Example See Also Send Feedback
Create a new job in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Job CreateJob(
    Job job
)
Visual Basic
Public Function CreateJob ( _
    job As Job _
) As Job
Visual C++
public:
Job^ CreateJob(
    Job^ job
)

Parameters

job
Type: Perforce.P4..::..Job
Job specification for the new job

Return Value

The Job object if new job was created, null if creation failed

Examples

To create a new job name of the form jobNNNNNN:
CopyC#
Job job = new Job();
job.Id = new;
job.Add("Status", "open");
job.Add("User", "admin");
job.Add("Description", "this is a test job");
Job job = _repository.CreateJob( job );

See Also

Repository Class
CreateJob Overload


CreateJob Method (Job, Options)

[image]

Perforce .NET API
Repository..::..CreateJob Method (Job, Options)
Repository Class Example See Also Send Feedback
Create a new job in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Job CreateJob(
    Job job,
    Options options
)
Visual Basic
Public Function CreateJob ( _
    job As Job, _
    options As Options _
) As Job
Visual C++
public:
Job^ CreateJob(
    Job^ job,
    Options^ options
)

Parameters

job
Type: Perforce.P4..::..Job
Job specification for the new job
options
Type: Perforce.P4..::..Options
The '-i' flags is needed when creating a new job

Return Value

The Job object if new job was created, null if creation failed

Remarks

The '-i' flags is added if not specified by the caller

p4 help job

job -- Create or edit a job (defect) specification

p4 job [-f] [jobName]
p4 job -d jobName
p4 job -o [jobName]
p4 job -i [-f]

The 'p4 job' command creates and edits job specifications using an
ASCII form. A job is a defect, enhancement, or other unit of
intended work.The 'p4 fix' command associates changelists with jobs.

With no arguments, 'p4 job' creates an empty job specification
and invokes the user's editor. When the specification is saved,
a job name of the form jobNNNNNN is assigned. If the jobName
parameter is specified on the command line, the job is created or
opened for editing.

As jobs are entered or updated, all fields are indexed for searching
Text fields are broken into individual alphanumeric words (punctuation
and whitespace are ignored) and each word is case-folded and entered
into the word index. Date fields are converted to an internal
representation (seconds since 1970/01/01 00:00:00) and entered
into the date index.

The fields that compose a job are defined by the 'p4 jobspec' command.
Perforce provides a default job specification that you can edit.

The -d flag deletes the specified job. You cannot delete a job if
it has pending or submitted fixes associated with it.

The -o flag writes the job specification to the standard output.
The user's editor is not invoked.

The -i flag reads a job specification from the standard input. The
user's editor is not invoked.

The -f flag enables you set fields that are read-only by default.
The -f flag requires 'admin' access, which is granted using the
'p4 protect' command.

Examples

To create a new job with a name 'Myjob':
CopyC#
Job job = new Job();
job.Id = "Myjob";
job.Add("Status", "open");
job.Add("User", "admin");
job.Add("Description", "this is a test job");
Job job = _repository.CreateJob( job, null);
 To create a job with name of the form jobNNNNNN:
CopyC#
Job job = new Job();
job.Id = "new";
job.Add("Status", "open");
job.Add("User", "admin");
job.Add("Description", "this is a test job");
Job job = _repository.CreateJob( job, JobCmdFlags.Input);

See Also

Repository Class
CreateJob Overload
Perforce.P4 Namespace
Perforce.P4..::..JobCmdFlags


CreateLabel Method

[image] [image]

Perforce .NET API
Repository..::..CreateLabel Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLabel(Label) | Create a new label in the repository.
Public method | CreateLabel(Label, Options) | Create a new label in the repository.

See Also

Repository Class
Repository Members


CreateLabel Method (Label)

[image]

Perforce .NET API
Repository..::..CreateLabel Method (Label)
Repository Class Example See Also Send Feedback
Create a new label in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Label CreateLabel(
    Label label
)
Visual Basic
Public Function CreateLabel ( _
    label As Label _
) As Label
Visual C++
public:
Label^ CreateLabel(
    Label^ label
)

Parameters

label
Type: Perforce.P4..::..Label
Label specification for the new label

Return Value

The Label object if new label was created, null if creation failed

Examples

To create a new label:
CopyC#
Label l = new Label();
l.Id = "newLabel";
l.Owner = "admin";
l.Description = "created by admin";
l.Options = "unlocked";
l.ViewMap = new ViewMap();
string v0 = "//depot/main/...";
string v1 = "//depot/rel1/...";
string v2 = "//depot/rel2/...";
string v3 = "//depot/dev/...";
l.ViewMap.Add(v0);
l.ViewMap.Add(v1);
l.ViewMap.Add(v2);
l.ViewMap.Add(v3);
Label newLabel = rep.CreateLabel(l, null);

See Also

Repository Class
CreateLabel Overload


CreateLabel Method (Label, Options)

[image]

Perforce .NET API
Repository..::..CreateLabel Method (Label, Options)
Repository Class Example See Also Send Feedback
Create a new label in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Label CreateLabel(
    Label label,
    Options options
)
Visual Basic
Public Function CreateLabel ( _
    label As Label, _
    options As Options _
) As Label
Visual C++
public:
Label^ CreateLabel(
    Label^ label,
    Options^ options
)

Parameters

label
Type: Perforce.P4..::..Label
Label specification for the new label
options
Type: Perforce.P4..::..Options
The '-i' flag is required when creating a new label

Return Value

The Label object if new label was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help label

label -- Create or edit a label specification

p4 label [-f -g -t template] name
p4 label -d [-f -g] name
p4 label -o [-t template] name
p4 label -i [-f -g]

Create or edit a label. The name parameter is required. The
specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

The label specification form contains the following fields:

Label: The label name (read only.)

Owner: The user who created this label. Can be changed.

Update: The date that this specification was last modified.

Access: The date of the last 'labelsync' or use of '@label'
referencing this label.

Description: A short description of the label (optional).

Options: Flags to change the label behavior.

locked Prevents users other than the label owner
unlocked from changing the specification. Prevents
the label from being deleted. Prevents the
owner from running 'p4 labelsync'. For a
loaded label, prevents 'p4 unload'.

autoreload For a static label, indicates where label
noautoreload revisions are stored. Specify 'noautoreload'
to indicate that the revisions should be
stored in the db.label table. Specify
'autoreload' to indicate that the revisions
should be stored in the unload depot.

Revision: An optional revision specification for an automatic
label. Enclose in double quotes if it contains the
# (form comment) character. An automatic label can
be treated as a pure alias of a single revision
specification (excluding @label) provided that the
View mapping is empty.

View: A mapping that selects files from the depot. The
default view selects all depot files. Only the left
side of the mapping is used for labels. Leave this
field blank when creating an automatic label as
a pure alias. See 'p4 help views'.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on any server.

A label is a named collection of revisions. A label is either
automatic or static. An automatic label refers to the revisions
given in the View: and Revision: fields. A static label refers to
the revisions that are associated with the label using the 'p4 tag'
or 'p4 labelsync' commands. A static label cannot have a Revison:
field. See 'p4 help revisions' for information on using labels as
revision specifiers.

Only the label owner can run 'p4 labelsync', and only if the label
is unlocked. A label without an owner can be labelsync'd by any user.

Flag -d deletes the specified label. You cannot delete a locked label.
The -f flag forces the delete.

The -o flag writes the label specification to standard output. The
user's editor is not invoked.

The -i flag reads a label specification from standard input. The
user's editor is not invoked.

The -t flag copies the view and options from the template label to
the new label.

The -f flag forces the deletion of a label. By default, locked labels
can only be deleted by their owner. The -f flag also permits the
Last Modified date to be set. The -f flag requires 'admin' access,
which is granted by 'p4 protect'.

The -g flag should be used on an Edge Server to update a global
label. Without -g, the label definition is visible only to users
of this Edge Server. Configuring rpl.labels.global=1 reverses this
default and causes this flag to have the opposite meaning.

Examples

To create a new label:
CopyC#
Label l = new Label();
l.Id = "newLabel";
l.Owner = "admin";
l.Description = "created by admin";
l.Options = "unlocked";
l.ViewMap = new ViewMap();
string v0 = "//depot/main/...";
string v1 = "//depot/rel1/...";
string v2 = "//depot/rel2/...";
string v3 = "//depot/dev/...";
l.ViewMap.Add(v0);
l.ViewMap.Add(v1);
l.ViewMap.Add(v2);
l.ViewMap.Add(v3);
Label newLabel = rep.CreateLabel(l, null);
 To create a label using another label as a template:
CopyC#
Label newLabel2 = rep.CreateLabel(newLabel,
    new LabelCmdOptions(LabelCmdFlags.None, newLabel.Id));

See Also

Repository Class
CreateLabel Overload


CreateStream Method

[image] [image]

Perforce .NET API
Repository..::..CreateStream Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateStream(Stream) | Create a new stream in the repository.
Public method | CreateStream(Stream, Options) | Create a new stream in the repository.

See Also

Repository Class
Repository Members


CreateStream Method (Stream)

[image]

Perforce .NET API
Repository..::..CreateStream Method (Stream)
Repository Class Example See Also Send Feedback
Create a new stream in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream CreateStream(
    Stream stream
)
Visual Basic
Public Function CreateStream ( _
    stream As Stream _
) As Stream
Visual C++
public:
Stream^ CreateStream(
    Stream^ stream
)

Parameters

stream
Type: Perforce.P4..::..Stream
Stream specification for the new stream

Return Value

The Stream object if new stream was created, null if creation failed

Examples

To create a new locked release type stream in the repository, with ignored and remapped paths:
CopyC#
Stream s = new Stream();
string targetId = "//Rocket/rel1";
s.Id = targetId;
s.Type = StreamType.Release;
s.Options = new StreamOptionEnum(StreamOption.Locked | StreamOption.NoToParent);
s.Parent = new DepotPath("//Rocket/main");
s.Name = "Release1";
s.Paths = new ViewMap();
MapEntry p1 = new MapEntry(MapType.Import, new DepotPath("..."), null);
s.Paths.Add(p1);
MapEntry p2 = new MapEntry(MapType.Share, new DepotPath("core/gui/..."), null);
s.Paths.Add(p2);
s.OwnerName = "admin";
s.Description = "release stream for first release";
s.Ignored = new ViewMap();
MapEntry ig1 = new MapEntry(MapType.Include, new DepotPath(".tmp"), null);
s.Ignored.Add(ig1);
MapEntry ig2 = new MapEntry(MapType.Include, new DepotPath("/bmps/..."), null);
s.Ignored.Add(ig2);
MapEntry ig3 = new MapEntry(MapType.Include, new DepotPath("/test"), null);
s.Ignored.Add(ig3);
MapEntry ig4 = new MapEntry(MapType.Include, new DepotPath(".jpg"), null);
s.Ignored.Add(ig4);
s.Remapped = new ViewMap();
MapEntry re1 = new MapEntry(MapType.Include, new DepotPath("..."), new DepotPath("x/..."));
s.Remapped.Add(re1);
MapEntry re2 = new MapEntry(MapType.Include, new DepotPath("y/*"), new DepotPath("y/z/*"));
s.Remapped.Add(re2);
MapEntry re3 = new MapEntry(MapType.Include, new DepotPath("ab/..."), new DepotPath("a/..."));
s.Remapped.Add(re3);

Stream newStream = rep.CreateStream(s);

See Also

Repository Class
CreateStream Overload


CreateStream Method (Stream, Options)

[image]

Perforce .NET API
Repository..::..CreateStream Method (Stream, Options)
Repository Class Example See Also Send Feedback
Create a new stream in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream CreateStream(
    Stream stream,
    Options options
)
Visual Basic
Public Function CreateStream ( _
    stream As Stream, _
    options As Options _
) As Stream
Visual C++
public:
Stream^ CreateStream(
    Stream^ stream,
    Options^ options
)

Parameters

stream
Type: Perforce.P4..::..Stream
Stream specification for the new stream
options
Type: Perforce.P4..::..Options
The '-i' flag is required when creating a new stream

Return Value

The Stream object if new stream was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help stream

stream -- Create, delete, or modify a stream specification

p4 stream [-P parent] -t type name
p4 stream [-f] [-d] [-o [-v]] [-P parent] -t type name
p4 stream -i [-f]

A stream specification ('spec') names a path in a stream depot to be
treated as a stream. (See 'p4 help streamintro'.) The spec also
defines the stream's lineage, its view, and its expected flow of
change.

The 'p4 stream' command puts the stream spec into a temporary file and
invokes the editor configured by the environment variable $P4EDITOR.
When creating a stream, the type of the stream must be specified with
the '-t' flag. Saving the file creates or modifies the stream spec.

Creating a stream spec does not branch a new stream. To branch a
stream, use 'p4 copy -r -S stream', where 'stream' is the name of a
stream spec.

The stream spec contains the following fields:

Stream: The stream's path in a stream depot, of the form
//depotname/streamname. This is both the name of the stream
spec and the permanent, unique identifier of the stream.

Update: The date this stream spec was last changed.

Access: The date of the last command used with this spec.

Owner: The stream's owner. A stream can be owned by a user, or
owned by a group. Can be changed.

Name: An alternate name of the stream, for use in display outputs.
Defaults to the 'streamname' portion of the stream path.
Can be changed.

Parent: The parent of this stream. Can be 'none' if the stream type
is 'mainline', otherwise must be set to an existing stream
identifier, of the form //depotname/streamname.
Can be changed.

Type: 'mainline', 'virtual', 'development', 'release' or 'task'.
Defines the role of a stream: A 'mainline' may not have a
parent. A 'virtual' stream is not a stream but an alternate
view of its parent stream. The 'development' and 'release'
streams have controlled flow. Can be changed. A 'task'
stream is a lightweight short-lived stream that only
promotes edited files to the repository; branched and
integrated files are stored in shadow tables that are
removed when the task stream is deleted or unloaded.

Flow control is provided by 'p4 copy -S' and 'p4 merge -S'.
These commands restrict the flow of change as follows:

Stream Type Direction of flow Allowed with
----------- ----------------- ------------
development to parent stream 'p4 copy'
task to parent stream 'p4 copy'
release to parent stream 'p4 merge'
development from parent stream 'p4 merge'
release from parent stream 'p4 copy'

Description: An optional description of the stream.

Options: Flags to configure stream behavior. Defaults are marked *:

unlocked * Indicates whether the stream spec is locked
locked against modifications. If locked, the spec
may not be deleted, and only its owner or
group users can modify it.

allsubmit * Indicates whether all users or only the
ownersubmit owner (or group users) of the stream may
submit changes to the stream path.

toparent * Indicates if controlled flow from the
notoparent stream to its parent is expected to occur.

fromparent * Indicates if controlled flow to the stream
nofromparent from its parent is expected to occur.

mergedown * Indicates if merge flow is restricted or
mergeany merge is permitted from any other stream.

The [no]fromparent and [no]toparent options determine if
'p4 copy -S' and 'p4 merge -S' allow change to flow between
a stream and its parent. A 'virtual' stream must have its
flow options set as 'notoparent' and 'nofromparent'. Flow
options are ignored for 'mainline' streams.

Paths: One or more lines that define file paths in the stream view.
Each line is of the form:

<path_type> <view_path> [<depot_path>]

where <path_type> is a single keyword, <view_path> is a file
path with no leading slashes, and the optional <depot_path>
is a file path beginning with '//'. Both <view_path> and
<depot_path> may contain trailing wildcards, but no leading
or embedded wildcards. Lines in the Paths field may appear
in any order. A duplicated <view_path> overrides its
preceding entry.

For example:

share src/...
import lib/abc/... //over/there/abc/...
isolate bin/*

Default is:

share ...

The <path_type> keyword must be one of:

share: <view_path> will be included in client views and
in branch views. Files in this path are accessible
to workspaces, can be submitted to the stream, and
can be integrated with the parent stream.

isolate: <view_path> will be included in client views but
not in branch views. Files in this path are
accessible to workspaces, can be submitted to the
stream, but are not integratable with the parent
stream.

import: <view_path> will be included in client views but
not in branch views. Files in this path are mapped
as in the parent stream's view (the default) or to
<depot_path> (optional); they are accessible to
workspaces, but can not be submitted or integrated
to the stream. If <depot_path> is used it may
include a changelist specifier; clients of that
stream will be limited to seeing revisions at that
change or lower within that depot path.

import+: <view_path> same as 'import' except that files can
be submitted to the import path.

exclude: <view_path> will be excluded from client views
and branch views. Files in this path are not
accessible to workspaces, and can't be submitted
or integrated to the stream.

Paths are inherited by child stream views. A child stream's
paths can downgrade the inherited view, but not upgrade it.
(For instance, a child stream can downgrade a shared path to
an isolated path, but it can't upgrade an isolated path to a
shared path.) Note that <depot_path> is relevant only when
<path_type> is 'import'.

Remapped: Optional; one or more lines that define how stream view paths
are to be remapped in client views. Each line is of the form:

<view_path_1> <view_path_2>

where <view_path_1> and <view_path_2> are Perforce view paths
with no leading slashes and no leading or embedded wildcards.
For example:

... x/...
y/* y/z/*

Line ordering in the Remapped field is significant; if more
than one line remaps the same files, the later line has
precedence. Remapping is inherited by child stream client
views.

Ignored: Optional; a list of file or directory names to be ignored in
client views. For example:

/tmp # ignores files named 'tmp'
/tmp/... # ignores dirs named 'tmp'
.tmp # ignores file names ending in '.tmp'

Lines in the Ignored field may appear in any order. Ignored
names are inherited by child stream client views.

The -d flag causes the stream spec to be deleted. A stream spec may
not be deleted if it is referenced by child streams or stream clients.
Deleting a stream spec does not remove stream files, but it does mean
changes can no longer be submitted to the stream's path.

The -o flag causes the stream spec to be written to the standard
output. The user's editor is not invoked. -v may be used with -o to
expose the automatically generated client view for this stream.
('p4 help branch' describes how to expose the branch view.)

The -P flag can be used to insert a value into the Parent field of a
new stream spec. It has no effect on an existing spec.

The -t flag is used to insert a value into the type field of a
new stream spec and to adjust the default fromparent option
for a new 'release' -type stream. The flag has no effect on an
existing spec.

The -i flag causes a stream spec to be read from the standard input.
The user's editor is not invoked.

The -f flag allows a user other than the owner to modify or delete a
locked stream. It requires 'admin' access granted by 'p4 protect'.

Examples

To create a new mainline stream:
CopyC#
Stream main  = new Stream();
string mainTargetId = "//Rocket/mainline";
main.Id = mainTargetId;
main.Type = StreamType.Mainline;
main.Parent = new DepotPath("none");
main.Options = new StreamOptionEnum(StreamOption.None);
main.Name = "mainline";
main.Paths = new ViewMap();
MapEntry p1 = new MapEntry(MapType.Import, new DepotPath("..."), null);
main.Paths.Add(p1);
MapEntry p2 = new MapEntry(MapType.Share, new DepotPath("core/gui/..."), null);
main.Paths.Add(p2);
main.OwnerName = "admin";
Stream mainline = rep.CreateStream(main, null);
 To create a new development type stream with the parent //Rocket/mainline:
CopyC#
Stream dev = new Stream();
string developmentTargetId = "//Rocket/dev";
dev.Id = developmentTargetId;
dev.Type = StreamType.Development;
dev.Parent = new DepotPath("//Rocket/mainline");
dev.Name = "releasetest";
dev.Options = new StreamOptionEnum(StreamOption.None);
dev.Paths = new ViewMap();
MapEntry devp1 = new MapEntry(MapType.Share, new DepotPath("..."), null);
dev.Paths.Add(devp1);
dev.OwnerName = "admin";
Stream dev1 = rep.CreateStream(dev, null);

See Also

Repository Class
CreateStream Overload
Perforce.P4 Namespace
Perforce.P4..::..StreamCmdFlags


CreateUser Method

[image] [image]

Perforce .NET API
Repository..::..CreateUser Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateUser(User) | Create a new user in the repository.
Public method | CreateUser(User, Options) | Create a new user in the repository.

See Also

Repository Class
Repository Members


CreateUser Method (User)

[image]

Perforce .NET API
Repository..::..CreateUser Method (User)
Repository Class Example See Also Send Feedback
Create a new user in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User CreateUser(
    User user
)
Visual Basic
Public Function CreateUser ( _
    user As User _
) As User
Visual C++
public:
User^ CreateUser(
    User^ user
)

Parameters

user
Type: Perforce.P4..::..User
User specification for the new user

Return Value

The User object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Examples

To create a user with the username bsmith (when connected with Connection.UserName = "bsmith"):
CopyC#
User u = new User();
u.Id = "bsmith";
u.FullName = "Brian Smith";
u.EmailAddress = "bsmith@hotmail.com";

u = Repository.CreateUser(u);

See Also

Repository Class
CreateUser Overload
Perforce.P4 Namespace
Perforce.P4..::..UserCmdFlags


CreateUser Method (User, Options)

[image]

Perforce .NET API
Repository..::..CreateUser Method (User, Options)
Repository Class Example See Also Send Feedback
Create a new user in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User CreateUser(
    User user,
    Options options
)
Visual Basic
Public Function CreateUser ( _
    user As User, _
    options As Options _
) As User
Visual C++
public:
User^ CreateUser(
    User^ user,
    Options^ options
)

Parameters

user
Type: Perforce.P4..::..User
User specification for the new user
options
Type: Perforce.P4..::..Options
The '-f' and '-i' flags are required when creating a new user

Return Value

The User object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Examples

To create a user with the username bsmith (when connected with Connection.UserName = "bsmith"):
CopyC#
User u = new User();
u.Id = "bsmith";
u.FullName = "Brian Smith";
u.EmailAddress = "bsmith@hotmail.com";

u = Repository.CreateUser(u, null);
 To create a user with the username bsmith (when connected with a user that has super access):
CopyC#
User u = new User();
u.Id = "bsmith";
u.FullName = "Brian Smith";
u.EmailAddress = "bsmith@hotmail.com";

UserCmdOptions opts = new UserCmdOptions(UserCmdFlags.Force);

u = Repository.CreateUser(u, opts);

See Also

Repository Class
CreateUser Overload
Perforce.P4 Namespace
Perforce.P4..::..UserCmdFlags


DeleteBranchSpec Method

[image]

Perforce .NET API
Repository..::..DeleteBranchSpec Method
Repository Class Example See Also Send Feedback
Delete a branch from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteBranchSpec(
    BranchSpec branch,
    Options options
)
Visual Basic
Public Sub DeleteBranchSpec ( _
    branch As BranchSpec, _
    options As Options _
)
Visual C++
public:
void DeleteBranchSpec(
    BranchSpec^ branch,
    Options^ options
)

Parameters

branch
Type: Perforce.P4..::..BranchSpec
The branch to be deleted
options
Type: Perforce.P4..::..Options
The '-f' and '-d' flags are valid when deleting an existing branch

Examples

To delete a branch spec owned by you [-d implied]:
CopyC#
BranchSpec deleteBranchSpec = new BranchSpec();
deleteBranchSpec.Id = "newBranchSpec";
_repository.DeleteBranchSpec(deleteBranchSpec, null);
 To delete a branch owned by someone other than you [-d implied] [-f requires admin privileges]:
CopyC#
BranchSpec deleteBranchSpec = new BranchSpec();
deleteBranchSpec.Id = "newBranchSpec";
Options opts = new Options(BranchSpecsCmdFlags.Force);
_repository.DeleteBranchSpec(deleteBranchSpec, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..BranchSpecCmdFlags


DeleteChangelist Method

[image]

Perforce .NET API
Repository..::..DeleteChangelist Method
Repository Class Example See Also Send Feedback
Delete a change from the repository
Get the record for an existing change from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteChangelist(
    Changelist change,
    Options options
)
Visual Basic
Public Sub DeleteChangelist ( _
    change As Changelist, _
    options As Options _
)
Visual C++
public:
void DeleteChangelist(
    Changelist^ change,
    Options^ options
)

Parameters

change
Type: Perforce.P4..::..Changelist
The change to be deletedChangelist name
options
Type: Perforce.P4..::..Options
The '-f' and '-s' flags are valid when deleting an existing change'-f' is a valid flag to use when deleting an existing change

Return Value

The Changelist object if new change was found, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To delete pending changelist 34:
CopyC#
Repository.DeleteChangelist(34,null);
 To delete pending changelist 34 as an admin user who is not owner of the change:
CopyC#
ChangeCmdOptions opts = new ChangeCmdOptions(ChangeCmdFlags.Force);
Repository.DeleteChangelist(34, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..ChangeCmdFlags


DeleteClient Method

[image]

Perforce .NET API
Repository..::..DeleteClient Method
Repository Class Example See Also Send Feedback
Delete a client from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteClient(
    Client client,
    Options options
)
Visual Basic
Public Sub DeleteClient ( _
    client As Client, _
    options As Options _
)
Visual C++
public:
void DeleteClient(
    Client^ client,
    Options^ options
)

Parameters

client
Type: Perforce.P4..::..Client
The client to be deleted
options
Type: Perforce.P4..::..Options
Only the '-f' flag is valid when deleting an existing client

Remarks

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

Examples

To delete a client named main_ws with the user who owns it:
CopyC#
Client c = Repository.GetClient("main_ws");
Repository.DeleteClient(c, null);
 To delete a locked client named main_ws with an admin user:
CopyC#
Client c = Repository.GetClient("main_ws", null);

ClientCmdOptions opts = new ClientCmdOptions(ClientCmdFlags.Force);
rep.DeleteClient(c, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..ClientCmdFlags


DeleteCounter Method

[image]

Perforce .NET API
Repository..::..DeleteCounter Method
Repository Class Example See Also Send Feedback
Delete a Perforce counter from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Object DeleteCounter(
    string name,
    Options options
)
Visual Basic
Public Function DeleteCounter ( _
    name As String, _
    options As Options _
) As Object
Visual C++
public:
Object^ DeleteCounter(
    String^ name,
    Options^ options
)

Parameters

name
Type: System..::..String
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help counter

counter -- Display, set, or delete a counter

p4 counter name
p4 counter [-f] name value
p4 counter [-f] -d name
p4 counter [-f] -i name
p4 counter [-f] -m [ pair list ]

The first form displays the value of the specified counter.

The second form sets the counter to the specified value.

The third form deletes the counter. This option usually has the
same effect as setting the counter to 0.

The -f flag sets or deletes counters used by Perforce, which are
listed by 'p4 help counters'. Important: Never set the 'change'
counter to a value that is lower than its current value.

The -i flag increments a counter by 1 and returns the new value.
This option is used instead of a value argument and can only be
used with numeric counters.

The fifth form allows multiple operations in one command.
With this, the list is pairs of arguments. Each pair is either
counter value or '-' counter. To set a counter use a name and value.
To delete a counter use a '-' followed by the name.

Counters can be assigned textual values as well as numeric ones,
despite the name 'counter'.

'p4 counter' requires 'review' access granted by 'p4 protect'.
The -f flag requires that the user be an operator or have 'super'
access.

Examples

To delete a counter named test:
CopyC#
Counter target = Repository.DeleteCounter("test", null);
 To delete a counter named build using -f with a user with super access:
CopyC#
Options opts = new Options();
opts["-f"] = null;
Counter target = Repository.DeleteCounter("build", opts);

See Also

Repository Class


DeleteDepot Method

[image]

Perforce .NET API
Repository..::..DeleteDepot Method
Repository Class Example See Also Send Feedback
Delete a depot from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteDepot(
    Depot depot,
    Options options
)
Visual Basic
Public Sub DeleteDepot ( _
    depot As Depot, _
    options As Options _
)
Visual C++
public:
void DeleteDepot(
    Depot^ depot,
    Options^ options
)

Parameters

depot
Type: Perforce.P4..::..Depot
The depot to be deleted
options
Type: Perforce.P4..::..Options
Only the '-d' flag is valid when deleting an existing depot

Remarks

p4 help depot

depot -- Create or edit a depot specification

p4 depot name
p4 depot -d [-f] name
p4 depot -o name
p4 depot -i

Create a new depot specification or edit an existing depot
specification. The specification form is put into a temporary file
and the editor (configured by the environment variable $P4EDITOR)
is invoked.

The depot specification contains the following fields:

Depot: The name of the depot. This name cannot be the same as
any branch, client, or label name.

Owner: The user who created this depot.

Date: The date that this specification was last modified.

Description: A short description of the depot (optional).

Type: One of the types: 'local', 'stream', 'remote', 'spec',
'archive', or 'unload'.

A 'local' depot (the default) is managed directly by
the server and its files reside in the server's root
directory.

A 'stream' depot is a local depot dedicated to the
storage of files in a stream.

A 'remote' depot refers to files in another Perforce
server.

A 'spec' depot automatically archives all edited forms
(branch, change, client, depot, group, job, jobspec,
protect, triggers, typemap, and user) in special,
read-only files. The files are named:
//depotname/formtype/name[suffix]. Updates to jobs made
by the 'p4 change', 'p4 fix', and 'p4 submit' commands
are also saved, but other automatic updates such as
as access times or opened files (for changes) are not.
A server can contain only one 'spec' depot.

A 'archive' depot defines a storage location to which
obsolete revisions may be relocated.

An 'unload' depot defines a storage location to which
database records may be unloaded and from which they
may be reloaded.

Address: For remote depots, the $P4PORT (connection address)
of the remote server.

Suffix: For spec depots, the optional suffix to be used
for generated paths. The default is '.p4s'.

Map: Path translation information, in the form of a file
pattern with a single ... in it. For local depots,
this path is relative to the server's root directory
or to server.depot.root if it has been configured
(Example: depot/...). For remote depots, this path
refers to the remote server's namespace
(Example: //depot/...).

SpecMap: For spec depots, the optional description of which
specs should be saved, as one or more patterns.

The -d flag deletes the specified depot. If any files reside in the
depot, they must be removed with 'p4 obliterate' before deleting the
depot. If any archive files remain in the depot directory, they may
be referenced by lazy copies in other depots; use 'p4 snap' to break
those linkages. Snap lazy copies prior to obliterating the old depot
files to allow the obliterate command to remove any unreferenced
archives from the depot directory. If the depot directory is not
empty, you must specify the -f flag to delete the depot.

The -o flag writes the depot specification to standard output. The
user's editor is not invoked.

The -i flag reads a depot specification from standard input. The
user's editor is not invoked.

Examples

To delete a streams depot named MobileApp:
CopyC#
Depot d = Repository.GetDepot("MobileApp");

Repository.DeleteDepot(d, null);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..DepotCmdFlags


DeleteGroup Method

[image]

Perforce .NET API
Repository..::..DeleteGroup Method
Repository Class Example See Also Send Feedback
Delete a group from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteGroup(
    Group group,
    Options options
)
Visual Basic
Public Sub DeleteGroup ( _
    group As Group, _
    options As Options _
)
Visual C++
public:
void DeleteGroup(
    Group^ group,
    Options^ options
)

Parameters

group
Type: Perforce.P4..::..Group
The group to be deleted
options
Type: Perforce.P4..::..Options
The -a flag is needed to delete a group when the user is an owner but not a superuser

Examples

To delete the group 'Mygroup' when the user is a superuser:
CopyC#
string targetGroup = "Mygroup";
Group group = new Group();
group.Id = targetGroup;
_repository.DeleteGroup(group, null);
 To delete the group 'Mygroup' when the user is an owner but not a superuser:
CopyC#
string targetGroup = "Mygroup";
Group group = new _repository.GetGroup(targetGroup);
GroupCmdOptions opts = new GroupCmdOptions(GroupCmdFlags.OwnerAccess);
_repository.DeleteGroup(group, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GroupCmdFlags


DeleteJob Method

[image]

Perforce .NET API
Repository..::..DeleteJob Method
Repository Class Example See Also Send Feedback
Delete a job from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteJob(
    Job job,
    Options options
)
Visual Basic
Public Sub DeleteJob ( _
    job As Job, _
    options As Options _
)
Visual C++
public:
void DeleteJob(
    Job^ job,
    Options^ options
)

Parameters

job
Type: Perforce.P4..::..Job
The job to be deleted
options
Type: Perforce.P4..::..Options
Only the '-f' flag is valid when deleting an existing job

Examples

To delete job000002 from the repository :
CopyC#
Job u = _repository.GetJob("job000002");
_repository.DeleteJob(u, null);

See Also

Repository Class


DeleteLabel Method

[image]

Perforce .NET API
Repository..::..DeleteLabel Method
Repository Class Example See Also Send Feedback
Delete a label from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteLabel(
    Label label,
    Options options
)
Visual Basic
Public Sub DeleteLabel ( _
    label As Label, _
    options As Options _
)
Visual C++
public:
void DeleteLabel(
    Label^ label,
    Options^ options
)

Parameters

label
Type: Perforce.P4..::..Label
The label to be deleted
options
Type: Perforce.P4..::..Options
The 'f' and '-d' flags are valid when deleting an existing label

Examples

To delete the label admin_label:
CopyC#
Label deleteTarget = new Label();
deleteTarget.Id = "admin_label";
rep.DeleteLabel(deleteTarget, null);

See Also

Repository Class


DeleteStream Method

[image]

Perforce .NET API
Repository..::..DeleteStream Method
Repository Class Example See Also Send Feedback
Delete a stream from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteStream(
    Stream stream,
    Options options
)
Visual Basic
Public Sub DeleteStream ( _
    stream As Stream, _
    options As Options _
)
Visual C++
public:
void DeleteStream(
    Stream^ stream,
    Options^ options
)

Parameters

stream
Type: Perforce.P4..::..Stream
The stream to be deleted
options
Type: Perforce.P4..::..Options
Only the '-f' flag is valid when deleting an existing stream

Examples

To delete a locked stream with no child streams or active clients as an admin user:
CopyC#
Stream stream = rep.GetStream("//Rocket/GUI");
StreamCmdOptions opts = new StreamCmdOptions(StreamCmdFlags.Force,
                                       null, null);
rep.DeleteStream(stream, opts);

See Also

Repository Class


DeleteUser Method

[image]

Perforce .NET API
Repository..::..DeleteUser Method
Repository Class Example See Also Send Feedback
Delete a user from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void DeleteUser(
    User user,
    Options options
)
Visual Basic
Public Sub DeleteUser ( _
    user As User, _
    options As Options _
)
Visual C++
public:
void DeleteUser(
    User^ user,
    Options^ options
)

Parameters

user
Type: Perforce.P4..::..User
The user to be deleted
options
Type: Perforce.P4..::..Options
Only the '-f' flag is valid when deleting an existing user

Remarks

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Examples

To delete a user with the username bsmith (when connected with Connection.UserName = "bsmith"):
CopyC#
User u = Repository.GetUser("bsmith");
Repository.DeleteUser(u, null);
 To delete a user with the username bsmith (when connected with a user that has super access):
CopyC#
UserCmdOptions opts = new UserCmdOptions(UserCmdFlags.Force);

User u = Repository.GetUser("bsmith");
Repository.DeleteUser(u, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..UserCmdFlags


Dispose Method

[image]

Perforce .NET API
Repository..::..Dispose Method
Repository Class See Also Send Feedback
Releases all resources used by the Repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Repository Class


GetBranchSpec Method

[image] [image]

Perforce .NET API
Repository..::..GetBranchSpec Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBranchSpec(String) |
Public method | GetBranchSpec(String, String, String, Options) | Get the record for an existing branch from the repository.

See Also

Repository Class
Repository Members


GetBranchSpec Method (String)

[image]

Perforce .NET API
Repository..::..GetBranchSpec Method (String)
Repository Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchSpec GetBranchSpec(
    string branch
)
Visual Basic
Public Function GetBranchSpec ( _
    branch As String _
) As BranchSpec
Visual C++
public:
BranchSpec^ GetBranchSpec(
    String^ branch
)

Parameters

branch
Type: System..::..String

See Also

Repository Class
GetBranchSpec Overload


GetBranchSpec Method (String, String, String, Options)

[image]

Perforce .NET API
Repository..::..GetBranchSpec Method (String, String, String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing branch from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchSpec GetBranchSpec(
    string branch,
    string stream,
    string parent,
    Options options
)
Visual Basic
Public Function GetBranchSpec ( _
    branch As String, _
    stream As String, _
    parent As String, _
    options As Options _
) As BranchSpec
Visual C++
public:
BranchSpec^ GetBranchSpec(
    String^ branch,
    String^ stream,
    String^ parent,
    Options^ options
)

Parameters

branch
Type: System..::..String
Branch name
stream
Type: System..::..String
parent
Type: System..::..String
options
Type: Perforce.P4..::..Options

Return Value

The Branch object if branch was found, null if creation failed

Examples

To get a branch spec:
CopyC#
BranchSpec getBranchSpec = _repository.GetBranchSpec("newBranchSpec");

See Also

Repository Class
GetBranchSpec Overload


GetBranchSpecs Method

[image]

Perforce .NET API
Repository..::..GetBranchSpecs Method
Repository Class Example See Also Send Feedback
Get a list of branches from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<BranchSpec> GetBranchSpecs(
    Options options
)
Visual Basic
Public Function GetBranchSpecs ( _
    options As Options _
) As IList(Of BranchSpec)
Visual C++
public:
IList<BranchSpec^>^ GetBranchSpecs(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

Return Value

A list containing the matching branches

Remarks

p4 help branches

branches -- Display list of branch specifications

p4 branches [-t] [-u user] [[-e|-E] nameFilter -m max]

Lists branch specifications. (See 'p4 help branch'.)

The -t flag displays the time as well as the date.

The -u user flag lists branch specs owned by the specified user.

The -e nameFilter flag lists branch specs with a name that matches
the nameFilter pattern, for example: -e 'svr-dev-rel*'. The -e flag
uses the server's normal case-sensitivity rules. The -E flag makes
the matching case-insensitive, even on a case-sensitive server.

The -m max flag limits output to the specified number of branch specs.

Examples

To get all branches and include timestamps [-t] (WARNING, will fetch all branches from the repository):
CopyC#
Options opts = new Options(BranchSpecsCmdFlags.Time, "", "", -1);
IList<Branch> branches = _repository.GetBranchSpecs(opts);
 To get branches owned by 'Bob' [-u]:
CopyC#
Options opts = new Options(BranchSpecsCmdFlags.None, "Bob", "", -1);
IList<Branch> branches = _repository.GetBranchSpecs(opts);
 To get the first 10 branches that start with the capital letter 'A' [-m] [-e]:
CopyC#
Options opts = new Options(BranchSpecsCmdFlags.None, "", "A*", 10);
IList<Branch> branches = _repository.GetBranchSpecs(opts);
 To get the first 10 branches that start with the letter 'A' case insensitive [-m] [-E]:
CopyC#
Options opts = new Options(BranchSpecsCmdFlags.IgnoreCase, "", "A*", 10);
IList<Branch> branches = _repository.GetBranchSpecs(opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..BranchSpecsCmdFlags


GetChangelist Method

[image] [image]

Perforce .NET API
Repository..::..GetChangelist Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChangelist(Int32) | Get the record for an existing change from the repository.
Public method | GetChangelist(Int32, Options) | Get the record for an existing change from the repository.

See Also

Repository Class
Repository Members


GetChangelist Method (Int32)

[image]

Perforce .NET API
Repository..::..GetChangelist Method (Int32)
Repository Class Example See Also Send Feedback
Get the record for an existing change from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist GetChangelist(
    int changeId
)
Visual Basic
Public Function GetChangelist ( _
    changeId As Integer _
) As Changelist
Visual C++
public:
Changelist^ GetChangelist(
    int changeId
)

Parameters

changeId
Type: System..::..Int32

Return Value

The Changelist object if new change was found, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To get changelist 25:
CopyC#
Changelist c = Repository.GetChangelist(25);

See Also

Repository Class
GetChangelist Overload


GetChangelist Method (Int32, Options)

[image]

Perforce .NET API
Repository..::..GetChangelist Method (Int32, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing change from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist GetChangelist(
    int changeId,
    Options options
)
Visual Basic
Public Function GetChangelist ( _
    changeId As Integer, _
    options As Options _
) As Changelist
Visual C++
public:
Changelist^ GetChangelist(
    int changeId,
    Options^ options
)

Parameters

changeId
Type: System..::..Int32
options
Type: Perforce.P4..::..Options
'-f' or '-s' are valid flags to use when fetching an existing change

Return Value

The Changelist object if new change was found, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To get changelist 25:
CopyC#
Changelist c = Repository.GetChangelist(25, null);

See Also

Repository Class
GetChangelist Overload
Perforce.P4 Namespace
Perforce.P4..::..ChangeCmdFlags


GetChangelists Method

[image]

Perforce .NET API
Repository..::..GetChangelists Method
Repository Class Example See Also Send Feedback
Get a list of changes from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Changelist> GetChangelists(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function GetChangelists ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of Changelist)
Visual C++
public:
IList<Changelist^>^ GetChangelists(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
options for the changes command[!:ChangelistsOptions]
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]
array of FileSpecs for the changes command

Return Value

A list containing the matching changes

Remarks

p4 help changes

changes -- Display list of pending and submitted changelists
changelists -- synonym for 'changes'

p4 changes [options] [file[revRange] ...]

options: -i -t -l -L -f -c client -m max -s status -u user

Returns a list of all pending and submitted changelists currently
stored in the server.

If files are specified, 'p4 changes' lists only changelists that
affect those files. If the file specification includes a revision
range, 'p4 changes' lists only submitted changelists that affect
the specified revisions. See 'p4 help revisions' for details.

If files are not specified, 'p4 changes' limits its report
according to each change's type ('public' or 'restricted').
If a submitted or shelved change is restricted, the change is
not reported unless the user owns the change or has list
permission for at least one file in the change. Only the owner
of a restricted and pending (not shelved) change is permitted
to see it.

The -i flag also includes any changelists integrated into the
specified files.

The -t flag displays the time as well as the date.

The -l flag displays the full text of the changelist
descriptions.

The -L flag displays the changelist descriptions, truncated to 250
characters if longer.

The -f flag enables admin users to view restricted changes.

The -c client flag displays only submitted by the specified client.

The -m max flag limits changes to the 'max' most recent.

The -s status flag limits the output to changelists with the specified
status. Specify '-s pending', '-s shelved', or '-s submitted'.

The -u user flag displays only changes owned by the specified user.

Examples

To get all changelists owned by user bsmith:
CopyC#
ChangesCmdOptions opts =new ChangesCmdOptions(ChangesCmdFlags.None,
    null, 0, ChangeListStatus.None, "bsmith");

IList<Changelist> changes =
Repository.GetChangelists(opts, null);
 To get all shelved changelists in file path //depot/main/...:
CopyC#
   ChangesCmdOptions opts =new ChangesCmdOptions(ChangesCmdFlags.None,
       null, 0, ChangeListStatus.Shelved, null);

FileSpec file =
new FileSpec(new DepotPath("//depot/main/..."), null, null, null);

   IList<Changelist> changes =
   Repository.GetChangelists(opts, file);
 To the 20 latest submitted changelists from client "build_workspace" with their full description:
CopyC#
ChangesCmdOptions opts =new ChangesCmdOptions(ChangesCmdFlags.FullDescription,
    "build_workspace", 20, ChangeListStatus.Submitted, null);

IList<Changelist> changes =
Repository.GetChangelists(opts, null);
 To get all pending changelists as an admin user in file path //depot/finance/... including restricted changelists:
CopyC#
   ChangesCmdOptions opts =new ChangesCmdOptions(ChangesCmdFlags.ViewRestricted,
       null, 0, ChangeListStatus.Pending, null);

FileSpec file =
new FileSpec(new DepotPath("//depot/finance/..."), null, null, null);

   IList<Changelist> changes =
   Repository.GetChangelists(opts, file);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..ChangesCmdFlags


GetClient Method

[image] [image]

Perforce .NET API
Repository..::..GetClient Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetClient(String) | Get the record for an existing client from the repository.
Public method | GetClient(String, Options) | Get the record for an existing client from the repository.

See Also

Repository Class
Repository Members


GetClient Method (String)

[image]

Perforce .NET API
Repository..::..GetClient Method (String)
Repository Class Example See Also Send Feedback
Get the record for an existing client from the repository.
Create a new client in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Client GetClient(
    string client
)
Visual Basic
Public Function GetClient ( _
    client As String _
) As Client
Visual C++
public:
Client^ GetClient(
    String^ client
)

Parameters

client
Type: System..::..String
Client nameClient specification for the new user

Return Value

The Client object if new client was found, null if creation failed

Return Value

The Client object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

Examples

To get the spec for a client named main_ws:
CopyC#
Client c = Repository.GetClient("main_ws");

See Also

Repository Class
GetClient Overload


GetClient Method (String, Options)

[image]

Perforce .NET API
Repository..::..GetClient Method (String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing client from the repository.
Create a new client in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Client GetClient(
    string client,
    Options options
)
Visual Basic
Public Function GetClient ( _
    client As String, _
    options As Options _
) As Client
Visual C++
public:
Client^ GetClient(
    String^ client,
    Options^ options
)

Parameters

client
Type: System..::..String
Client nameClient specification for the new user
options
Type: Perforce.P4..::..Options
There are no valid flags to use when fetching an existing clientThe '-i' flags is required when creating a new user

Return Value

The Client object if new client was found, null if creation failed

Return Value

The Client object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

Examples

To get the spec for a client named main_ws:
CopyC#
Client c = Repository.GetClient("main_ws", null);

See Also

Repository Class
GetClient Overload
Perforce.P4 Namespace
Perforce.P4..::..ClientCmdFlags


GetClientMetadata Method

[image]

Perforce .NET API
Repository..::..GetClientMetadata Method
Repository Class Example See Also Send Feedback
Get client application information.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ClientMetadata GetClientMetadata()
Visual Basic
Public Function GetClientMetadata As ClientMetadata
Visual C++
public:
ClientMetadata^ GetClientMetadata()

Return Value

Information avout a connection's client-side application context.

Remarks

p4 help info

info -- Display client/server information

p4 info [-s]

Info lists information about the current client (user name,
client name, applicable client root, client current directory,
and the client IP address) and some server information (server
IP address, server root, date, uptime, version and license data).

The -s option produces 'short' output that omits any information
that requires a database lookup such as the client root).

Examples

To get the current client host name:
CopyC#
ClientMetadata c = rep.GetClientMetadata();
string machinename = c.HostName;

See Also

Repository Class


GetClients Method

[image]

Perforce .NET API
Repository..::..GetClients Method
Repository Class Example See Also Send Feedback
Get a list of clients from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Client> GetClients(
    Options options
)
Visual Basic
Public Function GetClients ( _
    options As Options _
) As IList(Of Client)
Visual C++
public:
IList<Client^>^ GetClients(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options
options for the clients commandClientsCmdOptions

Return Value

A list containing the matching clients

Remarks

p4 help clients

clients -- Display list of clients
workspaces -- synonym for 'clients'

p4 clients [-t] [-u user] [[-e|-E] nameFilter -m max] [-S stream]
[-a | -s serverID]
p4 clients -U

Lists all client workspaces currently defined in the server.

The -t flag displays the time as well as the date.

The -u user flag lists client workspaces that are owned by the
specified user.

The -e nameFilter flag lists workspaces with a name that matches
the nameFilter pattern, for example: -e 'svr-dev-rel*'. The -e flag
uses the server's normal case-sensitivity rules. The -E flag makes
the matching case-insensitive, even on a case-sensitive server.

The -m max flag limits output to the specified number of workspaces.

The -S stream flag limits output to the client workspaces dedicated
to the stream.

The -U flag lists unloaded clients (see 'p4 help unload').

The -a flag specifies that all clients should be displayed, not just
those that are bound to this server.

The -s serverID flag specifies that only those clients bound to the
specified serverID should be displayed. On an Edge Server, the -s
flag defaults to the Edge Server's serverID.

Examples

To get a list of a maximum of 10 clients:
CopyC#
ClientsCmdOptions opts =
new ClientsCmdOptions(ClientsCmdFlags.NoneIncludeTime, null, null, 10, null));

IList<Client> clients = Repository.GetClients(opts);
 To get a list of clients that have "iOS_app" in their name:
CopyC#
ClientsCmdOptions opts =
new ClientsCmdOptions(ClientsCmdFlags.NoneIncludeTime, null, "*iOS_app*, 0, null));

IList<Client> clients = Repository.GetClients(opts);
 To get a list of clients that can be used with stream //depot/main:
CopyC#
ClientsCmdOptions opts =
new ClientsCmdOptions(ClientsCmdFlags.NoneIncludeTime, null, null, 0, "//depot/main"));

IList<Client> clients = Repository.GetClients(opts);
 To get a list clients owned by user bsmith:
CopyC#
ClientsCmdOptions opts =
new ClientsCmdOptions(ClientsCmdFlags.NoneIncludeTime, "bsmith", null, 0, null));

IList<Client> clients = Repository.GetClients(opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..ClientsCmdOptions


GetCounter Method

[image]

Perforce .NET API
Repository..::..GetCounter Method
Repository Class Example See Also Send Feedback
Get a named Perforce counter value from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Counter GetCounter(
    string name,
    Options options
)
Visual Basic
Public Function GetCounter ( _
    name As String, _
    options As Options _
) As Counter
Visual C++
public:
Counter^ GetCounter(
    String^ name,
    Options^ options
)

Parameters

name
Type: System..::..String
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help counter

counter -- Display, set, or delete a counter

p4 counter name
p4 counter [-f] name value
p4 counter [-f] -d name
p4 counter [-f] -i name
p4 counter [-f] -m [ pair list ]

The first form displays the value of the specified counter.

The second form sets the counter to the specified value.

The third form deletes the counter. This option usually has the
same effect as setting the counter to 0.

The -f flag sets or deletes counters used by Perforce, which are
listed by 'p4 help counters'. Important: Never set the 'change'
counter to a value that is lower than its current value.

The -i flag increments a counter by 1 and returns the new value.
This option is used instead of a value argument and can only be
used with numeric counters.

The fifth form allows multiple operations in one command.
With this, the list is pairs of arguments. Each pair is either
counter value or '-' counter. To set a counter use a name and value.
To delete a counter use a '-' followed by the name.

Counters can be assigned textual values as well as numeric ones,
despite the name 'counter'.

'p4 counter' requires 'review' access granted by 'p4 protect'.
The -f flag requires that the user be an operator or have 'super'
access.

Examples

To get the job counter:
CopyC#
Counter target = Repository.GetCounter("job", null);
 To get the change counter:
CopyC#
Counter target = Repository.GetCounter("change", null);
 To get the journal counter:
CopyC#
Counter target = Repository.GetCounter("journal", null);

See Also

Repository Class


GetCounters Method

[image]

Perforce .NET API
Repository..::..GetCounters Method
Repository Class Example See Also Send Feedback
Get the Perforce counters for this repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Counter> GetCounters(
    Options options
)
Visual Basic
Public Function GetCounters ( _
    options As Options _
) As IList(Of Counter)
Visual C++
public:
IList<Counter^>^ GetCounters(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help counters

counters -- Display list of known counters

p4 counters [-e nameFilter -m max]

Lists the counters in use by the server. The server
uses the following counters directly:

change Current change number
job Current job number
journal Current journal number
lastCheckpointAction Data about the last complete checkpoint
logger Event log index used by 'p4 logger'
traits Internal trait lot number used by 'p4 attribute'
upgrade Server database upgrade level

The -e nameFilter flag lists counters with a name that matches
the nameFilter pattern, for example: -e 'mycounter-*'.

The -m max flag limits the output to the first 'max' counters.

The names 'minClient', 'minClientMessage', 'monitor',
'security', 'masterGenNumber', and 'unicode' are reserved names:
do not use them as ordinary counters.

For general-purpose server configuration, see 'p4 help configure'.

Examples

To get the counters on the server:
CopyC#
IList<Counter> target = Repository.GetCounters(null);
 To get the counters on the server that start with the name "build_":
CopyC#
Options opts = new Options();
opts["-e"] = "build_*";
IList<Counter> target = Repository.GetCounters(opts);

See Also

Repository Class


GetDepot Method

[image] [image]

Perforce .NET API
Repository..::..GetDepot Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDepot(String) | Get the record for an existing depot from the repository.
Public method | GetDepot(String, Options) | Get the record for an existing depot from the repository.

See Also

Repository Class
Repository Members


GetDepot Method (String)

[image]

Perforce .NET API
Repository..::..GetDepot Method (String)
Repository Class Example See Also Send Feedback
Get the record for an existing depot from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Depot GetDepot(
    string depot
)
Visual Basic
Public Function GetDepot ( _
    depot As String _
) As Depot
Visual C++
public:
Depot^ GetDepot(
    String^ depot
)

Parameters

depot
Type: System..::..String
Depot name

Return Value

The Depot object if depot was found, null if not

Remarks

p4 help depot

depot -- Create or edit a depot specification

p4 depot name
p4 depot -d [-f] name
p4 depot -o name
p4 depot -i

Create a new depot specification or edit an existing depot
specification. The specification form is put into a temporary file
and the editor (configured by the environment variable $P4EDITOR)
is invoked.

The depot specification contains the following fields:

Depot: The name of the depot. This name cannot be the same as
any branch, client, or label name.

Owner: The user who created this depot.

Date: The date that this specification was last modified.

Description: A short description of the depot (optional).

Type: One of the types: 'local', 'stream', 'remote', 'spec',
'archive', or 'unload'.

A 'local' depot (the default) is managed directly by
the server and its files reside in the server's root
directory.

A 'stream' depot is a local depot dedicated to the
storage of files in a stream.

A 'remote' depot refers to files in another Perforce
server.

A 'spec' depot automatically archives all edited forms
(branch, change, client, depot, group, job, jobspec,
protect, triggers, typemap, and user) in special,
read-only files. The files are named:
//depotname/formtype/name[suffix]. Updates to jobs made
by the 'p4 change', 'p4 fix', and 'p4 submit' commands
are also saved, but other automatic updates such as
as access times or opened files (for changes) are not.
A server can contain only one 'spec' depot.

A 'archive' depot defines a storage location to which
obsolete revisions may be relocated.

An 'unload' depot defines a storage location to which
database records may be unloaded and from which they
may be reloaded.

Address: For remote depots, the $P4PORT (connection address)
of the remote server.

Suffix: For spec depots, the optional suffix to be used
for generated paths. The default is '.p4s'.

Map: Path translation information, in the form of a file
pattern with a single ... in it. For local depots,
this path is relative to the server's root directory
or to server.depot.root if it has been configured
(Example: depot/...). For remote depots, this path
refers to the remote server's namespace
(Example: //depot/...).

SpecMap: For spec depots, the optional description of which
specs should be saved, as one or more patterns.

The -d flag deletes the specified depot. If any files reside in the
depot, they must be removed with 'p4 obliterate' before deleting the
depot. If any archive files remain in the depot directory, they may
be referenced by lazy copies in other depots; use 'p4 snap' to break
those linkages. Snap lazy copies prior to obliterating the old depot
files to allow the obliterate command to remove any unreferenced
archives from the depot directory. If the depot directory is not
empty, you must specify the -f flag to delete the depot.

The -o flag writes the depot specification to standard output. The
user's editor is not invoked.

The -i flag reads a depot specification from standard input. The
user's editor is not invoked.

Examples

To get the spec for a streams depot named MobileApp:
CopyC#
Depot MobileApp = Repository.GetDepot("MobileApp");

See Also

Repository Class
GetDepot Overload
Perforce.P4 Namespace
Perforce.P4..::..DepotCmdFlags


GetDepot Method (String, Options)

[image]

Perforce .NET API
Repository..::..GetDepot Method (String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing depot from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Depot GetDepot(
    string depot,
    Options options
)
Visual Basic
Public Function GetDepot ( _
    depot As String, _
    options As Options _
) As Depot
Visual C++
public:
Depot^ GetDepot(
    String^ depot,
    Options^ options
)

Parameters

depot
Type: System..::..String
Depot name
options
Type: Perforce.P4..::..Options
There are no valid flags to use when fetching an existing depot

Return Value

The Depot object if depot was found, null if not

Remarks

p4 help depot

depot -- Create or edit a depot specification

p4 depot name
p4 depot -d [-f] name
p4 depot -o name
p4 depot -i

Create a new depot specification or edit an existing depot
specification. The specification form is put into a temporary file
and the editor (configured by the environment variable $P4EDITOR)
is invoked.

The depot specification contains the following fields:

Depot: The name of the depot. This name cannot be the same as
any branch, client, or label name.

Owner: The user who created this depot.

Date: The date that this specification was last modified.

Description: A short description of the depot (optional).

Type: One of the types: 'local', 'stream', 'remote', 'spec',
'archive', or 'unload'.

A 'local' depot (the default) is managed directly by
the server and its files reside in the server's root
directory.

A 'stream' depot is a local depot dedicated to the
storage of files in a stream.

A 'remote' depot refers to files in another Perforce
server.

A 'spec' depot automatically archives all edited forms
(branch, change, client, depot, group, job, jobspec,
protect, triggers, typemap, and user) in special,
read-only files. The files are named:
//depotname/formtype/name[suffix]. Updates to jobs made
by the 'p4 change', 'p4 fix', and 'p4 submit' commands
are also saved, but other automatic updates such as
as access times or opened files (for changes) are not.
A server can contain only one 'spec' depot.

A 'archive' depot defines a storage location to which
obsolete revisions may be relocated.

An 'unload' depot defines a storage location to which
database records may be unloaded and from which they
may be reloaded.

Address: For remote depots, the $P4PORT (connection address)
of the remote server.

Suffix: For spec depots, the optional suffix to be used
for generated paths. The default is '.p4s'.

Map: Path translation information, in the form of a file
pattern with a single ... in it. For local depots,
this path is relative to the server's root directory
or to server.depot.root if it has been configured
(Example: depot/...). For remote depots, this path
refers to the remote server's namespace
(Example: //depot/...).

SpecMap: For spec depots, the optional description of which
specs should be saved, as one or more patterns.

The -d flag deletes the specified depot. If any files reside in the
depot, they must be removed with 'p4 obliterate' before deleting the
depot. If any archive files remain in the depot directory, they may
be referenced by lazy copies in other depots; use 'p4 snap' to break
those linkages. Snap lazy copies prior to obliterating the old depot
files to allow the obliterate command to remove any unreferenced
archives from the depot directory. If the depot directory is not
empty, you must specify the -f flag to delete the depot.

The -o flag writes the depot specification to standard output. The
user's editor is not invoked.

The -i flag reads a depot specification from standard input. The
user's editor is not invoked.

Examples

To get the spec for a streams depot named MobileApp:
CopyC#
Depot MobileApp = Repository.GetDepot("MobileApp", null);

See Also

Repository Class
GetDepot Overload
Perforce.P4 Namespace
Perforce.P4..::..DepotCmdFlags


GetDepotDirs Method

[image] [image]

Perforce .NET API
Repository..::..GetDepotDirs Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDepotDirs(IList<(Of <<'(String>)>>), Options) | List selected directory paths in the repository.
Public method | GetDepotDirs(Options, array<String>[]()[][]) | List selected directory paths in the repository.

See Also

Repository Class
Repository Members


GetDepotDirs Method (IList(String), Options)

[image]

Perforce .NET API
Repository..::..GetDepotDirs Method (IList<(Of <(<'String>)>)>, Options)
Repository Class Example See Also Send Feedback
List selected directory paths in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> GetDepotDirs(
    IList<string> dirs,
    Options options
)
Visual Basic
Public Function GetDepotDirs ( _
    dirs As IList(Of String), _
    options As Options _
) As IList(Of String)
Visual C++
public:
IList<String^>^ GetDepotDirs(
    IList<String^>^ dirs,
    Options^ options
)

Parameters

dirs
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help dirs

dirs -- List depot subdirectories

p4 dirs [-C -D -H] [-S stream] dir[revRange] ...

List directories that match the specified file pattern (dir).
This command does not support the recursive wildcard (...).
Use the * wildcard instead.

Perforce does not track directories individually. A path is treated
as a directory if there are any undeleted files with that path as a
prefix.

By default, all directories containing files are listed. If the dir
argument includes a revision range, only directories containing files
in the range are listed. For details about specifying file revisions,
see 'p4 help revisions'.

The -C flag lists only directories that fall within the current
client view.

The -D flag includes directories containing only deleted files.

The -H flag lists directories containing files synced to the current
client workspace.

The -S flag limits output to depot directories mapped in a stream's
client view.

Examples

To get dirs on the server that fall within the current client view:
CopyC#
GetDepotDirsCmdOptions opts =
new GetDepotDirsCmdOptions(GetDepotDirsCmdFlags.CurrentClientOnly, null);

IList<String> dirs = new List<String>()
dirs.Add("//*");

IList<String> target = Repository.GetDepotDirs(dirs, opts);
 To get dirs on the server that contain files synced to the current client workspace:
CopyC#
GetDepotDirsCmdOptions opts =
new GetDepotDirsCmdOptions(GetDepotDirsCmdFlags.SyncedDirs, null);

IList<String> dirs = new List<String>()
dirs.Add("//*");

IList<String> target = Repository.GetDepotDirs(dirs, opts);
 To get dirs on the server that fall under the path //depot/main/:
CopyC#
GetDepotDirsCmdOptions opts =
new GetDepotDirsCmdOptions(GetDepotDirsCmdFlags.None, null);

IList<String> dirs = new List<String>()
dirs.Add("//depot/main/*");

IList<String> target = Repository.GetDepotDirs(dirs, opts);

See Also

Repository Class
GetDepotDirs Overload
Perforce.P4 Namespace
Perforce.P4..::..GetDepotDirsCmdFlags


GetDepotDirs Method (Options, String[])

[image]

Perforce .NET API
Repository..::..GetDepotDirs Method (Options, array<String>[]()[][])
Repository Class Example See Also Send Feedback
List selected directory paths in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> GetDepotDirs(
    Options options,
    params string[] dirs
)
Visual Basic
Public Function GetDepotDirs ( _
    options As Options, _
    ParamArray dirs As String() _
) As IList(Of String)
Visual C++
public:
IList<String^>^ GetDepotDirs(
    Options^ options,
    ... array<String^>^ dirs
)

Parameters

options
Type: Perforce.P4..::..Options
dirs
Type: array< System..::..String >[]()[][]

Return Value

Remarks

p4 help dirs

dirs -- List depot subdirectories

p4 dirs [-C -D -H] [-S stream] dir[revRange] ...

List directories that match the specified file pattern (dir).
This command does not support the recursive wildcard (...).
Use the * wildcard instead.

Perforce does not track directories individually. A path is treated
as a directory if there are any undeleted files with that path as a
prefix.

By default, all directories containing files are listed. If the dir
argument includes a revision range, only directories containing files
in the range are listed. For details about specifying file revisions,
see 'p4 help revisions'.

The -C flag lists only directories that fall within the current
client view.

The -D flag includes directories containing only deleted files.

The -H flag lists directories containing files synced to the current
client workspace.

The -S flag limits output to depot directories mapped in a stream's
client view.

Examples

To get dirs on the server that fall within the current client view:
CopyC#
GetDepotDirsCmdOptions opts =
new GetDepotDirsCmdOptions(GetDepotDirsCmdFlags.CurrentClientOnly, null);

IList<String> target = Repository.GetDepotDirs(opts, "//* );
 To get dirs on the server that contain files synced to the current client workspace:
CopyC#
GetDepotDirsCmdOptions opts =
new GetDepotDirsCmdOptions(GetDepotDirsCmdFlags.SyncedDirs, null);

IList<String> target = Repository.GetDepotDirs(opts, "//* );
 To get dirs on the server that fall under the path //depot/main/:
CopyC#
GetDepotDirsCmdOptions opts =
new GetDepotDirsCmdOptions(GetDepotDirsCmdFlags.None, null);

IList<String> target = Repository.GetDepotDirs(opts, "//depot/main/* );

See Also

Repository Class
GetDepotDirs Overload
Perforce.P4 Namespace
Perforce.P4..::..GetDepotDirsCmdFlags


GetDepotFileDiffs Method

[image]

Perforce .NET API
Repository..::..GetDepotFileDiffs Method
Repository Class Example See Also Send Feedback
Get content and existence diff details for two depot files.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<DepotFileDiff> GetDepotFileDiffs(
    string filespecleft,
    string filespecright,
    Options options
)
Visual Basic
Public Function GetDepotFileDiffs ( _
    filespecleft As String, _
    filespecright As String, _
    options As Options _
) As IList(Of DepotFileDiff)
Visual C++
public:
IList<DepotFileDiff^>^ GetDepotFileDiffs(
    String^ filespecleft,
    String^ filespecright,
    Options^ options
)

Parameters

filespecleft
Type: System..::..String
filespecright
Type: System..::..String
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help diff2

diff2 -- Compare one set of depot files to another

p4 diff2 [options] fromFile[rev] toFile[rev]
p4 diff2 [options] -b branch [[fromFile[rev]] toFile[rev]]
p4 diff2 [options] -S stream [-P parent] [[fromFile[rev]] toFile[rev]]

options: -d<flags> -Od -q -t -u

'p4 diff2' runs on the server to compare one set of depot files (the
'source') to another (the 'target'). Source and target file sets
can be specified on the 'p4 diff2' command line or through a branch
view.

With a branch view, fromFile and toFile are optional; fromFile limits
the scope of the source file set, and toFile limits the scope of the
target. If only one file argument is given, it is assumed to be
toFile.

fromFile and toFile can include revision specifiers; by default, the
head revisions are diffed. See 'p4 help revisions' for details
about specifying file revisions.

'p4 diff2' precedes each diffed file pair with a header line of the
following form:

==== source#rev (type) - target#rev (type) ==== summary

A source or target file shown as '<none>' means there is no file
at the specified name or revision to pair with its counterpart.
The summary status is one of the following: 'identical' means file
contents and types are identical, 'types' means file contents are
identical but the types are different, and 'content' means file
contents are different.

The -b flag makes 'p4 diff2' use a user-defined branch view. (See
'p4 help branch'.) The left side of the branch view is the source
and the right side is the target.

The -S flag makes 'p4 diff2' use a generated branch view that maps
a stream (or its underlying real stream) to its parent. -P can be
used to generate the branch view using a parent stream other than
the stream's actual parent.

The -d<flags> modify the output of diffs as follows:

-dn (RCS)
-dc[n] (context)
-ds (summary)
-du[n] (unified)
-db (ignore whitespace changes)
-dw (ignore whitespace)
-dl (ignore line endings).

The optional argument to -dc/-du specifies number of context lines.

The -Od flag limits output to files that differ.

The -q omits files that have identical content and types and
suppresses the actual diff for all files.

The -t flag forces 'p4 diff2' to diff binary files.

The -u flag uses the GNU diff -u format and displays only files
that differ. The file names and dates are in Perforce syntax, but
the output can be used by the patch program.

Examples

To get the depot file diffs between //depot/main/Program.cs and //depot/rel/Program.cs and ignore whitespace changes:
CopyC#
GetDepotFileDiffsCmdOptions opts =
new GetDepotFileDiffsCmdOptions(GetDepotFileDiffsCmdFlags.IgnoreWhitespaceChanges,
0, 0, null,null,null);

IList<DepotFileDiff> target =
Repository.GetDepotFileDiffs(//depot/main/Program.cs,
//depot/rel/Program.cs, opts);
 To get the depot files that differ between all files under //depot/main/... and //depot/rel/... and display in GNU format only listing files that differ:
CopyC#
GetDepotFileDiffsCmdOptions opts =
new GetDepotFileDiffsCmdOptions(GetDepotFileDiffsCmdFlags.GNU,
0, 0, null,null,null);

IList<DepotFileDiff> target =
Repository.GetDepotFileDiffs(//depot/main/..., //depot/rel/..., opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetDepotFileDiffsCmdFlags


GetDepotFiles Method

[image]

Perforce .NET API
Repository..::..GetDepotFiles Method
Repository Class Example See Also Send Feedback
Return a list of FileSpecs of files in the depot that correspond to the passed-in FileSpecs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> GetDepotFiles(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetDepotFiles ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ GetDepotFiles(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help files

files -- List files in the depot

p4 files [ -a ] [ -A ] [ -e ] [ -m max ] file[revRange] ...
p4 files -U unloadfile ...

List details about specified files: depot file name, revision,
file, type, change action and changelist number of the current
head revision. If client syntax is used to specify the file
argument, the client view mapping is used to determine the
corresponding depot files.

By default, the head revision is listed. If the file argument
specifies a revision, then all files at that revision are listed.
If the file argument specifies a revision range, the highest revision
in the range is used for each file. For details about specifying
revisions, see 'p4 help revisions'.

The -a flag displays all revisions within the specific range, rather
than just the highest revision in the range.

The -A flag displays files in archive depots.

The -e flag displays files with an action of anything other than
deleted, purged or archived. Typically this revision is always
available to sync or integrate from.

The -m flag limits files to the first 'max' number of files.

The -U option displays files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Examples

To get a maximum of 10 files from the repository:
CopyC#
GetDepotFilesCmdOptions opts =
new GetDepotFilesCmdOptions(GetDepotFilesCmdFlags.None, 10);
FileSpec fs = new FileSpec(new DepotPath("//depot/..."), null);
List<FileSpec> lfs = new List<FileSpec>();
lfs.Add(fs);
IList<FileSpec> files = Repository.GetDepotFiles(lfs, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetDepotFilesCmdFlags


GetDepots Method

[image]

Perforce .NET API
Repository..::..GetDepots Method
Repository Class Example See Also Send Feedback
Get a list of depots from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Depot> GetDepots()
Visual Basic
Public Function GetDepots As IList(Of Depot)
Visual C++
public:
IList<Depot^>^ GetDepots()

Return Value

A list containing the matching depots

Remarks

p4 help depots

depots -- Lists defined depots

p4 depots

Lists all depots defined in the server.
Depots takes no arguments.

Examples

To list the depots on the server:
CopyC#
IList<Depot> depots = Repository.GetDepots();

See Also

Repository Class


GetFileAnnotations Method

[image]

Perforce .NET API
Repository..::..GetFileAnnotations Method
Repository Class Example See Also Send Feedback
Return FileAnnotation objects for the listed FileSpecs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileAnnotation> GetFileAnnotations(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetFileAnnotations ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileAnnotation)
Visual C++
public:
IList<FileAnnotation^>^ GetFileAnnotations(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help annotate

annotate -- Print file lines and their revisions

p4 annotate [-aciIqt -d<flags>] file[revRange] ...

Prints all lines of the specified files, indicating the revision that
introduced each line into the file.

If the file argument includes a revision, then only revisions up to
the specified revision are displayed. If the file argument has a
revision range, only revisions within that range are displayed. For
details about specifying revisions, see 'p4 help revisions'.

The -a flag includes both deleted files and lines no longer present
at the head revision. In the latter case, both the starting and ending
revision for each line is displayed.

The -c flag directs the annotate command to output changelist numbers
rather than revision numbers for each line.

The -d<flags> change the way whitespace and/or line endings are
treated: -db (ignore whitespace changes), -dw (ignore whitespace),
-dl (ignore line endings).

The -i flag follows branches. If a file was created by branching,
'p4 annotate' includes the revisions of the source file up to the
branch point, just as 'p4 filelog -i' does. If a file has history
prior to being created by branching (such as a file that was branched
on top of a deleted file), -i ignores those prior revisions and
follows the source. -i implies -c.

The -I flag follows all integrations into the file. If a line was
introduced into the file by a merge, the source of the merge is
displayed as the changelist that introduced the line. If the source
itself was the result of an integration, that source is used instead,
and so on. -I implies -c and may not be combined with -i.

The -q flag suppresses the one-line header that is displayed by
default for each file.

The -t flag forces 'p4 annotate' to display binary files.

Examples

To get the file annotations of the file //depot/MyCode/README.txt:
CopyC#
GetFileAnnotationsCmdOptions opts =
new GetFileAnnotationsCmdOptions(GetFileAnnotationsCmdFlags.None, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileAnnotation> target = Repository.GetFileAnnotations(filespecs, opts);
 To get the file annotations of the file //depot/MyCode/README.txt redirecting the contents to local file C:\Doc\README.txt and supressing the one-line header:
CopyC#
GetFileAnnotationsCmdOptions opts =
new GetFileAnnotationsCmdOptions(GetFileAnnotationsCmdFlags.Suppress,
"C:\\Doc\\README.txt");

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileAnnotation> target = Repository.GetFileAnnotations(filespecs, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetFileAnnotationsCmdFlags


GetFileContents Method

[image] [image]

Perforce .NET API
Repository..::..GetFileContents Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFileContents(IList<(Of <<'(FileSpec>)>>), Options) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContents(Options, array<FileSpec>[]()[][]) | Return the contents of the files identified by the passed-in file specs.

See Also

Repository Class
Repository Members


GetFileContents Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Repository..::..GetFileContents Method (IList<(Of <(<'FileSpec>)>)>, Options)
Repository Class Example See Also Send Feedback
Return the contents of the files identified by the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> GetFileContents(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetFileContents ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of String)
Visual C++
public:
IList<String^>^ GetFileContents(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help print

print -- Write a depot file to standard output

p4 print [-a -A -k -o localFile -q -m max] file[revRange] ...
p4 print -U unloadfile ...

Retrieve the contents of a depot file to the client's standard output.
The file is not synced. If file is specified using client syntax,
Perforce uses the client view to determine the corresponding depot
file.

By default, the head revision is printed. If the file argument
includes a revision, the specified revision is printed. If the
file argument has a revision range, then only files selected by
that revision range are printed, and the highest revision in the
range is printed. For details about revision specifiers, see 'p4
help revisions'.

The -a flag prints all revisions within the specified range, rather
than just the highest revision in the range.

The -A flag prints files in archive depots.

The -k flag suppresses keyword expansion.

The -o localFile flag redirects the output to the specified file on
the client filesystem.

The -q flag suppresses the initial line that displays the file name
and revision.

The -m flag limits print to the first 'max' number of files.

The -U option prints files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Examples

To get the contents of the file //depot/MyCode/README.txt:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.None, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<String> target = Repository.GetFileContents(filespecs, opts);
 To get the contents of the file //depot/MyCode/README.txt redirecting the contents to local file C:\Doc\README.txt and supressing the file name and revision line:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.Suppress,
"C:\\Doc\\README.txt");

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<String> target = Repository.GetFileContents(filespecs, opts);

See Also

Repository Class
GetFileContents Overload
Perforce.P4 Namespace
Perforce.P4..::..GetFileContentsCmdFlags


GetFileContents Method (Options, FileSpec[])

[image]

Perforce .NET API
Repository..::..GetFileContents Method (Options, array<FileSpec>[]()[][])
Repository Class Example See Also Send Feedback
Return the contents of the files identified by the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> GetFileContents(
    Options options,
    params FileSpec[] filespecs
)
Visual Basic
Public Function GetFileContents ( _
    options As Options, _
    ParamArray filespecs As FileSpec() _
) As IList(Of String)
Visual C++
public:
IList<String^>^ GetFileContents(
    Options^ options,
    ... array<FileSpec^>^ filespecs
)

Parameters

options
Type: Perforce.P4..::..Options
filespecs
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help print

print -- Write a depot file to standard output

p4 print [-a -A -k -o localFile -q -m max] file[revRange] ...
p4 print -U unloadfile ...

Retrieve the contents of a depot file to the client's standard output.
The file is not synced. If file is specified using client syntax,
Perforce uses the client view to determine the corresponding depot
file.

By default, the head revision is printed. If the file argument
includes a revision, the specified revision is printed. If the
file argument has a revision range, then only files selected by
that revision range are printed, and the highest revision in the
range is printed. For details about revision specifiers, see 'p4
help revisions'.

The -a flag prints all revisions within the specified range, rather
than just the highest revision in the range.

The -A flag prints files in archive depots.

The -k flag suppresses keyword expansion.

The -o localFile flag redirects the output to the specified file on
the client filesystem.

The -q flag suppresses the initial line that displays the file name
and revision.

The -m flag limits print to the first 'max' number of files.

The -U option prints files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Examples

To get the contents of the file //depot/MyCode/README.txt:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.None, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);

IList<String> target = Repository.GetFileContents(opts, filespec);
 To get the contents of the file //depot/MyCode/README.txt redirecting the contents to local file C:\Doc\README.txt and supressing the file name and revision line:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.Suppress,
"C:\\Doc\\README.txt");

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);

IList<String> target = Repository.GetFileContents(opts, filespec);

See Also

Repository Class
GetFileContents Overload
Perforce.P4 Namespace
Perforce.P4..::..GetFileContentsCmdFlags


GetFileContentsEx Method

[image] [image]

Perforce .NET API
Repository..::..GetFileContentsEx Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFileContentsEx(IList<(Of <<'(FileSpec>)>>), Options) | Return the contents of the files identified by the passed-in file specs.
Public method | GetFileContentsEx(Options, array<FileSpec>[]()[][]) | Return the contents of the files identified by the passed-in file specs.

See Also

Repository Class
Repository Members


GetFileContentsEx Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Repository..::..GetFileContentsEx Method (IList<(Of <(<'FileSpec>)>)>, Options)
Repository Class Example See Also Send Feedback
Return the contents of the files identified by the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Object> GetFileContentsEx(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetFileContentsEx ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of Object)
Visual C++
public:
IList<Object^>^ GetFileContentsEx(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help print

print -- Write a depot file to standard output

p4 print [-a -A -k -o localFile -q -m max] file[revRange] ...
p4 print -U unloadfile ...

Retrieve the contents of a depot file to the client's standard output.
The file is not synced. If file is specified using client syntax,
Perforce uses the client view to determine the corresponding depot
file.

By default, the head revision is printed. If the file argument
includes a revision, the specified revision is printed. If the
file argument has a revision range, then only files selected by
that revision range are printed, and the highest revision in the
range is printed. For details about revision specifiers, see 'p4
help revisions'.

The -a flag prints all revisions within the specified range, rather
than just the highest revision in the range.

The -A flag prints files in archive depots.

The -k flag suppresses keyword expansion.

The -o localFile flag redirects the output to the specified file on
the client filesystem.

The -q flag suppresses the initial line that displays the file name
and revision.

The -m flag limits print to the first 'max' number of files.

The -U option prints files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Examples

To get the contents of the file //depot/MyCode/README.txt:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.None, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<String> target = Repository.GetFileContents(filespecs, opts);
 To get the contents of the file //depot/MyCode/README.txt redirecting the contents to local file C:\Doc\README.txt and supressing the file name and revision line:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.Suppress,
"C:\\Doc\\README.txt");

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<String> target = Repository.GetFileContents(filespecs, opts);

See Also

Repository Class
GetFileContentsEx Overload
Perforce.P4 Namespace
Perforce.P4..::..GetFileContentsCmdFlags


GetFileContentsEx Method (Options, FileSpec[])

[image]

Perforce .NET API
Repository..::..GetFileContentsEx Method (Options, array<FileSpec>[]()[][])
Repository Class Example See Also Send Feedback
Return the contents of the files identified by the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Object> GetFileContentsEx(
    Options options,
    params FileSpec[] filespecs
)
Visual Basic
Public Function GetFileContentsEx ( _
    options As Options, _
    ParamArray filespecs As FileSpec() _
) As IList(Of Object)
Visual C++
public:
IList<Object^>^ GetFileContentsEx(
    Options^ options,
    ... array<FileSpec^>^ filespecs
)

Parameters

options
Type: Perforce.P4..::..Options
filespecs
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help print

print -- Write a depot file to standard output

p4 print [-a -A -k -o localFile -q -m max] file[revRange] ...
p4 print -U unloadfile ...

Retrieve the contents of a depot file to the client's standard output.
The file is not synced. If file is specified using client syntax,
Perforce uses the client view to determine the corresponding depot
file.

By default, the head revision is printed. If the file argument
includes a revision, the specified revision is printed. If the
file argument has a revision range, then only files selected by
that revision range are printed, and the highest revision in the
range is printed. For details about revision specifiers, see 'p4
help revisions'.

The -a flag prints all revisions within the specified range, rather
than just the highest revision in the range.

The -A flag prints files in archive depots.

The -k flag suppresses keyword expansion.

The -o localFile flag redirects the output to the specified file on
the client filesystem.

The -q flag suppresses the initial line that displays the file name
and revision.

The -m flag limits print to the first 'max' number of files.

The -U option prints files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Examples

To get the contents of the file //depot/MyCode/README.txt:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.None, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);

IList<String> target = Repository.GetFileContents(opts, filespec);
 To get the contents of the file //depot/MyCode/README.txt redirecting the contents to local file C:\Doc\README.txt and supressing the file name and revision line:
CopyC#
GetFileContentsCmdOptions opts =
new GetFileContentsCmdOptions(GetFileContentsCmdFlags.Suppress,
"C:\\Doc\\README.txt");

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);

IList<String> target = Repository.GetFileContents(opts, filespec);

See Also

Repository Class
GetFileContentsEx Overload
Perforce.P4 Namespace
Perforce.P4..::..GetFileContentsCmdFlags


GetFileHistory Method

[image] [image]

Perforce .NET API
Repository..::..GetFileHistory Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFileHistory(IList<(Of <<'(FileSpec>)>>), Options) | Get the revision history data for the passed-in file specs.
Public method | GetFileHistory(Options, array<FileSpec>[]()[][]) | Get the revision history data for the passed-in file specs.

See Also

Repository Class
Repository Members


GetFileHistory Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Repository..::..GetFileHistory Method (IList<(Of <(<'FileSpec>)>)>, Options)
Repository Class Example See Also Send Feedback
Get the revision history data for the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileHistory> GetFileHistory(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetFileHistory ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileHistory)
Visual C++
public:
IList<FileHistory^>^ GetFileHistory(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help filelog

filelog -- List revision history of files

p4 filelog [-c changelist# -h -i -l -L -t -m max -p -s] file[revRange] ...

List the revision history of the specified files, from the most
recent revision to the first. If the file specification includes
a revision, the command lists revisions at or prior to the specified
revision. If the file specification includes a revision range,
the command lists only the specified revisions. See 'p4 help revisions'
for details.

The -c changelist# flag displays files submitted at the specified
changelist number.

The -i flag includes inherited file history. If a file was created by
branching (using 'p4 integrate'), filelog lists the revisions of the
file's ancestors up to the branch points that led to the specified
revision. File history inherited by renaming (using 'p4 move') is
always displayed regardless of whether -i is specified.

The -h flag displays file content history instead of file name
history. The list includes revisions of other files that were
branched or copied (using 'p4 integrate' and 'p4 resolve -at') to
the specified revision. Revisions that were replaced by copying
or branching are omitted, even if they are part of the history of
the specified revision.

The -t flag displays the time as well as the date.

The -l flag lists the full text of the changelist descriptions.

The -L flag lists the full text of the changelist descriptions,
truncated to 250 characters if longer.

The -m max displays at most 'max' revisions per file of the file[rev]
argument specified.

The -p flag is used in conjunction with the '-h' flag to prevent
filelog from following content of promoted task streams. This flag
is useful when there are many child task streams branched from the
file argument supplied.

The -s flag displays a shortened form of filelog that omits
non-contributory integrations.

Examples

To get the file history of the file //depot/MyCode/README.txt submitted at change 43578 and showing the full changelist description:
CopyC#
GetFileHistoryCmdOptions opts =
new GetFileHistoryCmdOptions(GetFileHistoryCmdFlags.FullDescription
43578, 0);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<String> target = Repository.GetFileHistory(filespecs, opts);
 To get the file history of the file //depot/MyCode/README.txt showing both time and date for the 10 latest revisions:
CopyC#
GetFileHistoryCmdOptions opts =
new GetFileHistoryCmdOptions(GetFileHistoryCmdFlags.Time,
0, 10)

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<String> target = Repository.GetFileHistory(filespecs, opts);

See Also

Repository Class
GetFileHistory Overload
Perforce.P4 Namespace
Perforce.P4..::..FileLogCmdFlags
Perforce.P4..::..GetFileHistoryCmdFlags


GetFileHistory Method (Options, FileSpec[])

[image]

Perforce .NET API
Repository..::..GetFileHistory Method (Options, array<FileSpec>[]()[][])
Repository Class Example See Also Send Feedback
Get the revision history data for the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileHistory> GetFileHistory(
    Options options,
    params FileSpec[] filespecs
)
Visual Basic
Public Function GetFileHistory ( _
    options As Options, _
    ParamArray filespecs As FileSpec() _
) As IList(Of FileHistory)
Visual C++
public:
IList<FileHistory^>^ GetFileHistory(
    Options^ options,
    ... array<FileSpec^>^ filespecs
)

Parameters

options
Type: Perforce.P4..::..Options
filespecs
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

Remarks

p4 help filelog

filelog -- List revision history of files

p4 filelog [-c changelist# -h -i -l -L -t -m max -p -s] file[revRange] ...

List the revision history of the specified files, from the most
recent revision to the first. If the file specification includes
a revision, the command lists revisions at or prior to the specified
revision. If the file specification includes a revision range,
the command lists only the specified revisions. See 'p4 help revisions'
for details.

The -c changelist# flag displays files submitted at the specified
changelist number.

The -i flag includes inherited file history. If a file was created by
branching (using 'p4 integrate'), filelog lists the revisions of the
file's ancestors up to the branch points that led to the specified
revision. File history inherited by renaming (using 'p4 move') is
always displayed regardless of whether -i is specified.

The -h flag displays file content history instead of file name
history. The list includes revisions of other files that were
branched or copied (using 'p4 integrate' and 'p4 resolve -at') to
the specified revision. Revisions that were replaced by copying
or branching are omitted, even if they are part of the history of
the specified revision.

The -t flag displays the time as well as the date.

The -l flag lists the full text of the changelist descriptions.

The -L flag lists the full text of the changelist descriptions,
truncated to 250 characters if longer.

The -m max displays at most 'max' revisions per file of the file[rev]
argument specified.

The -p flag is used in conjunction with the '-h' flag to prevent
filelog from following content of promoted task streams. This flag
is useful when there are many child task streams branched from the
file argument supplied.

The -s flag displays a shortened form of filelog that omits
non-contributory integrations.

Examples

To get the file history of the file //depot/MyCode/README.txt submitted at change 43578 and showing the full changelist description:
CopyC#
GetFileHistoryCmdOptions opts =
new GetFileHistoryCmdOptions(GetFileHistoryCmdFlags.FullDescription
43578, 0);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);

IList<String> target = Repository.GetFileHistory(opts, filespec);
 To get the file history of the file //depot/MyCode/README.txt showing both time and date for the 10 latest revisions:
CopyC#
GetFileHistoryCmdOptions opts =
new GetFileHistoryCmdOptions(GetFileHistoryCmdFlags.Time,
0, 10)

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);

IList<String> target = Repository.GetFileHistory(opts, filespec);

See Also

Repository Class
GetFileHistory Overload
Perforce.P4 Namespace
Perforce.P4..::..FileLogCmdFlags
Perforce.P4..::..GetFileHistoryCmdFlags


GetFileLineMatches Method

[image]

Perforce .NET API
Repository..::..GetFileLineMatches Method
Repository Class Example See Also Send Feedback
Get a list of matching lines in the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileLineMatch> GetFileLineMatches(
    IList<FileSpec> filespecs,
    string pattern,
    Options options
)
Visual Basic
Public Function GetFileLineMatches ( _
    filespecs As IList(Of FileSpec), _
    pattern As String, _
    options As Options _
) As IList(Of FileLineMatch)
Visual C++
public:
IList<FileLineMatch^>^ GetFileLineMatches(
    IList<FileSpec^>^ filespecs,
    String^ pattern,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
pattern
Type: System..::..String
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help grep

grep -- Print lines matching a pattern

p4 grep [options] -e pattern file[revRange]...

options: -a -i -n -A <num> -B <num> -C <num> -t -s (-v|-l|-L) (-F|-G)

Searches files for lines that match the specified regular expression,
which can contain wildcards. The parser used by the Perforce server
is based on V8 regexp and might not be compatible with later parsers,
but the majority of functionality is available.

By default the head revision is searched. If the file argument includes
a revision specification, all corresponding revisions are searched.
If the file argument includes a revision range, only files in that
range are listed, and the highest revision in the range is searched.
For details about revision specifiers, see 'p4 help revisions'.

The -a flag searches all revisions within the specified range. By
default only the highest revision in the range is searched.

The -i flag causes the pattern matching to be case-insensitive. By
default, matching is case-sensitive.

The -n flag displays the matching line number after the file revision
number. By default, matches are displayed as revision#: <text>.

The -v flag displays files with non-matching lines.

The -F flag is used to interpret the pattern as a fixed string.

The -G flag is used to interpret the pattern as a regular expression,
which is the default behavior.

The -L flag displays the name of each selected file from which no
output would normally have been displayed. Scanning stops on the
first match.

The -l flag displays the name of each selected file containing
matching text. Scanning stops on the first match.

The -s flag suppresses error messages that result from abandoning
files that have a maximum number of characters in a single line that
are greater than 4096. By default, an error is reported when grep
abandons such files.

The -t flag searches binary files. By default, only text files are
searched.

The -A <num> flag displays the specified number of lines of trailing
context after matching lines.

The -B <num> flag displays the specified number of lines of leading
context before matching lines.

The -C <num> flag displays the specified number of lines of output
context.

Regular expressions:

A regular expression is zero or more branches, separated by `|'. It
matches anything that matches one of the branches.

A branch is zero or more pieces, concatenated. It matches a match
for the first, followed by a match for the second, etc.

A piece is an atom possibly followed by `*', `+', or `?'. An atom
followed by `*' matches a sequence of 0 or more matches of the atom.
An atom followed by `+' matches a sequence of 1 or more matches of
the atom. An atom followed by `?' matches a match of the atom, or
the null string.

An atom is a regular expression in parentheses (matching a match for
the regular expression), a range (see below), `.' (matching any
single character), `^' (matching the null string at the beginning
of the input string), `$' (matching the null string at the end of
the input string), a `\' followed by a single character (matching
that character), or a single character with no other significance
(matching that character).

A range is a sequence of characters enclosed in `[]'. It normally
matches any single character from the sequence. If the sequence
begins with `^', it matches any single character not from the rest
of the sequence. If two characters in the sequence are separated by
`-', this is shorthand for the full list of ASCII characters between
them (e.g. `[0-9]' matches any decimal digit). To include a literal
`]' in the sequence, make it the first character (following a possible
`^'). To include a literal `-', make it the first or last character.

The symbols '\<' and '\>' respectively match the empty string at
the beginning and end of a word.

Examples

To get the file line matches for the pattern "OpenConnection" in the file //depot/main/Program.cs with case-insensitive search:
CopyC#
GetFileLineMatchesCmdOptions opts =
new GetFileLineMatchesCmdOptions(GetFileLineMatchesCmdFlags.CaseInsensitive,
0, 0, 0);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/main/Program.cs"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileLineMatch> target =
Repository.GetFileLineMatches(filespecs, "OpenConnection" opts);
 To get the file line matches for the pattern "OpenConnection" in the file //depot/main/Program.cs showing 2 lines before and after the found pattern and showing line numbers:
CopyC#
GetFileLineMatchesCmdOptions opts =
new GetFileLineMatchesCmdOptions(GetFileLineMatchesCmdFlags.IncludeLineNumbers,
2, 2, 0);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/main/Program.cs"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileLineMatch> target =
Repository.GetFileLineMatches(filespecs, "OpenConnection" opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetFileLineMatchesCmdFlags


GetFileMetaData Method

[image] [image]

Perforce .NET API
Repository..::..GetFileMetaData Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFileMetaData(IList<(Of <<'(FileSpec>)>>), Options) |
Public method | GetFileMetaData(Options, array<FileSpec>[]()[][]) |

See Also

Repository Class
Repository Members


GetFileMetaData Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Repository..::..GetFileMetaData Method (IList<(Of <(<'FileSpec>)>)>, Options)
Repository Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileMetaData> GetFileMetaData(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetFileMetaData ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileMetaData)
Visual C++
public:
IList<FileMetaData^>^ GetFileMetaData(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

See Also

Repository Class
GetFileMetaData Overload


GetFileMetaData Method (Options, FileSpec[])

[image]

Perforce .NET API
Repository..::..GetFileMetaData Method (Options, array<FileSpec>[]()[][])
Repository Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileMetaData> GetFileMetaData(
    Options options,
    params FileSpec[] filespecs
)
Visual Basic
Public Function GetFileMetaData ( _
    options As Options, _
    ParamArray filespecs As FileSpec() _
) As IList(Of FileMetaData)
Visual C++
public:
IList<FileMetaData^>^ GetFileMetaData(
    Options^ options,
    ... array<FileSpec^>^ filespecs
)

Parameters

options
Type: Perforce.P4..::..Options
filespecs
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

Repository Class
GetFileMetaData Overload


GetFiles Method

[image] [image]

Perforce .NET API
Repository..::..GetFiles Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFiles(IList<(Of <<'(FileSpec>)>>), Options) | Return a list of Files in the depot that correspond to the passed-in FileSpecs.
Public method | GetFiles(Options, array<FileSpec>[]()[][]) | Return a list of Files in the depot that correspond to the passed-in FileSpecs.

See Also

Repository Class
Repository Members


GetFiles Method (IList(FileSpec), Options)

[image]

Perforce .NET API
Repository..::..GetFiles Method (IList<(Of <(<'FileSpec>)>)>, Options)
Repository Class Example See Also Send Feedback
Return a list of Files in the depot that correspond to the passed-in FileSpecs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<File> GetFiles(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetFiles ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of File)
Visual C++
public:
IList<File^>^ GetFiles(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Remarks

p4 help files

files -- List files in the depot

p4 files [ -a ] [ -A ] [ -e ] [ -m max ] file[revRange] ...
p4 files -U unloadfile ...

List details about specified files: depot file name, revision,
file, type, change action and changelist number of the current
head revision. If client syntax is used to specify the file
argument, the client view mapping is used to determine the
corresponding depot files.

By default, the head revision is listed. If the file argument
specifies a revision, then all files at that revision are listed.
If the file argument specifies a revision range, the highest revision
in the range is used for each file. For details about specifying
revisions, see 'p4 help revisions'.

The -a flag displays all revisions within the specific range, rather
than just the highest revision in the range.

The -A flag displays files in archive depots.

The -e flag displays files with an action of anything other than
deleted, purged or archived. Typically this revision is always
available to sync or integrate from.

The -m flag limits files to the first 'max' number of files.

The -U option displays files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Examples

To get Files in local depot //depot/...:
CopyC#
FileSpec fs = new FileSpec(new DepotPath("//depot/..."), null);
IList<FileSpec> lfs = new List<FileSpec>();
lfs.Add(fs);

GetDepotFilesCmdOptions opts =
new GetDepotFilesCmdOptions(GetDepotFilesCmdFlags.None, 0);

IList<File> target = Repository.GetFiles(lfs, opts);
 To get Files in unload depot //Unloaded/...:
CopyC#
FileSpec fs = new FileSpec(new DepotPath("//Unloaded/..."), null);
IList<FileSpec> lfs = new List<FileSpec>();
lfs.Add(fs);

GetDepotFilesCmdOptions opts =
new GetDepotFilesCmdOptions(GetDepotFilesCmdFlags.InUnloadDepot, 0);

IList<File> target = Repository.GetFiles(lfs, opts);

See Also

Repository Class
GetFiles Overload
Perforce.P4 Namespace
Perforce.P4..::..GetDepotFilesCmdFlags


GetFiles Method (Options, FileSpec[])

[image]

Perforce .NET API
Repository..::..GetFiles Method (Options, array<FileSpec>[]()[][])
Repository Class Example See Also Send Feedback
Return a list of Files in the depot that correspond to the passed-in FileSpecs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<File> GetFiles(
    Options options,
    params FileSpec[] filespecs
)
Visual Basic
Public Function GetFiles ( _
    options As Options, _
    ParamArray filespecs As FileSpec() _
) As IList(Of File)
Visual C++
public:
IList<File^>^ GetFiles(
    Options^ options,
    ... array<FileSpec^>^ filespecs
)

Parameters

options
Type: Perforce.P4..::..Options
filespecs
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Remarks

p4 help files

files -- List files in the depot

p4 files [ -a ] [ -A ] [ -e ] [ -m max ] file[revRange] ...
p4 files -U unloadfile ...

List details about specified files: depot file name, revision,
file, type, change action and changelist number of the current
head revision. If client syntax is used to specify the file
argument, the client view mapping is used to determine the
corresponding depot files.

By default, the head revision is listed. If the file argument
specifies a revision, then all files at that revision are listed.
If the file argument specifies a revision range, the highest revision
in the range is used for each file. For details about specifying
revisions, see 'p4 help revisions'.

The -a flag displays all revisions within the specific range, rather
than just the highest revision in the range.

The -A flag displays files in archive depots.

The -e flag displays files with an action of anything other than
deleted, purged or archived. Typically this revision is always
available to sync or integrate from.

The -m flag limits files to the first 'max' number of files.

The -U option displays files in the unload depot (see 'p4 help unload'
for more information about the unload depot).

Examples

To get Files in local depot //depot/...:
CopyC#
GetDepotFilesCmdOptions opts =
new GetDepotFilesCmdOptions(GetDepotFilesCmdFlags.None, 0);

FileSpec fs = new FileSpec(new DepotPath("//depot/..."), null);

IList<File> target = Repository.GetFiles(opts, fs);
 To get Files in unload depot //Unloaded/...:
CopyC#
GetDepotFilesCmdOptions opts =
new GetDepotFilesCmdOptions(GetDepotFilesCmdFlags.InUnloadDepot, 0);

FileSpec fs = new FileSpec(new DepotPath("//Unloaded/..."), null);

IList<File> target = Repository.GetFiles(opts, fs);

See Also

Repository Class
GetFiles Overload
Perforce.P4 Namespace
Perforce.P4..::..GetDepotFilesCmdFlags


GetFixes Method

[image]

Perforce .NET API
Repository..::..GetFixes Method
Repository Class Example See Also Send Feedback
List fixes affecting files and / or jobs and / or changelists.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Fix> GetFixes(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetFixes ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of Fix)
Visual C++
public:
IList<Fix^>^ GetFixes(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help fixes

fixes -- List jobs with fixes and the changelists that fix them

p4 fixes [-i -m max -c changelist# -j jobName] [file[revRange] ...]

'p4 fixes' list fixed jobs and the number of the changelist that
contains the fix. Fixes are associated with changelists using the
'p4 fix' command or by editing and submitting changelists.

The 'p4 fixes' command lists both submitted and pending changelists.

By default, 'p4 fixes' lists all fixes. This list can be limited
as follows: to list fixes for a specified job, use the -j jobName
flag. To list fixes for a specified changelist, use -c changelist#.
To list fixes that affect specified files, include the file argument.
The file pattern can include wildcards and revision specifiers. For
details about revision specifiers, see 'p4 help revisions'

The -i flag also includes any fixes made by changelists integrated
into the specified files.

The -m max flag limits output to the specified number of job
fixes.

Examples

To list the fixes related to job000001:
CopyC#
   GetFixesCmdOptions opts =
   new GetFixesCmdOptions(GetFixesCmdFlags.None, 0, "job000001", 0);

FileSpec filespec =
new FileSpec(new DepotPath("//..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

   IList<Fix> target = Repository.GetFixes(filespecs, opts);
 To list the fixes related to changelist 47921:
CopyC#
   GetFixesCmdOptions opts =
   new GetFixesCmdOptions(GetFixesCmdFlags.None, 47921, null, 0);

FileSpec filespec =
new FileSpec(new DepotPath("//..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

   IList<Fix> target = Repository.GetFixes(filespecs, opts);
 To list the fixes related to path //depot/rel/src that occurred between 2014/1/1 and 2014/1/31:
CopyC#
   GetFixesCmdOptions opts =
   new GetFixesCmdOptions(GetFixesCmdFlags.None, 0, null, 0);

VersionRange vr = new VersionRange(new DateTimeVersion(new DateTime(2014, 1, 1)),
new DateTimeVersion(new DateTime(2014, 1, 31)));

FileSpec filespec =
new FileSpec(new DepotPath("//..."), vr);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

   IList<Fix> target = Repository.GetFixes(filespecs, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetFixesCmdFlags


GetFormSpec Method

[image]

Perforce .NET API
Repository..::..GetFormSpec Method
Repository Class Example See Also Send Feedback
Get a FormSpec of the specified form type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec GetFormSpec(
    Options options,
    string spectype
)
Visual Basic
Public Function GetFormSpec ( _
    options As Options, _
    spectype As String _
) As FormSpec
Visual C++
public:
FormSpec^ GetFormSpec(
    Options^ options,
    String^ spectype
)

Parameters

options
Type: Perforce.P4..::..Options
spectype
Type: System..::..String

Return Value

Remarks

p4 help spec

spec -- Edit spec comments and formatting hints (unsupported)

p4 spec [-d -i -o] type

Edit any type of specification: branch, change, client, depot,
group, job, label, spec, stream, triggers, typemap, or user. Only
the comments and the formatting hints can be changed. Any fields
that you add during editing are discarded when the spec is saved.

'p4 jobspec' is equivalent to 'p4 spec job', and any custom spec
(including the job spec) can be deleted with 'p4 spec -d type'.

Examples

To get the FormSpec for changelist:
CopyC#
Options ops = new Options();
ops["-o"] = null;

FormSpec target = Repository.GetFormSpec(ops, "change");
 To get the FormSpec for client:
CopyC#
Options ops = new Options();
ops["-o"] = null;

FormSpec target = Repository.GetFormSpec(ops, "clinet");
 To get the FormSpec for user:
CopyC#
Options ops = new Options();
ops["-o"] = null;

FormSpec target = Repository.GetFormSpec(ops, "user");

See Also

Repository Class


GetGroup Method

[image] [image]

Perforce .NET API
Repository..::..GetGroup Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGroup(String) | Get the record for an existing group from the repository.
Public method | GetGroup(String, Options) | Get the record for an existing group from the repository.

See Also

Repository Class
Repository Members


GetGroup Method (String)

[image]

Perforce .NET API
Repository..::..GetGroup Method (String)
Repository Class Example See Also Send Feedback
Get the record for an existing group from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group GetGroup(
    string group
)
Visual Basic
Public Function GetGroup ( _
    group As String _
) As Group
Visual C++
public:
Group^ GetGroup(
    String^ group
)

Parameters

group
Type: System..::..String
Group name

Return Value

The Group object if new group was found, null if creation failed

Examples

To get the group 'everyone':
CopyC#
string targetGroup = "everyone";
IList<Group> group = _repository.getGroup(targetGroup);

See Also

Repository Class
GetGroup Overload


GetGroup Method (String, Options)

[image]

Perforce .NET API
Repository..::..GetGroup Method (String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing group from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group GetGroup(
    string group,
    Options options
)
Visual Basic
Public Function GetGroup ( _
    group As String, _
    options As Options _
) As Group
Visual C++
public:
Group^ GetGroup(
    String^ group,
    Options^ options
)

Parameters

group
Type: System..::..String
Group name
options
Type: Perforce.P4..::..Options
The Owner Access flag (-a) needs to be used if a user without 'super' access is an 'owner' of that group.

Return Value

The Group object if new group was found, null if creation failed

Examples

To get the group 'everyone' when connected as a user with super access:
CopyC#
string targetGroup = "everyone";
Group group = _repository.GetGroup(targetGroup, null);
 To get the group 'Mygroup' when connected as a without super access who is the owner of that group:
CopyC#
string targetGroup = "everyone";
GroupCmdOptions opts = new GroupCmdOptions(GroupCmdFlags.OwnerAccess);
Group group = _repository.GetGroup(targetGroup, opts);

See Also

Repository Class
GetGroup Overload
Perforce.P4 Namespace
Perforce.P4..::..GroupCmdFlags


GetGroups Method

[image]

Perforce .NET API
Repository..::..GetGroups Method
Repository Class Example See Also Send Feedback
Get a list of groups from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Group> GetGroups(
    Options options,
    params string[] groups
)
Visual Basic
Public Function GetGroups ( _
    options As Options, _
    ParamArray groups As String() _
) As IList(Of Group)
Visual C++
public:
IList<Group^>^ GetGroups(
    Options^ options,
    ... array<String^>^ groups
)

Parameters

options
Type: Perforce.P4..::..Options
options for the groups commandGroupsCmdOptions
groups
Type: array< System..::..String >[]()[][]

Return Value

A list containing the matching groups

Remarks

p4 help groups

groups -- List groups (of users)

p4 groups [-m max] [-v] [group]
p4 groups [-m max] [-i [-v]] user | group
p4 groups [-m max] [-g | -u | -o] name

The first form lists all user groups defined in the server, or just
the specified group.

The second form displays subgroup relationships. If a user argument is
specified, only groups containing that user are displayed. If a group
argument is specified, only groups containing the group are displayed.

The third form is useful when there are groups and users with the
same name, or when requesting all groups owned by a certain user.

The -i flag also displays groups that the user or group belongs to
indirectly by means of membership in subgroups.

The -m max flag limits output to the specified number of groups.

The -v flag displays the MaxResults, MaxScanRows, MaxLockTime, and
Timeout values for each group that is displayed.

The -g flag indicates that the 'name' argument is a group.

The -u flag indicates that the 'name' argument is a user.

The -o flag indicates that the 'name' argument is an owner.

Examples

To get the first 10 groups:
CopyC#
Options opts = new Options(GroupsCmdFlags.None, 10);
IList<Group> groups = _repository.getGroups(opts);
 To get all groups that 'Bob' belongs to, including subgroups:
CopyC#
Options opts = new Options(GroupsCmdFlags.IncludeIndirect, -1);
IList<Group> groups = _repository.getGroups(opts, "Bob");
 To get all the groups with the MaxResults, MaxScanRows, MaxLockTime, and Timeout values for the specified group:
CopyC#
Options opts = new Options(GroupsCmdFlags.IncludeAllValues, -1);
IList<Group> groups = _repository.getGroups(opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GroupsCmdFlags


GetJob Method

[image] [image]

Perforce .NET API
Repository..::..GetJob Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetJob(String) | Get the record for an existing job from the repository.
Public method | GetJob(String, Options) | Get the record for an existing job from the repository.

See Also

Repository Class
Repository Members


GetJob Method (String)

[image]

Perforce .NET API
Repository..::..GetJob Method (String)
Repository Class Example See Also Send Feedback
Get the record for an existing job from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Job GetJob(
    string job
)
Visual Basic
Public Function GetJob ( _
    job As String _
) As Job
Visual C++
public:
Job^ GetJob(
    String^ job
)

Parameters

job
Type: System..::..String
Job name

Return Value

The Job object if new job was found, null if the requested job does not exist

Examples

Get the record for job 'job000001':
CopyC#
Job job = _repository.GetJob("job000001");

See Also

Repository Class
GetJob Overload


GetJob Method (String, Options)

[image]

Perforce .NET API
Repository..::..GetJob Method (String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing job from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Job GetJob(
    string job,
    Options options
)
Visual Basic
Public Function GetJob ( _
    job As String, _
    options As Options _
) As Job
Visual C++
public:
Job^ GetJob(
    String^ job,
    Options^ options
)

Parameters

job
Type: System..::..String
Job name
options
Type: Perforce.P4..::..Options
There are no valid flags to use when fetching an existing job

Return Value

The Job object if new job was found, null if the requested job does not exist

Examples

Get the record for job 'job000001':
CopyC#
Job job = _repository.GetJob("job000001", null);

See Also

Repository Class
GetJob Overload


GetJobs Method

[image]

Perforce .NET API
Repository..::..GetJobs Method
Repository Class Example See Also Send Feedback
Get a list of jobs from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Job> GetJobs(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function GetJobs ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of Job)
Visual C++
public:
IList<Job^>^ GetJobs(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
options for the jobs command[!:JobsOptions]
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

A list containing the matching jobs

Remarks

p4 help jobs

jobs -- Display list of jobs

p4 jobs [-e jobview -i -l -m max -r] [file[revRange] ...]
p4 jobs -R

Lists jobs in the server. If a file specification is included, fixes
for submitted changelists affecting the specified files are listed.
The file specification can include wildcards and a revision range.
See 'p4 help revisions' for details about specifying revisions.

The -e flag lists jobs matching the expression specified in the
jobview parameter. For a description of jobview syntax, see 'p4 help
jobview'.

The -i flag includes any fixes made by changelists integrated into
the specified files.

The -l flag produces long output with the full text of the job
descriptions.

The -m max flag limits the output to the first 'max' jobs, ordered
by their job name.

The -r flag sorts the jobs in reverse order (by job name).

The -R flag rebuilds the jobs table and reindexes each job, which
is necessary after upgrading to 98.2. 'p4 jobs -R' requires that the
user be an operator or have 'super' access granted by 'p4 protect'.

Examples

To get a list of 100 jobs that include files under a given filepath:
CopyC#
FileSpec path = new FileSpec(new DepotPath(@"//depot/..."), null);
IList<Job> jobs = rep.GetJobs((new Options(JobsCmdFlags.LongDescriptions, null, 100)), path);
 To get a list of 100 jobs with the status "open":
CopyC#
string jobView = "status=open";
IList<Job> jobs = rep.GetJobs((new Options(JobsCmdFlags.LongDescriptions, jobView, 100)), path);
 To get a list of 10 jobs in reverse order:
CopyC#
IList<Job> jobs = rep.GetJobs((new Options(JobsCmdFlags.ReverseSort, null, 10));
 To get a list of 10 jobs that include any fixes made by changelists integrated into the specified files:
CopyC#
FileSpec path = new FileSpec(new DepotPath(@"//depot/..."), null);
IList<Job> jobs = rep.GetJobs((new Options(JobsCmdFlags.IncludeIntegratedFixes, null, 10)), path);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..JobsCmdFlags


GetLabel Method

[image] [image]

Perforce .NET API
Repository..::..GetLabel Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLabel(String) | Get the record for an existing label from the repository.
Public method | GetLabel(String, String, Options) | Get the record for an existing label from the repository.

See Also

Repository Class
Repository Members


GetLabel Method (String)

[image]

Perforce .NET API
Repository..::..GetLabel Method (String)
Repository Class Example See Also Send Feedback
Get the record for an existing label from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Label GetLabel(
    string label
)
Visual Basic
Public Function GetLabel ( _
    label As String _
) As Label
Visual C++
public:
Label^ GetLabel(
    String^ label
)

Parameters

label
Type: System..::..String
Label name

Return Value

The Label object if label was found, null if creation failed

Examples

To get the admin_label:
CopyC#
string targetLabel = "admin_label";
Label l = rep.GetLabel(targetLabel);

See Also

Repository Class
GetLabel Overload


GetLabel Method (String, String, Options)

[image]

Perforce .NET API
Repository..::..GetLabel Method (String, String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing label from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Label GetLabel(
    string label,
    string template,
    Options options
)
Visual Basic
Public Function GetLabel ( _
    label As String, _
    template As String, _
    options As Options _
) As Label
Visual C++
public:
Label^ GetLabel(
    String^ label,
    String^ template,
    Options^ options
)

Parameters

label
Type: System..::..String
Label name
template
Type: System..::..String
options
Type: Perforce.P4..::..Options
Flags used when fetching an existing label

Return Value

The Label object if label was found, null if creation failed

Examples

To get the admin_label with the gobal option:
CopyC#
LabelCmdOptions opts = new LabelCmdOptions(LabelCmdFlags.Global,null);
Label label = rep.GetLabel("admin_label", null, opts);

See Also

Repository Class
GetLabel Overload


GetLabels Method

[image]

Perforce .NET API
Repository..::..GetLabels Method
Repository Class Example See Also Send Feedback
Get a list of labels from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Label> GetLabels(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function GetLabels ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of Label)
Visual C++
public:
IList<Label^>^ GetLabels(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

Return Value

A list containing the matching labels

Remarks

p4 help labels

labels -- Display list of defined labels

p4 labels [-t] [-u user] [[-e|-E] nameFilter -m max] [file[revrange]]
p4 labels [-t] [-u user] [[-e|-E] nameFilter -m max] [-a|-s serverID]
p4 labels -U

Lists labels defined in the server.

If files are specified, 'p4 labels' lists the labels that contain
those files. If you include a file specification, automatic labels
and labels with the 'autoreload' option set are omitted from the list.
If the file specification includes a revision range, 'p4 labels'
lists labels that contain the specified revisions.

See 'p4 help revisions' for details about specifying revisions.

The -t flag displays the time as well as the date.

The -u user flag lists labels owned by the specified user.

The -e nameFilter flag lists labels with a name that matches
the nameFilter pattern, for example: -e 'svr-dev-rel*'. The -e flag
uses the server's normal case-sensitivity rules. The -E flag makes
the matching case-insensitive, even on a case-sensitive server.

The -m max flag limits output to the first 'max' number of labels.

The -U flag lists unloaded labels (see 'p4 help unload').

The -a and -s flags are useful in a distributed server installation
(see 'p4 help distributed') in order to see the names of local labels
stored on other Edge Servers. These flags are not allowed if the
command includes a file specification.

The -a flag specifies that all labels should be displayed, not just
those that are bound to this server.

The -s serverID flag specifies that only those labels bound to the
specified serverID should be displayed.

On an Edge Server, if neither -s nor -a is specified, only those
local labels bound to this Edge Server are displayed. Labels created
on the Commit Server are global, and are also included in the output.

Examples

To get 50 labels on a distributed server installation:
CopyC#
LabelsCmdOptions opts = new LabelsCmdOptions(LabelsCmdFlags.All,
    null, null, 50, null, null);
IList<Label> labels = rep.GetLabels(opts);
 To get labels which contain files with the path //depot/Modifiers/...:
CopyC#
FileSpec path = new FileSpec(new DepotPath("//depot/Modifiers/..."), null);
Options ops = new Options();
IList<Label> l = rep.GetLabels(ops, path);

See Also

Repository Class


GetOpenedFiles Method

[image]

Perforce .NET API
Repository..::..GetOpenedFiles Method
Repository Class Example See Also Send Feedback
Return a list of Files opened by users / clients.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<File> GetOpenedFiles(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetOpenedFiles ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of File)
Visual C++
public:
IList<File^>^ GetOpenedFiles(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help opened

opened -- List open files and display file status

p4 opened [-a -c changelist# -C client -u user -m max -s] [file ...]
p4 opened [-a -x -m max ] [file ...]

Lists files currently opened in pending changelists, or, for
specified files, show whether they are currently opened or locked.
If the file specification is omitted, all files open in the current
client workspace are listed.

Files in shelved changelists are not displayed by this command. To
display shelved changelists, see 'p4 changes -s shelved'; to display
the files in those shelved changelists, see 'p4 describe -s -S'.

The -a flag lists opened files in all clients. By default, only
files opened by the current client are listed.

The -c changelist# flag lists files opened in the specified
changelist#.

The -C client flag lists files open in the specified client workspace.

The -u user flag lists files opened by the specified user.

The -m max flag limits output to the first 'max' number of files.

The -s option produces 'short' and optimized output when used with
the -a (all clients) option. For large repositories '-a' can take
a long time when compared to '-as'.

The -x option lists files that are opened 'exclusive'. This option
only applies to a distributed installation where global tracking of
these file types is necessary across servers. The -x option implies
the -a option.

Examples

To get a maximum of 10 opened files from the repository, opened by user fred, opened with any client:
CopyC#
FileSpec fs = new FileSpec(new DepotPath("//..."), null);

List<FileSpec> lfs = new List<FileSpec>();
lfs.Add(fs);

// null for changelist and client options
GetOpenedFilesOptions opts =
new GetOpenedFilesOptions(GetOpenedFilesCmdFlags.AllClients,
null, null, "fred", 10);

IList<File> target = Repository.GetOpenedFiles(lfs, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetOpenedFilesCmdFlags


GetProtectionEntries Method

[image]

Perforce .NET API
Repository..::..GetProtectionEntries Method
Repository Class Example See Also Send Feedback
Get a list of Perforce protection entries for the passed-in file specs

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<ProtectionEntry> GetProtectionEntries(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetProtectionEntries ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of ProtectionEntry)
Visual C++
public:
IList<ProtectionEntry^>^ GetProtectionEntries(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help protects

protects -- Display protections defined for a specified user and path

p4 protects [-a | -g group | -u user] [-h host] [-m] [file ...]

'p4 protects' displays the lines from the protections table that
apply to the current user. The protections table is managed using
the 'p4 protect' command.

If the -a flag is specified, protection lines for all users are
displayed. If the -g group flag or -u user flag is specified,
protection lines for that group or user are displayed.

If the -h host flag is specified, the protection lines that apply
to the specified host (IP address) are displayed.

If the -m flag is given, a single word summary of the maximum
access level is reported. Note that this summary does not take
exclusions or the specified file path into account.

If the file argument is specified, protection lines that apply to
the specified files are displayed.

The -a/-g/-u flags require 'super' access granted by 'p4 protect'.

Examples

To get the protections for the user tim for the entire server:
CopyC#
GetProtectionEntriesCmdOptions opts =
new GetProtectionEntriesCmdOptions(GetProtectionEntriesCmdFlags.None,
null, "tim", null);

FileSpec filespec =
new FileSpec(new DepotPath("//..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<ProtectionEntry> target =
Repository.GetProtectionEntries(filespecs, opts);
 To get the protections summary for the group development tim for the entire server when connecting from IP address 10.24.4.6:
CopyC#
GetProtectionEntriesCmdOptions opts =
new GetProtectionEntriesCmdOptions(GetProtectionEntriesCmdFlags.AccessSummary,
"development", null, "10.24.4.6");

FileSpec filespec =
new FileSpec(new DepotPath("//..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<ProtectionEntry> target =
Repository.GetProtectionEntries(filespecs, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetProtectionEntriesCmdFlags


GetProtectionTable Method

[image]

Perforce .NET API
Repository..::..GetProtectionTable Method
Repository Class Example See Also Send Feedback
Get the repository's protection table.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<ProtectionEntry> GetProtectionTable(
    Options options
)
Visual Basic
Public Function GetProtectionTable ( _
    options As Options _
) As IList(Of ProtectionEntry)
Visual C++
public:
IList<ProtectionEntry^>^ GetProtectionTable(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help protect

protect -- Modify protections in the server namespace

p4 protect
p4 protect -o
p4 protect -i

'p4 protect' edits the protections table in a text form.

Each line in the table contains a protection mode, a group/user
indicator, the group/user name, client host ID and a depot file
path pattern. Users receive the highest privilege that is granted
on any line.

Note: remote depots are accessed using the pseudo-user 'remote'.
To control access from other servers that define your server as
a remote server, grant appropriate permissions to the 'remote' user.

Mode: The permission level or right being granted or denied.
Each permission level includes all the permissions above
it, except for 'review'. Each permission only includes
the specific right and no lesser rights. This approach
enables you to deny individual rights without having to
re-grant lesser rights. Modes prefixed by '=' are rights.
All other modes are permission levels.

Valid modes are:

list - users can see names but not contents of files;
users can see all non-file related metadata
(clients, users, changelists, jobs, etc.)

read - users can sync, diff, and print files

open - users can open files (add, edit. delete,
integrate)

write - users can submit open files

admin - permits those administrative commands and
command options that don't affect the server's
security.

super - access to all commands and command options.

review - permits access to the 'p4 review' command;
implies read access

=read - if this right is denied, users can't sync,
diff, or print files

=branch - if this right is denied, users are not
permitted to use files as a source
for 'p4 integrate'

=open = if this right is denied, users cannot open
files (add, edit, delete, integrate)

=write = if this right is denied, users cannot submit
open files

Group/User indicator: specifies the grantee is a group or user.

Name: A Perforce group or user name; can include wildcards.

Host: The IP address of a client host; can include wildcards.

The server can distinguish connections coming from a
proxy, broker, or replica. The server prepends the string
'proxy-' to the IP address of the true client of such
a connection when the server enforces the protections.

Specify the 'proxy-' prefix for the IP address in the
Host: field in the protections table to indicate the
protections that should thus apply.

For example, 'proxy-*' applies to all connections from
all proxies, brokers, and replicas, while
'proxy-10.0.0.5' identifies a client machine with an IP
address of 10.0.0.5 which is connecting to p4d through
a proxy, broker, or replica.

If you wish to write a single set of protections entries
which apply both to directly-connected clients as well
as to those which connect via a proxy, broker, or
replica, you can omit the 'proxy-' prefix and also set
dm.proxy.protects=0. In this case, the 'proxy-' prefix
is not prepended to the IP address of connections which
are made via a proxy, replica or broker. Note that in
this scenario, all intermediate proxies, brokers, and
replicas should be at release 2012.1 or higher.

Path: The part of the depot to which access is being granted
or denied. To deny access to a depot path, preface the
path with a "-" character. These exclusionary mappings
apply to all access levels, even if only one access
level is specified in the first field.

The -o flag writes the protection table to the standard output.
The user's editor is not invoked.

The -i flag reads the protection table from the standard input.
The user's editor is not invoked.

After protections are defined, 'p4 protect' requires 'super'
access.

Examples

To get the protections table:
CopyC#
GetProtectionTableCmdOptions opts =
new GetProtectionTableCmdOptions(GetProtectionTableCmdFlags.Output);

IList<ProtectionEntry> target = Repository.GetProtectionTable(opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetProtectionTableCmdFlags


GetReviewers Method

[image]

Perforce .NET API
Repository..::..GetReviewers Method
Repository Class Example See Also Send Feedback
List Perforce users assigned to review files.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<User> GetReviewers(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetReviewers ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of User)
Visual C++
public:
IList<User^>^ GetReviewers(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help reviews

reviews -- List the users who are subscribed to review files

p4 reviews [-C client] [-c changelist#] [file ...]

'p4 reviews' lists all users who have subscribed to review the
specified files.

The -c flag limits the files to the submitted changelist.

The -C flag limits the files to those opened in the specified clients
workspace, when used with the -c flag limits the workspace to files
opened in the specified changelist.

To subscribe to review files, issue the 'p4 user' command and edit
the 'Reviews field'.

Examples

To get the list of users who are reviewing submits to //depot/main/src:
CopyC#
GetReviewersCmdOptions opts =
new GetReviewersCmdOptions(GetReviewersCmdFlags.None, 0);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/main/src/..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<ProtectionEntry> target =
Repository.GetProtectionEntries(filespecs, opts);
 To get the list of users who are reviewing submitted changelist 83476:
CopyC#
GetReviewersCmdOptions opts =
new GetReviewersCmdOptions(GetReviewersCmdFlags.None, 83476);

FileSpec filespec =
new FileSpec(new DepotPath("//..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<ProtectionEntry> target =
Repository.GetProtectionEntries(filespecs, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetProtectionEntriesCmdFlags


GetServerMetaData Method

[image] [image]

Perforce .NET API
Repository..::..GetServerMetaData Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetServerMetaData()()()() | Obsolete.
Public method | GetServerMetaData(Options) | Get server information.

See Also

Repository Class
Repository Members


GetServerMetaData Method

[image]

Perforce .NET API
Repository..::..GetServerMetaData Method
Repository Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[ObsoleteAttribute]
public ServerMetaData GetServerMetaData()
Visual Basic
<ObsoleteAttribute> _
Public Function GetServerMetaData As ServerMetaData
Visual C++
[ObsoleteAttribute]
public:
ServerMetaData^ GetServerMetaData()

Return Value

See Also

Repository Class
GetServerMetaData Overload


GetServerMetaData Method (Options)

[image]

Perforce .NET API
Repository..::..GetServerMetaData Method (Options)
Repository Class Example See Also Send Feedback
Get server information.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerMetaData GetServerMetaData(
    Options options
)
Visual Basic
Public Function GetServerMetaData ( _
    options As Options _
) As ServerMetaData
Visual C++
public:
ServerMetaData^ GetServerMetaData(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

Return Value

Information about a connection's client-side application context.

Remarks

p4 help info

info -- Display client/server information

p4 info [-s]

Info lists information about the current client (user name,
client name, applicable client root, client current directory,
and the client IP address) and some server information (server
IP address, server root, date, uptime, version and license data).

The -s option produces 'short' output that omits any information
that requires a database lookup such as the client root).

Examples

To get the server root:
CopyC#
ServerMetaData s = rep.GetServerMetaData(null);
string root = s.Root;
 To get the server case handling:
CopyC#
ServerMetaData s = rep.GetServerMetaData(null);
bool caseSensitive = s.CaseSensitive;

See Also

Repository Class
GetServerMetaData Overload


GetStream Method

[image] [image]

Perforce .NET API
Repository..::..GetStream Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetStream(String) | Get the record for an existing stream from the repository.
Public method | GetStream(String, String, Options) | Get the record for an existing stream from the repository.

See Also

Repository Class
Repository Members


GetStream Method (String)

[image]

Perforce .NET API
Repository..::..GetStream Method (String)
Repository Class Example See Also Send Feedback
Get the record for an existing stream from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream GetStream(
    string stream
)
Visual Basic
Public Function GetStream ( _
    stream As String _
) As Stream
Visual C++
public:
Stream^ GetStream(
    String^ stream
)

Parameters

stream
Type: System..::..String
Stream name

Return Value

The Stream object if new stream was found, null if creation failed

Examples

Get the stream with the stream Id "//Rocket/GUI":
CopyC#
string targetStream = "//Rocket/GUI";
Stream s = rep.GetStream(targetStream);

See Also

Repository Class
GetStream Overload


GetStream Method (String, String, Options)

[image]

Perforce .NET API
Repository..::..GetStream Method (String, String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing stream from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream GetStream(
    string stream,
    string parent,
    Options options
)
Visual Basic
Public Function GetStream ( _
    stream As String, _
    parent As String, _
    options As Options _
) As Stream
Visual C++
public:
Stream^ GetStream(
    String^ stream,
    String^ parent,
    Options^ options
)

Parameters

stream
Type: System..::..String
Stream name
parent
Type: System..::..String
options
Type: Perforce.P4..::..Options
There are no valid flags to use when fetching an existing stream

Return Value

The Stream object if new stream was found, null if creation failed

Examples

Get the stream with the stream Id "//Rocket/GUI":
CopyC#
string targetStream = "//Rocket/GUI";
Stream s = rep.GetStream(targetStream, null, null);
 Get stream spec for a new development type stream with the parent //Rocket/MAIN:
CopyC#
string targetStream = "//Rocket/GUI2";
string parentStream = "//Rocket/MAIN";
Stream stream = rep.GetStream(targetStream, parentStream,
    new StreamCmdOptions(StreamCmdFlags.None, parentStream,
    StreamType.Development.ToString()));

See Also

Repository Class
GetStream Overload


GetStreamMetaData Method

[image]

Perforce .NET API
Repository..::..GetStreamMetaData Method
Repository Class Example See Also Send Feedback
Get the integration status for a stream in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamMetaData GetStreamMetaData(
    Stream stream,
    Options options
)
Visual Basic
Public Function GetStreamMetaData ( _
    stream As Stream, _
    options As Options _
) As StreamMetaData
Visual C++
public:
StreamMetaData^ GetStreamMetaData(
    Stream^ stream,
    Options^ options
)

Parameters

stream
Type: Perforce.P4..::..Stream
The stream to get integration status on
options
Type: Perforce.P4..::..Options
options for the istat command

Return Value

The integration status of the stream

Remarks

p4 help istat

istat -- Show/cache a stream's integration status

p4 istat [ -a -c -r -s ] stream

'p4 istat' shows a stream's cached integration status with respect
to its parent. If the cache is stale, either because newer changes
have been submitted or the stream's branch view has changed, 'p4
istat' checks for pending integrations and updates the cache before
showing status.

Pending integrations are shown only if they are expected by the
stream; that is, only if they are warranted by the stream's type
and its fromParent/toParent flow options. (See 'p4 help stream'.)

The -r flag shows the status of integration to the stream from its
parent. By default, status of integration in the other direction is
shown, from the stream to its parent.

The -a flag shows status of integration in both directions.

The -c flag forces 'p4 istat' to assume the cache is stale; it
causes a search for pending integrations. Use of this flag can
impact server performance.

The -s flag shows cached state without refreshing stale data.

Examples

Get the direction of integration for stream "//Rocket/GUI" with respect to its parent:
CopyC#
Stream s = rep.GetStream("//Rocket/GUI",null,null);
StreamMetaData smd = rep.GetStreamMetaData(s, null);
StreamMetaData.IntegAction action = smd.IntegToParentHow;
 Get the direction of integration for stream "//Rocket/GUI" from its parent:
CopyC#
Stream s = rep.GetStream("//Rocket/GUI",null,null);
StreamMetaData smd = rep.GetStreamMetaData(s,new Options(GetStreamMetaDataCmdFlags.Reverse));
StreamMetaData.IntegAction action = smd.IntegFromParentHow;

See Also

Repository Class


GetStreams Method

[image]

Perforce .NET API
Repository..::..GetStreams Method
Repository Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Stream> GetStreams(
    Options options,
    params FileSpec[] files
)
Visual Basic
Public Function GetStreams ( _
    options As Options, _
    ParamArray files As FileSpec() _
) As IList(Of Stream)
Visual C++
public:
IList<Stream^>^ GetStreams(
    Options^ options,
    ... array<FileSpec^>^ files
)

Parameters

options
Type: Perforce.P4..::..Options
files
Type: array< Perforce.P4..::..FileSpec >[]()[][]

See Also

Repository Class


GetSubmittedIntegrations Method

[image]

Perforce .NET API
Repository..::..GetSubmittedIntegrations Method
Repository Class Example See Also Send Feedback
Get a list of submitted integrations for the passed-in file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileIntegrationRecord> GetSubmittedIntegrations(
    IList<FileSpec> filespecs,
    Options options
)
Visual Basic
Public Function GetSubmittedIntegrations ( _
    filespecs As IList(Of FileSpec), _
    options As Options _
) As IList(Of FileIntegrationRecord)
Visual C++
public:
IList<FileIntegrationRecord^>^ GetSubmittedIntegrations(
    IList<FileSpec^>^ filespecs,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help integrated

integrated -- List integrations that have been submitted

p4 integrated [-r] [-b branch] [file ...]

The p4 integrated command lists integrations that have been submitted.
To list unresolved integrations, use 'p4 resolve -n'. To list
resolved but unsubmitted integrations, use 'p4 resolved'.

If the -b branch flag is specified, only files integrated from the
source to target files in the branch view are listed. Qualified
files are listed, even if they were integrated without using the
branch view.

The -r flag reverses the mappings in the branch view, swapping the
target files and source files. The -b branch flag is required.

Examples

To get the file intergration records for the path //depot/rel defined by branch specification main_to_rel:
CopyC#
GetSubmittedIntegrationsCmdOptions opts =
new GetSubmittedIntegrationsCmdOptions(GetSubmittedIntegrationsCmdFlags.None,
"main_to_rel");

FileSpec filespec =
new FileSpec(new DepotPath("//depot/rel/..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileIntegrationRecord> target =
Repository.GetSubmittedIntegrations(filespecs, opts);
 To get the file intergration records for the path //depot/main defined by branch specification main_to_rel in reverse direction:
CopyC#
GetSubmittedIntegrationsCmdOptions opts =
new GetSubmittedIntegrationsCmdOptions(GetSubmittedIntegrationsCmdFlags.ReverseMappings,
"main_to_rel");

FileSpec filespec =
new FileSpec(new DepotPath("//depot/rel/..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileIntegrationRecord> target =
Repository.GetSubmittedIntegrations(filespecs, opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetSubmittedIntegrationsCmdFlags


GetTriggerTable Method

[image]

Perforce .NET API
Repository..::..GetTriggerTable Method
Repository Class Example See Also Send Feedback
Get the repository's trigger table.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<Trigger> GetTriggerTable(
    Options options
)
Visual Basic
Public Function GetTriggerTable ( _
    options As Options _
) As IList(Of Trigger)
Visual C++
public:
IList<Trigger^>^ GetTriggerTable(
    Options^ options
)

Parameters

options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help triggers

triggers -- Modify list of server triggers

p4 triggers
p4 triggers -o
p4 triggers -i

'p4 triggers' edits the table of triggers, which are used for
change submission validation, form validation, external authentication,
external job fix integration, external archive integration, and command
policies.

Triggers are administrator-defined commands that the server runs
to perform the following:

Validate changelist submissions.

The server runs changelist triggers before the file transfer,
between file transfer and changelist commit, upon commit failure,
or after the commit.

Validate shelve operations.

The server runs shelve triggers before files are shelved, after
files are shelved, or when shelved files have been discarded
(via shelve -d).

Manipulate and validate forms.

The server runs form-validating triggers between generating
and outputting the form, between inputting and parsing the
form, between parsing and saving the form, or when deleting
the form.

Authenticate or change a user password.

The server runs authentication triggers to either validate
a user password during login or when setting a new password.

Intercept job fix additions or deletions.

The server run fix triggers prior to adding or deleting a fix
between a job and changelist.

Access external archive files.

For files with the +X filetype modifier, the server runs an
archive trigger to read, write, or delete files in the archive.

Command execution policy.

Command triggers can be specified to run before and after
processing of user requests. Pre-execution triggers can
prevent the command from running.

The trigger form has a single entry 'Triggers:', followed by any
number of trigger lines. Each trigger line must be indented with
spaces or tabs in the form. Triggers are executed in the order listed
and if a trigger fails, subsequent triggers are not run. A trigger
succeeds if the executed command exits returning 0 and fails otherwise.
Normally the failure of a trigger prevents the operation from
completing, except for the commit triggers, which run after the
operation is complete, or the change-failed trigger which is only
advisory.

Each trigger line contains a trigger name, a trigger type, a depot
file path pattern matching where the trigger will be executed, a
command name or form type and a command to run.

Name: The name of the trigger. For change triggers, a run of the
same trigger name on contiguous lines is treated as a single
trigger so that multiple paths can be specified. Only the
command of the first such trigger line is used.

Type: When the trigger is to execute:

archive:
Execute an archive trigger for the server to access
any file with the +X filetype modifier.

auth-check:
service-check:
Execute an authentication check trigger to verify a
user's password against an external password manager
during login or when setting a new password.

auth-check-sso:
Facilitate a single sign-on user authentication. This
configuration requires two programs or scripts to run;
one on the client, the other on the server.

client:
Set the environment variable 'P4LOGINSSO' to point to
a script that can be executed to obtain the user's
credentials or other information that the server
trigger can verify. The client-side script must
write the message to the standard output
(max length 128K).

Example: P4LOGINSSO=/Users/joe/bin/runsso

The two variables available to this trigger are
%P4PORT% and %serverAddress%. The distinction is
that serverAddress is the address of the target server
and the P4PORT is what the client is connecting to,
which might be an intermediate like a Perforce Proxy.

These variables can be passed to the client script by
appending them to the client command string, as in:

P4LOGINSSO="/Users/joe/bin/runsso %serverAddress%"

server:
Execute an authentication (sso) trigger that gets
this message from the standard input and returns an
exit status of 0 (for verified) or otherwise failed.

Example:
sso auth-check-sso auth "/secure/verify %user%"

The user must issue the 'p4 login' command, but no
password prompting is invoked. If the server
determines that the user is valid, they are issued a
Perforce ticket just as if they had logged in with a
password.

Pre-2007.2 clients cannot run a client-side single
sign-on. Specifying an 'auth-check' trigger as a backup
for a user to gain access will prompt the user for a
password if it's an older client or P4LOGINSSO has not
been configured.

Unlike passwords which are encrypted, the sso message is
sent to the server in clear text.

auth-set:
Execute an authentication set trigger to send a new
password to an external password manager.

change-submit:
Execute pre-submit trigger after changelist has been
created and files locked but prior to file transfer.

change-content:
Execute mid-submit trigger after file transfer but prior
to commit. Files can be accessed by the 'p4 diff2',
'p4 files', 'p4 fstat', and 'p4 print' commands using
the revision specification '@=change', where 'change' is
the pending changelist number passed as %changelist%.

change-commit:
Execute post-submit trigger after changelist commit.

change-failed:
Executes only if the changelist commit failed.
Note that this trigger only fires on errors
occurring after a commit process has started. It does
not fire for early usage errors, or due to errors from
the submit form. In short, if a change-* trigger
could have run, then the change-failed trigger
will fire if that commit fails.

command:
Execute pre/post trigger when users run commands.

edge-submit:
Execute pre-submit trigger on Edge Server after changelist
has been created but prior to file transfer.

edge-content:
Execute mid-submit trigger on Edge Server after file
transfer but prior to beginning submit on Commit Server.

fix-add:
Execute fix trigger prior to adding a fix. The special
variable %jobs% is available for expansion and must be
the last argument to the trigger as it expands to one
argument for each job listed on the 'p4 fix' command.

fix-delete:
Execute fix trigger prior to deleting a fix. The special
variable %jobs% is available for expansion and must be
the last argument to the trigger as it expands to one
argument for each job listed on the 'p4 fix -d' command.

form-out:
Execute form trigger on generation of form. Trigger may
modify form.

form-in:
Execute form trigger on input of form before its contents
are parsed and validated. Trigger may modify form.

form-save:
Execute form trigger prior to save of form after its
contents are parsed.

form-commit:
Execute form trigger after it has been committed, allowing
access to automatically generated fields (jobname, dates
etc). It cannot modify the form. This trigger for job
forms is run by 'p4 job' and 'p4 fix' (after the status
is updated), 'p4 change' (if the job is added or deleted)
and 'p4 submit' (if the job is associated with the change).
The 'form-commit' trigger has access to the new job name
created with 'p4 job', while the 'form-in' and 'form-save'
triggers are run before the job name is created. The
special variable %action% is available on the job
'form-commit' trigger command line, and is expanded when
the job is modified by a fix.

form-delete:
Execute form trigger prior to delete of form after its
contents are parsed.

shelve-submit:
Execute pre-shelve trigger after changelist has been
created but prior to file transfer.

shelve-commit:
Execute post-shelve trigger after files are shelved.

shelve-delete:
Execute shelve trigger prior to discarding shelved files.

Path: For change and submit triggers, a file pattern to match files
in the changelist. This file pattern can be an exclusion
mapping (-pattern), to exclude files. For form triggers, the
name of the form (branch, client, etc). For fix triggers
'fix' is required as the path value. For authentication
triggers, 'auth' is required as the path value. For archive
triggers, a file pattern to match the name of the file being
accessed in the archive. Note that, due to lazy copying when
branching files, the name of the file in the archive can not
be the same as the name of the file in the depot. For command
triggers, use the name of the command to match, e.g.
'pre-user-$cmd' or a regular expression, e.g.
'(pre|post)-user-add'.

Command: The OS command to run for validation. If the command
contains spaces, enclose it in double quotes. The
following variables are expanded in the command string.
Use of the triggers.io configurable with a value greater than
zero is recommended, as some vars may be empty or contain
shell metacharacters.

%//depot/trigger.exe% -- depot paths within %vars%
are filled with the path to a temporary file containing
the referenced file's contents. Only standard and stream
depot files whose contents is available are valid.
%argc% -- number of command arguments
%args% -- command argument string
%argsQuoted% -- command argument string, CSV delimited
%client% -- the client issuing the command
%clientcwd% -- client current working directory
%clienthost% -- the hostname of the client
%clientip% -- the IP address of the client
%clientprog% -- the program name of the client
%clientversion% -- the version of the client
%command% -- name of command being run
%groups% -- list of groups user is a member of
%intermediateService% -- presence of a Broker/Proxy/etc
%maxErrorSeverity% -- highest error seen for this cmd
%maxErrorText% -- text and errno for highest error
%maxLockTime% -- user-specified override of group value
%maxResults% -- user-specified override of group value
%maxScanRows% -- user-specified override of group value
%quote% -- double quote character
%serverhost% -- the hostname of the server
%serverid% -- the value of the server's server.id
%serverip% -- the IP address of the server
%servername% -- the value of the server's $P4NAME
%serverpid% -- the PID of the server
%serverport% -- the IP address:port of the server
preceded by the transport prefix,
if needed (i.e. P4PORT)
%serverroot% -- the value of the server's $P4ROOT
%serverservices% -- the services provided by the server
%serverVersion% -- the server's version string
%terminated% -- if the command was forced to quit early
%termReason% -- reason for early termination
%triggerMeta_action% -- command to execute by trigger
%triggerMeta_depotFile% -- third field in trigger def.
%triggerMeta_name% -- name from trigger definition
%triggerMeta_trigger% -- second field in trigger definition
%user% -- the user issuing the command

%changelist% -- the changelist being submitted
%changeroot% -- the root path of files submitted
%oldchangelist% -- the pre-commit changelist number

(More information can be gathered about the
changelist being submitted by running
'p4 describe %changelist%'.)

%formfile% -- path to temp file containing form
%formname% -- the form's name (branch name, etc)
%formtype% -- the type of form (branch, etc)
%action% -- added/deleted/submitted on job form-commit

%jobs% -- list of job names for fix triggers

%op% -- read/write/delete for archive access
%file% -- name of archive file
%rev% -- revision of archive file

If the command was sent via a proxy, broker, or replica:
%peerhost% -- the hostname of the proxy/broker/replica
%peerip% -- the IP address of the proxy/broker/replica
If the command was sent directly, %peerhost% and
%peerip% match %clienthost% and %clientip%.

For a change-* trigger in a distributed installation,
%submitserverid% -- the server.id where submit was run

For a post-rmt-Push trigger:
%firstPushedChange% -- first new changelist number
%lastPushedChange% -- last new changelist number

Note that not all variables are available for every
trigger type. E.g. argc and argv only show up for
pre-user-$cmd and change-submit (and so on), but not for
post-user-$cmd or change-commit.

The command's standard input depends on the value of the
triggers.io configurable. When it is set to zero, stdin is
empty for change, shelve, fix and command triggers, it
is the file content for the archive, and password for auth
triggers. When triggers.io is set to 1, stdin is a textual
dictionary containing connection information that the trigger
must read (with the exception of archive/auth triggers,
which behave the same as when triggers.io=0.)

If the command fails, the command's standard output (not
error output) is sent to the client as the text of a trigger
failure error message.

If the command succeeds, the command's standard output is
sent as an unadorned message to the client for all triggers
except archive triggers; for archive triggers, the command's
standard output is the file content.

The -o flag writes the trigger table to the standard output.
The user's editor is not invoked.

The -i flag reads the trigger table from the standard input.
The user's editor is not invoked.

'p4 triggers' requires 'super' access granted by 'p4 protect'.

Examples

To get the trigger table:
CopyC#
GetTriggerTableCmdOptions opts =
new GetTriggerTableCmdOptions(GetTriggerTableCmdFlags.Output);

IList<Trigger> target = Repository.GetTriggerTable(opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..GetTriggerTableCmdFlags


GetTypeMap Method

[image]

Perforce .NET API
Repository..::..GetTypeMap Method
Repository Class Example See Also Send Feedback
Get the repository's type map.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<TypeMapEntry> GetTypeMap()
Visual Basic
Public Function GetTypeMap As IList(Of TypeMapEntry)
Visual C++
public:
IList<TypeMapEntry^>^ GetTypeMap()

Return Value

Remarks

runs the command p4 typemap -o

Remarks

p4 help typemap

typemap -- Edit the filename-to-filetype mapping table

p4 typemap
p4 typemap -o
p4 typemap -i

'p4 typemap' edits a name-to-type mapping table for 'p4 add', which
uses the table to assign a file's filetype based on its name.

The typemap form has a single field, 'TypeMap', followed by any
number of typemap lines. Each typemap line contains a filetype
and a depot file path pattern:

Filetype: See 'p4 help filetypes' for a list of valid filetypes.

Path: Names to be mapped to the filetype. The mapping is
a file pattern in depot syntax. When a user adds a file
matching this pattern, its default filetype is the
file type specified in the table. To exclude files from
the typemap, use exclusionary (-pattern) mappings.
To match all files anywhere in the depot hierarchy,
the pattern must begin with '//...'. To match files
with a specified suffix, use '//.../*.suffix' or
use '//....suffix' (four dots).

Later entries override earlier entries. If no matching entry is found
in the table, 'p4 add' determines the filetype by examining the file's
contents and execution permission bits.

The -o flag writes the typemap table to standard output. The user's
editor is not invoked.

The -i flag reads the typemap table from standard input. The user's
editor is not invoked.

'p4 typemap' requires 'admin' access, which is granted by 'p4 protect'.

Examples

To get the typemap table:
CopyC#
IList<TypeMapEntry> target = Repository.GetTypeMap();

See Also

Repository Class


GetUser Method

[image] [image]

Perforce .NET API
Repository..::..GetUser Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUser(String) | Get the record for an existing user from the repository.
Public method | GetUser(String, Options) | Get the record for an existing user from the repository.

See Also

Repository Class
Repository Members


GetUser Method (String)

[image]

Perforce .NET API
Repository..::..GetUser Method (String)
Repository Class Example See Also Send Feedback
Get the record for an existing user from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User GetUser(
    string user
)
Visual Basic
Public Function GetUser ( _
    user As String _
) As User
Visual C++
public:
User^ GetUser(
    String^ user
)

Parameters

user
Type: System..::..String
User name

Return Value

The User object if new user was found, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Examples

To get a user's specification for a user with the username bsmith:
CopyC#
User u = Repository.GetUser("bsmith");

See Also

Repository Class
GetUser Overload
Perforce.P4 Namespace
Perforce.P4..::..UserCmdFlags


GetUser Method (String, Options)

[image]

Perforce .NET API
Repository..::..GetUser Method (String, Options)
Repository Class Example See Also Send Feedback
Get the record for an existing user from the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User GetUser(
    string user,
    Options options
)
Visual Basic
Public Function GetUser ( _
    user As String, _
    options As Options _
) As User
Visual C++
public:
User^ GetUser(
    String^ user,
    Options^ options
)

Parameters

user
Type: System..::..String
User name
options
Type: Perforce.P4..::..Options
There are no valid flags to use when fetching an existing user

Return Value

The User object if new user was found, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Examples

To get a user's specification for a user with the username bsmith:
CopyC#
User u = Repository.GetUser("bsmith", null);

See Also

Repository Class
GetUser Overload
Perforce.P4 Namespace
Perforce.P4..::..UserCmdFlags


GetUsers Method

[image] [image]

Perforce .NET API
Repository..::..GetUsers Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUsers(IList<(Of <<'(String>)>>), Options) | Get a list of users from the repository
Public method | GetUsers(Options, array<String>[]()[][]) | Get a list of users from the repository

See Also

Repository Class
Repository Members


GetUsers Method (IList(String), Options)

[image]

Perforce .NET API
Repository..::..GetUsers Method (IList<(Of <(<'String>)>)>, Options)
Repository Class Example See Also Send Feedback
Get a list of users from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<User> GetUsers(
    IList<string> users,
    Options options
)
Visual Basic
Public Function GetUsers ( _
    users As IList(Of String), _
    options As Options _
) As IList(Of User)
Visual C++
public:
IList<User^>^ GetUsers(
    IList<String^>^ users,
    Options^ options
)

Parameters

users
Type: System.Collections.Generic..::..IList <(Of <(<' String >)>)>
options
Type: Perforce.P4..::..Options
Options for the users command. See: UsersCmdFlags

Return Value

A list containing the matching users

Remarks

p4 help users

users -- List Perforce users

p4 users [-l -a -r -c] [-m max] [user ...]

Lists all Perforce users or users that match the 'user' argument.
The report includes the last time that each user accessed the system.

The -m max flag limits output to the first 'max' number of users.

The -a flag includes service and operator users in the output.

The -l flag includes additional information in the output. The -l
flag requires 'super' access, which is granted by 'p4 protect'.

The -r and -c flags are only allowed on replica servers. When
-r is given only users who have used a replica are reported and
when -c is given only the user information from the central server
is reported. Otherwise on a replica server, the user list will
be slightly different from the master server as the user access times
will reflect replica usage or master usage whichever is newer.

Examples

To get the first 10 users that start with the letter 'A':
CopyC#
UsersCmdOptions opts = new UsersCmdOptions(UsersCmdFlags.None, 10);

IList<String> names = new List<String>();
names.Add("A*");

IList<User> users = Repository.getUsers(names, opts);
 To get the users for 'Bob', 'Ted', 'Carol' and 'Alice':
CopyC#
UsersCmdOptions opts = new UsersCmdOptions(UsersCmdFlags.None, -1);

IList<String> names = new List<String>();
names.Add("Bob");
names.Add("Ted");
names.Add("Carol");
names.Add("Alice");

IList<User> users = Repository.getUsers(names, opts);
 To get all the users (WARNING, will fetch all users from the repository):
CopyC#
UsersCmdOptions opts = new UsersCmdOptions(UsersCmdFlags.IncludeAll, -1);
IList<User> users = Repository.getUsers(null, opts);

See Also

Repository Class
GetUsers Overload
Perforce.P4 Namespace
Perforce.P4..::..UsersCmdFlags


GetUsers Method (Options, String[])

[image]

Perforce .NET API
Repository..::..GetUsers Method (Options, array<String>[]()[][])
Repository Class Example See Also Send Feedback
Get a list of users from the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<User> GetUsers(
    Options options,
    params string[] user
)
Visual Basic
Public Function GetUsers ( _
    options As Options, _
    ParamArray user As String() _
) As IList(Of User)
Visual C++
public:
IList<User^>^ GetUsers(
    Options^ options,
    ... array<String^>^ user
)

Parameters

options
Type: Perforce.P4..::..Options
Options for the users command. See: UsersCmdFlags
user
Type: array< System..::..String >[]()[][]
Optional list of users.

Return Value

A list containing the matching users

Remarks

p4 help users

users -- List Perforce users

p4 users [-l -a -r -c] [-m max] [user ...]

Lists all Perforce users or users that match the 'user' argument.
The report includes the last time that each user accessed the system.

The -m max flag limits output to the first 'max' number of users.

The -a flag includes service and operator users in the output.

The -l flag includes additional information in the output. The -l
flag requires 'super' access, which is granted by 'p4 protect'.

The -r and -c flags are only allowed on replica servers. When
-r is given only users who have used a replica are reported and
when -c is given only the user information from the central server
is reported. Otherwise on a replica server, the user list will
be slightly different from the master server as the user access times
will reflect replica usage or master usage whichever is newer.

Examples

To get the first 10 users that start with the letter 'A':
CopyC#
UsersCmdOptions opts = new UsersCmdOptions(UsersCmdFlags.None, 10);
IList<User> users = Repository.getUsers(opts, "A*");
 To get the users for 'Bob', 'Ted', 'Carol' and 'Alice':
CopyC#
UsersCmdOptions opts = new UsersCmdOptions(UsersCmdFlags.None, -1);
IList<User> users = Repository.getUsers(opts, "Bob", "Ted", "Carol", "Alice");
 To get all the users (WARNING, will fetch all users from the repository):
CopyC#
UsersCmdOptions opts = new UsersCmdOptions(UsersCmdFlags.IncludeAll, -1);
IList<User> users = Repository.getUsers(opts, null);

See Also

Repository Class
GetUsers Overload
Perforce.P4 Namespace
Perforce.P4..::..UsersCmdFlags


NewChangelist Method

[image]

Perforce .NET API
Repository..::..NewChangelist Method
Repository Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist NewChangelist()
Visual Basic
Public Function NewChangelist As Changelist
Visual C++
public:
Changelist^ NewChangelist()

See Also

Repository Class


TagFiles Method

[image]

Perforce .NET API
Repository..::..TagFiles Method
Repository Class Example See Also Send Feedback
Tag depot files with the passed-in label.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSpec> TagFiles(
    IList<FileSpec> filespecs,
    string labelid,
    Options options
)
Visual Basic
Public Function TagFiles ( _
    filespecs As IList(Of FileSpec), _
    labelid As String, _
    options As Options _
) As IList(Of FileSpec)
Visual C++
public:
IList<FileSpec^>^ TagFiles(
    IList<FileSpec^>^ filespecs,
    String^ labelid,
    Options^ options
)

Parameters

filespecs
Type: System.Collections.Generic..::..IList <(Of <(<' FileSpec >)>)>
labelid
Type: System..::..String
options
Type: Perforce.P4..::..Options

Return Value

Remarks

p4 help tag

tag -- Tag files with a label

p4 tag [-d -g -n -U] -l label file[revRange] ...

Tag associates the named label with the file revisions specified by
the file argument. After file revisions are tagged with a label,
revision specifications of the form '@label' can be used to refer
to them.

If the file argument does not include a revision specification, the
head revisions is tagged. See 'p4 help revisions' for revision
specification options.

If the file argument includes a revision range specification, only
the files with revisions in that range are tagged. Files with more
than one revision in the range are tagged at the highest revision.

The -d deletes the association between the specified files and the
label, regardless of revision.

The -n flag previews the results of the operation.

Tag can be used with an existing label (see 'p4 help labels') or
with a new one. An existing label can be used only by its owner,
and only if it is unlocked. (See 'p4 help label').

The -U flag specifies that the new label should be created with the
'autoreload' option (See 'p4 help label'). It has no effect on an
existing label.

To list the file revisions tagged with a label, use 'p4 files
@label'.

The -g flag is used on an Edge Server to update a global label.
Configuring rpl.labels.global=1 reverses this default and causes this
flag to have the opposite meaning.

Examples

To tag the file //depot/MyCode/README.txt with build_label:
CopyC#
TagCmdOptions opts =
new TagCmdOptions(TagFilesCmdFlags.None, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileSpec> target =
Repository.TagFiles(filespecs, "build_label", opts);
 To remove the association between the file //depot/MyCode/README.txt and build_label:
CopyC#
TagCmdOptions opts =
new TagCmdOptions(TagFilesCmdFlags.Delete, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/MyCode/README.txt"), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileSpec> target =
Repository.TagFiles(filespecs, "build_label", opts);
 To get a preview list of the files that would be tagged in path //depot/main/src with build_label:
CopyC#
TagCmdOptions opts =
new TagCmdOptions(TagFilesCmdFlags.ListOnly, null);

FileSpec filespec =
new FileSpec(new DepotPath("//depot/main/src/..."), null);
IList<FileSpec> filespecs = new List<FileSpec>();
filespecs.Add(filespec);

IList<FileSpec> target =
Repository.TagFiles(filespecs, "build_label", opts);

See Also

Repository Class
Perforce.P4 Namespace
Perforce.P4..::..TagFilesCmdFlags


UpdateBranchSpec Method

[image]

Perforce .NET API
Repository..::..UpdateBranchSpec Method
Repository Class Example See Also Send Feedback
Update the record for a branch in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public BranchSpec UpdateBranchSpec(
    BranchSpec branch
)
Visual Basic
Public Function UpdateBranchSpec ( _
    branch As BranchSpec _
) As BranchSpec
Visual C++
public:
BranchSpec^ UpdateBranchSpec(
    BranchSpec^ branch
)

Parameters

branch
Type: Perforce.P4..::..BranchSpec
Branch specification for the branch being updated

Return Value

The Branch object if new depot was saved, null if creation failed

Examples

To append a view to an existing branch spec:
CopyC#
BranchSpec updateBranchSpec = _repository.GetBranchSpec("newBranchSpec");
string v0 = "\"//depot/main/a file with spaces.txt\" \"//depot/rel1/a file with spaces.txt\"";
updateBranchSpec.ViewMap.Add(v0);
_repository.UpdateBranchSpec(updateBranchSpec);
 To lock a branch spec:
CopyC#
BranchSpec updateBranchSpec = _repository.GetBranchSpec("newBranchSpec");
updateBranchSpec.Locked = true;
_repository.UpdateBranchSpec(updateBranchSpec);

See Also

Repository Class


UpdateChangelist Method

[image] [image]

Perforce .NET API
Repository..::..UpdateChangelist Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateChangelist(Changelist) | Update the record for a change in the repository
Public method | UpdateChangelist(Changelist, Options) | Update the record for a change in the repository

See Also

Repository Class
Repository Members


UpdateChangelist Method (Changelist)

[image]

Perforce .NET API
Repository..::..UpdateChangelist Method (Changelist)
Repository Class Example See Also Send Feedback
Update the record for a change in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist UpdateChangelist(
    Changelist change
)
Visual Basic
Public Function UpdateChangelist ( _
    change As Changelist _
) As Changelist
Visual C++
public:
Changelist^ UpdateChangelist(
    Changelist^ change
)

Parameters

change
Type: Perforce.P4..::..Changelist
Changelist specification for the change being updated

Return Value

The Changelist object if new change was saved, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To update changelist 15:
CopyC#
Changelist c = Repository.GetChangelist(15);

// change the description
c.Description = "fixes for localization";
c = Repository.UpdateChangelist(c);

See Also

Repository Class
UpdateChangelist Overload


UpdateChangelist Method (Changelist, Options)

[image]

Perforce .NET API
Repository..::..UpdateChangelist Method (Changelist, Options)
Repository Class Example See Also Send Feedback
Update the record for a change in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist UpdateChangelist(
    Changelist change,
    Options options
)
Visual Basic
Public Function UpdateChangelist ( _
    change As Changelist, _
    options As Options _
) As Changelist
Visual C++
public:
Changelist^ UpdateChangelist(
    Changelist^ change,
    Options^ options
)

Parameters

change
Type: Perforce.P4..::..Changelist
Changelist specification for the change being updated
options
Type: Perforce.P4..::..Options

Return Value

The Changelist object if new change was saved, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To update changelist 15:
CopyC#
Changelist c = Repository.GetChangelist(15);

// change the description
c.Description = "fixes for localization";
c = Repository.UpdateChangelist(c);
 To update changelist 15 as an admin user, changing type to Public:
CopyC#
Changelist c = Repository.GetChangelist(15);

ChangeCmdOptions opts =
new ChangeCmdOptions(ChangeCmdFlags.Force);
c.Type = ChangeListType.Public;
c = Repository.UpdateChangelist(c, opts);

See Also

Repository Class
UpdateChangelist Overload
Perforce.P4 Namespace
Perforce.P4..::..ChangeCmdFlags


UpdateClient Method

[image]

Perforce .NET API
Repository..::..UpdateClient Method
Repository Class Example See Also Send Feedback
Update the record for a client in the repository
Create a new client in the repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Client UpdateClient(
    Client client
)
Visual Basic
Public Function UpdateClient ( _
    client As Client _
) As Client
Visual C++
public:
Client^ UpdateClient(
    Client^ client
)

Parameters

client
Type: Perforce.P4..::..Client
Client specification for the client being updatedClient specification for the new user

Return Value

The Client object if new client was saved, null if creation failed

Return Value

The Client object if new user was created, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help client

client -- Create or edit a client workspace specification and its view
workspace -- Synonym for 'client'

p4 client [-f] [-t template] [name]
p4 client -d [-f [-Fs]] name
p4 client -o [-t template] [name]
p4 client -S stream [[-c change] -o] [name]
p4 client -s [-f] -S stream [name]
p4 client -s [-f] -t template [name]
p4 client -i [-f]

Creates a new client specification ('spec') or edits an existing
spec. A client spec is a named mapping of depot files to workspace
files.

The 'p4 client' command puts the client spec into a temporary file
and invokes the editor configured by the environment variable
$P4EDITOR. For new workspaces, the client name defaults to the
$P4CLIENT environment variable, if set, or to the current host name.
Saving the file creates or modifies the client spec.

The client spec contains the following fields:

Client: The client name.

Host: If set, restricts access to the named host.
If unset, access is allowed from any host.

Owner: The user who created this client.

Update: The date that this spec was last modified.

Access: The date that this client was last used in any way.

Description: A short description of the workspace.

Root: The root directory of the workspace (specified in local
file system syntax), under which all versioned files
will be placed. If you change this setting, you must
physically relocate any files that currently reside
there. On Windows client machines, you can specify the
root as "null" to enable you to map files to multiple
drives.

AltRoots: Up to two optional alternate client workspace roots.
The first of the main and alternate roots to match the
client program's current working directory is used. If
none match, the main root is used. 'p4 info' displays
the root that is being used.

Options: Flags to configure the client behavior. Defaults
are marked with *.

allwrite Leaves all files writable on the client;
noallwrite * by default, only files opened by 'p4 edit'
are writable. If set, files might be clobbered
as a result of ignoring the clobber option
(see below).

clobber Permits 'p4 sync' to overwrite writable
noclobber * files on the client. noclobber is ignored if
allwrite is set.

compress Compresses data sent between the client
nocompress * and server to speed up slow connections.

locked Allows only the client owner to use or change
unlocked * the client spec. Prevents the client spec from
being deleted or unloaded.

modtime Causes 'p4 sync' and 'p4 submit' to preserve
nomodtime * file modification time, as with files with the
+m type modifier. (See 'p4 help filetypes'.)
With nomodtime, file timestamps are updated by
sync and submit operations.

rmdir Makes 'p4 sync' attempt to delete a workspace
normdir * directory when all files in it are removed.

SubmitOptions: Flags to change submit behavior.

submitunchanged All open files are submitted (default).

revertunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
reverted.

leaveunchanged Files that have content, type, or resolved
changes are submitted. Unchanged files are
moved to the default changelist.

+reopen Can be appended to the submit option flag
to cause submitted files to be reopened in
the default changelist.
Example: submitunchanged+reopen

LineEnd: Set line-ending character(s) for client text files.

local mode that is native to the client (default).
unix linefeed: UNIX style.
mac carriage return: Macintosh style.
win carriage return-linefeed: Windows style.
share hybrid: writes UNIX style but reads UNIX,
Mac or Windows style.

View: Maps files in the depot to files in your client
workspace. Defines the files that you want in your
client workspace and specifies where you want them
to reside. The default view maps all depot files
onto the client. See 'p4 help views' for view syntax.
A new view takes effect on the next 'p4 sync'.

ChangeView: Restricts depot paths to a particular point in time.
Example: //depot/path/...@1000
Revisions submitted to the path after the specified
changelist will not be visible. Files matching a
ChangeView path may not be submitted.

Stream: The stream to which this client's view will be dedicated.
(Files in stream paths can be submitted only by dedicated
stream clients.) When this optional field is set, the
View field will be automatically replaced by a stream
view as the client spec is saved.

StreamAtChange:
Stream meta-data (for view creation) is versioned.
When StreamAtChange is set, the stream hierarchy is
constructed back-in-time to reproduce the view that was
available to clients in the past. With this field set
changes cannot be be submitted from the client.
StreamAtChange is optional; Stream must be set as well.

ServerID: If set, restricts usage to the named server.
If unset, usage is allowed on the master server and on
any replicas of the master other than Edge Servers.

Note: changing the client root does not actually move the client
files; you must relocate them manually. Similarly, changing
the 'LineEnd' option does not actually update the client files;
you can refresh them with 'p4 sync -f'.

The -d flag deletes the specified spec, as long as the client
workspace has no opened files or pending changes. (See 'p4 help
opened'.) The -f flag forces the delete. The -Fs option used with -f
forces client deletion even when the user has shelved changes. In
this case, the shelved changes are left intact.

The -o flag writes the named client spec to the standard output.
The user's editor is not invoked.

The -i flag reads a client spec from the standard input. The
user's editor is not invoked.

The -t template flag, where 'template' is the name of another client
spec, causes the View and Options fields to be replaced by those of
the template.

The -f flag can force the updating of locked clients; normally
locked clients can only be modified by their owner. -f also allows
the last modified date to be set. The -f flag requires 'admin'
access granted by 'p4 protect'.

The -s flag is used to switch an existing client spec's view without
invoking the editor. It can be used with -S to switch to a stream
view, or with -t to switch to a view defined in another client spec.
Switching views is not allowed in a client that has opened files.
The -f flag can be used with -s to force switching with opened files.
View switching has no effect on files in a client workspace until
'p4 sync' is run.

Without -s, the '-S stream' flag can be used to create a new client
spec dedicated to a stream. If the client spec already exists, and
-S is used without -s, an error occurs when the client is bound to
a different, or no stream. Using -S sets the new client's
Stream field. The special syntax '-S //a/stream@changelist' can
be used to set both Stream and StreamAtChange at the same time.

The '-S stream' flag can be used with '-o -c change' to inspect an
old stream client view. It yields the client spec that would have
been created for the stream at the moment the change was recorded.

A server of type 'build-server' (see 'p4 help server') is a replica
which supports build farm integration, and the 'p4 client' command
may be used to create or edit client workspaces on a build-server.
Such workspaces may issue the 'p4 sync' command, in addition to any
read-only command supported by the replica. For more information, run
'p4 help buildserver'.

When creating or editing a client workspace for a build-server,
the client specified by the optional 'name' argument, as well as the
client specified by the $P4CLIENT environment variable or via the
global '-c client' argument must not exist, or must be restricted
to this server; this command may not be used to create or edit a
workspace that is not restricted to this build-server.

Examples

To update a client named main_ws:
CopyC#
   Client c = Repository.GetClient("main_ws");

// change the description add add a MapEntry to the ViewMap
   c.Description = "client for main dev. Adding tools path";

   DepotPath left = new DepotPath("//depot/tools/...");
   ClientPath right = new ClientPath("//main_ws/tools/...");

   MapEntry line = new MapEntry(MapType.Include, left, right);
   c.ViewMap.Add(line);

   Repository.UpdateClient(c);

See Also

Repository Class


UpdateDepot Method

[image]

Perforce .NET API
Repository..::..UpdateDepot Method
Repository Class Example See Also Send Feedback
Update the record for a depot in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Depot UpdateDepot(
    Depot depot
)
Visual Basic
Public Function UpdateDepot ( _
    depot As Depot _
) As Depot
Visual C++
public:
Depot^ UpdateDepot(
    Depot^ depot
)

Parameters

depot
Type: Perforce.P4..::..Depot
Depot specification for the depot being updated

Return Value

The Depot object if new depot was saved, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help depot

depot -- Create or edit a depot specification

p4 depot name
p4 depot -d [-f] name
p4 depot -o name
p4 depot -i

Create a new depot specification or edit an existing depot
specification. The specification form is put into a temporary file
and the editor (configured by the environment variable $P4EDITOR)
is invoked.

The depot specification contains the following fields:

Depot: The name of the depot. This name cannot be the same as
any branch, client, or label name.

Owner: The user who created this depot.

Date: The date that this specification was last modified.

Description: A short description of the depot (optional).

Type: One of the types: 'local', 'stream', 'remote', 'spec',
'archive', or 'unload'.

A 'local' depot (the default) is managed directly by
the server and its files reside in the server's root
directory.

A 'stream' depot is a local depot dedicated to the
storage of files in a stream.

A 'remote' depot refers to files in another Perforce
server.

A 'spec' depot automatically archives all edited forms
(branch, change, client, depot, group, job, jobspec,
protect, triggers, typemap, and user) in special,
read-only files. The files are named:
//depotname/formtype/name[suffix]. Updates to jobs made
by the 'p4 change', 'p4 fix', and 'p4 submit' commands
are also saved, but other automatic updates such as
as access times or opened files (for changes) are not.
A server can contain only one 'spec' depot.

A 'archive' depot defines a storage location to which
obsolete revisions may be relocated.

An 'unload' depot defines a storage location to which
database records may be unloaded and from which they
may be reloaded.

Address: For remote depots, the $P4PORT (connection address)
of the remote server.

Suffix: For spec depots, the optional suffix to be used
for generated paths. The default is '.p4s'.

Map: Path translation information, in the form of a file
pattern with a single ... in it. For local depots,
this path is relative to the server's root directory
or to server.depot.root if it has been configured
(Example: depot/...). For remote depots, this path
refers to the remote server's namespace
(Example: //depot/...).

SpecMap: For spec depots, the optional description of which
specs should be saved, as one or more patterns.

The -d flag deletes the specified depot. If any files reside in the
depot, they must be removed with 'p4 obliterate' before deleting the
depot. If any archive files remain in the depot directory, they may
be referenced by lazy copies in other depots; use 'p4 snap' to break
those linkages. Snap lazy copies prior to obliterating the old depot
files to allow the obliterate command to remove any unreferenced
archives from the depot directory. If the depot directory is not
empty, you must specify the -f flag to delete the depot.

The -o flag writes the depot specification to standard output. The
user's editor is not invoked.

The -i flag reads a depot specification from standard input. The
user's editor is not invoked.

Examples

To update the streams depot named MobileApp:
CopyC#
   Depot d = Repository.GetDepot("MobileApp");

// change description
   d.Description = "Stream depot for Win8 phone apps";

   Depot MobileApp = Repository.UpdateDepot(d);

See Also

Repository Class


UpdateGroup Method

[image] [image]

Perforce .NET API
Repository..::..UpdateGroup Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateGroup(Group) | Update the record for a group in the repository
Public method | UpdateGroup(Group, Options) | Update the record for a group in the repository

See Also

Repository Class
Repository Members


UpdateGroup Method (Group)

[image]

Perforce .NET API
Repository..::..UpdateGroup Method (Group)
Repository Class Example See Also Send Feedback
Update the record for a group in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group UpdateGroup(
    Group group
)
Visual Basic
Public Function UpdateGroup ( _
    group As Group _
) As Group
Visual C++
public:
Group^ UpdateGroup(
    Group^ group
)

Parameters

group
Type: Perforce.P4..::..Group
Group specification for the group being updated

Return Value

The Group object if new group was saved, null if creation failed

Examples

To add the user 'Carol' to the group 'Mygroup':
CopyC#
string targetGroup = "Mygroup";
Group group = GetGroup(targetGroup, null);
group.UserNames.Add("Carol");
_repository.UpdateGroup(group);

See Also

Repository Class
UpdateGroup Overload


UpdateGroup Method (Group, Options)

[image]

Perforce .NET API
Repository..::..UpdateGroup Method (Group, Options)
Repository Class Example See Also Send Feedback
Update the record for a group in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Group UpdateGroup(
    Group group,
    Options options
)
Visual Basic
Public Function UpdateGroup ( _
    group As Group, _
    options As Options _
) As Group
Visual C++
public:
Group^ UpdateGroup(
    Group^ group,
    Options^ options
)

Parameters

group
Type: Perforce.P4..::..Group
Group specification for the group being updated
options
Type: Perforce.P4..::..Options

Return Value

The Group object if new group was saved, null if creation failed

Examples

To add the user 'Carol' to the group 'Mygroup':
CopyC#
string targetGroup = "Mygroup";
Group group = GetGroup(targetGroup, null);
group.UserNames.Add("Carol");
_repository.UpdateGroup(group);

See Also

Repository Class
UpdateGroup Overload


UpdateJob Method

[image]

Perforce .NET API
Repository..::..UpdateJob Method
Repository Class Example See Also Send Feedback
Update the record for a job in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Job UpdateJob(
    Job job
)
Visual Basic
Public Function UpdateJob ( _
    job As Job _
) As Job
Visual C++
public:
Job^ UpdateJob(
    Job^ job
)

Parameters

job
Type: Perforce.P4..::..Job
Job specification for the job being updated

Return Value

The Job object if new job was saved, null if creation failed

Examples

To update the description of job 'job000001':
CopyC#
Job job = _repository.GetJob("job000001");
job["Description"] += "\n\Updated description";
_repository.UpdateJob("job000001");

See Also

Repository Class


UpdateLabel Method

[image]

Perforce .NET API
Repository..::..UpdateLabel Method
Repository Class Example See Also Send Feedback
Update the record for a label in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Label UpdateLabel(
    Label label
)
Visual Basic
Public Function UpdateLabel ( _
    label As Label _
) As Label
Visual C++
public:
Label^ UpdateLabel(
    Label^ label
)

Parameters

label
Type: Perforce.P4..::..Label
Label specification for the label being updated

Return Value

The Label object if new depot was saved, null if creation failed

Examples

To lock a label:
CopyC#
Label l = rep.GetLabel("admin_label");
l.Locked = true;
rep.UpdateLabel(l);

See Also

Repository Class


UpdateStream Method

[image] [image]

Perforce .NET API
Repository..::..UpdateStream Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateStream(Stream) | Update the record for a stream in the repository
Public method | UpdateStream(Stream, Options) | Update the record for a stream in the repository

See Also

Repository Class
Repository Members


UpdateStream Method (Stream)

[image]

Perforce .NET API
Repository..::..UpdateStream Method (Stream)
Repository Class Example See Also Send Feedback
Update the record for a stream in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream UpdateStream(
    Stream stream
)
Visual Basic
Public Function UpdateStream ( _
    stream As Stream _
) As Stream
Visual C++
public:
Stream^ UpdateStream(
    Stream^ stream
)

Parameters

stream
Type: Perforce.P4..::..Stream
Stream specification for the stream being updated

Return Value

The Stream object if new stream was saved, null if creation failed

Examples

To set the locked option on a stream:
CopyC#
Stream streamToUpdate = rep.GetStream("//Rocket/GUI");
streamToUpdate.Options |= StreamOption.Locked;
streamToUpdate = rep.UpdateStream(streamToUpdate);

See Also

Repository Class
UpdateStream Overload


UpdateStream Method (Stream, Options)

[image]

Perforce .NET API
Repository..::..UpdateStream Method (Stream, Options)
Repository Class Example See Also Send Feedback
Update the record for a stream in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream UpdateStream(
    Stream stream,
    Options options
)
Visual Basic
Public Function UpdateStream ( _
    stream As Stream, _
    options As Options _
) As Stream
Visual C++
public:
Stream^ UpdateStream(
    Stream^ stream,
    Options^ options
)

Parameters

stream
Type: Perforce.P4..::..Stream
Stream specification for the stream being updated
options
Type: Perforce.P4..::..Options

Return Value

The Stream object if new stream was saved, null if creation failed

Examples

To update a locked stream when connected as an admin user:
CopyC#
Stream streamToUpdate = rep.GetStream("//Rocket/GUI");
// set locked option
streamToUpdate.Options |= StreamOption.Locked;
streamToUpdate = rep.UpdateStream(streamToUpdate);
streamToUpdate.Description = "edited";
string parent = streamToUpdate.Parent.ToString();
string type = streamToUpdate.Type.ToString();
streamToUpdate = rep.UpdateStream(streamToUpdate,
  new StreamCmdOptions(StreamCmdFlags.Force, parent, type ));

See Also

Repository Class
UpdateStream Overload


UpdateSubmittedChangelist Method

[image] [image]

Perforce .NET API
Repository..::..UpdateSubmittedChangelist Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateSubmittedChangelist(Changelist) | Update the record for a submitted change in the repository
Public method | UpdateSubmittedChangelist(Changelist, Options) | Update the record for a submitted change in the repository

See Also

Repository Class
Repository Members


UpdateSubmittedChangelist Method (Changelist)

[image]

Perforce .NET API
Repository..::..UpdateSubmittedChangelist Method (Changelist)
Repository Class Example See Also Send Feedback
Update the record for a submitted change in the repository
Update the record for a change in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist UpdateSubmittedChangelist(
    Changelist change
)
Visual Basic
Public Function UpdateSubmittedChangelist ( _
    change As Changelist _
) As Changelist
Visual C++
public:
Changelist^ UpdateSubmittedChangelist(
    Changelist^ change
)

Parameters

change
Type: Perforce.P4..::..Changelist
Changelist specification for the change being updatedChangelist specification for the change being updated

Return Value

The Changelist object if new change was saved, null if creation failed

Return Value

The Changelist object if new change was saved, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To update changelist 25:
CopyC#
Changelist c = Repository.GetChangelist(25);

// change the description
c.Description = "fixes for localization";
c = Repository.UpdateSubmittedChangelist(c);

See Also

Repository Class
UpdateSubmittedChangelist Overload


UpdateSubmittedChangelist Method (Changelist, Options)

[image]

Perforce .NET API
Repository..::..UpdateSubmittedChangelist Method (Changelist, Options)
Repository Class Example See Also Send Feedback
Update the record for a submitted change in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Changelist UpdateSubmittedChangelist(
    Changelist change,
    Options options
)
Visual Basic
Public Function UpdateSubmittedChangelist ( _
    change As Changelist, _
    options As Options _
) As Changelist
Visual C++
public:
Changelist^ UpdateSubmittedChangelist(
    Changelist^ change,
    Options^ options
)

Parameters

change
Type: Perforce.P4..::..Changelist
Changelist specification for the change being updated
options
Type: Perforce.P4..::..Options
options for the submitted change being updated

Return Value

The Changelist object if new change was saved, null if creation failed

Remarks

p4 help change

change -- Create or edit a changelist description
changelist -- synonym for 'change'

p4 change [-s] [-f | -u] [[-O] changelist#]
p4 change -d [-f -s -O] changelist#
p4 change -o [-s] [-f] [[-O] changelist#]
p4 change -i [-s] [-f | -u]
p4 change -t restricted | public [-U user] [-f | -u | -O] changelist#
p4 change -U user [-t restricted | public] [-f] changelist#

'p4 change' creates and edits changelists and their descriptions.
With no argument, 'p4 change' creates a new changelist. If a
changelist number is specified, 'p4 change' edits an existing
pending changelist. In both cases, the changelist specification
is placed into a form and the user's editor is invoked.

The -d flag deletes a pending changelist, if it has no opened files
and no pending fixes associated with it. Use 'p4 opened -a' to
report on opened files and 'p4 reopen' to move them to another
changelist. Use 'p4 fixes -c changelist#' to report on pending
fixes and 'p4 fix -d -c changelist# jobs...' to delete pending
fixes. The changelist can be deleted only by the user and client
who created it, or by a user with 'admin' privilege using the -f
flag.

The -o flag writes the changelist specification to the standard
output. The user's editor is not invoked.

The -i flag reads a changelist specification from the standard
input. The user's editor is not invoked.

The -f flag forces the update or deletion of other users' pending
changelists. -f can also force the deletion of submitted changelists
after they have been emptied of files using 'p4 obliterate'. By
default, submitted changelists cannot be changed. The -f flag can
also force display of the 'Description' field in a restricted
changelist. Finally the -f flag can force changing the 'User' of
an empty pending change via -U. The -f flag requires 'admin'
access granted by 'p4 protect'. The -f and -u flags are mutually
exclusive.

The -u flag can force the update of a submitted change by the owner
of the change. Only the Jobs, Type, and Description fields can be
changed using the -u flag. The -f and -u flags cannot be used in
the same change command.

The -s flag extends the list of jobs to include the fix status
for each job. On new changelists, the fix status begins as the
special status 'ignore', which, if left unchanged simply excludes
the job from those being fixed. Otherwise, the fix status, like
that applied with 'p4 fix -s', becomes the job's status when
the changelist is committed. Note that this option exists
to support integration with external defect trackers.

The -O flag specifies that the changelist number is the original
number of a changelist which was renamed on submit.

The -U flag changes the 'User' of an empty pending change to the
specified user. The user field can only be changed using this flag
by the user who created the change, or by a user with 'admin'
privilege using the -f flag. This option is useful for running
in a trigger or script.

The -t flag changes the 'Type' of the change to 'restricted'
or 'public' without displaying the change form. This option is
useful for running in a trigger or script.

The 'Type' field can be used to hide the change or its description
from users. Valid values for this field are 'public' (default), and
'restricted'. A shelved or committed change that is 'restricted' is
accessible only to users who own the change or have 'list' permission
to at least one file in the change. A pending (not shelved)
restricted change is only accessible to its owner. Public changes
are accessible to all users. This setting affects the output of the
'p4 change', 'p4 changes', and 'p4 describe' commands. Note that
the '-S' flag is required with 'p4 describe' for the command to
enforce shelved rather than pending restricted changelist rules.

If a user is not permitted to have access to a restricted change,
The 'Description' text is replaced with a 'no permission' message
(see 'Type' field). Users with admin permission can override the
restriction using the -f flag.

Examples

To update changelist 25:
CopyC#
Changelist c = Repository.GetChangelist(25);

// change the description
c.Description = "fixes for localization";
c = Repository.UpdateChangelist(c);
 To update changelist 15 as an admin user, changing type to Public:
CopyC#
Changelist c = Repository.GetChangelist(25);

ChangeCmdOptions opts =
new ChangeCmdOptions(ChangeCmdFlags.Force);
c.Type = ChangeListType.Public;
c = Repository.UpdateChangelist(c, opts);

See Also

Repository Class
UpdateSubmittedChangelist Overload
Perforce.P4 Namespace
Perforce.P4..::..ChangeCmdFlags


UpdateUser Method

[image] [image]

Perforce .NET API
Repository..::..UpdateUser Method
Repository Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateUser(User) | Update the record for a user in the repository
Public method | UpdateUser(User, Options) | Update the record for a user in the repository

See Also

Repository Class
Repository Members


UpdateUser Method (User)

[image]

Perforce .NET API
Repository..::..UpdateUser Method (User)
Repository Class Example See Also Send Feedback
Update the record for a user in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User UpdateUser(
    User user
)
Visual Basic
Public Function UpdateUser ( _
    user As User _
) As User
Visual C++
public:
User^ UpdateUser(
    User^ user
)

Parameters

user
Type: Perforce.P4..::..User
User specification for the user being updated

Return Value

The User object if new user was saved, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Examples

To update a user with the username bsmith (when connected with Connection.UserName = "bsmith"):
CopyC#
User u = Repository.GetUser("bsmith");

// update email address
u.EmailAddress = "bsmith@hotmail.com";

u = Repository.UpdateUser(u, null);

See Also

Repository Class
UpdateUser Overload
Perforce.P4 Namespace
Perforce.P4..::..UserCmdFlags


UpdateUser Method (User, Options)

[image]

Perforce .NET API
Repository..::..UpdateUser Method (User, Options)
Repository Class Example See Also Send Feedback
Update the record for a user in the repository

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User UpdateUser(
    User user,
    Options options
)
Visual Basic
Public Function UpdateUser ( _
    user As User, _
    options As Options _
) As User
Visual C++
public:
User^ UpdateUser(
    User^ user,
    Options^ options
)

Parameters

user
Type: Perforce.P4..::..User
User specification for the user being updated
options
Type: Perforce.P4..::..Options

Return Value

The User object if new user was saved, null if creation failed

Remarks

The '-i' flag is added if not specified by the caller

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Examples

To update a user with the username bsmith (when connected with a user that has super access):
CopyC#
User u = Repository.GetUser("bsmith");

// update email address
u.EmailAddress = "bsmith@hotmail.com";

UserCmdOptions opts = new UserCmdOptions(UserCmdFlags.Force);

u = Repository.UpdateUser(u, opts);

See Also

Repository Class
UpdateUser Overload
Perforce.P4 Namespace
Perforce.P4..::..UserCmdFlags


Repository Properties

[image] [image]

Perforce .NET API
Repository Properties
Repository Class See Also Send Feedback

The Repository type exposes the following members.

Properties

 | Name | Description
Public property | Connection | Represents the logical connection between a specific Perforce Server instance and a specific client application.
Public property | Server | Represents a specific Perforce server.

See Also

Repository Class


Connection Property

[image]

Perforce .NET API
Repository..::..Connection Property
Repository Class See Also Send Feedback
Represents the logical connection between a specific Perforce Server instance and a specific client application.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Connection Connection { get; }
Visual Basic
Public ReadOnly Property Connection As Connection
    Get
Visual C++
public:
property Connection^ Connection {
    Connection^ get ();
}

See Also

Repository Class


Server Property

[image]

Perforce .NET API
Repository..::..Server Property
Repository Class See Also Send Feedback
Represents a specific Perforce server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Server Server { get; private set; }
Visual Basic
Public Property Server As Server
    Get
    Private Set
Visual C++
public:
property Server^ Server {
    Server^ get ();
    private: void set (Server^ value);
}

See Also

Repository Class


ResolveAction Enumeration

[image]

Perforce .NET API
ResolveAction Enumeration
See Also Send Feedback
The action used in resolving the file.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ResolveAction
Visual Basic
<FlagsAttribute> _
Public Enumeration ResolveAction
Visual C++
[FlagsAttribute]
public enum class ResolveAction

Members

Member name | Value | Description
None | 0 |
Unresolved | 1 |
CopyFrom | 2 |
MergeFrom | 4 |
EditFrom | 8 |
Ignored | 16 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ResolveAnalysis Class

[image]

Perforce .NET API
ResolveAnalysis Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ResolveAnalysis
Visual Basic
Public Class ResolveAnalysis
Visual C++
public ref class ResolveAnalysis

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ResolveAnalysis

See Also

ResolveAnalysis Members


ResolveAnalysis Members

[image] [image]

Perforce .NET API
ResolveAnalysis Members
ResolveAnalysis Class Constructors Methods Fields Properties See Also Send Feedback

The ResolveAnalysis type exposes the following members.

Constructors

 | Name | Description
Public method | ResolveAnalysis()()()() | Initializes a new instance of the ResolveAnalysis class
Public method | ResolveAnalysis(String) | Initializes a new instance of the ResolveAnalysis class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetResolveType(String) |
Public method | SetResolveType(ResolveType) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | SuggestedAction |

Properties

 | Name | Description
Public property | CommonDiffCount |
Public property | ConflictCount |
Public property | MergeAction |
Public property | Options |
Public property | ResolveType |
Public property | SourceDiffCnt |
Public property | TargetDiffCnt |
Public property | TheirsAction |
Public property | YoursAction |

See Also

ResolveAnalysis Class


ResolveAnalysis Constructor

[image] [image]

Perforce .NET API
ResolveAnalysis Constructor
ResolveAnalysis Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResolveAnalysis()()()() | Initializes a new instance of the ResolveAnalysis class
Public method | ResolveAnalysis(String) | Initializes a new instance of the ResolveAnalysis class

See Also

ResolveAnalysis Class
ResolveAnalysis Members


ResolveAnalysis Constructor

[image]

Perforce .NET API
ResolveAnalysis Constructor
ResolveAnalysis Class See Also Send Feedback
Initializes a new instance of the ResolveAnalysis class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveAnalysis()
Visual Basic
Public Sub New
Visual C++
public:
ResolveAnalysis()

See Also

ResolveAnalysis Class
ResolveAnalysis Overload


ResolveAnalysis Constructor (String)

[image]

Perforce .NET API
ResolveAnalysis Constructor (String)
ResolveAnalysis Class See Also Send Feedback
Initializes a new instance of the ResolveAnalysis class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveAnalysis(
    string str
)
Visual Basic
Public Sub New ( _
    str As String _
)
Visual C++
public:
ResolveAnalysis(
    String^ str
)

Parameters

str
Type: System..::..String

See Also

ResolveAnalysis Class
ResolveAnalysis Overload


ResolveAnalysis Fields

[image] [image]

Perforce .NET API
ResolveAnalysis Fields
ResolveAnalysis Class See Also Send Feedback

The ResolveAnalysis type exposes the following members.

Fields

 | Name | Description
Public field | SuggestedAction |

See Also

ResolveAnalysis Class


SuggestedAction Field

[image]

Perforce .NET API
ResolveAnalysis..::..SuggestedAction Field
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public P4ClientMerge..::..MergeStatus SuggestedAction
Visual Basic
Public SuggestedAction As P4ClientMerge..::..MergeStatus
Visual C++
public:
P4ClientMerge..::..MergeStatus SuggestedAction

See Also

ResolveAnalysis Class


ResolveAnalysis Methods

[image] [image]

Perforce .NET API
ResolveAnalysis Methods
ResolveAnalysis Class See Also Send Feedback

The ResolveAnalysis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetResolveType(String) |
Public method | SetResolveType(ResolveType) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolveAnalysis Class


SetResolveType Method

[image] [image]

Perforce .NET API
ResolveAnalysis..::..SetResolveType Method
ResolveAnalysis Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetResolveType(String) |
Public method | SetResolveType(ResolveType) |

See Also

ResolveAnalysis Class
ResolveAnalysis Members


SetResolveType Method (String)

[image]

Perforce .NET API
ResolveAnalysis..::..SetResolveType Method (String)
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveType SetResolveType(
    string sType
)
Visual Basic
Public Function SetResolveType ( _
    sType As String _
) As ResolveType
Visual C++
public:
ResolveType SetResolveType(
    String^ sType
)

Parameters

sType
Type: System..::..String

See Also

ResolveAnalysis Class
SetResolveType Overload


SetResolveType Method (ResolveType)

[image]

Perforce .NET API
ResolveAnalysis..::..SetResolveType Method (ResolveType)
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveType SetResolveType(
    ResolveType type
)
Visual Basic
Public Function SetResolveType ( _
    type As ResolveType _
) As ResolveType
Visual C++
public:
ResolveType SetResolveType(
    ResolveType type
)

Parameters

type
Type: Perforce.P4..::..ResolveType

See Also

ResolveAnalysis Class
SetResolveType Overload


ResolveAnalysis Properties

[image] [image]

Perforce .NET API
ResolveAnalysis Properties
ResolveAnalysis Class See Also Send Feedback

The ResolveAnalysis type exposes the following members.

Properties

 | Name | Description
Public property | CommonDiffCount |
Public property | ConflictCount |
Public property | MergeAction |
Public property | Options |
Public property | ResolveType |
Public property | SourceDiffCnt |
Public property | TargetDiffCnt |
Public property | TheirsAction |
Public property | YoursAction |

See Also

ResolveAnalysis Class


CommonDiffCount Property

[image]

Perforce .NET API
ResolveAnalysis..::..CommonDiffCount Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int CommonDiffCount { get; set; }
Visual Basic
Public Property CommonDiffCount As Integer
    Get
    Set
Visual C++
public:
property int CommonDiffCount {
    int get ();
    void set (int value);
}

See Also

ResolveAnalysis Class


ConflictCount Property

[image]

Perforce .NET API
ResolveAnalysis..::..ConflictCount Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ConflictCount { get; set; }
Visual Basic
Public Property ConflictCount As Integer
    Get
    Set
Visual C++
public:
property int ConflictCount {
    int get ();
    void set (int value);
}

See Also

ResolveAnalysis Class


MergeAction Property

[image]

Perforce .NET API
ResolveAnalysis..::..MergeAction Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string MergeAction { get; set; }
Visual Basic
Public Property MergeAction As String
    Get
    Set
Visual C++
public:
property String^ MergeAction {
    String^ get ();
    void set (String^ value);
}

See Also

ResolveAnalysis Class


Options Property

[image]

Perforce .NET API
ResolveAnalysis..::..Options Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveOptions Options { get; set; }
Visual Basic
Public Property Options As ResolveOptions
    Get
    Set
Visual C++
public:
property ResolveOptions Options {
    ResolveOptions get ();
    void set (ResolveOptions value);
}

See Also

ResolveAnalysis Class


ResolveType Property

[image]

Perforce .NET API
ResolveAnalysis..::..ResolveType Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveType ResolveType { get; set; }
Visual Basic
Public Property ResolveType As ResolveType
    Get
    Set
Visual C++
public:
property ResolveType ResolveType {
    ResolveType get ();
    void set (ResolveType value);
}

See Also

ResolveAnalysis Class


SourceDiffCnt Property

[image]

Perforce .NET API
ResolveAnalysis..::..SourceDiffCnt Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int SourceDiffCnt { get; set; }
Visual Basic
Public Property SourceDiffCnt As Integer
    Get
    Set
Visual C++
public:
property int SourceDiffCnt {
    int get ();
    void set (int value);
}

See Also

ResolveAnalysis Class


TargetDiffCnt Property

[image]

Perforce .NET API
ResolveAnalysis..::..TargetDiffCnt Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int TargetDiffCnt { get; set; }
Visual Basic
Public Property TargetDiffCnt As Integer
    Get
    Set
Visual C++
public:
property int TargetDiffCnt {
    int get ();
    void set (int value);
}

See Also

ResolveAnalysis Class


TheirsAction Property

[image]

Perforce .NET API
ResolveAnalysis..::..TheirsAction Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string TheirsAction { get; set; }
Visual Basic
Public Property TheirsAction As String
    Get
    Set
Visual C++
public:
property String^ TheirsAction {
    String^ get ();
    void set (String^ value);
}

See Also

ResolveAnalysis Class


YoursAction Property

[image]

Perforce .NET API
ResolveAnalysis..::..YoursAction Property
ResolveAnalysis Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string YoursAction { get; set; }
Visual Basic
Public Property YoursAction As String
    Get
    Set
Visual C++
public:
property String^ YoursAction {
    String^ get ();
    void set (String^ value);
}

See Also

ResolveAnalysis Class


ResolveCmdOptions Class

[image]

Perforce .NET API
ResolveCmdOptions Class
Members See Also Send Feedback
Options for the resolve command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ResolveCmdOptions : Options
Visual Basic
Public Class ResolveCmdOptions _
    Inherits Options
Visual C++
public ref class ResolveCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ResolveCmdOptions

See Also

ResolveCmdOptions Members


ResolveCmdOptions Members

[image] [image]

Perforce .NET API
ResolveCmdOptions Members
ResolveCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ResolveCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ResolveCmdOptions | Options for the resolve command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ResolveCmdOptions Class


ResolveCmdOptions Constructor

[image]

Perforce .NET API
ResolveCmdOptions Constructor
ResolveCmdOptions Class See Also Send Feedback
Options for the resolve command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolveCmdOptions(
    ResolveFilesCmdFlags flags,
    int changeList
)
Visual Basic
Public Sub New ( _
    flags As ResolveFilesCmdFlags, _
    changeList As Integer _
)
Visual C++
public:
ResolveCmdOptions(
    ResolveFilesCmdFlags flags,
    int changeList
)

Parameters

flags
Type: Perforce.P4..::..ResolveFilesCmdFlags
changeList
Type: System..::..Int32

Return Value

Remarks

p4 help resolve

resolve -- Resolve integrations and updates to workspace files

p4 resolve [options] [file ...]

options: -A<flags> -a<flags> -d<flags> -f -n -N -o -t -v
-c changelist#

'p4 resolve' resolves changes to files in the client workspace.

'p4 resolve' works only on files that have been scheduled to be
resolved. The commands that can schedule resolves are: 'p4 sync',
'p4 update', 'p4 submit', 'p4 merge', and 'p4 integrate'. Files must
be resolved before they can be submitted.

Resolving involves two sets of files, a source and a target. The
target is a set of depot files that maps to opened files in the
client workspace. When resolving an integration, the source is a
different set of depot files than the target. When resolving an
update, the source is the same set of depot files as the target,
at a different revision.

The 'p4 resolve' file argument specifies the target. If the file
argument is omitted, all unresolved files are resolved.

Resolving can modify workspace files. To back up files, use 'p4
shelve' before using 'p4 resolve'.

The resolve process is a classic three-way merge. The participating
files are referred to as follows:

'yours' The target file open in the client workspace
'theirs' The source file in the depot
'base' The common ancestor; the highest revision of the
source file already accounted for in the target.
'merged' The merged result.

Filenames, filetypes, and text file content can be resolved by
accepting 'yours', 'theirs', or 'merged'. Branching, deletion, and
binary file content can be resolved by accepting either 'yours' or
'theirs'.

When resolving integrated changes, 'p4 resolve' distinguishes among
four results: entirely yours, entirely theirs, a pure merge, or an
edited merge. The distinction is recorded when resolved files are
submitted, and will be used by future commands to determine whether
integration is needed.

In all cases, accepting 'yours' leaves the target file in its current
state. The result of accepting 'theirs' is as follows:

Content: The target file content is overwritten.
Attribute: The target's attributes are replaced.
Branching: A new target is branched.
Deletion: The target file is deleted.
Filename: The target file is moved or renamed.
Filetype: The target file's type is changed.

For each unresolved change, the user is prompted to accept a result.
Content and non-content changes are resolved separately. For content,
'p4 resolve' places the merged result into a temporary file in the
client workspace. If there are any conflicts, the merged file contains
conflict markers that must be removed by the user.

'p4 resolve' displays a count of text diffs and conflicts, and offers
the following prompts:

Accept:
at Keep only changes to their file.
ay Keep only changes to your file.
* am Keep merged file.
* ae Keep merged and edited file.
* a Keep autoselected file.

Diff:
* dt See their changes alone.
* dy See your changes alone.
* dm See merged changes.
d Diff your file against merged file.

Edit:
et Edit their file (read only).
ey Edit your file (read/write).
* e Edit merged file (read/write).

Misc:
* m Run '$P4MERGE base theirs yours merged'.
(Runs '$P4MERGEUNICODE charset base theirs
yours merged' if set and the file is a
unicode file.)
s Skip this file.
h Print this help message.
^C Quit the resolve operation.

Options marked (*) appear only for text files. The suggested action
will be displayed in brackets.

The 'merge' (m) option enables you to invoke your own merge program, if
one is configured using the $P4MERGE environment variable. Four files
are passed to the program: the base, yours, theirs, and the temporary
file. The program is expected to write merge results to the temporary
file.

The -A flag can be used to limit the kind of resolving that will be
attempted; without it, everything is attempted:

-Aa Resolve attributes.
-Ab Resolve file branching.
-Ac Resolve file content changes.
-Ad Resolve file deletions.
-Am Resolve moved and renamed files.
-At Resolve filetype changes.
-AQ Resolve charset changes.

The -a flag puts 'p4 resolve' into automatic mode. The user is not
prompted, and files that can't be resolved automatically are skipped:

-as 'Safe' resolve; skip files that need merging.
-am Resolve by merging; skip files with conflicts.
-af Force acceptance of merged files with conflicts.
-at Force acceptance of theirs; overwrites yours.
-ay Force acceptance of yours; ignores theirs.

The -as flag causes the workspace file to be replaced with their file
only if theirs has changed and yours has not.

The -am flag causes the workspace file to be replaced with the result
of merging theirs with yours. If the merge detected conflicts, the
file is left untouched and unresolved.

The -af flag causes the workspace file to be replaced with the result
of merging theirs with yours, even if there were conflicts. This can
leave conflict markers in workspace files.

The -at flag resolves all files by copying theirs into yours. It
should be used with care, as it overwrites any changes made to the
file in the client workspace.

The -ay flag resolves all files by accepting yours and ignoring
theirs. It preserves the content of workspace files.

The -d flags can be used to control handling of whitespace and line
endings when merging files:

-db Ignore whitespace changes.
-dw Ignore whitespace altogether.
-dl Ignores line endings.

The -d flags are also passed to the diff options in the 'p4 resolve'
dialog. Additional -d flags that modify the diff output but do not
modify merge behavior include -dn (RCS), -dc (context), -ds (summary),
and -du (unified). Note that 'p4 resolve' uses text from the client
file if the files differ only in whitespace.

The -f flag enables previously resolved content to be resolved again.
By default, after files have been resolved, 'p4 resolve' does not
process them again.

The -n flag previews the operation without altering files.

The -N flag previews the operation with additional information about
any non-content resolve actions that are scheduled.

The -o flag displays the base file name and revision to be used
during the the merge.

The -t flag forces 'p4 resolve' to attempt a textual merge, even for
files with non-text (binary) types.

The -v flag causes 'p4 resolve' to insert markers for all changes,
not just conflicts.

The -c flag limits 'p4 resolve' to the files in changelist#.

'p4 resolve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

ResolveCmdOptions Class


ResolveCmdOptions Methods

[image] [image]

Perforce .NET API
ResolveCmdOptions Methods
ResolveCmdOptions Class See Also Send Feedback

The ResolveCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ResolveCmdOptions Class


ResolveCmdOptions Properties

[image] [image]

Perforce .NET API
ResolveCmdOptions Properties
ResolveCmdOptions Class See Also Send Feedback

The ResolveCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ResolveCmdOptions Class


ResolvedCmdOptions Class

[image]

Perforce .NET API
ResolvedCmdOptions Class
Members See Also Send Feedback
Options for Resolve command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ResolvedCmdOptions : Options
Visual Basic
Public Class ResolvedCmdOptions _
    Inherits Options
Visual C++
public ref class ResolvedCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ResolvedCmdOptions

See Also

ResolvedCmdOptions Members


ResolvedCmdOptions Members

[image] [image]

Perforce .NET API
ResolvedCmdOptions Members
ResolvedCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ResolvedCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ResolvedCmdOptions | Resolved command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ResolvedCmdOptions Class


ResolvedCmdOptions Constructor

[image]

Perforce .NET API
ResolvedCmdOptions Constructor
ResolvedCmdOptions Class See Also Send Feedback
Resolved command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ResolvedCmdOptions(
    GetResolvedFilesCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As GetResolvedFilesCmdFlags _
)
Visual C++
public:
ResolvedCmdOptions(
    GetResolvedFilesCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..GetResolvedFilesCmdFlags

Return Value

Remarks

p4 help resolved

resolved -- Show files that have been resolved but not submitted

p4 resolved [-o] [file ...]

'p4 resolved' lists file updates and integrations that have been
resolved but not yet submitted. To see unresolved integrations,
use 'p4 resolve -n'. To see already submitted integrations, use
'p4 integrated'.

If a depot file path is specified, the output lists resolves for
'theirs' files that match the specified path. If a client file
path is specified, the output lists resolves for 'yours' files
that match the specified path.

The -o flag reports the revision used as the base during the
resolve.

See Also

ResolvedCmdOptions Class


ResolvedCmdOptions Methods

[image] [image]

Perforce .NET API
ResolvedCmdOptions Methods
ResolvedCmdOptions Class See Also Send Feedback

The ResolvedCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ResolvedCmdOptions Class


ResolvedCmdOptions Properties

[image] [image]

Perforce .NET API
ResolvedCmdOptions Properties
ResolvedCmdOptions Class See Also Send Feedback

The ResolvedCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ResolvedCmdOptions Class


ResolveFilesCmdFlags Enumeration

[image]

Perforce .NET API
ResolveFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the resolve command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ResolveFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration ResolveFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class ResolveFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
FileAttributesOnly | 1 | The -A flag can be used to limit the kind of resolving that will be attempted; without it, everything is attempted: -Aa Resolve attributes.
FileBranchingOnly | 2 | The -A flag can be used to limit the kind of resolving that will be attempted; without it, everything is attempted: -Ab Resolve file branching.
FileContentChangesOnly | 4 | The -A flag can be used to limit the kind of resolving that will be attempted; without it, everything is attempted: -Ac Resolve file content changes.
FileDeletionsOnly | 8 | The -A flag can be used to limit the kind of resolving that will be attempted; without it, everything is attempted: -Ad Resolve file deletions.
FileMovesOnly | 16 | The -A flag can be used to limit the kind of resolving that will be attempted; without it, everything is attempted: -Am Resolve moved and renamed files.
FileTypeChangesOnly | 32 | The -A flag can be used to limit the kind of resolving that will be attempted; without it, everything is attempted: -At Resolve filetype changes.
AFlags | 63 |
AutomaticSafeMode | 256 | The -a flag puts 'p4 resolve' into automatic mode. The user is not prompted, and files that can't be resolved automatically are skipped: -as 'Safe' resolve; skip files that need merging. The -as flag causes the workspace file to be replaced with their file only if theirs has changed and yours has not.
AutomaticMergeMode | 512 | The -a flag puts 'p4 resolve' into automatic mode. The user is not prompted, and files that can't be resolved automatically are skipped: -am Resolve by merging; skip files with conflicts. The -am flag causes the workspace file to be replaced with the result of merging theirs with yours. If the merge detected conflicts, the file is left untouched and unresolved.
AutomaticForceMergeMode | 1024 | The -a flag puts 'p4 resolve' into automatic mode. The user is not prompted, and files that can't be resolved automatically are skipped: -af Force acceptance of merged files with conflicts. The -af flag causes the workspace file to be replaced with the result of merging theirs with yours, even if there were conflicts. This can leave conflict markers in workspace files.
AutomaticTheirsMode | 2048 | The -a flag puts 'p4 resolve' into automatic mode. The user is not prompted, and files that can't be resolved automatically are skipped: -at Force acceptance of theirs; overwrites yours. The -at flag resolves all files by copying theirs into yours. It should be used with care, as it overwrites any changes made to the file in the client workspace.
AutomaticYoursMode | 8192 | The -a flag puts 'p4 resolve' into automatic mode. The user is not prompted, and files that can't be resolved automatically are skipped: -ay Force acceptance of yours; ignores theirs. The -ay flag resolves all files by accepting yours and ignoring theirs. It preserves the content of workspace files.
aFlags | 12032 |
ForceResolve | 16384 | The -f flag enables previously resolved files to be resolved again. By default, after files have been resolved, 'p4 resolve' does not process them again.
PreviewOnly | 32768 | The -n flag previews the operation without altering files.
PreviewPlusOnly | 65536 | The -N flag previews the operation with additional information about any non-content resolve actions that are scheduled.
DisplayBaseFile | 131072 | The -o flag displays the base file name and revision to be used during the the merge.
ForceTextualMerge | 262144 | The -t flag forces 'p4 resolve' to attempt a textual merge, even for files with non-text (binary) types.
MarkAllChanges | 524288 | The -v flag causes 'p4 resolve' to insert markers for all changes, not just conflicts.
IgnoreWhitespaceChanges | 1048576 | The -d flags can be used to control handling of whitespace and line endings when merging files: -db Ignore Whitespace Changes
IgnoreWhitespace | 2097152 | The -d flags can be used to control handling of whitespace and line endings when merging files: -dw Ingore whitespace altogether.
IgnoreLineEndings | 4194304 | The -d flags can be used to control handling of whitespace and line endings when merging files: -dl Ignore Line Endings
WsFlags | 7340032 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ResolveOptions Enumeration

[image]

Perforce .NET API
ResolveOptions Enumeration
See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ResolveOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration ResolveOptions
Visual C++
[FlagsAttribute]
public enum class ResolveOptions

Members

Member name | Value | Description
None | 0 |
AcceptMerged | 1 |
AcceptYours | 2 |
AccecptTheirs | 4 |
Skip | 8 |
Merge | 16 |
AutoSelect | 32 |
All | 63 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ResolveSubtype Enumeration

[image]

Perforce .NET API
ResolveSubtype Enumeration
See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum ResolveSubtype
Visual Basic
Public Enumeration ResolveSubtype
Visual C++
public enum class ResolveSubtype

Members

Member name | Value | Description
None | 0 |
ThreeWayText | 1 |
ThreeWayRaw | 2 |
TwoWayRaw | 3 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ResolveType Enumeration

[image]

Perforce .NET API
ResolveType Enumeration
See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum ResolveType
Visual Basic
Public Enumeration ResolveType
Visual C++
public enum class ResolveType

Members

Member name | Value | Description
None | 0 |
Branch | 1 |
Content | 2 |
Delete | 3 |
Move | 4 |
Filetype | 5 |
Attribute | 6 |

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


RevertCmdOptions Class

[image]

Perforce .NET API
RevertCmdOptions Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class RevertCmdOptions : Options
Visual Basic
Public Class RevertCmdOptions _
    Inherits Options
Visual C++
public ref class RevertCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..RevertCmdOptions

See Also

RevertCmdOptions Members


RevertCmdOptions Members

[image] [image]

Perforce .NET API
RevertCmdOptions Members
RevertCmdOptions Class Constructors Methods Properties See Also Send Feedback

The RevertCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | RevertCmdOptions | Revert command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

RevertCmdOptions Class


RevertCmdOptions Constructor

[image]

Perforce .NET API
RevertCmdOptions Constructor
RevertCmdOptions Class See Also Send Feedback
Revert command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public RevertCmdOptions(
    RevertFilesCmdFlags flags,
    int changelist
)
Visual Basic
Public Sub New ( _
    flags As RevertFilesCmdFlags, _
    changelist As Integer _
)
Visual C++
public:
RevertCmdOptions(
    RevertFilesCmdFlags flags,
    int changelist
)

Parameters

flags
Type: Perforce.P4..::..RevertFilesCmdFlags
changelist
Type: System..::..Int32

Return Value

Remarks

p4 help revert

revert -- Discard changes from an opened file

p4 revert [-a -n -k -w -c changelist# -C client] file ...

Revert an open file to the revision that was synced from the depot,
discarding any edits or integrations that have been made. You must
explicitly specify the files to be reverted. Files are removed from
the changelist in which they are open. Locked files are unlocked.

The -a flag reverts only files that are open for edit, add, or
integrate and are unchanged or missing. Files with pending
integration records are left open. The file arguments are optional
when -a is specified.

The -n flag displays a preview of the operation.

The -k flag marks the file as reverted in server metadata without
altering files in the client workspace.

The -w flag causes files that are open for add to be deleted from the
workspace when they are reverted.

The -c flag reverts files that are open in the specified changelist.

The -C flag allows a user to specify the workspace that has the file
opened rather than defaulting to the current client workspace. When
this option is used, the '-k' flag is also enabled and the check for
matching user is disabled. The -C flag requires 'admin' access, which
is granted by 'p4 protect'.

See Also

RevertCmdOptions Class


RevertCmdOptions Methods

[image] [image]

Perforce .NET API
RevertCmdOptions Methods
RevertCmdOptions Class See Also Send Feedback

The RevertCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

RevertCmdOptions Class


RevertCmdOptions Properties

[image] [image]

Perforce .NET API
RevertCmdOptions Properties
RevertCmdOptions Class See Also Send Feedback

The RevertCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

RevertCmdOptions Class


RevertFilesCmdFlags Enumeration

[image]

Perforce .NET API
RevertFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the revert command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum RevertFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration RevertFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class RevertFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
UnchangedOnly | 1 | The -a flag reverts only files that are open for edit or integrate and are unchanged or missing. Files with pending integration records are left open. The file arguments are optional when -a is specified.
Preview | 2 | The -n flag displays a preview of the operation.
ServerOnly | 4 | The -k flag marks the file as reverted in server metadata without altering files in the client workspace.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


Revision Class

[image]

Perforce .NET API
Revision Class
Members See Also Send Feedback
A revision specifier that is a single revision.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Revision : VersionSpec
Visual Basic
Public Class Revision _
    Inherits VersionSpec
Visual C++
public ref class Revision : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..Revision

See Also

Revision Members


Revision Members

[image] [image]

Perforce .NET API
Revision Members
Revision Class Constructors Methods Properties See Also Send Feedback

The Revision type exposes the following members.

Constructors

 | Name | Description
Public method | Revision | A revision specifier that is a single revision.

Methods

 | Name | Description
Public method | Equals | Equals method for for Revision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for Revision (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | Rev |

See Also

Revision Class


Revision Constructor

[image]

Perforce .NET API
Revision Constructor
Revision Class See Also Send Feedback
A revision specifier that is a single revision.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Revision(
    int rev
)
Visual Basic
Public Sub New ( _
    rev As Integer _
)
Visual C++
public:
Revision(
    int rev
)

Parameters

rev
Type: System..::..Int32

See Also

Revision Class


Revision Methods

[image] [image]

Perforce .NET API
Revision Methods
Revision Class See Also Send Feedback

The Revision type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for Revision (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for Revision (Overrides VersionSpec..::..ToString()()()().)

See Also

Revision Class


Equals Method

[image]

Perforce .NET API
Revision..::..Equals Method
Revision Class See Also Send Feedback
Equals method for for Revision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get revision

Return Value

True/False

See Also

Revision Class


ToString Method

[image]

Perforce .NET API
Revision..::..ToString Method
Revision Class See Also Send Feedback
ToString method for for Revision

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String client revision version

See Also

Revision Class


Revision Properties

[image] [image]

Perforce .NET API
Revision Properties
Revision Class See Also Send Feedback

The Revision type exposes the following members.

Properties

 | Name | Description
Public property | Rev |

See Also

Revision Class


Rev Property

[image]

Perforce .NET API
Revision..::..Rev Property
Revision Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Rev { get; private set; }
Visual Basic
Public Property Rev As Integer
    Get
    Private Set
Visual C++
public:
property int Rev {
    int get ();
    private: void set (int value);
}

See Also

Revision Class


RevisionIntegrationSummary Class

[image]

Perforce .NET API
RevisionIntegrationSummary Class
Members See Also Send Feedback
Describes an integration, specifying the from file and how the integration was done.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class RevisionIntegrationSummary
Visual Basic
Public Class RevisionIntegrationSummary
Visual C++
public ref class RevisionIntegrationSummary

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..RevisionIntegrationSummary

See Also

RevisionIntegrationSummary Members


RevisionIntegrationSummary Members

[image] [image]

Perforce .NET API
RevisionIntegrationSummary Members
RevisionIntegrationSummary Class Constructors Methods Properties See Also Send Feedback

The RevisionIntegrationSummary type exposes the following members.

Constructors

 | Name | Description
Public method | RevisionIntegrationSummary | Initializes a new instance of the RevisionIntegrationSummary class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FromFile |
Public property | How |

See Also

RevisionIntegrationSummary Class


RevisionIntegrationSummary Constructor

[image]

Perforce .NET API
RevisionIntegrationSummary Constructor
RevisionIntegrationSummary Class See Also Send Feedback
Initializes a new instance of the RevisionIntegrationSummary class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public RevisionIntegrationSummary(
    FileSpec fromfile,
    string how
)
Visual Basic
Public Sub New ( _
    fromfile As FileSpec, _
    how As String _
)
Visual C++
public:
RevisionIntegrationSummary(
    FileSpec^ fromfile,
    String^ how
)

Parameters

fromfile
Type: Perforce.P4..::..FileSpec
how
Type: System..::..String

See Also

RevisionIntegrationSummary Class


RevisionIntegrationSummary Methods

[image] [image]

Perforce .NET API
RevisionIntegrationSummary Methods
RevisionIntegrationSummary Class See Also Send Feedback

The RevisionIntegrationSummary type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevisionIntegrationSummary Class


RevisionIntegrationSummary Properties

[image] [image]

Perforce .NET API
RevisionIntegrationSummary Properties
RevisionIntegrationSummary Class See Also Send Feedback

The RevisionIntegrationSummary type exposes the following members.

Properties

 | Name | Description
Public property | FromFile |
Public property | How |

See Also

RevisionIntegrationSummary Class


FromFile Property

[image]

Perforce .NET API
RevisionIntegrationSummary..::..FromFile Property
RevisionIntegrationSummary Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileSpec FromFile { get; set; }
Visual Basic
Public Property FromFile As FileSpec
    Get
    Set
Visual C++
public:
property FileSpec^ FromFile {
    FileSpec^ get ();
    void set (FileSpec^ value);
}

See Also

RevisionIntegrationSummary Class


How Property

[image]

Perforce .NET API
RevisionIntegrationSummary..::..How Property
RevisionIntegrationSummary Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string How { get; set; }
Visual Basic
Public Property How As String
    Get
    Set
Visual C++
public:
property String^ How {
    String^ get ();
    void set (String^ value);
}

See Also

RevisionIntegrationSummary Class


Server Class

[image]

Perforce .NET API
Server Class
Members See Also Send Feedback
Represents a specific Perforce server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Server
Visual Basic
Public Class Server
Visual C++
public ref class Server

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Server

See Also

Server Members


Server Members

[image] [image]

Perforce .NET API
Server Members
Server Class Constructors Methods Properties See Also Send Feedback

The Server type exposes the following members.

Constructors

 | Name | Description
Public method | Server | Initializes a new instance of the Server class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | The host:port used to connect to a Perforce server.
Public property | Metadata |
Public property | State |

See Also

Server Class


Server Constructor

[image]

Perforce .NET API
Server Constructor
Server Class See Also Send Feedback
Initializes a new instance of the Server class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Server(
    ServerAddress address
)
Visual Basic
Public Sub New ( _
    address As ServerAddress _
)
Visual C++
public:
Server(
    ServerAddress^ address
)

Parameters

address
Type: Perforce.P4..::..ServerAddress

See Also

Server Class


Server Methods

[image] [image]

Perforce .NET API
Server Methods
Server Class See Also Send Feedback

The Server type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Server Class


Server Properties

[image] [image]

Perforce .NET API
Server Properties
Server Class See Also Send Feedback

The Server type exposes the following members.

Properties

 | Name | Description
Public property | Address | The host:port used to connect to a Perforce server.
Public property | Metadata |
Public property | State |

See Also

Server Class


Address Property

[image]

Perforce .NET API
Server..::..Address Property
Server Class See Also Send Feedback
The host:port used to connect to a Perforce server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerAddress Address { get; internal set; }
Visual Basic
Public Property Address As ServerAddress
    Get
    Friend Set
Visual C++
public:
property ServerAddress^ Address {
    ServerAddress^ get ();
    internal: void set (ServerAddress^ value);
}

Remarks

Note: this can be different than the value returned by the info command if a proxy or broker is used to make the connection.

See Also

Server Class


Metadata Property

[image]

Perforce .NET API
Server..::..Metadata Property
Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerMetaData Metadata { get; private set; }
Visual Basic
Public Property Metadata As ServerMetaData
    Get
    Private Set
Visual C++
public:
property ServerMetaData^ Metadata {
    ServerMetaData^ get ();
    private: void set (ServerMetaData^ value);
}

See Also

Server Class


State Property

[image]

Perforce .NET API
Server..::..State Property
Server Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerState State { get; set; }
Visual Basic
Public Property State As ServerState
    Get
    Set
Visual C++
public:
property ServerState State {
    ServerState get ();
    void set (ServerState value);
}

See Also

Server Class


ServerAddress Class

[image]

Perforce .NET API
ServerAddress Class
Members See Also Send Feedback
The address of the Perforce server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ServerAddress
Visual Basic
Public Class ServerAddress
Visual C++
public ref class ServerAddress

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ServerAddress

See Also

ServerAddress Members


ServerAddress Members

[image] [image]

Perforce .NET API
ServerAddress Members
ServerAddress Class Constructors Methods Properties See Also Send Feedback

The ServerAddress type exposes the following members.

Constructors

 | Name | Description
Public method | ServerAddress | Initializes a new instance of the ServerAddress class

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Uri |

See Also

ServerAddress Class


ServerAddress Constructor

[image]

Perforce .NET API
ServerAddress Constructor
ServerAddress Class See Also Send Feedback
Initializes a new instance of the ServerAddress class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerAddress(
    string uri
)
Visual Basic
Public Sub New ( _
    uri As String _
)
Visual C++
public:
ServerAddress(
    String^ uri
)

Parameters

uri
Type: System..::..String

See Also

ServerAddress Class


ServerAddress Methods

[image] [image]

Perforce .NET API
ServerAddress Methods
ServerAddress Class See Also Send Feedback

The ServerAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

ServerAddress Class


Equals Method

[image]

Perforce .NET API
ServerAddress..::..Equals Method
ServerAddress Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

ServerAddress Class


ToString Method

[image]

Perforce .NET API
ServerAddress..::..ToString Method
ServerAddress Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ServerAddress Class


ServerAddress Properties

[image] [image]

Perforce .NET API
ServerAddress Properties
ServerAddress Class See Also Send Feedback

The ServerAddress type exposes the following members.

Properties

 | Name | Description
Public property | Uri |

See Also

ServerAddress Class


Uri Property

[image]

Perforce .NET API
ServerAddress..::..Uri Property
ServerAddress Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Uri { get; private set; }
Visual Basic
Public Property Uri As String
    Get
    Private Set
Visual C++
public:
property String^ Uri {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerAddress Class


ServerLicense Class

[image]

Perforce .NET API
ServerLicense Class
Members See Also Send Feedback
The Perforce server's license information.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ServerLicense
Visual Basic
Public Class ServerLicense
Visual C++
public ref class ServerLicense

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ServerLicense

See Also

ServerLicense Members


ServerLicense Members

[image] [image]

Perforce .NET API
ServerLicense Members
ServerLicense Class Constructors Methods Properties See Also Send Feedback

The ServerLicense type exposes the following members.

Constructors

 | Name | Description
Public method | ServerLicense | Initializes a new instance of the ServerLicense class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Expires |
Public property | Users |

See Also

ServerLicense Class


ServerLicense Constructor

[image]

Perforce .NET API
ServerLicense Constructor
ServerLicense Class See Also Send Feedback
Initializes a new instance of the ServerLicense class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerLicense(
    int users,
    DateTime expires
)
Visual Basic
Public Sub New ( _
    users As Integer, _
    expires As DateTime _
)
Visual C++
public:
ServerLicense(
    int users,
    DateTime expires
)

Parameters

users
Type: System..::..Int32
expires
Type: System..::..DateTime

See Also

ServerLicense Class


ServerLicense Methods

[image] [image]

Perforce .NET API
ServerLicense Methods
ServerLicense Class See Also Send Feedback

The ServerLicense type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerLicense Class


ServerLicense Properties

[image] [image]

Perforce .NET API
ServerLicense Properties
ServerLicense Class See Also Send Feedback

The ServerLicense type exposes the following members.

Properties

 | Name | Description
Public property | Expires |
Public property | Users |

See Also

ServerLicense Class


Expires Property

[image]

Perforce .NET API
ServerLicense..::..Expires Property
ServerLicense Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Expires { get; private set; }
Visual Basic
Public Property Expires As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Expires {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

ServerLicense Class


Users Property

[image]

Perforce .NET API
ServerLicense..::..Users Property
ServerLicense Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Users { get; private set; }
Visual Basic
Public Property Users As Integer
    Get
    Private Set
Visual C++
public:
property int Users {
    int get ();
    private: void set (int value);
}

See Also

ServerLicense Class


ServerMetaData Class

[image]

Perforce .NET API
ServerMetaData Class
Members See Also Send Feedback
Defines useful metadata about a Perforce server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ServerMetaData
Visual Basic
Public Class ServerMetaData
Visual C++
public ref class ServerMetaData

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ServerMetaData

See Also

ServerMetaData Members


ServerMetaData Members

[image] [image]

Perforce .NET API
ServerMetaData Members
ServerMetaData Class Constructors Methods Properties See Also Send Feedback

The ServerMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | ServerMetaData()()()() | Initializes a new instance of the ServerMetaData class
Public method | ServerMetaData(ServerAddress) | Initializes a new instance of the ServerMetaData class
Public method | ServerMetaData(String, ServerAddress, String, DateTime, String, Int32, ServerVersion, ServerLicense, String, Boolean, Boolean, Boolean) | Initializes a new instance of the ServerMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGetServerMetaDataCmdTaggedOutput | Read the fields from the tagged output of an info command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address |
Public property | CaseSensitive |
Public property | Date |
Public property | DateTimeOffset |
Public property | License |
Public property | LicenseIp |
Public property | MoveEnabled |
Public property | Name |
Public property | RawData |
Public property | Root |
Public property | UnicodeEnabled |
Public property | Uptime |
Public property | Version |

See Also

ServerMetaData Class


ServerMetaData Constructor

[image] [image]

Perforce .NET API
ServerMetaData Constructor
ServerMetaData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ServerMetaData()()()() | Initializes a new instance of the ServerMetaData class
Public method | ServerMetaData(ServerAddress) | Initializes a new instance of the ServerMetaData class
Public method | ServerMetaData(String, ServerAddress, String, DateTime, String, Int32, ServerVersion, ServerLicense, String, Boolean, Boolean, Boolean) | Initializes a new instance of the ServerMetaData class

See Also

ServerMetaData Class
ServerMetaData Members


ServerMetaData Constructor

[image]

Perforce .NET API
ServerMetaData Constructor
ServerMetaData Class See Also Send Feedback
Initializes a new instance of the ServerMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerMetaData()
Visual Basic
Public Sub New
Visual C++
public:
ServerMetaData()

See Also

ServerMetaData Class
ServerMetaData Overload


ServerMetaData Constructor (ServerAddress)

[image]

Perforce .NET API
ServerMetaData Constructor (ServerAddress)
ServerMetaData Class See Also Send Feedback
Initializes a new instance of the ServerMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerMetaData(
    ServerAddress address
)
Visual Basic
Public Sub New ( _
    address As ServerAddress _
)
Visual C++
public:
ServerMetaData(
    ServerAddress^ address
)

Parameters

address
Type: Perforce.P4..::..ServerAddress

See Also

ServerMetaData Class
ServerMetaData Overload


ServerMetaData Constructor (String, ServerAddress, String, DateTime, String, Int32, ServerVersion, ServerLicense, String, Boolean, Boolean, Boolean)

[image]

Perforce .NET API
ServerMetaData Constructor (String, ServerAddress, String, DateTime, String, Int32, ServerVersion, ServerLicense, String, Boolean, Boolean, Boolean)
ServerMetaData Class See Also Send Feedback
Initializes a new instance of the ServerMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerMetaData(
    string name,
    ServerAddress address,
    string root,
    DateTime date,
    string dateTimeOffset,
    int uptime,
    ServerVersion version,
    ServerLicense license,
    string licenseIp,
    bool caseSensitive,
    bool unicodeEnabled,
    bool moveEnabled
)
Visual Basic
Public Sub New ( _
    name As String, _
    address As ServerAddress, _
    root As String, _
    date As DateTime, _
    dateTimeOffset As String, _
    uptime As Integer, _
    version As ServerVersion, _
    license As ServerLicense, _
    licenseIp As String, _
    caseSensitive As Boolean, _
    unicodeEnabled As Boolean, _
    moveEnabled As Boolean _
)
Visual C++
public:
ServerMetaData(
    String^ name,
    ServerAddress^ address,
    String^ root,
    DateTime date,
    String^ dateTimeOffset,
    int uptime,
    ServerVersion^ version,
    ServerLicense^ license,
    String^ licenseIp,
    bool caseSensitive,
    bool unicodeEnabled,
    bool moveEnabled
)

Parameters

name
Type: System..::..String
address
Type: Perforce.P4..::..ServerAddress
root
Type: System..::..String
date
Type: System..::..DateTime
dateTimeOffset
Type: System..::..String
uptime
Type: System..::..Int32
version
Type: Perforce.P4..::..ServerVersion
license
Type: Perforce.P4..::..ServerLicense
licenseIp
Type: System..::..String
caseSensitive
Type: System..::..Boolean
unicodeEnabled
Type: System..::..Boolean
moveEnabled
Type: System..::..Boolean

See Also

ServerMetaData Class
ServerMetaData Overload


ServerMetaData Methods

[image] [image]

Perforce .NET API
ServerMetaData Methods
ServerMetaData Class See Also Send Feedback

The ServerMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromGetServerMetaDataCmdTaggedOutput | Read the fields from the tagged output of an info command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerMetaData Class


FromGetServerMetaDataCmdTaggedOutput Method

[image]

Perforce .NET API
ServerMetaData..::..FromGetServerMetaDataCmdTaggedOutput Method
ServerMetaData Class See Also Send Feedback
Read the fields from the tagged output of an info command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromGetServerMetaDataCmdTaggedOutput(
    TaggedObject objectInfo
)
Visual Basic
Public Sub FromGetServerMetaDataCmdTaggedOutput ( _
    objectInfo As TaggedObject _
)
Visual C++
public:
void FromGetServerMetaDataCmdTaggedOutput(
    TaggedObject^ objectInfo
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'info' command

See Also

ServerMetaData Class


ServerMetaData Properties

[image] [image]

Perforce .NET API
ServerMetaData Properties
ServerMetaData Class See Also Send Feedback

The ServerMetaData type exposes the following members.

Properties

 | Name | Description
Public property | Address |
Public property | CaseSensitive |
Public property | Date |
Public property | DateTimeOffset |
Public property | License |
Public property | LicenseIp |
Public property | MoveEnabled |
Public property | Name |
Public property | RawData |
Public property | Root |
Public property | UnicodeEnabled |
Public property | Uptime |
Public property | Version |

See Also

ServerMetaData Class


Address Property

[image]

Perforce .NET API
ServerMetaData..::..Address Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerAddress Address { get; internal set; }
Visual Basic
Public Property Address As ServerAddress
    Get
    Friend Set
Visual C++
public:
property ServerAddress^ Address {
    ServerAddress^ get ();
    internal: void set (ServerAddress^ value);
}

See Also

ServerMetaData Class


CaseSensitive Property

[image]

Perforce .NET API
ServerMetaData..::..CaseSensitive Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool CaseSensitive { get; private set; }
Visual Basic
Public Property CaseSensitive As Boolean
    Get
    Private Set
Visual C++
public:
property bool CaseSensitive {
    bool get ();
    private: void set (bool value);
}

See Also

ServerMetaData Class


Date Property

[image]

Perforce .NET API
ServerMetaData..::..Date Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Date { get; private set; }
Visual Basic
Public Property Date As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Date {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

ServerMetaData Class


DateTimeOffset Property

[image]

Perforce .NET API
ServerMetaData..::..DateTimeOffset Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string DateTimeOffset { get; private set; }
Visual Basic
Public Property DateTimeOffset As String
    Get
    Private Set
Visual C++
public:
property String^ DateTimeOffset {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerMetaData Class


License Property

[image]

Perforce .NET API
ServerMetaData..::..License Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerLicense License { get; private set; }
Visual Basic
Public Property License As ServerLicense
    Get
    Private Set
Visual C++
public:
property ServerLicense^ License {
    ServerLicense^ get ();
    private: void set (ServerLicense^ value);
}

See Also

ServerMetaData Class


LicenseIp Property

[image]

Perforce .NET API
ServerMetaData..::..LicenseIp Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string LicenseIp { get; private set; }
Visual Basic
Public Property LicenseIp As String
    Get
    Private Set
Visual C++
public:
property String^ LicenseIp {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerMetaData Class


MoveEnabled Property

[image]

Perforce .NET API
ServerMetaData..::..MoveEnabled Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool MoveEnabled { get; private set; }
Visual Basic
Public Property MoveEnabled As Boolean
    Get
    Private Set
Visual C++
public:
property bool MoveEnabled {
    bool get ();
    private: void set (bool value);
}

See Also

ServerMetaData Class


Name Property

[image]

Perforce .NET API
ServerMetaData..::..Name Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerMetaData Class


RawData Property

[image]

Perforce .NET API
ServerMetaData..::..RawData Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObject RawData { get; private set; }
Visual Basic
Public Property RawData As TaggedObject
    Get
    Private Set
Visual C++
public:
property TaggedObject^ RawData {
    TaggedObject^ get ();
    private: void set (TaggedObject^ value);
}

See Also

ServerMetaData Class


Root Property

[image]

Perforce .NET API
ServerMetaData..::..Root Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Root { get; private set; }
Visual Basic
Public Property Root As String
    Get
    Private Set
Visual C++
public:
property String^ Root {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerMetaData Class


UnicodeEnabled Property

[image]

Perforce .NET API
ServerMetaData..::..UnicodeEnabled Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool UnicodeEnabled { get; private set; }
Visual Basic
Public Property UnicodeEnabled As Boolean
    Get
    Private Set
Visual C++
public:
property bool UnicodeEnabled {
    bool get ();
    private: void set (bool value);
}

See Also

ServerMetaData Class


Uptime Property

[image]

Perforce .NET API
ServerMetaData..::..Uptime Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Uptime { get; private set; }
Visual Basic
Public Property Uptime As Integer
    Get
    Private Set
Visual C++
public:
property int Uptime {
    int get ();
    private: void set (int value);
}

See Also

ServerMetaData Class


Version Property

[image]

Perforce .NET API
ServerMetaData..::..Version Property
ServerMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerVersion Version { get; private set; }
Visual Basic
Public Property Version As ServerVersion
    Get
    Private Set
Visual C++
public:
property ServerVersion^ Version {
    ServerVersion^ get ();
    private: void set (ServerVersion^ value);
}

See Also

ServerMetaData Class


ServerMetaData.ServerTimeZone Class

[image]

Perforce .NET API
ServerMetaData..::..ServerTimeZone Class
ServerMetaData Class Members See Also Send Feedback
Defines the UTC offset for the server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ServerTimeZone
Visual Basic
Public Class ServerTimeZone
Visual C++
public ref class ServerTimeZone

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ServerMetaData..::..ServerTimeZone

See Also

ServerMetaData..::..ServerTimeZone Members


ServerMetaData.ServerTimeZone Members

[image] [image]

Perforce .NET API
ServerMetaData..::..ServerTimeZone Members
ServerMetaData..::..ServerTimeZone Class Constructors Methods See Also Send Feedback

Defines useful metadata about a Perforce server.

The ServerMetaData..::..ServerTimeZone type exposes the following members.

Constructors

 | Name | Description
Public method | ServerMetaData..::..ServerTimeZone | Initializes a new instance of the ServerMetaData..::..ServerTimeZone class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UtcOffset |

See Also

ServerMetaData..::..ServerTimeZone Class


ServerMetaData.ServerTimeZone Constructor

[image]

Perforce .NET API
ServerMetaData..::..ServerTimeZone Constructor
ServerMetaData..::..ServerTimeZone Class See Also Send Feedback
Initializes a new instance of the ServerMetaData..::..ServerTimeZone class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerTimeZone()
Visual Basic
Public Sub New
Visual C++
public:
ServerTimeZone()

See Also

ServerMetaData..::..ServerTimeZone Class


ServerMetaData.ServerTimeZone Methods

[image] [image]

Perforce .NET API
ServerMetaData..::..ServerTimeZone Methods
ServerMetaData..::..ServerTimeZone Class See Also Send Feedback

The ServerMetaData..::..ServerTimeZone type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UtcOffset |

See Also

ServerMetaData..::..ServerTimeZone Class


UtcOffset Method

[image]

Perforce .NET API
ServerMetaData..::..ServerTimeZone..::..UtcOffset Method
ServerMetaData..::..ServerTimeZone Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static int UtcOffset()
Visual Basic
Public Shared Function UtcOffset As Integer
Visual C++
public:
static int UtcOffset()

See Also

ServerMetaData..::..ServerTimeZone Class


ServerState Enumeration

[image]

Perforce .NET API
ServerState Enumeration
See Also Send Feedback
The current state of a specific server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ServerState
Visual Basic
<FlagsAttribute> _
Public Enumeration ServerState
Visual C++
[FlagsAttribute]
public enum class ServerState

Members

Member name | Value | Description
Offline | 0 | The server is offline.
Online | 1 | The server is online.
Unknown | 2 | The state of the server is unknown.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ServerVersion Class

[image]

Perforce .NET API
ServerVersion Class
Members See Also Send Feedback
The Perforce server's version information.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ServerVersion
Visual Basic
Public Class ServerVersion
Visual C++
public ref class ServerVersion

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ServerVersion

See Also

ServerVersion Members


ServerVersion Members

[image] [image]

Perforce .NET API
ServerVersion Members
ServerVersion Class Constructors Methods Properties See Also Send Feedback

The ServerVersion type exposes the following members.

Constructors

 | Name | Description
Public method | ServerVersion()()()() | Initializes a new instance of the ServerVersion class
Public method | ServerVersion(String, String, String, String, DateTime) | Initializes a new instance of the ServerVersion class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Date |
Public property | Major |
Public property | Minor |
Public property | Platform |
Public property | Product |

See Also

ServerVersion Class


ServerVersion Constructor

[image] [image]

Perforce .NET API
ServerVersion Constructor
ServerVersion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ServerVersion()()()() | Initializes a new instance of the ServerVersion class
Public method | ServerVersion(String, String, String, String, DateTime) | Initializes a new instance of the ServerVersion class

See Also

ServerVersion Class
ServerVersion Members


ServerVersion Constructor

[image]

Perforce .NET API
ServerVersion Constructor
ServerVersion Class See Also Send Feedback
Initializes a new instance of the ServerVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerVersion()
Visual Basic
Public Sub New
Visual C++
public:
ServerVersion()

See Also

ServerVersion Class
ServerVersion Overload


ServerVersion Constructor (String, String, String, String, DateTime)

[image]

Perforce .NET API
ServerVersion Constructor (String, String, String, String, DateTime)
ServerVersion Class See Also Send Feedback
Initializes a new instance of the ServerVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ServerVersion(
    string product,
    string platform,
    string major,
    string minor,
    DateTime date
)
Visual Basic
Public Sub New ( _
    product As String, _
    platform As String, _
    major As String, _
    minor As String, _
    date As DateTime _
)
Visual C++
public:
ServerVersion(
    String^ product,
    String^ platform,
    String^ major,
    String^ minor,
    DateTime date
)

Parameters

product
Type: System..::..String
platform
Type: System..::..String
major
Type: System..::..String
minor
Type: System..::..String
date
Type: System..::..DateTime

See Also

ServerVersion Class
ServerVersion Overload


ServerVersion Methods

[image] [image]

Perforce .NET API
ServerVersion Methods
ServerVersion Class See Also Send Feedback

The ServerVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerVersion Class


ServerVersion Properties

[image] [image]

Perforce .NET API
ServerVersion Properties
ServerVersion Class See Also Send Feedback

The ServerVersion type exposes the following members.

Properties

 | Name | Description
Public property | Date |
Public property | Major |
Public property | Minor |
Public property | Platform |
Public property | Product |

See Also

ServerVersion Class


Date Property

[image]

Perforce .NET API
ServerVersion..::..Date Property
ServerVersion Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Date { get; private set; }
Visual Basic
Public Property Date As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Date {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

ServerVersion Class


Major Property

[image]

Perforce .NET API
ServerVersion..::..Major Property
ServerVersion Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Major { get; private set; }
Visual Basic
Public Property Major As String
    Get
    Private Set
Visual C++
public:
property String^ Major {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerVersion Class


Minor Property

[image]

Perforce .NET API
ServerVersion..::..Minor Property
ServerVersion Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Minor { get; private set; }
Visual Basic
Public Property Minor As String
    Get
    Private Set
Visual C++
public:
property String^ Minor {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerVersion Class


Platform Property

[image]

Perforce .NET API
ServerVersion..::..Platform Property
ServerVersion Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Platform { get; private set; }
Visual Basic
Public Property Platform As String
    Get
    Private Set
Visual C++
public:
property String^ Platform {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerVersion Class


Product Property

[image]

Perforce .NET API
ServerVersion..::..Product Property
ServerVersion Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Product { get; private set; }
Visual Basic
Public Property Product As String
    Get
    Private Set
Visual C++
public:
property String^ Product {
    String^ get ();
    private: void set (String^ value);
}

See Also

ServerVersion Class


ShelvedFile Class

[image]

Perforce .NET API
ShelvedFile Class
Members See Also Send Feedback
Shelved file information from a Describe -S command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ShelvedFile
Visual Basic
Public Class ShelvedFile
Visual C++
public ref class ShelvedFile

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..ShelvedFile

See Also

ShelvedFile Members


ShelvedFile Members

[image] [image]

Perforce .NET API
ShelvedFile Members
ShelvedFile Class Constructors Methods Properties See Also Send Feedback

The ShelvedFile type exposes the following members.

Constructors

 | Name | Description
Public method | ShelvedFile | Initializes a new instance of the ShelvedFile class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action |
Public property | Digest |
Public property | Path |
Public property | Revision |
Public property | Size |
Public property | Type |

See Also

ShelvedFile Class


ShelvedFile Constructor

[image]

Perforce .NET API
ShelvedFile Constructor
ShelvedFile Class See Also Send Feedback
Initializes a new instance of the ShelvedFile class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ShelvedFile()
Visual Basic
Public Sub New
Visual C++
public:
ShelvedFile()

See Also

ShelvedFile Class


ShelvedFile Methods

[image] [image]

Perforce .NET API
ShelvedFile Methods
ShelvedFile Class See Also Send Feedback

The ShelvedFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShelvedFile Class


ShelvedFile Properties

[image] [image]

Perforce .NET API
ShelvedFile Properties
ShelvedFile Class See Also Send Feedback

The ShelvedFile type exposes the following members.

Properties

 | Name | Description
Public property | Action |
Public property | Digest |
Public property | Path |
Public property | Revision |
Public property | Size |
Public property | Type |

See Also

ShelvedFile Class


Action Property

[image]

Perforce .NET API
ShelvedFile..::..Action Property
ShelvedFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileAction Action { get; set; }
Visual Basic
Public Property Action As FileAction
    Get
    Set
Visual C++
public:
property FileAction Action {
    FileAction get ();
    void set (FileAction value);
}

See Also

ShelvedFile Class


Digest Property

[image]

Perforce .NET API
ShelvedFile..::..Digest Property
ShelvedFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Digest { get; set; }
Visual Basic
Public Property Digest As String
    Get
    Set
Visual C++
public:
property String^ Digest {
    String^ get ();
    void set (String^ value);
}

See Also

ShelvedFile Class


Path Property

[image]

Perforce .NET API
ShelvedFile..::..Path Property
ShelvedFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotPath Path { get; set; }
Visual Basic
Public Property Path As DepotPath
    Get
    Set
Visual C++
public:
property DepotPath^ Path {
    DepotPath^ get ();
    void set (DepotPath^ value);
}

See Also

ShelvedFile Class


Revision Property

[image]

Perforce .NET API
ShelvedFile..::..Revision Property
ShelvedFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Revision { get; set; }
Visual Basic
Public Property Revision As Integer
    Get
    Set
Visual C++
public:
property int Revision {
    int get ();
    void set (int value);
}

See Also

ShelvedFile Class


Size Property

[image]

Perforce .NET API
ShelvedFile..::..Size Property
ShelvedFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public long Size { get; set; }
Visual Basic
Public Property Size As Long
    Get
    Set
Visual C++
public:
property long long Size {
    long long get ();
    void set (long long value);
}

See Also

ShelvedFile Class


Type Property

[image]

Perforce .NET API
ShelvedFile..::..Type Property
ShelvedFile Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType Type { get; set; }
Visual Basic
Public Property Type As FileType
    Get
    Set
Visual C++
public:
property FileType^ Type {
    FileType^ get ();
    void set (FileType^ value);
}

See Also

ShelvedFile Class


ShelvedInChangelistIdVersion Class

[image]

Perforce .NET API
ShelvedInChangelistIdVersion Class
Members See Also Send Feedback
A revision specifier for a file that is shelved in a changelist id.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ShelvedInChangelistIdVersion : VersionSpec
Visual Basic
Public Class ShelvedInChangelistIdVersion _
    Inherits VersionSpec
Visual C++
public ref class ShelvedInChangelistIdVersion : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..ShelvedInChangelistIdVersion

See Also

ShelvedInChangelistIdVersion Members


ShelvedInChangelistIdVersion Members

[image] [image]

Perforce .NET API
ShelvedInChangelistIdVersion Members
ShelvedInChangelistIdVersion Class Constructors Methods Properties See Also Send Feedback

The ShelvedInChangelistIdVersion type exposes the following members.

Constructors

 | Name | Description
Public method | ShelvedInChangelistIdVersion | Initializes a new instance of the ShelvedInChangelistIdVersion class

Methods

 | Name | Description
Public method | Equals | Equals method for for ChangelistIdVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ChangelistIdVersion (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | ChanglistId | get Version as changelist

See Also

ShelvedInChangelistIdVersion Class


ShelvedInChangelistIdVersion Constructor

[image]

Perforce .NET API
ShelvedInChangelistIdVersion Constructor
ShelvedInChangelistIdVersion Class See Also Send Feedback
Initializes a new instance of the ShelvedInChangelistIdVersion class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ShelvedInChangelistIdVersion(
    int Changelist
)
Visual Basic
Public Sub New ( _
    Changelist As Integer _
)
Visual C++
public:
ShelvedInChangelistIdVersion(
    int Changelist
)

Parameters

Changelist
Type: System..::..Int32
The changelist.

See Also

ShelvedInChangelistIdVersion Class


ShelvedInChangelistIdVersion Methods

[image] [image]

Perforce .NET API
ShelvedInChangelistIdVersion Methods
ShelvedInChangelistIdVersion Class See Also Send Feedback

The ShelvedInChangelistIdVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for ChangelistIdVersion (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for ChangelistIdVersion (Overrides VersionSpec..::..ToString()()()().)

See Also

ShelvedInChangelistIdVersion Class


Equals Method

[image]

Perforce .NET API
ShelvedInChangelistIdVersion..::..Equals Method
ShelvedInChangelistIdVersion Class See Also Send Feedback
Equals method for for ChangelistIdVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get changelist

Return Value

True/False

See Also

ShelvedInChangelistIdVersion Class


ToString Method

[image]

Perforce .NET API
ShelvedInChangelistIdVersion..::..ToString Method
ShelvedInChangelistIdVersion Class See Also Send Feedback
ToString method for for ChangelistIdVersion

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String changelist version

See Also

ShelvedInChangelistIdVersion Class


ShelvedInChangelistIdVersion Properties

[image] [image]

Perforce .NET API
ShelvedInChangelistIdVersion Properties
ShelvedInChangelistIdVersion Class See Also Send Feedback

The ShelvedInChangelistIdVersion type exposes the following members.

Properties

 | Name | Description
Public property | ChanglistId | get Version as changelist

See Also

ShelvedInChangelistIdVersion Class


ChanglistId Property

[image]

Perforce .NET API
ShelvedInChangelistIdVersion..::..ChanglistId Property
ShelvedInChangelistIdVersion Class See Also Send Feedback
get Version as changelist

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChanglistId { get; private set; }
Visual Basic
Public Property ChanglistId As Integer
    Get
    Private Set
Visual C++
public:
property int ChanglistId {
    int get ();
    private: void set (int value);
}

See Also

ShelvedInChangelistIdVersion Class


ShelveFilesCmdFlags Enumeration

[image]

Perforce .NET API
ShelveFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the shelve command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum ShelveFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration ShelveFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class ShelveFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Force | 1 | The -f (force) flag must be used with the -c or -i flag to overwrite any existing shelved files in a pending changelist.
Replace | 2 | The -r flag (used with -c or -i) enables you to replace all shelved files in that changelist with the files opened in your own workspace at that changelist number. Only the user and client workspace of the pending changelist can replace its shelved files.
Delete | 4 | The -d flag (used with -c) deletes the shelved files in the specified changelist so that they can no longer be unshelved. By default, only the user and client of the pending changelist can delete its shelved files. A user with 'admin' access can delete shelved files by including the -f flag to force the operation.
ShelveUnchanged | 8 | The -a flag enables you to handle unchanged files similarly to some client submit options, namely 'submitunchanged' and 'leaveunchanged'. The default behavior of shelving all files corresponds to the 'submitunchanged' option. The 'leaveunchanged' option only shelves changed files, and then leaves the files opened in the pending changelist on the client.
LeaveUnchanged | 16 | The -a flag enables you to handle unchanged files similarly to some client submit options, namely 'submitunchanged' and 'leaveunchanged'. The default behavior of shelving all files corresponds to the 'submitunchanged' option. The 'leaveunchanged' option only shelves changed files, and then leaves the files opened in the pending changelist on the client.
Promote | 32 | The -p flag promotes a shelved change from an edge server to a commitserver where it can be accessed by other edge servers participating in the distributed configuration. Once a shelved change has been promoted, all subsequent local modifications to the shelf are also pushed to the commit server and remain until the shelf is deleted. Once a shelf has been created, the combination of flags '-p -c' will promote the shelf without modification.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


ShelveFilesCmdOptions Class

[image]

Perforce .NET API
ShelveFilesCmdOptions Class
Members See Also Send Feedback
Shelve command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ShelveFilesCmdOptions : Options
Visual Basic
Public Class ShelveFilesCmdOptions _
    Inherits Options
Visual C++
public ref class ShelveFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..ShelveFilesCmdOptions

See Also

ShelveFilesCmdOptions Members


ShelveFilesCmdOptions Members

[image] [image]

Perforce .NET API
ShelveFilesCmdOptions Members
ShelveFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The ShelveFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ShelveFilesCmdOptions | Shelve command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ShelveFilesCmdOptions Class


ShelveFilesCmdOptions Constructor

[image]

Perforce .NET API
ShelveFilesCmdOptions Constructor
ShelveFilesCmdOptions Class See Also Send Feedback
Shelve command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ShelveFilesCmdOptions(
    ShelveFilesCmdFlags flags,
    Changelist newChangelist,
    int changelistId
)
Visual Basic
Public Sub New ( _
    flags As ShelveFilesCmdFlags, _
    newChangelist As Changelist, _
    changelistId As Integer _
)
Visual C++
public:
ShelveFilesCmdOptions(
    ShelveFilesCmdFlags flags,
    Changelist^ newChangelist,
    int changelistId
)

Parameters

flags
Type: Perforce.P4..::..ShelveFilesCmdFlags
newChangelist
Type: Perforce.P4..::..Changelist
changelistId
Type: System..::..Int32

Return Value

Remarks

p4 help shelve

shelve -- Store files from a pending changelist into the depot

p4 shelve [-p] [files]
p4 shelve [-a option] [-p] -i [-f | -r]
p4 shelve [-a option] [-p] -r -c changelist#
p4 shelve [-a option] [-p] -c changelist# [-f] [file ...]
p4 shelve -d -c changelist# [-f] [file ...]

'p4 shelve' creates, modifies or deletes shelved files in a pending
changelist. Shelved files remain in the depot until they are deleted
(using 'p4 shelve -d') or replaced by subsequent shelve commands.
After 'p4 shelve', the user can revert the files and restore them
later using 'p4 unshelve'. Other users can 'p4 unshelve' the stored
files into their own workspaces.

Files that have been shelved can be accessed by the 'p4 diff',
'p4 diff2', 'p4 files' and 'p4 print' commands using the revision
specification '@=change', where 'change' is the pending changelist
number.

By default, 'p4 shelve' creates a changelist, adds files from the
user's default changelist, then shelves those files in the depot.
The user is presented with a text changelist form displayed using
the editor configured using the $P4EDITOR environment variable.

If a file pattern is specified, 'p4 shelve' shelves the files that
match the pattern.

The -i flag reads the pending changelist specification with shelved
files from the standard input. The user's editor is not invoked.
To modify an existing changelist with shelved files, specify the
changelist number using the -c flag.

The -c flag specifies the pending changelist that contains shelved
files to be created, deleted, or modified. Only the user and client
of the pending changelist can add or modify its shelved files. Any
files specified by the file pattern must already be opened in the
specified changelist; use 'p4 reopen' to move an opened file from
one changelist to another.

The -f (force) flag must be used with the -c or -i flag to overwrite
any existing shelved files in a pending changelist.

The -r flag (used with -c or -i) enables you to replace all shelved
files in that changelist with the files opened in your own workspace
at that changelist number. Previously shelved files will be deleted.
Only the user and client workspace of the pending changelist can
replace its shelved files.

The -a flag enables you to handle unchanged files similarly to some
client submit options, namely 'submitunchanged' and 'leaveunchanged'.
The default behavior of shelving all files corresponds to the
'submitunchanged' option. The 'leaveunchanged' option only shelves
changed files, and then leaves the files opened in the pending
changelist on the client.

The -d flag (used with -c) deletes the shelved files in the specified
changelist so that they can no longer be unshelved. By default, only
the user and client of the pending changelist can delete its shelved
files. A user with 'admin' access can delete shelved files by including
the -f flag to force the operation.

The -p flag promotes a shelved change from an edge server to a commit
server where it can be accessed by other edge servers participating
in the distributed configuration. Once a shelved change has been
promoted, all subsequent local modifications to the shelf are also
pushed to the commit server and remain until the shelf is deleted.
Once a shelf has been created, the combination of flags '-p -c' will
promote the shelf without modification unless '-f' or '-r' are also
used to update the shelved files before promotion.

'p4 shelve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

ShelveFilesCmdOptions Class


ShelveFilesCmdOptions Methods

[image] [image]

Perforce .NET API
ShelveFilesCmdOptions Methods
ShelveFilesCmdOptions Class See Also Send Feedback

The ShelveFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ShelveFilesCmdOptions Class


ShelveFilesCmdOptions Properties

[image] [image]

Perforce .NET API
ShelveFilesCmdOptions Properties
ShelveFilesCmdOptions Class See Also Send Feedback

The ShelveFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

ShelveFilesCmdOptions Class


SimpleList(T) Class

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class SimpleList<T>
Visual Basic
Public Class SimpleList(Of T)
Visual C++
generic<typename T>
public ref class SimpleList

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..SimpleList<(Of <(<'T>)>)>

See Also

SimpleList<(Of <(<'T>)>)> Members


SimpleList(T) Members

[image] [image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> Members
SimpleList<(Of <(<'T>)>)> Class Constructors Methods Operators Properties See Also Send Feedback

The SimpleList<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleList<(Of <(<'T>)>)> | Initializes a new instance of the SimpleList<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Add |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(T>)>>) to List<(Of <<'(T>)>>)) |
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(T>)>>) to array<T>[]()[][]) |

Properties

 | Name | Description
Public property | Count |
Public property | Head |
Public property | Tail |

See Also

SimpleList<(Of <(<'T>)>)> Class


SimpleList(T) Constructor

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> Constructor
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the SimpleList<(Of <(<'T>)>)> class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SimpleList()
Visual Basic
Public Sub New
Visual C++
public:
SimpleList()

See Also

SimpleList<(Of <(<'T>)>)> Class


SimpleList(T) Methods

[image] [image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> Methods
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

The SimpleList<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SimpleList<(Of <(<'T>)>)> Class


Add Method

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)>..::..Add Method
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Add(
    T item
)
Visual Basic
Public Function Add ( _
    item As T _
) As Integer
Visual C++
public:
int Add(
    T item
)

Parameters

item
Type: T

See Also

SimpleList<(Of <(<'T>)>)> Class


ToArray Method

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)>..::..ToArray Method
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public T[] ToArray()
Visual Basic
Public Function ToArray As T()
Visual C++
public:
array<T>^ ToArray()

See Also

SimpleList<(Of <(<'T>)>)> Class


ToString Method

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)>..::..ToString Method
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

SimpleList<(Of <(<'T>)>)> Class


SimpleList(T) Type Conversions

[image] [image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> Type Conversions
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Operators

Name | Description
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(T>)>>) to List<(Of <<'(T>)>>)) |
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(T>)>>) to array<T>[]()[][]) |

See Also

SimpleList<(Of <(<'T>)>)> Class


Explicit Conversion Operators

[image] [image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> ExplicitNarrowingExplicitExplicitExplicit Conversion Operators
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

Name | Description
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(T>)>>) to List<(Of <<'(T>)>>)) |
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(T>)>>) to array<T>[]()[][]) |

See Also

SimpleList<(Of <(<'T>)>)> Class
SimpleList<(Of <(<'T>)>)> Members


Explicit Conversion (SimpleList(T) to List(T))

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> ExplicitNarrowingExplicitExplicitExplicit Conversion (SimpleList<(Of <(<'T>)>)> to List<(Of <(<'T>)>)>)
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static explicit operator List<T> (
    SimpleList<T> l
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    l As SimpleList(Of T) _
) As List(Of T)
Visual C++
static explicit operator List<T>^ (
    SimpleList<T>^ l
)

Parameters

l
Type: Perforce.P4..::..SimpleList <(Of <(<' T >)>)>

See Also

SimpleList<(Of <(<'T>)>)> Class
ExplicitNarrowingExplicitExplicitExplicit Overload


Explicit Conversion (SimpleList(T) to T[])

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> ExplicitNarrowingExplicitExplicitExplicit Conversion (SimpleList<(Of <(<'T>)>)> to array<T>[]()[][])
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static explicit operator T[] (
    SimpleList<T> l
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    l As SimpleList(Of T) _
) As T()
Visual C++
static explicit operator array<T>^ (
    SimpleList<T>^ l
)

Parameters

l
Type: Perforce.P4..::..SimpleList <(Of <(<' T >)>)>

See Also

SimpleList<(Of <(<'T>)>)> Class
ExplicitNarrowingExplicitExplicitExplicit Overload


SimpleList(T) Properties

[image] [image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)> Properties
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

The SimpleList<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count |
Public property | Head |
Public property | Tail |

See Also

SimpleList<(Of <(<'T>)>)> Class


Count Property

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)>..::..Count Property
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Count { get; private set; }
Visual Basic
Public Property Count As Integer
    Get
    Private Set
Visual C++
public:
property int Count {
    int get ();
    private: void set (int value);
}

See Also

SimpleList<(Of <(<'T>)>)> Class


Head Property

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)>..::..Head Property
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SimpleListItem<T> Head { get; private set; }
Visual Basic
Public Property Head As SimpleListItem(Of T)
    Get
    Private Set
Visual C++
public:
property SimpleListItem<T>^ Head {
    SimpleListItem<T>^ get ();
    private: void set (SimpleListItem<T>^ value);
}

See Also

SimpleList<(Of <(<'T>)>)> Class


Tail Property

[image]

Perforce .NET API
SimpleList<(Of <(<'T>)>)>..::..Tail Property
SimpleList<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SimpleListItem<T> Tail { get; private set; }
Visual Basic
Public Property Tail As SimpleListItem(Of T)
    Get
    Private Set
Visual C++
public:
property SimpleListItem<T>^ Tail {
    SimpleListItem<T>^ get ();
    private: void set (SimpleListItem<T>^ value);
}

See Also

SimpleList<(Of <(<'T>)>)> Class


SimpleListItem(T) Class

[image]

Perforce .NET API
SimpleListItem<(Of <(<'T>)>)> Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class SimpleListItem<T>
Visual Basic
Public Class SimpleListItem(Of T)
Visual C++
generic<typename T>
public ref class SimpleListItem

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..SimpleListItem<(Of <(<'T>)>)>

See Also

SimpleListItem<(Of <(<'T>)>)> Members


SimpleListItem(T) Members

[image] [image]

Perforce .NET API
SimpleListItem<(Of <(<'T>)>)> Members
SimpleListItem<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The SimpleListItem<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | SimpleListItem<(Of <(<'T>)>)> | Initializes a new instance of the SimpleListItem<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item |
Public property | Next |

See Also

SimpleListItem<(Of <(<'T>)>)> Class


SimpleListItem(T) Constructor

[image]

Perforce .NET API
SimpleListItem<(Of <(<'T>)>)> Constructor
SimpleListItem<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the SimpleListItem<(Of <(<'T>)>)> class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SimpleListItem(
    T item
)
Visual Basic
Public Sub New ( _
    item As T _
)
Visual C++
public:
SimpleListItem(
    T item
)

Parameters

item
Type: T

See Also

SimpleListItem<(Of <(<'T>)>)> Class


SimpleListItem(T) Methods

[image] [image]

Perforce .NET API
SimpleListItem<(Of <(<'T>)>)> Methods
SimpleListItem<(Of <(<'T>)>)> Class See Also Send Feedback

The SimpleListItem<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleListItem<(Of <(<'T>)>)> Class


SimpleListItem(T) Properties

[image] [image]

Perforce .NET API
SimpleListItem<(Of <(<'T>)>)> Properties
SimpleListItem<(Of <(<'T>)>)> Class See Also Send Feedback

The SimpleListItem<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Item |
Public property | Next |

See Also

SimpleListItem<(Of <(<'T>)>)> Class


Item Property

[image]

Perforce .NET API
SimpleListItem<(Of <(<'T>)>)>..::..Item Property
SimpleListItem<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public T Item { get; private set; }
Visual Basic
Public Property Item As T
    Get
    Private Set
Visual C++
public:
property T Item {
    T get ();
    private: void set (T value);
}

See Also

SimpleListItem<(Of <(<'T>)>)> Class


Next Property

[image]

Perforce .NET API
SimpleListItem<(Of <(<'T>)>)>..::..Next Property
SimpleListItem<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SimpleListItem<T> Next { get; internal set; }
Visual Basic
Public Property Next As SimpleListItem(Of T)
    Get
    Friend Set
Visual C++
public:
property SimpleListItem<T>^ Next {
    SimpleListItem<T>^ get ();
    internal: void set (SimpleListItem<T>^ value);
}

See Also

SimpleListItem<(Of <(<'T>)>)> Class


SpecField Class

[image]

Perforce .NET API
SpecField Class
Members See Also Send Feedback
Class representing a field in a FormSpec.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class SpecField
Visual Basic
Public Class SpecField
Visual C++
public ref class SpecField

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..SpecField

See Also

SpecField Members


SpecField Members

[image] [image]

Perforce .NET API
SpecField Members
SpecField Class Constructors Methods Properties See Also Send Feedback

The SpecField type exposes the following members.

Constructors

 | Name | Description
Public method | SpecField()()()() | Create a default FormSpec
Public method | SpecField(Int32, String, SpecFieldDataType, Int32, SpecFieldFieldType) | Create a FormSpec

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromSpecCmdTaggedData | Create a SpecField from a 'Fields' entry in the tagged data from the 'spec' command.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Numeric code identifying this form field.
Public property | DataType | A field's type, i.e. whether it's a single word, a date, a selection, or a text field
Public property | FieldType | Specifies whether the field is optional, required, a key, or set by the server.
Public property | Name | Name of this form field.

See Also

SpecField Class


SpecField Constructor

[image] [image]

Perforce .NET API
SpecField Constructor
SpecField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SpecField()()()() | Create a default FormSpec
Public method | SpecField(Int32, String, SpecFieldDataType, Int32, SpecFieldFieldType) | Create a FormSpec

See Also

SpecField Class
SpecField Members


SpecField Constructor

[image]

Perforce .NET API
SpecField Constructor
SpecField Class See Also Send Feedback
Create a default FormSpec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SpecField()
Visual Basic
Public Sub New
Visual C++
public:
SpecField()

See Also

SpecField Class
SpecField Overload


SpecField Constructor (Int32, String, SpecFieldDataType, Int32, SpecFieldFieldType)

[image]

Perforce .NET API
SpecField Constructor (Int32, String, SpecFieldDataType, Int32, SpecFieldFieldType)
SpecField Class See Also Send Feedback
Create a FormSpec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SpecField(
    int code,
    string name,
    SpecFieldDataType datatype,
    int length,
    SpecFieldFieldType fieldtype
)
Visual Basic
Public Sub New ( _
    code As Integer, _
    name As String, _
    datatype As SpecFieldDataType, _
    length As Integer, _
    fieldtype As SpecFieldFieldType _
)
Visual C++
public:
SpecField(
    int code,
    String^ name,
    SpecFieldDataType datatype,
    int length,
    SpecFieldFieldType fieldtype
)

Parameters

code
Type: System..::..Int32
name
Type: System..::..String
datatype
Type: Perforce.P4..::..SpecFieldDataType
length
Type: System..::..Int32
fieldtype
Type: Perforce.P4..::..SpecFieldFieldType

See Also

SpecField Class
SpecField Overload


SpecField Methods

[image] [image]

Perforce .NET API
SpecField Methods
SpecField Class See Also Send Feedback

The SpecField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromSpecCmdTaggedData | Create a SpecField from a 'Fields' entry in the tagged data from the 'spec' command.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpecField Class


FromSpecCmdTaggedData Method

[image]

Perforce .NET API
SpecField..::..FromSpecCmdTaggedData Method
SpecField Class See Also Send Feedback
Create a SpecField from a 'Fields' entry in the tagged data from the 'spec' command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static SpecField FromSpecCmdTaggedData(
    string def
)
Visual Basic
Public Shared Function FromSpecCmdTaggedData ( _
    def As String _
) As SpecField
Visual C++
public:
static SpecField^ FromSpecCmdTaggedData(
    String^ def
)

Parameters

def
Type: System..::..String

Return Value

See Also

SpecField Class


SpecField Properties

[image] [image]

Perforce .NET API
SpecField Properties
SpecField Class See Also Send Feedback

The SpecField type exposes the following members.

Properties

 | Name | Description
Public property | Code | Numeric code identifying this form field.
Public property | DataType | A field's type, i.e. whether it's a single word, a date, a selection, or a text field
Public property | FieldType | Specifies whether the field is optional, required, a key, or set by the server.
Public property | Name | Name of this form field.

See Also

SpecField Class


Code Property

[image]

Perforce .NET API
SpecField..::..Code Property
SpecField Class See Also Send Feedback
Numeric code identifying this form field.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Code { get; set; }
Visual Basic
Public Property Code As Integer
    Get
    Set
Visual C++
public:
property int Code {
    int get ();
    void set (int value);
}

See Also

SpecField Class


DataType Property

[image]

Perforce .NET API
SpecField..::..DataType Property
SpecField Class See Also Send Feedback
A field's type, i.e. whether it's a single word, a date, a selection, or a text field

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SpecFieldDataType DataType { get; set; }
Visual Basic
Public Property DataType As SpecFieldDataType
    Get
    Set
Visual C++
public:
property SpecFieldDataType DataType {
    SpecFieldDataType get ();
    void set (SpecFieldDataType value);
}

See Also

SpecField Class


FieldType Property

[image]

Perforce .NET API
SpecField..::..FieldType Property
SpecField Class See Also Send Feedback
Specifies whether the field is optional, required, a key, or set by the server.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SpecFieldFieldType FieldType { get; set; }
Visual Basic
Public Property FieldType As SpecFieldFieldType
    Get
    Set
Visual C++
public:
property SpecFieldFieldType FieldType {
    SpecFieldFieldType get ();
    void set (SpecFieldFieldType value);
}

See Also

SpecField Class


Name Property

[image]

Perforce .NET API
SpecField..::..Name Property
SpecField Class See Also Send Feedback
Name of this form field.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SpecField Class


SpecFieldDataType Enumeration

[image]

Perforce .NET API
SpecFieldDataType Enumeration
See Also Send Feedback
Field Data Type for a field in a form specification.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum SpecFieldDataType
Visual Basic
<FlagsAttribute> _
Public Enumeration SpecFieldDataType
Visual C++
[FlagsAttribute]
public enum class SpecFieldDataType

Members

Member name | Value | Description
None | 0 | No value.
Word | 1 | Word: a single word (any value).
Date | 2 | Date: a date/time field.
Select | 4 | Select: one of a set of words.
Line | 8 | Line: a one-liner.
Text | 16 | Text: a block of text.
Bulk | 32 | Bulk: text not indexed for 'p4 jobs -e'

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


SpecFieldFieldType Enumeration

[image]

Perforce .NET API
SpecFieldFieldType Enumeration
See Also Send Feedback
Field Type for a field in a form specification.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum SpecFieldFieldType
Visual Basic
<FlagsAttribute> _
Public Enumeration SpecFieldFieldType
Visual C++
[FlagsAttribute]
public enum class SpecFieldFieldType

Members

Member name | Value | Description
Key | 0 | The unique identifier for the field.
Required | 1 | Required: default provided, value must be present.
Always | 2 | Always: always set to the default when saving the form.
Optional | 4 | Optional: no default, and not required to be present.
Default | 8 | Default: default provided, still not required.
Once | 16 | Once: set once to the default and never changed.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


Stream Class

[image]

Perforce .NET API
Stream Class
Members See Also Send Feedback
A stream specification in a Perforce repository.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Stream
Visual Basic
Public Class Stream
Visual C++
public ref class Stream

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Stream

See Also

Stream Members


Stream Members

[image] [image]

Perforce .NET API
Stream Members
Stream Class Constructors Methods Properties See Also Send Feedback

The Stream type exposes the following members.

Constructors

 | Name | Description
Public method | Stream()()()() | Initializes a new instance of the Stream class
Public method | Stream(String, DateTime, DateTime, String, String, PathSpec, PathSpec, StreamType, String, StreamOption, String, String, String, ViewMap, ViewMap, ViewMap, ViewMap, FormSpec) | Initializes a new instance of the Stream class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStreamCmdTaggedOutput | Read the fields from the tagged output of a 'stream' command
Public method | FromStreamsCmdTaggedOutput | Read the fields from the tagged output of a 'streams' command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a stream specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Accessed |
Public property | BaseParent |
Public property | ChangeFlowsFromParent |
Public property | ChangeFlowsToParent |
Public property | Description |
Public property | FirmerThanParent |
Public property | Id |
Public property | Ignored |
Public property | Name |
Public property | Options |
Public property | OwnerName |
Public property | Parent |
Public property | Paths |
Public property | Remapped |
Public property | Spec |
Public property | Type |
Public property | Updated |
Public property | View |

See Also

Stream Class


Stream Constructor

[image] [image]

Perforce .NET API
Stream Constructor
Stream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Stream()()()() | Initializes a new instance of the Stream class
Public method | Stream(String, DateTime, DateTime, String, String, PathSpec, PathSpec, StreamType, String, StreamOption, String, String, String, ViewMap, ViewMap, ViewMap, ViewMap, FormSpec) | Initializes a new instance of the Stream class

See Also

Stream Class
Stream Members


Stream Constructor

[image]

Perforce .NET API
Stream Constructor
Stream Class See Also Send Feedback
Initializes a new instance of the Stream class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream()
Visual Basic
Public Sub New
Visual C++
public:
Stream()

See Also

Stream Class
Stream Overload


Stream Constructor (String, DateTime, DateTime, String, String, PathSpec, PathSpec, StreamType, String, StreamOption, String, String, String, ViewMap, ViewMap, ViewMap, ViewMap, FormSpec)

[image]

Perforce .NET API
Stream Constructor (String, DateTime, DateTime, String, String, PathSpec, PathSpec, StreamType, String, StreamOption, String, String, String, ViewMap, ViewMap, ViewMap, ViewMap, FormSpec)
Stream Class See Also Send Feedback
Initializes a new instance of the Stream class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Stream(
    string id,
    DateTime updated,
    DateTime accessed,
    string ownername,
    string name,
    PathSpec parent,
    PathSpec baseparent,
    StreamType type,
    string description,
    StreamOption options,
    string firmerthanparent,
    string changeflowstoparent,
    string changeflowsfromparent,
    ViewMap paths,
    ViewMap remapped,
    ViewMap ignored,
    ViewMap view,
    FormSpec spec
)
Visual Basic
Public Sub New ( _
    id As String, _
    updated As DateTime, _
    accessed As DateTime, _
    ownername As String, _
    name As String, _
    parent As PathSpec, _
    baseparent As PathSpec, _
    type As StreamType, _
    description As String, _
    options As StreamOption, _
    firmerthanparent As String, _
    changeflowstoparent As String, _
    changeflowsfromparent As String, _
    paths As ViewMap, _
    remapped As ViewMap, _
    ignored As ViewMap, _
    view As ViewMap, _
    spec As FormSpec _
)
Visual C++
public:
Stream(
    String^ id,
    DateTime updated,
    DateTime accessed,
    String^ ownername,
    String^ name,
    PathSpec^ parent,
    PathSpec^ baseparent,
    StreamType type,
    String^ description,
    StreamOption options,
    String^ firmerthanparent,
    String^ changeflowstoparent,
    String^ changeflowsfromparent,
    ViewMap^ paths,
    ViewMap^ remapped,
    ViewMap^ ignored,
    ViewMap^ view,
    FormSpec^ spec
)

Parameters

id
Type: System..::..String
updated
Type: System..::..DateTime
accessed
Type: System..::..DateTime
ownername
Type: System..::..String
name
Type: System..::..String
parent
Type: Perforce.P4..::..PathSpec
baseparent
Type: Perforce.P4..::..PathSpec
type
Type: Perforce.P4..::..StreamType
description
Type: System..::..String
options
Type: Perforce.P4..::..StreamOption
firmerthanparent
Type: System..::..String
changeflowstoparent
Type: System..::..String
changeflowsfromparent
Type: System..::..String
paths
Type: Perforce.P4..::..ViewMap
remapped
Type: Perforce.P4..::..ViewMap
ignored
Type: Perforce.P4..::..ViewMap
view
Type: Perforce.P4..::..ViewMap
spec
Type: Perforce.P4..::..FormSpec

See Also

Stream Class
Stream Overload


Stream Methods

[image] [image]

Perforce .NET API
Stream Methods
Stream Class See Also Send Feedback

The Stream type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromStreamCmdTaggedOutput | Read the fields from the tagged output of a 'stream' command
Public method | FromStreamsCmdTaggedOutput | Read the fields from the tagged output of a 'streams' command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a stream specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

See Also

Stream Class


FromStreamCmdTaggedOutput Method

[image]

Perforce .NET API
Stream..::..FromStreamCmdTaggedOutput Method
Stream Class See Also Send Feedback
Read the fields from the tagged output of a 'stream' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromStreamCmdTaggedOutput(
    TaggedObject objectInfo
)
Visual Basic
Public Sub FromStreamCmdTaggedOutput ( _
    objectInfo As TaggedObject _
)
Visual C++
public:
void FromStreamCmdTaggedOutput(
    TaggedObject^ objectInfo
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'stream' command

See Also

Stream Class


FromStreamsCmdTaggedOutput Method

[image]

Perforce .NET API
Stream..::..FromStreamsCmdTaggedOutput Method
Stream Class See Also Send Feedback
Read the fields from the tagged output of a 'streams' command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromStreamsCmdTaggedOutput(
    TaggedObject objectInfo,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromStreamsCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromStreamsCmdTaggedOutput(
    TaggedObject^ objectInfo,
    String^ offset,
    bool dst_mismatch
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'streams' command
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

Stream Class


Parse Method

[image]

Perforce .NET API
Stream..::..Parse Method
Stream Class See Also Send Feedback
Parse the fields from a stream specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
Text of the stream specification in server format

Return Value

See Also

Stream Class


ToString Method

[image]

Perforce .NET API
Stream..::..ToString Method
Stream Class See Also Send Feedback
Convert to specification in server format

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

Stream Class


Stream Properties

[image] [image]

Perforce .NET API
Stream Properties
Stream Class See Also Send Feedback

The Stream type exposes the following members.

Properties

 | Name | Description
Public property | Accessed |
Public property | BaseParent |
Public property | ChangeFlowsFromParent |
Public property | ChangeFlowsToParent |
Public property | Description |
Public property | FirmerThanParent |
Public property | Id |
Public property | Ignored |
Public property | Name |
Public property | Options |
Public property | OwnerName |
Public property | Parent |
Public property | Paths |
Public property | Remapped |
Public property | Spec |
Public property | Type |
Public property | Updated |
Public property | View |

See Also

Stream Class


Accessed Property

[image]

Perforce .NET API
Stream..::..Accessed Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Accessed { get; set; }
Visual Basic
Public Property Accessed As DateTime
    Get
    Set
Visual C++
public:
property DateTime Accessed {
    DateTime get ();
    void set (DateTime value);
}

See Also

Stream Class


BaseParent Property

[image]

Perforce .NET API
Stream..::..BaseParent Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public PathSpec BaseParent { get; set; }
Visual Basic
Public Property BaseParent As PathSpec
    Get
    Set
Visual C++
public:
property PathSpec^ BaseParent {
    PathSpec^ get ();
    void set (PathSpec^ value);
}

See Also

Stream Class


ChangeFlowsFromParent Property

[image]

Perforce .NET API
Stream..::..ChangeFlowsFromParent Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ChangeFlowsFromParent { get; set; }
Visual Basic
Public Property ChangeFlowsFromParent As String
    Get
    Set
Visual C++
public:
property String^ ChangeFlowsFromParent {
    String^ get ();
    void set (String^ value);
}

See Also

Stream Class


ChangeFlowsToParent Property

[image]

Perforce .NET API
Stream..::..ChangeFlowsToParent Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ChangeFlowsToParent { get; set; }
Visual Basic
Public Property ChangeFlowsToParent As String
    Get
    Set
Visual C++
public:
property String^ ChangeFlowsToParent {
    String^ get ();
    void set (String^ value);
}

See Also

Stream Class


Description Property

[image]

Perforce .NET API
Stream..::..Description Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Stream Class


FirmerThanParent Property

[image]

Perforce .NET API
Stream..::..FirmerThanParent Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string FirmerThanParent { get; set; }
Visual Basic
Public Property FirmerThanParent As String
    Get
    Set
Visual C++
public:
property String^ FirmerThanParent {
    String^ get ();
    void set (String^ value);
}

See Also

Stream Class


Id Property

[image]

Perforce .NET API
Stream..::..Id Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Stream Class


Ignored Property

[image]

Perforce .NET API
Stream..::..Ignored Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap Ignored { get; set; }
Visual Basic
Public Property Ignored As ViewMap
    Get
    Set
Visual C++
public:
property ViewMap^ Ignored {
    ViewMap^ get ();
    void set (ViewMap^ value);
}

See Also

Stream Class


Name Property

[image]

Perforce .NET API
Stream..::..Name Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Stream Class


Options Property

[image]

Perforce .NET API
Stream..::..Options Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamOption Options { get; set; }
Visual Basic
Public Property Options As StreamOption
    Get
    Set
Visual C++
public:
property StreamOption Options {
    StreamOption get ();
    void set (StreamOption value);
}

See Also

Stream Class


OwnerName Property

[image]

Perforce .NET API
Stream..::..OwnerName Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string OwnerName { get; set; }
Visual Basic
Public Property OwnerName As String
    Get
    Set
Visual C++
public:
property String^ OwnerName {
    String^ get ();
    void set (String^ value);
}

See Also

Stream Class


Parent Property

[image]

Perforce .NET API
Stream..::..Parent Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public PathSpec Parent { get; set; }
Visual Basic
Public Property Parent As PathSpec
    Get
    Set
Visual C++
public:
property PathSpec^ Parent {
    PathSpec^ get ();
    void set (PathSpec^ value);
}

See Also

Stream Class


Paths Property

[image]

Perforce .NET API
Stream..::..Paths Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap Paths { get; set; }
Visual Basic
Public Property Paths As ViewMap
    Get
    Set
Visual C++
public:
property ViewMap^ Paths {
    ViewMap^ get ();
    void set (ViewMap^ value);
}

See Also

Stream Class


Remapped Property

[image]

Perforce .NET API
Stream..::..Remapped Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap Remapped { get; set; }
Visual Basic
Public Property Remapped As ViewMap
    Get
    Set
Visual C++
public:
property ViewMap^ Remapped {
    ViewMap^ get ();
    void set (ViewMap^ value);
}

See Also

Stream Class


Spec Property

[image]

Perforce .NET API
Stream..::..Spec Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

Stream Class


Type Property

[image]

Perforce .NET API
Stream..::..Type Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamType Type { get; set; }
Visual Basic
Public Property Type As StreamType
    Get
    Set
Visual C++
public:
property StreamType Type {
    StreamType get ();
    void set (StreamType value);
}

See Also

Stream Class


Updated Property

[image]

Perforce .NET API
Stream..::..Updated Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Updated { get; set; }
Visual Basic
Public Property Updated As DateTime
    Get
    Set
Visual C++
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}

See Also

Stream Class


View Property

[image]

Perforce .NET API
Stream..::..View Property
Stream Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap View { get; private set; }
Visual Basic
Public Property View As ViewMap
    Get
    Private Set
Visual C++
public:
property ViewMap^ View {
    ViewMap^ get ();
    private: void set (ViewMap^ value);
}

See Also

Stream Class


StreamCmdFlags Enumeration

[image]

Perforce .NET API
StreamCmdFlags Enumeration
See Also Send Feedback
Flags for the stream command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum StreamCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration StreamCmdFlags
Visual C++
[FlagsAttribute]
public enum class StreamCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the specified stream (unless the stream is referenced by child streams or stream clients).
Output | 2 | The -o flag writes the stream specification to the standard output. The user's editor is not invoked.
View | 4 | The -v may be used with -o to expose the automatically generated client view for this stream.
Input | 8 | The -i flag reads a stream specification from the standard input. The user's editor is not invoked.
Force | 16 | The -f flag allows a user other than the owner to modify or delete a locked stream. It requires 'admin' access granted by 'p4 protect'.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


StreamCmdOptions Class

[image]

Perforce .NET API
StreamCmdOptions Class
Members See Also Send Feedback
Stream command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class StreamCmdOptions : Options
Visual Basic
Public Class StreamCmdOptions _
    Inherits Options
Visual C++
public ref class StreamCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..StreamCmdOptions

See Also

StreamCmdOptions Members


StreamCmdOptions Members

[image] [image]

Perforce .NET API
StreamCmdOptions Members
StreamCmdOptions Class Constructors Methods Properties See Also Send Feedback

The StreamCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | StreamCmdOptions | Stream command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

StreamCmdOptions Class


StreamCmdOptions Constructor

[image]

Perforce .NET API
StreamCmdOptions Constructor
StreamCmdOptions Class See Also Send Feedback
Stream command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamCmdOptions(
    StreamCmdFlags flags,
    string parent,
    string type
)
Visual Basic
Public Sub New ( _
    flags As StreamCmdFlags, _
    parent As String, _
    type As String _
)
Visual C++
public:
StreamCmdOptions(
    StreamCmdFlags flags,
    String^ parent,
    String^ type
)

Parameters

flags
Type: Perforce.P4..::..StreamCmdFlags
parent
Type: System..::..String
type
Type: System..::..String

See Also

StreamCmdOptions Class


StreamCmdOptions Methods

[image] [image]

Perforce .NET API
StreamCmdOptions Methods
StreamCmdOptions Class See Also Send Feedback

The StreamCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

StreamCmdOptions Class


StreamCmdOptions Properties

[image] [image]

Perforce .NET API
StreamCmdOptions Properties
StreamCmdOptions Class See Also Send Feedback

The StreamCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

StreamCmdOptions Class


StreamMetaData Class

[image]

Perforce .NET API
StreamMetaData Class
Members See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class StreamMetaData
Visual Basic
Public Class StreamMetaData
Visual C++
public ref class StreamMetaData

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..StreamMetaData

See Also

StreamMetaData Members


StreamMetaData Members

[image] [image]

Perforce .NET API
StreamMetaData Members
StreamMetaData Class Constructors Methods Properties See Also Send Feedback

The StreamMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | StreamMetaData()()()() | Initializes a new instance of the StreamMetaData class
Public method | StreamMetaData(DepotPath, DepotPath, StreamType, StreamType, Boolean, Boolean, Boolean, Boolean, StreamMetaData..::..IntegAction, String, Boolean, StreamMetaData..::..IntegAction, String) | Initializes a new instance of the StreamMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromIstatCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChangeFlowsFromParent |
Public property | ChangeFlowsToParent |
Public property | FirmerThanParent |
Public property | FromResult |
Public property | IntegFromParent |
Public property | IntegFromParentHow |
Public property | IntegToParent |
Public property | IntegToParentHow |
Public property | Parent |
Public property | ParentType |
Public property | Stream |
Public property | ToResult |
Public property | Type |

See Also

StreamMetaData Class


StreamMetaData Constructor

[image] [image]

Perforce .NET API
StreamMetaData Constructor
StreamMetaData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StreamMetaData()()()() | Initializes a new instance of the StreamMetaData class
Public method | StreamMetaData(DepotPath, DepotPath, StreamType, StreamType, Boolean, Boolean, Boolean, Boolean, StreamMetaData..::..IntegAction, String, Boolean, StreamMetaData..::..IntegAction, String) | Initializes a new instance of the StreamMetaData class

See Also

StreamMetaData Class
StreamMetaData Members


StreamMetaData Constructor

[image]

Perforce .NET API
StreamMetaData Constructor
StreamMetaData Class See Also Send Feedback
Initializes a new instance of the StreamMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamMetaData()
Visual Basic
Public Sub New
Visual C++
public:
StreamMetaData()

See Also

StreamMetaData Class
StreamMetaData Overload


StreamMetaData Constructor (DepotPath, DepotPath, StreamType, StreamType, Boolean, Boolean, Boolean, Boolean, StreamMetaData.IntegAction, String, Boolean, StreamMetaData.IntegAction, String)

[image]

Perforce .NET API
StreamMetaData Constructor (DepotPath, DepotPath, StreamType, StreamType, Boolean, Boolean, Boolean, Boolean, StreamMetaData..::..IntegAction, String, Boolean, StreamMetaData..::..IntegAction, String)
StreamMetaData Class See Also Send Feedback
Initializes a new instance of the StreamMetaData class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamMetaData(
    DepotPath stream,
    DepotPath parent,
    StreamType type,
    StreamType parenttype,
    bool firmerthanParent,
    bool changeflowstoparent,
    bool changeflowsfromparent,
    bool integtoparent,
    StreamMetaData..::..IntegAction integtoparenthow,
    string toresult,
    bool integfromparent,
    StreamMetaData..::..IntegAction integfromparenthow,
    string fromresult
)
Visual Basic
Public Sub New ( _
    stream As DepotPath, _
    parent As DepotPath, _
    type As StreamType, _
    parenttype As StreamType, _
    firmerthanParent As Boolean, _
    changeflowstoparent As Boolean, _
    changeflowsfromparent As Boolean, _
    integtoparent As Boolean, _
    integtoparenthow As StreamMetaData..::..IntegAction, _
    toresult As String, _
    integfromparent As Boolean, _
    integfromparenthow As StreamMetaData..::..IntegAction, _
    fromresult As String _
)
Visual C++
public:
StreamMetaData(
    DepotPath^ stream,
    DepotPath^ parent,
    StreamType type,
    StreamType parenttype,
    bool firmerthanParent,
    bool changeflowstoparent,
    bool changeflowsfromparent,
    bool integtoparent,
    StreamMetaData..::..IntegAction integtoparenthow,
    String^ toresult,
    bool integfromparent,
    StreamMetaData..::..IntegAction integfromparenthow,
    String^ fromresult
)

Parameters

stream
Type: Perforce.P4..::..DepotPath
parent
Type: Perforce.P4..::..DepotPath
type
Type: Perforce.P4..::..StreamType
parenttype
Type: Perforce.P4..::..StreamType
firmerthanParent
Type: System..::..Boolean
changeflowstoparent
Type: System..::..Boolean
changeflowsfromparent
Type: System..::..Boolean
integtoparent
Type: System..::..Boolean
integtoparenthow
Type: Perforce.P4..::..StreamMetaData..::..IntegAction
toresult
Type: System..::..String
integfromparent
Type: System..::..Boolean
integfromparenthow
Type: Perforce.P4..::..StreamMetaData..::..IntegAction
fromresult
Type: System..::..String

See Also

StreamMetaData Class
StreamMetaData Overload


StreamMetaData Methods

[image] [image]

Perforce .NET API
StreamMetaData Methods
StreamMetaData Class See Also Send Feedback

The StreamMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromIstatCmdTaggedData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StreamMetaData Class


FromIstatCmdTaggedData Method

[image]

Perforce .NET API
StreamMetaData..::..FromIstatCmdTaggedData Method
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromIstatCmdTaggedData(
    TaggedObject obj
)
Visual Basic
Public Sub FromIstatCmdTaggedData ( _
    obj As TaggedObject _
)
Visual C++
public:
void FromIstatCmdTaggedData(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject

See Also

StreamMetaData Class


StreamMetaData Properties

[image] [image]

Perforce .NET API
StreamMetaData Properties
StreamMetaData Class See Also Send Feedback

The StreamMetaData type exposes the following members.

Properties

 | Name | Description
Public property | ChangeFlowsFromParent |
Public property | ChangeFlowsToParent |
Public property | FirmerThanParent |
Public property | FromResult |
Public property | IntegFromParent |
Public property | IntegFromParentHow |
Public property | IntegToParent |
Public property | IntegToParentHow |
Public property | Parent |
Public property | ParentType |
Public property | Stream |
Public property | ToResult |
Public property | Type |

See Also

StreamMetaData Class


ChangeFlowsFromParent Property

[image]

Perforce .NET API
StreamMetaData..::..ChangeFlowsFromParent Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool ChangeFlowsFromParent { get; set; }
Visual Basic
Public Property ChangeFlowsFromParent As Boolean
    Get
    Set
Visual C++
public:
property bool ChangeFlowsFromParent {
    bool get ();
    void set (bool value);
}

See Also

StreamMetaData Class


ChangeFlowsToParent Property

[image]

Perforce .NET API
StreamMetaData..::..ChangeFlowsToParent Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool ChangeFlowsToParent { get; set; }
Visual Basic
Public Property ChangeFlowsToParent As Boolean
    Get
    Set
Visual C++
public:
property bool ChangeFlowsToParent {
    bool get ();
    void set (bool value);
}

See Also

StreamMetaData Class


FirmerThanParent Property

[image]

Perforce .NET API
StreamMetaData..::..FirmerThanParent Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool FirmerThanParent { get; set; }
Visual Basic
Public Property FirmerThanParent As Boolean
    Get
    Set
Visual C++
public:
property bool FirmerThanParent {
    bool get ();
    void set (bool value);
}

See Also

StreamMetaData Class


FromResult Property

[image]

Perforce .NET API
StreamMetaData..::..FromResult Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string FromResult { get; set; }
Visual Basic
Public Property FromResult As String
    Get
    Set
Visual C++
public:
property String^ FromResult {
    String^ get ();
    void set (String^ value);
}

See Also

StreamMetaData Class


IntegFromParent Property

[image]

Perforce .NET API
StreamMetaData..::..IntegFromParent Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IntegFromParent { get; set; }
Visual Basic
Public Property IntegFromParent As Boolean
    Get
    Set
Visual C++
public:
property bool IntegFromParent {
    bool get ();
    void set (bool value);
}

See Also

StreamMetaData Class


IntegFromParentHow Property

[image]

Perforce .NET API
StreamMetaData..::..IntegFromParentHow Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamMetaData..::..IntegAction IntegFromParentHow { get; set; }
Visual Basic
Public Property IntegFromParentHow As StreamMetaData..::..IntegAction
    Get
    Set
Visual C++
public:
property StreamMetaData..::..IntegAction IntegFromParentHow {
    StreamMetaData..::..IntegAction get ();
    void set (StreamMetaData..::..IntegAction value);
}

See Also

StreamMetaData Class


IntegToParent Property

[image]

Perforce .NET API
StreamMetaData..::..IntegToParent Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool IntegToParent { get; set; }
Visual Basic
Public Property IntegToParent As Boolean
    Get
    Set
Visual C++
public:
property bool IntegToParent {
    bool get ();
    void set (bool value);
}

See Also

StreamMetaData Class


IntegToParentHow Property

[image]

Perforce .NET API
StreamMetaData..::..IntegToParentHow Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamMetaData..::..IntegAction IntegToParentHow { get; set; }
Visual Basic
Public Property IntegToParentHow As StreamMetaData..::..IntegAction
    Get
    Set
Visual C++
public:
property StreamMetaData..::..IntegAction IntegToParentHow {
    StreamMetaData..::..IntegAction get ();
    void set (StreamMetaData..::..IntegAction value);
}

See Also

StreamMetaData Class


Parent Property

[image]

Perforce .NET API
StreamMetaData..::..Parent Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotPath Parent { get; set; }
Visual Basic
Public Property Parent As DepotPath
    Get
    Set
Visual C++
public:
property DepotPath^ Parent {
    DepotPath^ get ();
    void set (DepotPath^ value);
}

See Also

StreamMetaData Class


ParentType Property

[image]

Perforce .NET API
StreamMetaData..::..ParentType Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamType ParentType { get; set; }
Visual Basic
Public Property ParentType As StreamType
    Get
    Set
Visual C++
public:
property StreamType ParentType {
    StreamType get ();
    void set (StreamType value);
}

See Also

StreamMetaData Class


Stream Property

[image]

Perforce .NET API
StreamMetaData..::..Stream Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DepotPath Stream { get; set; }
Visual Basic
Public Property Stream As DepotPath
    Get
    Set
Visual C++
public:
property DepotPath^ Stream {
    DepotPath^ get ();
    void set (DepotPath^ value);
}

See Also

StreamMetaData Class


ToResult Property

[image]

Perforce .NET API
StreamMetaData..::..ToResult Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string ToResult { get; set; }
Visual Basic
Public Property ToResult As String
    Get
    Set
Visual C++
public:
property String^ ToResult {
    String^ get ();
    void set (String^ value);
}

See Also

StreamMetaData Class


Type Property

[image]

Perforce .NET API
StreamMetaData..::..Type Property
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamType Type { get; set; }
Visual Basic
Public Property Type As StreamType
    Get
    Set
Visual C++
public:
property StreamType Type {
    StreamType get ();
    void set (StreamType value);
}

See Also

StreamMetaData Class


StreamMetaData.IntegAction Enumeration

[image]

Perforce .NET API
StreamMetaData..::..IntegAction Enumeration
StreamMetaData Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public enum IntegAction
Visual Basic
Public Enumeration IntegAction
Visual C++
public enum class IntegAction

Members

Member name | Value | Description
None | 0 | No options.
Merge | 1 | Leaves all files writable on the client; by default, only files opened by 'p4 edit' are writable. If set, files might be clobbered as a result of ignoring the clobber option.
Copy | 2 | Permits 'p4 sync' to overwrite writable files on the client. noclobber is ignored if allwrite is set.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


StreamOption Enumeration

[image]

Perforce .NET API
StreamOption Enumeration
See Also Send Feedback
Flags to configure stream behavior.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum StreamOption
Visual Basic
<FlagsAttribute> _
Public Enumeration StreamOption
Visual C++
[FlagsAttribute]
public enum class StreamOption

Members

Member name | Value | Description
None | 0 | No flags.
OwnerSubmit | 1 | Indicates whether all users or only the of the stream may submit changes to the stream path.
Locked | 2 | Indicates whether the stream spec is locked against modifications. If locked, the spec may not be deleted, and only its owner may modify it.
NoToParent | 4 | Indicates whether integration from the stream to its parent is expected to occur.
NoFromParent | 8 | Indicates whether integration to the stream from its parent is expected to occur.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


StreamsCmdFlags Enumeration

[image]

Perforce .NET API
StreamsCmdFlags Enumeration
See Also Send Feedback
Flags for the streams command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum StreamsCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration StreamsCmdFlags
Visual C++
[FlagsAttribute]
public enum class StreamsCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


StreamsCmdOptions Class

[image]

Perforce .NET API
StreamsCmdOptions Class
Members See Also Send Feedback
Streams command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class StreamsCmdOptions : Options
Visual Basic
Public Class StreamsCmdOptions _
    Inherits Options
Visual C++
public ref class StreamsCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..StreamsCmdOptions

See Also

StreamsCmdOptions Members


StreamsCmdOptions Members

[image] [image]

Perforce .NET API
StreamsCmdOptions Members
StreamsCmdOptions Class Constructors Methods Properties See Also Send Feedback

The StreamsCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | StreamsCmdOptions | Streams command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

StreamsCmdOptions Class


StreamsCmdOptions Constructor

[image]

Perforce .NET API
StreamsCmdOptions Constructor
StreamsCmdOptions Class See Also Send Feedback
Streams command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StreamsCmdOptions(
    StreamsCmdFlags flags,
    string filter,
    string tagged,
    string streampath,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As StreamsCmdFlags, _
    filter As String, _
    tagged As String, _
    streampath As String, _
    maxItems As Integer _
)
Visual C++
public:
StreamsCmdOptions(
    StreamsCmdFlags flags,
    String^ filter,
    String^ tagged,
    String^ streampath,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..StreamsCmdFlags
filter
Type: System..::..String
tagged
Type: System..::..String
streampath
Type: System..::..String
maxItems
Type: System..::..Int32

See Also

StreamsCmdOptions Class


StreamsCmdOptions Methods

[image] [image]

Perforce .NET API
StreamsCmdOptions Methods
StreamsCmdOptions Class See Also Send Feedback

The StreamsCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

StreamsCmdOptions Class


StreamsCmdOptions Properties

[image] [image]

Perforce .NET API
StreamsCmdOptions Properties
StreamsCmdOptions Class See Also Send Feedback

The StreamsCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

StreamsCmdOptions Class


StreamType Enumeration

[image]

Perforce .NET API
StreamType Enumeration
See Also Send Feedback
Defines the expected flow of change between a stream and its parent.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum StreamType
Visual Basic
<FlagsAttribute> _
Public Enumeration StreamType
Visual C++
[FlagsAttribute]
public enum class StreamType

Members

Member name | Value | Description
Development | 0 | Development: Default. Direction of flow is to parent stream with copy and from parent stream with merge.
Mainline | 1 | Mainline: May not have a parent.
Release | 2 | Release: Direction of flow is to parent with merge and from parent with copy.
Virtual | 4 | Virtual: Not a stream but an alternative view of its parent stream.
Task | 8 | Task: A lightweight short-lived stream that only promotes modified content to the repository, branched data is stored in shadow tables that are removed when the task stream is deleted or unloaded.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


StringEnumCase Enumeration

[image]

Perforce .NET API
StringEnumCase Enumeration
See Also Send Feedback
Defines the case for the StringEnum.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum StringEnumCase
Visual Basic
<FlagsAttribute> _
Public Enumeration StringEnumCase
Visual C++
[FlagsAttribute]
public enum class StringEnumCase

Members

Member name | Value | Description
None | 0 | No case defined.
Lower | 1 | Lowercase.
Upper | 2 | Uppercase.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


StringList Class

[image]

Perforce .NET API
StringList Class
Members See Also Send Feedback
Augment String List used mostly for passing of parameters to command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class StringList : List<string>
Visual Basic
Public Class StringList _
    Inherits List(Of String)
Visual C++
public ref class StringList : public List<String^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' String >)>)>
Perforce.P4..::..StringList

See Also

StringList Members


StringList Members

[image] [image]

Perforce .NET API
StringList Members
StringList Class Constructors Methods Operators Properties See Also Send Feedback

The StringList type exposes the following members.

Constructors

 | Name | Description
Public method | StringList()()()() | Default constructer
Public method | StringList(Int32) | Construct a list with the specified capacity and preallocate the members
Public method | StringList(array<String>[]()[][]) | Create a list from a string array

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Copy | Copy elements from another StringList into this list
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Equals | Test to see if an object is equal to this StringLis. An object is equal if it is a StringArray (or can be cast as one and has the same elements in the same order. (Overrides Object..::..Equals(Object).)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetHashCode | Override to quell compilation warning (Overrides Object..::..GetHashCode()()()().)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
 | IsNullOrEmpy | Test to see if the StringList is null or empty (has no elements)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToString | Convert the list to a single String. Each element is separated by a /r/n line separator. (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' String >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)

Operators

Name | Description
Addition | Add to string lists
Equality | Test to see if two StringList are equal. They are equal if they have the same elements in the same order.
Implicit Widening Implicit Implicit Implicit (array<String>[]()[][] to StringList) | Cast a string array to a string list
Implicit Widening Implicit Implicit Implicit (StringList to array<String>[]()[][]) | Cast a StringList to a String[]
Inequality | Test to see if to StringList are different (not equal)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' String >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class


StringList Constructor

[image] [image]

Perforce .NET API
StringList Constructor
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StringList()()()() | Default constructer
Public method | StringList(Int32) | Construct a list with the specified capacity and preallocate the members
Public method | StringList(array<String>[]()[][]) | Create a list from a string array

See Also

StringList Class
StringList Members


StringList Constructor

[image]

Perforce .NET API
StringList Constructor
StringList Class See Also Send Feedback
Default constructer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StringList()
Visual Basic
Public Sub New
Visual C++
public:
StringList()

See Also

StringList Class
StringList Overload


StringList Constructor (Int32)

[image]

Perforce .NET API
StringList Constructor (Int32)
StringList Class See Also Send Feedback
Construct a list with the specified capacity and preallocate the members

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StringList(
    int capacity
)
Visual Basic
Public Sub New ( _
    capacity As Integer _
)
Visual C++
public:
StringList(
    int capacity
)

Parameters

capacity
Type: System..::..Int32

See Also

StringList Class
StringList Overload


StringList Constructor (String[])

[image]

Perforce .NET API
StringList Constructor (array<String>[]()[][])
StringList Class See Also Send Feedback
Create a list from a string array

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public StringList(
    string[] l
)
Visual Basic
Public Sub New ( _
    l As String() _
)
Visual C++
public:
StringList(
    array<String^>^ l
)

Parameters

l
Type: array< System..::..String >[]()[][]

See Also

StringList Class
StringList Overload


StringList Methods

[image] [image]

Perforce .NET API
StringList Methods
StringList Class See Also Send Feedback

The StringList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Copy | Copy elements from another StringList into this list
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Equals | Test to see if an object is equal to this StringLis. An object is equal if it is a StringArray (or can be cast as one and has the same elements in the same order. (Overrides Object..::..Equals(Object).)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetHashCode | Override to quell compilation warning (Overrides Object..::..GetHashCode()()()().)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
 | IsNullOrEmpy | Test to see if the StringList is null or empty (has no elements)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | ToString | Convert the list to a single String. Each element is separated by a /r/n line separator. (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' String >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class


BinarySearch Method

[image] [image]

Perforce .NET API
StringList..::..BinarySearch Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


Copy Method

[image]

Perforce .NET API
StringList..::..Copy Method
StringList Class See Also Send Feedback
Copy elements from another StringList into this list

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Copy(
    StringList src,
    int destIdx,
    int cnt
)
Visual Basic
Public Sub Copy ( _
    src As StringList, _
    destIdx As Integer, _
    cnt As Integer _
)
Visual C++
public:
void Copy(
    StringList^ src,
    int destIdx,
    int cnt
)

Parameters

src
Type: Perforce.P4..::..StringList
The source StringList
destIdx
Type: System..::..Int32
The index of the first element copied in the destination array
cnt
Type: System..::..Int32
How many elements to copy

See Also

StringList Class


CopyTo Method

[image] [image]

Perforce .NET API
StringList..::..CopyTo Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


Equals Method

[image]

Perforce .NET API
StringList..::..Equals Method
StringList Class See Also Send Feedback
Test to see if an object is equal to this StringLis. An object is equal if it is a StringArray (or can be cast as one and has the same elements in the same order.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to test

Return Value

true if equal

See Also

StringList Class


FindIndex Method

[image] [image]

Perforce .NET API
StringList..::..FindIndex Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


FindLastIndex Method

[image] [image]

Perforce .NET API
StringList..::..FindLastIndex Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


GetHashCode Method

[image]

Perforce .NET API
StringList..::..GetHashCode Method
StringList Class See Also Send Feedback
Override to quell compilation warning

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

See Also

StringList Class


IndexOf Method

[image] [image]

Perforce .NET API
StringList..::..IndexOf Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' String >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


IsNullOrEmpy Method

[image]

Perforce .NET API
StringList..::..IsNullOrEmpy Method
StringList Class See Also Send Feedback
Test to see if the StringList is null or empty (has no elements)

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool IsNullOrEmpy(
    StringList s
)
Visual Basic
Public Shared Function IsNullOrEmpy ( _
    s As StringList _
) As Boolean
Visual C++
public:
static bool IsNullOrEmpy(
    StringList^ s
)

Parameters

s
Type: Perforce.P4..::..StringList

Return Value

See Also

StringList Class


LastIndexOf Method

[image] [image]

Perforce .NET API
StringList..::..LastIndexOf Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' String >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


Reverse Method

[image] [image]

Perforce .NET API
StringList..::..Reverse Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


Sort Method

[image] [image]

Perforce .NET API
StringList..::..Sort Method
StringList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class
StringList Members


ToString Method

[image]

Perforce .NET API
StringList..::..ToString Method
StringList Class See Also Send Feedback
Convert the list to a single String. Each element is separated by a /r/n line separator.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

StringList Class


StringList Operators and Type Conversions

[image] [image]

Perforce .NET API
StringList Operators and Type Conversions
StringList Class See Also Send Feedback

The StringList type exposes the following members.

Operators

Name | Description
Addition | Add to string lists
Equality | Test to see if two StringList are equal. They are equal if they have the same elements in the same order.
Implicit Widening Implicit Implicit Implicit (array<String>[]()[][] to StringList) | Cast a string array to a string list
Implicit Widening Implicit Implicit Implicit (StringList to array<String>[]()[][]) | Cast a StringList to a String[]
Inequality | Test to see if to StringList are different (not equal)

See Also

StringList Class


Addition Operator

[image]

Perforce .NET API
StringList..::..Addition Operator
StringList Class See Also Send Feedback
Add to string lists

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static StringList operator +(
    StringList l,
    StringList r
)
Visual Basic
Public Shared Operator + ( _
    l As StringList, _
    r As StringList _
) As StringList
Visual C++
public:
static StringList^ operator +(
    StringList^ l,
    StringList^ r
)

Parameters

l
Type: Perforce.P4..::..StringList
The left list
r
Type: Perforce.P4..::..StringList
The right list

Return Value

A new list consisting of the elements of the left list followed by the elements of the right list

See Also

StringList Class


Equality Operator

[image]

Perforce .NET API
StringList..::..Equality Operator
StringList Class See Also Send Feedback
Test to see if two StringList are equal. They are equal if they have the same elements in the same order.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool operator ==(
    StringList l1,
    StringList l2
)
Visual Basic
Public Shared Operator = ( _
    l1 As StringList, _
    l2 As StringList _
) As Boolean
Visual C++
public:
static bool operator ==(
    StringList^ l1,
    StringList^ l2
)

Parameters

l1
Type: Perforce.P4..::..StringList
The first list
l2
Type: Perforce.P4..::..StringList
The second list

Return Value

true if equal

See Also

StringList Class


Implicit Conversion Operators

[image] [image]

Perforce .NET API
StringList ImplicitWideningImplicitImplicitImplicit Conversion Operators
StringList Class See Also Send Feedback

Overload List

Name | Description
Implicit Widening Implicit Implicit Implicit (array<String>[]()[][] to StringList) | Cast a string array to a string list
Implicit Widening Implicit Implicit Implicit (StringList to array<String>[]()[][]) | Cast a StringList to a String[]

See Also

StringList Class
StringList Members


Implicit Conversion (String[] to StringList)

[image]

Perforce .NET API
StringList ImplicitWideningImplicitImplicitImplicit Conversion (array<String>[]()[][] to StringList)
StringList Class See Also Send Feedback
Cast a string array to a string list

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator StringList (
    string[] l
)
Visual Basic
Public Shared Widening Operator CType ( _
    l As String() _
) As StringList
Visual C++
static implicit operator StringList^ (
    array<String^>^ l
)

Parameters

l
Type: array< System..::..String >[]()[][]
The list to cast

Return Value

New StringList representing the results of the cast

See Also

StringList Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (StringList to String[])

[image]

Perforce .NET API
StringList ImplicitWideningImplicitImplicitImplicit Conversion (StringList to array<String>[]()[][])
StringList Class See Also Send Feedback
Cast a StringList to a String[]

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static implicit operator string[] (
    StringList l
)
Visual Basic
Public Shared Widening Operator CType ( _
    l As StringList _
) As String()
Visual C++
static implicit operator array<String^>^ (
    StringList^ l
)

Parameters

l
Type: Perforce.P4..::..StringList
The StringList being cast

Return Value

new String[]

See Also

StringList Class
ImplicitWideningImplicitImplicitImplicit Overload


Inequality Operator

[image]

Perforce .NET API
StringList..::..Inequality Operator
StringList Class See Also Send Feedback
Test to see if to StringList are different (not equal)

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static bool operator !=(
    StringList l1,
    StringList l2
)
Visual Basic
Public Shared Operator <> ( _
    l1 As StringList, _
    l2 As StringList _
) As Boolean
Visual C++
public:
static bool operator !=(
    StringList^ l1,
    StringList^ l2
)

Parameters

l1
Type: Perforce.P4..::..StringList
The first list
l2
Type: Perforce.P4..::..StringList
The second list

Return Value

true if not equal

See Also

StringList Class


StringList Properties

[image] [image]

Perforce .NET API
StringList Properties
StringList Class See Also Send Feedback

The StringList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' String >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' String >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' String >)>)>.)

See Also

StringList Class


SubmitCmdOptions Class

[image]

Perforce .NET API
SubmitCmdOptions Class
Members See Also Send Feedback
Submit command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class SubmitCmdOptions : Options
Visual Basic
Public Class SubmitCmdOptions _
    Inherits Options
Visual C++
public ref class SubmitCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..SubmitCmdOptions

See Also

SubmitCmdOptions Members


SubmitCmdOptions Members

[image] [image]

Perforce .NET API
SubmitCmdOptions Members
SubmitCmdOptions Class Constructors Methods Properties See Also Send Feedback

The SubmitCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitCmdOptions | Submit command options

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

SubmitCmdOptions Class


SubmitCmdOptions Constructor

[image]

Perforce .NET API
SubmitCmdOptions Constructor
SubmitCmdOptions Class See Also Send Feedback
Submit command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SubmitCmdOptions(
    SubmitFilesCmdFlags flags,
    int changelist,
    Changelist newChangelist,
    string description,
    ClientSubmitOptions submitOptions
)
Visual Basic
Public Sub New ( _
    flags As SubmitFilesCmdFlags, _
    changelist As Integer, _
    newChangelist As Changelist, _
    description As String, _
    submitOptions As ClientSubmitOptions _
)
Visual C++
public:
SubmitCmdOptions(
    SubmitFilesCmdFlags flags,
    int changelist,
    Changelist^ newChangelist,
    String^ description,
    ClientSubmitOptions^ submitOptions
)

Parameters

flags
Type: Perforce.P4..::..SubmitFilesCmdFlags
changelist
Type: System..::..Int32
newChangelist
Type: Perforce.P4..::..Changelist
description
Type: System..::..String
submitOptions
Type: Perforce.P4..::..ClientSubmitOptions

Return Value

Remarks

p4 help submit

submit -- Submit open files to the depot

p4 submit [-r -s -f option --noretransfer 0|1]
p4 submit [-r -s -f option] file
p4 submit [-r -f option] -d description
p4 submit [-r -f option] -d description file
p4 submit [-r -f option --noretransfer 0|1] -c changelist#
p4 submit -e shelvedChange#
p4 submit -i [-r -s -f option]
--parallel=threads=N[,batch=N][,min=N]

'p4 submit' commits a pending changelist and its files to the depot.

By default, 'p4 submit' attempts to submit all files in the 'default'
changelist. Submit displays a dialog where you enter a description
of the change and, optionally, delete files from the list of files
to be checked in.

To add files to a changelist before submitting, use any of the
commands that open client workspace files: 'p4 add', 'p4 edit',
etc.

If the file parameter is specified, only files in the default
changelist that match the pattern are submitted.

Files in a stream path can be submitted only by client workspaces
dedicated to the stream. See 'p4 help client'.

Before committing a changelist, 'p4 submit' locks all the files being
submitted. If any file cannot be locked or submitted, the files are
left open in a numbered pending changelist. By default, the files in
a failed submit operation are left locked unless the
submit.unlocklocked configurable is set. Files are unlocked even if
they were manually locked prior to submit if submit fails when
submit.unlocklocked is set. 'p4 opened' shows unsubmitted files
and their changelists.

Submit is atomic: if the operation succeeds, all files are updated
in the depot. If the submit fails, no depot files are updated.

If submit fails, some or all of the files may have been copied to
the server. By default, retrying a failed submit will transfer all of
the files again unless the submit.noretransfer configurable is set.
If submit.noretransfer is set to 1, submit uses digest comparisons to
to detect if the files have already been transferred in order to
avoid file re-transfer when retrying a failed submit.

The --noretransfer flag is used to override the submit.noretransfer
configurable so the user can choose his preferred re-transfer
behavior during the current submit operation.

The -c flag submits the specified pending changelist instead of the
default changelist. Additional changelists can be created manually,
using the 'p4 change' command, or automatically as the result of a
failed attempt to submit the default changelist.

The -e flag submits a shelved changelist without transferring files
or modifying the workspace. The shelved change must be owned by
the person submitting the change, but the client may be different.
However, files shelved to a stream target may only be submitted by
a stream client that is mapped to the target stream. In addition,
files shelved to a non-stream target cannot be submitted by a stream
client. To submit a shelved change, all files in the shelved change
must be up to date and resolved. No files may be open in any workspace
at the same change number. Client submit options (ie revertUnchanged,
etc) will be ignored. If the submit is successful, the shelved change
and files are cleaned up, and are no longer available to be unshelved
or submitted.

The -d flag passes a description into the specified changelist rather
than displaying the changelist dialog for manual editing. This option
is useful for scripting, but does not allow you to add jobs or modify
the default changelist.

The -f flag enables you to override submit options that are configured
for the client that is submitting the changelist. This flag overrides
the -r (reopen)flag, if it is specified. See 'p4 help client' for
details about submit options.

The -i flag reads a changelist specification from the standard input.
The user's editor is not invoked.

The -r flag reopens submitted files in the default changelist after
submission.

The -s flag extends the list of jobs to include the fix status
for each job, which becomes the job's status when the changelist
is committed. See 'p4 help change' for details.

The --parallel flag specifies options for parallel file transfer. If
parallel file transfer has been enabled by setting the
net.parallel.max configurable, and if there are sufficient resources
across the system, a submit command may execute more rapidly by
transferring multiple files in parallel. Specify threads=N to request
files be sent concurrently, using N independent network connections.
The N threads grab work in batches; specify batch=N to control the
number of files in a batch. A submit that is too small will not
initiate parallel file transfers; specify min=N to control the
minimum number of files in a parallel submit. Requesting progress
indicators causes the --parallel flag to be ignored.

Using --parallel from an edge server allows parallel file transfer
from the edge server to the commit server. This uses standard pull
threads to transfer the files. Note that an adminstrator must insure
that pull threads can be run on the commit server. The address
used by the commit server to connect to the edge server must
be specified in the ExternalAddress field of the edge server spec.

Only 'submit -e' is supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

SubmitCmdOptions Class


SubmitCmdOptions Methods

[image] [image]

Perforce .NET API
SubmitCmdOptions Methods
SubmitCmdOptions Class See Also Send Feedback

The SubmitCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

SubmitCmdOptions Class


SubmitCmdOptions Properties

[image] [image]

Perforce .NET API
SubmitCmdOptions Properties
SubmitCmdOptions Class See Also Send Feedback

The SubmitCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

SubmitCmdOptions Class


SubmitFilesCmdFlags Enumeration

[image]

Perforce .NET API
SubmitFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the submit command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum SubmitFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration SubmitFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class SubmitFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
ReopenFiles | 1 | The -r flag reopens submitted files in the default changelist after submission.
IncludeJobs | 2 | The -s flag extends the list of jobs to include the fix status for each job, which becomes the job's status when the changelist is committed. See 'p4 help change' for details. submission.
SubmitShelved | 4 | The -e flag submits a shelved changelist without transferring files or modifying the workspace. The shelved change must be owned by the person submitting the change, but the client may be different. However, files shelved to a stream target may only be submitted by a stream client that is mapped to the target stream. In addition, files shelved to a non-stream target cannot be submitted by a stream client. Submitting shelved changes by a task stream client is not supported. To submit a shelved change, all files in the shelved change must be up to date and resolved. No files may be open in any workspace at the same change number. Client submit options (ie revertUnchanged, etc) will be ignored. If the submit is successful, the shelved change and files are cleaned up, and are no longer available to be unshelved or submitted.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


SubmitResults Class

[image]

Perforce .NET API
SubmitResults Class
Members See Also Send Feedback
Describes the results for a submit operation on one or more files.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class SubmitResults
Visual Basic
Public Class SubmitResults
Visual C++
public ref class SubmitResults

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..SubmitResults

See Also

SubmitResults Members


SubmitResults Members

[image] [image]

Perforce .NET API
SubmitResults Members
SubmitResults Class Constructors Methods Properties See Also Send Feedback

The SubmitResults type exposes the following members.

Constructors

 | Name | Description
Public method | SubmitResults()()()() | Initializes a new instance of the SubmitResults class
Public method | SubmitResults(Int32, Int32, Int32) | Initializes a new instance of the SubmitResults class
Public method | SubmitResults(Int32, Int32, Int32, IList<(Of <<'(FileSubmitRecord>)>>)) | Initializes a new instance of the SubmitResults class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChangeIdAfterSubmit |
Public property | ChangeIdBeforeSubmit |
Public property | Files |
Public property | FilesLockedBySubmit |

See Also

SubmitResults Class


SubmitResults Constructor

[image] [image]

Perforce .NET API
SubmitResults Constructor
SubmitResults Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SubmitResults()()()() | Initializes a new instance of the SubmitResults class
Public method | SubmitResults(Int32, Int32, Int32) | Initializes a new instance of the SubmitResults class
Public method | SubmitResults(Int32, Int32, Int32, IList<(Of <<'(FileSubmitRecord>)>>)) | Initializes a new instance of the SubmitResults class

See Also

SubmitResults Class
SubmitResults Members


SubmitResults Constructor

[image]

Perforce .NET API
SubmitResults Constructor
SubmitResults Class See Also Send Feedback
Initializes a new instance of the SubmitResults class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SubmitResults()
Visual Basic
Public Sub New
Visual C++
public:
SubmitResults()

See Also

SubmitResults Class
SubmitResults Overload


SubmitResults Constructor (Int32, Int32, Int32)

[image]

Perforce .NET API
SubmitResults Constructor (Int32, Int32, Int32)
SubmitResults Class See Also Send Feedback
Initializes a new instance of the SubmitResults class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SubmitResults(
    int changeIdBeforeSubmit,
    int filesLockedBySubmit,
    int changeIdAfterSubmit
)
Visual Basic
Public Sub New ( _
    changeIdBeforeSubmit As Integer, _
    filesLockedBySubmit As Integer, _
    changeIdAfterSubmit As Integer _
)
Visual C++
public:
SubmitResults(
    int changeIdBeforeSubmit,
    int filesLockedBySubmit,
    int changeIdAfterSubmit
)

Parameters

changeIdBeforeSubmit
Type: System..::..Int32
filesLockedBySubmit
Type: System..::..Int32
changeIdAfterSubmit
Type: System..::..Int32

See Also

SubmitResults Class
SubmitResults Overload


SubmitResults Constructor (Int32, Int32, Int32, IList(FileSubmitRecord))

[image]

Perforce .NET API
SubmitResults Constructor (Int32, Int32, Int32, IList<(Of <(<'FileSubmitRecord>)>)>)
SubmitResults Class See Also Send Feedback
Initializes a new instance of the SubmitResults class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SubmitResults(
    int changeIdBeforeSubmit,
    int filesLockedBySubmit,
    int changeIdAfterSubmit,
    IList<FileSubmitRecord> files
)
Visual Basic
Public Sub New ( _
    changeIdBeforeSubmit As Integer, _
    filesLockedBySubmit As Integer, _
    changeIdAfterSubmit As Integer, _
    files As IList(Of FileSubmitRecord) _
)
Visual C++
public:
SubmitResults(
    int changeIdBeforeSubmit,
    int filesLockedBySubmit,
    int changeIdAfterSubmit,
    IList<FileSubmitRecord^>^ files
)

Parameters

changeIdBeforeSubmit
Type: System..::..Int32
filesLockedBySubmit
Type: System..::..Int32
changeIdAfterSubmit
Type: System..::..Int32
files
Type: System.Collections.Generic..::..IList <(Of <(<' FileSubmitRecord >)>)>

See Also

SubmitResults Class
SubmitResults Overload


SubmitResults Methods

[image] [image]

Perforce .NET API
SubmitResults Methods
SubmitResults Class See Also Send Feedback

The SubmitResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitResults Class


SubmitResults Properties

[image] [image]

Perforce .NET API
SubmitResults Properties
SubmitResults Class See Also Send Feedback

The SubmitResults type exposes the following members.

Properties

 | Name | Description
Public property | ChangeIdAfterSubmit |
Public property | ChangeIdBeforeSubmit |
Public property | Files |
Public property | FilesLockedBySubmit |

See Also

SubmitResults Class


ChangeIdAfterSubmit Property

[image]

Perforce .NET API
SubmitResults..::..ChangeIdAfterSubmit Property
SubmitResults Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChangeIdAfterSubmit { get; internal set; }
Visual Basic
Public Property ChangeIdAfterSubmit As Integer
    Get
    Friend Set
Visual C++
public:
property int ChangeIdAfterSubmit {
    int get ();
    internal: void set (int value);
}

See Also

SubmitResults Class


ChangeIdBeforeSubmit Property

[image]

Perforce .NET API
SubmitResults..::..ChangeIdBeforeSubmit Property
SubmitResults Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int ChangeIdBeforeSubmit { get; internal set; }
Visual Basic
Public Property ChangeIdBeforeSubmit As Integer
    Get
    Friend Set
Visual C++
public:
property int ChangeIdBeforeSubmit {
    int get ();
    internal: void set (int value);
}

See Also

SubmitResults Class


Files Property

[image]

Perforce .NET API
SubmitResults..::..Files Property
SubmitResults Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<FileSubmitRecord> Files { get; internal set; }
Visual Basic
Public Property Files As IList(Of FileSubmitRecord)
    Get
    Friend Set
Visual C++
public:
property IList<FileSubmitRecord^>^ Files {
    IList<FileSubmitRecord^>^ get ();
    internal: void set (IList<FileSubmitRecord^>^ value);
}

See Also

SubmitResults Class


FilesLockedBySubmit Property

[image]

Perforce .NET API
SubmitResults..::..FilesLockedBySubmit Property
SubmitResults Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int FilesLockedBySubmit { get; internal set; }
Visual Basic
Public Property FilesLockedBySubmit As Integer
    Get
    Friend Set
Visual C++
public:
property int FilesLockedBySubmit {
    int get ();
    internal: void set (int value);
}

See Also

SubmitResults Class


SubmitType Enumeration

[image]

Perforce .NET API
SubmitType Enumeration
See Also Send Feedback
Flags to change submit behavior.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum SubmitType
Visual Basic
<FlagsAttribute> _
Public Enumeration SubmitType
Visual C++
[FlagsAttribute]
public enum class SubmitType

Members

Member name | Value | Description
SubmitUnchanged | 0 | All open files are submitted (default).
RevertUnchanged | 1 | Files that have content or type changes are submitted. Unchanged files are reverted.
LeaveUnchanged | 2 | Files that have content or type changes are submitted. Unchanged files are moved to the default changelist.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


SyncFilesCmdFlags Enumeration

[image]

Perforce .NET API
SyncFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the sync command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum SyncFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration SyncFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class SyncFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Force | 1 | The -f flag forces resynchronization even if the client already has the file, and overwriting any writable files. This flag doesn't affect open files.
ProcessLikeLabel | 2 | The -L flag can be used with multiple file arguments that are in full depot syntax and include a valid revision number. When this flag is used the arguments are processed together by building an internal table similar to a label. This file list processing is significantly faster than having to call the internal query engine for each individual file argument. However, the file argument syntax is strict and the command will not run if an error is encountered.
Preview | 4 | The -n flag previews the operation without updating the workspace.
ServerOnly | 8 | The -k flag updates server metadata without syncing files. It is intended to enable you to ensure that the server correctly reflects the state of files in the workspace while avoiding a large data transfer. Caution: an erroneous update can cause the server to incorrectly reflect the state of the workspace.
PopulateClient | 16 | The -p flag populates the client workspace, but does not update the server to reflect those updates. Any file that is already synced or opened will be bypassed with a warning message. This option is very useful for build clients or when publishing content without the need to track the state of the client workspace.
Quiet | 32 | The -q flag suppresses normal output messages. Messages regarding errors or exceptional conditions are not suppressed.
SafeMode | 64 | The -s flag adds a safety check before sending content to the client workspace. This check uses MD5 digests to compare the content on the clients workspace against content that was last synced. If the file has been modified outside of Perforce's control then an error message is displayed and the file is not overwritten. This check adds some extra processing which will affect the performance of the operation.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


SyncFilesCmdOptions Class

[image]

Perforce .NET API
SyncFilesCmdOptions Class
Members See Also Send Feedback
Sync command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class SyncFilesCmdOptions : Options
Visual Basic
Public Class SyncFilesCmdOptions _
    Inherits Options
Visual C++
public ref class SyncFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..SyncFilesCmdOptions

See Also

SyncFilesCmdOptions Members


SyncFilesCmdOptions Members

[image] [image]

Perforce .NET API
SyncFilesCmdOptions Members
SyncFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The SyncFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SyncFilesCmdOptions | Sync command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

SyncFilesCmdOptions Class


SyncFilesCmdOptions Constructor

[image]

Perforce .NET API
SyncFilesCmdOptions Constructor
SyncFilesCmdOptions Class See Also Send Feedback
Sync command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public SyncFilesCmdOptions(
    SyncFilesCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As SyncFilesCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
SyncFilesCmdOptions(
    SyncFilesCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..SyncFilesCmdFlags
maxItems
Type: System..::..Int32

Remarks

p4 help sync

sync -- Synchronize the client with its view of the depot
flush -- synonym for 'sync -k'
update -- synonym for 'sync -s'

p4 sync [-f -L -n -N -k -q -r] [-m max] [file[revRange] ...]
p4 sync [-L -n -N -q -s] [-m max] [file[revRange] ...]
p4 sync [-L -n -N -p -q] [-m max] [file[revRange] ...]
--parallel=threads=N[,batch=N][,batchsize=N][,min=N][,minsize=N]

Sync updates the client workspace to reflect its current view (if
it has changed) and the current contents of the depot (if it has
changed). The client view maps client and depot file names and
locations.

Sync adds files that are in the client view and have not been
retrieved before. Sync deletes previously retrieved files that
are no longer in the client view or have been deleted from the
depot. Sync updates files that are still in the client view and
have been updated in the depot.

By default, sync affects all files in the client workspace. If file
arguments are given, sync limits its operation to those files.
The file arguments can contain wildcards.

If the file argument includes a revision specifier, then the given
revision is retrieved. Normally, the head revision is retrieved.
See 'p4 help revisions' for help specifying revisions.

If the file argument includes a revision range specification,
only files selected by the revision range are updated, and the
highest revision in the range is used.

Normally, sync does not overwrite workspace files that the user has
manually made writable. Setting the 'clobber' option in the
client specification disables this safety check.

The -f flag forces resynchronization even if the client already
has the file, and overwriting any writable files. This flag doesn't
affect open files.

The -L flag can be used with multiple file arguments that are in
full depot syntax and include a valid revision number. When this
flag is used the arguments are processed together by building an
internal table similar to a label. This file list processing is
significantly faster than having to call the internal query engine
for each individual file argument. However, the file argument syntax
is strict and the command will not run if an error is encountered.

The -n flag previews the operation without updating the workspace.

The -N flag also previews the operation without updating the
workspace, but reports only a summary of the work the sync would do.

The -k flag updates server metadata without syncing files. It is
intended to enable you to ensure that the server correctly reflects
the state of files in the workspace while avoiding a large data
transfer. Caution: an erroneous update can cause the server to
incorrectly reflect the state of the workspace.

The -p flag populates the client workspace, but does not update the
server to reflect those updates. Any file that is already synced or
opened will be bypassed with a warning message. This option is very
useful for build clients or when publishing content without the
need to track the state of the client workspace.

The -q flag suppresses normal output messages. Messages regarding
errors or exceptional conditions are not suppressed.

The -r flag allows open files which are mapped to new locations
in the depot to be reopened in the new location. By default, open
workspace files remain associated with the depot files that they were
originally opened as.

The -s flag adds a safety check before sending content to the client
workspace. This check uses MD5 digests to compare the content on the
clients workspace against content that was last synced. If the file
has been modified outside of Perforce's control then an error message
is displayed and the file is not overwritten. This check adds some
extra processing which will affect the performance of the operation.
Clients with 'allwrite' and 'noclobber' set do this check by default.

The -m flag limits sync to the first 'max' number of files. This
option is useful in conjunction with tagged output and the '-n'
flag, to preview how many files will be synced without transferring
all the file data.

The --parallel flag specifies options for parallel file transfer. If
your administrator has enabled parallel file transfer by setting the
net.parallel.max configurable, and if there are sufficient resources
across the system, a sync command may execute more rapidly by
transferring multiple files in parallel. Specify threads=N to request
files be sent concurrently, using N independent network connections.
The N threads grab work in batches; specify batch=N to control the
number of files in a batch, or batchsize=N to control the number of
bytes in a batch. A sync that is too small will not initiate parallel
file transfers; specify min=N to control the minimum number of files
in a parallel sync, or minsize=N to control the minimum number of
bytes in a parallel sync. Requesting progress indicators causes the
--parallel flag to be ignored.

See Also

SyncFilesCmdOptions Class


SyncFilesCmdOptions Methods

[image] [image]

Perforce .NET API
SyncFilesCmdOptions Methods
SyncFilesCmdOptions Class See Also Send Feedback

The SyncFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

SyncFilesCmdOptions Class


SyncFilesCmdOptions Properties

[image] [image]

Perforce .NET API
SyncFilesCmdOptions Properties
SyncFilesCmdOptions Class See Also Send Feedback

The SyncFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

SyncFilesCmdOptions Class


TagCmdOptions Class

[image]

Perforce .NET API
TagCmdOptions Class
Members See Also Send Feedback
Tag command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TagCmdOptions : Options
Visual Basic
Public Class TagCmdOptions _
    Inherits Options
Visual C++
public ref class TagCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..TagCmdOptions

See Also

TagCmdOptions Members


TagCmdOptions Members

[image] [image]

Perforce .NET API
TagCmdOptions Members
TagCmdOptions Class Constructors Methods Properties See Also Send Feedback

The TagCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | TagCmdOptions | Options for the tag command.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TagCmdOptions Class


TagCmdOptions Constructor

[image]

Perforce .NET API
TagCmdOptions Constructor
TagCmdOptions Class See Also Send Feedback
Options for the tag command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TagCmdOptions(
    TagFilesCmdFlags flags,
    string label
)
Visual Basic
Public Sub New ( _
    flags As TagFilesCmdFlags, _
    label As String _
)
Visual C++
public:
TagCmdOptions(
    TagFilesCmdFlags flags,
    String^ label
)

Parameters

flags
Type: Perforce.P4..::..TagFilesCmdFlags
label
Type: System..::..String

See Also

TagCmdOptions Class


TagCmdOptions Methods

[image] [image]

Perforce .NET API
TagCmdOptions Methods
TagCmdOptions Class See Also Send Feedback

The TagCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TagCmdOptions Class


TagCmdOptions Properties

[image] [image]

Perforce .NET API
TagCmdOptions Properties
TagCmdOptions Class See Also Send Feedback

The TagCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TagCmdOptions Class


TagFilesCmdFlags Enumeration

[image]

Perforce .NET API
TagFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the tag command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum TagFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration TagFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class TagFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d deletes the association between the specified files and the label, regardless of revision.
ListOnly | 2 | The -n flag previews the results of the operation.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


TaggedInfoItem Class

[image]

Perforce .NET API
TaggedInfoItem Class
Members See Also Send Feedback
Base class for objects returned by a command as 'tagged' data.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TaggedInfoItem : TaggedObject
Visual Basic
Public Class TaggedInfoItem _
    Inherits TaggedObject
Visual C++
public ref class TaggedInfoItem : public TaggedObject

Remarks

Contains a Hashtable of the field values for the object. Derived object can provide properties to directly access their standard attributes.

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..TaggedObject
Perforce.P4..::..TaggedInfoItem

See Also

TaggedInfoItem Members


TaggedInfoItem Members

[image] [image]

Perforce .NET API
TaggedInfoItem Members
TaggedInfoItem Class Constructors Methods Properties See Also Send Feedback

The TaggedInfoItem type exposes the following members.

Constructors

 | Name | Description
Public method | TaggedInfoItem | Default constructer

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | ItemData | The raw data returned from the server
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Name | String that that is the field that identifies this object
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TaggedInfoItem Class


TaggedInfoItem Constructor

[image]

Perforce .NET API
TaggedInfoItem Constructor
TaggedInfoItem Class See Also Send Feedback
Default constructer

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedInfoItem()
Visual Basic
Public Sub New
Visual C++
public:
TaggedInfoItem()

See Also

TaggedInfoItem Class


TaggedInfoItem Methods

[image] [image]

Perforce .NET API
TaggedInfoItem Methods
TaggedInfoItem Class See Also Send Feedback

The TaggedInfoItem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TaggedInfoItem Class


TaggedInfoItem Properties

[image] [image]

Perforce .NET API
TaggedInfoItem Properties
TaggedInfoItem Class See Also Send Feedback

The TaggedInfoItem type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | ItemData | The raw data returned from the server
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Name | String that that is the field that identifies this object
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TaggedInfoItem Class


ItemData Property

[image]

Perforce .NET API
TaggedInfoItem..::..ItemData Property
TaggedInfoItem Class See Also Send Feedback
The raw data returned from the server

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObject ItemData { get; }
Visual Basic
Public ReadOnly Property ItemData As TaggedObject
    Get
Visual C++
public:
property TaggedObject^ ItemData {
    TaggedObject^ get ();
}

See Also

TaggedInfoItem Class


Name Property

[image]

Perforce .NET API
TaggedInfoItem..::..Name Property
TaggedInfoItem Class See Also Send Feedback
String that that is the field that identifies this object

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

TaggedInfoItem Class


TaggedObject Class

[image]

Perforce .NET API
TaggedObject Class
Members See Also Send Feedback
The tagged output of a command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TaggedObject : Dictionary<string, string>
Visual Basic
Public Class TaggedObject _
    Inherits Dictionary(Of String, String)
Visual C++
public ref class TaggedObject : public Dictionary<String^, String^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..TaggedObject
Perforce.P4..::..TaggedInfoItem

See Also

TaggedObject Members


TaggedObject Members

[image] [image]

Perforce .NET API
TaggedObject Members
TaggedObject Class Constructors Methods Properties See Also Send Feedback

The TaggedObject type exposes the following members.

Constructors

 | Name | Description
Public method | TaggedObject()()()() | Basic constrictor
Public method | TaggedObject(TaggedObject) | Copy constructor

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TaggedObject Class


TaggedObject Constructor

[image] [image]

Perforce .NET API
TaggedObject Constructor
TaggedObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TaggedObject()()()() | Basic constrictor
Public method | TaggedObject(TaggedObject) | Copy constructor

See Also

TaggedObject Class
TaggedObject Members


TaggedObject Constructor

[image]

Perforce .NET API
TaggedObject Constructor
TaggedObject Class See Also Send Feedback
Basic constrictor

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObject()
Visual Basic
Public Sub New
Visual C++
public:
TaggedObject()

See Also

TaggedObject Class
TaggedObject Overload


TaggedObject Constructor (TaggedObject)

[image]

Perforce .NET API
TaggedObject Constructor (TaggedObject)
TaggedObject Class See Also Send Feedback
Copy constructor

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObject(
    TaggedObject obj
)
Visual Basic
Public Sub New ( _
    obj As TaggedObject _
)
Visual C++
public:
TaggedObject(
    TaggedObject^ obj
)

Parameters

obj
Type: Perforce.P4..::..TaggedObject
Source object

See Also

TaggedObject Class
TaggedObject Overload


TaggedObject Methods

[image] [image]

Perforce .NET API
TaggedObject Methods
TaggedObject Class See Also Send Feedback

The TaggedObject type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TaggedObject Class


TaggedObject Properties

[image] [image]

Perforce .NET API
TaggedObject Properties
TaggedObject Class See Also Send Feedback

The TaggedObject type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TaggedObject Class


TaggedObjectList Class

[image]

Perforce .NET API
TaggedObjectList Class
Members See Also Send Feedback
A list of tagged objects.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TaggedObjectList : List<TaggedObject>
Visual Basic
Public Class TaggedObjectList _
    Inherits List(Of TaggedObject)
Visual C++
public ref class TaggedObjectList : public List<TaggedObject^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' TaggedObject >)>)>
Perforce.P4..::..TaggedObjectList

See Also

TaggedObjectList Members


TaggedObjectList Members

[image] [image]

Perforce .NET API
TaggedObjectList Members
TaggedObjectList Class Constructors Methods Operators Properties See Also Send Feedback

The TaggedObjectList type exposes the following members.

Constructors

 | Name | Description
Public method | TaggedObjectList()()()() | Initializes a new instance of the TaggedObjectList class
Public method | TaggedObjectList(Int32) | Initializes a new instance of the TaggedObjectList class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

Operators

Name | Description
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(TaggedObject>)>>) to TaggedObjectList) |

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class


TaggedObjectList Constructor

[image] [image]

Perforce .NET API
TaggedObjectList Constructor
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TaggedObjectList()()()() | Initializes a new instance of the TaggedObjectList class
Public method | TaggedObjectList(Int32) | Initializes a new instance of the TaggedObjectList class

See Also

TaggedObjectList Class
TaggedObjectList Members


TaggedObjectList Constructor

[image]

Perforce .NET API
TaggedObjectList Constructor
TaggedObjectList Class See Also Send Feedback
Initializes a new instance of the TaggedObjectList class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObjectList()
Visual Basic
Public Sub New
Visual C++
public:
TaggedObjectList()

See Also

TaggedObjectList Class
TaggedObjectList Overload


TaggedObjectList Constructor (Int32)

[image]

Perforce .NET API
TaggedObjectList Constructor (Int32)
TaggedObjectList Class See Also Send Feedback
Initializes a new instance of the TaggedObjectList class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TaggedObjectList(
    int capcity
)
Visual Basic
Public Sub New ( _
    capcity As Integer _
)
Visual C++
public:
TaggedObjectList(
    int capcity
)

Parameters

capcity
Type: System..::..Int32

See Also

TaggedObjectList Class
TaggedObjectList Overload


TaggedObjectList Methods

[image] [image]

Perforce .NET API
TaggedObjectList Methods
TaggedObjectList Class See Also Send Feedback

The TaggedObjectList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class


BinarySearch Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..BinarySearch Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


CopyTo Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..CopyTo Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


FindIndex Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..FindIndex Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


FindLastIndex Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..FindLastIndex Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


IndexOf Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..IndexOf Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


LastIndexOf Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..LastIndexOf Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


Reverse Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..Reverse Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


Sort Method

[image] [image]

Perforce .NET API
TaggedObjectList..::..Sort Method
TaggedObjectList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class
TaggedObjectList Members


TaggedObjectList Type Conversions

[image] [image]

Perforce .NET API
TaggedObjectList Type Conversions
TaggedObjectList Class See Also Send Feedback

The TaggedObjectList type exposes the following members.

Operators

Name | Description
Explicit Narrowing Explicit Explicit Explicit (SimpleList<(Of <<'(TaggedObject>)>>) to TaggedObjectList) |

See Also

TaggedObjectList Class


Explicit Conversion (SimpleList(TaggedObject) to TaggedObjectList)

[image]

Perforce .NET API
TaggedObjectList ExplicitNarrowingExplicitExplicitExplicit Conversion (SimpleList<(Of <(<'TaggedObject>)>)> to TaggedObjectList)
TaggedObjectList Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static explicit operator TaggedObjectList (
    SimpleList<TaggedObject> l
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    l As SimpleList(Of TaggedObject) _
) As TaggedObjectList
Visual C++
static explicit operator TaggedObjectList^ (
    SimpleList<TaggedObject^>^ l
)

Parameters

l
Type: Perforce.P4..::..SimpleList <(Of <(<' TaggedObject >)>)>

See Also

TaggedObjectList Class


TaggedObjectList Properties

[image] [image]

Perforce .NET API
TaggedObjectList Properties
TaggedObjectList Class See Also Send Feedback

The TaggedObjectList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TaggedObject >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' TaggedObject >)>)>.)

See Also

TaggedObjectList Class


Trigger Class

[image]

Perforce .NET API
Trigger Class
Members See Also Send Feedback
Describes an individual entry in the trigger table.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class Trigger
Visual Basic
Public Class Trigger
Visual C++
public ref class Trigger

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..Trigger

See Also

Trigger Members


Trigger Members

[image] [image]

Perforce .NET API
Trigger Members
Trigger Class Constructors Methods Properties See Also Send Feedback

The Trigger type exposes the following members.

Constructors

 | Name | Description
Public method | Trigger | Initializes a new instance of the Trigger class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Command |
Public property | Name |
Public property | Order |
Public property | Path |
Public property | Type |

See Also

Trigger Class


Trigger Constructor

[image]

Perforce .NET API
Trigger Constructor
Trigger Class See Also Send Feedback
Initializes a new instance of the Trigger class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Trigger(
    string name,
    int order,
    TriggerType type,
    string path,
    string command
)
Visual Basic
Public Sub New ( _
    name As String, _
    order As Integer, _
    type As TriggerType, _
    path As String, _
    command As String _
)
Visual C++
public:
Trigger(
    String^ name,
    int order,
    TriggerType type,
    String^ path,
    String^ command
)

Parameters

name
Type: System..::..String
order
Type: System..::..Int32
type
Type: Perforce.P4..::..TriggerType
path
Type: System..::..String
command
Type: System..::..String

See Also

Trigger Class


Trigger Methods

[image] [image]

Perforce .NET API
Trigger Methods
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Trigger Class


Trigger Properties

[image] [image]

Perforce .NET API
Trigger Properties
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Properties

 | Name | Description
Public property | Command |
Public property | Name |
Public property | Order |
Public property | Path |
Public property | Type |

See Also

Trigger Class


Command Property

[image]

Perforce .NET API
Trigger..::..Command Property
Trigger Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Command { get; set; }
Visual Basic
Public Property Command As String
    Get
    Set
Visual C++
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class


Name Property

[image]

Perforce .NET API
Trigger..::..Name Property
Trigger Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class


Order Property

[image]

Perforce .NET API
Trigger..::..Order Property
Trigger Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public int Order { get; set; }
Visual Basic
Public Property Order As Integer
    Get
    Set
Visual C++
public:
property int Order {
    int get ();
    void set (int value);
}

See Also

Trigger Class


Path Property

[image]

Perforce .NET API
Trigger..::..Path Property
Trigger Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class


Type Property

[image]

Perforce .NET API
Trigger..::..Type Property
Trigger Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TriggerType Type { get; set; }
Visual Basic
Public Property Type As TriggerType
    Get
    Set
Visual C++
public:
property TriggerType Type {
    TriggerType get ();
    void set (TriggerType value);
}

See Also

Trigger Class


TriggerTable Class

[image]

Perforce .NET API
TriggerTable Class
Members See Also Send Feedback
Defines triggers on Perforce events.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TriggerTable : List<Trigger>
Visual Basic
Public Class TriggerTable _
    Inherits List(Of Trigger)
Visual C++
public ref class TriggerTable : public List<Trigger^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Trigger >)>)>
Perforce.P4..::..TriggerTable

See Also

TriggerTable Members


TriggerTable Members

[image] [image]

Perforce .NET API
TriggerTable Members
TriggerTable Class Constructors Methods Properties See Also Send Feedback

The TriggerTable type exposes the following members.

Constructors

 | Name | Description
Public method | TriggerTable | Initializes a new instance of the TriggerTable class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public property | Entry |
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public property | Spec |

See Also

TriggerTable Class


TriggerTable Constructor

[image]

Perforce .NET API
TriggerTable Constructor
TriggerTable Class See Also Send Feedback
Initializes a new instance of the TriggerTable class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TriggerTable(
    Trigger entry,
    FormSpec spec
)
Visual Basic
Public Sub New ( _
    entry As Trigger, _
    spec As FormSpec _
)
Visual C++
public:
TriggerTable(
    Trigger^ entry,
    FormSpec^ spec
)

Parameters

entry
Type: Perforce.P4..::..Trigger
spec
Type: Perforce.P4..::..FormSpec

See Also

TriggerTable Class


TriggerTable Methods

[image] [image]

Perforce .NET API
TriggerTable Methods
TriggerTable Class See Also Send Feedback

The TriggerTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class


BinarySearch Method

[image] [image]

Perforce .NET API
TriggerTable..::..BinarySearch Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


CopyTo Method

[image] [image]

Perforce .NET API
TriggerTable..::..CopyTo Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


FindIndex Method

[image] [image]

Perforce .NET API
TriggerTable..::..FindIndex Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


FindLastIndex Method

[image] [image]

Perforce .NET API
TriggerTable..::..FindLastIndex Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


IndexOf Method

[image] [image]

Perforce .NET API
TriggerTable..::..IndexOf Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


LastIndexOf Method

[image] [image]

Perforce .NET API
TriggerTable..::..LastIndexOf Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


Reverse Method

[image] [image]

Perforce .NET API
TriggerTable..::..Reverse Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


Sort Method

[image] [image]

Perforce .NET API
TriggerTable..::..Sort Method
TriggerTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' Trigger >)>)>.)

See Also

TriggerTable Class
TriggerTable Members


TriggerTable Properties

[image] [image]

Perforce .NET API
TriggerTable Properties
TriggerTable Class See Also Send Feedback

The TriggerTable type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public property | Entry |
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' Trigger >)>)>.)
Public property | Spec |

See Also

TriggerTable Class


Entry Property

[image]

Perforce .NET API
TriggerTable..::..Entry Property
TriggerTable Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public Trigger Entry { get; set; }
Visual Basic
Public Property Entry As Trigger
    Get
    Set
Visual C++
public:
property Trigger^ Entry {
    Trigger^ get ();
    void set (Trigger^ value);
}

See Also

TriggerTable Class


Spec Property

[image]

Perforce .NET API
TriggerTable..::..Spec Property
TriggerTable Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

TriggerTable Class


TriggerType Enumeration

[image]

Perforce .NET API
TriggerType Enumeration
See Also Send Feedback
Defines whent he trigger is to execute.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum TriggerType
Visual Basic
<FlagsAttribute> _
Public Enumeration TriggerType
Visual C++
[FlagsAttribute]
public enum class TriggerType

Members

Member name | Value | Description
Archive | 0 | archive: Execute an archive trigger for the server to access any file with the +X filetype modifier.
AuthServiceCheck | 1 | service-check: Execute an authentication check trigger to verify a user's password against an external password manager during login or when setting a new password.
AuthCheckSSO | 2 | auth-check-sso: Facilitate a single sign-on user authentication. This configuration requires two programs or scripts to run; one on the client, the other on the server.
AuthSet | 4 | auth-set: Execute an authentication set trigger to send a new password to an external password manager.
ChangeSubmit | 8 | change-submit: Execute pre-submit trigger after changelist has been created and files locked but prior to file transfer.
ChangeContent | 16 | change-content: Execute mid-submit trigger after file transfer but prior to commit. Files can be accessed by the 'p4 diff2', 'p4 files', 'p4 fstat', and 'p4 print' commands using the revision specification '@=change', where 'change' is the pending changelist number passed as %changelist%.
ChangeCommit | 32 | change-commit: Execute post-submit trigger after changelist commit.
FixAdd | 64 | fix-add: Execute fix trigger prior to adding a fix. The special variable %jobs% is available for expansion and must be the last argument to the trigger as it expands to one argument for each job listed on the 'p4 fix' command.
FixDelete | 128 | fix-delete: Execute fix trigger prior to deleting a fix. The special variable %jobs% is available for expansion and must be the last argument to the trigger as it expands to one argument for each job listed on the 'p4 fix -d' command.
FormOut | 256 | form-out: Execute form trigger on generation of form. Trigger may modify form.
FormIn | 512 | form-in: Execute form trigger on input of form before its contents are parsed and validated. Trigger may modify form.
FormSave | 1024 | form-save: Execute form trigger prior to save of form after its contents are parsed.
FormCommit | 2048 | form-commit: Execute form trigger after it has been committed, allowing access to automatically generated fields (jobname, dates etc). It cannot modify the form. This trigger for job forms is run by 'p4 job' and 'p4 fix' (after the status is updated), 'p4 change' (if the job is added or deleted) and 'p4 submit' (if the job is associated with the change). The 'form-commit' trigger has access to the new job name created with 'p4 job', while the 'form-in' and 'form-save' triggers are run before the job name is created. The special variable %action% is available on the job 'form-commit' trigger command line, and is expanded when the job is modified by a fix.
FormDelete | 4096 | form-delete: Execute form trigger prior to delete of form after its contents are parsed.
ShelveSubmit | 8192 | shelve-submit: Execute pre-shelve trigger after changelist has been created but prior to file transfer.
ShelveCommit | 16384 | shelve-commit: Execute post-shelve trigger after files are shelved.
ShelveDelete | 32768 | shelve-delete: Execute shelve trigger prior to discarding shelved files.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


TrustCmdFlags Enumeration

[image]

Perforce .NET API
TrustCmdFlags Enumeration
See Also Send Feedback
Flags for the trust command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum TrustCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration TrustCmdFlags
Visual C++
[FlagsAttribute]
public enum class TrustCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
List | 1 | The -l flag lists existing known fingerprints.
AutoAccept | 2 | The -y flag will cause prompts to be automatically accepted.
AutoReject | 4 | The -n flag will cause prompts to be automatically refused.
Delete | 8 | The -d flag will remove an existing trusted fingerprint of a connection.
ForceReplacement | 16 | The -f flag will force the replacement of a mismatched fingerprint.
Install | 32 | The -i flag will allow a specific fingerprint to be installed.
Replacement | 64 | The -r flag specifies that a replacement fingerprint is to be affected. Replacement fingerprints can be used in anticipation of a server replacing its key. If a replacement fingerprint exists for a connection and the primary fingerprint does not match while the replacement fingerprint does, the replacement fingerprint will replace the primary. This flag can be combined with -l, -i, or -d.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


TrustCmdOptions Class

[image]

Perforce .NET API
TrustCmdOptions Class
Members See Also Send Feedback
Options for the Trust command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TrustCmdOptions : Options
Visual Basic
Public Class TrustCmdOptions _
    Inherits Options
Visual C++
public ref class TrustCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..TrustCmdOptions

See Also

TrustCmdOptions Members


TrustCmdOptions Members

[image] [image]

Perforce .NET API
TrustCmdOptions Members
TrustCmdOptions Class Constructors Methods Properties See Also Send Feedback

The TrustCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | TrustCmdOptions | Options for the Describe command

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TrustCmdOptions Class


TrustCmdOptions Constructor

[image]

Perforce .NET API
TrustCmdOptions Constructor
TrustCmdOptions Class See Also Send Feedback
Options for the Describe command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TrustCmdOptions(
    TrustCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As TrustCmdFlags _
)
Visual C++
public:
TrustCmdOptions(
    TrustCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..TrustCmdFlags

Remarks

p4 trust -h

trust -- Establish trust of an SSL connection

p4 trust [ -l -y -n -d -f -r -i <fingerprint> ]

Establish trust of an SSL connection. This client command manages
the p4 trust file. This file contains fingerprints of the keys
received on ssl connections. When an SSL connection is made, this
file is examined to determine if the SSL connection has been used
before and if the key is the same as a previously seen key for that
connection. Establishing trust with a connection prevents undetected
communication interception (man-in-the-middle) attacks.

Most options are mutually exclusive. Only the -r and -f options
can be combined with the others.

The -l flag lists existing known fingerprints.

Without options, this command will make a connection to a server
and examine the key if present, if one cannot be found this command
will show a fingerprint and ask if this connection should be trusted.
If a fingerprint exists and does not match, an error that a possible
security problems exists will be displayed.

The -y flag will cause prompts to be automatically accepted.

The -n flag will cause prompts to be automatically refused.

The -d flag will remove an existing trusted fingerprint of a connection.

The -f flag will force the replacement of a mismatched fingerprint.

The -i flag will allow a specific fingerprint to be installed.

The -r flag specifies that a replacement fingerprint is to be
affected. Replacement fingerprints can be used in anticipation
of a server replacing its key. If a replacement fingerprint
exists for a connection and the primary fingerprint does not match
while the replacement fingerprint does, the replacement fingerprint
will replace the primary. This flag can be combined with -l, -i,
or -d.

See Also

TrustCmdOptions Class


TrustCmdOptions Methods

[image] [image]

Perforce .NET API
TrustCmdOptions Methods
TrustCmdOptions Class See Also Send Feedback

The TrustCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TrustCmdOptions Class


TrustCmdOptions Properties

[image] [image]

Perforce .NET API
TrustCmdOptions Properties
TrustCmdOptions Class See Also Send Feedback

The TrustCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

TrustCmdOptions Class


TypeMap Class

[image]

Perforce .NET API
TypeMap Class
Members See Also Send Feedback
Defines a Perforce repository's default mapping between file names or locations and file types.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TypeMap : List<TypeMapEntry>
Visual Basic
Public Class TypeMap _
    Inherits List(Of TypeMapEntry)
Visual C++
public ref class TypeMap : public List<TypeMapEntry^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' TypeMapEntry >)>)>
Perforce.P4..::..TypeMap

See Also

TypeMap Members


TypeMap Members

[image] [image]

Perforce .NET API
TypeMap Members
TypeMap Class Constructors Methods Properties See Also Send Feedback

The TypeMap type exposes the following members.

Constructors

 | Name | Description
Public method | TypeMap()()()() | Initializes a new instance of the TypeMap class
Public method | TypeMap(TypeMapEntry, FormSpec) | Initializes a new instance of the TypeMap class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public property | Mapping |
Public property | Spec |

See Also

TypeMap Class


TypeMap Constructor

[image] [image]

Perforce .NET API
TypeMap Constructor
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeMap()()()() | Initializes a new instance of the TypeMap class
Public method | TypeMap(TypeMapEntry, FormSpec) | Initializes a new instance of the TypeMap class

See Also

TypeMap Class
TypeMap Members


TypeMap Constructor

[image]

Perforce .NET API
TypeMap Constructor
TypeMap Class See Also Send Feedback
Initializes a new instance of the TypeMap class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TypeMap()
Visual Basic
Public Sub New
Visual C++
public:
TypeMap()

See Also

TypeMap Class
TypeMap Overload


TypeMap Constructor (TypeMapEntry, FormSpec)

[image]

Perforce .NET API
TypeMap Constructor (TypeMapEntry, FormSpec)
TypeMap Class See Also Send Feedback
Initializes a new instance of the TypeMap class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TypeMap(
    TypeMapEntry mapping,
    FormSpec spec
)
Visual Basic
Public Sub New ( _
    mapping As TypeMapEntry, _
    spec As FormSpec _
)
Visual C++
public:
TypeMap(
    TypeMapEntry^ mapping,
    FormSpec^ spec
)

Parameters

mapping
Type: Perforce.P4..::..TypeMapEntry
spec
Type: Perforce.P4..::..FormSpec

See Also

TypeMap Class
TypeMap Overload


TypeMap Methods

[image] [image]

Perforce .NET API
TypeMap Methods
TypeMap Class See Also Send Feedback

The TypeMap type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class


BinarySearch Method

[image] [image]

Perforce .NET API
TypeMap..::..BinarySearch Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


CopyTo Method

[image] [image]

Perforce .NET API
TypeMap..::..CopyTo Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


FindIndex Method

[image] [image]

Perforce .NET API
TypeMap..::..FindIndex Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


FindLastIndex Method

[image] [image]

Perforce .NET API
TypeMap..::..FindLastIndex Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


IndexOf Method

[image] [image]

Perforce .NET API
TypeMap..::..IndexOf Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


LastIndexOf Method

[image] [image]

Perforce .NET API
TypeMap..::..LastIndexOf Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


Reverse Method

[image] [image]

Perforce .NET API
TypeMap..::..Reverse Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


Sort Method

[image] [image]

Perforce .NET API
TypeMap..::..Sort Method
TypeMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)

See Also

TypeMap Class
TypeMap Members


TypeMap Properties

[image] [image]

Perforce .NET API
TypeMap Properties
TypeMap Class See Also Send Feedback

The TypeMap type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' TypeMapEntry >)>)>.)
Public property | Mapping |
Public property | Spec |

See Also

TypeMap Class


Mapping Property

[image]

Perforce .NET API
TypeMap..::..Mapping Property
TypeMap Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TypeMapEntry Mapping { get; set; }
Visual Basic
Public Property Mapping As TypeMapEntry
    Get
    Set
Visual C++
public:
property TypeMapEntry^ Mapping {
    TypeMapEntry^ get ();
    void set (TypeMapEntry^ value);
}

See Also

TypeMap Class


Spec Property

[image]

Perforce .NET API
TypeMap..::..Spec Property
TypeMap Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

TypeMap Class


TypeMapEntry Class

[image]

Perforce .NET API
TypeMapEntry Class
Members See Also Send Feedback
Describes an individual entry in the Perforce repository's typemap.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class TypeMapEntry
Visual Basic
Public Class TypeMapEntry
Visual C++
public ref class TypeMapEntry

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..TypeMapEntry

See Also

TypeMapEntry Members


TypeMapEntry Members

[image] [image]

Perforce .NET API
TypeMapEntry Members
TypeMapEntry Class Constructors Methods Properties See Also Send Feedback

The TypeMapEntry type exposes the following members.

Constructors

 | Name | Description
Public method | TypeMapEntry(String) | Initializes a new instance of the TypeMapEntry class
Public method | TypeMapEntry(FileType, String) | Initializes a new instance of the TypeMapEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FileType |
Public property | Path |

See Also

TypeMapEntry Class


TypeMapEntry Constructor

[image] [image]

Perforce .NET API
TypeMapEntry Constructor
TypeMapEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeMapEntry(String) | Initializes a new instance of the TypeMapEntry class
Public method | TypeMapEntry(FileType, String) | Initializes a new instance of the TypeMapEntry class

See Also

TypeMapEntry Class
TypeMapEntry Members


TypeMapEntry Constructor (String)

[image]

Perforce .NET API
TypeMapEntry Constructor (String)
TypeMapEntry Class See Also Send Feedback
Initializes a new instance of the TypeMapEntry class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TypeMapEntry(
    string spec
)
Visual Basic
Public Sub New ( _
    spec As String _
)
Visual C++
public:
TypeMapEntry(
    String^ spec
)

Parameters

spec
Type: System..::..String

See Also

TypeMapEntry Class
TypeMapEntry Overload


TypeMapEntry Constructor (FileType, String)

[image]

Perforce .NET API
TypeMapEntry Constructor (FileType, String)
TypeMapEntry Class See Also Send Feedback
Initializes a new instance of the TypeMapEntry class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public TypeMapEntry(
    FileType filetype,
    string path
)
Visual Basic
Public Sub New ( _
    filetype As FileType, _
    path As String _
)
Visual C++
public:
TypeMapEntry(
    FileType^ filetype,
    String^ path
)

Parameters

filetype
Type: Perforce.P4..::..FileType
path
Type: System..::..String

See Also

TypeMapEntry Class
TypeMapEntry Overload


TypeMapEntry Methods

[image] [image]

Perforce .NET API
TypeMapEntry Methods
TypeMapEntry Class See Also Send Feedback

The TypeMapEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

TypeMapEntry Class


Parse Method

[image]

Perforce .NET API
TypeMapEntry..::..Parse Method
TypeMapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Parse(
    string spec
)
Visual Basic
Public Sub Parse ( _
    spec As String _
)
Visual C++
public:
void Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String

See Also

TypeMapEntry Class


ToString Method

[image]

Perforce .NET API
TypeMapEntry..::..ToString Method
TypeMapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

TypeMapEntry Class


TypeMapEntry Properties

[image] [image]

Perforce .NET API
TypeMapEntry Properties
TypeMapEntry Class See Also Send Feedback

The TypeMapEntry type exposes the following members.

Properties

 | Name | Description
Public property | FileType |
Public property | Path |

See Also

TypeMapEntry Class


FileType Property

[image]

Perforce .NET API
TypeMapEntry..::..FileType Property
TypeMapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FileType FileType { get; set; }
Visual Basic
Public Property FileType As FileType
    Get
    Set
Visual C++
public:
property FileType^ FileType {
    FileType^ get ();
    void set (FileType^ value);
}

See Also

TypeMapEntry Class


Path Property

[image]

Perforce .NET API
TypeMapEntry..::..Path Property
TypeMapEntry Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

TypeMapEntry Class


UnlockFilesCmdFlags Enumeration

[image]

Perforce .NET API
UnlockFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the unlock command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum UnlockFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration UnlockFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class UnlockFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Force | 1 | By default, files can be unlocked only by the changelist owner. The -f flag enables you to unlock files in changelists owned by other users. The -f flag requires 'admin' access, which is granted by 'p4 protect'.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


UnlockFilesCmdOptions Class

[image]

Perforce .NET API
UnlockFilesCmdOptions Class
Members See Also Send Feedback
Unlock command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class UnlockFilesCmdOptions : Options
Visual Basic
Public Class UnlockFilesCmdOptions _
    Inherits Options
Visual C++
public ref class UnlockFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..UnlockFilesCmdOptions

See Also

UnlockFilesCmdOptions Members


UnlockFilesCmdOptions Members

[image] [image]

Perforce .NET API
UnlockFilesCmdOptions Members
UnlockFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The UnlockFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | UnlockFilesCmdOptions | Unlock command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UnlockFilesCmdOptions Class


UnlockFilesCmdOptions Constructor

[image]

Perforce .NET API
UnlockFilesCmdOptions Constructor
UnlockFilesCmdOptions Class See Also Send Feedback
Unlock command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public UnlockFilesCmdOptions(
    UnlockFilesCmdFlags flags,
    int changelistId
)
Visual Basic
Public Sub New ( _
    flags As UnlockFilesCmdFlags, _
    changelistId As Integer _
)
Visual C++
public:
UnlockFilesCmdOptions(
    UnlockFilesCmdFlags flags,
    int changelistId
)

Parameters

flags
Type: Perforce.P4..::..UnlockFilesCmdFlags
changelistId
Type: System..::..Int32

Return Value

Remarks

p4 help unlock

unlock -- Release a locked file, leaving it open

p4 unlock [-c | -s changelist# | -x] [-f] [file ...]
p4 -c client unlock [-f] -r

'p4 unlock' releases locks on the specified files, which must be
open in the specified pending changelist. If you omit the changelist
number, the default changelist is assumed. If you omit the file name,
all locked files are unlocked.

The -s flag unlocks files from a shelved changelist caused by an
aborted 'submit -e' operation. The -c flag applies to opened files
in a pending changelist locked by 'p4 lock' or by a failed submit
of a change that is not shelved.

By default, files can be unlocked only by the changelist owner who
must also be the person who has the files locked. The -f flag
enables you to unlock files in changelists owned by other users.
The -f flag requires 'admin' access, which is granted by 'p4
protect'.

The -x option unlocks files that are opened 'exclusive' but are
orphaned (see 'p4 opened -x'). This option only applies to a
distributed installation where global tracking of these file types
is necessary across servers.

If a push command from a remote server to this server fails, files
can be left locked on this server, preventing other users from
submitting changes to those files. In this case, the user who issued
the push command can specify the -r flag with the name of the client
that was used on that remote server to unlock the files on this
server. An administrator can run 'unlock -f -r' as well.

See Also

UnlockFilesCmdOptions Class


UnlockFilesCmdOptions Methods

[image] [image]

Perforce .NET API
UnlockFilesCmdOptions Methods
UnlockFilesCmdOptions Class See Also Send Feedback

The UnlockFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UnlockFilesCmdOptions Class


UnlockFilesCmdOptions Properties

[image] [image]

Perforce .NET API
UnlockFilesCmdOptions Properties
UnlockFilesCmdOptions Class See Also Send Feedback

The UnlockFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UnlockFilesCmdOptions Class


UnshelveFilesCmdFlags Enumeration

[image]

Perforce .NET API
UnshelveFilesCmdFlags Enumeration
See Also Send Feedback
Flags for the unshelve command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum UnshelveFilesCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration UnshelveFilesCmdFlags
Visual C++
[FlagsAttribute]
public enum class UnshelveFilesCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Force | 1 | The -f flag forces the clobbering of any writeable but unopened files that are being unshelved.
Preview | 2 | The -n flag previews the operation without changing any files or metadata.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


UnshelveFilesCmdOptions Class

[image]

Perforce .NET API
UnshelveFilesCmdOptions Class
Members See Also Send Feedback
Unshelve command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class UnshelveFilesCmdOptions : Options
Visual Basic
Public Class UnshelveFilesCmdOptions _
    Inherits Options
Visual C++
public ref class UnshelveFilesCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..UnshelveFilesCmdOptions

See Also

UnshelveFilesCmdOptions Members


UnshelveFilesCmdOptions Members

[image] [image]

Perforce .NET API
UnshelveFilesCmdOptions Members
UnshelveFilesCmdOptions Class Constructors Methods Properties See Also Send Feedback

The UnshelveFilesCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | UnshelveFilesCmdOptions | Unshelve command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UnshelveFilesCmdOptions Class


UnshelveFilesCmdOptions Constructor

[image]

Perforce .NET API
UnshelveFilesCmdOptions Constructor
UnshelveFilesCmdOptions Class See Also Send Feedback
Unshelve command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public UnshelveFilesCmdOptions(
    UnshelveFilesCmdFlags flags,
    int changelistId,
    int newChangelistId
)
Visual Basic
Public Sub New ( _
    flags As UnshelveFilesCmdFlags, _
    changelistId As Integer, _
    newChangelistId As Integer _
)
Visual C++
public:
UnshelveFilesCmdOptions(
    UnshelveFilesCmdFlags flags,
    int changelistId,
    int newChangelistId
)

Parameters

flags
Type: Perforce.P4..::..UnshelveFilesCmdFlags
changelistId
Type: System..::..Int32
newChangelistId
Type: System..::..Int32

Return Value

Remarks

p4 help unshelve

unshelve -- Restore shelved files from a pending change into a workspace

p4 unshelve -s changelist# [options] [file ...]
Options: [-f -n] [-c changelist#] [-b branch|-S stream [-P parent]]

'p4 unshelve' retrieves shelved files from the specified pending
changelist, opens them in a pending changelist and copies them
to the invoking user's workspace. Unshelving files from a pending
changelist is restricted by the user's permissions on the files.
A successful unshelve operation places the shelved files on the
user's workspace with the same open action and pending integration
history as if it had originated from that user and client.

Unshelving a file over an already opened file is permitted if both
shelved file and opened file are opened for 'edit'. In a distributed
environment, an additional requirement is that the shelve was created
on the same edge server. After unshelving, the workspace file is
flagged as unresolved, and 'p4 resolve' must be run to resolve the
differences between the shelved file and the workspace file.

Unshelving a file opened for 'add' when the file already exists
in the depot will result in the file being opened for edit. After
unshelving, the workspace file is flagged as unresolved, and
'p4 resolve' must be run to resolve the differences between the
shelved file and the depot file at the head revision. Note that
unshelving a file opened for 'add' over an already opened file is
not supported.

The -s flag specifies the number of the pending changelist that
contains the shelved files.

If a file pattern is specified, 'p4 unshelve' unshelves files that
match the pattern.

The -b flag specifies a branch spec that the shelved files will be
mapped through prior to being unshelved, allowing files to be shelved
in one branch and unshelved in another. As with unshelving into an
open file, it may be necessary to run 'p4 resolve'. In a distributed
environment, an additional requirement is that the shelve was created
on the same edge server.

The -S flag uses a generated branch view to map the shelved files
between the specified stream and its parent stream. The -P flag
can be used to generate the view using a parent stream other than
the actual parent.

The -c flag specifies the changelist to which files are unshelved.
By default, 'p4 unshelve' opens shelved files in the default
changelist.

The -f flag forces the clobbering of any writeable but unopened files
that are being unshelved.

The -n flag previews the operation without changing any files or
metadata.

'p4 unshelve' is not supported for files with propagating attributes
from an edge server in a distributed environment.

See Also

UnshelveFilesCmdOptions Class


UnshelveFilesCmdOptions Methods

[image] [image]

Perforce .NET API
UnshelveFilesCmdOptions Methods
UnshelveFilesCmdOptions Class See Also Send Feedback

The UnshelveFilesCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UnshelveFilesCmdOptions Class


UnshelveFilesCmdOptions Properties

[image] [image]

Perforce .NET API
UnshelveFilesCmdOptions Properties
UnshelveFilesCmdOptions Class See Also Send Feedback

The UnshelveFilesCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UnshelveFilesCmdOptions Class


User Class

[image]

Perforce .NET API
User Class
Members See Also Send Feedback
A user on a Perforce Server, represented by a P4 User spec.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class User
Visual Basic
Public Class User
Visual C++
public ref class User

Remarks

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..User

See Also

User Members


User Members

[image] [image]

Perforce .NET API
User Members
User Class Constructors Methods Properties See Also Send Feedback

The User type exposes the following members.

Constructors

 | Name | Description
Public method | User()()()() | Initializes a new instance of the User class
Public method | User(String, String, String, String, DateTime, DateTime, String, List<(Of <<'(String>)>>), UserType, FormSpec) | Initializes a new instance of the User class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromUserCmdTaggedOutput | Read the fields from the tagged output of a user command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a user specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Accessed | The date this user was last active. Read only.
Public property | EmailAddress | The user's email address; for email review.
Public property | FullName | The user's real name.
Public property | Id | The user's user name.
Public property | JobView | Selects jobs for inclusion during changelist creation.
Public property | Password | If set, user must have matching $P4PASSWD on client.
Public property | Reviews | Listing of depot files to be reviewed by user.
Public property | Spec | The specification for the user form
Public property | Type | Either 'service', 'operator', or 'standard'. Default: 'standard'. Read only.
Public property | Updated | The date this specification was last modified.

See Also

User Class


User Constructor

[image] [image]

Perforce .NET API
User Constructor
User Class See Also Send Feedback

Overload List

 | Name | Description
Public method | User()()()() | Initializes a new instance of the User class
Public method | User(String, String, String, String, DateTime, DateTime, String, List<(Of <<'(String>)>>), UserType, FormSpec) | Initializes a new instance of the User class

See Also

User Class
User Members


User Constructor

[image]

Perforce .NET API
User Constructor
User Class See Also Send Feedback
Initializes a new instance of the User class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User()
Visual Basic
Public Sub New
Visual C++
public:
User()

See Also

User Class
User Overload


User Constructor (String, String, String, String, DateTime, DateTime, String, List(String), UserType, FormSpec)

[image]

Perforce .NET API
User Constructor (String, String, String, String, DateTime, DateTime, String, List<(Of <(<'String>)>)>, UserType, FormSpec)
User Class See Also Send Feedback
Initializes a new instance of the User class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public User(
    string id,
    string fullname,
    string password,
    string emailaddress,
    DateTime updated,
    DateTime accessed,
    string jobview,
    List<string> reviews,
    UserType type,
    FormSpec spec
)
Visual Basic
Public Sub New ( _
    id As String, _
    fullname As String, _
    password As String, _
    emailaddress As String, _
    updated As DateTime, _
    accessed As DateTime, _
    jobview As String, _
    reviews As List(Of String), _
    type As UserType, _
    spec As FormSpec _
)
Visual C++
public:
User(
    String^ id,
    String^ fullname,
    String^ password,
    String^ emailaddress,
    DateTime updated,
    DateTime accessed,
    String^ jobview,
    List<String^>^ reviews,
    UserType type,
    FormSpec^ spec
)

Parameters

id
Type: System..::..String
fullname
Type: System..::..String
password
Type: System..::..String
emailaddress
Type: System..::..String
updated
Type: System..::..DateTime
accessed
Type: System..::..DateTime
jobview
Type: System..::..String
reviews
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
type
Type: Perforce.P4..::..UserType
spec
Type: Perforce.P4..::..FormSpec

See Also

User Class
User Overload


User Methods

[image] [image]

Perforce .NET API
User Methods
User Class See Also Send Feedback

The User type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromUserCmdTaggedOutput | Read the fields from the tagged output of a user command
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parse the fields from a user specification
Public method | ToString | Convert to specification in server format (Overrides Object..::..ToString()()()().)

See Also

User Class


FromUserCmdTaggedOutput Method

[image]

Perforce .NET API
User..::..FromUserCmdTaggedOutput Method
User Class See Also Send Feedback
Read the fields from the tagged output of a user command

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void FromUserCmdTaggedOutput(
    TaggedObject objectInfo,
    string offset,
    bool dst_mismatch
)
Visual Basic
Public Sub FromUserCmdTaggedOutput ( _
    objectInfo As TaggedObject, _
    offset As String, _
    dst_mismatch As Boolean _
)
Visual C++
public:
void FromUserCmdTaggedOutput(
    TaggedObject^ objectInfo,
    String^ offset,
    bool dst_mismatch
)

Parameters

objectInfo
Type: Perforce.P4..::..TaggedObject
Tagged output from the 'user' command
offset
Type: System..::..String
dst_mismatch
Type: System..::..Boolean

See Also

User Class


Parse Method

[image]

Perforce .NET API
User..::..Parse Method
User Class See Also Send Feedback
Parse the fields from a user specification

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public bool Parse(
    string spec
)
Visual Basic
Public Function Parse ( _
    spec As String _
) As Boolean
Visual C++
public:
bool Parse(
    String^ spec
)

Parameters

spec
Type: System..::..String
Text of the user specification in server format

Return Value

See Also

User Class


ToString Method

[image]

Perforce .NET API
User..::..ToString Method
User Class See Also Send Feedback
Convert to specification in server format

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

User Class


User Properties

[image] [image]

Perforce .NET API
User Properties
User Class See Also Send Feedback

The User type exposes the following members.

Properties

 | Name | Description
Public property | Accessed | The date this user was last active. Read only.
Public property | EmailAddress | The user's email address; for email review.
Public property | FullName | The user's real name.
Public property | Id | The user's user name.
Public property | JobView | Selects jobs for inclusion during changelist creation.
Public property | Password | If set, user must have matching $P4PASSWD on client.
Public property | Reviews | Listing of depot files to be reviewed by user.
Public property | Spec | The specification for the user form
Public property | Type | Either 'service', 'operator', or 'standard'. Default: 'standard'. Read only.
Public property | Updated | The date this specification was last modified.

See Also

User Class


Accessed Property

[image]

Perforce .NET API
User..::..Accessed Property
User Class See Also Send Feedback
The date this user was last active. Read only.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Accessed { get; set; }
Visual Basic
Public Property Accessed As DateTime
    Get
    Set
Visual C++
public:
property DateTime Accessed {
    DateTime get ();
    void set (DateTime value);
}

See Also

User Class


EmailAddress Property

[image]

Perforce .NET API
User..::..EmailAddress Property
User Class See Also Send Feedback
The user's email address; for email review.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic
Public Property EmailAddress As String
    Get
    Set
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


FullName Property

[image]

Perforce .NET API
User..::..FullName Property
User Class See Also Send Feedback
The user's real name.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string FullName { get; set; }
Visual Basic
Public Property FullName As String
    Get
    Set
Visual C++
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


Id Property

[image]

Perforce .NET API
User..::..Id Property
User Class See Also Send Feedback
The user's user name.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


JobView Property

[image]

Perforce .NET API
User..::..JobView Property
User Class See Also Send Feedback
Selects jobs for inclusion during changelist creation.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string JobView { get; set; }
Visual Basic
Public Property JobView As String
    Get
    Set
Visual C++
public:
property String^ JobView {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


Password Property

[image]

Perforce .NET API
User..::..Password Property
User Class See Also Send Feedback
If set, user must have matching $P4PASSWD on client.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


Reviews Property

[image]

Perforce .NET API
User..::..Reviews Property
User Class See Also Send Feedback
Listing of depot files to be reviewed by user.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public IList<string> Reviews { get; set; }
Visual Basic
Public Property Reviews As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ Reviews {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

See Also

User Class


Spec Property

[image]

Perforce .NET API
User..::..Spec Property
User Class See Also Send Feedback
The specification for the user form

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public FormSpec Spec { get; set; }
Visual Basic
Public Property Spec As FormSpec
    Get
    Set
Visual C++
public:
property FormSpec^ Spec {
    FormSpec^ get ();
    void set (FormSpec^ value);
}

See Also

User Class


Type Property

[image]

Perforce .NET API
User..::..Type Property
User Class See Also Send Feedback
Either 'service', 'operator', or 'standard'. Default: 'standard'. Read only.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public UserType Type { get; set; }
Visual Basic
Public Property Type As UserType
    Get
    Set
Visual C++
public:
property UserType Type {
    UserType get ();
    void set (UserType value);
}

See Also

User Class


Updated Property

[image]

Perforce .NET API
User..::..Updated Property
User Class See Also Send Feedback
The date this specification was last modified.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public DateTime Updated { get; set; }
Visual Basic
Public Property Updated As DateTime
    Get
    Set
Visual C++
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}

See Also

User Class


UserCmdFlags Enumeration

[image]

Perforce .NET API
UserCmdFlags Enumeration
See Also Send Feedback
Flags for the user command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum UserCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration UserCmdFlags
Visual C++
[FlagsAttribute]
public enum class UserCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
Delete | 1 | The -d flag deletes the specified user (unless the user has files open).
Output | 2 | The -o flag writes the user specification to the standard output. The user's editor is not invoked.
Input | 4 | The -i flag reads a user specification from the standard input. The user's editor is not invoked.
Force | 8 | The -f flag forces the creation, update or deletion of the specified user, and enables you to change the Last Modified date. By default, users can only delete or modify their own user specifications. The -f flag requires 'super' access, which is granted by 'p4 protect'.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


UserCmdOptions Class

[image]

Perforce .NET API
UserCmdOptions Class
Members See Also Send Feedback
User command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class UserCmdOptions : Options
Visual Basic
Public Class UserCmdOptions _
    Inherits Options
Visual C++
public ref class UserCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..UserCmdOptions

See Also

UserCmdOptions Members


UserCmdOptions Members

[image] [image]

Perforce .NET API
UserCmdOptions Members
UserCmdOptions Class Constructors Methods Properties See Also Send Feedback

The UserCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | UserCmdOptions | User command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UserCmdOptions Class


UserCmdOptions Constructor

[image]

Perforce .NET API
UserCmdOptions Constructor
UserCmdOptions Class See Also Send Feedback
User command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public UserCmdOptions(
    UserCmdFlags flags
)
Visual Basic
Public Sub New ( _
    flags As UserCmdFlags _
)
Visual C++
public:
UserCmdOptions(
    UserCmdFlags flags
)

Parameters

flags
Type: Perforce.P4..::..UserCmdFlags

Return Value

Remarks

p4 help user

user -- Create or edit a user specification

p4 user [-f] [name]
p4 user -d [-f] name
p4 user -o [name]
p4 user -i [-f]

Create a new user specification or edit an existing user specification.
The specification form is put into a temporary file and the editor
(configured by the environment variable $P4EDITOR) is invoked.

Normally, a user specification is created automatically the first
time that the user issues any command that updates the depot. The
'p4 user' command is typically used to edit the user's subscription
list for change review.

The user specification form contains the following fields:

User: The user name (read-only).

Email: The user's email address (Default: user@client).

Update: The date the specification was last modified (read-only).

Access: The date that the user last issued a client command.

FullName: The user's real name.

JobView: Selects jobs that are displayed when the user creates
a changelist. These jobs can be closed automatically
when the user submits the changelist. For a description
of jobview syntax, see 'p4 help jobview'

Reviews: The subscription list for change review. There is no
limit on the number of lines that this field can contain.
You can include the following wildcards:

... matches any characters including /
* matches any character except /

Password: The user's password. See 'p4 help passwd'.

Type: Must be 'service', operator, or 'standard'. Default is
'standard'. Once set, the user type cannot be changed.

AuthMethod: Must be 'perforce' or 'ldap'. Default is 'perforce'
Unless overridden by the 'auth.default.method'
configurable, see 'p4 help configurables'. AuthMethod
can only be changed when the -f flag has been provided.

The -d flag deletes the specified user (unless the user has files
open).

The -o flag writes the user specification to the standard output.
The user's editor is not invoked.

The -i flag reads a user specification from the standard input.
The user's editor is not invoked.

The -f flag forces the creation, update or deletion of the specified
user, and enables you to change the Last Modified date. By default,
users can only delete or modify their own user specifications. The
-f flag requires 'super' access, which is granted by 'p4 protect'.

See Also

UserCmdOptions Class


UserCmdOptions Methods

[image] [image]

Perforce .NET API
UserCmdOptions Methods
UserCmdOptions Class See Also Send Feedback

The UserCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UserCmdOptions Class


UserCmdOptions Properties

[image] [image]

Perforce .NET API
UserCmdOptions Properties
UserCmdOptions Class See Also Send Feedback

The UserCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UserCmdOptions Class


UsersCmdFlags Enumeration

[image]

Perforce .NET API
UsersCmdFlags Enumeration
See Also Send Feedback
Flags for the users command.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum UsersCmdFlags
Visual Basic
<FlagsAttribute> _
Public Enumeration UsersCmdFlags
Visual C++
[FlagsAttribute]
public enum class UsersCmdFlags

Members

Member name | Value | Description
None | 0 | No flags.
IncludeAll | 1 | The -a flag includes service and operator users in the output.
LongForm | 2 | The -l flag includes additional information in the output. The -l flag requires 'super' access, which is granted by 'p4 protect'.

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


UsersCmdOptions Class

[image]

Perforce .NET API
UsersCmdOptions Class
Members See Also Send Feedback
Users command options

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class UsersCmdOptions : Options
Visual Basic
Public Class UsersCmdOptions _
    Inherits Options
Visual C++
public ref class UsersCmdOptions : public Options

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Perforce.P4..::..Options
Perforce.P4..::..UsersCmdOptions

See Also

UsersCmdOptions Members


UsersCmdOptions Members

[image] [image]

Perforce .NET API
UsersCmdOptions Members
UsersCmdOptions Class Constructors Methods Properties See Also Send Feedback

The UsersCmdOptions type exposes the following members.

Constructors

 | Name | Description
Public method | UsersCmdOptions | Users command options.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UsersCmdOptions Class


UsersCmdOptions Constructor

[image]

Perforce .NET API
UsersCmdOptions Constructor
UsersCmdOptions Class See Also Send Feedback
Users command options.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public UsersCmdOptions(
    UsersCmdFlags flags,
    int maxItems
)
Visual Basic
Public Sub New ( _
    flags As UsersCmdFlags, _
    maxItems As Integer _
)
Visual C++
public:
UsersCmdOptions(
    UsersCmdFlags flags,
    int maxItems
)

Parameters

flags
Type: Perforce.P4..::..UsersCmdFlags
maxItems
Type: System..::..Int32

Return Value

Remarks

p4 help users

users -- List Perforce users

p4 users [-l -a -r -c] [-m max] [user ...]

Lists all Perforce users or users that match the 'user' argument.
The report includes the last time that each user accessed the system.

The -m max flag limits output to the first 'max' number of users.

The -a flag includes service and operator users in the output.

The -l flag includes additional information in the output. The -l
flag requires 'super' access, which is granted by 'p4 protect'.

The -r and -c flags are only allowed on replica servers. When
-r is given only users who have used a replica are reported and
when -c is given only the user information from the central server
is reported. Otherwise on a replica server, the user list will
be slightly different from the master server as the user access times
will reflect replica usage or master usage whichever is newer.

See Also

UsersCmdOptions Class


UsersCmdOptions Methods

[image] [image]

Perforce .NET API
UsersCmdOptions Methods
UsersCmdOptions Class See Also Send Feedback

The UsersCmdOptions type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public method | ToString | (Inherited from Options.)
Public method | ToStringList | (Inherited from Options.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UsersCmdOptions Class


UsersCmdOptions Properties

[image] [image]

Perforce .NET API
UsersCmdOptions Properties
UsersCmdOptions Class See Also Send Feedback

The UsersCmdOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, String >)>)>.)

See Also

UsersCmdOptions Class


UserType Enumeration

[image]

Perforce .NET API
UserType Enumeration
See Also Send Feedback
Defines the user type.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
[FlagsAttribute]
public enum UserType
Visual Basic
<FlagsAttribute> _
Public Enumeration UserType
Visual C++
[FlagsAttribute]
public enum class UserType

Members

Member name | Value | Description
Standard | 0 | Standard: a normal user (licensed)
Service | 1 | Service: a service user (not licensed)
Operator | 2 | Operator: an operator user (not licensed)

See Also

Perforce.P4 Namespace

Send comments on this topic to manual@perforce.com


VersionRange Class

[image]

Perforce .NET API
VersionRange Class
Members See Also Send Feedback
A revision range specifier consisting of a lower and upper revision.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class VersionRange : VersionSpec
Visual Basic
Public Class VersionRange _
    Inherits VersionSpec
Visual C++
public ref class VersionRange : public VersionSpec

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..VersionRange

See Also

VersionRange Members


VersionRange Members

[image] [image]

Perforce .NET API
VersionRange Members
VersionRange Class Constructors Methods Properties See Also Send Feedback

The VersionRange type exposes the following members.

Constructors

 | Name | Description
Public method | VersionRange(Int32, Int32) | A revision range specifier consisting of a lower and upper revision.
Public method | VersionRange(VersionSpec, VersionSpec) | A revision range specifier consisting of a lower and upper revision.

Methods

 | Name | Description
Public method | Equals | Equals method for for VersionRange (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for VersionRange (Overrides VersionSpec..::..ToString()()()().)

Properties

 | Name | Description
Public property | Lower | Lower version revision.
Public property | Upper | Upper version revision.

See Also

VersionRange Class


VersionRange Constructor

[image] [image]

Perforce .NET API
VersionRange Constructor
VersionRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | VersionRange(Int32, Int32) | A revision range specifier consisting of a lower and upper revision.
Public method | VersionRange(VersionSpec, VersionSpec) | A revision range specifier consisting of a lower and upper revision.

See Also

VersionRange Class
VersionRange Members


VersionRange Constructor (Int32, Int32)

[image]

Perforce .NET API
VersionRange Constructor (Int32, Int32)
VersionRange Class See Also Send Feedback
A revision range specifier consisting of a lower and upper revision.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public VersionRange(
    int lower,
    int upper
)
Visual Basic
Public Sub New ( _
    lower As Integer, _
    upper As Integer _
)
Visual C++
public:
VersionRange(
    int lower,
    int upper
)

Parameters

lower
Type: System..::..Int32
int to get lower revision
upper
Type: System..::..Int32
int to get upper revision

See Also

VersionRange Class
VersionRange Overload


VersionRange Constructor (VersionSpec, VersionSpec)

[image]

Perforce .NET API
VersionRange Constructor (VersionSpec, VersionSpec)
VersionRange Class See Also Send Feedback
A revision range specifier consisting of a lower and upper revision.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public VersionRange(
    VersionSpec lower,
    VersionSpec upper
)
Visual Basic
Public Sub New ( _
    lower As VersionSpec, _
    upper As VersionSpec _
)
Visual C++
public:
VersionRange(
    VersionSpec^ lower,
    VersionSpec^ upper
)

Parameters

lower
Type: Perforce.P4..::..VersionSpec
version spec to get lower revision
upper
Type: Perforce.P4..::..VersionSpec
version spec to get upper revision

See Also

VersionRange Class
VersionRange Overload


VersionRange Methods

[image] [image]

Perforce .NET API
VersionRange Methods
VersionRange Class See Also Send Feedback

The VersionRange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Equals method for for VersionRange (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | ToString method for for VersionRange (Overrides VersionSpec..::..ToString()()()().)

See Also

VersionRange Class


Equals Method

[image]

Perforce .NET API
VersionRange..::..Equals Method
VersionRange Class See Also Send Feedback
Equals method for for VersionRange

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
object to get version range

Return Value

True/False

See Also

VersionRange Class


ToString Method

[image]

Perforce .NET API
VersionRange..::..ToString Method
VersionRange Class See Also Send Feedback
ToString method for for VersionRange

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String version range

See Also

VersionRange Class


VersionRange Properties

[image] [image]

Perforce .NET API
VersionRange Properties
VersionRange Class See Also Send Feedback

The VersionRange type exposes the following members.

Properties

 | Name | Description
Public property | Lower | Lower version revision.
Public property | Upper | Upper version revision.

See Also

VersionRange Class


Lower Property

[image]

Perforce .NET API
VersionRange..::..Lower Property
VersionRange Class See Also Send Feedback
Lower version revision.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public VersionSpec Lower { get; set; }
Visual Basic
Public Property Lower As VersionSpec
    Get
    Set
Visual C++
public:
property VersionSpec^ Lower {
    VersionSpec^ get ();
    void set (VersionSpec^ value);
}

See Also

VersionRange Class


Upper Property

[image]

Perforce .NET API
VersionRange..::..Upper Property
VersionRange Class See Also Send Feedback
Upper version revision.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public VersionSpec Upper { get; set; }
Visual Basic
Public Property Upper As VersionSpec
    Get
    Set
Visual C++
public:
property VersionSpec^ Upper {
    VersionSpec^ get ();
    void set (VersionSpec^ value);
}

See Also

VersionRange Class


VersionSpec Class

[image]

Perforce .NET API
VersionSpec Class
Members See Also Send Feedback
Identifies a specific revision or revision range of a Perforce managed SCM resource.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public abstract class VersionSpec
Visual Basic
Public MustInherit Class VersionSpec
Visual C++
public ref class VersionSpec abstract

Inheritance Hierarchy

System..::..Object
Perforce.P4..::..VersionSpec
Perforce.P4..::..ActionVersion
Perforce.P4..::..ChangelistIdVersion
Perforce.P4..::..ClientNameVersion
Perforce.P4..::..DateTimeVersion
Perforce.P4..::..HaveRevision
Perforce.P4..::..HeadRevision
Perforce.P4..::..LabelNameVersion
Perforce.P4..::..NoneRevision
Perforce.P4..::..Revision
Perforce.P4..::..ShelvedInChangelistIdVersion
Perforce.P4..::..VersionRange

See Also

VersionSpec Members


VersionSpec Members

[image] [image]

Perforce .NET API
VersionSpec Members
VersionSpec Class Constructors Methods Fields See Also Send Feedback

The VersionSpec type exposes the following members.

Constructors

 | Name | Description
Protected method | VersionSpec | Initializes a new instance of the VersionSpec class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

Name | Description
Have |
Head |
None |

See Also

VersionSpec Class


VersionSpec Constructor

[image]

Perforce .NET API
VersionSpec Constructor
VersionSpec Class See Also Send Feedback
Initializes a new instance of the VersionSpec class

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
protected VersionSpec()
Visual Basic
Protected Sub New
Visual C++
protected:
VersionSpec()

See Also

VersionSpec Class


VersionSpec Fields

[image] [image]

Perforce .NET API
VersionSpec Fields
VersionSpec Class See Also Send Feedback

The VersionSpec type exposes the following members.

Fields

Name | Description
Have |
Head |
None |

See Also

VersionSpec Class


Have Field

[image]

Perforce .NET API
VersionSpec..::..Have Field
VersionSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static HaveRevision Have
Visual Basic
Public Shared Have As HaveRevision
Visual C++
public:
static HaveRevision^ Have

See Also

VersionSpec Class


Head Field

[image]

Perforce .NET API
VersionSpec..::..Head Field
VersionSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static HeadRevision Head
Visual Basic
Public Shared Head As HeadRevision
Visual C++
public:
static HeadRevision^ Head

See Also

VersionSpec Class


None Field

[image]

Perforce .NET API
VersionSpec..::..None Field
VersionSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static NoneRevision None
Visual Basic
Public Shared None As NoneRevision
Visual C++
public:
static NoneRevision^ None

See Also

VersionSpec Class


VersionSpec Methods

[image] [image]

Perforce .NET API
VersionSpec Methods
VersionSpec Class See Also Send Feedback

The VersionSpec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

VersionSpec Class


ToString Method

[image]

Perforce .NET API
VersionSpec..::..ToString Method
VersionSpec Class See Also Send Feedback

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public abstract string ToString()
Visual Basic
Public MustOverride Function ToString As String
Visual C++
public:
virtual String^ ToString() abstract override

See Also

VersionSpec Class


ViewMap Class

[image]

Perforce .NET API
ViewMap Class
Members See Also Send Feedback
Maps one or more Perforce file specs to zero, one, or more other Perforce file specs.

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public class ViewMap : List<MapEntry>
Visual Basic
Public Class ViewMap _
    Inherits List(Of MapEntry)
Visual C++
public ref class ViewMap : public List<MapEntry^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' MapEntry >)>)>
Perforce.P4..::..ViewMap

See Also

ViewMap Members


ViewMap Members

[image] [image]

Perforce .NET API
ViewMap Members
ViewMap Class Constructors Methods Properties See Also Send Feedback

The ViewMap type exposes the following members.

Constructors

 | Name | Description
Public method | ViewMap()()()() | Create an empty workspace view
Public method | ViewMap(List<(Of <<'(String>)>>)) | Create a workspace view
Public method | ViewMap(array<String>[]()[][]) | Create a workspace view

Methods

 | Name | Description
Public method | Add(String) | Add a line to the end of the view
Public method | Add(T) | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Add(String, String, MapType) | Add a line to the end of the view
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
 | SplitViewLine | Split a single line from a view specification into left and right parts
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | ToString | Convert to a Perforce server compatible string for a workspace spec (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class


ViewMap Constructor

[image] [image]

Perforce .NET API
ViewMap Constructor
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ViewMap()()()() | Create an empty workspace view
Public method | ViewMap(List<(Of <<'(String>)>>)) | Create a workspace view
Public method | ViewMap(array<String>[]()[][]) | Create a workspace view

See Also

ViewMap Class
ViewMap Members


ViewMap Constructor

[image]

Perforce .NET API
ViewMap Constructor
ViewMap Class See Also Send Feedback
Create an empty workspace view

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap()
Visual Basic
Public Sub New
Visual C++
public:
ViewMap()

See Also

ViewMap Class
ViewMap Overload


ViewMap Constructor (List(String))

[image]

Perforce .NET API
ViewMap Constructor (List<(Of <(<'String>)>)>)
ViewMap Class See Also Send Feedback
Create a workspace view

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap(
    List<string> text
)
Visual Basic
Public Sub New ( _
    text As List(Of String) _
)
Visual C++
public:
ViewMap(
    List<String^>^ text
)

Parameters

text
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
List of Left/Right pairs for the map

See Also

ViewMap Class
ViewMap Overload


ViewMap Constructor (String[])

[image]

Perforce .NET API
ViewMap Constructor (array<String>[]()[][])
ViewMap Class See Also Send Feedback
Create a workspace view

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public ViewMap(
    string[] text
)
Visual Basic
Public Sub New ( _
    text As String() _
)
Visual C++
public:
ViewMap(
    array<String^>^ text
)

Parameters

text
Type: array< System..::..String >[]()[][]
Array of Left/Right pairs for the map

See Also

ViewMap Class
ViewMap Overload


ViewMap Methods

[image] [image]

Perforce .NET API
ViewMap Methods
ViewMap Class See Also Send Feedback

The ViewMap type exposes the following members.

Methods

 | Name | Description
Public method | Add(String) | Add a line to the end of the view
Public method | Add(T) | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Add(String, String, MapType) | Add a line to the end of the view
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
 | SplitViewLine | Split a single line from a view specification into left and right parts
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | ToString | Convert to a Perforce server compatible string for a workspace spec (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class


Add Method

[image] [image]

Perforce .NET API
ViewMap..::..Add Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(String) | Add a line to the end of the view
Public method | Add(T) | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Add(String, String, MapType) | Add a line to the end of the view

See Also

ViewMap Class
ViewMap Members


Add Method (String)

[image]

Perforce .NET API
ViewMap..::..Add Method (String)
ViewMap Class See Also Send Feedback
Add a line to the end of the view

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Add(
    string line
)
Visual Basic
Public Sub Add ( _
    line As String _
)
Visual C++
public:
void Add(
    String^ line
)

Parameters

line
Type: System..::..String
Left/Right pair for the map

See Also

ViewMap Class
Add Overload


Add Method (String, String, MapType)

[image]

Perforce .NET API
ViewMap..::..Add Method (String, String, MapType)
ViewMap Class See Also Send Feedback
Add a line to the end of the view

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public void Add(
    string left,
    string right,
    MapType lineType
)
Visual Basic
Public Sub Add ( _
    left As String, _
    right As String, _
    lineType As MapType _
)
Visual C++
public:
void Add(
    String^ left,
    String^ right,
    MapType lineType
)

Parameters

left
Type: System..::..String
left side of mapping
right
Type: System..::..String
right side of mapping
lineType
Type: Perforce.P4..::..MapType

See Also

ViewMap Class
Add Overload


BinarySearch Method

[image] [image]

Perforce .NET API
ViewMap..::..BinarySearch Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


CopyTo Method

[image] [image]

Perforce .NET API
ViewMap..::..CopyTo Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


FindIndex Method

[image] [image]

Perforce .NET API
ViewMap..::..FindIndex Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


FindLastIndex Method

[image] [image]

Perforce .NET API
ViewMap..::..FindLastIndex Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


IndexOf Method

[image] [image]

Perforce .NET API
ViewMap..::..IndexOf Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


LastIndexOf Method

[image] [image]

Perforce .NET API
ViewMap..::..LastIndexOf Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


Reverse Method

[image] [image]

Perforce .NET API
ViewMap..::..Reverse Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


Sort Method

[image] [image]

Perforce .NET API
ViewMap..::..Sort Method
ViewMap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class
ViewMap Members


SplitViewLine Method

[image]

Perforce .NET API
ViewMap..::..SplitViewLine Method
ViewMap Class See Also Send Feedback
Split a single line from a view specification into left and right parts

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public static string[] SplitViewLine(
    string line
)
Visual Basic
Public Shared Function SplitViewLine ( _
    line As String _
) As String()
Visual C++
public:
static array<String^>^ SplitViewLine(
    String^ line
)

Parameters

line
Type: System..::..String

Return Value

Remarks

Handles case where the left and/or the right string are enclosed in quotes because they contain spaces. I.e "C:\my code\project 1\..."

See Also

ViewMap Class


ToString Method

[image]

Perforce .NET API
ViewMap..::..ToString Method
ViewMap Class See Also Send Feedback
Convert to a Perforce server compatible string for a workspace spec

Namespace: Perforce.P4
Assembly: p4api.net (in p4api.net.dll) Version: 2016.1.140.7015 (2016.1.140.7015)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

ViewMap Class


ViewMap Properties

[image] [image]

Perforce .NET API
ViewMap Properties
ViewMap Class See Also Send Feedback

The ViewMap type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' MapEntry >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' MapEntry >)>)>.)

See Also

ViewMap Class