|
} public boolean isTicketPathSet() { - return "ticketPathSet".equals(value); + return getTicketValue() == null;
mark_foundry (on TicketModeImpl.java, line 56) commented
10 years ago
Should this be getTicketPath()? |
Reply ·0 | |
|
|
|
} public boolean isTicketPathSet() { - return "ticketPathSet".equals(value); + return getTicketValue() == null;
Paul Allen (on TicketModeImpl.java, line 56) commented
10 years ago
I used the != and == conditions of getTicketValue to guarantee only one condition. If I had used getTicketPath there is a small chance they both could be true. |
Reply ·0 | |
|
|
|
} public boolean isTicketPathSet() { - return "ticketPathSet".equals(value); + return getTicketValue() == null;
mark_foundry (on TicketModeImpl.java, line 56) commented
10 years ago
Ah right. It looks just like a copy-n-paste error, which is why I queried it :) |
Reply ·0 | |
|
|
|
} public boolean isTicketPathSet() { - return "ticketPathSet".equals(value); + return getTicketValue() == null;
Paul Allen (on TicketModeImpl.java, line 56) commented
10 years ago
Thanks for checking; it did make me double check. I have added some help bubbles too for tips on using |
Reply ·0 | |
|